Cisco Nexus 7000 シリーズ NX-OS インターフェイス コンフィギュレーション ガイド、リリース 5.x
vPC の設定
vPC の設定
発行日;2015/03/05 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

vPC の設定

vPC の設定

この章では、Cisco NX-OS デバイス上で仮想ポート チャネル(vPC)を設定する方法を説明します。


) Cisco NX-OS リリース 5.1(1) 以降では、vPC は FabricPath と相互運用するように機能強化されました。FabricPath ネットワークで vPC を設定するには、『Cisco Nexus 7000 Series NX-OS FabricPath Configuration Guide, Release 5.x』を参照してください。


Cisco NX-OS リリース 5.1(1) 以降では、個々のスイッチの vPC ピア リンクに対し F シリーズ モジュールでは 10 Gbps イーサネット(10GE)インターフェイスを、または M シリーズ モジュールでは 10GE インターフェイスを使用できますが、F モジュール上のメンバ ポートを M モジュール上のポートと組み合わせて単一スイッチ上の単一ポート チャネルにすることはできません。ポート チャネルの互換性パラメータは、物理スイッチのすべてのポート チャネル メンバーで同じである必要があります。

vPC の一部になるように共有インターフェイスを設定できません。共有インターフェイスに関する詳細については、『 Cisco NX-OS FCoE Configuration Guide for Cisco Nexus 7000 and Cisco MDS 9500 』を参照してください。


) ポート チャネルの互換性パラメータは、両方のピアのすべての vPC メンバ ポートでも同じでなければならないので、シャーシごとに同じタイプのモジュールを使用する必要があります。


この章は、次の項で構成されています。

「vPC について」

「vPC のライセンス要件」

「注意事項と制約事項」

「デフォルト設定値」

「vPC の設定」

「vPC 設定の確認」

「vPC のモニタリング」

「vPC の設定例」

「その他の参考資料」

「vPC の設定機能の履歴」


) ポート チャネルと Link Aggregation Control Protocol(LACP)の設定の詳細については、「ポート チャネルの設定」を参照してください。


vPC について

この項では、次のトピックについて取り上げます。

「vPC の概要」

「vPC の用語」

「vPC ピア リンク」

「ピアキープアライブ リンクとメッセージ」

「vPC ピア ゲートウェイ」

「vPC ドメイン」

「vPC トポロジ」

「vPC インターフェイスの互換パラメータ」

「vPC 番号」

「他のポート チャネルの vPC への移行」

「単一モジュール上での vPC ピア リンクとコアへのリンクの設定」

「その他の機能との vPC の相互作用」

「仮想化のサポート」

「停電後の vPC リカバリ」

「High Availability(高可用性)」

vPC の概要

仮想ポート チャネル(vPC)は、物理的には 2 台の異なる Cisco Nexus 7000 シリーズ デバイスに接続されているリンクを、第 3 のデバイスには単一のポートに見えるようにします(図 7-1 を参照)。第 3 のデバイスは、スイッチ、サーバ、ポート チャネルをサポートするその他の任意のネットワーキング デバイスのいずれでもかまいません。vPC は、ノード間の複数の並列パスを可能にし、トラフィックのロード バランシングを可能にすることによって、冗長性を作り、バイセクショナルな帯域幅を増やすレイヤ 2 マルチパスを提供できます。

図 7-1 vPC のアーキテクチャ

 

vPC で使用できるのは、レイヤ 2 ポート チャネルだけです。vPC ドメインは単一の VDC に関連付けられるため、同じ 1 つの vPC ドメインに所属するすべての vPC インターフェイスが同一 VDC 内で定義されていなければなりません。配置した各 VDC に、独立した vPC ピア リンクとピアキープアライブ リンクのインフラストラクチャがなくてはなりません。vPC ピア(ドメインが同じ 2 台の vPC ピア デバイス)を同じ物理デバイスの 2 つの VDC 内に統合することは、サポートされていません。vPC ピア リンクは、リンクの両エンドに 10 ギガバイト イーサネット ポートを使用しなければならず、そうなっていないとリンクが形成されません。

ポート チャネルの設定は、次のいずれかを使用して行います。

プロトコルなし

リンク集約制御プロトコル(LACP)

LACP を使用せずに vPC(vPC ピア リンク チャネルも含めて)のポート チャネルを設定する場合は、各デバイスが、単一のポート チャネル内に最大 8 つのアクティブ リンクを持てます。LACP を使用して vPC(vPC ピア リンク チャネルも含めて)のポート チャネルを設定する場合は、各デバイスが、単一のポート チャネル内に 8 つのアクティブ リンクと 8 つのスタンバイ リンクを持つことができます (LACP と vPC の使用方法の詳細については、「その他の機能との vPC の相互作用」を参照してください)。


) vPC の機能を設定したり実行したりするには、まず vPC 機能をイネーブルにする必要があります。


Cisco NX-OS リリース 4.2 以降では、システムは機能のディセーブル化の前に自動的にチェックポイントを作成するため、このチェックポイントにロールバックできます。ロールバックとチェックポイントについては、『 Cisco Nexus 7000 Series NX-OS System Management Configuration Guide, Release 5.x 』を参照してください。

vPC 機能をイネーブルにしたら、ピアキープアライブ リンクを作成します。このリンクは、2 つの vPC ピア デバイス間でのハートビート メッセージの送信を行います。

専用モードで 2 つ以上の 10 ギガビット イーサネット ポートを使用することにより、1 台の Cisco Nexus 7000 シリーズ シャーシでポート チャネルを設定して vPC ピア リンクを作成できます。正しいハードウェアをイネーブルにしており、Cisco NX-OS Release 4.1(5) で始まった vPC を実行していることを確認するには、 show hardware feature-capability コマンドを入力します。vPC の向かいに X が表示されている場合、そのハードウェアでは vPC 機能をイネーブルにできません。

vPC ピア リンク レイヤ 2 ポート チャネルは、トランクとして設定することを推奨します。次に、もう 1 つの Cisco Nexus 7000 シリーズ シャーシで、やはり 2 つ以上の 10 ギガビット イーサネット ポートを専用モードで使用して、もう 1 つのポート チャネルを設定します。これらの 2 つのポート チャネルを接続すると、リンクされた 2 つの Cisco Nexus デバイスが第 3 のデバイスには 1 つのデバイスとして見える vPC ピア リンクが作成されます。第 3 のデバイス、またはダウンストリーム デバイスは、スイッチ、サーバ、vPC に接続された正規のポート チャネルを使用するその他の任意のネットワーキング デバイスのいずれでもかまいません。正しいモジュールを使用していないと、システムからエラー メッセージが表示されます。


) 異なるモジュールの専用ポート上で vPC ピア リンクを設定して、障害発生の可能性を下げることをお勧めします。復元力を最適にしたい環境では、少なくとも 2 つのモジュールを使用してください。


Cisco NX-OS リリース 4.2 以降では、すべての vPC ピア リンクおよびコアに面したインターフェイスを 1 つのモジュール上で設定しなければならない場合、コアへのレイヤ 3 リンクに関連付けられているトラック オブジェクトおよび両方の vPC ピア デバイス上の vPC ピア リンク上のすべてのリンクを設定してください。いったんこの機能を設定したら、プライマリ vPC ピア デバイスに障害が発生した場合には、プライマリ vPC ピア デバイス上のすべての vPC リンクを、システムが自動的に停止します。システムが安定するまでは、このアクションにより、すべての vPC トラフィックが強制的にセカンダリ vPC ピア デバイスに送られます。

トラック オブジェクトを作成し、コアおよび vPC ピア リンクに接続されているプライマリ vPC ピア デバイス上のすべてのリンクにそのオブジェクトを適用します。 track interface コマンドについては、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x 』を参照してください。

vPC ドメインには、両方の vPC ピア デバイス、vPC ピアキープアライブ リンク、vPC ピア リンク、および vPC ドメイン内にあってダウンストリーム デバイスに接続されているすべてのポート チャネルが含まれます。各デバイスに設定できる vPC ドメイン ID は、1 つだけです。

このバージョンでは、各ダウンストリーム デバイスを、単一のポート チャネルを使用して単一の vPC ドメイン ID に接続できます。


) 常にすべての vPC デバイスを両方の vPC ピア デバイスに、ポート チャネルを使用して接続してください。


vPC(図 7-2 を参照)には、次の利点があります。

単一のデバイスが 2 つのアップストリーム デバイスを介して 1 つのポート チャネルを使用することを可能にします。

スパニングツリー プロトコル(STP)のブロック ポートが不要になります。

ループフリーなトポロジが実現されます。

利用可能なすべてのアップリンク帯域幅を使用します。

リンクまたはデバイスに障害が発生した場合に、ファースト コンバージェンスを提供します。

リンクレベルの復元力を提供します。

ハイ アベイラビリティが保証されます。

図 7-2 1 つの VDC 内の vPC インターフェイス

 

VDC の詳細については Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide, Release 5.x 』を参照してください。

vPC の用語

vPC で使用される用語は、次のとおりです。

vPC:vPC ピア デバイスとダウンストリーム デバイスの間の結合されたポート チャネル。

vPC ピア デバイス:vPC ピア リンクと呼ばれる特殊なポート チャネルで接続されている一対のデバイスの 1 つ。

vPC ピア リンク:vPC ピア デバイス間の状態を同期するために使用されるリンク。両エンドが 10 ギガバイト イーサネット インターフェイス上になくてはなりません。

vPC メンバ ポート:vPC に属するインターフェイス。

ホスト vPC ポート:vPC に属するファブリック エクステンダのホスト インターフェイス。

vPC ドメイン:このドメインには、両方の vPC ピア デバイス、vPC ピアキープアライブ リンク、vPC 内にあってダウンストリーム デバイスに接続されているすべてのポート チャネルが含まれます。また、このドメインは、vPC グローバル パラメータを割り当てるために使用する必要があるコンフィギュレーション モードに関連付けられています。

vPC ピアキープアライブ リンク:ピアキープアライブ リンクは、さまざまな vPC ピア Cisco Nexus 7000 シリーズのデバイスをモニタします。ピアキープアライブ リンクは、vPC ピア デバイス間での設定可能なキープアライブ メッセージの定期的な送信を行います。

ピアキープアライブ リンクを、各 vPC ピア デバイス内のレイヤ 3 インターフェイスにマッピングされている独立した VRF に関連付けることを推奨します。独立した VRF を設定しなかった場合は、デフォルトで管理 VRF が使用されます。ただし、ピアキープアライブ リンクに管理インターフェイスを使用する場合は、各 vPC ピア デバイスのアクティブ管理ポートとスタンバイ管理ポートの両方に接続した管理スイッチを置く必要があります(図 7-3 を参照)。

図 7-3 vPC ピアキープアライブ リンクの管理ポートを接続するための独立したスイッチが必要

 

vPC ピアキープアライブ リンク上を移動するデータまたは同期トラフィックはありません。このリンクを流れるトラフィックは、送信元スイッチが稼働しており、vPC を実行していることを知らせるメッセージだけです。

vPC メンバ ポート:vPC に属するインターフェイス。

デュアル アクティブ:プライマリとして動作する両方の vPC ピア。この状況は、両方のピアがまだアクティブなときにピアキープアライブとピア リンクがダウンした場合に発生します。この場合、セカンダリ vPC はプライマリ vPC が動作しないと想定し、プライマリ vPC として機能します。

リカバリ:ピアキープアライブとピア リンクが起動すると、1 台のスイッチがセカンダリ vPC になります。セカンダリ vPC になるスイッチで、vPC リンクが停止してから復帰します。

vPC ピア リンク

vPC ピア リンクは、vPC ピア デバイス間の状態を同期するために使用されるリンクです。リンクの両エンドが、10 ギガビット イーサネット インターフェイス上になくてはなりません。

vPC に 2 台のスイッチで動作するスプリット コントロール プレーンが含まれているため、vPC は次のようにピア リンクを使用します。

両方の vPC ピア スイッチにコントロール プレーン情報を同期します(vPC 状態、一貫性パラメータ、MAC アドレスなど)。

ローカル vPC がダウンしたとき、vPC ピア スイッチにデータ パケットを転送します。

同一の物理 Cisco Nexus 7000 デバイス上の 2 つの VDC 間の単一 vPC ドメインはサポートされません。

ここでは、vPC ピア リンクについて説明します。内容は次のとおりです。

「vPC ピア リンクの概要」

「プライマリおよびセカンダリ デバイス上で手動で設定する必要がある機能」

「vPC ピア リンクのレイヤ 3 バックアップ ルートの設定」


) vPC ピア リンクを設定する場合は、あらかじめピアキープアライブ リンクを設定しておく必要があります。設定しておかないと、ピア リンクは機能しません (vPC のピアキープアライブ リンクとメッセージの詳細については、「ピアキープアライブ リンクとメッセージ」 を参照してください)。


vPC ピア リンクは、2 つのデバイスを vPC ピアとして設定するように設定できます。vPC ピア リンクを設定するためには、モジュールを使用する必要があります。


) vPC ピア リンクを設定する場合は、専用ポート モードを使用することを推奨します。専用ポート モードの詳細については、「基本インターフェイス パラメータの設定」 を参照してください。


vPC ピア リンクと I/O モジュールのサポート

vPC ピア リンクの一方の側にある同一の I/O モジュールのみがサポートされます。vPC ピア リンクの一方の側で異なる I/O モジュールを使用している場合はサポートされません。ポート チャネルの同じ側で I/O モジュールを混在している場合もサポートされません。 表 7-1 では、vPC ピア リンクの両側でサポートされる I/O モジュールを表示します。図 7-4 から 図 7-7 では、vPC ピア リンクの両側でサポートされる設定とサポートされない設定を表示します。

表 7-1 vPC ピア リンクの両側でサポートされる I/O モジュールの組み合わせ

vPC プライマリ
vPC セカンダリ

F1 I/O モジュール

F1 I/O モジュール

M1 I/O モジュール

M1 I/O モジュール

図 7-4 サポート対象:vPC ピア リンクの一方の側にある 2 つの F1 I/O モジュール

 

図 7-5 サポート対象:vPC ピア リンクの一方の側にある 2 つの M1 I/O モジュール

 

図 7-6 サポート対象外:vPC ピア リンクの一方の側にある 2 つの異なる I/O モジュール
(M1 と F1)

 

図 7-7 サポート対象外:ピア リンクの同じ側にある混在した I/O モジュール

 

vPC ピア リンクの概要

vPC ピアとして持てるのは 2 台のデバイスだけです。各デバイスが、他方の 1 つの vPC ピアに対してだけ vPC ピアとして機能します。vPC ピア デバイスは、他のデバイスに対する非 vPC リンクも持つことができます。

無効な vPC ピア設定については、図 7-8 を参照してください。

図 7-8 許可されていない vPC ピア設定

 

有効な設定を作成するには、まず各デバイス上でポート チャネルを設定してから、vPC ドメインを設定します。ポート チャネルを各デバイスに、同じ vPC ドメイン ID を使用してピア リンクとして割り当てます。vPC ピア リンクのインターフェイスの片方に障害が発生した場合に、デバイスが自動的にピア リンク内の他方のインターフェイスを使用するようにフォールバックするため、冗長性のために少なくとも 2 つの専用ポートをポート チャネルに設定することを推奨します。


) レイヤ 2 ポート チャネルをトランク モードで設定することを推奨します。


多くの動作パラメータおよび設定パラメータが、vPC ピア リンクによって接続されている各デバイスで同じでなければなりません(「vPC インターフェイスの互換パラメータ」を参照)。各デバイスが管理プレーンから完全に独立しているため、デバイスが重要なパラメータについて互換性があることを管理者が確認する必要があります。vPC ピア デバイスは、独立したコントロール プレーンを持っています。vPC ピア リンクを設定し終えたら、各 vPC ピア デバイスの設定を表示して、設定に互換性があることを確認してください。


) vPC ピア リンクによって接続されている 2 つのデバイスが、特定の同じ動作パラメータおよび設定パラメータを持っていることを確認する必要があります。一貫性が必要な設定の詳細については、「vPC インターフェイスの互換パラメータ」を参照してください。


vPC ピア リンクを設定すると、vPC ピア デバイスは接続されたデバイスの一方がプライマリ デバイスで、もう一方の接続デバイスがセカンダリ デバイスであると交渉します(「vPC の設定」 を参照)。Cisco NX-OS ソフトウェアは、最小の MAC アドレスを使用してプライマリ デバイスを選択します。特定のフェールオーバー条件の下でだけ、ソフトウェアが各デバイス(つまり、プライマリ デバイスおよびセカンダリ デバイス)に対して異なるアクションを取ります。プライマリ デバイスに障害が発生すると、システムの回復時にセカンダリ デバイスが新しいプライマリ デバイスになり、以前のプライマリ デバイスがセカンダリ デバイスになります。

どちらの vPC デバイスをプライマリ デバイスにするか設定することもできます。vPC ピア デバイスのプライオリティを変更すると、ネットワークでインターフェイスがアップしたりダウンしたりする可能性があります。1 台の vPC デバイスをプライマリ デバイスにするよう再度ロール プライオリティを設定する場合は、プライオリティ値が低い プライマリ vPC デバイスと値が高いセカンダリ vPC デバイスの両方でロール プライオリティを設定します。次に、 shutdown コマンド を入力して、両方のデバイスで vPC ピア リンクであるポート チャネルをシャットダウンし、最後に no shutdown コマンドを入力して、両方のデバイスでポート チャネルを再度イネーブルにします。


) 各 vPC ピア デバイスの vPC ピア リンクに対して、冗長性のために、2 つの異なるモジュールを使用することを推奨します。


ソフトウェアは、vPC ピアを介して転送されたすべてのトラフィックをローカル トラフィックとしてキープします。ポート チャネルから入ってきたパケットは、vPC ピア リンクを介して移動するのではなく、ローカル リンクの 1 つを使用します。不明なユニキャスト、マルチキャスト、およびブロードキャスト トラフィック(STP BPDU を含む)は、vPC ピア リンクでフラッディングされます。ソフトウェアが、マルチキャスト フォワーディングを両方の vPC ピア デバイス上で同期された状態に保ちます。

両方の vPC ピア リンク デバイスおよびダウンストリーム デバイスで、任意の標準ロード バランシング スキームを設定できます(ロード バランシングの詳細については、「ポート チャネルの設定」を参照してください)。

設定情報は、Cisco Fabric Service over Ethernet(CFSoE)プロトコルを使用して vPC ピア リンクを流れます (CFSoE の詳細については、「CFSoE」を参照してください)。

両方のデバイス上で設定されているこれらの VLAN の MAC アドレスはすべて、vPC ピア デバイス間で同期されています。この同期に、CFSoE が使用されます (CFSoE については、「CFSoE」を参照してください)。

vPC ピア リンクに障害が発生した場合は、ソフトウェアが、両方のデバイスが稼働していることを確認するための vPC ピア デバイス間のリンクであるピアキープアライブ リンクを使用して、リモート vPC ピア デバイスのステータスをチェックします。vPC ピア デバイスが稼働している場合は、セカンダリ vPC デバイスは、ループやトラフィックの消失あるいはフラッディングを防ぐために、そのデバイス上のすべての vPC ポートをディセーブルにします。したがって、データは、ポート チャネルの残っているアクティブなリンクに転送されます。


) 独立した VRF を作成して設定し、その vPC ピアキープアライブ リンクのための VRF 内の各 vPC ピア デバイス上でレイヤ 3 ポートを設定することを推奨します。ピアキープアライブのデフォルト ポートとデフォルト VRF は、管理ポートと管理 VRF です。


ソフトウェアは、ピアキープアライブ リンクを介したキープアライブ メッセージが返されない場合に、vPC ピア デバイスに障害が発生したことを学習します。

vPC ピア デバイス間の設定可能なキープアライブ メッセージの送信には、独立したリンク(vPC ピアキープアライブ リンク)を使用します。vPC ピアキープアライブ リンク上のキープアライブ メッセージから、障害が vPC ピア リンク上でだけ発生したのか、vPC ピア デバイス上で発生したのかがわかります。キープアライブ メッセージは、ピア リンク内のすべてのリンクで障害が発生した場合にだけ使用されます。キープアライブ メッセージの詳細については、「ピアキープアライブ リンクとメッセージ」を参照してください。

プライマリおよびセカンダリ デバイス上で手動で設定する必要がある機能

各 vPC ピア デバイスのプライマリ/セカンダリ マッピングに従うために、次の機能を手動で設定する必要があります。

STP ルート:プライマリ vPC ピア デバイスを STP プライマリ ルート デバイスとして設定し、vPC セカンダリ デバイスを STP セカンダリ ルート デバイスとして設定します。vPC および STP の詳細については、「vPC ピア リンクと STP」を参照してください。

Bridge Assurance がすべての vPC ピア リンク上でイネーブルになるように、vPC ピア リンク インターフェイスを STP ネットワーク ポートとして設定することを推奨します。

プライマリ デバイスがすべての VLAN のルートになるように Rapid PVST+ を設定し、プライマリ デバイスがすべてのインターフェイスのルートになるように MST を設定することを推奨します。

レイヤ 3 VLAN ネットワーク インターフェイス:両方のデバイスから同じ VLAN の VLAN ネットワーク インターフェイスを設定することにより、各 vPC ピア デバイスからのレイヤ 3 接続を設定します。

HSRP アクティブ:vPC ピア デバイス上で HSRP と VLAN インターフェイスを使用する場合は、プライマリ vPC ピア デバイスを HSRP アクティブの最も高いプライオリティで設定します。セカンダリ デバイスは HSRP スタンバイになるように設定します。また、同じ管理/動作モードにある各 vPC デバイス上に VLAN インターフェイスがあることを確認します (vPC および HSRP の詳細については、「vPC ピア リンクとルーティング」を参照してください)。

vPC ピア リンクの両側で単方向リンク検出(UDLD)を設定することを推奨します。UDLD を設定する手順については「UDLD モードの設定」を参照してください。

vPC ピア リンクのレイヤ 3 バックアップ ルートの設定

HSRP や PIM などのアプリケーションを使用するネットワークのレイヤ 3 にリンクするために、vPC ピア デバイス上の VLAN ネットワーク インターフェイスを使用できます。ただし、この目的には VLAN ネットワーク インターフェイスを使用するよりも、vPC ピア デバイスからのルーティングのためのレイヤ 3 リンクを別途設定することを推奨します。


) 各ピア デバイス上で VLAN ネットワーク インターフェイスが設定されており、そのインターフェイスが各デバイス上で同じ VLAN に接続されていることを確認してください。また、各 VLAN インターフェイスが、同じ管理/動作モードになっていなければなりません。VLAN ネットワーク インターフェイスの設定方法の詳細については、「レイヤ 3 インターフェイスの設定」を参照してください。


vPC ピア リンクでフェールオーバーが発生すると、vPC ピア デバイス上の VLAN インターフェイスも影響を受けます。vPC ピア リンクに障害が発生すると、セカンダリ vPC ピア デバイス上の関連付けられている VLAN インターフェイスがシステムによって停止されます。

Cisco NX-OS リリース 4.2(1) 以降では、指定した VLAN インターフェイスが vPC ピア リンクに障害が発生しても vPC セカンダリ デバイス上で停止しないようにすることができるようになりました。

この機能を設定するには、 dual-active exclude interface-vlan コマンドを使用します。


) vPC ドメインにレイヤ 3 デバイスを接続した場合、vPC ピア リンク上でも送信される VLAN を使用したルーティング プロトコルのピアリングはサポートされません。vPC ピア デバイスおよび汎用レイヤ 3 デバイスの間でルーティング プロトコルの隣接関係が必要な場合は、相互接続に物理的にルーティングされたインターフェイスを使用する必要があります。vPC ピアゲートウェイ機能の使用では、この要件は変わりません。


ピアキープアライブ リンクとメッセージ

Cisco NX-OS ソフトウェアは、vPC ピア間でピアキープアライブ リンクを使用して、設定可能なキープアライブ メッセージを定期的に送信します。これらのメッセージを送信するには、ピア デバイス間にレイヤ 3 接続がなくてはなりません。ピアキープアライブ リンクが有効になって稼働していないと、システムは vPC ピア リンクを稼働させることができません。


) vPC ピアキープアライブ リンクを、各 vPC ピア デバイス内のレイヤ 3 インターフェイスにマッピングされている独立した VRF に関連付けることを推奨します。独立した VRF を設定しなかった場合は、デフォルトで管理 VRF と管理ポートが使用されます。vPC ピアキープアライブ メッセージの送受信にピア リンク自体を使用することはしないでください。VRF の設定方法の詳細については、『Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x』を参照してください。


片方の vPC ピア デバイスに障害が発生したら、vPC ピア リンクの他方の側にある vPC ピア デバイスは、ピアキープアライブ メッセージを受信しなくなることによってその障害を感知します。vPC ピアキープアライブ メッセージのデフォルトの間隔は、1 秒です。この間隔は、400 ミリ秒~ 10 秒の範囲内で設定可能です。

ホールドタイムアウト値は、3 ~ 10 秒の範囲内で設定可能で、デフォルトのホールドタイムアウト値は 3 秒です。このタイマーは、vPC ピア リンクが停止した時点で開始します。セカンダリ vPC ピア デバイスは、ネットワークの収束が確実に発生してから vPC アクションが発生するようにするために、このホールドタイムアウト期間の間は vPC ピアキープアライブ メッセージを無視します。ホールドタイムアウト期間の目的は、誤ったポジティブ ケースを防ぐことです。

タイムアウト値は、3 ~ 20 秒の範囲内で設定可能で、デフォルトのタイムアウト値は 5 秒です。このタイマーは、ホールドタイムアウト間隔が終了した時点で開始します。このタイムアウト期間の間は、セカンダリ vPC ピア デバイスは、プライマリ vPC ピア デバイスから vPC ピアキープアライブ hello メッセージが送信されてこないかチェックします。セカンダリ vPC ピア デバイスが 1 つの hello メッセージを受信したら、そのデバイスは、セカンダリ vPC ピア デバイス上のすべての vPC インターフェイスをディセーブルにします。

ホールドタイムアウト パラメータとタイムアウト パラメータの相違点は、次のとおりです。

ホールドタイムアウトの間は、vPC セカンダリ デバイスは、受信したキープアライブ メッセージに基づいてアクションを起こしません。それにより、たとえばスーパーバイザがピア リンクがダウンした数秒後に失敗した場合などに、キープアライブが一時的に受信される可能性がある場合に、システムがアクションを起こすのを回避できます。

タイムアウト中は、vPC セカンダリ デバイスは、設定された間隔が終了するまでにキープアライブ メッセージを受信できないと、vPC プライマリ デバイスになるというアクションを取ります。

キープアライブ メッセージのタイマーの設定については、「vPC の設定」 を参照してください。


) ピアキープアライブ メッセージに使用される送信元 IP アドレスと宛先 IP アドレスがどちらもネットワーク上で一意であり、かつそれらの IP アドレスがその vPC ピアキープアライブ リンクに関連付けられている VRF から到達可能であることを確認してください。


コマンドライン インターフェイス(CLI)を使用して、vPC ピアキープアライブ メッセージを使用するインターフェイスを信頼できるポートとして設定してください。優先順位をデフォルト(6)のままにしておくか、またはもっと高い値に設定します。次に、インターフェイスを信頼できるポートとして設定する例を示します。

(config)# class-map type qos match-all trust-map
(config-cmap-qos)# match cos 4-7
 
(config)# policy-map type qos ingresspolicy
(config-pmap-qos)# class trust-map
 
(config)# interface Ethernet8/11
(config-if)# service-policy type qos input ingresspolicy
 

信頼できるポートと優先順位の設定方法の詳細については、『 Cisco Nexus 7000 Series NX-OS Quality of Service Configuration Guide, Release 5.x 』を参照してください。

vPC ピア ゲートウェイ

Cisco NX-OS リリース 4.2(1) 以降では、vPC ピア デバイスを、vPC ピア デバイスの MAC アドレスを送信先とするパケットに対してもゲートウェイとして機能するように設定できるようになりました。

この機能を設定するには、 peer-gateway コマンドを使用します。

一部の Network-Attached Storage(NAS)デバイスまたはロードバランサは、特定のアプリケーションのパフォーマンスを最適化することを目的とした機能を備えている場合があります。基本的に、こういった機能では、同じサブネットにローカルには接続されていないホストから発生した要求に応答する場合に、ルーティング テーブル ルックアップの実行が避けられます。このようなデバイスは、一般的な HSRP ゲートウェイではなく、送信元 Cisco Nexus 7000 シリーズ デバイスの MAC アドレスを使用して、トラフィックに応答する場合があります。このような動作は、一部の基本的なイーサネット RFC 規格と互換性がありません。ローカルではないルータ MAC アドレスの vPC デバイスに到達するパケットは、ピア リンクを介して送信され、最終的な宛先が他の vPC の背後にある場合には、組み込みの vPC ループ回避メカニズムによってドロップされる場合があります。

vPC ピアゲートウェイ機能は、vPC スイッチが、vPC ピアのルータ MAC アドレスを宛先とするパケットに対して、アクティブなゲートウェイとして機能することを可能にします。この機能は、このようなパケットが vPC ピア リンクを通過する必要なしにローカルに転送されることを可能にします。このシナリオでは、この機能によってピア リンクの使用が最適化され、トラフィック損失が回避されます。

ピアゲートウェイ機能の設定は、プライマリ vPC ピアとセカンダリ vPC ピアの両方で行う必要がありますが、デバイスの稼働も vPC トラフィックも中断しません。vPC ピアゲートウェイ機能は、vPC ドメイン サブモードの下でグローバルに設定できます。

この機能をイネーブルにすると、ピア ゲートウェイ ルータを介してスイッチングされたパケットの IP リダイレクト メッセージの発生を避けるために、Cisco NX-OS は vPC VLAN を介してマッピングされるすべてのインターフェイス VLAN 上で IP リダイレクトを自動的にディセーブルにします。


) Cisco NX-OS リリース 5.1(3) 以降では、VLAN インターフェイスが vPC ピア デバイスのレイヤ 3 バックアップ ルーティングに使用され、F1 ラインカードがピア リンクとして使用される場合は、peer-gateway exclude-vlan vlan-number コマンドを実行して VLAN をピアゲートウェイ機能から除外する必要があります(イネーブルの場合)。バックアップ ルートについての詳細については、「vPC ピア リンクのレイヤ 3 バックアップ ルートの設定」 を参照してください。


ピアゲートウェイ vPC デバイスに到達するパケットは、その TTL がデクリメントされるため、TTL = 1 となっているパケットは TTL の失効が原因で伝送中にドロップされる可能性があります。ピアゲートウェイ機能がイネーブルになっており、パケットを TTL = 1 で送出する特定のネットワーク プロトコルが vPC VLAN 上で稼働している場合は、これを考慮する必要があります。

vPC ドメイン

vPC ドメイン ID を使用すれば、vPC ダウンストリーム デバイスに接続されている vPC ピア リンクとポートを識別できます。

vPC ドメインは、キープアライブ メッセージを設定するために使用したり、他の vPC ピア リンク パラメータについて、デフォルト値をそのまま使用するのではなく値を設定する場合に使用したりするコンフィギュレーション モードでもあります。これらのパラメータの設定方法については、「vPC の設定」を参照してください。

vPC ドメインを作成するには、まず各 vPC ピア デバイス上で、1 ~ 1000 の値を使用して vPC ドメイン ID を作成しなければなりません。VDC につき設定できる vPC ドメインは、1 つだけです。

各デバイス上で、ピア リンクとして機能させるポート チャネルを明示的に設定する必要があります。各デバイス上でピア リンクにしたポート チャネルを、1 つの vPC ドメインからの同じ vPC ドメイン ID に関連付けます。このドメイン内で、システムはループフリー トポロジとレイヤ 2 マルチパスを提供します。

これらのポート チャネルと vPC ピア リンクは、静的にしか設定できません。各 vPC ピア デバイス上の vPC 内のすべてのポートが、同じ VDC 内になくてはなりません。ポート チャネルおよび vPC ピア リンクは、LACP を使用するかまたはプロトコルなしのいずれかで設定できます。各 vPC でポート チャネルを設定するにはアクティブ モードのインターフェイスで LACP を使用することを推奨します。それにより、ポート チャネルのフェールオーバー シナリオの最適でグレースフルなリカバリが保証され、ポート チャネル間の設定不一致に対する設定検査が行われます。

vPC ピア デバイスは、設定された vPC ドメイン ID を使用して、一意の vPC システム MAC アドレスを自動的に割り当てます。各 vPC ドメインが、具体的な vPC 関連操作に ID として使用される一意の MAC アドレスを持ちます。ただし、デバイスは vPC システム MAC アドレスを LACP などのリンクスコープでの操作にしか使用しません。連続したレイヤ 2 ネットワーク内の各 vPC ドメインを、一意のドメイン ID で作成することを推奨します。Cisco NX-OS ソフトウェアにアドレスを割り当てさせるのではなく、vPC ドメインに特定の MAC アドレスを設定することもできます。

vPC MAC の表示の詳細については、「CFSoE」を参照してください。

vPC ドメインを作成した後は、Cisco NX-OS ソフトウェアによって vPC ドメインのシステム プライオリティが作成されます。vPC ドメインに特定のシステム プライオリティを設定することもできます。


) システム プライオリティを手動で設定する場合は、必ず両方の vPC ピア デバイス上で同じプライオリティ値を割り当てる必要があります。vPC ピア デバイス同士が異なるシステム プライオリティ値を持っていると、vPC は稼働しません。


vPC トポロジ

図 7-3 では、Cisco Nexus 7000 シリーズ スイッチ ポートが別のスイッチまたはホストに直接接続され、vPC の一部となるポート チャネルの一部として設定される基本設定を示します。

図 7-9 スイッチ vPC トポロジ

 

この図では、vPC 20 がポート チャネル 20 で設定され、最初のスイッチには Eth1/10 が、2 番目のスイッチには Eth2/1 がメンバ ポートとしてあります。

Cisco NX-OS リリース 5.2(1) 以降では、図 7-10 に示すように、ファブリック エクステンダ(FEX)を通してピア デバイスから vPC を設定できます。

図 7-10 FEX Straight-Through トポロジ(ホスト vPC)

 

この図では、各 FEX が Cisco Nexus 7000 シリーズ スイッチ でシングルホーム(Straight-Through FEX トポロジ)になっています。この FEX 上のホスト インターフェイスはポート チャネルとして設定され、それらのポート チャネルは vPC として設定されています。Eth100/1/1 および Eth102/1/5 は、PO200 のメンバーとして設定され、PO200 は vPC 200 に対し設定されます。

どちらのトポロジでも、ポート チャネル P020 および P0200 をピア スイッチ上でまったく同じように設定する必要があります。その後、設定の同期を使用して vPC スイッチの設定を同期します。

FEX ポート設定の詳細については、『 Configuring the Cisco Nexus 2000 Series Fabric Extender 』 を参照してください。

vPC インターフェイスの互換パラメータ

多くの設定パラメータおよび動作パラメータが、vPC 内のすべてのインターフェイスで同じでなければなりません。vPC ピア リンクに使用するレイヤ 2 ポート チャネルはトランク モードに設定することを推奨します。

両方の vPC ピア デバイス上で vPC 機能をイネーブルにし、ピア リンクを設定したら、CFS メッセージによって、ローカル vPC ピア デバイス上の設定のコピーがリモート vPC ピア デバイスに提供されます。これにより、システムが 2 つのデバイス上で異なっている重要な設定パラメータがないか調べます (CFS の詳細については、「CFSoE」を参照してください)。


) vPC 内のすべてのインターフェイスで設定されている値を表示するには、show vpc consistency-parameters コマンドを入力します。表示される設定は、vPC ピア リンクおよび vPC の稼働を制限する可能性のある設定だけです。


vPC の互換性チェックプロセスは、正規のポート チャネルの互換性チェックとは異なります。正規のポート チャネルについては、「ポート チャネルの設定」を参照してください。

ここでは、次の内容について説明します。

「同じでなければならない設定パラメータ」

「同じにすべき設定パラメータ」

「パラメータの不一致の結果」

同じでなければならない設定パラメータ

このセクションの設定パラメータは、vPC ピア リンクの両方のデバイスで同じに設定する必要があります。そうしないと、vPC は一時停止モードに完全にまたは部分的に移動します。


注意 VPC VLAN かどうかにかかわらず、スパニング ツリーがいずれの VLAN に対してもディセーブルの場合、グローバル タイプ 1 の不整合が生じ、すべて VPC VLAN が一時停止します。この問題は、存在しない VLAN に対しスパニング ツリーをディセーブルにする場合にも発生します。


) vPC 内のすべてのインターフェイスで、下に示す動作パラメータおよび設定パラメータの値が同じになっていなければなりません。



) vPC 内のすべてのインターフェイスで設定されている値を表示するには、show vpc consistency-parameters コマンドを入力します。表示される設定は、vPC ピア リンクおよび vPC の稼働を制限する可能性のある設定だけです。


vPC インターフェイスでのこれらのパラメータの一部は、デバイスによって自動的に互換性がチェックされます。インターフェイスごとのパラメータは、インターフェイスごとに一貫性を保っていなければならず、グローバル パラメータはグローバルに一貫性を保っていなければなりません。

ポートチャネル モード:オン、オフ、またはアクティブ

チャネル単位のリンク速度

チャネル単位のデュプレックス モード

チャネルごとのトランク モード:

ネイティブ VLAN

トランク上で許可される VLAN

ネイティブ VLAN トラフィックのタギング

スパニング ツリー プロトコル(STP)モード

Multiple Spanning Tree 用の STP リージョン コンフィギュレーション

VLAN ごとのイネーブル/ディセーブル状態

STP グローバル設定:

ブリッジ保証設定

ポート タイプ設定

ループ ガード設定

STP インターフェイス設定:

ポート タイプ設定

ループ ガード

ルート ガード

最大伝送単位(MTU)

これらのパラメータのいずれかがイネーブルになっていなかったり、片方のデバイスでしか定義されていないと、vPC の一貫性チェックではそのパラメータは無視されます。


) どの vPC インターフェイスもサスペンド モードになっていないことを確認するには、show vpc brief コマンドおよび show vpc consistency-parameters コマンドを入力して、syslog メッセージをチェックします。


同じにすべき設定パラメータ

次に挙げるパラメータのいずれかが両方の vPC ピア デバイス上で同じように設定されていないと、誤設定が原因でトラフィック フローに望ましくない動作が発生する可能性があります。

MAC エージング タイマー

スタティック MAC エントリ

VLAN インターフェイス:vPC ピア リンク エンドにある各デバイスの VLAN インターフェイスが両エンドで同じ VLAN 用に設定されていなければならず、さらに同じ管理モードで同じ動作モードになっていなければなりません。ピア リンクの片方のデバイスだけで設定されている VLAN は、vPC またはピア リンクを使用してトラフィックを通過させることはしません。すべての VLAN をプライマリ vPC デバイスとセカンダリ vPC デバイスの両方で作成する必要があります。そうなっていない VLAN は、停止します。

ACL のすべての設定とパラメータ

Quality of Service(QoS)の設定とパラメータ

STP インターフェイス設定:

BPDU Filter

BPDU ガード

コスト

リンク タイプ

プライオリティ

VLAN(Rapid PVST+)

ポート セキュリティ

Cisco Trusted Security(CTS)

ダイナミック ホスト コンフィギュレーション プロトコル(DHCP)スヌーピング

ネットワーク アクセス コントロール(NAC)

ダイナミック ARP インスペクション(DAI)

IP ソース ガード(IPSG)

インターネット グループ管理プロトコル(IGMP)スヌーピング

ホット スタンバイ ルーティング プロトコル(HSRP)

プロトコルに依存しないマルチキャスト(PIM)

ゲートウェイ ロード バランシング プロトコル(GLBP)

すべてのルーティング プロトコル設定

すべての設定パラメータで互換性が取れていることを確認するために、vPC の設定が終わったら、各 vPC ピア デバイスの設定を表示してみることを推奨します。

パラメータの不一致の結果

Cisco NX-OS リリース 5.2(1) より前のリリースでは、整合性検査により一致しなければならないパラメータのリストからパラメータの不一致が検出されると、vPC ピア リンクと vPC は稼働できません。vPC がすでに確立された後にパラメータの不一致が設定された場合は、vPC は一時停止モードに移動し、vPC にトラフィックは流れません。

Cisco NX-OS リリース 5.2(1) 以降では、グレースフルな整合性検査機能を設定でき、不一致が作動中の vPC で導入されたときに、セカンダリ ピア デバイス上のリンクのみを中断できます。この機能は CLI のみで設定可能で、デフォルトでイネーブルになっています。

この機能を設定するには、 graceful consistency-check コマンドを使用します。

一致しなければならないパラメータのリストのすべてのパラメータに関する整合性検査の一部として、システムはすべての VLAN の一貫性をチェックします。NX-OS リリース 5.2(1) より前のリリースでは、有効な VLAN の設定がピア デバイス間で矛盾している場合は、vPC の確立や一時停止モードへの移動はできません。

Cisco NX-OS リリース 5.2(1) 以降では、vPC は動作可能なままで、矛盾した VLAN のみがダウンします。この VLAN 単位の整合性検査機能はディセーブルにできず、マルチ スパニングツリー(MST)VLAN には適用されません。

vPC 番号

vPC ドメイン ID と vPC ピア リンクを作成し終えたら、ダウンストリーム デバイスを各 vPC ピア デバイスに接続するためのポート チャネルを作成します。つまり、プライマリ vPC ピア デバイスからダウンストリーム デバイスへのポート チャネルを 1 つ作成し、もう 1 つ、セカンダリ ピア デバイスからダウンストリーム デバイスへのポート チャネルも作成します。


) スイッチとしてもブリッジとしても機能しないホストまたはネットワーク デバイスに接続されているダウンストリーム デバイス上のポートは、STP エッジ ポートとして設定することを推奨します。STP ポート タイプの詳細については、Cisco Nexus 7000 Series NX-OS Layer 2 Switching Configuration Guide, Release 5.x』を参照してください。


最後に、各 vPC ピア デバイスで作業し、ダウンストリーム デバイスに接続するポート チャネルに vPC 番号を割り当てます。vPC の作成時にトラフィックが中断されることはほとんどありません。すべてのポート番号に、ポート チャネル自体と同じ vPC ID 番号を割り当てると(つまり、ポート チャネル 10 には vPC ID 10)、設定が簡単になります。


) vPC ピア デバイスからダウンストリーム デバイスに接続されているポート チャネルに割り当てる vPC 番号は、両方の vPC デバイスで同じでなければなりません


他のポート チャネルの vPC への移行


) ダウンストリーム デバイスは、ポート チャネルを使用して両方の vPC ピア デバイスに接続する必要があります。


ダウンストリーム デバイスを接続するために、プライマリ vPC ピア デバイスからダウンストリーム デバイスへのポート チャネルを作成し、セカンダリ ピア デバイスからダウンストリーム デバイスへのもう 1 つのポート チャネルを作成します。最後に、各 vPC ピア デバイスで作業し、ダウンストリーム デバイスに接続するポート チャネルに vPC 番号を割り当てます。vPC の作成時にトラフィックが中断されることはほとんどありません。

単一モジュール上での vPC ピア リンクとコアへのリンクの設定


) 異なるモジュールの専用ポート上で vPC ピア リンクを設定して、障害発生の可能性を下げることをお勧めします。復元力を最適にしたい環境では、少なくとも 2 つのモジュールを使用してください。


Cisco NX-OS Release 4.2 以降では、すべての vPC ピア リンクとコアに面するインターフェイスを単一モジュール上で設定しなければならない場合は、両方の vPC ピア デバイス上のすべての vPC ピア リンク上の、およびコアへのレイヤ 3 リンクに関連付けられているトラック オブジェクトとトラック リストをコマンドライン インターフェイスを使用して設定してください。トラック リスト上のすべてのトラッキング対象オブジェクトが停止した場合、システムは次のように動作するため、この設定を使用すれば、その特定のモジュールが停止した場合のトラフィックのドロップを避けることができます。

vPC プライマリ ピア デバイスによるピアキープアライブ メッセージの送信を停止します。これにより、vPC セカンダリ ピア デバイスが強制的に引き継がされます。

その vPC ピア デバイス上のすべてのダウンストリーム vPC を停止させます。これにより、すべてのトラフィックが強制的に他の vPC ピア デバイスに向けてそのアクセス スイッチでルーティングされます。

いったんこの機能を設定したら、モジュールに障害が発生した場合には、システムが自動的にプライマリ vPC ピア デバイス上のすべての vPC リンクを停止させ、ピアキープアライブ メッセージを停止します。このアクションにより、vPC セカンダリ デバイスが強制的にプライマリ ロールを引き継がされ、システムが安定するまで、すべての vPC トラフィックがこの新しい vPC プライマリ デバイスに送られます。

コアに対するすべてのリンクおよびすべての vPC ピア リンクを含むトラック リストを、そのオブジェクトとして作成します。このトラック リストの指定した vPC ドメインに対して、トラッキングをイネーブルにします。この同じ設定を他方の vPC ピア デバイスにも適用します。オブジェクト トラッキングとトラック リストについては、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x 』 を参照してください。

オブジェクト トラッキングの設定方法については、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x 』を参照してください。


) 次の例では、ブール OR を追跡リストで使用し、完全なモジュール障害の場合にのみすべてのトラフィックが vPC ピア デバイスへ流れるよう強制します。コア インターフェイスまたはピア リンクがダウンしたときにスイッチオーバーをトリガーする場合は、次の追跡リストでブール AND を使用します。


単一モジュール上の関連するすべてのインターフェイスが故障したときに vPC をリモート ピアに切替えるように追跡リストを設定するには、次の手順に従います。


ステップ 1 インターフェイス上(コアへのレイヤ 3)およびポート チャネル上(vPC ピア リンク)でトラック オブジェクトを設定します。

n7k-1(config-if)# track 35 interface ethernet 8/35 line-protocol
n7k-1(config-track)# track 23 interface ethernet 8/33 line-protocol
n7k-1(config)# track 55 interface port-channel 100 line-protocol
 

ステップ 2 ブール OR を使って追跡リスト内のすべてのインターフェイスを含むトラック リストを作成して、すべてのオブジェクトに障害が発生したときにトリガーします。

n7k-1(config)# track 44 list boolean OR
n7k-1(config-track)# object 23
n7k-1(config-track)# object 35
n7k-1(config-track)# object 55
n7k-1(config-track)# end
 

ステップ 3 このトラック オブジェクトを vPC ドメインに追加します。

n7k-1(config)# vpc domain 1
n7k-1(config-vpc-domain)# track 44
 

ステップ 4 次の例は、 show vpc brief コマンドを使用して、トラック オブジェクトを表示する方法を示します。

n7k-1# show vpc brief
Legend:
                (*) - local vPC is down, forwarding via vPC peer-link
vPC domain id                   : 1
Peer status                     : peer adjacency formed ok
vPC keep-alive status           : peer is alive
Configuration consistency status: success
vPC role                        : secondary
Number of vPCs configured       : 52
Track object                    : 44
 
vPC Peer-link status
---------------------------------------------------------------------
id   Port   Status Active vlans
--   ----   ------ --------------------------------------------------
1    Po100  up     1-5,140
 
vPC status
--------------------------------------------------------------------------------------
id   Port   Status Consistency Reason                     Active vlans
--   ----   ------ ----------- -------------------------- ------------
1    Po1    up     success     success                    1-5,140
 


 

次の例は、 show track brief コマンドを使用して、トラック オブジェクトに関する情報を表示する方法を示します。

n7k-1# show track brief
Track Type         Instance                                Parameter      State  Last Change
23    Interface    Ethernet8/33                            Line Protocol  UP     00:03:05
35    Interface    Ethernet8/35                            Line Protocol  UP     00:03:15
44    List         -----                                            Boolean or     UP     00:01:19
55    Interface    port-channel100                         Line Protocol  UP   00:00:34

vPC と LACP

LACP は、vPC ドメインのシステム MAC アドレスを使用して、vPC の LACP Aggregation Group(LAG)ID を形成します (LAG-ID と LACP については、「ポート チャネルの設定」を参照してください)。

ダウンストリーム デバイスからのチャネルも含めて、すべての vPC ポート チャネル上の LACP を使用できます。LACP は、vPC ピア デバイスの各ポート チャネル上のインターフェイスのアクティブ モードで設定することを推奨します。この設定により、デバイス、単方向リンク、およびマルチホップ接続の間の互換性をより簡単に検出できるようになり、実行時の変更およびリンク障害に対してダイナミックな応答が可能になります。

M シリーズ モジュールおよび LACP では、vPC ピア リンクは、16 個の LACP インターフェイス(8 個のアクティブ リンクと 8 個のホット スタンバイ リンク)をサポートします。ダウンストリーム vPC チャネル上では、8 個のアクティブ リンクと 8 個のホット スタンバイ リンクとで、16 個の LACP リンクを設定できます。LACP を使用せずにポート チャネルを設定する場合は、各チャネルに 8 個のリンクしか持てません。F シリーズのラインカードでは、vPC ピア リンクとダウンストリーム vPC チャネルは最大 16 個のアクティブな LACP リンクをサポートします。ポート チャネルが LACP を使用して設定されていなくても、各チャネルに 16 個のリンクを設定できます。

vPC ピア リンク デバイスのシステム プライオリティを手動で設定して、vPC ピア リンク デバイスが、接続されているダウンストリーム デバイスより確実に高い LACP プライオリティを持つようにすることを推奨します。システム プライオリティの値が低いほど、高い LACP プライオリティを意味します。


) システム プライオリティを手動で設定する場合は、必ず両方の vPC ピア デバイス上で同じプライオリティ値を割り当てる必要があります。vPC ピア デバイス同士が異なるシステム プライオリティ値を持っていると、vPC は稼働しません。


vPC ピア リンクと STP

vPC はループフリーなレイヤ 2 トポロジを提供しますが、それでもやはり、誤った配線やケーブルの欠陥、誤設定などから保護するための「フェールセイフ」メカニズムをスパニング ツリー プロトコル(STP)が提供する必要があります。vPC を初めて稼働させたときに、STP による再コンバージェンスが発生します。STP は、vPC ピア リンクを特殊なリンクとして扱い、常に vPC ピア リンクを STP のアクティブ トポロジに含めます。

すべての vPC ピア リンク インターフェイスを STP ネットワーク ポート タイプに設定して、すべての vPC リンク上で Bridge Assurance が自動的にイネーブルになるようにすることを推奨します。また、vPC ピア リンク上ではどの STP 拡張機能もイネーブルにしないことも推奨します。STP 拡張がすでに設定されている場合は何も問題は発生しませんが、これらを設定する必要はありません。

MST と Rapid PVST+ の両方を実行している場合は、必ず PVST シミュレーション機能を正しく設定してください。

STP 拡張機能と PVST シミュレーションの詳細については、 Cisco Nexus 7000 Series NX-OS Layer 2 Switching Configuration Guide, Release 5.x


) パラメータのリストは、vPC ピア リンクの両サイドの vPC ピア デバイス上で同じになるように設定する必要があります。これらの一致していなければならない必須設定については、「vPC インターフェイスの互換パラメータ」を参照してください。


STP は分散しています。つまり、このプロトコルは、両方の vPC ピア デバイス上で実行され続けます。ただし、プライマリ デバイスとして選択されている vPC ピア デバイス上での設定が、セカンダリ vPC ピア デバイス上の vPC インターフェイスの STP プロセスを制御します。

プライマリ vPC デバイスは、Cisco Fabric Services over Ethernet(CFSoE)を使用して、vPC セカンダリ ピア デバイス上の STP の状態を同期させます。CFSoE については、「CFSoE」を参照してください。

vPC の STP プロセスも、ピア リンク上で接続されているデバイスの 1 つに障害が発生したときにそれを検出するために、定期的なキープアライブ メッセージに依存しています。これらのメッセージについては、「ピアキープアライブ リンクとメッセージ」を参照してください。

vPC マネージャが、vPC ピア デバイス間で、プライマリ デバイスとセカンダリ デバイスを設定して 2 つのデバイスを STP 用に調整する提案/ハンドシェイク合意を実行します。その後、プライマリ vPC ピア デバイスが、プライマリ デバイスとセカンダリ デバイス両方での STP プロトコルの制御を行います。プライマリ vPC ピア デバイスを STP プライマリ ルート デバイスとして設定し、セカンダリ VPC デバイスを STP セカンダリ ルート デバイスになるように設定することを推奨します。

プライマリ vPC ピア デバイスがセカンダリ vPC ピア デバイスにフェールオーバーした場合、STP トポロジには何の変化も発生しません。

BPDU は、代表ブリッジ ID フィールドで、STP ブリッジ ID の vPC に設定されている MAC アドレスを使用します。vPC プライマリ デバイスが、vPC インターフェイス上でこれらの BPDU を送信します。

次のパラメータについて同じ STP 設定を使用して、vPC ピア リンクの両エンドを設定する必要があります。

STP グローバル設定:

STP モード

MST のための STP リージョン設定

VLAN ごとのイネーブル/ディセーブル状態

ブリッジ保証設定

ポート タイプ設定

ループ ガード設定

STP インターフェイス設定:

ポート タイプ設定

ループ ガード

ルート ガード


) これらのパラメータのいずれかに誤設定があった場合、Cisco NX-OS ソフトウェアが vPC 内のすべてのインターフェイスを停止します。syslog をチェックし、show vpc brief コマンドを入力して、vPC インターフェイスが停止していないか確認してください。


次の STP インターフェイス設定が、vPC ピア リンクの両側で同じになっていることを確認します。そうなっていないと、トラフィック フローに予測不能な動作が発生する可能性があります。

BPDU Filter

BPDU ガード

コスト

リンク タイプ

プライオリティ

VLAN(PVRST+)


) vPC ピア リンクの両側での設定を表示して、設定が同じであることを確認してください。


この機能がイネーブルになっている場合は、 show spanning-tree コマンドで vPC に関する情報を表示できます。例については、 Cisco Nexus 7000 Series NX-OS Layer 2 Switching Configuration Guide, Release 5.x を参照してください。


) ダウンストリーム デバイスのポートは、STP エッジ ポートとして設定することを推奨します。スイッチに接続されているすべてのホスト ポートを STP エッジ ポートとして設定してください (STP ポート タイプの詳細については、Cisco Nexus 7000 Series NX-OS Layer 2 Switching Configuration Guide, Release 5.x』を参照してください)。


vPC ピア スイッチ

vPC ピア スイッチ機能は、STP コンバージェンスに関連するパフォーマンス上の問題を解決するために、Cisco NX-OS Release 5.0(2) に追加されました。この機能は、一対の Cisco Nexus 7000 シリーズ デバイスがレイヤ 2 トポロジ内で 1 つの STP ルートとして現れることを可能にします。この機能は、STP ルートを vPC プライマリ スイッチに固定する必要性をなくし、vPC プライマリ スイッチに障害が発生した場合の vPC コンバージェンスを向上させます。

ループを回避するために、vPC ピア リンクは STP 計算からは除外されます。vPC ピア スイッチ モードでは、ダウンストリーム スイッチでの STP BPDU タイムアウトに関連した問題(この問題は、トラフィックの中断につながります)を避けるために、STP BPDU が両方の vPC ピア デバイスから送信されます。

この機能は、すべてのデバイス vPC に属する純粋なピア スイッチ トポロジで使用できます。


) ピア スイッチ機能は、vPC を使用するネットワークでサポートされ、STP ベースの冗長性はサポートされません。ハイブリッド ピア スイッチ設定で vPC ピア リンクに障害が発生すると、トラフィックが失われる場合があります。このシナリオでは、vPC ピアは同じ STP ルート ID や同じブリッジ ID を使用します。アクセス スイッチのトラフィックは 2 つに別れ、その半分が最初の vPC ピアに、残りの半分が 2 番目の vPC ピアに転送されます。ピア リンクに障害が発生すると、北南のトラフィックに影響はありませんが、東西のトラフィックが失われます(ブラックホール化されます)。


STP 拡張機能と Rapid PVST+ の詳細については、 Cisco Nexus 7000 Series NX-OS Layer 2 Switching Configuration Guide, Release 5.x 』を参照してください。

vPC および ARP または ND

Cisco Fabric Service over Ethernet(CFSoE)プロトコルの信頼性が高いトランスポート メカニズムを使用した、vPC ピア間のテーブル同期に対応する機能が Cisco NX-OS リリース 4.2(6) に追加されました。 ip arp synchronize および ipv6 nd synchronize コマンドをイネーブルにし、vPC ピア間のアドレス テーブルのコンバージェンスの高速化をサポートする必要があります。このコンバージェンスは、ピア リンク ポート チャネルがフラップしたり、vPC ピアがオンラインに戻るときに、IPv4 の場合は ARP テーブルの復元にまたは IPv6 の場合は ND テーブルの復元に関与する遅延を解消するように設計されています。

vPC マルチキャスト:PIM、IGMP、および IGMP スヌーピング


) Nexus 7000 シリーズ デバイスの Cisco NX-OS ソフトウェアは、PIM SSM も BIDR on vPC もサポートしていません。Cisco NX-OS ソフトウェアは、PIM ASM on vPC を完全にサポートします。


ソフトウェアが、マルチキャスト フォワーディングを両方の vPC ピア デバイス上で同期された状態に保ちます。vPC ピア デバイス上の IGMP スヌーピング プロセスは、学習したグループ情報を vPC リンクを通じて他の vPC ピア デバイスと共有します。マルチキャスト状態は、常に両方の vPC ピア デバイス上で同期されます。vPC モードでの PIM プロセスは、1 つの vPC ピア デバイスだけが受信者に向けてマルチキャスト トラフィックを転送する状態を確保します。

各 vPC ピアは、レイヤ 2 またはレイヤ 3 デバイスです。マルチキャスト トラフィックは 1 つの vPC ピア デバイスだけから伝送されます。次のシナリオで、重複したパケットが観察される場合があります。

孤立ホスト

送信元と受信者が、マルチキャスト ルーティングのイネーブルになった異なる VLAN 内のレイヤ 2 vPC クラウド内にあり、vPC メンバ リンクが停止している場合。

次のシナリオで、ごくわずかなトラフィック損失が観察される場合があります。

トラフィックを転送している vPC ピア デバイスをリロードした場合。

トラフィックを転送している vPC ピア デバイスの PIM を再起動した場合。

必ずすべてのレイヤ 3 デバイスを両方の vPC ピア デバイスにデュアル接続してください。片方の vPC ピア デバイスが停止した場合、他方の vPC ピア デバイスが、通常どおりにすべてのマルチキャスト トラフィックを転送し続けます。

vPC とマルチキャストに関する情報を表示するコマンドについては、『 Cisco Nexus 7000 Series NX-OS Interfaces Command Reference, Release 5.x 』を参照してください。

次に、vPC PIM および vPC IGMP/IGMP スヌーピングについて説明します。

vPC PIM:vPC モードの PIM プロセスは、vPC ピア デバイスの片方だけがマルチキャスト トラフィックを転送する状態を確保します。vPC モードの PIM プロセスは、送信元の状態を両方の vPC ピア デバイスと同期させ、トラフィックを転送する vPC ピア デバイスを選出します。

vPC IGMP/IGMP スヌーピング:vPC モードの IGMP プロセスは、両方の vPC ピア デバイスでの DR 情報を同期させます。vPC モードになっているときには、IGMP についてデュアル DR という概念があります。これは、vPC モードでないときは使用できないもので、両方の vPC ピア デバイスにピア間でマルチキャスト グループ情報を維持させます。

IGMP スヌーピングは、両方の vPC ピア デバイス上で同じようにイネーブルにしたりディセーブルにしたりする必要があり、すべての機能設定を同じにする必要があります。IGMP スヌーピングは、デフォルトで有効になっています。


) 次のコマンドは、vPC モードでサポートされていません。

ip pim spt-threshold infinity
ip pim use-shared-tree-only


 

マルチキャストの詳細については、 『Cisco Nexus 7000 Series NX-OS Multicast Routing Configuration Guide, Release 5.x を参照してください。

マルチキャスト PIM デュアル DR(プロキシ DR)

デフォルトでは、マルチキャスト ルータは該当する受信先が存在する場合のみ PIM ジョインをアップストリームに送信します。これらの該当する受信先は、IGMP ホスト(IGMP レポートを通じて通信します)または他のマルチキャスト ルータ(PIM ジョインを通じて通信します)のどちらかの場合があります。

Cisco NX-OS vPC 実装(非 F2 モード)では、PIM はデュアル指定ルータ(DR)モードで動作します。つまり、vPC デバイスが vPC SVI OIF 上の DR である場合、そのピアは自動的にプロキシ DR ロールを引き継ぎます。IGMP は、OIF が DR である場合、OIF(レポートはその OIF で学習されます)をフォワーディングに追加します。デュアル DR では、両方の vPC デバイスには、次の例に示すように、vPC SVI OIF に対して同一のエントリ (*,G) があります。

VPC Device1:
------------
(*,G)
oif1 (igmp)
 
VPC Device2:
------------
(*,G)
oif1 (igmp)

IP PIM PRE-BUILD SPT

マルチキャスト ソースがレイヤ 3 クラウド(vPC ドメイン外)にある場合、1 つの vPC ピアが送信元のフォワーダとして選定されます。このフォワーダの選択は、送信元に到達するためのメトリックに基づきます。関係がある場合、vPC プライマリはフォワーダとして選択されます。フォワーダのみがその関連する (S,G) 内に vPC OIF を持っており、非フォワーダ (S,G) は 0 OIF を持っています。したがって、フォワーダのみが次の例に示すように PIM (S,G) ジョインを送信元に送信します。

VPC Device1 (say this is Forwarder for Source 'S'):
------------
(*,G)
oif1 (igmp)
 
(S,G)
oif1 (mrib)
 
VPC Device2:
------------
(*,G)
oif1 (igmp)
 
(S,G)
NULL
 

障害が発生した場合(たとえば、フォワーダのレイヤ 3 RPF リンクが動作しない、またはフォワーダがリロードされるなど)、現在の非フォワーダが最終的にフォワーダになる場合は、トラフィック取得するために送信元への (S,G) に対する PIM ジョインの送信を開始をする必要があります。送信元に到達するホップ数によって、この操作には時間がかかる場合があります(PIM はホップバイホップ プロトコルです)。

この問題を排除し、より優れたコンバージェンスを取得するには、 ip pim pre-build-spt コマンドを使用します。このコマンドにより、マルチキャスト ルートに 0 OIF があっても PIM はジョインを送信できます。vPC デバイスでは、非フォワーダは送信元へ PIM (S,G) ジョインをアップストリームに送信します。欠点は非フォワーダからのリンク帯域幅アップストリームがそれにより最終的に廃棄されるトラフィックに使用されることですが、利点はより優れたコンバージェンスによる結果がリンク使用帯域幅の結果よりはるかに勝るという点です。したがって、すべての vPC カスタマーがこのコマンドを使用することを推奨します。

vPC ピア リンクとルーティング

ファーストホップ冗長プロトコル(FHRP)は、vPC と相互運用できます。ホット スタンバイ ルーティング プロトコル(HSRP)、ゲートウェイ ロード バランシング プロトコル(GLBP)、および仮想ルータ冗長プロトコル(VRRP)のすべてが、vPC と相互運用できます。すべてのレイヤ 3 デバイスを両方の vPC ピア デバイスにデュアル接続することを推奨します。

プライマリ FHRP デバイスは、たとえセカンダリ vPC デバイスがデータ トラフィックを転送したとしても、ARP 要求に応答します。

プライマリ vPC ピア デバイスを FHRP アクティブ ルータの最も高いプライオリティで設定しておくと、初期の設定確認と vPC/HSRP のトラブルシューティングを簡単にできます。

さらに、if-hsrp コンフィギュレーション モードで priority コマンドを使用して、vPC ピア リンク上でイネーブルになっているグループの状態がスタンバイになっているか、またはリッスン状態になっている場合のフェールオーバーのしきい値を設定できます。インターフェイスがアップまたはダウンするのを防ぐために下限および上限しきい値を設定できます。

VRRP は、vPC ピア デバイス上で実行されている場合に HSRP とよく似た動作を示します。VRRP は、HSRP を設定したのと同じ方法で設定してください。GLBP については、両方の vPC ピア デバイス上のフォワーダがトラフィックを転送します。

プライマリ vPC ピア デバイスに障害が発生した場合は、セカンダリ vPC ピア デバイスにフェールオーバーされ、FHRP トラフィックはシームレスに流れ続けます。

バックアップ ルーティング パスとして機能するように 2 台の vPC ピア デバイス間にルーティング隣接を設定することを推奨します。1 台の vPC ピア デバイスがレイヤ 3 アップリンクを失うと、その vPC はルーテッド トラフィックを他の vPC ピア デバイスにリダイレクトでき、そのアクティブ レイヤ 3 アップリンクを活用できます。

次の方法で、バックアップのルーティング パス用のスイッチ間リンクを設定できます。

2 台の vPC ピア デバイス間でレイヤ 3 リンクを作成します。

専用の VLAN インターフェイスを持つ非 VPC VLAN トランクを使用します。

専用の VLAN インターフェイスを持つ vPC ピア リンクを使用します。

vPC 環境での HSRP の焼き付け MAC アドレス オプション(use-bia)の設定、および任意の FHRP プロトコルのための仮想 MAC アドレスの手動での設定は、推奨できません。これらの設定は、vPC ロード バランシングに不利な影響を与えるためです。hsrp use-bia は、vPC ではサポートされていません。カスタム MAC アドレスを設定する際には、両方の vPC ピア デバイスに同じ MAC アドレスを設定する必要があります。

Cisco NX-OS リリース 4.2(1) 以降では、ピアの隣接が形成されて VLAN インターフェイスがバックアップされるまで vPC の再稼働を遅らせる復元タイマーを設定できるようになりました。この機能により、vPC が再びトラフィックの受け渡しをし始める前にルーティング テーブルが収束できなかった場合のパケットのドロップを回避できます。

この機能を設定するには、 delay restore コマンドを使用します。

復元した vPC ピア デバイス上の VLAN インターフェイスが稼働するのを遅延するには、 interfaces-vlan オプションを delay restore コマンドに使用します。

FHRP とルーティングの詳細については、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x 』を参照してください。

CFSoE

Cisco Fabric Services over Ethernet(CFSoE)は、vPC ピア デバイスのアクションを同期化するために使用される信頼性の高い状態転送メカニズムです。CFSoE は、vPC にリンクされている、STP、IGMP などの多くの機能のメッセージとパケットを伝送します。情報は、CFS/CFSoE プロトコル データ ユニット(PDU)に入れて伝送されます。

CFSoE は、vPC 機能をイネーブルにすると、デバイスによって自動的にイネーブルになります。何も設定する必要はありません。vPC の CFSoE 分散には、IP を介してまたは CFS リージョンに分散する機能は必要ありません。CFSoE 機能が vPC 上で正常に機能するために必要な設定は一切ありません。

CFSoE 転送は、各 VDC にローカルです。

show mac address-table コマンドを使用すれば、CFSoE が vPC ピア リンクのために同期する MAC アドレスを表示できます。


no cfs eth distribute コマンドと no cfs distribute コマンドは入力しないでください。CFSoE for vPC 機能のための CFSoE をイネーブルにしなければなりません。vPC をイネーブルにしてこれらのコマンドのいずれかを入力すると、エラー メッセージが表示されます。


show cfs application コマンドを入力すると、出力に「Physical-eth」と表示されます。これは、CFSoE を使用しているアプリケーションを表します。

Cisco Fabric Services は、TCP/IP を介したデータの転送も行います。CFS over IP の詳細については、『 Cisco Nexus 7000 Series NX-OS System Management Configuration Guide, Release 5.x 』を参照してください。


) CFS リージョンはサポートされていません。


vPC および孤立ポート

vPC 対応でないデバイスが各ピアに接続するとき、接続されたポートは vPC のメンバではないため、孤立ポートと称されます。一方のピアへのデバイスのリンクがアクティブ(フォワーディング)になり、他方のリンクは STP のためスタンバイ(ブロッキング)になります。

ピア リンク障害またはリストアが発生すると、孤立ポートの接続は vPC 障害または復元プロセスにバインドされる可能性があります。たとえば、デバイスのアクティブな孤立ポートがセカンダリ vPC ピアに接続する場合、ピア リンク障害が発生し、vPC ポートがセカンダリ ピアによって一時停止されると、そのデバイスはプライマリ ピアを経由する接続を失います。セカンダリ ピアがアクティブな孤立ポートも一時停止する場合は、デバイスのスタンバイ ポートがアクティブになり、プライマリ ピアへの接続が提供され接続が復元されます。Cisco NX-OS リリース 5.2(1) 以降では、セカンダリ ピアが vPC ポートを一時停止するときに特定の孤立ポートがそのピアによって一時停止され、vPC が復元されるとそのポートが復元されるように CLI で設定できます。

仮想化のサポート


) 1 つの VDC 内に配置した各 vPC ドメインについて、独立した vPC ピア リンクとピアキープアライブ リンクのインフラストラクチャをプロビジョニングしなければなりません。vPC ピア(ドメインが同じ 2 台の vPC ピア デバイス)を同じ物理デバイスの 2 つの VDC 内に統合することは、サポートされていません。


1 つの vPC 内のすべてのポートが、同じ VDC 内になくてはなりません。このバージョンのソフトウェアは、VDC ごとに 1 つの vPC ドメインしかサポートしません。各 VDC で 1 ~ 4096 の番号を使用して、vPC に番号を付けることができます。これらの vPC 番号は、別の VDC 内で再利用できます。


) VDC とリソースの割り当ての詳細については、『Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide, Release 5.x』を参照してください。


停電後の vPC リカバリ

データセンターの停電時には、vPC を構成する両方の Cisco Nexus 7000 シリーズ デバイスがリロードされます。まれに、ピアの片方だけが復元できることがあります。機能するピアキープアライブまたはピア リンクがないと、vPC は正常に機能することができません。しかし、Cisco NX-OS リリースによっては、vPC サービスが機能するピアのローカル ポートのみを使用するようにする方法が利用可能です。

リロードでの復元


) Cisco NX-OS リリース 5.2(1) 以降では、reload restore コマンドおよびメソッドが非推奨となっています。auto-recovery コマンドおよびメソッドを使用することを推奨します。


Cisco NX-OS リリース 5.0(2) 以降では、ピアがオンラインになれなかった場合に、 reload restore コマンドを使用して vPC サービスを復元するように Cisco Nexus 7000 シリーズ デバイスを設定できるようになりました。この設定は、スタートアップ コンフィギュレーションに保存しなければなりません。リロード時に、Cisco NX-OS ソフトウェアは、ユーザによる設定可能なタイマーを開始します(デフォルトは 240 秒)。ピア リンク ポートが物理的に稼働し始めるか、ピアキープアライブが機能し始めたら、タイマーは停止し、デバイスはピアの隣接が形成されるのを待ちます。

ピアキープアライブ パケットもピア リンク アップ パケットも受信できないままタイマーが切れると、Cisco NX-OS ソフトウェアは、プライマリ STP ロールとプライマリ LACP ロールを引き継ぎます。ソフトウェアが vPC を初期化し、そのローカル ポートを稼働させ始めます。ピアがないため、ローカル vPC ポートの一貫性チェックはバイパスされます。デバイスは、自身をそのロール プライオリティに関係なく STP プライマリに選出し、LACP ポート ロールのマスターとしても機能します。

自動リカバリ

Cisco NX-OS リリース 5.2(1) 以降では、ピアがオンラインになれなかった場合に、 auto-recovery コマンドを使用して vPC サービスを復元するように Cisco Nexus 7000 シリーズ デバイスを設定できるようになりました。この設定は、スタートアップ コンフィギュレーションに保存しなければなりません。リロード時に、ピア リンクがダウンし、 3 回連続してピアキープアライブ メッセージが失われた場合、セカンダリ デバイスはプライマリ STP ロールとプライマリ LACP ロールを引き継ぎます。ソフトウェアが vPC を初期化し、そのローカル ポートを稼働させ始めます。ピアがないため、ローカル vPC ポートの一貫性チェックはバイパスされます。デバイスは、自身をそのロール プライオリティに関係なく STP プライマリに選出し、LACP ポート ロールのマスターとしても機能します。

リカバリ後の vPC ピア ロール

ピア デバイスのリロードが完了し、隣接が形成されたら、次のプロセスが発生します。

1. 最初の vPC ピアがその現在のロールを維持して、その他のプロトコルへの任意の移行リセットを回避します。ピアが、他の可能なロールを受け入れます。

2. 隣接が形成されたら、整合性検査が実行され、適切なアクションが取られます。

High Availability(高可用性)

In-Service Software Upgrade(ISSU)では、最初の vPC デバイス上のソフトウェア リロード プロセスが、vPC 通信チャネルを介した CFS メッセージングを使用して、その vPC ピア デバイスをロックします。1 度に 1 つのデバイスだけアップグレードできます。最初のデバイスは、そのアップグレードが完了したら、そのピア デバイスのロックを解除します。次に、2 つ目のデバイスが、最初のデバイスが行ったのと同じように最初のデバイスをロックして、アップグレード プロセスを実行します。アップグレード中は、2 つの vPC デバイスが一時的に異なるリリースの Cisco NX-OS を実行することになりますが、その下位互換性により、システムは正常に機能します。


) ハイ アベイラビリティ機能の詳細については、 Cisco Nexus 7000 Series NX-OS High Availability and Redundancy Guide, Release 5.xを参照してください。


vPC のライセンス要件

次の表に、この機能のライセンス要件を示します。

 

製品
ライセンス要件

Cisco NX-OS

vPC には、ライセンスは必要ありません。ライセンス パッケージに含まれていない機能はすべて Cisco NX-OS システム イメージにバンドルされており、追加費用は一切発生しません。Cisco NX-OS のライセンス スキームの詳細については、『 Cisco NX-OS Licensing Guide 』を参照してください。

注意事項と制約事項

vPC には、次の注意事項と制約事項があります。

vPC ピアは、アップグレードまたはダウングレード プロセス中に、異なるバージョンの NX-OS ソフトウェアのみを稼働できます。

アップグレード/ダウングレードの期間外に異なるバージョンを実行している VPC ピアはサポートされません。

1 つの vPC のすべてのポートが、同じ VDC 内になくてはなりません。

vPC を設定するには、まず vPC をイネーブルにする必要があります。

システムが vPC ピア リンクを形成するには、その前にピアキープアライブ リンクとピアキープアライブ メッセージを設定する必要があります。

vPC に入れられるのは、レイヤ 2 ポート チャネルだけです。

両方の vPC ピア デバイスを設定しなければなりません。設定が片方のデバイスから他方へ送信されることはありません。

マルチレイヤ(バックツーバック)vPC を設定するには、それぞれの vPC に一意の vPC ドメイン ID を割り当てる必要があります。

必要な設定パラメータが、vPC ピア リンクの両側で互換性を保っているかチェックしてください。互換性に関する推奨事項について、「vPC インターフェイスの互換パラメータ」を参照してください。

vPC の設定中に、最小限のトラフィックの中断が発生する可能性があります。

vPC 上での BIDR PIM および SSM はサポートされていません。

vPC 環境での DHCP スヌーピング、DAI、IPSG はサポートされていません。DHCP リレーはサポートされています。

CFS リージョンはサポートされていません。

ポート チャネル上でのポート セキュリティは、サポートされていません。

vPC 内の LACP を使用するすべてのポート チャネルを、アクティブ モードのインターフェイスで設定することを推奨します。

この目的には VLAN ネットワーク インターフェイスを使用するよりも、vPC ピア デバイスからのルーティングのためのレイヤ 3 リンクを別途設定してください。

バックツーバックのマルチレイヤ vPC トポロジでは、それぞれの vPC に一意のドメイン ID が必要です。

vPC を使用する場合は、FHRP(HSRP、VRRP、GLBP)にデフォルトのタイマーを使用し、PIM 設定を行うことを推奨します。アグレッシブ タイマーを vPC 設定で使用すると、コンバージェンス時間のメリットがありません。

vPC 環境で OSPF を設定する場合は、コア スイッチ上でルータ コンフィギュレーション モードで次のタイマー コマンドを使用することにより、vPC ピア リンクがシャットダウンしたときに OSPF の高速コンバージェンスを実現します。

switch (config-router)# timers throttle spf 1 50 50
switch (config-router)# timers lsa-arrival 10
 

OSPF の詳細については、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x 』を参照してください。

HSRP の BFD は、vPC 環境ではサポートされていません。

STP ポート コストは、vPC 環境で 200 に固定されています。

同一の物理 Cisco Nexus 7000 デバイス上の 2 つの VDC 間の単一 vPC ドメインはサポートされません。

ジャンボ フレームは、vPC ピア リンクではデフォルトでイネーブルです。

デフォルト設定値

表 7-2 に、vPC パラメータのデフォルト設定を示します。

 

表 7-2 デフォルト vPC パラメータ

パラメータ(Parameters)
デフォルト

vPC システム プライオリティ

32667

vPC ピアキープアライブ メッセージ

ディセーブル

vPC ピアキープアライブ間隔

1 秒

vPC ピアキープアライブ タイムアウト

5 秒

vPC ピアキープアライブ UDP ポート

3200

vPC の設定


) この手順を vPC ピア リンクの両側にある両方のデバイスで使用しなければなりません。両方の vPC ピア デバイスをこの手順で設定します。


ここでは、コマンドライン インターフェイス(CLI)を使用して vPC を設定する方法を説明します。内容は次のとおりです。

「vPC のイネーブル化」

「vPC のディセーブル化」

「vPC ドメインの作成と vpc-domain モードの開始」

「vPC キープアライブ リンクと vPC キープアライブ メッセージの設定」

「vPC ピア リンクの作成」

「vPC ピアゲートウェイの設定」

「グレースフル整合性検査の設定」

「vPC ピア リンクの設定の互換性チェック」

「他のポート チャネルの vPC への移行」

「vPC ドメイン MAC アドレスの手動での設定」

「システム プライオリティの手動での設定」

「vPC ピア デバイス ロールの手動での設定」

「シングルモジュール vPC でのトラッキング機能の設定」

「停電後のリカバリの設定」

「孤立ポートの一時停止の設定」

「vPC ピア スイッチの設定」


) Cisco IOS の CLI に慣れている場合、この機能に対応する Cisco NX-OS コマンドは通常使用する Cisco IOS コマンドと異なる場合があるので注意してください。


vPC のイネーブル化

vPC を設定して使用するには、その前に vPC 機能をイネーブルにしなければなりません。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. feature vpc

3. exit

4. (任意)show feature

5. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

feature vpc

 

例:

switch(config)# feature vpc

デバイス上で vPC をイネーブルにします。

ステップ 3

exit

 

例:

switch(config)# exit

switch#

設定モードを終了します。

ステップ 4

show feature

 

例:

switch# show feature

(任意)デバイス上でイネーブルになっている機能を表示します。

ステップ 5

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次の例は、vPC 機能をイネーブルにする方法を示します。

switch# configure terminal
switch(config)# feature vpc
switch(config)#
 

vPC のディセーブル化


) vPC 機能をディセーブルにすると、デバイス上のすべての vPC 設定がクリアされます。


はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. no feature vpc

3. exit

4. (任意)show feature

5. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

no feature vpc

 

例:

switch(config)# no feature vpc

デバイスの vPC をディセーブルにします。

ステップ 3

exit

 

例:

switch(config)# exit

switch#

設定モードを終了します。

ステップ 4

show feature

 

例:

switch# show feature

(任意)デバイス上でイネーブルになっている機能を表示します。

ステップ 5

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次の例は、vPC 機能をディセーブルにする方法を示します。

switch# configure terminal
switch(config)# no feature vpc
switch(config)#
 

vPC ドメインの作成と vpc-domain モードの開始

vPC ドメインを作成し、両方の vPC ピア デバイス上で vPC ピア リンク ポート チャネルを同じ vPC ドメイン内に置くことができます。1 つの VDC 全体を通じて一意の vPC ドメイン番号を使用してください。このドメイン ID は、vPC システム MAC アドレスを自動的に形成するのに使用されます。

このコマンドを使用して、vpc-domain コマンド モードを開始することもできます。

はじめる前に

vPC 機能をイネーブルにしていることを確認します。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. vpc domain domain-id

3. exit

4. (任意) show vpc brief

5. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vpc domain domain-id

 

例:

switch(config)# vpc domain 5

switch(config-vpc-domain)#

デバイス上に vPC ドメインを作成し、設定目的で vpc-domain コンフィギュレーション モードを開始します。デフォルトはありません。指定できる範囲は 1 ~ 1,000 です。

ステップ 3

exit

 

例:

switch(config-vpc-domain)# exit

switch(config)#

vpc-domain コンフィギュレーション モードを終了します。

ステップ 4

show vpc brief

 

例:

switch# show vpc brief

(任意)各 vPC ドメインに関する簡単な情報を表示します。

ステップ 5

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、vPC ドメインを作成する例を示します。

switch# configure terminal
switch(config)# vpc domain 5
switch(config-vpc-domain)#
 

次に、vpc-domain コマンド モードを開始して、既存の vPC ドメインを設定する例を示します。

switch# configure terminal
switch(config)# vpc domain 5
switch(config-vpc-domain)#

vPC キープアライブ リンクと vPC キープアライブ メッセージの設定


) システムで vPC ピア リンクを形成できるようにするには、まず vPC ピアキープアライブ リンクを設定する必要があります。


キープアライブ メッセージを伝送するピアキープアライブ リンクの宛先 IP を設定できます。必要に応じて、キープアライブ メッセージのその他のパラメータも設定できます。


) 独立した仮想ルーティング/転送(VRF)インスタンスを設定し、各 vPC ピア デバイスからのレイヤ 3 ポートを vPC ピアキープアライブ リンクの VRF に入れることをお勧めします。ピア リンク自体を使用して vPC ピアキープアライブ メッセージを送信しないでください。VRF の作成と設定の詳細については、『Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x』を参照してください。
ピアキープアライブ メッセージに使用される送信元と宛先の両方の IP アドレスがネットワーク内で一意であることを確認してください。


管理ポートと管理 VRF が、これらのキープアライブ メッセージのデフォルトです。

はじめる前に

vPC 機能をイネーブルにしていることを確認します。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. vpc domain domain-id

3. peer-keepalive destination ip address [ hold-timeout secs | interval msecs { timeout secs} | { precedence {prec-value | network | internet | critical | flash - override | flash | immediate | priority | routine }} | { tos {tos-value | max-reliability | max-throughput | min-delay | min-monetary-cost | normal }} | tos-byte tos-byte-value} | source ipaddress | udp-port number | vrf {name | management | vpc-keepalive }]

4. exit

5. (任意)show vpc statistics

6. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vpc domain domain-id

 

例:

switch(config)# vpc domain 5

switch(config-vpc-domain)#

デバイス上に vPC ドメインを作成し、設定目的で vpc-domain コンフィギュレーション モードを開始します。

ステップ 3

peer-keepalive destination ipaddress [ hold-timeout secs | interval msecs { timeout secs} | { precedence { prec-value | network | internet | critical | flash-override | flash | immediate priority | routine}} | tos { tos-value | max-reliability | max-throughput | min-delay | min-monetary-cost | normal}} |tos-byte tos-byte-value} | source ipaddress | vrf {name | management vpc-keepalive }]

 

例:

switch(config-vpc-domain)# peer-keepalive destination 172.28.230.85

switch(config-vpc-domain)#

vPC ピアキープアライブ リンクのリモート エンドの IPv4 アドレスを設定します。

(注) vPC ピアキープアライブ リンクを設定するまでは、vPC ピア リンクは形成されません。

管理ポートと VRF がデフォルトです。

』を参照してください。

ステップ 4

exit

 

例:

switch(config-vpc-domain)# exit

switch(config)#

vpc-domain コンフィギュレーション モードを終了します。

ステップ 5

show vpc statistics

 

例:

switch# show vpc statistics

(任意)キープアライブ メッセージの設定に関する情報を表示します。

ステップ 6

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

VRF の設定方法の詳細については、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x 』を参照してください。

次の例は、vPC ピアキープアライブ リンクの宛先と送信元の IP アドレスおよび VRF を設定する方法を示します。

switch# configure terminal
switch(config)# feature vpc
switch(config)# vpc domain 100
switch(config-vpc-domain)# peer-keepalive destination 172.168.1.2 source 172.168.1.1 vrf vpc-keepalive

vPC ピア リンクの作成

vPC ピア リンクを作成するには、指定した vPC ドメインのピア リンクとするポート チャネルを各デバイス上で指定します。冗長性を確保するため、トランク モードで vPC ピア リンクとして指定したレイヤ 2 ポート チャネルを設定し、各 vPC ピア デバイス上の個別のモジュールで 2 つのポートを使用することを推奨します。

はじめる前に

vPC 機能をイネーブルにしていることを確認します。

レイヤ 2 ポート チャネルを使用していることを確認します。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. interface port-channel channel-number

3. (任意) switchport mode trunk

4. (任意) switchport trunk allowed vlan vlan-list

5. vpc peer-link

6. exit

7. (任意) show vpc brief

8. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface port-channel channel-number

 

例:

switch(config)# interface port-channel 20

switch(config-if)#

このデバイスの vPC ピア リンクとして使用するポート チャネルを選択し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switchport mode trunk

 

例:

switch(config-if)# switchport mode trunk

(任意)このインターフェイスのトランキング モードで設定します。

ステップ 4

switchport trunk allowed vlan vlan-list

 

例:

switch(config-if)# switchport trunk allowed vlan 1-120,201-3967

(任意)許容 VLAN リストを設定します。

ステップ 5

vpc peer-link

 

例:

switch(config-if)# vpc peer-link

switch(config-vpc-domain)#

選択したポート チャネルを vPC ピア リンクとして設定し、vpc-domain コンフィギュレーション モードを開始します。

ステップ 6

exit

 

例:

switch(config-vpc-domain)# exit

switch(config)#

vpc-domain コンフィギュレーション モードを終了します。

ステップ 7

show vpc brief

 

例:

switch# show vpc brief

(任意)各 vPC に関する情報を表示します。vPC ピア リンクに関する情報も表示されます。

ステップ 8

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次の例は、vPC ピア リンクを設定する方法を示します。

switch# configure terminal
switch(config)# interface port-channel 20
switch(config-if)# switchport mode
switch(config-if)# switchport mode trunk
switch(config-if)# switchport trunk allowed vlan 1-120,201-3967
switch(config-if)# vpc peer-link
switch(config-vpc-domain)#
 

vPC ピアゲートウェイの設定

Cisco NX-OS リリース 4.2(1) とそれ以降のリリースでは、vPC ピア デバイスを、vPC ピア デバイスの MAC アドレスを送信先とするパケットに対してもゲートウェイとして機能するように設定できるようになりました。


) vPC ドメインにレイヤ 3 デバイスを接続した場合、vPC ピアリンク上でも送信される VLAN を使用したルーティング プロトコルのピアリンクはサポートされません。vPC ピア デバイスおよび汎用レイヤ 3 デバイスの間でルーティング プロトコルの隣接関係が必要な場合は、相互接続に物理的にルーティングされたインターフェイスを使用する必要があります。vPC ピアゲートウェイ機能の使用では、この要件は変わりません。


はじめる前に

vPC 機能をイネーブルにしていることを確認します。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. vpc domain domain-id

3. peer-gateway

4. peer-gateway exclude-vlan backup-vlan-id

5. exit

6. (任意) show vpc brief

7. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vpc domain domain-id

 

例:

switch(config-if)# vpc domain 5

switch(config-vpc-domain)#

vPC ドメインがまだ存在しなかった場合はそれを作成し、vpc-domain コンフィギュレーション モードを開始します。

ステップ 3

peer-gateway

 

例:

switch(config-vpc-domain)# peer-gateway

(注)

------:: Disable IP redirects on all interface-vlans of this vPC domain for correct operation of this feature ::------

ピアのゲートウェイ MAC アドレスを宛先とするパケットのレイヤ 3 フォワーディングをイネーブルにします。

ステップ 4

peer-gateway exclude-vlan backup-vlan-id

 

例:

switch(config-vpc-domain)# peer-gateway exclude-vlan 2

(任意)Cisco NX-OS リリース 5.1(3) 以降では、混在シャーシ モードの中継 VLAN トラフィックのソフトウェア スイッチングを回避します。

(注) 詳細については、「vPC ピア ゲートウェイ」を参照してください。

ステップ 5

exit

 

例:

switch(config-vpc-domain)# exit

switch(config)#

vpc-domain コンフィギュレーション モードを終了します。

ステップ 6

show vpc brief

 

例:

switch# show vpc brief

(任意)各 vPC に関する情報を表示します。vPC ピア リンクに関する情報も表示されます。

ステップ 7

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

グレースフル整合性検査の設定

Cisco NX-OS リリース 5.2(1) 以降では、グレースフル整合性検査機能を設定できます。それはデフォルトでイネーブルになっています。この機能がイネーブルでない場合、必須互換性パラメータの不一致が動作中の vPC で導入されると、vPC は完全に一時停止します。この機能がイネーブルの場合、セカンダリ ピア デバイスのリンクだけが一時停止します。vPC 上での一貫した設定については、「vPC インターフェイスの互換パラメータ」を参照してください。

手順の概要

1. configure terminal

2. vpc domain domain-id

3. graceful consistency-check

4. exit

5. (任意) show vpc brief

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vpc domain domain-id

 

例:

switch(config-if)# vpc domain 5

switch(config-vpc-domain)#

vPC ドメインがまだ存在していない場合はそれを作成し、vpc-domain コンフィギュレーション モードを開始します。

ステップ 3

graceful consistency-check

 

例:

switch(config-vpc-domain)# graceful consistency-check

必須互換性パラメータで不一致が検出された場合に、セカンダリ ピア デバイスのリンクのみが一時停止するということを指定します。

この機能をディセーブルにする場合は、このコマンドの no 形式を使用します。

ステップ 4

exit

 

例:

switch(config-vpc-domain)# exit

switch(config)#

vpc-domain コンフィギュレーション モードを終了します。

ステップ 5

show vpc brief

 

例:

switch# show vpc brief

(任意)vPC に関する情報を表示します。

次に、グレースフル整合性検査機能をイネーブルにする例を示します。

switch# configure terminal
switch(config)# vpc domain 5
switch(config-vpc-domain)# graceful consistency-check

vPC ピア リンクの設定の互換性チェック

両方の vPC ピア デバイス上の vPC ピア リンクを設定した後に、すべての vPC インターフェイスで設定が一貫していることをチェックします。vPC 上での一貫した設定については、「vPC インターフェイスの互換パラメータ」を参照してください。

手順の概要

1. configure terminal

2. (Optional) show vpc consistency-parameters {global | interface port-channel channel-number}

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

show vpc consistency-parameters {global | interface port-channel channel-number}

 

例:

switch(config)# show vpc consistency-parameters global

switch(config)#

(任意)すべての vPC インターフェイス全体で一貫している必要があるパラメータのステータスを表示します。

次の例は、すべての vPC インターフェイスの間で必須設定の互換性が保たれているかチェックする方法を示します。

switch# configure terminal
switch(config)# show vpc consistency-parameters global
switch(config)#
 

) vPC インターフェイス設定の互換性に関するメッセージが syslog にも記録されます。


他のポート チャネルの vPC への移行


) 冗長性を確保するために、vPC ドメイン ダウンストリーム ポート チャネルを 2 つのデバイスに接続することを推奨します。


ダウンストリーム デバイスに接続するには、ダウンストリーム デバイスからプライマリ vPC ピア デバイスへのポート チャネルを作成し、ダウンストリーム デバイスからセカンダリ ピア デバイスへのもう 1 つのポート チャネルを作成します。最後に、各 vPC ピア デバイスで作業し、ダウンストリーム デバイスに接続するポート チャネルに vPC 番号を割り当てます。vPC の作成時にトラフィックが中断されることはほとんどありません。

はじめる前に

vPC 機能をイネーブルにしていることを確認します。

レイヤ 2 ポート チャネルを使用していることを確認します。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. interface port-channel channel-number

3. vpc number

4. exit

5. (任意) show vpc brief

6. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface port-channel channel-number

 

例:

switch(config)# interface port-channel 20

switch(config-if)#

ダウンストリーム デバイスに接続するために vPC に入れるポート チャネルを選択し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

vpc number

 

例:

switch(config-if)# vpc 5

switch(config-vpc-domain)#

選択したポート チャネルを vPC に入れてダウンストリーム デバイスに接続するように設定します。これらのポート チャネルには、デバイス内の任意のモジュールを使用できます。範囲は、1 ~ 4096 です。

ステップ 4

exit

 

例:

switch(config-vpc-domain)# exit

switch(config)#

vpc-domain コンフィギュレーション モードを終了します。

ステップ 5

show vpc brief

 

例:

switch# show vpc brief

(任意)vPC に関する情報を表示します。

ステップ 6

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次の例は、ダウンストリーム デバイスに接続されるポート チャネルを設定する方法を示します。

switch# configure terminal
switch(config)# interface port-channel 20
switch(config-if)# vpc 5
switch(config-if

vPC ドメイン MAC アドレスの手動での設定

vPC ドメインを作成すると、Cisco NX-OS ソフトウェアが自動的に vPC システム MAC アドレスを作成します。このアドレスは、LACP など、リンク スコープに制限される操作に使用されます。ただし、vPC ドメインの MAC アドレスを手動で設定すように選択することもできます。

はじめる前に

vPC 機能をイネーブルにしていることを確認します。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. vpc domain domain-id

3. system-mac mac-address

4. exit

5. (任意)show vpc role

6. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vpc domain domain-id

 

例:

switch(config)# vpc domain 5

switch(config-vpc-domain)#

設定する vPC ドメインの番号を入力します。vpc-domain コンフィギュレーション モードを開始します。

ステップ 3

system-mac mac-address

 

例:

switch(config-vpc-domain)# system-mac 23fb.4ab5.4c4e

switch(config-vpc-domain)#

指定した vPC ドメインに割り当てる MAC アドレスを aaaa.bbbb.cccc の形式で入力します。

ステップ 4

exit

 

例:

switch(config-vpc-domain)# exit

switch(config)#

vpc-domain コンフィギュレーション モードを終了します。

ステップ 5

show vpc role

 

例:

switch# show vpc brief

(任意)vPC システム MAC アドレスを表示します。

ステップ 6

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次の例は、vPC ドメイン MAC アドレスを手動で設定する方法を示します。

switch# configure terminal
switch(config)# vpc domain 5
switch(config-vpc-domain)# system-mac 13gb.4ab5.4c4e
 

システム プライオリティの手動での設定

vPC ドメインを作成すると、vPC システム プライオリティが自動的に作成されます。ただし、vPC ドメインのシステム プライオリティは手動で設定することもできます。


) LACP の実行時には、vPC ピア デバイスが LACP のプライマリ デバイスになるように、vPC システム プライオリティを手動で設定することを推奨します。システム プライオリティを手動で設定する場合には、必ず同じプライオリティ値を両方の vPC ピア デバイスに設定します。これらの値が一致しないと、vPC は起動しません。


はじめる前に

vPC 機能をイネーブルにしていることを確認します。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. vpc domain domain-id

3. system-priority priority

4. exit

5. (任意)show vpc role

6. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vpc domain domain-id

 

例:

switch(config)# vpc domain 5

switch(config-vpc-domain)#

設定する vPC ドメインの番号を入力します。vpc-domain コンフィギュレーション モードを開始します。

ステップ 3

system-priority priority

 

例:

switch(config-vpc-domain)# system-priority 4000

switch(config-vpc-domain)#

指定した vPC ドメインに割り当てるシステム プライオリティを入力します。指定できる値の範囲は、1 ~ 65535 です。デフォルト値は 32667 です。

ステップ 4

exit

 

例:

switch(config-vpc-domain)# exit

switch(config)#

vpc-domain コンフィギュレーション モードを終了します。

ステップ 5

show vpc role

 

例:

switch# show vpc role

(任意)vPC システム プライオリティを表示します。

ステップ 6

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次の例は、vPC ドメインのシステム プライオリティを手動で設定する方法を示します。

switch# configure terminal
switch(config)# vpc domain 5
switch(config-vpc-domain)# system-priority 4000

vPC ピア デバイス ロールの手動での設定

デフォルトでは、vPC ドメインと、vPC ピア リンクの両端を設定すると、Cisco NX-OS ソフトウェアはプライマリとセカンダリの vPC ピア デバイスを選択します。ただし、vPC のプライマリ デバイスとして、特定の vPC ピア デバイスを選択することもできます。選択したら、プライマリ デバイスにする vPC ピア デバイスに、他の vPC ピア デバイスより小さいロール値を手動で設定します。

vPC はロールのプリエンプションをサポートしていません。プライマリ vPC ピア デバイスに障害が発生すると、セカンダリ vPC ピア デバイスが、vPC プライマリ デバイスの機能を引き継ぎます。ただし、以前のプライマリ vPC が再起動しても、機能のロールは元に戻りません。

はじめる前に

vPC 機能をイネーブルにしていることを確認します。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. vpc domain domain-id

3. role priority priority

4. exit

5. (任意)show vpc role

6. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vpc domain domain-id

 

例:

switch(config)# vpc domain 5

switch(config-vpc-domain)#

設定する vPC ドメインの番号を入力します。vpc-domain コンフィギュレーション モードを開始します。

ステップ 3

role priority priority

 

例:

switch(config-vpc-domain)# role priority 4

switch(config-vpc-domain)#

vPC システム プライオリティに与えるロール プライオリティを入力します。指定できる値の範囲は 1 ~ 65636 で、デフォルト値は 32667 です。低い値は、このスイッチがプライマリ vPC になる可能性が高いということを意味します。

ステップ 4

exit

 

例:

switch(config-vpc-domain)# exit

switch(config)#

vpc-domain コンフィギュレーション モードを終了します。

ステップ 5

show vpc role

 

例:

switch# show vpc role

(任意)vPC システム プライオリティを表示します。

ステップ 6

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次の例は、vPC ピア デバイスのロール プライオリティを手動で設定する方法を示します。

switch# configure terminal
switch(config)# vpc domain 5
switch(config-vpc-domain)# role priority 4

シングルモジュール vPC でのトラッキング機能の設定

Cisco NX-OS Release 4.2 以降では、すべての vPC ピア リンクとコアに面するインターフェイスを単一モジュール上で設定しなければならない場合は、両方のプライマリ vPC ピア デバイス上の vPC ピア リンクのすべてのリンク上の、およびコアへのレイヤ 3 リンクに関連付けられているトラック オブジェクトとトラック リストを設定しなければなりません。いったんこの機能を設定したら、プライマリ vPC ピア デバイスに障害が発生した場合には、プライマリ vPC ピア デバイス上のすべての vPC リンクを、システムが自動的に停止します。システムが安定するまでは、このアクションにより、すべての vPC トラフィックが強制的にセカンダリ vPC ピア デバイスに送られます。

この設定は、両方の vPC ピア デバイスに置かなければなりません。さらに、いずれの vPC ピア デバイスも機能上のプライマリ vPC ピア デバイスになる場合があるため、両方の vPC ピア デバイスに同じ設定を置いておく必要があります。

はじめる前に

vPC 機能をイネーブルにしていることを確認します。

正しい仮想デバイス コンテキスト(VDC)を開始していることを確認します(または switchto vdc コマンドを使用します)。

トラック オブジェクトとトラック リストが設定済みであることを確認します。コアおよび vPC ピア リンクに接続されているすべてのインターフェイスが両方の vPC ピア デバイス上のトラックリンク オブジェクトに割り当てられていることを確認します。

手順の概要

1. configure terminal

2. vpc domain domain-id

3. track track-object-id

4. exit

5. (任意) show vpc

6. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vpc domain domain-id

 

例:

switch(config)# vpc domain 5

switch(config-vpc-domain)#

設定する vPC ドメインの番号を入力します。vpc-domain コンフィギュレーション モードを開始します。

ステップ 3

track track-object-id

 

例:

switch(config-vpc-domain)# track object 23

switch(config-vpc-domain)#

以前に関連するインターフェイスで設定されたトラックリスト オブジェクトを vPC ドメインに追加します。オブジェクト トラッキングとトラック リストの設定方法については、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x 』を参照してください。

ステップ 4

exit

 

例:

switch(config-vpc-domain)# exit

switch(config)#

vpc-domain コンフィギュレーション モードを終了します。

ステップ 5

show vpc brief

 

例:

switch# show vpc brief

(任意)トラッキング対象オブジェクトに関する情報を表示します。

ステップ 6

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、以前に設定されたトラック リスト オブジェクトを、vPC ピア デバイス上の vPC ドメインに配置する例を示します。

switch# configure terminal
switch(config)# vpc domain 5
switch(config-vpc-domain)# track object 5

停電後のリカバリの設定

停電が発生すると、vPC は、スイッチがリロードされてピアの隣接が形成されるのを待ちます。この状況は、許容範囲内に収まらないほど長いサービスの中断に至る場合があります。Cisco Nexus 7000 シリーズ デバイスは、そのピアがオンラインになるのに失敗した場合に vPC サービスを復元するように設定できます。

リロード復元の設定


) Cisco NX-OS リリース 5.2(1) 以降では、reload restore コマンドおよびこのセクションで説明されている手順が非推奨となっています。auto-recovery コマンドおよび 「自動リカバリの設定」 で説明されている手順を使用することを推奨します。


Cisco NX-OS リリース 5.0(2) 以降では、ピアがオンラインになれなかった場合に、 reload restore コマンドを使用して vPC サービスを復元するように Cisco Nexus 7000 シリーズ デバイスを設定できるようになりました。

はじめる前に

vPC 機能をイネーブルにしていることを確認します。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. vpc domain domain-id

3. reload restore [ delay time-out ]

4. exit

5. (任意)show running-config vpc

6. (任意)show vpc consistency-parameters interface port-channel number

7. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vpc domain domain-id

 

例:

switch(config)# vpc domain 5

switch(config-vpc-domain)#

設定する vPC ドメインの番号を入力します。vpc-domain コンフィギュレーション モードを開始します。

ステップ 3

reload restore [ delay time-out ]

 

例:

switch(config-vpc-domain)# reload restore

vPC がそのピアが機能しないことを前提として vPC を稼働させ始めるように設定します。デフォルト遅延値は 240 秒です。タイムアウト遅延は 240 ~ 3600 秒の間で設定できます。

vPC を標準動作にリセットするには、このコマンドの no 形式を使用します。

ステップ 4

exit

 

例:

switch(config-vpc-domain)# exit

switch(config)#

 

vpc-domain コンフィギュレーション モードを終了します。

ステップ 5

show running-config vpc

 

例:

switch# show running-config vpc

(任意)vPC に関する情報、特にリロード ステータスを表示します。

ステップ 6

show vpc consistency-parameters interface port-channel number

 

例:

switch# show vpc consistency-parameters interface port-channel 1

(任意)指定したインターフェイスの vPC の一貫性パラメータに関する情報を表示します。

ステップ 7

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

(注) リロード機能がイネーブルになっていることを確認するには、この手順を実行します。

次に、vPC リロード復元機能を設定し、それをスイッチのスタートアップ コンフィギュレーションに保存する例を示します。

switch# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
switch(config)# vpc domain 5
switch(config-vpc-domain)# reload restore
Warning:
 Enables restoring of vPCs in a peer-detached state after reload, will wait for 240
seconds (by default) to determine if peer is un-reachable
switch(config-vpc-domain)# exit
switch(config)# exit
switch# copy running-config startup-config
switch# show running-config vpc
 
!Command: show running-config vpc
!Time: Wed Mar 24 18:43:54 2010
 
version 5.0(2)
feature vpc
 
logging level vpc 6
vpc domain 5
  reload restore
 

次の例は、一貫性パラメータを確認する方法を示します。

switch# show vpc consistency-parameters interface port-channel 1
    Legend:
        Type 1 : vPC will be suspended in case of mismatch 
Name                        Type  Local Value   Peer Value
-------------               ----  -----------   ---------------
STP Port Type                 1    Default              -
STP Port Guard                1    None                 -
STP MST Simulate PVST         1    Default              -
mode                          1    on                   -
Speed                         1    1000 Mb/s            -
Duplex                        1    full                 -
Port Mode                     1    trunk                -
Native Vlan                   1    1                    -
MTU                           1    1500                 -
Allowed VLANs                 -    1-3967,4048-4093
Local suspended VLANs         -    -                    -

自動リカバリの設定

Cisco NX-OS リリース 5.2(1) 以降では、ピアがオンラインになれなかった場合に、 auto-recovery コマンドを使用して vPC サービスを復元するように Cisco Nexus 7000 シリーズ デバイスを設定できるようになりました。

はじめる前に

vPC 機能をイネーブルにしていることを確認します。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. vpc domain domain-id

3. auto-recovery [ reload-delay time ]

4. exit

5. (任意)show running-config vpc

6. (任意)show vpc consistency-parameters interface port-channel number

7. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vpc domain domain-id

 

例:

switch(config)# vpc domain 5

switch(config-vpc-domain)#

設定する vPC ドメインの番号を入力します。vpc-domain コンフィギュレーション モードを開始します。

ステップ 3

auto-recovery [ reload-delay time ]

 

例:

switch(config-vpc-domain)# auto-recovery

vPC がそのピアが機能しないことを前提として vPC を稼働させ始めるように設定し、vPC を復元するためのリロード後に待機する時間を指定します。デフォルト遅延値は 240 秒です。240 ~ 3600 秒の遅延を設定できます。

vPC を標準動作にリセットするには、このコマンドの no 形式を使用します。

ステップ 4

exit

 

例:

switch(config-vpc-domain)# exit

switch(config)#

 

vpc-domain コンフィギュレーション モードを終了します。

ステップ 5

show running-config vpc

 

例:

switch# show running-config vpc

(任意)vPC に関する情報、特にリロード ステータスを表示します。

ステップ 6

show vpc consistency-parameters interface port-channel number

 

例:

switch# show vpc consistency-parameters interface port-channel 1

(任意)指定したインターフェイスの vPC の一貫性パラメータに関する情報を表示します。

ステップ 7

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

(注) 自動リカバリ機能がイネーブルになっていることを確認するには、この手順を実行します。

次に、vPC 自動リカバリ機能を設定し、それをスイッチのスタートアップ コンフィギュレーションに保存する例を示します。

switch# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
switch(config)# vpc domain 5
switch(config-vpc-domain)# auto-recovery
Warning:
 Enables restoring of vPCs in a peer-detached state after reload, will wait for 240 seconds to determine if peer is un-reachable
switch(config-vpc-domain)# exit
switch(config)# exit
switch# copy running-config startup-config

孤立ポートの一時停止の設定

vPC 対応でないデバイスが各ピアに接続するとき、接続されたポートは vPC のメンバではないため、孤立ポートと称されます。Cisco NX-OS リリース 5.2(1) 以降では、ピア リンクまたはピア キープアライブ障害に応えてセカンダリ ピアが vPC ポートを一時停止するときに、セカンダリ ピアによって一時停止(シャットダウン)される孤立ポートとして物理インターフェイスを明示的に宣言できます。孤立ポートは vPC が復元されたときに復元されます。


) vPC 孤立ポートの一時停止は、ポート チャネルのメンバ ポートではなく、物理ポートでのみ設定できます。


はじめる前に

vPC 機能をイネーブルにしていることを確認します。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. show vpc orphan-ports

3. interface type slot/port

4. vpc orphan-ports suspend

5. exit

6. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

show vpc orphan-ports

 

例:

switch# show vpc orphan-ports

(任意)孤立ポートのリストを表示します。

ステップ 3

interface type slot/port

 

例:

switch(config)# interface ethernet 3/1

switch(config-if)#

設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

vpc orphan-ports suspend

 

例:

switch(config-if)# vpc orphan-ports suspend

選択したインターフェイスを vPC 障害時にセカンダリ ピアにより一時停止される vPC 孤立ポートとして設定します。

ステップ 5

exit

 

例:

switch(config-if)# exit

switch(config)#

インターフェイス コンフィギュレーション モードを終了します。

ステップ 6

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、インターフェイスを vPC 障害時にセカンダリ ピアにより一時停止される vPC 孤立ポートとして設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 3/1
switch(config-if)# vpc orphan-ports suspend

vPC ピア スイッチの設定

Cisco Nexus 7000 シリーズ デバイスは、一対の vPC デバイスがレイヤ 2 トポロジ内で 1 つの STP ルートとして現れるように設定することができます。この項では、次のトピックについて取り上げます。

「純粋な vPC ピア スイッチ トポロジの設定」

「ハイブリッド vPC ピア スイッチ トポロジの設定」

純粋な vPC ピア スイッチ トポロジの設定

純粋な vPC ピア スイッチ トポロジを設定するには、 peer-switch コマンドを使用し、次に可能な範囲内で最高の(最も小さい)スパニングツリー ブリッジ プライオリティ値を設定します。

はじめる前に

vPC 機能をイネーブルにしていることを確認します。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. vpc domain domain-id

3. peer-switch

4. spanning-tree vlan vlan-range priority value

5. exit

6. (任意)show spanning-tree summary

7. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vpc domain domain-id

 

例:

switch(config)# vpc domain 5

switch(config-vpc-domain)#

設定する vPC ドメインの番号を入力します。vpc-domain コンフィギュレーション モードを開始します。

ステップ 3

peer-switch

 

例:

switch(config-vpc-domain)# peer-switch

vPC スイッチ ペアがレイヤ 2 トポロジ内で 1 つの STP ルートとして現れるようにします。

ピア スイッチ vPC トポロジをディセーブルにするには、このコマンドの no 形式を使用します。

ステップ 4

spanning-tree vlan vlan-range priority value

 

例:

switch(config)# spanning-tree vlan 1 priority 8192

VLAN のブリッジ プライオリティを設定します。有効な値は、4096 の倍数です。デフォルト値は 32768 です。

ステップ 5

exit

 

例:

switch(config-vpc-domain)# exit

switch(config)#

vpc-domain コンフィギュレーション モードを終了します。

ステップ 6

show spanning-tree summary

 

例:

switch# show spanning-tree summary

(任意)スパニングツリー ポートの状態の概要を表示します。これに、vPC ピア スイッチも含まれます。

ステップ 7

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次の例は、純粋な vPC ピア スイッチ トポロジを設定する方法を示します。

switch# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
switch(config)# vpc domain 5

switch(config-vpc-domain)# peer-switch

2010 Apr 28 14:44:44 switch %STP-2-VPC_PEERSWITCH_CONFIG_ENABLED: vPC peer-switch configuration is enabled.Please make sure to configure spanning tree "bridge" priority as per recommended guidelines to make vPC peer-switch operational.

switch(config-vpc-domain)# exit

switch(config)# spanning-tree vlan 1 priority 8192

 

ハイブリッド vPC ピア スイッチ トポロジの設定

spanning-tree pseudo-information コマンド(『 Cisco Nexus 7000 Series NX-OS Layer 2 Switching Command Reference, Release 5.x 』を参照してください)を使用して STP VLAN ベースのロード バランシング条件を満たすように代表ブリッジ ID を変更した後、ルート ブリッジ ID を最高のブリッジ プライオリティよりもよい値に変更することにより、ハイブリッド vPC または非 vPC ピア スイッチ トポロジを設定することができます。次に、ピア スイッチをイネーブルにします。

はじめる前に

vPC 機能をイネーブルにしていることを確認します。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. spanning-tree pseudo-information

3. vlan vlan-range designated priority value

4. vlan vlan-range root priority value

5. vpc domain domain-id

6. peer-switch

7. exit

8. (任意)show spanning-tree summary

9. (任意)opy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

spanning-tree pseudo-information

 

例:

switch(config)# spanning-tree pseudo-information

switch(config-pseudo)#

スパニングツリー疑似情報を設定します。

ステップ 3

vlan vlan-id designated priority priority

 

例:

switch(config-pseudo)# vlan 1 designated priority 8192

VLAN の指定ブリッジ プライオリティを設定します。有効な値は、0 ~ 61440 の範囲内の 4096 の倍数です。

ステップ 4

vlan vlan-id root priority priority

 

例:

switch(config-pseudo)# vlan 1 root priority 4096

VLAN のルート ブリッジ プライオリティを設定します。有効な値は、0 ~ 61440 の範囲内の 4096 の倍数です。

ステップ 5

vpc domain domain-id

 

例:

switch(config)# vpc domain 5

switch(config-vpc-domain)#

設定する vPC ドメインの番号を入力します。vpc-domain コンフィギュレーション モードを開始します。

ステップ 6

peer-switch

 

例:

switch(config-vpc-domain)# peer-switch

vPC スイッチ ペアがレイヤ 2 トポロジ内で 1 つの STP ルートとして現れるようにします。

ピア スイッチ vPC トポロジをディセーブルにするには、このコマンドの no 形式を使用します。

ステップ 7

exit

 

例:

switch(config-vpc-domain)# exit

switch(config)#

vpc-domain コンフィギュレーション モードを終了します。

ステップ 8

show spanning-tree summary

 

例:

switch# show spanning-tree summary

(任意)スパニングツリー ポートの状態の概要を表示します。これに、vPC ピア スイッチも含まれます。

ステップ 9

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次の例は、ハイブリッド vPC ピア スイッチ トポロジを設定する方法を示します。

switch# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.

switch(config)# spanning-tree pseudo-information

switch(config-pseudo)# vlan 1 designated priority 8192

switch(config-pseudo)# vlan 1 root priority 4096

switch(config-pseudo)# exit

switch(config)# vpc domain 5

switch(config-vpc-domain)# peer-switch

vPC 設定の確認

vPC 設定情報を表示するには、次の作業のいずれかを行います。

 

コマンド
目的

show feature

vPC がイネーブルになっているかどうかを表示します。

show vpc brief

vPC に関する簡単な情報を表示します。

show vpc consistency-parameters

すべての vPC インターフェイス全体で一貫している必要があるパラメータのステータスを表示します。

show running-config vpc

vPC の実行コンフィギュレーションの情報を表示します。

show port-channel capacity

設定されているポート チャネルの数、およびデバイス上でまだ使用可能なポート チャネル数を表示します。

show vpc statistics

vPC に関する統計情報を表示します。

show vpc peer-keepalive

ピアキープアライブ メッセージの情報を表示します。

show vpc role

ピア ステータス、ローカル デバイスのロール、vPC システム MAC アドレスとシステム プライオリティ、およびローカル vPC デバイスの MAC アドレスとプライオリティを表示します。

これらのコマンド出力のフィールドの詳細については、『 Cisco Nexus 7000 Series NX-OS Interfaces Command Reference, Release 5.x 』を参照してください。

vPC のモニタリング

vPC 統計情報を表示するには、 show vpc statistics コマンドを使用します。


) このコマンドは、現在作業している vPC ピア デバイスの vPC 統計情報しか表示しません。


vPC の設定例

次の例は、デバイス A 上で図 7-11 に示すとおりに vPC を設定する方法を示します。

図 7-11 vPC の設定例

 


ステップ 1 vPC および LACP をイネーブルにします。

switch# configure terminal
switch(config)# feature vPC
switch(config)# feature lacp
 

ステップ 2 (任意)ピア リンクにするインターフェイスの 1 つを専用モードに設定します。

switch(config)# interface ethernet 7/1, ethernet 7/3, ethernet 7/5.ethernet 7/7
switch(config-if)# shutdown
switch(config-if)# exit
switch(config)# interface ethernet 7/1
switch(config-if)# rate-mode dedicated
switch(config-if)# no shutdown
switch(config-if)# exit
switch(config)#
 

ステップ 3 (任意)ピア リンクにする 2 つ目の冗長インターフェイスを専用モードに設定します。

switch(config)# interface ethernet 7/2, ethernet 7/4, ethernet 7/6.ethernet 7/8
switch(config-if)# shutdown
switch(config-if)# exit
switch(config)# interface ethernet 7/2
switch(config-if)# rate-mode dedicated
switch(config-if)# no shutdown
switch(config-if)# exit
switch(config)#
 

ステップ 4 ピア リンクに入れる 2 つのインターフェイス(冗長性のために)をアクティブ レイヤ 2 LACP ポート チャネルに設定します。

switch(config)# interface ethernet 7/1-2
switch(config-if)# switchport
switch(config-if)# switchport mode trunk
switch(config-if)# switchport trunk allowed vlan 1-50
switch(config-if)# switchport trunk native vlan 20
switch(config-if)# channel-group 20 mode active
switch(config-if)# exit

 

ステップ 5 VLAN を作成し、イネーブルにします。

switch(config)# vlan 1-50
switch(config-vlan)# no shutdown
switch(config-vlan)# exit

 

ステップ 6 vPC ピアキープアライブ リンク用の独立した VEF を作成し、レイヤ 3 インターフェイスをその VRF に追加します。

switch(config)# vrf context pkal
switch(config-vrf)# exit
switch(config)# interface ethernet 8/1
switch(config-if)# vrf member pkal
switch(config-if)# ip address 172.23.145.218/24
switch(config-if)# no shutdown
switch(config-if)# exit

 

ステップ 7 vPC ドメインを作成し、vPC ピアキープアライブ リンクを追加します。

switch(config)# vpc domain 1
switch(config-vpc-domain)# peer-keepalive destination 172.23.145.217 source 172.23.145.218 vrf pkal
switch(config-vpc-domain)# exit

 

ステップ 8 vPC ピア リンクを設定します。

switch(config)# interface port-channel 20
switch(config-if)# switchport mode trunk
switch(config-if)# switchport trunk allowed vlan 1-50
switch(config-if)# vpc peer-link
switch(config-if)# exit
switch(config)#

 

ステップ 9 vPC のダウンストリーム デバイスへのポート チャネルのインターフェイスを設定します。

switch(config)# interface ethernet 7/9
switch(config-if)# switchport mode trunk
switch(config-if)# allowed vlan 1-50
switch(config-if)# native vlan 20
switch(config-if)# channel-group 50 mode active
switch(config-if)# exit
switch(config)# interface port-channel 50
switch(config-if)# vpc 50
switch(config-if)# exit
switch(config)#
 

ステップ 10 設定を保存します。

switch(config)# copy running-config startup-config


 


) まずポート チャネルを設定する場合は、それがレイヤ 2 ポート チャネルであることを確認してください。


その他の参考資料

vPC を実装する方法の詳細については、次の項目を参照してください。

「関連資料」

「標準」

「管理情報ベース(MIB)」

関連資料

関連項目
マニュアル タイトル

ポート チャネルの設定

「ポート チャネルの設定」

レイヤ 2 インターフェイスの設定

「レイヤ 2 インターフェイスの設定」

レイヤ 3 インターフェイスの設定

「レイヤ 3 インターフェイスの設定」

共有および専用ポート

「基本インターフェイス パラメータの設定」

コマンド リファレンス

『Cisco Nexus 7000 Series NX-OS Interfaces Command Reference, Release 5.x

インターフェイス

『Cisco DCNM Interfaces Configuration Guide, Release 5.x

システム管理

『Cisco Nexus 7000 Series NX-OS System Management Configuration Guide, Release 5.x

ハイ アベイラビリティ

Cisco Nexus 7000 Series NX-OS High Availability and Redundancy Guide, Release 5.x

VDC

『Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide, Release 5.x

リリース ノート

『Cisco Nexus 7000 Series NX-OS Release Notes, Release 5.x

標準

標準
タイトル

IEEE 802.3ad

--

管理情報ベース(MIB)

MIB
MIB のリンク

IEEE8023-LAG-CAPABILITY

CISCO-LAG-MIB

MIB を検索およびダウンロードするには、次の URL にアクセスしてください。

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

vPC の設定機能の履歴

表 7-3 に、この機能のリリース履歴を示します。

 

表 7-3 vPC の設定機能の履歴

機能名
リリース
機能情報

vPC

5.2(1)

矛盾した設定がピア間で検出されたときに、vPC プライマリ デバイスがトラフィックを転送することを可能にする graceful consistency-check コマンドが追加されました。

vPC

5.2(1)

矛盾した設定の VLAN だけが一時停止されるように VLAN 単位整合性検査が追加されました。

vPC

5.2(1)

停電後に vPC リカバリのスピードと信頼性を高めるための auto-recovery コマンドが追加されました。 reload restore コマンドが非推奨になりました。

vPC

5.2(1)

vPC で障害が発生したときに vPC セカンダリ デバイスの孤立ポートを一時停止するための vpc orphan-ports suspend コマンドが追加されました。

vPC

5.2(1)

サポートが 528 vPC にまで増えました。

vPC

5.0(2)

vPC スイッチがそのピアが機能しないことを前提として vPC を稼働させ始めるように設定する reload restore コマンドが追加されました。

vPC

5.0(2)

一対の vPC スイッチがレイヤ 2 トポロジ内で 1 つの STP ルートとして現れることを可能にする peer-switch コマンドが追加されました。

vPC

4.2(1)

サポートが 256 vPC にまで増えました。

vPC

4.2(1)

確実にすべてのパケットがデバイスのゲートウェイ MAC アドレスを使用するようにするために、 peer-gateway コマンドが追加されました。

vPC

4.2(1)

vPC ピア リンクに障害が発生しても、確実に VLAN インターフェイスが稼働したままになるようにするために、 dual-active exclude interface-vlan コマンドが追加されました。

vPC

4.2(1)

リロード後にルーティング テーブルが収束できるまで vPC セカンダリ デバイスの稼働を遅延させるための delay restore コマンドが追加されました。

vPC

4.1(4)

サポートが 192 vPC にまで増えました。

vPC

4.1(2)

これらの機能が導入されました。