Cisco Nexus 7000 シリーズ NX-OS インターフェイス コンフィギュレーション ガイド、リリース 5.x
IP トンネルの設定
IP トンネルの設定
発行日;2015/03/05 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

IP トンネルの設定

IP トンネルの設定

この章では、Cisco NX-OS デバイス上でGeneric Routing Encapsulation(GRE)を使用して IP トンネルを設定する方法について説明します。

この章は、次の項で構成されています。

「IP トンネルについて」

「IP トンネルのライセンス要件」

「IP トンネルの前提条件」

「注意事項および制約事項」

「デフォルト設定」

「IP トンネルの設定」

「IP トンネル設定の確認」

「IP トンネリングの設定例」

「その他の関連資料」

「IP トンネル設定の機能履歴」

IP トンネルについて

IP トンネルを使うと、同じレイヤまたは上位層プロトコルをカプセル化して、2 台のデバイス間で作成されたトンネルを通じて IP に結果を転送できます。

この項では、次のトピックについて取り上げます。

「IP トンネルの概要」

「GRE トンネル」

「パス MTU ディスカバリ」

「仮想化のサポート」

「High Availability(高可用性)」

IP トンネルの概要

IP トンネルは次の 3 つの主要コンポーネントで構成されています。

パッセンジャ プロトコル:カプセル化する必要があるプロトコル。パッセンジャ プロトコルの例には IPv4 があります。

キャリア プロトコル:パッセンジャ プロトコルをカプセル化するために使用するプロトコル。Cisco NX-OS はキャリア プロトコルとして GRE をサポートします。

トランスポート プロトコル:カプセル化したプロトコルを伝送するために使用するプロトコル。トランスポート プロトコルの例には IPv4 があります。

IP トンネルは IPv4 などのパッセンジャ プロトコルを使用し、このプロトコルを GRE などのキャリア プロトコル内にカプセル化します。次に、このキャリア プロトコルは IPv4 などのトランスポート プロトコルを通じてデバイスから送信されます。

対応する特性を持つトンネル インターフェイスをトンネルの両端にそれぞれ設定します。

詳細については、「IP トンネルの設定」を参照してください。

設定の前にトンネル機能をイネーブルにする必要があります。Cisco NX-OS リリース 4.2 から、システムは機能のディセーブル化の前に自動的にチェックポイントを作成するため、このチェックポイントにロールバックできます。ロールバックとチェックポイントについては、『 Cisco Nexus 7000 Series NX-OS System Management Configuration Guide, Release 5.x 』を参照してください。

Cisco NX-OS Release 4.2 以降では、ある VDC に設定されたトンネルは、同じ番号を持つ別の VDC に設定されたトンネルとは区別されます。たとえば、VDC 1 のトンネル 0 は VDC 2 のトンネル 0 とは異なります。

Cisco NX-OS Release 4.2 以降では、トンネル送信元 IP アドレスおよび宛先 IP アドレスは、同一の VRF にある必要があります。

GRE トンネル


) Cisco NX-OS リリース 5.1(1) 以降では、ソフトウェアは GRE トンネルを通じてマルチキャスティングをサポートします。


Generic Routing Encapsulation(GRE)をさまざまなパッセンジャ プロトコルのキャリア プロトコルとして使用できます。

図 8-1 に、GRE トンネルの IP トンネル コンポーネントを示します。オリジナルのパッセンジャ プロトコル パケットは GRE ペイロードとなり、デバイスはパケットに GRE ヘッダーを追加します。次にデバイスはトランスポート プロトコル ヘッダーをパケットに追加して送信します。

図 8-1 GRE Protocol Data Unit(PDU)

 

パス MTU ディスカバリ

パス最大伝送単位(MTU)ディスカバリ(PMTUD)は、パケットの発信元から宛先へのパスに沿って最小 MTU を動的に決定することで、2 つのエンドポイント間のパスのフラグメンテーションを防ぎます。PMTUD は、パケットにフラグメンテーションが必要であるという情報がインターフェイスに届くと、接続に対する送信 MTU 値を減らします。

PMTUD をイネーブルにすると、インターフェイスはトンネルを通過するすべてのパケットに Don't Fragment(DF)ビットを設定します。トンネルに入ったパケットがそのパケットの MTU 値よりも小さい MTU 値を持つリンクを検出すると、リモート リンクはそのパケットをドロップし、パケットの送信元にインターネット制御メッセージ プロトコル(ICMP)メッセージを返します。このメッセージには、フラグメンテーションが要求されたこと(しかし許可されなかったこと)と、パケットをドロップしたリンクの MTU が含まれています。


) トンネル インターフェイスの PMTUD は、トンネル エンドポイントがトンネルのパスでデバイスによって生成される ICMP メッセージを受信することを要求します。ファイアウォール接続を通じて PMTUD を使用する前に、ICMP メッセージが受信できることを確認してください。


仮想化のサポート

IP トンネルはデフォルトの仮想デバイス コンテキスト(VDC)およびデフォルトの仮想ルーティング/転送(VRF)インスタンスにだけ設定できます。

Cisco NX-OS Release 4.2 以降では、トンネル インターフェイスを仮想ルーティングと転送(VRF)インスタンスのメンバーおよび任意の VDC のメンバーとして設定できます。特に別の VDC や VRF を設定しない限り、デフォルトでは、Cisco NX-OS のデフォルトの VDC およびデフォルトの VRF が使用されます。ある VDC に設定されたトンネルは、同じ番号を持つ別の VDC に設定されたトンネルとは区別されます。たとえば、VDC 1 のトンネル 0 は VDC 2 のトンネル 0 とは異なります。

トンネル送信元 IP アドレスおよび宛先 IP アドレスは、同一の VRF にある必要があります。また、トンネルの宛先を検索するために使用する VRF を設定できます。この VRF は、トンネル送信元 IP アドレスの VRF に一致させる必要があります。

VDC の詳細については『 Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide, Release 5.x 』を、VRF の詳細については『 Cisco DCNM Virtual Device Context Configuration Guide, Release 5.x 』を参照してください。

High Availability(高可用性)

IP トンネルはステートフル再起動をサポートします。ステートフル再起動はスーパーバイザ切り替え時に発生します。切り替え後、Cisco NX-OS は実行時の設定を適用します。

IP トンネルのライセンス要件

次の表に、この機能のライセンス要件を示します。

 

製品
ライセンス要件

Cisco NX-OS

IP トンネルには Enterprise Services ライセンスが必要です。Cisco NX-OS ライセンス方式について、およびライセンスの取得方法と適用方法の詳細については、 Cisco NX-OS Licensing Guide を参照してください。

IP トンネルの前提条件

IP トンネルには次の前提条件があります。

IP トンネルを設定するための TCP/IP に関する基礎知識があること。

スイッチにログインしている。

Cisco NX-OS の Enterprise Services ライセンスをインストールしていること。

IP トンネルを設定してイネーブルにする前にデバイスのトンネリング機能をイネーブルにしておくこと。

注意事項および制約事項

IP トンネルの設定に関する注意事項と制約事項は次のとおりです。

Cisco NX-OS は、IETF RFC 2784 に定義されている GRE ヘッダーをサポートします。Cisco NX-OS は、トンネル キーと IETF RFC 1701 のその他のオプションをサポートしません。

Cisco NX-OS Release 5.2(5) および 5.2(x) リリース以降、異なる仮想ルーティングと転送インスタンス(VRF)でトンネル インターフェイスおよびトンネル転送を設定できます。トンネルは、Cisco Nexus 7000 シリーズ プラットフォームの M1 シリーズのカードでのみサポートされます。

Cisco NX-OS は、トンネル インターフェイスの WCCP をサポートしません。

Cisco NX-OS は、GRE トンネル キープアライブをサポートしません。

デフォルト設定

表 8-1 に、IP トンネル パラメータのデフォルト設定を示します。

 

表 8-1 デフォルトの IP トンネル パラメータ

パラメータ(Parameters)
デフォルト

Path MTU Discovery 経過時間タイマー

10 分

パス MTU ディスカバリの最小 MTU

64

トンネル機能

ディセーブル

IP トンネルの設定

この項では、次のトピックについて取り上げます。

「トンネリングのイネーブル化」

「トンネル インターフェイスの作成」

「GRE トンネルの設定」

「Path MTU Discovery のイネーブル化」

「トンネル インターフェイスへの VRF メンバーシップの割り当て」


) Cisco IOS の CLI に慣れている場合、この機能に対応する Cisco NX-OS コマンドは通常使用する Cisco IOS コマンドと異なる場合があるので注意してください。


トンネリングのイネーブル化

IP トンネルを設定する前にトンネリング機能をイネーブルにする必要があります。

手順の概要

1. configure terminal

2. feature tunnel

3. exit

4. show feature

5. copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

feature tunnel

 

例:

switch(config)# feature tunnel

switch(config-if)#

新しいトンネル インターフェイスを作成できます。

トンネル インターフェイス機能をディセーブルにするには、このコマンドの no 形式を使用します。

ステップ 3

exit

 

例:

switch(config-if)# exit

switch(config)#

インターフェイス モードを終了し、コンフィギュレーション モードに戻ります。

ステップ 4

show feature

 

switch(config-if)# show feature

(任意)デバイス上でイネーブルされている機能に関する情報を表示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

トンネル インターフェイスの作成

トンネル インターフェイスを作成して、この論理インターフェイスを IP トンネルに設定できます。

はじめる前に

Cisco NX-OS Release 5.2(5) および 5.2(x) リリース以降、異なる VRF でトンネルの送信元とトンネルの宛先を設定できます。トンネリング機能がイネーブルになっていることを確認します。

手順の概要

1. configure terminal

2. interface tunnel number

3. tunnel source { ip-address | interface-name }

4. tunnel destination { ip-address | host-name }

5. tunnel use-vrf vrf-name

6. show interfaces tunnel number

7. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

interface tunnel number

 

例:

switch(config)# interface tunnel 1

switch(config-if)#

新しいトンネル インターフェイスを作成します。

ステップ 3

tunnel source { ip-address | interface-name }

 

例:

switch(config-if)# tunnel source ethernet 1/2

この IP トンネルの送信元アドレスを設定します。

ステップ 4

tunnel destination { ip-address | host-name }

 

例:

switch(config-if)# tunnel destination 192.0.2.1

この IP トンネルの宛先アドレスを設定します。

ステップ 5

tunnel use-vrf vrf-name

 

例:

switch(config-if)# tunnel use-vrf blue

(任意)設定された VRF をトンネルの IP 宛先アドレスの検索に使用します。

ステップ 6

show interfaces tunnel number

 

switch(config-if)# show interfaces tunnel 1

(任意)トンネル インターフェイス統計情報を表示します。

ステップ 7

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

トンネル インターフェイスおよび関連するすべての設定を削除するには、 no interface tunnel コマンドを使用します。

 

コマンド
目的

no interface tunnel number

 

例:

switch(config)# no interface tunnel 1

トンネル インターフェイスおよび関連する設定を削除します。

次のオプション パラメータを設定して、インターフェイス コンフィギュレーション モードでトンネルを調整することができます。

 

コマンド
目的

description string

 

例:

 

switch(config-if)# description GRE tunnel

トンネルの説明を設定します。

mtu value

 

例:

 

switch(config-if)# mtu 1400

インターフェイスで送信される IP パケットの MTU を設定します。

tunnel ttl value

 

例:

 

switch(config-if)# tunnel ttl 100

トンネルの存続可能時間を設定します。指定できる範囲は 1 ~ 255 です。

次に、トンネル インターフェイスを作成する例を示します。

switch# configure terminal

switch(config)# i nterface tunnel 1

switch(config-if)# tunnel source ethernet 1/2

switch(config-if)# tunnel destination 192.0.2.1

switch(config-if)# copy running-config startup-config

GRE トンネルの設定

トンネル インターフェイスを GRE トンネル モードに設定できます。

はじめる前に

トンネリング機能がイネーブルになっていることを確認します。

手順の概要

1. configure terminal

2. interface tunnel number

3. tunnel mode gre ip

4. show interfaces tunnel number

5. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

interface tunnel number

 

例:

switch(config)# interface tunnel 1

switch(config-if)#

トンネル インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

tunnel mode gre ip

 

例:

switch(config-if)# tunnel mode gre ip

このトンネル モードを GRE に設定します。

ステップ 4

show interfaces tunnel number

 

switch(config-if)# show interfaces tunnel 1

(任意)トンネル インターフェイス統計情報を表示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、トンネル インターフェイスを GRE に設定して、GRE トンネル キープアライブを設定する例を示します。

switch# configure terminal

switch(config)# i nterface tunnel 1

switch(config-if)# tunnel mode gre ip

switch(config-if)# copy running-config startup-config

Path MTU Discovery のイネーブル化

トンネルでパス MTU ディスカバリをイネーブルにするには、 tunnel path-mtu discovery コマンドを使用します。

 

コマンド
目的

tunnel path-mtu-discovery [ age-timer min ] [ min-mtu bytes ]

switch(config-if)# tunnel path-mtu-discovery 25 1500

トンネル インターフェイスで Path MTU Discovery(PMTUD)をイネーブルにします。パラメータは次のとおりです。

mins :分数を指定します。有効な範囲は 10 ~ 30 です。デフォルトは 10 です。

mtu-bytes :認識された最小 MTU。範囲は 92 ~ 65535 です。デフォルト値は 92 です。

トンネル インターフェイスへの VRF メンバーシップの割り当て

VRF にトンネル インターフェイスを追加できます。

はじめる前に

トンネリング機能がイネーブルになっていることを確認します。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

VRF 用のインターフェイスを設定した後で、トンネル インターフェイスに IP アドレスを割り当てます。

手順の概要

1. configure terminal

2. interface tunnel number

3. vrf member vrf-name

4. ip-address ip-prefix/length

5. show vrf [ vrf-name ] interface interface-type number

6. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

interface tunnel number

 

switch(config)# interface tunnel 0

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

vrf member vrf-name

 

例:

switch(config-if)# vrf member RemoteOfficeVRF

このインターフェイスを VRF に追加します。

ステップ 4

ip address ip-prefix/length

 

例:

switch(config-if)# ip address 192.0.2.1/16

このインターフェイスの IP アドレスを設定します。このステップは、このインターフェイスを VRF に割り当てたあとに行う必要があります。

ステップ 5

show vrf [ vrf-name ] interface interface-type number

 

switch(config-vrf)# show vrf Enterprise interface tunnel 0

(任意)VRF 情報を表示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、VRF にトンネル インターフェイスを追加する例を示します。

switch# configure terminal

switch(config)# interface tunnel 0

switch(config-if)# vrf member RemoteOfficeVRF

switch(config-if)# ip address 209.0.2.1/16

switch(config-if)# copy running-config startup-config

IP トンネル設定の確認

IP トンネルの設定情報を確認するには、次のいずれかの作業を行います。

コマンド
目的

show interface tunnel number

トンネル インターフェイスの設定を表示します(MTU、プロトコル、転送、および VRF)。入力および出力パケット、バイト、およびパケット レートを表示します。

show interface tunnel number brief

トンネル インターフェイスの動作状態、IP アドレス、カプセル化のタイプ、MTU を表示します。

show interface tunnel number description

トンネル インターフェイスに設定された説明を表示します。

show interface tunnel number status

トンネル インターフェイスの動作ステータスを表示します。

show interface tunnel number status err-disabled

トンネル インターフェイスの errdisable 状態を表示します。

IP トンネリングの設定例

次の例では、簡易 GRE トンネルを示します。イーサネット 1/2 は、ルータ A のトンネル送信元であり、ルータ B のトンネル宛先です。イーサネット インターフェイス 2/1 は、ルータ B のトンネル送信元であり、ルータ A のトンネル宛先です。

ルータ A:

feature tunnel
interface tunnel 0
  ip address 209.165.20.2/8
  tunnel source ethernet 1/2
  tunnel destination 192.0.2.2
  tunnel mode gre ip
  tunnel path-mtu-discovery 25 1500
interface Ethernet1/2
  ip address 192.0.2.55/8
 

ルータ B:

feature tunnel
interface tunnel 0
  ip address 209.165.20.1/8
  tunnel source ethernet2/1
  tunnel destination 192.0.2.55
  tunnel mode gre ip
interface ethernet 2/1
ip address 192.0.2.2/8

その他の関連資料

IP トンネルの実装に関する追加情報については、次の項を参照してください。

「関連資料」

「標準」

関連資料

関連項目
マニュアル タイトル

IP トンネル コマンド

Cisco Nexus 7000 Series NX-OS Interfaces Command Reference, Release 5.x

IP フラグメンテーションおよび Path MTU Discovery

『Resolve IP Fragmentation, MTU, MSS, and PMTUD Issues with GRE and IPSEC』

標準

標準
タイトル

この機能でサポートされる新規の標準または変更された標準はありません。また、既存の標準のサポートは変更されていません。

--

IP トンネル設定の機能履歴

表 8-2 に、この機能のリリース履歴を示します。

 

表 8-2 IP トンネル設定の機能履歴

機能名
リリース
機能情報

M1 シリーズ I/O モジュールのみに関する異なる VRF 内のトンネルと転送のサポート

5.2(5)

この機能拡張は、NX-OS Release 5.2(5) と 5.2(x) リリース以降でサポートされました。

デフォルト以外の VDC および VRF 内の IP トンネル

4.2(1)

この機能が導入されました。

IP トンネル

4.0(1)

この機能が導入されました。