Cisco Nexus 7000 シリーズ NX-OS インターフェイス コンフィギュレーション ガイド、リリース 5.x
レイヤ 3 インターフェイスの設定
レイヤ 3 インターフェイスの設定
発行日;2015/03/05 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

レイヤ 3 インターフェイスの設定

レイヤ 3 インターフェイスの設定

この章では、 Cisco NX-OS デバイスのレイヤ 3 インターフェイスを設定する方法について説明します。

この章は、次の項で構成されています。

「レイヤ 3 インターフェイスについて」

「レイヤ 3 インターフェイスのライセンス要件」

「注意事項と制約事項」

「デフォルト設定値」

「ライセンス 3 インターフェイスの前提条件」

「レイヤ 3 インターフェイスの設定」

「レイヤ 3 インターフェイス設定の確認」

「レイヤ 3 インターフェイスのモニタリング」

「レイヤ 3 インターフェイスの設定例」

「関連項目」

「その他の参考資料」

「レイヤ 3 インターフェイス設定の機能履歴」

レイヤ 3 インターフェイスについて

レイヤ 3 インターフェイスは、IPv4 および IPv6 パケットをスタティックまたはダイナミック ルーティング プロトコルを使って別のデバイスに転送します。レイヤ 2 トラフィックの IP ルーティングおよび内部 Virtual Local Area Network(VLAN)ルーティングにはレイヤ 3 インターフェイスが使用できます。

共有インターフェイスをレイヤ 3 インターフェイスとして設定することはできません。共有インターフェイスについては、『 Cisco NX-OS FCoE Configuration Guide for Cisco Nexus 7000 and Cisco MDS 9500 』を参照してください。

Cisco Release 5.2(1) 以降では、ファブリック エクステンダ(FEX)ポートをホスト接続のためのレイヤ 3 インターフェイスとして設定できますが、ルーティング用には設定できません。ファブリック エクステンダに関する詳細については、『 Configuring the Cisco Nexus 2000 Series Fabric Extender 』を参照してください。

この項では、次のトピックについて取り上げます。

「ルーテッド インターフェイス」

「サブインターフェイス」

「VLAN インターフェイス」

「ループバック インターフェイス」

「トンネル インターフェイス」

「High Availability(高可用性)」

「仮想化のサポート」

ルーテッド インターフェイス

ポートをレイヤ 2 インターフェイスまたはレイヤ 3 インターフェイスとして設定できます。ルーテッド インターフェイスは、IP トラフィックを他のデバイスにルーティングできる物理ポートです。ルーテッド インターフェイスはレイヤ 3 インターフェイスだけで、スパニングツリー プロトコル(STP)などのレイヤ 2 プロトコルはサポートしません。

すべてのイーサネット ポートは、デフォルトでルーテッド インターフェイスです。このデフォルト動作を変更するには、CLI セットアップ スクリプトまたは system default switchport コマンドを使用します。

ポートに IP アドレスを割り当て、ルーティングをイネーブルにし、このルーテッド インターフェイスにルーティング プロトコル特性を割り当てることができます。

Cisco リリース 4.2(1) からスタティック Media Access Control(MAC)アドレスをレイヤ 3 インターフェイスに割り当てられます。デフォルトでは、レイヤ 3 インターフェイスの MAC アドレスは、割り当て先の VDC の MAC アドレスです。MAC アドレスの設定方法の詳細については、 Cisco Nexus 7000 Series NX-OS Layer 2 Switching Configuration Guide, Release 5.x 』 を参照してください。

ルーテッド インターフェイスからレイヤ 3 ポート チャネルも作成できます。ポート チャネルの詳細については、「ポート チャネルの設定」を参照してください。

ルーテッド インターフェイスおよびサブインターフェイスは、指数関数的に減少するレート カウンタをサポートします。Cisco NX-OS はこれらの平均カウンタを用いて次の統計情報を追跡します。

入力パケット数/秒

出力パケット数/秒

入力バイト数/秒

出力バイト数/秒

サブインターフェイス

レイヤ 3 インターフェイスとして設定した親インターフェイスに仮想サブインターフェイスを作成できます。親インターフェイスは物理ポートでもポート チャネルでもかまいません。

親インターフェイスはサブインターフェイスによって複数の仮想インターフェイスに分割されます。これらの仮想インターフェイスに IP アドレスやダイナミック ルーティング プロトコルなど固有のレイヤ 3 パラメータを割り当てることができます。各サブインターフェイスの IP アドレスは、親インターフェイスの他のサブインターフェイスのサブネットとは異なります。

サブインターフェイスの名前は、親インターフェイスの名前(たとえば Ethernet 2/1)+ ピリオド(.)+ そのインターフェイス独自の番号です。たとえば、イーサネット インターフェイス 2/1 に Ethernet 2/1.1 というサブインターフェイスを作成できます。この場合、.1 はそのサブインターフェイスを表します。

Cisco NX-OS では、親インターフェイスがイネーブルの場合にサブインターフェイスがイネーブルになります。サブインターフェイスは、親インターフェイスには関係なくシャットダウンできます。親インターフェイスをシャットダウンすると、関連するサブインターフェイスもすべてシャットダウンされます。

サブインターフェイスを使用すると、親インターフェイスがサポートするそれぞれの仮想ローカル エリア ネットワーク(VLAN)に独自のレイヤ 3 インターフェイスを実現できます。この場合、親インターフェイスは別のデバイスのレイヤ 2 トランキング ポートに接続します。サブインターフェイスを設定したら 802.1Q トランキングを使って VLAN ID に関連付けます。

図 4-1 に、インターフェイス E 2/1 のルータ B に接続するスイッチのトランキング ポートを示します。このインターフェイスには 3 つのサブインターフェイスがあり、トランキング ポートに接続する 3 つの VLAN にそれぞれ関連付けられています。

図 4-1 VLAN のサブインターフェイス

 

VLAN の詳細については、 Cisco Nexus 7000 Series NX-OS Layer 2 Switching Configuration Guide, Release 5.x を参照してください。

VLAN インターフェイス

VLAN インターフェイスまたはスイッチ仮想インターフェイス(SVI)は、デバイス上の VLAN を同じデバイス上のレイヤ 3 ルータ エンジンに接続する仮想ルーテッド インターフェイスです。VLAN には 1 つの VLAN インターフェイスだけを関連付けることができますが、VLAN に VLAN インターフェイスを設定する必要があるのは、VLAN 間でルーティングする場合か、または管理 VRF(仮想ルーティング/転送)以外の VRF インスタンスを経由してデバイスを IP ホスト接続する場合だけです。VLAN インターフェイスの作成をイネーブルにすると、Cisco NX-OS によってデフォルト VLAN(VLAN 1)に VLAN インターフェイスが作成され、リモート スイッチ管理が許可されます。

設定の前に VLAN ネットワーク インターフェイス機能をイネーブルにする必要があります。Cisco NX-OS リリース 4.2 から、システムは機能のディセーブル化の前に自動的にチェックポイントを作成するため、このチェックポイントにロールバックできます。ロールバックとチェックポイントについては、『 Cisco Nexus 7000 Series NX-OS System Management Configuration Guide, Release 5.x 』を参照してください。

VLAN と同じ VDC に VLAN ネットワーク インターフェイスを設定する必要があります。


) VLAN 1 の VLAN インターフェイスは削除できません。


VLAN インターフェイスをルーティングするには、トラフィックをルーティングする VLAN ごとに VLAN インターフェイスを作成し、その VLAN インターフェイスに IP アドレスを割り当ててレイヤ 3 内部 VLAN ルーティングを実現します。IP アドレスと IP ルーティングの詳細については、 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x を参照してください。

図 4-2 に、2 つの VLAN に 2 つのホストが接続しているデバイスを示します。VLAN ごとに VLAN インターフェイスを設定し、VLAN 間の IP ルーティングを使ってホスト 1 とホスト 2 を通信させることができます。VLAN 1 は VLAN インターフェイス 1 のレイヤ 3 で、VLAN 10 は VLAN インターフェイス 10 のレイヤ 3 で通信します。

図 4-2 VLAN インターフェイスに接続した 2 つの VLAN

 


) シャーシ内の F1 シリーズ モジュールを使用して、Cisco Nexus 7000 シリーズ スイッチでインバンド管理のための VLAN インターフェイスを設定できます。


ループバック インターフェイス

ループバック インターフェイスは、常にアップ状態にある単独のエンドポイントを持つ仮想インターフェイスです。ループバック インターフェイスを通過するパケットはこのインターフェイスでただちに受信されます。ループバック インターフェイスは物理インターフェイスをエミュレートします。VDC ごとに最大 1024 のループバック インターフェイスが設定できます。VDC には 0 ~ 1023 の番号が付いています。

ループバック インターフェイスを使用すると、パフォーマンスの分析、テスト、ローカル通信が実行できます。ループバック インターフェイスは、ルーティング プロトコル セッションの終端アドレスとして設定することができます。ループバックをこのように設定すると、アウトバウンド インターフェイスの一部がダウンしている場合でもルーティング プロトコル セッションはアップしたままです。

トンネル インターフェイス

Cisco NX-OS は、IP トンネルとしてトンネル インターフェイスをサポートします。IP トンネルを使うと、同じレイヤまたは上位層プロトコルをカプセル化して、2 台のルータ間で作成されたトンネルを通じて IP の結果を転送できます。IP トンネルの詳細については、「IP トンネルの設定」を参照してください。

High Availability(高可用性)

レイヤ 3 インターフェイスは、ステートフル再起動とステートレス再起動をサポートします。切り替え後、Cisco NX-OS は実行時の設定を適用します。

ハイ アベイラビリティの詳細については、『 Cisco Nexus 7000 Series NX-OS High Availability and Redundancy Guide, Release 5.x 』を参照してください。

仮想化のサポート

レイヤ 3 インターフェイスは、仮想ルーティング/転送(VRF)インスタンスをサポートします。VRF は仮想化デバイス コンテキスト(VDC)内にあります。特に別の VDC や VRF を設定しない限り、デフォルトでは、Cisco NX-OS のデフォルトの VDC およびデフォルトの VRF が使用されます。ある VDC に設定されたレイヤ 3 論理インターフェイス(VLAN インターフェイス、ループバック)は、同じ番号を持つ別の VDC に設定されたレイヤ 3 論理インターフェイスとは区別されます。たとえば、VDC 1 のループバック 0 は VDC 2 のループバック 0 とは異なります。

VDC ごとに最大 1024 のループバック インターフェイスを設定できます。

このインターフェイスは VRF に関連付けることができます。VLAN インターフェイスの場合、VLAN と同じ VDC に設定する必要があります。

VDC については Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide, Release 5.x を、 VRF でのインターフェイスの設定については Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x を参照してください


) そのインターフェイスに IP アドレスを設定する前に、インターフェイスを VRF に割り当てる必要があります。


レイヤ 3 インターフェイスのライセンス要件

次の表に、この機能のライセンス要件を示します。

 

製品
ライセンス要件

Cisco NX-OS

レイヤ 3 インターフェイスにライセンスは必要ありません。ライセンス パッケージに含まれていない機能はすべて Cisco NX-OS システム イメージにバンドルされており、追加費用は一切発生しません。Cisco NX-OS のライセンス スキームの詳細については、『 Cisco NX-OS Licensing Guide 』を参照してください。

ライセンス 3 インターフェイスの前提条件

ライセンス 3 インターフェイスには次の前提条件があります。

Advanced Services ライセンスがインストールされており、VDC を設定している場合は目的の VDC が入力されている( Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide, Release 5.x を参照)。

IP アドレッシングおよび基本設定を熟知している。IP アドレッシングの詳細については、 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x を参照してください

注意事項と制約事項

レイヤ 3 インターフェイスの設定には次の注意事項と制約事項があります。

レイヤ 3 インターフェイスをレイヤ 2 インターフェイスに変更する場合、Cisco NX-OS はインターフェイスをシャットダウンしてインターフェイスを再度イネーブルにし、レイヤ 3 固有の設定をすべて削除します。

レイヤ 2 インターフェイスをレイヤ 3 インターフェイスに変更する場合、Cisco NX-OS はインターフェイスをシャットダウンしてインターフェイスを再度イネーブルにし、レイヤ 2 固有の設定をすべて削除します。

Cisco Nexus 2000 ファブリック エクステンダは、そのポートに接続されたデバイスでルーティング プロトコルの隣接に参加できません。直接ルートだけがサポートされます。これは、次のサポートされる接続例両方に適用されます。

レイヤ 2 モードのファブリック エクステンダ単一ポートまたはポートチャネルを有する SVI。

レイヤ 3 モードのファブリック エクステンダのポートまたはポートチャネル。

レイヤ 3 のルータ インターフェイスとサブインターフェースは、F1 I/O モジュールでは設定できません。

F2 シリーズ I/O モジュールは VLAN 単位の統計情報はサポートしません。したがって、show interface コマンドは、スイッチ仮想インターフェイス(SVI)の VLAN 単位の Rx/Tx カウンタまたは統計情報を表示しません。


) Cisco IOS の CLI に慣れている場合、この機能に対応する Cisco NX-OS コマンドは通常使用する Cisco IOS コマンドと異なる場合があるので注意してください。


デフォルト設定値

表 4-1 は、レイヤ 3 インターフェイス パラメータのデフォルト設定です。

 

表 4-1 レイヤ 3 インターフェイスのデフォルト パラメータ

パラメータ(Parameters)
デフォルト

管理ステート

閉じる

レイヤ 3 インターフェイスの設定

この項では、次のトピックについて取り上げます。

「ルーテッド インターフェイスの設定」

「サブインターフェイスの設定」

「インターフェイスでの帯域幅の設定」

「VLAN インターフェイスの設定」

「Nexus シャーシでのインバンド管理の設定」

「ループバック インターフェイスの設定」

「VRF へのインターフェイスの割り当て」

ルーテッド インターフェイスの設定

任意のイーサネット ポートをルーテッド インターフェイスとして設定できます。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. interface ethernet slot/port

3. no switchport

4. ip address ip-address/length
または
ipv6 address ipv6-address/length

5. (任意) show interfaces

6. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

interface ethernet slot/port

 

例:

switch(config)# interface ethernet 2/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

no switchport

 

例:

switch(config-if)# no switchport

インターフェイスをレイヤ 3 インターフェイスとして設定し、このインターフェイス上のレイヤ 2 に固有の設定をすべて削除します。

ステップ 4

ip address ip-address/length

 

例:

switch(config-if)# ip address 192.0.2.1/8

このインターフェイスの IP アドレスを設定します。IP アドレスの詳細については、 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x を参照してください。

ipv6 address ipv6-address/length

 

例:

switch(config-if)# ipv6 address 2001:0DB8::1/8

このインターフェイスの IPv6 アドレスを設定します。IPv6 アドレスの詳細については、 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x を参照してください。

ステップ 5

show interfaces

 

switch(config-if)# show interfaces ethernet 2/1

(任意)レイヤ 3 インターフェイスの統計情報を表示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

インターフェイス メディアをポイント ツー ポイントまたはブロードキャストのどちらかとして設定するには、 medium コマンドを使用します。

 

コマンド
目的

medium { broadcast | p2p }

 

例:

switch(config-if)# medium p2p

インターフェイス メディアをポイント ツー ポイントまたはブロードキャストのどちらかとして設定します。


) デフォルト設定は broadcast であり、この設定はどの show コマンドにも表示されません。ただし、p2p に設定を変更した場合、show running config コマンドを入力すると、この設定が表示されます。


レイヤ 3 インターフェイスをレイヤ 2 インターフェイスに変換するには、 switchport コマンドを使用します。

 

コマンド
目的

switchport

 

例:

switch(config-if)# switchport

インターフェイスをレイヤ 2 インターフェイスとして設定し、このインターフェイス上のレイヤ 3 固有の設定を削除します。

次に、ルーテッド インターフェイスを設定する例を示します。

switch# configure terminal

switch(config)# i nterface ethernet 2/1

switch(config-if)# no switchport

switch(config-if)# ip address 192.0.2.1/8

switch(config-if)# copy running-config startup-config

 

インターフェイスのデフォルト設定がルーテッドされます。レイヤ 2 にインターフェイスを設定するには、 switchport コマンドを入力します。レイヤ 2 インターフェイスをルーテッド インターフェイスに変更する場合は、 no switchport コマンドを入力します。

サブインターフェイスの設定

ルーテッド インターフェイスまたはルーテッド インターフェイスで作成したポート チャネルに 1 つまたは複数のサブインターフェイスを設定できます。

はじめる前に

親インターフェイスをルーテッド インターフェイスとして設定します。

「ルーテッド インターフェイスの設定」を参照してください。

このポート チャネル上にサブインターフェイスを作成するには、ポート チャネル インターフェイスを作成します。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. interface ethernet slot/port.number

3. ip address ip-address/length
または
ipv6 address ipv6-address/length

4. encapsulation dot1q vlan-id

5. (任意) show interfaces

6. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

interface ethernet slot/port.number

 

例:

switch(config)# interface ethernet 2/1.1

switch(config-subif)#

サブインターフェイスを作成し、サブインターフェイス コンフィギュレーション モードを開始します number の範囲は 1 ~ 4094 です。

ステップ 3

ip address ip-address/length

 

例:

switch(config-subif)# ip address 192.0.2.1/8

このサブインターフェイスの IP アドレスを設定します。IP アドレスの詳細については、 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x を参照してください。

ipv6 address ipv6-address/length

 

例:

switch(config-subif)# ipv6 address 2001:0DB8::1/8

このサブインターフェイスの IPv6 アドレスを設定します。IPv6 アドレスの詳細については、 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x を参照してください。

ステップ 4

encapsulation dot1Q vlan-id

 

例:

switch(config-subif)# encapsulation dot1Q 33

サブインターフェイス上の IEEE 802.1Q VLAN カプセル化を設定します。範囲は 2 ~ 4093 です。

ステップ 5

show interfaces

 

switch(config-subif)# show interfaces ethernet 2/1.1

(任意)レイヤ 3 インターフェイスの統計情報を表示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config-subif)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、サブインターフェイスを作成する例を示します。

switch# configure terminal

switch(config)# i nterface ethernet 2/1.1

switch(config-if)# ip address 192.0.2.1/8

switch(config-if)# encapsulation dot1Q 33

switch(config-if)# copy running-config startup-config

インターフェイスでの帯域幅の設定

ルーテッド インターフェイス、ポート チャネル、またはサブインターフェイスに帯域幅を設定できます。上位層プロトコルは帯域幅パラメータを使用してパス コストを計算します。サブインターフェイスの帯域幅は、次のいずれかの方法で設定できます。

明示的:サブインターフェイスの帯域幅を直接設定します。

継承:サブインターフェイスが固有の値として、つまり親インターフェイスの帯域幅を親インターフェイスから継承するように帯域幅を設定します。

サブインターフェイスの帯域幅を設定しない場合、または親インターフェイスの帯域幅を継承しない場合、サブインターフェイスの帯域幅は次の方法で決定されます。

親インターフェイスがアップしている場合、サブインターフェイスの帯域幅は親インターフェイスの動作速度と同じです。ポートの場合、サブインターフェイスの帯域幅は設定されているリンク速度またはネゴシエート対象のリンク速度です。ポート チャネルの場合、サブインターフェイスの帯域幅は、ポート チャネルの各メンバのリンク速度の集合です。

親インターフェイスがダウンしている場合、サブインターフェイスの帯域幅は親インターフェイスのタイプによって異なります。

ポート チャネル サブインターフェイスの場合、サブインターフェイスの帯域幅は 100 Mb/s です。

1 Gb/s イーサネット ポートの場合、サブインターフェイスの帯域幅は 1 Gb/s です。

10 Gb/s イーサネット ポートの場合、サブインターフェイスの帯域幅は 10 Gb/s です。

インターフェイスの帯域幅を設定するには、インターフェイス モードで次のコマンドを使用します。

 

コマンド
目的

bandwidth

 

例:

switch(config-if)# bandwidth 100000

ルーテッド インターフェイス、ポート チャネル、またはサブインターフェイスに帯域幅パラメータを設定します。

親インターフェイスから帯域幅を継承するようにサブインターフェイスを設定するには、インターフェイス モードで次のコマンドを使用します。

 

コマンド
目的

bandwidth inherit [ value ]

 

例:

switch(config-if)# bandwidth inherit 100000

設定された帯域幅の値を継承するように、このインターフェイスのすべてのサブインターフェイスを設定します。値を設定しない場合、サブインターフェイスは親インターフェイスの帯域幅を継承します。指定できる範囲は 1 ~ 10000000(KB 単位)です。

VLAN インターフェイスの設定

VLAN インターフェイスを作成して内部 VLAN ルーティングを行うことができます。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. feature interface-vlan

3. interface vlan number

4. ip address ip-address/length
または
ipv6 address ipv6-address/length

5. (任意) show interface vlan number

6. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

feature interface-vlan

例:

switch(config)# feature interface-vlan

VLAN インターフェイス モードをイネーブルにします。

ステップ 3

interface vlan number

 

例:

Switch(config)# interface vlan 10

switch(config-if)#

VLAN インターフェイスを作成します。 number の範囲は 1 ~ 4094 です。

ステップ 4

ip address ip-address/length

 

例:

switch(config-if)# ip address 192.0.2.1/8

この VLAN インターフェイスの IP アドレスを設定します。IP アドレスの詳細については、 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x を参照してください。

ipv6 address ipv6-address/length

 

例:

switch(config-if)# ipv6 address 2001:0DB8::1/8

この VLAN インターフェイスの IPv6 アドレスを設定します。IPv6 アドレスの詳細については、 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x を参照してください。

ステップ 5

show interface vlan number

 

switch(config-if)# show interface vlan 10

(任意)レイヤ 3 インターフェイスの統計情報を表示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、VLAN インターフェイスを作成する例を示します。

switch# configure terminal

switch(config)# feature interface-vlan

Switch(config)# in terface vlan 10

switch(config-if)# ip address 192.0.2.1/8

switch(config-if)# copy running-config startup-config

 

Nexus シャーシでのインバンド管理の設定

シャーシ内に F1 シリーズ モジュールのみがある場合に、Cisco Nexus 7000 シリーズ スイッチでインバンド管理のための VLAN インターフェイスを作成できます。


注意 F1 シリーズ モジュールのインバンド管理には専用の VLAN を使用することを推奨します。インバンド管理に使用している VLAN 上でデータ トラフィックを実行しないでください。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. feature interface-vlan

3. interface vlan number

4. no shutdown

5. management

6. ip address ip-address/length

7. (任意) show interface vlan number

8. (任意) copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

feature interface-vlan
例:
switch(config)# feature interface-vlan

ループバック インターフェイスを作成します。指定できる範囲は 0 ~ 1023 です。

ステップ 3

interface vlan number

 

例:

Switch(config)# interface vlan 10

switch(config-if)#

VLAN インターフェイスを作成します。 number の範囲は 1 ~ 4094 です。

(注) VLAN を設定し、インターフェイスを追加します。

ステップ 4

no shutdown
 

例:

switch(config-if)# no shutdown

インターフェイスを管理上のアップ状態にします(インターフェイスをイネーブルまたはディセーブルにします)。

ステップ 5

management

 

例:

switch(config-if)# management

VLAN インターフェイスの IP アドレスへのインバンド管理アクセスを許可します。

ステップ 6

ip address ip-address/length

 

例:

switch(config-if)# ip address 192.0.2.1/8

この VLAN インターフェイスの IP アドレスを設定します。IP アドレスの詳細については、 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x を参照してください。

ステップ 7

show interface vlan number

 

switch(config-if)# show interface vlan 10

(任意)レイヤ 3 インターフェイスの統計情報を表示します。

ステップ 8

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、Cisco Nexus 7000 シャーシでインバンド管理を作成する例を示します。

switch# configure terminal

switch(config)# feature interface-vlan

switch(config)# in terface vlan 5

switch(config)# no shutdown

switch(config)# management

switch(config-if)# ip address 192.0.2.1/8

switch(config-if)# copy running-config startup-config

ループバック インターフェイスの設定

ループバック インターフェイスを設定して、常にアップ状態にある仮想インターフェイスを作成できます。

はじめる前に

ループバック インターフェイスの IP アドレスが、ネットワークの全ルータで一意であることを確認します。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. interface loopback instance

3. ipv4 address ip-address
または
ipv6 address ip-address

4. (任意) show interfaces loopback instance

5. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

interface loopback instance

 

例:

switch(config)# interface loopback 0

switch(config-if)#

ループバック インターフェイスを作成します。指定できる範囲は 0 ~ 1023 です。

ステップ 3

ip address ip-address/length

 

例:

switch(config-if)# ip address 192.0.2.100/8

このインターフェイスの IP アドレスを設定します。IP アドレスの詳細については、 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x を参照してください。

ipv6 address ipv6-address/length

 

例:

switch(config-if)# ipv6 address 2001:0DB8::18/8

このインターフェイスの IPv6 アドレスを設定します。IPv6 アドレスの詳細については、 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x を参照してください。

ステップ 4

show interfaces loopback instance

 

switch(config-if)# show interfaces loopback 0

(任意)ループバック インターフェイスの統計情報を表示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、ループバック インターフェイスを作成する例を示します。

switch# configure terminal

switch(config)# in terface loopback 0

switch(config-if)# ip address 192.0.2.100/8

switch(config-if)# copy running-config startup-config

 

VRF へのインターフェイスの割り当て

VRF にレイヤ 3 インターフェイスを追加できます。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

VRF 用のインターフェイスを設定した後で、トンネル インターフェイスに IP アドレスを割り当てます。

手順の概要

1. configure terminal

2. interface interface-type number

3. vrf member vrf-name

4. ip-address ip-prefix/length

5. (任意) show vrf [ vrf-name ] interface interface-type number

6. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

interface interface-type number

 

switch(config)# interface loopback 0

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

vrf member vrf-name

 

例:

switch(config-if)# vrf member RemoteOfficeVRF

このインターフェイスを VRF に追加します。

ステップ 4

ip address ip-prefix/length

 

例:

switch(config-if)# ip address 192.0.2.1/16

このインターフェイスの IP アドレスを設定します。このステップは、このインターフェイスを VRF に割り当てたあとに行う必要があります。

ステップ 5

show vrf [ vrf-name ] interface interface-type number

 

switch(config-vrf)# show vrf Enterprise interface loopback 0

(任意)VRF 情報を表示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、VRF にレイヤ 3 インターフェイスを追加する例を示します。

switch# configure terminal

switch(config)# interface loopback 0

switch(config-if)# vrf member RemoteOfficeVRF

switch(config-if)# ip address 209.0.2.1/16

switch(config-if)# copy running-config startup-config

レイヤ 3 インターフェイス設定の確認

レイヤ 3 の設定を表示するには、次のいずれかの作業を行います。

 

コマンド
目的

show interface ethernet slot/port

レイヤ 3 インターフェイスの設定情報、ステータス、カウンタ(インバウンドおよびアウトバウンド パケット レートおよびバイト レートが 5 分間に指数関数的に減少した平均値を含む)を表示します。

show interface ethernet slot/port brief

レイヤ 3 インターフェイスの動作ステータスを表示します。

show interface ethernet slot/port capabilities

レイヤ 3 インターフェイスの機能(ポート タイプ、速度、およびデュプレックスを含む)を表示します。

show interface ethernet slot/port description

レイヤ 3 インターフェイスの説明を表示します。

show interface ethernet slot/port status

レイヤ 3 インターフェイスの管理ステータス、ポート モード、速度、およびデュプレックスを表示します。

show interface ethernet slot/port.number

サブインターフェイスの設定情報、ステータス、カウンタ(インバウンドおよびアウトバウンド パケット レートおよびバイト レートが 5 分間に指数関数的に減少した平均値を含む)を表示します。

show interface port-channel channel-id.number

ポート チャネル サブインターフェイスの設定情報、ステータス、カウンタ(インバウンドおよびアウトバウンド パケット レートおよびバイト レートが 5 分間に指数関数的に減少した平均値を含む)を表示します。

show interface loopback number

ループバック インターフェイスの設定情報、ステータス、カウンタを表示します。

show interface loopback number brief

ループバック インターフェイスの動作ステータスを表示します。

show interface loopback number description

ループバック インターフェイスの説明を表示します。

show interface loopback number status

ループバック インターフェイスの管理ステータスおよびプロトコル ステータスを表示します。

show interface vlan number

VLAN インターフェイスの設定情報、ステータス、カウンタを表示します。

show interface vlan number brief

VLAN インターフェイスの動作ステータスを表示します。

show interface vlan number description

VLAN インターフェイスの説明を表示します。

show interface vlan number private-vlan mapping

VLAN インターフェイスのプライベート VLAN 情報を表示します。

show interface vlan number status

VLAN インターフェイスの管理ステータスおよびプロトコル ステータスを表示します。

レイヤ 3 インターフェイスのモニタリング

レイヤ 3 統計情報を表示するには、次のコマンドを使用します。

 

コマンド
目的

load- interval {interval seconds {1 | 2 | 3 }}

Cisco Nexus 7000 シリーズ デバイスの Cisco NX-OS Release 4.2(1) から、3 種類のサンプリング間隔をビットレートおよびパケットレートの統計情報に設定します。VLAN ネットワーク インターフェイスでの範囲は 60 ~ 300 秒であり、レイヤ インターフェイスでの範囲は 30 ~ 300 秒です。

show interface ethernet slot/port counters

レイヤ 3 インターフェイスの統計情報を表示します(ユニキャスト、マルチキャスト、ブロードキャスト)。

show interface ethernet slot/port counters brief

レイヤ 3 インターフェイスの入力および出力カウンタを表示します。

show interface ethernet slot/port counters detailed [ all ]

レイヤ 3 インターフェイスの統計情報を表示します。オプションとして、32 ビットと 64 ビットのパケットおよびバイト カウンタ(エラーを含む)をすべて含めることができます。

show interface ethernet slot/port counters errors

レイヤ 3 インターフェイスの入力および出力エラーを表示します。

show interface ethernet slot/port counters snmp

SNMP MIB から報告されたレイヤ 3 インターフェイス カウンタを表示します。これらのカウンタはクリアできません。

show interface ethernet slot/port.number counters

サブインターフェイスの統計情報(ユニキャスト、マルチキャスト、およびブロードキャスト)を表示します。

show interface port-channel channel-id.number counters

ポート チャネル サブインターフェイスの統計情報(ユニキャスト、マルチキャスト、およびブロードキャスト)を表示します。

show interface loopback number counters

ループバック インターフェイスの入力および出力カウンタ(ユニキャスト、マルチキャスト、およびブロードキャスト)を表示します。

show interface loopback number counters detailed [ all ]

ループバック インターフェイスの統計情報を表示します。オプションとして、32 ビットと 64 ビットのパケットおよびバイト カウンタ(エラーを含む)をすべて含めることができます。

show interface loopback number counters errors

ループバック インターフェイスの入力および出力エラーを表示します。

show interface vlan number counters

VLAN インターフェイスの入力および出力カウンタ(ユニキャスト、マルチキャスト、およびブロードキャスト)を表示します。

show interface vlan number counters detailed [ all ]

VLAN インターフェイスの統計情報を表示します。オプションとして、レイヤ 3 パケットおよびバイト カウンタをすべて含めることができます(ユニキャストおよびマルチキャスト)。

show interface vlan number counters snmp

SNMP MIB から報告された VLAN インターフェイス カウンタを表示します。これらのカウンタはクリアできません。

これらのコマンドについては、 Cisco Nexus 7000 Series NX-OS Interfaces Command Reference, Release 5.x を参照してください。

レイヤ 3 インターフェイスの設定例

次に、イーサネット サブインターフェイスを設定する例を示します。

interface ethernet 2/1.10

description Layer 3 for VLAN 10

encapsulation dot1q 10

ip address 192.0.2.1/8

次に、VLAN インターフェイスを設定する例を示します。

interface vlan 100
 ipv6 address 33:0DB::2/8
 

次に、ループバック インターフェイスを設定する例を示します。

interface loopback 3
ip address 192.0.2.2/32

関連項目

レイヤ 3 インターフェイスの詳細については、次の項目を参照してください。

「ポート チャネルの設定」

Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x

その他の参考資料

レイヤ 3 インターフェイスの実装に関する追加情報については、次の項を参照してください。

「関連資料」

「管理情報ベース(MIB)」

「標準」

関連資料

関連項目
マニュアル タイトル

コマンド構文

Cisco Nexus 7000 Series NX-OS Interfaces Command Reference, Release 5.x

IP

Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x 内の IP の設定 」の章

VLAN

Cisco Nexus 7000 Series NX-OS Layer 2 Switching Configuration Guide, Release 5.x 内の VLAN の設定 の章

管理情報ベース(MIB)

MIB
MIB のリンク

IF-MIB

CISCO-IF-EXTENSION-MIB

ETHERLIKE-MIB

MIB を検索およびダウンロードするには、次の URL にアクセスしてください。

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

標準

標準
タイトル

この機能でサポートされる新規の標準または変更された標準はありません。また、既存の標準のサポートは変更されていません。

--

レイヤ 3 インターフェイス設定の機能履歴

表 4-2 に、この機能のリリース履歴を示します。

 

表 4-2 レイヤ 3 インターフェイス設定の機能履歴

機能名
リリース
機能情報

インターフェイス統計情報の 3 つの設定可能なサンプリング間隔

4.2(1)

load-interval コマンドが追加されました。

レイヤ 3 インターフェイス

4.0(1)

この機能が導入されました。