Cisco Nexus 7000 シリーズ NX-OS インターフェイス コンフィギュレーション ガイド、リリース 5.x
双方向フォワーディング検出の設定
双方向フォワーディング検出の設定
発行日;2015/03/05 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

双方向フォワーディング検出の設定

BFD について

非同期モード

BFD の障害検出

分散型動作

BFD エコー機能

セキュリティ

High Availability(高可用性)

仮想化のサポート

BFD のライセンス要件

BFD の前提条件

注意事項と制約事項

デフォルト設定値

BFD の設定

設定階層

BFD 設定のタスク フロー

BFD 機能のイネーブル化

グローバルな BFD パラメータの設定

インターフェイスでの BFD の設定

ポート チャネルの BFD の設定

BFD エコー機能の設定

サブインターフェイスの BFD の最適化

ルーティング プロトコルに対する BFD サポートの設定

BGP での BFD の設定

EIGRP 上での BFD の設定

OSPF での BFD の設定

IS-IS での BFD の設定

HSRP での BFD の設定

VRRP での BFD の設定

Protocol Independent Multicast(PIM)上での BFD の設置

スタティック ルートでの BFD の設定

MPLS TE 高速再ルーティングの BFD 設定

インターフェイスにおける BFD のディセーブル化

BFD 設定の確認

BFD のモニタ

BFD の設定例

その他の関連資料

関連資料

RFC

BFD の機能の履歴

双方向フォワーディング検出の設定

この章では、Cisco NX-OS デバイスで双方向フォワーディング検出(BFD)を設定する方法について説明します。

この章は、次の項で構成されています。

「BFD について」

「BFD のライセンス要件」

「BFD の前提条件」

「注意事項と制約事項」

「デフォルト設定値」

「BFD の設定」

「BFD 設定の確認」

「BFD のモニタ」

「BFD の設定例」

「その他の関連資料」

「BFD の機能の履歴」

BFD について

BFD は、メディア タイプ、カプセル化、トポロジ、およびルーティング プロトコルの転送パス障害を高速で検出するように設計された検出プロトコルです。BFD を使用することで、さまざまなプロトコルの Hello メカニズムにより、変動速度ではなく一定速度で転送パス障害を検出できます。BFD はプロファイリングおよびプランニングを簡単にし、再コンバージェンス時間の一貫性を保ち、予測可能にします。

BFD は 2 台の隣接デバイス間のサブセカンド障害を検出し、BFD の負荷の一部を、サポートされるモジュール上のデータ プレーンに分散できるため、プロトコル hello メッセージよりも CPU を使いません。

この項では、次のトピックについて取り上げます。

「非同期モード」

「BFD の障害検出」

「分散型動作」

「BFD エコー機能」

「セキュリティ」

「High Availability(高可用性)」

「仮想化のサポート」

非同期モード

Cisco NX-OS は、BFD 非同期モードをサポートします。BFD 非同期モードでは、2 個の隣接するデバイス間で BFD 制御パケットが送信され、デバイス間の BFD ネイバー セッションがアクティベートされ、維持されます。両方のデバイス(または BFD ネイバー)で BFD を設定できます。インターフェイスおよび適切なプロトコルで一度 BFD がイネーブルになると、Cisco NX-OS は BFD セッションを作成し、BFD セッション パラメータをネゴシエートし、BFD 制御パケットをネゴシエートされた間隔で各 BFD ネイバーに送信し始めます。BFD セッション パラメータは、次のとおりです。

目的の最小送信間隔:このデバイスが BFD Hello メッセージを送信する間隔。

必要最小受信間隔:このデバイスが別の BFD デバイスからの BFD Hello メッセージを受け付ける最小間隔。

検出乗数:転送パスの障害を検出するまでに喪失した、別の BFD デバイスからの BFD Hello メッセージの数。

図 5-1 に BFD セッション確立方法を示します。この図は、OSPF と BFD を実行する 2 台のルータがある単純なネットワークを示します。OSPF がネイバーを検出すると(1)、OSPF 隣接ルータで BFD ネイバー セッションを開始する要求が、ローカル BFD プロセスに送信されます(2)。OSPF ネイバー ルータとの BFD ネイバー セッションが確立されました(3)。

図 5-1 BFD ネイバー関係の確立

BFD の障害検出

一度 BFD セッションが確立され、タイマー ネゴシエーションが終了すると、BFD ネイバーは、より速い速度の場合を除き IGP Hello プロトコルと同じ動作をする BFD 制御パケットを送信し、活性度を検出します。BFD は障害を検出しますが、プロトコルが障害の発生したピアをバイパスするための処置を行う必要があります。

BFD は転送パスに障害を検出したとき、障害検出通知を BFD 対応プロトコルに送信します。ローカル デバイスは、プロトコル再計算プロセスを開始してネットワーク全体の収束時間を削減できます。

図 5-2 に、ネットワーク(1)で障害が発生した場合を示します。OSPF ネイバー ルータでの BFD ネイバー セッションが停止されます(2)。BFD はローカル OSPF プロセスに BFD ネイバーに接続できなくなったことを通知します(3)。ローカル OSPF プロセスは OSPF ネイバー関係を解除します(4)。代替パスが使用可能な場合、ルータはただちにそのパスでコンバージェンスを開始します。


) BFD 障害検出は 1 秒未満で行われます。これは OSPF Hello メッセージが同じ障害を検出するより高速です。


図 5-2 OSPF ネイバー関係の解除

分散型動作

Cisco NX-OS は、BFD をサポートする互換性のあるモジュールへ BDF 動作を配布できます。このプロセスで、BFD パケット処理の CPU の負荷を、BFD ネイバーに接続された各モジュールへオフロードします。すべての BFD セッションはモジュール CPU 上で行われます。BFD 障害が検出されたときに、モジュールはスーパーバイザに通知します。

BFD エコー機能

BFD エコー機能は、転送エンジンからリモート BFD ネイバーにエコー パケットを送信します。BFD ネイバーは検出を実行するために同じパスに沿ってエコー パケットを返送します。BFD ネイバーは、エコー パケットの実際の転送に参加しません。エコー機能および転送エンジンが検出の処理を行います。BFD はエコー機能がイネーブルになっている場合に非同期セッションの速度を低下させ、2 台の BFD ネイバー間で送信される BFD 制御パケット数を減らすために、slow timer を使用できます。また、転送エンジンは、リモート システムを含めないでリモート(ネイバー)システムの転送パスをテストするので、パケット間遅延の変動が少なくなり、障害検出時間が短縮されます。

BFD ネイバーの両方がエコー機能を実行している場合、エコー機能には非対称性がありません。


) ユニキャスト リバース パス転送チェック(uRPF)はデフォルトではディセーブルです。これを BFD のあるインターフェイス機能でイネーブルにする必要がある場合は、BFD エコー機能がディセーブルになっている必要があります。


セキュリティ

Cisco NX-OS は BFD パケットを隣接する BFD ピアから受信したことを確認するためにパケットの存続可能時間(TTL)値を使用します。すべての非同期およびエコー要求パケットの場合、BFD ネイバーは TTL 値を 255 に設定し、ローカル BFD プロセスは着信パケットを処理する前に TTL 値を 255 として確認します。エコー応答パケットの場合、BFD は TTL 値を 254 に設定します。

Cisco NX-OS リリース 5.2 以降では、BFD パケットの SHA-1 認証を設定できます。

High Availability(高可用性)

BFD は、ステートレスなリスタートとインサービス ソフトウェア アップグレード(ISSU)をサポートします。ISSU を使用すると、転送に影響を与えることなく、ソフトウェアをアップグレードできます。リブートまたはスーパーバイザ スイッチオーバー後に、Cisco NX-OS が実行コンフィギュレーションを適用し、BFD がただちに制御パケットを BFD ピアに送信します。

仮想化のサポート

BFD は、仮想ルーティングおよび転送(VRF)インスタンスをサポートしています。VRF は仮想化デバイス コンテキスト(VDC)内にあります。デフォルトでは、特に別の VDC および VRF を設定しない限り、Cisco NX-OS によりデフォルト VDC およびデフォルト VRF が使用されます。詳細については、 Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide, Release 5.x 』 を参照してください。

BFD のライセンス要件

次の表に、この機能のライセンス要件を示します。

 

製品
ライセンス要件

Cisco NX-OS

BFD にはライセンスは不要です。ライセンス パッケージに含まれていない機能はすべて Cisco NX-OS システム イメージにバンドルされており、追加費用は一切発生しません。Cisco NX-OS のライセンス スキームの詳細については、『 Cisco NX-OS Licensing Guide 』を参照してください。

BFD の前提条件

BFD には、次の前提条件があります。

BFD 機能をイネーブルにする必要があります(「BFD 機能のイネーブル化」を参照)。

BFD をイネーブルにする任意のクライアント プロトコルでは、そのクライアント プロトコルの BFD をイネーブルにします。「ルーティング プロトコルに対する BFD サポートの設定」を参照してください。

BFD 対応インターフェイスでインターネット制御メッセージ プロトコル(ICMP)リダイレクト メッセージをディセーブルにします。

デフォルト VDC の同一 IP の送信元および宛先アドレスの IP パケット検証チェックをディセーブルにします。

設定作業とともに一覧表示されているその他の詳細な前提条件を参照してください。

注意事項と制約事項

BFD 設定時の注意事項と制約事項は次のとおりです。

BFD は BFD バージョン 1 をサポートします。

BFD は IPv4 をサポートします。

BFD は、シングルホップ BFD をサポートします。

ボーダー ゲートウェイ プロトコル(BGP)の BFD は、シングルホップ External BGP(EBGP)および Internal BGP(iBGP)ピアをサポートしています。

BFD は、Cisco NX-OS リリース 5.2 以降ではキー付き SHA-1 認証をサポートします。

BFD は、次のレイヤ 3 インターフェイスをサポートします。物理インターフェイス、ポート チャネル、サブインターフェイス、および VLAN インターフェイス。

BFD はレイヤ 3 隣接情報に応じて、レイヤ 2 のトポロジ変更を含むトポロジ変更を検出します。レイヤ 3 隣接情報が使用できない場合、VLAN インターフェイス(SVI)の BFD セッションはレイヤ 2 トポロジのコンバージェンス後に稼働しない可能性があります。

ポート チャネル設定の制限事項

BFD で使用されるレイヤ 3 ポート チャネルでは、ポート チャネルの LACP をイネーブルにする必要があります。

SVI のセッションで使用されるレイヤ 2 ポート チャネルでは、ポート チャネルの LACP をイネーブルにする必要があります。

SVI の制限事項

ASIC リセットにより他のポートのトラフィックが中断されます。このイベントは、その他のポートの SVI セッションがフラップする原因になることがあります。ASIC がリセットする既存のトリガーには、VDC をリロードしている VDC 間のポート移動があります。また、キャリア インターフェイスが仮想ポート チャネル(vPC)の場合、BFD は SVI インターフェイスではサポートされません。

トポロジを変更すると(たとえば、VLAN へのリンクの追加または削除、レイヤ 2 ポート チャネルからのメンバの削除など)、SVI セッションが影響を受ける場合があります。SVI セッションはダウンした後、トポロジ ディスカバリの終了後に起動する場合があります。


ヒント SVI のセッションがフラップしないようにし、トポロジを変更する必要がある場合は、変更を加える前に BFD 機能をディセーブルにして、変更後、BFD を再度イネーブルにできます。また、大きな値(たとえば、5 秒)になるように BFD タイマーを設定し、上記のイベントの完了後に高速なタイマーに戻すこともできます。

N7K-F132XL-15 モジュール上でのみメンバー ポートがある VLAN インターフェイスを通した BFD はサポートされません。N7K-F132XL-15 モジュール上でのみメンバー ポートを持ついずれかの VLAN を通した BFD をディセーブルにする必要があります。


) (たとえば、OSPF から)ルータ レベルで BFD をイネーブルにすると、N7K-F132XL-15 ラインカードを通した BFD セッションは発生しません。OSPF およびその他のルーティング プロトコルについては、『Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x』 を参照してください。


分散レイヤ 3 ポート チャネルで BFD エコー機能を設定した場合、メンバー モジュールをリロードすると、そのモジュールでホストされた BFD セッションがフラップされ、そのためパケット損失が発生します。

レイヤ 2 スイッチを間に入れずに BFD ピアを直接接続する場合、代替策として BFD per-link モードを使用できます。


) BFD per-link モードとサブインターフェイス最適化をレイヤ 3 ポート チャネルで同時に使用することはサポートされていません。


IPv4 に対する HSRP は、BFD でサポートされます。IPv6 に対する HSRP は、BFD でサポートされていません。

サポートされている Cisco NX-OS デバイス ラインカードによって生成される BFD パケットは COS 6/DSCP CS6 とともに送信されます。BFD パケットの DSCP/COS 値は、ユーザが設定可能な値ではありません。

デフォルト設定値

表 5-1 に、BFD パラメータのデフォルト設定を示します。

 

表 5-1 デフォルトの BFD パラメータ

パラメータ(Parameters)
デフォルト

BFD 機能

ディセーブル

必要最小受信間隔

50 ミリ秒

目的の最小送信間隔

50 ミリ秒

検出乗数

3

エコー機能

イネーブル

モード

非同期

ポート チャネル

論理モード(送信元/宛先ペアのアドレスごとに 1 セッション)。

slow timer

2000 ミリ秒

サブインターフェイスの最適化

ディセーブル

BFD の設定

この項では、次のトピックについて取り上げます。

「設定階層」

「BFD 設定のタスク フロー」

「BFD 機能のイネーブル化」

「グローバルな BFD パラメータの設定」

「インターフェイスでの BFD の設定」

「ポート チャネルの BFD の設定」

「BFD エコー機能の設定」

「サブインターフェイスの BFD の最適化」

「ルーティング プロトコルに対する BFD サポートの設定」

設定階層

グローバル レベル、およびインターフェイスまたはサブインターフェイス レベルで BFD を設定できます(物理インターフェイスとポート チャネルの場合)。インターフェイスまたはサブインターフェイスの設定は、グローバル コンフィギュレーションよりも優先されます。サポートされているインターフェイス上で、サブインターフェイス レベルの設定は、サブインターフェイスの最適化がイネーブルになっていない限りインターフェイスまたはポート チャネル設定よりも優先されます。詳細については、「サブインターフェイスの BFD の最適化」を参照してください。


) BFD per-link モードとサブインターフェイス最適化をレイヤ 3 ポート チャネルで同時に使用することはサポートされていません。


ポート チャネルのメンバである物理ポートについては、メンバ ポートはマスター ポート チャネルの BFD 設定を継承します。メンバ ポート サブインターフェイスは、サブインターフェイスの最適化がイネーブルになっていない限りマスター ポート チャネルの BFD 設定より優先することができます。

BFD 設定のタスク フロー

BFD の設定には、次の作業を行います。


ステップ 1 BFD 機能のイネーブル化

ステップ 2 グローバルな BFD パラメータの設定または インターフェイスでの BFD の設定

ステップ 3 ルーティング プロトコルに対する BFD サポートの設定


 

BFD 機能のイネーブル化

デバイス(VDC)内のインターフェイスおよびプロトコルで BFD を設定する前に、BFD 機能をイネーブルにする必要があります。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. feature bfd

3. (任意) show feature | include bfd

4. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

feature bfd

 

例:

switch(config)# feature bfd

BFD 機能をイネーブルにします。

ステップ 3

show feature | include bfd

 

例:

switch(config)# show feature | include bfd

(任意)イネーブルおよびディセーブルにされた機能を表示します。

ステップ 4

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

no feature bfd コマンドを使用して、BFD 機能をディセーブルにし、関連するコンフィギュレーションをすべて削除します。

 

コマンド
目的

no feature bfd

 

例:

switch(config)# no feature bfd

BFD 機能をディセーブルにして、関連するすべての設定を削除します。

グローバルな BFD パラメータの設定

デバイスのすべての BFD セッションの BFD セッション パラメータを設定できます。BFD セッション パラメータは、スリーウェイ ハンドシェイクの BFD ピア間でネゴシエートされます。

インターフェイスのグローバルなセッション パラメータを無効にするには、「インターフェイスでの BFD の設定」を参照してください。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

BFD 機能をイネーブルにします。「BFD 機能のイネーブル化」を参照してください。

手順の概要

1. configure terminal

2. bfd interval mintx min_rx msec multiplier value

3. bfd slow-timer [ interval ]

4. (任意)show running-config bfd

5. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

bfd interval mintx min_rx msec multiplier value

 

例:

switch(config)# bfd interval 50 min_rx 50 multiplier 3

デバイスのすべての BFD セッションの BFD セッション パラメータを設定します。インターフェイスで BFD セッション パラメータを設定することにより、これらの値を無効にすることができます。 mintx および msec の範囲は 50 ~ 999 ミリ秒で、デフォルトは 50 です。乗数の範囲は 1 ~ 50 です。乗数のデフォルトは 3 です。

ステップ 3

bfd slow-timer [ interval ]

 

例:

switch(config)# bfd slow-timer 2000.

エコー機能で使用される slow timer を設定します。この値はエコー機能がイネーブルの場合、BFD が新しいセッションを開始する速度および非同期セッションが BFD 制御パケットに使用する速度を決定します。slow-timer 値は新しい制御パケット間隔として使用されますが、エコー パケットは設定された BFD 間隔を使用します。エコー パケットはリンク障害検出に使用されますが、低速の制御パケットは BFD セッションを維持します。指定できる範囲は 1000 ~ 30000 ミリ秒です。デフォルトは 2000 です。

ステップ 4

show running-config bfd

 

例:

switch(config)# show running-config bfd

(任意)BFD 実行コンフィギュレーションを表示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

インターフェイスでの BFD の設定

インターフェイスのすべての BFD セッションの BFD セッション パラメータを設定できます。BFD セッション パラメータは、スリーウェイ ハンドシェイクの BFD ピア間でネゴシエートされます。

この設定は、設定されたインターフェイスのグローバル セッション パラメータより優先されます。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

BFD 機能をイネーブルにします。「BFD 機能のイネーブル化」を参照してください。

手順の概要

1. configure terminal

2. interface int-if

3. bfd interval mintx min_rx msec multiplier value

4. (任意) bfd authentication keyed-sha1 keyid id key ascii_key

5. (任意)show running-config bfd

6. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

interface int-if

 

例:

switch(config)# interface ethernet 2/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。 ? サポートされているインターフェイスを表示します。

ステップ 3

bfd interval mintx min_rx msec multiplier value

 

例:

switch(config-if)# bfd interval 50 min_rx 50 multiplier 3

インターフェイスのすべての BFD セッションの BFD セッション パラメータを設定します。これはグローバルな BFD セッション パラメータより優先されます。 mintx および msec の範囲は 50 ~ 999 ミリ秒で、デフォルトは 50 です。乗数の範囲は 1 ~ 50 です。乗数のデフォルトは 3 です。

ステップ 4

bfd authentication keyed-sha1 keyid id key ascii_key

 

例:

switch(config-if)# bfd authentication keyed-sha1 keyid 1 ascii_key cisco123

(任意)インターフェイス上のすべての BFD セッションの SHA-1 認証を設定します。 ascii_key 文字列は BFD ピア間で共有される秘密キーです。0 ~ 255 の数値の id 値が、この特定の ascii_key に割り当てられます。BFD パケットは id でキーを指定し、複数のアクティブ キーが使用できます。

インターフェイスの SHA-1 認証をディセーブルにするには、コマンドの no 形式を使用します。

ステップ 5

show running-config bfd

 

例:

switch(config-if)# show running-config bfd

(任意)BFD 実行コンフィギュレーションを表示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

ポート チャネルの BFD の設定

ポート チャネルのすべての BFD セッションの BFD セッション パラメータを設定できます。パーリンク モードがレイヤ 3 ポート チャネルに使用される場合、BFD により、ポート チャネルの各リンクのセッションが作成され、集約結果がクライアント プロトコルへ提供されます。たとえば、ポート チャネルの 1 つのリンクの BFD セッションが稼働している場合、OSPF などのクライアント プロトコルにポート チャネルが稼働していることが通知されます。BFD セッション パラメータは、スリーウェイ ハンドシェイクの BFD ピア間でネゴシエートされます。

この設定は、設定されたポート チャネルのグローバル セッション パラメータより優先されます。ポート チャネルのメンバ ポートはメンバ ポートのサブインターフェイス レベルで BFD パラメータを設定しない限り、ポート チャネルの BFD セッション パラメータを継承します。その場合、サブインターフェイス最適化がイネーブルにされていなければ、メンバ ポート サブインターフェイスはサブインターフェイス BFD コンフィギュレーションを使用します。詳細については、「サブインターフェイスの BFD の最適化」を参照してください。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

BFD をイネーブルにする前に、ポート チャネルの Link Aggregation Control Protocol(LACP)がイネーブルにされていることを確認します。

BFD 機能をイネーブルにします。「BFD 機能のイネーブル化」を参照してください。

手順の概要

1. configure terminal

2. interface port-channel number

3. bfd per-link

4. (任意) bfd interval mintx min_rx msec multiplier value

5. (任意) bfd authentication keyed-sha1 keyid id key ascii_key

6. (任意)show running-config bfd

7. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

interface port-channel number

 

例:

switch(config)# interface port-channel 2

switch(config-if)#

ポート チャネル コンフィギュレーション モードを開始します。 ? キーワードを使用してサポートされている番号の範囲を表示します。

ステップ 3

bfd per-link

 

例:

switch(config-if)# bfd per-link

ポート チャネルのリンクごとに BFD セッションを設定します。

ステップ 4

bfd interval mintx min_rx msec multiplier value

 

例:

switch(config-if)# bfd interval 50 min_rx 50 multiplier 3

(任意)ポート チャネルのすべての BFD セッションの BFD セッション パラメータを設定します。これはグローバルな BFD セッション パラメータより優先されます。 mintx および msec の範囲は 50 ~ 999 ミリ秒で、デフォルトは 50 です。乗数の範囲は 1 ~ 50 です。乗数のデフォルトは 3 です。

ステップ 5

bfd authentication keyed-sha1 keyid id key ascii_key

 

例:

switch(config-if)# bfd authentication keyed-sha1 keyid 1 ascii_key cisco123

(任意)インターフェイス上のすべての BFD セッションの SHA-1 認証を設定します。 ascii_key 文字列は BFD ピア間で共有される秘密キーです。0 ~ 255 の数値の id 値が、この特定の ascii_key に割り当てられます。BFD パケットは id でキーを指定し、複数のアクティブ キーが使用できます。

インターフェイスの SHA-1 認証をディセーブルにするには、コマンドの no 形式を使用します。

ステップ 6

show running-config bfd

 

例:

switch(config-if)# show running-config bfd

(任意)BFD 実行コンフィギュレーションを表示します。

ステップ 7

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

BFD エコー機能の設定

BFD モニタ対象リンクの一端または両端で BFD エコー機能を設定できます。エコー機能は設定された slow timer に基づいて必要最小受信間隔を遅くします。RequiredMinEchoRx BFD セッション パラメータは、エコー機能がディセーブルの場合、ゼロに設定されます。slow timer は、エコー機能がイネーブルの場合、必要最小受信間隔になります。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

BFD 機能をイネーブルにします。「BFD 機能のイネーブル化」を参照してください。

BFD セッション パラメータを設定します。(「グローバルな BFD パラメータの設定」 または 「インターフェイスでの BFD の設定」 を参照)。

インターネット制御メッセージ プロトコル(ICMP)のリダイレクト メッセージが BFD 対応インターフェイスでディセーブルであることを確認します。インターフェイスで no ip redirects コマンドを使用します。

同一の送信元アドレスおよび宛先アドレスを調べる IP パケット検証チェックがディセーブルになっていることを確認します。デフォルト VDC では no hardware ip verify address identical コマンドを使用します。このコマンドの詳細については、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x 』を参照してください。

手順の概要

1. configure terminal

2. bfd slow-timer echo-interval

3. interface int-if

4. bfd echo

5. (任意)show running-config bfd

6. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

bfd slow-timer echo-interval

 

例:

switch(config)# bfd slow-timer 2000

エコー機能で使用される slow timer を設定します。この値は BFD が新しいセッションを開始する速度を決定し、BFD エコー機能がイネーブルの場合に非同期セッションの速度を低下させるために使用されます。この値は、エコー機能がイネーブルの場合、必要最小受信間隔より優先されます。指定できる範囲は 1000 ~ 30000 ミリ秒です。デフォルトは 2000 です。

ステップ 3

interface int-if

 

例:

switch(config)# interface ethernet 2/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。 ? サポートされているインターフェイスを表示します。

ステップ 4

bfd echo

 

例:

switch(config-if)# bfd echo

エコー機能をイネーブルにします。デフォルトではイネーブルになっています。

ステップ 5

show running-config bfd

 

例:

switch(config-if)# show running-config bfd

(任意)BFD 実行コンフィギュレーションを表示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

サブインターフェイスの BFD の最適化

サブインターフェイスで BFD を最適化できます。BFD により、設定されているすべてのサブインターフェイスのセッションが作成されます。BFD により、設定されている最小の VLAN ID を持つサブインターフェイスがマスター サブインターフェイスとして設定され、そのサブインターフェイスは親インターフェイスの BFD セッション パラメータを使用します。残りのサブインターフェイスは slow timer を使用します。最適化されたサブインターフェイス セッションでエラーが検出されると、BFD により、その物理インターフェイスのすべてのサブインターフェイスがダウンとマークされます。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

BFD 機能をイネーブルにします。「BFD 機能のイネーブル化」を参照してください。

BFD セッション パラメータを設定します。(「グローバルな BFD パラメータの設定」 または 「インターフェイスでの BFD の設定」 を参照)。

これらのサブインターフェイスが別の Cisco NX-OS デバイスに接続するようにしてください。この機能は、Cisco NX-OS でだけサポートされます。

手順の概要

1. configure terminal

2. interface int-if

3. bfd optimize subinterface

4. (任意)show running-config bfd

5. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

interface int-if

 

例:

switch(config)# interface ethernet 2/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。 ? サポートされているインターフェイスを表示します。

ステップ 3

bfd optimize subinterface

 

例:

switch(config-if)# bfd optimize subinterface

BFD 対応インターフェイスのサブインターフェイスを最適化します。デフォルトではディセーブルになっています。

ステップ 4

show running-config bfd

 

例:

switch(config-if)# show running-config bfd

(任意)BFD 実行コンフィギュレーションを表示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

BGP での BFD の設定

ボーダー ゲートウェイ プロトコル(BGP)の BFD を設定できます。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

BFD 機能をイネーブルにします。「BFD 機能のイネーブル化」を参照してください。

BFD セッション パラメータを設定します。(「グローバルな BFD パラメータの設定」 または 「インターフェイスでの BFD の設定」 を参照)。

BGP 機能をイネーブルにします。詳細については、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x 』を参照してください。

手順の概要

1. configure terminal

2. router bgp as-number

3. neighbor { ip-address | ipv6-address } remote-as as-number

4. bfd

5. (任意)show running-config bgp

6. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

router bgp as-number

 

例:

switch(config)# router bgp 64496

switch(config-router)#

BGP をイネーブルにして、ローカル BGP スピーカに AS 番号を割り当てます。AS 番号は 16 ビット整数または 32 ビット整数にできます。上位 16 ビット 10 進数と下位 16 ビット 10 進数による xx.xx という形式です。

ステップ 3

neighbor { ip-address | ipv6-address } remote-as as-number

 

例:

switch(config-router)# neighbor 209.165.201.1 remote-as 64497

switch(config-router-neighbor)#

リモート BGP ピアの IPv4 アドレスまたは IPv6 アドレスおよび AS 番号を設定します。 ip-address の形式は x.x.x.x です。 ipv6-address の形式は A:B::C:D です。

ステップ 4

bfd

 

例:

switch(config-router-neighbor)# bfd

この BGP ピアの BFD をイネーブルにします。

ステップ 5

show running-config bgp

 

例:

switch(config-router-neighbor)# show running-config bgp

(任意)BGP 実行コンフィギュレーションを表示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config-router-neighbor)# copy running-config startup-config

(任意)この設定の変更を保存します。

EIGRP 上での BFD の設定

Enhanced Interior Gateway Routing Protocol(EIGRP)で BFD を設定できます。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

BFD 機能をイネーブルにします。「BFD 機能のイネーブル化」を参照してください。

BFD セッション パラメータを設定します。(「グローバルな BFD パラメータの設定」 または 「インターフェイスでの BFD の設定」 を参照)。

EIGRP 機能をイネーブルにします。詳細については、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x 』を参照してください。

手順の概要

1. configure terminal

2. router eigrp instance-tag

3. bfd

4. interface int-if

5. (任意)ip eigrp instance-tag bfd

6. (任意) show ip eigrp [ vrf vrf-name ] [ interfaces if ]

7. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

router eigrp instance-tag

 

例:

switch(config)# router eigrp Test1

switch(config-router)#

インスタンス タグを設定して、新しい EIGRP プロセスを作成します。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

AS 番号であると認められていない instance-tag を設定する場合は、 autonomous-system コマンドを使用して AS 番号を明示的に設定する必要があります。そうしないと、この EIGRP インスタンスはシャットダウン状態のままになります。

ステップ 3

bfd

 

例:

switch(config-router-neighbor)# bfd

(任意)すべての EIGRP インターフェイスの BFD をイネーブルにします。

ステップ 4

interface int-if

 

例:

switch(config-router-neighbor)# interface ethernet 2/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。 ? サポートされているインターフェイスを表示します。

ステップ 5

ip eigrp instance-tag bfd

 

例:

switch(config-if)# ip eigrp Test1 bfd

(任意)EIGRP インターフェイスの BFD をイネーブルまたはディセーブルにします。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

デフォルトではディセーブルになっています。

ステップ 6

show ip eigrp [ vrf vrf-name ] [ interfaces if ]

 

例:

switch(config-if)# show ip eigrp

(任意)EIGRP に関する情報を表示します。vrf-name には最大 32 文字の英数字文字列を指定します。大文字と小文字は区別されます。

ステップ 7

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

OSPF での BFD の設定

Open Shortest Path First バージョン 2(OSPFv2)で BFD を設定できます。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

BFD 機能をイネーブルにします。「BFD 機能のイネーブル化」を参照してください。

BFD セッション パラメータを設定します。(「グローバルな BFD パラメータの設定」 または 「インターフェイスでの BFD の設定」 を参照)。

OSPF 機能をイネーブルにします。詳細については、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x 』を参照してください。

手順の概要

1. configure terminal

2. router ospf instance-tag

3. bfd

4. interface int-if

5. (任意) if ospf bfd

6. (任意)show ip ospf [ vrf vrf-name ] [ interface if ]

7. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

router ospf instance-tag

 

例:

switch(config)# router ospf 201

switch(config-router)#

新規 OSPFv2 インスタンスを作成して、設定済みのインスタンス タグを割り当てます。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

ステップ 3

bfd

 

例:

switch(config-router)# bfd

(任意)すべての OSPFv2 インターフェイスの BFD をイネーブルにします。

ステップ 4

interface int-if

 

例:

switch(config-router)# interface ethernet 2/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。 ? サポートされているインターフェイスを表示します。

ステップ 5

ip ospf bfd

 

例:

switch(config-if)# ip ospf 201 bfd

(任意)OSPFv2 インターフェイスの BFD をイネーブルまたはディセーブルにします。デフォルトではディセーブルになっています。

ステップ 6

show ip ospf [ vrf vrf-name ] [ interface if ]

 

例:

switch(config-if)# show ip ospf

(任意)OSPF に関する情報を表示します。vrf-name には最大 32 文字の英数字文字列を指定します。大文字と小文字は区別されます。

ステップ 7

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

IS-IS での BFD の設定

Intermediate System-to-Intermediate System(IS-IS)プロトコルで BFD を設定できます。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

BFD 機能をイネーブルにします。「BFD 機能のイネーブル化」を参照してください。

BFD セッション パラメータを設定します。(「グローバルな BFD パラメータの設定」 または 「インターフェイスでの BFD の設定」 を参照)。

IS-IS 機能をイネーブルにします。詳細については、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x 』を参照してください。

手順の概要

1. configure terminal

2. router isis instance-tag

3. bfd

4. interface int-if

5. (任意) isis bfd

6. (任意)show isis [vrf vrf-name ] [interface if ]

7. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

router isis instance-tag

 

例:

switch(config)# router isis Enterprise

switch(config-router)#

instance tag を設定して、新しい IS-IS インスタンスを作成します。

ステップ 3

bfd

 

例:

switch(config-router)# bfd

(任意)すべての OSPFv2 インターフェイスの BFD をイネーブルにします。

ステップ 4

interface int-if

 

例:

switch(config-router)# interface ethernet 2/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。 ? サポートされているインターフェイスを表示します。

ステップ 5

isis bfd

 

例:

switch(config-if)# isis bfd

(任意)IS-IS インターフェイスの BFD をイネーブルまたはディセーブルにします。デフォルトではディセーブルになっています。

ステップ 6

show isis [ vrf vrf-name ] [ interface if ]

 

例:

switch(config-if)# showisis

(任意)IS-IS に関する情報を表示します。vrf-name には最大 32 文字の英数字文字列を指定します。大文字と小文字は区別されます。

ステップ 7

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

HSRP での BFD の設定

ホットスタンバイ ルータ プロトコル(HSRP)の BFD を設定できます。アクティブおよびスタンバイの HSRP ルータは BFD を介して相互に追跡しています。スタンバイ HSRP ルータ上の BFD がアクティブ HSRP ルータが動作していないことを検知すると、スタンバイ HSRP はこのイベントをアクティブ タイマー失効として取り扱いアクティブ HSRP ルータとして役割を引き継ぎます。

show hsrp detail では、このイベントが BFD@Act-down または BFD@Sby-down として表示されます。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

BFD 機能をイネーブルにします。「BFD 機能のイネーブル化」を参照してください。

BFD セッション パラメータを設定します。(「グローバルな BFD パラメータの設定」 または 「インターフェイスでの BFD の設定」 を参照)。

HSRP 機能をイネーブルにします。詳細については、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x 』を参照してください。

手順の概要

1. configure terminal

2. hsrp bfd all-interfaces

3. interface int-if

4. (任意)hsrp bfd

5. (任意)show running-config hsrp

6. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 1

hsrp bfd all-interfaces

 

例:

switch# hsrp bfd all-interfaces

(任意)すべての HSRP インターフェイスで BFD をイネーブルまたはディセーブルにします。デフォルトではディセーブルになっています。

ステップ 2

interface int-if

 

例:

switch(config)# interface ethernet 2/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。 ? サポートされているインターフェイスを表示します。

ステップ 3

hsrp bfd

 

例:

switch(config-if)# hsrp bfd

(任意)HSRP インターフェイスの BFD をイネーブルまたはディセーブルにします。デフォルトではディセーブルになっています。

ステップ 4

show running-config hsrp

 

例:

switch(config-if)# show running-config hsrp

(任意)HSRP 実行コンフィギュレーションを表示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

VRRP での BFD の設定

想ルータ冗長プロトコル(VRRP)の BFD を設定できます。アクティブおよびスタンバイの VRRP ルータは BFD を介して相互に追跡しています。スタンバイ VRRP ルータ上の BFD がアクティブ VRRP ルータが動作していないことを検知すると、スタンバイ VRRP はこのイベントをアクティブ タイマー失効として取り扱いアクティブ VRRP ルータとして役割を引き継ぎます。

show vrrp detail では、このイベントが BFD@Act-down または BFD@Sby-down として表示されます。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

BFD 機能をイネーブルにします。「BFD 機能のイネーブル化」を参照してください。

BFD セッション パラメータを設定します。(「グローバルな BFD パラメータの設定」 または 「インターフェイスでの BFD の設定」 を参照)。

VRRP 機能をイネーブルにします。詳細については、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x 』を参照してください。

手順の概要

1. configure terminal

2. interface int-if

3. vrrp bfd

4. (任意)show running-config vrrp

5. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

interface int-if

 

例:

switch(config)# interface ethernet 2/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。 ? サポートされているインターフェイスを表示します。

ステップ 3

vrrp bfd

 

例:

switch(config-if)# vrrp bfd

VRRP インターフェイスで BFD をイネーブルまたはディセーブルにします。デフォルトではディセーブルになっています。

ステップ 4

show running-config vrrp

 

例:

switch(config-if)# show running-config vrrp

(任意)VRRP 実行コンフィギュレーションを表示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

Protocol Independent Multicast(PIM)上での BFD の設置

Protocol Independent Multicast(PIM)で BFD を設定できます。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

BFD 機能をイネーブルにします。「BFD 機能のイネーブル化」を参照してください。

PIM 機能をイネーブルにします。詳細については、『 Cisco Nexus 7000 Series NX-OS Multicast Routing Configuration Guide, Release 5.x 』を参照してください。

手順の概要

1. configure terminal

2. ip pim bfd

3. interface if-type

4. (任意)ip pim bfd-instance [ disable ]

5. (任意) show running-config pim

6. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

ip pim bfd

 

switch(config)# ip pim bfd

PIM の BFD をイネーブルにします。

ステップ 3

interface int-if

 

例:

switch(config)# interface ethernet 2/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。 ? キーワードを使用してサポートされている番号の範囲を表示します。

ステップ 4

ip pim bfd-instance [ disable ]

 

例:

switch(config-if)# ip pim bfd-instance

(任意)PIM インターフェイスの BFD をイネーブルまたはディセーブルにします。デフォルトではディセーブルになっています。

ステップ 5

show running-config pim

 

例:

switch(config)# show running-config pim

(任意)PIM 実行コンフィギュレーションを表示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

スタティック ルートでの BFD の設定

インターフェイスのスタティック ルータの BFD を設定できます。仮想ルーティングおよび転送(VRF)インスタンス内のスタティック ルートでの BFD を任意で設定できます。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

BFD 機能をイネーブルにします。「BFD 機能のイネーブル化」を参照してください。

手順の概要

1. configure terminal

2. (任意) vrf context vrf-name

3. ip route route interface if { nh-address | nh-prefix }

4. ip route static bfd interface { nh-address | nh-prefix }

5. (任意)show ip route static [ vrf vrf-name ]

6. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

vrf context vrf-name

 

例:

switch(config)# vrf context Red

switch(config-vrf)#

(任意)VRF コンフィギュレーション モードを開始します。

ステップ 3

ip route route interface { nh-address | nh-prefix }

 

switch(config-vrf)# ip route 192.0.2.1 ethernet 2/1 192.0.2.4

スタティック ルートを作り「 ? 」を使用します。サポートされているインターフェイスを表示します。

ステップ 4

ip route static bfd interface { nh-address | nh-prefix }

 

switch(config-vrf)# ip route static bfd ethernet 2/1 192.0.2.4

インターフェイスのすべてのスタティック ルートの BFD をイネーブルにします。 ? サポートされているインターフェイスを表示します。

ステップ 5

show ip route static [ vrf vrf-name ]

 

例:

switch(config-vrf)# show ip route static vrf Red

(任意)スタティック ルートを表示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config-vrf)# copy running-config startup-config

(任意)この設定の変更を保存します。

MPLS TE 高速再ルーティングの BFD 設定

MPLS トラフィック エンジニアリング(TE)は BFD を使用して、ノード障害の検出を高速化し、転送パス障害の検出時間を短縮します。MPLS TE 高速再ルーティングの BFD は、トンネルで高速再ルーティングをイネーブルにすると自動的に設定されます。詳細については、『 Cisco Nexus 7000 Series NX-OS Multiprotocol Label Switching Configuration Guide, Release 5.x 』の「Configuring MPLS TE Fast Reroute Link and Node Protection(MPLS TE 高速再ルーティングのリンクおよびノード保護の設定)」の章を参照してください。

インターフェイスにおける BFD のディセーブル化

グローバルまたは VRF レベルで BFD がイネーブルになっているルーティング プロトコルのインターフェイスで BFD を選択的にディセーブルにできます。

インターフェイスで BFD をディセーブルにするには、インターフェイス コンフィギュレーション モードで次のコマンドのいずれかを使用します。

コマンド
目的

ip eigrp instance-tag bfd disable

 

例:

switch(config-if)# ip eigrp Test1 bfd disable

EIGRP インターフェイスで BFD をディセーブルにします。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

ip ospf bfd disable

 

例:

switch(config-if)# ip ospf 201 bfd disable

OSPFv2 インターフェイスで BFD をディセーブルにします。

isis bfd disable

 

例:

switch(config-if)# isis bfd disable

IS-IS インターフェイスで BFD をディセーブルにします。

BFD 設定の確認

BFD 設定情報を表示するには、次の作業のいずれかを行います。

コマンド
目的

show running-config bfd

実行 BFD コンフィギュレーションを表示します。

show startup-config bfd

次のシステム起動時に適用される BFD コンフィギュレーションを表示します。

これらのコマンド出力のフィールドの詳細については、『 Cisco Nexus 7000 Series NX-OS Interfaces Command Reference, Release 5.x を参照してください。

BFD のモニタ

BFD を表示するには、次のコマンドを使用します。

 

コマンド
目的

show bfd neighbors [ application name ] [ details ]

BGP や OSPFv2 などのサポートされるアプリケーションの BFD に関する情報を表示します。

show bfd neighbors [ interface int-if ] [ details ]

インターフェイスの BGP セッションに関する情報を表示します。

show bfd neighbors [ dest-ip ip-address ] [ src-ip ip-address ][ details ]

インターフェイス上の指定された BGP セッションに関する情報を表示します。

show bfd neighbors [ vrf vrf-name ] [ details ]

VRF の BFD に関する情報を表示します。

これらのコマンド出力のフィールドの詳細については、『 Cisco Nexus 7000 Series NX-OS Interfaces Command Reference, Release 5.x 』を参照してください。

BFD の設定例

次に、デフォルト BFD セッション パラメータを使用した、Ethernet 2/1 上の OSPFv2 の BFD 設定例を示します。

feature bfd
feature ospf
router ospf Test1
interface ethernet 2/1
  ip ospf bfd
no shutdown
 

次に、デフォルト BFD セッション パラメータを使用した、EIGRP インターフェイスの BFD 設定例を示します。

feature bfd
feature eigrp
bfd interval 100 min_rx 100 multiplier 4
router eigrp Test2
 bfd

その他の関連資料

BFD の実装に関する詳細は、次の各項を参照してください。

「関連資料」

「RFC」

「BFD の機能の履歴」

関連資料

関連項目
マニュアル タイトル

BFD コマンド

詳細については、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x 』を参照してください。

RFC

RFC
タイトル

RFC 5880

双方向フォワーディング検出(BFD)

RFC 5881

『BFD for IPv4 and IPv6 (Single Hop)』

BFD の機能の履歴

表 5-2 に、この機能のリリース履歴を示します。

 

表 5-2 BFD 機能の履歴

機能名
リリース
機能情報

BFD 認証

5.2(1)

キー付き SHA-1 認証は BFD パケットでサポートされます。

VRRP 用 BFD

5.2(1)

VRRP の BFD のサポートが追加されました。

BFD

5.0(2)

この機能が導入されました。