Cisco Nexus 7000 シリーズ NX-OS ユニキャスト ルーティング コンフィギュレーション ガイド リリース 6.x
VRRP の設定
VRRP の設定
発行日;2015/03/23 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 10MB) | フィードバック

目次

VRRP の設定

機能情報の確認

VRRP の概要

VRRP の動作

VRRP の利点

マルチ VRRP グループ

VRRP ルータのプライオリティおよびプリエンプション

vPC および VRRP

VRRP のアドバタイズメント

VRRP 認証

VRRP トラッキング

BFD

ハイ アベイラビリティ

仮想化のサポート

VRRPv3 について

VRRPv3 の利点

VRRS

VRRPv3 での VRRS の使用

ハイ アベイラビリティ

VRRP のライセンス要件

VRRP の注意事項と制約事項

VRRPv3 の注意事項と制約事項

デフォルト設定値

VRRP の設定

VRRP 機能のイネーブル化

VRRP グループの設定

VRRP プライオリティの設定

VRRP 認証の設定

アドバタイズメント パケットのタイム インターバル設定

プリエンプションのディセーブル化

VRRP インターフェイス ステート トラッキングの設定

VRRPv3 の設定

VRRPv3 機能のイネーブル化

VRRPv3 グループの作成

FHRP クライアントの初期化の遅延時間の設定

VRRPv3 制御グループの設定

VRRS 経路の設定

VRRP の設定確認

VRRP 統計情報のモニタリング

VRRP の設定例

VRRPv3 の設定例

その他の関連資料

関連資料

VRRP 機能の履歴

VRRP の設定

この章では、Cisco NX-OS デバイスで仮想ルータ冗長プロトコル(VRRP)を設定する方法について説明します。

この章は、次の項で構成されています。

「機能情報の確認」

「VRRP の概要」

「VRRPv3 について」

「VRRP のライセンス要件」

「VRRP の注意事項と制約事項」

「デフォルト設定値」

「VRRP の設定」

「VRRPv3 の設定」

「VRRP の設定確認」

「VRRP 統計情報のモニタリング」

「VRRP の設定例」

「VRRPv3 の設定例」

「その他の関連資料」

「VRRP 機能の履歴」

機能情報の確認

ご使用のソフトウェア リリースで、このモジュールで説明されるすべての機能がサポートされているとは限りません。最新の警告および機能情報については、 https://tool.cisco.com/bugsearch/ の Bug Search Tool およびご使用のソフトウェア リリースのリリース ノートを参照してください。このモジュールに記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「新機能および変更された機能に関する情報」の項または以下の「機能の履歴」表を参照してください。

VRRP の概要

VRRP を使用すると、仮想 IP アドレスを共有するルータ グループを設定することによって、ファーストホップ IP ルータで透過的フェールオーバーが可能になります。VRRP ではそのグループのマスター ルータが選択され、仮想 IP アドレスへのすべてのパケットが処理できるようになります。残りのルータはスタンバイになり、マスター ルータで障害が発生した場合に処理を引き継ぎます。

この項では、次のトピックについて取り上げます。

「VRRP の動作」

「VRRP の利点」

「マルチ VRRP グループ」

「VRRP ルータのプライオリティおよびプリエンプション」

「vPC および VRRP」

「VRRP のアドバタイズメント」

「VRRP 認証」

「VRRP トラッキング」

「BFD」

「VRRPv3 は、ステートフル スイッチオーバーをサポートしていません。」

「仮想化のサポート」

VRRP の動作

LAN クライアントは、ダイナミック プロセスまたはスタティック設定を使用することによって、特定のリモート宛先へのファーストホップにするルータを決定できます。ダイナミック ルータ ディスカバリの例を示します。

プロキシ ARP:クライアントはアドレス解決プロトコル(ARP)を使用して到達すべき宛先を取得します。ルータは独自の MAC アドレスで ARP 要求に応答します。

ルーティング プロトコル:クライアントはダイナミック ルーティング プロトコルのアップデートを(ルーティング情報プロトコル(RIP)などから)受信し、独自のルーティング テーブルを形成します。

ICMP Router Discovery Protocol(IRDP)クライアント:クライアントはインターネット制御メッセージ プロトコル(ICMP)ルータ ディスカバリ クライアントを実行します。

ダイナミック ディスカバリ プロトコルのデメリットは、LAN クライアントにある程度、設定および処理のオーバーヘッドが発生することです。また、ルータが故障した場合、他のルータに切り替えるプロセスも遅くなる場合があります。

ダイナミック ディスカバリ プロトコルの代わりに、クライアント上でデフォルト ルータをスタティックに設定することもできます。この方法を使用すると、クライアントの設定および処理が簡素化されますが、シングルポイント障害が生じます。デフォルト ゲートウェイで障害が発生した場合、LAN クライアントの通信はローカル IP ネットワーク セグメントに限定され、ネットワークの他の部分から切り離されます。

VRRP では、ルータ グループ(VRRP グループ)が単一の仮想 IP アドレスを共有できるようにすることによって、スタティック設定に伴う問題を解決できます。さらに、デフォルト ゲートウェイとして仮想 IP アドレスを指定して、LAN クライアントを設定できます。

図 21-1 に、基本的な VLAN トポロジを示します。この例では、ルータ A、B、および C が VRRP グループを形成します。グループの IP アドレスは、ルータ A のイーサネット インターフェイスに設定されているアドレス(10.0.0.1)と同じです。

図 21-1 基本的な VRRP トポロジ

 

仮想 IP アドレスにルータ A の物理イーサネット インターフェイスの IP アドレスを使用するので、ルータ A がマスター(別名、 IP アドレス オーナー )です。ルータ A はマスターとして、VRRP グループの仮想 IP アドレスを所有し、送信されたパケットをこの IP アドレスに転送します。クライアント 1 ~ 3 には、デフォルト ゲートウェイの IP アドレス 10.0.0.1 が設定されています。

ルータ B および C の役割はバックアップです。マスターで障害が発生すると、プライオリティが最も高いバックアップ ルータがマスターになり、仮想 IP アドレスを引き継いで、LAN ホストへのサービスが途切れないようにします。ルータ A が回復すると、そのルータが再びマスターになります。詳細については、「VRRP ルータのプライオリティおよびプリエンプション」の項を参照してください。


) Cisco NX-OS Release 4.1(2) 以降では、VRRP 仮想 IP アドレス宛のルーテッド ポートで受信したパケットはローカル ルータで終端します。この処理は、そのルータがマスタ VRRP ルータであってもバックアップ VRRP ルータであっても同様に行われます。これには ping トラフィックと Telnet トラフィックが含まれます。VRRP 仮想 IP アドレス宛のレイヤ 2(VLAN)インターフェイスで受信したパケットは、マスター ルータで終端します。


VRRP の利点

VRRP の利点は、次のとおりです。

冗長性:複数のルータをデフォルト ゲートウェイ ルータとして設定できるので、ネットワークにシングル ポイント障害が発生する確率が下がります。

ロード シェアリング:複数のルータで LAN クライアントとの間のトラフィックを分担できます。トラフィックの負荷が使用可能なルータ間でより公平に分担されます。

マルチ VRRP グループ:プラットフォームが複数の MAC アドレスをサポートする場合、ルータの物理インターフェイス上で、複数の VRRP グループをサポートします。マルチ VRRP グループによって、LAN トポロジで冗長性およびロード シェアリングを実現できます。

マルチ IP アドレス:セカンダリ IP アドレスを含めて、複数の IP アドレスを管理できます。イーサネット インターフェイス上で複数のサブネットを設定している場合は、各サブネットで VRRP を設定できます。

プリエンプト:障害マスターを引き継いでいたバックアップ ルータより、さらにプライオリティが高いバックアップ ルータが使用可能になったときに、プライオリティが高い方を優先させることができます。

アドバタイズメント プロトコル:VRRP アドバタイズメントに、専用のインターネット割り当て番号局(IANA)規格マルチキャスト アドレス(224.0.0.18)を使用します。このアドレッシング方式によって、マルチキャストを提供するルータ数が最小限になり、テスト機器でセグメント上の VRRP パケットを正確に識別できるようになります。IANA は VRRP に IP プロトコル番号 112 を割り当てています。

VRRP トラッキング:インターフェイスのステートに基づいて VRRP プライオリティを変更することによって、最適な VRRP ルータがグループのマスターになることが保証されます。

マルチ VRRP グループ

物理インターフェイス上で複数の VRRP グループを設定できます。サポートされる VRRP グループの数については、『 Cisco Nexus 7000 Series NX-OS Verified Scalability Guide 』を参照してください。

ルータ インターフェイスがサポートできる VRRP グループの数は、次の要因によって決まります。

ルータの処理能力

ルータのメモリの能力

ルータ インターフェイス上で複数の VRRP グループが設定されたトポロジでは、インターフェイスはある VRRP グループのマスター、および他の 1 つまたは複数の VRRP グループのバックアップとして動作可能です。

図 21-2 に、ルータ A および B がクライアント 1 ~ 4 との間でトラフィックを共有するように VRRP が設定されている LAN トポロジを示します。ルータ A と B の一方で障害が発生した場合、もう一方がバックアップとして機能します。

図 21-2 ロード シェアリングおよび冗長構成の VRRP トポロジ

このトポロジには、オーバーラップする 2 つの VRRP グループに対応する 2 つの仮想 IP アドレスが含まれています。VRRP グループ 1 では、ルータ A が IP アドレス 10.0.0.1 のオーナーであり、マスターです。ルータ B はルータ A のバックアップです。クライアント 1 ~ 2 には、デフォルト ゲートウェイの IP アドレス 10.0.0.1 が設定されています。

VRRP グループ 2 では、ルータ B が IP アドレス 10.0.0.2 のオーナーであり、マスターです。ルータ A はルータ B のバックアップです。クライアント 3 ~ 4 には、デフォルト ゲートウェイの IP アドレス 10.0.0.2 が設定されています。

VRRP ルータのプライオリティおよびプリエンプション

VRRP 冗長構成の重要なポイントは、VRRP ルータのプライオリティです。プライオリティによって、各 VRRP ルータが果たす役割が決まり、マスター ルータで障害が発生した場合のアクションが決まるからです。

VRRP ルータが仮想 IP アドレスおよび物理インターフェイスの IP アドレスを所有する場合、そのルータはマスターとして機能します。マスターのプライオリティは 255 です。

プライオリティによって、VRRP ルータがバックアップ ルータとして動作するかどうかが決まり、さらに、マスターで障害が発生した場合にマスターになる順序も決まります。

たとえば、ルータ A が LAN トポロジにおけるマスターであり、そのルータ A で障害が発生した場合、VRRP はバックアップ B が引き継ぐのか、バックアップ C が引き継ぐのかを判断する必要があります。ルータ B にプライオリティ 101 が設定されていて、ルータ C がデフォルトのプライオリティ 100 の場合、VRRP はルータ B をマスターになるべきルータとして選択します。ルータ B の方がプライオリティが高いからです。ルータ B および C にデフォルトのプライオリティ 100 が設定されている場合は、VRRP は IP アドレスが大きい方のバックアップをマスターになるべきルータとして選択します。

VRRP ではプリエンプションを使用して、VRRP バックアップ ルータがマスターになってからのアクションを決定します。プリエンプションはデフォルトでイネーブルなので、VRRP は新しいマスターよりプライオリティの高いバックアップがオンラインになると、バックアップに切り替えます。たとえば、ルータ A がマスターであり、そのルータ A で障害が発生した場合、VRRP は(プライオリティの順位が次である)ルータ B を選択します。ルータ C がルータ B より高いプライオリティでオンラインになると、ルータ B で障害が発生していなくても、VRRP はルータ C を新しいマスターとして選択します。

プリエンプションをディセーブルにした場合、VRRP が切り替わるのは、元のマスターが回復した場合、または新しいマスターで障害が発生した場合に限られます。

vPC および VRRP

VRRP は、仮想ポート チャネル(vPC)と連携します。vPCs を使用すると、2 つの異なる Cisco Nexus 7000 シリーズ デバイスに物理的に接続しているリンクが、別のデバイスからは単一のポート チャネルとして認識できます。vPC の詳細については、『 Cisco Nexus 7000 Series NX-OS Layer 2 Switching Configuration Guide 』を参照してください。

vPC はマスター VRRP ルータとバックアップ VRRP ルータの両方を使用してトラフィックを転送します。「VRRP プライオリティの設定」を参照してください。


) プライマリ vPC ピア デバイスの VRRP をアクティブに、セカンダリ vPC デバイスの VRRP をスタンバイにそれぞれ設定する必要があります。


VRRP のアドバタイズメント

VRRP マスターは同じグループ内の他の VRRP ルータに、VRRP アドバタイズメントを送信します。アドバタイズメントは、マスターのプライオリティおよびステートを伝達します。Cisco NX-OS は VRRP アドバタイズメントを IP パケットにカプセル化して、VRRP グループに割り当てられた IP マルチキャスト アドレスに送信します。Cisco NX-OS がアドバタイズメントを送信する間隔はデフォルトでは 1 秒ですが、ユーザ側で別のアドバタイズ インターバルを設定できます。

VRRP 認証

VRRP は、次の認証機能をサポートします。

認証なし

プレーン テキスト認証

VRRP は次の場合に、パケットを拒否します。

認証方式がルータと着信パケットで異なる。

テキスト認証文字列がルータと着信パケットで異なる。

VRRP トラッキング

VRRP は次の 2 つのトラッキング オプションをサポートしています。

ネイティブ インターフェイス トラッキング:インターフェイスのステートを追跡し、そのステートを使用して VRRP グループの VRRP ルータのプライオリティを判別します。インターフェイスがダウンしている場合、またはインターフェイスにプライマリ IP アドレスがない場合、トラッキング対象ステートはダウンとなります。

オブジェクト トラッキング:設定されたオブジェクトのステートを追跡し、そのステートを使用して VRRP グループの VRRP ルータのプライオリティを判別します。オブジェクト トラッキングの詳細については、「オブジェクト トラッキングの設定」を参照してください。

トラッキング対象ステート(インターフェイスまたはオブジェクト)がダウンになると、VRRP はユーザがトラッキング対象ステートに対して新しいプライオリティをどのように設定するかに基づいて、プライオリティをアップデートします。トラッキング対象ステートがオンラインになると、VRRP は仮想ルータ グループの元のプライオリティを復元します。

たとえば、ネットワークへのアップリンクがダウンした場合、別のグループ メンバーが VRRP グループのマスターとして引き継げるように、VRRP グループ メンバーのプライオリティを引き下げなければならないことがあります。詳細については、「VRRP インターフェイス ステート トラッキングの設定」を参照してください。


) VRRP はレイヤ 2 インターフェイスのトラッキングをサポートしていません。


BFD

この機能では、双方向フォワーディング検出(BFD)をサポートします。BFD は、高速転送とパス障害の検出時間を提供する検出プロトコルです。BFD は 2 台の隣接デバイス間のサブセカンド障害を検出し、BFD の負荷の一部を、サポートされるモジュール上のデータ プレーンに分散できるため、プロトコル hello メッセージよりも CPU を使いません。詳細については、『 Cisco Nexus 7000 Series NX-OS Interfaces Configuration Guide, Release 6.x 』を参照してください。

ハイ アベイラビリティ

VRRP は、ステートフル リスタートとステートフル スイッチオーバーを通してハイ アベイラビリティをサポートします。ステートフル リスタートは、VRRP が障害を処理してリスタートするときに行われます。ステートフル スイッチオーバーは、アクティブ スーパーバイザがスタンバイ スーパーバイザに切り替わるときに行われます。Cisco NX-OS は、スイッチオーバー後に実行コンフィギュレーションを適用します。

仮想化のサポート

VRRP は、仮想ルーティングおよび転送(VRF)インスタンスをサポートします。VRF は仮想化デバイス コンテキスト(VDC)内にあります。デフォルトでは、特に別の VDC および VRF を設定しない限り、Cisco NX-OS によりデフォルト VDC およびデフォルト VRF が使用されます。

インターフェイスの VRF メンバーシップを変更すると、Cisco NX-OS によって、すべてのレイヤ 3 設定(VRRP を含む)が削除されます。

詳細については、 Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide および「レイヤ 3 仮想化の設定」を参照してください。

VRRPv3 について

VRRP のバージョン 3(VRRPv3)では、スイッチのグループで単一の仮想スイッチを形成して、冗長性を実現し、ネットワーク内のシングル ポイント障害が生じる可能性を減らすことができます。これにより、仮想スイッチをデフォルト ゲートウェイとして使用するように、LAN クライアントを設定できます。スイッチのグループを表す仮想スイッチは、VRRPv3 グループとも呼ばれます。

この項では、次のトピックについて取り上げます。

「VRRP の利点」

「VRRS」

「ハイ アベイラビリティ」

VRRPv3 の利点

VRRPv3 の利点は、次のとおりです。

マルチベンダー環境での相互運用性。

IPv4 および IPv6 アドレス ファミリのサポート。

VRRS 経路によるスケーラビリティの向上。

VRRS

仮想ルータ冗長サービス(VRRS)では、VRRPv3 を監視することでステートレス冗長サービスを VRRS 経路と VRRS クライアントに提供することで VRRPv3 のスケーラビリティが向上します。VRRPv3 は、VRRPv3 ステータス情報(現在および過去の冗長状態、アクティブおよび非アクティブのレイヤ 2 およびレイヤ 3 アドレスなど)を VRRS 経路とすべての登録済み VRRS クライアントに配信する VRRS サーバとして機能します。

VRRS クライアントは、VRRPv3 を使用して、グループのステートに応じてサービスやリソースを提供または抑制する他の Cisco プロセスまたはアプリケーションです。VRRS 経路は、VRRS データベース情報を使用して、拡張インターフェイス環境全体に拡張ファーストホップ ゲートウェイの冗長性を提供する特殊な VRRS クライアントです。

VRRS は、単独ではそれ自身のステートを管理することしかできません。VRRPv3 グループに VRRS クライアントをリンクすると、ステートレスまたはステートフル フェールオーバーが実装可能になるように、VRRS でクライアント アプリケーションにサービスを提供できるようにするメカニズムが提供されます。ステートフル フェールオーバーでは、フェールオーバーが発生したときに運用データが失われないように障害の前に所定バックアップとの通信が必要になります。

VRRS 経路はクライアントと同様に動作しますが、VRRS アーキテクチャと統合されます。この経路により、何百ものインターフェイス間で 1 つの仮想アドレスを設定することでファーストホップ ゲートウェイの冗長性を拡張する方法が提供されます。VRRS 経路の仮想ゲートウェイの状態は、ファーストホップ冗長プロトコル(FHRP)VRRS サーバの状態によります。

VRRPv3 での VRRS の使用

VRRPv3 は、現在の状態(マスター、バックアップ、または運用不可能な初期状態(INIT))を VRRS に通知し、その情報を経路またはクライアントに渡します。VRRPv3 グループ名は、VRRS をアクティブにし、VRRPv3 グループをクライアントまたは同じ名前の VRRS の一部として設定されている経路と関連付けます。

経路およびクライアントは、VRRPv3 サーバの状態で機能します。VRRPv3 グループの状態が変化すると、VRRS 経路とクライアントの動作(インターフェイスのシャット ダウン、アカウンティング ログの追加などのタスクの実行)が VRRS から受信した状態により変化します。

ハイ アベイラビリティ

VRRPv3 は、ステートフル スイッチオーバーをサポートしていません。

VRRP のライセンス要件

次の表に、この機能のライセンス要件を示します。

 

製品
ライセンス要件

Cisco NX-OS

VRRP にライセンスは不要です。ライセンス パッケージに含まれていない機能はすべて Cisco NX-OS システム イメージにバンドルされており、追加費用は一切発生しません。Cisco NX-OS のライセンス スキームの詳細については、『 Cisco NX-OS Licensing Guide 』を参照してください。

VRRP の注意事項と制約事項

VRRP 設定時の注意事項および制約事項は、次のとおりです。

管理インターフェイス上で VRRP を設定できません。

VRRP がイネーブルの場合は、ネットワーク上のデバイス全体で VRRP 設定を複製する必要があります。

同一インターフェイス上では、複数のファーストホップ冗長プロトコルを設定しないことを推奨します。

VRRP を設定するインターフェイスに IP アドレスを設定し、そのインターフェイスをイネーブルにしてからでなければ、VRRP はアクティブになりません。

インターフェイス VRF メンバーシップまたはポート チャネル メンバーシップを変更した場合、またはポート モードをレイヤ 2 に変更した場合は、Cisco NX-OS によってインターフェイス上のすべてのレイヤ 3 設定が削除されます。

VRRP でレイヤ 2 インターフェイスをトラッキングするよう設定した場合、レイヤ 2 をシャットダウンしてからインターフェイスを再度イネーブル化することにより、VRRP プライオリティを更新してレイヤ 2 インターフェイスのステートを反映させる必要があります。

VRRP の BFD は、2 台のルータ間でのみ設定できます。

VRRP IP アドレスは VRRP に参加するデバイスの物理 IP アドレスと異なっている必要があります。そのようになっていないと、ARP または MAC エントリが破損し、転送の問題が発生する場合があります。

VRRPv3 の注意事項と制約事項

VRRPv3 設定時の注意事項と制約事項は次のとおりです。

VRRPv3 は既存のダイナミック プロトコルの代替にはなりません。VRRPv3 は、マルチアクセス、マルチキャスト、または ブロードキャスト対応イーサネット LAN で使用するために設計されています。

VRRPv3 は、イーサネットおよびファスト イーサネット インターフェイス、ブリッジ グループ仮想インターフェイス(BVI)、およびギガビット イーサネット インターフェイスと、マルチプロトコル ラベル スイッチング(MPLS)仮想プライベート ネットワーク(VPN)、VRF 対応 MPLS VPN、および VLAN 上でのみサポートされます。

VRRPv3 が使用中の場合、VRRPv2 は使用できません。VRRPv3 を設定するには、VRRPv2 設定をディセーブルにする必要があります。

VRRPv3 が VRRS 経路の冗長インターフェイスと同じネットワーク パス上で動作する場合にのみ、完全なネットワークの冗長性を実現できます。完全な冗長性のために、次の制約事項が適用されます。

VRRS 経路は、親 VRRPv3 グループと同じ物理インターフェイスを使用する必要があるか、または親 VRRPv3 グループと同じ物理インターフェイスを持つサブインターフェイス上で設定する必要があります。

VRRS 経路をスイッチ仮想インターフェイス(SVI)に設定できるのは、関連付けられた VLAN が親 VRRPv3 グループが設定された VLAN と同じトランクを共有する場合のみです。

VRRS は現在、VRRPv3 と合わせて使用する場合にのみ使用できます。

VRRPv3 ミリ秒タイマーは、絶対に必要な場合以外は使用しないようにし、使用する場合は慎重な検討とテストが必要です。ミリ秒の値は望ましい状況でのみ動作します。ミリ秒のタイマー値は、VRRPv3 も含めてサポートしている限り、サードパーティ ベンダーと互換性があります。

デフォルト設定値

表 21-1 に、VRRP パラメータのデフォルト設定を示します。

 

表 21-1 デフォルトの VRRP パラメータ

パラメータ
デフォルト

VRRP

ディセーブル

アドバタイズ インターバル

1 秒

認証

認証なし

プリエンプション

イネーブル

プライオリティ

100

VRRPv3

ディセーブル

VRRS

ディセーブル

VRRPv3 セカンダリ アドレスの一致

イネーブル

VRRPv3 グループのプライオリティ

100

VRRPv3 アドバタイズメント タイマー

1000 ミリ秒

VRRP の設定

この項では、次のトピックについて取り上げます。

「VRRP 機能のイネーブル化」

「VRRP グループの設定」

「VRRP プライオリティの設定」

「VRRP 認証の設定」

「アドバタイズメント パケットのタイム インターバル設定」

「プリエンプションのディセーブル化」

「VRRP インターフェイス ステート トラッキングの設定」


) Cisco IOS の CLI に慣れている場合、この機能に対応する Cisco NX-OS コマンドは通常使用する Cisco IOS コマンドと異なる場合があるので注意してください。


VRRP 機能のイネーブル化

VRRP グループを設定してイネーブルにするには、その前に VRRP 機能をグローバルでイネーブルにする必要があります。

VRRP 機能をイネーブルにするには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

feature vrrp

 

例:

switch(config)# feature vrrp

VRRP をイネーブルにします。

VDC で VRRP 機能をディセーブルにし、関連付けられた設定をすべて削除するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

no feature vrrp

 

例:

switch(config)# no feature vrrp

VDC で VRRP 機能をディセーブルにします。

VRRP グループの設定

VRRP グループを作成し、仮想 IP アドレスを割り当て、グループをイネーブルにすることができます。

VRRP グループに設定できる仮想 IPv4 アドレスは 1 つです。マスター VRRP ルータはデフォルトで、仮想 IP アドレスを直接の宛先とするパケットをドロップします。これは、VRRP マスターがパケットを転送するネクストホップ ルータとしてのみ想定されているからです。アプリケーションによって、Cisco NX-OS が仮想ルータ IP 宛のパケットを受け付けるようにする必要があります。仮想 IP アドレスに secondary オプションを使用すると、ローカル ルータが VRRP マスターの場合に、これらのパケットを受け付けます。

VRRP グループを設定した場合は、そのグループをアクティブにするために、グループを明示的にイネーブルにする必要があります。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

インターフェイス上で IP アドレスが設定されていることを確認します(「IPv4 アドレッシングの設定」を参照)。

手順の概要

1. configure terminal

2. interface interface-type slot/port

3. vrrp number

4. address ip-address [ secondary ]

5. no shutdown

6. (任意)show vrrp

7. (任意)copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface - type slot/port

 

例:

switch(config)# interface ethernet 2/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

vrrp number

 

例:

switch(config-if)# vrrp 250

switch(config-if-vrrp)#

仮想ルータ グループを作成します。指定できる範囲は 1 ~ 255 です。

ステップ 4

address ip-address [ secondary ]

 

例:

switch(config-if-vrrp)# address 192.0.2.8

指定の VRRP グループに仮想 IPv4 アドレスを設定します。このアドレスは、インターフェイスの IPv4 アドレスと同じサブネットになければなりません。

secondary オプションは、VRRP ルータが仮想ルータの IP アドレスに送信されたパケットを受け付けて、アプリケーションに配信することをアプリケーションが要求する場合に限られます。

ステップ 5

no shutdown

 

例:

switch(config-if-vrrp)# no shutdown

switch(config-if-vrrp)#

VRRP グループをイネーブルにします。デフォルトでは、ディセーブルです。

ステップ 6

show vrrp

 

例:

switch(config-if-vrrp)# show vrrp

(任意)VRRP 情報を表示します。

ステップ 7

copy running-config startup-config

 

例:

switch(config-if-vrrp)# copy running-config startup-config

(任意)この設定の変更を保存します。

VRRP プライオリティの設定

仮想ルータの有効なプライオリティ範囲は 1 ~ 254 です(1 が最下位、254 が最上位のプライオリティ)。バックアップのデフォルトのプライオリティ値は 100 です。インターフェイス アドレスがプライマリ仮想 IP アドレスと同じデバイス(マスター)の場合、デフォルト値は 255 です。

vPC 対応のインターフェイスで VRRP を設定する場合は、オプションで vPC トランクにフェールオーバーする時期を制御するしきい値の上限と下限を設定できます。バックアップ ルータのプライオリティが下限のしきい値を下回った場合、VRRP は、すべてのバックアップ ルータ トラフィックを vPC トランク全体に送信し、マスター VRRP ルータを通して転送します。バックアップ VRRP ルータのプライオリティがしきい値の上限を超えるまで、VRRP はこの処理を継続します。

はじめる前に

VRRP をイネーブルにする必要があります(「VRRP の設定」を参照)。

インターフェイス上で IP アドレスを設定していることを確認します(「IPv4 アドレッシングの設定」を参照)。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. interface interface-type slot/port

3. vrrp number

4. shutdown

5. priority leve l [ forwarding-threshold lower lower-value upper upper-value ]

6. no shutdown

7. (任意) show vrrp

8. (任意)copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-type slot/port

 

例:

switch(config)# interface ethernet 2/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

vrrp number

 

例:

switch(config-if)# vrrp 250

switch(config-if-vrrp)#

仮想ルータ グループを作成します。

ステップ 4

shutdown

 

例:

switch(config-if-vrrp)# shutdown

switch(config-if-vrrp)#

VRRP グループをディセーブルにします。デフォルトでは、ディセーブルです。

ステップ 5

priority level [ forwarding-threshold lower lower-value upper upper-value ]

 

例:

switch(config-if-vrrp)# priority 60 forwarding-threshold lower 40 upper 50

 

VRRP グループでのアクティブ ルータ選択に使用するプライオリティ レベルを設定します。 level の範囲は 1 ~ 254 です。バックアップの場合、デフォルトは 100 です。インターフェイス IP アドレスが仮想 IP アドレスと等しいマスターの場合は 255 です。

オプションで、vPC トランクにフェールオーバーする時点を決定するために vPC が使用するしきい値の上限と下限を設定します。 lower-value の範囲は 1 ~ 255 です。デフォルトは 1 です。 upper-value の範囲は 1 ~ 255 です。デフォルトは 255 です。

ステップ 6

no shutdown

 

例:

switch(config-if-vrrp)# no shutdown

switch(config-if-vrrp)#

VRRP グループをイネーブルにします。デフォルトでは、ディセーブルです。

ステップ 7

show vrrp

 

例:

switch(config-if-vrrp)# show vrrp

(任意)VRRP 情報の要約を表示します。

ステップ 8

copy running-config startup-config

 

例:

switch(config-if-vrrp)# copy running-config startup-config

(任意)この設定の変更を保存します。

VRRP 認証の設定

VRRP グループに単純なテキスト認証を設定できます。

はじめる前に

ネットワーク上のすべての VRRP デバイスで、認証設定が同じであることを確認します。

VRRP がイネーブルになっていることを確認します(「VRRP の設定」を参照)。

インターフェイス上で IP アドレスを設定していることを確認します(「IPv4 アドレッシングの設定」を参照)。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. interface interface-type slot/port

3. vrrp number

4. shutdown

5. authentication text password

6. no shutdown

7. (任意) show vrrp

8. (任意) copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-type slot/port

 

例:

switch(config)# interface ethernet 2/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

vrrp number

 

例:

switch(config-if)# vrrp 250

switch(config-if-vrrp)#

仮想ルータ グループを作成します。

ステップ 4

shutdown

 

例:

switch(config-if-vrrp)# shutdown

switch(config-if-vrrp)#

VRRP グループをディセーブルにします。デフォルトでは、ディセーブルです。

ステップ 5

authentication text password

 

例:

switch(config-if-vrrp)# authentication text aPassword

単純なテキスト認証オプションを指定し、キーネーム パスワードを指定します。キーネームの範囲は 1 ~ 255 文字です。16 文字以上を推奨します。テキスト パスワードは、英数字で最大 8 文字です。

ステップ 6

no shutdown

 

例:

switch(config-if-vrrp)# no shutdown

switch(config-if-vrrp)#

VRRP グループをイネーブルにします。デフォルトでは、ディセーブルです。

ステップ 7

show vrrp

 

例:

switch(config-if-vrrp)# show vrrp

(任意)VRRP 情報の要約を表示します。

ステップ 8

copy running-config startup-config

 

例:

switch(config-if-vrrp)# copy running-config startup-config

(任意)この設定の変更を保存します。

アドバタイズメント パケットのタイム インターバル設定

アドバタイズメント パケットのタイム インターバルを設定できます。

はじめる前に

VRRP をイネーブルにする必要があります(「VRRP の設定」を参照)。

インターフェイス上で IP アドレスを設定していることを確認します(「IPv4 アドレッシングの設定」を参照)。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. interface interface-type slot/port

3. vrrp number

4. shutdown

5. advertisement-interval seconds

6. no shutdown

7. (任意) show vrrp

8. (任意)copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-type slot/port

 

例:

switch(config)# interface ethernet 2/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

vrrp number

 

例:

switch(config-if)# vrrp 250

switch(config-if-vrrp)#

仮想ルータ グループを作成します。

ステップ 4

shutdown

 

例:

switch(config-if-vrrp)# shutdown

switch(config-if-vrrp)#

VRRP グループをディセーブルにします。デフォルトでは、ディセーブルです。

ステップ 5

advertisement-interval seconds

 

例:

switch(config-if-vrrp)# advertisement-interval 15

アドバタイズメント フレームの送信間隔を秒数で設定します。指定できる範囲は 1 ~ 255 です。デフォルト値は 1 秒です。

ステップ 6

no shutdown

 

例:

switch(config-if-vrrp)# no shutdown

switch(config-if-vrrp)#

VRRP グループをイネーブルにします。デフォルトでは、ディセーブルです。

ステップ 7

show vrrp

 

例:

switch(config-if-vrrp)# show vrrp

(任意)VRRP 情報の要約を表示します。

ステップ 8

copy running-config startup-config

 

例:

switch(config-if-vrrp)# copy running-config startup-config

(任意)この設定の変更を保存します。

プリエンプションのディセーブル化

VRRP グループ メンバのプリエンプションをディセーブルにできます。プリエンプションをディセーブルにした場合は、プライオリティのより高いバックアップ ルータが、プライオリティのより低いマスター ルータを引き継ぐことはありません。プリエンプションはデフォルトでイネーブルです。

はじめる前に

VRRP をイネーブルにする必要があります(「VRRP の設定」を参照)。

インターフェイス上で IP アドレスを設定していることを確認します(「IPv4 アドレッシングの設定」を参照)。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. interface interface-type slot/port

3. vrrp number

4. shutdown

5. no preempt

6. no shutdown

7. (任意) show vrrp

8. (任意)copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-type slot/port

 

例:

switch(config)# interface ethernet 2/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

vrrp number

 

例:

switch(config-if)# vrrp 250

switch(config-if-vrrp)#

仮想ルータ グループを作成します。

ステップ 4

no shutdown

 

例:

switch(config-if-vrrp)# no shutdown

VRRP グループをイネーブルにします。デフォルトでは、ディセーブルです。

ステップ 5

no preempt

 

例:

switch(config-if-vrrp)# no preempt

プリエンプト オプションをディセーブルにして、プライオリティが上位のバックアップが使用されてもマスターが変わらないようにします。

ステップ 6

no shutdown

 

例:

switch(config-if-vrrp)# no shutdown

VRRP グループをイネーブルにします。デフォルトでは、ディセーブルです。

ステップ 7

show vrrp

 

例:

switch(config-if-vrrp)# show vrrp

(任意)VRRP 情報の要約を表示します。

ステップ 8

copy running-config startup-config

 

例:

switch(config-if-vrrp)# copy running-config startup-config

(任意)この設定の変更を保存します。

VRRP インターフェイス ステート トラッキングの設定

インターフェイス ステート トラッキングは、デバイスの別のインターフェイスのステートに基づいて、仮想ルータのプライオリティを変更します。トラッキング対象のインターフェイスがダウンしたり、IP アドレスが削除されると、Cisco NX-OS はトラッキング プライオリティ値を仮想ルータに割り当てます。トラッキング対象のインターフェイスがオンライン状態になり、IP アドレスがこのインターフェイスに設定されると、Cisco NX-OS は仮想ルータに設定されていたプライオリティを復元します(「VRRP プライオリティの設定」を参照)。


) インターフェイス ステート トラッキングを動作させるには、インターフェイス上でプリエンプションをイネーブルにする必要があります。



) VRRP はレイヤ 2 インターフェイスのトラッキングをサポートしていません。


はじめる前に

VRRP をイネーブルにする必要があります(「VRRP の設定」を参照)。

インターフェイス上で IP アドレスを設定していることを確認します(「IPv4 アドレッシングの設定」を参照)。

仮想ルータがイネーブルになっていることを確認します(「VRRP グループの設定」を参照)。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. interface interface-type slot/port

3. vrrp number

4. shutdown

5. track interface type number priority value

6. no shutdown

7. (任意) show vrrp

8. (任意) copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-type slot/port

 

例:

switch(config)# interface ethernet 2/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

vrrp number

 

例:

switch(config-if)# vrrp 250

switch(config-if-vrrp)#

仮想ルータ グループを作成します。

ステップ 4

shutdown

 

switch(config-if-vrrp)# shutdown

switch(config-if-vrrp)#

VRRP グループをディセーブルにします。デフォルトでは、ディセーブルです。

ステップ 5

track interface type number priority value

 

例:

switch(config-if-vrrp)# track interface ethernet 2/10 priority 254

VRRP グループのインターフェイス プライオリティ トラッキングをイネーブルにします。プライオリティの範囲は 1 ~ 254 です。

ステップ 6

no shutdown

 

switch(config-if-vrrp)# no shutdown

switch(config-if-vrrp)#

VRRP グループをイネーブルにします。デフォルトでは、ディセーブルです。

ステップ 7

show vrrp

 

例:

switch(config-if-vrrp)# show vrrp

(任意)VRRP 情報の要約を表示します。

ステップ 8

copy running-config startup-config

 

例:

switch(config-if-vrrp)# copy running-config startup-config

(任意)この設定の変更を保存します。

VRRPv3 の設定

この項は、次の内容で構成されています。

「VRRPv3 機能のイネーブル化」

「VRRPv3 グループの作成」

「FHRP クライアントの初期化の遅延時間の設定」

「VRRPv3 制御グループの設定」

「VRRS 経路の設定」


) Cisco IOS の CLI に慣れている場合、この機能に対応する Cisco NX-OS コマンドは通常使用する Cisco IOS コマンドと異なる場合があるので注意してください。


VRRPv3 機能のイネーブル化

VRRPv3 グループを設定してイネーブルにするには、その前に VRRPv3 機能をグローバルでイネーブルにする必要があります。

VRRPv3 機能をイネーブルにするには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

feature vrrpv3

 

switch(config)# feature vrrpv3

VRRP バージョン 3 と仮想ルータ冗長サービス(VRRS)をイネーブルにします。

コマンドを使用して VRRPv3 を有効にします。

VDC で VRRPv3 機能をディセーブルにし、関連付けられた設定をすべて削除するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

no feature vrrpv3

 

switch(config)# no feature vrrpv3

VDC で VRRPv3 と VRRS をディセーブルにします。

VRRPv3 グループの作成

VRRPv3 グループを作成し、仮想 IP アドレスを割り当て、グループをイネーブルにすることができます。

はじめる前に

VRRPv3 機能がイネーブルであることを確認します。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

インターフェイス上で IP アドレスが設定されていることを確認します(「IPv4 アドレッシングの設定」を参照)。

手順の概要

1. configure terminal

2. interface interface-type slot/port

3. vrrpv3 number address-family { ipv4 | ipv6 }

4. (任意) address ip-address [ primary | secondary ]

5. (任意)description descriptio n

6. (任意)match-address

7. (任意) preempt [delay minimum seconds ]

8. (任意) priority level

9. (任意) timers advertise interval

10. (任意) vrrpv2

11. (任意) vrrs leader vrrs-leader-name

12. (任意) shutdown

13. (任意)show fhrp [ interface-type interface-number] [verbose]

14. (任意)copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface - type slot/port

 

例:

switch(config)# interface ethernet 2/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

vrrpv3 number address-family { ipv4 | ipv6 }

 

例:

switch(config-if)# vrrpv3 5 address-family

ipv4

switch(config-if-vrrpv3-group)#

VRRPv3 グループを作成し、VRRPv3 グループ コンフィギュレーション モードを開始します。指定できる範囲は 1 ~ 255 です。

ステップ 4

address ip-address [ primary | secondary ]

 

例:

switch(config-if-vrrpv3-group)# address

100.0.1.10 primary

(任意)VRRPv3 グループにプライマリまたはセカンダリ IPv4 アドレスまたは IPv6 アドレスを指定します。

(注) VRRPv3 グループでセカンダリ IP アドレスを使用するには、まず同じグループでプライマリ IP アドレスを設定する必要があります。

ステップ 5

description description

 

例:

switch(config-if-vrrpv3-group)# description

group3

(任意)VRRPv3 グループの説明を指定します。最大 80 文字の英数字を入力できます。

ステップ 6

match-address

 

例:

switch(config-if-vrrpv3-group)# match-address

(任意)アドバタイズメント パケットのセカンダリ アドレスを設定したアドレスと照合します。

ステップ 7

preempt [ delay minimum seconds ]

 

例:

switch(config-if-vrrpv3-group)# preempt

delay minimum 30

(任意)プライオリティの低いマスター スイッチのプリエンプションをオプションの延期期間でイネーブルにします。範囲は 0 ~ 3600 です。

ステップ 8

priority level

 

例:

switch(config-if-vrrpv3-group)# priority 3

(任意)VRRPv3 グループのプライオリティを指定します。範囲は 1 ~ 254 です。

ステップ 9

timers advertise interval

 

例:

switch(config-if-vrrpv3-group)# timers advertise 1000

(任意)アドバタイズメント タイマーをミリ秒で設定します。範囲は 100 ~ 40950 です。

(注) シスコは、このタイマーを 1 秒以上の値に設定することを推奨します。

ステップ 10

vrrpv2

 

例:

switch(config-if-vrrpv3-group)# vrrpv2

(任意)VRRPv2 のみをサポートするデバイスとの相互運用性を確保するために、VRRPv2 へのサポートも同時にイネーブルにします。

(注) VRRPv2 互換モードは、VRRPv2 から VRRPv3 にアップグレードするために提供されます。これは完全な VRRPv2 実装ではないので、アップグレードを実行する場合にのみ使用してください。

ステップ 11

vrrs leader vrrs-leader-name

 

例:

switch(config-if-vrrpv3-group)# vrrs leader leader1

(任意)リーダーの名前を VRRS に登録されるように指定します。

ステップ 12

shutdown

 

switch(config-if-vrrp3-group)# shutdown

(任意)VRRPv3 グループの VRRP 設定をディセーブルにします。

ステップ 13

show fhrp [ interface-type interface-number ] [verbose]

 

例:

switch(config-if-vrrp3-group)# show fhrp port-channnel 101 verbose

(任意)ファースト ホップ冗長性プロトコル(FHRP)の情報を表示します。

詳細情報を表示するには、 verbose キーワードを使用します。

ステップ 14

copy running-config startup-config

 

例:

switch(config-if-vrrp3-group)# copy running-config startup-config

(任意)この設定の変更を保存します。

FHRP クライアントの初期化の遅延時間の設定

FHRP クライアントの初期化の遅延期間を設定できます。

この機能を設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

fhrp delay {[ minimum ] [ reload ] seconds }

 

switch(config)# fhrp delay minimum 34

FHRP クライアントの初期化の遅延時間を指定します。指定できる範囲は 0 ~ 3600 秒です。

minimal キーワードを使用すると、インターフェイスが使用可能になった後の遅延時間が設定されます。

reload コマンドを使用すると、デバイスのリロード後の遅延時間が設定されます。

VRRPv3 制御グループの設定

VRRPv3 制御グループを設定できます。

はじめる前に

VRRPv3 機能がイネーブルであることを確認します。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

インターフェイス上で IP アドレスが設定されていることを確認します(「IPv4 アドレッシングの設定」を参照)。

手順の概要

1. configure terminal

2. interface interface-type slot/port

3. ip address ip-address mask [ secondary ]

4. vrrpv3 number address-family { ipv4 | ipv6 }

5. (任意) address ip-address [ primary | secondary ]

6. (任意) vrrs leader vrrs-leader-name

7. (任意)show fhrp [ interface-type interface-number] [verbose]

8. (任意)copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface - type slot/port

 

例:

switch(config)# interface ethernet 2/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

ip address ip-address mask [ secondary]

 

例:

switch(config-if)# ip address 209.165.200.230 255.255.255.224

インターフェイスの IP アドレスを設定します。

キーワードを使用して、インターフェイスで追加の IP アドレスを設定できます。

ステップ 4

vrrpv3 number address-family { ipv4 | ipv6 }

 

例:

switch(config-if)# vrrpv3 5 address-family

ipv4

switch(config-if-vrrpv3-group)#

VRRPv3 グループを作成し、VRRPv3 グループ コンフィギュレーション モードを開始します。指定できる範囲は 1 ~ 255 です。

ステップ 5

address ip-address [ primary | secondary ]

 

例:

switch(config-if-vrrpv3-group)# address

209.165.200.227 primary

(任意)VRRPv3 グループにプライマリまたはセカンダリ IPv4 アドレスまたは IPv6 アドレスを指定します。

ステップ 6

vrrs leader vrrs-leader-name

 

例:

switch(config-if-vrrpv3-group)# vrrs leader leader1

(任意)リーダーの名前を VRRS に登録されるように指定します。

ステップ 7

shutdown

 

switch(config-if-vrrp3-group)# shutdown

(任意)VRRPv3 グループの VRRP 設定をディセーブルにします。

ステップ 8

show fhrp [ interface-type interface-number ] [verbose]

 

例:

switch(config-if-vrrp3-group)# show fhrp port-channnel 101 verbose

(任意)ファースト ホップ冗長性プロトコル(FHRP)の情報を表示します。

詳細情報を表示するには、 verbose キーワードを使用します。

ステップ 9

copy running-config startup-config

 

例:

switch(config-if-vrrp3-group)# copy running-config startup-config

(任意)この設定の変更を保存します。

VRRS 経路の設定

仮想ルータ冗長サービス(VRRS)の経路を設定できます。拡張環境では、VRRS 経路は VRRPv3 制御グループと組み合わせて使用する必要があります。

はじめる前に

VRRPv3 機能がイネーブルであることを確認します。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

インターフェイス上で IP アドレスが設定されていることを確認します(「IPv4 アドレッシングの設定」を参照)。

手順の概要

1. configure terminal

2. interface interface-type slot/port

3. ip address ip-address mask [ secondary ]

4. vrrs pathway vrrs-tag

5. mac address { mac-address | inherit }

6. address ip-address

7. (任意)追加の経路を設定するには、ステップ 1 ~ 6 を繰り返して行ってください。

8. (任意) show vrrs pathway interface-type number

9. (任意)show vrrs server

10. (任意)show vrrs client [ client-name]

11. (任意)show vrrs tag [ tag-name]

12. (任意)copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface - type slot/port

 

例:

switch(config)# interface port-channel 101

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

ip address ip-address mask [ secondary]

 

例:

switch(config-if)# ip address 209.165.200.230 255.255.255.224

インターフェイスの IP アドレスを設定します。

キーワードを使用して、インターフェイスで追加の IP アドレスを設定できます。

ステップ 4

vrrs pathway vrrs-tag

 

例:

switch(config-if)# vrrs pathway path1

switch(config-if-vrrs-pw)#

VRRS グループの VRRS 経路を定義し、VRRS 経路コンフィギュレーション モードを開始します。

vrrs-tag 引数は、経路に関連付けられている VRRS タグの名前を指定します。

ステップ 5

mac address {mac-address | inherit }

 

例:

switch(config-if-vrrs-pw)# mac address

fe24.fe24.fe24

経路の MAC アドレスを指定します。

キーワードを使用すると、経路は関連付けられている VRRPv3 グループの仮想 MAC アドレスを継承します。

ステップ 6

address ip-address

 

例:

switch(config-if-vrrs-pw)# address

209.165.201.10

経路の仮想 IPv4 アドレスまたは IPv6 アドレスを定義します。

(注) VRRPv3 グループは、複数の経路を制御できます。

ステップ 7

(任意)追加の経路を設定するには、ステップ 1 ~ 6 を繰り返して行ってください。

--

ステップ 8

show vrrs pathway interface-type interface-number

 

例:

switch(config-if-vrrs-pw)# show vrrs pathway port-channel 101

(任意)異なる経路の状態(アクティブ、非アクティブ、非対応など)に関する VRRS 経路の情報を表示します。

ステップ 9

show vrrs server

 

例:

switch(config-if-vrrs-pw)# show vrrs server

(任意)VRRS サーバ情報を表示します。

ステップ 10

show vrrs client [client-name ]

 

例:

switch(config-if-vrrs-pw)# show vrrs client

(任意)VRRS クライアント情報を表示します。

ステップ 11

show vrrs tag [tag-name ]

 

例:

switch(config-if-vrrs-pw)# show vrrs tag

(任意)VRRS タグ情報を表示します。

ステップ 12

copy running-config startup-config

 

例:

switch(config-if-vrrp3-group)# copy running-config startup-config

(任意)この設定の変更を保存します。

VRRP の設定確認

VRRP 設定情報を表示するには、次の作業のいずれかを行います。

 

コマンド
目的

show vrrp

すべてのグループについて、VRRP ステータスを表示します。

show vrrs client [ client-name]

VRRS クライアント情報を表示します。

show vrrs pathway interface-type number

異なる経路の状態(アクティブ、非アクティブ、非対応など)に関する VRRS 経路の情報を表示します。

show vrrs server

VRRS サーバ情報を表示します。

show vrrs tag [ tag-name]

VRRS タグ情報を表示します。

show fhrp [ interface-type interface-number] [verbose]

ファースト ホップ冗長性プロトコル(FHRP)の情報を表示します。

show interface interface-type

インターフェイスの仮想ルータ設定を表示します。

VRRP 統計情報のモニタリング

VRRP の統計情報を表示するには、次のコマンドを使用します。

 

コマンド
目的

show vrrp statistics

VRRP の統計情報を表示します。

デバイスのすべてのインターフェイスについて、すべての VRRP 統計情報を消去するには、 clear vrrp statistics コマンドを使用します。

特定のインターフェイスについて、IPv4 VRRP 統計情報を消去するには、 clear vrrp vr コマンドを使用します。

特定の IPv4 仮想ルータについて、すべての統計情報を消去するには、 clear vrrp ipv4 コマンドを使用します。

VRRP の設定例

この例では、ルータ A およびルータ B はそれぞれ 3 つの VRRP グループに所属しています。コンフィギュレーションにおいて、各グループのプロパティは次のとおりです。

グループ 1:

仮想 IP アドレスは 10.1.0.10 です。

ルータ A はプライオリティ 120 で、このグループのマスターになります。

アドバタイズ インターバルは 3 秒です。

プリエンプションはイネーブルです。

グループ 5:

ルータ B はプライオリティ 200 で、このグループのマスターになります。

アドバタイズ インターバルは 30 秒です。

プリエンプションはイネーブルです。

グループ 100:

ルータ A は、IP アドレスが上位(10.1.0.2)なので、このグループのマスターになります。

アドバタイズ インターバルはデフォルトの 1 秒です。

プリエンプションはディセーブルです。

ルータ A

interface ethernet 1/0
   ip address 10.1.0.2/16
   no shutdown
    vrrp 1
 priority 120
 authentication text cisco
 advertisement-interval 3
 address 10.1.0.10
 no shutdown
vrrp 5
 priority 100
 advertisement-interval 30
 address 10.1.0.50
 no shutdown
vrrp 100
 no preempt
 address 10.1.0.100
 no shutdown

ルータ B

interface ethernet 1/0
 ip address 10.2.0.1/2
 no shutdown
vrrp 1
 priority 100
 authentication text cisco
 advertisement-interval 3
 address 10.2.0.10
 no shutdown
 
vrrp 5
 priority 200
 advertisement-interval 30
 address 10.2.0.50
 no shutdown
vrrp 100
 no preempt
 address 10.2.0.100
 no shutdown
 

VRRPv3 の設定例

次に、VRRPv3 をイネーブルにし VRRPv3 グループを作成およびカスタマイズする例を示します。

switch# configure terminal
switch(config)# feature vrrpv3
switch(config)# interface ethernet 4/6
switch(config-if)# vrrpv3 5 address-family ipv4
switch(config-if-vrrpv3-group)# address 209.165.200.225 primary
switch(config-if-vrrpv3-group)# description group3
switch(config-if-vrrpv3-group)# match-address
switch(config-if-vrrpv3-group)# preempt delay minimum 30
switch(config-if-vrrpv3-group)# show fhrp verbose
Interface Ethernet4/6
Interface handle : 0x1a185000
Reference count : 3
Client 1 : VRRP
Client 2 : PATHWAY
Verify up running : 63 (expired)
Verify up retries : 6
Verify up next retry : 0.000 secs
Reload Delay : 0
Minimum Delay : 30
Delay remaining : 0.000 secs
Interface state : down
IPv4 state : down
IPv6 state : down
Hardware state : present

その他の関連資料

VRRP の実装に関連する詳細情報については、次の項を参照してください。

「関連資料」

関連資料

関連項目
マニュアル タイトル

ゲートウェイ ロード バランシング プロトコルの設定

「GLBP の設定」

HSRP の設定

「HSRP の設定」

VRRP CLI コマンド

『Cisco Nexus 7000 Series NX-OS Unicast Routing Command Reference

ハイ アベイラビリティの設定

『Cisco Nexus 7000 Series NX-OS High Availability and Redundancy Guide

VRRP 機能の履歴

表 21-2 に、この機能のリリース履歴を示します。

 

表 21-2 VRRP 機能の履歴

機能名
リリース
機能情報

VRRPv3 および VRRS

6.2(2)

これらの機能が導入されました。

VRRP プライオリティのしきい値

4.2(1)

プライオリティのしきい値と vPC のサポートが追加されました。

VRRP オブジェクト トラッキング

4.2(1)

VRRP の複数のオブジェクト タイプのトラッキングのサポートが追加されました。

VRRP

4.0(1)

この機能が導入されました。