Cisco Nexus 7000 シリーズ NX-OS ユニキャスト ルーティング コンフィギュレーション ガイド リリース 6.x
スタティック ルーティングの設定
スタティック ルーティングの設定
発行日;2015/03/23 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 10MB) | フィードバック

目次

スタティック ルーティングの設定

機能情報の確認

スタティック ルーティングの概要

アドミニストレーティブ ディスタンス

直接接続のスタティック ルート

完全指定のスタティック ルート

フローティング スタティック ルート

スタティック ルートのリモート ネクスト ホップ

オブジェクト トラッキングを導入した信頼性が高いスタティック ルーティングのバックアップ

IP サービス レベル契約

BFD

仮想化のサポート

スタティック ルーティングのライセンス要件

スタティック ルーティングの前提条件

スタティック ルーティングの注意事項および制約事項

デフォルト設定値

スタティック ルーティングの設定

スタティック ルートの設定

VLAN を介したスタティック ルートの設定

オブジェクト トラッキングを使用した信頼性が高いスタティック ルーティングのバックアップの設定

仮想化の設定

スタティック ルーティングの設定確認

スタティック ルーティングの設定例

オブジェクト トラッキングを使用した信頼性が高いスタティック ルーティングのバックアップの設定例

その他の関連資料

関連資料

スタティック ルーティングの機能の履歴

スタティック ルーティングの設定

この章では、Cisco NX-OS デバイス上でスタティック ルーティングを設定する方法について説明します。

この章は、次の項で構成されています。

「機能情報の確認」

「スタティック ルーティングの概要」

「スタティック ルーティングのライセンス要件」

「スタティック ルーティングの前提条件」

「スタティック ルーティングの注意事項および制約事項」

「デフォルト設定値」

「スタティック ルーティングの設定」

「スタティック ルーティングの設定確認」

「スタティック ルーティングの設定例」

「オブジェクト トラッキングを使用した信頼性が高いスタティック ルーティングのバックアップの設定例」

「その他の関連資料」

「スタティック ルーティングの機能の履歴」

機能情報の確認

ご使用のソフトウェア リリースで、このモジュールで説明されるすべての機能がサポートされているとは限りません。最新の警告および機能情報については、 https://tool.cisco.com/bugsearch/ の Bug Search Tool およびご使用のソフトウェア リリースのリリース ノートを参照してください。このモジュールに記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「新機能および変更された機能に関する情報」の項または以下の「機能の履歴」表を参照してください。

スタティック ルーティングの概要

ルータは、ユーザが手動で設定したルート テーブル エントリのルート情報を使用するか、またはダイナミック ルーティング アルゴリズムで計算されたルート情報を使用して、パケットを転送します。

スタティック ルートは、2 つのルータ間の明示パスを定義するものであり、自動的にはアップデートされません。ネットワークに変更があった場合は、ユーザが手動でスタティック ルートを再設定する必要があります。スタティック ルートは、ダイナミック ルートに比べて使用する帯域幅が少なくなります。ルーティング アップデートの計算や分析に CPU サイクルを使用しません。

必要に応じて、スタティック ルートでダイナミック ルートを補うことができます。スタティック ルートをダイナミック ルーティング アルゴリズムに再配布できますが、ダイナミック ルーティング アルゴリズムで計算されたルーティング情報をスタティック ルーティング テーブルに再配布できません。

スタティック ルートは、ネットワーク トラフィックが予測可能で、ネットワーク設計が単純な環境で使用します。スタティック ルートはネットワークの変化に対応できないので、大規模でたえず変化しているネットワークでは、スタティック ルートを使用すべきではありません。大部分のネットワークは、ルータ間の通信にダイナミック ルートを使用しますが、特殊な状況でスタティック ルートを 1 つか 2 つ設定する場合があります。 スタティック ルートは、最終手段としてのゲートウェイ(ルーティング不能なすべてのパケットの送信先となるデフォルト ルータ)を指定する場合にも便利です。

この項では、次のトピックについて取り上げます。

「アドミニストレーティブ ディスタンス」

「直接接続のスタティック ルート」

「完全指定のスタティック ルート」

「フローティング スタティック ルート」

「スタティック ルートのリモート ネクスト ホップ」

「オブジェクト トラッキングを導入した信頼性が高いスタティック ルーティングのバックアップ」

「BFD」

「仮想化のサポート」

アドミニストレーティブ ディスタンス

アドミニストレーティブ ディスタンスは、2 つの異なるルーティング プロトコルから同じ宛先に、2 つ以上のルートが存在する場合に、最適なパスを選択するために、ルータが使用するメトリックです。複数のプロトコルがユニキャスト ルーティング テーブルに同じルートを追加した場合に、アドミニストレーティブ ディスタンスを手がかりに、他のルーティング プロトコル(またはスタティック ルート)ではなく、特定のルーティング プロトコル(またはスタティック ルート)が選択されます。各ルーティング プロトコルは、アドミニストレーティブ ディスタンス値を使用して、信頼性の高い順にプライオリティが与えられます。

スタティック ルートのデフォルトのアドミニストレーティブ ディスタンスは 1 です。ルータは値の小さいルートが最短であると見なすので、スタティック ルートがダイナミック ルートより優先されます。ダイナミック ルートでスタティック ルートを上書きする場合は、スタティック ルートにアドミニストレーティブ ディスタンスを指定します。たとえば、アドミニストレーティブ ディスタンスが 120 のダイナミック ルートが 2 つある場合に、ダイナミック ルートでスタティック ルートを上書きするには、スタティック ルートに 120 より大きいアドミニストレーティブ ディスタンスを指定します。

直接接続のスタティック ルート

直接接続のスタティック ルートでは、出力インターフェイス(あらゆるパケットを宛先ネットワークに送り出すインターフェイス)のみを指定する必要があります。ルータは宛先が出力インターフェイスに直接接続されているものと見なし、パケットの宛先をネクストホップ アドレスとして使用します。ネクストホップは、ポイントツーポイント インターフェイスの場合に限り、インターフェイスにできます。ブロードキャスト インターフェイスの場合は、ネクストホップを IPv4/IPv6 アドレスにする必要があります。

完全指定のスタティック ルート

完全指定のスタティック ルートでは、出力インターフェイス(あらゆるパケットを宛先ネットワークに送り出すインターフェイス)またはネクスト ホップ アドレスのどちらかを指定する必要があります。完全指定のスタティック ルートを使用できるのは、出力インターフェイスがマルチアクセス インターフェイスで、ネクストホップ アドレスを特定する必要がある場合です。ネクストホップ アドレスは、指定された出力インターフェイスに直接接続する必要があります。

フローティング スタティック ルート

フローティング スタティック ルートは、ダイナミック ルートをバックアップするためにルータが使用するスタティック ルートです。フローティング スタティック ルートには、バックアップするダイナミック ルートより大きいアドミニストレーティブ ディスタンスを設定する必要があります。この場合、ルータはフローティング スタティック ルートよりダイナミック ルートを優先させます。フローティング スタティック ルートは、ダイナミック ルートが失われた場合の代用として使用できます。


) デフォルトでは、ルータはダイナミック ルートよりスタティック ルートを優先させます。スタティック ルートの方がダイナミック ルートより、アドミニストレーティブ ディスタンスが小さいからです。


スタティック ルートのリモート ネクスト ホップ

リモート(非直接接続)ネクストホップを指定したスタティック ルートの場合、ルータに直接接続されていない隣接ルータのネクストホップ アドレスを指定できます。データ転送時に、スタティック ルートにリモート ネクストホップがあると、そのネクスト ホップがユニキャスト ルーティング テーブルで繰り返し使用され、リモート ネクストホップに到達可能な、対応する直接接続のネクストホップ(複数可)が特定されます。

オブジェクト トラッキングを導入した信頼性が高いスタティック ルーティングのバックアップ

プライマリ ゲートウェイへの回路が中断された場合に、代替ポートからバックアップ接続を開始するように Cisco NX-OS を設定できます。インターネット回線の障害やピア デバイスの障害などの特定の致命的なイベント発生時に、信頼性の高い導入のバックアップを確保できます。

オブジェクト トラッキングを使用した信頼性の高いスタティック ルーティング バックアップにより、ダイナミック ルーティング プロトコルをイネーブルにする必要なくプライマリ接続の状態を判定できます。また、バックアップ回路を自動的に実行させることなく、ダウンしてはならない重要な回路に使用できる信頼性の高いバックアップ ソリューションが提供されます。

一般的なシナリオでは、リモート ルータのプライマリ インターフェイスは、リモート LAN から本社にトラフィックを転送します。ルータが本社との接続を失うと、追跡対象オブジェクトのステータスはアップからダウンに変化します。この変化が発生すると、ルータはプライマリ インターフェイスのルーティング テーブル エントリを削除し、セカンダリ インターフェイスに事前構成済みのフローティング スタティック ルートをインストールします。次に、ルータのセカンダリ インターフェイスが事前設定された宛先にトラフィックを転送します。バックアップ回路はインターネットを使用するために設定できます。トラッキング対象オブジェクトのステータスがダウンからアップに変化すると、ルータはプライマリ インターフェイスのルーティング テーブル エントリを再インストールし、セカンダリ インターフェイスのフローティング スタティック ルートを削除します。

IP サービス レベル契約

この機能は、ネットワーク モニタリング機能セットである IP サービス レベル契約(IP SLA)を使用し、プライマリ ゲートウェイへの接続状態をモニタするための ICMP ping を生成します。IP SLA は、社内ネットワーク内の公的にルーティング可能な IP アドレスまたはターゲットなどのターゲットに ping するために設定されます。ping はプライマリ インターフェイスからのみルーティングされます。トラック オブジェクトは、IP SLA 設定のステータスをモニタするために作成されます。トラック オブジェクトは、状態の変化が発生した場合に、スタティック ルートであるクライアントに通知します。セカンダリ インターフェイスの事前構成済みフローティング スタティック ルートは、状態がアップからダウンに変化したときにインストールされます。


) ユーザ データグラム プロトコル(UDP)エコー、または IP SLA でサポートされる他のプロトコルが ICMP ping の代わりに使用できます。


IP SLA の詳細については、『 Cisco Nexus 7000 Series NX-OS IP SLAs Configuration Guide 』を参照してください。

BFD

この機能では、双方向フォワーディング検出(BFD)をサポートします。BFD は、転送パスの障害を高速で検出することを目的にした検出プロトコルです。BFD は 2 台の隣接デバイス間のサブセカンド障害を検出し、BFD の負荷の一部を、サポートされるモジュール上のデータ プレーンに分散できるため、プロトコル hello メッセージよりも CPU を使いません。詳細については、『 Cisco Nexus 7000 Series NX-OS Interfaces Configuration Guide 』を参照してください。

仮想化のサポート

スタティック ルートdeは、仮想ルーティング/転送(VRF)インスタンスをサポートします。VRF は仮想化デバイス コンテキスト(VDC)内にあります。デフォルトでは、特に別の VDC および VRF を設定しない限り、Cisco NX-OS によりデフォルト VDC およびデフォルト VRF が使用されます。詳細については、 Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide および「レイヤ 3 仮想化の設定」を参照してください。

スタティック ルーティングのライセンス要件

次の表に、この機能のライセンス要件を示します。

 

製品
ライセンス要件

Cisco NX-OS

スタティック ルーティングにライセンスは不要です。ライセンス パッケージに含まれていない機能はすべて Cisco NX-OS システム イメージにバンドルされており、追加費用は一切発生しません。Cisco NX-OS のライセンス スキームの詳細については、『 Cisco NX-OS Licensing Guide 』を参照してください。

スタティック ルーティングの前提条件

スタティック ルーティングの前提条件は、次のとおりです。

スタティック ルートのネクストホップ アドレスが到達不能な場合、そのスタティック ルートはユニキャスト ルーティング テーブルに追加されません。

スタティック ルーティングの注意事項および制約事項

スタティック ルーティング設定時の注意事項および制約事項は、次のとおりです。

スタティック ルートのネクストホップ アドレスとしてインターフェイスを指定できるのは、総称ルーティング カプセル化(GRE)トンネルなどのポイントツーポイント インターフェイスの場合に限られます。

スタティック ルートの前方参照は、トラック オブジェクトではサポートされません。

デフォルト設定値

表 13-1 に、スタティック ルーティング パラメータのデフォルト設定を示します。

 

表 13-1 デフォルトのスタティック ルーティング パラメータ

パラメータ
デフォルト

アドミニストレーティブ ディスタンス

1

RIP 機能

ディセーブル

スタティック ルーティングの設定

この項では、次のトピックについて取り上げます。

「スタティック ルートの設定」

「VLAN を介したスタティック ルートの設定」

「オブジェクト トラッキングを使用した信頼性が高いスタティック ルーティングのバックアップの設定」

「仮想化の設定」

「スタティック ルーティングの設定確認」


) Cisco IOS の CLI に慣れている場合、この機能に対応する Cisco NX-OS コマンドは通常使用する Cisco IOS コマンドと異なる場合があるので注意してください。


スタティック ルートの設定

ルータ上でスタティック ルートを設定できます。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

ip route { ip-prefix | ip-addr / ip-mask } {[ next-hop | nh-prefix ] | [ interface next-hop | nh-prefix ]} [ name nexthop-name] [ tag tag-value] [ pref ]

 

例:

switch(config)# ip route 192.0.2.0/8 ethernet 1/2 192.0.2.4

スタティック ルートおよびこのスタティック ルート用のインターフェイスを設定します。 ? を使用すると、サポートされているインターフェイスのリストが表示されます。 null 0 を使用すると、ヌル インターフェイスを指定できます。

任意でネクストホップ アドレスを設定できます。

preference 値でアドミニストレーティブ ディスタンスを設定します。指定できる範囲は 1 ~ 255 です。デフォルトは 1 です。

ipv6 route ip6-prefix { nh-prefix | link-local-nh-prefix } | ( nexthop [ interface ] | link-local-nexthop [ interface ]} [ name nexthop-name] [ tag tag-value ] [ pref ]

 

例:

switch(config)# ipv6 route 2001:0DB8::/48 6::6 ethernet 2/1

スタティック ルートおよびこのスタティック ルート用のインターフェイスを設定します。 ? を使用すると、サポートされているインターフェイスのリストが表示されます。 null 0 を使用すると、ヌル インターフェイスを指定できます。

任意でネクストホップ アドレスを設定できます。

preference 値でアドミニストレーティブ ディスタンスを設定します。指定できる範囲は 1 ~ 255 です。デフォルトは 1 です。

ステップ 3

show { ip | ipv6 } static-route

 

例:

switch(config)# show ip static-route

(任意)スタティック ルート情報を表示します。

ステップ 4

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、ヌル インターフェイスのスタティック ルートを設定する例を示します。

switch# configure terminal

switch(config)# ip route 1.1.1.1/32 null 0

switch(config)# copy running-config startup-config

 

スタティック ルートを削除するには、 no { ip | ipv6 } static-route コマンドを使用します。

VLAN を介したスタティック ルートの設定

スイッチ仮想インターフェイス(SVI)とも呼ばれる、VLAN を介したネクスト ホップのサポートなしでスタティック ルートを設定できます。

はじめる前に

アクセス ポートが VLAN の一部であることを確認します。

手順の詳細

 

コマンド
目的

ステップ 1

switch# c onfigure terminal

 

グローバル コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# feature interface-vlan

VLAN インターフェイス モードをイネーブルにします。

ステップ 3

switch(config)# interface vlan vlan-id

スイッチ仮想インターフェイス(SVI)を作成して、インターフェイス コンフィギュレーション モードを開始します。

vlan-id 引数の範囲は 1 ~ 4094 ですが、内部スイッチ用に予約されている VLAN は除きます。

ステップ 4

switch(config-if)# ip address ip-addr / length

 

VLAN の IP アドレスを設定します。

ステップ 5

switch(config-if)# ip route ip-addr / length } vlan-id

SVI 上のネクスト ホップなしでインターフェイスのスタティック ルートを追加します。

IP アドレスは、スイッチに接続されたインターフェイスで設定されるアドレスです。

ステップ 6

switch(config-if)# show ip route

(任意)Unicast Route Information Base(URIB)からルートを表示します。

ステップ 7

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、SVI を介したネクスト ホップなしでスタティック ルートを設定する例を示します。

switch# configure terminal

switch(config)# feature interface-vlan

swicth(config)# interface vlan 10

switch(config-if)# ip address 192.0.2.1/8

switch(config-if)# ip route 209.165.200.224/27 vlan 10 <===209,165.200.224 is the IP address of the interface that is configured on the interface that is directly connected to the switch.

switch(config-if)# copy running-config startup-config

 

スタティック ルートを削除するには、 no ip static-route コマンドを使用します。

オブジェクト トラッキングを使用した信頼性が高いスタティック ルーティングのバックアップの設定

接続がダウンしたときに識別し、代替ポートからバックアップ接続を開始する Internet Control Message Protocol(ICMP)の ping を使用するように Cisco NX-OS を設定できます。

はじめる前に

信頼性が高いスタティック ルーティングのバックアップに使用されるようにプライマリ インターフェイスとバックアップ インターフェイスの両方を設定します(「IPv4 アドレッシングの設定」を参照)。

ポリシーベースのルーティング オブジェクト トラッキングを含む IP SLA を信頼性が高いスタティック ルーティングのバックアップに使用するように設定します(『 Cisco Nexus 7000 Series NX-OS IP SLAs Configuration Guide 』を参照)。

信頼性が高いスタティック ルーティングのバックアップに使用されるようにスタティック ルーティングのルーティング ポリシーを設定します(「スタティック ルーティングの設定」を参照)。

track object-id interface コマンドを使用して、スタティック ルートに関連付けられるようにトラック オブジェクトを作成します(「オブジェクト トラッキングの設定」を参照)。


) トラック オブジェクトを作成する前にトラック オブジェクトに関連付けられたスタティック ルートを設定しようとすると、スタティック ルート コマンドは、スイッチによって受け入れられません。


正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

{ip | ipv6} route ip-prefix ip-mask ip-addr track object-number

 

例:

switch(config)# ip route 0.0.0.0 0.0.0.0 10.1.1.242 track 123

トラック オブジェクトに関連付けられたスタティック ルートを設定します。 object-number 引数は、設定されたトラック オブジェクトがアップの場合にのみスタティック ルートがインストールされるように指定します。

ステップ 3

show {ip | ipv6} static-route track-table

 

例:

switch(config)# show ip static-route track-table

(任意)IPv4 または IPv6 スタティック ルート トラック テーブルに関する情報を表示します。

ステップ 4

show track track-number

 

例:

switch(config)# show track 123

(任意)特定のトラッキング対象オブジェクトに関する情報を表示します。

ステップ 5

{ ip | ipv6 } route network-number network-mask {ip-address | interface} [distance] [ name name]

 

例:

switch(config)# ip route 0.0.0.0 0.0.0.0 10.2.2.125 254

セカンダリ インターフェイスでフローティング IPv4 または IPv6 スタティック ルートを設定します。

ネットワーク プレフィクスおよびマスク長は、トラック オブジェクトに関連付けられたプライマリ インターフェイスに以前設定されたスタティック ルートと同じである必要があります。フローティング スタティック ルートには、トラック オブジェクトに関連付けられたルートより優先順位の高い値が必要です。

仮想化の設定

VRF でスタティック ルートを設定できます。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vrf context vrf-name

 

例:

switch(config)# vrf context StaticVrf

VRF を作成し、VRF コンフィギュレーション モードを開始します。

ステップ 3

ip route { ip-prefix | ip-addr ip-mask } { next-hop | nh-prefix | interface } [ name nexthop-name] [ tag tag-value ] [ pref ]

 

例:

switch(config-vrf)# ip route 192.0.2.0/8 ethernet 1/2

スタティック ルートおよびこのスタティック ルート用のインターフェイスを設定します。 ? を使用すると、サポートされているインターフェイスのリストが表示されます。 null 0 を使用すると、ヌル インターフェイスを指定できます。

任意でネクストホップ アドレスを設定できます。

preference 値でアドミニストレーティブ ディスタンスを設定します。指定できる範囲は 1 ~ 255 です。デフォルトは 1 です。

ipv6 route ip6-prefix { nh-prefix | link-local-nh-prefix } | ( nexthop [ interface ] | link-local-nexthop [ interface ]} [ name nexthop-name] [ tag tag-value ] [ pref ]

 

例:

switch(config)# ipv6 route 2001:0DB8::/48 6::6 ethernet 2/1

スタティック ルートおよびこのスタティック ルート用のインターフェイスを設定します。 ? を使用すると、サポートされているインターフェイスのリストが表示されます。 null 0 を使用すると、ヌル インターフェイスを指定できます。

任意でネクストホップ アドレスを設定できます。

preference 値でアドミニストレーティブ ディスタンスを設定します。指定できる範囲は 1 ~ 255 です。デフォルトは 1 です。

ステップ 4

show { ip | ipv6 } static-route vrf vrf-name

 

例:

switch(config-vrf)# show ip static-route

(任意)スタティック ルート情報を表示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config-vrf)# copy running-config startup-config

(任意)この設定の変更を保存します。

スタティック ルートの設定例を示します。

switch# configure terminal

switch(config)# vrf context StaticVrf

switch(config-vrf)# ip route 192.0.2.0/8 192.0.2.10

switch(config-vrf)# copy running-config startup-config

スタティック ルーティングの設定確認

スタティック ルーティングの設定を表示するには、次のいずれかの作業を行います。

 

コマンド
目的

show {ip | ipv6} static-route

設定されているスタティック ルートを表示します。

show ipv6 static-route vrf vrf-name

各 VRF のスタティック ルートの情報を表示します。

show {ip | ipv6} static-route track-table

IPv4 または IPv6 スタティック ルート トラック テーブルに関する情報を表示します。

show track track-number

特定のトラッキング対象オブジェクトに関する情報を表示します。

スタティック ルーティングの設定例

次に、スタティック ルーティングの設定例を示します。

configure terminal

 ip route 192.0.2.0/8 192.0.2.10

 copy running-config startup-config

 

オブジェクト トラッキングを使用した信頼性が高いスタティック ルーティングのバックアップの設定例

次に、信頼性が高いスタティック ルーティングのバックアップに使用するプライマリ インターフェイスおよびバックアップ インターフェイスを設定する例を示します。

switch# configure terminal
switch(config)# interface Ethernet 1/0
switch(config-if)# description primary-link
switch(config-if)# ip address 209.165.200.225 255.0.0.0
switch(config-if)# exit
switch(config)# interface Ethernet 2/1
switch(config-if)# ip address 209.165.201.1 255.255.255.0
switch(config-if)# exit
 

次に、ポリシーベースのルーティング オブジェクト トラッキングを含む IP SLA を信頼性が高いスタティック ルーティングのバックアップに使用するように設定する例を示します。

switch(config)# ip sla 1
switch(config-ip-sla)# icmp-echo 172.16.23.7
switch(config-ip-sla-echo)# timeout 500
switch(config-ip-sla-echo)# frequency 15
switch(config-ip-sla-echo)# threshold 2
switch(config-ip-sla-echo)# exit
switch(config)# ip sla schedule 10 life forever start-time now
switch(config)# track 123 interface
switch(config-track)# exit
 

次に、信頼性が高いスタティック ルーティングのバックアップに使用されるようにスタティック ルーティングのルーティング ポリシーを設定する例を示します。

switch(config)# ip access-list static-route-acl
switch(config-acl)# permit icmp any host 172.16.23.7 echo
switch(config-acl)# exit
switch(config)# route-map MY-LOCAL-POLICY permit 10
switch(config-route-map)# match ip address static-route-acl
switch(config-route-map)# set ip next-hop 10.1.1.242
switch(config-route-map)# exit
switch(config)# ip local policy route-map MY-LOCAL-POLICY

 

次に、スタティック ルーティングを使用してプライマリ インターフェイスのデフォルト ルートを設定する例を示します。

switch(config)# track 123 interface ethernet 2/1 ip routing
switch(config)# ip route 0.0.0.0 0.0.0.0 10.1.1.242 track 123
または
switch(config)# ip route 5.5.5.0/24 209.165.201.2 track 1
または
switch(config)# ip route 6.6.6.0/24 tunnel 1 track 2
または
switch(config)# ip route 7.7.7.0/24 ethernet 2/1 209.165.201.2 track 3
switch(config)# show ip static-route track-table
Static-route for VRF "default"(1)
IPv4 Unicast Static Routes:
5.5.5.0/24, configured nh: 2.2.2.2/32
(not installed in urib)
rnh(installed in urib)
Track Object Id Associated: 1, Track Object State: UP
switch(config)# show track 123
Interface Ethernet1/1 Line Protocol
Line Protocol is UP
1 changes, last change 00:00:16
Tracked by:
IP_STATIC_ROUTING 0
 

次に、セカンダリ インターフェイスでフローティング スタティック ルートを設定する例を示します。

switch(config)# ip route 0.0.0.0 0.0.0.0 10.1.1.242 254
または
switch(config)# ip route 5.5.5.0/24 209.165.201.2 254
または
switch(config)# ip route 6.6.6.0/24 tunnel 1 254
または
switch(config)# ip route 7.7.7.0/24 ethernet 2/1 209.165.201.2 254

その他の関連資料

スタティック ルーティングの実装に関連する詳細情報については、次の項を参照してください。

「関連資料」

関連資料

関連項目
マニュアル タイトル

スタティック ルーティング CLI

『Cisco Nexus 7000 Series NX-OS Unicast Routing Command Reference

VDC

Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide

スタティック ルーティングの機能の履歴

表 13-2 に、この機能のリリース履歴を示します。

 

表 13-2 スタティック ルーティングの機能の履歴

機能名
リリース
機能情報

VLAN を介したスタティック ルート

6.2(2a)

この機能が導入されました。

オブジェクト トラッキングを使用した信頼性が高いスタティック ルーティングのバックアップ

6.2(2)

この機能が導入されました。

スタティック ルーティング

6.0(1)

F2 シリーズ モジュールが更新されました。

スタティック ルーティング

5.1(1)

ip route コマンドに name オプションが追加されました。

BFD

5.0(2)

BFD のサポートが追加されました。詳細については、『 Cisco Nexus 7000 Series NX-OS Interfaces Configuration Guide 』を参照してください。

スタティック ルーティング

4.0(1)

この機能が導入されました。