Cisco Nexus 7000 シリーズ NX-OS ユニキャスト ルーティング コンフィギュレーション ガイド リリース 6.x
ポリシーベース ルーティングの設定
ポリシーベース ルーティングの設定
発行日;2015/03/23 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 10MB) | フィードバック

目次

ポリシーベース ルーティングの設定

機能情報の確認

ポリシーベース ルーティングに関する情報

ポリシー ルート マップ

ポリシーベース ルーティングの set 基準

ローカル ポリシー ルーティング

ポリシーベース ルーティングのライセンス要件

ポリシーベース ルーティングの前提条件

ポリシーベース ルーティングの注意事項と制約事項

デフォルト設定値

ポリシーベース ルーティングの設定

ポリシーベース ルーティング機能のイネーブル化

ルート ポリシーの設定

ローカル ポリシー ルーティングの設定

ポリシーベース ルーティングの設定確認

ポリシーベース ルーティングの設定例

ローカル ポリシー ルーティングの設定例

関連項目

その他の関連資料

関連資料

標準

ポリシーベース ルーティングの機能の履歴

ポリシーベース ルーティングの設定

この章では、Cisco NX-OS デバイスでポリシー ベース ルーティングを設定する方法について説明します。

この章は、次の項で構成されています。

「機能情報の確認」

「ポリシーベース ルーティングに関する情報」

「ポリシーベース ルーティングのライセンス要件」

「ポリシーベース ルーティングの前提条件」

「ポリシーベース ルーティングの注意事項と制約事項」

「デフォルト設定値」

「ポリシーベース ルーティングの設定」

「ポリシーベース ルーティングの設定確認」

「ポリシーベース ルーティングの設定例」

「ローカル ポリシー ルーティングの設定例」

「関連項目」

「その他の関連資料」

「ポリシーベース ルーティングの機能の履歴」

機能情報の確認

ご使用のソフトウェア リリースで、このモジュールで説明されるすべての機能がサポートされているとは限りません。最新の警告および機能情報については、 https://tool.cisco.com/bugsearch/ の Bug Search Tool およびご使用のソフトウェア リリースのリリース ノートを参照してください。このモジュールに記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「新機能および変更された機能に関する情報」の項または以下の「機能の履歴」表を参照してください。

ポリシーベース ルーティングに関する情報

ポリシーベース ルーティングを使用すると、IPv4 および IPv6 トラフィック フローに定義済みのポリシーを設定し、ルーティング プロトコルから派生したルートへの依存を弱めることができます。ポリシーベース ルーティングがイネーブルのインターフェイスで受信するすべてのパケットは、拡張パケット フィルタまたは ルート マップ を経由して渡されます。ルート マップでは、パケットの転送先を決定するポリシーを記述します。

ルート マップは match 文および set 文からなり、許可または拒否を指定できます。文の解釈は次のとおりです。

パケットがあらゆるルート マップと一致する match 文の場合、すべての set 文が適用されます。そのアクションの 1 つに、ネクスト ホップの選択が含まれます。

文に拒否が指定されている場合、一致基準を満たすパケットは標準のフォワーディング チャネルを通じて送り返され、宛先ベース ルーティングが実行されます。

文に許可が指定されていて、パケットがいずれのルート マップ文にも一致しない場合、そのパケットは通常の転送チャネルを介して返送され、宛先ベースのルーティングが実行されます。

詳細については、「ルート マップ」を参照してください。

ポリシーベース ルーティングには、次の機能が含まれます。

送信元ベース ルーティング:異なるユーザ セットを起点とするトラフィックをポリシー ルータ上のそれぞれ異なる接続を使用してルーティングします。

Quality of Service(QoS):ネットワークの周辺で IP パケット ヘッダーに優先または ToS(タイプ オブ サービス)値を設定することによって、またはキューイング メカニズムを利用して、ネットワークのコアまたはバックボーンでトラフィックにプライオリティを設定することによって、トラフィックを差別化します(『 Cisco Nexus 7000 Series NX-OS Quality of Service Configuration Guide 』を参照)。

ロード シェアリング:トラフィックの特性に基づいて、複数のパスにトラフィックを分散します。

この項では、次のトピックについて取り上げます。

「ポリシー ルート マップ」

「ポリシーベース ルーティングの set 基準」

「ローカル ポリシー ルーティング」

ポリシー ルート マップ

ルート マップの各エントリで、match および set 文のコンビネーションを指定します。match 文では、該当するパケットが特定のポリシーを満たす基準(つまり、満たすべき条件)を定義します。set 文節で、match 基準を満たしたパケットをどのようにルーティングするかを説明します。

ルート マップ文を許可または拒否として指定できます。文に拒否が指定されている場合、一致基準を満たすパケットは標準のフォワーディング チャネルを通じて送り返されます(宛先ベース ルーティングが実行されます)。文に許可が指定されていて、なおかつパケットが一致基準を満たしている場合は、すべての set 文節が適用されます。文に許可が指定されていて、なおかつパケットが一致基準を満たしていない場合は、それらのパケットも標準のルーティング チャネルを通じて転送されます。


) ポリシー ルーティングは、パケットの送信元となるインターフェイスではなく、パケットを受信するインターフェイス上で指定します。


ポリシーベース ルーティングの set 基準

ルート マップの set 基準は、ルート マップに指定された順番で評価されます。ポリシーベース ルーティング用のルート マップに固有の set 基準は、次のとおりです。

1. パケットを通過させてルーティングできるインターフェイスのリスト:複数のインターフェイスを指定した場合は、最初にアップとして検出されたインターフェイスがパケット転送に使用されます。

2. 指定 IP アドレスのリスト:IP アドレスでは、パケットの転送先である宛先へのパス上の隣接ネクストホップ ルータを指定できます。その時点でアップの接続インターフェイスに関連付けられた最初の IP アドレスがパケットのルーティングに使用されます。


) 任意で、最大 16 の IP アドレスにロード バランシングを行うように、ネクストホップ アドレスの set 基準を設定できます。この場合、Cisco NX-OS は各 IP フローのすべてのトラフィックを特定の IP ネクストホップ アドレスに送信します。


3. デフォルト インターフェイス リスト:ポリシー ルーティング対象とされるパケットの宛先アドレスに使用できる明示的ルートがない場合は、ルート マップによって、指定デフォルト インターフェイス リストで最初にアップだったインターフェイスにパケットがルーティングされます。

4. デフォルト ネクストホップ IP アドレスのリスト:ルーティング テーブルに、パケットの宛先アドレスに対応する明示的ルートがない場合は、この set 文で指定されたインターフェイスまたはネクストホップ アドレスだけにルーティングされます。


) 任意で、最大 16 の IP アドレスにトラフィックのロード バランシングを行うように、デフォルトのネクストホップ アドレスの set 基準を設定できます。この場合、Cisco NX-OS は各 IP フローのすべてのトラフィックを特定の IP ネクストホップ アドレスに送信します。


パケットが定義された一致基準のいずれにも一致しない場合、そのパケットは標準の宛先ベース ルーティング プロセスを使用してルーティングされます。

ローカル ポリシー ルーティング

ローカル ポリシー ルーティングでは、ローカル(デバイス生成)トラフィックにルート マップを適用できます。通常はポリシーでルーティングされないデバイスから発信されるすべてのパケットが、ローカル ポリシー ルーティングの対象になります。

ポリシーベース ルーティングのライセンス要件

次の表に、この機能のライセンス要件を示します。

 

製品
ライセンス要件

Cisco NX-OS

ポリシーベース ルーティングには Enterprise Services ライセンスが必要です。Cisco NX-OS ライセンス方式の詳細と、ライセンスの取得および適用の方法については、『 Cisco NX-OS Licensing Guide 』を参照してください。

ポリシーベース ルーティングの前提条件

ポリシーベース ルーティングの前提条件は、次のとおりです。

有効なライセンスをインストールします。

ポリシー ベース ルーティングをイネーブルにする必要があります(「ポリシーベース ルーティング機能のイネーブル化」を参照)。

インターフェイスに IP アドレスを割り当て、インターフェイスをアップにしてから、ポリシーベース ルーティング用のルート マップをインターフェイス上で適用します。

VDC を設定する場合は、適切なライセンスをインストールし、所定の VDC を開始します( 設定情報については 『Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide を、 ライセンス情報については 、『 Cisco NX-OS Licensing Guide 』 を参照してください)。

ポリシーベース ルーティングの注意事項と制約事項

ポリシーベース ルーティングに関する注意事項および制約事項は、次のとおりです。

ポリシーベース ルーティングのルート マップでは、1 つのルート マップ文に match 文または set 文を 1 つだけ指定できます。

match コマンドで、ポリシーベース ルーティング用ルート マップの複数の ACL を参照できません。

インターフェイスが同じ仮想ルーティング/転送(VRF)インスタンスに所属している場合は、ポリシーベース ルーティング対応のさまざまなインターフェイス間で、同じルート マップを共有できます。

ポリシーベース ルーティングのポリシーでネクスト ホップとしてのトンネル インターフェイスを介したトンネル インターフェイスまたは IP アドレスの設定はサポートされません。トンネル インターフェイスへのポリシーベース ルーティングまたは ip policy route-map の適用もサポートされていません。

ポリシーベース ルーティングは、FEX ポートの着信トラフィックでサポートされていません。

一致基準としての prefix-list の使用はサポートされていません。ポリシーベース ルーティングのルートマップで prefix-list を使用しないでください。

Cisco NX-OS Release 6.1 以降では、バンク チェーニングがディセーブルの場合、ポリシーベース ルーティングおよび WCCPv2 は同じインターフェイスでサポートされます。

Cisco NX-OS Release 6.1(3) 以降では、VACL、ポリシーベース ルーティング、および QoS の一連のシーケンスベースの機能において拒否アクセス コントロール エントリ(ACE)をサポートするようにデバイスを設定できます。詳細については、『 Cisco Nexus 7000 Series NX-OS Security Configuration Guide 』の「Configuring VLAN ACLs」の章を参照してください。以前のリリースでは、ポリシーベース ルーティングのルート マップで使用する ACL には、deny 文を含めることができません。

Cisco IOS の CLI に慣れている場合、この機能に対応する Cisco NX-OS コマンドは通常使用する Cisco IOS コマンドと異なる場合があるので注意してください。

デフォルト設定値

表 18-1 に、ポリシーベース ルーティング パラメータのデフォルト設定を示します。

 

表 18-1 デフォルトのポリシーベース ルーティング パラメータ

パラメータ
デフォルト

ポリシーベース ルーティング

ディセーブル

ポリシーベース ルーティングの設定

この項では、次のトピックについて取り上げます。

「ポリシーベース ルーティング機能のイネーブル化」

「ルート ポリシーの設定」

「ローカル ポリシー ルーティングの設定」


) Cisco IOS の CLI に慣れている場合、この機能に対応する Cisco NX-OS コマンドは通常使用する Cisco IOS コマンドと異なる場合があるので注意してください。


ポリシーベース ルーティング機能のイネーブル化

ルート ポリシーを設定する前に、ポリシーベース ルーティング機能をイネーブルにしておく必要があります。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. feature pbr

3. (任意) show feature

4. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

feature pbr

 

例:

switch(config)# feature pbr

ポリシーベース ルーティング機能をイネーブルにします。

ステップ 3

show feature

 

例:

switch(config)# show feature

(任意)イネーブルおよびディセーブルにされた機能を表示します。

ステップ 4

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

ポリシーベース ルーティング機能をディセーブルにして、関連するすべての設定を削除する場合は、 no feature pbr コマンドを使用します。

 

コマンド
目的

no feature pbr

 

例:

switch(config)# no feature pbr

ポリシーベース ルーティングをディセーブルにして、関連するすべての設定を削除します。

ルート ポリシーの設定

ポリシーベース ルーティングでルート マップを使用すると、着信インターフェイスにルーティング ポリシーを割り当てることができます。「ルート マップの設定」を参照してください。

手順の概要

1. configure terminal

2. interface type slot/port

3. ip policy route-map map - name

または

ipv6 policy route-map map - name

4. (任意)exit

5. (任意) exit

6. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface type slot/port

 

例:

switch(config)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

ip policy route-map map-name

 

例:

switch(config-if)# ip policy route-map Testmap

IPv4 ポリシーベース ルーティング用のルート マップをインターフェイスに割り当てます。

ipv6 policy route-map map-name

 

例:

switch(config-if)# ipv6 policy route-map TestIPv6map

IPv6 ポリシーベース ルーティング用のルート マップをインターフェイスに割り当てます。

ステップ 4

exit

 

例:

switch(config-if)# exit

switch(config)#

(任意)インターフェイス コンフィギュレーション モードを終了します。

ステップ 5

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

 

次に、インターフェイスにルート マップを追加する例を示します。

switch# configure terminal

switch(config)# interface ethernet 1/2

switch(config-if)# ip policy route-map Testmap

switch(config)# exit

switch(config)# copy running-config startup-config

 

ルート マップ コンフィギュレーション モードで、オプションとして、ルート マップに次の match パラメータを設定できます。

 

コマンド
目的

match ip address access-list-name name [ name... ]

 

例:

switch(config-route-map)# match ip address access-list-name ACL1

1 つまたは複数の IP アクセス コントロール リスト(ACL)に対して IPv4 アドレスを照合します。このコマンドはポリシーベース ルーティング用であり、ルート フィルタリングまたは再配布では無視されます。

match ipv6 address access-list-name name [ name ... ]

 

例:

switch(config-route-map)# match ipv6 address access-list-name ACLv6

1 つまたは複数の IPv6 ACL に対して IPv6 アドレスを照合します。このコマンドはポリシーベース ルーティング用であり、ルート フィルタリングまたは再配布では無視されます。

match length min max

 

例:

switch(config-route-map)# match length 64 1500

パケット長と照合します。このコマンドはポリシーベース ルーティング用です。

match mac-list maclist [... maclist ]

 

例:

switch(config-route-map)# match mac-list MacList10

MAC アドレスのリストと照合します。このコマンドはポリシーベース ルーティング用です。

match metric metric-value [ +- deviation-number ] [... metric-value [ +- deviation-number ]]

 

例:

switch(config-route-map)# match metric 10

ルーティング プロトコル メトリックと照合します。このコマンドはポリシーベース ルーティング用です。

match vlan vlan-range

 

例:

switch(config-route-map)# match vlan 64

パケットの VLAN ID と照合します。このコマンドはポリシーベース ルーティング用です。

ルート マップ コンフィギュレーション モードで、オプションとして、ルート マップに次の set パラメータを設定できます。

 

コマンド
目的

set ip next-hop address1 [ address2... ] { load-share | peer-address }

 

例:

switch(config-route-map)# set ip next-hop 192.0.2.1

ポリシーベース ルーティング用の IPv4 ネクストホップ アドレスを設定します。このコマンドでは、複数のアドレスが設定されている場合に、最初の有効なネクストホップ アドレスが使用されます。

任意の load-share キーワードを使用して、最大 16 のネクストホップ アドレスにトラフィックのロード バランシングを行います。

set ip default next-hop address1 [ address2... ] { load-share }

 

例:

switch(config-route-map)# set ip default next-hop 192.0.2.2

宛先への明示的ルートがない場合に使用する、ポリシーベース ルーティング用の IPv4 ネクストホップ アドレスを設定します。このコマンドでは、複数のアドレスが設定されている場合に、最初の有効なネクストホップ アドレスが使用されます。

任意の load-share キーワードを使用して、最大 16 のネクストホップ アドレスにトラフィックのロード バランシングを行います。

set ipv6 next-hop address1 [ address2... ] { load-share | peer-address }

 

例:

switch(config-route-map)# set ipv6 next-hop 2001:0DB8::1

ポリシーベース ルーティング用の IPv6 ネクストホップ アドレスを設定します。このコマンドでは、複数のアドレスが設定されている場合に、最初の有効なネクストホップ アドレスが使用されます。

任意の load-share キーワードを使用して、最大 16 のネクストホップ アドレスにトラフィックのロード バランシングを行います。

set ipv6 default next-hop address1 [ address2... ]

 

例:

switch(config-route-map)# set ipv6 default next-hop 2001:0DB8::2

宛先への明示的ルートがない場合に使用する、ポリシーベース ルーティング用の IPv6 ネクストホップ アドレスを設定します。このコマンドでは、複数のアドレスが設定されている場合に、最初の有効なネクストホップ アドレスが使用されます。

set interface { null0 | tunnel-te )

例:

switch(config-route-map)# set interface null0

ルーティングに使用するインターフェイスを設定します。パケットをドロップするには null0 インターフェイスを使用します。MPLS TE トンネルにパケットを転送するには、 tunnel-te インターフェイスを使用します。

set vrf vrf-name

 

例:

switch(config-route-map)# set vrf MainVRF

ネクストホップ解決用の Virtual Routing and Forwarding(VRF)を設定します。

Cisco NX-OS はネクスト ホップおよびインターフェイスを検出すると、ただちにパケットをルーティングします。

ローカル ポリシー ルーティングの設定

デバイスによって生成されたパケットのローカル ポリシー ルーティングをイネーブルにし、デバイスが使用するルート マップを指定できます。

手順の概要

1. configure terminal

2. {ip | ipv6} local policy route-map map - name

3. (任意) show {ip | ipv6} local policy

4. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

{ip | ipv6} local policy route-map map-name

 

例:

switch(config)# ip local policy route-map pbr-src-90

デバイスによって生成されたパケットの IPv4 または IPv6 のローカル ポリシー ルート マップを設定します。

ステップ 3

show {ip | ipv6} local policy

 

例:

switch(config)# show ip local policy

(任意)IPv4 または IPv6 のローカル ポリシー ルーティングに使用されるルート マップを表示します。

ステップ 4

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)この設定の変更を保存します。

ポリシーベース ルーティングの設定確認

ポリシーベース ルーティングの設定情報を表示するには、次の作業のいずれかを行います。

 

コマンド
目的

show [ip | ipv6] policy [name]

IPv4 または IPv6 ポリシーに関する情報を表示します。

show {ip | ipv6} local policy [ vrf name ]

IPv4 または IPv6 のローカル ポリシー ルーティングに使用されるルート マップを表示します。

show route-map [name] pbr-statistics

ポリシー統計情報を表示します。

ポリシー統計をイネーブルにするには、 route-map map-name pbr-statistics を使用します。ポリシー統計を消去するには、 clear route-map map-name pbr-statistics を使用します。

ポリシーベース ルーティングの設定例

インターフェイス上で単純なルート ポリシーを設定する例を示します。

feature pbr
ip access-list pbr-sample
  permit tcp host 10.1.1.1 host 192.168.2.1 eq 80
!
route-map pbr-sample
 match ip address pbr-sample
 set ip next-hop 192.168.1.1
!
route-map pbr-sample pbr-statistics
 
 interface ethernet 1/2
  ip policy route-map pbr-sample
 

次の出力で、この設定を確認します。

switch# show route-map pbr-sample
 
route-map pbr-sample, permit, sequence 10
Match clauses:
ip address (access-lists): pbr-sample
Set clauses:
ip next-hop 192.168.1.1
 
switch# show route-map pbr-sample pbr-statistics
 
route-map pbr-sample, permit, sequence 10
Policy routing matches: 84 packets
 
Default routing: 233 packets

ローカル ポリシー ルーティングの設定例

次に、拡張アクセス リスト 131 で許可された宛先 IP アドレスの一致があるパケットを IP アドレス 172.30.3.20 のルータに送信する例を示します。

ip local policy route-map xyz
!
route-map xyz
match ip address 131
set ip next-hop 172.30.3.20

関連項目

ポリシーベース ルーティングの詳細については、次の項目を参照してください。

「Route Policy Manager の設定」

その他の関連資料

IP の実装に関する詳細情報については、次の各項を参照してください。

「関連資料」

「標準」

関連資料

関連項目
マニュアル タイトル

ポリシーベース ルーティング CLI コマンド

『Cisco Nexus 7000 Series NX-OS Unicast Routing Command Reference

VDC および VRF

『Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide

標準

標準
タイトル

この機能でサポートされる新規の標準または変更された標準はありません。また、既存の標準のサポートは変更されていません。

--

ポリシーベース ルーティングの機能の履歴

表 18-2 に、この機能のリリース履歴を示します。

 

表 18-2 ポリシーベース ルーティングの機能の履歴

機能名
リリース
機能情報

ローカル ポリシー ルーティング

6.2(2)

この機能が導入されました。

ポリシーベース ルーティング

6.1(3)

次の一連のシーケンスベースの機能における拒否アクセス コントロール エントリ(ACE)のサポートが追加されました。VACL、ポリシーベース ルーティング、および QoS。

ポリシーベース ルーティング

6.1(1)

バンク チェーニングがディセーブルの場合、同じインターフェイスのポリシーベース ルーティングおよび WCCPv2 のサポートが追加されました。

インターフェイス

5.2(1)

set interface の route-map コマンドのサポートが追加されました。

IPv6 ポリシー

4.2(1)

IPv6 ポリシーのサポートが追加されました。

ポリシーベース ルーティング

4.0(1)

この機能が導入されました。