Cisco Nexus 7000 シリーズ NX-OS ユニキャスト ルーティング コンフィギュレーション ガイド リリース 6.x
HSRP の設定
HSRP の設定
発行日;2015/03/23 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 10MB) | フィードバック

目次

HSRP の設定

機能情報の確認

HSRP について

HSRP の概要

HSRP のバージョン

IPv4 の HSRP

HSRP for IPv6

HSRP IPv6 アドレス

HSRP のマルチ グループの最適化

HSRP 認証

HSRP メッセージ

HSRP ロード シェアリング

オブジェクト トラッキングおよび HSRP

vPC と HSRP

vPC ピア ゲートウェイと HSRP

FabricPath エニーキャスト HSRP

BFD

ハイ アベイラビリティおよび拡張ノンストップ フォワーディング

仮想化のサポート

HSRP のライセンス要件

HSRPP の前提条件

HSRP の注意事項および制約事項

デフォルト設定値

HSRP の設定

HSRP のイネーブル化

HSRP バージョン設定

IPv4 の HSRP グループの設定

HSRP の設定

この章では、Cisco NX-OS デバイスでホットスタンバイ ルータ プロトコル( HSRP )を設定する方法について説明します。

この章は、次の項で構成されています。

「機能情報の確認」

「HSRP について」

「HSRP のライセンス要件」

「HSRPP の前提条件」

「HSRP の注意事項および制約事項」

「デフォルト設定値」

「HSRP の設定」

「HSRP 設定の確認」

「HSRP の設定例」

「その他の関連資料」

「HSRP 機能の履歴」

機能情報の確認

ご使用のソフトウェア リリースで、このモジュールで説明されるすべての機能がサポートされているとは限りません。最新の警告および機能情報については、 https://tool.cisco.com/bugsearch/ の Bug Search Tool およびご使用のソフトウェア リリースのリリース ノートを参照してください。このモジュールに記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「新機能および変更された機能に関する情報」の項または以下の「機能の履歴」表を参照してください。

HSRP について

HSRP は、ファーストホップ IP ルータの透過的フェールオーバーが可能な、ファーストホップ冗長プロトコル( FHRP )です。HSRP は、デフォルト ルータの IP アドレスを指定して設定された、イーサネット ネットワーク上の IP ホストにファーストホップ ルーティングの冗長性を提供します。ルータ グループでは HSRP を使用して、アクティブ ルータおよびスタンバイ ルータを選択します。ルータのグループにおいて、アクティブ ルータはパケットをルーティングするルータ、スタンバイ ルータはアクティブ ルータに障害が発生したとき、またはプリセットされた条件に一致したときにアクティブ ルータを引き継ぐルータです。

大部分のホストの実装では、ダイナミックなルータ ディスカバリ メカニズムをサポートしていませんが、デフォルトのルータを設定することはできます。すべてのホスト上でダイナミックなルータ ディスカバリ メカニズムを実行するのは、管理上のオーバーヘッド、処理上のオーバーヘッド、セキュリティ上の問題など、さまざまな理由で現実的ではありません。HSRP は、そうしたホスト上にフェールオーバー サービスを提供します。

この項では、次のトピックについて取り上げます。

「HSRP の概要」

「HSRP のバージョン」

「IPv4 の HSRP」

「HSRP for IPv6」

「HSRP のマルチ グループの最適化」

「HSRP 認証」

「HSRP メッセージ」

「HSRP ロード シェアリング」

「オブジェクト トラッキングおよび HSRP」

「vPC と HSRP」

「FabricPath エニーキャスト HSRP」

「BFD」

「ハイ アベイラビリティおよび拡張ノンストップ フォワーディング」

「仮想化のサポート」

HSRP の概要

HSRP を使用する場合、HSRP 仮想 IP アドレス を(実際のルータの IP アドレスではなく)ホストのデフォルト ルータとして設定します。仮想 IP アドレスは、HSRP が動作するルータのグループで共有される IPv4 または IPv6 アドレスです。

ネットワーク セグメントに HSRP を設定する場合は、HSRP グループ用の 仮想 MAC アドレス および仮想 IP アドレスを指定します。グループの各 HSRP 対応インターフェイス上で、同じ仮想アドレスを指定します。各インターフェイス上で、実アドレスとして機能する固有の IP アドレスおよび MAC アドレスも設定します。HSRP はこれらのインターフェイスの 1 つを アクティブ ルータ として選択します。アクティブ ルータは、グループの仮想 MAC アドレス宛てのパケットを受信してルーティングします。

指定されたアクティブ ルータで障害が発生すると、HSRP によって検出されます。この時点で、選択されている スタンバイ ルータ が HSRP グループの仮想 MAC および IP アドレスの制御を引き継ぎます。HSRP はこの時点で、新しいスタンバイ ルータの選択も行います。

HSRP ではプライオリティ指示子を使用して、デフォルトのアクティブ ルータにする HSRP 設定インターフェイスを決定します。アクティブ ルータとしてインターフェイスを設定するには、グループ内の他のすべての HSRP 設定インターフェイスよりも高いプライオリティを与えます。デフォルトのプライオリティは 100 なので、それよりもプライオリティが高いインターフェイスを 1 つ設定すると、そのインターフェイスがデフォルトのアクティブ ルータになります。

HSRP が動作するインターフェイスは、マルチキャスト ユーザ データグラム プロトコル(UDP)ベースの hello メッセージを送受信して、障害を検出し、アクティブおよびスタンバイ ルータを指定します。アクティブ ルータが設定された時間内に hello メッセージを送信できなかった場合は、最高のプライオリティのスタンバイ ルータがアクティブ ルータになります。アクティブ ルータとスタンバイ ルータ間のパケット フォワーディング機能の移動は、ネットワーク上のすべてのホストに対して完全に透過的です。

1 つのインターフェイス上で複数の HSRP グループを設定できます。

図 20-1 に、HSRP 対応として設定されたネットワークを示します。仮想 MAC アドレスおよび仮想 IP アドレスを共有することによって、2 つ以上のインターフェイスを単一の 仮想ルータ として動作させることができます。

図 20-1 2 台の対応ルータを含む HSRP トポロジ

 

仮想ルータは物理的には存在しませんが、相互にバックアップするように設定されたインターフェイスにとって、共通のデフォルト ルータになります。アクティブ ルータの IP アドレスを使用して、LAN 上でホストを設定する必要はありません。代わりに、仮想ルータの IP アドレス(仮想 IP アドレス)をホストのデフォルト ルータとして設定します。アクティブ ルータが設定時間内に hello メッセージを送信できなかった場合は、スタンバイ ルータが引き継いで仮想アドレスに応答し、アクティブ ルータになってアクティブ ルータの役割を引き受けます。ホストの観点からは、仮想ルータは同じままです。


) ルーテッド ポートで受信した HSRP 仮想 IP アドレス宛のパケットは、ローカル ルータ上で終端します。そのルータがアクティブ HSRP ルータであるのかスタンバイ HSRP ルータであるのかは関係ありません。このプロセスには ping トラフィックと Telnet トラフィックが含まれます。レイヤ 2(VLAN)インターフェイスで受信した HSRP 仮想 IP アドレス宛のパケットは、アクティブ ルータ上で終端します。


HSRP のバージョン

Cisco NX-OS は、デフォルトで HSRP バージョン 1 をサポートします。HSRP バージョン 2 を使用するようにインターフェイスを設定できます。

HSRP バージョン 2 では、HSRP バージョン 1 から次のように拡張されています。

グループ番号の範囲が拡大されました。HSRP バージョン 1 がサポートするグループ番号は 0 ~ 255 です。HSRP バージョン 2 がサポートするグループ番号は 0 ~ 4095 です。

IPv4 では、HSRP バージョン 1 で使用する IP マルチキャスト アドレス 224.0.0.2 の代わりに、IPv4 マルチキャスト アドレス 224.0.0.102 または IPv6 マルチキャスト アドレス FF02::66 を使用して hello パケットを送信します。

IPv4 では 0000.0C9F.F000 ~ 0000.0C9F.FFFF、IPv6 アドレスでは 0005.73A0.0000 ~ 0005.73A0.0FFF の MAC アドレス範囲を使用します。HSRP バージョン 1 は、MAC アドレス範囲 0000.0C07.AC00 ~ 0000.0C07.ACFF を使用します。

MD 5 認証のサポートが追加されました。

HSRP のバージョンを変更すると、Cisco NX-OS がグループを再初期化します。新しい仮想 MAC アドレスがグループに与えられるからです。

HSRP バージョン 2 では HSRP バージョン 1 とは異なるパケット フォーマットを使用します。パケット フォーマットは Type-Length-Value(TLV)です。HSRP バージョン 1 ルータは、HSRP バージョン 2 パケットを受信しても無視します。

IPv4 の HSRP

HSRP ルータは HSRP hello パケットを交換することによって、相互に通信します。これらのパケットは、UDP ポート 1985 上の宛先 IP マルチキャスト アドレス 224.0.0.2(すべてのルータと通信するための予約済みマルチキャスト アドレス)に送信されます。アクティブ ルータが設定済みの IP アドレスと HSRP 仮想 MAC アドレスから hello パケットを取得するのに対して、スタンバイ ルータは、設定済みの IP アドレスとインターフェイス MAC アドレス(バーンドイン アドレス(BIA)である可能性があります)から hello パケットを取得します。BIA は、MAC アドレスの下位 6 バイトで、ネットワーク カード(NIC)の製造元によって割り当てられます。

ホストはデフォルト ルータが HSRP 仮想 IP アドレスとして設定されているので、HSRP 仮想 IP アドレスに関連付けられた MAC アドレスと通信する必要があります。この MAC アドレスは、仮想 MAC アドレス 0000.0C07.ACxy です。この場合、xy はそれぞれのインターフェイスに基づく、16 進数の HSRP グループ番号です。たとえば、HSRP グループ 1 は 0000.0C07.AC01 という HSRP 仮想 MAC アドレスを使用します。隣接 LAN セグメント上のホストは、標準のアドレス解決プロトコル(ARP)プロセスを使用して、関連付けられた MAC アドレスを解決します。

HSRP バージョン 2 では新しい IP マルチキャスト アドレス 224.0.0.102 を使用して hello パケットを送信します。バージョン 1 では、このマルチキャスト アドレスが 224.0.0.2 です。バージョン 2 では、拡張グループ番号範囲 0 ~ 4095 を使用できます。また、新しい MAC アドレス範囲 0000.0C9F.F000 ~ 0000.0C9F.FFFF を使用します。

HSRP for IPv6

IPv6 ホストは、IPv6 ネイバー探索(ND)ルータ アドバタイズメント(RA)メッセージを通じて使用可能な IPv6 ルータを学習します。これらのメッセージは、定期的にマルチキャストされる他、ホストによって送信要求されることもあります。ただし、デフォルト ルートがダウンしていることを検出したときの遅延時間は 30 秒以上になることもあります。IPv6 の HSRP は、IPv6 ND プロトコルを使用した場合よりも、代替デフォルト ルータへのスイッチオーバーが大幅に高速であり、ミリ秒タイマーが使用される場合は 1 秒未満になります。IPv6 の HSRP では、IPv6 ホストの仮想ファースト ホップを提供します。

HSRP の IPv6 インターフェイスを設定すると、IPv6 ND がルータのライフタイムがゼロで最終 RA を送信した後で、インターフェイスのリンクローカル アドレスに対する定期 RA が停止します。インターフェイスの IPv6 リンクローカル アドレスに制限はありません。他のプロトコルは、このアドレスへのパケットを送受信し続けます。

IPv6 ND は、HSRP グループがアクティブなときに、HSRP 仮想 IPv6 リンクローカル アドレスの定期 RA を送信します。これらの RA は、HSRP グループがアクティブ状態のままのときに、ルータのライフタイムがゼロで最終 RA が送信されると停止します。HSRP は、アクティブ HSRP グループ メッセージ(hello、coup、redesign)でのみ仮想 MAC アドレスを使用します。

IPv6 の HSRP は、次のパラメータを使用します。

HSRP バージョン 2

UDP ポート 2029

0005.73A0.0000 ~ 0005.73A0.0FFF の範囲の仮想 MAC アドレス

マルチキャスト リンクローカル IP 宛先アドレス FF02::66

ホップ リミット 255

HSRP IPv6 アドレス

HSRP IPv6 グループには、HSRP グループ番号から導出される仮想 MAC アドレス、および HSRP 仮想 MAC アドレスからデフォルトで導出される仮想 IPv6 リンクローカル アドレスがあります。仮想 IPv6 リンクローカル アドレスを形成するために HSRP IPv6 グループのデフォルトの仮想 MAC アドレスが常に使用されます。グループによって実際に使用されている仮想 MAC アドレスは関係ありません。

表 20-1 に、IPv6 ネイバー探索パケットおよび HSRP パケットに使用される MAC アドレスおよび IP アドレスを示します。

表 20-1 HSRP および IPv6 ND アドレス

パケット
送信元 MAC アドレス
送信元 IPv6 アドレス
宛先 IPv6 アドレス
リンク層アドレス オプション

ネイバー送信要求(NS)

インターフェイス MAC アドレス

インターフェイス IPv6 アドレス

--

インターフェイス MAC アドレス

ルータ送信要求(RS)

インターフェイス MAC アドレス

インターフェイス IPv6 アドレス

--

インターフェイス MAC アドレス

ネイバー アドバタイズメント(NA)

インターフェイス MAC アドレス

インターフェイス IPv6 アドレス

仮想 IPv6 アドレス

HSRP 仮想 MAC アドレス

ルート アドバタイズメント(RA)

インターフェイス MAC アドレス

仮想 IPv6 アドレス

--

HSRP 仮想 MAC アドレス

HSRP(非アクティブ)

インターフェイス MAC アドレス

インターフェイス IPv6 アドレス

--

--

HSRP(アクティブ)

仮想 MAC アドレス

インターフェイス IPv6 アドレス

--

--

HSRP は、IPv6 リンクローカル アドレスをユニキャスト ルーティング情報ベース(URIB)に追加しません。リンクローカル アドレスには、セカンダリ仮想 IP アドレスがありません。

グローバル ユニキャスト アドレスの場合は、HSRP によって仮想 IPv6 アドレスが URIB および IPv6 に追加されますが、それらの仮想 IPv6 アドレスは ICMPv6 には登録されません。ICMPv6 リダイレクトは HSRP IPv6 グループでサポートされません。

HSRP のマルチ グループの最適化

Cisco NX-OS Release 6.2(2) 以降では、HSRP はマルチ グループの最適化(MGO)をサポートしています。MGO により、複数の HSRP グループが多くのサブインターフェイスで設定される場合にパフォーマンスと帯域幅が最適化されます。MGO は、アクティブ ルータとスタンバイ ルータを選出するために、物理インターフェイス上でマスター グループとして知られる HSRP グループを 1 つだけ必要とします。

物理インターフェイスまたは SVI インターフェイスなどの異なるインターフェイスのサブインターフェイスで他の HSRP グループを作成し、マスター HSRP グループにこれらをリンクできます。これらのグループは、スレーブ グループと呼ばれます。スレーブ グループは、HSRP 選択メカニズムに参加しないように、それらのマスター グループ ステートに従います。マスター グループは、設定された速度で hello メッセージを送信します。スレーブ グループは、mac-refresh 間隔速度と呼ばれる減速した速度で hello メッセージを送信します。このプロセスは、スイッチやラーニング ブリッジの MAC アドレスを更新するためにスレーブ グループが定期メッセージを送信するために必要です。

HSRP 認証

HSRP Message Digest 5(MD5)アルゴリズム方式の認証は、HSRP スプーフィング ソフトウェアから保護し、業界標準である MD5 アルゴリズムを使用して、信頼性およびセキュリティを向上させます。HSRP では、認証 TLV に IPv4 または IPv6 アドレスが含まれます。

HSRP メッセージ

HSRP が設定されたルータは、次の 3 種類のマルチキャスト メッセージを交換できます。

hello:hello メッセージは、ルータの HSRP プライオリティおよびステート情報を他の HSRP ルータに伝えます。

coup:スタンバイ ルータがアクティブ ルータの機能を引き受けるときに、coup メッセージを送信します。

resign:このメッセージは、アクティブ ルータであるルータがシャットダウン直前、またはプライオリティの高いルータから hello または coup メッセージが送信されたときに、ルータから送信されます。

HSRP ロード シェアリング

HSRP では、1 つのインターフェイス上で複数のグループを設定できます。オーバーラップする 2 つの IPv4 HSRP グループを設定すると、期待されるデフォルト ルータの冗長性を HSRP から提供しながら、接続ホストからのトラフィックのロード シェアリングが可能です。図 20-2 に、ロード シェアリングが行われる HSRP IPv4 構成の例を示します。

図 20-2 HSRP ロード シェアリング

 

図 20-2 に、ルータ A、ルータ B、および 2 つの HSRP グループを示します。ルータ A はグループ A のアクティブ ルータであり、グループ B のスタンバイ ルータです。同様に、ルータ B はグループ B のアクティブ ルータであり、グループ A のスタンバイ ルータです。両方のルータがアクティブである限り、HSRP は両方のルータにわたって、ホストからのトラフィックのロード バランシングを図ります。どちらかのルータで障害が発生すると、残りのルータが引き続き、両方のホストのトラフィックを処理します。


) IPv6 の HSRP では、デフォルトでロード バランシングを行います。サブネット上に 2 つの HSRP IPv6 グループが存在する場合、ホストはそれぞれのルータ アドバタイズメントから両方のグループを学習し、アドバタイズされたルータ間で負荷が共有されるように 1 つのグループを使用することを選択します。


オブジェクト トラッキングおよび HSRP

オブジェクト トラッキングを使用すると、別のインターフェイスの動作状態に基づいて、HSRP インターフェイスのプライオリティを変更できます。オブジェクト トラッキングによって、メイン ネットワークへのインターフェイスで障害が発生した場合に、スタンバイ ルータにルーティングできます。

トラッキング可能なオブジェクトは、インターフェイスのライン プロトコル ステートまたは IP ルートの到達可能性の 2 種類です。指定したオブジェクトがダウンすると、設定された値だけ、Cisco NX-OS が HSRP プライオリティを引き下げます。詳細については、「HSRP オブジェクト トラッキングの設定」を参照してください。

vPC と HSRP

HSRP は、仮想ポート チャネル(vPC)と連携します。vPCs を使用すると、2 つの異なる Cisco Nexus 7000 シリーズ デバイスに物理的に接続しているリンクが、別のデバイスからは単一のポート チャネルとして認識できます。vPC の詳細については、『 Cisco Nexus 7000 Series NX-OS Layer 2 Switching Configuration Guide 』を参照してください。

vPC は、アクティブ HSRP ルータとスタンバイ HSRP ルータの両方を通じてトラフィックを転送します。詳細については、「HSRP プライオリティの設定」および「HSRP の設定例」を参照してください。


) プライマリ vPC ピア デバイス上の HSRP をアクティブ、vPC セカンダリ デバイス上の HSRP をスタンバイとして設定する必要があります。


vPC ピア ゲートウェイと HSRP

一部のサード パーティ製デバイスは HSRP 仮想 MAC アドレスを無視し、代わりに HSRP ルータの送信元 MAC アドレスを使用する場合があります。vPC 環境では、この送信元 MAC アドレスを使用するパケットが vPC ピア リンク経由で送信され、それによってパケットのドロップが発生する可能性があります。vPC ピア ゲートウェイを設定して、HSRP ルータで、ローカル vPC ピア MAC アドレスとリモート vPC ピア MAC アドレス、および HSRP 仮想 MAC アドレスに送信されたパケットを直接処理できるようにします。vPC ピア ゲートウェイの詳細については、『 Cisco Nexus 7000 Series NX-OS Layer 2 Switching Configuration Guide 』を参照してください。


) F シリーズ モジュール上に vPC ピア リンクが設定されている混在シャーシの構成では、vPC ピア リンクを移動するレイヤ 3 バックアップ ルートを除外するために、vPC ピア ゲートウェイの exclude オプションを設定します。vPC ピア ゲートウェイの除外オプションの詳細については、『Cisco Nexus 7000 Series NX-OS Layer 2 Switching Configuration Guide』を参照してください。


FabricPath エニーキャスト HSRP

Cisco NX-OS Release 6.2(2) 以降のリリースでは、3 つ以上のノードに対するサポートを提供することでスパイン レイヤのさらなるスケーラビリティが促進されます。一連の VLAN とエニーキャストのスイッチ ID とのアソシエーションであるエニーキャスト バンドルを作成できます。VLAN または HSRP グループのセットは、アクティブ ルータとスタンバイ ルータを選択します。グループの残りのルータはリッスン状態にあります。

設定されたエニーキャスト スイッチ ID を持つすべての HSRP ルータは、FabricPath IS-IS を介してその ID をアドバタイズします。アクティブな HSRP ルータは、その hello パケットでエニーキャスト スイッチ ID を使用する唯一のルータです。リーフ スイッチは、エニーキャスト スイッチ ID がグループ内のすべてのルータによって到達可能であることを学習します。

スパイン レイヤのすべてのファースト ホップ ゲートウェイは、アクティブ-アクティブ フォワーディング モードで機能する必要があります。IP パケットは、宛先がゲートウェイ MAC アドレスとして設定されたスパイン スイッチによって受信され、これらのパケットが終了しローカル的に転送されます。この機能の詳細については、『 Cisco Nexus 7000 Series NX-OS FabricPath Configuration Guide 』を参照してください。

BFD

この機能では、双方向フォワーディング検出(BFD)をサポートします。BFD は、高速転送とパス障害の検出時間を提供する検出プロトコルです。BFD は 2 台の隣接デバイス間のサブセカンド障害を検出し、BFD の負荷の一部を、サポートされるモジュール上のデータ プレーンに分散できるため、プロトコル hello メッセージよりも CPU を使いません。詳細については、 『Cisco Nexus 7000 Series NX-OS Interfaces Configuration Guide, Release 6.x』 を参照してください。

ハイ アベイラビリティおよび拡張ノンストップ フォワーディング

HSRP は、ステートフル リスタートおよびステートフル スイッチオーバーをサポートします。ステートフル リスタートは、HSRP プロセスが失敗してリスタートするときに行われます。ステートフル スイッチオーバーは、アクティブ スーパーバイザがスタンバイ スーパーバイザに切り替わるときに行われます。Cisco NX-OS は、スイッチオーバー後に実行コンフィギュレーションを適用します。

HSRP ホールド タイマーが短時間に設定されている場合は、制御されたスイッチオーバーまたはインサービス ソフトウェア アップグレード(ISSU)中に、これらのタイマーが切れる可能性があります。HSRP では、拡張ノンストップ フォワーディング(NSF)をサポートしており、制御されたスイッチオーバーまたは ISSU 時は一時的にこれらの HSRP ホールド タイマーを延長します。

拡張 NSF を設定している場合、HSRP は延長されたタイマーを使用して hello メッセージを送信します。HSRP ピアは、この新しい値でホールド タイマーを更新します。タイマーが延長されることにより、スイッチオーバーまたは ISSU 時に不要な HSRP 状態の変更が発生することを防ぎます。スイッチオーバーまたは ISSU イベント後に、HSRP はホールド タイマーを元の設定値に復元します。スイッチオーバーに失敗すると、延長されたホールド タイマー値が満了してから HSRP はホールド タイマーを復元します。

詳細については、「HSRP の拡張ホールド タイマーの設定」を参照してください。

仮想化のサポート

HSRP は、仮想ルーティングおよび転送(VRF)インスタンスをサポートします。VRF は仮想化デバイス コンテキスト(VDC)内にあります。デフォルトでは、特に別の VDC および VRF を設定しない限り、Cisco NX-OS によりデフォルト VDC およびデフォルト VRF が使用されます。

インターフェイスの VRF メンバーシップを変更すると、Cisco NX-OS によって HSRP を含め、すべてのレイヤ 3 設定が削除されます。

詳細については、 Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide 』および「レイヤ 3 仮想化の設定」 を参照してください。

HSRP のライセンス要件

次の表に、この機能のライセンス要件を示します。

 

製品
ライセンス要件

Cisco NX-OS

HSRP にライセンスは不要です。ライセンス パッケージに含まれていない機能はすべて Cisco NX-OS システム イメージにバンドルされており、追加費用は一切発生しません。Cisco NX-OS のライセンス スキームの詳細については、『 Cisco NX-OS Licensing Guide 』を参照してください。

HSRPP の前提条件

HSRP グループを設定してイネーブルにするには、その前に HSRP 機能をデバイスでイネーブルにする必要があります。

VDC を設定する場合は、適切なライセンスをインストールし、所定の VDC を開始します( 設定情報については Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide を、 ライセンス情報については 、『 Cisco NX-OS Licensing Guide 』 を参照してください)。

HSRP の注意事項および制約事項

HSRP 設定時の注意事項および制約事項は、次のとおりです。

HSRP を設定するインターフェイスに IP アドレスを設定し、そのインターフェイスをイネーブルにしてからでなければ、HSRP はアクティブになりません。

HSRP に IPv6 インターフェイスを設定するときは、HSRP バージョン 2 を設定する必要があります。

IPv4 では、仮想 IP アドレスは、インターフェイス IP アドレスと同じサブネットになければなりません。

同一インターフェイス上では、複数のファーストホップ冗長プロトコルを設定しないことを推奨します。

HSRP バージョン 2 は HSRP バージョン 1 と相互運用できません。どちらのバージョンも相互に排他的なので、インターフェイスはバージョン 1 およびバージョン 2 の両方を運用できません。しかし、同一ルータの異なる物理インターフェイス上であれば、異なるバージョンを実行できます。

バージョン 1 で認められるグループ番号範囲(0 ~ 255)を超えるグループを設定している場合は、バージョン 2 からバージョン 1 への変更はできません。

IPv4 に対する HSRP は、BFD でサポートされます。IPv6 に対する HSRP は、BFD でサポートされていません。

インターフェイス VRF メンバーシップ、ポート チャネル メンバーシップを変更した場合、またはポート モードをレイヤ 2 に変更した場合は、Cisco NX-OS によってインターフェイス上のすべてのレイヤ 3 設定が削除されます。

vPC で仮想 MAC アドレスを設定するときは、vPC ピアの両方で同じ仮想 MAC アドレスを設定する必要があります。

F シリーズ モジュール上に vPC ピア リンクが設定されている混在シャーシの構成では、vPC ピア リンクを移動するレイヤ 3 バックアップ ルートを除外するために、vPC ピア ゲートウェイの exclude オプションを設定します。

vPC メンバである VLAN インターフェイスで HSRP MAC アドレスのバーンドイン オプションは使用できません。

認証を設定していない場合、 show hsrp コマンドは次の文字列を表示します。

Authentication text "cisco"

HSRP のデフォルトの動作は RFC 2281 で定義されています。

認証データが設定されていない場合、推奨されるデフォルト
値は 0x63 0x69 0x73 0x63 0x6F 0x00 0x00 0x00 です。

MGO 用 HSRP に関する制約事項は、次のとおりです。

マスター グループとスレーブ グループは、同じインターフェイスに制限されません。

MGO の HSRP は、HSRP バージョン 2 のみをサポートしています。

マスター グループとスレーブ グループは、同じアドレス タイプでなければなりません。

スレーブ グループとして HSRP グループを設定すると、仮想 IP アドレスなどのグループの他の設定が通知なしで消去されるため、ip ip-address コマンドを入力する前に follow コマンドを入力する必要があります。

双方向フォワーディング(BFD)は、スレーブ グループには適用されません。

MGO の HSRP は、IPv4 と IPv6 の両方のインターフェイスをサポートし、通常の HSRP グループが動作するすべてのレイヤ 3 インターフェイスで動作します。

HSRP グループは、マスター グループとスレーブ グループの両方として同時に設定できません。

デフォルト設定値

表 20-2 に、HSRP パラメータのデフォルト設定を示します。

 

表 20-2 デフォルトの HSRP パラメータ

パラメータ
デフォルト

HSRP

ディセーブル

認証

バージョン 1 の場合はテキストとしてイネーブル、パスワードは cisco

HSRP バージョン

バージョン 1

プリエンプション

ディセーブル

プライオリティ

100

仮想 MAC アドレス

HSRP グループ番号から生成

HSRP の設定

この項では、次のトピックについて取り上げます。

「HSRP のイネーブル化」

「HSRP バージョン設定」

「IPv4 の HSRP グループの設定」

「IPv6 の HSRP グループの設定」

「MGO の HSRP グループの設定」

「HSRP 仮想 MAC アドレスの設定」

「HSRP の認証」

「HSRP オブジェクト トラッキングの設定」

「HSRP プライオリティの設定」

「HSRP のカスタマイズ」

「HSRP の拡張ホールド タイマーの設定」


) Cisco IOS の CLI に慣れている場合、この機能に対応する Cisco NX-OS コマンドは通常使用する Cisco IOS コマンドと異なる場合があるので注意してください。


HSRP のイネーブル化

HSRP グループを設定してイネーブルにするには、その前に HSRP をグローバルでイネーブルにする必要があります。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の詳細

VDC で HSRP 機能をイネーブルにするには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

feature hsrp

 

switch(config)# feature hsrp

HSRP をイネーブルにします。

VDC で HSRP 機能をディセーブルにし、関連付けられた設定をすべて削除するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

no feature hsrp

 

switch(config)# no feature hsrp

VDC ですべてのグループの HSRP をディセーブルにします。

HSRP バージョン設定

HSRP のバージョンを設定できます。既存グループのバージョンを変更すると、仮想 MAC アドレスが変更されるので、Cisco NX-OS がそれらのグループの HSRP を再初期化します。HSRP のバージョンは、インターフェイス上のすべてのグループに適用されます。


) IPv6 HSRP グループは、HSRP バージョン 2 として設定する必要があります。


HSRP のバージョンを設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

hsrp version { 1 | 2 }

 

switch(config-if)# hsrp version 2

HSRP バージョンを設定します。デフォルトはバージョン 1 です。

IPv4 の HSRP グループの設定

IPv4 インターフェイス上で HSRP グループを設定し、その HSRP グループに仮想 IP アドレスおよび仮想 MAC アドレスを設定できます。

はじめる前に

HSRP 機能がイネーブルになっていることを確認します(「HSRP のイネーブル化」を参照)。

Cisco NX-OS では、仮想 IP アドレスを設定すると HSRP グループがイネーブルになります。HSRP グループをイネーブルにする前に、認証、タイマー、プライオリティなどの HSRP 属性を設定する必要があります。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. interface type number

3. ip address ip-address/length

4. hsrp group-number [ ipv4 ]

5. ip [ ip-address [ secondary ]]

6. exit

7. no shutdown

8. (任意)show hsrp [group group-number ] [ ipv4 ]

9. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface type number

 

例:

switch(config)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

ip address ip-address/length

 

switch(config-if)# ip 192.0.2.2/8

インターフェイスの IPv4 アドレスを設定します。

ステップ 4

hsrp group-number [ ipv4 ]

 

switch(config-if)# hsrp 2

switch(config-if-hsrp)#

HSRP グループを作成し、HSRP コンフィギュレーション モードを開始します。HSRP バージョン 1 で指定できる範囲は 0 ~ 255 です。HSRP バージョン 2 で指定できる範囲は 0 ~ 4095 です。デフォルト値は 0 です

ステップ 5

ip [ ip-address [ secondary ]]

 

switch(config-if-hsrp)# ip 192.0.2.1

HSRP グループの仮想 IP アドレスを設定し、グループをイネーブルにします。このアドレスは、インターフェイスの IPv4 アドレスと同じサブネットになければなりません。

ステップ 6

exit

 

switch(config-if-hsrp)# exit

HSRP コンフィギュレーション モードを終了します。

ステップ 7

no shutdown

 

switch(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 8

show hsrp [ group group-number ] [ ipv4 ]

 

switch(config-if)# show hsrp group 2

(任意)HSRP 情報を表示します。

ステップ 9

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

 


) 設定完了後にインターフェイスをイネーブルにするには、no shutdown コマンドを使用する必要があります。


次に Ethernet 1/2 上で HSRP グループを設定する例を示します。

switch# configure terminal

switch(config)# interface ethernet 1/2

switch(config-if)# ip 192.0.2.2/8

switch(config-if)# hsrp 2

switch(config-if-hsrp)# ip 192.0.2.1

switch(config-if-hsrp)# exit

switch(config-if)# no shutdown

switch(config-if)# copy running-config startup-config

IPv6 の HSRP グループの設定

IPv6 インターフェイス上で HSRP グループを設定し、その HSRP グループに仮想 MAC アドレスを設定できます。

IPv6 の HSRP グループを設定すると、HSRP はリンクローカル プレフィックスからリンクローカル アドレスを生成します。HSRP では、Modified EUI-64 形式のインターフェイス ID も生成します。EUI-64 インターフェイス ID は、関連の HSRP 仮想 MAC アドレスから作成されます。

はじめる前に

HSRP をイネーブルにする必要があります(「HSRP のイネーブル化」を参照)。

IPv6 HSRP グループを設定するインターフェイスで HSRP バージョン 2 がイネーブルになっていることを確認します。

HSRP グループをイネーブルにする前に、認証、タイマー、プライオリティなどの HSRP 属性を設定してあることを確認します。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. interface type number

3. ipv6 address ipv6-address/length

4. hsrp version 2

5. hsrp group-number ipv6

6. ip ipv6-address

7. ip autoconfig

8. no shutdown

9. (任意)show hsrp [group group-number ] [ ipv6 ]

10. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface type number

 

例:

switch(config)# interface ethernet 3/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

ipv6 address ipv6-address/length

 

switch(config-if)# ipv6 address 2001:0DB8::0001:0001/64

インターフェイスの IPv6 アドレスを設定します。

ステップ 4

hsrp version 2

 

switch(config-if-hsrp)# hsrp version 2

HSRP バージョン 2 にこのグループを設定します。

ステップ 5

hsrp group-number ipv6

 

switch(config-if)# hsrp 10 ipv6

switch(config-if-hsrp)#

IPv6 HSRP グループを作成し、HSRP コンフィギュレーション モードを開始します。HSRP バージョン 2 で指定できる範囲は 0 ~ 4095 です。デフォルト値は 0 です

ステップ 6

ip ipv6-address

 

switch(config-if-hsrp)# ip 2001:DB8::1

HSRP グループの仮想 IPv6 アドレスを設定し、そのグループをイネーブルにします。

ステップ 7

ip autoconfig

 

switch(config-if-hsrp)# ip autoconfig

計算されたリンクローカル仮想 IPv6 アドレスから HSRP グループの仮想 IPv6 アドレスを自動設定し、グループをイネーブルにします。

ステップ 8

no shutdown

 

switch(config-if-hsrp)# no shutdown

インターフェイスをイネーブルにします。

ステップ 9

show hsrp [ group group-number ] [ ipv6 ]

 

switch(config-if-hsrp)# show hsrp group 10

(任意)HSRP 情報を表示します。

ステップ 10

copy running-config startup-config

 

例:

switch(config-if-hsrp)# copy running-config startup-config

(任意)この設定の変更を保存します。

 


) 設定完了後にインターフェイスをイネーブルにするには、no shutdown コマンドを使用する必要があります。


次に Ethernet 3/2 上で IPv6 HSRP グループを設定する例を示します。

switch# configure terminal

switch(config)# interface ethernet 3/2

switch(config-if)# ipv6 address 2001:0DB8::0001:0001/64

switch(config-if-hsrp)# hsrp version 2

switch(config-if)# hsrp 2 ipv6

switch(config-if-hsrp)# ip 2001:DB8::1

switch(config-if-hsrp)# exit

switch(config-if)# no shutdown

switch(config-if)# copy running-config startup-config

MGO の HSRP グループの設定

マスター グループおよびスレーブ グループを設定することによるスケーリング時のパフォーマンスを最適化するように MGO の HSRP を設定できます。スレーブ グループは、送信される hello メッセージの数を最小化するマスター グループ ステートに従います。Cisco NX-OS では、仮想 IP アドレスを設定すると HSRP グループがイネーブルになります。


) スレーブ グループがマスター グループと同じ冗長性要件を持つことができるように、マスター グループをスレーブ グループと同じ親インターフェイスに設定することを推奨します。マスター リンクで障害が発生した場合、設定されたリンクが残っていても、スレーブ グループもすべてダウンします。


HSRP マスター グループの設定

はじめる前に

HSRP 機能がイネーブルになっていることを確認します(「HSRP のイネーブル化」を参照)。

HSRP グループをマスター グループとしてイネーブルにする前に、認証、タイマー、プライオリティなどの HSRP 属性を設定します。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. interface type number

3. ip address ip-address/length

4. hsrp version 2

5. [no] hsrp group-number [ ipv6 ]

6. [no] name [master-group-name]

7. ip [ ip-address [secondary] ]

8. exit

9. no shutdown

10. (任意)show hsrp [brief] [group group-number ] [ ipv4 ] [ipv6]

11. (任意)show hsrp mgo [name name ] [brief]

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface type number

 

例:

switch(config)# interface ethernet 1/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始し、インターフェイス タイプを設定します。

ステップ 3

ip address ip-address/length

 

switch(config-if)# ip address 11.0.0.1/24

インターフェイスの IP アドレスを設定します。

ステップ 4

hsrp version 2

 

switch(config-if)# hsrp version 2

HSRP バージョンを設定します。

(注) MGO が HSRP バージョン 2 のみをサポートするため、HSRP バージョンをバージョン 2 に設定する必要があります。デフォルトはバージョン 1 です。

ステップ 5

[no] hsrp group-number [ ipv6 ]

 

switch(config-if)# hsrp 11

switch(config-if-hsrp)#

HSRP グループを作成し、HSRP コンフィギュレーション モードを開始します。HSRP グループ番号の範囲は 0 ~ 4095 です。

このコマンドの no 形式を使用すると、グループは削除されます。

ステップ 6

[no] name [master-group-name]

 

switch(config-if-hsrp)# name master1

マスター グループ名を指定します。name コマンドを使用すると、通常の HSRP グループがマスター グループに変わります。名前を指定しないと、一意の名前が自動的に生成されます。

このコマンドの no 形式を使用すると、マスター グループが通常の HSRP グループに戻ります。

ステップ 7

ip [ ip-address [secondary] ]

 

switch(config-if-hsrp)# ip 11.0.0.100

HSRP グループの仮想 IP アドレスを設定し、マスター グループをイネーブルにします。

ステップ 8

exit

 

switch(config-if-hsrp)# exit
switch(config-if)#

HSRP コンフィギュレーション モードを終了します。

ステップ 9

no shutdown

 

switch(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 10

show hsrp [brief] [ group group-number ] [ ipv4 ] [ipv6]

 

switch(config-if)# show hsrp group 11

(任意)HSRP 情報を表示します。

ステップ 11

show hsrp mgo [ name name] [brief]

 

switch(config-if)# show hsrp mgo name master1

 

 

(任意)MGO に使用中の HSRP グループとそれらのスレーブ セッションとの関係を表示します。name キーワードは、一致する設定名を持つセッションへの出力を制限します。brief キーワードは、各 MGO セッションのサマリーに関連するスレーブ セッションを提供します。

次に、イーサネット インターフェイス 1/1 上で HSRP マスター グループを設定する例を示します。

switch# configure terminal

switch(config)# interface ethernet 1/1

switch(config-if)# ip address 11.0.0.1/24

switch(config-if)# hsrp version 2

switch(config-if)# hsrp 11

switch(config-if-hsrp)# name master1

switch(config-if-hsrp)# ip 11.0.0.100

switch(config-if-hsrp)# exit

switch(config-if)# no shutdown

switch(config-if)# show hsrp group 11

switch(config-if)# show hsrp mgo name master1

HSRP スレーブ グループの設定


) マスター グループとは異なるインターフェイスに属するスレーブ リンクで障害が発生すると、追従しているグループの状態に関係なく、スレーブ グループはダウンします。


はじめる前に

HSRP 機能がイネーブルになっていることを確認します(「HSRP のイネーブル化」を参照)。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. interface type number

3. ip address ip-address/length

4. hsrp version 2

5. (任意)hsrp mac-refresh seconds

6. [no] hsrp group-number [ ipv6 ]

7. [no] follow master-group-name

8. ip [ip-address]

9. exit

10. no shutdown

11. (任意)show hsrp [brief] [group group-number ] [ ipv4 ] [ipv6]

12. (任意)show hsrp mgo [ name name] [brief]

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface type number

 

例:

switch(config)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始し、インターフェイス タイプを設定します。

ステップ 3

ip address ip-address/length

 

switch(config-if)# ip 12.0.0.1/24

インターフェイスの IP アドレスを設定します。

ステップ 4

hsrp version 2

 

switch(config-if)# hsrp version 2

HSRP バージョンを設定します。

(注) MGO が HSRP バージョン 2 のみをサポートするため、HSRP バージョンをバージョン 2 に設定する必要があります。デフォルトはバージョン 1 です。

ステップ 5

hsrp mac-refresh seconds

 

switch(config-if)# hsrp mac-refresh 30

(任意)HSRP スレーブ グループの MAC リフレッシュ間隔を設定します。このコマンドを使用して、複数のサブインターフェイスが設定されている場合に、送信される hello メッセージの数を最小化して、HSRP のプロトコル オーバーヘッドと CPU 使用率を削減することができます。

このコマンドは、個別のサブインターフェイスでは使用できません。これは、すべてのサブインターフェイス上のすべてのグループに適用されます。デフォルトは 60 秒です。範囲は 0 ~ 10000 です。

ステップ 6

[no] hsrp group-number [ ipv6 ]

 

switch(config-if)# hsrp 12

switch(config-if-hsrp)#

HSRP グループを作成し、HSRP コンフィギュレーション モードを開始します。範囲は 0 ~ 4095 です。

このコマンドの no 形式を使用すると、グループは削除されます。

ステップ 7

[no] follow master-group-name

 

switch(config-if-hsrp)# follow master1

通常の HSRP グループをスレーブ グループとして設定します。

(注) スレーブ グループとして HSRP グループを設定すると、仮想 IP アドレスなどのグループの他の設定が通知なしで消去されるため、ip ip-address コマンドを入力する前に follow コマンドを入力する必要があります。

(注) スレーブ グループは、未定義のリファレンス マスター グループ名を転送する場合があります。

このコマンドの no 形式を使用すると、スレーブ グループが通常の HSRP グループに戻ります。

ステップ 8

ip [ip-address]

 

switch(config-if-hsrp)# ip 12.0.0.100

HSRP グループの仮想 IP アドレスを設定し、スレーブ グループをイネーブルにします。

ステップ 9

exit

 

switch(config-if-hsrp)# exit

switch(config-if)#

HSRP コンフィギュレーション モードを終了します。

ステップ 10

no shutdown

 

switch(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 11

show hsrp [brief] [ group group-number ] [ ipv4 ] [ipv6]

 

switch(config-if)# show hsrp group 12

(任意)HSRP 情報を表示します。

ステップ 12

show hsrp mgo [ name name] [brief]

 

switch(config-if)# show hsrp mgo name master1

 

 

(任意)MGO に使用中の HSRP グループとそれらのスレーブ セッションとの関係を表示します。name キーワードは、一致する設定名を持つセッションへの出力を制限します。brief キーワードは、各 MGO セッションのサマリーに関連するスレーブ セッションを提供します。

次に、イーサネット インターフェイス 1/2 でスレーブ グループを設定する例を示します。

switch# configure terminal

switch(config)# interface ethernet 1/2

switch(config-if)# ip 12.0.0.1/24

switch(config-if)# hsrp version 2

switch(config-if)# hsrp 12

switch(config-if-hsrp)# follow master1

switch(config-if-hsrp)# ip 12.0.0.100

switch(config-if-hsrp)# exit

switch(config-if)# no shutdown

switch(config-if)# show hsrp mgo name master1

 

次に、イーサネット サブインターフェイス 1/1.1 でスレーブ グループを設定する例を示します。

switch# configure terminal

switch(config)# interface ethernet 1/1.1

switch(config-if)# ip 12.1.1.1/24

switch(config-if)# hsrp version 2

switch(config-if)# hsrp 12

switch(config-if-hsrp)# follow master1

switch(config-if-hsrp)# ip 12.1.1.100

switch(config-if-hsrp)# exit

switch(config-if)# no shutdown

switch(config-if)# show hsrp mgo name master1

HSRP 仮想 MAC アドレスの設定

設定されたグループ番号に基づいて HSRP が生成したデフォルト仮想 MAC アドレスを変更できます。


) vPC リンクの vPC ピアの両方で同じ仮想 MAC アドレスを設定する必要があります。


HSRP グループの仮想 MAC アドレスを手動で設定するには、HSRP コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

mac-address string

 

switch(config-if-hsrp)# mac-address 5000.1000.1060

HSRP グループの仮想 MAC アドレスを設定します。ストリングには標準の MAC アドレス フォーマット(xxxx.xxxx.xxxx)を使用します。

仮想 MAC アドレスに BIA(バーンドイン MAC アドレス)を使用するように HSRP を設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

hsrp use-bia [ scope interface ]

 

switch(config-if)# hsrp use-bia

HSRP 仮想 MAC アドレスにインターフェイスの BIA を使用するように、HSRP を設定します。任意で scope interface キーワードを使用すると、このインターフェイス上のすべてのグループに BIA を使用するように HSRP を設定できます。

HSRP の認証

クリアテキストまたは MD5 ダイジェスト認証を使用してプロトコルを認証するように、HSRP を設定できます。MD5 認証ではキーチェーンを使用します( Cisco Nexus 7000 Series NX-OS Security Configuration Guide 』を参照)。

はじめる前に

HSRP をイネーブルにする必要があります(「HSRP のイネーブル化」を参照)。

HSRP グループのすべてのメンバに同じ認証およびキーを設定する必要があります。

MD5 認証を使用する場合は、キーチェーンが作成してあることを確認します。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. interface interface- type slot/port

3. hsrp group- number [ ipv4 | ipv6 ]

4. authentication text string

または

authentication md5 { key-chain key-chain | key-string { 0 | 7 } text [ timeout seconds ]}

5. (任意)show hsrp [ group group-number ]

6. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-type slot/port

 

例:

switch(config)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

hsrp group-number [ ipv4 | ipv6 ]

 

switch(config-if)# hsrp 2

switch(config-if-hsrp)#

HSRP グループを作成し、HSRP コンフィギュレーション モードを開始します。

ステップ 4

authentication text string

 

switch(config-if-hsrp)# authentication text mypassword

このインターフェイス上で、HSRP のクリアテキスト認証を設定します。

authentication md5 { key-chain key-chain | key-string { 0 | 7 } text [ timeout seconds ]}

 

switch(config-if-hsrp)# authentication md5 key-chain hsrp-keys

このインターフェイス上で、HSRP の MD5 認証を設定します。キーチェーンまたはキー ストリングを使用できます。キー ストリングを使用する場合は、必要に応じて、HSRP が新しいキーのみを受け入れる時間のタイムアウトを設定できます。指定できる範囲は 0 ~ 32767 秒です。

ステップ 5

show hsrp [ group group-number ]

 

switch(config-if-hsrp)# show hsrp group 2

(任意)HSRP 情報を表示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config-if-hsrp)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、キーチェーン作成後に HSRP の MD5 認証を Ethernet 1/2 上で設定する例を示します。

switch# configure terminal

switch(config)# key chain hsrp-keys
switch(config-keychain)# key 0
switch(config-keychain-key)# key-string 7 zqdest
switch(config-keychain-key) accept-lifetime 00:00:00 Jun 01 2010 23:59:59 Sep 12 2010
switch(config-keychain-key) send-lifetime 00:00:00 Jun 01 2010 23:59:59 Aug 12 2010
switch(config-keychain-key) key 1
switch(config-keychain-key) key-string 7 uaeqdyito
switch(config-keychain-key) accept-lifetime 00:00:00 Aug 12 2010 23:59:59 Dec 12 2010
switch(config-keychain-key) send-lifetime 00:00:00 Sep 12 2010 23:59:59 Nov 12 2010

switch(config-keychain-key)# interface ethernet 1/2

switch(config-if)# hsrp 2

switch(config-if-hsrp)# authentication md5 key-chain hsrp-keys

switch(config-if-hsrp)# copy running-config startup-config

HSRP オブジェクト トラッキングの設定

他のインターフェイスまたはルータの可用性に基づいて、プライオリティが調整されるように HSRP グループを設定できます。デバイスがオブジェクト トラッキング対応として設定されていて、なおかつトラッキング対象のオブジェクトがダウンした場合、デバイスのプライオリティはダイナミックに変更されます。

トラッキング プロセスはトラッキング対象オブジェクトに定期的にポーリングを実行し、値の変化をすべて記録します。値が変化すると、HSRP がプライオリティを再計算します。HSRP インターフェイスにプリエンプションを設定している場合は、プライオリティの高い HSRP インターフェイスがアクティブ ルータになります。

手順の概要

1. configure terminal

2. track object-id interface interface-type number {{ip | ipv6} routing | line-protocol}

3. track object-id {ip | ipv6} route ip-prefix/length reachability

4. interface interface-type slot/port

5. hsrp group-number [ipv4 | ipv6]

6. priority [value]

7. track object-number [decrement value]

8. preempt [delay [minimum seconds] [reload seconds] [sync seconds]]

9. (任意)show hsrp interface interface-type number

10. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

track object-id interface interface-type number {{ ip | ipv6 } routing | line-protocol }

 

例:

switch(config)# track 1 interface ethernet 2/2 line-protocol

switch(config-track#

この HSRP インターフェイスが追跡するインターフェイスを設定します。インターフェイスのステート変化は次のように、この HSRP のプライオリティを左右します。

HSRP コンフィギュレーション モードで、 track コマンドで使用するインターフェイスおよび対応するオブジェクト番号を設定します。

line-protocol キーワードを指定すると、インターフェイスがアップ状態かどうかが追跡されます。 ip キーワードを指定すると、インターフェイス上で IP ルーティングがイネーブルであり、IP アドレスが設定されているかどうかもチェックされます。

track object-id { ip | ipv6 } route ip-prefix/length reachability

 

例:

switch(config)# track 2 ip route 192.0.2.0/8 reachability

switch(config-track#

ルートのトラッキング対象オブジェクトを作成し、トラッキング コンフィギュレーション モードを開始します。 object-id の範囲は 1 ~ 500 です。

ステップ 3

track object-id { ip | ipv6 } route ip-prefix/length reachability

 

例:

switch(config)# track 2 ip route 192.0.2.0/8 reachability

switch(config-track#

ルートのトラッキング対象オブジェクトを作成し、トラッキング コンフィギュレーション モードを開始します。 object-id の範囲は 1 ~ 500 です。

ステップ 4

interface interface-type slot/port

 

例:

switch(config)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 5

hsrp group-number [ ipv4 | ipv6 ]

 

switch(config-if)# hsrp 2

switch(config-if-hsrp)#

HSRP グループを作成し、HSRP コンフィギュレーション モードを開始します。

ステップ 6

priority [ value ]

 

例:

switch(config-if-hsrp)# priority 254

HSRP グループでのアクティブ ルータ選択に使用するプライオリティ レベルを設定します。有効な範囲は 0 ~ 255 です。デフォルトは 100 です。

ステップ 7

track object-number [ decrement value ]

 

例:

switch(config-if-hsrp)# track 1 decrement 20

HSRP インターフェイスの重み付けを左右する、トラッキング対象のオブジェクトを指定します。

value 引数には、トラッキング対象のオブジェクトで障害が発生した場合に、HSRP インターフェイスのプライオリティから差し引く値を指定します。指定できる範囲は 1 ~ 255 です。デフォルトは 10 です。

ステップ 8

preempt [ delay [ minimum seconds ] [ reload seconds ] [ sync seconds ]]

 

例:

switch(config-if-hsrp)# preempt delay minimum 60

現在のアクティブ ルータよりプライオリティが高い場合に、HSRP グループのアクティブ ルータとして引き継ぐようにルータを設定します。このコマンドは、デフォルトでディセーブルになっています。指定できる範囲は 0 ~ 3600 秒です。

ステップ 9

show hsrp interface interface-type number

 

例:

switch(config-if-hsrp)# show hsrp interface ethernet 1/2

(任意)インターフェイスの HSRP 情報を表示します。

ステップ 10

copy running-config startup-config

 

例:

switch(config-if-hsrp)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、Ethernet 1/2 上で HSRP オブジェクト トラッキングを設定する例を示します。

switch# configure terminal

switch(config)# track 1 interface ethernet 2/2 line-protocol

switch(config)# interface ethernet 1/2

switch(config-if)# hsrp 2

switch(config-if-hsrp)# priority 254

switch(config-if-hsrp)# track 1 decrement 20

switch(config-if-hsrp)# preempt delay minimum 60

switch(config-if-hsrp)# copy running-config startup-config

HSRP プライオリティの設定

インターフェイス上で HSRP プライオリティを設定できます。HSRP では、プライオリティを使用して、アクティブ ルータとして動作する HSRP グループ メンバを決定します。vPC 対応のインターフェイスで HSRP を設定する場合は、オプションで vPC トランクにフェールオーバーする時期を制御するしきい値の上限と下限を設定できます。スタンバイ ルータのプライオリティが下限のしきい値を下回った場合、HSRP は、すべてのスタンバイ ルータ トラフィックを vPC トランク全体に送信し、アクティブな HSRP ルータを通して転送します。HSRP では、スタンバイ HSRP ルータ プライオリティが上限しきい値を超えるまで、この状況を維持します。

IPv6 HSRP グループでは、すべてのグループ メンバのプライオリティが同じ場合、HSRP は IPv6 リンクローカル アドレスに基づいてアクティブ ルータを選択します。

HSRP プライオリティを設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

priority level [ forwarding-threshold lower lower-value upper upper-value ]

 

例:

switch(config-if-hsrp)# priority 60 forwarding-threshold lower 40 upper 50

HSRP グループでのアクティブ ルータ選択に使用するプライオリティ レベルを設定します。 level の範囲は 0 ~ 255 です。デフォルトは 100 です。オプションで、このコマンドを使用して vPC トランクにフェールオーバーする時点を決定するために vPC が使用するしきい値の上限と下限を設定できます。 lower-value の範囲は 1 ~ 255 です。デフォルトは 1 です。 upper-value の範囲は 1 ~ 255 です。デフォルトは 255 です。

HSRP のカスタマイズ

任意で、HSRP の動作をカスタマイズできます。仮想 IP アドレスを設定することによって、HSRP グループをイネーブルにすると、そのグループがただちに動作可能になることに注意してください。HSRP をカスタマイズする前に HSRP グループをイネーブルにした場合、機能のカスタマイズが完了しないうちに、ルータがグループの制御を引き継いでアクティブ ルータになる可能性があります。HSRP のカスタマイズを予定している場合は、HSRP グループをイネーブルにする前に行ってください。HSRP をカスタマイズするには、HSRP コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

name string

 

例:

switch(config-if-hsrp)# name HSRP-1

HSRP グループの IP 冗長名を指定します。 string は 1 ~ 255 文字です。デフォルト ストリングのフォーマットは、

hsrp-interface short-name group-id. たとえば、hsrp-Eth2/1-1 です。

preempt [ delay [ minimum seconds ] [ reload seconds ] [ sync seconds ]]

 

例:

switch(config-if-hsrp)# preempt delay minimum 60

現在のアクティブ ルータよりもプライオリティが高い場合に、HSRP グループのアクティブ ルータとして引き継ぐようにルータを設定します。このコマンドは、デフォルトでディセーブルになっています。指定できる範囲は 0 ~ 3600 秒です。

timers [ msec ] hellotime [ msec ] holdtime

 

例:

switch(config-if-hsrp)# timers 5 18

次のように、この HSRP メンバーの hello タイムおよびホールド タイムを設定します。

hellotime :hello パケットを送信してから、次の hello パケットを送信するまでのインターバル。指定できる範囲は 1 ~ 254 秒です。

holdtime :hello パケットの情報が無効と見なされるまでのインターバル。範囲は 3 ~ 255 です。

オプションの msec キーワードは、引数がデフォルトの秒単位ではなく、ミリ秒単位で表されることを指定します。タイマーの範囲(ミリ秒)は次のとおりです。

hellotime :hello パケットを送信してから、次の hello パケットを送信するまでのインターバル。指定できる範囲は 255 ~ 999 ミリ秒です。

holdtime :hello パケットの情報が無効と見なされるまでのインターバル。指定できる範囲は 750 ~ 3000 ミリ秒です。

HSRP をカスタマイズするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

hsrp delay minimum seconds

 

例:

switch(config-if)# hsrp delay minimum 30

グループがイネーブルになってから、グループに参加するまでに HSRP が待機する最小時間を指定します。指定できる範囲は 0 ~ 10000 秒です。デフォルト値は 0 です。

hsrp delay reload seconds

 

例:

switch(config-if)# hsrp delay reload 30

リロード後、グループに参加するまでに HSRP が待機する最小時間を指定します。指定できる範囲は 0 ~ 10000 秒です。デフォルト値は 0 です。

HSRP の拡張ホールド タイマーの設定

拡張ホールド タイマーを使用して、制御された(グレースフル)スイッチオーバーまたは ISSU 時(ソフトウェアのアップグレード時やスーパーバイザによるスイッチオーバー時など)に、拡張 NSF をサポートするように HSRP を設定できます。拡張ホールド タイマーはすべての HSRP ルータで設定してください(「ハイ アベイラビリティおよび拡張ノンストップ フォワーディング」を参照)。


) 拡張ホールド タイマーを設定する場合は、すべての HSRP ルータで拡張ホールド タイマーを設定する必要があります。デフォルトでないホールド タイマーを設定する場合は、HSRP 拡張ホールド タイマーの設定時にすべての HSRP ルータで同じ値を設定してください。



) HSRP 拡張ホールド タイマーは、HSRPv1 のミリ秒の hello タイマーやホールド タイマーを設定した場合は適用されません。これは、HSRPv2 には適用されません。


HSRP 拡張ホールド タイマーを設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

hsrp timers extended-hold [ timer ]

 

switch(config)# hsrp timers extended-hold

IPv4 と IPv6 両方のグループに HSRP 拡張ホールド タイマーを秒単位で設定します。タイマーの範囲は 10 ~ 255 です。デフォルトは 10 です。

拡張ホールド時間を表示するには、 show hsrp コマンドまたは show running-config hsrp コマンドを使用します。

HSRP 設定の確認

HSRP 設定情報を表示するには、次の作業のいずれかを行います。

 

コマンド
目的

show hsrp [group group-number]

すべてのグループまたは特定のグループの HSRP ステータスを表示します。

show hsrp delay [interface interface-type slot/port]

すべてのインターフェイスまたは特定のインターフェイスの HSRP 遅延値を表示します。

show hsrp [interface interface-type slot/port]

インターフェイスの HSRP ステータスを表示します。

show hsrp [group group-number] [interface interface-type slot/port] [active] [all] [init] [learn] [listen] [speak] [standby]

ステートが active、init、listen、または standby の仮想フォワーダについて、グループまたはインターフェイスの HSRP ステータスを表示します。disabled を含めてすべてのステートを表示する場合は、 all キーワードを使用します。

show hsrp [group group-number] [interface interface-type slot/port] active] [all] [init] [learn] [listen] [speak] [standby] brief

ステートが active、init、listen、または standby の仮想フォワーダについて、グループまたはインターフェイスの HSRP ステータスの要約を表示します。disabled を含めてすべてのステートを表示する場合は、 all キーワードを使用します。

show hsrp mgo [name name ] [brief]

(任意)MGO に使用中の HSRP グループとそれらのスレーブ セッションとの関係を表示します。

HSRP の設定例

次に、MD5 認証およびインターフェイス トラッキングを指定して、インターフェイス上で HSRP をイネーブルにする例を示します。

key chain hsrp-keys
 key 0
   key-string 7 zqdest
   accept-lifetime 00:00:00 Jun 01 2008 23:59:59 Sep 12 2008
   send-lifetime 00:00:00 Jun 01 2008 23:59:59 Aug 12 2008
  key 1
   key-string 7 uaeqdyito
   accept-lifetime 00:00:00 Aug 12 2008 23:59:59 Dec 12 2008
   send-lifetime 00:00:00 Sep 12 2008 23:59:59 Nov 12 2008

feature hsrp

track 2 interface ethernet 2/2 ip

interface ethernet 1/2

 ip address 192.0.2.2/8

  hsrp 1

   authenticate md5 key-chain hsrp-keys

   priority 90

   track 2 decrement 20

   ip 192.0.2.10

 no shutdown

次に、インターフェイス上で HSRP プライオリティを設定する例を示します。

interface vlan 1

hsrp 0

preempt

priority 100 forwarding-threshold lower 80 upper 90

ip 192.0.2.2

track 1 decrement 30

その他の関連資料

HSRP の実装に関する詳細は、次の各項を参照してください。

「関連資料」

「MIB」

関連資料

関連項目
マニュアル タイトル

ゲートウェイ ロード バランシング プロトコルの設定

「GLBP の設定」

VRRP の設定

「VRRP の設定」

HSRP CLI コマンド

『Cisco Nexus 7000 Series NX-OS Unicast Routing Command Reference

ハイ アベイラビリティの設定

『Cisco Nexus 7000 Series NX-OS High Availability and Redundancy Guide

MIB

MIB
MIB のリンク

CISCO-HSRP-MIB

MIB を検索およびダウンロードするには、次の URL にアクセスしてください。

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

HSRP 機能の履歴

表 20-3 に、この機能のリリース履歴を示します。

 

表 20-3 HSRP 機能の履歴

機能名
リリース
機能情報

MGO

6.2(2)

この機能が導入されました。

FabricPath エニーキャスト HSRP

6.2(2)

この機能が導入されました。

BFD

5.0(2)

BFD のサポートが追加されました。詳細については、 『Cisco Nexus 7000 Series NX-OS Interfaces Configuration Guide, Release 6.x』 を参照してください。

IPv6

5.0(2)

IPv6 のサポートが追加されました。

オブジェクト トラック リスト

4.2(1)

オブジェクト トラック リストのサポートが追加されました。

拡張ホールド タイマー

4.2(1)

拡張 NFS サポートの拡張ホールド タイマーのサポートが追加されました。

CISCO-HSRP-MIB

4.2(1)

CISCO-HSRP-MIB のサポートが追加されました。

プライオリティしきい値

4.1(3)

HSRP プライオリティにおける vPC しきい値のサポートが追加されました。

HSRP

4.0(1)

この機能が導入されました。