Cisco Nexus 7000 シリーズ NX-OS IP SLA コンフィギュレーション ガイド、リリース 6.x
IP SLA PBR オブジェクト トラッキングの設定
IP SLA PBR オブジェクト トラッキングの設定

IP SLA PBR オブジェクト トラッキングの設定

この章では、IP サービス レベル契約(SLA)の PBR オブジェクト トラッキング機能について説明します。

この章の内容は、次のとおりです。

IP SLA PBR オブジェクト トラッキング

この機能により、ルートを使用する前にネクスト ホップが到達可能であることを確認できます。 ネクスト ホップが到達可能でない場合、ポリシー ベース ルーティング(PBR)設定で定義されている別のルートが使用されます。 ルート マップに他のルートがない場合は、ルーティング テーブルが使用されます。

オブジェクト トラッキング

オブジェクト トラッキングでは、次のようなオブジェクトがモニタされます。

  • インターフェイスの回線プロトコルの状態

  • ルーティング テーブル内のエントリの存在

PBR などのクライアントは、特定のトラッキング対象オブジェクトを登録し、それらのオブジェクトの状態が変化した時点でアクションを実行することができます。

IP SLA PBR オブジェクト トラッキングの概要

PBR オブジェクト トラッキング機能により、トラッキング プロセスで使用できるすべてのオブジェクトへのポリシー ベース ルーティング(PBR)にアクセスできます。 トラッキング プロセスを使って、ICMP ping 到達可能性、ルーティング隣接関係、リモート デバイス上で実行中のアプリケーション、Routing Information Base(RIB)内のルートなどの個々のオブジェクトや、インターフェイス回線プロトコルの状態をトラッキングできます。

オブジェクト トラッキングが機能する仕組みとして、PBR がトラッキング プロセスに特定のオブジェクトを追跡するように通知すると、そのオブジェクトで変更が発生した時点で、トラッキング プロセスが PBR に通知します。

IP SLA PBR オブジェクト トラッキングの設定

手順
     コマンドまたはアクション目的
    ステップ 1 configure terminal


    例:
    switch# configure terminal
     

    グローバル コンフィギュレーション モードを開始します

     
    ステップ 2 ip sla operation-number


    例:
    switch(config)# ip sla 1
     

    Cisco IOS IP サービス レベル契約(SLA)動作設定を開始し、IP SLA コンフィギュレーション モードに移行します。

     
    ステップ 3 icmp-echo destination-ip-address


    例:
    switch(config-ip-sla)# icmp-echo 10.3.3.2
     

    IP SLA Internet Control Message Protocol(ICMP)エコー プローブ動作を設定します。

     
    ステップ 4 exit


    例:
    switch(config-ip-sla)# exit
     

    IP SLA コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

     
    ステップ 5 ip sla schedule operation-number life forever start-time now


    例:
    switch(config)# ip sla schedule 1 life forever start-time now
     

    単一の Cisco IOS IP SLA 動作のスケジューリング パラメータを設定します。

    • この例では、IP SLA 動作の時間パラメータを設定します。

    (注)     

    他の IP SLA 動作を構成およびスケジュールするには、ステップ 2 から 5 を繰り返します。

     
    ステップ 6 track object-number ip sla entry-number reachability


    例:
    switch(config)# track 1 ip sla 1 reachability
     

    オブジェクトの到達可能性を追跡し、トラッキング コンフィギュレーション モードを開始します。

    (注)     

    他の動作を追跡するには、この手順を繰り返します。

     
    ステップ 7 exit


    例:
    switch(config-track)# exit
     

    トラッキング コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

     
    ステップ 8 ip access-list standard access-list-name


    例:
    switch(config)# ip access-list standard ACL
     

    パケットのフィルタリングをイネーブルにするために、IP アクセス リストのアクセス コントロール リスト(ACL)を定義します。

     
    ステップ 9 permit ip source destination


    例:
    switch(config-acl)# permit ip 10.2.2.20/24 10.1.1.1/32
     

    条件に一致するトラフィックを許可する、アクセス コントロール リスト(ACL)のルールを作成します。

     
    ステップ 10 exit


    例:
    switch(config-acl)# exit
     

    ACL コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

     
    ステップ 11 route-map map-tag


    例:
    switch(config)# route-map PBR
     

    ルート マップを指定し、ルート マップ コンフィギュレーション モードを開始します。

     
    ステップ 12 match ip address access-list-name


    例:
    switch(config-route-map)# match ip address ACL
     

    標準アクセス リストで許可された宛先 IPv4 ネットワーク番号アドレスを含むすべてのルートを配布します。

     
    ステップ 13 set ip next-hop verify-availability next-hop-address track object


    例:
    switch(config-route-map)# set ip next-hop verify-availability 10.3.3.2 track 1
     

    トラッキング対象オブジェクトの到達可能性を確認するためのルート マップを設定します。

    (注)     

    この手順を繰り返して、他のトラッキング対象オブジェクトの到達可能性を確認するためのルート マップを設定します。

     
    ステップ 14 exit


    例:
    switch(config-route-map)# exit
     

    ルート マップ コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

     
    ステップ 15 interface type number


    例:
    switch(config)# interface ethernet 0/0
     

    インターフェイスのタイプと番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

     
    ステップ 16 ip address ip-address mask


    例:
    switch(config-if)# ip address 10.2.2.1 255.255.255.0 
     

    インターフェイスのプライマリ IP アドレスを指定します。

     
    ステップ 17 ip policy route-map map-tag


    例:
    switch(config-if)# ip policy route-map PBR
     

    ポリシー ルーティングをイネーブルにし、ポリシー ルーティングに使用するルート マップを指定します。

     
    ステップ 18 end


    例:
    switch(config-if)# end
     

    インターフェイス コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

     
    ステップ 19 show track object-number


    例:
    switch# show track 1
     

    (任意)トラッキング情報を表示します。

    このコマンドを使用して、設定を確認します。

     
    ステップ 20 show route-map map-name


    例:
    switch# show route-map PBR
     

    (任意)ルート マップ情報を表示します。

     

    例:IP SLA PBR オブジェクト トラッキングの設定

    以下に、PBR に対して設定されたオブジェクト トラッキングの例を示します。

    ! Configure and schedule IP SLA operations
    ip sla 1
     icmp-echo 10.3.3.2
    ip sla schedule 1 life forever start-time now
    !
    ip sla 2
     udp-echo 10.4.4.2
    ip sla schedule 2 life forever start-time now
    !
    ip sla 3
     icmp-echo 10.5.5.2
    ip sla schedule 3 life forever start-time now
    !
    ip sla 4
     icmp-echo 10.6.6.2
    ip sla schedule 4 life forever start-time now
    !
    ip sla 5
     icmp-echo 10.7.7.2
    ip sla schedule 5 life forever start-time now
    !
    ! Configure Object Tracking to track the operations 
    !
    track 1 ip sla 1 reachability
    track 2 ip sla 2 reachability
    track 3 ip sla 3 reachability
    track 4 ip sla 4 reachability
    track 5 ip sla 5 reachability
    !
    ! Configure ACL
    ip access-list standard ACL
    	permit ip 10.2.2.0/24 10.1.1.1/32
    !
    ! Configure PBR policing on the router
    route-map PBR
    	match ip address ACL
    	set ip next-hop verify-availability 10.3.3.2 track 1
    	set ip next-hop verify-availability 10.4.4.2 track 2
    	set ip next-hop verify-availability 10.5.5.2 track 3
    !
    ! Apply PBR policy on the incoming interface of the router.
    interface ethernet 0/0
     ip address 10.2.2.1 255.255.255.0
     	ip policy route-map PBR
    !
    ! Display PBR related information 
    show route-map
    show track brief
    show ip sla stat
    show ip sla application
    !
    

    IP SLA PBR オブジェクト トラッキングの機能履歴

    この表には、機能が追加または変更されたリリースの更新のみが含まれています。

    表 1 IP SLA PBR オブジェクト トラッキングの機能履歴
    機能名 リリース 機能情報

    IP SLA PBR オブジェクト トラッキング

    6.2(2)

    この機能が導入されました。