Cisco Nexus 7000 シリーズ NX-OS ユニキャスト ルーティング コンフィギュレーション ガイド リリース 6.x
OSPFv2 の設定
OSPFv2 の設定
発行日;2013/08/27 | 英語版ドキュメント(2013/08/22 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 7MB) | フィードバック

目次

OSPFv2 の設定

OSPFv2 について

hello パケット

ネイバー

隣接関係

指定ルータ

エリア

リンクステート アドバタイズメント

LSA タイプ

リンク コスト

フラッディングと LSA グループ ペーシング

リンクステート データベース

不透明 LSA

OSPFv2 とユニキャスト RIB

認証

簡易パスワード認証

MD5 認証

高度な機能

スタブ エリア

Not-So-Stubby エリア

仮想リンク

ルートの再配布

ルート集約

ハイ アベイラビリティおよびグレースフル リスタート

OSPFv2 スタブ ルータ アドバタイズメント

複数の OSPFv2 インスタンス

SPF 最適化

BFD

仮想化のサポート

OSPFv2 のライセンス要件

OSPFv2 の前提条件

OSPFv2 に関する注意事項および制約事項

デフォルト設定

基本的 OSPFv2 の設定

OSPFv2 のイネーブル化

OSPFv2 インスタンスの作成

OSPFv2 インスタンス上のオプション パラメータの設定

OSPFv2 でのネットワークの設定

エリアの認証の設定

インターフェイスの認証の設定

高度な OSPFv2 の設定

境界ルータのフィルタ リストの設定

スタブ エリアの設定

OSPFv2 の設定

この章では、Cisco NX-OS デバイスで IPv4 ネットワーク用の Open Shortest Path First version 2(OSPFv2)を設定する方法について説明します。

この章では、次の内容について説明します。

「OSPFv2 について」

「OSPFv2 のライセンス要件」

「OSPFv2 の前提条件」

「OSPFv2 に関する注意事項および制約事項」

「デフォルト設定」

「基本的 OSPFv2 の設定」

「高度な OSPFv2 の設定」

「OSPFv2 設定の確認」

「OSPFv2 のモニタリング」

「OSPFv2 の設定例」

「その他の関連資料」

「OSPFv2 機能の履歴」

OSPFv2 について

OSPFv2 は、IPv4 ネットワーク用 IETF リンクステート プロトコルです(「リンクステート プロトコル」を参照)。OSPFv2 ルータは、 hello パケット と呼ばれる特別なメッセージを各 OSPF 対応インターフェイスに送信して、ほかの OSPFv2 隣接ルータを探索します。隣接ルータが発見されると、この 2 台のルータは hello パケットの情報を比較して、両者の設定に互換性のあるかどうかを判定します。これらの隣接ルータは 隣接関係 を確立しようとします。つまり、両者のリンクステート データベースを同期させて、確実に同じ OSPFv2 ルーティング情報を持つようにします。隣接ルータは、各リンクの稼働状態に関する情報、リンクのコスト、およびその他のあらゆるネイバー情報を含む リンクステート アドバタイズメント (LSA)を共有します。これらのルータはその後、受信した LSA をすべての OSPF 対応インターフェイスにフラッディングします。これにより、すべての OSPFv2 ルータのリンクステート データベースが最終的に同じになります。すべての OSPFv2 ルータのリンクステート データベースが同じになると、ネットワークは 収束 されます(「コンバージェンス」を参照)。その後、各ルータは、ダイクストラの最短パス優先(SPF)アルゴリズムを使用して、自身のルート テーブルを構築します。

OSPFv2 ネットワークは、複数のエリアに分割できます。ルータは、ほとんどの LSA を 1 つのエリア内だけに送信するため、OSPF 対応ルータの CPU とメモリの要件が緩やかになります。

OSPFv2 は IPv4 をサポートし、OSPFv3 は IPv6 をサポートしています。詳細については、「OSPFv3 の設定」を参照してください。


) Cisco NX-OS の OSPFv2 では、RFC 2328 をサポートしています。この RFC では、ルート サマリー コストの計算に、RFC1583 で使用する計算と互換性がない別の方法が導入されました。また RFC 2328 では、AS-external パスに対して異なる選択基準が導入されました。すべてのルータが同じ RFC をサポートしていることを確認することが重要です。RFC1583 だけに対応しているルータがネットワークに含まれる場合は、rfc1583compatibility コマンドを使用します。デフォルトでサポートされている OSPFv2 用の RFC 標準は、Cisco NX-OS と Cisco IOS とで異なる場合があります。値が同じになるように設定するには、調整が必要です。詳細については、「OSPF RFC 互換モードの例」を参照してください。


ここでは、次の内容について説明します。

「hello パケット」

「ネイバー」

「隣接関係」

「指定ルータ」

「エリア」

「リンクステート アドバタイズメント」

「OSPFv2 とユニキャスト RIB」

「認証」

「高度な機能」

hello パケット

OSPFv2 ルータは、すべての OSPF 対応インターフェイスに hello パケットを定期的に送信します。ルータがこの hello パケットを送信する頻度は、インターフェイスごとに設定された hello 間隔 により決定されます。OSPFv2 は、hello パケットを使用して、次のタスクを実行します。

ネイバー探索

キープアライブ

双方向通信

指定ルータの選定(「指定ルータ」を参照)

hello パケットには、リンクの OSPFv2 コスト割り当て、hello 間隔、送信元ルータのオプション機能など、送信元の OSPFv2 インターフェイスとルータに関する情報が含まれます。これらの hello パケットを受信する OSPFv2 インターフェイスは、設定に受信インターフェイスの設定との互換性があるかどうかを判定します。互換性のあるインターフェイスはネイバーと見なされ、ネイバー テーブルに追加されます(「ネイバー」を参照)。

hello パケットには、送信元インターフェイスが通信したルータのルータ ID のリストも含まれます。受信インターフェイスが、このリストで自身の ID を見つけた場合は、2 つのインターフェイス間で双方向通信が確立されます。

OSPFv2 は、hello パケットをキープアライブ メッセージとして使用して、ネイバーが通信を継続中であるかどうかを判定します。設定された デッド間隔 (通常は hello 間隔の倍数)でルータが hello パケットを受信しない場合、そのネイバーはローカル ネイバー テーブルから削除されます。

ネイバー

ネイバーと見なされるためには、OSPFv2 インターフェイスがリモート インターフェイスとの互換性を持つように設定されている必要があります。この 2 つの OSPFv2 インターフェイスで、次の基準が一致している必要があります。

hello 間隔

デッド間隔

エリア ID(「エリア」 を参照)

認証

オプション機能

一致する場合は、次の情報がネイバー テーブルに入力されます。

ネイバー ID:ネイバーのルータ ID

プライオリティ:ネイバーのプライオリティ。プライオリティは、指定ルータの選定(「指定ルータ」を参照)に使用されます。

状態:ネイバーから通信があったか、双方向通信の確立処理中であるか、リンクステート情報を共有しているか、または完全な隣接関係が確立されたかを示します。

デッド タイム:このネイバーから最後の hello パケットを受信したあとに経過した時間を示します。

IP アドレス:ネイバーの IP アドレス

指定ルータ:ネイバーが指定ルータ、またはバックアップ指定ルータとして宣言されたかどうかを示します(「指定ルータ」を参照)。

ローカル インターフェイス:このネイバーの hello パケットを受信したローカル インターフェイス

隣接関係

すべてのネイバーが隣接関係を確立するわけではありません。ネットワーク タイプと確立された指定ルータに応じて、完全な隣接関係を確立して、すべてのネイバーと LSA を共有するものと、そうでないものがあります。詳細については、「指定ルータ」を参照してください。

隣接関係は、OSPF のデータベース説明パケット、リンク状態要求パケット、およびリンク状態更新パケットを使用して確立されます。データベース説明パケットに含まれるのは、ネイバーのリンクステート データベースからの LSA ヘッダーだけです(「リンクステート データベース」を参照)。ローカル ルータは、これらのヘッダーを自身のリンクステート データベースと比較して、新規の LSA か、更新された LSA かを判定します。ローカル ルータは、新規または更新の情報を必要とする各 LSA について、リンク状態要求パケットを送信します。これに対し、ネイバーはリンク状態更新パケットを返信します。このパケット交換は、両方のルータのリンクステート情報が同じになるまで継続します。

指定ルータ

複数のルータを含むネットワークは、OSPF 特有の状況です。すべてのルータがネットワークで LSA をフラッディングした場合は、同じリンクステート情報が複数の送信元から送信されます。ネットワークのタイプに応じて、OSPFv2 は 指定ルータ DR )という 1 台のルータを使用して、LSA のフラッディングを制御し、OSPFv2 の残りの部分に対してネットワークを代表する場合があります(「エリア」を参照)。DR がダウンした場合、OSPFv2 は バックアップ指定ルータ (BDR)を選定します。DR がダウンすると、OSPFv2 はこの BDR を使用します。

ネットワーク タイプは次のとおりです。

ポイントツーポイント:2 台のルータ間にのみ存在するネットワーク。ポイントツーポイント ネットワーク上の全ネイバーは隣接関係を確立し、DR は存在しません。

ブロードキャスト:ブロードキャスト トラフィックが可能なイーサネットなどの共有メディア上で通信できる複数のルータを持つネットワーク。OSPFv2 ルータは DR および BDR を確立し、これらにより、ネットワーク上の LSA フラッディングを制御します。OSPFv2 は、よく知られている IPv4 マルチキャスト アドレス 224.0.0.5 および MAC アドレス 0100.5300.0005 を使用して、ネイバーと通信します。

DR と BDR は、hello パケット内の情報に基づいて選択されます。インターフェイスは hello パケットの送信時に、どれが DR および BDR かわかっている場合は、優先フィールドと、DR および BDR フィールドを設定します。ルータは、hello パケットの DR および BDR フィールドで宣言されたルータと優先フィールドに基づいて、選定手順を実行します。最終的に OSPFv2 は、最も大きいルータ ID を DR および BDR として選択します。

他のルータはすべて DR および BDR と隣接関係を確立し、IPv4 マルチキャスト アドレス 224.0.0.6 を使用して、LSA 更新情報を DR と BDR に送信します。図 6-1 は、すべてのルータと DR の間のこの隣接関係を示します。

DR は、ルータ インターフェイスに基づいています。1 つのネットワークの DR であるルータは、別のインターフェイス上の他のネットワークの DR となることはできません。

図 6-1 マルチアクセス ネットワークの DR

 

エリア

OSPFv2 ネットワークを複数の エリア に分割すると、ルータに要求される OSPFv2 の CPU とメモリに関する要件を制限できます。 エリアとは、ルータの論理的な区分で、OSPFv2 ドメイン内にリンクして別のサブドメインを作成します。LSA フラッディングはエリア内でのみ発生し、リンクステート データベースはエリア内のリンクにのみ制限されます。定義されたエリア内のインターフェイスには、エリア ID を割り当てることができます。エリア ID は、10.2.3.1 などの、数字またはドット付き 10 進表記で入力できる 32 ビット値です。
Cisco NX-OS はエリアを常にドット付き 10 進表記で表示します。
OSPFv2 ネットワーク内に複数のエリアを定義する場合は、0 という予約されたエリア ID を持つバックボーン エリアも定義する必要があります。エリアが複数ある場合は、1 台以上のルータが エリア境界ルータ (ABR)となります。ABR は、バックボーン エリアと他の 1 つ以上の定義済みエリアの両方に接続します(図 6-2を参照)。

図 6-2 OSPFv2 エリア

 

ABR には、接続するエリアごとに個別のリンクステート データベースがあります。ABR は、接続したエリアの 1 つからバックボーン エリアにネットワーク集約(タイプ 3)LSA(「ルート集約」を参照)を送信します。バックボーン エリアは、1 つのエリアに関する集約情報を別のエリアに送信します。図 6-2 では、エリア 0 が、エリア 5 に関する集約情報をエリア 3 に送信しています。

OSPFv2 では、自律システム境界ルータ(ASBR)という、もう 1 つのルータ タイプも定義されています。このルータは、OSPFv2 エリアを別の自律システムに接続します。自律システムとは、単一の技術的管理エンティティにより制御されるネットワークです。OSPFv2 は、そのルーティング情報を別の自律システムに再配布したり、再配布されたルートを別の自律システムから受信したりできます。詳細については、「高度な機能」を参照してください。

リンクステート アドバタイズメント

OSPFv2 はリンクステート アドバタイズメント(LSA)を使用して、自身のルーティング テーブルを構築します。

ここでは、次の内容について説明します。

「LSA タイプ」

「リンク コスト」

「フラッディングと LSA グループ ペーシング」

「リンクステート データベース」

「不透明 LSA」

LSA タイプ

表 6-1 は、Cisco NX-OS でサポートされる LSA タイプを示します。

 

表 6-1 LSA タイプ

タイプ
名前
説明

1

ルータ LSA

すべてのルータが送信する LSA。この LSA には、すべてのリンクの状態とコスト、およびリンク上のすべての OSPFv2 ネイバーの一覧が含まれます。ルータ LSA は SPF 再計算をトリガーします。ルータ LSA はローカル OSPFv2 エリアにフラッディングされます。

2

ネットワーク LSA

DR が送信する LSA。この LSA には、マルチアクセス ネットワーク内のすべてのルータの一覧が含まれます。ネットワーク LSA は SPF 再計算をトリガーします。「指定ルータ」を参照してください。

3

ネットワーク集約 LSA

ABR が、ローカル エリア内の宛先ごとに外部エリアに送信する LSA。この LSA には、ABR からローカルの宛先へのリンク コストが含まれます。「エリア」を参照してください。

4

ASBR 集約 LSA

ABR が外部エリアに送信する LSA。この LSA は、リンク コストを ASBR のみにアドバタイズします。「エリア」を参照してください。

5

AS 外部 LSA

ASBR が生成する LSA。この LSA には、外部 AS 宛先へのリンク コストが含まれます。AS 外部 LSA は、AS 全体にわたってフラッディングされます。「エリア」を参照してください。

7

NSSA 外部 LSA

ASBR が Not-So-Stubby エリア(NSSA)内で生成する LSA。この LSA には、外部 AS 宛先へのリンク コストが含まれます。NSSA 外部 LSA は、ローカル NSSA 内のみでフラッディングされます。「エリア」を参照してください。

9 ~ 11

不透明 LSA

OSPF の拡張に使用される LSA。「不透明 LSA」を参照してください。

リンク コスト

各 OSPFv2 インターフェイスには、 リンク コスト が割り当てられます。このコストは任意の数字です。デフォルトでは、Cisco NX-OS が、設定された参照帯域幅をインターフェイス帯域幅で割った値をコストとして割り当てます。デフォルトでは、参照帯域幅は 40 Gbps です。リンク コストは各リンクに対して、LSA 更新情報で伝えられます。

フラッディングと LSA グループ ペーシング

OSPFv2 ルータは、LSA を受信すると、その LSA をすべての OSPF 対応インターフェイスに転送し、OSPFv2 エリアをこの情報でフラッディングします。この LSA フラッディングにより、ネットワーク内のすべてのルータが同じルーティング情報を持つことが保証されます。LSA フラッディングは、OSPFv2 エリアの設定により異なります(「エリア」を参照)。LSA は、 リンクステート リフレッシュ 時間に基づいて(デフォルトでは 30 分ごとに)フラッディングされます。各 LSA には、リンクステート リフレッシュ時間が設定されています。

ネットワークの LSA 更新情報のフラッディング レートは、LSA グループ ペーシング機能を使用して制御できます。LSA グループ ペーシングにより、CPU またはバッファの高い使用率を低下させることができます。この機能により、同様のリンクステート リフレッシュ時間を持つ LSA がグループ化されるため、OSPFv2 で、複数の LSA を 1 つの OSPFv2 更新メッセージにまとめることが可能となります。

デフォルトでは、相互のリンクステート リフレッシュ時間が 10 秒以内の LSA が、同じグループに入れられます。この値は、大規模なリンクステート データベースでは低く、小規模のデータベースでは高くして、ネットワーク上の OSPFv2 負荷を最適化する必要があります。

リンクステート データベース

各ルータは、OSPFv2 ネットワーク用のリンクステート データベースを維持しています。このデータベースには、収集されたすべての LSA が含まれ、ネットワークを通過するすべてのルートに関する情報が格納されます。OSPFv2 は、この情報を使用して、各宛先への最適パスを計算し、この最適パスをルーティング テーブルに入力します。

MaxAge と呼ばれる設定済みの時間間隔で受信された LSA 更新情報がまったくない場合は、リンクステート データベースから LSA が削除されます。ルータは、LSA を 30 分ごとに繰り返してフラッディングし、正確なリンクステート情報が期限切れで削除されるのを防ぎます。Cisco NX-OS は、すべての LSA が同時にリフレッシュされるのを防ぐために、LSA グループ機能をサポートしています。詳細については、「フラッディングと LSA グループ ペーシング」を参照してください。

不透明 LSA

不透明 LSA により、OSPF 機能の拡張が可能となります。不透明 LSA は、標準 LSA ヘッダーと、それに続くアプリケーション固有の情報で構成されます。この情報は、OSPFv2 または他のアプリケーションにより使用される場合があります。OSPFv2 は不透明 LSA を使用して、OSPFv2 グレースフル リスタート機能(「ハイ アベイラビリティおよびグレースフル リスタート」を参照)をサポートしています。次のような 3 種類の不透明 LSA タイプが定義されています。

LSA タイプ 9:ローカル ネットワークにフラッディングされます。

LSA タイプ 10:ローカル エリアにフラッディングされます。

LSA タイプ 11:ローカル AS にフラッディングされます。

OSPFv2 とユニキャスト RIB

OSPFv2 は、リンクステート データベースでダイクストラの SPF アルゴリズムを実行します。このアルゴリズムにより、パス上の各リンクのリンク コストの合計に基づいて、各宛先への最適パスが選択されます。そして、選択された各宛先への最短パスが OSPFv2 ルート テーブルに入力されます。OSPFv2 ネットワークが収束すると、このルート テーブルはユニキャスト RIB にデータを提供します。OSPFv2 はユニキャスト RIB と通信し、次の動作を行います。

ルートの追加または削除

他のプロトコルからのルートの再配布への対応

変更されていない OSPFv2 ルートの削除およびスタブ ルータ アドバタイズメントを行うためのコンバージェンス更新情報の提供(「OSPFv2 スタブ ルータ アドバタイズメント」を参照)

さらに OSPFv2 は、変更済みダイクストラ アルゴリズムを実行して、集約および外部(タイプ 3、4、5、7)LSA の変更の高速再計算を行います。

認証

OSPFv2 メッセージに認証を設定して、ネットワークでの不正な、または無効なルーティング更新を防止できます。Cisco NX-OS は、次の 2 つの認証方式をサポートしています。

簡易パスワード認証

MD5 認証ダイジェスト

OSPFv2 認証は、OSPFv2 エリアに対して、またはインターフェイスごとに設定できます。

簡易パスワード認証

簡易パスワード認証では、OSPFv2 メッセージの一部として送信された単純なクリア テキストのパスワードを使用します。受信 OSPFv2 ルータが OSPFv2 メッセージを有効なルート更新情報として受け入れるには、同じクリア テキスト パスワードで設定されている必要があります。パスワードがクリア テキストであるため、ネットワーク上のトラフィックをモニタできるあらゆるユーザがパスワードを入手できます。

MD5 認証

OSPFv2 メッセージを認証するには、MD5 認証を使用する必要があります。そのためには、ローカル ルータとすべてのリモート OSPFv2 ネイバーが共有するパスワードを設定します。Cisco NX-OS は各 OSPFv2 メッセージに対して、メッセージと暗号化されたパスワードに基づく MD5 一方向メッセージ ダイジェストを作成します。インターフェイスはこのダイジェストを OSPFv2 メッセージとともに送信します。受信する OSPFv2 ネイバーは、同じ暗号化パスワードを使用して、このダイジェストを確認します。メッセージが変更されていない場合はダイジェストの計算が同一であるため、OSPFv2 メッセージは有効と見なされます。

MD5 認証には、ネットワークでのメッセージの再送を防ぐための、各 OSPFv2 メッセージのシーケンス番号が含まれます。

高度な機能

Cisco NX-OS は、ネットワークでの OSPFv2 の可用性やスケーラビリティを向上させる高度な OSPFv2 機能をサポートしています。ここでは、次の内容について説明します。

「スタブ エリア」

「Not-So-Stubby エリア」

「仮想リンク」

「ルートの再配布」

「ルート集約」

「ハイ アベイラビリティおよびグレースフル リスタート」

「OSPFv2 スタブ ルータ アドバタイズメント」

「複数の OSPFv2 インスタンス」

「SPF 最適化」

「BFD」

「仮想化のサポート」

スタブ エリア

エリアを スタブ エリア にすると、エリアでフラッディングされる外部ルーティング情報の量を制限できます。スタブ エリアとは、AS 外部(タイプ 5)LSA(「リンクステート アドバタイズメント」を参照)が許可されないエリアです。これらの LSA は通常、外部ルーティング情報を伝播するためにローカル AS 全体でフラッディングされます。スタブ エリアには、次の要件があります。

スタブ エリア内のすべてのルータはスタブ ルータです。「スタブ ルーティング」を参照してください。

スタブ エリアには ASBR ルータは存在しません。

スタブ エリアには仮想リンクを設定できません。

図 6-3 は、外部 AS に到達するためにエリア 0.0.0.10 内のすべてのルータが ABR を通過する必要のある OSPFv2 AS の例を示します。エリア 0.0.0.10 は、スタブ エリアとして設定できます。

図 6-3 スタブ エリア

 

スタブ エリアは、外部自律システムへのバックボーン エリアを通過する必要のあるすべてのトラフィックにデフォルト ルートを使用します。IPv4 の場合のデフォルト ルートは 0.0.0.0 です。

Not-So-Stubby エリア

Not-So-Stubby エリア( NSSA )はスタブ エリアに似ていますが、NSSA では、再配布を使用して NSSA 内で AS 外部ルートをインポートできる点が異なります。NSSA ASBR はこれらのルートを再配布し、NSSA 外部(タイプ 7)LSA を生成して NSSA 全体でフラッディングします。または、NSSA を他のエリアに接続する ABR を設定することにより、この NSSA 外部 LSA を AS 外部(タイプ 5)LSA に変換することもできます。こうすると、ABR は、これらの AS 外部 LSA を OSPFv2 AS 全体にフラッディングします。変換時には、集約およびフィルタリングがサポートされます。NSSA 外部 LSA に関する情報については、「リンクステート アドバタイズメント」を参照してください。

たとえば、OSPFv2 を使用する中央サイトを、異なるルーティング プロトコルを使用するリモート サイトに接続するときに NSSA を使用すると、管理作業を簡素化できます。リモート サイトへのルートはスタブ エリア内に再配布できないため、NSSA を使用する前に、企業サイトの境界ルータとリモート ルータの間の接続を OSPFv2 スタブ エリアとして実行できません。NSSA を使用すると、企業のルータとリモート ルータ間のエリアを NSSA として定義する(「NSSA の設定」を参照)ことで、OSPFv2 を拡張してリモート接続性をサポートできます。

バックボーン エリア 0 を NSSA にできません。

仮想リンク

仮想リンクを使用すると、物理的に直接接続できない場合に、OSPFv2 エリア ABR をバックボーン エリア ABR に接続できます。図 6-4 は、エリア 3 をエリア 5 経由でバックボーン エリアに接続する仮想リンクを示します。

図 6-4 仮想リンク

 

また、仮想リンクを使用して、分割エリアから一時的に回復できます。分割エリアは、エリア内のリンクがダウンしたために隔離された一部のエリアで、ここからはバックボーン エリアへの代表 ABR に到達できません。

ルートの再配布

OSPFv2 は、ルート再配布を使用して、他のルーティング プロトコルからルートを学習できます。「ルートの再配布」を参照してください。リンク コストをこれらの再配布されたルートに割り当てるか、またはデフォルト リンク コストを再配布されたすべてのルートに割り当てるように、OSPFv2 を設定します。

ルート再配布では、ルート マップを使用して、再配布する外部ルートを管理します。再配布を指定したルート マップを設定して、どのルートが OSPFv2 に渡されるかを制御する必要があります。ルート マップを使用すると、宛先、送信元プロトコル、ルート タイプ、ルート タグなどの属性に基づいて、ルートをフィルタリングできます。ルート マップを使用して、ローカル OSPFv2 AS でアドバタイズされる前に AS 外部(タイプ 5)LSA および NSSA 外部(タイプ 7)LSA のパラメータを変更できます。 ルート マップの設定の詳細については、「Route Policy Manager の設定」を参照してください。

ルート集約

OSPFv2 は、学習したすべてのルートを、すべての OSPF 対応ルータと共有するため、ルート集約を使用して、すべての OSPF 対応ルータにフラッディングされる一意のルートの数を削減した方がよい場合があります。ルート集約により、より具体的な複数のアドレスが、すべての具体的なアドレスを表す 1 つのアドレスに置き換えられるため、ルート テーブルが簡素化されます。たとえば、10.1.1.0/24、10.1.2.0/24、および 10.1.3.0/24 というアドレスを 1 つの集約アドレス 10.1.0.0/16 に置き換えることができます。

一般的には、ABR の境界ごとに集約します。集約は 2 つのエリアの間でも設定できますが、バックボーンの方向に集約する方が適切です。こうすると、バックボーンがすべての集約アドレスを受信し、すでに集約されているそれらのアドレスを他のエリアに投入できるためです。集約には、次の 2 タイプがあります。

エリア間ルート集約

外部ルート集約

エリア間ルート集約は ABR 上で設定し、AS 内のエリア間のルートを集約します。集約の利点を生かすには、これらのアドレスを 1 つの範囲内にまとめることができるように、連続するネットワーク番号をエリア内で割り当てる必要があります。

外部ルート集約は、ルート再配布を使用して OSPFv2 に投入される外部ルートに特有のルート集約です。集約する外部の範囲が連続していることを確認する必要があります。異なる 2 台のルータからの重複範囲を集約すると、誤った宛先にパケットが送信される原因となる場合があります。外部ルート集約は、ルートを OSPF に再配布している ASBR で設定してください。

集約アドレスの設定時に Cisco NX-OS は、ルーティング ブラック ホールおよびルート ループを防ぐために、集約アドレスの廃棄ルートを自動的に設定します。

ハイ アベイラビリティおよびグレースフル リスタート

Cisco NX-OS では、複数レベルのハイ アベイラビリティ アーキテクチャを提供します。OSPFv2 は、ステートフル リスタートをサポートしています。これは、ノンストップ ルーティング(NSR)とも呼ばれます。OSPFv2 で問題が発生した場合は、以前の実行時状態からの再起動を試みます。この場合、ネイバーはいずれのネイバー イベントも登録しません。最初の再起動が正常ではなく、別の問題が発生した場合、OSPFv2 はグレースフル リスタートを試みます。

グレースフル リスタート、つまり、ノンストップ フォワーディング(NSF)では、処理の再起動中も OSPFv2 がデータ転送パス上に存在し続けます。OSPFv2 はグレースフル リスタートを実行する必要がある場合、猶予 LSA と呼ばれるリンクローカル不透明(タイプ 9)LSA(「不透明 LSA」を参照)を送信します。この再起動中の OSPFv2 プラットフォームは NSF 対応と呼ばれます。

猶予 LSA には猶予期間が含まれます。猶予期間とは、ネイバー OSPFv2 インターフェイスが再起動中の OSPFv2 インターフェイスからの LSA を待つように指定された時間です (通常、OSPFv2 は隣接関係を解消し、ダウンした、または再起動中の OSPFv2 インターフェイスが発信するすべての LSA を廃棄します)。関与するネイバーは NSF ヘルパーと呼ばれ、再起動中の OSPFv2 インターフェイスが発信するすべての LSA を、このインターフェイスが隣接したままであるかのように維持します。

再起動中の OSPFv2 インターフェイスが稼働を再開すると、ネイバーを再探索して隣接関係を確立し、LSA 更新情報の送信を再開します。この時点で、NSF ヘルパーは、グレースフル リスタートが完了したと認識します。

ステートフル リスタートは次のシナリオで使用されます。

プロセスでの問題発生後の最初の回復試行

ISSU

system switchover コマンドによる手動でのスイッチオーバー

グレースフル リスタートは次のシナリオで使用されます。

プロセスでの問題発生後の 2 回目の回復試行(4 分以内)

restart ospf コマンドによるプロセスの手動での再開

アクティブ スーパーバイザの削除

reload module active-sup コマンドによるアクティブ スーパーバイザのリロード

OSPFv2 スタブ ルータ アドバタイズメント

OSPFv2 スタブ ルータ アドバタイズメント機能を使用して、OSPFv2 インターフェイスをスタブ ルータとして機能するように設定できません。この機能は、ネットワークに新規ルータを機能制限付きで導入する場合や、過負荷になっているルータの負荷を制限する場合など、このルータ経由の OSPFv2 トラフィックを制限するときに使用します。また、この機能は、さまざまな管理上またはトラフィック エンジニアリング上の理由により使用される場合もあります。

OSPFv2 スタブ ルータ アドバタイズメントは、OSPFv2 ルータをネットワーク トポロジから削除しませんが、他の OSPFv2 ルータがこのルータを使用して、ネットワークの他の部分にトラフィックをルーティングできないようにします。このルータを宛先とするトラフィック、またはこのルータに直接接続されたトラフィックだけが送信されます。

OSPFv2 スタブ ルータ アドバタイズメントは、すべてのスタブ リンク(ローカル ルータに直接接続された)を、ローカル OSPFv2 インターフェイスのコストとしてマークします。すべてのリモート リンクは、最大のコスト(0xFFFF)としてマークされます。

複数の OSPFv2 インスタンス

Cisco NX-OS は、同じノード上で動作する、OSPFv2 プロトコルの複数インスタンスをサポートしています。同一インターフェイスには複数のインスタンスを設定できません。デフォルトでは、すべてのインスタンスが同じシステム ルータ ID を使用します。複数のインスタンスが同じ OSPFv2 AS にある場合は、各インスタンスのルータ ID を手動で設定する必要があります。

SPF 最適化

Cisco NX-OS は、次の方法で SPF アルゴリズムを最適化します。

ネットワーク(タイプ 2)LSA、ネットワーク集約(タイプ 3)LSA、および AS 外部(タイプ 5)LSA 用の部分的 SPF:これらの LSA のいずれかが変更されると、Cisco NX-OS は、全体的な SPF 計算ではなく、高速部分計算を実行します。

SPF タイマー:さまざまなタイマーを設定して、SPF 計算を制御できます。これらのタイマーには、後続の SPF 計算の幾何バックオフが含まれます。幾何バックオフにより、複数の SPF 計算による CPU 負荷が制限されます。

BFD

この機能では、双方向フォワーディング検出(BFD)をサポートします。BFD は、転送パスの障害を高速で検出することを目的にした検出プロトコルです。BFD は 2 台の隣接デバイス間のサブセカンド障害を検出し、BFD の負荷の一部を、サポートされるモジュール上のデータ プレーンに分散できるため、プロトコル hello メッセージよりも CPU を使いません。詳細については、『 Cisco Nexus 7000 Series NX-OS Interfaces Configuration Guide, Release 6.x 』を参照してください。

仮想化のサポート

OSPFv2 では、仮想ルーティング/転送(VRF)インスタンスをサポートしています。VRF は仮想化デバイス コンテキスト(VDC)内にあります。デフォルトでは、特に別の VDC および VRF を設定しない限り、Cisco NX-OS によりデフォルト VDC およびデフォルト VRF が使用されます。

Cisco NX-OS Release 6.1 は VDC ごとに OSPFv2 の 4 つ以上のプロセス インスタンスをサポートします。ただし、MPLS LDP と MPLS TE でサポートされるのは、設定された OSPFv2 インスタンスの最初の 4 つだけです。各 OSPFv2 インスタンスは、システム制限値の範囲で複数の VRF をサポートできます。詳細については、『 Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide, Release 5.x 』、『 Cisco Nexus 7000 Series NX-OS Verified Scalability Guide 』、および「レイヤ 3 仮想化の設定」を参照してください。

OSPFv2 のライセンス要件

次の表に、この機能のライセンス要件を示します。

 

製品
ライセンス要件

Cisco NX-OS

OSPFv2 には Enterprise Services ライセンスが必要です。Cisco NX-OS ライセンス方式、およびライセンスの取得方法と適用方法の詳細については、 『Cisco NX-OS Licensing Guide を参照してください。

OSPFv2 の前提条件

OSPFv2 には、次の前提条件があります。

OSPF を設定するための、ルーティングの基礎に関する詳しい知識がある。

スイッチにログインしている。

リモート OSPFv2 ネイバーと通信可能な IPv4 用インターフェイスが 1 つ以上設定されている。

Enterprise Services ライセンスがインストールされている。

OSPFv2 ネットワーク戦略と、ネットワークのプランニングが完成している。たとえば、複数のエリアが必要かどうかを決定する必要があります。

OSPF 機能がイネーブルにされている(「OSPFv2 のイネーブル化」を参照)。

VDC を設定する場合に、適切なライセンスをインストールし、所定の VDC を開始している( 設定情報については Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide, Release 5.x 』、 ライセンスの詳細については、『Cisco NX-OS Licensing Guide を参照してください)。

OSPFv2 に関する注意事項および制約事項

OSPFv2 設定時の注意事項および制約事項は次のとおりです。

Cisco NX-OS は、ユーザがエリアを 10 進表記で入力するか、ドット付き 10 進表記で入力するかに関係なく、ドット付き 10 進表記でエリアを表示します。

すべての OSPFv2 ルータが、同じ RFC 互換モードで動作する必要があります。Cisco NX-OS の OSPFv2 は RFC 2328 に準拠しています。ネットワークに RFC 1583 だけに対応しているルータが含まれる場合は、ルータ コンフィギュレーション モードで rfc1583compatibility コマンドを使用します。

スケール シナリオでは、インターフェイスと OSPF プロセスのリンク ステート アドバタイズメントの数が大きい場合、OSPF MIB オブジェクトの SNMP エージェントのタイムアウト値が小さい SNMP ウォークは、タイムアウトになると予想されます。OSPF MIB オブジェクトのポーリング中に問い合わせる SNMP エージェントのタイムアウトを確認する場合は、ポーリングする SNMP エージェントのタイムアウト値を増加してください。

Cisco NX-OS Release 6.1 は VDC ごとに OSPFv2 の 4 つ以上のプロセス インスタンスをサポートします。ただし、MPLS LDP と MPLS TE でサポートされるのは、設定された OSPFv2 インスタンスの最初の 4 つだけです。

次の注意事項と制約事項は、Cisco NX-OS Release 6.1 以降のリリースでサポートされるアドミニストレーティブ ディスタンス機能に適用されます。

OSPF ルートに複数の等コスト パスがある場合、アドミニストレーティブ ディスタンスを設定しても match ip route-source コマンドに対しては決定性を持ちません。

アドミニストレーティブ ディスタンスの設定は、 match route-type match ip address prefix-list および match ip route-source prefix-list コマンドのみでサポートされます。別の match 文は無視されます。

OSPF ルートのアドミニストレーティブ ディスタンスを設定するための match route-type match ip address 、および match ip route-source コマンドにはプリファレンスがありません。このように、Cisco NX-OS OSPF アドミニストレーティブ ディスタンスを設定するためのテーブル マップの動作は、Cisco IOS OSPF の場合と異なります。

廃棄ルートには、アドミニストレーティブ ディスタンス 220 が常に割り当てられます。テーブル マップの設定は OSPF の廃棄ルートには適用されません。


) Cisco IOS の CLI に慣れている場合、この機能に対応する Cisco NX-OS コマンドは通常使用する Cisco IOS コマンドと異なる場合があるので注意してください。


デフォルト設定

表 6-2 に、OSPFv2 パラメータのデフォルト設定を示します。

 

表 6-2 デフォルトの OSPFv2 パラメータ

パラメータ
デフォルト

アドミニストレーティブ ディスタンス

110

hello 間隔

10 秒

デッド間隔

40 秒

グレースフル リスタートの猶予期間

60 秒

OSPFv2 機能

ディセーブル

スタブ ルータ アドバタイズメントの宣言期間

600 秒

リンク コスト計算の参照帯域幅

40 Gbps

LSA 最小到着時間

1000 ミリ秒

LSA グループ ペーシング

10 秒

SPF 計算初期遅延時間

200 ミリ秒

SPF の最小ホールド タイム

5000 ミリ秒

SPF 計算初期遅延時間

1000 ミリ秒

基本的 OSPFv2 の設定

OSPFv2 は、OSPFv2 ネットワークを設計したあとに設定します。

ここでは、次の内容について説明します。

「OSPFv2 のイネーブル化」

「OSPFv2 インスタンスの作成」

「OSPFv2 インスタンス上のオプション パラメータの設定」

「OSPFv2 でのネットワークの設定」

「エリアの認証の設定」

「インターフェイスの認証の設定」

OSPFv2 のイネーブル化

OSPFv2 を設定するには、その前に OSPFv2 機能をイネーブルにする必要があります。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. feature ospf

3. (任意)show feature

4. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

feature ospf

 

Example:

switch(config)# feature ospf

OSPFv2 機能をイネーブルにします。

ステップ 3

show feature

 

Example:

switch(config)# show feature

(任意)イネーブルおよびディセーブルにされた機能を表示します。

ステップ 4

copy running-config startup-config

 

Example:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

OSPFv2 機能をディセーブルにして、関連付けられている設定をすべて削除するには、コンフィギュレーション モードで no feature ospf コマンドを使用します。

 

コマンド
目的

no feature ospf

 

Example:

switch(config)# no feature ospf

OSPFv2 機能をディセーブルにして、関連付けられた設定をすべて削除します。

OSPFv2 インスタンスの作成

OSPFv2 設定の最初のステップは OSPFv2 インスタンスの作成です。作成した OSPFv2 インスタンスには、一意のインスタンス タグを割り当てます。インスタンス タグは任意の文字列です。

OSPFv2 インスタンス パラメータの詳細については、「高度な OSPFv2 の設定」を参照してください。

はじめる前に

OSPF 機能がイネーブルにされていることを確認します(「OSPFv2 のイネーブル化」を参照)。

show ip ospf instance-tag コマンドを使用して、インスタンス タグが使用されていないことを確認します。

OSPFv2 がルータ ID(設定済みのループバック アドレスなど)を入手可能であるか、またはルータ ID オプションを設定する必要があります。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. router ospf instance-tag

3. router-id ip-address

4. (任意)show ip ospf instance-tag

5. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router ospf instance-tag

 

Example:

switch(config)# router ospf 201

switch(config-router)#

新規 OSPFv2 インスタンスを作成して、設定済みのインスタンス タグを割り当てます。

ステップ 3

router-id ip-address

 

Example:

switch(config-router)# router-id 192.0.2.1

(任意)OSPFv2 ルータ ID を設定します。この IP アドレスにより、この OSPFv2 インスタンスが識別されます。このアドレスは、システムの設定済みインターフェイス上に存在する必要があります。

ステップ 4

show ip ospf instance-tag

 

Example :

switch(config-router)# show ip ospf 201

(任意)OSPF 情報を表示します。

ステップ 5

copy running-config startup-config

 

Example:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

OSPFv2 インスタンスと、関連付けられている設定をすべて削除するには、コンフィギュレーション モードで no feature ospf コマンドを使用します。

 

コマンド
目的

no router ospf instance-tag

 

Example:

switch(config)# no router ospf 201

OSPF インスタンスと、関連付けられた設定を削除します。


) このコマンドは、インターフェイス モードでは OSPF 設定を削除しません。インターフェイス モードで設定された OSPFv2 コマンドはいずれも、手動で削除する必要があります。


OSPFv2 インスタンス上のオプション パラメータの設定

OSPF のオプション パラメータを設定できます。

OSPFv2 インスタンス パラメータの詳細については、「高度な OSPFv2 の設定」を参照してください。

はじめる前に

OSPF 機能がイネーブルにされていることを確認します(「OSPFv2 のイネーブル化」を参照)。

OSPFv2 がルータ ID(設定済みのループバック アドレスなど)を入手可能であるか、またはルータ ID オプションを設定する必要があります。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の詳細

ルータ コンフィギュレーション モードで、次の OSPFv2 用オプション パラメータを設定できます。

 

コマンド
目的

distance number

 

Example:

switch(config-router)# distance 25

この OSPFv2 インスタンスのアドミニストレーティブ ディスタンスを設定します。指定できる範囲は 1 ~ 255 です。デフォルトは 110 です。

log-adjacency-changes [ detail ]

 

Example:

switch(config-router)# log-adjacency-changes

ネイバーの状態が変化するたびに、システム メッセージを生成します。

maximum-paths path-number

 

Example:

switch(config-router)# maximum-paths 4

ルート テーブル内の宛先への同じ OSPFv2 パスの最大数を設定します。このコマンドはロード バランシングに使用されます。指定できる範囲は 1 ~ 16 です。デフォルトは 8 です。

passive-interface default

 

Example:

switch(config-router)# passive-interface default

すべてのインターフェイス上でルーティングが更新されないようにします。このコマンドは、VRF またはインターフェイス コマンド モードの設定によって上書きされます。

次の例は、OSPFv2 インスタンスを作成する方法を示しています。

switch# configure terminal

switch(config)# router ospf 201

switch(config-router)# copy running-config startup-config

 

OSPFv2 でのネットワークの設定

ルータがこのネットワークへの接続に使用するインターフェイスを介して、OSPFv2 へのネットワークを関連付けることで、このネットワークを設定できます(「ネイバー」を参照)。すべてのネットワークをデフォルト バックボーン エリア(エリア 0)に追加したり、任意の 10 進数または IP アドレスを使用して新規エリアを作成したりできます。


) すべてのエリアは、バックボーン エリアに直接、または仮想リンク経由で接続する必要があります。



) インターフェイスに有効な IP アドレスを設定するまでは、OSPF はインターフェイス上でイネーブルにされません。


はじめる前に

OSPF 機能がイネーブルにされていることを確認します(「OSPFv2 のイネーブル化」を参照)。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. interface interface-type slot/port

3. ip address ip-prefix/length

4. ip router ospf instance-tag area area-id [ secondaries none ]

5. (任意)show ip ospf instance-tag interface interface-type slot/por t

6. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface interface-type slot/port

 

Example:

switch(config)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

ip address ip-prefix/length

 

Example:

switch(config-if)# ip address 192.0.2.1/16

このインターフェイスに IP アドレスおよびサブネット マスクを割り当てます。

ステップ 4

ip router ospf instance-tag area area-id [ secondaries none ]

 

Example:

switch(config-if)# ip router ospf 201 area 0.0.0.15

OSPFv2 インスタンスおよびエリアにインターフェイスを追加します。

ステップ 5

show ip ospf instance-tag interface interface-type slot/port

 

Example :

switch(config-if)# show ip ospf 201 interface ethernet 1/2

(任意)OSPF 情報を表示します。

ステップ 6

copy running-config startup-config

 

Example:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

インターフェイス コンフィギュレーション モードで、省略可能な次の OSPFv2 パラメータを設定できます。

 

コマンド
目的

ip ospf cost number

 

Example:

switch(config-if)# ip ospf cost 25

このインターフェイスの OSPFv2 コスト メトリックを設定します。デフォルトでは、参照帯域幅とインターフェイス帯域幅に基づいて、コスト メトリックが計算されます。有効な範囲は 1 ~ 65535 です。

ip ospf dead-interval seconds

 

Example:

switch(config-if)# ip ospf dead-interval 50

OSPFv2 デッド間隔を秒単位で設定します。有効な範囲は 1 ~ 65535 です。デフォルトでは、hello 間隔の秒数の 4 倍です。

ip ospf hello-interval seconds

 

Example:

switch(config-if)# ip ospf hello-interval 25

OSPFv2 hello 間隔を秒単位で設定します。有効な範囲は 1 ~ 65535 です。デフォルト値は 10 秒です。

ip ospf mtu-ignore

 

Example:

switch(config-if)# ip ospf mtu-ignore

OSPFv2 で、ネイバーとのあらゆる IP MTU 不一致が無視されるように設定します。デフォルトでは、ネイバー MTU がローカル インターフェイス MTU が不一致の場合には、隣接関係が確立されません。

[ default | no ] ip ospf passive-interface

 

Example:

switch(config-if)# ip ospf passive-interface

インターフェイス上でルーティングが更新されないようにします。このコマンドによって、ルータまたは VRF コマンド モードの設定が上書きされます。 default オプションは、このインターフェイス モード コマンドを削除して、ルータまたは VRF の設定がある場合にはそれに戻します。

ip ospf priority number

 

Example:

switch(config-if)# ip ospf priority 25

エリアの DR の決定に使用される OSPFv2 プライオリティを設定します。有効な範囲は 0 ~ 255 です。デフォルトは 1 です。「指定ルータ」を参照してください。

ip ospf shutdown

 

Example:

switch(config-if)# ip ospf shutdown

このインターフェイス上の OSPFv2 インスタンスをシャットダウンします。

次に、OSPFv2 インスタンス 201 にネットワーク エリア 0.0.0.10 を追加する例を示します。

switch# configure terminal

switch(config)# interface ethernet 1/2

switch(config-if)# ip address 192.0.2.1/16

switch(config-if)# ip router ospf 201 area 0.0.0.10

switch(config-if)# copy running-config startup-config

 

インターフェイス設定を確認するには、 show ip ospf interface コマンドを使用します。このインターフェイスのネイバーを確認するには、 show ip ospf neighbor コマンドを使用します。

エリアの認証の設定

エリア内のすべてのネットワーク、またはエリア内の個々のインターフェイスの認証を設定できます。インターフェイス認証設定を使用すると、エリア認証は無効になります。

はじめる前に

OSPF 機能がイネーブルにされていることを確認します(「OSPFv2 のイネーブル化」を参照)。

インターフェイス上のすべてのネイバーが、共有認証キーを含め、同じ認証設定を共有することを確認します。

この認証設定のためのキー チェーンを作成します。『 Cisco Nexus 7000 Series NX-OS Security Configuration Guide, Release 6.x を参照してください。


) OSPFv2 の場合、key key-id コマンドのキー ID の値は 0 ~ 255 です。


正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. router ospf instance-tag

3. area area-id authentication [ message-digest ]

4. interface interface-type slot/port

5. (任意)ip ospf authentication-key [ 0 | 3 ] key

または

ip ospf message-digest-key key-id md5 [ 0 | 3 ] key

6. (任意)show ip ospf instance-tag interface interface-type slot/por t

7. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router ospf instance-tag

 

Example:

switch(config)# router ospf 201

switch(config-router)#

新規 OSPFv2 インスタンスを作成して、設定済みのインスタンス タグを割り当てます。

ステップ 3

area area-id authentication [ message-digest ]

 

Example:

switch(config-router)# area 0.0.0.10 authentication

エリアの認証モードを設定します。

ステップ 4

interface interface-type slot/port

 

Example:

switch(config-router)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 5

ip ospf authentication-key [ 0 | 3 ] key

 

Example:

switch(config-if)# ip ospf authentication-key 0 mypass

(任意)このインターフェイスに簡易パスワード認証を設定します。認証が、キーチェーンにもメッセージ ダイジェストにも設定されていない場合は、このコマンドを使用します。0 の場合は、パスワードをクリア テキストで設定します。3 の場合は、パスワードを 3DES 暗号化として設定します。

ip ospf message-digest-key key-id md5 [ 0 | 3 ] key

 

Example:

switch(config-if)# ip ospf message-digest-key 21 md5 0 mypass

(任意)このインターフェイスにメッセージ ダイジェスト認証を設定します。認証がメッセージ ダイジェストに設定されている場合は、このコマンドを使用します。key-id の範囲は 1 ~ 255 です。MD5 オプションが 0 の場合はパスワードがクリア テキストで設定され、3 の場合はパス キーが 3DES 暗号化として設定されます。

ステップ 6

show ip ospf instance-tag interface interface-type slot/port

 

Example :

switch(config-if)# show ip ospf 201 interface ethernet 1/2

(任意)OSPF 情報を表示します。

ステップ 7

copy running-config startup-config

 

Example:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

インターフェイスの認証の設定

エリア内の個々のインターフェイスに認証を設定できます。インターフェイス認証設定を使用すると、エリア認証は無効になります。

はじめる前に

OSPF 機能がイネーブルにされていることを確認します(「OSPFv2 のイネーブル化」を参照)。

インターフェイス上のすべてのネイバーが、共有認証キーを含め、同じ認証設定を共有することを確認します。

この認証設定のためのキー チェーンを作成します。『 Cisco Nexus 7000 Series NX-OS Security Configuration Guide, Release 6.x を参照してください


) OSPFv2 の場合、key key-id コマンドのキー ID の値は 0 ~ 255 です。


正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. interface interface-type slot/port

3. ip ospf authentication [ message-diges t]

4. (任意) ip ospf authentication key-chain key-id

5. (任意) ip ospf authentication-key [ 0 | 3 | 7] key

6. (任意) ip ospf message-digest-key key-id md5 [ 0 | 3 | 7 ] key

7. (任意) show ip ospf instance-tag interface interface-type slot/por t

8. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface interface-type slot/port

 

Example:

switch(config)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

ip ospf authentication [ message-digest ]

 

Example:

switch(config-if)# ip ospf authentication

OSPFv2 のインターフェイス認証モードをクリアテキスト タイプとメッセージ ダイジェスト タイプのどちらかでイネーブルにします。このインターフェイスのエリアに基づく認証を上書きするには、このコマンドを使用します。すべてのネイバーが、この認証タイプを共有する必要があります。

ステップ 4

ip ospf authentication key-chain key-id

 

Example:

switch(config-if)# ip ospf authentication key-chain Test1

(任意)OSPFv2 のキーチェーンを使用するようにインターフェイス認証を設定します。キーチェーンの詳細については、『 Cisco Nexus 7000 Series NX-OS Security Configuration Guide, Release 6.x 』を参照してください。

ステップ 5

ip ospf authentication-key [ 0 | 3 | 7 ] key

 

Example:

switch(config-if)# ip ospf authentication-key 0 mypass

(任意)このインターフェイスに簡易パスワード認証を設定します。認証が、キーチェーンにもメッセージ ダイジェストにも設定されていない場合は、このコマンドを使用します。

オプションは次のとおりです。

0:パスワードをクリア テキストで設定します。

3:パス キーを 3DES 暗号化として設定します。

7:パス キーを Cisco タイプ 7 暗号化として設定します。

ステップ 6

ip ospf message-digest-key key-id md5 [ 0 | 3 | 7 ] key

 

Example:

switch(config-if)# ip ospf message-digest-key 21 md5 0 mypass

(任意)このインターフェイスにメッセージ ダイジェスト認証を設定します。認証がメッセージ ダイジェストに設定されている場合は、このコマンドを使用します。key-id の範囲は 1 ~ 255 です。MD5 オプションは次のとおりです。

0:パスワードをクリア テキストで設定します。

3:パス キーを 3DES 暗号化として設定します。

7:パス キーを Cisco タイプ 7 暗号化として設定します。

ステップ 7

show ip ospf instance-tag interface interface-type slot/port

 

Example :

switch(config-if)# show router ospf 201 interface ethernet 1/2

(任意)OSPF 情報を表示します。

ステップ 8

copy running-config startup-config

 

Example:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、インターフェイスに暗号化されていない簡単なパスワードを設定し、イーサネット インターフェイス 1/2 のパスワードを設定する例を示します。

switch# configure terminal

switch(config)# router ospf 201

switch(config-router)# exit

switch(config)# interface ethernet 1/2

switch(config-if)# ip router ospf 201 area 0.0.0.10

switch(config-if)# ip ospf authentication

switch(config-if)# ip ospf authentication-key 0 mypass

switch(config-if)# copy running-config startup-config

 

高度な OSPFv2 の設定

OSPFv2 は、OSPFv2 ネットワークを設計したあとに設定します。

ここでは、次の内容について説明します。

「境界ルータのフィルタ リストの設定」

「スタブ エリアの設定」

「Totally Stubby エリアの設定」

「NSSA の設定」

「仮想リンクの設定」

「再配布の設定」

「再配布されるルート数の制限」

「ルート集約の設定」

「スタブ ルート アドバタイズメントの設定」

「ルートのアドミニストレーティブ ディスタンスの設定」

「デフォルト タイマーの変更」

「グレースフル リスタートの設定」

「OSPFv2 インスタンスの再起動」

境界ルータのフィルタ リストの設定

OSPFv2 ドメインを、関連性のある各ネットワークを含む一連のエリアに分離できます。すべてのエリアは、ABR 経由でバックボーン エリアに接続している必要があります。OSPFv2 ドメインは、 自律システム境界ルータ (ASBR)を介して、外部ドメインに接続可能です。「エリア」を参照してください。

ABR には、省略可能な次の設定パラメータがあります。

Area range:エリア間のルート集約を設定します。「ルート集約の設定」を参照してください。

Filter list:外部エリアから受信したネットワーク集約(タイプ 3)LSA をフィルタリングします。

ASBR もフィルタ リストをサポートしています。

はじめる前に

OSPF 機能がイネーブルにされていることを確認します(「OSPFv2 のイネーブル化」を参照)。

フィルタ リストが、着信または発信ネットワーク集約(タイプ 3)LSA の IP プレフィックスのフィルタリングに使用するルート マップを作成します。「Route Policy Manager の設定」を参照してください。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. router ospf instance-tag

3. area area-id filter-list route-map map-name {in | out}

4. (任意)show ip ospf policy statistics area id filter-list {in | out}

5. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router ospf instance-tag

 

Example:

switch(config)# router ospf 201

switch(config-router)#

新規 OSPFv2 インスタンスを作成して、設定済みのインスタンス タグを割り当てます。

ステップ 3

area area-id filter-list route-map map-name { in | out }

 

Example:

switch(config-router)# area 0.0.0.10 filter-list route-map FilterLSAs in

ABR 上で着信または発信ネットワーク集約(タイプ 3)LSA をフィルタリングします。

ステップ 4

show ip ospf policy statistics area id filter-list { in | out }

 

Example :

switch(config-if)# show ip ospf policy statistics area 0.0.0.10 filter-list in

(任意)OSPF ポリシー情報を表示します。

ステップ 5

copy running-config startup-config

 

Example:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、エリア 0.0.0.10 でフィルタ リストを設定する例を示します。

switch# configure terminal

switch(config)# router ospf 201

switch(config-router)# area 0.0.0.10 filter-list route-map FilterLSAs in

switch(config-router)# copy running-config startup-config

スタブ エリアの設定

OSPFv2 ドメインの、外部トラフィックが不要な部分にスタブ エリアを設定できます。スタブ エリアは AS 外部(タイプ 5)LSA をブロックし、選択したネットワークへの往復の不要なルーティングを制限します。 「スタブ エリア」を参照してください。また、すべての集約ルートがスタブ エリアを経由しないようブロックすることもできます。

はじめる前に

OSPF 機能がイネーブルにされていることを確認します(「OSPFv2 のイネーブル化」を参照)。

設定されるスタブ エリア内に、仮想リンクと ASBR のいずれも含まれないことを確認します。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. router ospf instance-tag

3. area area-id stub

4. (任意)area area-id default-cost cost

5. (任意)show ip ospf instance-tag

6. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router ospf instance-tag

 

Example:

switch(config)# router ospf 201

switch(config-router)#

新規 OSPFv2 インスタンスを作成して、設定済みのインスタンス タグを割り当てます。

ステップ 3

area area-id stub

 

Example:

switch(config-router)# area 0.0.0.10 stub

このエリアをスタブ エリアとして作成します。

ステップ 4

area area-id default-cost cost

 

Example:

switch(config-router)# area 0.0.0.10 default-cost 25

(任意)このスタブ エリアに送信されるデフォルト集約ルートのコスト メトリックを設定します。指定できる範囲は 0 ~ 16777215 です。デフォルトは 1 です。

ステップ 5

show ip ospf instance-tag

 

Example :

switch(config-if)# show ip ospf 201

(任意)OSPF 情報を表示します。

ステップ 6

copy running-config startup-config

 

Example:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

 

次に、スタブ エリアを作成する例を示します。

switch# configure terminal

switch(config)# router ospf 201

switch(config-router)# area 0.0.0.10 stub

switch(config-router)# copy running-config startup-config

 

Totally Stubby エリアの設定

Totally Stubby エリアを作成して、すべての集約ルート更新がスタブ エリアを経由しないようにすることができます。

Totally Stubby エリアを作成するには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

area area-id stub no-summary

 

Example:

switch(config-router)# area 20 stub no-summary

このエリアを Totally Stubby エリアとして作成します。

NSSA の設定

OSPFv2 ドメインの、ある程度の外部トラフィックが必要な部分に NSSA を設定できます。NSSA の詳細については、「Not-So-Stubby エリア」を参照してください。また、この外部トラフィックを AS 外部(タイプ 5)LSA に変換して、このルーティング情報で OSPFv2 ドメインをフラッディングすることもできます。NSSA は、省略可能な次のパラメータで設定できます。

No redistribution: 再配布されたルートが NSSA をバイパスして、OSPFv2 AS 内の他のエリアに再配布されます。このオプションは、NSSA ASBR が ABR も兼ねているときに使用します。

Default information originate:外部 AS へのデフォルト ルートの NSSA 外部(タイプ 7)LSA を生成します。このオプションは、ASBR のルーティング テーブルにデフォルト ルートが含まれる場合に NSSA ASBR 上で使用します。このオプションは、ASBR のルーティング テーブルにデフォルト ルートが含まれるかどうかに関係なく、NSSA ASBR 上で使用できます。

Route map:目的のルートだけが NSSA および他のエリア全体でフラッディングされるように、外部ルートをフィルタリングします。

Translate:NSSA 外のエリア向けに、NSSA 外部 LSA を AS 外部 LSA に変換します。再配布されたルートを OSPFv2 AS 全体でフラッディングするには、このコマンドを NSSA ABR 上で使用します。また、これらの AS 外部 LSA の転送アドレスを無効にすることもできます。このオプションを選択した場合は、転送アドレスが 0.0.0.0 に設定されます。

No summary:すべての集約ルートが NSSA でフラッディングされないようにします。このオプションは NSSA ABR 上で使用します。

はじめる前に

OSPF 機能がイネーブルにされていることを確認します(「OSPFv2 のイネーブル化」を参照)。

設定する NSSA 上に仮想リンクがないことと、この NSSA がバックボーン エリアでないことを確認します。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. router ospf instance-tag

3. area area-id nssa [ no-redistribution ] [ default-information-originate [ route-map map-name ]] [ no-summary ] [ translate type7 { always | never } [ suppress-fa ]]

4. (任意)area area-id default-cost cost

5. (任意)show ip ospf instance-tag

6. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router ospf instance-tag

 

Example:

switch(config)# router ospf 201

switch(config-router)#

新規 OSPFv2 インスタンスを作成して、設定済みのインスタンス タグを割り当てます。

ステップ 3

area area-id nssa [ no-redistribution ] [ default-information-originate

[ route-map map-name ]] [ no-summary ] [ translate type7 { always | never } [ suppress-fa ]]

 

Example:

switch(config-router)# area 0.0.0.10 nssa

このエリアを NSSA として作成します。

ステップ 4

area area-id default-cost cost

 

Example:

switch(config-router)# area 0.0.0.10 default-cost 25

(任意)この NSSA に送信されるデフォルト集約ルートのコスト メトリックを設定します。

ステップ 5

show ip ospf instance-tag

 

Example :

switch(config-if)# show ip ospf 201

(任意)OSPF 情報を表示します。

ステップ 6

copy running-config startup-config

 

Example:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、すべての集約ルート更新をブロックする NSSA を作成する例を示します。

switch# configure terminal

switch(config)# router ospf 201

switch(config-router)# area 0.0.0.10 nssa no-summary

switch(config-router)# copy running-config startup-config

 

次に、デフォルト ルートを生成する NSSA を作成する例を示します。

switch# configure terminal

switch(config)# router ospf 201

switch(config-router)# area 0.0.0.10 nssa default-info-originate

switch(config-router)# copy running-config startup-config

 

次に、外部ルートをフィルタリングし、すべての集約ルート更新をブロックする NSSA を作成する例を示します。

switch# configure terminal

switch(config)# router ospf 201

switch(config-router)# area 0.0.0.10 nssa route-map ExternalFilter no-summary

switch(config-router)# copy running-config startup-config

 

次に、常に NSSA 外部(タイプ 5)LSA を AS 外部(タイプ 7)LSA に変換する NSSA を作成する例を示します。

switch# configure terminal

switch(config)# router ospf 201

switch(config-router)# area 0.0.0.10 nssa translate type 7 always

switch(config-router)# copy running-config startup-config

 

仮想リンクの設定

仮想リンクは、隔離されたエリアを、中継エリア経由でバックボーン エリアに接続します。 「仮想リンク」を参照してください。仮想リンクには、省略可能な次のパラメータを設定できます。

Authentication:簡単なパスワード認証または MD5 メッセージ ダイジェスト認証、および関連付けられたキーを設定します。

Dead interval:ローカル ルータがデッドであることを宣言し、隣接関係を解消する前に、ネイバーが hello パケットを待つ時間を設定します。

Hello interval:連続する hello パケット間の時間間隔を設定します。

Retransmit interval:連続する LSA 間の推定時間間隔を設定します。

Transmit delay:LSA をネイバーに送信する推定時間を設定します。


) リンクがアクティブになる前に、関与する両方のルータで仮想リンクを設定する必要があります。


スタブ エリアには仮想リンクを追加できません。

はじめる前に

OSPF がイネーブルになっていることを確認します(「OSPFv2 のイネーブル化」を参照)。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. router ospf instance-tag

3. area area-id virtual-link router-id

4. (任意)show ip ospf virtual-link [ brief ]

5. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router ospf instance-tag

 

Example:

switch(config)# router ospf 201

switch(config-router)#

新規 OSPFv2 インスタンスを作成して、設定済みのインスタンス タグを割り当てます。

ステップ 3

area area-id virtual-link router-id

 

Example:

switch(config-router)# area 0.0.0.10 virtual-link 10.1.2.3

switch(config-router-vlink)#

リモート ルータへの仮想リンクの端を作成します。仮想リンクをリモート ルータ上に作成して、リンクを完成させる必要があります。

ステップ 4

show ip ospf virtual-link [ brief ]

 

Example :

switch(config-router-vlink)# show ip ospf virtual-link

(任意)OSPF 仮想リンク情報を表示します。

ステップ 5

copy running-config startup-config

 

Example:

switch(config-router-vlink)# copy running-config startup-config

(任意)この設定の変更を保存します。

仮想リンク コンフィギュレーション モードで、省略可能な次のコマンドを設定できます。

 

コマンド
目的

authentication [ key-chain key-id | message-digest | null ]

 

Example:

switch(config-router-vlink)# authentication message-digest

(任意)これにより、エリアに基づくこの仮想リンクの認証が無効となります。

authentication-key [ 0 | 3 ] key

 

Example:

switch(config-router-vlink)# authentication-key 0 mypass

(任意)この仮想リンクに簡易パスワードを設定します。認証が、キーチェーンにもメッセージ ダイジェストにも設定されていない場合は、このコマンドを使用します。0 の場合は、パスワードをクリア テキストで設定します。3 の場合は、パスワードを 3DES 暗号化として設定します。

dead-interval seconds

 

Example :

switch(config-router-vlink)# dead-interval 50

(任意)OSPFv2 デッド間隔を秒単位で設定します。有効な範囲は 1 ~ 65535 です。デフォルトでは、hello 間隔の秒数の 4 倍です。

hello-interval seconds

 

Example:

switch(config-router-vlink)# hello-interval 25

(任意)OSPFv2 hello 間隔を秒単位で設定します。有効な範囲は 1 ~ 65535 です。デフォルト値は 10 秒です。

message-digest-key key-id md5 [ 0 | 3 ] key

 

Example:

switch(config-router-vlink)#

message-digest-key 21 md5 0 mypass

(任意)この仮想リンクにメッセージ ダイジェスト認証を設定します。認証がメッセージ ダイジェストに設定されている場合は、このコマンドを使用します。0 の場合は、パスワードをクリア テキストで設定します。3 の場合は、パス キーを 3DES 暗号化として設定します。

retransmit-interval seconds

 

Example :

switch(config-router-vlink)# retransmit-interval 50

(任意)OSPFv2 再送間隔を秒単位で設定します。有効な範囲は 1 ~ 65535 です。デフォルトは 5 です。

transmit-delay seconds

 

Example:

switch(config-router-vlink)# transmit-delay 2

(任意)OSPFv2 送信遅延を秒単位で設定します。指定できる範囲は 1 ~ 450 です。デフォルトは 1 です。

次に、2 つの ABR 間に簡単な仮想リンクを作成する例を示します。

ABR 1(ルータ ID 27.0.0.55)の設定は、次のとおりです。

switch# configure terminal

switch(config)# router ospf 201

switch(config-router)# area 0.0.0.10 virtual-link 10.1.2.3

switch(config-router)# copy running-config startup-config

 

ABR 2(ルータ ID 10.1.2.3)の設定は、次のとおりです。

switch# configure terminal

switch(config)# router ospf 101

switch(config-router)# area 0.0.0.10 virtual-link 27.0.0.55

switch(config-router)# copy running-config startup-config

 

再配布の設定

他のルーティング プロトコルから学習したルートを、ASBR 経由で OSPFv2 AS に再配布できます。

OSPF でのルート再配布には、省略可能な次のパラメータを設定できます。

Default information originate:外部 AS へのデフォルト ルートの AS 外部(タイプ 5)LSA を生成します。


) Default information originate はオプションのルート マップ内の match 文を無視します。


Default metric:すべての再配布ルートに同じコスト メトリックを設定します。


) スタティック ルートを再配布すると、Cisco NX-OS はデフォルトのスタティック ルートも再配布します。


はじめる前に

OSPF がイネーブルになっていることを確認します(「OSPFv2 のイネーブル化」を参照)。

再配布で使用する、必要なルート マップを作成します。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. router ospf instance-tag

3. redistribute { bgp id | direct | eigrp id | isis id | ospf id | rip id | static } route-map map-name

4. default-information originate [ always ] [ route-map map-name ]

5. default-metric cost

6. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router ospf instance-tag

 

Example:

switch(config)# router ospf 201

switch(config-router)#

新規 OSPFv2 インスタンスを作成して、設定済みのインスタンス タグを割り当てます。

ステップ 3

redistribute { bgp id | direct | eigrp id | isis id | ospf id | rip id | static } route-map map-name

 

Example:

switch(config-router)# redistribute bgp route-map FilterExternalBGP

設定したルート マップ経由で、選択したプロトコルを OSPF に再配布します。

(注) スタティック ルートを再配布すると、Cisco NX-OS はデフォルトのスタティック ルートも再配布します。

ステップ 4

default-information originate [ always ] [ route-map map-name]

 

Example:

switch(config-router)# default-information-originate route-map DefaultRouteFilter

デフォルト ルートが RIB に存在する場合は、この OSPF ドメインにデフォルト ルートを作成します。次の省略可能なキーワードを使用します。

always :ルートが RIB に存在しない場合でも、常にデフォルト ルートの 0.0.0. を生成します。

route-map :ルート マップが true を返す場合にデフォルト ルートを生成します。

文を無視します。

ステップ 5

default-metric cost

 

Example:

switch(config-router)# default-metric 25

再配布されたルートのコスト メトリックを設定します。このコマンドは、直接接続されたルートには適用されません。ルート マップを使用して、直接接続されたルートのデフォルトのメトリックを設定します。

ステップ 6

copy running-config startup-config

 

Example:

switch(config-router)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)を OSPF に再配布する例を示します。

switch# configure terminal

switch(config)# router ospf 201

switch(config-router)# redistribute bgp route-map FilterExternalBGP

switch(config-router)# copy running-config startup-config

再配布されるルート数の制限

ルートの再配布によって、OSPFv2 ルート テーブルに多くのルートが追加される可能性があります。外部プロトコルから受け取るルートの数に最大制限を設定できます。OSPFv2 には、再配布ルートの制限を設定するために次のオプションが用意されています。

上限固定:設定された最大値に OSPFv2 が達すると、メッセージをログに記録します。OSPFv2 は以降の再配布ルートを受け取りません。任意で、最大値のしきい値パーセンテージを設定して、OSPFv2 がこのしきい値を超えたときに警告を記録するようにすることもできます。

警告のみ:OSPFv2 が最大値に達したときのみ、警告のログを記録します。OSPFv2 は、再配布されたルートを受け入れ続けます。

取り消し:OSPFv2 が最大値に達したときにタイムアウト期間を開始します。このタイムアウト期間後、現在の再配布されたルート数が最大制限より少なければ、OSPFv2 はすべての再配布されたルートを要求します。再配布されたルートの現在数が最大数に達した場合、OSPFv2 はすべての再配布されたルートを取り消します。OSPFv2 が追加の再配布されたルートを受け付ける前に、この状況を解消する必要があります。

任意で、タイムアウト期間を設定できます。

はじめる前に

OSPF がイネーブルになっていることを確認します(「OSPFv2 のイネーブル化」を参照)。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. router ospf instance-tag

3. redistribute { bgp id | direct | eigrp id | isis id | ospf id | rip id | static } route-map map-name

4. redistribute maximum-prefix max [ threshold ] [ warning-only | withdraw [ num-retries timeout ]]

5. (任意)show running-config ospf

6. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router ospf instance-tag

 

Example:

switch(config)# router ospf 201

switch(config-router)#

新規 OSPFv2 インスタンスを作成して、設定済みのインスタンス タグを割り当てます。

ステップ 3

redistribute { bgp id | direct | eigrp id | isis id | ospf id | rip id | static } route-map map-name

 

Example:

switch(config-router)# redistribute bgp route-map FilterExternalBGP

設定したルート マップ経由で、選択したプロトコルを OSPF に再配布します。

ステップ 4

redistribute maximum-prefix max [ threshold ] [ warning-only | withdraw [ num-retries timeout ]]

 

Example:

switch(config-router)# redistribute maximum-prefix 1000 75 warning-only

OSPFv2 が配布するプレフィックスの最大数を指定します。指定できる範囲は 0 ~ 65536 です。任意で次のオプションを指定します。

threshold :警告メッセージをトリガーする最大プレフィックスの割合。

warning-only :プレフィックスの最大数を超えたときに警告メッセージを記録します。

withdraw :再配布されたすべてのルートを取り消します。任意で再配布されたルートを取得しようと試みます。 num-retries の範囲は 1 ~ 12 です。 timeout は 60 ~ 600 秒です。デフォルト値は 300 秒です。 clear ip ospf redistribution コマンドは、すべてのルートが取り消された場合に使用します。

ステップ 5

show running-config ospf

 

Example:

switch(config-router)# show running-config ospf

(任意)OSPFv2 の設定を表示します。

ステップ 6

copy running-config startup-config

 

Example:

switch(config-router)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、OSPF に再配布されるルートの数を制限する例を示します。

switch# configure terminal

switch(config)# router ospf 201

switch(config-router)# redistribute bgp route-map FilterExternalBGP

switch(config-router)# redistribute maximum-prefix 1000 75

 

ルート集約の設定

集約されたアドレス範囲を設定して、エリア間ルートのルート集約を設定できます。また、ASBR 上のこれらのルートの集約アドレスを設定して、外部の再配布されたルートのルート集約を設定することもできます。詳細については、「ルート集約」を参照してください。

はじめる前に

OSPF がイネーブルになっていることを確認します(「OSPFv2 のイネーブル化」を参照)。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. router ospf instance-tag

3. area area-id range ip-prefix/length [ no-advertise ] [ cost cost ]

または

4. summary-address ip-prefix/length [ no-advertise | tag tag-id ]

5. (任意)show ip ospf summary-address

6. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router ospf instance-tag

 

Example:

switch(config)# router ospf 201

switch(config-router)#

新規 OSPFv2 インスタンスを作成して、設定済みのインスタンス タグを割り当てます。

ステップ 3

area area-id range ip-prefix/length [ no-advertise ] [ cost cost ]

 

Example:

switch(config-router)# area 0.0.0.10 range 10.3.0.0/16

一定の範囲のアドレスの集約アドレスを ABR 上に作成します。この集約アドレスをネットワーク集約(タイプ 3)LSA にアドバタイズしないようにすることもできます。 cost の範囲は 0 ~ 16777215 です。

ステップ 4

summary-address ip-prefix/length [ no-advertise | tag tag]

 

Example:

switch(config-router)# summary-address 10.5.0.0/16 tag 2

一定の範囲のアドレスの集約アドレスを ABR 上に作成します。ルート マップによる再配布で使用できるよう、この集約アドレスにタグを割り当てることもできます。

ステップ 5

show ip ospf summary-address

 

Example :

switch(config-router)# show ip ospf summary-address

(任意)OSPF 集約アドレスに関する情報を表示します。

ステップ 6

copy running-config startup-config

 

Example:

switch(config-router)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、ABR 上のエリア間の集約アドレスを作成する例を示します。

switch# configure terminal

switch(config)# router ospf 201

switch(config-router)# area 0.0.0.10 range 10.3.0.0/16

switch(config-router)# copy running-config startup-config

 

次に、ASBR 上の集約アドレスを作成する例を示します。

switch# configure terminal

switch(config)# router ospf 201

switch(config-router)# summary-address 10.5.0.0/16

switch(config-router)# copy running-config startup-config

スタブ ルート アドバタイズメントの設定

短期間だけ、このルータ経由の OSPFv2 トラフィックを制限する場合は、スタブ ルート アドバタイズメントを使用します。詳細については、「OSPFv2 スタブ ルータ アドバタイズメント」を参照してください。

スタブ ルート アドバタイズメントは、省略可能な次のパラメータで設定できます。

On startup:指定した宣言期間だけ、スタブ ルート アドバタイズメントを送信します。

Wait for BGP:BGP がコンバージェンスするまで、スタブ ルート アドバタイズメントを送信します。


) ルータの実行コンフィギュレーションがグレースフル シャットダウンを行うよう設定されている場合は、その実行コンフィギュレーションを保存しないでください。保存すると、ルータが、リロード後に最大メトリックをアドバタイズし続けることになります。


はじめる前に

OSPF がイネーブルになっていることを確認します(「OSPFv2 のイネーブル化」を参照)。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. router ospf instance-tag

3. max-metric router-lsa [external-lsa [ max-metric-value ]] [include-stub] [on-startup { seconds | wait-for bgp tag }] [summary-lsa [ max-metric-value ]]

4. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router ospf instance-tag

 

Example:

switch(config)# router ospf 201

switch(config-router)#

新規 OSPFv2 インスタンスを作成して、設定済みのインスタンス タグを割り当てます。

ステップ 3

max-metric router-lsa [ external-lsa [ max-metric-value] ] [ include-stub ] [ on-startup { seconds | wait-for bgp tag }] [ summary-lsa [ max-metric-value ]]

Example:

switch(config-router)# max-metric router-lsa

OSPFv2 スタブ ルート アドバタイズメントを設定します。

ステップ 4

copy running-config startup-config

 

Example:

switch(config-router)# copy running-config startup-config

(任意)この設定の変更を保存します。

 

次に、起動時にスタブ ルータ アドバタイズメントを、デフォルトの 600 秒間イネーブルにする例を示します。

switch# configure terminal

switch(config)# router ospf 201

switch(config-router)# max-metric router-lsa on-startup

switch(config-router)# copy running-config startup-config

ルートのアドミニストレーティブ ディスタンスの設定

Cisco NX-OS Release 6.1 以降では、RIB に OSPFv2 によって追加されるルートのアドミニストレーティブ ディスタンスを設定できます。

アドミニストレーティブ ディスタンスは、ルーティング情報源の信頼性を示す評価基準です。値が高いほど信頼性の評価は低くなります。一般的にルートは、複数のルーティング プロトコルを通じて検出されます。アドミニストレーティブ ディスタンスは、複数のルーティング プロトコルから学習したルートを区別するために使用されます。最もアドミニストレーティブ ディスタンスが低いルートが IP ルーティング テーブルに組み込まれます。

はじめる前に

OSPF がイネーブルになっていることを確認します(「OSPFv2 のイネーブル化」を参照)。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

この機能に関する注意事項と制約事項については、「OSPFv2 に関する注意事項および制約事項」を参照してください。

手順の概要

1. configure terminal

2. router ospf instance-tag

3. [ no ] table-map map-name

4. exit

5. route-map map-name [ permit | deny ] [ seq ]

6. match route-type route-type

7. match ip route-source prefix-list name

8. match ip address prefix-list name

9. set distance value

10. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router ospf instance-tag

 

Example:

switch(config)# router ospf 201

switch(config-router)#

新規 OSPFv2 インスタンスを作成して、設定済みのインスタンス タグを割り当てます。

ステップ 3

[ no ] table-map map-name

 

Example:

switch(config-router)# table-map foo

OSPFv2 ルートを RIB に送信する前に、OSPFv2 ルートをフィルタリングまたは変更するポリシーを設定します。マップ名には最大 63 文字の英数字を入力できます。

ステップ 4

exit

 

Example:

switch(config-router)# exit

switch(config)#

ルータ コンフィギュレーション モードを終了します。

ステップ 5

route-map map-name [ permit | deny ] [ seq ]

 

Example:

switch(config)# route-map foo permit 10

switch(config-route-map)#

ルート マップを作成するか、または既存のルート マップに対応するルート マップ コンフィギュレーション モードを開始します。 seq を使用して、ルート マップ エントリを順序付けます。

オプションを使用すると、デフォルトのディスタンスが適用されます。

ステップ 6

match route-type route-type

 

Example:

switch(config-route-map)# match route-type external

次のルート タイプのいずれかと照合します。

external:外部ルート(BGP、EIGRP、OSPF タイプ 1 または 2)

inter-area:OSPF エリア間ルート

internal:内部ルート(OSPF エリア内またはエリア間ルートを含む)

intra-area:OSPF エリア内ルート

nssa-external:NSSA 外部ルート(OSPF タイプ 1 または 2)

type-1:OSPF 外部タイプ 1 ルート

type-2:OSPF 外部タイプ 2 ルート

ステップ 7

match ip route-source prefix-list name

 

Example:

switch(config-route-map)# match ip route-source prefix-list p1

1 つまたは複数の IP プレフィックス リストに対して、ルートの IPv4 ルート送信元アドレスまたはルータ ID と照合します。プレフィックス リストは ip prefix-list コマンドを使用して作成します。

ステップ 8

match ip address prefix-list name

 

Example:

switch(config-route-map)# match ip address prefix-list p1

1 つまたは複数の IPv4 プレフィックス リストと照合。プレフィックス リストは ip prefix-list コマンドを使用して作成します。

ステップ 9

set distance value

 

Example:

switch(config-route-map)# set distance 150

OSPFv2 のルートのアドミニストレーティブ ディスタンスを設定します。指定できる範囲は 1 ~ 255 です。

ステップ 10

copy running-config startup-config

 

Example:

switch(config-route-map)# copy running-config startup-config

(任意)この設定の変更を保存します。

 

次に、OSPFv2 アドミニストレーティブ ディスタンスについて、エリア間ルートを 150、外部ルートを 200、およびプレフィックス リスト p1 内のすべてのプレフィックスを 190 に設定する例を示します。

switch# configure terminal

switch(config)# router ospf 201

switch(config-router)# table-map foo

switch(config-router)# exit

 

switch(config)# route-map foo permit 10

switch(config-route-map)# match route-type inter-area

switch(config-route-map)# set distance 150

switch(config)# route-map foo permit 20

switch(config-route-map)# match route-type external

switch(config-route-map)# set distance 200

switch(config)# route-map foo permit 30

switch(config-route-map)# match ip route-source prefix-list p1

switch(config-route-map)# match ip address prefix-list p1

switch(config-route-map)# set distance 190

デフォルト タイマーの変更

OSPFv2 には、プロトコル メッセージの動作および SPF 計算を制御する数多くのタイマーが含まれます。OSPFv2 には、省略可能な次のタイマー パラメータが含まれます。

LSA arrival time:ネイバーから着信する LSA 間で許容される最小間隔を設定します。この時間より短時間で到着する LSA はドロップされます。

Pacing LSAs:LSA が集められてグループ化され、リフレッシュされて、チェックサムが計算される間隔、つまり期限切れとなる間隔を設定します。このタイマーは、LSA 更新が実行される頻度を制御し、LSA 更新メッセージで送信される LSA 更新の数を制御します(「フラッディングと LSA グループ ペーシング」を参照)。

Throttle LSAs:LSA 生成のレート制限を設定します。このタイマーは、トポロジが変更された後に LSA が生成される頻度を制御します。

Throttle SPF calculation:SPF 計算の実行頻度を制御します。

インターフェイス レベルでは、次のタイマーも制御できます。

Retransmit interval:連続する LSA 間の推定時間間隔を設定します。

Transmit delay:LSA をネイバーに送信する推定時間を設定します。

hello 間隔とデッド タイマーに関する情報の詳細については、「OSPFv2 でのネットワークの設定」を参照してください。

はじめる前に

OSPF がイネーブルになっていることを確認します(「OSPFv2 のイネーブル化」を参照)。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. router ospf instance-tag

3. timers lsa-arrival msec

4. timers lsa-group-pacing seconds

5. timers throttle lsa start-time hold-interval max-time

6. timers throttle spf delay-time hold-time

7. interface type slot/port

8. ip ospf hello-interval seconds

9. ip ospf dead-interval seconds

10. ip ospf retransmit-interval seconds

11. ip ospf transmit-delay seconds

12. (任意)show ip ospf

13. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router ospf instance-tag

 

Example:

switch(config)# router ospf 201

switch(config-router)#

新規 OSPFv2 インスタンスを作成して、設定済みのインスタンス タグを割り当てます。

ステップ 3

timers lsa-arrival msec

 

Example:

switch(config-router)# timers lsa-arrival 2000

LSA 到着時間をミリ秒で設定します。指定できる範囲は 10 ~ 600000 です。デフォルトは 1000 ミリ秒です。

ステップ 4

timers lsa-group-pacing seconds

 

Example:

switch(config-router)# timers lsa-group-pacing 200

LSA がグループ化される間隔を秒で設定します。指定できる範囲は 1 ~ 1800 です。デフォルト値は 10 秒です。

ステップ 5

timers throttle lsa start-time hold-interval max-time

 

Example:

switch(config-router)# timers throttle lsa 3000

次のタイマーを使用して、LSA 生成のレート制限をミリ秒で設定します。

start-time :指定できる範囲は 0 ~ 5000 ミリ秒です。デフォルト値は 0 ミリ秒です。

hold-interval :指定できる範囲は 50 ~ 30,000 ミリ秒です。デフォルト値は 5000 ミリ秒です。

max-time :指定できる範囲は 50 ~ 30,000 ミリ秒です。デフォルト値は 5000 ミリ秒です。

ステップ 6

timers throttle spf delay-time hold-time max-wait

 

Example:

switch(config-router)# timers throttle spf 3000 2000 4000

SPF 最適パス スケジュール初期遅延時間と、各 SPF 最適パス計算間の最小ホールド タイム(秒単位)を設定します。指定できる範囲は 1 ~ 600000 です。デフォルトは、遅延時間なし、およびホールド タイム 5000 ミリ秒です。

ステップ 7

interface type slot/port

 

Example :

switch(config)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 8

ip ospf hello-interval seconds

 

Example:

switch(config-if)# ip ospf hello-interval 30

このインターフェイスの hello 間隔を設定します。有効な範囲は 1 ~ 65535 です。デフォルトは 10 です。

ステップ 9

ip ospf dead-interval seconds

 

Example:

switch(config-if)# ip ospf dead-interval 30

このインターフェイスのデッド間隔を設定します。有効な範囲は 1 ~ 65535 です。

ステップ 10

ip ospf retransmit-interval seconds

 

Example:

switch(config-if)# ip ospf retransmit-interval 30

このインターフェイスから送信される各 LSA 間の推定時間間隔を設定します。有効な範囲は 1 ~ 65535 です。デフォルトは 5 です。

ステップ 11

ip ospf transmit-delay seconds

 

Example:

switch(config-if)# ip ospf transmit-delay 600

switch(config-if)#

LSA をネイバーに送信する推定時間間隔を秒で設定します。指定できる範囲は 1 ~ 450 です。デフォルトは 1 です。

ステップ 12

show ip ospf

 

Example :

switch(config-if)# show ip ospf

(任意)OSPF に関する情報を表示します。

ステップ 13

copy running-config startup-config

 

Example:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、lsa-group-pacing オプションで LSA フラッディングを制御する例を示します。

switch# configure terminal

switch(config)# router ospf 201

switch(config-router)# timers lsa-group-pacing 300

switch(config-router)# copy running-config startup-config

グレースフル リスタートの設定

グレースフル リスタートは、デフォルトでイネーブルにされています。OSPFv2 インスタンスのグレースフル リスタートには、省略可能な次のパラメータを設定できます。

Grace period:グレースフル リスタートの開始後に、ネイバーが隣接関係を解消するまでに待つ時間を設定します。

Helper mode disabled:ローカル OSPFv2 インスタンスのヘルパー モードをディセーブルにします。OSPFv2 は、ネイバーのグレースフル リスタートには関与しません。

Planned graceful restart only:予定された再起動の場合にだけグレースフル リスタートがサポートされるように OSPFv2 を設定します。

はじめる前に

OSPF がイネーブルになっていることを確認します(「OSPFv2 のイネーブル化」を参照)。

すべてのネイバーで、一致した省略可能なパラメータ一式とともにグレースフル リスタートが設定されていることを確認します。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. router ospf instance-tag

3. graceful-restart

4. (任意)graceful-restart grace-period seconds

5. (任意)graceful-restart helper-disable

6. (任意)graceful-restart planned-only

7. (任意)show ip ospf instance-tag

8. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router ospf instance-tag

 

Example:

switch(config)# router ospf 201

switch(config-router)#

新規 OSPFv2 インスタンスを作成して、設定済みのインスタンス タグを割り当てます。

ステップ 3

graceful-restart

 

Example:

switch(config-router)# graceful-restart

グレースフル リスタートをイネーブルにします。グレースフル リスタートは、デフォルトでイネーブルにされています。

ステップ 4

graceful-restart grace-period seconds

 

Example:

switch(config-router)# graceful-restart grace-period 120

(任意)猶予期間を秒で設定します。指定できる範囲は 5 ~ 1800 です。デフォルトは 60 秒です。

ステップ 5

graceful-restart helper-disable

 

Example:

switch(config-router)# graceful-restart helper-disable

(任意)ヘルパー モードをディセーブルにします。この機能は、デフォルトでイネーブルにされています。

ステップ 6

graceful-restart planned-only

 

Example:

switch(config-router)# graceful-restart planned-only

(任意)予定された再起動時にだけグレースフル リスタートを設定します。

ステップ 7

show ip ospf instance-tag

 

Example :

switch(config-if)# show ip ospf 201

(任意)OSPF 情報を表示します。

ステップ 8

copy running-config startup-config

 

Example:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、ディセーブルにされているグレースフル リスタートをイネーブルにし、猶予期間を 120 秒に設定する例を示します。

switch# configure terminal

switch(config)# router ospf 201

switch(config-router)# graceful-restart

switch(config-router)# graceful-restart grace-period 120

switch(config-router)# copy running-config startup-config

OSPFv2 インスタンスの再起動

OSPFv2 インスタンスを再起動できます。この処理では、インスタンスのすべてのネイバーが消去されます。

OSPFv2 インスタンスを再起動して、関連付けられたすべてのネイバーを削除するには、次のコマンドを使用します。

 

コマンド
目的

restart ospf instance-tag

 

Example:

switch(config)# restart ospf 201

OSPFv2 インスタンスを再起動して、すべてのネイバーを削除します。

仮想化による OSPFv2 の設定

各 VDC で複数の OSPFv2 インスタンスを設定できます。各 VDC 内に複数の VRF を作成して、各 VRF で同じまたは複数の OSPFv2 インスタンスを使用することもできます。VRF には OSPFv2 インターフェイスを割り当てます。


) インターフェイスの VRF を設定したあとに、インターフェイスの他のすべてのパラメータを設定します。インターフェイスの VRF を設定すると、そのインターフェイスのすべての設定が削除されます。


はじめる前に

VDC を作成します。

OSPF がイネーブルになっていることを確認します(「OSPFv2 のイネーブル化」を参照)。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. vrf context vrf_name

3. router ospf instance-tag

4. vrf vrf-name

5. (任意)maximum-paths paths

6. interface interface-type slot/port

7. vrf member vrf-name

8. ip-address ip-prefix/length

9. router ospf instance-tag area area-id

10. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

vrf context vrf-name

 

Example:

switch(config)# vrf context RemoteOfficeVRF

switch(config-vrf)#

新しい VRF を作成し、VRF コンフィギュレーション モードを開始します。

ステップ 3

router ospf instance-tag

 

Example:

switch(config-vrf)# router ospf 201

switch(config-router)#

新規 OSPFv2 インスタンスを作成して、設定済みのインスタンス タグを割り当てます。

ステップ 4

vrf vrf-name

 

Example:

switch(config-router)# vrf RemoteOfficeVRF

switch(config-router-vrf)#

VRF コンフィギュレーション モードを開始します。

ステップ 5

maximum-paths paths

 

Example :

switch(config-router-vrf)# maximum-paths 4

(任意)この VRF のルート テーブル内の宛先への、同じ OSPFv2 パスの最大数を設定します。この機能は、ロード バランシングに使用されます。

ステップ 6

interface interface-type slot/port

 

Example :

switch(config-router-vrf)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 7

vrf member vrf-name

 

Example:

switch(config-if)# vrf member RemoteOfficeVRF

このインターフェイスを VRF に追加します。

ステップ 8

ip address ip-prefix/length

 

Example:

switch(config-if)# ip address 192.0.2.1/16

このインターフェイスの IP アドレスを設定します。このステップは、このインターフェイスを VRF に割り当てたあとに行う必要があります。

ステップ 9

ip router ospf instance-tag area area-id

 

Example:

switch(config-if)# ip router ospf 201 area 0

このインターフェイスを OSPFv2 インスタンスおよび設定エリアに割り当てます。

ステップ 10

copy running-config startup-config

 

Example:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、VRF を作成して、その VRF にインターフェイスを追加する例を示します。

switch# configure terminal

switch(config)# vrf context NewVRF

switch(config)# router ospf 201

switch(config)# interface ethernet 1/2

switch(config-if)# vrf member NewVRF

switch(config-if)# ip address 192.0.2.1/16

switch(config-if)# ip router ospf 201 area 0

switch(config)# copy running-config startup-config

OSPFv2 設定の確認

OSPFv2 の設定を表示するには、次のいずれかの作業を行います。

 

コマンド
目的

show ip ospf

OSPFv2 設定を表示します。

show ip ospf border-routers [ vrf { vrf-name | all | default | management }]

OSPFv2 境界ルータ設定を表示します。

show ip ospf database [ vrf { vrf-name | all | default | management }]

OSPFv2 リンクステート データベースの要約を表示します。

show ip ospf interface number [ vrf { vrf-name | all | default | management }]

OSPFv2 インターフェイス設定を表示します。

show ip ospf lsa-content-changed-list neighbor-id interface - type number [ vrf { vrf-name | all | default | management }]

変更された OSPFv2 LSA を表示します。

show ip ospf neighbors [ neighbor-id ] [ detail ] [ interface - type number ] [ vrf { vrf-name | all | default | management }] [ summary ]

OSPFv2 ネイバーの一覧を表示します。

show ip ospf request-list neighbor-id interface - type number [ vrf { vrf-name | all | default | management }]

OSPFv2 リンクステート要求の一覧を表示します。

show ip ospf retransmission-list neighbor-id interface - type number [ vrf { vrf-name | all | default | management }]

OSPFv2 リンクステート再送の一覧を表示します。

show ip ospf route [ ospf-route ] [ summary ] [ vrf { vrf-name | all | default | management }]

内部 OSPFv2 ルートを表示します。

show ip ospf summary-address [ vrf { vrf-name | all | default | management }]

OSPFv2 集約アドレスに関する情報を表示します。

show ip ospf virtual-links [ brief ] [ vrf { vrf-name | all | default | management }]

OSPFv2 仮想リンクに関する情報を表示します。

show ip ospf vrf { vrf-name | all | default | management }

VRF ベースの OSPFv2 設定に関する情報を表示します。

show running-configuration ospf

現在実行中の OSPFv2 設定を表示します。

OSPFv2 のモニタリング

OSPFv2 統計情報を表示するには、次のコマンドを使用します。

 

コマンド
目的

show ip ospf policy statistics area area-id filter-list { in | out } [ vrf { vrf-name | all | default | management }]

エリアの OSPFv2 ルート ポリシー統計情報を表示します。

show ip ospf policy statistics redistribute { bgp id | direct | eigrp id | isis id | ospf id | rip id | static } [ vrf { vrf-name | all | default | management }]

OSPFv2 ルート ポリシー統計情報を表示します。

show ip ospf statistics [ vrf { vrf-name | all | default | management }]

OSPFv2 イベント カウンタを表示します。

show ip ospf traffic [ interface - type number ] [ vrf { vrf-name | all | default | management }]

OSPFv2 パケット カウンタを表示します。

OSPFv2 の設定例

次に、OSPFv2 を設定する例を示します。

feature ospf
router ospf 201
router-id 290.0.2.1
 
interface ethernet 1/2
ip router ospf 201 area 0.0.0.10
ip ospf authentication
ip ospf authentication-key 0 mypass
 

OSPF RFC 互換モードの例

次に、RFC 1583 互換ルータと互換性を持つように OSPF を設定する例を示します。


) RFC1583 互換の OSPF のみを実行するルータに接続するすべての VRF で、RFC 1583 の互換性を設定する必要があります。


switch#_configure terminal
switch(config)# feature ospf
switch(config)# router ospf Test1
switch(config-router)# rfc1583compatibility
switch(config-router)# vrf A
switch(config-router-vrf)# rfc1583compatibility

その他の関連資料

OSPF の実装に関する詳細情報については、次のページを参照してください。

「関連資料」

「MIB」

関連資料

関連項目
マニュアル名

OSPFv2 CLI コマンド

『Cisco Nexus 7000 Series NX-OS Unicast Routing Command Reference』

仮想デバイス コンテキスト(VDC)

『Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide, Release 5.x

IPv6 ネットワーク向け OSPFv3

「OSPFv3 の設定」

ルート マップ

「Route Policy Manager の設定」

MIB

管理情報ベース(MIB)
MIB のリンク

OSPF-MIB

OSPF-TRAP-MIB

管理情報ベース(MIB)を検索およびダウンロードするには、次の URL にアクセスしてください。

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

OSPFv2 機能の履歴

表 6-3 は、この機能のリリースの履歴です。

 

表 6-3 OSPFv2 機能の履歴

機能名
リリース
機能情報

OSPFv2

6.1(1)

VDC ごとに OSPFv2 の 4 つ以上のプロセス インスタンスのサポートが追加されました。

OSPFv2

6.1(1)

OSPFv2 のルートのアドミニストレーティブ ディスタンスを設定するサポートが追加されました。

パッシブ インターフェイス

5.2(1)

ルータまたは VRF のすべてのインターフェイスでパッシブ インターフェイス モードを設定する機能を追加しました。

OSPFv2

5.1(2)

max-metric router-lsa コマンドのオプションが追加されました。

BFD

5.0(2)

BFD のサポートが追加されました。詳細については、『 Cisco Nexus 7000 Series NX-OS Interfaces Configuration Guide, Release 6.x 』を参照してください。

OSPFv2

4.0(1)

この機能が導入されました。