Cisco Nexus 7000 シリーズ NX-OS ユニキャスト ルーティング コンフィギュレーション ガイド リリース 6.x
EIGRP の設定
EIGRP の設定
発行日;2013/08/27 | 英語版ドキュメント(2013/08/22 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 7MB) | フィードバック

目次

EIGRP の設定

EIGRP について

EIGRP のコンポーネント

Reliable Transport Protocol

ネイバー探索およびネイバー回復

拡散更新アルゴリズム

EIGRP ルート更新

内部ルート メトリック

ワイド メトリック

外部ルート メトリック

EIGRP とユニキャスト RIB

高度な EIGRP

アドレス ファミリ

認証

スタブ ルータ

ルート集約

ルートの再配布

ロード バランシング

スプリット ホライズン

BFD

仮想化のサポート

グレースフル リスタートおよびハイ アベイラビリティ

EIGRP のライセンス要件

EIGRP の前提条件

EIGRP の注意事項および制約事項

デフォルト設定

基本的 EIGRP の設定

EIGRP 機能のイネーブル化

EIGRP インスタンスの作成

EIGRP インスタンスの再起動

EIGRP インスタンスのシャットダウン

EIGRP の受動インターフェイスの設定

インターフェイスでの EIGRP のシャットダウン

高度な EIGRP の設定

EIGRP での認証の設定

EIGRP スタブ ルーティングの設定

EIGRP のサマリー集約アドレスの設定

EIGRP へのルートの再配布

再配布されるルート数の制限

EIGRP でのロードバランスの設定

EIGRP のグレースフル リスタートの設定

hello パケットとホールド タイムの間隔調整

スプリット ホライズンのディセーブル化

ワイド メトリックのイネーブル化

EIGRP の調整

EIGRP の仮想化の設定

EIGRP 設定の確認

EIGRP のモニタリング

EIGRP の設定例

関連資料

その他の関連資料

関連資料

管理情報ベース(MIB)

EIGRP 機能の履歴

EIGRP の設定

この章では、Cisco NX-OS デバイス上で Enhanced Interior Gateway Routing Protocol( EIGRP )を設定する方法について説明します。

この章では、次の内容について説明します。

「EIGRP について」

「EIGRP のライセンス要件」

「EIGRP の前提条件」

「EIGRP の注意事項および制約事項」

「デフォルト設定」

「基本的 EIGRP の設定」

「高度な EIGRP の設定」

「EIGRP の仮想化の設定」

「EIGRP 設定の確認」

「EIGRP のモニタリング」

「EIGRP の設定例」

「関連資料」

「その他の関連資料」

「EIGRP 機能の履歴」

EIGRP について

EIGRP は、リンクステート プロトコルの機能にディスタンス ベクトル プロトコルの利点を組み合わせたプロトコルです。EIGRP は、定期的に Hello メッセージを送信してネイバーを探索します。EIGRP は、新規ネイバーを検出すると、すべてのローカル EIGRP ルートおよびルート メトリックに対する 1 回限りの更新を送信します。受信側の EIGRP ルータは、受信したメトリックと、その新規ネイバーにローカルで割り当てられたリンクのコストに基づいて、ルート ディスタンスを計算します。この最初の全面的なルート テーブルの更新後は、ルート変更の影響を受けるネイバーにのみ、差分更新が EIGRP により送信されます。この処理により、コンバージェンスにかかる時間が短縮され、EIGRP が使用する帯域幅が最小限になります。

ここでは、次の内容について説明します。

「EIGRP のコンポーネント」

「EIGRP ルート更新」

「高度な EIGRP」

EIGRP のコンポーネント

EIGRP には、次の基本コンポーネントがあります。

「Reliable Transport Protocol」

「ネイバー探索およびネイバー回復」

「拡散更新アルゴリズム」

Reliable Transport Protocol

Reliable Transport Protocol により、すべてのネイバーへの EIGRP パケットの配信が保証されます (「ネイバー探索およびネイバー回復」を参照)。Reliable Transport Protocol は、マルチキャスト パケットとユニキャスト パケットの混合伝送をサポートしています。この転送は信頼性が高く、未確認パケットが保留されているときにも、マルチキャスト パケットの迅速な送信が可能です。この方式により、さまざまな速度のリンクでも短いコンバージェンス時間が維持されるようになります。マルチキャスト パケットとユニキャスト パケットの送信を制御するデフォルト タイマーの変更の詳細については、「高度な EIGRP の設定」を参照してください。

Reliable Transport Protocol には、次のメッセージ タイプが含まれます。

Hello:ネイバー探索およびネイバー回復に使用されます。EIGRP はデフォルトでは、定期的なマルチキャスト Hello メッセージをローカル ネットワーク上に、設定された hello 間隔 で送信します。デフォルトの hello 間隔は 5 秒です。

確認:更新、照会、返信を確実に受信したことを確認します。

更新:ルーティング情報が変更されると、その影響を受けるネイバーに送信されます。更新には、ルートの宛先、アドレス マスク、および遅延や帯域幅などのルート メトリックが含まれます。更新情報は EIGRP トポロジ テーブルに格納されます。

照会および応答:EIGRP で使用される拡散更新アルゴリズムの一部として送信されます。

ネイバー探索およびネイバー回復

EIGRP は、Reliable Transport Protocol からの Hello メッセージを使用して、直接接続されたネットワーク上のネイバー EIGRP ルータを探索します。EIGRP により、ネイバー テーブルにネイバーが追加されます。ネイバー テーブルの情報には、ネイバー アドレス、検出されたインターフェイス、および ホールド タイム が含まれています。ホールド タイムは、ネイバー到達不能を宣言する前に EIGRP が待機する時間を示します。デフォルトのホールド タイムは、hello 間隔の 3 倍または 15 秒です。

EIGRP は、ローカル EIGRP ルーティング情報を共有するために、一連の更新メッセージを新規ネイバーに送信します。このルート情報は EIGRP トポロジ テーブルに格納されます。このように EIGRP ルート情報全体を最初に送信したあとは、ルーティングが変更されたときにのみ、EIGRP により更新メッセージが送信されます。これらの更新メッセージは新情報または更新情報のみを含んでおり、変更の影響を受けるネイバーにのみ送信されます。「EIGRP ルート更新」を参照してください。

EIGRP はネイバーへのキープアライブとして、Hello メッセージも使用します。Hello メッセージを受信している限り、Cisco NX-OS は、ネイバーがダウンせずに機能していると判定します。

拡散更新アルゴリズム

拡散更新アルゴリズム (DUAL)により、トポロジ テーブルの宛先ネットワークに基づいてルーティング情報が計算されます。トポロジ テーブルには、次の情報が含まれます。

IPv4 または IPv6 アドレス/マスク:この宛先のマスクのネットワーク アドレスおよびネットワーク マスク。

サクセサ:すべての フィジブル サクセサ または、現在の フィジブル ディスタンス よりも短いディスタンスをアドバタイズするネイバーの IP アドレスおよびローカル インターフェイス接続。

Feasibility Distance(FD; フィジブル ディスタンス):計算された、宛先までの最短ディスタンス。フィジブル ディスタンスは、ネイバーがアドバタイズした距離に、そのネイバーへのリンク コストを加えた合計です。

DUAL は、ディスタンス メトリックを使用して、ループが発生しない効率的なパスを選択します。DUAL はルートを選択し、フィジブル サクセサに基づいてユニキャスト Routing Information Base(RIB; ルーティング情報ベース)に挿入します。トポロジが変更されると、DUAL は、トポロジ テーブルでフィジブル サクセサを探します。フィジブル サクセサが見つかった場合、DUAL は、最短のフィジブル ディスタンスを持つフィジブル サクセサを選択して、それをユニキャスト RIB に挿入します。これにより、再計算が不要となります。

フィジブル サクセサが存在しないが、宛先をアドバタイズするネイバーが存在する場合は、DUAL がパッシブ状態からアクティブ状態へと移行し、新しいサクセサまたは宛先へのネクスト ホップ ルータを決定する再計算をトリガーします。ルートの再計算に必要な時間はコンバージェンス時間に影響します。EIGRP は照会メッセージをすべてのネイバーに送信し、フィジブル サクセサを探します。フィジブル サクセサを持つネイバーは、その情報を含む返信メッセージを送信します。フィジブル サクセサを持たないネイバーは、DUAL の再計算をトリガーします。

EIGRP ルート更新

トポロジが変更されると、EIGRP は、変更されたルーティング情報のみを含む更新メッセージを、影響を受けるネイバーに送信します。更新メッセージには、新規の、または更新されたネットワーク宛先へのディスタンス情報が含まれます。

EIGRP でのディスタンス情報は、帯域幅、遅延、負荷使用状況、リンクの信頼性などの使用可能なルート メトリックの組み合わせとして表現されます。各メトリックには重みが関連付けられており、これにより、メトリックがディスタンスの計算に含まれるかどうかが決定します。このメトリックの重みは設定することができます。特性を微調整して最適なパスを完成することもできますが、設定可能なメトリックの大部分でデフォルト設定を使用することを推奨します。

ここでは、次の内容について説明します。

「内部ルート メトリック」

「ワイド メトリック」

「外部ルート メトリック」

「EIGRP とユニキャスト RIB」

内部ルート メトリック

内部ルートとは、同じ EIGRP 自律システム内のネイバー間のルートです。これらのルートには、次のメトリックがあります。

ネクスト ホップ:ネクスト ホップ ルータの IP アドレス

遅延:宛先ネットワークへのルートを形成するインターフェイス上で設定された遅延の合計。遅延は 10 マイクロ秒単位で設定されます。

帯域幅:宛先へのルートの一部であるインターフェイスで設定された最小帯域幅から計算されます。


) デフォルト帯域幅の値の使用を推奨します。この帯域幅パラメータは EIGRP でも使用されます。


MTU:宛先へのルート上の最大伝送単位の最小値

ホップ カウント:宛先までにルートが通過するホップまたはルータの数。このメトリックは、DUAL 計算で直接には使用されません。

信頼性:宛先までのリンクの信頼性を示します。

負荷:宛先までのリンク上のトラフィック量を示します。

デフォルトで EIGRP は、帯域幅と遅延のメトリックを使用して、宛先までのディスタンスを計算します。計算に他のメトリックが含まれるように、メトリックの重みを変更できます。

ワイド メトリック

EIGRP は、より高速なインターフェイスまたはバンドルされたインターフェイス上でのルート選択を改善するためのワイド(64 ビット)メトリックをサポートします。ワイド メトリックをサポートしているルータは、次のように、ワイド メトリックをサポートしていないルータと相互運用できます。

ワイド メトリックをサポートするルータ:受信した値にローカルのワイド メトリック値を追加し、その情報を転送します。

ワイド メトリックをサポートしていないルータ:受信したすべてのメトリックを、その値を変更せずに転送します。

EIGRP では、次の式を使用してワイド メトリックでのパス コストを計算します。

メトリック = [k1 x 帯域幅 + (k2 x 帯域幅)/(256 - 負荷) + k3 x 遅延 + k6 x 拡張属性] x [k5/(信頼性 + k4)]

ユニキャスト RIB は 64 ビット メトリック値をサポートできないため、EIGRP ワイド メトリックでは、RIB スケール係数を含む次の式を使用して 64 ビットのメトリック値を 32 ビットの値に変換します。

RIB メトリック = (ワイド メトリック/RIB スケール値)。

ここで、RIB スケール値は設定可能なパラメータです。

EIGRP ワイド メトリックでは、EIGRP メトリック設定で k6 として表される、次の 2 つの新しいメトリック値が導入されています。

ジッター:(マイクロ秒で測定されます)ルート パス内のすべてのリンクにわたって累積されます。EIGRP パス選択には、ジッター値の小さいルートが適しています。

エネルギー:(ワット数/キロビットで測定されます)ルート パス内のすべてのリンクにわたって累積されます。EIGRP パス選択には、エネルギー値の小さいルートが適しています。

EIGRP では、ジッターまたはエネルギー メトリック値がないか、ジッターまたはメトリック値の小さいパスの方が、これらの値が大きいパスより適しています。


) EIGRP ワイド メトリックは、TLV バージョン 2 で送信されます。詳細については、「ワイド メトリックのイネーブル化」を参照してください。


外部ルート メトリック

外部ルートとは、異なる EIGRP AS にあるネイバー間のルートです。これらのルートには、次のメトリックがあります。

ネクスト ホップ:ネクスト ホップ ルータの IP アドレス

ルータ ID:このルートを EIGRP に再配布したルータのルータ ID

AS 番号:宛先の自律システム番号。

プロトコル ID:宛先へのルートを学習したルーティング プロトコルを表すコード

タグ:ルート マップで使用可能な任意のタグ

メトリック:外部ルーティング プロトコルの、このルートのルート メトリック

EIGRP とユニキャスト RIB

EIGRP は、学習したルートをすべて、EIGRP トポロジ テーブルとユニキャスト RIB に追加します。トポロジが変更されると、EIGRP は、これらのルートを使用してフィジブル サクセサを探します。EIGRP は、他のルーティング プロトコルから EIGRP に再配布されたあらゆるルートの変更についてのユニキャスト RIB からの通知も待ち受けます。

高度な EIGRP

EIGRP の高度な機能を使用して、EIGRP の設定を最適化できます。

ここでは、次の内容について説明します。

「アドレス ファミリ」

「認証」

「スタブ ルータ」

「ルート集約」

「ルートの再配布」

「ロード バランシング」

「スプリット ホライズン」

「BFD」

「仮想化のサポート」

「グレースフル リスタートおよびハイ アベイラビリティ」

アドレス ファミリ

EIGRP では、IPv4 と IPv6 の両方のアドレス ファミリをサポートしています。下位互換性を保つために、ルート コンフィギュレーション モードまたは IPV4 アドレス ファミリ モードで EIGRPv4 を設定できます。IPv6 の EIGRP をアドレス ファミリ モードで設定する必要があります。

アドレス ファミリ コンフィギュレーション モードには、次の EIGRP 機能が含まれます。

認証

AS 番号

デフォルト ルート

メトリック

ディスタンス

グレースフル リスタート

ロギング

ロード バランシング

再配布

ルータ ID

スタブ ルータ

タイマー

複数のコンフィギュレーション モードで同じ機能を設定できません。たとえばルータ コンフィギュレーション モードでデフォルト メトリックを設定すると、アドレス ファミリ モードでデフォルト メトリックを設定できません。

認証

EIGRP メッセージに認証を設定して、ネットワークでの不正な、または無効なルーティング更新を防止できます。EIGRP 認証は MD5 認証ダイジェストをサポートしています。

認証キーのキーチェーン管理を使用して、仮想ルーティング/転送(VRF)インスタンスごと、またはインターフェイスごとに EIGRP 認証を設定できます。キーチェーン管理を使用すると、MD5 認証ダイジェストが使用する認証キーへの変更を管理できます。キー チェーンの作成の詳細については、 『 Cisco Nexus 7000 Series NX-OS Security Configuration Guide, Release 6.x』 を参照してください。

MD5 認証を行うには、ローカル ルータとすべてのリモート EIGRP ネイバーで同一のパスワードを設定します。EIGRP メッセージが作成されると、Cisco NX-OS は、そのメッセージ自体と暗号化されたパスワードに基づいて MD5 一方向メッセージ ダイジェストを作成し、このダイジェストを EIGRP メッセージとともに送信します。受信する EIGRP ネイバーは、同じ暗号化パスワードを使用して、このダイジェストを確認します。メッセージが変更されていない場合は計算が同一であるため、EIGRP メッセージは有効と見なされます。

MD5 認証には各 EIGRP メッセージのシーケンス番号も含まれており、これにより、ネットワークでのメッセージの再送が防止されます。

スタブ ルータ

EIGRP スタブ ルーティング機能を使用して、ネットワークの安定性を向上させ、リソースの使用を削減し、スタブ ルータ設定を簡素化することができます。スタブ ルータは、リモート ルータ経由で EIGRP ネットワークに接続します。「スタブ ルーティング」を参照してください。

EIGRP スタブ ルーティングを使用すると、EIGRP を使用するように配布とリモート ルータを設定し、リモート ルータのみをスタブとして設定する必要があります。EIGRP スタブ ルーティングで、分散ルータでの集約が自動的にイネーブルになるわけではありません。ほとんどの場合、分散ルータでの集約の設定が必要です。

EIGRP スタブ ルーティングを使用しない場合は、分散ルータからリモート ルータに送信されたルートがフィルタリングまたは集約されたあとでも、問題が発生することがあります。たとえば、ルートが企業ネットワーク内のどこかで失われた場合に、EIGRP が分散ルータに照会を送信することがあります。分散ルータは、ルートが集約されている場合でも、リモート ルータに照会を送信することがあります。分散ルータとリモート ルータの間の WAN リンク上の通信で問題が発生した場合は EIGRP がアクティブ状態のままとなり、ネットワークの他の場所が不安定となる場合があります。EIGRP スタブ ルーティングを使用すると、リモート ルータに照会が送信されなくなります。

ルート集約

指定したインターフェイスにサマリー集約アドレスを設定できます。ルート集約を使用すると、固有性の強い一連のアドレスをすべての固有アドレスを代表する 1 つのアドレスに置き換えることによって、ルート テーブルを簡素化できます。たとえば、10.1.1.0/24、10.1.2.0/24、および 10.1.3.0/24 というアドレスを 1 つの集約アドレス 10.1.0.0/16 に置き換えることができます。

より具体的なアドレスがルーティング テーブルにある場合、EIGRP は、より具体的なルートの最小メトリックに等しいメトリックを持つインターフェイスからの集約アドレスをアドバタイズします。


) EIGRP は、自動ルート集約をサポートしていません。


ルートの再配布

EIGRP を使用すると、スタティック ルート、他の EIGRP 自律システムによって学習されたルート、または他のプロトコルからのルートを再配布できます。再配布を指定したルート マップを設定して、どのルートが EIGRP に渡されるかを制御する必要があります。ルート マップを使用すると、宛先、送信元プロトコル、ルート タイプ、ルート タグなどの属性に基づいて、ルートをフィルタリングできます。「Route Policy Manager の設定」を参照してください。

インポートされた EIGRP へのすべてのルートに使用されるデフォルト メトリックも設定できます。

ルーティング アップデートからルートをフィルタリングするには、配布リストを使用します。これらのフィルタ処理されたルートは、 ip distribute-list eigrp コマンドで各インターフェイスに適用されます。

ロード バランシング

ロード バランシングを使用すると、ルータによって、宛先アドレスから同じ距離にあるすべてのルータ ネットワーク ポートにトラフィックが分散されます。ロード バランシングにより、ネットワーク セグメントの使用率が向上し、それによってネットワーク帯域幅の効率も向上します。

Cisco NX-OS は、EIGRP ルート テーブルおよびユニキャスト RIB 中の 16 までの等コスト パスを使用する等コスト マルチパス(ECMP)機能をサポートしています。これらのパスの一部または全部に対してトラフィックのロード バランスを行うよう、EIGRP を設定できます。


) Cisco NX-OS の EIGRP は、等コストでないロード バランシングはサポートしていません。


スプリット ホライズン

スプリット ホライズンを使用して、EIGRP が、ルートを伝えたインターフェイスからそのルートをアドバタイズしないようにすることができます。

スプリット ホライズンは、EIGRP 更新パケットおよび EIGRP 照会パケットの送信を制御する方式です。インターフェイスでスプリット ホライズンをイネーブルにすると、Cisco NX-OS は、このインターフェイスから学習された宛先への更新パケットも照会パケットも送信しません。この方法でアップデート パケットとクエリー パケットを制御すると、ルーティング ループの可能性が低くなります。

ポイズン リバースによるスプリット ホライズンにより、EIGRP は、EIGRP がルートを学習したインターフェイス経由で、そのルートを到達不能としてアドバタイズするよう設定されます。

EIGRP は、次のシナリオでスプリット ホライズン、またはポイズン リバースによるスプリット ホライズンを使用します。

スタートアップ モードで、2 台のルータ間で初めてトポロジ テーブルを交換する。

トポロジ テーブルの変更をアドバタイズする。

照会メッセージを送信する。

デフォルトでは、スプリット ホライズン機能がすべてのインターフェイスでイネーブルになっています。

BFD

この機能では、双方向フォワーディング検出(BFD)をサポートします。BFD は、転送パスの障害を高速で検出することを目的にした検出プロトコルです。BFD は 2 台の隣接デバイス間のサブセカンド障害を検出し、BFD の負荷の一部を、サポートされるモジュール上のデータ プレーンに分散できるため、プロトコル hello メッセージよりも CPU を使いません。詳細については、『 Cisco Nexus 7000 Series NX-OS Interfaces Configuration Guide, Release 6.x』 を参照してください。

仮想化のサポート

Cisco NX-OS は、同一システム上で動作する複数の EIGRP インスタンスをサポートしています。EIGRP は、仮想ルーティング/転送(VRF)インスタンスをサポートしています。VRF は仮想化デバイス コンテキスト(VDC)内にあります。デフォルトでは、特に別の VDC および VRF を設定しない限り、Cisco NX-OS によりデフォルト VDC およびデフォルト VRF が使用されます。『 Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide, Release 5.x』 および「レイヤ 3 仮想化の設定」を参照してください。

デフォルトでは、すべてのインスタンスが同じシステム ルータ ID を使用します。インスタンスごとに一意のルータ ID を設定することもできます。

グレースフル リスタートおよびハイ アベイラビリティ

Cisco NX-OS は、EIGRP の無停止フォワーディングおよびグレースフル リスタートをサポートします。

EIGRP の NSF を使用すると、フェールオーバー後に EIGRP ルーティング プロトコル情報が復元される間に、データ パケットを FIB 内の既存のルートで転送できます。ノンストップ フォワーディング(NSF)を使用すると、ピア ネットワーキング デバイスでルーティング フラップが発生することがありません。フェールオーバー時に、データ トラフィックはインテリジェント モジュール経由で転送され、スタンバイ スーパーバイザがアクティブになります。

Cisco NX-OS システムでコールド リブートが発生した場合、デバイスはシステムにトラフィックを転送せず、ネットワーク トポロジからシステムを削除します。このシナリオでは、EIGRP でステートレス再起動が発生し、すべてのネイバーが削除されます。 Cisco NX-OS はスタートアップ コンフィギュレーションを適用し、EIGRP がネイバーを再検出して、完全な EIGRP ルーティング情報を再度共有します。

Cisco NX-OS を実行するデュアル スーパーバイザ プラットフォームで、ステートフル スーパーバイザ スイッチオーバーが発生します。このスイッチオーバーが発生する前に、EIGRP はグレースフル リスタートを使用して、EIGRP がしばらく使用不可であることを宣言します。スイッチオーバーの間、EIGRP は無停止フォワーディングを使用して FIB の情報に基づいてトラフィックを転送し続け、システムがネットワーク トポロジから取り除かれることはありません。

グレースフル リスタート対応ルータは、Hello メッセージを使用して、そのネイバーにグレースフル リスタート動作が開始されたことを通知します。グレースフル リスタート認識ルータが、グレースフル リスタート対応ネイバーからグレースフル リスタート動作が進行中であるという通知を受信すると、両方のルータは各トポロジ テーブルをただちに交換します。グレースフル リスタート認識ルータは、ルータの再起動を支援するための次のアクションを実行します。

ルータは、hello メッセージに設定された時間間隔を短縮するために EIGRP hello ホールド タイマーの期限を終了します。このプロセスにより、グレースフル リスタート認識ルータは、再起動中のルータに、より短時間で応答し、再起動中のルータがネイバーを再検出してトポロジ テーブルを再構築するために必要な時間を削減することができます。

ルータは、ルート保留タイマーを開始します。このタイマーで、グレースフル リスタート認識ルータが、再起動中の隣接ルータのために既知のルートを保留する時間の長さが設定されます。デフォルトの期間は 240 秒です。

ルータは、ネイバーが再起動していることをピア リストに記載する、隣接関係を維持する、グレースフル リスタート認識ルータのトポロジ テーブルを送信する準備ができたことを知らせるシグナルをネイバーが送信するか、ルートホールド タイマーが期限切れになるまで再起動中のネイバーを保持する、ということを行います。グレースフル リスタート認識ルータ上でルート保留タイマーの期限が切れた場合、グレースフル リスタート認識ルータは保留ルートを破棄し、再起動中のルータをネットワークに参加する新しいルータとして扱い、隣接関係を再確立します。

スイッチオーバー後に、Cisco NX-OS は実行コンフィギュレーションを適用し、EIGRP は、自身が再び稼動していることをネイバーに通知します。


グレースフル リスタートでは、EIGRP の In-Service Software Upgrade(ISSU; インサービス ソフトウェア アップグレード)のサポートをイネーブルにする必要があります。グレースフル リスタートをディセーブルにすると、この設定では ISSU をサポートできないことを伝える警告が Cisco NX-OS から出されます。


EIGRP のライセンス要件

次の表に、この機能のライセンス要件を示します。

 

製品
ライセンス要件

Cisco NX-OS

EIGRP には Enterprise Services ライセンスが必要です。Cisco NX-OS ライセンス方式、およびライセンスの取得方法と適用方法の詳細については、『 Cisco NX-OS Licensing Guide』 を参照してください。

EIGRP の前提条件

EIGRP を使用するには、次の前提条件を満たしている必要があります。

EIGRP をイネーブルにする必要があります(「EIGRP 機能のイネーブル化」を参照)。

VDC を設定するには、Advanced Services ライセンスをインストールし、所定の VDC を開始してください(『 Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide, Release 5.x』 を参照)。

EIGRP の注意事項および制約事項

EIGRP 設定時の注意事項および制約事項は次のとおりです。

他のプロトコル、接続されたルータ、またはスタティック ルートからの再配布には、メトリック設定(デフォルト メトリック設定オプションまたはルート マップによる)が必要です(「Route Policy Manager の設定」を参照)。

グレースフル スタートについては、NSF 認識ルータが動作中であり、ネットワークで完全に収束している場合にのみ、このルータが NSF 対応ルータのグレースフル リスタート動作を支援できます。

グレースフル リスタートについては、グレースフル リスタートに関係する隣接デバイスが NSF 認識、または NSF 対応である必要があります。

Cisco NX-OS EIGRP は Cisco IOS ソフトウェアの EIGRP と互換性があります。

妥当な理由がない限り、メトリックの重みを変更しないでください。メトリックの重みを変更した場合は、同じ AS 内のすべての EIGRP ルータに、それを適用する必要があります。

インターフェイス速度が 1 ギガビット以上の EIGRP ネットワーク内に標準のメトリックとワイド メトリックを混在させると、最適ではないルーティングが行われる可能性があります。

大規模ネットワークの場合は、スタブの使用を検討してください。

EIGRP ベクトル メトリックは維持されないため、異なる EIGRP AS 間での再配布は避けてください。

no { ip | ipv6 } next-hop-self コマンドは、ネクスト ホップの到達可能性を保証しません。

{ ip | ipv6 } passive-interface eigrp コマンドを使用すると、ネイバーが形成されなくなります。

Cisco NX-OS は IGRP も、IGRP および EIGRP クラウドの接続もサポートしていません。

自動サマライズはデフォルトでディセーブルであり、イネーブルにすることはできません。

Cisco NX-OS は IP のみをサポートしています。


) Cisco IOS の CLI に慣れている場合、この機能に対応する Cisco NX-OS コマンドは通常使用する Cisco IOS コマンドと異なる場合があるので注意してください。


デフォルト設定

表 8-1 は、各 EIGRP パラメータに対するデフォルト設定を示します。

 

表 8-1 デフォルト EIGRP パラメータ

パラメータ
デフォルト

アドミニストレーティブ ディスタンス

内部ルート:90

外部ルート:170

帯域幅の割合

50%

再配布されたルートのデフォルトのメトリック

帯域幅:100000 Kb/s

遅延:100(10 マイクロ秒単位)

信頼性:255

ロード:1

MTU:1500

EIGRP 機能

ディセーブル

Hello 間隔

5 秒

ホールド タイム

15 秒

等コスト パス

8

メトリック重み

1 0 1 0 0 0

アドバタイズされたネクスト ホップ アドレス

ローカル インターフェイスの IP アドレス

NSF コンバージェンス時間

120

NSF ルート保留時間

240

NSF 信号送信時間

20

再配布

ディセーブル

スプリット ホライズン

イネーブル

基本的 EIGRP の設定

ここでは、次の内容について説明します。

「EIGRP 機能のイネーブル化」

「EIGRP インスタンスの作成」

「EIGRP インスタンスの再起動」

「EIGRP インスタンスのシャットダウン」

「インターフェイスでの EIGRP のシャットダウン」

EIGRP 機能のイネーブル化

EIGRP を設定するには、その前に EIGRP をイネーブルにする必要があります。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. feature eigrp

3. (任意)show feature

4. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

feature eigrp

 

例:

switch(config)# feature eigrp

EIGRP 機能をイネーブルにします。

ステップ 3

show feature

 

例:

switch(config)# show feature

(任意)イネーブルにされた機能の情報を表示します。

ステップ 4

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

EIGRP 機能をディセーブルにして、関連付けられている設定をすべて削除するには、コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

no feature eigrp

 

例:

switch(config)# no feature eigrp

EIGRP 機能をディセーブルにして、関連付けられたコンフィギュレーションをすべて削除します。

EIGRP インスタンスの作成

EIGRP インスタンスを作成して、そのインスタンスにインターフェイスを関連付けることができます。この EIGRP プロセスに一意の AS 番号を割り当てます(「自律システム」を参照)。ルート再配布をイネーブルにしていない限り、他の AS からルートがアドバタイズされることも、受信されることもありません。

はじめる前に

EIGRP をイネーブルにする必要があります(「EIGRP 機能のイネーブル化」を参照)。

EIGRP がルータ ID(設定済みのループバック アドレスなど)を入手可能であるか、またはルータ ID オプションを設定する必要があります。

AS 番号であると認められていないインスタンス タグを設定する場合は、AS 番号を明示的に設定する必要があります。そうしないと、この EIGRP インスタンスはシャットダウン状態のままになります。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. router eigrp instance-tag

3. (任意)autonomous-system as-number

4. (任意) log-adjacency-changes

5. (任意) log-neighbor-warnings [seconds]

6. interface interface-type slot/port

7. { ip | ipv6 } router eigrp instance-tag

8. (任意) show { ip | ipv6 } eigrp interfaces

9. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router eigrp instance-tag

 

例:

switch(config)# router eigrp Test1

switch(config-router)#

インスタンス タグを設定して、新しい EIGRP プロセスを作成します。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

AS 番号であると認められていない instance-tag を設定する場合は、 autonomous-system コマンドを使用して AS 番号を明示的に設定する必要があります。そうしないと、この EIGRP インスタンスはシャットダウン状態のままになります。

ステップ 3

autonomous-system as-number

 

例:

switch(config-router)# autonomous-system 33

(任意)この EIGRP インスタンスに一意の AS 番号を設定します。有効な範囲は 1 ~ 65535 です。

ステップ 4

log-adjacency-changes

 

例:

switch(config-router)# log-adjacency-changes

(任意) 隣接関係の状態が変化するたびに、システム メッセージを生成します。このコマンドは、デフォルトでイネーブルにされています。

ステップ 5

log-neighbor-warnings [ seconds]

 

例:

switch(config-router)# log-neighbor-warnings

(任意)ネイバー警告が発生するたびに、システム メッセージを生成します。警告メッセージの時間間隔を、1 ~ 65535 の秒数で設定できます。デフォルト値は 10 秒です。このコマンドは、デフォルトでイネーブルにされています。

ステップ 6

interface interface-type slot/port

 

例:

switch(config-router)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。 ? を使用すると、スロットおよびポートの範囲を確認できます。

ステップ 7

{ ip | ipv6 } router eigrp instance-tag

 

例:

switch(config-if)# ip router eigrp Test1

このインターフェイスを、設定された EIGRP プロセスに関連付けます。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

ステップ 8

show { ip | ipv6 } eigrp interfaces

 

例:

switch(config-if)# show ip eigrp interfaces

(任意) EIGRP インターフェイスに関する情報を表示します。

ステップ 9

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

EIGRP プロセスとそれに関連付けられている設定を削除するには、コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

no router eigrp instance-tag

 

例:

switch(config)# no router eigrp Test1

EIGRP プロセスと、関連付けられたすべての設定を削除します。


) EIGRP プロセスを削除する場合は、インターフェイス モードで設定された EIGRP コマンドも削除する必要があります。


次に、EIGRP プロセスを作成し、EIGRP のインターフェイスを設定する例を示します。

switch# configure terminal

switch(config)# router eigrp Test1

switch(config)# i nterface ethernet 1/2

switch(config-if)# ip router eigrp Test1

switch(config-if)# no shutdown

switch(config-if)# copy running-config startup-config

 

その他の EIGRP パラメータの詳細については、「高度な EIGRP の設定」を参照してください。

EIGRP インスタンスの再起動

EIGRP インスタンスは再起動できます。この処理では、インスタンスのすべてのネイバーが消去されます。

EIGRP インスタンスを再起動して、関連付けられたすべてのネイバーを削除するには、次のコマンドを使用します。

 

コマンド
目的

flush-routes

 

例:

switch(config)# flush-routes

(任意)この EIGRP インスタンスを再起動するときに、ユニキャスト RIB のすべての EIGRP ルートをフラッシュします。

restart eigrp instance-tag

 

例:

switch(config)# restart eigrp Test1

EIGRP インスタンスを再起動して、すべてのネイバーを削除します。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

EIGRP インスタンスのシャットダウン

EIGRP インスタンスを正常にシャットダウンできます。このアクションによって、すべてのルートと隣接関係が削除されますが、EIGRP 設定は保持されます。

EIGRP インスタンスをディセーブルにするには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

switch(config-router)# shutdown

 

例:

switch(config-router)# shutdown

この EIGRP インスタンスをディセーブルにします。EIGRP ルータ設定は残ります。

EIGRP の受動インターフェイスの設定

EIGRP の受動インターフェイスを設定できます。パッシブ インターフェイスは、EIGRP 隣接関係に参加しませんが、このインターフェイスのネットワーク アドレスは EIGRP トポロジ テーブルに残ります。

EIGRP の受動インターフェイスを設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

{ ip | ipv6 } passive-interface eigrp instance-tag

 

例:

switch(config-if)# ip passive-interface eigrp tag10

EIGRP hello を抑制します。これにより、EIGRP インターフェイス上でネイバーがルーティング アップデートを形成および送信することを防ぎます。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

インターフェイスでの EIGRP のシャットダウン

インターフェイスで EIGRP を正常にシャットダウンできます。これにより、すべての隣接関係が削除され、このインターフェイスで EIGRP トラフィックが停止しますが、EIGRP 設定は保持されます。

インターフェイスで EIGRP をディセーブルにするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

switch(config-if)# { ip | ipv6 } eigrp instance-tag shutdown

 

例:

switch(config-router)# ip eigrp Test1 shutdown

このインターフェイスで EIGRP をディセーブルにします。EIGRP インターフェイス設定は残ります。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

高度な EIGRP の設定

ここでは、次の内容について説明します。

「EIGRP での認証の設定」

「EIGRP スタブ ルーティングの設定」

「EIGRP のサマリー集約アドレスの設定」

「EIGRP へのルートの再配布」

「再配布されるルート数の制限」

「EIGRP でのロードバランスの設定」

「EIGRP のグレースフル リスタートの設定」

「hello パケットとホールド タイムの間隔調整」

「スプリット ホライズンのディセーブル化」

「EIGRP の調整」

EIGRP での認証の設定

EIGRP のネイバー間での認証を設定できます。「認証」を参照してください。

EIGRP プロセスまたは個々のインターフェイスに対応する EIGRP 認証を設定できます。インターフェイスの EIGRP 認証設定は、EIGRP プロセスレベルの認証設定より優先されます。

はじめる前に

EIGRP をイネーブルにする必要があります(「EIGRP 機能のイネーブル化」を参照)。

EIGRP プロセスのすべてのネイバーが、共有認証キーを含め、同じ認証設定を共有することを確認します。

この認証設定のためのキー チェーンを作成します。詳細については、『 Cisco Nexus 7000 Series NX-OS Security Configuration Guide, Release 5.x 』を参照してください。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. router eigrp instance-tag

3. address-family { ipv4 | ipv6 } unicast

4. authentication key-chain key-chain

5. authentication mode md5

6. interface interface-type slot/port

7. { ip | ipv6 } router eigrp instance-tag

8. { ip | ipv6 } authentication key-chain eigrp instance-tag key-chain

9. { ip | ipv6 } authentication mode eigrp instance-tag md5

10. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router eigrp instance-tag

 

例:

switch(config)# router eigrp Test1

switch(config-router)#

インスタンス タグを設定して、新しい EIGRP プロセスを作成します。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

AS 番号であると認められていない instance-tag を設定する場合は、 autonomous-system コマンドを使用して AS 番号を明示的に設定する必要があります。そうしないと、この EIGRP インスタンスはシャットダウン状態のままになります。

ステップ 3

address-family { ipv4 | ipv6 } unicast

 

例:

switch(config-router)# address-family ipv4 unicast

switch(config-router-af)#

アドレス ファミリ コンフィギュレーション モードを開始します。IPv4 の場合、このコマンドはオプションです。

ステップ 4

authentication key-chain key-chain

 

例:

switch(config-router-af)# authentication key-chain routeKeys

この VRF の EIGRP プロセスにキーチェーンを関連付けます。キー チェーン名は、大文字と小文字が区別される 20 文字以下の任意の英数字文字列にできます。

ステップ 5

authentication mode md5

 

例:

switch(config-router-af)# authentication mode md5

この VRF の MD5 メッセージ ダイジェスト認証モードを設定します。

ステップ 6

interface interface-type slot/port

 

例:

switch(config-router-af) interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。 ? を使用すると、サポートされているインターフェイスを調べることができます。

ステップ 7

{ ip | ipv6 } router eigrp instance-tag

 

例:

switch(config-if)# ip router eigrp Test1

このインターフェイスを、設定された EIGRP プロセスに関連付けます。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

ステップ 8

{ ip | ipv6 } authentication key-chain eigrp instance-tag key-chain

 

例:

switch(config-if)# ip authentication key-chain eigrp Test1 routeKeys

このインターフェイスの EIGRP プロセスにキーチェーンを関連付けます。この設定は、ルータの VRF モードで設定された認証設定よりも優先します。

インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

ステップ 9

{ ip | ipv6 } authentication mode eigrp instance-tag md5

 

例:

switch(config-if)# ip authentication mode eigrp Test1 md5

このインターフェイスの MD5 メッセージ ダイジェスト認証モードを設定します。この設定は、ルータの VRF モードで設定された認証設定よりも優先します。

インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

ステップ 10

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、EIGRP の MD5 メッセージ ダイジェスト認証をイーサネット インターフェイス 1/2 上で設定する例を示します。

switch# configure terminal

switch(config)# router eigrp Test1

switch(config-router)# exit

switch(config)# interface ethernet 1/2

switch(config-if)# ip router eigrp Test1

switch(config-if)# ip authentication key-chain eigrp Test1 routeKeys

switch(config-if)# ip authentication mode eigrp Test1 md5

switch(config-if)# copy running-config startup-config

 

EIGRP スタブ ルーティングの設定

ルータで EIGRP スタブ ルーティングを設定するには、アドレス ファミリ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

switch(config-router-af)# stub [ direct | receive-only | redistributed [ direct ] leak-map map-name ]

 

例:

switch(config-router-af)# eigrp stub redistributed

リモート ルータを EIGRP スタブ ルータとして設定します。マップ名には最大 20 文字の英数字を使用できます。大文字と小文字は区別されます。

次に、直接接続され、再配布されるルートをアドバタイズするスタブ ルータを設定する例を示します。

switch# configure terminal

switch(config)# router eigrp Test1

switch(config-router)# address-family ipv6 unicast

switch(config-router-af)# stub direct redistributed

switch(config-router-af)# copy running-config startup-config

 

ルータがスタブ ルータとして設定されていることを確認するには、show ip eigrp neighbor detail コマンドを使用します。出力の最後の行は、リモート ルータまたはスポーク ルータのスタブ ステータスを示します。

次に、 show ip eigrp neighbor detail コマンドの出力例を示します。

Router# show ip eigrp neighbor detail
IP-EIGRP neighbors for process 201
H Address Interface Hold Uptime SRTT RTO Q Seq Type
(sec) (ms) Cnt Num
0 10.1.1.2 Se3/1 11 00:00:59 1 4500 0 7
Version 12.1/1.2, Retrans: 2, Retries: 0
Stub Peer Advertising ( CONNECTED SUMMARY ) Routes
 

EIGRP のサマリー集約アドレスの設定

指定したインターフェイスにサマリー集約アドレスを設定できます。ルーティング テーブルに他にも個別のルートがある場合、EIGRP は、それらすべての個別ルートのメトリックのうち最小のメトリックを使用して、集約アドレスをインターフェイスからアドバタイズします。「ルート集約」を参照してください。

サマリー集約アドレスを設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

switch(config-if)# { ip | ipv6 } summary-address eigrp instance-tag ip-prefix/length [ distance | leak-map map-name ]

 

例:

switch(config-if)# ip summary-address eigrp Test1 192.0.2.0/8

サマリー集約アドレスを、IP アドレスとネットワーク マスク、または IP プレフィクス/長さとして設定します。インスタンス タグおよびマップ名には最大 20 文字の英数字を使用できます。大文字と小文字は区別されます。

また、この集約アドレスのアドミニストレーティブ ディスタンスを設定することもできます。集約アドレスのデフォルト アドミニストレーティブ ディスタンスは 5 です。

次に、EIGRP でイーサネット 1/2 のみからネットワーク 192.0.2.0 を要約するようにする例を示します。

switch(config)# interface ethernet 1/2
switch(config-if)# ip summary-address eigrp Test1 192.0.2.0 255.255.255.0
 

EIGRP へのルートの再配布

他のルーティング プロトコルから EIGRP にルートを再配布できます。

はじめる前に

EIGRP をイネーブルにする必要があります(「EIGRP 機能のイネーブル化」を参照)。

他のプロトコルから再配布されるルートには、メトリック(デフォルト メトリック設定オプションまたはルート マップによる)を設定する必要があります。

ルート マップを作成して、EIGRP に再配布されるルートのタイプを管理する必要があります。「Route Policy Manager の設定」を参照してください。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. router eigrp instance-tag

3. address-family { ipv4 | ipv6 } unicast

4. redistribute { bgp as | { eigrp | isis | ospf | ospfv3 | rip } instance-tag | direct | static } route-map name

5. default-metric bandwidth delay reliability loading mtu

6. (任意)show { ip | ipv6 } eigrp route-map statistics redistribute

7. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router eigrp instance-tag

 

例:

switch(config)# router eigrp Test1

switch(config-router)#

インスタンス タグを設定して、新しい EIGRP プロセスを作成します。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

AS 番号であると認められていない instance-tag を設定する場合は、 autonomous-system コマンドを使用して AS 番号を明示的に設定する必要があります。そうしないと、この EIGRP インスタンスはシャットダウン状態のままになります。

ステップ 3

address-family { ipv4 | ipv6 } unicast

 

例:

switch(config-router)# address-family ipv4 unicast

switch(config-router-af)#

アドレス ファミリ コンフィギュレーション モードを開始します。IPv4 の場合、このコマンドはオプションです。

ステップ 4

redistribute { bgp as | { eigrp | isis | ospf | ospfv3 | rip } instance-tag | direct | static } route-map name

 

例:

switch(config-router-af)# redistribute bgp 100 route-map BGPFilter

1 つのルーティング ドメインから EIGRP にルートを注入します。インスタンス タグおよびマップ名には最大 20 文字の英数字を使用できます。大文字と小文字は区別されます。

ステップ 5

default-metric bandwidth delay reliability loading mtu

 

例:

switch(config-router-af)# default-metric 500000 30 200 1 1500

ルート再配布で学習したルートに割り当てられるメトリックを設定します。デフォルト値は次のとおりです。

bandwidth:100000 kbps

delay:100(10 マイクロ秒単位)

reliability:255

loading:1

MTU:1492

ステップ 6

show { ip | ipv6 } eigrp route-map statistics redistribute

 

例:

switch(config-router-af)# show ip eigrp route-map statistics redistribute bgp

(任意) EIGRP ルート マップ統計に関する情報を表示します。

ステップ 7

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、BGP を IPv4 向けの EIGRP に再配布する例を示します。

switch# configure terminal

switch(config)# router eigrp Test1

switch(config-router)# redistribute bgp 100 route-map BGPFilter

switch(config-router)# default-metric 500000 30 200 1 1500

switch(config-router)# copy running-config startup-config

 

再配布されるルート数の制限

ルートの再配布では、多くのルートを EIGRP ルート テーブルに追加できます。外部プロトコルから受け取るルートの数に最大制限を設定できます。EIGRP では、再配布されるルートの上限を設定するために次のオプションが用意されています。

上限固定:EIGRP が設定された最大値に達すると、メッセージをログに記録します。EIGRP は、それ以上の再配布されたルートを受け入れません。必要に応じて、しきい値を超えたときに EIGRP が警告をログに記録する、最大値のしきい値パーセンテージを設定できます。

警告のみ:EIGRP が最大値に達したときのみ、警告のログを記録します。EIGRP は、再配布されたルートを受け入れ続けます。

取り消し:EIGRP が最大値に達すると、タイムアウト期間が開始されます。タイムアウト期間の経過後、再配布されたルートの現在数が最大数よりも少ない場合、EIGRP はすべての再配布されたルートを要求します。再配布されたルートの現在数が最大数に達した場合、EIGRP はすべての再配布されたルートを取り消します。EIGRP が再配布されたルートをさらに受け入れられるように、この条件をクリアする必要があります。任意で、タイムアウト期間を設定できます。

はじめる前に

EIGRP をイネーブルにする必要があります(「EIGRP 機能のイネーブル化」を参照)。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. router eigrp instance-tag

3. redistribute { bgp id | direct | eigrp id | isis id | ospf id | rip id | static } route-map map-name

4. redistribute maximum-prefix max [ threshold ] [ warning-only | withdraw [ num-retries timeout ]]

5. (任意)show running-config eigrp

6. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router eigrp instance-tag

 

例:

switch(config)# router eigrp Test1

switch(config-router)#

インスタンス タグを設定して、新しい EIGRP インスタンスを作成します。

ステップ 3

redistribute { bgp id | direct | eigrp id | isis id | ospf id | rip id | static } route-map map-name

 

例:

switch(config-router)# redistribute bgp route-map FilterExternalBGP

設定したルート マップ経由で、選択したプロトコルを EIGRP に再配布します。

ステップ 4

redistribute maximum-prefix max [ threshold ] [ warning-only | withdraw [ num-retries timeout ]]

 

例:

switch(config-router)# redistribute maximum-prefix 1000 75 warning-only

EIGRP が配布するプレフィクスの最大数を指定します。指定できる範囲は 0 ~ 65536 です。任意で次のオプションを指定します。

threshold :警告メッセージをトリガーする最大プレフィクスの割合。

warning-only :プレフィクスの最大数を超えたときに警告メッセージを記録します。

withdraw :再配布されたすべてのルートを取り消します。任意で再配布されたルートを取得しようと試みます。 num-retries の範囲は 1 ~ 12 です。 timeout は 60 ~ 600 秒です。デフォルト値は 300 秒です。 clear ip eigrp redistribution コマンドは、すべてのルートが取り消された場合に使用します。

ステップ 5

show running-config eigrp

 

例:

switch(config-router)# show running-config eigrp

(任意)EIGRP の設定を表示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config-router)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、EIGRP に再配布されるルートの数を制限する例を示します。

switch# configure terminal

switch(config)# router eigrp Test1

switch(config-router)# redistribute bgp route-map FilterExternalBGP

switch(config-router)# redistribute maximum-prefix 1000 75

 
 

EIGRP でのロードバランスの設定

EIGRP でのロードバランスを設定できます。最大パス オプションを使用して、ECMP ルートの数を設定できます。「EIGRP でのロードバランスの設定」を参照してください。

はじめる前に

EIGRP をイネーブルにする必要があります(「EIGRP 機能のイネーブル化」を参照)。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. router eigrp instance-tag

3. address-family { ipv4 | ipv6 } unicast

4. maximum-paths num-paths

5. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router eigrp instance-tag

 

例:

switch(config)# router eigrp Test1

switch(config-router)#

インスタンス タグを設定して、新しい EIGRP プロセスを作成します。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

AS 番号であると認められていない instance-tag を設定する場合は、 autonomous-system コマンドを使用して AS 番号を明示的に設定する必要があります。そうしないと、この EIGRP インスタンスはシャットダウン状態のままになります。

ステップ 3

address-family { ipv4 | ipv6 } unicast

 

例:

switch(config-router)# address-family ipv4 unicast

switch(config-router-af)#

アドレス ファミリ コンフィギュレーション モードを開始します。IPv4 の場合、このコマンドはオプションです。

ステップ 4

maximum-paths num-paths

 

例:

switch(config-router-af)# maximum-paths 5

EIGRP がルート テーブルに受け入れる等コスト パスの数を設定します。指定できる範囲は 1 ~ 16 です。デフォルトは 8 です。

ステップ 5

copy running-config startup-config

 

例:

switch(config-router-af)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、6 つまでの等コストパスによる、EIGRP の等コスト ロードバランスを IPv4 上で設定する例を示します。

switch# configure terminal

switch(config)# router eigrp Test1

switch(config-router)# maximum-paths 6

switch(config-router)# copy running-config startup-config

EIGRP のグレースフル リスタートの設定

EIGRP のグレースフル リスタートまたは NSF を設定できます。「グレースフル リスタートおよびハイ アベイラビリティ」を参照してください。


) デフォルトでは、グレースフル リスタートはイネーブルです。


はじめる前に

EIGRP をイネーブルにする必要があります(「EIGRP 機能のイネーブル化」を参照)。

NSF 認識ルータが動作中であり、ネットワークで完全に収束している場合にのみ、このルータが NSF 対応ルータのグレースフル リスタート動作を支援できます。

グレースフル リスタートに関与するネイバー デバイスが NSF 認識または NSF 対応である必要があります。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. router eigrp instance-tag

3. address-family { ipv4 | ipv6 } unicast

4. graceful-restart

5. timers nsf converge seconds

6. timers nsf route-hold seconds

7. timers nsf signal seconds

8. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router eigrp instance-tag

 

例:

switch(config)# router eigrp Test1

switch(config-router)#

インスタンス タグを設定して、新しい EIGRP プロセスを作成します。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

AS 番号であると認められていない instance-tag を設定する場合は、 autonomous-system コマンドを使用して AS 番号を明示的に設定する必要があります。そうしないと、この EIGRP インスタンスはシャットダウン状態のままになります。

ステップ 3

address-family { ipv4 | ipv6 } unicast

 

例:

switch(config-router)# address-family ipv4 unicast

switch(config-router-af)#

アドレス ファミリ コンフィギュレーション モードを開始します。IPv4 の場合、このコマンドはオプションです。

ステップ 4

graceful-restart

 

例:

switch(config-router-af)# graceful-restart

グレースフル リスタートをイネーブルにします。この機能は、デフォルトでイネーブルにされています。

ステップ 5

timers nsf converge seconds

 

例:

switch(config-router-af)# timers nsf converge 100

スイッチオーバー後にコンバージェンスするまでの制限時間を設定します。範囲は 60 ~ 180 秒です。デフォルトは 120 です。

ステップ 6

timers nsf route-hold seconds

 

例:

switch(config-router-af)# timers nsf route-hold 200

グレースフル リスタート認識ピアから学習したルートのホールド タイムを設定します。範囲は 20 ~ 300 秒です。デフォルトは 240 です。

ステップ 7

timers nsf signal seconds

 

例:

switch(config-router-af)# timers nsf signal 15

グレースフル リスタートの信号を送信する時間制限を設定します。範囲は 10 ~ 30 秒です。デフォルトは 20 です。

ステップ 8

copy running-config startup-config

 

例:

switch(config-router-af)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、デフォルト タイマー値を使用して IPv6 上で EIGRP のグレースフル リスタートを設定する例を示します。

switch# configure terminal

switch(config)# router eigrp Test1

switch(config-router)# address-family ipv6 unicast

switch(config-router-af)# graceful-restart

switch(config-router-af)# copy running-config startup-config

hello パケットとホールド タイムの間隔調整

各 Hello メッセージの間隔とホールド タイムを調整できます。

デフォルトでは、5 秒ごとに Hello メッセージが送信されます。ホールド タイムは Hello メッセージでアドバタイズされ、送信者が有効であると見なすまでの時間をネイバーに示します。デフォルトのホールド タイムは、hello 間隔の 3 倍または 15 秒です。

hello パケットの間隔を変更するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

switch(config-if)# { ip | ipv6 } hello-interval eigrp instance-tag seconds

 

例:

switch(config-if)# ip hello-interval eigrp Test1 30

EIGRP ルーティング処理の hello 間隔を設定します。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。指定できる範囲は 1 ~ 65535 秒です。デフォルトは 5 です。

非常に輻輳した大規模ネットワークでは、一部のルータが、デフォルト ホールド タイム内にネイバーから hello パケットを受信できない可能性があります。この場合は、ホールド タイムを増やすことを推奨します。

ホールド タイムを変更するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

switch(config-if)# { ip | ipv6 } hold-time eigrp instance-tag seconds

 

例:

switch(config-if)# ipv6 hold-time eigrp Test1 30

EIGRP ルーティング処理のホールド タイムを設定します。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。有効な範囲は 1 ~ 65535 です。

タイマー設定を確認するには、 show ip eigrp interface detail コマンドを使用します。

スプリット ホライズンのディセーブル化

スプリット ホライズンを使用して、ルート情報がルータにより、その情報の送信元インターフェイスの外部にアドバタイズされないようにすることができます。通常はスプリット ホライズンにより、特にリンクに障害がある場合に、複数のルーティング デバイス間での通信が最適化されます。

デフォルトでは、スプリット ホライズンはすべてのインターフェイスでイネーブルになっています。

スプリット ホライズンをディセーブルにするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

switch(config-if)# no { ip | ipv6 } split-horizon eigrp instance-tag

 

例:

switch(config-if)# no ip split-horizon eigrp Test1

スプリット ホライズンをディセーブルにします。

ワイド メトリックのイネーブル化

ワイド メトリックをイネーブルにするには、ルータまたはアドレス ファミリ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

switch(config-router)# metrics version 64bit

例:

switch(config-router)# metrics version 64bit

64 ビットのメトリック値をイネーブルにします。

必要に応じて RIB のスケール係数を設定するには、ルータまたはアドレス ファミリ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

switch(config-router)# metrics rib-scale value

例:

switch(config-router)# metrics rib-scale 128

(任意)RIB で 64 ビットのメトリック値を 32 ビットに変換するために使用されるスケール係数を設定します。指定できる範囲は 1 ~ 255 です。デフォルトは 128 です。

EIGRP の調整

省略可能なパラメータを設定して、EIGRP をネットワークに合わせて調整できます。

アドレス ファミリ コンフィギュレーション モードでは、次のオプション パラメータを設定できます。

 

コマンド
目的
default-information originate [ always | route-map map-name ]
 

例:

switch(config-router-af)# default-information originate always

プレフィクス 0.0.0.0/0 を持つデフォルト ルートを発信するか、受け入れます。ルート マップが提供されると、ルート マップが true 状態となっている場合にのみデフォルト ルートが発信されます。マップ名には最大 20 文字の英数字を使用できます。大文字と小文字は区別されます。

distance internal external

 

例:

switch(config-router-af)# distance 25 100

この EIGRP プロセスのアドミニストレーティブ ディスタンスを設定します。指定できる範囲は 1 ~ 255 です。内部の値で、同じ AS 内で学習したルートのディスタンスが設定されます(デフォルト値は 90 です)。外部の値で、外部 AS から学習したルートのディスタンスが設定されます(デフォルト値は 170 です)。

metric max-hops hop-count
 

例:

switch(config-router-af)# metric max-hops 70

アドバタイズされるルートに許容される最大ホップ数を設定します。ホップ カウントがこの最大値を超えるルートは、到達不能としてアドバタイズされます。指定できる範囲は 1 ~ 255 です。デフォルトは 100 です。

metric weights tos k1 k2 k3 k4 k5 k6
 

例:

switch(config-router-af)# metric weights 0 1 3 2 1 0

EIGRP メトリックまたは K 値を調整します。EIGRP は次の式を使用して、ネットワークへの合計メトリックを決定します。

メトリック = [k1 x 帯域幅 + (k2 x 帯域幅)/(256 - 負荷) + k3 x 遅延 + k6 x 拡張属性] * [k5/(信頼性 + k4)]

デフォルト値と指定できる範囲は、次のとおりです。

TOS:0。指定できる範囲は 0 ~ 8 です。

k1:1。有効な範囲は 0 ~ 255 です。

k2:0。有効な範囲は 0 ~ 255 です。

k3:1。有効な範囲は 0 ~ 255 です。

k4:0。有効な範囲は 0 ~ 255 です。

k5:0。有効な範囲は 0 ~ 255 です。

k6:0。有効な範囲は 0 ~ 255 です。

timers active-time { time-limit | disabled }

 

例:

switch(config-router-af)# timers active-time 200

(照会の送信後に)ルートがアクティブ(SIA)状態のままとなっていることを宣言するまでに、ルータが待機する時間を分単位で設定します。有効な範囲は 1 ~ 65535 です。デフォルトは 3 です。

インターフェイス コンフィギュレーション モードで、省略可能な次のパラメータを設定できます。

 

コマンド
目的

{ ip | ipv6 } bandwidth eigrp instance-tag bandwidth

 

例:

switch(config-if)# ip bandwidth eigrp Test1 30000

 

インターフェイス上の EIGRP の帯域幅メトリックを設定します。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。帯域幅の範囲は、1 ~ 2,560,000,000 kbps です。

{ ip | ipv6 } bandwidth-percent eigrp instance-tag percent

 

例:

switch(config-if)# ip bandwidth-percent eigrp Test1 30

 

EIGRP がインターフェイス上で使用する可能性のある帯域幅の割合を設定します。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

割合の範囲は 0 ~ 100 です。デフォルトは 50 です。

no { ip | ipv6 } delay eigrp instance-tag delay

 

例:

switch(config-if)# ip delay eigrp Test1 100

インターフェイス上の EIGRP の遅延メトリックを設定します。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。遅延の範囲は、1 ~ 16777215(10 マイクロ秒単位)です。

{ ip | ipv6 } distribute-list eigrp instance-tag

{ prefix-list name | route-map name} { in | out }

 

例:

switch(config-if)# ip distribute-list eigrp Test1 route-map EigrpTest in

このインターフェイス上の EIGRP のルータ フィルタリング ポリシーを設定します。インスタンス タグ、プレフィクス リスト名、およびルート マップ名には最大 20 文字の英数字を使用できます。大文字と小文字は区別されます。

no { ip | ipv6 } next-hop-self eigrp instance-tag

 

例:

switch(config-if)# ipv6 next-hop-self eigrp Test1

このインターフェイスのアドレスではなく、受信したネクスト ホップ アドレスを使用するよう、EIGRP を設定します。デフォルトでは、このインターフェイスの IP アドレスをネクスト ホップ アドレスに使用します。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

{ ip | ipv6 } offset-list eigrp instance-tag { prefix-list name | route-map name} { in | out } offset

 

例:

switch(config-if)# ip offset-list eigrp Test1 prefix-list EigrpList in

EIGRP が学習したルートに、着信および発信メトリックへのオフセットを追加します。インスタンス タグ、プレフィクス リスト名、およびルート マップ名には最大 20 文字の英数字を使用できます。大文字と小文字は区別されます。

{ ip | ipv6 } passive-interface eigrp instance-tag

 

例:

switch(config-if)# ip passive-interface eigrp Test1

EIGRP hello を抑制します。これにより、EIGRP インターフェイス上でネイバーがルーティング アップデートを形成および送信することを防ぎます。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

EIGRP の仮想化の設定

各 VDC で複数の EIGRP プロセスを設定できます。各 VDC 内に複数の VRF を作成して、各 VRF で同じまたは複数の EIGRP プロセスを使用することもできます。VRF にはインターフェイスを割り当てます。


) インターフェイスの VRF を設定したあとに、インターフェイスの他のすべてのパラメータを設定します。インターフェイスの VRF を設定すると、そのインターフェイスの他の設定がすべて削除されます。


はじめる前に

EIGRP をイネーブルにする必要があります(「EIGRP 機能のイネーブル化」を参照)。

VDC および VRF を作成します。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. vrf context vrf-name

3. router eigrp instance-tag

4. interface ethernet slot/port

5. vrf member vrf-name

6. { ip | ipv6 } router eigrp instance-tag

7. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

vrf context vrf-name

 

例:

switch(config)# vrf context RemoteOfficeVRF

switch(config-vrf)#

新しい VRF を作成し、VRF コンフィギュレーション モードを開始します。VRF 名には最大 20 文字の英数字を使用できます。大文字と小文字は区別されます。

ステップ 3

router eigrp instance-tag

 

例:

switch(config)# router eigrp Test1

switch(config-router)#

インスタンス タグを設定して、新しい EIGRP プロセスを作成します。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

AS 番号であると認められていない instance-tag を設定する場合は、 autonomous-system コマンドを使用して AS 番号を明示的に設定する必要があります。そうしないと、この EIGRP インスタンスはシャットダウン状態のままになります。

ステップ 4

interface ethernet slot/port

 

例:

switch(config)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。 ? を使用すると、スロットおよびポートの範囲を調査できます。

ステップ 5

vrf member vrf-name

 

例:

switch(config-if)# vrf member RemoteOfficeVRF

このインターフェイスを VRF に追加します。VRF 名には最大 20 文字の英数字を使用できます。大文字と小文字は区別されます。

ステップ 6

{ ip | ipv6 } router eigrp instance-tag

 

例:

switch(config-if)# ip router eigrp Test1

このインターフェイスを EIGRP プロセスに追加します。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

ステップ 7

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、VRF を作成して、その VRF にインターフェイスを追加する例を示します。

switch# configure terminal

switch(config)# vrf context NewVRF

switch(config-vrf)# router eigrp Test1

switch(config-router)# i nterface ethernet 1/2

switch(config-if)# ip router eigrp Test1

switch(config-if)# vrf member NewVRF

switch(config-if)# copy running-config startup-config

 

EIGRP 設定の確認

EIGRP 設定を表示するには、次のいずれかの作業を行います。

 

コマンド
目的

show { ip | ipv6 } eigrp [instance-tag]

設定した EIGRP プロセスの要約を表示します。

show { ip | ipv6 } eigrp [instance-tag] interfaces [type number] [ brief ] [ detail ]

設定されているすべての EIGRP インターフェイスに関する情報を表示します。

show { ip | ipv6 } eigrp instance-tag neighbors [type number] [detail]

すべての EIGRP ネイバーに関する情報を表示します。EIGRP ネイバー設定を確認するには、次のコマンドを使用します。

show { ip | ipv6 } eigrp [instance-tag] route [ip-prefix/length] [active] [all-links] [detail-links] [pending] [summary] [zero-successors] [vrf vrf-name]

すべての EIGRP ルートに関する情報を表示します。

show { ip | ipv6 } eigrp [instance-tag] topology [ip-prefix/length] [active] [all-links] [detail-links] [pending] [summary] [zero-successors] [vrf vrf-name]

EIGRP トポロジ テーブルに関する情報を表示します。

show running-configuration eigrp

現在実行中の EIGRP コンフィギュレーションを表示します。

EIGRP のモニタリング

EIGRP 統計情報を表示するには、次のコマンドを使用します。

 

コマンド
目的

show { ip | ipv6 } eigrp [instance-tag] accounting [vrf vrf-name]

EIGRP の課金統計情報を表示します。

show { ip | ipv6 } eigrp [instance-tag] route-map statistics redistribute

EIGRP の再配布統計情報を表示します。

show { ip | ipv6 } eigrp [instance-tag] traffic [vrf vrf-name]

EIGRP のトラフィック統計情報を表示します。

EIGRP の設定

次に、EIGRP を設定する例を示します。

feature eigrp
interface ethernet 1/2
ip address 192.0.2.55/24
ip router eigrp Test1
no shutdown
router eigrp Test1
router-id 192.0.2.1
 

関連資料

ルート マップの詳細については、「Route Policy Manager の設定」を参照してください。

その他の関連資料

EIGRP の実装に関する詳細情報については、次のページを参照してください。

「関連資料」

関連資料

関連項目
マニュアル名

EIGRP CLI コマンド

『Cisco Nexus 7000 Series NX-OS Unicast Routing Command Reference』

VDC および VRF

『Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide, Release 5.x』

http://www.cisco.com/warp/public/103/1.html

『Introduction to EIGRP Tech Note』

http://www.cisco.com/en/US/tech/tk365/technologies_q_and_a_item09186a008012dac4.shtml

EIGRP Frequently Asked Questions

管理情報ベース(MIB)

管理情報ベース(MIB)
MIB のリンク

CISCO-EIGRP-MIB

管理情報ベース(MIB)を検索およびダウンロードするには、次の URL にアクセスしてください。

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

EIGRP 機能の履歴

表 8-2 は、この機能のリリースの履歴です。

 

表 8-2 EIGRP 機能の履歴

機能名
リリース
機能情報

EIGRP

6.0(1)

Release 5.2 以降、変更はありません。

ワイド メトリック

5.2(1)

EIGRP ワイド メトリックのサポートが追加されました。

EIGRP

5.1(1)

Release 5.0 以降、変更はありません。

BFD

5.0(2)

BFD のサポートが追加されました。詳細については、『 Cisco Nexus 7000 Series NX-OS Interfaces Configuration Guide, Release 6.x』 を参照してください。

グレースフル シャットダウン

4.2(1)

EIGRP インスタンスまたはインターフェイス上の EIGRP を正常にシャットダウンしながらも、EIGRP 設定は保持するためのサポートが追加されました。

EIGRP インスタンス タグ

4.2(1)

長さが 20 文字に変更されました。

再配布されるルート数の制限

4.2(1)

再配布されるルート数の制限に関するサポートが追加されました。

EIGRP IPv6 のサポート

4.1(2)

IPv6 のサポートが追加されました。

認証

4.0(3)

EIGRP 向けに VRF 内で認証を設定する機能が追加されました。

EIGRP

4.0(1)

この機能が導入されました。