Cisco Nexus 7000 シリーズ NX-OS ユニキャスト ルーティング コンフィギュレーション ガイド リリース 6.x
ベーシック BGP の設定
ベーシック BGP の設定
発行日;2013/08/27 | 英語版ドキュメント(2013/08/22 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 7MB) | フィードバック

目次

ベーシック BGP の設定

ベーシック BGP の概要

BGP AS

4 バイトの AS 番号のサポート

アドミニストレーティブ ディスタンス

BGP ピア

BGP セッション

プレフィクス ピアのダイナミック AS 番号

BGP ルータ ID

BGP パスの選択

ステップ 1:パス ペアの比較

ステップ 2:比較順序の決定

ステップ 3:最適パス変更の抑制の決定

BGP およびユニキャスト RIB

BGP プレフィクス独立コンバージェンスのコア機能

BGP の仮想化

ベーシック BGP のライセンス要件

BGP の前提条件

BGP に関する注意事項および制限事項

デフォルト設定

CLI コンフィギュレーション モード

グローバル コンフィギュレーション モード

アドレス ファミリ コンフィギュレーション モード

ネイバー コンフィギュレーション モード

ネイバー アドレス ファミリ コンフィギュレーション モード

ベーシック BGP の設定

BGP のイネーブル化

BGP インスタンスの作成

BGP インスタンスの再起動

BGP のシャットダウン

BGP ピアの設定

プレフィクス ピアのダイナミック AS 番号の設定

BGP 情報のクリア

ベーシック BGP の設定確認

BGP 統計情報のモニタリング

ベーシック BGP の設定例

関連資料

次の作業

その他の関連資料

関連資料

RFC

管理情報ベース(MIB)

BGP 機能の履歴

ベーシック BGP の設定

この章では、Cisco NX-OS デバイスでボーダー ゲートウェイ プロトコル(BGP)を設定する方法について説明します。

この章では、次の内容について説明します。

「ベーシック BGP の概要」

「ベーシック BGP のライセンス要件」

「BGP の前提条件」

「BGP に関する注意事項および制限事項」

「デフォルト設定」

「CLI コンフィギュレーション モード」

「ベーシック BGP の設定」

「ベーシック BGP の設定確認」

「BGP 統計情報のモニタリング」

「ベーシック BGP の設定例」

「関連資料」

「次の作業」

「その他の関連資料」

「BGP 機能の履歴」

ベーシック BGP の概要

Cisco NX-OS は BGP バージョン 4 をサポートします。BGP v4 に組み込まれているマルチプロトコル拡張機能を使用すると、IP マルチキャスト ルートおよび複数のレイヤ 3 プロトコル アドレス ファミリに関するルーティング情報を BGP に伝送させることができます。BGP では、他の BGP 対応デバイスとの間で TCP セッションを確立するための、信頼できるトランスポート プロトコルとして TCP を使用します。

BGP ではパスベクトル ルーティング アルゴリズムを使用して、BGP 対応ネットワーク デバイスまたは BGP スピーカ 間でルーティング情報を交換します。各 BGP スピーカはこの情報を使用して、特定の宛先までのパスを判別し、なおかつルーティング ループを伴うパスを検出して回避します。ルーティング情報には、宛先の実際のルート プレフィクス、宛先に対する Autonomous System(AS; 自律システム)のパス、およびその他のパス属性が含まれます。

BGP はデフォルトで、宛先ホストまたはネットワークへの最適パスとして、1 つだけパスを選択します。各パスは、BGP ベストパス分析で使用される well-known mandatory、well-known discretionary、optional transitive の各属性を伝送します。BGP ポリシーを設定し、これらの属性の一部を変更することによって、BGP パス選択を制御できます。詳細については、「ルート ポリシーおよび BGP セッションのリセット」を参照してください。

BGP は、ロード バランシングまたは Equal-Cost Multipath(ECMP; 等コスト マルチパス)もサポートします。詳細については、「ロード シェアリングおよびマルチパス」を参照してください。

MPLS ネットワークでの BGP の設定については、『 Cisco Nexus 7000 Series NX-OS MPLS Configuration Guide』 を参照してください。

ここでは、次の内容について説明します。

「BGP AS」

「アドミニストレーティブ ディスタンス」

「BGP ピア」

「BGP ルータ ID」

「BGP パスの選択」

「BGP およびユニキャスト RIB」

「BGP プレフィクス独立コンバージェンスのコア機能」

「BGP の仮想化」

BGP AS

自律システム (AS)とは、単一の管理エンティティにより制御されるネットワークです。 AS は 1 つまたは複数の IGP および整合性のある一連のルーティング ポリシーを使用して、ルーティング ドメインを形成します。BGP は 16 ビットおよび 32 ビットの AS 番号をサポートします。詳細については、「自律システム」を参照してください。

個々の BGP AS は external BGP(eBGP; 外部 BGP)ピアリング セッションを通じて、ルーティング情報をダイナミックに交換します。同じ AS 内の BGP スピーカは、internal BGP(iBGP; 内部 BGP)を通じて、ルーティング情報を交換できます。

4 バイトの AS 番号のサポート

BGP では、2 バイトまたは 4 バイトの AS 番号をサポートしています。Cisco NX-OS は、プレーンテキスト表記で 4 バイト(つまり 32 ビットの整数)の AS 番号を表示します。4 バイトの AS 番号は、プレーンテキスト表記(たとえば 1 ~ 4294967295)または AS ドット表記(たとえば 1.0)で設定できます。詳細については、「自律システム」を参照してください。

アドミニストレーティブ ディスタンス

アドミニストレーティブ ディスタンス は、ルーティング情報の送信元の信頼性のランクです。BGP はデフォルトで、 表 10-1 のアドミニストレーティブ ディスタンスを使用します。

 

表 10-1 デフォルトの BGP アドミニストレーティブ ディスタンス

ディスタンス
デフォルト値
機能

外部

20

eBGP から学習したルートに適用

内部

200

iBGP から学習したルートに適用

ローカル

200

ルータを起点とするルートに適用


) アドミニストレーティブ ディスタンスが BGP パス選択アルゴリズムに影響を与えることはありませんが、BGP で学習されたルートが IP ルーティング テーブルに組み込まれるかどうかを左右します。


詳細については、「アドミニストレーティブ ディスタンス」を参照してください。

BGP ピア

BGP スピーカが別の BGP スピーカを自動的に検出することはありません。ユーザ側で BGP スピーカ間の関係を設定する必要があります。 BGP ピア は、もう 1 つの BGP スピーカとの間にアクティブな TCP 接続が存在する BGP スピーカです。

BGP セッション

BGP は TCP ポート 179 を使用して、ピアとの TCP セッションを作成します。ピア間で TCP 接続が確立されると、各 BGP ピアは最初に相手と、それぞれのすべてのルートを交換し、BGP ルーティング テーブルを完成させます。初期交換以後、BGP ピアはネットワーク トポロジが変化したとき、またはルーティング ポリシーが変更されたときに、差分アップデートだけを送信します。このようなアップデートからアップデートまでの非アクティブ期間中に、ピアは キープアライブ という特殊なメッセージを交換します。 ホールド タイム は、次の BGP アップデートまたはキープアライブ メッセージを受信するまでに経過することが許容される、最大時間限度です。

Cisco NX-OS では、次のピア設定オプションをサポートしています。

個別の IPv4 または IPv4 アドレス:BGP は、リモート アドレスと AS 番号が一致する BGP スピーカとのセッションを確立します。

単一 AS 番号の IPv4 または IPv6 プレフィクス ピア:BGP は、プレフィクスおよび AS 番号が一致する BGP スピーカとのセッションを確立します。

ダイナミック AS 番号プレフィクス ピア:BGP は、プレフィクスと、設定済み AS 番号のリストに載っている AS 番号と一致する BGP スピーカとのセッションを確立します。

プレフィクス ピアのダイナミック AS 番号

Cisco NX-OS では、BGP セッションを確立する AS 番号の範囲またはリストを受け入れます。たとえば IPv4 プレフィクス 192.0.2.0/8 および AS 番号 33、66、99 を使用するように BGP を設定する場合、BGP は 192.0.2.1 および AS 番号 66 を使用してセッションを確立しますが、192.0.2.2 および AS 番号 50 からのセッションは拒否します。

Cisco NX-OS では、セッションが確立されるまで internal BGP(iBGP; 内部 BGP)または external BGP(eBGP; 外部 BGP)セッションとして、プレフィクス ピアをダイナミック AS 番号と関連付けません。iBGP および eBGP の詳細については、「拡張 BGP の設定」を参照してください。


) ダイナミック AS 番号プレフィクス ピア設定は、BGP テンプレートから継承した個々の AS 番号の設定よりも優先します。詳細については、「拡張 BGP の設定」を参照してください。


BGP ルータ ID

ピア間で BGP セッションを確立するには、BGP に ルータ ID を設定する必要があります。ルータ ID は BGP セッションの確立時に、OPEN メッセージで BGP ピアに送信されます。BGP ルータ ID は 32 ビット値であり、IPv4 アドレスで表すことがよくあります。ルータ ID はユーザ側で設定できます。ルータ ID はデフォルトで、Cisco NX-OS によってルータのループバック インターフェイスの IPv4 アドレスに設定されます。ルータ上でループバック インターフェイスが設定されていない場合は、BGP ルータ ID を表すためにルータ上の物理インターフェイスに設定されている最上位の IPv4 アドレスがソフトウェアによって選択されます。BGP ルータ ID は、ネットワーク内の BGP ピアごとに一意である必要があります。

BGP にルータ ID が設定されていない場合、BGP ピアとのピアリング セッションを確立できません。

BGP パスの選択

BGP は複数の送信元から、同じルートのアドバタイズメントを受信する可能性がありますが、BGP は最適パスとして、パスを 1 つだけ選択します。BGP は、そのパスを IP ルーティング テーブルに格納し、ピアにパスを伝達します。

所定のネットワークでパスが追加または削除されるたびに、ベストパス アルゴリズムが実行されます。ベストパス アルゴリズムは、ユーザが BGP 設定を変更した場合にも実行されます。BGP は所定のネットワークで使用できる一連の有効パスの中から、最適パスを選択します。

Cisco NX-OS は次の手順で、BGP ベストパス アルゴリズムを実行します。


ステップ 1 2 つのパスを比較し、どちらが適切かを判別します(「ステップ 1:パス ペアの比較」を参照)。

ステップ 2 すべてのパスを確認し、全体として最適パスを選択するためにパスを比較する順序を決定します(「ステップ 2:比較順序の決定」を参照)。

ステップ 3 新しい最適パスを使用するに足るだけの差が新旧の最適パスにあるかどうかを判別します(「ステップ 3:最適パス変更の抑制の決定」を参照)。


 


) 重要なのは、パート 2 で決定される比較順序です。A、B、C という 3 つのパスがあるとします。A と B を比較して Cisco NX-OS は A を選択します。B と C を比較して Cisco NX-OS は B を選択します。しかし、A と C を比較した場合、Cisco NX-OS は A を選択しません。これは一部の BGP メトリックが同じネイバー AS からのパスだけに適用され、すべてのパスにわたっては適用されないからです。


パス選択には、BGP AS パス属性が使用されます。AS パス属性には、アドバタイズされたパスでたどる自律システム番号(AS 番号)のリストが含まれます。BGP AS を AS の集合または連合に細分化する場合は、AS パスにローカル定義の AS を指定した連合セグメントが含まれます。

ステップ 1:パス ペアの比較

BGP ベストパス アルゴリズムの最初のステップでは、より適切なパスを判別するために 2 つのパスを比較します。次に、Cisco NX-OS が 2 つのパスを比較して、より適切なパスを判別する基本的なステップについて説明します。

1. Cisco NX-OS は、比較する有効なパスを選択します (たとえば、到達不能なネクスト ホップがあるパスは無効です)。

2. Cisco NX-OS は、重み値が最大のパスを選択します。

3. Cisco NX-OS は、ローカル プリファレンスが最大のパスを選択します。

4. パスの一方がローカル起点の場合、Cisco NX-OS はそのパスを選択します。

5. Cisco NX-OS は、AS パスが短い方のパスを選択します。


) AS パス長を計算するときに、Cisco NX-OS は連合セグメントを無視し、AS セットを 1 として数えます。詳細については、「AS 連合」を参照してください。


6. Cisco NX-OS は、オリジンが低い方のパスを選択します。IGP は EGP よりも低いと見なされます。

7. Cisco NX-OS は、multiexit discriminator(MED)が小さい方のパスを選択します。

このステップが実行されるされないを左右する、一連のオプションを選択できます。Cisco NX-OS が両方のパスの MED を比較するのは、通常、同じ AS のピアからそれらのパスを受け取った場合です。それ以外の場合、Cisco NX-OS は MED の比較を省略します。

パスのピア AS に関係なく、ベストパス アルゴリズムの MED 比較が必ず実行されるように、Cisco NX-OS を設定することもできます。詳細については、「ベストパス アルゴリズムの調整」を参照してください。この設定を行わなかった場合、MED 比較が実行されるかどうかは、次のように比較する 2 つのパスの AS パス属性によって決まります。

a. パスに AS パスまたは AS_SET から始まる AS パスがない場合、パスは内部であり、Cisco NX-OS は他の内部パスに対して MED を比較します。

b. AS パスが AS_SEQUENCE から始まる場合、ピア AS がシーケンスで最初の AS 番号になり、Cisco NX-OS は同じピア AS を持つ他のパスに対して MED を比較します。

c. AS-path パスに連合セグメントだけが含まれている場合、または連合セグメントで始まり、AS_SET が続いている場合、パスは内部であり、Cisco NX-OS は他の内部パスに対して MED を比較します。

d. AS パスが連合セグメントで始まり、AS_SEQUENCE が続いている場合、ピア AS が AS_SEQUENCE で最初の AS 番号になり、Cisco NX-OS は同じピア AS を持つ他のパスに対して MED を比較します。


) Cisco NX-OS がパスの指定された MED 属性を受信しなかった場合、欠落 MED が使用可能な最大値になるように、ユーザがベストパス アルゴリズムを設定していない限り、Cisco NX-OS は MED を 0 と見なします。詳細については、「ベストパス アルゴリズムの調整」を参照してください。


e. 非決定性の MED 比較機能がイネーブルの場合、ベストパス アルゴリズムでは Cisco IOS スタイルの MED 比較が使用されます。詳細については、「ベストパス アルゴリズムの調整」を参照してください。

8. 一方のパスが内部ピアから、他方のパスが外部ピアからの場合、Cisco NX-OS は外部ピアからのパスを選択します。

9. ネクストホップ アドレスへの IGP メトリックが異なるバスの場合、Cisco NX-OS は IGP メトリックが小さい方のパスを選択します。

10. Cisco NX-OS は、最後に実行したベストパス アルゴリズムによって選択されたパスを使用します。

ステップ 1 ~ 9 のすべてのパス パラメータが同じ場合、ルータ ID を比較するようにベストパス アルゴリズムを設定できます。詳細については、「ベストパス アルゴリズムの調整」を参照してください。パスに発信元属性が含まれている場合、Cisco NX-OS はその属性をルータ ID として使用して比較します。発信元属性が含まれていない場合、Cisco NX-OS はパスを送信したピアのルータ ID を使用します。パス間でルータ ID が異なる場合、Cisco NX-OS はルータ ID が小さい方のパスを選択します。


) 属性の送信元をルータ ID として使用する場合は、2 つのパスに同じルータ ID を設定することができます。また、同じピア ルータとの 2 つの BGP セッションが可能です。したがって、同じルータ ID で 2 つのパスを受信できます。


11. Cisco NX-OS は、クラスタ長が短いほうのパスを選択します。クラスタ リスト属性の指定されたパスを受け取らなかった場合、クラスタ長は 0 です。

12. Cisco NX-OS は、IP アドレスが小さいほうのピアから受信したパスを選択します。ローカル発生のパス(再配布のパスなど)は、ピア IP アドレスが 0 になります。


) ステップ 9 以降が同じパスは、マルチパスを設定している場合、マルチパスに使用できます。詳細については、「ロード シェアリングおよびマルチパス」を参照してください。


ステップ 2:比較順序の決定

BGP ベストパス アルゴリズム実装の 2 番目のステップでは、Cisco NX-OS がパスを比較する順序を決定します。

1. Cisco NX-OS は、パスをグループに分けます。各グループ内で、Cisco NX-OS はすべてのパスにわたって MED を比較します。 Cisco NX-OS は、「ステップ 1:パス ペアの比較」と同じルールを使用して、2 つのパス間で MED を比較できるかどうかを決定します。この比較では通常、ネイバー AS ごとに 1 つずつグループが選択されます。 bgp bestpath med always コマンドを設定すると、Cisco NX-OS はすべてのパスが含まれた 1 グループだけを選択します。

2. Cisco NX-OS は、常に最適な方を維持しながら、グループのすべてのパスを反復することによって、各グループの最適パスを決定します。 Cisco NX-OS は、各パスをそれまでの一時的な最適パスと比較します。それまでの最適パスよりも適切な場合は、そのパスが新しく一時的な最適パスになり、Cisco NX-OS はグループの次のパスと比較します。

3. Cisco NX-OS は、ステップ 2 の各グループで選択された最適パスからなる、パス セットを形成します。 Cisco NX-OS は、このパス セットでもステップ 2 と同様にそれぞれの比較を繰り返すことによって、全体としての最適パスを選択します。

ステップ 3:最適パス変更の抑制の決定

実装の次のパートでは、Cisco NX-OS が新しい最適パスを使用するのか抑制するのかを決定します。新しい最適パスが古いパスとまったく同じ場合、ルータは引き続き既存の最適パスを使用できます(ルータ ID が同じ場合)。Cisco NX-OS では引き続き既存の最適パスを使用することによって、ネットワークにおけるルート変更を回避できます。

抑制機能をオフにするには、ルータ ID を比較するように最適パス アルゴリズムを設定します。詳細については、「ベストパス アルゴリズムの調整」を参照してください。この機能を設定すると、新しい最適パスが常にに既存の最適パスよりも優先されます。

次の条件が発生した場合に、最適パス変更を抑制できません。

既存の最適パスが無効になった。

既存または新しい最適パスを内部(または連合)ピアから受信したか、またはローカルに発生した(再配布などによって)。

同じピアからパスを受信した(パスのルータ ID が同じ)。

パス間で重み値、ローカル プリファレンス、オリジン、またはネクスト ホップ アドレスに対する IGP メトリックが異なっている。

パス間で MED が異なっている。

BGP およびユニキャスト RIB

BGP はユニキャスト RIB(ルーティング情報ベース)と通信して、ユニキャスト ルーティング テーブルに IPv4 ルートを格納します。最適パスの選択後、最適パスの変更をルーティング テーブルに反映させる必要があると BGP が判別した場合、BGP はユニキャスト RIB にルート アップデートを送信します。

BGP はユニキャスト RIB における BGP ルートの変更に関して、ルート通知を受け取ります。さらに、再配布をサポートする他のプロトコル ルートに関するルート通知を受け取ります。

BGP はネクスト ホップの変更に関する通知も、ユニキャスト RIB から受け取ります。BGP はこれらの通知を使用して、ネクスト ホップ アドレスへの到達可能性および IGP メトリックをトラッキングします。

ユニキャスト RIB でネクスト ホップ到達可能性または IGP メトリックが変更されるたびに、BGP は影響を受けるルートについて、最適パス再計算を開始させます。

BGP は IPv6 ユニキャスト RIB と通信し、IPv6 ルートについて、これらの動作を実行します。

BGP プレフィクス独立コンバージェンスのコア機能

Cisco NX-OS リリース 5.2 では、BGP プレフィクス独立コンバージェンス(PIC)のコア機能を導入しました。この機能を使用すると、ネットワークのコア部分で障害が発生した場合に、同じリモート ネクスト ホップを共有する BGP プレフィクス宛てのトラフィックの、高速コンバージェンスが可能になります。MPLS と純粋な IP トラフィックの両方で、この機能の利点を活用できます。デフォルトでイネーブルであり、ディセーブルにすることはできません。BGP PIC コアを MPLS ネットワークで使用する場合のその他の考慮事項については、『 Cisco Nexus 7000 Series NX-OS MPLS Configuration Guide』 を参照してください。

BGP の仮想化

BGP では、仮想ルーティング/転送(VRF)インスタンスをサポートしています。VRF は仮想化デバイス コンテキスト(VDC)内にあります。デフォルトでは、特に別の VDC および VRF を設定しない限り、Cisco NX-OS によりデフォルト VDC およびデフォルト VRF が使用されます。詳細については、 Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide, Release 5.x』 および「レイヤ 3 仮想化の設定」 を参照してください。

ベーシック BGP のライセンス要件

次の表に、この機能のライセンス要件を示します。

 

製品
ライセンス要件

Cisco NX-OS

BGP には Enterprise Services ライセンスが必要です。Cisco NX-OS ライセンス方式、およびライセンスの取得方法と適用方法の詳細については、『 Cisco NX-OS Licensing Guide 』を参照してください。

BGP の前提条件

BGP を使用するには、次の前提条件を満たしている必要があります。

BGP をイネーブルにします(「BGP のイネーブル化」を参照)。

システムに有効なルータ ID を設定しておく必要があります。

Regional Internet Registry(RIR)によって割り当てられたか、またはローカル管理の AS 番号を取得しておく必要があります。

再帰ネクスト ホップ解決に対応できる IGP を 1 つ以上設定する必要があります。

BGP セッションを確立するネイバー環境で、アドレス ファミリを設定する必要があります。

BGP に関する注意事項および制限事項

BGP 設定時の注意事項および制約事項は、次のとおりです。

ダイナミック AS 番号プレフィクス ピア設定は、BGP テンプレートから継承した個々の AS 番号の設定よりも優先します。

AS 連合でプレフィクス ピアにダイナミック AS 番号を設定した場合、BGP はローカル連合の AS 番号のみでセッションを確立します。

ダイナミック AS 番号プレフィクス ピアで作成された BGP セッションは、設定済みの eBGP マルチホップ Time-to-Live(TTL; 存続可能時間)値や直接接続ピアに対するディセーブル済みのチェックを無視します。

ルータ ID の自動変更およびセッション フラップを避けるために、BGP 用のルータ ID を設定します。

ピアごとに最大プレフィクス設定オプションを使用し、受信するルート数および使用するシステム リソース数を制限してください。

update-source を設定し、BGP/eBGP マルチホップ セッションでセッションを確立します。

再配布を設定する場合は、BGP ポリシーを指定します。

VRF 内で BGP ルータ ID を定義します。

キープアライブおよびホールド タイマーの値を小さくすると、BGP セッション フラップが発生する可能性があります。

すべての iBGP および eBGP セッションの BGP の最小ルート アドバタイズメント インターバル(MRAI)値はゼロであり、設定できません。

VDC を設定する場合は、Advanced Services ライセンスをインストールし、所定の VDC を開始してください(『 Cisco NX-OS Virtual Device Context Configuration Guide 』を参照)。

VRF を設定する場合は、Advanced Services ライセンスをインストールし、所定の VRF を開始してください(「レイヤ 3 仮想化の設定」を参照)。

デフォルト設定

表 10-2 に、BGP パラメータのデフォルト設定を示します。

 

表 10-2 デフォルトの BGP パラメータ

パラメータ
デフォルト

BGP 機能

ディセーブル

キープアライブ インターバル

60 秒

ホールド タイマー

180 秒

BGP PIC コア

イネーブル

CLI コンフィギュレーション モード

ここでは BGP に対応する各 CLI コンフィギュレーション モードの開始方法について説明します。各モードから、 ? コマンドを入力すると、そのモードで使用できるコマンドが表示されます。

グローバル コンフィギュレーション モード

グローバル コンフィギュレーション モードは、BGP プロセスを作成したり、AS 連合、ルート ダンプニングなどの拡張機能を設定したりする場合に使用します。詳細については、「拡張 BGP の設定」 を参照してください。

次に、ルータ コンフィギュレーション モードを開始する例を示します。

switch# configuration
switch(config)# router bgp 64496
switch(config-router)#
 

BGP では VRF がサポートされます。ネットワークで VRF を使用する場合は、適切な VRF 内で BGP を設定できます。詳細については、「仮想化の設定」を参照してください。

次に、VRF コンフィギュレーション モードを開始する例を示します。

switch(config)# router bgp 64497
switch(config-router)# vrf vrf_A
switch(config-router-vrf)#

アドレス ファミリ コンフィギュレーション モード

任意で、BGP がサポートするアドレス ファミリを設定できます。アドレス ファミリ用の機能を設定する場合は、ルータ コンフィギュレーション モードで address-family コマンドを使用します。ネイバーに対応する特定のアドレス ファミリを設定する場合は、ネイバー コンフィギュレーション モードで address-family コマンドを使用します。

ルート再配布、アドレス集約、ロード バランシングなどの拡張機能を使用する場合は、アドレス ファミリを設定する必要があります。

次に、ルータ コンフィギュレーション モードからアドレス ファミリ コンフィギュレーション モードを開始する例を示します。

switch(config)# router bgp 64496
switch(config-router)# address-family ipv6 unicast
switch(config-router-af)#
 

次に、VRF を使用している場合に、VRF アドレス ファミリ コンフィギュレーション モードを開始する例を示します。

switch(config)# router bgp 64497
switch(config-router)# vrf vrf_A
switch(config-router-vrf)# address-family ipv6 unicast
switch(config-router-vrf-af)#
 

ネイバー コンフィギュレーション モード

Cisco NX-OS には、BGP ピアを設定するためのネイバー コンフィギュレーション モードがあります。ネイバー コンフィギュレーション モードを使用して、ピアのあらゆるパラメータを設定できます。

次に、ネイバー コンフィギュレーション モードを開始する例を示します。

switch(config)# router bgp 64496
switch(config-router)# neighbor 192.0.2.1
switch(config-router-neighbor)#
 

次に、VRF ネイバー コンフィギュレーション モードを開始する例を示します。

switch(config)# router bgp 64497
switch(config-router)# vrf vrf_A
switch(config-router-vrf)# neighbor 192.0.2.1
switch(config-router-vrf-neighbor)#

ネイバー アドレス ファミリ コンフィギュレーション モード

アドレス ファミリ固有のネイバー設定を入力し、ネイバーのアドレス ファミリをイネーブルにするには、ネイバー コンフィギュレーション サブモード内のアドレス ファミリ コンフィギュレーション サブモードを使用できます。このモードは、所定のネイバーに認められるプレフィクス数の制限、eBGP のプライベート AS 番号の削除といった拡張機能に使用します。

次に、ネイバー アドレス ファミリ コンフィギュレーション モードを開始する例を示します。

switch(config)# router bgp 64496
switch(config-router# neighbor 192.0.2.1
switch(config-router-neighbor)# address-family ipv4 unicast
switch(config-router-neighbor-af)#
 

次に、VRF ネイバー アドレス ファミリ コンフィギュレーション モードを開始する例を示します。

switch(config)# router bgp 64497
switch(config-router)# vrf vrf_A
switch(config-router-vrf)# neighbor 209.165.201.1
switch(config-router-vrf-neighbor)# address-family ipv4 unicast
switch(config-router-vrf-neighbor-af)#

ベーシック BGP の設定

ベーシック BGP を設定するには、BGP をイネーブルにして、BGP ピアを設定する必要があります。ベーシック BGP ネットワークの設定は、いくつかの必須作業と多数の任意の作業からなります。BGP ルーティング プロセスおよび BGP ピアの設定は必須です。

ここでは、次の内容について説明します。

「BGP のイネーブル化」

「BGP インスタンスの作成」

「BGP インスタンスの再起動」

「BGP のシャットダウン」

「BGP ピアの設定」

「プレフィクス ピアのダイナミック AS 番号の設定」

「BGP 情報のクリア」


) Cisco IOS の CLI に慣れている場合、この機能に対応する Cisco NX-OS コマンドは通常使用する Cisco IOS コマンドと異なる場合があるので注意してください。


BGP のイネーブル化

BGP を設定する前に、BGP をイネーブルにする必要があります。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. feature bgp

3. (任意)show feature

4. (任意) copy running-config startup-config

手順の詳細

 

 
コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

feature bgp

 

例:

switch(config)# feature bgp

BGP をイネーブルにします。

ステップ 3

show feature

 

例:

switch(config)# show feature

(任意)イネーブルおよびディセーブルにされた機能を表示します。

ステップ 4

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

BGP をディセーブルにして、関連するすべての設定を削除する場合は、 no feature bgp コマンドを使用します。

 

コマンド
目的

no feature bgp

 

例:

switch(config)# no feature bgp

BGP をディセーブルにして、関連するすべての設定を削除します。

BGP インスタンスの作成

BGP インスタンスを作成し、BGP インスタンスにルータ ID を割り当てることができます。詳細については、「BGP ルータ ID」を参照してください。 Cisco NX-OS は、2 バイトまたは 4 バイトのプレーンテキスト表記または AS ドット表記による AS 番号をサポートします。詳細については、「4 バイトの AS 番号のサポート」を参照してください。

はじめる前に

BGP をイネーブルにします(「BGP のイネーブル化」を参照)。

BGP はルータ ID(設定済みループバック アドレスなど)を取得できなければなりません。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. router bgp autonomous-system-number

3. (任意) router-id ip-address

4. (任意) address-family { ipv4 | ipv6 | vpnv4 | vpnv6 } { unicast | multicast }

5. (任意) network ip-prefix [ route-map map-name ]

6. (任意)show bgp all

7. (任意)copy running-config startup-config

手順の詳細

 

 
コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router bgp autonomous-system-number

 

例:

switch(config)# router bgp 64496

switch(config-router)#

BGP をイネーブルにして、ローカル BGP スピーカに AS 番号を割り当てます。AS 番号は 16 ビット整数または 32 ビット整数にできます。上位 16 ビット 10 進数と下位 16 ビット 10 進数による xx.xx という形式です。

ステップ 3

router-id ip-address

 

例:

switch(config-router)# router-id 192.0.2.255

(任意)BGP ルータ ID を設定します。この IP アドレスによって、この BGP スピーカを特定します。このコマンドによって、BGP ネイバー セッションの自動通知およびセッション リセットが開始されます。

ステップ 4

address-family { ipv4 | ipv6 | vpnv4 | vpnv6 }{ unicast | multicast }

 

例:

switch(config-router)# address-family ipv4 unicast

switch(config-router-af)#

(任意)IP または VPN アドレス ファミリに対応するグローバル アドレス ファミリ コンフィギュレーション モードを開始します。このコマンドによって、すべての BGP ネイバー セッションの自動通知およびセッション リセットが開始されます。

ステップ 5

network ip-prefix [ route-map map-name ]

 

例:

switch(config-router-af)# network 192.0.2.0

(任意)この AS にローカルとしてネットワークを指定し、BGP ルーティング テーブルに追加します。

エクステリア プロトコルの場合、network コマンドでアドバタイズするネットワークを制御します。内部プロトコルは network コマンドを使用して、アップデートの送信先を判断します。

ステップ 6

show bgp all

 

例:

switch(config-router-af)# show bgp all

(任意)すべての BGP アドレス ファミリに関する情報を表示します。

ステップ 7

copy running-config startup-config

 

例:

switch(config-router-af)# copy running-config startup-config

(任意)この設定の変更を保存します。

BGP プロセスおよび関連するすべての設定を削除するには、 no router bgp コマンドを使用します。

 

コマンド
目的

no router bgp autonomous-system-number

 

例:

switch(config)# no router bgp 201

BGP プロセスおよび関連する設定を削除します。

次に、IPv4 ユニキャスト アドレス ファミリを指定して BGP をイネーブルに設定し、アドバタイズするネットワークを 1 つ追加する例を示します。

switch# configure terminal

switch(config)# router bgp 64496

switch(config-router)# address-family ipv4 unicast

switch(config-router-af)# network 192.0.2.0

switch(config-router-af)# copy running-config startup-config

 

BGP インスタンスの再起動

BGP インスタンスを再起動し、そのインスタンスのすべてのピア セッションをクリアできます。

BGP インスタンスを再起動し、関連付けられたすべてのピアを削除するには、次のコマンドを使用します。

 

コマンド
目的

restart bgp instance-tag

 

例:

switch(config)# restart bgp 201

BGP インスタンスを再起動し、すべてのピアリング セッションをリセットまたは再確立します。

BGP のシャットダウン

BGP をシャットダウンして BGP を正常にディセーブルし、設定を保持できます。

BGP をシャットダウンするには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

shutdown

 

例:

switch(config-router)# shutdown

BGP を正常にシャットダウンします。

BGP ピアの設定

BGP プロセス内で BGP ピアを設定できます。BGP ピアごとに、関連付けられたキープアライブ タイマーとホールド タイマーがあります。これらのタイマーは、グローバルに設定することも、BGP ピアごとに設定することもできます。ピア設定はグローバル設定を上書きします。


) ピアごとに、ネイバー コンフィギュレーション モードでアドレス ファミリを設定する必要があります。


はじめる前に

BGP をイネーブルにします(「BGP のイネーブル化」を参照)。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. router bgp autonomous-system-number

3. neighbor { ip-address | ipv6-address } remote-as as-number

4. (任意) description text

5. (任意) timers keepalive-time hold-time

6. (任意)shutdown

7. address-family { ipv4 | ipv6 | vpnv4 | vpnv6} { unicast | multicast }

8. (任意)show bgp { ipv4 | ipv6 | vpnv4 | vpnv6 } { unicast | multicast } neighbors

9. (任意)copy running-config startup-config

手順の詳細

 

 
コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router bgp autonomous-system-number

 

例:

switch(config)# router bgp 64496

switch(config-router)#

BGP をイネーブルにして、ローカル BGP スピーカに AS 番号を割り当てます。AS 番号は 16 ビット整数または 32 ビット整数にできます。上位 16 ビット 10 進数と下位 16 ビット 10 進数による xx.xx という形式です。

ステップ 3

neighbor { ip-address | ipv6-address } remote-as as-number

 

例:

switch(config-router)# neighbor 209.165.201.1 remote-as 64497

switch(config-router-neighbor)#

リモート BGP ピアの IPv4 アドレスまたは IPv6 アドレスおよび AS 番号を設定します。 ip-address の形式は x.x.x.x です。 ipv6-address の形式は A:B::C:D です。

ステップ 4

description text

 

例:

switch(config-router-neighbor)# description Peer Router B

switch(config-router-neighbor)#

(任意)ネイバーの説明を追加します。最大 80 文字の英数字ストリングを使用できます。

ステップ 5

timers keepalive-time hold-time

 

例:

switch(config-router-neighbor )# timers 30 90

(任意)ネイバーのキープアライブおよびホールド タイムを表す BGP タイマー値を追加します。指定できる範囲は 0 ~ 3600 秒です。デフォルトは、キープアライブ タイムで 60 秒、ホールド タイムで 180 秒です。

ステップ 6

shutdown

 

例:

switch(config-router-neighbor)# shutdown

(任意) この BGP ネイバーを管理目的でシャットダウンします。このコマンドによって、BGP ネイバー セッションの自動通知およびセッション リセットが開始されます。

ステップ 7

address-family { ipv4 | ipv6 | vpnv4 | vpnv6 }{ unicast | multicast }

 

例:

switch(config-router-neighbor)# address-family ipv4 unicast

switch(config-router-neighbor-af)#

ユニキャスト IPv4 アドレス ファミリに対応するネイバー アドレス ファミリ コンフィギュレーション モードを開始します。

ステップ 8

show bgp { ipv4 | ipv6 | vpnv4 | vpnv6 }{ unicast | multicast } neighbors

 

例:

switch(config-router-neighbor-af)# show bgp ipv4 unicast neighbors

(任意)GBP ピアの情報を表示します。

ステップ 9

copy running-config startup-config

 

例:

switch(config-router-neighbor-af) copy running-config startup-config

(任意)この設定の変更を保存します。

次に、BGP ピアの設定例を示します。

switch# configure terminal

switch(config)# router bgp 64496

switch(config-router)# neighbor 192.0.2.1 remote-as 64497

switch(config-router-neighbor)# description Peer Router B

switch(config-router-neighbor)# address-family ipv4 unicast

switch(config-router-neighbor-af)# copy running-config startup-config

 

プレフィクス ピアのダイナミック AS 番号の設定

BGP プロセス内で複数の BGP ピアを設定できます。BGP セッションの確立をルート マップの単一の AS 番号または複数の AS 番号に制限できます。

プレフィクス ピアのダイナミック AS 番号を使用して設定された BGP セッションでは、 ebgp-multihop コマンドおよび disable-connected-check コマンドを無視します。

ルート マップの AS 番号のリストを変更できますが、ルート マップ名を変更するには no neighbor コマンドを使用する必要があります。設定されたルート マップの AS 番号に変更を加えた場合、新しいセッションのみに影響します。

はじめる前に

BGP をイネーブルにします(「BGP のイネーブル化」を参照)。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. router bgp autonomous-system-number

3. neighbor prefix remote-as route-map map-name

4. (任意)show bgp { ipv4 | ipv6 | vpnv4 | vpnv6 } { unicast | multicast } neighbors

5. (任意)copy running-config startup-config

手順の詳細

 

 
コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router bgp autonomous-system-number

 

例:

switch(config)# router bgp 64496

switch(config-router)#

BGP をイネーブルにして、ローカル BGP スピーカに AS 番号を割り当てます。AS 番号は 16 ビット整数または 32 ビット整数にできます。上位 16 ビット 10 進数と下位 16 ビット 10 進数による xx.xx という形式です。

ステップ 3

neighbor prefix remote-as route-map map-name

 

例:

switch(config-router)# neighbor 192.0.2.0/8 remote-as routemap BGPPeers

switch(config-router-neighbor)#

IPv4 プレフィクスまたは IPv6 プレフィクス、およびリモート BGP ピアの受け付けられた AS 番号のリストのルート マップを設定します。IPv4 の場合の prefix の形式は「x.x.x.x/長さ」です。長さの範囲は 1 ~ 32 です。IPv6 の場合の prefix の形式は「A:B::C:D/長さ」です。length の範囲は 1 ~ 128 です。

map-name には最大 63 文字の英数字を使用できます。大文字と小文字は区別されます。

ステップ 4

show bgp { ipv4 | ipv6 | vpnv4 | vpnv6 }{ unicast | multicast } neighbors

 

例:

switch(config-router-neighbor-af)# show bgp ipv4 unicast neighbors

(任意)GBP ピアの情報を表示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config-router-neighbor-af)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、プレフィクス ピアのダイナミック AS 番号を設定する例を示します。

switch# configure terminal

switch(config)# route-map BGPPeers

switch(config-route-map)# match as-number 64496, 64501-64510

switch(config-route-map)# match as-number as-path-list List1, List2

switch(config-route-map)# exit

switch(config)# router bgp 64496

switch(config-router)# neighbor 192.0.2.0/8 remote-as route-map BGPPeers

switch(config-router-neighbor)# description Peer Router B

switch(config-router-neighbor)# address-family ipv4 unicast

switch(config-router-neighbor-af)# copy running-config startup-config

 

ルート マップについては、「Route Policy Manager の設定」を参照してください。

BGP 情報のクリア

BGP 情報をクリアするには、次のコマンドを使用します。

 

コマンド
目的

clear bgp all { neighbor | * | as-number | peer-template name | prefix } [ vrf vrf-name ]

すべてのアドレス ファミリから 1 つ以上のネイバーをクリアします。 * は、すべてのアドレス ファミリのすべてのネイバーをクリアします。引数は次のとおりです。

neighbor :ネイバーの IPv4 または IPv6 アドレス。

as-number :AS 番号。AS 番号は 16 ビット整数または 32 ビット整数にできます。上位 16 ビット 10 進数と下位 16 ビット 10 進数による xx.xx という形式です。

name :ピア テンプレート名。名称は 64 文字以内の英数字のストリング(大文字と小文字を区別)で指定します。

prefix :IPv4 または IPv6 プレフィクス。そのプレフィクス内のすべてのネイバーがクリアされます。

vrf-name :VRF 名。その VRF 内のすべてのネイバーがクリアされます。名称は 64 文字以内の英数字のストリング(大文字と小文字を区別)で指定します。

clear bgp all dampening [ vrf vrf-name ]

すべてのアドレス ファミリのルート フラップ ダンプニング ネットワークをクリアします。 vrf-name には最大 64 文字の英数字文字列を指定します。大文字と小文字は区別されます。

clear bgp all flap-statistics [ vrf vrf-name ]

すべてのアドレス ファミリのルート フラップ統計情報をクリアします。 vrf-name には最大 64 文字の英数字文字列を指定します。大文字と小文字は区別されます。

clear bgp { ipv4 | ipv6 | vpnv4 | vpnv6 } { unicast | multicast } dampening [ vrf vrf-name ]

選択したアドレス ファミリのルート フラップ ダンプニング ネットワークをクリアします。 vrf-name には最大 64 文字の英数字文字列を指定します。大文字と小文字は区別されます。

clear bgp { ipv4 | ipv6 | vpnv4 | vpnv6 } { unicast | multicast } flap-statistics [ vrf vrf-name ]

選択したアドレス ファミリのルート フラップ統計情報をクリアします。 vrf-name には最大 64 文字の英数字文字列を指定します。大文字と小文字は区別されます。

clear bgp { ipv4 | ipv6 | vpnv4 | vpnv6 } { unicast | multicast } { neighbor | * | as-number | peer-template name | prefix } [ vrf vrf-name ]

選択したアドレス ファミリから 1 つ以上のネイバーをクリアします。 * は、アドレス ファミリのすべてのネイバーをクリアします。引数は次のとおりです。

neighbor :ネイバーの IPv4 または IPv6 アドレス。

as-number :AS 番号。AS 番号は 16 ビット整数または 32 ビット整数にできます。上位 16 ビット 10 進数と下位 16 ビット 10 進数による xx.xx という形式です。

name :ピア テンプレート名。名称は 64 文字以内の英数字のストリング(大文字と小文字を区別)で指定します。

prefix :IPv4 または IPv6 プレフィクス。そのプレフィクス内のすべてのネイバーがクリアされます。

vrf-name :VRF 名。その VRF 内のすべてのネイバーがクリアされます。名称は 64 文字以内の英数字のストリング(大文字と小文字を区別)で指定します。

clear ip bgp { ip { unicast | multicast }} { neighbor | * | as-number | peer-template name | prefix } [ vrf vrf-name ]

1 つ以上のネイバーをクリアします。 * は、アドレス ファミリのすべてのネイバーをクリアします。引数は次のとおりです。

neighbor :ネイバーの IPv4 または IPv6 アドレス。

as-number :AS 番号。AS 番号は 16 ビット整数または 32 ビット整数にできます。上位 16 ビット 10 進数と下位 16 ビット 10 進数による xx.xx という形式です。

name :ピア テンプレート名。名称は 64 文字以内の英数字のストリング(大文字と小文字を区別)で指定します。

prefix :IPv4 または IPv6 プレフィクス。そのプレフィクス内のすべてのネイバーがクリアされます。

vrf-name :VRF 名。その VRF 内のすべてのネイバーがクリアされます。名称は 64 文字以内の英数字のストリング(大文字と小文字を区別)で指定します。

clear ip bgp dampening [ ip-neighbor | ip-prefix ] [ vrf vrf-name ]

1 つ以上のネットワークのルート フラップ ダンプニングをクリアします。引数は次のとおりです。

ip-neighbor :ネイバーの IPv4 アドレス。

ip-prefix :IPv4。そのプレフィクス内のすべてのネイバーがクリアされます。

vrf-name :VRF 名。その VRF 内のすべてのネイバーがクリアされます。名称は 64 文字以内の英数字のストリング(大文字と小文字を区別)で指定します。

clear ip bgp flap-statistics [ ip-neighbor | ip-prefix ] [ vrf vrf-name ]

1 つ以上のネットワークのルート フラップ統計情報をクリアします。引数は次のとおりです。

ip-neighbor :ネイバーの IPv4 アドレス。

ip-prefix :IPv4。そのプレフィクス内のすべてのネイバーがクリアされます。

vrf-name :VRF 名。その VRF 内のすべてのネイバーがクリアされます。名称は 64 文字以内の英数字のストリング(大文字と小文字を区別)で指定します。

clear ip mbgp { ip { unicast | multicast }} { neighbor | * | as-number | peer-template name | prefix } [ vrf vrf-name ]

1 つ以上のネイバーをクリアします。 * は、アドレス ファミリのすべてのネイバーをクリアします。引数は次のとおりです。

neighbor :ネイバーの IPv4 または IPv6 アドレス。

as-number :AS 番号。AS 番号は 16 ビット整数または 32 ビット整数にできます。上位 16 ビット 10 進数と下位 16 ビット 10 進数による xx.xx という形式です。

name :ピア テンプレート名。名称は 64 文字以内の英数字のストリング(大文字と小文字を区別)で指定します。

prefix :IPv4 または IPv6 プレフィクス。そのプレフィクス内のすべてのネイバーがクリアされます。

vrf-name :VRF 名。その VRF 内のすべてのネイバーがクリアされます。名称は 64 文字以内の英数字のストリング(大文字と小文字を区別)で指定します。

clear ip mbgp dampening [ ip-neighbor | ip-prefix ] [ vrf vrf-name ]

1 つ以上のネットワークのルート フラップ ダンプニングをクリアします。引数は次のとおりです。

ip-neighbor :ネイバーの IPv4 アドレス。

ip-prefix :IPv4。そのプレフィクス内のすべてのネイバーがクリアされます。

vrf-name :VRF 名。その VRF 内のすべてのネイバーがクリアされます。名称は 64 文字以内の英数字のストリング(大文字と小文字を区別)で指定します。

clear ip mbgp flap-statistics [ ip-neighbor | ip-prefix ] [ vrf vrf-name ]

1 つ以上のネットワークのルート フラップ統計情報をクリアします。引数は次のとおりです。

ip-neighbor :ネイバーの IPv4 アドレス。

ip-prefix :IPv4。そのプレフィクス内のすべてのネイバーがクリアされます。

vrf-name :VRF 名。その VRF 内のすべてのネイバーがクリアされます。名称は 64 文字以内の英数字のストリング(大文字と小文字を区別)で指定します。

ベーシック BGP の設定確認

BGP の設定を表示するには、次のいずれかの作業を行います。

 

コマンド
目的

show bgp all [summary] [vrf vrf-name]

すべてのアドレス ファミリについて、BGP 情報を表示します。

show bgp convergence [vrf vrf-name]

すべてのアドレス ファミリについて、BGP 情報を表示します。

show bgp { ipv4 | ipv6 | vpnv4 | vpnv6 } {unicast | multicast} [ip-address | ipv6-prefix] community {regexp expression | [community] [no-advertise] [no-export] [no-export-subconfed]} [vrf vrf-name]

BGP コミュニティと一致する BGP ルートを表示します。

show bgp [vrf vrf-name] { ipv4 | ipv6 | vpnv4 | vpnv6 } {unicast | multicast} [ip-address | ipv6-prefix] community-list list-name [vrf vrf-name]

BGP コミュニティ リストと一致する BGP ルートを表示します。

show bgp { ipv4 | ipv6 | vpnv4 | vpnv6 } {unicast | multicast} [ip-address | ipv6-prefix] extcommunity {regexp expression | generic [non-transitive | transitive] aa4:nn [exact-match]} [vrf vrf-name]

BGP 拡張コミュニティと一致する BGP ルートを表示します。

show bgp { ipv4 | ipv6 | vpnv4 | vpnv6 } {unicast | multicast} [ip-address | ipv6-prefix] extcommunity-list list-name [exact-match]} [vrf vrf-name]

BGP 拡張コミュニティ リストと一致する BGP ルートを表示します。

show bgp { ipv4 | ipv6 | vpnv4 | vpnv6 } {unicast | multicast} [ip-address | ipv6-prefix] {dampening dampened-paths [regexp expression]} [vrf vrf-name]

BGP ルート ダンプニングの情報を表示します。ルート フラップ ダンプニング情報を消去するには、 clear bgp dampening コマンドを使用します。

show bgp { ipv4 | ipv6 | vpnv4 | vpnv6 } {unicast | multicast} [ip-address | ipv6-prefix] history-paths [regexp expression] [vrf vrf-name]

BGP ルート ヒストリ パスを表示します。

show bgp { ipv4 | ipv6 | vpnv4 | vpnv6 } {unicast | multicast} [ip-address | ipv6-prefix] filter-list list-name [vrf vrf-name]

BGP フィルタ リストの情報を表示します。

show bgp { ipv4 | ipv6 | vpnv4 | vpnv6 } {unicast | multicast} [ip-address | ipv6-prefix] neighbors [ip-address | ipv6-prefix] [vrf vrf-name]

BGP ピアの情報を表示します。これらのネイバーを消去するには、 clear bgp neighbors コマンドを使用します。

 

show bgp { ipv4 | ipv6 | vpnv4 | vpnv6 } {unicast | multicast} [ip-address | ipv6-prefix] {nexthop | nexthop-database} [vrf vrf-name]

BGP ルート ネクスト ホップの情報を表示します。

show bgp paths

BGP パス情報を表示します。

show bgp { ipv4 | ipv6 | vpnv4 | vpnv6 } {unicast | multicast} [ip-address | ipv6-prefix] policy name [vrf vrf-name]

BGP ポリシー情報を表示します。ポリシー情報を消去するには、 clear bgp policy コマンドを使用します。

show bgp { ipv4 | ipv6 | vpnv4 | vpnv6 } {unicast | multicast} [ip-address | ipv6-prefix] prefix-list list-name [vrf vrf-name]

プレフィクス リストと一致する BGP ルートを表示します。

show bgp { ipv4 | ipv6 | vpnv4 | vpnv6 } {unicast | multicast} [ip-address | ipv6-prefix] received-paths [vrf vrf-name]

ソフト再構成用に保管されている BGP パスを表示します。

show bgp { ipv4 | ipv6 | vpnv4 | vpnv6 } {unicast | multicast} [ip-address | ipv6-prefix] regexp expression [vrf vrf-name]

AS_path 正規表現と一致する BGP ルートを表示します。

show bgp { ipv4 | ipv6 | vpnv4 | vpnv6 } {unicast | multicast} [ip-address | ipv6-prefix] route-map map-name [vrf vrf-name]

ルート マップと一致する BGP ルートを表示します。

show bgp peer-policy name [vrf vrf-name]

BGP ピア ポリシー情報を表示します。

show bgp peer-session name [vrf vrf-name]

BGP ピア セッション情報を表示します。

show bgp peer-template name [vrf vrf-name]

BGP ピア テンプレート情報を表示します。ピア テンプレートのすべてのネイバーを消去するには、 clear bgp peer-template コマンドを使用します。

show bgp process

BGP プロセス情報を表示します。

show {ip | ipv6} bgp options

BGP のステータスと構成情報を表示します。このコマンドには複数のオプションがあります。詳細については、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Command Reference』 を参照してください。

show {ip | ipv6} mbgp options

BGP のステータスと構成情報を表示します。このコマンドには複数のオプションがあります。詳細については、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Command Reference』 を参照してください。

show running-configuration bgp

現在実行中の BGP コンフィギュレーションを表示します。

BGP 統計情報のモニタリング

BGP の統計情報を表示するには、次のコマンドを使用します。

 

コマンド
目的

show bgp { ipv4 | ipv6 | vpnv4 | vpnv6 } {unicast | multicast} [ip-address | ipv6-prefix] flap-statistics [vrf vrf-name]

BGP ルート フラップの統計情報を表示します。これらの統計情報を消去するには、 clear bgp flap-statistics コマンドを使用します。

show bgp sessions [vrf vrf-name]

すべてのピアの BGP セッションを表示します。これらの統計情報を消去するには、 clear bgp sessions コマンドを使用します。

show bgp sessions [vrf vrf-name]

すべてのピアの BGP セッションを表示します。これらの統計情報を消去するには、 clear bgp sessions コマンドを使用します。

show bgp statistics

BGP 統計情報を表示します。

ベーシック BGP の設定例

次に、ベーシック BGP 設定の例を示します。

feature bgp
router bgp 64496
neighbor 2001:ODB8:0:1::55 remote-as 64496
address-family ipv6 unicast
next-hop-self

関連資料

BGP の関連項目は、次のとおりです。

「Route Policy Manager の設定」

次の作業

次の機能の詳細について、「拡張 BGP の設定」を参照してください。

ピア テンプレート

ルートの再配布

ルート マップ

その他の関連資料

BGP の実装に関連する詳細情報については、次の項を参照してください。

「関連資料」

「RFC」

「管理情報ベース(MIB)」

関連資料

関連項目
マニュアル名

BGP CLI コマンド

『Cisco Nexus 7000 Series NX-OS Unicast Routing Command Reference』

MPLS の設定

Cisco Nexus 7000 Series NX-OS MPLS Configuration Guide』

VDC および VRF

『Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide, Release 5.x』

RFC

RFC
タイトル

RFC 2918

『Route Refresh Capability for BGP-4』

管理情報ベース(MIB)

管理情報ベース(MIB)
MIB のリンク

BGP4-MIB

CISCO-BGP4-MIB

管理情報ベース(MIB)を検索およびダウンロードするには、次の URL にアクセスしてください。

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

BGP 機能の履歴

表 10-3 は、この機能のリリースの履歴です。

 

表 10-3 BGP 機能の履歴

機能名
リリース
機能情報

BGP

6.0(1)

Release 5.2 以降、変更はありません。

BGP

5.2(1)

BGP PIC のコア機能のサポートが追加されました。

VPN アドレス ファミリ

5.2(1)

VPN アドレス ファミリのサポートが追加されました。

BGP

5.1(1)

Release 5.0 以降、変更はありません。

BFD

5.0(2)

BFD のサポートが追加されました。詳細については、『 Cisco Nexus 7000 Series NX-OS Interfaces Configuration Guide, Release 6.x』 を参照してください。

ISSU

4.2(3)

BGP の最小ホールド タイム チェックが 8 秒に短縮されました。

IPv6

4.2(1)

IPv6 のサポートが追加されました。

4 バイトの AS 番号

4.2(1)

プレーンテキスト表記による 4 バイトの AS 番号のサポートが追加されました。

条件付きアドバタイズメント

4.2(1)

他のルートが BGP テーブルに存在するかどうかに基づいて BGP ルートを条件付きでアドバタイズするサポートが追加されました。

プレフィクス ピアのダイナミック AS 番号

4.1(2)

BGP プレフィクス ピア設定の AS 番号の範囲のサポートが追加されました。

BGP

4.0(1)

この機能が導入されました。