Cisco Nexus 7000 シリーズ NX-OS インターフェイ ス コンフィギュレーション ガイド リリース 5.x
vPC の設定
vPC の設定
発行日;2012/02/06 | 英語版ドキュメント(2012/01/24 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

vPC の設定

vPC について

vPC の概要

vPC の用語

vPC ピア リンク

vPC ピア リンクの概要

プライマリおよびセカンダリ デバイス上で手動で設定しなければならない機能

レイヤ 3 接続のための VLAN インターフェイスの設定

ピアキープアライブ リンクとメッセージ

vPC ピア ゲートウェイ

vPC ドメイン

vPC ピア リンクの互換パラメータ

同じでなければならない設定パラメータ

同じにすべき設定パラメータ

vPC 番号

他のポート チャネルの vPC への移行

単一モジュール上での vPC ピア リンクとコアへのリンクの設定

その他の機能との vPC の相互作用

vPC と LACP

vPC ピア リンクと STP

vPC ピア スイッチ

vPC マルチキャスト:PIM、IGMP、および IGMP スヌーピング

vPC ピア リンクとルーティング

CFSoE

バーチャライゼーションのサポート

リロードでの vPC の復元

vPC 復元ピア ロール

ハイ アベイラビリティ

vPC のライセンス要件

注意事項および制約事項

vPC の設定

vPC のイネーブル化

vPC のディセーブル化

vPC ドメインの作成と vpc-domain モードの開始

vPC キープアライブ リンクと vPC キープアライブ メッセージの設定

vPC ピア リンクの作成

vPC ピアゲートウェイの設定

vPC ピア リンクの設定の互換性チェック

他のポート チャネルの vPC への移行

vPC ドメイン MAC アドレスの手動での設定

システム プライオリティの手動での設定

vPC ピア デバイス ロールの手動での設定

シングルモジュール vPC でのトラッキング機能の設定

リロード復元の設定

vPC ピア スイッチの設定

純粋な vPC ピア スイッチ トポロジの設定

ハイブリッド vPC ピア スイッチ トポロジの設定

vPC 設定の確認

vPC 統計情報の監視

vPC の設定例

デフォルト設定

その他の関連資料

関連資料

標準規格

管理情報ベース(MIB)

vPC の設定機能の履歴

vPC の設定

この章では、Cisco Nexus 7000 シリーズのデバイス上で仮想ポート チャネル(vPCs)を設定する方法を説明します。

この章では、次の内容について説明します。

「vPC について」

「vPC のライセンス要件」

「注意事項および制約事項」

「vPC の設定」

「vPC 設定の確認」

「vPC 統計情報の監視」

「vPC の設定例」

「デフォルト設定」

「その他の関連資料」

「vPC の設定機能の履歴」


) ポート チャネルと Link Aggregation Control Protocol(LACP)の設定の詳細については、「ポート チャネルの設定」を参照してください。


vPC について

ここでは、次の内容について説明します。

「vPC の概要」

「vPC の用語」

「vPC ピア リンク」

「ピアキープアライブ リンクとメッセージ」

「vPC ピア ゲートウェイ」

「vPC ドメイン」

「vPC ピア リンクの互換パラメータ」

「vPC 番号」

「他のポート チャネルの vPC への移行」

「単一モジュール上での vPC ピア リンクとコアへのリンクの設定」

「その他の機能との vPC の相互作用」

「バーチャライゼーションのサポート」

「リロードでの vPC の復元」

「ハイ アベイラビリティ」

vPC の概要

仮想ポート チャネル(vPC)は、物理的には 2 台の異なる Cisco Nexus 7000 シリーズ デバイスに接続されているリンクを、第 3 のデバイスには単一のポートに見えるようにします(図 7-1 を参照してください)。第 3 のデバイスは、スイッチ、サーバ、ポート チャネルをサポートするその他の任意のネットワーキング デバイスのいずれでもかまいません。Cisco NX-OS Release 4.1(4) から、デバイスごとに最大 256 個の vPC を設定できます。vPC は、ノード間の複数の並列パスを可能にし、トラフィックのロード バランシングを可能にすることによって、冗長性を作り、バイセクショナルな帯域幅を増やすレイヤ 2 マルチパスを提供できます。

図 7-1 vPC のアーキテクチャ

 

vPC で使用できるのは、レイヤ 2 ポート チャネルだけです。vPC ドメインは単一の VDC に関連付けられるため、同じ 1 つの vPC ドメインに所属するすべての vPC インターフェイスが同一 VDC 内で定義されていなければなりません。配置した各 VDC に、独立した vPC ピアリンクとピアキープアライブ リンクのインフラストラクチャがなくてはなりません。vPC ピア(ドメインが同じ 2 台の vPC ピア デバイス)を同じ物理デバイスの 2 つの VDC 内に統合することは、サポートされていません。vPC ピア リンクは、リンクの両エンドに 10 ギガバイト イーサネット ポートを使用しなければならず、そうなっていないとリンクが形成されません。

ポート チャネルの設定は、次のいずれかを使用して行います。

プロトコルなし

Link Aggregation Control Protocol(LACP)

LACP を使用せずに vPC(vPC ピア リンク チャネルも含めて)のポート チャネルを設定する場合は、各デバイスが、単一のポート チャネル内に最大 8 つのアクティブ リンクを持てます。LACP を使用して vPC(vPC ピア リンク チャネルも含めて)のポート チャネルを設定する場合は、各デバイスが、単一のポート チャネル内に 8 つのアクティブ リンクと 8 つのスタンバイ リンクを持つことができます (LACP と vPCs の使用方法の詳細については、「その他の機能との vPC の相互作用」を参照してください)。


) vPC の機能を設定したり実行したりするには、まず vPC 機能をイネーブルにする必要があります。


リリース 4.2 から、システムはこの機能をディセーブルにする前のチェックポイントを自動的に取得するようになったため、このチェックポイントにロールバックすれば機能をイネーブルにできます。ロールバックとチェックポイントについては、『 Cisco Nexus 7000 Series NX-OS System Management Configuration Guide, Release 5.x を参照してください。

vPC 機能をイネーブルにしたら、ピアキープアライブ リンクを作成します。このリンクは、2 つの vPC ピア デバイス間でのハートビート メッセージの送信を行います。

1 つの Cisco Nexus 7000 シリーズ シャーシ上のポートを、2 つ以上の 10 ギガビット イーサネット ポートを専用モードで使用し、設定することにより、vPC ピア リンクを作成できます。正しいハードウェアをイネーブルにしており、Cisco NX-OS Release 4.1(5) で始まった vPC を実行していることを確認するには、 show hardware feature-capability コマンドを入力します。vPC の向かいに X が表示されている場合、そのハードウェアでは vPC 機能をイネーブルにできません。

vPC ピアリンク レイヤ 2 ポート チャネルは、トランクとして設定することをお勧めします。次に、もう 1 つの Cisco Nexus 7000 シリーズ シャーシで、やはり 2 つ以上の 10 ギガビット イーサネット ポートを専用モードで使用して、もう 1 つのポート チャネルを設定します。これらの 2 つのポート チャネルを接続すると、リンクされた 2 つの Nexus デバイスが第 3 のデバイスには 1 つのデバイスとして見える vPC ピア リンクが作成されます。第 3 のデバイス、またはダウンストリーム デバイスは、スイッチ、サーバ、vPC に接続された正規のポート チャネルを使用するその他の任意のネットワーク デバイスのいずれでもかまいません。正しいモジュールを使用していないと、システムからエラー メッセージが表示されます。


) 異なるモジュールの専用ポート上で vPC ピア リンクを設定して、障害発生の可能性を下げることをお勧めします。復元力を最適にしたい環境では、少なくとも 2 つのモジュールを使用してください。


Cisco リリース NX-OS 4.2 から、すべての vPC ピア リンクおよびコアに面したインターフェイスを 1 つのモジュール上で設定しなければならない場合、コアへのレイヤ 3 リンクに関連付けられているトラック オブジェクトおよび両方の vPC ピア デバイス上の vPC ピア リンク上のすべてのリンクを設定してください。いったんこの機能を設定したら、プライマリ vPC ピア デバイスに障害が発生した場合には、プライマリ vPC ピア デバイス上のすべての vPC リンクを、システムが自動的に停止します。システムが安定するまでは、このアクションにより、すべての vPC トラフィックが強制的にセカンダリ vPC ピア デバイスに送られます。

トラック オブジェクトを作成し、コアおよび vPC ピア リンクに接続されているプライマリ vPC ピア デバイス上のすべてのリンクにそのオブジェクトを適用します。 track interface コマンドの詳細については、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x を参照してください。

vPC ドメインには、両方の vPC ピア デバイス、vPC ピアキープアライブ リンク、vPC ピア リンク、および vPC ドメイン内にあってダウンストリーム デバイスに接続されているすべてのポート チャネルが含まれます。各デバイス上で持てる vPC ドメイン ID は 1 つだけです。

このバージョンでは、各ダウンストリーム デバイスを、単一のポート チャネルを使用して単一の vPC ドメイン ID に接続できます。


) 常にすべての vPC デバイスを両方の vPC ピア デバイスに、ポート チャネルを使用して接続してください。


vPC(図 7-2 を参照してください)は、次の利点を提供します。

単一のデバイスが 2 つのアップストリーム デバイスを介して 1 つのポート チャネルを使用することを可能にします。

スパニング ツリー プロトコル(STP)のブロック ポートをなくします。

ループフリーなトポロジを提供します。

利用可能なすべてのアップリンク帯域幅を使用します。

リンクまたはデバイスに障害が発生した場合に、ファースト コンバージェンスを提供します。

リンクレベルの復元力を提供します。

ハイ アベイラビリティを保証します。

図 7-2 1 つの VDC 内の vPC インターフェイス

 

VDC の詳細については Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide, Release 5.x を参照してください。

vPC の用語

vPCs で使用される用語は、次のとおりです。

vPC:vPC ピア デバイスとダウンストリーム デバイスの間の結合されたポート チャネル。

vPC ピア デバイス:vPC ピア リンクと呼ばれる特殊なポート チャネルで接続されている一対のデバイスの 1 つ。

vPC ピア リンク:vPC ピア デバイス間の状態を同期するために使用されるリンク。両エンドが 10 ギガバイト イーサネット インターフェイス上になくてはなりません。

vPC ドメイン:このドメインには、両方の vPC ピア デバイス、vPC ピアキープアライブ リンク、vPC 内にあってダウンストリーム デバイスに接続されているすべてのポート チャネルが含まれます。また、このドメインは、vPC グローバル パラメータを割り当てるために使用しなければならないコンフィギュレーション モードに関連付けられています。

vPC ピアキープアライブ リンク:ピアキープアライブ リンクは、さまざまな vPC ピア Cisco Nexus 7000 シリーズ デバイスを監視します。ピアキープアライブ リンクは、vPC ピア デバイス間での設定可能なキープアライブ メッセージの定期的な送信を行います。

ピアキープアライブ リンクを、各 vPC ピア デバイス内のレイヤ 3 インターフェイスにマッピングされている独立した VRF に関連付けることをお勧めします。独立した VRF を設定しなかった場合は、デフォルトで管理 VRF が使用されます。ただし、ピアキープアライブ リンクに管理インターフェイスを使用する場合は、各 vPC ピア デバイスのアクティブ管理ポートとスタンバイ管理ポートの両方に接続した管理スイッチを置かなければなりません(図 7-3 を参照してください)。

図 7-3 vPC ピアキープアライブ リンクの管理ポートを接続するための独立したスイッチが必要

 

vPC ピアキープアライブ リンク上を移動するデータまたは同期トラフィックはありません。このリンクを流れるトラフィックは、送信元スイッチが稼動しており、vPC を実行していることを知らせるメッセージだけです。

vPC メンバ ポート:vPCs に属するインターフェイス。

vPC ピア リンク

vPC ピア リンクは、vPC ピア デバイス間の状態を同期するために使用されるリンクです。リンクの両エンドが、10 ギガビット イーサネット インターフェイス上になくてはなりません。

ここでは、vPC ピア リンクについて説明します。内容は次のとおりです。

「vPC ピア リンクの概要」

「プライマリおよびセカンダリ デバイス上で手動で設定しなければならない機能」

「レイヤ 3 接続のための VLAN インターフェイスの設定」


) vPC ピアリンクを設定するよりも前にピアキープアライブ リンクを設定しなければなりません。そうしないと、ピアリンクは機能しません (vPC のピアキープアライブ リンクとメッセージの詳細については、「ピアキープアライブ リンクとメッセージ」を参照してください)。


vPC ピア リンクは、2 つのデバイスを vPC ピアとして設定するように設定できます。vPC ピア リンクを設定するためには、モジュールを使用しなければなりません。


) vPC ピア リンクを設定する場合は、専用ポート モードを使用することをお勧めします。専用ポート モードの詳細については、「基本インターフェイス パラメータの設定」を参照してください。


vPC ピア リンクの概要

vPC ピアとして持てるのは 2 台のデバイスだけです。各デバイスが、他方の 1 つの vPC ピアに対してだけ vPC ピアとして機能します。vPC ピア デバイスは、他のデバイスに対する非 vPC リンクも持つことができます。

無効な vPC ピア設定については、図 7-4 を参照してください。

図 7-4 許可されていない vPC ピア設定

 

有効な設定を作成するには、まず各デバイス上でポート チャネルを設定してから、vPC ドメインを設定します。ポート チャネルを各デバイスに、同じ vPC ドメイン ID を使用してピア リンクとして割り当てます。vPC ピア リンクのインターフェイスの片方に障害が発生した場合に、デバイスが自動的にピア リンク内の他方のインターフェイスを使用するようにフォールバックするため、冗長性のために少なくとも 2 つの専用ポートをポート チャネルに設定することをお勧めします。


) レイヤ 2 ポート チャネルをトランク モードで設定することをお勧めします。


多くの動作パラメータおよび設定パラメータが、vPC ピア リンクによって接続されている各デバイスで同じでなければなりません(「vPC ピア リンクの互換パラメータ」を参照してください)。各デバイスが管理プレーンから完全に独立しているため、デバイスが重要なパラメータについて互換性があることを管理者が確認しなければなりません。vPC ピア デバイスは、独立したコントロール プレーンを持っています。vPC ピア リンクを設定し終えたら、各 vPC ピア デバイスの設定を表示して、設定に互換性があることを確認してください。


) vPC ピア リンクによって接続されている 2 つのデバイスが、特定の同じ動作パラメータおよび設定パラメータを持っていることを確認しなければなりません。一貫性が必要な設定の詳細については、「vPC ピア リンクの互換パラメータ」を参照してください。


vPC ピア リンクを設定すると、接続されているデバイスの片方がプライマリ デバイスになり、接続されているデバイスの他方がセカンダリ デバイスになるように、vPC ピア デバイスがネゴシエートします(「vPC の設定」を参照してください)。Cisco NX-OS ソフトウェアは、最も小さい MAC アドレスを使用してプライマリ デバイスを選択します。特定のフェールオーバー条件の下でだけ、ソフトウェアが各デバイス(つまり、プライマリ デバイスおよびセカンダリ デバイス)に対して異なるアクションを取ります。プライマリ デバイスに障害が発生すると、システムの回復時にセカンダリ デバイスが新しいプライマリ デバイスになり、以前プライマリ デバイスだったデバイスがセカンダリ デバイスになります。

いずれの vPC デバイスがプライマリ デバイスになるかを設定することもできます。vPC ピア デバイスのプライオリティを変更すると、ネットワーク上のインターフェイスが停止してから再開します。ロール プライオリティを再度設定して片方の vPC がプライマリ デバイスになるようにしたい場合は、プライマリとセカンダリ両方の vPC デバイス上でロール プライオリティを適切な値に設定します。次に、両方のデバイス上で shutdown コマンドを入力して、vPC ピア リンクになっているポート チャネルをシャットダウンし、最後に、両方のデバイス上で no shutdown コマンドを入力して、ポート チャネルを再びイネーブルにします。


) 各 vPC ピア デバイスの vPC ピア リンクに対して、冗長性のために、2 つの異なるモジュールを使用することをお勧めします。


ソフトウェアは、vPC ピアを介して転送されたすべてのトラフィックをローカル トラフィックとしてキープします。ポート チャネルから入ってきたパケットは、vPC ピア リンクを介して移動するのではなく、ローカル リンクの 1 つを使用します。不明なユニキャスト、マルチキャスト、およびブロードキャスト トラフィック(STP BPDU を含む)は、vPC ピア リンクでフラッディングされます。ソフトウェアが、マルチキャスト フォワーディングを両方の vPC ピア デバイス上で同期された状態に保ちます。

両方の vPC ピア リンク デバイスおよびダウンストリーム デバイスで、任意の標準ロード バランシング スキームを設定できます(ロード バランシングの詳細については、「ポート チャネルの設定」を参照してください)。

設定情報は、Cisco Fabric Service over Ethernet(CFSoE)プロトコルを使用して vPC ピア リンクを流れます。(CFSoE の詳細については、「CFSoE」を参照してください)。

両方のデバイス上で設定されているこれらの VLAN の MAC アドレスはすべて、vPC ピア デバイス間で同期されています。この同期に、CFSoE が使用されます (CFSoE については、「CFSoE」を参照してください)。

Cisco NX-OS 4.2(1) から、vPC ピア デバイスを、vPC ピア デバイスの MAC アドレスを送信先とするパケットに対してもゲートウェイとして機能するように設定できるようになりました。

この機能を設定するには、 peer-gateway コマンドを使用します。

vPC ピア リンクに障害が発生した場合は、ソフトウェアが、両方のデバイスが稼動していることを確認するための vPC ピア デバイス間のリンクであるピアキープアライブ リンクを使用して、リモート vPC ピア デバイスのステータスをチェックします。vPC ピア デバイスが稼動している場合は、セカンダリ vPC デバイスは、ループやトラフィックの消失あるいはフラッディングを防ぐために、そのデバイス上のすべての vPC ポートをディセーブルにします。したがって、データは、ポート チャネルの残っているアクティブなリンクに転送されます。


) 独立した VRF を作成して設定し、その vPC ピアキープアライブ リンクのための VRF 内の各 vPC ピア デバイス上でレイヤ 3 ポートを設定することをお勧めします。ピアキープアライブのデフォルト ポートとデフォルト VRF は、管理ポートと管理 VRF です。


ソフトウェアは、ピアキープアライブ リンクを介したキープアライブ メッセージが返されない場合に、vPC ピア デバイスに障害が発生したことを学習します。

vPC ピア デバイス間の設定可能なキープアライブ メッセージの送信には、独立したリンク(vPC ピアキープアライブ リンク)を使用します。vPC ピアキープアライブ リンク上のキープアライブ メッセージから、障害が vPC ピア リンク上でだけ発生したのか、vPC ピア デバイス上で発生したのかがわかります。キープアライブ メッセージは、ピア リンク内のすべてのリンクで障害が発生した場合にだけ使用されます。キープアライブ メッセージの詳細については、「ピアキープアライブ リンクとメッセージ」を参照してください。

プライマリおよびセカンダリ デバイス上で手動で設定しなければならない機能

各 vPC ピア デバイスのプライマリ/セカンダリ マッピングに従うために、次の機能を手動で設定しなければなりません。

STP ルート:プライマリ vPC ピア デバイスを STP プライマリ ルート デバイスとして設定し、vPC セカンダリ デバイスを STP セカンダリ ルート デバイスとして設定します。vPC および STP の詳細については、「vPC ピア リンクと STP」を参照してください。

Bridge Assurance がすべての vPC ピア リンク上でイネーブルになるように、vPC ピア リンク インターフェイスを STP ネットワーク ポートとして設定することをお勧めします。

プライマリ デバイスがすべての VLAN のルートになるように Rapid PVST+ を設定し、プライマリ デバイスがすべてのインターフェイスのルートになるように MST を設定することをお勧めします。

レイヤ 3 VLAN ネットワーク インターフェイス:両方のデバイスから同じ VLAN の VLAN ネットワーク インターフェイスを設定することにより、各 vPC ピア デバイスからのレイヤ 3 接続を設定します。

HSRP アクティブ:vPC ピア デバイス上で HSRP と VLAN インターフェイスを使用する場合は、プライマリ vPC ピア デバイスを HSRP アクティブの最も高いプライオリティで設定します。セカンダリ デバイスは HSRP スタンバイになるように設定します。また、同じ管理/動作モードにある各 vPC デバイス上に VLAN インターフェイスがあることを確認します (vPC および HSRP の詳細については、「vPC ピア リンクとルーティング」を参照してください)。

vPC ピア リンクの両側で Unidirectional Link Detection(UDLD; 単一方向リンク検出)を設定することをお勧めします。UDLD を設定する手順については「UDLD モードの設定」を参照してください。

レイヤ 3 接続のための VLAN インターフェイスの設定

HSRP や PIM などのアプリケーションを使用するネットワークのレイヤ 3 にリンクするために、vPC ピア デバイス上の VLAN ネットワーク インターフェイスを使用できます。ただし、この目的には VLAN ネットワーク インターフェイスを使用するよりも、vPC ピア デバイスからのルーティングのためのレイヤ 3 リンクを別途設定することをお勧めします。


) 各ピア デバイス上で VLAN ネットワーク インターフェイスが設定されており、そのインターフェイスが各デバイス上で同じ VLAN に接続されていることを確認してください。また、各 VLAN インターフェイスが、同じ管理/動作モードになっていなければなりません。VLAN ネットワーク インターフェイスの設定方法の詳細については、「レイヤ 3 インターフェイスの設定」を参照してください。


vPC ピア リンクでフェールオーバーが発生すると、vPC ピア デバイス上の VLAN インターフェイスも影響を受けます。vPC ピア リンクに障害が発生すると、セカンダリ vPC ピア デバイス上の関連付けられている VLAN インターフェイスがシステムによって停止されます。

Cisco NX-OS 4.2(1) から、指定した VLAN インターフェイスが vPC ピア リンクに障害が発生しても vPC セカンダリ デバイス上で停止しないようにすることができるようになりました。

この機能を設定するには、 dual-active exclude interface-vlan コマンドを使用します。


) vPC ドメインにレイヤ 3 デバイスを接続した場合、vPC ピアリンク上でも送信される VLAN を使用したルーティング プロトコルのピアリンクはサポートされません。vPC ピア デバイスおよび汎用レイヤ 3 デバイスの間でルーティング プロトコルの隣接関係が必要な場合は、相互接続に物理的にルーティングされたインターフェイスを使用しなければなりません。vPC ピアゲートウェイ機能の使用では、この要件は変わりません。


ピアキープアライブ リンクとメッセージ

Cisco NX-OS ソフトウェアは、vPC ピア間のピアキープアライブ リンクを使用して、設定可能なキープアライブ メッセージを定期的に送信します。これらのメッセージを送信するには、ピア デバイス間にレイヤ 3 接続がなくてはなりません。ピアキープアライブ リンクが有効になって稼動していないと、システムは vPC ピア リンクを稼動させることができません。


) vPC ピアキープアライブ リンクを、各 vPC ピア デバイス内のレイヤ 3 インターフェイスにマッピングされている独立した VRF に関連付けることをお勧めします。独立した VRF を設定しなかった場合は、デフォルトで管理 VRF と管理ポートが使用されます。vPC ピアキープアライブ メッセージの送受信にピア リンク自体を使用することはしないでください。VRF の設定方法の詳細については、『Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.xを参照してください。


片方の vPC ピア デバイスに障害が発生したら、vPC ピア リンクの他方の側にある vPC ピア デバイスは、ピアキープアライブ メッセージを受信しなくなることによってその障害を感知します。vPC ピアキープアライブ メッセージのデフォルトの間隔は、1 秒です。この間隔は、400 ミリ秒~ 10 秒の範囲内で設定可能です。

ホールドタイムアウト値は、3 ~ 10 秒の範囲内で設定可能で、デフォルトのホールドタイムアウト値は 3 秒です。このタイマーは、vPC ピア リンクが停止した時点で開始します。セカンダリ vPC ピア デバイスは、ネットワークの収束が確実に発生してから vPC アクションが発生するようにするために、このホールドタイムアウト期間の間は vPC ピアキープアライブ メッセージを無視します。ホールドタイムアウト期間の目的は、誤ったポジティブ ケースを防ぐことです。

タイムアウト値は、3 ~ 20 秒の範囲内で設定可能で、デフォルトのタイムアウト値は 5 秒です。このタイマーは、ホールドタイムアウト間隔が終了した時点で開始します。このタイムアウト期間の間は、セカンダリ vPC ピア デバイスは、プライマリ vPC ピア デバイスから vPC ピアキープアライブ hello メッセージが送信されてこないかチェックします。セカンダリ vPC ピア デバイスが 1 つの hello メッセージを受信したら、そのデバイスは、セカンダリ vPC ピア デバイス上のすべての vPC インターフェイスをディセーブルにします。

ホールドタイムアウト パラメータとタイムアウト パラメータの相違点は、次のとおりです。

ホールドタイムアウトの間は、vPC セカンダリ デバイスは、受信したキープアライブ メッセージに基づくアクションは一切行いません。これは、スーパーバイザがピア リンクの停止後数秒間の間に失敗したなどが原因で、システムが一時的なキープアライブを受信した場合に、システムがアクションを取ることを防ぐためです。

タイムアウト中は、vPC セカンダリ デバイスは、設定された間隔が終了するまでにキープアライブ メッセージを受信できないと、vPC プライマリ デバイスになるというアクションを取ります。

キープアライブ メッセージの時間の設定方法については、「vPC の設定」を参照してください。


) ピアキープアライブ メッセージに使用される送信元 IP アドレスと宛先 IP アドレスの両方が、ネットワーク上で一意であり、それらの IP アドレスがその vPC ピアキープアライブ リンクに関連付けられている VRF から到達できることを確認してください。


Command-Line Interface(CLI; コマンドライン インターフェイス)を使用して、vPC ピアキープアライブ メッセージを使用するインターフェイスを信頼できるポートとして設定してください。優先順位をデフォルト(6)のままにしておくか、またはもっと高い値に設定します。次に、インターフェイスを信頼できるポートとして設定する例を示します。

(config)# class-map type qos match-all trust-map
(config-cmap-qos)# match cos 4-7
 
(config)# policy-map type qos ingresspolicy
(config-pmap-qos)# class trust-map
 
(config)# interface Ethernet8/11
(config-if)# service-policy type qos input ingresspolicy
 

信頼できるポートと優先順位の設定方法の詳細については、『 Cisco Nexus 7000 Series NX-OS Quality of Service Configuration Guide, Release 5.x 』を参照してください。

vPC ピア ゲートウェイ

Cisco NX-OS 4.2(1) から、vPC ピア デバイスを、vPC ピア デバイスの MAC アドレスを送信先とするパケットに対してもゲートウェイとして機能するように設定できるようになりました。この機能を設定するには、 peer-gateway コマンドを使用します。

一部の Network-Attached Atorage(NAS)デバイスまたはロードバランサは、特定のアプリケーションのパフォーマンスを最適化することを目的とした機能を備えている場合があります。基本的に、こういった機能では、同じサブネットにローカルには接続されていないホストから発生した要求に応答する場合に、ルーティング テーブル ルックアップの実行が避けられます。このようなデバイスは、一般的な HSRP ゲートウェイではなく、送信元 Cisco Nexus 7000 デバイスの MAC アドレスを使用して、トラフィックに応答する場合があります。このような動作は、一部の基本的なイーサネット RFC 規格と互換性がありません。ローカルではないルータ MAC アドレスの vPC デバイスに到達するパケットは、ピアリンクを介して送信され、最終的な宛先が他の vPC の背後にある場合には、組み込みの vPC ループ回避メカニズムによってドロップされる場合があります。

vPC ピアゲートウェイ機能は、vPC スイッチが、vPC ピアのルータ MAC アドレスを宛先とするパケットに対して、アクティブなゲートウェイとして機能することを可能にします。この機能は、このようなパケットが vPC ピアリンクを通過する必要なしにローカルに転送されることを可能にします。このシナリオでは、この機能は、ピアリンクの使用を最適化し、トラフィック損失の可能性をなくします。

ピアゲートウェイ機能の設定は、プライマリ vPC ピアとセカンダリ vPC ピアの両方で行う必要がありますが、デバイスの稼動も vPC トラフィックも中断しません。vPC ピアゲートウェイ機能は、vPC ドメイン サブモードの下でグローバルに設定できます。

この機能をイネーブルにする場合は、ピア ゲートウェイ ルータを介してスイッチングされたパケットの IP リダイレクト メッセージの発生を避けるために、vPC VLAN を介してマッピングされるすべてのインターフェイス VLAN 上で IP リダイレクトをディセーブルにする必要があります。vPC ドメイン内でこの機能をイネーブルにすると、このような要件があることが、適切なメッセージによってユーザに通知されます。

ピアゲートウェイ vPC デバイスに到達するパケットは、その TTL がデクリメントされるため、TTL = 1 となっているパケットは TTL の失効が原因で伝送中にドロップされる可能性があります。ピアゲートウェイ機能がイネーブルになっており、パケットを TTL = 1 で送出する特定のネットワーク プロトコルが vPC VLAN 上で稼動している場合は、これを考慮する必要があります。

vPC ドメイン

vPC ドメイン ID を使用すれば、vPC ダウンストリーム デバイスに接続されている vPC ピア リンクとポートを識別できます。

vPC ドメインは、キープアライブ メッセージを設定するために使用したり、他の vPC ピア リンク パラメータについて、デフォルト値をそのまま使用するのではなく値を設定する場合に使用したりするコンフィギュレーション モードでもあります。これらのパラメータの設定方法については、「vPC の設定」を参照してください。

vPC ドメインを作成するには、まず各 vPC ピア デバイス上で、1 ~ 1000 の値を使用して vPC ドメイン ID を作成しなければなりません。vPC ドメインは、VDC ごとに 1 つだけ持つことができます。

各デバイス上で、ピア リンクとして機能させるポート チャネルを明示的に設定しなければなりません。各デバイス上でピア リンクにしたポート チャネルを、1 つの vPC ドメインからの同じ vPC ドメイン ID に関連付けます。このドメイン内で、システムはループフリー トポロジとレイヤ 2 マルチパスを提供します。

これらのポート チャネルと vPC ピア リンクは、静的にしか設定できません。各 vPC ピア デバイス上の vPC 内のすべてのポートが、同じ VDC 内になくてはなりません。ポート チャネルおよび vPC ピア リンクは、LACP を使用するかまたはプロトコルなしのいずれかで設定できます。可能であれば、各 vPC 内で LACP をアクティブ モードのインターフェイスと一緒に使用してポート チャネルを設定することをお勧めします。これにより、ポート チャネルのフェールオーバーが発生した場合の最適化されたスマートな回復が保証され、さらにポート チャネル自体の間での設定の不一致に対する設定チェックが提供されます。

vPC ピア デバイスは、設定された vPC ドメイン ID を使用して、一意の vPC システム MAC アドレスを自動的に割り当てます。各 vPC ドメインが、具体的な vPC 関連操作に ID として使用される一意の MAC アドレスを持ちます。ただし、デバイスは vPC システム MAC アドレスを LACP などのリンクスコープでの操作にしか使用しません。連続したレイヤ 2 ネットワーク内の各 vPC ドメインを、一意のドメイン ID で作成することをお勧めします。Cisco NX-OS ソフトウェアにアドレスを割り当てさせるのではなく、vPC ドメインに特定の MAC アドレスを設定することもできます。

vPC MAC の表示の詳細については、「CFSoE」を参照してください。

vPC ドメインを作成した後は、Cisco NX-OS ソフトウェアによって vPC ドメインのシステム プライオリティが作成されます。vPC ドメインに特定のシステム プライオリティを設定することもできます。


) システム プライオリティを手動で設定する場合は、必ず両方の vPC ピア デバイス上で同じプライオリティ値を割り当てなければなりません。vPC ピア デバイス同士が異なるシステム プライオリティ値を持っていると、vPC は稼動しません。


vPC ピア リンクの互換パラメータ

多くの設定パラメータおよび動作パラメータが、vPC 内のすべてのインターフェイスで同じでなければなりません。vPC ピア リンクに使用するレイヤ 2 ポート チャネルはトランク モードに設定することをお勧めします。

両方の vPC ピア デバイス上で vPC 機能をイネーブルにし、ピア リンクを設定したら、CFS メッセージによって、ローカル vPC ピア デバイス上の設定のコピーがリモート vPC ピア デバイスに提供されます。これにより、システムが 2 つのデバイス上で異なっている重要な設定パラメータがないか調べます (CFS の詳細については、「CFSoE」を参照してください)。


) vPC 内のすべてのインターフェイスで設定されている値を表示するには、show vpc consistency-parameters コマンドを入力します。表示される設定は、vPC ピア リンクおよび vPC の稼動を制限する可能性のある設定だけです。


vPC の互換性チェックプロセスは、正規のポート チャネルの互換性チェックとは異なります。正規のポート チャネルについては、「ポート チャネルの設定」を参照してください。

ここで説明する内容は、次のとおりです。

「同じでなければならない設定パラメータ」

「同じにすべき設定パラメータ」

同じでなければならない設定パラメータ

ここで示す設定パラメータは、vPC ピア リンクの両方のデバイスで同じように設定されていなければなりません。そうなっていないと、vPC はサスペンド モードに移行します。


) vPC 内のすべてのインターフェイスで、下に示す動作パラメータおよび設定パラメータの値が同じになっていなければなりません。



) vPC 内のすべてのインターフェイスで設定されている値を表示するには、show vpc consistency-parameters コマンドを入力します。表示される設定は、vPC ピア リンクおよび vPC の稼動を制限する可能性のある設定だけです。


vPC インターフェイスでのこれらのパラメータの一部は、デバイスによって自動的に互換性がチェックされます。インターフェイスごとのパラメータは、インターフェイスごとに一貫性を保っていなければならず、グローバル パラメータはグローバルに一貫性を保っていなければなりません。

ポート チャネル モード:オン、オフ、またはアクティブ

チャネルごとのリンク速度

チャネルごとのデュプレックス モード

チャネルごとのトランク モード:

Native VLAN

トランク上の許可 VLAN

ネイティブ VLAN トラフィックのタギング

Spanning Tree Protocol(STP; スパニング ツリー プロトコル)モード

多重スパニング ツリーの STP リージョン設定

VLAN ごとのイネーブル/ディセーブル状態

STP グローバル設定:

Bridge Assurance の設定

ポート タイプの設定

ループ ガードの設定

STP インターフェイス設定:

ポート タイプの設定

ループ ガード

ルート ガード

Maximum Transmission Unit(MTU; 最大伝送ユニット)

これらのパラメータのいずれかがイネーブルになっていなかったり、片方のデバイスでしか定義されていないと、vPC の一貫性チェックではそのパラメータは無視されます。


) どの vPC インターフェイスもサスペンド モードになっていないことを確認するには、show vpc brief コマンドおよび show vpc consistency-parameters コマンドを入力して、syslog メッセージをチェックします。


同じにすべき設定パラメータ

次の挙げるパラメータのいずれかが両方の vPC ピア デバイス上で同じように設定されていないと、誤設定が原因でトラフィック フローに望ましくない動作が発生する可能性があります。

MAC エージング タイマー

スタティック MAC エントリ

VLAN インターフェイス:vPC ピア リンク エンドにある各デバイスの VLAN インターフェイスが両エンドで同じ VLAN 用に設定されていなければならず、さらに同じ管理モードで同じ動作モードになっていなければなりません。ピア リンクの片方のデバイスだけで設定されている VLAN は、vPC またはピア リンクを使用してトラフィックを通過させることはしません。すべての VLAN をプライマリ vPC デバイスとセカンダリ vPC デバイスの両方で作成しなければなりません。そうなっていない VLAN は、停止します。

ACL のすべての設定とパラメータ

Quality of Service(QoS; サービス品質)の設定とパラメータ

STP インターフェイス設定:

BPDU フィルタ

BPDU ガード

コスト

リンク タイプ

プライオリティ

VLAN(Rapid PVST+)

ポート セキュリティ

Cisco Trusted Security(CTS)

Dynamic Host Configuration Protocol(DHCP)スヌーピング

Network Access Control(NAC; ネットワーク アクセス コントロール)

Dynamic ARP Inspection(DAI; ダイナミック ARP インスペクション)

IP Source Guard(IPSG; IP ソース ガード)

Internet Group Management Protocol(IGMP; インターネット グループ管理プロトコル)スヌーピング

Hot Standby Routing Protocol(HSRP; ホット スタンバイ ルーティング プロトコル)

Protocol Independent Multicast(PIM; プロトコル独立マルチキャスト)

Gateway Load-Balancing Protocol(GLBP; ゲートウェイ ロード バランシング プロトコル)

すべてのルーティング プロトコル設定

すべての設定パラメータで互換性が取れていることを確認するために、vPC の設定が終わったら、各 vPC ピア デバイスの設定を表示してみることをお勧めします。

vPC 番号

vPC ドメイン ID と vPC ピア リンクを作成し終えたら、ダウンストリーム デバイスを各 vPC ピア デバイスに接続するためのポート チャネルを作成します。つまり、プライマリ vPC ピア デバイスからダウンストリーム デバイスへのポート チャネルを 1 つ作成し、もう 1 つ、セカンダリ ピア デバイスからダウンストリーム デバイスへのポート チャネルも作成します。


) スイッチとしてもブリッジとしても機能しないホストまたはネットワーク デバイスに接続されているダウンストリーム デバイス上のポートは、STP エッジ ポートとして設定することをお勧めします。STP ポート タイプの詳細については、『Cisco Nexus 7000 Series NX-OS Layer 2 Switching Configuration Guide, Release 5.xを参照してください。


最後に、各 vPC ピア デバイス上で作業して、ダウンストリーム デバイスに接続されているポート チャネルに vPC 番号を割り当てます。vPC を作成するときには、最小限のトラフィックの中断が発生します。すべてのポート番号に、ポート チャネル自体と同じ vPC ID 番号を割り当てると(つまり、ポート チャネル 10 には vPC ID 10)、設定が簡単になります。


) vPC ピア デバイスからダウンストリーム デバイスに接続されているポート チャネルに割り当てる vPC 番号は、両方の vPC デバイスで同じでなければなりません


他のポート チャネルの vPC への移行


) ダウンストリーム デバイスは、ポート チャネルを使用して両方の vPC ピア デバイスに接続しなければなりません。


ダウンストリーム デバイスを接続するために、プライマリ vPC ピア デバイスからダウンストリーム デバイスへのポート チャネルを作成し、セカンダリ ピア デバイスからダウンストリーム デバイスへのもう 1 つのポート チャネルを作成します。最後に、各 vPC ピア デバイス上で作業して、ダウンストリーム デバイスに接続されているポート チャネルに vPC 番号を割り当てます。vPC を作成するときには、最小限のトラフィックの中断が発生します。

単一モジュール上での vPC ピア リンクとコアへのリンクの設定


) 異なるモジュールの専用ポート上で vPC ピア リンクを設定して、障害発生の可能性を下げることをお勧めします。復元力を最適にしたい環境では、少なくとも 2 つのモジュールを使用してください。


Cisco NX-OS Release 4.2 以降では、すべての vPC ピア リンクとコアに面するインターフェイスを単一モジュール上で設定しなければならない場合は、両方の vPC ピア デバイス上のすべての vPC ピア リンク上の、およびコアへのレイヤ 3 リンクに関連付けられているトラック オブジェクトとトラック リストをコマンドライン インターフェイスを使用して設定してください。トラック リスト上のすべてのトラッキング対象オブジェクトが停止した場合、システムは次のように動作するため、この設定を使用すれば、その特定のモジュールが停止した場合のトラフィックのドロップを避けることができます。

vPC プライマリ ピア デバイスによるピアキープアライブ メッセージの送信を停止します。これにより、vPC セカンダリ ピア デバイスが強制的に引き継がされます。

その vPC ピア デバイス上のすべてのダウンストリーム vPC を停止させます。これにより、すべてのトラフィックが強制的に他の vPC ピア デバイスに向けてそのアクセス スイッチでルーティングされます。

いったんこの機能を設定したら、モジュールに障害が発生した場合には、システムが自動的にプライマリ vPC ピア デバイス上のすべての vPC リンクを停止させ、ピアキープアライブ メッセージを停止します。このアクションにより、vPC セカンダリ デバイスが強制的にプライマリ ロールを引き継がされ、システムが安定するまで、すべての vPC トラフィックがこの新しい vPC プライマリ デバイスに送られます。

コアへのすべてのリンクとすべての vPC ピア リンクが入っているトラック リストをそのオブジェクトとして作成します。このトラック リスト用の指定した vPC ドメインのトラッキングをイネーブルにします。この同じ設定を他方の vPC ピア デバイスにも適用します。オブジェクト トラッキングとトラック リストの設定方法については、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x を参照してください。

オブジェクト トラッキングの設定方法については、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x を参照してください。


) オブジェクトトラッキング リストを設定するときには、必ず Boolean OR を使用してください。


1 つのモジュール上で vPC ピア リンクとコアへのリンクを設定するには、次の手順を実行します。


ステップ 1 インターフェイス上(コアへのレイヤ 3)およびポート チャネル上(vPC ピア リンク)でトラック オブジェクトを設定します。

n7k-1(config-if)# track 35 interface ethernet 8/35 line-protocol
n7k-1(config-track)# track 23 interface ethernet 8/33 line-protocol
n7k-1(config)# track 55 interface port-channel 100 line-protocol
 

ステップ 2 Boolean OR を使用して、トラック リスト内にすべてのインターフェイスを含むトラック リストを作成します。

n7k-1(config)# track 44 list boolean OR
n7k-1(config-track)# object 23
n7k-1(config-track)# object 35
n7k-1(config-track)# object 55
n7k-1(config-track)# end
 

ステップ 3 このトラック オブジェクトを vPC ドメインに追加します。

n7k-1(config)# vpc domain 1
n7k-1(config-vpc-domain)# track 44
 

ステップ 4 次の例は、 show vpc brief コマンドを使用して、トラック オブジェクトを表示する方法を示します。

n7k-1# show vpc brief
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
vPC domain id : 1
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status: success
vPC role : secondary
Number of vPCs configured : 52
Track object : 44
 
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po100 up 1-5,140
 
vPC status
----------------------------------------------------------------------
id Port Status Consistency Reason Active vlans
-- ---- ------ ----------- -------------------------- ------------
1 Po1 up success success 1-5,140
 


 

次の例は、 show track brief コマンドを使用して、トラック オブジェクトに関する情報を表示する方法を示します。

n7k-1# show track brief
Track Type Instance Parameter State Last Change
23 Interface Ethernet8/33 Line Protocol UP 00:03:05
35 Interface Ethernet8/35 Line Protocol UP 00:03:15
44 List ----- Boolean or UP 00:01:19
55 Interface port-channel100 Line Protocol UP 00:00:34

vPC と LACP

LACP は、vPC ドメインのシステム MAC アドレスを使用して、vPC の LACP Aggregation Group(LAG)ID を形成します (LAG-ID と LACP については、「ポート チャネルの設定」を参照してください)。

ダウンストリーム デバイスからのチャネルも含めて、すべての vPC ポート チャネル上の LACP を使用できます。LACP は、vPC ピア デバイスの各ポート チャネル上のインターフェイスのアクティブ モードで設定することをお勧めします。この設定により、デバイス、単方向リンク、およびマルチホップ接続の間の互換性をより簡単に検出できるようになり、実行時の変更およびリンク障害に対してダイナミックな応答が可能になります。

vPC ピア リンクは、8 個のアクティブ リンクと 8 個のホット スタンバイ リンクとで、16 個の LACP インターフェイスをサポートします。ダウンストリーム vPC チャネル上では、8 個のアクティブ リンクと 8 個のホット スタンバイ リンクとで、16 個の LACP リンクを設定できます。LACP を使用せずにポート チャネルを設定する場合は、各チャネルに 8 個のリンクしか持てません。

vPC ピアリンク デバイスのシステム プライオリティを手動で設定して、vPC ピアリンク デバイスが、接続されているダウンストリーム デバイスより確実に高い LACP プライオリティを持つようにすることをお勧めします。システム プライオリティの値が低いほど、高い LACP プライオリティを意味します。


) システム プライオリティを手動で設定する場合は、必ず両方の vPC ピア デバイス上で同じプライオリティ値を割り当てなければなりません。vPC ピア デバイス同士が異なるシステム プライオリティ値を持っていると、vPC は稼動しません。


vPC ピア リンクと STP

vPC はループフリーなレイヤ 2 トポロジを提供しますが、それでもやはり、誤った配線やケーブルの欠陥、誤設定などから保護するための「フェールセイフ」メカニズムをスパニング ツリー プロトコル(STP)が提供する必要があります。vPC を初めて稼動させたときに、STP による再コンバージェンスが発生します。STP は、vPC ピア リンクを特殊なリンクとして扱い、常に vPC ピア リンクを STP のアクティブ トポロジに含めます。

すべての vPC ピア リンク インターフェイスを STP ネットワーク ポート タイプに設定して、すべての vPC リンク上で Bridge Assurance が自動的にイネーブルになるようにすることをお勧めします。また、vPC ピア リンク上ではどの STP 拡張機能もイネーブルにしないこともお勧めします。STP 拡張がすでに設定されている場合は何も問題は発生しませんが、これらを設定する必要はありません。

MST と Rapid PVST+ の両方を実行している場合は、必ず PVST シミュレーション機能を正しく設定してください。

STP 拡張機能と PVST シミュレーションの詳細については、『 Cisco Nexus 7000 Series NX-OS Layer 2 Switching Configuration Guide, Release 5.x を参照してください。


) パラメータのリストは、vPC ピア リンクの両サイドの vPC ピア デバイス上で同じになるように設定しなければなりません。これらの一致していなければならない必須設定については、「vPC ピア リンクの互換パラメータ」を参照してください。


STP は分散しています。つまり、このプロトコルは、両方の vPC ピア デバイス上で実行され続けます。ただし、プライマリ デバイスとして選択されている vPC ピア デバイス上での設定が、セカンダリ vPC ピア デバイス上の vPC インターフェイスの STP プロセスを制御します。

プライマリ vPC デバイスは、Cisco Fabric Services over Ethernet(CFSoE)を使用して、vPC セカンダリ ピア デバイス上の STP の状態を同期させます。CFSoE については、「CFSoE」を参照してください。

vPC の STP プロセスも、ピア リンク上で接続されているデバイスの 1 つに障害が発生したときにそれを検出するために、定期的なキープアライブ メッセージに依存しています。これらのメッセージについては、「ピアキープアライブ リンクとメッセージ」を参照してください。

vPC マネージャが、vPC ピア デバイス間で、プライマリ デバイスとセカンダリ デバイスを設定して 2 つのデバイスを STP 用に調整する提案/ハンドシェイク合意を実行します。その後、プライマリ vPC ピア デバイスが、プライマリ デバイスとセカンダリ デバイス両方での STP プロトコルの制御を行います。プライマリ vPC ピア デバイスを STP プライマリ ルート デバイスとして設定し、セカンダリ VPC デバイスを STP セカンダリ ルート デバイスになるように設定することをお勧めします。

プライマリ vPC ピア デバイスがセカンダリ vPC ピア デバイスにフェールオーバーした場合、STP トポロジには何の変化も発生しません。

BPDU は、代表ブリッジ ID フィールドで、STP ブリッジ ID の vPC に設定されている MAC アドレスを使用します。vPC プライマリ デバイスが、vPC インターフェイス上でこれらの BPDU を送信します。

次のパラメータについて同じ STP 設定を使用して、vPC ピア リンクの両エンドを設定しなければなりません。

STP グローバル設定:

STP モード

MST のための STP リージョン設定

VLAN ごとのイネーブル/ディセーブル状態

Bridge Assurance の設定

ポート タイプの設定

ループ ガードの設定

STP インターフェイス設定:

ポート タイプの設定

ループ ガード

ルート ガード


) これらのパラメータのいずれかに誤設定があった場合、Cisco NX-OS ソフトウェアが vPC 内のすべてのインターフェイスを停止します。syslog をチェックし、show vpc brief コマンドを入力して、vPC インターフェイスが停止していないか確認してください。


次の STP インターフェイス設定が、vPC ピア リンクの両側で同じになっていることを確認します。そうなっていないと、トラフィック フローに予測不能な動作が発生する可能性があります。

BPDU フィルタ

BPDU ガード

コスト

リンク タイプ

プライオリティ

VLAN(PVRST+)


) vPC ピア リンクの両側での設定を表示して、設定が同じであることを確認してください。


この機能がイネーブルになっている場合は、 show spanning-tree コマンドで vPC に関する情報を表示できます。例については、 『Cisco Nexus 7000 Series NX-OS Layer 2 Switching Configuration Guide, Release 5.x を参照してください。


) ダウンストリーム デバイスのポートは、STP エッジ ポートとして設定することをお勧めします。スイッチに接続されているすべてのホスト ポートを STP エッジ ポートとして設定してください (STP ポート タイプの詳細については、『Cisco Nexus 7000 Series NX-OS Layer 2 Switching Configuration Guide, Release 5.xを参照してください)。


vPC ピア スイッチ

vPC ピア スイッチ機能は、STP コンバージェンスに関連するパフォーマンス上の問題を解決するために、Cisco NX-OS Release 5.0(2) に追加されました。この機能は、一対の Cisco Nexus 7000 シリーズ デバイスがレイヤ 2 トポロジ内で 1 つの STP ルートとして現れることを可能にします。この機能は、STP ルートを vPC プライマリ スイッチに固定する必要性をなくし、vPC プライマリ スイッチに障害が発生した場合の vPC コンバージェンスを向上させます。

ループを回避するために、vPC ピア リンクは STP 計算からは除外されます。vPC ピア スイッチ モードでは、ダウンストリーム スイッチでの STP BPDU タイムアウトに関連した問題(この問題は、トラフィックの中断につながります)を避けるために、STP BPDU が両方の vPC ピア デバイスから送信されます。

この機能は、次のトポロジで使用できます。

すべてのデバイスが vPC に属する純粋なピア スイッチ トポロジ。

その設定内に vPC デバイスと非 vPC デバイスが混在するハイブリッド ピア スイッチ トポロジ。

STP 拡張機能と Rapid PVST+ の詳細については、『 Cisco Nexus 7000 Series NX-OS Layer 2 Switching Configuration Guide, Release 5.x を参照してください。

vPC マルチキャスト:PIM、IGMP、および IGMP スヌーピング


) Nexus 7000 シリーズ デバイスの Cisco NX-OS ソフトウェアは、PIM SSM も BIDR on vPC もサポートしていません。Cisco NX-OS ソフトウェアは、PIM ASM on vPC を完全にサポートします。


ソフトウェアが、マルチキャスト フォワーディングを両方の vPC ピア デバイス上で同期された状態に保ちます。vPC ピア デバイス上の IGMP スヌーピング プロセスは、学習したグループ情報を vPC リンクを通じて他の vPC ピア デバイスと共有します。マルチキャスト状態は、常に両方の vPC ピア デバイス上で同期されます。vPC モードでの PIM プロセスは、1 つの vPC ピア デバイスだけが受信者に向けてマルチキャスト トラフィックを転送する状態を確保します。

各 vPC ピアは、レイヤ 2 またはレイヤ 3 デバイスです。マルチキャスト トラフィックは 1 つの vPC ピア デバイスだけから伝送されます。次のシナリオで、重複したパケットが観察される場合があります。

孤立ホスト

送信元と受信者が、マルチキャスト ルーティングのイネーブルになった異なる VLAN 内のレイヤ 2 vPC クラウド内にあり、vPC メンバ リンクが停止している場合。

次のシナリオで、ごくわずかなトラフィック損失が観察される場合があります。

トラフィックを転送している vPC ピア デバイスをリロードした場合。

トラフィックを転送している vPC ピア デバイスの PIM を再起動した場合。

必ずすべてのレイヤ 3 デバイスを両方の vPC ピア デバイスにデュアル接続してください。片方の vPC ピア デバイスが停止した場合、他方の vPC ピア デバイスが、通常どおりにすべてのマルチキャスト トラフィックを転送し続けます。

vPC とマルチキャストに関する情報を表示するコマンドについては、『 Cisco Nexus 7000 Series NX-OS Interfaces Command Reference, Release 5.x を参照してください。

次に、vPC PIM および vPC IGMP/IGMP スヌーピングについて説明します。

vPC PIM:vPC モードの PIM プロセスは、vPC ピア デバイスの片方だけがマルチキャスト トラフィックを転送する状態を確保します。vPC モードの PIM プロセスは、送信元の状態を両方の vPC ピア デバイスと同期させ、トラフィックを転送する vPC ピア デバイスを選出します。

vPC IGMP/IGMP スヌーピング:vPC モードの IGMP プロセスは、両方の vPC ピア デバイスでの DR 情報を同期させます。vPC モードになっているときには、IGMP についてデュアル DR という概念があります。これは、vPC モードでないときは使用できないもので、両方の vPC ピア デバイスにピア間でマルチキャスト グループ情報を維持させます。

IGMP スヌーピングは、両方の vPC ピア デバイス上で同じようにイネーブルにしたりディセーブルにしたりする必要があり、すべての機能設定を同じにしなければなりません。IGMP スヌーピングは、デフォルトで有効になっています。

マルチキャストの詳細については、 『Cisco Nexus 7000 Series NX-OS Multicast Routing Configuration Guide, Release 5.x を参照してください。

vPC ピア リンクとルーティング

First Hop Routing Protocols(FHRP; ファーストホップ冗長プロトコル)は、vPC と相互運用できます。Hot Standby Routing Protocol(HSRP; ホット スタンバイ ルーティング プロトコル)、Gateway Load Balancing Protocol(GLBP; ゲートウェイ ロード バランシング プロトコル)、および Virtual Router Redundancy Protocol(VRRP; 仮想ルータ冗長プロトコル)のすべてが、vPCs と相互運用できます。すべてのレイヤ 3 デバイスを両方の vPC ピア デバイスにデュアル接続することをお勧めします。


) 両方のデバイスから同じ VLAN の VLAN ネットワーク インターフェイスを設定することにより、各 vPC ピア デバイスからのレイヤ 3 接続をイネーブルにしなければなりません (VLAN ネットワーク インターフェイスの作成については、「レイヤ 3 インターフェイスの設定」を参照してください)。


プライマリ FHRP デバイスは、たとえセカンダリ vPC デバイスがデータ トラフィックを転送したとしても、ARP 要求に応答します。

プライマリ vPC ピア デバイスを FHRP アクティブ ルータの最も高いプライオリティで設定しておくと、初期の設定確認と vPC/HSRP のトラブルシューティングを簡単にできます。

さらに、if-hsrp コンフィギュレーション モードで priority コマンドを使用して、vPC ピア リンク上でイネーブルになっているグループの状態がスタンバイになっているか、またはリスン状態になっている場合のフェールオーバーのしきい値を設定できます。インターフェイスが停止したり稼動したりするのを防ぐために、低いしきい値と高いしきい値を設定できます。

VRRP は、vPC ピア デバイス上で実行されている場合に HSRP とよく似た動作を示します。VRRP は、HSRP を設定したのと同じ方法で設定してください。GLBP については、両方の vPC ピア デバイス上のフォワーダがトラフィックを転送します。

プライマリ vPC ピア デバイスに障害が発生した場合は、セカンダリ vPC ピア デバイスにフェールオーバーされ、FHRP トラフィックはシームレスに流れ続けます。

この目的には VLAN ネットワーク インターフェイスを使用するよりも、vPC ピア デバイスからのルーティングのためのレイヤ 3 リンクを別途設定してください。

vPC 環境での HSRP の焼き付け MAC アドレス オプション(use-bia)の設定、および任意の FHRP プロトコルのための仮想 MAC アドレスの手動での設定は、お勧めできません。これらの設定は、vPC ロード バランシングに不利な影響を与えるためです。hsrp use-bia は、vPC ではサポートされていません。カスタム MAC アドレスを設定する際には、両方の vPC ピア デバイスに同じ MAC アドレスを設定しなければなりません。

Cisco NX-OS 4.2(1) から、ピアの隣接が形成されて VLAN インターフェイスがバックアップされるまで vPC の再稼動を遅らせる復元タイマーを設定できるようになりました。この機能により、vPC が再びトラフィックの受け渡しをし始める前にルーティング テーブルが収束できなかった場合のパケットのドロップを回避できます。

この機能を設定するには、 delay restore コマンドを使用します。


) データ センターが停電した場合に、vPC が正常に稼動し始める前に HSRP がイネーブルになると、トラフィック損失が発生します。vPC が安定するまでの時間を確保するために、HSRP 遅延をイネーブルにする必要があります。HSRP 遅延とプリエンプション遅延の両方をイネーブルにすると、Cisco Nexus 7000 シリーズ デバイスは、両方のタイマーの時間が切れた後にレイヤ 2 スイッチングを有効にします。


FHRP とルーティングの詳細については、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x を参照してください。

CFSoE

Cisco Fabric Services over Ethernet(CFSoE)は、vPC ピア デバイスのアクションを同期化するために使用される信頼性の高い状態転送メカニズムです。CFSoE は、vPC にリンクされている、STP、IGMP などの多くの機能のメッセージとパケットを伝送します。情報は、CFS/CFSoE プロトコル データ ユニット(PDU)に入れて伝送されます。

CFSoE は、vPC 機能をイネーブルにすると、デバイスによって自動的にイネーブルになります。何も設定する必要はありません。vPC の CFSoE 分散には、IP を介してまたは CFS リージョンに分散する機能は必要ありません。CFSoE 機能が vPC 上で正常に機能するために必要な設定は一切ありません。

CFSoE 転送は、各 VDC にローカルです。

show mac address-table コマンドを使用すれば、CFSoE が vPC ピア リンクのために同期する MAC アドレスを表示できます。


no cfs eth distribute コマンドと no cfs distribute コマンドは入力しないでください。CFSoE for vPC 機能のための CFSoE をイネーブルにしなければなりません。vPC をイネーブルにしてこれらのコマンドのいずれかを入力すると、エラー メッセージが表示されます。


show cfs application コマンドを入力すると、出力に「Physical-eth」と表示されます。これは、CFSoE を使用しているアプリケーションを示します。

Cisco Fabric Services は、TCP/IP を介したデータの転送も行います。CFS over IP の詳細については、『 Cisco Nexus 7000 Series NX-OS System Management Configuration Guide, Release 5.x を参照してください。


) CFS リージョンはサポートされていません。


バーチャライゼーションのサポート


) 1 つの VDC 内に配置した各 vPC ドメインについて、独立した vPC ピアリンクとピアキープアライブ リンクのインフラストラクチャをプロビジョニングしなければなりません。vPC ピア(ドメインが同じ 2 台の vPC ピア デバイス)を同じ物理デバイスの 2 つの VDC 内に統合することは、サポートされていません。


1 つの vPC 内のすべてのポートが、同じ VDC 内になくてはなりません。このバージョンのソフトウェアは、VDC ごとに 1 つの vPC しかサポートしません。各 VDC で 1 ~ 4096 の番号を使用して、vPC に番号を付けることができます。これらの vPC 番号は、別の VDC 内で再利用できます。


) VDC とリソース割り当ての詳細については、『Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide, Release 5.xを参照してください。


リロードでの vPC の復元

データ センターの停電時には、vPC を構成する両方の Cisco Nexus 7000 シリーズ デバイスがリロードされます。まれに、ピアの片方だけが復元できることがあります。リモート ピアとのハンドシェイクが実行されないと vPC ポート チャネルは稼動できないため、通信ができず、vPC は機能できません。

Cisco NX-OS Release 5.0(2) からは、ピアがオンラインになれなかった場合に、 reload restore コマンドを使用して vPC サービスを復元するように Cisco Nexus 7000 シリーズ デバイスを設定できるようになりました。この設定は、スタートアップ コンフィギュレーションに保存しなければなりません。リロード時に、Cisco NX-OS ソフトウェアは、ユーザによる設定が可能なタイマーを開始します(デフォルトは 240 秒)。ピアリンク ポートが物理的に稼動し始めるか、ピアキープアライブが機能し始めたら、タイマーは停止し、デバイスはピアの隣接が形成されるのを待ちます。

ピアキープアライブ パケットもピアリンク アップ パケットも受信できないままタイマーが切れると、Cisco NX-OS ソフトウェアは、プライマリ STP ロールとプライマリ LACP ロールを想定します。ソフトウェアが vPC を初期化し、そのローカル ポートを稼動させ始めます。ピアがないため、ローカル vPC ポートの一貫性チェックはバイパスされます。デバイスは、自身をそのロール プライオリティに関係なく STP プライマリに選出し、LACP ポート ロールのマスターとしても機能します。

vPC 復元ピア ロール

ピア デバイスのリロードが完了し、隣接が形成されたら、次のプロセスが発生します。

1. 最初の vPC ピアがその現在のロールを維持して、その他のプロトコルへの任意の移行リセットを回避します。ピアが、他の可能なロールを受け入れます。

2. 隣接が形成されたら、一貫性チェックが実行され、適切なアクションが取られます。

ハイ アベイラビリティ

In-Service Software Upgrade(ISSU)では、最初の vPC デバイス上のソフトウェア リロード プロセスが、vPC 通信チャネルを介した CFS メッセージングを使用して、その vPC ピア デバイスをロックします。1 度に 1 つのデバイスだけアップグレードできます。最初のデバイスは、そのアップグレードが完了したら、そのピア デバイスのロックを解除します。次に、2 つ目のデバイスが、最初のデバイスが行ったのと同じように最初のデバイスをロックして、アップグレード プロセスを実行します。アップグレード中は、2 つの vPC デバイスが一時的に異なるリリースの Cisco NX-OS を実行することになりますが、その下位互換性により、システムは正常に機能します。


) ハイアベイラビリティ機能の詳細については、『Cisco Nexus 7000 Series NX-OS High Availability and Redundancy Guide, Release 5.xを参照してください。


vPC のライセンス要件

次の表に、この機能のライセンス要件を示します。

 

製品
ライセンス要件

Cisco NX-OS

vPC には、ライセンスは必要ありません。ライセンス パッケージに含まれていない機能はすべて Cisco NX-OS システム イメージにバンドルされており、追加費用は一切発生しません。Cisco NX-OS のライセンス スキームの詳細については、『 Cisco Nexus 7000 Series NX-OS Licensing Guide, Release 5.x を参照してください。

注意事項および制約事項

vPC には、次の注意事項と制約事項があります。

1 つの vPC のすべてのポートが、同じ VDC 内になくてはなりません。

vPC を設定するには、まず vPC をイネーブルにしなければなりません。

システムが vPC ピア リンクを形成するには、その前にピアキープアライブ リンクとピアキープアライブ メッセージを設定しなければなりません。

vPC に入れられるのは、レイヤ 2 ポート チャネルだけです。

両方の vPC ピア デバイスを設定しなければなりません。設定が片方のデバイスから他方へ送信されることはありません。

マルチレイヤ(バックツーバック)vPC を設定するには、それぞれの vPC に一意の vPC ドメイン ID を割り当てなければなりません。

必要な設定パラメータが、vPC ピア リンクの両側で互換性を保っているかチェックしてください。互換性に関する推奨事項について、「vPC ピア リンクの互換パラメータ」を参照してください。

vPC の設定中に、最小限のトラフィックの中断が発生する可能性があります。

vPC 上での BIDR PIM および SSM はサポートされていません。

vPC 環境での DHCP スヌーピング、DAI、IPSG はサポートされていません。DHCP リレーはサポートされています。

CFS リージョンはサポートされていません。

ポート チャネル上でのポート セキュリティは、サポートされていません。

vPC 内の LACP を使用するすべてのポート チャネルを、アクティブ モードのインターフェイスで設定することをお勧めします。

この目的には VLAN ネットワーク インターフェイスを使用するよりも、vPC ピア デバイスからのルーティングのためのレイヤ 3 リンクを別途設定してください。

バックツーバックのマルチレイヤ vPC トポロジでは、それぞれの vPC に一意のドメイン ID が必要です。

vPC 環境で OSPF を設定する場合は、vPC ピアリンクが停止した場合のファースト OSPF コンバージェンスを確保するために、コア スイッチ上でルータ コンフィギュレーション モードで次のタイマー コマンドを使用してください。

switch (config-router)# timers throttle spf 1 50 50
switch (config-router)# timers lsa-arrival 10
 

OSPF の詳細については、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x を参照してください。

vPC の設定


) この手順を vPC ピア リンクの両側にある両方のデバイスで使用しなければなりません。両方の vPC ピア デバイスをこの手順で設定します。


ここでは、Command-Line Interface(CLI; コマンドライン インターフェイス)を使用して vPC を設定する方法を説明します。内容は次のとおりです。

「vPC のイネーブル化」

「vPC のディセーブル化」

「vPC ドメインの作成と vpc-domain モードの開始」

「vPC キープアライブ リンクと vPC キープアライブ メッセージの設定」

「vPC ピア リンクの作成」

「vPC ピアゲートウェイの設定」

「vPC ピア リンクの設定の互換性チェック」

「他のポート チャネルの vPC への移行」

「vPC ドメイン MAC アドレスの手動での設定」

「システム プライオリティの手動での設定」

「vPC ピア デバイス ロールの手動での設定」

「シングルモジュール vPC でのトラッキング機能の設定」

「リロード復元の設定」

「vPC ピア スイッチの設定」


) Cisco IOS CLI を熟知している場合は、この機能の Cisco NX-OS コマンドと使用する Cisco IOS コマンドが異なる場合もある点に注意してください。


vPC のイネーブル化

vPC を設定して使用するには、その前に vPC 機能をイネーブルにしなければなりません。

作業を開始する前に

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. feature vpc

3. exit

4. show feature

5. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

feature vpc

 

例:

switch(config)# feature vpc

デバイスの vPC をイネーブルにします。

ステップ 3

exit

 

例:

switch(config)# exit

switch#

コンフィギュレーション モードを終了します。

ステップ 4

show feature

 

例:

switch# show feature

(任意)デバイス上でイネーブルになっている機能を表示します。

ステップ 5

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次の例は、vPC 機能をイネーブルにする方法を示します。

switch# configure terminal
switch(config)# feature vpc
switch(config)#
 

vPC のディセーブル化


) vPC 機能をディセーブルにすると、デバイス上のすべての vPC 設定がクリアされます。


作業を開始する前に

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. no feature vpc

3. exit

4. show feature

5. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

no feature vpc

 

例:

switch(config)# no feature vpc

デバイスの vPC をディセーブルにします。

ステップ 3

exit

 

例:

switch(config)# exit

switch#

コンフィギュレーション モードを終了します。

ステップ 4

show feature

 

例:

switch# show feature

(任意)デバイス上でイネーブルになっている機能を表示します。

ステップ 5

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次の例は、vPC 機能をディセーブルにする方法を示します。

switch# configure terminal
switch(config)# no feature vpc
switch(config)#
 

vPC ドメインの作成と vpc-domain モードの開始

vPC ドメインを作成し、両方の vPC ピア デバイス上で vPC ピア リンク ポート チャネルを同じ vPC ドメイン内に置くことができます。1 つの VDC 全体を通じて一意の vPC ドメイン番号を使用してください。このドメイン ID は、vPC システム MAC アドレスを自動的に形成するのに使用されます。

このコマンドを使用して、vpc-domain コマンド モードを開始することもできます。

作業を開始する前に

vPC 機能がイネーブルになっていることを確認します。

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. vpc domain domain-id

3. exit

4. show vpc brief

5. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vpc domain domain-id

 

例:

switch(config)# vpc domain 5

switch(config-vpc-domain)#

デバイス上に vPC ドメインを作成し、設定目的で vpc-domain コンフィギュレーション モードを開始します。デフォルトはありません。指定できる範囲は 1 ~ 1,000 です。

ステップ 3

exit

 

例:

switch(config-vpc-domain)# exit

switch(config)#

vpc-domain コンフィギュレーション モードを終了します。

ステップ 4

show vpc brief

 

例:

switch# show vpc brief

(任意)各 vPC ドメインに関する簡単な情報を表示します。

ステップ 5

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次の例は、vPC ドメインを作成する方法を示します。

switch# configure terminal
switch(config)# vpc domain 5
switch(config-vpc-domain)#
 

次の例は、vpc-domain コマンドモードを開始して、既存の vPC ドメインを設定する方法を示します。

switch# configure terminal
switch(config)# vpc domain 5
switch(config-vpc-domain)#
 

vPC キープアライブ リンクと vPC キープアライブ メッセージの設定


) システムが vPC ピア リンクを形成するには、その前に vPC ピアキープアライブ リンクを設定しなければなりません。


キープアライブ メッセージを伝送するピアキープアライブ リンクの宛先 IP を設定できます。必要に応じて、キープアライブ メッセージのその他のパラメータも設定できます。


) 独立した Virtual Routing and Forwarding(VRF; 仮想ルーティング/転送)インスタンスを設定し、各 vPC ピア デバイスからのレイヤ 3 ポートを vPC ピアキープアライブ リンクの VRF に入れることをお勧めします。vPC ピアキープアライブ メッセージの送信にピア リンク自体を使用することはしないでください。VRF の作成と設定の方法については、『Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.xを参照してください。
ピアキープアライブ メッセージの送信元と宛先両方の IP アドレスが、ネットワーク上で固有になっていることを確認してください。


管理ポートと管理 VRF が、これらのキープアライブ メッセージのデフォルトです。

作業を開始する前に

vPC 機能がイネーブルになっていることを確認します。

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. vpc domain domain-id

3. peer-keepalive destination ip address [ hold-timeout secs | interval msecs { timeout secs} | { precedence {prec-value | network | internet | critical | flash - override | flash | immediate | priority | routine }} | { tos {tos-value | max-reliability | max-throughput | min-delay | min-monetary-cost | normal }} | tos-byte tos-byte-value} | source ipaddress | udp-port number | vrf {name | management | vpc-keepalive }]

4. exit

5. show vpc statistics

6. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vpc domain domain-id

 

例:

switch(config)# vpc domain 5

switch(config-vpc-domain)#

デバイス上に vPC ドメインを作成し、設定目的で vpc-domain コンフィギュレーション モードを開始します。

ステップ 3

peer-keepalive destination ipaddress [ hold-timeout secs | interval msecs { timeout secs} | { precedence { prec-value | network | internet | critical | flash-override | flash | immediate priority | routine}} | tos { tos-value | max-reliability | max-throughput | min-delay | min-monetary-cost | normal}} |tos-byte tos-byte-value} | source ipaddress | vrf {name | management vpc-keepalive }]

 

例:

switch(config-vpc-domain)# peer-keepalive destination 172.28.230.85

switch(config-vpc-domain)#

vPC ピアキープアライブ リンクのリモート エンドの IPv4 アドレスを設定します。

(注) vPC ピアキープアライブ リンクを設定するまでは、vPC ピア リンクは形成されません。

管理ポートと VRF がデフォルトです。

を参照してください。

ステップ 4

exit

 

例:

switch(config-vpc-domain)# exit

switch(config)#

vpc-domain コンフィギュレーション モードを終了します。

ステップ 5

show vpc statistics

 

例:

switch# show vpc statistics

(任意)キープアライブ メッセージの設定に関する情報を表示します。

ステップ 6

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

VRF の設定方法の詳細については、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x を参照してください。

次の例は、vPC ピアキープアライブ リンクの宛先と送信元の IP アドレスおよび VRF を設定する方法を示します。

switch# configure terminal
switch(config)# feature vpc
switch(config)# vpc domain 100
switch(config-vpc-domain)# peer-keepalive destination 172.168.1.2 source 172.168.1.1 vrf vpc-keepalive
 

vPC ピア リンクの作成

vPC ピア リンクを作成するには、指定した vPC ドメインのピア リンクとするポート チャネルを各デバイス上で指定します。vPC ピア リンクとして指定するレイヤ 2 ポート チャネルはトランク モードに設定し、冗長性のために各 vPC ピア デバイス上で独立したモジュール上の 2 つのポートを使用することをお勧めします。

作業を開始する前に

vPC 機能がイネーブルになっていることを確認します。

レイヤ 2 ポート チャネルを使用していることを確認します。

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. interface port-channel channel-number

3. vpc peer-link

4. exit

5. show vpc brief

6. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface port-channel channel-number

 

例:

switch(config)# interface port-channel 20

switch(config-if)#

このデバイスの vPC ピア リンクとして使用するポート チャネルを選択し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

vpc peer-link

 

例:

switch(config-if)# vpc peer-link

switch(config-vpc-domain)#

選択したポート チャネルを vPC ピア リンクとして設定し、vpc-domain コンフィギュレーション モードを開始します。

ステップ 4

exit

 

例:

switch(config-vpc-domain)# exit

switch(config)#

vpc-domain コンフィギュレーション モードを終了します。

ステップ 5

show vpc brief

 

例:

switch# show vpc brief

(任意)各 vPC に関する情報を表示します。vPC ピア リンクに関する情報も表示されます。

ステップ 6

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次の例は、vPC ピア リンクを設定する方法を示します。

switch# configure terminal
switch(config)# interface port-channel 20
switch(config-if)# vpc peer-link
switch(config-vpc-domain)#
 

vPC ピアゲートウェイの設定

Cisco NX-OS 4.2(1) から、vPC ピア デバイスを、vPC ピア デバイスの MAC アドレスを送信先とするパケットに対してゲートウェイとして機能するように設定できるようになりました。


) vPC ドメインにレイヤ 3 デバイスを接続した場合、vPC ピアリンク上でも送信される VLAN を使用したルーティング プロトコルのピアリンクはサポートされません。vPC ピア デバイスおよび汎用レイヤ 3 デバイスの間でルーティング プロトコルの隣接関係が必要な場合は、相互接続に物理的にルーティングされたインターフェイスを使用しなければなりません。vPC ピアゲートウェイ機能の使用では、この要件は変わりません。


作業を開始する前に

vPC 機能がイネーブルになっていることを確認します。

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. interface vlan vpc-interface-vlan-id

3. no ip redirects

4. vpc domain domain-id

5. peer-gateway

6. exit

7. show vpc brief

8. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface vlan vpc-interface-vlan-id

 

例:

switch(config)# interface vlan 10

switch(config-if)#

vPC VLAN を選択し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

no ip redirects

 

例:

switch(config-if)# no ip redirects

switch(config-vpc-domain)#

VLAN インターフェイスでの Internet Control Message Protocol(ICMP; インターネット制御メッセージ プロトコル)リダイレクト メッセージの送信をディセーブルにします。

ステップ 4

vpc domain domain-id

 

例:

switch(config-if)# vpc domain 5

switch(config-vpc-domain)#

vPC ドメインがまだ存在しなかった場合はそれを作成し、vpc-domain コンフィギュレーション モードを開始します。

ステップ 5

peer-gateway

 

例:

switch(config-vpc-domain)# peer-gateway

Note:

------:: Disable IP redirects on all interface-vlans of this vPC domain for correct operation of this feature ::------

ピアのゲートウェイ MAC アドレスを宛先とするパケットのレイヤ 3 フォワーディングをイネーブルにします。

ステップ 6

exit

 

例:

switch(config-vpc-domain)# exit

switch(config)#

vpc-domain コンフィギュレーション モードを終了します。

ステップ 7

show vpc brief

 

例:

switch# show vpc brief

(任意)各 vPC に関する情報を表示します。vPC ピア リンクに関する情報も表示されます。

ステップ 8

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

vPC ピア リンクの設定の互換性チェック

両方の vPC ピア デバイス上の vPC ピア リンクを設定した後に、すべての vPC インターフェイスで設定が一貫していることをチェックします。vPC 上での一貫した設定については、「vPC ピア リンクの互換パラメータ」を参照してください。

手順の概要

1. configure terminal

2. show vpc consistency-parameters {global | interface port-channel channel-number}

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

show vpc consistency-parameters {global | interface port-channel channel-number}

 

例:

switch(config)# show vpc consistency-parameters global

switch(config)#

すべての vPC インターフェイスの間で一貫していなければならないパラメータのステータスを表示します。

次の例は、すべての vPC インターフェイスの間で必須設定の互換性が保たれているかチェックする方法を示します。

switch# configure terminal
switch(config)# show vpc consistency-parameters global
switch(config)#
 

) vPC インターフェイス設定の互換性に関するメッセージが syslog にも記録されます。


他のポート チャネルの vPC への移行


) 冗長性のために vPC ドメインのダウンストリーム ポート チャネルを 2 つのデバイスに接続することをお勧めします。


ダウンストリーム デバイスに接続するには、ダウンストリーム デバイスからプライマリ vPC ピア デバイスへのポート チャネルを作成し、ダウンストリーム デバイスからセカンダリ ピア デバイスへのもう 1 つのポート チャネルを作成します。最後に、各 vPC ピア デバイス上で作業して、ダウンストリーム デバイスに接続されているポート チャネルに vPC 番号を割り当てます。vPC を作成するときには、最小限のトラフィックの中断が発生します。

作業を開始する前に

vPC 機能がイネーブルになっていることを確認します。

レイヤ 2 ポート チャネルを使用していることを確認します。

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. interface port-channel channel-number

3. vpc number

4. exit

5. show vpc brief

6. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface port-channel channel-number

 

例:

switch(config)# interface port-channel 20

switch(config-if)#

ダウンストリーム デバイスに接続するために vPC に入れるポート チャネルを選択し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

vpc number

 

例:

switch(config-if)# vpc peer-link

switch(config-vpc-domain)#

選択したポート チャネルを vPC に入れてダウンストリーム デバイスに接続するように設定します。これらのポート チャネルには、デバイス内の任意のモジュールを使用できます。指定できる範囲は 1 ~ 4096 です。

ステップ 4

exit

 

例:

switch(config-vpc-domain)# exit

switch(config)#

vpc-domain コンフィギュレーション モードを終了します。

ステップ 5

show vpc brief

 

例:

switch# show vpc brief

(任意)vPC に関する情報を表示します。

ステップ 6

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次の例は、ダウンストリーム デバイスに接続されるポート チャネルを設定する方法を示します。

switch# configure terminal
switch(config)# interface port-channel 20
switch(config-if)# vpc 5
switch(config-if
 

vPC ドメイン MAC アドレスの手動での設定

vPC ドメインを作成すると、Cisco NX-OS ソフトウェアが自動的に vPC システム MAC アドレスを作成します。このアドレスは、LACP など、リンク スコープに制限される操作に使用されます。ただし、vPC ドメイン MAC アドレスは手動で設定することも可能です。

作業を開始する前に

vPC 機能がイネーブルになっていることを確認します。

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. vpc domain domain-id

3. system-mac mac-address

4. exit

5. show vpc role

6. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vpc domain domain-id

 

例:

switch(config)# vpc domain 5

switch(config-vpc-domain)#

設定する vPC ドメインの番号を入力します。vpc-domain コンフィギュレーション モードを開始します。

ステップ 3

system-mac mac-address

 

例:

switch(config-vpc-domain)# system-mac 23fb.4ab5.4c4e

switch(config-vpc-domain)#

指定した vPC ドメインに割り当てる MAC アドレスを aaaa.bbbb.cccc の形式で入力します。

ステップ 4

exit

 

例:

switch(config-vpc-domain)# exit

switch(config)#

vpc-domain コンフィギュレーション モードを終了します。

ステップ 5

show vpc role

 

例:

switch# show vpc brief

(任意)vPC システム MAC アドレスを表示します。

ステップ 6

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次の例は、vPC ドメイン MAC アドレスを手動で設定する方法を示します。

switch# configure terminal
switch(config)# vpc domain 5
switch(config-vpc-domain)# system-mac 13gb.4ab5.4c4e
 

システム プライオリティの手動での設定

vPC ドメインを作成すると、vPC システム プライオリティが自動的に作成されます。ただし、vPC ドメインのシステム プライオリティは手動で設定することもできます。


) LACP を実行している場合は、手動で vPC システム プライオリティを設定して、vPC ピア デバイスが確実に LACP 上のプライマリ デバイスになるようにすることをお勧めします。システム プライオリティを手動で設定する場合は、必ず両方の vPC ピア デバイス上で同じプライオリティ値を設定してください。これらの値が一致していないと、vPC は稼動しません。


作業を開始する前に

vPC 機能がイネーブルになっていることを確認します。

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. vpc domain domain-id

3. system-priority priority

4. exit

5. show vpc role

6. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vpc domain domain-id

 

例:

switch(config)# vpc domain 5

switch(config-vpc-domain)#

設定する vPC ドメインの番号を入力します。vpc-domain コンフィギュレーション モードを開始します。

ステップ 3

system-priority priority

 

例:

switch(config-vpc-domain)# system-priority 4000

switch(config-vpc-domain)#

指定した vPC ドメインに割り当てるシステム プライオリティを入力します。指定できる値の範囲は、1 ~ 65535 です。デフォルト値は 32667 です。

ステップ 4

exit

 

例:

switch(config-vpc-domain)# exit

switch(config)#

vpc-domain コンフィギュレーション モードを終了します。

ステップ 5

show vpc role

 

例:

switch# show vpc role

(任意)vPC システム プライオリティを表示します。

ステップ 6

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次の例は、vPC ドメインのシステム プライオリティを手動で設定する方法を示します。

switch# configure terminal
switch(config)# vpc domain 5
switch(config-vpc-domain)# system-priority 4000

vPC ピア デバイス ロールの手動での設定

デフォルトでは、vPC ドメインと vPC ピア リンクの両側を設定した後に、Cisco NX-OS ソフトウェアによってプライマリ vPC ピア デバイスとセカンダリ vPC ピア デバイスが選出されます。ただし、vPC のプライマリ デバイスとして特定の vPC ピア デバイスを選出したい場合もあるでしょう。その場合、プライマリ デバイスにする vPC ピア デバイスのロール値を手動でその他の vPC ピア デバイスより低い値に設定してください。

vPC は、ロール プリエンプションはサポートしません。プライマリ vPC ピア デバイスに障害が発生すると、セカンダリ vPC ピア デバイスが機能上 vPC プライマリ デバイスを引き継ぎます。ただし、以前のプライマリ vPC が再び稼動し始めても、元の動作ロールは復元されません。

作業を開始する前に

vPC 機能がイネーブルになっていることを確認します。

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. vpc domain domain-id

3. role priority priority

4. exit

5. show vpc role

6. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vpc domain domain-id

 

例:

switch(config)# vpc domain 5

switch(config-vpc-domain)#

設定する vPC ドメインの番号を入力します。vpc-domain コンフィギュレーション モードを開始します。

ステップ 3

role priority priority

 

例:

switch(config-vpc-domain)# role priority 4000

switch(config-vpc-domain)#

vPC システム プライオリティに与えるロール プライオリティを入力します。指定できる値の範囲は 1 ~ 65636 で、デフォルト値は 32667 です。

ステップ 4

exit

 

例:

switch(config-vpc-domain)# exit

switch(config)#

vpc-domain コンフィギュレーション モードを終了します。

ステップ 5

show vpc role

 

例:

switch# show vpc role

(任意)vPC システム プライオリティを表示します。

ステップ 6

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次の例は、vPC ピア デバイスのロール プライオリティを手動で設定する方法を示します。

switch# configure terminal
switch(config)# vpc domain 5
switch(config-vpc-domain)# role priority 4000
 

シングルモジュール vPC でのトラッキング機能の設定

Cisco NX-OS Release 4.2 以降では、すべての vPC ピア リンクとコアに面するインターフェイスを単一モジュール上で設定しなければならない場合は、両方のプライマリ vPC ピア デバイス上の vPC ピア リンクのすべてのリンク上の、およびコアへのレイヤ 3 リンクに関連付けられているトラック オブジェクトとトラック リストを設定しなければなりません。いったんこの機能を設定したら、プライマリ vPC ピア デバイスに障害が発生した場合には、プライマリ vPC ピア デバイス上のすべての vPC リンクを、システムが自動的に停止します。システムが安定するまでは、このアクションにより、すべての vPC トラフィックが強制的にセカンダリ vPC ピア デバイスに送られます。

この設定は、両方の vPC ピア デバイスに置かなければなりません。さらに、いずれの vPC ピア デバイスも機能上のプライマリ vPC ピア デバイスになる場合があるため、両方の vPC ピア デバイスに同じ設定を置いておく必要があります。

作業を開始する前に

vPC 機能がイネーブルになっていることを確認します。

正しい Virtual Device Context(VDC; 仮想デバイス コンテキスト)を開始していることを確認します(または switchto vdc コマンドを使用します)。

トラック オブジェクトとトラック リストが設定済みであることを確認します。コアおよび vPC ピア リンクに接続されているすべてのインターフェイスが両方の vPC ピア デバイス上のトラックリンク オブジェクトに割り当てられていることを確認します。

手順の概要

1. configure terminal

2. vpc domain domain-id

3. track track-object-id

4. exit

5. show vpc

6. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vpc domain domain-id

 

例:

switch(config)# vpc domain 5

switch(config-vpc-domain)#

設定する vPC ドメインの番号を入力します。vpc-domain コンフィギュレーション モードを開始します。

ステップ 3

track track-object-id

 

例:

switch(config-vpc-domain)# track object 23

switch(config-vpc-domain)#

以前に関連するインターフェイスで設定されたトラックリスト オブジェクトを vPC ドメインに追加します。オブジェクト トラッキングとトラック リストの設定方法については、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x を参照してください。

ステップ 4

exit

 

例:

switch(config-vpc-domain)# exit

switch(config)#

vpc-domain コンフィギュレーション モードを終了します。

ステップ 5

show vpc brief

 

例:

switch# show vpc brief

(任意)トラッキング対象オブジェクトに関する情報を表示します。

ステップ 6

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次の例は、以前から設定されていたトラック リストオブジェクトを vPC ピア デバイス上の vPC ドメインに入れる方法を示します。

switch# configure terminal
switch(config)# vpc domain 5
switch(config-vpc-domain)# track object 5
 

リロード復元の設定

停電が発生すると、vPC は、スイッチがリロードされてピアの隣接が形成されるのを待ちます。この状況は、許容範囲内に収まらないほど長いサービスの中断に至る場合があります。Cisco Nexus 7000 シリーズ デバイスは、そのピアがオンラインになるのに失敗した場合に vPC サービスを復元するように設定できます。

作業を開始する前に

vPC 機能がイネーブルになっていることを確認します。

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. vpc domain domain-id

3. reload restore [ delay time-out ]

4. exit

5. show running-config vpc

6. show vpc consistency-parameters interface port-channel number

7. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vpc domain domain-id

 

例:

switch(config)# vpc domain 5

switch(config-vpc-domain)#

設定する vPC ドメインの番号を入力します。vpc-domain コンフィギュレーション モードを開始します。

ステップ 3

reload restore [ delay time-out ]

 

例:

switch(config-vpc-domain)# reload restore

vPC をそのピアが機能しないことを前提として vPC を稼動させるように設定します。デフォルトの遅延は 240 秒です。タイムアウト遅延は、240 ~ 3600 秒の範囲内で設定できます。

vPC を標準の動作にリセットするには、このコマンドの no 形式を使用します。

ステップ 4

exit

vpc-domain コンフィギュレーション モードを終了します。

ステップ 5

show running-config vpc

 

例:

switch# show running-config vpc

(任意)vPC に関する情報、特にリロード ステータスを表示します。

ステップ 6

show vpc consistency-parameters interface port-channel number

 

例:

switch# show vpc consistency-parameters interface port-channel 1

(任意)指定したインターフェイスの vPC の一貫性パラメータに関する情報を表示します。

ステップ 7

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

(注) リロード機能がイネーブルになっていることを確認するには、この手順を実行します。

次の例は、vPC リロード復元機能を設定し、それをスイッチのスタートアップ コンフィギュレーションに保存する方法を示します。

switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
switch(config)# vpc domain 5
switch(config-vpc-domain)# reload restore
Warning:
Enables restoring of vPCs in a peer-detached state after reload, will wait for 240
seconds (by default) to determine if peer is un-reachable
switch(config-vpc-domain)# exit
switch(config)# exit
switch# copy running-config startup-config
switch# show running-config vpc
 
!Command: show running-config vpc
!Time: Wed Mar 24 18:43:54 2010
 
version 5.0(2)
feature vpc
 
logging level vpc 6
vpc domain 5
reload restore
 

次の例は、一貫性パラメータを確認する方法を示します。

switch# show vpc consistency-parameters interface port-channel 1
Legend:
Type 1 : vPC will be suspended in case of mismatch
Name Type Local Value Peer Value
------------- ---- ----------- ---------------
STP Port Type 1 Default -
STP Port Guard 1 None -
STP MST Simulate PVST 1 Default -
mode 1 on -
Speed 1 1000 Mb/s -
Duplex 1 full -
Port Mode 1 trunk -
Native Vlan 1 1 -
MTU 1 1500 -
Allowed VLANs - 1-3967,4048-4093
Local suspended VLANs - - -
 

vPC ピア スイッチの設定

Cisco Nexus 7000 シリーズ デバイスは、一対の vPC デバイスがレイヤ 2 トポロジ内で 1 つの STP ルートとして現れるように設定することができます。ここでは、次の内容について説明します。

「純粋な vPC ピア スイッチ トポロジの設定」

「ハイブリッド vPC ピア スイッチ トポロジの設定」

純粋な vPC ピア スイッチ トポロジの設定

純粋な vPC ピア スイッチ トポロジを設定するには、 peer-switch コマンドを使用し、次に可能な範囲内で最高の(最も小さい)スパニング ツリー ブリッジ プライオリティ値を設定します。

作業を開始する前に

vPC 機能がイネーブルになっていることを確認します。

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. vpc domain domain-id

3. peer-switch

4. spanning-tree vlan vlan-range priority value

5. exit

6. show spanning-tree summary

7. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vpc domain domain-id

 

例:

switch(config)# vpc domain 5

switch(config-vpc-domain)#

設定する vPC ドメインの番号を入力します。vpc-domain コンフィギュレーション モードを開始します。

ステップ 3

peer-switch

 

例:

switch(config-vpc-domain)# peer-switch

vPC スイッチ ペアがレイヤ 2 トポロジ内で 1 つの STP ルートとして現れるようにします。

ピア スイッチ vPC トポロジをディセーブルにするには、このコマンドの no 形式を使用します。

ステップ 4

spanning-tree vlan vlan-range priority value

 

例:

switch(config)# spanning-tree vlan 1 priority 8192

VLAN のブリッジ プライオリティを設定します。有効な値は、4096 の倍数です。デフォルト値は 32768 です。

ステップ 5

exit

vpc-domain コンフィギュレーション モードを終了します。

ステップ 6

show spanning-tree summary

 

例:

switch# show spanning-tree summary

(任意)スパニング ツリー ポートの状態の概要を表示します。これに、vPC ピア スイッチも含まれます。

ステップ 7

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次の例は、純粋な vPC ピア スイッチ トポロジを設定する方法を示します。

switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
switch(config)# vpc domain 5

switch(config-vpc-domain)# peer-switch

2010 Apr 28 14:44:44 switch %STP-2-VPC_PEERSWITCH_CONFIG_ENABLED: vPC peer-switch configuration is enabled.Please make sure to configure spanning tree "bridge" priority as per recommended guidelines to make vPC peer-switch operational.

switch(config-vpc-domain)# exit

switch(config)# spanning-tree vlan 1 priority 8192

 

ハイブリッド vPC ピア スイッチ トポロジの設定

spanning-tree pseudo-information コマンド(『 Cisco Nexus 7000 Series NX-OS Layer 2 Switching Command Reference, Release 5.x を参照してください)を使用して STP VLAN ベースのロード バランシング条件を満たすように代表ブリッジ IC を変更した後、ルート ブリッジ ID を最高のブリッジ プライオリティよりもよい値に変更することにより、ハイブリッド vPC または非 vPC ピア スイッチ トポロジを設定することができます。次に、ピア スイッチをイネーブルにします。

作業を開始する前に

vPC 機能がイネーブルになっていることを確認します。

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. spanning-tree pseudo-information

3. vlan vlan-range designated priority value

4. vlan vlan-range root priority value

5. vpc domain domain-id

6. peer-switch

7. exit

8. show spanning-tree summary

9. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

spanning-tree pseudo-information

 

例:

switch(config)# spanning-tree pseudo-information

switch(config-pseudo)#

スパニング ツリー疑似情報を設定します。

ステップ 3

vlan vlan-id designated priority priority

 

例:

switch(config-pseudo)# vlan 1 designated priority 8192

VLAN の指定ブリッジ プライオリティを設定します。有効な値は、0 ~ 61440 の範囲内の 4096 の倍数です。

ステップ 4

vlan vlan-id root priority priority

 

例:

switch(config-pseudo)# vlan 1 root priority 4096

VLAN のルート ブリッジ プライオリティを設定します。有効な値は、0 ~ 61440 の範囲内の 4096 の倍数です。

ステップ 5

vpc domain domain-id

 

例:

switch(config)# vpc domain 5

switch(config-vpc-domain)#

設定する vPC ドメインの番号を入力します。vpc-domain コンフィギュレーション モードを開始します。

ステップ 6

peer-switch

 

例:

switch(config-vpc-domain)# peer-switch

vPC スイッチ ペアがレイヤ 2 トポロジ内で 1 つの STP ルートとして現れるようにします。

ピア スイッチ vPC トポロジをディセーブルにするには、このコマンドの no 形式を使用します。

ステップ 7

exit

vpc-domain コンフィギュレーション モードを終了します。

ステップ 8

show spanning-tree summary

 

例:

switch# show spanning-tree summary

(任意)スパニング ツリー ポートの状態の概要を表示します。これに、vPC ピア スイッチも含まれます。

ステップ 9

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次の例は、ハイブリッド vPC ピア スイッチ トポロジを設定する方法を示します。

switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.

switch(config)# spanning-tree pseudo-information

switch(config-pseudo)# vlan 1 designated priority 8192

switch(config-pseudo)# vlan 1 root priority 4096

switch(config-pseudo)# exit

switch(config)# vpc domain 5

switch(config-vpc-domain)# peer-switch

 

vPC 設定の確認

vPC 設定情報を表示するには、次の作業のいずれかを行います。

 

コマンド
目的

show feature

vPC がイネーブルになっているかどうかを表示します。

show vpc brief

vPC に関する簡単な情報を表示します。

show vpc consistency-parameters

すべての vPC インターフェイスの間で一貫していなければならないパラメータのステータスを表示します。

show running-config vpc

vPC の実行コンフィギュレーションの情報を表示します。

show port-channel capacity

設定されているポート チャネルの数、およびデバイス上でまだ使用可能なポート チャネル数を表示します。

show vpc statistics

vPC に関する統計情報を表示します。

show vpc peer-keepalive

ピアキープアライブ メッセージに関する情報を表示します。

show vpc role

ピア ステータス、ローカル デバイスのロール、vPC システム MAC アドレスとシステム プライオリティ、およびローカル vPC デバイスの MAC アドレスとプライオリティを表示します。

これらのコマンドの出力フィールドの詳細については、『 Cisco Nexus 7000 Series NX-OS Interfaces Command Reference, Release 5.x を参照してください。

vPC 統計情報の監視

vPC 統計情報を表示するには、 show vpc statistics コマンドを使用します。


) このコマンドは、現在作業している vPC ピア デバイスの vPC 統計情報しか表示しません。


vPC の設定例

次の例は、デバイス A 上で図 7-5 に示すとおりに vPC を設定する方法を示します。

図 7-5 vPC の設定例

 


ステップ 1 vPC および LACP をイネーブルにします。

switch# configure terminal
switch(config)# feature vPC
switch(config)# feature lacp
 

ステップ 2 (任意)ピア リンクにするインターフェイスの 1 つを専用モードに設定します。

switch(config)# interface ethernet 7/1, ethernet 7/3, ethernet 7/5.ethernet 7/7
switch(config-if)# shutdown
switch(config-if)# exit
switch(config)# interface ethernet 7/1
switch(config-if)# rate-mode dedicated
switch(config-if)# no shutdown
switch(config-if)# exit
switch(config)#
 

ステップ 3 (任意)ピア リンクにする 2 つ目の冗長インターフェイスを専用モードに設定します。

switch(config)# interface ethernet 7/2, ethernet 7/4, ethernet 7/6.ethernet 7/8
switch(config-if)# shutdown
switch(config-if)# exit
switch(config)# interface ethernet 7/2
switch(config-if)# rate-mode dedicated
switch(config-if)# no shutdown
switch(config-if)# exit
switch(config)#
 

ステップ 4 ピア リンクに入れる 2 つのインターフェイス(冗長性のために)をアクティブ レイヤ 2 LACP ポート チャネルに設定します。

switch(config)# interface ethernet 7/1-2
switch(config-if)# switchport
switch(config-if)# switchport mode trunk
switch(config-if)# switchport trunk allowed vlan 1-50
switch(config-if)# switchport trunk native vlan 20
switch(config-if)# channel-group 20 mode active
switch(config-if)# exit

 

ステップ 5 VLAN を作成し、イネーブルにします。

switch(config)# vlan 1-50
switch(config-vlan)# no shutdown
switch(config-vlan)# exit

 

ステップ 6 vPC ピアキープアライブ リンク用の独立した VEF を作成し、レイヤ 3 インターフェイスをその VRF に追加します。

switch(config)# vrf context pkal
switch(config-vrf)# exit
switch(config)# interface ethernet 8/1
switch(config-if)# vrf member pkal
switch(config-if)# ip address 172.23.145.218/24
switch(config-if)# no shutdown
switch(config-if)# exit

 

ステップ 7 vPC ドメインを作成し、vPC ピアキープアライブ リンクを追加します。

switch(config)# vpc domain 1
switch(config-vpc-domain)# peer-keepalive destination 172.23.145.217 source 172.23.145.218 vrf pkal
switch(config-vpc-domain)# exit

 

ステップ 8 vPC ピア リンクを設定します。

switch(config)# interface port-channel 20
switch(config-if)# vpc peer-link
switch(config-if)# exit
switch(config)#

 

ステップ 9 vPC のダウンストリーム デバイスへのポート チャネルのインターフェイスを設定します。

switch(config)# interface ethernet 7/9
switch(config-if)# switchport mode trunk
switch(config-if)# allowed vlan 1-50
switch(config-if)# native vlan 20
switch(config-if)# channel-group 50 mode active
switch(config-if)# exit
switch(config)# interface port-channel 50
switch(config-if)# vpc 50
switch(config-if)# exit
switch(config)#
 

ステップ 10 設定を保存します。

switch(config)# copy running-config startup-config

) まずポート チャネルを設定する場合は、それがレイヤ 2 ポート チャネルであることを確認してください。



 

デフォルト設定

表 7-1 に、vPC パラメータのデフォルト設定を示します。

 

表 7-1 デフォルト vPC パラメータ

パラメータ
デフォルト

vPC システム プライオリティ

32667

vPC ピアキープアライブ メッセージ

ディセーブル

vPC ピアキープアライブ間隔

1 秒

vPC ピアキープアライブ タイムアウト

5 秒

vPC ピアキープアライブ UDP ポート

3200

その他の関連資料

vPC を実装する方法の詳細については、次の項目を参照してください。

「関連資料」

「標準規格」

「管理情報ベース(MIB)」

関連資料

関連項目
参照先

ポート チャネルの設定

「ポート チャネルの設定」

レイヤ 2 インターフェイスの設定

「レイヤ 2 インターフェイスの設定」

レイヤ 3 インターフェイスの設定

「レイヤ 3 インターフェイスの設定」

共有および専用ポート

「基本インターフェイス パラメータの設定」

コマンド リファレンス

『Cisco Nexus 7000 Series NX-OS Interfaces Command Reference, Release 5.x

インターフェイス

『Cisco DCNM Interfaces Configuration Guide, Release 5.x

システム管理

『Cisco Nexus 7000 Series NX-OS System Management Configuration Guide, Release 5.x

ハイ アベイラビリティ

『Cisco Nexus 7000 Series NX-OS High Availability and Redundancy Guide, Release 5.x

VDC

『Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide, Release 5.x

リリース ノート

『Cisco Nexus 7000 Series NX-OS Release Notes, Release 5.x

標準規格

標準規格
タイトル

IEEE 802.3ad

--

管理情報ベース(MIB)

管理情報ベース(MIB)
MIB リンク

IEEE8023-LAG-CAPABILITY

CISCO-LAG-MIB

Management Information Base(MIB; 管理情報ベース)を検索およびダウンロードするには、次の URL にアクセスしてください。

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

vPC の設定機能の履歴

表 7-2 は、この機能のリリースの履歴です。

 

表 7-2 vPC の設定機能の履歴

機能名
リリース
機能情報

vPC

4.1(2)

これらの機能が導入されました。

vPC

4.1(4)

サポートが 192 vPC にまで増えました。

vPC

4.2(1)

サポートが 256 vPC にまで増えました。

vPC

4.2(1)

確実にすべてのパケットがデバイスのゲートウェイ MAC アドレスを使用するようにするために、 peer-gateway コマンドが追加されました。

vPC

4.2(1)

vPC ピア リンクに障害が発生しても、確実に VLAN インターフェイスが稼動したままになるようにするために、 dual-active exclude interface-vlan コマンドが追加されました。

vPC

4.2(1)

リロード後にルーティング テーブルが収束できるまで vPC セカンダリ デバイスの稼動を遅延させるための delay restore コマンドが追加されました。

vPC

5.0(2)

vPC スイッチがそのピアが機能しないことを前提として vPC を稼動させ始めるように設定する reload restore コマンドが追加されました。

vPC

5.0(2)

一対の vPC スイッチがレイヤ 2 トポロジ内で 1 つの STP ルートとして現れることを可能にする peer-switch コマンドが追加されました。