Cisco Nexus 7000 シリーズ NX-OS インターフェイ ス コンフィギュレーション ガイド リリース 5.x
IP トンネルの設定
IP トンネルの設定
発行日;2012/02/06 | 英語版ドキュメント(2011/12/09 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

IP トンネルの設定

IP トンネルについて

IP トンネルの概要

GRE トンネル

Path MTU Discovery(PMTUD)

バーチャライゼーションのサポート

ハイ アベイラビリティ

IP トンネルのライセンス要件

IP トンネルの前提条件

注意事項および制約事項

IP トンネルの設定

トンネリングのイネーブル化

トンネル インターフェイスの作成

GRE トンネルの設定

Path MTU Discovery のイネーブル化

トンネル インターフェイスに割り当てる VRF メンバシップ

IP トンネル設定情報の確認

IP トンネルの設定例

デフォルト設定

その他の関連資料

関連資料

標準規格

IP トンネル設定の機能履歴

IP トンネルの設定

この章では、Cisco Nexus 7000 シリーズ デバイスで Generic Route Encapsulation(GRE)を使って IP トンネルを設定する手順について説明します。

この章では、次の内容について説明します。

「IP トンネルについて」

「IP トンネルのライセンス要件」

「IP トンネルの前提条件」

「注意事項および制約事項」

「IP トンネルの設定」

「IP トンネル設定情報の確認」

「IP トンネルの設定例」

「デフォルト設定」

「その他の関連資料」

「IP トンネル設定の機能履歴」

IP トンネルについて

IP トンネルを使うと、同じレイヤまたは上位レイヤ プロトコルをカプセル化して、2 台のデバイス間で作成されたトンネルを通じて IP に結果を転送できます。

ここでは、次の内容について説明します。

「IP トンネルの概要」

「GRE トンネル」

「Path MTU Discovery(PMTUD)」

「バーチャライゼーションのサポート」

「ハイ アベイラビリティ」

IP トンネルの概要

IP トンネルは次の 3 つの主要コンポーネントで構成されています。

パッセンジャ プロトコル:カプセル化する必要があるプロトコル。パッセンジャ プロトコルの例には IPv4 があります。

キャリア プロトコル:パッセンジャ プロトコルをカプセル化するために使用するプロトコル。Cisco NX-OS はキャリア プロトコルとして GRE をサポートします。

トランスポート プロトコル:カプセル化したプロトコルを伝送するために使用するプロトコル。トランスポート プロトコルの例には IPv4 があります。

IP トンネルは IPv4 などのパッセンジャ プロトコルを使用し、このプロトコルを GRE などのキャリア プロトコル内にカプセル化します。次に、このキャリア プロトコルは IPv4 などのトランスポート プロトコルを通じてデバイスから送信されます。

対応する特性を持つトンネル インターフェイスをトンネルの両端にそれぞれ設定します。

詳細については、「IP トンネルの設定」を参照してください。

設定の前にトンネル機能をイネーブルにする必要があります。Cisco NX-OS Release 4.2 から、システムは機能のディセーブル化の前に自動的にチェックポイントを作成するため、このチェックポイントにロールバックできます。コールバックとチェックポイントについては、『 Cisco Nexus 7000 Series NX-OS System Management Configuration Guide, Release 5.x を参照してください。

Cisco NX-OS Release 4.2 から、ある Virtual Device Context(VDC; 仮想デバイス コンテキスト)に設定されたトンネルは、同じ番号を持つ別の VDC に設定されたトンネルとは区別されます。たとえば、VDC 1 のトンネル 0 は VDC 2 のトンネル 0 とは異なります。

Cisco NX-OS Release 4.2 から、トンネル送信元 IP アドレスおよび宛先 IP アドレスは、同一の Virtual Routing and Forwarding(VRF; 仮想ルーティング/転送)にある必要があります。

GRE トンネル

Generic Routing Encapsulation(GRE)をさまざまなパッセンジャ プロトコルのキャリア プロトコルとして使用できます。

図 8-1 に、GRE トンネルの IP トンネル コンポーネントを示します。オリジナルのパッセンジャ プロトコル パケットは GRE ペイロードとなり、デバイスはパケットに GRE ヘッダーを追加します。次にデバイスはトランスポート プロトコル ヘッダーをパケットに追加して送信します。

図 8-1 GRE Protocol Data Unit(PDU)

 

Path MTU Discovery(PMTUD)

Path Maximum Transmission Unit(MTU; 最大伝送ユニット)Discovery(PMTUD)は、パケットの発信元から宛先へのパスに沿って最小 MTU を動的に決定することで、2 つのエンドポイント間のパスのフラグメンテーションを防ぎます。PMTUD は、パケットにフラグメンテーションが必要であるという情報がインターフェイスに届くと、接続に対する送信 MTU 値を減らします。

PMTUD をイネーブルにすると、インターフェイスはトンネルを通過するすべてのパケットに Don't Fragment(DF)ビットを設定します。トンネルに入ったパケットがそのパケットの MTU 値よりも小さい MTU 値を持つリンクを検出すると、リモート リンクはそのパケットをドロップし、パケットの送信元に Internet Control Message Protocol(ICMP; インターネット制御メッセージ プロトコル)メッセージを返します。このメッセージには、フラグメンテーションが要求されたこと(しかし許可されなかったこと)と、パケットをドロップしたリンクの MTU が含まれています。


) トンネル インターフェイスの PMTUD は、トンネル エンドポイントがトンネルのパスでデバイスによって生成される ICMP メッセージを受信することを要求します。ファイアウォール接続を通じて PMTUD を使用する前に、ICMP メッセージが受信できることを確認してください。


バーチャライゼーションのサポート

IP トンネルはデフォルトの Virtual Device Context(VDC; 仮想デバイス コンテキスト)およびデフォルトの Virtual Routing and Forwarding(VRF; 仮想ルーティング/転送)インスタンスにだけ設定できます。

Cisco NX-OS Release 4.2 から、トンネル インターフェイスは Virtual Routing and Forwarding(VRF; 仮想ルーティング/転送)インスタンスのメンバとして、および、VDC のメンバとして設定できます。特に別の VDC や VRF を設定しない限り、デフォルトでは、Cisco NX-OS のデフォルトの VDC およびデフォルトの VRF が使用されます。ある VDC に設定されたトンネルは、同じ番号を持つ別の VDC に設定されたトンネルとは区別されます。たとえば、VDC 1 のトンネル 0 は VDC 2 のトンネル 0 とは異なります。

トンネル送信元 IP アドレスおよび宛先 IP アドレスは、同一の VRF にある必要があります。VRF がトンネル宛先の検索に何を使用するかも指定できます。この VRF は、トンネル送信元 IP アドレスの VRF と一致しなければなりません。

VDC については、 『Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide, Release 5.x を、VRF については、 『Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x を参照してください。

ハイ アベイラビリティ

IP トンネルはステートフル再起動をサポートします。ステートフル再起動はスーパーバイザ切り替え時に発生します。切り替え後、Cisco NX-OS は実行時の設定を適用します。

IP トンネルのライセンス要件

次の表に、この機能のライセンス要件を示します。

 

製品
ライセンス要件

Cisco NX-OS

IP トンネルには Enterprise Services ライセンスが必要です。Cisco NX-OS ライセンス方式について、およびライセンスの取得方法と適用方法についての詳細については、 『Cisco Nexus 7000 Series NX-OS Licensing Guide, Release 5.x を参照してください。

IP トンネルの前提条件

IP トンネルには次の前提条件があります。

IP トンネルを設定するための TCP/IP に関する基礎知識があること。

スイッチにログ オンしていること。

Cisco NX-OS の Enterprise Services ライセンスをインストールしていること。

IP トンネルを設定してイネーブルにする前にデバイスのトンネリング機能をイネーブルにしておくこと。

注意事項および制約事項

IP トンネルには、次の注意事項と制約事項があります。

Cisco NX-OS は、IETF RFC 2784 に定義されている GRE ヘッダーをサポートします。Cisco NX-OS は、トンネル キーと IETF RFC 1701 のその他のオプションをサポートしません。

トンネル インターフェイスとトンネル転送の両方は、同一の VRF 内になければなりません。そうでない場合は、ハードウェア データ パスにエラーが発生します。

IP トンネルの設定

ここでは、次の内容について説明します。

「トンネリングのイネーブル化」

「トンネル インターフェイスの作成」

「GRE トンネルの設定」

「Path MTU Discovery のイネーブル化」

「トンネル インターフェイスに割り当てる VRF メンバシップ」


) Cisco IOS CLI を熟知している場合は、この機能の Cisco NX-OS コマンドと使用する Cisco IOS コマンドが異なる場合もある点に注意してください。


トンネリングのイネーブル化

IP トンネルを設定する前にトンネリング機能をイネーブルにする必要があります。

手順の概要

1. configure terminal

2. feature tunnel

3. exit

4. show feature

5. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

feature tunnel

 

例:

switch(config)# feature tunnel

デバイスのトンネルをイネーブルにします。

ステップ 3

exit

 

例:

switch(config)# exit

switch#

コンフィギュレーション モードを終了します。

ステップ 4

show feature

 

例:

switch# show feature

(任意)デバイス上でイネーブルになっている機能を表示します。

ステップ 5

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

トンネル インターフェイスの作成

トンネル インターフェイスを作成して、この論理インターフェイスを IP トンネルに設定できます。

作業を開始する前に

トンネル インターフェイスとトンネル宛先の両方が、同一の VRF 内にあることが必要です。

トンネリング機能がイネーブルになっていることを確認します。

手順の概要

1. configure terminal

2. interface tunnel number

3. tunnel source { ip-address | interface-name }

4. tunnel destination { ip-address | host-name }

5. tunnel use-vrf vrf-name

6. show interfaces tunnel number

7. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface tunnel number

 

例:

switch(config)# interface tunnel 1

switch(config-if)#

新しいトンネル インターフェイスを作成します。

ステップ 3

tunnel source { ip-address | interface-name }

 

例:

switch(config-if)# tunnel source ethernet 1/2

この IP トンネルの送信元アドレスを設定します。

ステップ 4

tunnel destination { ip-address | host-name }

 

例:

switch(config-if)# tunnel destination 192.0.2.1

この IP トンネルの宛先アドレスを設定します。

ステップ 5

tunnel use-vrf vrf-name

 

例:

switch(config-if)# tunnel vrf blue

(任意)トンネル IP 宛先アドレスの検索に設定された VRF を使用します。

ステップ 6

show interfaces tunnel number

 

:

switch(config-if)# show interfaces tunnel 1

(任意)トンネル インターフェイスの統計情報を表示します。

ステップ 7

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

トンネル インターフェイスおよびすべての関連する設定を削除するには、 no interface tunnel コマンドを使用します。

 

コマンド
目的

no interface tunnel number

 

例:

switch(config)# no interface tunnel 1

トンネル インターフェイスおよび関連する設定を削除します。

次のパラメータを任意に設定し、インターフェイス コンフィギュレーション モードでトンネルを調整します。

 

コマンド
目的

description string

 

例:

 

switch(config-if)# description GRE tunnel

トンネルの説明を設定します。

mtu value

 

例:

 

switch(config-if)# mtu 1400

インターフェイス上で送信する IP パケットの MTU を設定します。

tunnel ttl value

 

例:

 

switch(config-if)# tunnel ttl 100

トンネルの Time-to-Live(TTL; 存続可能時間)値を設定します。有効な範囲は 1 ~ 255 です。

次に、トンネル インターフェイスを作成する例を示します。

switch# configure terminal

switch(config)# i nterface tunnel 1

switch(config-if)# tunnel source ethernet 1/2

switch(config-if)# tunnel destination 192.0.2.1

switch(config-if)# copy running-config startup-config

 

GRE トンネルの設定

トンネル インターフェイスを GRE トンネル モードに設定できます。

作業を開始する前に

トンネリング機能がイネーブルになっていることを確認します。

手順の概要

1. configure terminal

2. interface tunnel number

3. tunnel mode gre ip

4. show interfaces tunnel number

5. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface tunnel number

 

例:

switch(config)# interface tunnel 1

switch(config-if)#

トンネル インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

tunnel mode gre ip

 

例:

switch(config-if)# tunnel mode gre ip

このトンネル モードを GRE に設定します。

ステップ 4

show interfaces tunnel number

 

:

switch(config-if)# show interfaces tunnel 1

(任意)トンネル インターフェイスの統計情報を表示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、トンネル インターフェイスに GRE を設定し、GRE トンネルにキープアライブを設定する方法を示します。

switch# configure terminal

switch(config)# i nterface tunnel 1

switch(config-if)# tunnel mode gre ip

switch(config-if)# copy running-config startup-config

 

Path MTU Discovery のイネーブル化

トンネルの Path MTU Discovery をイネーブルにするには、インターフェイス コンフィギュレーション モードで tunnel path-mtu discovery コマンドを使用します。

 

コマンド
目的

tunnel path-mtu-discovery [ age-timer min ] [ min-mtu bytes ]

:

switch(config-if)# tunnel path-mtu-discovery 25 1500

トンネル インターフェイスで Path MTU Discovery(PMTUD)をイネーブルにします。次のパラメータがあります。

mins :分数を指定します。有効な範囲は 10 ~ 30 です。デフォルトは 10 です。

mtu-bytes :認識される最小 MTU。有効な範囲は 92 ~ 65535 です。デフォルトは 92 です。

トンネル インターフェイスに割り当てる VRF メンバシップ

VRF にトンネル インターフェイスを追加できます。

作業を開始する前に

トンネリング機能がイネーブルになっていることを確認します。

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

VRF にインターフェイスを設定してから、トンネル インターフェイスに IP アドレスを割り当てます。

手順の概要

1. configure terminal

2. interface tunnel number

3. vrf member vrf-name

4. ip-address ip-prefix/length

5. show vrf [ vrf-name ] interface interface-type number

6. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface tunnel number

 

:

switch(config)# interface tunnel 0

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

vrf member vrf-name

 

例:

switch(config-if)# vrf member RemoteOfficeVRF

このインターフェイスを VRF に追加します。

ステップ 4

ip address ip-prefix/length

 

例:

switch(config-if)# ip address 192.0.2.1/16

このインターフェイスに IP アドレスを設定します。このステップは、このインターフェイスを VRF に割り当ててから実行します。

ステップ 5

show vrf [ vrf-name ] interface interface-type number

 

:

switch(config-vrf)# show vrf Enterprise interface tunnel 0

(任意)VRF の内容を表示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、トンネル インターフェイスを VRF に追加する例を示します。

switch# configure terminal

switch(config)# interface tunnel 0

switch(config-if)# vrf member RemoteOfficeVRF

switch(config-if)# ip address 209.0.2.1/16

switch(config-if)# copy running-config startup-config

IP トンネル設定情報の確認

IP トンネルの設定情報を表示するには、次のコマンドを使用します。

 

コマンド
目的

show interface tunnel number

トンネル インターフェイスの設定を表示します(MTU、プロトコル、トランスポート、VRF)。入力および出力パケット、バイト、パケット レートを表示します。

show interface tunnel number brief

トンネル インターフェイスの動作状態、IP アドレス、カプセル化のタイプ、MTU を表示します。

show interface tunnel number description

トンネル インターフェイスに設定されている説明を表示します。

show interface tunnel number status

トンネル インターフェイスの動作状態を表示します。

show interface tunnel number status err-disabled

トンネル インターフェイスの errdisable 状態を表示します。

IP トンネルの設定例

次に、簡単な GRE トンネルの例を示します。イーサネット 1/2 はルータ A のトンネル送信元およびルータ B のトンネル宛先です。イーサネット インターフェイス 2/1 はルータ B のトンネル送信元およびルータ A のトンネル宛先です。

ルータ A:

feature tunnel
interface tunnel 0
ip address 209.165.20.2/8
tunnel source ethernet 1/2
tunnel destination 192.0.2.2
tunnel mode gre ip
tunnel path-mtu-discovery 25 1500
interface ethernet1/2
ip address 192.0.2.55/8
 

ルータ B:

feature tunnel
interface tunnel 0
ip address 209.165.20.1/8
tunnel source ethernet2/1
tunnel destination 192.0.2.55
tunnel mode gre ip
interface ethernet 2/1
ip address 192.0.2.2/8

デフォルト設定

表 8-1 に、IP トンネル パラメータのデフォルト設定を示します。

 

表 8-1 デフォルトの IP トンネル パラメータ

パラメータ
デフォルト

Path MTU Discovery 経過時間タイマー

10 分

Path MTU Discovery 最小 MTU

64

トンネル機能

ディセーブル

その他の関連資料

IP トンネルの実装に関する追加情報については、次の項を参照してください。

「関連資料」

「標準規格」

 

関連資料

関連項目
参照先

IP トンネル コマンド

Cisco Nexus 7000 Series NX-OS Interfaces Command Reference, Release 5.x

IP フラグメンテーションおよび Path MTU Discovery

『Resolve IP Fragmentation, MTU, MSS, and PMTUD Issues with GRE and IPSEC』

標準規格

標準規格
タイトル

この機能でサポートされる新規または改訂された標準規格はありません。また、この機能による既存の標準規格サポートの変更はありません。

--

IP トンネル設定の機能履歴

表 8-2 は、この機能のリリースの履歴です。

 

表 8-2 IP トンネル設定の機能履歴

機能名
リリース
機能情報

IP トンネル

4.0(1)

この機能が導入されました。

デフォルト以外の VDC および VRF 内の IP トンネル

4.2(1)

この機能が導入されました。