Cisco Nexus 7000 シリーズ NX-OS インターフェイ ス コンフィギュレーション ガイド リリース 5.x
双方向フォワーディング検出(BFD)の設定
双方向フォワーディング検出(BFD)の設定
発行日;2012/02/06 | 英語版ドキュメント(2012/01/22 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

双方向フォワーディング検出(BFD)の設定

BFD について

非同期モード

BFD 障害検出

分散モード

BFD エコー モード

セキュリティ

ハイ アベイラビリティ

バーチャライゼーションのサポート

BFD のライセンス要件

BFD の前提条件

注意事項および制約事項

デフォルト設定

BFD の設定

階層の設定

BFD 設定のタスク フロー

BFD 機能のイネーブル化

グローバル BFD パラメータの設定

インターフェイス上での BFD の設定

ポート チャネル上での BFD の設定

BFD エコー モードの設定

サブインターフェイス上での BFD の最適化

ルーティング プロトコルの BFD サポートの設定

BGP 上での BFD の設定

EIGRP 上での BFD の設定

OSPF 上での BFD の設定

IS-IS での BFD の設定

インターフェイス上での BFD のディセーブル化

ホットスタンバイ ルータ プロトコル(HSRP)での BFD の設定

Protocol Independent Multicast(PIM)上での BFD の設置

スタティック ルータ上での BFD の設定

BFD 設定の確認

BFD のモニタ

BFD の設定例

その他の関連資料

関連資料

RFC

BFD 機能の履歴

双方向フォワーディング検出(BFD)の設定

この章では、Cisco NX-OS デバイスで Bidirectional Forwarding Detection(BFD; 双方向フォワーディング検出)を設定する方法について説明します。

この章では、次の内容について説明します。

「BFD について」

「BFD のライセンス要件」

「BFD の前提条件」

「注意事項および制約事項」

「デフォルト設定」

「BFD の設定」

「BFD 設定の確認」

「BFD のモニタ」

「BFD の設定例」

「その他の関連資料」

「BFD 機能の履歴」

BFD について

BFD は、メディア タイプ、カプセル化、トポロジ、およびルーティング プロトコルの転送パス障害を高速で検出するように設計された検出プロトコルです。BFD を使用することで、さまざまなプロトコルの Hello メカニズムにより、変動速度ではなく一定速度で転送パス障害を検出できます。BFD によって、ネットワーク プロファイリングおよびプランニングが容易になり、再収束時間の整合性が保たれ、予測可能になります。

BFD は、2 個の隣接するデバイス間のサブセカンド障害検出を行います。さらに、BFD の負荷の一部をサポート モジュールのデータ プレーンに分散できるため、プロトコル Hello メッセージに比べて CPU への集中を緩和できます。

ここでは、次の内容について説明します。

「非同期モード」

「BFD 障害検出」

「分散モード」

「BFD エコー モード」

「セキュリティ」

「ハイ アベイラビリティ」

「バーチャライゼーションのサポート」

非同期モード

Cisco NX-OS は、BFD 非同期モードをサポートします。BFD 非同期モードでは、2 個の隣接するデバイス間で BFD 制御パケットが送信され、デバイス間の BFD ネイバー セッションがアクティベートされ、維持されます。両方のデバイス(つまり BFD ネイバー)に BFD を設定します。インターフェイスおよび適切なプロトコルで一度 BFD がイネーブルになると、Cisco NX-OS は BFD セッションを作成し、BFD セッション パラメータをネゴシエートし、BFD 制御パケットをネゴシエートされた間隔で各 BFD ネイバーに送信し始めます。BFD セッション パラメータには次の項目が含まれます。

指定最小転送間隔:デバイスが予期する BFD Hello メッセージの送信間隔。

必要最小受信間隔:デバイスが別の BFD デバイスから BFD Hello メッセージを受信できる最少間隔。

検出乗数:転送パスの障害を検出するまでに喪失した、別の BFD デバイスからの BFD Hello メッセージの数。

図 5-1 に BFD セッション確立方法を示します。図では、OSPF と BFD を実行する 2 個のルータがある単純なネットワークを示しています。OSPF がネイバーを検出したとき(1)、ローカル BFD プロセスに要求を送信して、OSPF ネイバー ルータと BFD ネイバー セッションを開始します(2)。OSPF ネイバー ルータとの BFD ネイバー セッションが確立されました(3)。

図 5-1 BFD ネイバー関係の確立

BFD 障害検出

一度 BFD セッションが確立され、タイマー ネゴシエーションが終了すると、BFD ネイバーは、より速い速度の場合を除き IGP Hello プロトコルと同じ動作をする BFD 制御パケットを送信し、活性度を検出します。BFD は障害を検出しますが、プロトコルが障害の発生したピアをバイパスするための処置を行う必要があります。

BFD は転送パスに障害を検出したとき、障害検出通知を BFD 対応プロトコルに送信します。ローカル デバイスは、プロトコル再計算プロセスを開始してネットワーク全体の収束時間を削減できます。

図 5-2 は、ネットワークで障害が発生したとき(1)に何が起こるかを示しています。OSPF ネイバー ルータとの BFD ネイバー セッションが終了されます(2)。BFD はローカル OSPF プロセスに BFD ネイバーが到達可能ではなくなったことを通知します(3)。ローカル OSPF プロセスは、OSPF ネイバー関係を終了します(4)。代替パスが利用できる場合は、ルータはすぐにコンバージェンスを開始します。


) BFD 障害検出は、サブセカンド タイムで発生し、同じ障害を OSPF Hello メッセージよりも高速で検出できます。


図 5-2 OSPF ネイバー関係の終了

分散モード

Cisco NX-OS は、BFD 動作を互換モジュールに分散できます。このプロセスは、BFD パケット処理の CPU 負荷を BFD ネイバーに接続された各モジュールに移します。すべての BFD セッション トラフィックはモジュール CPU で発生します。BFD 障害が検出されたとき、モジュールはスーパーバイザに通知します。

BFD 分散モードは、次の Cisco Nexus 7000 シリーズ モジュールでサポートされます。

Cisco Nexus 7000 シリーズ 48 ポート 10/100/1000 イーサネット モジュール(N7K-M148GT-11)

Cisco Nexus 7000 シリーズ 32 ポート 10 ギガビット イーサネット モジュール、80Gbps ファブリック(N7K-M132XP-12)

Cisco Nexus 7000 シリーズ 8 ポート 10 ギガビット イーサネット モジュール、80Gbps ファブリック


) その他のすべてのモジュールは、スーパーバイザか、または別のサポート モジュールを使用して、BFD パケット処理を行います。


BFD エコー モード

BFD エコー モードは、エコー パケットを転送エンジンからリモート BFD ネイバーに送信します。BFD ネイバーは、検出を行う目的でエコー パケットを同じパスを通じて送り返します。BFD ネイバーは実際のエコー パケットの転送には関与しません。エコー機能および転送エンジンは、検出プロセスに責任を持ちます。BFD は、スロー タイマーを使用することで、2 個の BFD ネイバー間で送信される BFD 制御パケットの数を削減できます。また、転送エンジンはリモート システムに影響を与えることなく、リモート(ネイバー)システム上の転送パスをテストします。このため、インターパケット遅延の変動は小さくなり、障害検出は高速になります。

エコー モードは、両方の BFD ネイバーがエコー モードを実行する場合、非対照ではありません。

セキュリティ

Cisco NX-OS は、パケット Time to Live(TTL; 存続可能時間)値を使用して、BFD パケットが隣接する BFD ピアから送信されたことを確認します。すべての非同期要求パケットおよびエコー要求パケットに対して、BFD ネイバーは TTL 値を 255 に設定し、ローカル BFD プロセスは受信パケットの処理の前に TTL 値が 255 であることを確認します。エコー応答パケットの場合、BFD は TTL 値を 254 に設定します。

ハイ アベイラビリティ

BFD は、ステートレスな再起動、および In-Service Software Upgrade(ISSU; インサービス ソフトウェア アップグレード)をサポートします。ISSU では、転送に影響を与えることなくソフトウェアをアップグレードできます。リブートまたはスーパーバイザ スイッチオーバーの後に、Cisco DC-OS は実行コンフィギュレーションを適用し、BFD はすぐに制御パケットを BFD ピアに送信します。

バーチャライゼーションのサポート

BFD は Virtual Routing and Forwarding(VRF; 仮想ルーティング/転送)インスタンスをサポートします。VRF は仮想デバイス コンテキスト(VDC)内に存在します。VDC や VRF を特別に設定しない限り、デフォルトでは、Cisco DC-OS のデフォルトの VDC およびデフォルトの VRF が使用されます。詳細については、『 Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide, Release 5.x を参照してください。

BFD のライセンス要件

次の表に、この機能のライセンス要件を示します。

 

製品
ライセンス要件

Cisco NX-OS

BFD にライセンスは必要ありません。ライセンス パッケージに含まれていない機能はすべて Cisco NX-OS システム イメージにバンドルされており、追加費用は一切発生しません。Cisco NX-OS のライセンス スキームの詳細については、『 Cisco Nexus 7000 Series NX-OS Licensing Guide, Release 5.x を参照してください

BFD の前提条件

BFD を使用するには、次の前提条件を満たしている必要があります。

BFD 機能をイネーブルにする必要があります(「BFD 機能のイネーブル化」を参照)。

BFD をイネーブルにする必要のあるすべてのクライアント プロトコルに対して、BFD をイネーブルにします。「ルーティング プロトコルの BFD サポートの設定」を参照してください。

BFD 対応インターフェイスで Internet Control Message Protocol(ICMP; インターネット制御メッセージ プロトコル)リダイレクト メッセージをディセーブルにします。

デフォルト VDC の同一の IP 送信元アドレスと IP 宛先アドレスのパケット検証チェックをディセーブルにします。

詳細な前提条件については、設定タスクを参照してください。

注意事項および制約事項

BFD には、次の注意事項と制約事項があります。

BFD バージョン 1 をサポートしています。

IPv4 をサポートしています。

シングルホップ BFD をサポートしています。

Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)の BFD は、シングルホップ External BGP(EBGP)および Internal BGP(iBGP)ピアをサポートしています。

レイヤ 3 インターフェイスである、物理インターフェイス、ポート チャネル、サブインターフェイス、および VLAN インターフェイスをサポートします。

BFD は、レイヤ 3 隣接情報によって、レイヤ 2 トポロジ変化を含むトポロジ変化を検出しています。レイヤ 3 隣接情報が利用できない場合、VLAN インターフェイス(Switched Virtual Interface(SVI; スイッチ仮想インターフェイス))上の BFD セッションは、レイヤ 2 トポロジの収束後にアップになりません。

デフォルト設定

表 5-1 は、各 BFD パラメータに対するデフォルト設定を示します。

 

表 5-1 デフォルト BFD パラメータ

パラメータ
デフォルト

BFD 機能

ディセーブル

必要最小受信間隔

50 ミリ秒

指定最小転送間隔

50 ミリ秒

検出乗数

3

エコー モード

イネーブル

モード

非同期

ポート チャネル

論理モード(発信元-宛先ペア アドレスごとに 1 セッション)

スロー タイマー

2000 ミリ秒

サブインターフェイス最適化

ディセーブル

BFD の設定

ここでは、次の内容について説明します。

「階層の設定」

「BFD 設定のタスク フロー」

「BFD 機能のイネーブル化」

「グローバル BFD パラメータの設定」

「インターフェイス上での BFD の設定」

「ポート チャネル上での BFD の設定」

「BFD エコー モードの設定」

「サブインターフェイス上での BFD の最適化」

「ルーティング プロトコルの BFD サポートの設定」

階層の設定

グローバル レベル、VRF レベル、インターフェイス レベル、ポート チャネル レベル、またはサブインターフェイス レベル(物理インターフェイスおよびポート チャネルの場合)で BFD を設定できます。VRF コンフィギュレーションは、グローバル コンフィギュレーションより優先されます。インターフェイス コンフィギュレーションまたはポート チャネル コンフィギュレーションは、VRF コンフィギュレーションまたはグローバル コンフィギュレーションより優先されます。サポートされるインターフェイスでは、サブインターフェイス最適化がイネーブルにされない限り、サブインターフェイス レベル コンフィギュレーションは、インターフェイス コンフィギュレーションまたはポート チャネル コンフィギュレーションより優先されます。詳細については、「サブインターフェイス上での BFD の最適化」を参照してください。

ポート チャネルのメンバである物理ポートの場合、メンバ ポートはマスター ポート チャネルの BFD コンフィギュレーションを継承します。サブインターフェイス最適化がイネーブルにされない限り、メンバ ポート サブインターフェイスは、マスター ポート チャネルの BFD コンフィギュレーションより優先されます。

BFD 設定のタスク フロー

BFD を設定するには、次の作業を行います。


ステップ 1 BFD 機能のイネーブル化

ステップ 2 グローバル BFD パラメータの設定またはインターフェイス上での BFD の設定

ステップ 3 ルーティング プロトコルの BFD サポートの設定


 

BFD 機能のイネーブル化

デバイス(VDC)のインターフェイスまたはプロコル上で BFD を設定する前に、BFD 機能をイネーブルにする必要があります。

作業を開始する前に

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. feature bfd

3. show feature | include bfd

4. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

feature bfd

 

例:

switch(config)# feature bfd

BFD 機能をイネーブルにします。

ステップ 3

show feature | include bfd

 

例:

switch(config)# show feature | include bfd

(任意)イネーブルにされた機能およびディセーブルにされた機能を表示します。

ステップ 4

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

no feature bfd コマンドを使用して、BFD 機能をディセーブルにし、関連するコンフィギュレーションをすべて削除します。

 

コマンド
目的

no feature bfd

 

例:

switch(config)# no feature bfd

BFD 機能をディセーブルにして、関連するコンフィギュレーションをすべて削除します。

グローバル BFD パラメータの設定

デバイスのすべての BFD セッションの BFD セッション パラメータを設定できます。BFD セッション パラメータは、BFD ピア間においてスリーウェイ ハンドシェイクでネゴシエートされます。

これらのインターフェイス上のグローバル セッション パラメータを無効にするには、「インターフェイス上での BFD の設定」を参照してください。

作業を開始する前に

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

BFD 機能をイネーブルにします。「BFD 機能のイネーブル化」を参照してください。

手順の概要

1. configure terminal

2. bfd interval mintx min_rx msec multiplier value

3. bfd slow-timer [ interval ]

4. show running-config bfd

5. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

bfd interval mintx min_rx msec multiplier value

 

例:

switch(config)# bfd interval 50 min_rx 50 multiplier 3

デバイスのすべての BFD セッションの BFD セッション パラメータを設定します。インターフェイスで BFD セッション パラメータを設定すると、これらの値より優先されます。 mintx および msec の範囲は 50 ~ 999 ミリ秒で、デフォルトは 50 です。乗数(multiplier)の範囲は 1 ~ 50 です。乗数のデフォルトは 3 です。

ステップ 3

bfd slow-timer [ interval ]

 

例:

switch(config)# bfd slow-timer 2000.

スロー タイマーを設定します。この値は、BFD が新しいセッションを開始する速度を決定します。指定できる範囲は 1000 ~ 30000 ミリ秒です。デフォルトは 2000 です。

ステップ 4

show running-config bfd

 

例:

switch(config)# show running-config bfd

(任意)BFD 実行コンフィギュレーションを表示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

インターフェイス上での BFD の設定

インターフェイスのすべての BFD セッションの BFD セッション パラメータを設定できます。BFD セッション パラメータは、BFD ピア間においてスリーウェイ ハンドシェイクでネゴシエートされます。

この設定は、設定されたインターフェイスのグローバル セッション パラメータより優先されます。

作業を開始する前に

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

BFD 機能をイネーブルにします。「BFD 機能のイネーブル化」を参照してください。

手順の概要

1. configure terminal

2. interface int-if

3. bfd interval mintx min_rx msec multiplier value

4. show running-config bfd

5. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface int-if

 

例:

switch(config)# interface ethernet 2/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。 ? キーワードを使用して、サポートされるインターフェイスを表示します。

ステップ 3

bfd interval mintx min_rx msec multiplier value

 

例:

switch(config-if)# bfd interval 50 min_rx 50 multiplier 3

インターフェイスのすべての BFD セッションの BFD セッション パラメータを設定します。これは、グローバル BFD セッション パラメータより優先されます。 mintx および msec の範囲は 50 ~ 999 ミリ秒で、デフォルトは 50 です。乗数(multiplier)の範囲は 1 ~ 50 です。乗数のデフォルトは 3 です。

ステップ 4

show running-config bfd

 

例:

switch(config-if)# show running-config bfd

(任意)BFD 実行コンフィギュレーションを表示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

ポート チャネル上での BFD の設定

ポート チャネルのすべての BFD セッションの BFD セッション パラメータを設定できます。ポート チャネルの各リンクに対して BFD はセッションを作成し、集約結果をクライアント プロトコルに提供します。たとえば、ポート チャネル上のあるリンクの BFD セッションがアップであるとき、BFD は OSPF などのクライアント プロトコルにポート チャネルがアップであることを通知します。BFD セッション パラメータは、BFD ピア間においてスリーウェイ ハンドシェイクでネゴシエートされます。

この設定は、設定されたポート チャネルのグローバル セッション パラメータより優先されます。ポート チャネルのメンバ ポートは、サブインターフェイス レベル BFD パラメータをメンバ ポート上で設定しない限り、ポート チャネルの BFD セッション パラメータを継承します。その場合、サブインターフェイス最適化がイネーブルにされていなければ、メンバ ポート サブインターフェイスはサブインターフェイス BFD コンフィギュレーションを使用します。詳細については、「サブインターフェイス上での BFD の最適化」を参照してください。

作業を開始する前に

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

BFD をイネーブルにする前に、ポート チャネルの Link Aggregation Control Protocol(LACP)がイネーブルにされていることを確認します。

BFD 機能をイネーブルにします。「BFD 機能のイネーブル化」を参照してください。

手順の概要

1. configure terminal

2. interface port-channel number

3. bfd per-link

4. (任意) bfd interval mintx min_rx msec multiplier value

5. show running-config bfd

6. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface port-channel number

 

例:

switch(config)# interface port-channel 2

switch(config-if)#

ポート チャネル コンフィギュレーション モードを開始します。 ? キーワードを使用して、サポートされる数字の範囲を表示します。

ステップ 3

bfd per-link

 

例:

switch(config-if)# bfd per-link

ポート チャネルの各リンクに BFD セッションを設定します。

ステップ 4

bfd interval mintx min_rx msec multiplier value

 

例:

switch(config-if)# bfd interval 50 min_rx 50 multiplier 3

(任意)ポート チャネルのすべての BFD セッションの BFD セッション パラメータを設定します。これは、グローバル BFD セッション パラメータより優先されます。 mintx および msec の範囲は 50 ~ 999 ミリ秒で、デフォルトは 50 です。乗数(multiplier)の範囲は 1 ~ 50 です。乗数のデフォルトは 3 です。

ステップ 5

show running-config bfd

 

例:

switch(config-if)# show running-config bfd

(任意)BFD 実行コンフィギュレーションを表示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

BFD エコー モードの設定

BFD モニタ対象リンクの一方または両方の端に BFD エコー モードを設定できます。エコー モードは設定されたスロー タイマーに基づいて必要最小受信間隔をスロー ダウンします。エコー モードがディセーブルにされている場合、RequiredMinEchoRx BFD セッション パラメータはゼロに設定されます。エコー モードがイネーブルにされている場合、スロー タイマーが必要最小受信間隔になります。

作業を開始する前に

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

BFD 機能をイネーブルにします。「BFD 機能のイネーブル化」を参照してください。

BFD セッション パラメータを設定します。「グローバル BFD パラメータの設定」または「インターフェイス上での BFD の設定」を参照してください。

BFD 対応インターフェイスでインターネット制御メッセージ プロトコル(ICMP)リダイレクト メッセージがディセーブルにされていることを確認します。インターフェイス上で no ip redirects コマンドを使用します。

同一の IP 送信元アドレスと IP 宛先アドレスのパケット検証チェックがディセーブルにされていることを確認します。デフォルト VDC で no hardware ip verify address identical コマンドを使用します。このコマンドの詳細については、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x を参照してください。

手順の概要

1. configure terminal

2. bfd slow-timer echo-interval

3. interface int-if

4. bfd echo

5. show running-config bfd

6. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

bfd slow-timer echo-interval

 

例:

switch(config)# bfd slow-timer 2000

エコー モードで使用されるスロー タイマーを設定します。エコー モードがイネーブルにされているとき、この値は必要最小受信間隔より優先されます。指定できる範囲は 1000 ~ 30000 ミリ秒です。デフォルトは 2000 です。

ステップ 3

interface int-if

 

例:

switch(config)# interface ethernet 2/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。 ? キーワードを使用して、サポートされるインターフェイスを表示します。

ステップ 4

bfd echo

 

例:

switch(config-if)# bfd echo

BFD エコー モードをイネーブルにします。デフォルトはイネーブルです。

ステップ 5

show running-config bfd

 

例:

switch(config-if)# show running-config bfd

(任意)BFD 実行コンフィギュレーションを表示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

サブインターフェイス上での BFD の最適化

サブインターフェイス上で最適化できます。BFD は、設定されたすべてのサブインターフェイスに対してセッションを作成します。BFD は、最小の VLAN ID が設定されたサブインターフェイスをマスター サブインターフェイスとして設定し、そのサブインターフェイスは親インターフェイスの BFD セッション パラメータを使用します。その他のサブインターフェイスはスロー タイマーを使用します。最適化されたサブインターフェイス セッションがエラーを検出した場合、BFD はその物理インターフェイスのすべてのサブインターフェイスをダウンとしてマークします。

作業を開始する前に

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

BFD 機能をイネーブルにします。「BFD 機能のイネーブル化」を参照してください。

BFD セッション パラメータを設定します。「グローバル BFD パラメータの設定」または「インターフェイス上での BFD の設定」を参照してください。

これらのサブインターフェイスが別の Cisco NX-OS デバイスに接続されていることを確認します。この機能は Cisco NX-OS だけでサポートされています。

手順の概要

1. configure terminal

2. interface int-if

3. bfd optimize subinterface

4. show running-config bfd

5. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface int-if

 

例:

switch(config)# interface ethernet 2/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。 ? キーワードを使用して、サポートされるインターフェイスを表示します。

ステップ 3

bfd optimize subinterface

 

例:

switch(config-if)# bfd optimize subinterface

BFD 対応インターフェイスのサブインターフェイスを最適化します。デフォルトはディセーブルです。

ステップ 4

show running-config bfd

 

例:

switch(config-if)# show running-config bfd

(任意)BFD 実行コンフィギュレーションを表示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

BGP 上での BFD の設定

ボーダー ゲートウェイ プロトコル(BGP)の BFD を設定できます。

作業を開始する前に

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

BFD 機能をイネーブルにします。「BFD 機能のイネーブル化」を参照してください。

BFD セッション パラメータを設定します。「グローバル BFD パラメータの設定」または「インターフェイス上での BFD の設定」を参照してください。

BGP 機能をイネーブルにします。詳細については、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x を参照してください。

手順の概要

1. configure terminal

2. router bgp as-number

3. neighbor { ip-address | ipv6-address } remote-as as-number

4. bfd

5. show running-config bgp

6. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router bgp as-number

 

例:

switch(config)# router bgp 64496

switch(config-router)#

BGP をイネーブルにし、AS 番号をローカル BGP スピーカーに割り当てます。AS 番号は、16 ビット整数または 32 ビット整数(xx.xx の形式で、上位 16 ビット 10 進数と下位 16 ビット 10 進数から形成される)が可能です。

ステップ 3

neighbor { ip-address | ipv6-address } remote-as as-number

 

例:

switch(config-router)# neighbor 209.165.201.1 remote-as 64497

switch(config-router-neighbor)#

リモート BGP ピアの IPv4 アドレスまたは IPv6 アドレス、および AS 番号を設定します。 ip-address の形式は x.x.x.x です。 ipv6-address の形式は A:B::C:D です。

ステップ 4

bfd

 

例:

switch(config-router-neighbor)# bfd

この BGP ピアの BFD をイネーブルにします。

ステップ 5

show running-config bgp

 

例:

switch(config-router-neighbor)# show running-config bgp

(任意)BGP 実行コンフィギュレーションを表示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config-router-neighbor)# copy running-config startup-config

(任意)この設定の変更を保存します。

EIGRP 上での BFD の設定

Enhanced Interior Gateway Routing Protocol(EIGRP)での BFD の設定

作業を開始する前に

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

BFD 機能をイネーブルにします。「BFD 機能のイネーブル化」を参照してください。

BFD セッション パラメータを設定します。「グローバル BFD パラメータの設定」または「インターフェイス上での BFD の設定」を参照してください。

EIGRP 機能をイネーブルにします。詳細については、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x を参照してください。

手順の概要

1. configure terminal

2. router eigrp instance-tag

3. bfd

4. interface int-if

5. { ip | ipv6 } eigrp instance-tag bfd

6. show { ip | ipv6 } eigrp [ vrf vrf-name ] [ interfaces if ]

7. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router eigrp instance-tag

 

例:

switch(config)# router eigrp Test1

switch(config-router)#

設定されたインスタンス タグを持つ新しい EIGRP プロセスを作成します。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

AS 番号として適切ではない インスタンス タグ を設定する場合、 autonomous-system コマンドを使用して、AS 番号を明示的に設定する必要があります。AS 番号を明示的に設定しない場合、この EIGRP インスタンスはシャットダウン状態のままになります。

ステップ 3

bfd

 

例:

switch(config-router-neighbor)# bfd

(任意)すべての EIGRP インターフェイスの BFD をイネーブルにします。

ステップ 4

interface int-if

 

例:

switch(config-router-neighbor)# interface ethernet 2/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。 ? キーワードを使用して、サポートされるインターフェイスを表示します。

ステップ 5

{ ip | ipv6 } eigrp instance-tag bfd

例:

switch(config-if)# ip eigrp Test1 bfd

(任意)EIGRP インターフェイスの BFD をイネーブルまたはディセーブルにします。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

デフォルトはディセーブルです。

ステップ 6

show { ip | ipv6 } eigrp [ vrf vrf-name ] [ interfaces if ]

 

例:

switch(config-if)# show ip eigrp

(任意)EIGRP に関する情報を表示します。vrf-name には最大 32 文字の英数字を使用できます。大文字と小文字を区別します。

ステップ 7

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

OSPF 上での BFD の設定

Open Shortest Path First version 2(OSPFv2)の BFD を設定できます。

作業を開始する前に

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

BFD 機能をイネーブルにします。「BFD 機能のイネーブル化」を参照してください。

BFD セッション パラメータを設定します。「グローバル BFD パラメータの設定」または「インターフェイス上での BFD の設定」を参照してください。

OSPF 機能をイネーブルにします。詳細については、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x を参照してください。

手順の概要

1. configure terminal

2. router ospf instance-tag

3. bfd

4. interface int-if

5. if ospf bfd

6. show ip ospf [ vrf vrf-name ] [ interface if ]

7. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router ospf instance-tag

 

例:

switch(config)# router ospf 201

switch(config-router)#

設定されたインスタンス タグを持つ新しい OSPFv2 インスタンスを作成します。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

ステップ 3

bfd

 

例:

switch(config-router)# bfd

(任意)すべての OSPFv2 インターフェイスの BFD をイネーブルにします。

ステップ 4

interface int-if

 

例:

switch(config-router)# interface ethernet 2/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。 ? キーワードを使用して、サポートされるインターフェイスを表示します。

ステップ 5

ip ospf bfd

 

例:

switch(config-if)# ip ospf 201 bfd

(任意)OSPFv2 インターフェイスの BFD をイネーブルまたはディセーブルにします。デフォルトはディセーブルです。

ステップ 6

show ip ospf [ vrf vrf-name ] [ interface if ]

 

例:

switch(config-if)# show ip ospf

(任意)OSPF に関する情報を表示します。vrf-name には最大 32 文字の英数字を使用できます。大文字と小文字を区別します。

ステップ 7

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

IS-IS での BFD の設定

Intermediate System-to-Intermediate System(IS-IS)プロトコルの BFD を設定できます。

作業を開始する前に

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

BFD 機能をイネーブルにします。「BFD 機能のイネーブル化」を参照してください。

BFD セッション パラメータを設定します。「グローバル BFD パラメータの設定」または「インターフェイス上での BFD の設定」を参照してください。

IS-IS 機能をイネーブルにします。詳細については、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x を参照してください。

手順の概要

1. configure terminal

2. router isis instance-tag

3. bfd

4. interface int-if

5. isis bfd

6. show isis

7. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router isis instance-tag

 

例:

switch(config)# router isis Enterprise

switch(config-router)#

設定された インスタンス タグ を持つ新しい IS-IS インスタンスを作成します。

ステップ 3

bfd

 

例:

switch(config-router)# bfd

(任意)すべての OSPFv2 インターフェイスの BFD をイネーブルにします。

ステップ 4

interface int-if

 

例:

switch(config-router)# interface ethernet 2/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。 ? キーワードを使用して、サポートされるインターフェイスを表示します。

ステップ 5

isis bfd

例:

switch(config-if)# isis bfd

(任意)IS-IS インターフェイスの BFD をイネーブルまたはディセーブルにします。デフォルトはディセーブルです。

ステップ 6

show isis [ vrf vrf-name ] [ interface if ]

 

例:

switch(config-if)# showisis

(任意)IS-IS に関する情報を表示します。vrf-name には最大 32 文字の英数字を使用できます。大文字と小文字を区別します。

ステップ 7

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

インターフェイス上での BFD のディセーブル化

グローバル レベルまたは VRF レベルで BFD がイネーブルにされているルーティング プロトコルに対し、選択的にインターフェイス上の BFD をディセーブルにできます。

インターフェイス上で BFD をディセーブルにするには、インターフェイス コンフィギュレーション モードで次のコマンドのうちのいずれかを使用します。

コマンド
目的

{ ip | ipv6 } eigrp instance-tag bfd disable

 

例:

switch(config-if)# ip eigrp Test1 bfd disable

EIGRP インターフェイス上で BFD をディセーブルにします。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

ip ospf bfd disable

 

例:

switch(config-if)# ip ospf 201 bfd disable

OSPFv2 インターフェイス上で BFD をディセーブルにします。

isis bfd disable

例:

switch(config-if)# isis bfd disable

IS-IS インターフェイス上で BFD をディセーブルにします。

ホットスタンバイ ルータ プロトコル(HSRP)での BFD の設定

Hot Standby Router Protocol(HSRP; ホットスタンバイ ルータ プロトコル)の BFD を設定できます。アクティブ HSRP ルータおよびスタンバイ HSRP ルータは、BFD を通じてお互いをトラッキングします。スタンバイ HSRP ルータの BFD が、アクティブ HSRP ルータがダウンしていることを検出した場合、スタンバイ HSRP ルータは、このイベントをアクティブ タイム満了として処理し、アクティブ HSRP ルータを引き継ぎます。

show hsrp detail では、このイベントが BFD@Act-down または BFD@Sby-down として表示されます。

作業を開始する前に

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

BFD 機能をイネーブルにします。「BFD 機能のイネーブル化」を参照してください。

BFD セッション パラメータを設定します。「グローバル BFD パラメータの設定」または「インターフェイス上での BFD の設定」を参照してください。

HSRP 機能をイネーブルにします。詳細については、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x を参照してください。

手順の概要

1. configure terminal

2. interface int-if

3. hsrp bfd

4. show running-config hsrp

5. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface int-if

 

例:

switch(config)# interface ethernet 2/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。 ? キーワードを使用して、サポートされるインターフェイスを表示します。

ステップ 3

hsrp bfd

 

例:

switch(config-if)# hsrp bfd

(任意)HSRP インターフェイスの BFD をイネーブルまたはディセーブルにします。デフォルトはディセーブルです。

ステップ 4

show running-config hsrp

 

例:

switch(config-if)# show running-config hsrp

(任意)HSRP 実行コンフィギュレーションを表示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

Protocol Independent Multicast(PIM)上での BFD の設置

Protocol Independent Multicast(PIM)プロトコルの BFD を設置できます。

作業を開始する前に

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

BFD 機能をイネーブルにします。「BFD 機能のイネーブル化」を参照してください。

PIM 機能をイネーブルにします。詳細については、『 Cisco Nexus 7000 Series NX-OS Multicast Routing Configuration Guide, Release 5.x を参照してください。

手順の概要

1. configure terminal

2. ip pim bfd

3. interface if-type

4. ip pim bfd-instance [ disable ](任意)

5. show running-config pim

6. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

ip pim bfd

 

:

switch(config)# ip pim bfd

PIM の BFD をイネーブルにします。

ステップ 3

interface int-if

 

例:

switch(config)# interface ethernet 2/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。 ? キーワードを使用して、サポートされるインターフェイスを表示します。

ステップ 4

ip pim bfd-instance [ disable ]

 

例:

switch(config-if)# ip pim bfd-instance

(任意)PIM インターフェイスの BFD をイネーブルまたはディセーブルにします。デフォルトはディセーブルです。

ステップ 5

show running-config pim

 

例:

switch(config)# show running-config pim

(任意)PIM 実行コンフィギュレーションを表示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

スタティック ルータ上での BFD の設定

インターフェイスのスタティック ルータの BFD を設定できます。オプションで Virtual Routing and Forwarding(VRF; 仮想ルーティング/転送)インスタンス内のスタティック ルータの BFD を設定できます。

作業を開始する前に

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

BFD 機能をイネーブルにします。「BFD 機能のイネーブル化」を参照してください。

手順の概要

1. configure terminal

2. vrf context vrf-name (任意)

3. ip route route interface if { nh-address | nh-prefix }

4. ip route static bfd interface { nh-address | nh-prefix }

5. show ip route static [ vrf vrf-name ]

6. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

vrf context vrf-name

 

例:

switch(config)# vrf context Red

switch(config-vrf)#

(任意)VRF コンフィギュレーション モードを開始します。

ステップ 3

ip route route interface { nh-address | nh-prefix }

 

:

switch(config-vrf)# ip route 192.0.2.1 ethernet 2/1 192.0.2.4

スタティック ルートを作成します。 ? キーワードを使用して、サポートされるインターフェイスを表示します。

ステップ 4

ip route static bfd interface { nh-address | nh-prefix }

 

:

switch(config-vrf)# ip route static bfd ethernet 2/1 192.0.2.4

インターフェイス上のすべてのスタティック ルートの BFD をイネーブルにします。 ? キーワードを使用して、サポートされるインターフェイスを表示します。

ステップ 5

show ip route static [ vrf vrf-name ]

 

例:

switch(config-vrf)# show ip route static vrf Red

(任意)スタティック ルートを表示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config-vrf)# copy running-config startup-config

(任意)この設定の変更を保存します。

BFD 設定の確認

BFD 設定情報を表示するには、次の作業のいずれかを行います。

 

コマンド
目的

show running-config bfd

実行 BFD コンフィギュレーションを表示します。

show startup-config bfd

次のシステム起動時に適用される BFD コンフィギュレーションを表示します。

これらのコマンドの出力フィールドの詳細については、『 Cisco Nexus 7000 Series NX-OS Interfaces Command Reference, Release 5.x を参照してください

BFD のモニタ

BFD ステータス情報を表示するには、次の作業のいずれかを行います。

 

コマンド
目的

show bfd neighbors [ application name ] [ details ]

BGP や OSPFv2 などのサポートされるアプリケーションの BFD に関する情報を表示します。

show bfd neighbors [ interface int-if ] [ details ]

インターフェイス上の BGP セッションに関する情報を表示します。

show bfd neighbors [ dest-ip ip-address ] [ src-ip ip-address ][ details ]

インターフェイス上の指定された BGP セッションに関する情報を表示します。

show bfd neighbors [ vrf vrf-name ] [ details ]

VRF の BFD に関する情報を表示します。

これらのコマンドの出力フィールドの詳細については、『 Cisco Nexus 7000 Series NX-OS Interfaces Command Reference, Release 5.x を参照してください。

BFD の設定例

次に、デフォルト BFD セッション パラメータを使用した、Ethernet 2/1 上の OSPFv2 の BFD 設定例を示します。

feature bfd
feature ospf
router ospf Test1
interface ethernet 2/1
ip ospf bfd
no shutdown
 

次に、デフォルト BFD セッション パラメータを使用した、EIGRP インターフェイスの BFD 設定例を示します。

feature bfd
feature eigrp
bfd interval 100 min_rx 100 multiplier 4
router eigrp Test2
bfd
 

その他の関連資料

BFD の実装に関する詳細は、次の各項を参照してください。

「関連資料」

「RFC」

「BFD 機能の履歴」

関連資料

関連項目
参照先

BFD コマンド

詳細については、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x を参照してください。

RFC

RFC
タイトル

draft-ietf-bfd-base-09.txt

『Bidirectional Forwarding Detection』(バージョン 1)

draft-ietf-bfd-multihop-06.txt

『BFD for Multihop Paths』

draft-ietf-bfd-v4v6-1hop9-.txt

『BFD for IPv4 and IPv6 (Single Hop)』

BFD 機能の履歴

表 5-2 は、この機能のリリースの履歴です。

 

表 5-2 BFD 機能の履歴

機能名
リリース
機能情報

BFD

5.0(2)

この機能が導入されました。