Cisco Nexus 7000 シリーズ NX-OS インターフェイ ス コンフィギュレーション ガイド リリース 5.x
基本インターフェイス パラメータの設定
基本インターフェイス パラメータの設定
発行日;2012/02/06 | 英語版ドキュメント(2011/12/09 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

基本インターフェイス パラメータの設定

基本インターフェイス パラメータについて

説明

ビーコン

MDIX

デバウンス タイマー

Error Disabled

レート モード

速度モードとデュプレックス モード

フロー制御

ポート MTU サイズ

帯域幅

スループット遅延

管理ステータス

UDLD パラメータ

UDLD の概要

UDLD のデフォルト設定

UDLD アグレッシブ モードおよび非アグレッシブ モード

キャリア遅延

ポート チャネル パラメータ

ポート プロファイル

タイム ドメイン反射率計(TDR)ケーブル診断

ライセンス要件

注意事項および制約事項

基本インターフェイス パラメータの設定

設定するインターフェイスの指定

説明の設定

ビーコン モードの設定

帯域幅レート モードの変更

1 ポート専用帯域幅

帯域幅をポート グループ内で共有

Error-Disabled ステートの設定

Error Disable 検出のイネーブル化

Error-Disabled 回復のイネーブル化

Error-Disabled 回復間隔の設定

MDIX パラメータの設定

デバウンス タイマーの設定

インターフェイス速度およびデュプレックス モードの設定

フロー制御の設定

MTU サイズの設定

インターフェイス MTU サイズの設定

システム ジャンボ MTU サイズの設定

帯域幅の設定

スループット遅延の設定

インターフェイスのシャットダウンおよび再開

UDLD モードの設定

キャリア遅延タイマーの設定

ポート プロファイルの設定

ポート プロファイルの作成

ポート プロファイル コンフィギュレーション モードの開始とポート プロファイルの修正

一定範囲のインターフェイスへのポート プロファイルの割り当て

特定のポート プロファイルのイネーブル化

ポート プロファイルの継承

一定範囲のインターフェイスからのポート プロファイルの削除

継承されたポート プロファイルの削除

TDR ケーブル診断の実施

基本インターフェイス パラメータの確認

インターフェイス カウンタの表示とクリア

インターフェイス統計情報の表示

インターフェイス カウンタのクリア

デフォルト設定

その他の関連資料

関連資料

標準規格

基本インターフェイス パラメータ設定の機能履歴

基本インターフェイス パラメータの設定

この章では、Cisco Nexus 7000 シリーズ NX-OS デバイスで基本インターフェイス パラメータを設定する方法について説明します。

この章では、次の内容について説明します。

「基本インターフェイス パラメータについて」

「ライセンス要件」

「注意事項および制約事項」

「基本インターフェイス パラメータの設定」

「基本インターフェイス パラメータの確認」

「インターフェイス カウンタの表示とクリア」

「デフォルト設定」

「その他の関連資料」

「基本インターフェイス パラメータ設定の機能履歴」


) レイヤ 2 インターフェイスで独自に使用するパラメータを設定するには、「レイヤ 2 インターフェイスの設定」を参照してください(アクセス インターフェイスやトランキング インターフェイス)。レイヤ 3 インターフェイスで独自に使用するパラメータを設定するには、「レイヤ 3 インターフェイスの設定」を参照してください(ルーテッド インターフェイス、サブインターフェイス、VLAN インターフェイス、ループバック インターフェイス、IP トンネル)。


基本インターフェイス パラメータについて

ここでは、次の内容について説明します。

「説明」

「ビーコン」

「MDIX」

「デバウンス タイマー」

「Error Disabled」

「レート モード」

「速度モードとデュプレックス モード」

「フロー制御」

「ポート MTU サイズ」

「帯域幅」

「スループット遅延」

「管理ステータス」

「UDLD パラメータ」

「キャリア遅延」

「ポート チャネル パラメータ」

「ポート プロファイル」

「タイム ドメイン反射率計(TDR)ケーブル診断」

説明

イーサネット インターフェイスおよび管理インターフェイスに説明パラメータを設定して、インターフェイスにわかりやすい名前を付けることができます。それぞれのインターフェイスに独自の名前を使用すれば、複数のインターフェイスから探す場合でも必要なインターフェイスをすぐに見つけることができます。

ポート チャネル インターフェイスに説明パラメータを設定する方法については、「ポート チャネルの説明の設定」を参照してください。別のインターフェイスにこのパラメータを設定する方法については、「説明の設定」を参照してください。

ビーコン

ビーコン モードをイネーブルにするとリンク ステート LED が緑に点滅し、物理ポートを識別できます。デフォルトでは、このモードはディセーブルです。インターフェイスの物理ポートを識別するには、インターフェイスのビーコン パラメータを有効にします。

ビーコン パラメータの設定手順については、「ビーコン モードの設定」を参照してください。

MDIX

Medium Dependent Interface-crossover(MDI-X; メディア依存インターフェイスクロスオーバー)パラメータを使用して、デバイス間のクロスオーバー接続のイネーブル/ディセーブルを切り替えます。このパラメータは銅線インターフェイスだけに適用します。デフォルトでは、このパラメータはイネーブルです。

MDIX パラメータの設定手順については、「MDIX パラメータの設定」を参照してください。

デバウンス タイマー

デバウンス タイマーを設定するとリンク変更の通知が遅くなり、ネットワークの再設定によるトラフィック損失が減少します。デバウンス タイマーはイーサネット ポートごとに個別に設定します。遅延時間はミリ秒単位で指定できます。デフォルトでは、このパラメータは 100 ミリ秒に設定されています。


注意 デバウンス タイマーをイネーブルにするとリンクアップおよびリンクダウン検出が遅くなり、デバウンス期間中のトラフィックが失われます。この状況は、一部のレイヤ 2 とレイヤ 3 プロトコルのコンバージェンスと再コンバージェンスに影響する可能性があります。

デバウンス タイマー パラメータの設定手順については、「デバウンス タイマーの設定」を参照してください。

Error Disabled

ポートが管理上( no shutdown コマンドを使用しない)イネーブルであるが、プロセスによって実行時にディセーブルになる場合、そのポートはerror-disabled(err-disabled)ステートです。たとえば、UDLD が単方向リンクを検出した場合、ポートは実行時にシャットダウンされます。ただし、ポートは管理上イネーブルなので、ポート ステータスは err-disable として表示されます。ポートが err-disable ステートになると、手動で再イネーブル化する必要があります。または、自動回復を提供するタイムアウト値を設定できます。自動回復はデフォルトでは設定されておらず、デフォルトでは、err-disable の検出はすべての原因に対してイネーブルです。

インターフェイスが err-disabled ステートの場合、 errdisable detect cause コマンドを使用して、エラーに関する情報を検索します。

特定の error-disabled の原因に自動 error-disabled 回復タイムアウトを設定し、回復期間を設定できます。

errdisable recovery cause コマンドは、300 秒後に自動回復を提供します。

errdisable recovery interval コマンドを使用して、回復期間を 30 ~ 65535 秒の範囲内で変更できます。また、特定の err-disable の原因に回復タイムアウトを設定することもできます。

その原因に対して error-disabled の回復をイネーブルにしない場合、インターフェイスは、 shutdown および no shutdown コマンドが入力されるまで error-disabled ステートのままです。原因の回復をイネーブルにした場合、インターフェイスは error-disabled ステートから回復し、すべての原因がタイムアウトになったときに動作を再開できるようになります。エラーの背後にある理由を表示するには、 show interface status err-disabled コマンドを使用します。

レート モード

32 ポートの 10 ギガビット イーサネット モジュールでは、4 ポート単位で 10 Gbps(ギガビット/秒)の帯域幅を処理します。レートモード パラメータを使用すれば、この帯域幅を 4 ポートのうちの最初のポート専用にさせることも、4 ポート全体でこの帯域幅を共有させることもできます。

表 2-1 に、10 Gbps ごとの帯域幅を共有するポートのグループと、帯域幅全体を利用するために使用するグループの専用ポートを示します。

 

表 2-1 共有ポートと専用ポート

帯域幅を共有するポート グループ
10 ギガビット イーサネットの帯域幅を専用するポート

1、3、5、7

1

2、4、6、8

2

9、11、13、15

9

10、12、14、16

10

17、19、21、23

17

18、20、22、24

18

25、27、29、31

25

26、28、30、32

26


) 各ポート グループのポートはすべて同じ Virtual Device Context(VDC)に属している必要があります。VDC の詳細については、『Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide, Release 5.xを参照してください。


速度モードとデュプレックス モード

速度モードとデュプレックス モードはそれぞれ、イーサネット インターフェイスおよび管理インターフェイスと相関関係にあります。デフォルトでは、これらのインターフェイスの速度およびデュプレックス モードは他のインターフェイスとそれぞれ自動ネゴシエートしますが、設定を変更することもできます。設定を変更する場合は、両方のインターフェイスで同じ速度とデュプレックス モード設定を使用するか、または少なくとも 1 つのインターフェイスで自動ネゴシエーションを使用します。 表 2-2 は、イーサネット インターフェイスおよび管理インターフェイスの各タイプで動作する設定を示します。

 

表 2-2 イーサネットおよび管理インターフェイスで使用する速度およびデュプレックスモード設定

モジュールのタイプ
速度モード設定
デュプレックス モード設定
動作速度(Mb/s)
動作デュプレックス モード

32 ポート 10 ギガビット イーサネット

自動1

自動 1

10,000

全二重

48 ポート 10/100/1000 イーサネット

自動 1

自動 1

1000

全二重

10 または 100

半二重

1000

自動 1 または全二重

1000

全二重

100

自動 1 または半二重

100

半二重

全二重

100

全二重

10

自動 1 または半二重

10

半二重

全二重

10

全二重

管理

自動 1

自動 1

1000

全二重

10 または 100

半二重

1000

自動 1 または全二重

1000

全二重

100

自動 1 または半二重

100

半二重

全二重

100

全二重

10

自動 1 または半二重

10

半二重

全二重

10

全二重

1.デフォルト設定

ポート チャネル インターフェイスに速度モードおよびデュプレックス モードを設定する方法については、「ポート チャネル インターフェイスへの速度とデュプレックスの設定」を参照してください。他のインターフェイスに速度モードおよびデュプレックス モードを設定する方法については、「インターフェイス速度およびデュプレックス モードの設定」を参照してください。

フロー制御

1 Gbps 以上で稼動するイーサネット ポートの受信バッファが満杯になると、フロー制御によりそのポートから送信ポートに IEEE 802.3x ポーズ フレームが送信され、指定した時間だけデータの送信を停止するよう要求されます。送信ポートは任意の速度で動作しており、ポーズ フレームを受信してデータの転送を停止することができます。

2 つのポート間のフロー制御を有効にするには、それぞれのポートで対応する受信および送信フロー制御パラメータをイネーブルまたはディセーブルに設定します。パラメータをイネーブルに設定すると、もう一方のポートの設定とは関係なく送信または受信フロー制御機能がアクティブになります。指定したパラメータを設定すると、もう一方のポートの対応するフロー制御状態をイネーブルまたはディセーブルに設定すれば、送信または受信フロー制御機能がアクティブになります。いずれかのフロー制御状態をディセーブルに設定すると、その送信方向のフロー制御がディセーブルになります。異なるポート フロー制御状態がリンク フロー制御状態に与える影響については、 表 2-3 を参照してください。

 

表 2-3 リンク フロー制御上でのポート フロー制御の影響

ポート フロー制御の状態
リンク フロー制御の状態
データ受信ポート
(ポーズ フレームを送信)
データ送信ポート(ポーズ フレームを受信)

イネーブル

イネーブル

イネーブル

イネーブル

指定

イネーブル

イネーブル

ディセーブル

ディセーブル

指定

イネーブル

イネーブル

指定

指定

イネーブル

指定

ディセーブル

ディセーブル

ディセーブル

イネーブル

ディセーブル

ディセーブル

指定

ディセーブル

ディセーブル

ディセーブル

ディセーブル

フロー制御パラメータの設定手順については、「フロー制御の設定」を参照してください。

ポート MTU サイズ

Maximum Transmission Unit(MTU; 最大伝送ユニット)サイズは、イーサネット ポートで処理できる最大フレーム サイズを指定します。2 つのポート間で転送するには、どちらのポートにも同じ MTU サイズを設定する必要があります。ポートの MTU サイズを超えたフレームはドロップされます。

デフォルトではそれぞれのポートの MTU は 1500 バイトです。これはイーサネット フレームに関する IEEE 802.3 標準です。これよりも大きい MTU サイズでは、より少ないオーバーヘッドでデータをより効率的に処理できます。このようなフレームをジャンボ フレームと呼び、最大 9216 バイトまで指定できます。これもデフォルトのシステム ジャンボ MTU サイズです。

レイヤ 3 インターフェイスでは、576 ~ 9216 バイトの MTU サイズを設定できます。I/O モジュールごとに最大 64 MTU まで設定できます。


) グローバル LAN ポート MTU サイズは、非デフォルト MTU サイズを設定したレイヤ 3 イーサネット LAN ポートを通過するトラフィックに適用します。


レイヤ 2 ポートには、システム デフォルト(1500 バイト)またはシステム ジャンボ MTU サイズ(当初は 9216 バイト)のいずれかの MTU サイズを設定できます。


) システム ジャンボ MTU サイズを変更すると、ポートの一部または全部に新しいシステム ジャンボ MTU サイズを指定しない限り、レイヤ 2 ポートは自動的にシステム デフォルト MTU サイズ(1500 バイト)を使用します。


MTU サイズの設定手順については、「MTU サイズの設定」を参照してください。

帯域幅

イーサネット ポートには、物理レベルで 1,000,000 Kb の固定帯域幅があります。レイヤ 3 プロトコルでは、内部メトリックが計算できるように設定した帯域幅の値が使用されます。設定した値はレイヤ 3 プロトコルで情報目的だけで使用され、物理レベルでの固定帯域幅が変更されることはありません。たとえば、Interior Gateway Routing Protocol(IGRP)ではルーティング メトリックを指定するために最小パス帯域幅が使用されますが、物理レベルの帯域幅は 1,000,000 Kb のまま変わりません。

ポート チャネル インターフェイスに帯域幅パラメータを設定する方法については、「帯域幅と遅延の割り当て(情報目的)」を参照してください。他のインターフェイスに帯域幅パラメータ設定する方法については、「帯域幅の設定」を参照してください。

スループット遅延

スループット遅延パラメータの値を指定するとレイヤ 3 プロトコルで使用する値が指定できますが、インターフェイスの実際のスループット遅延は変更されません。レイヤ 3 プロトコルはこの値を使用して動作を決定します。たとえば、リンク速度などの他のパラメータが等しい場合、EIGRP は、遅延設定を使用して、あるイーサネット リンクの別のイーサネット リンクに対するプリファレンスを設定できます。設定する遅延値の単位は 10 マイクロ秒です。

ポート チャネル インターフェイスに帯域幅パラメータを設定する方法については、「帯域幅と遅延の割り当て(情報目的)」を参照してください。他のインターフェイスにスループット遅延パラメータを設定する方法については、「スループット遅延の設定」を参照してください。

管理ステータス

管理ステータス パラメータはインターフェイスのアップまたはダウンを指定します。管理的にダウンしたインターフェイスはディセーブルであり、データを転送できません。管理的にアップしたインターフェイスはイネーブルであり、データを転送できます。

ポート チャネル インターフェイスに管理ステータス パラメータを設定する方法については、「ポート チャネル インターフェイスのシャットダウンと再起動」を参照してください。他のインターフェイスに管理ステータス パラメータを設定する方法については、「インターフェイスのシャットダウンおよび再開」を参照してください。

UDLD パラメータ

ここでは、次の内容について説明します。

「UDLD の概要」

「UDLD のデフォルト設定」

「UDLD アグレッシブ モードおよび非アグレッシブ モード」

UDLD の概要

シスコシステムズ独自の Unidirectional Link Detection(UDLD; 単一方向リンク検出)プロトコルにより、光ファイバまたは銅線(カテゴリ 5 ケーブルなど)イーサネット ケーブルを使用して接続されたデバイスで、ケーブルの物理構成をモニタし、単一方向リンクの存在を検出することができます。デバイスで単一方向リンクが検出されると、UDLD が関係のある LAN ポートをシャットダウンし、ユーザに通知します。単方向リンクによって、スパニング ツリー トポロジ ループなどのさまざまな問題が発生する可能性があります。

UDLD は、レイヤ 1 プロトコルと連動し、リンクの物理的ステータスを判別するレイヤ 2 プロトコルです。レイヤ 1 では、物理シグナリングおよび障害検出が自動ネゴシエーションによって処理されます。UDLD は、ネイバーの ID の検出、誤って接続された LAN ポートのシャットダウンなど、自動ネゴシエーションでは実行できない処理を実行します。自動ネゴシエーションと UDLD の両方をイネーブルにすると、レイヤ 1 とレイヤ 2 の検知機能が連動し、物理的および論理的な単方向接続、および他のプロトコルの誤作動を防止します。

リンク上でローカル デバイスが送信したトラフィックをネイバーが受信するにもかかわらず、ネイバーから送信されたトラフィックをローカル デバイスが受信しない場合は、必ず単方向リンクが発生しています。対になっているファイバ ケーブルのどちらかの接続が切断されても、自動ネゴシエーションがアクティブである限り、リンクはアップしません。この場合、論理リンクは不確定であり、UDLD は何の処理も行いません。両方のファイバがレイヤ 1 で正常に動作していれば、レイヤ 2 の UDLD はそれらのファイバが適切に接続されているかどうか、また、適切なネイバー間でトラフィックが双方向に流れているかどうかを判別します。自動ネゴシエーションはレイヤ 1 で機能するため、このチェックは自動ネゴシエーションでは実行されません。

Cisco Nexus 7000 シリーズのデバイスは、UDLD をイネーブルにした LAN ポート上のネイバー デバイスに定期的に UDLD フレームを送信します。このフレームが一定の時間内にエコー バックされ、かつ特定の確認応答(エコー)がない場合は、そのリンクは単方向リンクとしてマークが付けられ、LAN ポートがシャットダウンされます。プロトコルが単方向リンクを正常に識別してディセーブルにするには、リンクの両端のデバイスが UDLD をサポートする必要があります。UDLD フレームの送信間隔は、グローバル単位でも指定されたインターフェイスにも設定できます。


) デフォルトでは、銅線の LAN ポート上の UDLD はローカルでディセーブルに設定されており、同じタイプのメディアに不要な制御トラフィックが送信されないようになっています。


図 2-1 に、単方向リンク条件の例を示します。デバイス B は、ポート上でデバイス A から正常にトラフィックを受信しますが、デバイス A は、同じポート上でデバイス B からのトラフィックを受信しません。UDLD によって問題が検出され、ポートがディセーブルにされます。

図 2-1 単方向リンク

 

UDLD のデフォルト設定

表 2-4 に、UDLD のデフォルト設定を示します。

 

表 2-4 UDLD のデフォルト設定

機能
デフォルト値

UDLD グローバル イネーブル ステート

グローバルにディセーブル

ポート別の UDLD ステート イネーブル(光ファイバ メディア用)

すべてのイーサネット光ファイバ LAN ポートでイネーブル

ツイスト ペア(銅線)メディア用のポート別 UDLD イネーブル ステート

すべてのイーサネット 10/100 および 1000BASE-TX LAN ポートでディセーブル

UDLD アグレッシブ モード

ディセーブル

UDLD メッセージの間隔

15 秒

デバイスとそのポートに UDLD を設定する手順については、「UDLD モードの設定」を参照してください。

UDLD アグレッシブ モードおよび非アグレッシブ モード

デフォルトでは、UDLD アグレッシブ モードはディセーブルになっています。UDLD アグレッシブ モードは、UDLD アグレッシブ モードをサポートするネットワーク デバイスの間のポイントツーポイントのリンク上に限って設定できます。UDLD アグレッシブ モードをイネーブルに設定した場合、UDLD 近接関係が設定されている双方向リンク上のポートが UDLD フレームを受信しなくなったとき、UDLD はネイバーとの接続を再確立しようとします。この再試行に 8 回失敗すると、ポートはディセーブルになります。

スパニング ツリー ループを防止するために、デフォルトの 15 秒間隔を使用する非アグレッシブ UDLD により、(デフォルトのスパニング ツリー パラメータを使用している場合)ブロッキング ポートがフォワーディング ステートに移行する前に、すみやかに単方向リンクをシャットダウンできます。

UDLD アグレッシブ モードをイネーブルにすると、次のようなことが発生します。

リンクの一方にポート スタックが生じる(送受信どちらも)

リンクの一方がダウンしているにもかかわらず、リンクのもう一方がアップしたままになる

このような場合、UDLD アグレッシブ モードでは、リンクのポートの 1 つがディセーブルになり、トラフィックが廃棄されるのを防止します。


) UDLD アグレッシブ モードをすべてのファイバ ポートでイネーブルにするには、UDLD アグレッシブ モードをグローバルでイネーブルにします。指定されたインターフェイスの銅ポートで、UDLD アグレッシブ モードをイネーブルにする必要があります。



ヒント In-Service Software Upgrade(ISSU; インサービス ソフトウェア アップグレード)中にラインカードのアップグレードが行われていて、ラインカード上の一部のポートがレイヤ 2 ポート チャネルのメンバであり、UDLD アグレッシブ モードで設定されている場合。リモート ポートのいずれかがシャットダウンされた場合、UDLD は、ローカル デバイスの対応するポートを error disabled ステートにします。これは正しい動作です。

ISSU の終了後にサービスを復元するには、ローカル ポートで、shutdown コマンド、no shutdown コマンドの順に実行します。


キャリア遅延


) キャリア遅延タイマーは、VLAN ネットワーク インターフェイスでだけ設定できます。このタイマーを他のインターフェイス モードで設定できません。VLAN ネットワーク インターフェイスの設定手順については、「レイヤ 3 インターフェイスの設定」を参照してください。


リンクがダウン状態になり、キャリア遅延タイマーが期限切れになる前にアップ状態に戻った場合、ダウン状態は効果的にフィルタリングされ、デバイスの他のソフトウェアは、リンクダウン イベントが発生したことを認識しません。大きなキャリア遅延タイマーでは、検出されるリンクアップ/リンクダウン イベントが少なくなります。キャリア遅延時間を 0 に設定すると、デバイスは発生する各リンクアップ/リンクダウン イベントを検出します。

ほとんどの環境では、短い遅延時間は長い遅延時間より良好です。選択する正確な値は、リンク停止の性質およびこれらのリンクがネットワークで持続すると予想される時間によって異なります。データ リンクが短い停止の影響を受ける場合(特に、これらの停止時間が IP ルーティングの収束にかかる時間より短い場合)、長いキャリア遅延の値を設定し、これらの短い停止によってルーティング テーブルで不要な問題が発生するのを防ぐ必要があります。ただし、停止がさらに長くなる傾向がある場合、停止を早く検出し、IP ルート収束が早く始まり早く終わるように、さらに短いキャリア遅延時間を設定できます。

デフォルトのキャリア遅延時間は 2 秒または 50 ミリ秒です。

ポート チャネル パラメータ

ポート チャネルは物理インターフェイスの集合体で、論理インターフェイスを構成します。1 つのポート チャネルに最大 8 つの個別インターフェイスをバンドルして、帯域幅と冗長性を向上させることができます。また、ポート チャネルでは、これらの集約された各物理インターフェイス間でトラフィックのロード バランシングも行います。ポート チャネルの物理インターフェイスが少なくとも 1 つ動作していれば、そのポート チャネルは動作しています。

レイヤ 2 ポート チャネルに適合するレイヤ 2 インターフェイスをバンドルすれば、レイヤ 2 ポート チャネルを作成できます。レイヤ 3 ポート チャネルに適合するレイヤ 3 インターフェイスをバンドルすれば、レイヤ 3 ポート チャネルを作成できます。レイヤ 2 インターフェイスとレイヤ 3 インターフェイスを同一のポート チャネルで組み合わせることはできません。

変更した設定をポート チャネルに適用すると、そのポート チャネルのインターフェイス メンバにもそれぞれ変更が適用されます。

ポート チャネルおよびポート チャネルの設定手順については、「ポート チャネルの設定」を参照してください。

ポート プロファイル

Cisco Nexus 7000 シリーズ デバイスの Cisco NX-OS Release 4.2(1) 以降では、多くのインターフェイス コマンドを含むポート プロファイルを作成し、そのポート プロファイルを一定範囲のインターフェイスに適用できます。各ポート プロファイルは、特定のタイプのインターフェイスにだけ適用できます。次のタイプを選択できます。

イーサネット

VLAN ネットワーク インターフェイス

ループバック

ポート チャネル

トンネル


) インターフェイスのタイプとしてイーサネットを選択すると、ポート プロファイルは、レイヤ 3 のデフォルト モードになります。ポート プロファイルをレイヤ 2 モードに変更するには、switchport コマンドを入力します。


ポート プロファイルを 1 つのインターフェイスまたは一定範囲のインターフェイスに適用すると、ポート プロファイルは継承されます。ポート プロファイルを 1 つのインターフェイスまたは一定範囲のインターフェイスに適用する(継承する)と、システムはそのポート プロファイルのすべてのコマンドをインターフェイスに適用します。さらに、1 つのポート プロファイルに別のポート プロファイルからの設定を継承させることができます。別のポート プロファイルを継承することによって、最初のポート プロファイルは、最初のポート プロファイルと矛盾しない 2 つめの継承されたポート プロファイルのすべてのコマンドを想定できます。4 つのレベルの継承がサポートされています。任意の数のポート プロファイルで同じポート プロファイルを継承できます。

システムは、次のガイドラインに従って、インターフェイスまたは一定範囲のインターフェイスが継承したコマンドを適用します。

矛盾がある場合、インターフェイス モードで入力するコマンドは、ポート プロファイルのコマンドより優先されます。ただし、ポート プロファイルは、ポート プロファイル内にそのコマンドを保持します。

port-profile コマンドがデフォルトのコマンドによって明示的に無効にされない限り、ポート プロファイルのコマンドは、インターフェイスのデフォルトのコマンドより優先されます。

一定範囲のインターフェイスが 2 つ目のポート プロファイルを継承すると、矛盾がある場合、最初のポート プロファイルのコマンドが 2 つ目のポート プロファイルのコマンドを無効にします。

ポート プロファイルを 1 つのインターフェイスまたは一定範囲のインターフェイスに継承後、インターフェイス設定レベルで新しい値を入力することによって、個々の設定値を無効にできます。インターフェイス設定レベルで個々の設定値を削除した場合、インターフェイスは、その値を再びポート プロファイルで使用します。

ポート プロファイルに関連付けられたデフォルトの設定はありません。

コマンドのサブセットは、指定するインターフェイスのタイプによって、ポート プロファイル コンフィギュレーション モードで使用できます。


) ポート プロファイルは Session Manager で使用できません。Session Manager の詳細については、『Cisco Nexus 7000 Series NX-OS System Management Configuration Guide, Release 5.xを参照してください。


ポート プロファイルの設定をインターフェイスに適用するには、特定のポート プロファイルをイネーブルにする必要があります。ポート プロファイルをイネーブルにする前に、ポート プロファイルを一定範囲のインターフェイスに設定し、継承できます。その後、指定されたインターフェイスで設定が実行されるように、そのポート プロファイルをイネーブルにします。

1 つまたは複数のポート プロファイルを元のポート プロファイルに継承した場合、最後に継承されたポート プロファイルだけをイネーブルにする必要があります。システムは、基盤となるポート プロファイルがイネーブルであることを想定します。

一定範囲のインターフェイスからポート プロファイルを削除すると、システムは最初にインターフェイスから設定を解除してから、ポート プロファイルのリンク自体を削除します。また、ポート プロファイルを削除すると、システムは、インターフェイスの設定をチェックし、直接入力されたインターフェイス コマンドによって無効にされた port-profile コマンドをスキップするか、コマンドをデフォルト値に戻します。

他のポート プロファイルによって継承されたポート プロファイルを削除する場合、ポート プロファイルを削除する前に、その継承を削除する必要があります。

また、ポート プロファイルを削除するインターフェイスのサブセットを、そのプロファイルを最初に適用したインターフェイスのグループから選択することもできます。たとえば、ポートプロファイルを設定し、そのポート プロファイルを継承する 10 個のインターフェイスを設定した場合、指定された 10 個のインターフェイスの一部だけからポート プロファイルを削除できます。ポート プロファイルは、適用されている残りのインターフェイスで動作し続けます。

インターフェイス コンフィギュレーション モードを使用して、指定された一定範囲のインターフェイスの特定の設定を削除した場合、その設定もその範囲のインターフェイスのポート プロファイルだけから削除されます。たとえば、ポート プロファイル内にチャネル グループがあり、インターフェイス コンフィギュレーション モードで、そのポート チャネルを削除した場合、指定されたポート チャネルはポート プロファイルからも削除されます。

デバイスと同様に、オブジェクトがインターフェイスに適用されていない状態で、ポート プロファイルのオブジェクトの設定を入力できます。たとえば、Virtual Routing and Forward(VRF)インスタンスは、システムに適用しなくても設定できます。その VRF と付帯的な設定をポート プロファイルから削除しても、システムは影響を受けません。

ポート プロファイルを 1 つのインターフェイスまたは一定範囲のインターフェイスに継承し、特定の設定値を削除した後、そのポート プロファイルの設定は、指定されたインターフェイスで動作しません。

ポート プロファイルを誤ったタイプのインターフェイスに適用しようとすると、エラーが返されます。

ポート プロファイルをイネーブルにするか、継承するか、または修正しようとすると、チェックポイントが作成されます。ポート プロファイルの設定が失敗した場合、以前の設定にロールバックし、エラーが返されます。ポート プロファイルは部分的にだけ適用されることはありません。

タイム ドメイン反射率計(TDR)ケーブル診断

Cisco Nexus 7000 シリーズ デバイスの Cisco NX-OS Release 5.0(2) および最新世代のラインカードの導入以降では、高価なサードパーティ製機器を使用せずに、ケーブル診断を実施できます。ラインカードに直接組み込まれているケーブル診断機能を使用すると、リンク障害の診断のために、ケーブルを取り外して、ケーブル テスターを接続する必要がありません。ラインカード上の各ポートは、Time Domain Reflectometry(TDR; タイム ドメイン反射率計)と呼ばれる新しいテクノロジーを使用して、単独でケーブルの問題を検出し、これらの問題をスイッチ ソフトウェアにレポートできます。

TDR は、パルス波形信号を送信し、反射した波形の極性、振幅、および往復時間を検査することによって、導体を分析するために使用される技術です。

ケーブル内での信号の伝播速度を推定し、その反射が送信元に戻るまでの時間を測定することによって、反射点までの距離を測定できます。また、元のパルスの極性および振幅をその反射率と比較することによって、異なるタイプの障害(たとえば、開いたペアまたは短絡したペア)を区別できます。

ケーブルの障害をリモートで診断できるので、問題の根本的な原因をより早くより効果的に特定できるようになり、ユーザは接続問題にすばやく対応できます。

ライセンス要件

次の表に、この機能のライセンス要件を示します。

 

製品
ライセンス要件

Cisco NX-OS

基本インターフェイス パラメータにライセンスは必要ありません。ライセンス パッケージに含まれていない機能はすべて Cisco NX-OS システム イメージにバンドルされており、追加費用は一切発生しません。Cisco NX-OS のライセンス スキームの詳細については、『 Cisco Nexus 7000 Series NX-OS Licensing Guide, Release 5.x を参照してください。


) VDC を使用する場合は Advanced Services ライセンスが必要です。


注意事項および制約事項

次の注意事項と制約事項に従って基本インターフェイス パラメータを設定します。

光ファイバ イーサネット ポートでは、シスコがサポートするトランシーバを使用する必要があります。シスコがサポートするトランシーバをポートに使用していることを確認するには、 show interface transceivers コマンドを使用します。シスコがサポートするトランシーバを持つインターフェイスは、機能インターフェイスとして一覧表示されます。

ポートはレイヤ 2 またはレイヤ 3 インターフェイスのいずれかです。両方が同時に成立することはありません。

デフォルトでは、どのポートもレイヤ 3 インターフェイスです。

レイヤ 3 インターフェイスをレイヤ 2 インターフェイスに変更するには、 switchport コマンドを使用します。レイヤ 2 インターフェイスをレイヤ 3 インターフェイスに変更するには、 no switchport コマンドを使用します。

ローカル ポートにフロー制御を設定する場合は、次の点に注意します。

リモート ポート送信パラメータの設定手順が不明の場合にポーズ フレームを受信するには、ローカル ポート受信パラメータを指定済みに設定します。

リモート ポート送信パラメータがイネーブルまたは指定済みである場合にポーズ フレームを受信するには、ローカル ポート受信パラメータをイネーブルに設定します。

受信したポーズ フレームを無視するには、ローカル ポート受信パラメータをディセーブルに設定します。

リモート ポート受信パラメータの設定手順が不明の場合にポーズ フレームを送信するには、ローカル ポート送信パラメータを指定済みに設定します。

リモート ポート受信パラメータがイネーブルまたは指定済みである場合にポーズ フレームを送信するには、ローカル ポート送信パラメータをイネーブルに設定します。

ポーズ フレームを送信しないようにするには、ローカル ポート送信パラメータをディセーブルに設定します。

通常、イーサネット ポート速度およびデュプレックス モード パラメータは自動に設定し、システムがポート間で速度およびデュプレックス モードをネゴシエートできるようにします。これらのポートのポート速度およびデュプレックス モードを手動で設定する場合は、次の点について考慮してください。

イーサネットまたは管理インターフェイスに速度およびデュプレックス モードを設定する前に、表 2-2 を参照して同時に設定できる速度およびデュプレックス モードの組み合わせを確認します。

イーサネット ポート速度を自動に設定すると、デバイスは自動的にデュプレックス モードを自動に設定します。

no speed コマンドを開始すると、デバイスは速度およびデュプレックス パラメータの両方を自動的に自動に設定します( no speed コマンドを入力すると、 speed auto コマンドを入力した場合と同じ結果になります)。

イーサネット ポート速度を自動以外の値(10 Mb/s、100 Mb/s、1000 Mb/s など)に設定する場合は、それに合わせて接続先ポートを設定してください。接続先ポートが速度をネゴシエートするように設定しないでください。


) 接続先ポートが自動以外の値に設定されている場合、デバイスはイーサネット ポート速度およびデュプレックス モードを自動的にネゴシエートできません。



注意 イーサネット ポート速度およびデュプレックス モードの設定を変更すると、インターフェイスがシャットダウンされてから再びイネーブルになる場合があります。

基本インターフェイス パラメータの設定

インターフェイスを設定する場合、パラメータを設定する前にインターフェイスを指定する必要があります。

ここでは、インターフェイスを指定してそれぞれの基本パラメータを設定する方法について説明します。

「設定するインターフェイスの指定」

「説明の設定」

「ビーコン モードの設定」

「帯域幅レート モードの変更」

「Error-Disabled ステートの設定」

「MDIX パラメータの設定」

「デバウンス タイマーの設定」

「インターフェイス速度およびデュプレックス モードの設定」

「フロー制御の設定」

「MTU サイズの設定」

「帯域幅の設定」

「スループット遅延の設定」

「インターフェイスのシャットダウンおよび再開」

「UDLD モードの設定」

「キャリア遅延タイマーの設定」

「ポート プロファイルの設定」

「TDR ケーブル診断の実施」

設定するインターフェイスの指定

同じタイプの 1 つ以上のインターフェイスのパラメータを設定する前に、インターフェイスのタイプと ID を指定する必要があります。

表 2-5 に、イーサネット インターフェイスおよび管理インターフェイスを指定するために使用するインターフェイス タイプと ID を示します。

表 2-5 設定するインターフェイスの識別に必要な情報

インターフェイス タイプ
ID

イーサネット

I/O モジュールのスロット番号およびモジュールのポート番号

管理

0(ポート 0)

インターフェイス範囲コンフィギュレーション モードを使用すると、同じ設定パラメータを持つ複数のインターフェイスを設定できます。インターフェイス範囲コンフィギュレーション モードを開始すると、インターフェイス範囲コンフィギュレーション モードを終了するまで、入力するすべてのコマンド パラメータが範囲内のすべてのインターフェイスに適用されます。

ダッシュ(-)とカンマ(,)を使用して、一定範囲のインターフェイスを入力します。ダッシュは連続するインターフェイスを区切り、カンマは連続しないインターフェイスを区切ります。連続しないインターフェイスを入力する場合、各インターフェイスのメディア タイプを入力する必要があります。

次に、連続するインターフェイス範囲を設定する例を示します。

switch(config)# interface ethernet 2/29-30
switch(config-if-range)#

 

次に、連続しないインターフェイス範囲を設定する例を示します。

switch(config)# interface ethernet 2/29, ethernet 2/33, ethernet 2/35
switch(config-if-range)#

 

サブインターフェイスが同じポートにある場合にだけ(例:2/29.1-2)、サブインターフェイスを範囲内で指定できます。しかし、一定範囲のポートにあるサブインターフェイスを指定できません。たとえば、2/29.2-2/30.2 は入力できません。2 つのサブインターフェイスを個別に指定できます。たとえば、2/29.2, 2/30.2 は入力できます。

手順の概要

1. configure terminal

2. interface interface

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface

 

例 1:

switch(config)# interface ethernet 2/1

switch(config-if)#

 

例 2:

switch(config)# interface mgmt0

switch(config-if)#

設定するインターフェイスを指定します。インターフェイス タイプと ID を指定できます。イーサネット ポートの場合、「ethernet slot/port 」を使用します。管理インターフェイスの場合、「mgmt0」を使用します。

例 1 は、スロット 2、ポート 1 イーサネット インターフェイスを指定する方法です。

例 2 は、管理インターフェイスを指定する方法です。


) インターフェイス タイプと ID の間に空白を追加する必要はありません(ポートまたはスロット/ポート番号)。たとえば、イーサネット スロット 4、ポート 5 のインターフェイスの場合、「ethernet 4/5」または「ethernet4/5」と指定できます。管理インターフェイスは、「mgmt0」または「mgmt 0」です。


インターフェイス コンフィギュレーション モードの場合、コマンドを入力するとこのモードに指定したインターフェイスが設定されます。

説明の設定

イーサネットおよび管理インターフェイスの説明を文字で設定します。使用できるのは英数字 80 字以内で、大文字と小文字は区別されます。

手順の概要

1. configure terminal

2. interface interface

3. description text

4. show interface interface

5. exit

6. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface

 

例:

switch(config)# interface ethernet 2/1

switch(config-if)#

 

switch(config)# interface mgmt0

switch(config-if)#

 

設定するインターフェイスを指定します。インターフェイス タイプと ID を指定できます。イーサネット ポートの場合、「ethernet slot/port 」を使用します。管理インターフェイスの場合、「mgmt0」を使用します。

例 1 は、スロット 2、ポート 1 イーサネット インターフェイスを指定する方法です。

例 2 は、管理インターフェイスを指定する方法です。

ステップ 3

description text

 

例:

switch(config-if)# description Ethernet port 3 on module 1.

switch(config-if)#

インターフェイスの説明を指定します。説明に使用できる文字数は最大 80 文字です。

ステップ 4

show interface interface

 

例:

switch(config)# show interface ethernet 2/1

インターフェイス ステータスを表示します。説明パラメータもあわせて表示します。

ステップ 5

exit

 

例:

switch(config-if)# exit

switch(config)#

インターフェイス モードを終了します。

ステップ 6

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、モジュール 3 のイーサネット ポート 24 にインターフェイスの説明を設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 3/24
switch(config-if)# description server1
switch(config-if)#

ビーコン モードの設定

イーサネット ポートのビーコン モードをイネーブルにして LED を点滅させ、物理的な位置を確認します

手順の概要

1. configure terminal

2. interface ethernet slot / port

3. beacon | { no beacon }

4. show interface ethernet slot / port

5. exit

6. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface ethernet slot/port

 

例:

switch(config)# interface ethernet 3/1

switch(config-if)#

設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

beacon | { no beacon }

 

例:

switch(config-if)# beacon

switch(config-if)#

ビーコン モードをイネーブルにします。またはビーコン モードをディセーブルにします。デフォルト モードはディセーブルです。

ステップ 4

show interface ethernet slot/port

 

例:

switch(config)# show interface ethernet 2/1

インターフェイス ステータスを表示します。ビーコン モード ステータスもあわせて表示します。

ステップ 5

exit

 

例:

switch(config-if)# exit

switch(config)#

インターフェイス モードを終了します。

ステップ 6

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、イーサネット ポート 3/1 のビーコン モードをイネーブルにする例を示します。

switch# configure terminal
switch(config)# interface ethernet 3/1
switch(config-if)# beacon
switch(config-if)#
 

次に、イーサネット ポート 3/1 のビーコン モードをディセーブルにする例を示します。

switch# configure terminal
switch(config)# interface ethernet 3/1
switch(config-if)# no beacon
switch(config-if)#

帯域幅レート モードの変更

32 ポート 10 ギガビット イーサネット モジュールの 10 GB ごとの帯域幅を 1 ポート専用にするのか同じポート グループの 4 つのポートで共有させるのかを指定できます

ここでは、次の内容について説明します。

「ポート プロファイルの作成」

「帯域幅をポート グループ内で共有」

1 ポート専用帯域幅

帯域幅を 1 つのポート専用にする場合、最初にそのグループの 4 つのポートを管理シャットダウンしてレート モードを専用に変更し、専用ポートを管理的にアップする必要があります。

手順の概要

1. configure terminal

2. interface ethernet slot / port, ethernet slot/port, ethernet slot/port, ethernet slot/port

3. shutdown

4. interface ethernet slot/port

5. rate-mode dedicated

6. no shutdown

7. show interface ethernet slot/port capabilities

8. exit

9. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface ethernet slot/port , ethernet slot/port , ethernet slot/port , ethernet slot/port

 

例:

switch(config)# interface ethernet 3/1, ethernet 3/3, ethernet 3/5, ethernet 3/7

switch(config-if)#

設定するイーサネット インターフェイスを指定します。インターフェイス コンフィギュレーション モードを開始します。

次に、1 つのポートを専用モードに指定する例を示します。

ステップ 3

shutdown

 

例:

switch(config)# shutdown

ポートを管理シャットダウンします。

ステップ 4

interface ethernet slot/port

 

例:

switch(config)# interface ethernet 3/1

switch(config)#

インターフェイスのグループで最初のイーサネット インターフェイスを指定します。

ステップ 5

rate-mode dedicated

 

例:

switch(config-if)# rate-mode dedicated

switch(config-if)#

10 GB の全帯域幅を 1 つのポート専用にします。帯域幅を専用にすると、以後のポートのサブコマンドはすべて専用モードになります。

ステップ 6

no shutdown

 

例:

switch(config-if)# no shutdown

ポートを管理的にアップします。

ステップ 7

show interface ethernet slot/port capabilities

 

例:

switch(config)# show interface ethernet 3/1

現在のレート モードを含むインターフェイス情報を表示します。

ステップ 8

exit

 

例:

switch(config-if)# exit

switch(config)#

インターフェイス モードを終了します。

ステップ 9

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、ポート 4/17、4/19、4/21、4/23 を含むグループでイーサネット ポート 4/17 の専用モードを設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 4/17, ethernet 4/19, ethernet 4/21, ethernet 4/23
switch(config-if)# shutdown
switch(config-if)# interface ethernet 4/17
switch(config-if)# rate-mode dedicated
switch(config-if)# no shutdown
switch(config-if)#

帯域幅をポート グループ内で共有

10 GB の帯域幅を 32 ポート 10 ギガビット イーサネット モジュールのポート グループ(4 ポート)で共有できます。帯域幅を共有するには、専用ポートを管理的にダウンさせて帯域幅を共有するポートを指定し、レート モードを共有に変更してからポートを管理的にアップします。

作業を開始する前に

同じグループのすべてのポートが同じ VDC に属している必要があります。

手順の概要

1. configure terminal

2. interface ethernet slot / port

3. shutdown

4. interface ethernet slot/port , ethernet slot/port , ethernet slot/port , ethernet slot/port

5. rate-mode shared

6. no shutdown

7. show interface ethernet slot/port

8. exit

9. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface ethernet slot/port

 

例:

switch(config)# interface ethernet 3/1

switch(config)#

インターフェイスのグループで最初のイーサネット インターフェイスを指定します。

ステップ 3

shutdown

 

例:

switch(config-if)# shutdown

ポートを管理的にダウンさせます。

ステップ 4

interface ethernet slot/port, ethernet slot/port, ethernet slot/port, ethernet slot/port

 

例:

switch(config)# interface ethernet 3/1, ethernet 3/3, ethernet 3/5, ethernet 3/7

switch(config-if)#

設定する 4 つのイーサネット インターフェイスを指定し(同じポート グループに所属している必要があります)、インターフェイス コンフィギュレーション モードを開始します。

次に、1 つのポートを専用モードに指定する例を示します。

ステップ 5

rate-mode shared

 

例:

switch(config-if)# rate-mode shared

switch(config-if)#

指定したポートに共有レート モードを設定します。

次に、共有モードを設定する例を示します。

ステップ 6

no shutdown

 

例:

switch(config-if)# no shutdown

ポートを管理的にアップします。

ステップ 7

show interface ethernet slot/port

 

例:

switch(config)# show interface ethernet 3/1

現在のレート モードを含むインターフェイス情報を表示します。

ステップ 8

exit

 

例:

switch(config-if)# exit

switch(config)#

インターフェイス モードを終了します。

ステップ 9

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、ポート 4/17、4/19、4/21、4/23 を含むグループでイーサネット ポート 4/17 の共有モードを設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 4/17
switch(config-if)# shutdown
switch(config)# interface ethernet 4/17, ethernet 4/19, ethernet 4/21, ethernet 4/23
switch(config-if)# rate-mode shared
switch(config-if)# no shutdown
switch(config-if)#

Error-Disabled ステートの設定

インターフェイスが error-disabled ステートに移行する理由を表示し、自動回復を設定できます。

ここでは、次の内容について説明します。

「Error Disable 検出のイネーブル化」

「Error-Disabled 回復のイネーブル化」

「Error-Disabled 回復間隔の設定」

Error Disable 検出のイネーブル化

アプリケーションでの error-disable 検出をイネーブルにできます。その結果、原因がインターフェイスで検出された場合、インターフェイスは error-disabled ステートとなり、リンクダウン ステートに類似した動作ステートとなります。

手順の概要

1. configure terminal

2. errdisable detect cause { acl-exception | all | link-flap | loopback }

3. shutdown

4. no shutdown

5. show interface status err-disabled

6. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

errdisable detect cause { acl-exception | all | link-flap | loopback }

 

例:

switch(config)# errdisable detect cause all

switch(config)#

インターフェイスを error-disabled ステートにする条件を指定します。デフォルトはディセーブルです。

ステップ 3

shutdown

 

例:

switch(config)# shutdown

switch(config)#

インターフェイスを管理的にダウンさせます。インターフェイスを error-disabled ステートから手動で回復させるには、最初にこのコマンドを入力します。

ステップ 4

no shutdown

 

例:

switch(config)# no shutdown

switch(config)#

インターフェイスを管理的にアップし、error-disabled ステートから手動で回復させるインターフェイスをイネーブルにします。

ステップ 5

show interface status err-disabled

 

例:

switch(config)# show interface status err-disabled

error-disabled インターフェイスに関する情報を表示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次の例では、すべての場合で error-disabled 検出をイネーブルにする方法を示します。

switch(config)# errdisable detect cause all

switch(config)#

Error-Disabled 回復のイネーブル化

インターフェイスを error-disabled ステートから回復させ、再びアップするアプリケーションを指定できます。回復タイマーを設定しない限り、300 秒後にリトライします( errdisable recovery interval コマンドを参照)。

手順の概要

1. configure terminal

2. errdisable recovery cause { all | bpdguard | link-flap | psecure-violation | security-violation | storm-control | udld }

3. show interface status err-disabled

4. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

errdisable recovery cause { all | bpduguard | link-flap | psecure-violation | security-violation | storm-control | udld }

 

例:

switch(config)# errdisable recovery cause all

switch(config-if)#

インターフェイスが error-disabled ステートから自動的に回復する条件を指定すると、デバイスはインターフェイスを再びアップします。デバイスは 300 秒後にリトライします。デフォルトはディセーブルです。

ステップ 3

show interface status err-disabled

 

例:

switch(config)# show interface status err-disabled

error-disabled インターフェイスに関する情報を表示します。

ステップ 4

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次の例では、すべての条件で error-disabled 回復をイネーブルにする方法を示します。

switch(config)# errdisable recovery cause all
 

Error-Disabled 回復間隔の設定

error-disabled 回復タイマーの値を設定できます。

手順の概要

1. configure terminal

2. errdisable recovery interval interval

3. show interface status err-disabled

4. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

errdisable recovery interval interval

 

例:

switch(config)# errdisable recovery interval 32

switch(config-if)#

インターフェイスが error-disabled ステートから回復する間隔を指定します。有効範囲は 30 ~ 65535 秒で、デフォルトは 300 秒です。

ステップ 3

show interface status err-disabled

 

例:

switch(config)# show interface status err-disabled

error-disabled インターフェイスに関する情報を表示します。

ステップ 4

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次の例では、error-disabled 回復タイマーが回復の間隔を 32 秒に設定するように設定する方法を示します。

switch(config)# errdisable recovery interval 32
switch(config)#

MDIX パラメータの設定

接続のタイプ(クロスオーバーまたはストレート)を他の銅線イーサネット ポート専用にする必要がある場合は、ローカル ポートの Medium Dependent Independent Crossover(MDIX)パラメータをイネーブルにします。デフォルトでは、このパラメータはイネーブルです

作業を開始する前に

リモート ポートの MDIX をイネーブルにする必要があります。

手順の概要

1. configure terminal

2. interface ethernet slot/port

3. { mdix auto } | { no mdix }

4. show interface ethernet slot / port

5. exit

6. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface ethernet slot / port

 

例:

switch(config)# interface ethernet 3/1

switch(config-if)#

設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

{ mdix auto} | {no mdix}

 

例:

switch(config-if)# mdix auto

switch(config-if)#

ポートの MDIX 検出をイネーブルまたはディセーブルに指定します。

ステップ 4

show interface ethernet slot / port

 

例:

switch(config)# show interface ethernet 3/1

switch(config-if)#

インターフェイス ステータスを表示します。MDIX ステータスもあわせて表示します。

ステップ 5

exit

 

例:

switch(config-if)# exit

switch(config)#

インターフェイス モードを終了します。

ステップ 6

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、イーサネット ポート 3/1 の MDIX をイネーブルにする例を示します。

switch# configure terminal
switch(config)# interface ethernet 3/1
switch(config-if)# mdix auto
switch(config-if)#
 

次に、イーサネット ポート 3/1 の MDIX をディセーブルにする例を示します。

switch# configure terminal
switch(config)# interface ethernet 3/1
switch(config-if)# no mdix
switch(config-if)#

デバウンス タイマーの設定

イーサネット ポートのデバウンス タイマーをイネーブルにするには、デバウンス時間をミリ秒(ms)で指定します。ディセーブルにするにはデバウンス時間を 0 に指定します。

show interface debounce コマンドを使用すると、すべてのイーサネット ポートのデバウンス時間を表示できます。

手順の概要

1. configure terminal

2. interface ethernet slot/port

3. link debounce time milliseconds

4. show interface debounce

5. exit

6. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface ethernet slot / port

 

例:

switch(config)# interface ethernet 3/1

switch(config-if)#

設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

link debounce time milliseconds

 

例:

switch(config-if)# link debounce time 1000

switch(config-if)#

合計時間を指定してデバウンス タイマーをイネーブルにします(0 ~ 5000 ms)。

0 ミリ秒を指定すると、デバウンス タイマーはディセーブルになります。

ステップ 4

show interface debounce

 

例:

switch(config)# show interface debounce

switch(config-if)#

すべてのイーサネット インターフェイスのリンク デバウンス時間を表示します。

ステップ 5

exit

 

例:

switch(config-if)# exit

switch(config)#

インターフェイス モードを終了します。

ステップ 6

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、イーサネット ポート 3/1 のデバウンス タイマーをイネーブルにし、デバウンス時間を 1,000 ms に設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 3/1
switch(config-if)# link debounce time 1000
switch(config-if)#
 

次に、イーサネット ポート 3/1 のデバウンス タイマーをディセーブルにする例を示します。

switch# configure terminal
switch(config)# interface ethernet 3/1
switch(config-if)# link debounce time 0
switch(config-if)#

インターフェイス速度およびデュプレックス モードの設定

インターフェイス速度とデュプレックス モードは相関関係にあります。このため、両方のパラメータを同時に設定する必要があります。

イーサネット インターフェイスおよび管理インターフェイスに同時に設定できる速度およびデュプレックス モードにつては、表 2-2 を参照してください。


) 指定するインターフェイス速度はインターフェイスで使用するデュプレックス モードに影響を与えます。このため、デュプレックス モードを設定する前に速度を設定する必要があります。自動ネゴシエーションの速度を設定する場合、デュプレックス モードは自動的に自動ネゴシエーションに設定されます。速度を 10 または 100 Mb/s に指定すると、ポートでは半二重モードを使用するように自動的に設定されますが、全二重モードを指定することもできます。1000 Mb/s(1 Gb/s)以上の速度に設定すると、自動的に全二重モードが使用されます。


作業を開始する前に

リモート ポートの速度設定はローカル ポートへの変更をサポートします。ローカル ポートを固有の速度で使用するには、リモート ポートにも同じ速度を設定するか、ローカル ポートがその速度を自動ネゴシエートするように設定する必要があります。

手順の概要

1. configure terminal

2. interface interface

3. speed {{ 10 | 100 | 1000 | { auto [ 10 100 [ 1000 ]]}} | { 10000 | auto }}

4. duplex { full | half | auto }

5. show interface interface

6. exit

7. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface

 

例 1:

switch(config)# interface ethernet 2/1

switch(config-if)#

 

例 2:

switch(config)# interface mgmt0

switch(config-if)#

 

設定するインターフェイスを指定します。インターフェイス タイプと ID を指定できます。イーサネット ポートの場合、「ethernet slot/port 」を使用します。管理インターフェイスの場合、「mgmt0」を使用します。

例 1 は、スロット 2、ポート 1 イーサネット インターフェイスを指定する方法です。

例 2 は、管理インターフェイスを指定する方法です。

ステップ 3

speed { { 10 | 100 | 1000 | { auto [ 10 100 [ 1000 ]]}} | { 10000 | auto }}

 

例:

switch(config-if)# speed 1000

switch(config-if)#

48 ポート 10/100/1000 モジュールのイーサネット ポートでは 10 Mb/s、100 Mb/s、1000 Mb/s の速度を設定します。またはポートの速度を同じリンクの他の 10/100/1000 ポートと自動ネゴシエートするように設定します。

32 ポート 10 ギガビット イーサネット モジュールのイーサネット ポートでは 10,000 Mb/s(10 Gb/s)の速度を設定します。または、ポートがリンクの他の 10 ギガビット イーサネット ポートの速度と自動ネゴシエートするように設定します。

管理インターフェイスでは、速度を 1000 Mb/s に設定します。あるいはポートがその速度と自動ネゴシエートするように設定します。

ステップ 4

duplex { full | half | auto }

 

例:

switch(config-if)# duplex full

全二重モード、半二重モード、自動ネゴシエート モードを指定します。

ステップ 5

show interface interface

 

例:

switch(config)# show interface mgmt0

インターフェイス ステータスを表示します。速度およびデュプレックス モード パラメータもあわせて表示します。

ステップ 6

exit

 

例:

switch(config-if)# exit

switch(config)#

インターフェイス モードを終了します。

ステップ 7

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、スロット 3 の 48 ポート 10/100/1000 モジュールのイーサネット ポート 1 の速度を 1000 Mb/s に設定し、全二重モードに設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 3/1
switch(config-if)# speed 1000
switch(config-if)# duplex full
switch(config-if)#

フロー制御の設定

1 Gb/s 以上で動作するイーサネット ポートの場合、フロー制御ポーズ フレームを送受信するポートをイネーブルまたはディセーブルにできます。1 Gb/s 未満で動作するイーサネット ポートの場合、ポーズ フレームを受信するポートの性能だけをイネーブルまたはディセーブルにできます

ローカル ポートのフロー制御をイネーブルにすると、リモート ポートでのフロー制御設定にかかわらずローカル ポートでのフレームの送受信を完全にイネーブルにするか、リモート ポートで指定して使用する設定をローカルポートで使用するように設定します。ローカルおよびリモート ポートのフロー制御をどちらもイネーブルにする、一方のポートのフロー制御を指定して設定する、あるいはこの 2 つの状態を組み合わせて設定する場合、それらのポートではフロー制御がイネーブルです。


) 10 Gb/s で動作するポートの場合、状態を指定してパラメータを送受信できません。


作業を開始する前に

必要なフロー制御に対応する設定がリモート ポートにあることを確認します。ローカル ポートからフロー制御ポーズ フレームを送信するには、リモート ポートの受信パラメータがオンまたは指定になっていることを確認します。ローカル ポートでフロー制御ポーズ フレームを受信するには、リモート ポートの送信パラメータがオンまたは指定になっていることを確認します。フロー制御を使用しない場合は、リモート ポートの送信パラメータおよび受信パラメータをオフにします。

手順の概要

1. configure terminal

2. interface ethernet slot/port

3. flowcontrol { send | receive } { desired | on | off }

4. show interface ethernet slot/port

5. show interface flowcontrol

6. exit

7. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# config terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface ethernet slot / port

 

例:

switch(config)# interface ethernet 3/1

switch(config-if)#

イーサネット インターフェイスにスロット番号およびポート番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

flowcontrol { send | receive } { desired | on | off }

 

例:

switch(config-if)# flowcontrol send on

switch(config)-if#

ポートのフロー制御設定を指定します。1000 Mb/s 以上で動作するポートにだけ送信設定を指定できます。受信設定は任意の速度で動作するポートに設定できます。

ステップ 4

show interface ethernet slot / port

 

例:

switch(config)# show interface ethernet 3/1

switch(config)

インターフェイス ステータスを表示します。フロー制御パラメータもあわせて表示します。

ステップ 5

show interface flowcontrol

 

例:

switch(config)# show interface flowcontrol

switch(config)

すべてのイーサネット ポートのフロー制御状態を表示します。

ステップ 6

exit

 

例:

switch(config-if)# exit

switch(config)#

インターフェイス モードを終了します。

ステップ 7

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、イーサネット ポート 3/1 を設定してフロー制御ポーズ フレームを送信する例を示します。

switch# configure terminal
switch(config)# interface ethernet 3/1
switch(config-if)# flowcontrol send on
switch(config-if)#

MTU サイズの設定

レイヤ 2 およびレイヤ 3 イーサネット インターフェイスの最大伝送ユニット(MTU)サイズを設定できます。レイヤ 3 インターフェイスでは、576 ~ 9216 バイトの MTU を設定できます(偶数値にする必要があります)。レイヤ 2 インターフェイスでは、システム デフォルト MTU(1500 バイト)またはシステム ジャンボ MTU サイズ(デフォルト サイズは 9216 バイト)の MTU を設定できます。


) システム ジャンボ MTU サイズは変更できますが、この値を変更した場合は、値を使用するレイヤ 2 インターフェイスもアップデートして、新しいシステム ジャンボ MTU 値を使用する必要があります。レイヤ 2 インターフェイスの MTU 値をアップデートしない場合、これらのインターフェイスはシステム デフォルト MTU(1500 バイト)を使用します。


デフォルトでは、Cisco NX-OS はレイヤ 3 パラメータを設定します。レイヤ 2 パラメータを設定するには、ポート モードをレイヤ 2 に切り替える必要があります。

ポート モードを変更するには switchport コマンドを使用します。

ポート モードをレイヤ 2 に変更した後でレイヤ 3 に戻ってレイヤ 3 インターフェイスを設定するには、 no switchport コマンドを使って再びポート モードを変更します。

ここでは、次の内容について説明します。

「インターフェイス MTU サイズの設定」

「システム ジャンボ MTU サイズの設定」

インターフェイス MTU サイズの設定

レイヤ 3 インターフェイスでは、576 ~ 9216 バイトの MTU サイズを設定できます。

レイヤ 2 インターフェイスでは、すべてのレイヤ 2 インターフェイスをデフォルト MTU サイズ(1500 バイト)またはシステム ジャンボ MTU サイズ(デフォルト サイズは 9216 バイト)を使用するように設定できます。

レイヤ 2 インターフェイスとは異なるシステム ジャンボ MTU サイズを使用する場合は、「システム ジャンボ MTU サイズの設定」を参照してください。

手順の概要

1. configure terminal

2. interface ethernet slot / port

3. switchport | { no switchport }

4. mtu size

5. show interface ethernet slot / port

6. exit

7. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface ethernet slot/port

 

例:

switch(config)# interface ethernet 3/1

switch(config-if)#

設定するイーサネット インターフェイスを指定します。インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switchport | { no switchport }

 

例:

switch(config-if)# no switchport

switch(config-if)#

レイヤ 2 またはレイヤ 3 を使用するように指定します。

ステップ 4

mtu size

 

例:

switch(config-if)# mtu 9216

switch(config-if)#

レイヤ 2 インターフェイスでは、デフォルト MTU サイズ(1500)またはシステム ジャンボ MTU サイズ(システム ジャンボ MTU サイズを変更していない場合は 9216)を指定します。

レイヤ 3 インターフェイスでは、576 ~ 9216 の任意の偶数を指定します。

ステップ 5

show interface ethernet slot/port

 

例:

switch(config)# show interface ethernet 2/1

インターフェイス ステータスを表示します。MTU サイズもあわせて表示します。

ステップ 6

exit

 

例:

switch(config-if)# exit

switch(config)#

インターフェイス モードを終了します。

ステップ 7

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、レイヤ 2 イーサネット ポート 3/1 にデフォルト MTU サイズ(1500)を設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 3/1
switch(config-if)# switchport
switch(config-if)# mtu 1500
switch(config-if)#

システム ジャンボ MTU サイズの設定

システム ジャンボ MTU サイズを設定するとレイヤ 2 インターフェイスの MTU サイズを指定できます。1500 ~ 9216 の偶数を指定できます。システム ジャンボ MTU サイズを設定しない場合、デフォルトは 9216 バイトです。

手順の概要

1. configure terminal

2. system jumbomtu size

3. show running-config

4. interface type slot/port

5. mtu size

6. exit

7. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

system jumbomtu size

 

例:

switch(config)# system jumbomtu 8000

switch(config)#

システム ジャンボ MTU サイズを指定します。1500 ~ 9216 の偶数を使用します。

ステップ 3

show running-config all

 

例:

switch(config)# show running-config all | include jumbomtu

現在の動作設定を表示します。システム ジャンボ MTU サイズもあわせて表示します。

ステップ 4

interface type slot/port

 

例:

switch(config)# interface ethernet 2/1

switch(config-if)#

設定するインターフェイスを指定します。インターフェイス コンフィギュレーション モードを開始します。

ステップ 5

mtu size

 

例:

switch(config-if)# mtu 1500

switch(config-if)#

レイヤ 2 インターフェイスでは、デフォルト MTU サイズ(1500)または以前指定したシステム ジャンボ MTU サイズを指定します。

レイヤ 3 インターフェイスでは、576 ~ 9216 の任意の偶数サイズを指定します。

ステップ 6

exit

 

例:

switch(config-if)# exit

switch(config)#

インターフェイス モードを終了します。

ステップ 7

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、システム ジャンボ MTU を 8000 バイトに設定し、以前ジャンボ MTU サイズに設定したインターフェイスの MTU に変更する例を示します。

switch# configure terminal
switch(config)# system jumbomtu 8000
switch(config)# show running-config
switch(config)# interface ethernet 2/2
switch(config-if)# switchport
switch(config-if)# mtu 4608
switch(config-if)#

帯域幅の設定

イーサネット インターフェイスの帯域幅を設定できます。物理レベルでは 1 GB の変更不可能な帯域幅を使用しますが、レベル 3 プロトコルには 1 ~ 10,000,000 Kb の値を設定できます

手順の概要

1. configure terminal

2. interface ethernet slot / port

3. bandwidth kbps

4. show interface ethernet slot / port

5. exit

6. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface ethernet slot/port

 

例:

switch(config)# interface ethernet 3/1

switch(config-if)#

設定するイーサネット インターフェイスを指定します。インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

bandwidth kbps

 

例:

switch(config-if)# bandwidth 1000000

switch(config-if)#

情報用としてのみ 1 ~ 10,000,000 の値を帯域幅に指定します。

ステップ 4

show interface ethernet slot/port

 

例:

switch(config)# show interface ethernet 2/1

インターフェイス ステータスを表示します。帯域幅の値もあわせて表示します。

ステップ 5

exit

 

例:

switch(config-if)# exit

switch(config)#

インターフェイス モードを終了します。

ステップ 6

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、イーサネット スロット 3、ポート 1 インターフェイス帯域幅パラメータに情報用の値 1,000,000 Kb を設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 3/1
switch(config-if)# bandwidth 1000000
switch(config-if)#

スループット遅延の設定

イーサネット インターフェイスのインターフェイス スループット遅延を設定できます。実際の遅延時間は変わりませんが、1 ~ 16777215 の情報値を設定できます。単位は 10 マイクロ秒です

手順の概要

1. configure terminal

2. interface ethernet slot / port

3. delay value

4. show interface ethernet slot / port

5. exit

6. copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface ethernet slot / port

 

例:

switch(config)# interface ethernet 3/1

switch(config-if)#

設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

delay value

 

例:

switch(config-if)# delay 10000

switch(config-if)#

遅延時間を設定します。単位は 10 マイクロ秒です。 1 ~ 16777215 の情報値を設定できます。単位は 10 マイクロ秒です。

ステップ 4

show interface ethernet slot / port

 

例:

switch(config)# show interface ethernet 3/1

switch(config-if)#

インターフェイス ステータスを表示します。スループット遅延時間もあわせて表示します。

ステップ 5

exit

 

例:

switch(config-if)# exit

switch(config)#

インターフェイス モードを終了します。

ステップ 6

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、1 つのインターフェイスが別のインターフェイスより優先されるように、スループット遅延時間を設定する方法を示します。低い遅延値は高い遅延値より優先されます。次の例では、イーサネット 7/48 は 7/47 より優先されます。7/48 のデフォルト遅延は、最も高い値(16777215)に設定されている 7/47 の設定値より低くなっています。

switch# configure terminal
switch(config)# interface ethernet 7/47
switch(config-if)# delay 16777215
switch(config-if)# ip address 192.168.10.1/24
switch(config-if)# ip router eigrp 10
switch(config-if)# no shutdown
switch(config-if)# exit
switch(config)# interface ethernet 7/48
switch(config-if)# ip address 192.168.11.1/24
switch(config-if)# ip router eigrp 10
switch(config-if)# no shutdown
switch(config-if)#
 

feature eigrp コマンドを実行して、最初に EIGRP 機能がイネーブルであることを確認する必要があります。


インターフェイスのシャットダウンおよび再開

イーサネットまたは管理インターフェイスはシャットダウンして再起動できます。インターフェイスはシャットダウンするとディセーブルになり、すべてのモニタ画面にはダウン状態で表示されます。この情報は、すべてのダイナミック ルーティング プロトコルによってその他のネットワーク サーバに伝達されます。シャットダウンしたインターフェイスはどのルーティング アップデートにも含まれません。インターフェイスを再開するには、デバイスを再起動する必要があります

手順の概要

1. configure terminal

2. interface interface

3. shutdown

4. show interface interface

5. no shutdown

6. show interface interface

7. exit

8. copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface

 

例:

switch(config)# interface ethernet 2/1

switch(config-if)#

 

switch(config)# interface mgmt0

switch(config-if)#

設定するインターフェイスを指定します。インターフェイス タイプと ID を指定できます。イーサネット ポートの場合、「ethernet slot/port 」を使用します。管理インターフェイスの場合、「mgmt0」を使用します。

例 1 は、スロット 2、ポート 1 イーサネット インターフェイスを指定する方法です。

例 2 は、管理インターフェイスを指定する方法です。

ステップ 3

shutdown

 

例:

switch(config-if)# shutdown

switch(config-if)#

インターフェイスをディセーブルにします。

ステップ 4

show interface interface

 

例:

switch(config-if)# show interface ethernet 2/1

switch(config-if)#

インターフェイス ステータスを表示します。管理ステータスもあわせて表示します。

ステップ 5

no shutdown

 

例:

switch(config-if)# no shutdown

switch(config-if)#

インターフェイスを再びイネーブルにします。

ステップ 6

show interface interface

 

例:

switch(config-if)# show interface ethernet 2/1

switch(config-if)#

インターフェイス ステータスを表示します。管理ステータスもあわせて表示します。

ステップ 7

exit

 

例:

switch(config-if)# exit

switch(config)#

インターフェイス モードを終了します。

ステップ 8

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、イーサネット ポート 3/1 の管理ステータスをディセーブルからイネーブルに変更する例を示します。

switch# configure terminal
switch(config)# interface ethernet 3/1
switch(config-if)# shutdown
switch(config-if)# no shutdown
switch(config-if)#

UDLD モードの設定

UDLD を実行するように設定されたデバイスのイーサネット インターフェイスに、ノーマルまたはアグレッシブ単方向リンク検出(UDLD)モードを設定できます。インターフェイスの UDLD モードをイネーブルにする前に、インターフェイスを含むデバイスの UDLD がイネーブルになっていることを確認する必要があります。UDLD は他方のリンク先のインターフェイスおよびそのデバイスでもイネーブルになっている必要があります

ノーマル UDLD モードを使用するには、ポートのいずれかをノーマル モードに設定し、他のポートをノーマルまたはアグレッシブ モードに設定する必要があります。アグレッシブ UDLD モードを使用するには、両方のポートをアグレッシブ モードに設定する必要があります。

デフォルトでは、48 ポート 10/100/1000 イーサネット モジュール ポートでは UDLD がディセーブルですが、32 ポート 10 ギガビット イーサネット モジュール ポートではノーマル UDLD モードがイネーブルです。

作業を開始する前に

他方のリンク先ポートおよびデバイスで UDLD をイネーブルにする必要があります。

手順の概要

1. configure terminal

2. feature udld
no feature udld

3. udld message-time seconds

4. udld aggressive

5. interface ethernet slot / port

6. udld { enable | disable }

7. show udld [ ethernet slot / port | global | neighbors }

8. exit

9. copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

feature udld

 

例:

switch(config)# feature udld

switch(config)#

デバイスの UDLD をイネーブルにします。

no feature udld

 

例:

switch(config)# no feature udld

switch(config)#

デバイスの UDLD をディセーブルにします。

ステップ 3

udld message-time seconds

 

例:

switch(config)# udld message-time 30

switch(config)#

(任意)UDLD メッセージを送信する間隔を指定します。有効範囲は 7 ~ 90 秒で、デフォルトは 15 秒です。

ステップ 4

udld aggressive

 

例:

switch(config)# udld aggressive

switch(config)#

(任意)UDLD モードをアグレッシブに指定します。

(注) 銅インターフェイスの場合、UDLD アグレッシブ モードに設定するインターフェイスのインターフェイス コマンド モードを入力し、インターフェイス コマンド モードでこのコマンドを発行します。

ステップ 5

interface ethernet slot/port

 

例:

switch(config)# interface ethernet 3/1

switch(config-if)#

(任意)設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 6

udld {enable | disable}

 

例:

switch(config-if)# udld aggressive

switch(config-if)#

(任意)指定されたインターフェイスの UDLD をイネーブルまたはディセーブルにします。

ステップ 7

show udld [ethernet slot/port | global | neighbors]

 

例:

switch(config)# show udld

switch(config)#

(任意)UDLD のステータスを表示します。

ステップ 8

exit

 

例:

switch(config-if-range)# exit

switch(config)#

インターフェイス モードを終了します。

ステップ 9

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、デバイスの UDLD をイネーブルにする例を示します。

switch# configure terminal
switch(config)# feature udld
switch(config)#
 

次の例では、UDLD メッセージの間隔を 30 秒に設定する方法を示します。

switch# configure terminal
switch(config)# feature udld
switch(config)# udld message-time 30
switch(config)#
 

次の例は、ファイバ インターフェイスのアグレッシブ UDLD モードをイネーブルにする方法を示しています。

switch# configure terminal
switch(config)# feature udld
switch(config)# udld aggressive
switch(config)#

次に、銅インターフェイス イーサネット 3/1 のアグレッシブ UDLD モードをイネーブルにする例を示します。

switch# configure terminal
switch(config)# feature udld
switch(config)# interface ethernet 3/1
switch(config-if-range)# udld aggressive
switch(config-if-range)#

次に、イーサネット ポート 3/1 の UDLD をディセーブルにする例を示します。

switch# configure terminal
switch(config)# interface ethernet 3/1
switch(config-if-range)# no udld disable
switch(config-if-range)# exit

次に、デバイスの UDLD をディセーブルにする例を示します。

switch# configure terminal
switch(config)# no feature udld
switch(config)# exit
 

キャリア遅延タイマーの設定

キャリア遅延タイマーは、すべてのリンクダウン/リンクアップ イベントがデバイスの他のソフトウェアによって検出されない時間を設定します。長いキャリア遅延時間を設定すると、記録されるリンクダウン/リンクアップ イベントは少なくなります。キャリア遅延時間を 0 に設定すると、デバイスは各リンクダウン/リンクアップ イベントを検出します。


) キャリア遅延タイマーは、VLAN ネットワーク インターフェイスでだけ設定できます。このタイマーを他のインターフェイス モードで設定できません。


作業を開始する前に

VLAN インターフェイス モードであることを確認します。キャリア遅延タイマーは、他のインターフェイス モードで設定できません。

手順の概要

1. configure terminal

2. interface vlan vlan-id

3. carrier-delay { sec | msec number }

4. show interface vlan vlan-id

5. exit

6. copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface vlan -id

 

例:

switch(config)# interface vlan 5

switch(config-if)#

VLAN インターフェイス モードを開始します。

ステップ 3

carrier-delay { sec | msec number }

 

例:

switch(config-if)# carrier-delay 20

switch(config-if)#

キャリア遅延タイマーを設定します。0 ~ 60 秒または 0 ~ 1000 ミリ秒の時間を設定できます。デフォルトは 2 秒または 50 ミリ秒です。

ステップ 4

show interface vlan -id

 

例:

switch(config-if)# show interface vlan 5

switch(config-if)#

インターフェイスのステータスを表示します。

ステップ 5

exit

 

例:

switch(config-if)# exit

switch(config)#

インターフェイス モードを終了します。

ステップ 6

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次の例では、VLAN 5 のキャリア遅延タイマーを 20 秒に設定する方法を示します。

switch# configure terminal
switch(config)# interface vlan 5
switch(config-if)# carrier-delay 20
switch(config-if)#
 

を使用して、管理(mgmt0)イーサネット インターフェイスを設定して IP 上で接続できます。

ポート プロファイルの設定

いくつかの設定パラメータを一定範囲のインターフェイスに同時に適用できます。範囲内のすべてのインターフェイスが同じタイプである必要があります。また、1 つのポート プロファイルから別のポート プロファイルに設定を継承することもできます。システムは 4 つのレベルの継承をサポートしています。

ここでは、次の内容について説明します。

「ポート プロファイルの作成」

「ポート プロファイル コンフィギュレーション モードの開始とポート プロファイルの修正」

「一定範囲のインターフェイスへのポート プロファイルの割り当て」

「特定のポート プロファイルのイネーブル化」

「ポート プロファイルの継承」

「一定範囲のインターフェイスからのポート プロファイルの削除」

「継承されたポート プロファイルの削除」

ポート プロファイルの作成

デバイスにポート プロファイルを作成できます。各ポート プロファイルは、タイプにかかわらず、ネットワーク上で一意の名前を持つ必要があります。

手順の概要

1. configure terminal

2. port-profile [ type { ethernet | interface-vlan | loopback | port channel | tunnel }] name

3. exit

4. show port-profile

5. copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

port-profile [type {ethernet | interface-vlan | loopback | port channel | tunnel}] name

 

例:

switch(config)# port-profile type tunnel test

switch(config-ppm)#

指定されたタイプのインターフェイスのポート プロファイルを作成して命名し、ポート プロファイル コンフィギュレーション モードを開始します。

ステップ 3

exit

 

例:

switch(config-ppm)# exit

switch(config)#

ポート プロファイル コンフィギュレーション モードを終了します。

ステップ 4

show port-profile

 

例:

switch(config)# show port-profile

(任意)ポート プロファイルの設定を表示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次の例では、トンネル インターフェイスに test という名前のポート プロファイルを作成する方法を示します。

switch# configure terminal
switch(config)# port-profile type tunnel test
switch(config-ppm)#

ポート プロファイル コンフィギュレーション モードの開始とポート プロファイルの修正

ポート プロファイル コンフィギュレーション モードを開始し、ポート プロファイルを修正できます。ポート プロファイルを修正するには、ポート プロファイル コンフィギュレーション モードを開始する必要があります。

手順の概要

1. configure terminal

2. port-profile [ type { ethernet | interface-vlan | loopback | port channel | tunnel }] name

3. exit

4. show port-profile

5. copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

port-profile [type {ethernet | interface-vlan | loopback | port channel | tunnel}] name

 

例:

switch(config)# port-profile type tunnel test

switch(config-ppm)# no shutdown

switch(config-ppm)#

指定されたポート プロファイルのポート プロファイル コンフィギュレーション モードを開始し、プロファイルの設定を追加または削除します。

ステップ 3

exit

 

例:

switch(config-ppm)# exit

switch(config)#

ポート プロファイル コンフィギュレーション モードを終了します。

ステップ 4

show port-profile

 

例:

switch(config)# show port-profile

(任意)ポート プロファイルの設定を表示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、指定されたポート プロファイルのポート プロファイル コンフィギュレーション モードを開始し、すべてのインターフェイスを管理的にアップする例を示します。

switch# configure terminal
switch(config)# port-profile type tunnel test
switch(config-ppm)# no shutdown
switch(config-ppm)#

一定範囲のインターフェイスへのポート プロファイルの割り当て

1 つのインターフェイスまたは一定範囲のインターフェイスにポート プロファイルを割り当てることができます。すべてのインターフェイスが同じタイプである必要があります。

手順の概要

1. configure terminal

2. interface [ethernet slot/port | interface-vlan vlan-id | loopback number | port-channel number | tunnel number ]

3. inherit port-profile name

4. exit

5. show port-profile

6. copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface [ethernet slot/port | interface-vlan vlan-id | loopback number | port channel number | tunnel number ]

 

例:

switch(config)# interface ethernet 7/3-5, 10/2, 11/20-25

switch(config-if)#

インターフェイスの範囲を選択します。

ステップ 3

inherit port-profile name

 

例:

switch(config-if)# inherit port-profile adam

switch(config-if)#

選択されたインターフェイスに指定されたポート プロファイルを割り当てます。

ステップ 4

exit

 

例:

switch(config-ppm)# exit

switch(config)#

ポート プロファイル コンフィギュレーション モードを終了します。

ステップ 5

show port-profile

 

例:

switch(config)# show port-profile

(任意)ポート プロファイルの設定を表示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、イーサネット インターフェイス 7/3 ~ 7/5、10/2、および 11/20 ~ 11/25 に adam という名前のポート プロファイルを割り当てる例を示します。

switch# configure terminal
switch(config)# interface ethernet 7/3-5, 10/2, 11/20-25
switch(config-if)# inherit port-profile adam
switch(config-if)#

特定のポート プロファイルのイネーブル化

ポート プロファイルの設定をインターフェイスに適用するには、特定のポート プロファイルをイネーブルにする必要があります。ポート プロファイルをイネーブルにする前に、そのポート プロファイルを一定範囲のインターフェイスに設定し、継承できます。その後、指定されたインターフェイスで設定が実行されるように、そのポート プロファイルをイネーブルにします。

1 つまたは複数のポート プロファイルを元のポート プロファイルに継承した場合、最後に継承されたポート プロファイルだけをイネーブルにする必要があります。システムは、基盤となるポート プロファイルがイネーブルであることを想定します。

ポート プロファイルをイネーブルまたはディセーブルにするには、ポート プロファイル コンフィギュレーション モードを開始する必要があります。

手順の概要

1. configure terminal

2. port-profile [ type { ethernet | interface-vlan | loopback | port channel | tunnel }] name

3. state enabled

4. exit

5. show port-profile

6. copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

port-profile [type {ethernet | interface-vlan | loopback | port channel | tunnel}] name

 

例:

switch(config)# port-profile type tunnel test

switch(config-ppm)# no shutdown

switch(config-ppm)#

指定されたポート プロファイルに対して、ポート プロファイル コンフィギュレーション モードを開始します。

ステップ 3

state enabled

 

例:

switch(config-ppm)# state enabled

switch(config)#

そのポート プロファイルをイネーブルにします。

ステップ 4

exit

 

例:

switch(config-ppm)# exit

switch(config)#

ポート プロファイル コンフィギュレーション モードを終了します。

ステップ 5

show port-profile

 

例:

switch(config)# show port-profile

(任意)ポート プロファイルの設定を表示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次の例では、ポート プロファイル コンフィギュレーション モードを開始し、ポート プロファイルをイネーブルにする方法を示します。

switch# configure terminal
switch(config)# port-profile type tunnel test
switch(config-ppm)# state enabled
switch(config-ppm)#

ポート プロファイルの継承

ポート プロファイルを既存のポート プロファイルに継承できます。システムは 4 つのレベルの継承をサポートしています。

手順の概要

1. configure terminal

2. port-profile name

3. inherit port-profile name

4. exit

5. show port-profile

6. copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

port-profile name

 

例:

switch(config)# port-profile test

switch(config-ppm)#

指定されたポート プロファイルに対して、ポート プロファイル コンフィギュレーション モードを開始します。

ステップ 3

inherit port-profile name

 

例:

switch(config-ppm)# inherit port-profile adam

switch(config-ppm)#

別のポート プロファイルを既存のポート プロファイルに継承します。元のポート プロファイルは、継承されたポート プロファイルのすべての設定を想定します。

ステップ 4

exit

 

例:

switch(config-ppm)# exit

switch(config)#

ポート プロファイル コンフィギュレーション モードを終了します。

ステップ 5

show port-profile

 

例:

switch(config)# show port-profile

(任意)ポート プロファイルの設定を表示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次の例では、adam という名前のポート プロファイルを test という名前のポート プロファイルに継承する方法を示します。

switch# configure terminal
switch(config)# port-profile test
switch(config-ppm)# inherit port-profile adam
switch(config-ppm)#

一定範囲のインターフェイスからのポート プロファイルの削除

プロファイルを適用した一部またはすべてのインターフェイスから、ポート プロファイルを削除できます。この作業は、インターフェイス コンフィギュレーション モードで行います。

手順の概要

1. configure terminal

2. interface [ethernet slot/port | interface-vlan vlan-id | loopback number | port-channel number | tunnel number ]

3. no inherit port-profile name

4. exit

5. show port-profile

6. copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface [ethernet slot/port | interface-vlan vlan-id | loopback number | port channel number | tunnel number ]

 

例:

switch(config)# interface ethernet 7/3-5, 10/2, 11/20-25

switch(config-if)#

インターフェイスの範囲を選択します。

ステップ 3

no inherit port-profile name

 

例:

switch(config-if)# no inherit port-profile adam

switch(config-if)#

選択されたインターフェイスから指定されたポート プロファイルを削除します。

ステップ 4

exit

 

例:

switch(config-ppm)# exit

switch(config)#

ポート プロファイル コンフィギュレーション モードを終了します。

ステップ 5

show port-profile

 

例:

switch(config)# show port-profile

(任意)ポート プロファイルの設定を表示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、イーサネット インターフェイス 7/3 ~ 7/5、10/2、および 11/20 ~ 11/25 から adam という名前のポート プロファイルを削除する例を示します。

switch# configure terminal
switch(config)# interface ethernet 7/3-5, 10/2, 11/20-25
switch(config-if)# no inherit port-profile adam
switch(config-if)#

 

継承されたポート プロファイルの削除

継承されたポート プロファイルを削除できます。この作業は、ポート プロファイル モードで行います。

手順の概要

1. configure terminal

2. port-profile name

3. no inherit port-profile name

4. exit

5. show port-profile

6. copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

port-profile name

 

例:

switch(config)# port-profile test

switch(config-ppm)#

指定されたポート プロファイルに対して、ポート プロファイル コンフィギュレーション モードを開始します。

ステップ 3

no inherit port-profile name

 

例:

switch(config-ppm)# no inherit port-profile adam

switch(config-ppm)#

このポート プロファイルから継承されたポート プロファイルを削除します。

ステップ 4

exit

 

例:

switch(config-ppm)# exit

switch(config)#

ポート プロファイル コンフィギュレーション モードを終了します。

ステップ 5

show port-profile

 

例:

switch(config)# show port-profile

(任意)ポート プロファイルの設定を表示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次の例では、adam という名前の継承されたポート プロファイルを test という名前のポート プロファイルから削除する方法を示します。

switch# configure terminal
switch(config)# port-profile test
switch(config-ppm)# no inherit port-profile adam
switch(config-ppm)#
 

TDR ケーブル診断の実施

高価なサードパーティ製機器を使用せずに、ケーブル診断を実施できます。ラインカード上の各ポートは、TDR 診断を使用して、単独でケーブルの問題を検出し、これらの問題をスイッチ ソフトウェアにレポートできます。

作業を開始する前に

TDR テストのガイドラインは、次のとおりです。

TDR は最大 115 メートルの長さのケーブルをテストできます。

ケーブルの両端で同時にテストを開始しないでください。ケーブルの両端で同時にテストを開始すると、誤ったテスト結果が得られることがあります。

ケーブル診断テスト中にポートの設定を変更しないでください。ポートの設定を変更すると、誤ったテスト結果が得られることがあります。

TDR テストを実行する前に、インターフェイスをダウンさせる必要があります。

手順の概要

1. test cable-diagnostics tdr interface number

2. show interface number cable-diagnostics-tdr

手順の詳細

コマンド
目的

ステップ 1

test cable-diagnostics tdr interface number

例:

switch# test cable-diagnostics tdr interface ethernet 7/1

指定されたインターフェイスで TDR テストを開始します。インターフェイスで以前に shutdown コマンドが実行されている必要があります。

ステップ 2

show interface number cable-diagnostics-tdr

例:

switch(config)# show interface ethernet 7/1 cable-diagnostics-tdr

指定されたインターフェイスの TDR テスト結果を表示します。

次の例では、特定のインターフェイスで TDR テストを行う方法を示します。

switch# test cable-diagnostics tdr interface ethernet 7/1
switch# show interface ethernet 7/1 cable-diagnostics-tdr
 
--------------------------------------------------------------------------------
Interface Speed Pair Cable Length Distance to fault Channel Pair Status
-------------- ----- ---- -------------- ------------------- ------- -----------

基本インターフェイス パラメータの確認

基本インターフェイス パラメータは、値を表示して確認します。パラメータ値を表示してカウンタのリストをクリアすることもできます。


) システムには、作業中の VDC に割り当てられているポートだけが表示されます。


手順の詳細

基本的なインターフェイス設定情報を表示するには、次の作業のいずれかを行います。

 

コマンド
目的

show cdp

CDP ステータスを表示します。

show interface interface

1 つまたはすべてのインターフェイスに設定されている状態を表示します。

show interface interface

1 つまたはすべてのインターフェイスに設定されている状態を表示します。

show interface brief

インターフェイスの状態を示す表を表示します。

show interface switchport

レイヤ 2 ポートのステータスを表示します。

show interface status err-disabled

error-disabled インターフェイスに関する情報を表示します。

show vdc

現在の VDC のステータスを表示します。

show udld interface

現在のインターフェイスまたはすべてのインターフェイスの UDLD ステータスを表示します。

show udld-global

現在のデバイスの UDLD ステータスを表示します。

show port-profile

ポート プロファイルに関する情報を表示します。

これらのコマンドの出力フィールドの詳細については、『 Cisco Nexus 7000 Series NX-OS Interfaces Command Reference, Release 5.x を参照してください。

インターフェイス カウンタの表示とクリア

Cisco NX-OS を使用して、インターフェイス カウンタを表示し、クリアできます。ここで説明する内容は、次のとおりです。

「インターフェイス統計情報の表示」

「インターフェイス カウンタのクリア」

インターフェイス統計情報の表示

インターフェイスでの統計情報の収集に、最大 3 つのサンプリング間隔を設定できます。

手順の概要

1. configure terminal

2. load-interval counters {{ 1 | 2| 3 } seconds }

3. show interface

4. exit

5. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch#

コンフィギュレーション モードを開始します。

ステップ 2

load-interval counters {{ 1 | 2 | 3 } seconds }

 

例:

switch(config)# load-interval counters 1 100

switch(config)#

ビットレートおよびパケットレートの統計情報を収集する最大 3 つのサンプリング間隔を設定します。各カウンタのデフォルト値は、次のとおりです。

1:30 秒(VLAN ネットワーク インターフェイスでは 60 秒)

2:300 秒

3:設定なし

ステップ 3

show interface interface

 

例:

switch(config)# show interface vlan 10

switch#

インターフェイス ステータスを表示します。カウンタもあわせて表示します。

ステップ 4

exit

 

例:

switch(config)# exit

switch#

コンフィギュレーション モードを終了します。

ステップ 5

copy running-config startup-config

 

例:

switch# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次の例では、イーサネット ポート 3/1 に 3 つのサンプル間隔を設定する方法を示します。

switch# configure terminal
switch(config)# interface ethernet 3/1
switch(config-if)# load-interval counter 1 60
switch(config-if)# load-interval counter 2 135
switch(config-if)# load-interval counter 3 225
switch(config-if)#

インターフェイス カウンタのクリア

clear counters コマンドを使用して、イーサネットおよび管理インターフェイス カウンタをクリアできます。この作業は、コンフィギュレーションモードまたはインターフェイス コンフィギュレーション モードで実行できます。

手順の概要

1. clear counters interface

2. show interface

手順の詳細

 

コマンド
目的

ステップ 1

clear counters interface

 

例:

switch# clear counters ethernet 2/1

switch#

インターフェイス カウンタをクリアします。

ステップ 2

show interface interface

 

例:

switch# show interface vlan 10

switch#

インターフェイス ステータスを表示します。カウンタもあわせて表示します。

次に、イーサネット ポート 5/5 のカウンタをクリアしてリセットする例を示します。

switch# clear counters ethernet 5/5
switch#

デフォルト設定

表 2-6 に、基本インターフェイス パラメータのデフォルト設定を示します。

 

表 2-6 基本インターフェイス パラメータのデフォルト設定

パラメータ
デフォルト

説明

ブランク

ビーコン

ディセーブル

デバウンス タイマー

100 ミリ秒

帯域幅

インターフェイスのデータ レート

スループット遅延

100 マイクロ秒

管理ステータス

シャットダウン

MTU

1500 バイト

UDLD グローバル

グローバルにディセーブル

ポート別の UDLD ステート イネーブル(光ファイバ メディア用)

すべてのイーサネット光ファイバ LAN ポートでイネーブル

銅線メディア用のポート別 UDLD イネーブル ステート

すべてのイーサネット 10/100 および 1000BASE-TX LAN ポートでディセーブル

UDLD メッセージの間隔

ディセーブル

UDLD アグレッシブ モード

ディセーブル

キャリア遅延

2 秒または 50 ミリ秒

エラー ディセーブル

ディセーブル

エラー ディセーブル回復

ディセーブル

エラー ディセーブル回復間隔

300 秒

リンクのデバウンス

イネーブル

ポート プロファイル

ディセーブル

その他の関連資料

機能 1 の実装に関連した情報については、次を参照してください。

「関連資料」

「標準規格」

「基本インターフェイス パラメータ設定の機能履歴」

関連資料

関連項目
参照先

コマンド リファレンス

『Cisco Nexus 7000 Series NX-OS Interfaces Command Reference, Release 5.x

レイヤ 2 スイッチング

『Cisco Nexus 7000 Series NX-OS Layer 2 Switching Configuration Guide, Release 5.x

CDP

Cisco Nexus 7000 Series NX-OS System Management Command Reference, Release 5.x

標準規格

標準規格
タイトル

この機能でサポートされる新規または改訂された標準規格はありません。また、この機能による既存の標準規格サポートの変更はありません。

--

基本インターフェイス パラメータ設定の機能履歴

表 2-7 は、この機能のリリースの履歴です。

 

表 2-7 基本インターフェイス パラメータ設定の機能履歴

機能名
リリース
機能情報

基本インターフェイスの設定

4.0(1)

これらの機能が導入されました。

ポート プロファイル

4.2(1)

いくつかの設定を一定範囲のインターフェイスに同時に適用できます。