Cisco Nexus 7000 シリーズ NX-OS マルチキャスト ルーティング コンフィギュレーション ガイド リリー ス 5.x
PIM および PIM6 の設定
PIM および PIM6 の設定
発行日;2012/01/31 | 英語版ドキュメント(2011/12/16 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

PIM および PIM6 の設定

PIM および PIM6 の情報

hello メッセージ

Join/Prune メッセージ

ステートのリフレッシュ

ランデブー ポイント

スタティック RP

BSR

Auto-RP

1 つの PIM ドメイン内の複数の RP

Anycast-RP

PIM Register メッセージ

代表ルータ

Designated Forwarder

ASM モードにおける共有ツリーから送信元ツリーへのスイッチオーバー

管理用スコープの IP マルチキャスト

PIM の双方向フォワーディング検出

仮想化のサポート

ハイ アベイラビリティ

PIM および PIM6 のライセンス要件

PIM および PIM6 の前提条件

PIM および PIM6 に関する注意事項と制限事項

PIM および PIM6 の設定

PIM および PIM6 機能のイネーブル化

PIM または PIM6 スパース モードの設定

ASM および Bidir の設定

スタティック RP の設定

BSR の設定

Auto-RP の設定

PIM Anycast-RP セットの設定

ASM 専用の共有ツリーの設定

SSM の設定

マルチキャスト用 RPF ルートの設定

RP 情報配信を制御するルート マップの設定

メッセージ フィルタリングの設定

PIM プロセスおよび PIM6 プロセスの再起動

PIM の BFD の設定

PIM および PIM6 の設定の確認

統計情報の表示

PIM および PIM6 の統計情報の表示

PIM および PIM6 の統計情報のクリア

PIM の設定例

SSM の設定例

BSR の設定例

Auto-RP の設定例

PIM Anycast-RP の設定例

次の作業

デフォルト設定

その他の関連資料

関連資料

規格

MIB

PIM と PIM6 の機能履歴

PIM および PIM6 の設定

この章では、IPv4 ネットワークおよび IPv6 ネットワークの Cisco NX-OS デバイスに Protocol Independent Multicast(PIM)および PIM6 機能を設定する方法を説明します。

この章は、次の内容で構成されています。

「PIM および PIM6 の情報」

「PIM および PIM6 のライセンス要件」

「PIM および PIM6 の前提条件」

「PIM および PIM6 に関する注意事項と制限事項」

「PIM および PIM6 の設定」

「PIM および PIM6 の設定の確認」

「統計情報の表示」

「PIM の設定例」

「次の作業」

「デフォルト設定」

「その他の関連資料」

「PIM と PIM6 の機能履歴」

PIM および PIM6 の情報


) Cisco NX-OS Release 5.0(2a) 以降では、Bidirectional Forwarding Detection(BFD; 双方向フォワーディング検出)が PIM をサポートします。BFD については、Cisco Nexus 7000 Series NX-OS Interfaces Configuration Guide, Release 5.x』を参照してください。


マルチキャスト対応ルータ間で使用される PIM は、マルチキャスト配信ツリーを構築して、ルーティング ドメイン内にグループ メンバシップをアドバタイズします。PIM は、複数の送信元からのパケットが転送される共有配信ツリーと、単一の送信元からのパケットが転送される送信元配信ツリーを構築します。マルチキャストの詳細については、「マルチキャストに関する情報」を参照してください。

Cisco NX-OS は、IPv4 ネットワーク(PIM)および IPv6 ネットワーク(PIM6)で、PIM スパース モードをサポートしています(PIM スパース モードでは、ネットワーク上の要求元だけにマルチキャスト トラフィックが伝送されます)。PIM と PIM6 は、ルータ上で同時に実行するように設定できます。PIM および PIM6 グローバル パラメータを使用すると、Rendezvous Point(RP; ランデブー ポイント)、メッセージ パケット フィルタリング、および統計情報を設定できます。PIM および PIM6 インターフェイス パラメータを使用すると、マルチキャスト機能のイネーブル化、PIM の境界の識別、PIM hello メッセージ インターバルの設定、および Designated Router(DR; 代表ルータ)のプライオリティ設定を実行できます。詳細については、「PIM または PIM6 スパース モードの設定」を参照してください。


) Cisco NX-OS は PIM デンス モードをサポートしていません。


Cisco NX-OS でマルチキャスト機能をイネーブルにするには、各ルータで PIM または PIM6 機能をイネーブルにしてから、マルチキャストに参加する各インターフェイスで、PIM または PIM6 スパース モードをイネーブルにする必要があります。IPv4 ネットワークの場合は PIM を、IPv6 ネットワークの場合は PIM6 を設定できます。IPv4 ネットワーク上のルータで Internet Group Management Protocol(IGMP; インターネット グループ管理プロトコル)がイネーブルになっていない場合は、PIM によって自動的にイネーブルにされます。IPv6 ネットワークでは、デフォルトで Multicast Listener Discovery(MLD)がイネーブルになります。IGMP および MLD の設定方法については、 第 2 章「IGMP の設定」 および 第 3 章「MLD の設定」 を参照してください。

PIM および PIM6 グローバル コンフィギュレーション パラメータを使用すると、マルチキャスト グループ アドレスの範囲を設定して、次に示す 3 つのツリー 配信モードで利用できます。

Any Source Multicast(ASM):マルチキャスト送信元の検出機能を提供します。ASM では、マルチキャスト グループの送信元と受信者間に共有ツリーを構築し、新しい受信者がグループに追加された場合は、送信元ツリーに切り替えることができます。ASM モードを利用するには、RP を設定する必要があります。

Source Specific Multicast(SSM):マルチキャスト送信元への加入要求を受信する LAN セグメント上の代表ルータを起点として、送信元ツリーを構築します。SSM モードでは、RP を設定する必要がありません。送信元の検出は、その他の方法で実行する必要があります。

Bidirectional Shared Trees(Bidir; 双方向共有ツリー):マルチキャスト グループの送信元と受信者間に共有ツリーを構築しますが、新しい受信者がグループに追加された場合は、送信元ツリーに切り替えることができません。Bidir モードを利用するには、RP を設定する必要があります。Bidir 転送では共有ツリーだけが使用されるため、送信元を検出する必要はありません。

3 つのモードを組み合わせて、さまざまな範囲のグループ アドレスに対応することができます。詳細については、「PIM および PIM6 の設定」を参照してください。

ASM および Bidir モードで使用される PIM スパース モードと共有配信ツリーの詳細については、 RFC 4601 を参照してください。

PIM SSM モードの詳細については、 RFC 3569 を参照してください。

PIM Bidir モードの詳細については、 draft-ietf-pim-bidir-09.txt を参照してください。

ここでは、次の内容について説明します。

「hello メッセージ」

「Join/Prune メッセージ」

「ステートのリフレッシュ」

「ランデブー ポイント」

「PIM Register メッセージ」

「代表ルータ」

「Designated Forwarder」

「ASM モードにおける共有ツリーから送信元ツリーへのスイッチオーバー」

「管理用スコープの IP マルチキャスト」

「PIM の双方向フォワーディング検出」

「仮想化のサポート」

hello メッセージ

ルータがマルチキャスト アドレス 224.0.0.13 に PIM hello メッセージを送信して、PIM ネイバー ルータとの隣接関係を確立すると、PIM プロセスが開始されます。hello メッセージは 30 秒間隔で定期的に送信されます。PIM ソフトウェアはすべてのネイバーからの応答を確認すると、各 LAN セグメント内でプライオリティが最大のルータを Designated Router(DR; 代表ルータ)として選択します。DR プライオリティは、PIM hello メッセージの DR プライオリティ値に基づいて決まります。全ルータの DR プライオリティ値が不明、またはプライオリティが等しい場合は、IP アドレスが最上位のルータが DR として選定されます。

hello メッセージには保持時間の値も含まれています。通常、この値は hello インターバルの 3.5 倍です。ネイバーから後続の hello メッセージがないまま保持時間を経過すると、デバイスはそのリンクで PIM エラーを検出します。

PIM ソフトウェアで、PIM ネイバーとの PIM hello メッセージの認証に MD5 ハッシュ値を使用するよう設定すると、セキュリティを高めることができます。

hello メッセージ認証の設定方法については、「PIM または PIM6 スパース モードの設定」を参照してください。

Join/Prune メッセージ

受信者から送信された、新しいグループまたは送信元に対する IGMP メンバシップ レポート メッセージを受信すると、DR は、インターフェイスからランデブー ポイント方向(ASM または Bidir モード)または送信元方向(SSM モード)に PIM Join メッセージを送信して、受信者と送信元を接続するツリーを作成します。Rendezvous Point(RP; ランデブー ポイント)は共有ツリーのルートであり、ASM モードまたは Bidir モードで、PIM ドメイン内のすべての送信元およびホストによって使用されます。SSM では RP を使用せず、送信元と受信者間の最小コスト パスである Shortest Path Tree(SPT; 最短パス ツリー)が構築されます。

DR はグループまたは送信元から最後のホストが脱退したことを認識すると、PIM Prune メッセージを送信して、配信ツリーから該当するパスを削除します。

各ルータは、マルチキャスト配信ツリーの上流方向のホップに Join または Prune アクションを次々と転送し、パスを作成(Join)または削除(Prune)します。


) このマニュアル内の「PIM Join メッセージ」および「PIM Prune メッセージ」という用語は、PIM Join/Prune メッセージに関して、Join または Prune アクションのうち実行されるアクションをわかりやすく示すために使用しています。


Join/Prune メッセージは、ソフトウェアからできるだけ短時間で送信されます。Join/Prune メッセージをフィルタリングするには、ルーティング ポリシーを定義します。Join/Prune メッセージのポリシーの設定方法については、「PIM または PIM6 スパース モードの設定」を参照してください。

ステートのリフレッシュ

PIM では、3.5 分の間隔でマルチキャスト エントリをリフレッシュする必要があります。ステートをリフレッシュすると、トラフィックがアクティブなリスナーだけに配信されるため、ルータで不要なリソースが使用されなくなります。

PIM ステートを維持するために、最終ホップである DR は、Join/Prune メッセージを 1 分に 1 回送信します。次に、(*, G) ステートおよび (S, G) ステートの構築例を示します。

(*, G) ステートの構築例:IGMP (*, G) レポートを受信すると、DR は (*, G) PIM Join メッセージを RP 方向に送信します。

(S, G) ステートの構築例:IGMP (S, G) レポートを受信すると、DR は (S, G) PIM Join メッセージを送信元方向に送信します。

ステートがリフレッシュされていない場合、PIM ソフトウェアは、上流ルータのマルチキャスト発信インターフェイス リストから転送パスを削除し、配信ツリーを再構築します。

ランデブー ポイント

Rendezvous Point(RP; ランデブー ポイント)は、マルチキャスト ネットワーク ドメイン内にあるユーザが指定したルータで、マルチキャスト共有ツリーの共有ルートとして動作します。必要に応じて複数の RP を設定し、さまざまなグループ範囲をカバーすることができます。

ここでは、次の内容について説明します。

「スタティック RP」

「BSR」

「Auto-RP」

「Anycast-RP」

スタティック RP

マルチキャスト グループ範囲の RP を静的に設定できます。この場合、ドメイン内のすべてのルータに RP のアドレスを設定する必要があります。

スタティック RP を定義するのは、次のような場合です。

ルータに Anycast RP アドレスを設定する場合

デバイスに RP を手動で設定する場合

スタティック RP の設定方法については、「スタティック RP の設定」を参照してください。

BSR

Bootstrap Router(BSR; ブートストラップ ルータ)を使用すると、PIM ドメイン内のすべてのルータで、BSR と同じ RP キャッシュが保持されるようになります。BSR では、BSR 候補 RP から RP セットを選択するよう設定できます。BSR は、ドメイン内のすべてのルータに RP セットをブロードキャストする役割を果たします。ドメイン内の RP を管理するには、1 つまたは複数の候補 BSR を選択します。候補 BSR の 1 つが、ドメインの BSR として選定されます。


注意 同じネットワーク内では、Auto-RP プロトコルと BSR プロトコルを同時に設定できません。

図 4-1 に、BSR メカニズムの仕組みを示します。ここで、ルータ A(ソフトウェアによって選定された BSR)は、すべての有効なインターフェイスから BSR メッセージを送信しています(図の実線部分)。このメッセージには RP セットが含まれており、ネットワーク内のすべてのルータに次々とフラッディングされます。ルータ B および C は 候補 RP で、選定された BSR に候補 RP アドバタイズメントを直接送信しています(図の破線部分)。

選定された BSR は、ドメイン内のすべての候補 RP から 候補 RP メッセージを受信します。BSR から送信されるブートストラップ メッセージには、すべての候補 RP に関する情報が格納されています。各ルータでは共通のアルゴリズムを使用することにより、各マルチキャスト グループに対応する同一の RP アドレスが選択されます。

図 4-1 BSR メカニズム

 

RP 選択プロセスの実行中、ソフトウェアは最もプライオリティが高い RP アドレスを特定します。2 つ以上の RP アドレスのプライオリティが等しい場合は、選択プロセスで RP ハッシュを使用することもできます。1 つのグループに割り当てられる RP アドレスは 1 つだけです。

デフォルトでは、ルータは BSR メッセージの受信や転送を行いません。BSR メカニズムによって、PIM ドメイン内のすべてのルータに対して、マルチキャスト グループ範囲に割り当てられた RP セットが動的に通知されるようにするには、BSR リスニング機能および転送機能をイネーブルにする必要があります。

ブートストラップ ルータの詳細については、 RFC 5059 を参照してください。


) BSR メカニズムは、サードパーティ製ルータで使用可能な、ベンダー共通の RP 定義方式です。


BSR および候補 RP の設定方法については、「BSR の設定」を参照してください。

Auto-RP

Auto-RP は、インターネット標準であるブートストラップ ルータ メカニズムの前身となったシスコのプロトコルです。Auto-RP を設定するには、候補マッピング エージェントおよび候補 RP を選択します。候補 RP は、サポート対象グループ範囲を含んだ RP-Announce メッセージを Cisco RP-Announce マルチキャスト グループ 224.0.1.39 に送信します。Auto-RP マッピング エージェントは候補 RP からの RP-Announce メッセージを受信して、グループと RP 間のマッピング テーブルを形成します。マッピング エージェントは、このグループと RP 間の マッピング テーブルを RP-Discovery メッセージに格納して、Cisco RP-Discovery マルチキャスト グループ 224.0.1.40 にマルチキャストします。


注意 同じネットワーク内では、Auto-RP プロトコルと BSR プロトコルを同時に設定できません。

図 4-2 に、Auto-RP メカニズムを示します。RP マッピング エージェントは、受信した RP 情報を、定期的に Cisco RP-Discovery グループ 224.0.1.40 にマルチキャストします(図の実線部分)。

図 4-2 Auto-RP のメカニズム

 

デフォルトでは、ルータは Auto-RP メッセージの受信や転送を行いません。Auto-RP メカニズムによって、PIM ドメイン内のルータに対して、グループと RP 間のマッピング情報が動的に通知されるようにするには、Auto-RP リスニング機能および転送機能をイネーブルにする必要があります。


) Auto-RP は PIM6 ではサポートされていません。


Auto-RP の設定方法については、「Auto-RP の設定」を参照してください。

1 つの PIM ドメイン内の複数の RP

この項では、1 つの PIM ドメイン内に複数の RP が設定されている場合の選定プロセスのルールについて説明します。説明する内容は次のとおりです。

「PIM BSR ブートストラップ/Auto-RP マッピング エージェントの選定プロセス」

「PIM RP 対 RP の選定プロセス」

PIM BSR ブートストラップ/Auto-RP マッピング エージェントの選定プロセス

ここでは、次の内容について説明します。

「Bootstrap Router(BSR; ブートストラップ ルータ)の選定プロセスの詳細」

「Auto-RP マッピング エージェントの選定プロセス」

 

Bootstrap Router(BSR; ブートストラップ ルータ)の選定プロセスの詳細

 

BSR プライオリティが異なる場合は、プライオリティが最も高い(数値が最も大きい)BSR が PIM ドメインの BSR ルータとして選定されます(設定例 1 を参照)。

設定例 1(異なる BSR 候補プライオリティ):この例の場合、プライオリティが最も高い N7K-1 というラベルのデバイスが、PIM ドメインの BSR 候補として選定されます。N7K-2 というラベルが設定されたデバイスのプライオリティは、デフォルトの 64 です。

N7K-1 の設定:

interface loopback0
ip address 192.168.1.1/32
ip pim sparse-mode
 
ip pim bsr bsr-candidate loopback0 priority 128
 
ip pim bsr forward listen
 
 

N7K-2 の設定:

interface loopback0
ip address 192.168.2.1/32
ip pim sparse-mode
 
ip pim bsr bsr-candidate loopback0
 
ip pim bsr forward listen
 

N7K-1 の確認:

show ip pim rp
PIM RP Status Information for VRF "default"
BSR: 192.168.1.1*, next Bootstrap message in: 00:00:12,
priority: 128, hash-length: 30
 

N7K-2 の確認:

show ip pim rp
PIM RP Status Information for VRF "default"
BSR: 192.168.1.1, uptime: 00:04:27, expires: 00:02:00,
priority: 128, hash-length: 30
 

 

BSR プライオリティが同じ場合は、BSR 候補 IP アドレスが最上位である BSR が、PIM ドメインの BSR ルータとして選定されます(設定例 2 を参照)。

設定例 2(同じ BSR 候補プライオリティ):この例の場合、BSR 候補 IP アドレスが最上位である N7K-2 というラベルのデバイスが、PIM ドメインの BSR として選定されます。

N7K-1 の設定:

interface loopback0
ip address 192.168.1.1/32
ip pim sparse-mode
 
ip pim bsr bsr-candidate loopback0
 
ip pim bsr forward listen
 
 

N7K-2 の設定:

interface loopback0
ip address 192.168.2.1/32
ip pim sparse-mode
 
ip pim bsr bsr-candidate loopback0
 
ip pim bsr forward listen
 
 

N7K-1 の確認:

show ip pim rp
PIM RP Status Information for VRF "default"
BSR: 192.168.2.1, uptime: 01:45:20, expires: 00:01:54,
priority: 64, hash-length: 30
 

N7K-2 の確認:

show ip pim rp
PIM RP Status Information for VRF "default"
BSR: 192.168.2.1*, next Bootstrap message in: 00:00:30,
priority: 64, hash-length: 30

 

 

Auto-RP マッピング エージェントの選定プロセス

 

マッピング エージェント IP アドレスが最上位であるルータが、PIM ドメインのマッピング エージェントとして選定されます。Auto-RP マッピング エージェントにプライオリティを設定することはできません(設定例を参照)。

設定例(最上位の IP アドレス):この例の場合、マッピング エージェント IP アドレスが最上位である N7K-2 というラベルのデバイスが、PIM ドメインのマッピング エージェントとして選定されます。

N7K-1 の設定:

interface loopback0
ip address 192.168.1.1/32
ip pim sparse-mode
 
ip pim auto-rp mapping-agent loopback0
 
ip pim auto-rp forward listen
 
 

N7K-2 の設定:

interface loopback0
ip address 192.168.2.1/32
ip pim sparse-mode
 
ip pim auto-rp mapping-agent loopback0
 
ip pim auto-rp forward listen
 

N7K-1 の確認:

show ip pim rp
PIM RP Status Information for VRF "default"
BSR disabled
Auto-RP RPA: 192.168.2.1, next Discovery message in: 00:00:52
 

N7K-2 の確認:

show ip pim rp
PIM RP Status Information for VRF "default"
BSR disabled
Auto-RP RPA: 192.168.2.1*, next Discovery message in: 00:00:47
 

 

PIM RP 対 RP の選定プロセス

表 4-1 は、ネットワーク内で BSR、Auto-RP、またはスタティック RP 設定を使用して複数の RP が設定されている場合に、マルチキャスト グループの RP の選択に使用されるプロセスを示しています。

表 4-1 PIM RP 対 RP の選定プロセスの概要

 

BSR-RP 対 BSR-RP
BSR-RP 対 スタティック RP
Auto-RP 対 Auto- RP
Auto-RP 対 スタティック RP

1. 最も詳細な RP グループ リスト

1. 最も詳細な RP グループ リスト

1. 最も詳細な RP グループ リスト

1. 最も詳細な RP グループ リスト

2. 最も低い RP プライオリティ

2. 最上位の RP IP アドレス

2. 最上位の RP IP アドレス

2. 最上位の RP IP アドレス

3. 最上位の RP IP アドレス

--

--

--


) BSR-RP 対 Auto-RP は、同じネットワーク内で同時に実行しないことが推奨されるため、表 4-1 には示していません。


ここでは、次の内容について説明します。

「PIM BSR RP 候補対 BSR RP 候補の選定プロセス」

「PIM BSR RP 候補対 スタティック RP の選定プロセス」

「PIM Auto-RP 候補対 Auto-RP 候補の選定プロセス」

「PIM Auto-RP 候補対スタティック RP の選定プロセス」

 

PIM BSR RP 候補対 BSR RP 候補の選定プロセス

 

最も詳細なグループ リストを持つ BSR RP 候補が、設定済みのグループ リスト内に指定されているあらゆるマルチキャスト アドレスに対し、RP として選定されます。最も詳細なグループ リストは、BSR RP 候補プライオリティや最上位の BSR RP 候補 IP アドレスよりも優先されます(設定例 1 を参照)。

設定例 1(最も詳細なグループ リスト):この例の場合、224.1.1.0/24 グループ リスト内に指定されているすべてのマルチキャスト アドレスに対し、N7K-1 というラベルのデバイスが RP として選定されます。あまり詳細でない 224.0.0.0/4 グループ リスト内のマルチキャスト アドレスに対しては、N7K-2 というラベルのデバイスが選定されます。

N7K-1 の設定:

interface loopback0
ip address 192.168.1.1/32
ip pim sparse-mode
 
ip pim bsr bsr-candidate loopback0
ip pim bsr rp-candidate loopback0 group-list 224.1.1.0/24
ip pim bsr forward listen
 

N7K-2 の設定:

interface loopback0
ip address 192.168.2.1/32
ip pim sparse-mode
ip pim bsr bsr-candidate loopback0
ip pim bsr rp-candidate loopback0 group-list 224.0.0.0/4
ip pim bsr forward listen
 

N7K-1 の確認:

show ip pim group 224.1.1.0
PIM Group-Range Configuration for VRF "default"
Group-range Mode RP-address Shared-tree-only range
224.1.1.0/24 ASM 192.168.1.1 -
 
show ip pim group 224.3.0.0
PIM Group-Range Configuration for VRF "default"
Group-range Mode RP-address Shared-tree-only range
224.0.0.0/4 ASM 192.168.2.1 -
 

N7K-2 の確認:

show ip pim group 224.1.1.0
PIM Group-Range Configuration for VRF "default"
Group-range Mode RP-address Shared-tree-only range
224.1.1.0/24 ASM 192.168.1.1 -
 
show ip pim group 224.3.0.0
PIM Group-Range Configuration for VRF "default"
Group-range Mode RP-address Shared-tree-only range
224.0.0.0/4 ASM 192.168.2.1
 

 

複数の BSR RP 候補が同じグループ リスト(224.0.0.0/4 など)をアドバタイズした場合は、グループ リスト内に指定されているあらゆるマルチキャスト アドレスに対し、プライオリティが最も高い(数値が最も小さい)BSR RP 候補が RP として選定されます(設定例 2 を参照)。

設定例 2(同じグループ リストで、RP プライオリティが異なる): この例の場合、224.0.0.0/4 グループ リスト内に指定されているすべてのマルチキャスト アドレスに対し、RP 候補プライオリティが最も低い N7K-1 というラベルのデバイスが RP として選定されます。N7K-2 というラベルのデバイスのプライオリティは、デフォルトの 192 です。

N7K-1 の設定:

interface loopback0
ip address 192.168.1.1/32
ip pim sparse-mode
 
ip pim bsr bsr-candidate loopback0
ip pim bsr rp-candidate loopback0 group-list 224.0.0.0/4 priority 10
ip pim bsr forward listen
 

N7K-2 の設定:

interface loopback0
ip address 192.168.2.1/32
ip pim sparse-mode
 
ip pim bsr bsr-candidate loopback0
ip pim bsr rp-candidate loopback0 group-list 224.0.0.0/4
ip pim bsr forward listen
 

N7K-1 の確認:

show ip pim rp
PIM RP Status Information for VRF "default"
BSR: 192.168.2.1, uptime: 00:09:14, expires: 00:01:37,
priority: 64, hash-length: 30
Auto-RP disabled
BSR RP Candidate policy: None
BSR RP policy: None
Auto-RP Announce policy: None
Auto-RP Discovery policy: None
 
RP: 192.168.1.1*, (0), uptime: 00:08:15, expires: 00:01:57,
priority: 10, RP-source: 192.168.2.1 (B), group ranges:
224.0.0.0/4
 
RP: 192.168.2.1, (0), uptime: 00:08:15, expires: 00:01:57,
priority: 192, RP-source: 192.168.2.1 (B), group ranges:
224.0.0.0/4
 
show ip pim group 224.1.1.0
PIM Group-Range Configuration for VRF "default"
Group-range Mode RP-address Shared-tree-only range
224.0.0.0/4 ASM 192.168.1.1
 

N7K-2 の確認:

show ip pim rp
PIM RP Status Information for VRF "default"
BSR: 192.168.2.1*, next Bootstrap message in: 00:00:55,
priority: 64, hash-length: 30
Auto-RP disabled
BSR RP Candidate policy: None
BSR RP policy: None
Auto-RP Announce policy: None
Auto-RP Discovery policy: None
 
RP: 192.168.1.1, (0), uptime: 00:11:34, expires: 00:02:26,
priority: 10, RP-source: 192.168.1.1 (B), group ranges:
224.0.0.0/4
 
RP: 192.168.2.1*, (0), uptime: 00:12:21, expires: 00:02:22,
priority: 192, RP-source: 192.168.2.1 (B), group ranges:
224.0.0.0/4
 
show ip pim group 224.1.1.0
PIM Group-Range Configuration for VRF "default"
Group-range Mode RP-address Shared-tree-only range
224.0.0.0/4 ASM 192.168.1.1 -
 

複数の BSR RP 候補が同じグループ リスト(224.0.0.0/4 など)をアドバタイズした場合で、それらが同じ BSR RP 候補プライオリティで設定されている場合は、グループ リスト内に指定されているあらゆるマルチキャスト アドレスに対し、IP アドレスが最上位である BSR RP 候補が RP として選定されます(設定例 3 を参照)。

設定例 3(RP プライオリティおよびグループ リストが同じ): この例の場合、224.0.0.0/4 グループ リスト内に指定されているすべてのマルチキャスト アドレスに対し、RP 候補 IP アドレスが最上位である N7K-2 というラベルのデバイスが RP として選定されます。

N7K-1 の設定:

interface loopback0
ip address 192.168.1.1/32
ip pim sparse-mode
 
ip pim bsr bsr-candidate loopback0
ip pim bsr rp-candidate loopback0 group-list 224.0.0.0/4
ip pim bsr forward listen
 
 

N7K-2 の設定:

interface loopback0
ip address 192.168.2.1/32
ip pim sparse-mode
 
ip pim bsr bsr-candidate loopback0
ip pim bsr rp-candidate loopback0 group-list 224.0.0.0/4
ip pim bsr forward listen
 

N7K-1 の確認:

show ip pim group 224.1.1.0
PIM Group-Range Configuration for VRF "default"
Group-range Mode RP-address Shared-tree-only range
224.0.0.0/4 ASM 192.168.2.1 -
 
 

N7K-2 の確認:

show ip pim group 224.1.1.0
PIM Group-Range Configuration for VRF "default"
Group-range Mode RP-address Shared-tree-only range
224.0.0.0/4 ASM 192.168.2.1 -
 

 

PIM BSR RP 候補対 スタティック RP の選定プロセス

 

最も詳細なグループ リストを持つ RP が、設定済みのグループ リスト内に指定されているあらゆるマルチキャスト アドレスに対し、RP として選定されます。最も詳細なグループ リストは、最上位の RP IP アドレスよりも優先されます(設定例 1 を参照)。(RP プライオリティは、BSR RP 候補をスタティック RP と比較する際には適用されません)。

設定例 1(最も詳細なグループ リスト):この例の場合、224.1.1.0/24 グループ リスト内に指定されているすべてのマルチキャスト アドレスに対し、N7K-1 というラベルのデバイスが BSR RP として選定されます。あまり詳細でない 224.0.0.0/4 グループ リスト内のマルチキャスト アドレスに対しては、スタティック RP ステートメントにより、N7K-2 というラベルのデバイスが RP として選定されます。

N7K-1 の設定:

interface loopback0
ip address 192.168.1.1/32
ip pim sparse-mode
 
ip pim bsr bsr-candidate loopback0
ip pim rp-address 192.168.2.1 group-list 224.0.0.0/4
ip pim bsr rp-candidate loopback0 group-list 224.1.1.0/24
ip pim forward listen
 

N7K-2 の設定:

interface loopback0
ip address 192.168.2.1/32
ip pim sparse-mode
 
ip pim rp-address 192.168.2.1 group-list 224.0.0.0/4
 
ip pim bsr forward listen
 

N7K-1 の確認:

show ip pim group 224.1.1.0
PIM Group-Range Configuration for VRF "default"
Group-range Mode RP-address Shared-tree-only range
224.1.1.0/24 ASM 192.168.1.1 -
 
show ip pim group 224.3.0.0
PIM Group-Range Configuration for VRF "default"
Group-range Mode RP-address Shared-tree-only range
224.0.0.0/4 ASM 192.168.2.1 -
 

N7K-2 の確認:

show ip pim group 224.1.1.0
PIM Group-Range Configuration for VRF "default"
Group-range Mode RP-address Shared-tree-only range
224.1.1.0/24 ASM 192.168.1.1 -
 
show ip pim group 224.3.0.0
PIM Group-Range Configuration for VRF "default"
Group-range Mode RP-address Shared-tree-only range
224.0.0.0/4 ASM 192.168.2.1 -
 
 

スタティック RP および BSR RP 候補が同じグループ リスト(224.0.0.0/4 など)をアドバタイズした場合は、グループ リスト内に指定されているあらゆるマルチキャスト アドレスに対し、RP IP アドレスが最上位である候補が RP として選定されます(設定例 2 を参照)。

設定例 2(同じ RP グループ リスト):この例の場合、224.0.0.0/4 グループ リスト内に指定されているすべてのマルチキャスト アドレスに対し、RP IP アドレスが最上位である N7K-2 というラベルのデバイスが RP として選定されます。

N7K-1 の設定:

interface loopback0
ip address 192.168.1.1/32
ip pim sparse-mode
 
ip pim rp-address 192.168.1.1 group-list 224.0.0.0/4
 
ip pim bsr forward listen
 

N7K-2 の設定:

interface loopback0
ip address 192.168.2.1/32
ip pim sparse-mode
 
ip pim bsr bsr-candidate loopback0
ip pim rp-address 192.168.1.1 group-list 224.0.0.0/4
ip pim bsr rp-candidate loopback0 group-list 224.0.0.0/4
ip pim bsr forward listen
 

N7K-1 の確認:

show ip pim group 224.1.1.0
PIM Group-Range Configuration for VRF "default"
Group-range Mode RP-address Shared-tree-only range
224.0.0.0/4 ASM 192.168.2.1
 

N7K-2 の確認:

show ip pim group 224.1.1.0
PIM Group-Range Configuration for VRF "default"
Group-range Mode RP-address Shared-tree-only range
224.0.0.0/4 ASM 192.168.2.1 -

 

スタティック RP は設定できず、そのデフォルト値は 0 です。したがって、RP プライオリティは影響を与えません。BSR RP 候補には、0 ~ 255 の値を設定できます。システムでは、最も詳細なグループ リストを持つデバイスが選定されます。両方のデバイスが同じグループ リストを持つ場合は、RP IP アドレスが最上位であるデバイスが選定されます(設定例 3 を参照)。

設定例 3(同じグループ リストで同じ RP プライオリティ):この例の場合、224.0.0.0/4 グループ リスト内に指定されているすべてのマルチキャスト アドレスに対し、RP IP アドレスが最上位である N7K-2 というラベルのデバイスが RP として選定されます。BSR RP とスタティック RP の間で RP プライオリティは比較されません。

N7K-1 の設定:

interface loopback0
ip address 192.168.1.1/32
ip pim sparse-mode
 
ip pim bsr bsr-candidate loopback0
ip pim rp-address 192.168.2.1 group-list 224.0.0.0/4
ip pim bsr rp-candidate loopback0 group-list 224.0.0.0/4 priority 0
 
ip pim bsr forward listen
 

N7K-2 の設定:

interface loopback0
ip address 192.168.2.1/32
ip pim sparse-mode
 
ip pim rp-address 192.168.2.1 group-list 224.0.0.0/4
 
ip pim bsr forward listen
 

N7K-1 の確認:

show ip pim rp
PIM RP Status Information for VRF "default"
BSR: 192.168.1.1*, next Bootstrap message in: 00:00:52,
priority: 64, hash-length: 30
Auto-RP disabled
BSR RP Candidate policy: None
BSR RP policy: None
Auto-RP Announce policy: None
Auto-RP Discovery policy: None
 
RP: 192.168.1.1*, (0), uptime: 00:01:57, expires: 00:02:25,
priority: 0, RP-source: 192.168.1.1 (B), group ranges:
224.0.0.0/4
RP: 192.168.2.1, (0), uptime: 02:16:09, expires: never,
priority: 0, RP-source: (local), group ranges:
224.0.0.0/4
 
show ip pim group 224.1.1.0
PIM Group-Range Configuration for VRF "default"
Group-range Mode RP-address Shared-tree-only range
224.0.0.0/4 ASM 192.168.2.1 -
 

N7K-2 の確認:

show ip pim rp
PIM RP Status Information for VRF "default"
BSR: 192.168.1.1, uptime: 00:29:47, expires: 00:01:45,
priority: 64, hash-length: 30
Auto-RP disabled
BSR RP Candidate policy: None
BSR RP policy: None
Auto-RP Announce policy: None
Auto-RP Discovery policy: None
 
RP: 192.168.1.1, (0), uptime: 00:06:59, expires: 00:02:05,
priority: 0, RP-source: 192.168.1.1 (B), group ranges:
224.0.0.0/4
RP: 192.168.2.1*, (0), uptime: 00:13:15, expires: never,
priority: 0, RP-source: (local), group ranges:
224.0.0.0/4
 
show ip pim group 224.1.1.0
PIM Group-Range Configuration for VRF "default"
Group-range Mode RP-address Shared-tree-only range
224.0.0.0/4 ASM 192.168.2.1 -
 

 

PIM Auto-RP 候補対 Auto-RP 候補の選定プロセス

 

Auto-RP 候補の選定は、BSR RP 候補の選定プロセスと似ていますが、プライオリティはサポートされていません(「PIM BSR RP 候補対 BSR RP 候補の選定プロセス」を参照)。Auto-RP にプライオリティを設定することはできません。デフォルト値は 0 です。

 

PIM Auto-RP 候補対スタティック RP の選定プロセス

 

Auto-RP 候補対スタティック RP の選定には、BSR RP 候補対スタティック RP の選定プロセスと同じルールが使用されます(「PIM BSR RP 候補対 スタティック RP の選定プロセス」を参照)。

Anycast-RP

Anycast-RP の実装方式には、Multicast Source Discovery Protocol(MSDP)を使用する場合と、 RFC 4610 (『 Anycast-RP Using Protocol Independent Multicast (PIM) 』)に基づく場合の 2 種類があります。ここでは、PIM Anycast-RP の設定方法について説明します。

PIM Anycast-RP を使用すると、Anycast-RP セットというルータ グループを、複数のルータに設定された単一の RP アドレスに割り当てることができます。Anycast-RP セットとは、Anycast-RP として設定された一連のルータを表します。各マルチキャスト グループで複数の RP をサポートし、セット内のすべての RP に負荷を分散させることができるのは、この RP 方式だけです。Anycast-RP はすべてのマルチキャスト グループをサポートします。

ユニキャスト ルーティング プロトコルの機能に基づいて、PIM Register メッセージが最も近い RP に送信され、PIM Join/Prune メッセージが最も近い RP の方向に送信されます。いずれかの RP がダウンすると、これらのメッセージは、ユニキャスト ルーティングを使用して次に最も近い RP の方向へと送信されます。

PIM は、PIM Anycast RP に使用されるループバック インターフェイス上に設定する必要があります。

PIM Anycast-RP の詳細については、 RFC 4610 を参照してください。

Anycast-RP の設定方法については、「PIM Anycast-RP セットの設定」を参照してください。

PIM Register メッセージ

PIM Register メッセージは、マルチキャスト送信元に直接接続された Designated Router(DR; 代表ルータ)から RP にユニキャストされます。PIM Register メッセージには次の機能があります。

マルチキャスト グループに対する送信元からの送信がアクティブであることを RP に通知する

送信元から送られたマルチキャスト パケットを RP に配信し、共有ツリーの下流に転送する

DR は RP から Register-Stop メッセージを受信するまで、PIM Register メッセージを RP 宛に送信し続けます。RP が Register-Stop メッセージを送信するのは、次のいずれかの場合です。

RP が送信中のマルチキャスト グループに、受信者が存在しない場合

RP が送信元への SPT に加入しているにもかかわらず、送信元からのトラフィックの受信が開始されていない場合


) Cisco NX-OS では RP の処理の停滞を防ぐため、PIM Register メッセージのレート制限が行われます。


PIM Register メッセージをフィルタリングするには、ルーティング ポリシーを定義します。PIM Register メッセージのポリシーの設定方法については、「ASM 専用の共有ツリーの設定」を参照してください。

代表ルータ

PIM の ASM モードおよび SSM モードでは、各ネットワーク セグメント上のルータの中から代表ルータ(DR)が選択されます。DR は、セグメント上の指定グループおよび送信元にマルチキャスト データを転送します。

各 LAN セグメントの DR は、「hello メッセージ」に記載された手順で決定されます。

ASM モードの場合、DR は RP に PIM Register パケットをユニキャストします。DR が、直接接続された受信者からの IGMP メンバシップ レポートを受信すると、DR を経由するかどうかに関係なく、RP への最短パスが形成されます。これにより、同じマルチキャスト グループ上で送信を行うすべての送信元と、そのグループのすべての受信者を接続する共有ツリーが作成されます。

SSM モードの場合、DR は、RP 方向または送信元方向に (*, G) または (S, G) PIM Join メッセージを発信します。受信者から送信元へのパスは、各ホップで決定されます。この場合、送信元が受信者または DR で認識されている必要があります。

DR プライオリティの設定方法については、「PIM または PIM6 スパース モードの設定」を参照してください。

Designated Forwarder

PIM の Bidir モードでは、RP を検出する際に、各ネットワーク セグメント上のルータから Designated Forwarder(DF)が選択されます。DF は、セグメント上の指定グループにマルチキャスト データを転送します。DF は、ネットワーク セグメントから RP へのベスト メトリックに基づいて選定されます。

RPF インターフェイスで RP 方向へのパケットを受信したルータは、そのパケットを Outgoing Interface(OIF; 発信インターフェイス)リスト内のすべてのインターフェイスから転送します。パケットを受信したインターフェイスが属するルータが、LAN セグメントの DF に選定されている場合、そのパケットは、着信インターフェイスを除く OIF リスト内のすべてのインターフェイスから転送されます。また、RPF インターフェイスを経由して RP 方向にも転送されます。


) Cisco NX-OS では、RPF インターフェイスが Multicast Routing Information Base(MRIB)の OIF リストに追加されますが、Multicast Forwarding Information Base(MFIB)の OIF リストには追加されません。


ASM モードにおける共有ツリーから送信元ツリーへのスイッチオーバー

ASM モードでは、共有ツリーだけを使用するように PIM パラメータを設定しないかぎり、受信者に接続された DR が、共有ツリーから送信元への Shortest-Path Tree(SPT; 最短パス ツリー)に切り替わります。共有ツリーだけを使用するための設定方法については、「ASM 専用の共有ツリーの設定」を参照してください。

このスイッチオーバーの間、SPT および共有ツリーのメッセージが両方とも表示されることがあります。これらのメッセージの意味は異なります。共有ツリー メッセージは上流の RP に向かって伝播されますが、SPT メッセージは送信元に向かって送信されます。

SPT スイッチオーバーの詳細については、 RFC 4601 の「Last-Hop Switchover to the SPT」の項を参照してください。

管理用スコープの IP マルチキャスト

管理用スコープの IP マルチキャスト方式を使用すると、マルチキャスト データの配信先を制限できます。詳細については、 RFC 2365 を参照してください。

インターフェイスを PIM 境界として設定し、PIM メッセージがこのインターフェイスから送信されないようにできます。ドメイン境界パラメータの設定方法については、「PIM または PIM6 スパース モードの設定」を参照してください。

Auto-RP スコープ パラメータを使用すると、Time-To-Live(TTL; 存続可能時間)値を設定できます。詳細については、「ASM 専用の共有ツリーの設定」を参照してください。

PIM の双方向フォワーディング検出

Cisco NX-OS Release 5.0(2a) 以降では、Bidirectional Forwarding Detection(BFD; 双方向フォワーディング検出)により、ネットワーク内の障害をすばやく検出できます。BFD の詳細については、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x 』を参照してください。

PIM では、hello インターバルの一部として設定された保持時間が経過すると、リンク グループまたはネイバー グループの障害が検出されます。しかし、BFD はより効率的な障害検出手段を提供します。このプロトコルは、2 つのエンドポイント間にリンク経由でセッションを確立し、転送エンジンを使用します。BFD をイネーブルにすると、PIM プロセスはネイバーを検出するたびに BFD セッションを追加しようとします。BFD セッションがすでに存在する場合、PIM はセッションを重複して作成せずに、BFD セッションのステートを含むコールバックを受信します。PIM の BFD は、VRF 単位またはインターフェイス単位でイネーブルにすることができます。

VRF またはインターフェイスの BFD をディセーブルにした場合、インターフェイスが PIM インターフェイスでなくなった場合、および隣接する BFD セッションがダウンした場合、PIM はその BFD セッションを削除します。

仮想化のサポート

Virtual Device Context(VDC; 仮想デバイス コンテキスト)は、一連のシステム リソースを論理的に表現する用語です。各 VDC 内では、複数の Virtual Routing and Forwarding(VRF; 仮想ルーティングおよびフォワーディング)インスタンスを定義できます。システムでは、VDC 内の VRF ごとに、MRIB や M6RIB などの独立したマルチキャスト システム リソースが用意されます。

PIM および PIM6 の show コマンドに VRF 引数を指定して実行すると、表示される情報のコンテキストを確認できます。VRF 引数を指定しない場合は、デフォルト VRF が使用されます。

VDC の設定の詳細については、『 Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide, Release 4.2 』を参照してください。

VRF の設定の詳細については、『 Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x 』を参照してください。

ハイ アベイラビリティ

ハイ アベイラビリティの詳細については、『 Cisco Nexus 7000 Series NX-OS High Availability and Redundancy Guide, Release 5.x 』を参照してください。

PIM および PIM6 のライセンス要件

次の表に、この機能のライセンス要件を示します。

 

製品
ライセンス要件

Cisco NX-OS

PIM および PIM6 には Enterprise Services ライセンスが必要です。Cisco NX-OS ライセンス方式の詳細、およびライセンスの取得方法と適用方法については、 『Cisco NX-OS Licensing Guide を参照してください。

PIM および PIM6 の前提条件

PIM および PIM6 の利用条件は次のとおりです。

デバイスにログインしている。

現在の Virtual Device Context(VDC; 仮想デバイス コンテキスト)が正しい。VDC は、一連のシステム リソースを論理的に表現する用語です。 switchto vdc コマンドでは VDC 番号を指定できます。

現在の Virtual Routing and Forwarding(VRF; 仮想ルーティングおよびフォワーディング)モードが正しい(グローバル コマンドの場合)。この章の例で示すデフォルトのコンフィギュレーション モードは、デフォルト VRF に適用されます。

PIM および PIM6 に関する注意事項と制限事項

PIM および PIM6 に関する注意事項および制限事項は次のとおりです。

トンネル インターフェイスは PIM をサポートしません。

Cisco NX-OS の PIM および PIM6 は、いずれの形式の PIM デンス モード/PIM スパース モード バージョン 1 とも相互運用性がありません。

同じネットワーク内では、Auto-RP プロトコルと BSR プロトコルを同時に設定できません。

候補 RP インターバルを 15 秒以上に設定してください。

デバイスに BSR ポリシーが適用されており、BSR として選定されないように設定されている場合、このポリシーは無視されます。これにより、次のようなデメリットが発生します。

ポリシーで許可されている BSM をデバイスが受信した場合、意図に反してこのデバイスが BSR に選定されていると、対象の BSM がドロップされるために下流のルータではその BSM を受信できなくなります。また、下流のデバイスでは、不正な BSR から送信された BSM が正しくフィルタリングされるため、これらのデバイスでは RP 情報を受信できなくなります。

BSR に異なるデバイスから送られた BSM が着信すると、新しい BSM が送信されますが、その正規の BSM は下流のデバイスでは受信されません。

vPC とデュアル スーパーバイザの使用中は、次のようにデフォルトのタイマーを使用する必要があります。

デュアル スーパーバイザの使用にあたっては高いデフォルト タイマー値が推奨されますが、この間リンク障害が起きるとコンバージェンスが困難になります。ISSU を実行する場合、またはネットワークの再コンバージェンスを行わずにシステムで SSO を実行する場合は、高いデフォルト タイマー値を指定してください。

リリース 5.x 以降では、PIM に非デフォルトのタイマーではなく BFD を使用することを推奨します。

ほとんどの展開については、デフォルトの PIM タイマー値が推奨されます。タイマーがデフォルト値から変更されている場合は、ISSU や SSO が予想どおりに機能しないことがあります。

リリース 5.x 以降では、秒未満の単位で障害を検出できるように、PIM に BFD を使用することを推奨します。

PIM および PIM6 の設定

PIM と PIM6 は、同一のルータに同時に設定できます。インターフェイスで IPv4 または IPv6 のいずれが実行されているかに応じて、インターフェイスごとに PIM または PIM6 を設定できます。


) Cisco NX-OS がサポートしているのは PIM スパース モードのバージョン 2 だけです。このマニュアルで「PIM」と記載されている場合は、PIM スパース モードのバージョン 2 を意味しています。


マルチキャスト配信モードを使用すると、PIM または PIM6 ドメインに、それぞれ独立したアドレス範囲を設定できます( 表 4-2 を参照)。

 

表 4-2 PIM および PIM6 マルチキャスト配信モード

マルチキャスト配信モード
RP 設定の必要性
説明

ASM

必要

任意の送信元のマルチキャスト

Bidir

必要

双方向共有ツリー

SSM

不可

単一送信元のマルチキャスト

マルチキャスト用 RPF ルート

不可

マルチキャスト用 RPF ルート

PIM および PIM6 の設定手順は次のとおりです。


ステップ 1 表 4-2 に示したマルチキャスト配信モードについて、各モードに設定するマルチキャスト グループの範囲を選択します。

ステップ 2 PIM および PIM6 機能をイネーブルにします。「PIM および PIM6 機能のイネーブル化」を参照してください。

ステップ 3 PIM ドメインに参加させる各インターフェイスで、PIM または PIM6 スパース モードを設定します。「PIM または PIM6 スパース モードの設定」を参照してください。

ステップ 4 ステップ 1 で選択したマルチキャスト配信モードについて、次の設定作業を行います。

ASM モードまたは Bidir モードについては、「ASM および Bidir の設定」を参照してください。

SSM モードについては、「SSM の設定」を参照してください。

マルチキャスト用 RPF ルートについては、「マルチキャスト用 RPF ルートの設定」を参照してください。

ステップ 5 メッセージ フィルタリングを設定します。「メッセージ フィルタリングの設定」を参照してください。


 

次に、PIM または PIM6 の設定に使用される Command Line Interface(CLI; コマンドライン インターフェイス)コマンドの相違点を示します。

PIM コマンドは ip pim で始まり、PIM6 コマンドは ipv6 pim で始まります。

PIM コマンドは show ip pim で始まり、PIM6 コマンドは show ipv6 pim で始まります。

ここでは、次の内容について説明します。

「PIM および PIM6 機能のイネーブル化」

「PIM または PIM6 スパース モードの設定」

「ASM および Bidir の設定」

「SSM の設定」

「マルチキャスト用 RPF ルートの設定」

「RP 情報配信を制御するルート マップの設定」

「メッセージ フィルタリングの設定」

「PIM プロセスおよび PIM6 プロセスの再起動」

「PIM の BFD の設定」


) Cisco IOS CLI の詳しい知識がある場合は、この機能で使用する Cisco NX-OS コマンドが、よく使用される Cisco IOS コマンドとは異なる可能性があることに注意してください。


PIM および PIM6 機能のイネーブル化

PIM または PIM6 コマンドにアクセスするには、PIM または PIM6 機能をイネーブルにしておく必要があります。

はじめる前に

Enterprise Services ライセンスがインストールされていることを確認してください。

手順の概要

1. config t

2. feature pim

3. feature pim6

4. show running-configuration pim

5. show running-configuration pim6

6. copy running-config startup-config

手順の詳細

 

 
コマンド
目的

ステップ 1

config t

 

例:

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

feature pim

 

例:

switch(config)# feature pim

PIM をイネーブルにします。デフォルトでは PIM はディセーブルになっています。

ステップ 3

feature pim6

 

例:

switch(config)# feature pim6

PIM6 をイネーブルにします。デフォルトでは PIM6 はディセーブルになっています。

ステップ 4

show running-configuration pim

 

例:

switch(config)# show running-configuration pim

(任意) feature コマンドを含む、PIM の実行コンフィギュレーション情報を示します。

ステップ 5

show running-configuration pim6

 

例:

switch(config)# show running-configuration pim6

(任意) feature コマンドを含む、PIM6 の実行コンフィギュレーション情報を示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)コンフィギュレーションの変更を保存します。

PIM または PIM6 スパース モードの設定

スパース モード ドメインに参加させる各デバイス インターフェイスで、PIM または PIM6 スパース モードを設定します。このとき、 表 4-3 に示すスパース モード パラメータを設定できます。

 

表 4-3 PIM および PIM6 スパース モードのパラメータ

パラメータ
説明

デバイスにグローバルに適用

Auto-RP メッセージ アクション

Auto-RP メッセージの受信と転送をイネーブルにします。これらの機能はデフォルトではディセーブルになっているため、候補 RP またはマッピング エージェントとして設定されていないルータは、Auto-RP メッセージの受信と転送を行いません。

(注) PIM6 は、Auto-RP 方式をサポートしていません。

BSR メッセージ アクション

BSR メッセージの受信と転送をイネーブルにします。これらの機能はデフォルトではディセーブルになっているため、候補 RP または BSR 候補として設定されていないルータは、BSR メッセージの受信と転送を行いません。

Bidir RP 制限

IPv4 および IPv6 に設定可能な Bidir RP の数を設定します。PIM と PIM6 を組み合わせている場合は、各 VRF でサポートする Bidir RP の最大数を 8 以下にする必要があります。有効範囲は 0 ~ 8 です。デフォルトは、IPv4 の場合が 6、IPv6 の場合が 2 です。

Register のレート制限

IPv4 または IPv6 Register のレート制限を毎秒のパケット数で設定します。指定できる範囲は 1 ~ 65,535 です。デフォルト設定は無制限です。

初期ホールドダウン期間

IPv4 または IPv6 の初期ホールドダウン期間を秒単位で設定します。このホールドダウン期間は、MRIB が最初に起動するのにかかる時間です。コンバージェンスを高速化するには、小さい値を入力します。指定できる範囲は 90 ~ 210 です。ホールドダウン期間をディセーブルにするには、0 を指定します。デフォルト値は 210 です。

デバイスの各インターフェイスに適用

PIM スパース モード

インターフェイスで PIM または PIM6 をイネーブルにします。

DR プライオリティ

現在のインターフェイスに、PIM hello メッセージの一部としてアドバタイズされる Designated Router(DR; 代表ルータ)プライオリティを設定します。複数の PIM 対応ルータが存在するマルチアクセス ネットワークでは、DR プライオリティの最も高いルータが DR ルータとして選定されます。プライオリティが等しい場合は、IP アドレスが最上位のルータが DR に選定されます。DR は、直接接続されたマルチキャスト送信元に PIM Register メッセージを送信するとともに、直接接続された受信者に代わって、Rendezvous Point(RP; ランデブー ポイント)方向に PIM Join メッセージを送信します。有効範囲は 1 ~ 4294967295 です。デフォルトは 1 です。

hello 認証モード

インターフェイスで、PIM hello メッセージ内の MD5 ハッシュ認証キー(パスワード)をイネーブルにして、直接接続されたネイバーによる相互認証を可能にします。PIM hello メッセージは、Authentication Header(AH; 認証ヘッダー)オプションを使用して符号化された IP セキュリティ です。暗号化されていない(クリアテキストの)キーか、または次に示す値のいずれかを入力したあと、スペースと MD5 認証キーを入力します。

0:暗号化されていない(クリアテキストの)キーを指定します。

3:3-DES 暗号化キーを指定します。

7:Cisco Type 7 暗号化キーを指定します。

認証キーの文字数は最大 16 文字です。デフォルトではディセーブルになっています。

(注) PIM6 は hello 認証をサポートしません。

hello インターバル

hello メッセージの送信インターバルを、ミリ秒単位で設定します。指定できる範囲は 1 ~ 4294967295 です。デフォルト値は 30000 です。

ドメイン境界

インターフェイスを PIM ドメインの境界として設定し、対象のインターフェイスで、ブートストラップ、候補 RP、または Auto-RP の各メッセージが送受信されないようにします。デフォルトではディセーブルになっています。

(注) PIM6 は、Auto-RP 方式をサポートしていません。

ネイバー ポリシー

ルートマップ ポリシー 1 に基づいて、PIM ネイバーの隣接関係を設定します。隣接関係は、 match ip [ v6 ] address コマンドを使用して IP アドレスで指定できます。指定したポリシー名が存在しない場合、または IP アドレスがポリシー内で設定されていない場合は、すべてのネイバーとの隣接関係が確立されます。デフォルトでは、すべての PIM ネイバーと隣接関係が確立されます。

(注) この機能の設定は、経験を積んだネットワーク管理者が行うことを推奨します。

1.ルートマップ ポリシーの設定方法については、『Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x』を参照してください。

マルチキャスト ルート マップの設定方法については、「RP 情報配信を制御するルート マップの設定」を参照してください。


) Join/Prune ポリシーの設定方法については、「メッセージ フィルタリングの設定」を参照してください。


はじめる前に

Enterprise Services ライセンスがインストールされていること、および PIM または PIM6 がイネーブルになっていることを確認してください。

手順の概要

PIM コマンド

1. config t

2. ip pim auto-rp { listen [ forward ] | forward [ listen ]}

3. ip pim bsr { listen [ forward ] | forward [ listen ]}

4. show ip pim rp [ ip-prefix ] [ vrf vrf-name | all ]

5. ip pim bidir-rp-limit limit

6. ip pim register-rate-limit rate

7. [ ip | ipv4 ] routing multicast holddown holddown-period

8. show running-configuration pim

9. interface interface

10. ip pim sparse-mode

11. ip pim dr-priority priority

12. ip pim hello-authentication ah-md5 auth-key

13. ip pim hello-interval interval

14. ip pim border

15. ip pim neighbor-policy policy-name

16. show ip pim interface [ interface | brief ] [ vrf vrf-name | all ]

17. copy running-config startup-config

PIM6 コマンド

1. config t

2. ipv6 pim bsr { listen [ forward ] | forward [ listen ]}

3. show ipv6 pim rp [ ipv6-prefix ] [ vrf vrf-name | all ]

4. ipv6 pim bidir-rp-limit limit

5. ipv6 pim register-rate-limit rate

6. ipv6 routing multicast holddown holddown-period

7. show running-configuration pim6

8. interface interface

9. ipv6 pim sparse-mode

10. ipv6 pim dr-priority priority

11. ipv6 pim hello-interval interval

12. ipv6 pim border

13. ipv6 pim neighbor-policy policy-name

14. show ipv6 pim interface [ interface | brief ] [ vrf vrf-name | all ]

15. copy running-config startup-config

手順の詳細

PIM コマンド

 
コマンド
目的

ステップ 1

config t

 

例:

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

ip pim auto-rp { listen [ forward ] | forward [ listen ]}

 

例:

switch(config)# ip pim auto-rp listen

(任意)Auto-RP メッセージの受信と転送をイネーブルにします。デフォルトではこれらの機能がディセーブルになっているため、Auto-RP メッセージの受信と転送は行われません。

ステップ 3

ip pim bsr { listen [ forward ] | forward [ listen ]}

 

例:

switch(config)# ip pim bsr forward

(任意)BSR メッセージの受信と転送をイネーブルにします。デフォルトではこれらの機能がディセーブルになっているため、BSR メッセージの受信と転送は行われません。

ステップ 4

show ip pim rp [ ip-prefix ] [ vrf vrf-name | all ]

 

例:

switch(config)# show ip pim rp

(任意)Auto-RP および BSR の受信/転送ステートなど、PIM RP 情報を表示します。

ステップ 5

ip pim bidir-rp-limit limit

 

例:

switch(config)# ip pim bidir-rp-limit 4

(任意)IPv4 に設定可能な Bidir RP の数を指定します。PIM と PIM6 を組み合わせている場合は、各 VRF でサポートする Bidir RP の最大数を 8 以下にする必要があります。有効範囲は 0 ~ 8 です。デフォルト値は 6 です。

ステップ 6

ip pim register-rate-limit rate

 

例:

switch(config)# ip pim register-rate-limit 1000

(任意)レート制限を毎秒のパケット数で設定します。指定できる範囲は 1 ~ 65,535 です。デフォルト設定は無制限です。

ステップ 7

[ ip | ipv4 ] routing multicast holddown holddown-period

 

例:

switch(config)# ip routing multicast holddown 100

(任意)初期ホールドダウン期間を秒単位で設定します。指定できる範囲は 90 ~ 210 です。ホールドダウン期間をディセーブルにするには、0 を指定します。デフォルト値は 210 です。

ステップ 8

show running-configuration pim

 

例:

switch(config)# show running-configuration pim

(任意)Bidir RP 制限および Register のレート制限を含む、PIM 実行コンフィギュレーション情報を表示します。

ステップ 9

interface interface

 

例:

switch(config)# interface ethernet 2/1

switch(config-if)#

ethernet slot/port などのインターフェイス タイプおよび番号を入力して、インターフェイス モードを開始します。

ステップ 10

ip pim sparse-mode

 

例:

switch(config-if)# ip pim sparse-mode

現在のインターフェイスで PIM スパース モードをイネーブルにします。デフォルトではディセーブルになっています。

ステップ 11

ip pim dr-priority priority

 

例:

switch(config-if)# ip pim dr-priority 192

(任意)PIM hello メッセージの一部としてアドバタイズされる Designated Router(DR; 代表ルータ)プライオリティを設定します。有効範囲は 1 ~ 4294967295 です。デフォルトは 1 です。

ステップ 12

ip pim hello-authentication ah-md5 auth-key

 

例:

switch(config-if)# ip pim hello-authentication ah-md5 my_key

(任意)PIM hello メッセージ内の MD5 ハッシュ認証キーをイネーブルにします。暗号化されていない(クリアテキストの)キーか、または次に示す値のいずれかを入力したあと、スペースと MD5 認証キーを入力します。

0:暗号化されていない(クリアテキストの)キーを指定します。

3:3-DES 暗号化キーを指定します。

7:Cisco Type 7 暗号化キーを指定します。

キーの文字数は最大 16 文字です。デフォルトではディセーブルになっています。

ステップ 13

ip pim hello-interval interval

 

例:

switch(config-if)# ip pim hello-interval 25000

(任意)hello メッセージの送信インターバルを、ミリ秒単位で設定します。指定できる範囲は 1 ~ 4294967295 です。デフォルト値は 30000 です。

ステップ 14

ip pim border

 

例:

switch(config-if)# ip pim border

(任意)インターフェイスを PIM ドメインの境界として設定し、対象のインターフェイスで、ブートストラップ、候補 RP、または Auto-RP の各メッセージが送受信されないようにします。デフォルトではディセーブルになっています。

ステップ 15

ip pim neighbor-policy policy-name

 

例:

switch(config-if)# ip pim neighbor-policy my_neighbor_policy

(任意) match ip address コマンドを使用し、ルートマップ ポリシーに基づいて PIM ネイバーの隣接関係を設定します。ポリシー名の文字数は最大 63 文字です。デフォルトでは、すべての PIM ネイバーと隣接関係が確立されます。

(注) この機能の設定は、経験を積んだネットワーク管理者が行うことを推奨します。

ステップ 16

show ip pim interface [ interface | brief ] [ vrf vrf-name | all ]

 

例:

switch(config-if)# show ip pim interface

(任意)PIM インターフェイス情報を表示します。

ステップ 17

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)コンフィギュレーションの変更を保存します。

PIM6 コマンド

 
コマンド
目的

ステップ 1

config t

 

例:

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

ipv6 pim bsr { listen [ forward ] | forward [ listen ]}

 

例:

switch(config)# ipv6 pim bsr forward

(任意)BSR メッセージの受信と転送をイネーブルにします。デフォルトではこれらの機能がディセーブルになっているため、BSR メッセージの受信と転送は行われません。

ステップ 3

show ipv6 pim rp [ ipv6-prefix ] [ vrf vrf-name | all ]

 

例:

switch(config)# show ipv6 pim rp

(任意)BSR の受信/転送ステートなど、PIM6 RP 情報を表示します。

ステップ 4

ipv6 pim bidir-rp-limit limit

 

例:

switch(config)# ipv6 pim bidir-rp-limit 4

(任意)IPv6 に設定可能な Bidir RP の数を指定します。PIM と PIM6 を組み合わせている場合は、各 VRF でサポートする Bidir RP の最大数を 8 以下にする必要があります。有効範囲は 0 ~ 8 です。デフォルト値は 2 です。

ステップ 5

ipv6 pim register-rate-limit rate

 

例:

switch(config)# ipv6 pim register-rate-limit 1000

(任意)レート制限を毎秒のパケット数で設定します。指定できる範囲は 1 ~ 65,535 です。デフォルト設定は無制限です。

ステップ 6

ipv6 routing multicast holddown holddown-period

 

例:

switch(config)# ipv6 routing multicast holddown 100

(任意)初期ホールドダウン期間を秒単位で設定します。指定できる範囲は 90 ~ 210 です。ホールドダウン期間をディセーブルにするには、0 を指定します。デフォルト値は 210 です。

ステップ 7

show running-configuration pim6

 

例:

switch(config)# show running-configuration pim6

(任意)Bidir RP 制限および Register のレート制限を含む、PIM6 実行コンフィギュレーション情報を表示します。

ステップ 8

interface interface

 

例:

switch(config)# interface ethernet 2/1

switch(config-if)#

指定したインターフェイスでインターフェイス モードを開始します。

ステップ 9

ipv6 pim sparse-mode

 

例:

switch(config-if)# ipv6 pim sparse-mode

現在のインターフェイスで PIM6 スパース モードをイネーブルにします。デフォルトではディセーブルになっています。

ステップ 10

ipv6 pim dr-priority priority

 

例:

switch(config-if)# ipv6 pim dr-priority 192

(任意)PIM6 hello メッセージの一部としてアドバタイズされる Designated Router(DR; 代表ルータ)プライオリティを設定します。有効範囲は 1 ~ 4294967295 です。デフォルトは 1 です。

ステップ 11

ipv6 pim hello-interval interval

 

例:

switch(config-if)# ipv6 pim hello-interval 25000

(任意)hello メッセージの送信インターバルを、ミリ秒単位で設定します。指定できる範囲は 1 ~ 4294967295 です。デフォルト値は 30000 です。

ステップ 12

ipv6 pim border

 

例:

switch(config-if)# ipv6 pim border

(任意)インターフェイスを PIM6 ドメインの境界として設定し、対象のインターフェイスで、ブートストラップ、候補 RP、または Auto-RP の各メッセージが送受信されないようにします。デフォルトではディセーブルになっています。

ステップ 13

ipv6 pim neighbor-policy policy-name

 

例:

switch(config-if)# ipv6 pim neighbor-policy my_neighbor_policy

(任意) match ipv6 address コマンドを使用し、ルートマップ ポリシーに基づいて PIM6 ネイバーの隣接関係を設定します。ポリシー名の文字数は最大 63 文字です。デフォルトでは、すべての PIM6 ネイバーと隣接関係が確立されます。

(注) この機能の設定は、経験を積んだネットワーク管理者が行うことを推奨します。

ステップ 14

show ipv6 pim interface [ interface | brief ] [ vrf vrf-name | all ]

 

例:

switch(config-if)# show ipv6 pim interface

(任意)PIM6 インターフェイス情報を表示します。

ステップ 15

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)コンフィギュレーションの変更を保存します。

ASM および Bidir の設定

Any Source Multicast(ASM)および Bidirectional shared tree(Bidir; 双方向共有ツリー)のマルチキャスト配信モードでは、マルチキャスト データの送信元と受信者の間に、共通のルートとして動作する RP を設定する必要があります。

ASM または Bidir モードを有効にするには、スパース モードおよび RP の選択方式を設定します。RP の選択方式では、配信モードを指定して、マルチキャスト グループの範囲を割り当てます。


) Bidir モードは virtual Port Channel(vPC; 仮想ポート チャネル)ではサポートされません。vPC の詳細については、『Cisco Nexus 7000 Series NX-OS Interfaces Configuration Guide, Release 5.x』を参照してください。


ここでは、次の内容について説明します。

「スタティック RP の設定」

「BSR の設定」

「Auto-RP の設定」

「PIM Anycast-RP セットの設定」

「ASM 専用の共有ツリーの設定」

スタティック RP の設定

RP を静的に設定するには、PIM ドメインに参加するルータのそれぞれに RP アドレスを設定します。

match ip multicast コマンドで、使用するグループ プレフィクスを示すルートマップ ポリシー名を指定できます。

はじめる前に

Enterprise Services ライセンスがインストールされていること、および PIM または PIM6 がイネーブルになっていることを確認してください。

手順の概要

PIM コマンド

1. config t

2. ip pim rp-address rp-address [ group-list ip-prefix | route-map policy-name ] [ bidir ]

3. show ip pim group-range [ ip-prefix ] [ vrf vrf-name | all ]

4. copy running-config startup-config

PIM6 コマンド

1. config t

2. ipv6 pim rp-address rp-address [ group-list ipv6-prefix | route-map policy-name ] [ bidir ]

3. show ipv6 pim group-range [ ipv6-prefix ] [ vrf vrf-name | all ]

4. copy running-config startup-config

手順の詳細

PIM コマンド

 
コマンド
目的

ステップ 1

config t

 

例:

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

ip pim rp-address rp-address [ group-list ip-prefix | route-map policy-name ] [ bidir ]

 

例1:

switch(config)# ip pim rp-address 192.0.2.33 group-list 224.0.0.0/9

 

例2:

switch(config)# ip pim rp-address 192.0.2.34 group-list 224.128.0.0/9 bidir

マルチキャスト グループ範囲に、PIM スタティック RP アドレスを設定します。 match ip multicast コマンドで、使用するグループ プレフィクスを示すルートマップ ポリシー名を指定できます。 bidir キーワードを指定しない場合、デフォルト モードは ASM です。デフォルトのグループ範囲は 224.0.0.0 ~ 239.255.255.255 です。

例 1 では、指定したグループ範囲に PIM ASM モードを設定しています。

例 2 では、指定したグループ範囲に PIM Bidir モードを設定しています。

ステップ 3

show ip pim group-range [ ip-prefix ] [ vrf vrf-name | all ]

 

例:

switch(config)# show ip pim group-range

(任意)PIM モードおよびグループ範囲を表示します。

ステップ 4

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)コンフィギュレーションの変更を保存します。

PIM6 コマンド

 
コマンド
目的

ステップ 1

config t

 

例:

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

ipv6 pim rp-address rp-address [ group-list ipv6-prefix | route-map policy-name ] [ bidir ]

 

例1:

switch(config)# ipv6 pim rp-address 2001:0db8:0:abcd::1 group-list ff1e:abcd:def1::0/24

 

例2:

switch(config)# ipv6 pim rp-address 2001:0db8:0:abcd::2 group-list ff1e:abcd:def2::0/96 bidir

マルチキャスト グループ範囲に、PIM6 スタティック RP アドレスを設定します。 match ip multicast コマンドで、使用するグループ プレフィクスを示すルートマップ ポリシー名を指定できます。 bidir キーワードを指定しない場合、モードは ASM です。デフォルトのグループ範囲は ff00::0/8 です。

例 1 では、指定したグループ範囲に PIM6 ASM モードを設定しています。

例 2 では、指定したグループ範囲に PIM6 Bidir モードを設定しています。

ステップ 3

show ipv6 pim group-range [ ipv6-prefix ] [ vrf vrf-name | all ]

 

例:

switch(config)# show ipv6 pim group-range

(任意)PIM6 モードおよびグループ範囲を表示します。

ステップ 4

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)コンフィギュレーションの変更を保存します。

BSR の設定

BSR を設定するには、候補 BSR および候補 RP を選択します。


注意 同じネットワーク内では、Auto-RP プロトコルと BSR プロトコルを同時に設定できません。

候補 BSR の設定では引数を指定できます( 表 4-4 を参照)。

 

表 4-4 候補 BSR の引数

引数
説明

interface

ブートストラップ メッセージで使用する、BSR 送信元 IP アドレスを取得するためのインターフェイス タイプおよび番号。

hash-length

ハッシュ長は、マスクを適用するために使用される上位桁の 1 の個数です。マスクでは、候補 RP のグループ アドレス範囲の論理積をとることにより、ハッシュ値を算出します。マスクは、グループ範囲が等しい一連の RP に割り当てられる連続アドレスの個数を決定します。PIM の場合、この値の範囲は 0 ~ 32 で、デフォルト値は 30 秒です。PIM6 の場合、この値の範囲は 0 ~ 128 で、デフォルト値は 126 秒です。

priority

現在の BSR に割り当てられたプライオリティ。ソフトウェアにより、プライオリティが最も高い BSR が選定されます。BSR プライオリティが等しい場合は、IP アドレスが最上位の BSR が選定されます。この値の範囲は 0(プライオリティが最小)~ 255 で、デフォルト値は 64 です。

候補 RP の設定では引数を指定できます( 表 4-5 を参照)。

 

表 4-5 BSR 候補 RP の引数およびキーワード

引数またはキーワード
説明

interface

ブートストラップ メッセージで使用する、BSR 送信元 IP アドレスを取得するためのインターフェイス タイプおよび番号。

group-list ip-prefix

プレフィクス形式で指定された、この RP によって処理されるマルチキャスト グループ。

interval

候補 RP メッセージの送信間隔(秒)。この値の範囲は 1 ~ 65,535 で、デフォルト値は 60 秒です。

(注) 候補 RP インターバルは 15 秒以上に設定することを推奨します。

priority

現在の RP に割り当てられたプライオリティ。ソフトウェアにより、グループ範囲内でプライオリティが最も高い RP が選定されます。プライオリティが等しい場合は、IP アドレスが最上位の RP が選定されます(最も小さい数値が最も高いプライオリティになります)。この値の範囲は 0(最も高いプライオリティ)~ 255 で、デフォルトは 192 です。

(注) これは BSR 候補プライオリティとは異なります。BSR 候補プライオリティは、0 ~ 255 の間で、高い値ほどプライオリティが高くなります。

bidir

bidir を指定しない場合、現在の RP は ASM モードになります。bidir を指定した場合は、Bidir モードになります。

route-map policy-name

この機能を適用するグループ プレフィクスを定義するルートマップ ポリシー名を指定します。


ヒント 候補 BSR および 候補 RP は、PIM ドメインのすべての箇所と適切に接続されている必要があります。


BSR および候補 RP には同じルータを指定できます。多数のルータが設置されたドメインでは、複数の候補 BSR および候補 RP を選択することにより、BSR または RP に障害が発生した場合に、自動的に代替 BSR または代替 RP へとフェールオーバーすることができます。

候補 BSR および候補 RP を設定する手順は、次のとおりです。


ステップ 1 PIM ドメインの各ルータで BSR メッセージの受信と転送を行うかどうかを設定します。候補 RP または候補 BSR として設定されたルータは、インターフェイスにドメイン境界機能が設定されていない場合、すべての BSR プロトコル メッセージの受信と転送を自動的に実行します。詳細については、「PIM または PIM6 スパース モードの設定」を参照してください。

ステップ 2 候補 BSR および候補 RP として動作するルータを選択します。

ステップ 3 後述の手順に従い、候補 BSR および候補 RP をそれぞれ設定します。

ステップ 4 BSR メッセージ フィルタリングを設定します。「メッセージ フィルタリングの設定」を参照してください。


 

はじめる前に

Enterprise Services ライセンスがインストールされていること、および PIM または PIM6 がイネーブルになっていることを確認してください。

手順の概要

PIM コマンド

1. config t

2. ip pim bsr listen forward

3. ip pim [ bsr ] bsr-candidate interface [ hash-len hash-length ] [ priority priority ]

4. ip pim [ bsr ] rp-candidate interface {group-list ip-prefix | route-map policy-name }[ priority priority ] [ interval interval ] [ bidir ]

5. show ip pim group-range [ ip-prefix ] [ vrf vrf-name | all ]

6. copy running-config startup-config

PIM6 コマンド

1. config t

2. ipv6 pim [ bsr ] bsr-candidate interface [ hash-len hash-length ] [ priority priority ]

3. ipv6 pim [ bsr ] rp-candidate interface {group-list ipv6-prefix | route-map policy-name } [ priority priority ] [ interval interval ] [ bidir ]

4. show ipv6 pim group-range [ ipv6-prefix ] [ vrf vrf-name | all ]

5. copy running-config startup-config

手順の詳細

PIM コマンド

 
コマンド
目的

ステップ 1

config t

 

例:

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

ip pim bsr listen forward

 

例:

switch(config)# ip pim bsr listen forward

リッスンと転送を設定します。

リモート PE 上の各 VRF で確実にこのコマンドを入力してください。

ステップ 3

ip pim [ bsr ] bsr-candidate interface [ hash-len hash-length ] [ priority priority ]

 

例:

switch(config)# ip pim bsr-candidate ethernet 2/1 hash-len 24

候補 BootStrap Router(BSR; ブートストラップ ルータ)を設定します。ブートストラップ メッセージで使用される送信元 IP アドレスは、インターフェイスの IP アドレスです。ハッシュ長は 0 ~ 32 で、デフォルト値は 30 です。プライオリティは 0 ~ 255 で、デフォルト値は 64 です。パラメータの詳細については、 表 4-4 を参照してください。

ステップ 4

ip pim [ bsr ] rp-candidate interface { group-list ip-prefix | route-map policy-name } [ priority priority ] [ interval interval ] [ bidir ]

 

例1:

switch(config)# ip pim rp-candidate ethernet 2/1 group-list 239.0.0.0/24

 

例2:

switch(config)# ip pim rp-candidate ethernet 2/1 group-list 239.0.0.0/24 bidir

BSR の候補 RP を設定します。プライオリティは 0(プライオリティが最大)~ 65,535 で、デフォルト値は 192 です。インターバルは 1 ~ 65,535 秒で、デフォルト値は 60 秒です。

(注) 候補 RP インターバルは 15 秒以上に設定することを推奨します。

例 1 では、ASM の候補 RP を設定しています。

例 2 では、Bidir の候補 RP を設定しています。

ステップ 5

show ip pim group-range [ ip-prefix ] [ vrf vrf-name | all ]

 

例:

switch(config)# show ip pim group-range

(任意)PIM モードおよびグループ範囲を表示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)コンフィギュレーションの変更を保存します。

PIM6 コマンド

 
コマンド
目的

ステップ 1

config t

 

例:

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

ipv6 pim [ bsr ] bsr-candidate interface [ hash-len hash-length ] [ priority priority ]

 

例:

switch(config)# ipv6 pim bsr-candidate ethernet 2/1 hash-len 24 priority 192

候補 BootStrap Router(BSR; ブートストラップ ルータ)を設定します。ブートストラップ メッセージで使用される送信元 IP アドレスは、インターフェイスの IP アドレスです。ハッシュ長は 0 ~ 128 で、デフォルト値は 126 です。プライオリティは 0(プライオリティが最小)~ 255 で、デフォルト値は 64 です。パラメータの詳細については、 表 4-4 を参照してください。

ステップ 3

ipv6 pim [ bsr ] rp-candidate interface { group-list ipv6-prefix | route-map policy-name } [ priority priority ] [ interval interval ] [ bidir ]

 

例1:

switch(config)# ipv6 pim rp-candidate ethernet 2/1 group-list ff1e:abcd:def1::0/24

 

例2:

switch(config)# ipv6 pim rp-candidate ethernet 2/1 group-list ff1e:abcd:def2::0/24 bidir

BSR の候補 RP を設定します。プライオリティは 0(プライオリティが最大)~ 65,535 で、デフォルト値は 192 です。インターバルは 1 ~ 65,535 秒で、デフォルト値は 60 秒です。パラメータの詳細については、 表 4-5 を参照してください。

例 1 では、ASM の候補 RP を設定しています。

例 2 では、Bidir の候補 RP を設定しています。

ステップ 4

show ipv6 pim group-range [ ipv6-prefix ] [ vrf vrf-name | all ]

 

例:

switch(config)# show ipv6 pim group-range

(任意)PIM6 モードおよびグループ範囲を表示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)コンフィギュレーションの変更を保存します。

 

設定済みの PIM6 モードおよびグループ範囲を表示するには、 show ipv6 pim group-range コマンドを使用します。

Auto-RP の設定

Auto-RP を設定するには、候補マッピング エージェントおよび候補 RP を選択します。マッピング エージェントおよび候補 RP には同じルータを指定できます。


) Auto-RP は PIM6 ではサポートされていません。



注意 同じネットワーク内では、Auto-RP プロトコルと BSR プロトコルを同時に設定できません。

Auto-RP マッピング エージェントの設定では、引数を指定できます( 表 4-6 を参照)。

 

表 4-6 Auto-RP マッピング エージェントの引数

引数
説明

interface

ブートストラップ メッセージで使用する、Auto-RP マッピング エージェントの IP アドレスを取得するためのインターフェイス タイプおよび番号。

scope ttl

RP-Discovery メッセージが転送される最大ホップ数を表す Time-To-Live(TTL; 存続可能時間)値。この値の範囲は 1 ~ 255 で、デフォルト値は 32 です。

(注) 「PIM または PIM6 スパース モードの設定」の境界ドメイン機能を参照してください。

複数の Auto-RP マッピング エージェントを設定した場合、1 つだけがドメインのマッピング エージェントとして選定されます。選定されたマッピング エージェントは、すべての候補 RP メッセージを配信します。すべてのマッピング エージェントが配信された候補 RP メッセージを受信し、受信した RP キャッシュを、RP-Discovery メッセージの一部としてアドバタイズします。

候補 RP の設定では引数を指定できます( 表 4-7 を参照)。

 

表 4-7 Auto-RP 候補 RP の引数およびキーワード

引数またはキーワード
説明

interface

ブートストラップ メッセージで使用する、候補 RP の IP アドレスを取得するためのインターフェイス タイプおよび番号。

group-list ip-prefix

現在の RP で処理されるマルチキャスト グループ。プレフィクス形式で指定します。

scope ttl

RP-Discovery メッセージが転送される最大ホップ数を表す Time-To-Live(TTL; 存続可能時間)値。この値の範囲は 1 ~ 255 で、デフォルト値は 32 です。

(注) 「PIM または PIM6 スパース モードの設定」の境界ドメイン機能を参照してください。

interval

RP-Announce メッセージの送信間隔(秒)。この値の範囲は 1 ~ 65,535 で、デフォルト値は 60 です。

(注) 候補 RP インターバルは 15 秒以上に設定することを推奨します。

bidir

指定しない場合、現在の RP は ASM モードになります。指定した場合、現在の RP は Bidir モードになります。

route-map policy-name

この機能を適用するグループ プレフィクスを定義するルートマップ ポリシー名を指定します。


ヒント マッピング エージェントおよび候補 RP は、PIM ドメインのすべての箇所と適切に接続されている必要があります。


Auto-RP マッピング エージェントおよび候補 RP を設定する手順は、次のとおりです。


ステップ 1 PIM ドメインの各ルータで、Auto-RP メッセージの受信と転送を行うかどうかを設定します。候補 RP または Auto-RP マッピング エージェントとして設定されたルータは、インターフェイスにドメイン境界機能が設定されていない場合、すべての Auto-RP プロトコル メッセージの受信と転送を自動的に実行します。詳細については、「PIM または PIM6 スパース モードの設定」を参照してください。

ステップ 2 マッピング エージェントおよび候補 RP として動作するルータを選択します。

ステップ 3 後述の手順に従い、マッピング エージェントおよび候補 RP をそれぞれ設定します。

ステップ 4 Auto-RP メッセージ フィルタリングを設定します。「メッセージ フィルタリングの設定」を参照してください。


 

はじめる前に

Enterprise Services ライセンスがインストールされていること、および PIM または PIM6 がイネーブルになっていることを確認してください。

手順の概要

PIM コマンド

1. config t

2. ip pim { send-rp-discovery | { auto-rp mapping-agent }} interface [ scope ttl ]

3. ip pim { send-rp-announce | { auto-rp rp-candidate }} interface { group-list ip-prefix | route-map policy-name } [ scope ttl ] [ interval interval ] [ bidir ]

4. show ip pim group-range [ ip-prefix ] [ vrf vrf-name | all ]

5. copy running-config startup-config

手順の詳細

PIM コマンド

 
コマンド
目的

ステップ 1

config t

 

例:

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

ip pim { send-rp-discovery | { auto-rp mapping-agent }} interface [ scope ttl ]

 

例:

switch(config)# ip pim auto-rp mapping-agent ethernet 2/1

Auto-RP マッピング エージェントを設定します。Auto-RP Discovery メッセージで使用される送信元 IP アドレスは、インターフェイスの IP アドレスです。デフォルト スコープは 32 です。パラメータの詳細については、 表 4-6 を参照してください。

ステップ 3

ip pim {send-rp-announce | {auto-rp rp-candidate}} interface { group-list ip-prefix | route-map policy-name } [ scope ttl ] [ interval interval ] [ bidir ]

 

例1:

switch(config)# ip pim auto-rp rp-candidate ethernet 2/1 group-list 239.0.0.0/24

 

例2:

switch(config)# ip pim auto-rp rp-candidate ethernet 2/1 group-list 239.0.0.0/24 bidir

Auto-RP の候補 RP を設定します。デフォルト スコープは 32 です。デフォルト インターバルは 60 秒です。デフォルトでは、ASM の候補 RP が作成されます。パラメータの詳細については、 表 4-7 を参照してください。

(注) 候補 RP インターバルは 15 秒以上に設定することを推奨します。

例 1 では、ASM の候補 RP を設定しています。

例 2 では、Bidir の候補 RP を設定しています。

ステップ 4

show ip pim group-range [ ip-prefix ] [ vrf vrf-name | all ]

 

例:

switch(config)# show ip pim group-range

(任意)PIM モードおよびグループ範囲を表示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)コンフィギュレーションの変更を保存します。

PIM Anycast-RP セットの設定

PIM Anycast-RP セットを設定する手順は、次のとおりです。


ステップ 1 PIM Anycast-RP セットに属するルータを選択します。

ステップ 2 PIM Anycast-RP セットの IP アドレスを選択します。

ステップ 3 後述の手順に従い、PIM Anycast-RP セットに属するそれぞれのピア RP を設定します。


 

はじめる前に

Enterprise Services ライセンスがインストールされていること、および PIM または PIM6 がイネーブルになっていることを確認してください。

手順の概要

PIM コマンド

1. config t

2. interface loopback number

3. ip address ip-prefix

4. exit

5. ip pim anycast-rp anycast-rp-address anycast-rp-peer-address

6. RP セットに属する各 RP(ローカル ルータを含む)で、同じ anycast-rp を使用してステップ 5 を繰り返します。

7. show ip pim group-range [ ip-prefix ] [ vrf vrf-name | all ]

8. copy running-config startup-config

PIM6 コマンド

1. config t

2. interface loopback number

3. ipv6 address ipv6-prefix

4. exit

5. ipv6 pim anycast-rp anycast-rp-address anycast-rp-peer-address

6. RP セットに属する各 RP(ローカル ルータを含む)で、同じ anycast-rp を使用してステップ 5 を繰り返します。

7. show ipv6 pim group-range [ ipv6-prefix ] [ vrf vrf-name | all ]

8. copy running-config startup-config

手順の詳細

PIM コマンド

 
コマンド
目的

ステップ 1

config t

 

例:

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface loopback number

 

例:

switch(config)# interface loopback 0

インターフェイス ループバックを設定します。

この例では、インターフェイス ループバックを 0 に設定しています。

ステップ 3

ip address ip-prefix

 

例:

switch(config-if)# ip address 192.0.2.3/32

このインターフェイスの IP アドレスを設定します。

この例では、Anycast-RP の IP アドレスを設定しています。

ステップ 4

exit

 

例:

switch(config)# exit

コンフィギュレーション モードに戻ります。

 

ステップ 5

ip pim anycast-rp anycast-rp-address anycast-rp-peer-address

 

例:

switch(config)# ip pim anycast-rp 192.0.2.3 192.0.2.31

指定した Anycast-RP アドレスに対応する PIM Anycast-RP ピア アドレスを設定します。各コマンドで同じ Anycast-RP アドレスを指定して実行すると、Anycast-RP セットが作成されます。RP の IP アドレスは、同一セット内の RP との通信に使用されます。

ステップ 6

RP セットに属する各 RP(ローカル ルータを含む)で、同じ Anycast-RP アドレスを使用してステップ 5 を繰り返します。

--

ステップ 7

show ip pim group-range [ ip-prefix ] [ vrf vrf-name | all ]

 

例:

switch(config)# show ip pim group-range

(任意)PIM モードおよびグループ範囲を表示します。

ステップ 8

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)コンフィギュレーションの変更を保存します。

PIM6 コマンド

 
コマンド
目的

ステップ 1

config t

 

例:

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface loopback number

 

例:

switch(config)# interface loopback 0

インターフェイス ループバックを設定します。

この例では、ループバックを 0 に設定しています。

ステップ 3

ipv6 address ipv6-prefix

 

例:

switch(config-if)# ipv6 address 2001:0db8:0:abcd::3/32

このインターフェイスの IP アドレスを設定します。

この例では、Anycast-RP の IP アドレスを設定しています。

ステップ 4

exit

 

例:

switch(config)# exit

コンフィギュレーション モードに戻ります。

 

ステップ 5

ipv6 pim anycast-rp anycast-rp-address anycast-rp-peer-address

 

例:

switch(config)# ipv6 pim anycast-rp 2001:0db8:0:abcd::3 2001:0db8:0:abcd::31

指定した Anycast-RP アドレスに対応する PIM6 Anycast-RP ピア アドレスを設定します。各コマンドで同じ Anycast-RP アドレスを指定して実行すると、Anycast-RP セットが作成されます。RP の IP アドレスは、同一セット内の RP との通信に使用されます。

ステップ 6

RP セットに属する各 RP(ローカル ルータを含む)で、同じ Anycast-RP アドレスを使用してステップ 5 を繰り返します。

--

ステップ 7

show ipv6 pim group-range [ ipv6-prefix ] [ vrf vrf-name | all ]

 

例:

switch(config)# show ipv6 pim group-range

(任意)PIM6 モードおよびグループ範囲を表示します。

ステップ 8

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)コンフィギュレーションの変更を保存します。

ASM 専用の共有ツリーの設定

共有ツリーを設定できるのは、Any Source Multicast(ASM)グループの最終ホップ ルータだけです。この場合、新たな受信者がアクティブ グループに加入した場合、このルータでは共有ツリーから SPT へのスイッチオーバーは実行されません。 match ip [ v6 ] multicast コマンドで、共有ツリーを適用するグループ範囲を指定できます。このオプションは、送信元ツリーに対する Join/Prune メッセージを受信した場合の、ルータの標準動作には影響を与えません。

デフォルトではこの機能がディセーブルになっているため、ソフトウェアは送信元ツリーへのスイッチオーバーを行います。


) ASM モードでは、最終ホップ ルータだけが共有ツリーから SPT に切り替わります。


はじめる前に

Enterprise Services ライセンスがインストールされていること、および PIM または PIM6 がイネーブルになっていることを確認してください。

手順の概要

PIM コマンド

1. config t

2. ip pim use-shared-tree-only group-list policy-name

3. show ip pim group-range [ ip-prefix ] [ vrf vrf-name | all ]

4. copy running-config startup-config

PIM6 コマンド

1. config t

2. ipv6 pim use-shared-tree-only group-list policy-name

3. show ipv6 pim group-range [ ipv6-prefix ] [ vrf vrf-name | all ]

4. copy running-config startup-config

手順の詳細

PIM コマンド

 
コマンド
目的

ステップ 1

config t

 

例:

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

ip pim use-shared-tree-only group-list policy-name

 

例:

switch(config)# ip pim use-shared-tree-only group-list my_group_policy

共有ツリーだけを構築します。共有ツリーから SPT へのスイッチオーバーは実行されません。 match ip multicast コマンドで、使用するグループを示すルートマップ ポリシー名を指定します。デフォルトでは、送信元に対する (*, G) ステートのマルチキャスト パケットを受信すると、ソフトウェアは PIM (S, G) Join メッセージを送信元方向に発信します。

ステップ 3

show ip pim group-range [ ip-prefix ] [ vrf vrf-name | all ]

 

例:

switch(config)# show ip pim group-range

(任意)PIM モードおよびグループ範囲を表示します。

ステップ 4

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)コンフィギュレーションの変更を保存します。

PIM6 コマンド

 
コマンド
目的

ステップ 1

config t

 

例:

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

ipv6 pim use-shared-tree-only group-list policy-name

 

例:

switch(config)# ipv6 pim use-shared-tree-only group-list my_group_policy

共有ツリーだけを構築します。送信元ツリーが構築されることはありません。 match ipv6 multicast コマンドで、使用するグループを示すルートマップ ポリシー名を指定します。デフォルトでは、送信元に対する (*, G) ステートのマルチキャスト パケットを受信すると、ソフトウェアは PIM (S, G) Join メッセージを送信元方向に発信します。

ステップ 3

show ipv6 pim group-range [ ipv6-prefix ] [ vrf vrf-name | all ]

 

例:

switch(config)# show ipv6 pim group-range

(任意)PIM6 モードおよびグループ範囲を表示します。

ステップ 4

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)コンフィギュレーションの変更を保存します。

SSM の設定

Source-Specific Multicast(SSM)は、マルチキャスト送信元にデータを要求する受信者に対して、接続された DR 上のソフトウェアが対象の送信元への Shortest Path Tree(SPT; 最短パス ツリー)を構築するマルチキャスト配信モードです。


) Cisco NX-OS ソフトウェアは、vPC での PIM SSM をサポートしません。vPC の詳細については、『Cisco Nexus 7000 Series NX-OS Interfaces Configuration Guide, Release 5.x』を参照してください。


IPv4 ネットワーク上のホストから、送信元を特定してマルチキャスト データを要求するには、このホストおよびこのホストの DR で、IGMPv3 が実行されている必要があります。SSM モードでインターフェイスに PIM を設定する場合は、IGMPv3 をイネーブルにするのが一般的です。IGMPv1 または IGMPv2 を実行しているホストでは、SSM 変換を使用して、グループの送信元へのマッピングを設定できます。詳細については、 第 2 章「IGMP の設定」 および 第 3 章「MLD の設定」 を参照してください。

コマンドラインに値を指定することにより、SSM で使用するグループ範囲を設定できます。デフォルトでは、PIM の SSM グループ範囲は 232.0.0.0/8 で、PIM6 の SSM グループ範囲は FF3x/96 です。

match ip multicast コマンドで、使用するグループ プレフィクスを示すルートマップ ポリシー名を指定できます。


) デフォルトの SSM グループ範囲を使用する場合は、SSM グループ範囲の設定は不要です。


はじめる前に

Enterprise Services ライセンスがインストールされていること、および PIM または PIM6 がイネーブルになっていることを確認してください。

手順の概要

PIM コマンド

1. config t

2. ip pim ssm { range { ip-prefix | none } | route-map policy-name }

no ip pim ssm { range { ip-prefix | none } | route-map policy-name }

3. show ip pim group-range [ ip-prefix ] [ vrf vrf-name | all ]

4. copy running-config startup-config

PIM6 コマンド

1. config t

2. ipv6 pim ssm { range { ipv6-prefix | none } | route-map policy-name }

no ipv6 pim ssm { range { ipv6-prefix | none } | route-map policy-name }

3. show ipv6 pim group-range [ ipv6-prefix ] [ vrf vrf-name | all ]

4. copy running-config startup-config

手順の詳細

PIM コマンド

 
コマンド
目的

ステップ 1

config t

 

例:

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

ip pim ssm range { ip-prefix | none } | route-map policy-name }

 

例:

switch(config)# ip pim ssm range 239.128.1.0/24

SSM モードで処理するグループ範囲を最大 4 つまで設定します。 match ip multicast コマンドで、使用するグループ プレフィクスを示すルートマップ ポリシー名を指定できます。デフォルトの範囲は 232.0.0.0/8 です。キーワード none を指定すると、すべてのグループ範囲が削除されます。

no ip pim ssm {range { ip-prefix | none } | route-map policy-name }

 

例:

switch(config)# no ip pim ssm range none

SSM 範囲から指定のプレフィクスを削除するか、ルートマップ ポリシーを削除します。キーワード none を指定すると、SSM 範囲はデフォルトの 232.0.0.0/8 にリセットされます。

ステップ 3

show ip pim group-range [ ip-prefix ] [ vrf vrf-name | all ]

 

例:

switch(config)# show ip pim group-range

(任意)PIM モードおよびグループ範囲を表示します。

ステップ 4

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)コンフィギュレーションの変更を保存します。

PIM6 コマンド

 
コマンド
目的

ステップ 1

config t

 

例:

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

ipv6 pim ssm {range { ipv6-prefix | none } | route-map policy-name }

 

例:

switch(config)# ipv6 pim ssm range FF30::0/32

SSM モードで処理するグループ範囲を最大 4 つまで設定します。 match ip multicast コマンドで、使用するグループ プレフィクスを示すルートマップ ポリシー名を指定できます。キーワード none を指定すると、すべてのグループ範囲が削除されます。デフォルトの範囲は FF3x/96 です。

no ipv6 pim ssm {range { ipv6-prefix | none } | route-map policy-name }

 

例:

switch(config)# no ipv6 pim ssm range none

SSM 範囲から指定のプレフィクスを削除するか、ルートマップ ポリシーを削除します。キーワード none を指定すると、SSM 範囲がデフォルトの FF3x/96 にリセットされます。

ステップ 3

show ipv6 pim group-range [ ipv6-prefix ] [ vrf vrf-name | all ]

 

例:

switch(config)# show ipv6 pim group-range

(任意)PIM6 モードおよびグループ範囲を表示します。

ステップ 4

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)コンフィギュレーションの変更を保存します。

マルチキャスト用 RPF ルートの設定

ユニキャスト トラフィック パスを分岐させてマルチキャスト データを配信するには、マルチキャスト用 RPF ルートを定義します。境界ルータにマルチキャスト用 RPF ルートを定義すると、外部ネットワークへの Reverse Path Forwarding(RPF)がイネーブルになります。

マルチキャスト ルートはトラフィック転送に直接使用されるわけではなく、RPF チェックのために使用されます。マルチキャスト用 RPF ルートは再配布できません。マルチキャスト転送の詳細については、「マルチキャスト転送」を参照してください。


) IPv6 ではスタティック マルチキャスト ルートはサポートされていません。


はじめる前に

Enterprise Services ライセンスがインストールされていること、および PIM または PIM6 がイネーブルになっていることを確認してください。

手順の概要

PIM コマンド

1. config t

2. ip mroute { ip-addr mask | ip-prefix } { next-hop | nh-prefix | interface } [ route-preference ] [ vrf vrf-name ]

3. show ip static-route [ multicast ] [ vrf vrf-name ]

4. copy running-config startup-config

手順の詳細

PIM コマンド

 
コマンド
目的

ステップ 1

config t

 

例:

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

ip mroute { ip-addr mask | ip-prefix } { next-hop | nh-prefix | interface } [ route-preference ] [ vrf vrf-name ]

 

例:

switch(config)# ip mroute 192.0.2.33/1 224.0.0.0/1

RPF 計算で使用するマルチキャスト用 RPF ルートを設定します。ルート プリファレンスは 1 ~ 255 です。デフォルト プリファレンスは 1 です。

ステップ 3

show ip static-route [ multicast ] [ vrf vrf-name ]

 

例:

switch(config)# show ip static-route multicast

(任意)設定済みのスタティック ルートを表示します。

ステップ 4

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)コンフィギュレーションの変更を保存します。

RP 情報配信を制御するルート マップの設定

ルート マップは、一部の RP 設定のミスや悪意のある攻撃に対する保護機能を提供します。ルート マップを使用できるコマンドについては、「メッセージ フィルタリングの設定」を参照してください。

ルート マップを設定すると、ネットワーク全体について RP 情報の配信を制御できます。各クライアント ルータで発信元の BSR またはマッピング エージェントを指定したり、各 BSR およびマッピング エージェントで、アドバタイズされる(発信元の)候補 RP のリストを指定したりできるため、目的の情報だけが配信されるようになります。

詳細については、「BSR の設定」 および 「Auto-RP の設定」 を参照してください。


) ルート マップに影響を与えるコマンドは、match ip[v6] multicast だけです。


はじめる前に

Enterprise Services ライセンスがインストールされていること、および PIM または PIM6 がイネーブルになっていることを確認してください。

手順の概要

PIM コマンド

1. config t

2. route-map map-name [ permit | deny ] [ sequence-number ]

3. match ip multicast {{ rp ip-address [ rp-type rp-type ] [ group ip-prefix ]} | { group ip-prefix [ rp ip-address [ rp-type rp-type ]]}

4. show route-map

5. copy running-config startup-config

PIM6 コマンド

1. config t

2. route-map map-name [ permit | deny ] [ sequence-number ]

3. match ipv6 multicast {{ rp ipv6-address [ rp-type rp-type ] [ group ipv6-prefix ]} | { group ipv6-prefix [ rp ipv6-address [ rp-type rp-type ]]}

4. show route-map

5. copy running-config startup-config

手順の詳細

PIM コマンド

 
コマンド
目的

ステップ 1

config t

 

例:

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

route-map map-name [ permit | deny ] [ sequence-number ]

 

例(ASM のみの場合):

switch(config)# route-map ASM_only permit 10

switch(config-route-map)#

 

例(Bidir のみの場合):

switch(config)# route-map Bidir_only permit 10

switch(config-route-map)#

ルートマップ コンフィギュレーション モードを開始します。

キーワードを使用します。

ステップ 3

match ip multicast {{ rp ip-address [ rp-type rp-type ]} {{ group-range { gadrr_start to gadrr_end } | { group ip-prefix}} { source source- ip-address }

 

例(ASM のみの場合):

switch(config-route-map)# match ip multicast group 224.0.0.0/4 rp 0.0.0.0/0 rp-type ASM

 

例(Bidir のみの場合):

switch(config-route-map)# match ip multicast group 224.0.0.0/4 rp 0.0.0.0/0 rp-type Bidir

指定した グループ、RP、および RP タイプを関連付けます。ユーザは RP のタイプ(ASM または Bidir)を指定できます。例で示すとおり、このコンフィギュレーション モードでは、グループおよび RP を指定する必要があります。

コマンドは、permit または deny に対応しません。

ステップ 4

show route-map

 

例:

switch(config-route-map)# show route-map

(任意)設定済みのルート マップを表示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config-route-map)# copy running-config startup-config

(任意)コンフィギュレーションの変更を保存します。

PIM6 コマンド

 
コマンド
目的

ステップ 1

config t

 

例:

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

route-map map-name [ permit | deny ] [ sequence-number ]

 

例(ASM のみの場合):

switch(config)# route-map ASM_only permit 10

switch(config-route-map)#

 

例(Bidir のみの場合):

switch(config)# route-map Bidir_only permit 10

switch(config-route-map)#

ルートマップ コンフィギュレーション モードを開始します。

キーワードを使用します。

ステップ 3

match ipv6 multicast {{ rp ip-address [ rp-type rp-type ]} {{ group-range { gadrr_start to gadrr_end } | { group ip-prefix}} { source source- ip-address }

 

例(ASM のみの場合):

switch(config)# match ipv6 multicast group ff0e::2:101:0:0/96 rp 2001::0348:0:0/96 rp-type ASM

 

例(Bidir のみの場合):

switch(config)# match ipv6 multicast group ff0e::2:101:0:0/96 rp 2001::0348:0:0/96 rp-type Bidir

指定した グループ、RP、および RP タイプを関連付けます。ユーザは RP のタイプ(ASM または Bidir)を指定できます。例で示すとおり、このコンフィギュレーション モードでは、グループおよび RP を指定する必要があります。

コマンドは、permit または deny に対応しません。

ステップ 4

show route-map

 

例:

switch(config-route-map)# show route-map

(任意)設定済みのルート マップを表示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config-route-map)# copy running-config startup-config

(任意)コンフィギュレーションの変更を保存します。

メッセージ フィルタリングの設定


) rp-candidate-policy でのプレフィクスの照合では、プレフィクスが c-rp によるアドバタイズの内容と比較して完全に一致する必要があります。部分一致は許容されません。


表 4-8 に、PIM および PIM6 でのメッセージ フィルタリングの設定方法を示します。

表 4-8 PIM および PIM6 でのメッセージ フィルタリング

メッセージ タイプ
説明

デバイスにグローバルに適用

ネイバーの変更の記録

ネイバーのステート変更をリストする Syslog メッセージの生成をイネーブルにします。デフォルトではディセーブルになっています。

PIM Register ポリシー

ルートマップ ポリシー 2 に基づく、PIM Register メッセージのフィルタリングをイネーブルにします。 match ip [ v6 ] multicast コマンドで、グループ アドレスまたはグループと送信元アドレスを指定できます。このポリシーは、RP として動作するルータに適用されます。デフォルトではこの機能がディセーブルになっているため、PIM Register メッセージのフィルタリングは行われません。

BSR 候補 RP ポリシー

ルートマップ ポリシー 1 に基づく、BSR 候補 RP メッセージのフィルタリングをイネーブルにします。 match ip [ v6 ] multicast コマンドで、RP、グループ アドレス、およびタイプ(Bidir または ASM)を指定できます。このコマンドは、BSR の選定対象のルータで使用できます。デフォルトでは、BSR メッセージはフィルタリングされません。

BSR ポリシー

ルートマップ ポリシー 1 に基づく、BSR クライアント ルータによる BSR メッセージのフィルタリングをイネーブルにします。 match ip [ v6 ] multicast コマンドで、BSR 送信元アドレスを指定できます。このコマンドは、BSR メッセージを受信するクライアント ルータで使用できます。デフォルトでは、BSR メッセージはフィルタリングされません。

Auto-RP 候補 RP ポリシー

ルートマップ ポリシー 1 に基づく、Auto-RP マッピング エージェントによる Auto-RP Announce メッセージのフィルタリングをイネーブルにします。 match ip multicast コマンドで、RP、グループ アドレス、およびタイプ(Bidir または ASM)を指定できます。このコマンドは、マッピング エージェントで使用できます。デフォルトでは、Auto-RP メッセージはフィルタリングされません。

(注) PIM6 は、Auto-RP 方式をサポートしていません。

Auto-RP マッピング エージェント ポリシー

ルートマップ ポリシー 1 に基づく、クライアント ルータによる Auto-RP Discovery メッセージのフィルタリングをイネーブルにします。 match ip multicast コマンドで、マッピング エージェント送信元アドレスを指定できます。このコマンドは、Discovery メッセージを受信するクライアント ルータで使用できます。デフォルトでは、Auto-RP メッセージはフィルタリングされません。

(注) PIM6 は、Auto-RP 方式をサポートしていません。

デバイスの各インターフェイスに適用

Join/Prune ポリシー

ルートマップ ポリシー 1 に基づく、Join/Prune メッセージのフィルタリングをイネーブルにします。 match ip [ v6 ] multicast コマンドで、グループ、グループと送信元、またはグループと RP アドレスを指定できます。デフォルトでは、Join/Prune メッセージはフィルタリングされません。

2.ルートマップ ポリシーの設定方法については、『Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x』を参照してください。

マルチキャスト ルート マップの設定方法については、「RP 情報配信を制御するルート マップの設定」を参照してください。

次のコマンドでは、ルート マップをフィルタリング ポリシーとして使用できます(各ステートメントについて permit または deny のいずれか)。

jp-policy では (S,G)、(*,G)、または (RP,G) を使用できます。

register-policy では (S,G) または (*,G) を使用できます。

igmp report-policy では (*,G) または (S,G) を使用できます。

state-limit reserver-policy では (*,G) または (S,G) を使用できます。

auto-rp rp-candidate-policy では (RP,G) を使用できます。

bsr rp-candidate-policy では (RP,G) を使用できます。

autorp mapping-agent policy では (S) を使用できます。

bsr bsr-policy では (S) を使用できます。

次のコマンドでは、ルートマップ アクション( permit または deny )が無視された場合に、ルート マップをコンテナとして使用できます。

ip pim rp-address ルート マップでは G のみを使用できます。

ip pim ssm-range ルート マップでは G のみを使用できます。

ip igmp static-oif ルート マップでは (S,G)、(*,G)、(S,G-range)、(*,G-range) を使用できます。

ip igmp join-group ルート マップでは (S,G)、(*,G)、(S,G-range)、(*,G-range) を使用できます。

はじめる前に

Enterprise Services ライセンスがインストールされていること、および PIM または PIM6 がイネーブルになっていることを確認してください。

手順の概要

PIM コマンド

1. config t

2. ip pim log-neighbor-changes

3. ip pim register-policy policy-name

4. ip pim bsr rp-candidate-policy policy-name

5. ip pim bsr bsr-policy policy-name

6. ip pim auto-rp rp-candidate-policy policy-name

7. ip pim auto-rp mapping-agent-policy policy-name

8. interface interface

9. ip pim jp-policy policy-name [ in | out ]

10. show run pim

11. copy running-config startup-config

PIM6 コマンド

1. config t

2. ipv6 pim log-neighbor-changes

3. ipv6 pim register-policy policy-name

4. ipv6 pim bsr rp-candidate-policy policy-name

5. ipv6 pim bsr bsr-policy policy-name

6. interface interface

7. ipv6 pim jp-policy policy-name [ in | out ]

8. show run pim6

9. copy running-config startup-config

手順の詳細

PIM コマンド

 
コマンド
目的

ステップ 1

config t

 

例:

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

ip pim log-neighbor-changes

 

例:

switch(config)# ip pim log-neighbor-changes

(任意)ネイバーのステート変更をリストする Syslog メッセージの生成をイネーブルにします。デフォルトではディセーブルになっています。

ステップ 3

ip pim register-policy policy-name

 

例:

switch(config)# ip pim register-policy my_register_policy

(任意)ルートマップ ポリシーに基づく、PIM Register メッセージのフィルタリングをイネーブルにします。 match ip multicast コマンドで、グループ アドレスまたはグループと送信元アドレスを指定できます。

ステップ 4

ip pim bsr rp-candidate-policy policy-name

 

例:

switch(config)# ip pim bsr rp-candidate-policy my_bsr_rp_candidate_policy

(任意)ルートマップ ポリシーに基づく、BSR 候補 RP メッセージのフィルタリングをイネーブルにします。 match ip multicast コマンドで、RP、グループ アドレス、およびタイプ(Bidir または ASM)を指定できます。このコマンドは、BSR の選定対象のルータで使用できます。デフォルトでは、BSR メッセージはフィルタリングされません。

ステップ 5

ip pim bsr bsr-policy policy-name

 

例:

switch(config)# ip pim bsr bsr-policy my_bsr_policy

(任意)ルートマップ ポリシーに基づく、BSR クライアント ルータによる BSR メッセージのフィルタリングをイネーブルにします。 match ip multicast コマンドで、BSR 送信元アドレスを指定できます。このコマンドは、BSR メッセージを受信するクライアント ルータで使用できます。デフォルトでは、BSR メッセージはフィルタリングされません。

ステップ 6

ip pim auto-rp rp-candidate-policy policy-name

 

例:

switch(config)# ip pim auto-rp rp-candidate-policy my_auto_rp_candidate_policy

(任意)ルートマップ ポリシーに基づく、Auto-RP マッピング エージェントによる Auto-RP Announce メッセージのフィルタリングをイネーブルにします。 match ip multicast コマンドで、RP、グループ アドレス、およびタイプ(Bidir または ASM)を指定できます。このコマンドは、マッピング エージェントで使用できます。デフォルトでは、Auto-RP メッセージはフィルタリングされません。

ステップ 7

ip pim auto-rp mapping-agent-policy policy-name

 

例:

switch(config)# ip pim auto-rp mapping-agent-policy my_auto_rp_mapping_policy

(任意)ルートマップ ポリシーに基づく、クライアント ルータによる Auto-RP Discovery メッセージのフィルタリングをイネーブルにします。 match ip multicast コマンドで、マッピング エージェント送信元アドレスを指定できます。このコマンドは、Discovery メッセージを受信するクライアント ルータで使用できます。デフォルトでは、Auto-RP メッセージはフィルタリングされません。

ステップ 8

interface interface

 

例:

switch(config)# interface ethernet 2/1

switch(config-if)#

指定したインターフェイスでインターフェイス モードを開始します。

ステップ 9

ip pim jp-policy policy-name [in | out]

 

例:

switch(config-if)# ip pim jp-policy my_jp_policy

(任意)ルートマップ ポリシーに基づく、Join/Prune メッセージのフィルタリングをイネーブルにします。 match ip multicast コマンドで、グループ、グループと送信元、またはグループと RP アドレスを指定できます。デフォルトでは、Join/Prune メッセージはフィルタリングされません。

Cisco NX-OS Release 4.2(3) 以降では、このコマンドは着信方向と発信方向の両方でメッセージをフィルタリングします。

ステップ 10

show run pim

 

例:

switch(config-if)# show run pim

(任意)PIM コンフィギュレーション コマンドを表示します。

ステップ 11

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)コンフィギュレーションの変更を保存します。

PIM6 コマンド

 
コマンド
目的

ステップ 1

config t

 

例:

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

ipv6 pim log-neighbor-changes

 

例:

switch(config)# ipv6 pim log-neighbor-changes

(任意)ネイバーのステート変更をリストする Syslog メッセージの生成をイネーブルにします。デフォルトではディセーブルになっています。

ステップ 3

ipv6 pim register-policy policy-name

 

例:

switch(config)# ipv6 pim register-policy my_register_policy

(任意)ルートマップ ポリシーに基づく、PIM Register メッセージのフィルタリングをイネーブルにします。 match ipv6 multicast コマンドで、グループ アドレスまたはグループと送信元アドレスを指定できます。デフォルトではディセーブルになっています。

ステップ 4

ipv6 pim bsr rp-candidate-policy policy-name

 

例:

switch(config)# ipv6 pim bsr rp-candidate-policy my_bsr_rp_candidate_policy

(任意)ルートマップ ポリシーに基づく、BSR 候補 RP メッセージのフィルタリングをイネーブルにします。 match ipv6 multicast コマンドで、RP、グループ アドレス、およびタイプ(Bidir または ASM)を指定できます。このコマンドは、BSR の選定対象のルータで使用できます。デフォルトでは、BSR メッセージはフィルタリングされません。

ステップ 5

ipv6 pim bsr bsr-policy policy-name

 

例:

switch(config)# ipv6 pim bsr bsr-policy my_bsr_policy

(任意)ルートマップ ポリシー 1 に基づく、BSR クライアント ルータによる BSR メッセージのフィルタリングをイネーブルにします。 match ipv6 multicast コマンドで、BSR 送信元アドレスを指定できます。このコマンドは、BSR メッセージを受信するクライアント ルータで使用できます。デフォルトでは、BSR メッセージはフィルタリングされません。

ステップ 6

interface interface

 

例:

switch(config)# interface ethernet 2/1

switch(config-if)#

指定したインターフェイスでインターフェイス モードを開始します。

ステップ 7

ipv6 pim jp-policy policy-name [ in | out ]

 

例:

switch(config-if)# ipv6 pim jp-policy my_jp_policy

(任意)ルートマップ ポリシーに基づく、Join/Prune メッセージのフィルタリングをイネーブルにします。 match ipv6 multicast コマンドで、グループ、グループと送信元、またはグループと RP アドレスを指定できます。デフォルトでは、Join/Prune メッセージはフィルタリングされません。

Cisco NX-OS Release 4.2(3) 以降では、このコマンドは着信方向と発信方向の両方でメッセージをフィルタリングします。

ステップ 8

show run pim6

 

例:

switch(config-if)# show run pim6

(任意)PIM6 コンフィギュレーション コマンドを表示します。

ステップ 9

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)コンフィギュレーションの変更を保存します。

PIM プロセスおよび PIM6 プロセスの再起動

PIM プロセスおよび PIM6 プロセスを再起動し、オプションとして、すべてのルートをフラッシュすることができます。デフォルトでは、ルートはフラッシュされません。

フラッシュされたルートは、Multicast Routing Information Base(MRIB と M6RIB)および Multicast Forwarding Information Base(MFIB と M6FIB)から削除されます。

PIM または PIM6 を再起動すると、次の処理が実行されます。

PIM データベースが削除されます。

MRIB および MFIB は影響を受けず、トラフィックは引き続き転送されます。

マルチキャスト ルートの所有権が MRIB 経由で検証されます。

ネイバーから定期的に送信される PIM Join メッセージおよび Prune メッセージを使用して、データベースにデータが再度読み込まれます。

はじめる前に

Enterprise Services ライセンスがインストールされていること、および PIM または PIM6 がイネーブルになっていることを確認してください。

手順の概要

PIM コマンド

1. restart pim

2. config t

3. ip pim flush-routes

4. show running-configuration pim

5. copy running-config startup-config

PIM6 コマンド

1. restart pim6

2. config t

3. ipv6 pim flush-routes

4. show running-configuration pim6

5. copy running-config startup-config

手順の詳細

PIM コマンド

 
コマンド
目的

ステップ 1

restart pim

 

例:

switch# restart pim

PIM プロセスを再起動します。

ステップ 2

config t

 

例:

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 3

ip pim flush-routes

 

例:

switch(config)# ip pim flush-routes

PIM プロセスの再起動時に、ルートを削除します。デフォルトでは、ルートはフラッシュされません。

ステップ 4

show running-configuration pim

 

例:

switch(config)# show running-configuration pim

(任意) flush-routes コマンドを含む、PIM 実行コンフィギュレーション情報を示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)コンフィギュレーションの変更を保存します。

PIM6 コマンド

 
コマンド
目的

ステップ 1

restart pim6

 

例:

switch# restart pim6

PIM6 プロセスを再起動します。

ステップ 2

config t

 

例:

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 3

ipv6 pim flush-routes

 

例:

switch(config)# ipv6 pim flush-routes

PIM6 プロセスの再起動時に、ルートを削除します。デフォルトでは、ルートはフラッシュされません。

ステップ 4

show running-configuration pim6

 

例:

switch(config)# show running-configuration pim6

(任意) flush-routes コマンドを含む、PIM6 実行コンフィギュレーション情報を示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)コンフィギュレーションの変更を保存します。

PIM の BFD の設定

PIM の BFD は、VRF またはインターフェイスごとに設定できます。

はじめる前に

Enterprise Services ライセンスがインストールされていること、PIM または PIM6 がイネーブルになっていること、および BFD がイネーブルになっていることを確認してください。

手順の概要

1. config t

2. vrf context vrf-name

3. ip pim bfd

または

1. config t

2. interface interface-type

3. ip pim bfd instance

4. exit

5. show running-configuration pim

6. copy running-config startup-config

手順の詳細

 
コマンド
目的

ステップ 1

config t

 

例:

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

vrf context vrf-name

 

例:

switch# vrf context test

switch(config-vrf)#

VRF コンフィギュレーション モードを開始します。

ステップ 3

ip pim bfd

 

例:

switch(config-vrf)# ip pim bfd

指定した VRF の BFD をイネーブルにします。

コマンドを入力して、VRF の BFD をイネーブルにすることもできます。

 

または

 

ステップ 1

interface interface-type

 

例:

switch(config)# interface ethernet 7/40

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

ip pim bfd instance

 

例:

switch(config-if)# ip pim bfd instance

指定したインターフェイスの BFD をイネーブルにします。VRF の BFD をイネーブルにするかどうかに関係なく、RIM インターフェイスの BFD をイネーブルまたはディセーブルにすることができます。

ステップ 3

exit

 

例:

switch(config)# exit

VRF またはインターフェイス コンフィギュレーション モードを終了します。

ステップ 4

show running-configuration pim

 

例:

switch(config)# show running-configuration pim

(任意)PIM 実行コンフィギュレーション情報を表示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)コンフィギュレーションの変更を保存します。

PIM および PIM6 の設定の確認

PIM および PIM6 の設定を表示するには、 表 4-9 に示す各種コマンドを使用します。PIM コマンドでは show ip という形式を、PIM6 コマンドでは show ipv6 という形式を使用します。

 

表 4-9 PIM show コマンド

コマンド
説明

show ip [ v6 ] mroute { source group | group [ source ]} [ vrf vrf-name | all ]

IP または IPv6 マルチキャスト ルーティング テーブルを表示します。

show ip [ v6 ] pim df [ vrf vrf-name | all ]

各 RP の Designated Forwarder(DF)情報をインターフェイス別に表示します。

show ip [ v6 ] pim group-range [ vrf vrf-name | all ]

学習済みまたは設定済みのグループ範囲およびモードを表示します。同様の情報に関し、 show ip pim rp コマンドも参照してください。

show ip [ v6 ] pim interface [ interface | brief ] [ vrf vrf-name | all ]

情報をインターフェイス別に表示します。

show ip [ v6 ] pim neighbor [ vrf vrf-name | all ]

ネイバーをインターフェイス別に表示します。

show ip [ v6 ] pim oif-list group [ source ] [ vrf vrf-name | all ]

OIF リスト内のすべてのインターフェイスを表示します。

show ip [ v6 ] pim route {source group | group [source]} [ vrf vrf-name | all ]

各マルチキャスト ルートの情報を表示します。指定した (S, G) に対して、PIM Join メッセージを受信したインターフェイスなどを表示できます。

show ip [ v6 ] pim rp [ vrf vrf-name | all ]

ソフトウェアの既知の Rendezvous Point(RP; ランデブー ポイント)およびその学習方法と、それらのグループ範囲を表示します。同様の情報に関し、 show ip pim group-range コマンドも参照してください。

show ip [ v6 ] pim rp-hash [ vrf vrf-name | all ]

BootStrap Router(BSR; ブートストラップ ルータ)RP ハッシュ情報を表示します。RP ハッシュの詳細については、 RFC 5059 を参照してください。

show running-configuration pim [ 6 ]

実行コンフィギュレーション情報を表示します。

show startup-configuration pim [ 6 ]

スタートアップ コンフィギュレーション情報を表示します。

show ip [ v6 ] pim vrf [ vrf-name | all] [ detail ]

各 VRF の情報を表示します。

これらのコマンド出力のフィールドの詳細については、『 Cisco Nexus 7000 Series NX-OS Multicast Routing Command Reference, Release 5.x 』を参照してください。

統計情報の表示

次に、PIM および PIM6 の統計情報を、表示およびクリアするためのコマンドについて説明します。

ここでは、次の内容について説明します。

「PIM および PIM6 の統計情報の表示」

「PIM および PIM6 の統計情報のクリア」

PIM および PIM6 の統計情報の表示

表 4-10 に、PIM および PIM6 の統計情報とメモリ使用状況を表示するコマンドを示します。PIM コマンドでは show ip という形式を、PIM6 コマンドでは show ipv6 という形式を使用します。

 

表 4-10 PIM および PIM6 の統計情報コマンド

コマンド
説明

show ip [v6] pim policy statistics

Register、RP、および Join/Prune メッセージのポリシーについて、ポリシー統計情報を表示します。

show ip [v6] pim statistics [ vrf vrf-name | all ]

グローバル統計情報を表示します。PIM が vPC モードの場合は、vPC 統計情報を表示します。

これらのコマンド出力のフィールドの詳細については、『 Cisco Nexus 7000 Series NX-OS Multicast Routing Command Reference, Release 5.x 』を参照してください。

PIM および PIM6 の統計情報のクリア

PIM および PIM6 の統計情報をクリアするには、 表 4-11 に示す各種コマンドを使用します。PIM コマンドでは show ip という形式を、PIM6 コマンドでは show ipv6 という形式を使用します。

 

表 4-11 統計情報をクリアするための PIM および PIM6 コマンド

コマンド
説明

clear ip [v6] pim interface statistics interface

指定したインターフェイスのカウンタをクリアします。

clear ip [v6] pim policy statistics

Register、RP、および Join/Prune メッセージのポリシーについて、ポリシー カウンタをクリアします。

clear ip [v6] pim statistics [ vrf vrf-name | all ]

PIM プロセスで使用されるグローバル カウンタをクリアします。

PIM の設定例


) その他の設定例については、「1 つの PIM ドメイン内の複数の RP」を参照してください。


ここでは、さまざまなデータ配信モードおよび RP 選択方式を使用し、PIM を設定する方法について説明します。

ここでは、次の内容について説明します。

「SSM の設定例」

「BSR の設定例」

「Auto-RP の設定例」

「PIM Anycast-RP の設定例」

SSM の設定例

SSM モードで PIM を設定するには、PIM ドメイン内の各ルータで、次の手順を実行します。


ステップ 1 ドメインに参加させるインターフェイスで PIM スパース モード パラメータを設定します。すべてのインターフェイスで PIM をイネーブルにすることを推奨します。

switch# config t
switch(config)# interface ethernet 2/1
switch(config-if)# ip pim sparse-mode
 

ステップ 2 SSM をサポートする IGMP のパラメータを設定します。 第 2 章「IGMP の設定」 を参照してください。通常は、SSM をサポートするために、PIM インターフェイスに IGMPv3 を設定します。

switch# config t
switch(config)# interface ethernet 2/1
switch(config-if)# ip igmp version 3
 

ステップ 3 デフォルト範囲を使用しない場合は、SSM 範囲を設定します。

switch# config t
switch(config)# ip pim ssm range 239.128.1.0/24
 

ステップ 4 メッセージ フィルタリングを設定します。

switch# config t
switch(config)# ip pim log-neighbor-changes
 


 

次に、PIM SSM モードの設定例を示します。

config t
interface ethernet 2/1
ip pim sparse-mode
ip igmp version 3
exit
ip pim ssm range 239.128.1.0/24
ip pim log-neighbor-changes

BSR の設定例

BSR メカニズムを使用して ASM モードで PIM を設定するには、PIM ドメイン内の各ルータで、次の手順を実行します。


ステップ 1 ドメインに参加させるインターフェイスで PIM スパース モード パラメータを設定します。すべてのインターフェイスで PIM をイネーブルにすることを推奨します。

switch# config t
switch(config)# interface ethernet 2/1
switch(config-if)# ip pim sparse-mode
 

ステップ 2 ルータが BSR メッセージの受信と転送を行うかどうかを設定します。

switch# config t
switch(config)# ip pim bsr forward listen
 

ステップ 3 BSR として動作させるルータのそれぞれに、BSR パラメータを設定します。

switch# config t
switch(config)# ip pim bsr-candidate ethernet 2/1 hash-len 30
 

ステップ 4 候補 RP として動作させるルータのそれぞれに、RP パラメータを設定します。

switch# config t
switch(config)# ip pim rp-candidate ethernet 2/1 group-list 239.0.0.0/24
 

ステップ 5 メッセージ フィルタリングを設定します。

switch# config t
switch(config)# ip pim log-neighbor-changes
 


 

次に、BSR メカニズムを使用して PIM ASM モードを設定し、同一のルータに BSR と RP を設定する場合の例を示します。

config t
interface ethernet 2/1
ip pim sparse-mode
exit
ip pim bsr forward listen
ip pim bsr-candidate ethernet 2/1 hash-len 30
ip pim rp-candidate ethernet 2/1 group-list 239.0.0.0/24
ip pim log-neighbor-changes

Auto-RP の設定例

Auto-RP メカニズムを使用して Bidir モードで PIM を設定するには、PIM ドメイン内の各ルータで、次の手順を実行します。


ステップ 1 ドメインに参加させるインターフェイスで PIM スパース モード パラメータを設定します。すべてのインターフェイスで PIM をイネーブルにすることを推奨します。

switch# config t
switch(config)# interface ethernet 2/1
switch(config-if)# ip pim sparse-mode
 

ステップ 2 ルータが Auto-RP メッセージの受信と転送を行うかどうかを設定します。

switch# config t
switch(config)# ip pim auto-rp forward listen
 

ステップ 3 マッピング エージェントとして動作させるルータのそれぞれに、マッピング エージェント パラメータを設定します。

switch# config t
switch(config)# ip pim auto-rp mapping-agent ethernet 2/1
 

ステップ 4 候補 RP として動作させるルータのそれぞれに、RP パラメータを設定します。

switch# config t
switch(config)# ip pim auto-rp rp-candidate ethernet 2/1 group-list 239.0.0.0/24 bidir
 

ステップ 5 メッセージ フィルタリングを設定します。

switch# config t
switch(config)# ip pim log-neighbor-changes
 


 

次に、Auto-RP メカニズムを使用して PIM Bidir モードを設定し、同一のルータにマッピング エージェントと RP を設定する場合の例を示します。

config t
interface ethernet 2/1
ip pim sparse-mode
exit
ip pim auto-rp listen
ip pim auto-rp forward
ip pim auto-rp mapping-agent ethernet 2/1
ip pim auto-rp rp-candidate ethernet 2/1 group-list 239.0.0.0/24 bidir
ip pim log-neighbor-changes

PIM Anycast-RP の設定例

PIM Anycast-RP 方式を使用して ASM モードを設定するには、PIM ドメイン内の各ルータで、次の手順を実行します。


ステップ 1 ドメインに参加させるインターフェイスで PIM スパース モード パラメータを設定します。すべてのインターフェイスで PIM をイネーブルにすることを推奨します。

switch# config t
switch(config)# interface ethernet 2/1
switch(config-if)# ip pim sparse-mode
 

ステップ 2 Anycast-RP セット内のすべてのルータに適用する RP アドレスを設定します。

switch# config t
switch(config)# interface loopback 0
switch(config-if)# ip address 192.0.2.3/32
 

ステップ 3 Anycast-RP セットに加える各ルータで、その Anycast-RP セットに属するルータ間で通信に使用するアドレスを指定し、ループバックを設定します。

switch# config t
switch(config)# interface loopback 1
switch(config-if)# ip address 192.0.2.31/32
 

ステップ 4 Anycast-RP セットに加える各ルータについて、Anycast-RP パラメータとして Anycast-RP の IP アドレスを指定します。同じ作業を、Anycast-RP の各 IP アドレスで繰り返します。この例では、2 つの Anycast-RP を指定しています。

switch# config t
switch(config)# ip pim anycast-rp 192.0.2.3 193.0.2.31
switch(config)# ip pim anycast-rp 192.0.2.3 193.0.2.32
 

ステップ 5 メッセージ フィルタリングを設定します。

switch# config t
switch(config)# ip pim log-neighbor-changes
 


 

次に、2 つの Anycast-RP を使用し、PIM ASM モードを設定する場合の例を示します。

config t
interface ethernet 2/1
ip pim sparse-mode
exit
interface loopback 0
ip address 192.0.2.3/32
exit
ip pim anycast-rp 192.0.2.3 192.0.2.31
ip pim anycast-rp 192.0.2.3 192.0.2.32
ip pim log-neighbor-changes

次の作業

PIM および PIM6 の関連機能を設定するには、次の章を参照してください。

第 2 章「IGMP の設定」

第 3 章「MLD の設定」

第 5 章「IGMP スヌーピングの設定」

第 6 章「MSDP の設定」

デフォルト設定

表 4-12 に、PIM および PIM6 の各種パラメータについて、デフォルト設定を示します。

 

表 4-12 PIM および PIM6 のデフォルト パラメータ

パラメータ
デフォルト

共有ツリーだけを使用

ディセーブル

再起動時にルートをフラッシュ

ディセーブル

ネイバーの変更の記録

ディセーブル

Auto-RP メッセージ アクション

ディセーブル

BSR メッセージ アクション

ディセーブル

SSM マルチキャスト グループ範囲またはポリシー

IPv4 では 232.0.0.0/8、IPv6 では FF3x::/96

PIM スパース モード

ディセーブル

DR プライオリティ

0

hello 認証モード

ディセーブル

ドメイン境界

ディセーブル

RP アドレス ポリシー

メッセージをフィルタリングしない

PIM Register メッセージ ポリシー

メッセージをフィルタリングしない

BSR 候補 RP ポリシー

メッセージをフィルタリングしない

BSR ポリシー

メッセージをフィルタリングしない

Auto-RP マッピング エージェント ポリシー

メッセージをフィルタリングしない

Auto-RP 候補 RP ポリシー

メッセージをフィルタリングしない

Join/Prune ポリシー

メッセージをフィルタリングしない

ネイバーとの隣接関係ポリシー

すべての PIM ネイバーと隣接関係を確立

BFD

ディセーブル

その他の関連資料

PIM の実装に関する詳細情報については、次の項目を参照してください。

「関連資料」

「規格」

「MIB」

付録 A「IP マルチキャストに関する IETF RFC」

「PIM と PIM6 の機能履歴」

関連資料

関連項目
マニュアル名

VDC

『Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide, Release 4.2

CLI コマンド

『Cisco Nexus 7000 Series NX-OS Multicast Routing Command Reference, Release 5.x

VRF およびポリシーベース ルーティングの設定

『Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x

規格

規格
タイトル

この機能がサポートする新しい規格または変更された規格はありません。また、この機能で変更された既存規格のサポートはありません。

--

MIB

MIB
MIB のリンク

IPMCAST-MIB

適切な MIB を選択してダウンロードするには、次の URL を参照してください。

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

PIM と PIM6 の機能履歴

表 4-13 に、この機能のリリース履歴を示します。

 

表 4-13 PIM と PIM6 の機能履歴

機能名
リリース
機能情報

PIM(IPv4)に対する BFD サポート

5.0(2)

BFD は IPv4 の PIM に対してサポートされています。

vPC

4.1(3)

Nexus 7000 シリーズ デバイス対応の Cisco NX-OS ソフトウェアは、vPC 上の PIM SSM または BIDR をサポートしません。Cisco NX-OS ソフトウェアは、vPC 上の PIM ASM を完全にサポートします。

show ip pim statistics コマンドで vPC 統計を表示します。

次の項に、この機能の情報が記載されています。

「ASM および Bidir の設定」

「PIM および PIM6 の統計情報の表示」