Cisco Nexus 7000 シリーズ NX-OS ユニキャスト ルーティング コンフィギュレーション ガイド リリース 4.x
レイヤ 3 仮想化の設定
レイヤ 3 仮想化の設定
発行日;2012/05/09 | 英語版ドキュメント(2012/04/30 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

レイヤ 3 仮想化の設定

レイヤ 3 仮想化

レイヤ 3 仮想化の概要

VRF およびルーティング

VRF 認識サービス

到達可能性

フィルタリング

到達可能性とフィルタリングの組み合わせ

VRF のライセンス要件

VRF の前提条件

注意事項および制約事項

VRF の設定

VRF の作成

インターフェイスへの VRF メンバシップの割り当て

ルーティング プロトコルに関する VRF パラメータの設定

VRF 認識サービスの設定

VRF スコープの設定

VRF の設定確認

VRF の設定例

関連資料

デフォルト設定

その他の関連資料

関連資料

標準

VRF 機能の履歴

レイヤ 3 仮想化の設定

この章では、レイヤ 3 仮想化の設定手順について説明します。

この章では、次の内容について説明します。

「レイヤ 3 仮想化」

「VRF のライセンス要件」

「VRF の前提条件」

「注意事項および制約事項」

「VRF の設定」

「VRF の設定確認」

「VRF の設定例」

「関連資料」

「デフォルト設定」

「デフォルト設定」

「その他の関連資料」

「VRF 機能の履歴」

レイヤ 3 仮想化

ここで説明する内容は、次のとおりです。

「レイヤ 3 仮想化の概要」

「VRF およびルーティング」

「VRF 認識サービス」

レイヤ 3 仮想化の概要

Cisco NX-OS では仮想化の階層構造がサポートされており、物理システム リソースを複数の Virtual Device Context(VDC; 仮想デバイス コンテキスト)に分割できます。各 VDC は、レイヤ 2 サービスとレイヤ 3 サービスの両方が使用できる、独立型デバイスとして動作します。デフォルト VDC を含め、最大 4 の VDC を設定できます。VDC の詳細については、『 Cisco Cisco NX-OS Virtualization Configuration Guide 』を参照してください。

Cisco NX-OS は、各 VDC の仮想化をさらに進めて、VRF(仮想ルーティングおよびフォワーディング)インスタンスをサポートします。1 つの VDC に複数の VRF を設定できます。各 VRF には、IPv4 および IPv6 に対応するユニキャストおよびマルチキャスト ルート テーブルを備えた、独立したアドレス スペースが 1 つずつあり、他の VRF と無関係にルーティングを決定できます。

図 14-1 に、2 つの異なる VDC にある複数の独立した VRF を示します。

図 14-1 VDC 内の複数の VRF

 

VRF 名は VDC ローカルなので、VRF が異なる VDC に存在する場合は、同じ名前で 2 つの VRF を設定できます。図 14-1 では、VDC 2 の VRF A は、VDC n の VRF B および VRF A と無関係です。

ルータごとに、デフォルト VRF および管理 VRF があります。すべてのレイヤ 3 インターフェイスおよびルーティング プロトコルは、ユーザが別の VRF に割り当てないかぎり、デフォルト VRF に存在します。mgmt0 インターフェイスは管理 VRF にあり、あらゆる VDC からアクセスできます。各 VDC は、mgmt0 インターフェイスに固有の IP アドレスを使用します(『 Cisco Nexus 7000 Series NX-OS Fundamentals Configuration Guide, Release 4.x 』を参照)。

VRF およびルーティング

すべてのユニキャストおよびマルチキャスト ルーティング プロトコルは VRF をサポートします。VRF でルーティング プロトコルを設定する場合は、同じルーティング プロトコル インスタンスの別の VRF のルーティング パラメータに依存しないルーティング パラメータをその VRF に設定します。

VRF にインターフェイスおよびルーティング プロトコルを割り当てることによって、仮想レイヤ 3 ネットワークを作成できます。インターフェイスが存在する VRF は 1 つだけです。図 14-2 に、1 つの物理ネットワークが 2 つの VRF からなる 2 つの仮想ネットワークに分割されている例を示します。ルータ Z、A、および B は、VRF Red にあり、1 つのアドレス ドメインを形成しています。これらのルータは、ルータ C が含まれないルート アップデートを共有します。ルータ C は別の VRF で設定されているからです。

図 14-2 ネットワーク内の VRF

 

Cisco NX-OS はデフォルトで、着信インターフェイスの VRF を使用して、ルート検索に使用するルーティング テーブルを選択します。ルート ポリシーを設定すると、この動作を変更し、Cisco NX-OS が着信パケットに使用する VRF を設定できます。詳細については、「ポリシーベース ルーティングの設定」を参照してください。

Cisco NX-OS は VRF 間のルート リーク(インポートまたはエクスポート)を防止します。

VRF 認識サービス

Cisco NX-OS アーキテクチャの基本的な特徴として、すべての IP ベースの機能が VRF を認識することがあげられます。

次の VRF 認識サービスは、特定の VRF を選択することによって、リモート サーバに接続したり、選択した VRF に基づいて情報をフィルタリングすることができます。

AAA:詳細については、『 Cisco Nexus 7000 Series NX-OS Security Configuration Guide, Release 4.x 』を参照してください。

Call Home:詳細については、『 Cisco Nexus 7000 Series NX-OS System Management Configuration Guide, Release 4.x 』を参照してください。

DNS(ドメイン ネーム システム):詳細については、「DNS の設定」を参照してください。

GLBP:詳細については、「GLBP の設定」を参照してください。

HSRP:詳細については、「HSRP の設定」を参照してください。

HTTP:詳細については、『 Cisco Nexus 7000 Series NX-OS Fundamentals Configuration Guide, Release 4.x 』を参照してください。

Licensing:詳細については、『 Cisco NX-OS Licensing Guide 』を参照してください。

NetFlow:詳細については、『 Cisco Nexus 7000 Series NX-OS System Management Configuration Guide, Release 4.x 』を参照してください。

NTP:詳細については、『 Cisco Nexus 7000 Series NX-OS System Management Configuration Guide, Release 4.x 』を参照してください。

RADIUS:詳細については、『 Cisco Nexus 7000 Series NX-OS Security Configuration Guide, Release 4.x 』を参照してください。

ping および traceroute:詳細については、『 Cisco Nexus 7000 Series NX-OS Fundamentals Configuration Guide, Release 4.x 』を参照してください。

SSH:詳細については、『 Cisco Nexus 7000 Series NX-OS Fundamentals Configuration Guide, Release 4.x 』を参照してください。

SNMP:詳細については、『 Cisco Nexus 7000 Series NX-OS System Management Configuration Guide, Release 4.x 』を参照してください。

Syslog:詳細については、『 Cisco Nexus 7000 Series NX-OS System Management Configuration Guide, Release 4.x 』を参照してください。

TACACS+:詳細については、『 Cisco Nexus 7000 Series NX-OS Security Configuration Guide, Release 4.x 』を参照してください。

TFTP:詳細については、『 Cisco Nexus 7000 Series NX-OS Fundamentals Configuration Guide, Release 4.x 』を参照してください。

VRRP(仮想ルータ冗長プロトコル):詳細については、「VRRP の設定」を参照してください。

XML:詳細については、『 Cisco Nexus 7000 Series NX-OS XML Management Interface User Guide 』を参照してください。

各サービスで VRF サポートを設定する詳細については、各サービスの適切なコンフィギュレーション ガイドを参照してください。

ここで説明する内容は、次のとおりです。

「到達可能性」

「フィルタリング」

「到達可能性とフィルタリングの組み合わせ」

到達可能性

到達可能性は、サービスを提供するサーバに到達するために必要なルーティング情報がどの VRF にあるかを示します。たとえば、管理 VRF で到達可能な SNMP サーバを設定できます。ルータ上でサーバ アドレスを設定する場合は、サーバに到達するために Cisco NX-OS が使用しなければならない VRF も設定します。

図 14-3 に、管理 VRF を介して到達できる SNMP サーバを示します。SNMP サーバ ホスト 192.0.2.1 には管理 VRF を使用するように、ルータ A を設定します。

図 14-3 サービス VRF の到達可能性

 

フィルタリング

フィルタリングによって、VRF に基づいて VRF 認識サービスに渡す情報のタイプを制限できます。たとえば、Syslog サーバが特定の VRF をサポートするように設定できます。図 14-4 に示す 2 つの Syslog サーバは、それぞれ 1 つの VRF をサポートしています。Syslog サーバ A は VRF Red で設定されているので、Cisco NX-OS は VRF Red で生成されたシステム メッセージだけを Syslog サーバ A に送信します。

図 14-4 サービス VRF のフィルタリング

 

 

到達可能性とフィルタリングの組み合わせ

VRF 認識サービスの到達可能性とフィルタリングを組み合わせることができます。そのサービスに接続するために Cisco NX-OS が使用する VRF とともに、サービスがサポートする VRF も設定できます。デフォルト VRF でサービスを設定する場合は、任意で、すべての VRF をサポートするようにサービスを設定できます。

図 14-5 に、管理 VRF 上で到達できる SNMP サーバを示します。たとえば、SNMP サーバが VRF Red からの SNMP 通知だけをサポートするように設定できます。

図 14-5 サービス VRF の到達可能性とフィルタリング

 

VRF のライセンス要件

次の表に、この機能のライセンス要件を示します。

 

製品
ライセンス要件

NX-OS

VRF にライセンスは不要です。ライセンス パッケージに含まれていない機能はすべて Cisco NX-OS システム イメージにバンドルされており、追加費用は一切発生しません。NX-OS のライセンス方式の詳細については、『 Cisco NX-OS Licensing Guide 』を参照してください。

VRF の前提条件

VRF の前提条件は、次のとおりです。

デフォルト VDC 以外の VDC を使用するには、Advanced Services ライセンスをインストールする必要があります。

注意事項および制約事項

VRF に関する注意事項および制約事項は、次のとおりです。

インターフェイスを既存 VRF のメンバにすると、Cisco NX-OS はあらゆるレイヤ 3 設定を削除します。VRF にインターフェイスを追加したあとで、すべてのレイヤ 3 パラメータを設定する必要があります。

管理 VRF に mgmt0 インターフェイスを追加し、そのあとで mgmt0 の IP アドレスおよびその他のパラメータを設定します。

VRF が存在しないうちに VRF のインターフェイスを設定した場合は、VRF を作成するまで、そのインターフェイスは運用上のダウンになります。

Cisco NX-OS はデフォルトで、デフォルト VRF および管理 VRF を作成します。mgmt0 は管理 VRF のメンバにする必要があります。

write erase boot コマンドを実行しても、管理 VRF 設定は削除されません。 write erase コマンドを使用してから write erase boot コマンドを使用する必要があります。

VRF の設定

ここで説明する内容は、次のとおりです。

「VRF の作成」

「インターフェイスへの VRF メンバシップの割り当て」

「ルーティング プロトコルに関する VRF パラメータの設定」

「VRF 認識サービスの設定」

「VRF スコープの設定」


) Cisco IOS の CLI に慣れている場合、この機能に対応する Cisco NX-OS コマンドは通常使用する Cisco IOS コマンドと異なる場合があるので注意してください。


VRF の作成

VDC に VRF を作成できます。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. config t

2. vrf context vrf-name

3. オプション パラメータの設定

4. show vrf [ vrf-name ]

5. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

config t

 

例:

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

vrf context name

 

例:

switch(config)# vrf definition Enterprise

switch(config-vrf)#

新しい VRF を作成し、VRF コンフィギュレーション モードを開始します。 name には最大 32 文字の英数字を使用できます。大文字と小文字は区別されます。

ステップ 3

ip route { ip-prefix | ip-addr ip-mask } {[ next-hop | nh-prefix ] | [ interface next-hop | nh-prefix ]} [ tag t ag-value [ pref ]

 

例:

switch(config-vrf)# ip route 192.0.2.0/8 ethernet 1/2 192.0.2.4

スタティック ルートおよびこのスタティック ルート用のインターフェイスを設定します。任意でネクストホップ アドレスを設定できます。 preference 値でアドミニストレーティブ ディスタンスを設定します。指定できる範囲は 1 ~ 255 です。デフォルトは 1 です。

ステップ 4

show vrf [ vrf-name ]

 

例:

switch(config-vrf)# show vrf Enterprise

(任意)VRF 情報を表示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

VRF および関連する設定を削除するには、 no vrf context コマンドを使用します。

 

コマンド
目的

no vrf context name

 

例:

switch(config)# no vrf context Enterprise

VRF および関連するすべての設定を削除します。

グローバル コンフィギュレーション モードで使用できるコマンドはすべて、VRF コンフィギュレーション モードでも使用できます。

次に、VRF を作成し、VRF にスタティック ルートを追加する例を示します。

switch# config t

switch(config)# vrf context Enterprise

switch(config-vrf)# ip route 192.0.2.0/8 192.0.2.10

switch(config-vrf)# exit

switch(config)# copy running-config startup-config

 

インターフェイスへの VRF メンバシップの割り当て

インターフェイスを VRF のメンバにできます。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

VRF 用のインターフェイスを設定したあとで、インターフェイスに IP アドレスを割り当てます。

手順の概要

1. config t

2. interface interface-type slot/port

3. vrf member vrf-name

4. ip-address ip-prefix/length

5. show vrf vrf-name interface interface-type number

6. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

config t

 

例:

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface interface-type slot/port

 

例:

switch(config)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

vrf member vrf-name

 

例:

switch(config-if)# vrf member RemoteOfficeVRF

このインターフェイスを VRF に追加します。

ステップ 4

ip address ip-prefix/length

 

例:

switch(config-if)# ip address 192.0.2.1/16

このインターフェイスの IP アドレスを設定します。このステップは、このインターフェイスを VRF に割り当てたあとに行う必要があります。

ステップ 5

show vrf vrf-name interface interface-type number

 

例:

switch(config-vrf)# show vrf Enterprise interface ethernet 1/2

(任意)VRF 情報を表示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、VRF にインターフェイスを追加する例を示します。

switch# config t

switch(config)# interface ethernet 1/2

switch(config-if)# vrf member RemoteOfficeVRF

switch(config-if)# ip address 192.0.2.1/16

switch(config-if)# copy running-config startup-config

 

ルーティング プロトコルに関する VRF パラメータの設定

1 つまたは複数の VRF にルーティング プロトコルを関連付けることができます。ルーティング プロトコルに関する VRF の設定については、該当する章を参照してください。ここでは、詳細な設定手順の例として、OSPFv2 プロトコルを使用します。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. config t

2. router protocol tag

3. vrf vrf-name

4. VRF のプロトコルに対応するオプション パラメータの設定

5. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

config t

 

例:

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router ospf instance-tag

 

例:

switch(config-vrf)# router ospf 201

switch(config-router)#

新規 OSPFv2 インスタンスを作成して、設定済みのインスタンス タグを割り当てます。

ステップ 3

vrf vrf-name

 

例:

switch(config-router)# vrf RemoteOfficeVRF

switch(config-router-vrf)#

VRF コンフィギュレーション モードを開始します。

ステップ 4

maximum-paths paths

 

例:

switch(config-router-vrf)# maximum-paths 4

(任意)この VRF のルート テーブル内の宛先への、同じ OSPFv2 パスの最大数を設定します。ロード バランシングに使用されます。

ステップ 5

interface interface-type slot/port

 

例:

switch(config)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 6

vrf member vrf-name

 

例:

switch(config-if)# vrf member RemoteOfficeVRF

このインターフェイスを VRF に追加します。

ステップ 7

ip address ip-prefix/length

 

例:

switch(config-if)# ip address 192.0.2.1/16

このインターフェイスの IP アドレスを設定します。このステップは、このインターフェイスを VRF に割り当てたあとに行う必要があります。

ステップ 8

ip router ospf instance-tag area area-id

 

例:

switch(config-if)# ip router ospf 201 area 0

このインターフェイスを OSPFv2 インスタンスおよび設定エリアに割り当てます。

ステップ 9

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、VRF を作成して、その VRF にインターフェイスを追加する例を示します。

switch# config t

switch(config)# vrf context RemoteOfficeVRF

switch(config-vrf)# exit

switch(config)# router ospf 201

switch(config-router)# vrf RemoteOfficeVRF

switch(config-router-vrf)# maximum-paths 4

switch(config-router-vrf)# interface ethernet 1/2

switch(config-if)# vrf member RemoteOfficeVRF

switch(config-if)# ip address 192.0.2.1/16

switch(config-if)# ip router ospf 201 area 0

switch(config-if)# exit

switch(config)# copy running-config startup-config

 

VRF 認識サービスの設定

VRF 認識サービスの到達可能性およびフィルタリングを設定できます。VRF 用サービスの設定手順を扱っている、該当する章またはコンフィギュレーション ガイドへのリンクについては、「VRF 認識サービス」を参照してください。ここでは、サービスの詳細な設定手順の例として、SNMP および IP ドメイン リストを使用します。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順の概要

1. config t

2. service parameters [ filter_vrf vrf-name ] [ use-vrf vrf-name ]

3. vrf context [ vrf-name ]

4. service parameters [ all-vrfs ][ use-vrf vrf-name ]

5. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

config t

 

例:

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

snmp-server host ip-address [ filter-vrf vrf-name ] [ use-vrf vrf-name ]

 

例:

switch(config)# snmp-server host 192.0.2.1 use-vrf Red

switch(config-vrf)#

グローバル SNMP サーバを設定し、サービスに接続するために Cisco NX-OS が使用する VRF を設定します。選択した VRF からこのサーバへの情報をフィルタリングするには、 filter-vrf キーワードを使用します。

ステップ 3

vrf context vrf-name

 

例:

switch(config)# vrf context Blue

switch(config-vrf)#

新しい VRF を作成します。

ステップ 4

ip domain-list domain-name [ all-vrfs ][ use-vrf vrf-name ]

 

例:

switch(config-vrf)# ip domain-list List all-vrfs use-vrf Blue

switch(config-vrf)#

VRF でドメイン リストを設定し、さらに任意で、指定されたドメイン名に接続するために Cisco NX-OS が使用する VRF を設定します。

ステップ 5

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、VRF Red で到達可能な SNMP ホスト 192.0.2.1 に、すべての VRF の SNMP 情報を送信する例を示します。

switch# config t

switch(config)# snmp-server host 192.0.2.1 for-all-vrfs use-vrf Red

switch(config)# copy running-config startup-config

 

次に、VRF Red で到達可能な SNMP ホスト 192.0.2.12 に対して、VRF Blue の SNMP 情報をフィルタリングする例を示します。

switch# config t

switch(config)# vrf definition Blue

switch(config-vrf)# snmp-server host 192.0.2.12 use-vrf Red

switch(config)# copy running-config startup-config

 

VRF スコープの設定

すべての EXEC コマンド( show コマンドなど)に対応する VRF スコープを設定できます。VRF スコープを設定すると、EXEC コマンド出力のスコープが設定された VRF に自動的に限定されます。このスコープは、一部の EXEC コマンドで使用できる VRF キーワードによって上書きできます。

VRF スコープを設定するには、EXEC モードで次のコマンドを使用します。

 

コマンド
目的

routing-context vrf vrf-name

 

例:

switch# routing-context vrf red

switch%red#

すべての EXEC コマンドに対応するルーティング コンテキストを設定します。デフォルトのルーティング コンテキストはデフォルト VRF です。

デフォルトの VRF スコープに戻すには、EXEC モードで次のコマンドを使用します。

 

コマンド
目的

routing-context vrf default

 

例:

switch%red# routing-context vrf default

switch#

デフォルトのルーティング コンテキストを設定します。

VRF の設定確認

VRF の設定情報を表示するには、次のコマンドのいずれかを使用します。

 

コマンド
目的

show vrf [vrf-name]

すべてまたは 1 つの VRF の情報を表示します。

show vrf [vrf-name] detail

すべてまたは 1 つの VRF の詳細情報を表示します。

show vrf [vrf-name] [interface interface-type slot/port]

インターフェイスの VRF ステータスを表示します。

VRF の設定例

次に、VRF Red を設定し、その VRF に SNMP サーバを追加し、VRF Red に OSPF インスタンスを追加する例を示します。

config t

vrf context Red

snmp-server host 192.0.2.12 use-vrf Red

router ospf 201

interface ethernet 1/2

vrf member Red

ip address 192.0.2.1/16

ip router ospf 201 area 0

 

次に、VRF Red および Blue を設定し、各 VRF に OSPF インスタンスを追加し、各 OSPF インスタンスの SNMP コンテキストを作成する例を示します。

config t

!Create the VRFs

vrf context Red

vrf context Blue

!Create the OSPF instances and associate them with each VRF

feature ospf

router ospf Lab

vrf Red

router ospf Production

vrf Blue

!Configure one interface to use ospf Lab on VRF Red

interface ethernet 1/2

vrf member Red

ip address 192.0.2.1/16

ip router ospf Lab area 0

no shutdown

!Configure another interface to use ospf Production on VRF Blue

interface ethernet 10/2

vrf member Blue

ip address 192.0.2.1/16

ip router ospf Production area 0

no shutdown

!configure the SNMP server

snmp-server user admin network-admin auth md5 nbv-12345

snmp-server community public ro

!Create the SNMP contexts for each VRF
snmp-server context lab instance Lab vrf Red
snmp-server context production instance Production vrf Blue
 

この例で、VRF Red の OSPF インスタンス Lab の OSPF-MIB 値にアクセスするには、SNMP コンテキスト lab を使用します。

関連資料

VRF の詳細については、次の項目を参照してください。

『Cisco Nexus 7000 Series NX-OS Fundamentals Configuration Guide, Release 4.x

『Cisco Nexus 7000 Series NX-OS System Management Configuration Guide, Release 4.x

デフォルト設定

表 14-1 に、VRF パラメータのデフォルト設定を示します。

 

表 14-1 デフォルトの VRF パラメータ

パラメータ
デフォルト

設定されている VRF

デフォルト、管理

ルーティング コンテキスト

デフォルト VRF

その他の関連資料

仮想化の実装に関連する詳細情報については、次の項を参照してください。

「関連資料」

「標準」

関連資料

関連項目
マニュアル名

VRF CLI

『Cisco Nexus 7000 Series NX-OS Unicast Routing Command Reference

仮想デバイス コンテキスト(VDC)

『Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide, Release 4.x

標準

標準
タイトル

この機能でサポートされる新規または改訂された標準規格はありません。また、この機能による既存の標準規格サポートの変更はありません。

--

VRF 機能の履歴

表 14-2 は、この機能のリリースの履歴です。

 

表 14-2 VRF 機能の履歴

機能名
リリース
機能情報

VRF

4.0(1)

この機能が導入されました。