Cisco NX-OS Interfaces コンフィギュレーション Release 4.0
レイヤ 3 インターフェイスの設定
レイヤ 3 インターフェイスの設定
発行日;2012/01/13 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

レイヤ 3 インターフェイスの設定

レイヤ 3 インターフェイスについて

ルーテッド インターフェイス

サブインターフェイス

VLAN インターフェイス

ループバック インターフェイス

トンネル インターフェイス

ハイ アベイラビリティ

バーチャライゼーション サポート

レイヤ 3 インターフェイスのライセンス要件

ライセンス 3 インターフェイスの前提条件

注意事項と制限

レイヤ 3 インターフェイスの設定

ルーテッド インターフェイスの設定

サブインターフェイスの設定

インターフェイスでの帯域幅の設定

VLAN インターフェイスの設定

ループバック インターフェイスの設定

インターフェイスの VRF への割り当て

レイヤ 3 インターフェイスの設定の確認

レイヤ 3 インターフェイス統計情報の表示

レイヤ 3 インターフェイスの設定例

関連項目

デフォルト設定

その他の参考資料

関連資料

MIB

標準

レイヤ 3 インターフェイスについて

レイヤ 3 インターフェイスは、IPv4 および IPv6 パケットをスタティックまたはダイナミック ルーティング プロトコルを使って別のデバイスに転送します。レイヤ 2 トラフィックの IP ルーティングおよび内部 VLAN ルーティングにはレイヤ 3 ルーティングが使用できます。

ここでは、次の内容について説明します。

「ルーテッド インターフェイス」

「サブインターフェイス」

「VLAN インターフェイス」

「ループバック インターフェイス」

「トンネル インターフェイス」

「ハイ アベイラビリティ」

「バーチャライゼーション サポート」

ルーテッド インターフェイス

ポートをレイヤ 2 インターフェイスまたはレイヤ 3 インターフェイスとして設定できます。ルーテッド インターフェイスは、IP トラフィックを他のデバイスにルーティングできる物理ポートです。ルーテッド インターフェイスはレイヤ 3 インターフェイスだけで、Spanning Tree Protocol(STP; スパニング ツリー プロトコル)などのレイヤ 2 プロトコルはサポートしません。

すべてのイーサネット ポートは、デフォルトでルーテッド インターフェイスです。このデフォルト動作を変更するには、CLI(コマンドライン インターフェイス)セットアップ スクリプトまたは system default switchport コマンドを使用します。

ポートに IP アドレスを割り当て、ルーティングをイネーブルにし、このルーテッド インターフェイスにルーティング プロトコル特性を割り当てることができます。

ルーテッド インターフェイスからレイヤ 3 ポート チャネルも作成できます。ポート チャネルの詳細については、 第 5 章「ポート チャネルの設定」 を参照してください。

ルーテッド インターフェイスおよびサブインターフェイスは、指数関数的に減少するレート カウンタをサポートします。NX-OS はこれらの平均カウンタを用いて次の統計情報を追跡します。

毎秒入力パケット数

毎秒出力パケット数

毎秒入力バイト数

毎秒出力バイト数

サブインターフェイス

レイヤ 3 インターフェイスとして設定した親インターフェイスに仮想サブインターフェイスを作成できます。親インターフェイスは物理ポートでもポート チャネルでもかまいません。

親インターフェイスはサブインターフェイスによって複数の仮想インターフェイスに分割されます。これらの仮想インターフェイスに IP アドレスやダイナミック ルーティング プロトコルなど固有のレイヤ 3 パラメータを割り当てることができます。各サブインターフェイスの IP アドレスは、親インターフェイスの他のサブインターフェイスのサブネットとは異なります。

サブインターフェイスの名前は、親インターフェイスの名前(たとえば Ethernet 2/1)+ ピリオド(.)+そのインターフェイス独自の番号です。たとえば、イーサネット インターフェイス 2/1 に Ethernet 2/1.1 というサブインターフェイスを作成できます。この場合、.1 はそのサブインターフェイスを表します。

NX-OS では、親インターフェイスの場合にサブインターフェイスがイネーブルになります。サブインターフェイスは、親インターフェイスには関係なくシャットダウンできます。親インターフェイスをシャットダウンすると、関連するサブインターフェイスもすべてシャットダウンされます。

サブインターフェイスを使用すると、親インターフェイスがサポートするそれぞれの Virtual Local Area Network(VLAN; バーチャル LAN)に独自のレイヤ 3 インターフェイスを実現できます。この場合、親インターフェイスは別のデバイスのレイヤ 2 トランキング ポートに接続します。サブインターフェイスを設定したら 802.1Q トランキングを使って VLAN ID に関連付けます。

図4-1 に、インターフェイス E 2/1 のルータ B に接続するスイッチのトランキング ポートを示します。このインターフェイスには 3 つのサブインターフェイスがあり、トランキング ポートに接続する 3 つの VLAN にそれぞれ関連付けられています。

図4-1 VLAN のサブインターフェイス

 

VLAN の詳細については、『 Cisco NX-OS Layer 2 Switching Configuration Guide, Release 4.0 』を参照してください。

VLAN インターフェイス

VLAN インターフェイスまたは Switch Virtual Interface(SVI; スイッチ仮想インターフェイス)は仮想のルーテッド インターフェイスで、デバイスの VLAN を同じデバイスのレイヤ 3 ルータ エンジンに接続します。1 つの VLAN には 1 つの VLAN インターフェイスだけを関連付けできますが、VLAN 同士をルーティングする場合や管理 Virtual Routing and Forwarding(VRF)以外の VRF インスタンスを経由してデバイスを IP ホスト接続する場合以外は、VLAN に VLAN インターフェイスを設定する必要があります。VLAN インターフェイスの作成をイネーブルにすると、デフォルト VLAN(VLAN 1)に VLAN インターフェイスが作成され、リモート スイッチ管理が許可されます。


) VLAN 1 の VLAN インターフェイスは削除できません。


VLAN インターフェイスをルーティングするには、トラフィックをルーティングする VLAN ごとに VLAN インターフェイスを作成し、そのVLAN インターフェイスに IP アドレスを割り当ててレイヤ 3 内部 VLAN ルーティングを実現します。IP アドレスと IP ルーティングの詳細については、『 Cisco NX-OS Unicast Routing Configuration Guide, Release 4.0 』を参照してください。

図4-2 に、2 つの VLAN に 2 つのホストが接続しているデバイスを示します。VLAN ごとに VLAN インターフェイスを設定し、VLAN 間の IP ルーティングを使ってホスト 1 とホスト 2 を通信させることができます。VLAN 1 は VLAN インターフェイスのレイヤ 3 で、VLA 10 は VLAN インターフェイス 10 のレイヤ 3 で通信します。

図4-2 VLAN インターフェイスに接続した 2 つの VLAN

 

ループバック インターフェイス

ループバック インターフェイスは、常にアップ状態にある単独のエンドポイントを持つ仮想インターフェイスです。ループバック インターフェイスを通過するパケットはこのインターフェイスでただちに受信されます。ループバック インターフェイスは物理インターフェイスをエミュレートします。Virtual Device Context(VDC)ごとに 1024 のループバック インターフェイスが設定できます。VDC には 0 ~ 1023 の番号が付いています。

ループバック インターフェイスを使用すると、パフォーマンスの分析、テスト、ローカル通信が実行できます。ループバック インターフェイスは、ルーティング プロトコル セッションの終端アドレスとして設定することができます。ループバックをこのように設定すると、アウトバウンド インターフェイスの一部がダウンしている場合でもルーティング プロトコル セッションはアップしたままです。

トンネル インターフェイス

Cisco NX-OS は、IP トンネルとしてトンネル インターフェイスをサポートします。IP トンネルを使うと、同じレイヤまたは上位レイヤ プロトコルをカプセル化して、2 台のルータ間で作成されたトンネルを通じて IP の結果を転送できます。IP トンネルの詳細については、 第 6 章「IP トンネルの設定」 を参照してください。

ハイ アベイラビリティ

レイヤ 3 インターフェイスは、ステートフル再起動とステートレス再起動をサポートします。切り替え後、NX-OS は切り替え後の実行時設定を適用します。

ハイ アベイラビリティの詳細については、『 Cisco NX-OS High Availability and Redundancy Guide, Release 4.0 』を参照してください。

バーチャライゼーション サポート

レイヤ 3 インターフェイスは、VRF インスタンスをサポートします。VRF は VDC 内に存在します。VDC や VRF を特別に設定しないかぎり、デフォルトでは、NX-OS のデフォルトの VDC およびデフォルトの VRF が使用されます。ある VDC に設定されたレイヤ 3 論理インターフェイス(VLAN インターフェイス、ループバック)は、同じ番号を持つ別の VDC に設定されたレイヤ 3 論理インターフェイスとは区別されます。たとえば、VDC 1 のループバック 0 は VDC のループバック 0 とは異なります。

VDC ごとに最大 1024 のループバック インターフェイスを設定できます。

このインターフェイスは VRF に関連付けることができます。VLAN インターフェイスの場合、VLAN と同じ VDC に設定する必要があります。

VDC については『 Cisco NX-OS Virtual Device Context Configuration Guide, Release 4.0 』を、VRF でのインターフェイスの設定については『 Cisco NX-OS Unicast Routing Configuration Guide, Release 4.0 』を参照してください。


) そのインターフェイスに IP アドレスを設定する前に、インターフェイスに VRF を割り当てる必要があります。


レイヤ 3 インターフェイスのライセンス要件

次の表に、この機能のライセンス要件を示します。

 

製品
ライセンス要件

NX-OS

レイヤ 3 インターフェイスにライセンスは必要ありません。ライセンス パッケージに含まれていない機能は Cisco NX-OS システム イメージに組み込まれており、無料で提供されます。NX-OS ライセンス スキームの詳細については、『 Cisco NX-OS Licensing Guide 』を参照してください。

ライセンス 3 インターフェイスの前提条件

ライセンス 3 インターフェイスには次の前提条件があります。

Advanced Services ライセンスをインストールしており、VDC を設定する場合は、該当する VDC を開始している(『 Cisco NX-OS Virtual Device Context Configuration Guide, Release 4.0 』を参照してください)。

IP アドレッシングおよび基本設定を熟知している。IPアドレッシングの詳細については、『 Cisco NX-OS Unicast Routing Configuration Guide, Release 4.0 』を参照してください。

注意事項と制限

レイヤ 3 インターフェイスの設定には次の注意事項と制限があります。

レイヤ 3 インターフェイスをレイヤ 2 インターフェイスに変更する場合、NX-OS はインターフェイスをシャットダウンしてインターフェイスを再度イネーブルにし、レイヤ 3 固有の設定をすべて削除します。

レイヤ 2 インターフェイスをレイヤ 3 インターフェイスに変更する場合、NX-OS はインターフェイスをシャットダウンしてインターフェイスを再度イネーブルにし、レイヤ 2 固有の設定をすべて削除します。


) Cisco IOS CLI を熟知している場合は、この機能の NX-OS コマンドと、使用する Cisco IOS コマンドが異なる場合もある点に注意してください。


レイヤ 3 インターフェイスの設定

ここでは、次の内容について説明します。

「ルーテッド インターフェイスの設定」

「サブインターフェイスの設定」

「インターフェイスでの帯域幅の設定」

「VLAN インターフェイスの設定」

「ループバック インターフェイスの設定」

ルーテッド インターフェイスの設定

任意のイーサネット ポートをルーテッド インターフェイスとして設定できます。

作業の前に

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

ステップの概要

1. config t

2. interface ethernet slot/port

3. no switchport

4. ip address ip-address/length
または
ipv6 address ipv6-address/length

5. show interfaces

6. copy running-config startup-config

ステップの詳細

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface ethernet slot/port

 

switch(config)# interface ethernet 2/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

no switchport

 

switch(config-if)# no switchport

インターフェイスをレイヤ 3 インターフェイスとして設定し、このインターフェイス上のレイヤ 2 固有の設定を削除します。

ステップ 4

ip address ip-address/length

 

switch(config-if)# ip address 192.0.2.1/8

このインターフェイスに IP アドレスを設定します。IP アドレスの詳細については、『 NX-OS CLI Unicast Routing Configuration Guide 』を参照してください。

ipv6 address ipv6-address/length

 

switch(config-if)# ipv6 address 2001:0DB8::1/8

このインターフェイスに IPv6 アドレスを設定します。IPv6 アドレスの詳細については、『 NX-OS CLI Unicast Routing Configuration Guide 』を参照してください。

ステップ 5

show interfaces

 

switch(config-if)# show interfaces ethernet 2/1

(任意)レイヤ 3 インターフェイスの統計情報を表示します。

ステップ 6

copy running-config startup-config

 

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

インターフェイス メディアを point-to-point(p2p; ポイントツーポイント)またはブロードキャストに設定するには、 medium コマンドを使用します。

 

コマンド
目的

medium { broadcast | p2p }

 

switch(config-if)# medium p2p

インターフェイス メディアを p2p またはブロードキャストに設定します。

レイヤ 3 インターフェイスをレイヤ 2 インターフェイスに変換するには、 switchport コマンドを使用します。

 

コマンド
目的

switchport

 

switch(config-if)# no switchport

インターフェイスをレイヤ 2 インターフェイスとして設定し、このインターフェイス上のレイヤ 3 固有の設定を削除します。

次に、ルーテッド インターフェイスを設定する例を示します。

switch# config t

switch(config)# i nterface ethernet 2/1

switch(config-if)# no switchport

switch(config-if)# ip address 192.0.2.1/8

switch(config-if)# copy running-config startup-config

 

サブインターフェイスの設定

ルーテッド インターフェイスまたはルーテッド インターフェイスで作成したポート チャネルに 1 つまたは複数のサブインターフェイスを設定できます。

作業の前に

親インターフェイスをルーテッド インターフェイスとして設定します。「ルーテッド インターフェイスの設定」を参照してください。

このポートチャネル上にサブインターフェイスを作成するには、ポートチャネル インターフェイスを作成します( ポート チャネルの設定を参照)。

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

ステップの概要

1. config t

2. interface ethernet slot/port.number

3. ip address ip-address/length
または
ipv6 address ipv6-address/length

4. encapsulation dot1q van-id

5. show interfaces

6. copy running-config startup-config

ステップの詳細

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface ethernet slot/port.number

 

switch(config)# interface ethernet 2/1.1

switch(config-subif)#

サブインターフェイスを作成し、サブインターフェイス コンフィギュレーションモードを開始します。 number の範囲は 1 ~ 4094 です。

ステップ 3

ip address ip-address/length

 

switch(config-subif)# ip address 192.0.2.1/8

このサブインターフェイスに IP アドレスを設定します。IP アドレスの詳細については、『 NX-OS CLI Unicast Routing Configuration Guide 』を参照してください。

ipv6 address ipv6-address/length

 

switch(config-subif)# ipv6 address 2001:0DB8::1/8

このサブインターフェイスに IPv6 アドレスを設定します。IPv6 アドレスの詳細については、『 NX-OS CLI Unicast Routing Configuration Guide 』を参照してください。

ステップ 4

encapsulation dot1Q vlan-id

 

switch(config-subif)# encapsulation dot1Q 33

(任意)サブインターフェイスに IEEE 802.1Q VLAN カプセル化を設定します。有効値の範囲は 2 ~ 4093 です。

ステップ 5

show interfaces

 

switch(config-subif)# show interfaces ethernet 2/1.1

(任意)レイヤ 3 インターフェイスの統計情報を表示します。

ステップ 6

copy running-config startup-config

 

switch(config-subif)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、サブインターフェイスを作成する例を示します。

switch# config t

switch(config)# i nterface ethernet 2/1.1

switch(config-if)# ip address 192.0.2.1/8

switch(config-if)# encapsulation dot1Q 33

switch(config-if)# copy running-config startup-config

 

インターフェイスでの帯域幅の設定

ルーテッド インターフェイス、ポート チャネル、またはサブインターフェイスに帯域幅を設定できます。上位レイヤ プロトコルは帯域幅パラメータを使用してパス コストを計算します。サブインターフェイスの帯域幅は、次のいずれかの方法で設定できます。

明示的 ― サブインターフェイスの帯域幅を直接設定します。

継承 ― サブインターフェイスが親インターフェイスを継承するように帯域幅を設定します。特定の値の場合と親インターフェイスの帯域幅の場合があります。

サブインターフェイスの帯域幅を設定しない場合、または親インターフェイスの帯域幅を継承しない場合、サブインターフェイスの帯域幅は次の方法で決定されます。

親インターフェイスがアップしている場合、サブインターフェイスの帯域幅は親インターフェイスの動作速度と同じです。ポートの場合、サブインターフェイスの帯域幅は設定されているリンク速度またはネゴシエート対象のリンク速度です。ポート チャネルの場合、サブインターフェイスの帯域幅は、ポート チャネルの各メンバのリンク速度の集合です。

親インターフェイスがダウンしている場合、サブインターフェイスの帯域幅は親インターフェイスのタイプによって異なります。

ポートチャネル サブインターフェイスの場合、サブインターフェイスの帯域幅は 100 Mbps です。

1 Gbps イーサネット ポートの場合、サブインターフェイスの帯域幅は 1 Gbps です。

10 Gbps イーサネット ポートの場合、サブインターフェイスの帯域幅は 10 Gbps です。

インターフェイスの帯域幅を設定するには、インターフェイス モードで次のコマンドを使用します。

 

コマンド
目的

bandwidth

 

switch(config-if)# bandwidth 100000

ルーテッド インターフェイス、ポート チャネル、またはサブインターフェイスに帯域幅パラメータを設定します。

サブインターフェイスを設定して親インターフェイスの帯域幅を継承させるには、インターフェイス モードで次のコマンドを使用します。

 

コマンド
目的

bandwidth inherit [ value ]

 

switch(config-if)# bandwidth inherit 100000

このインターフェイスのすべてのサブインターフェイスが設定した帯域幅を継承するように設定します。値を設定しない場合、サブインターフェイスは親インターフェイスの帯域幅を継承します。有効値の範囲は 1 ~ 10,000,000 キロバイトです。

VLAN インターフェイスの設定

VLAN インターフェイスを作成して内部 VLAN ルーティングを行うことができます。

作業の前に

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

ステップの概要

1. config t

2. feature interface-vlan

3. interface vlan number

4. ip address ip-address/length
または
ipv6 address ipv6-address/length

5. show interface vlan number

6. copy running-config startup-config

ステップの詳細

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

feature interface-vlan

 

switch(config)# feature interface-vlan

VLAN インターフェイス機能をイネーブルにします。

ステップ 3

interface vlan number

 

switch(config)# interface vlan 10

switch(config-if)#

VLAN インターフェイスを作成します。 number の範囲は 1 ~ 4094 です。

ステップ 4

ip address ip-address/length

 

switch(config-if)# ip address 192.0.2.1/8

この VLAN インターフェイスに IP アドレスを設定します。IP アドレスの詳細については、『 NX-OS CLI Unicast Routing Configuration Guide 』を参照してください。

ipv6 address ipv6-address/length

 

switch(config-if)# ipv6 address 2001:0DB8::1/8

この VLAN インターフェイスに IPv6 アドレスを設定します。IPv6 アドレスの詳細については、『 NX-OS CLI Unicast Routing Configuration Guide 』を参照してください。

ステップ 5

show interface vlan number

 

switch(config-if)# show interface vlan 10

(任意)レイヤ 3 インターフェイスの統計情報を表示します。

ステップ 6

copy running-config startup-config

 

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、VLAN インターフェイスを作成する例を示します。

switch# config t

switch(config)# feature interface-vlan

switch(config)# in terface vlan 10

switch(config-if)# ip address 192.0.2.1/8

switch(config-if)# copy running-config startup-config

 

ループバック インターフェイスの設定

ループバック インターフェイスを設定して、常にアップ状態にある仮想インターフェイスを作成できます。

作業の前に

ループバック インターフェイスの IP アドレスが、ネットワークの全ルータで一意であることを確認します。

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

ステップの概要

1. config t

2. interface loopback instance

3. ipv4 address ip-address
または
ipv6 address

4. show interfaces loopback instance

5. copy running-config startup-config

ステップの詳細

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface loopback instance

 

switch(config)# interface loopback 0

switch(config-if)#

ループバック インターフェイスを作成します。有効値の範囲は 0 ~ 1023 です。

ステップ 3

ip address ip-address/length

 

switch(config-if)# ip address 192.0.2.100/8

このインターフェイスに IP アドレスを設定します。IP アドレスの詳細については、『 NX-OS CLI Unicast Routing Configuration Guide 』を参照してください。

ステップ 4

ipv6 address ipv6-address/length

 

switch(config-if)# ipv6 address 2001:0DB8::18/8

このインターフェイスに IPv6 アドレスを設定します。IPv6 アドレスの詳細については、『 NX-OS CLI Unicast Routing Configuration Guide 』を参照してください。

ステップ 5

show interfaces loopback instance

 

switch(config-if)# show interfaces loopback 0

(任意)ループバック インターフェイスの統計情報を表示します。

ステップ 6

copy running-config startup-config

 

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、ループバック インターフェイスを作成する例を示します。

switch# config t

switch(config)# in terface loopback 0

switch(config-if)# ip address 192.0.2.100/8

switch(config-if)# copy running-config startup-config

 

インターフェイスの VRF への割り当て

VRF にレイヤ 3 インターフェイスを追加できます。

作業の前に

正しい VDC を開始していることを確認します(または switchto vdc コマンドを使用します)。

VRF にインターフェイスを設定してから、トンネル インターフェイスに IP アドレスを割り当てます。

ステップの概要

1. config t

2. interface interface-type number

3. vrf member vrf-name

4. ip-address ip-prefix/length

5. show vrf [ vrf-name ] interface interface-type number

6. copy running-config startup-config

ステップの詳細

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface interface-type number

 

switch(config)# interface loopback 0

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

vrf member vrf-name

 

switch(config-if)# vrf member RemoteOfficeVRF

このインターフェイスを VRF に追加します。

ステップ 4

ip address ip-prefix/length

 

switch(config-if)# ip address 192.0.2.1/16

このインターフェイスに IP アドレスを設定します。このステップは、このインターフェイスに VRF を割り当ててから実行します。

ステップ 5

show vrf [ vrf-name ] interface interface-type number

 

switch(config-vrf)# show vrf Enterprise interface loopback 0

(任意)VRF の内容を表示します。

ステップ 6

copy running-config startup-config

 

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、レイヤ 3 インターフェイスに VRF を追加する例を示します。

switch# config t

switch(config)# interface loopback 0

switch(config-if)# vrf member RemoteOfficeVRF

switch(config-if)# ip address 209.0.2.1/16

switch(config-if)# copy running-config startup-config

 

レイヤ 3 インターフェイスの設定の確認

レイヤ 3 の設定情報を確認するには、次のコマンドを使用します。

 

コマンド
目的

show interface ethernet slot/port

レイヤ 3 インターフェイスの設定情報、ステータス、カウンタ(インバウンドおよびアウトバウンド パケット レートおよびバイト レートが 5 分間に指数関数的に減少した平均値を含む)を表示します。

show interface ethernet slot/port brief

レイヤ 3 インターフェイスの動作状態を表示します。

show interface ethernet slot/port capabilities

レイヤ 3 インターフェイスの能力(ポート タイプ、速度、デュプレックス)を表示します。

show interface ethernet slot/port description

レイヤ 3 インターフェイスの説明を表示します。

show interface ethernet slot/port status

レイヤ 3 インターフェイスの管理ステータス、ポート モード、速度、デュプレックスを表示します。

show interface ethernet slot/port.number

サブインターフェイスの設定情報、ステータス、カウンタ(インバウンドおよびアウトバウンド パケット レートおよびバイト レートが 5 分間に指数関数的に減少した平均値を含む)を表示します。

show interface port-channel channel-id.number

ポート チャネル サブインターフェイスの設定情報、ステータス、カウンタ(インバウンドおよびアウトバウンド パケット レートおよびバイト レートが 5 分間に指数関数的に減少した平均値を含む)を表示します。

show interface loopback number

ループバック インターフェイスの設定情報、ステータス、カウンタを表示します。

show interface loopback number brief

ループバック インターフェイスの動作状態を表示します。

show interface loopback number description

ループバック インターフェイスの説明を表示します。

show interface loopback number status

ループバック インターフェイスの管理ステータスおよびプロトコル ステータスを表示します。

show interface vlan number

VLAN インターフェイスの設定情報、ステータス、カウンタを表示します。

show interface vlan number brief

VLAN インターフェイスの動作状態を表示します。

show interface vlan number description

VLAN インターフェイスの説明を表示します。

show interface vlan number private-vlan mapping

VLAN インターフェイス プライベート VLAN の情報を表示します。

show interface vlan number status

VLAN インターフェイスの管理ステータスおよびプロトコル ステータスを表示します。

レイヤ 3 インターフェイス統計情報の表示

レイヤ 3 インターフェイスの統計情報を表示するには、次のコマンドを使用します。

 

コマンド
目的

show interface ethernet slot/port counters

レイヤ 3 インターフェイスの統計情報を表示します(ユニキャスト、マルチキャスト、ブロードキャスト)。

show interface ethernet slot/port counters brief

レイヤ 3 インターフェイスの入力および出力カウンタを表示します。

show interface ethernet slot/port counters detailed [ all ]

レイヤ 3 インターフェイスの統計情報を表示します。オプションとして、32 ビットおよび 64 ビットのパケットおよびバイト カウンタを、エラーを含めて追加できます。

show interface ethernet slot/port counters errors

レイヤ 3 インターフェイスの入力および出力エラーを表示します。

show interface ethernet slot/port counters snmp

SNMP MIB から報告されたレイヤ 3 インターフェイス カウンタを表示します。このカウンタはクリアできません。

show interface ethernet slot/port.number counters

サブインターフェイスの統計情報を表示します(ユニキャスト、マルチキャスト、ブロードキャスト)。

show interface port-channel channel-id.number counters

ポート チャネル サブインターフェイスの統計情報を表示します(ユニキャスト、マルチキャスト、ブロードキャスト)。

show interface loopback number counters

ループバック インターフェイスの入力および出力カウンタを表示します(ユニキャスト、マルチキャスト、ブロードキャスト)。

show interface loopback number counters detailed [ all ]

ループバック インターフェイスの統計情報を表示します。オプションとして、32 ビットおよび 64 ビットのパケットおよびバイト カウンタを、エラーを含めて追加できます。

show interface loopback number counters errors

ループバック インターフェイスの入力および出力エラーを表示します。

show interface vlan number counters

VLAN インターフェイスの入力および出力カウンタを表示します(ユニキャスト、マルチキャスト、ブロードキャスト)。

show interface vlan number counters detailed [ all ]

VLAN インターフェイスの統計情報を表示します。オプションとして、レイヤ 3 パケットおよびバイト カウンタをすべて含めることができます(ユニキャストおよびマルチキャスト)。

show interface vlan number counters snmp

SNMP MIB から報告された VLAN インターフェイス カウンタを表示します。このカウンタはクリアできません。

レイヤ 3 インターフェイスの設定例

次に、イーサネット サブインターフェイスを設定する例を示します。

interface ethernet 2/1.10
description Layer 3 for VLAN 10
encapsulation dot1q 10
ip address 192.0.2.1/8
 

次に、VLAN インターフェイスを設定する例を示します。

interface vlan 100
ipv6 address 33:0DB::2/8
 

次に、ループバック インターフェイスを設定する例を示します。

interface loopback 3
ip address 192.0.2.2/32
 

関連項目

レイヤ 3 インターフェイスの詳細については、次の項目を参照してください。

第 5 章「ポート チャネルの設定」

Cisco NX-OS Unicast Routing Configuration Guide, Release 4.0

デフォルト設定

表4-1 に、レイヤ 3 インターフェイス パラメータのデフォルト設定を示します。

 

表4-1 デフォルトのレイヤ 3 インターフェイス パラメータ

パラメータ
デフォルト

管理ステート

閉じる

その他の参考資料

レイヤ 3 インターフェイスの実装に関する追加情報については、次のセクションを参照してください。

「関連資料」

「MIB」

「標準」

関連資料

 

関連項目
マニュアル タイトル

コマンド構文

Cisco NX-OS Interfaces Command Reference, Release 4.0

IP

Cisco NX-OS Unicast Routing Configuration Guide, Release 4.0 』の「Configuring IP」の章

VLAN

Cisco NX-OS Layer 2 Switching Configuration Guide, Release 4.0 』の「Configuring VLANs」の章

MIB

 

MIB
MIB リンク

IF-MIB

CISCO-IF-EXTENSION-MIB

ETHERLIKE-MIB

次の URL で MIB にアクセスしてダウンロードします。

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

標準

 

標準
タイトル

この機能でサポートする新しい標準や変更された標準はありません。現在サポートされている標準のうち、この機能で変更されたものはありません。

--