Cisco NX-OS Unicast Routing コンフィギュレーション ガイド Release 4.0
IS-IS の設定
IS-IS の設定
発行日;2012/01/13 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

IS-IS の設定

IS-IS 情報

IS-IS の概要

IS-IS エリア

NET およびシステム ID

DIS

IS-IS 認証

メッシュ グループ

過負荷ビット

ルート集約

ルートの再配布

ロード バランシング

仮想化サポート

ハイ アベイラビリティおよびグレースフル リスタート

複数の IS-IS インスタンス

IS-IS のライセンス要件

IS-IS の前提条件

設定時の注意事項および制約事項

IS-IS の設定

IS-IS コンフィギュレーション モード

IS-IS 機能のイネーブル化

IS-IS インスタンスの作成

IS-IS インスタンスの再起動

インターフェイス上での IS-IS の設定

エリアでの IS-IS 認証の設定

インターフェイス上での IS-IS 認証の設定

メッシュ グループの設定

DIS の設定

ダイナミック ホスト交換の設定

過負荷ビットの設定

サマリー アドレスの設定

再配布の設定

グレースフル リスタートの設定

仮想化の設定

IS-IS の調整

IS-IS の設定確認

IS-IS 統計情報の表示

IS-IS の設定例

関連項目

デフォルト設定

その他の関連資料

関連資料

規格

IS-IS 情報

IS-IS は、ISO(国際標準化機構)/IEC(国際電気標準化会議)10589 に基づく IGP です。Cisco NX-OS は、IPv4(インターネット プロトコル バージョン 4)および IPv6 をサポートします。IS-IS はネットワーク トポロジの変化を検出し、他のネットワーク ノードへのループフリー ルートを計算できる、ダイナミック リンクステート ルーティング プロトコルです。各ルータは、ネットワークの状態を記述するリンクステート データベースを維持し、設定された各リンクにパケットを送信してネイバーを検出します。IS-IS はネットワークを介して各ネイバーにリンクステート情報をフラッディングします。ルータもすべての既存ネイバーを通じて、リンクステート データベースのアドバタイズメントおよびアップデートを送信します。

ここでは、次の内容について説明します。

「IS-IS の概要」

「IS-IS 認証」

「メッシュ グループ」

「過負荷ビット」

「ルート集約」

「ルートの再配布」

「ロード バランシング」

「仮想化サポート」

「ハイ アベイラビリティおよびグレースフル リスタート」

「複数の IS-IS インスタンス」

IS-IS の概要

IS-IS は設定されている各インターフェイスに hello パケット を送信し、IS-IS ネイバー ルータを検出します。hello パケットには認証、エリア、サポート対象プロトコルなど、受信側インターフェイスが発信側インターフェイスとの互換性を判別するために使用する情報が含まれます。互換インターフェイスは隣接関係を形成し、リンクステート アップデート メッセージ(LSP)を使用して、リンクステート データベースのルーティング情報をアップデートします。ルータはデフォルトで、10 分間隔で定期的に LSP リフレッシュを送信し、LSP は 20 分間(LSP ライフタイム)リンクステート データベースに残ります。LSP ライフタイムが終了するまでにルータが LSP リフレッシュを受信しなかった場合、ルータはデータベースから LSP を削除します。

LSP インターバルは、LSP ライフタイムより短くする必要があります。そうしないと、リフレッシュ前に LSP がタイムアウトします。

IS-IS エリア

IS-IS ネットワークは、ネットワーク内のすべてのルータが含まれるシングル エリアとして設計することも、バックボーンまたは レベル 2 エリアに接続する複数のエリアとして設計することもできます。非バックボーン エリアのルータは レベル 1 ルータで、ローカル エリア内で隣接関係を確立します(エリア内ルーティング)。レベル 2 エリアのルータは、他のレベル 2 ルータと隣接関係を確立し、レベル 1 エリア間のルーティングを実行します(エリア間ルーティング)。1 つのルータにレベル 1 エリアとレベル 2 エリアの両方を設定できます。これらのレベル 1/レベル 2 ルータは、エリア境界ルータとして動作し、ローカル エリアからレベル 2 バックボーン エリアに情報をルーティングします(図8-1 を参照)。

レベル 1 エリア内のルータは、そのエリア内の他のすべてのルータに対する到達方法を認識します。エリア間では、ルータはレベル 2 エリアに接続するエリア境界ルータへの到達方法を認識します。レベル 2 ルータは、他のエリア境界ルータおよび他のレベル 2 ルータへの到達方法を認識します。レベル 1/レベル 2 ルータは 2 つのエリアの境界にまたがり、レベル 2 バックボーン エリアとの間で双方向にトラフィックをルーティングします。

Cisco NX-OS の IS-IS インスタンスは、レベル 1 またはレベル 2 エリアを 1 つだけサポートするか、またはそれぞれのエリアを 1 つずつサポートします。デフォルトでは、すべての IS-IS インスタンスが自動的にレベル 1 およびレベル 2 ルーティングをサポートします。

図8-1 エリアに分割された IS-IS ネットワーク

 

ASBR(自律システム境界ルータ)は、IS-IS AS(自律システム)全体に外部宛先をアドバタイズします。外部ルートは、他のプロトコルから IS-IS に再配布されたルートです。

NET およびシステム ID

IS-IS インスタンスごとに NET が関連付けられています。NET は、その IS-IS インスタンスをエリア内で一意に特定する IS-IS システム ID とエリア ID からなります。たとえば、NET が 47.0004.004d.0001.0001.0c11.1111.00 の場合、システム ID は 0000.0c11.1111.00、エリア ID は 47.0004.004d.0001 です。

DIS

IS-IS はブロードキャスト ネットワーク内で DIS(designated intermediate system; 代表中継システム)を使用し、各ルータがブロードキャスト ネットワーク上の他のすべてのルータと不要なリンクを形成することがないようにします。IS-IS ルータは DIS に LSP を送信し、DIS がブロードキャスト ネットワークのあらゆるリンクステート情報を管理します。エリア内で DIS を選択するために IS-IS に使用させる IS-IS プライオリティをユーザ側で設定できます。


) ポイントツーポイント ネットワークでは DIS は不要です。


IS-IS 認証

隣接関係および LSP 交換を制御するために、認証を設定できます。ネイバーになろうとするルータは、設定されている認証レベルの同じパスワードを交換する必要があります。パスワードが無効なルータは、IS-IS によってブロックされます。IS-IS 認証はグローバルに設定することも、レベル 1、レベル 2、またはレベル 1/レベル 2 両方のルーティングに対応する個々のインターフェイスに設定することもできます。

IS-IS がサポートする認証方式は、次のとおりです。

クリア テキスト ― 交換するすべてのパケットで、クリアテキストの 128 ビット パスワードが伝送されます。

MD5 ダイジェスト ― 交換するすべてのパケットで、128 ビット鍵に基づくメッセージ ダイジェストが伝送されます。

パッシブ アタック対策上、IS-IS が MD5 秘密鍵をクリアテキストとしてネットワークに流すことはありません。また、リプレイ アタックから保護するために、IS-IS は各パケットにシーケンス番号を組み込みます。

hello および LSP 認証用のキーチェーンも使用できます。キーチェーン管理については、『 Cisco Cisco NX-OS Security Configuration Guide 』を参照してください。

メッシュ グループ

メッシュ グループ は、一連のインターフェイスであり、それらのインターフェイスを介して到達可能なすべてのルータは、他の各ルータとの間に 1 つ以上のリンクがあります。ネットワークから 1 つまたは複数のルータを切り離さないと、多数のリンクが失敗する可能性があります。

通常のフラッディングでは、新しい LSP を受信したインターフェイスは、その LSP をルータ上の他のすべてのインターフェイスにフラッディングします。メッシュ グループを使用する場合、メッシュ グループに含まれているインターフェイスは新しい LSP を受信しても、メッシュ グループ内の他のインターフェイスには、新しい LSP をフラッディングしません。


) 特定のメッシュ ネットワーク トポロジーで、ネットワークのスケーラビリティを向上させるために、LSP を制限しなければならない場合があります。LSP フラッディングを制限すると、ネットワークの信頼性も下がります(障害発生時)。したがって、メッシュ グループはどうしても必要な場合に限り、慎重にネットワークを設計したうえで使用することを推奨します。


ルータ間のパラレル リンクに、ブロック モードでメッシュ グループを設定することもできます。このモードでは、各ルータがそれぞれリンクステート情報を最初に交換すると、それ以後はメッシュ グループのそのインターフェイスですべての LSP がブロックされます。

過負荷ビット

IS-IS は過負荷ビットを使用して、トラフィックの転送にはローカル ルータを使用しないが、引き続き、そのローカル ルータ宛てのトラフィックをルーティングすることを他のルータに指示します。

過負荷ビットを使用する状況は、次のとおりです。

ルータがクリティカル条件下にある。

ネットワークに対して通常手順でルータの追加および除去を行う。

その他(管理上またはトラフィック エンジニアリング上)の理由。たとえば、BGP コンバージェンス待ちなどです。

ルート集約

サマリー集約アドレスを設定できます。ルート集約を使用すると、固有性の強い一連のアドレスをすべての固有アドレスを代表する 1 つのアドレスに置き換えることによって、ルート テーブルを簡素化できます。たとえば、10.1.1.0/24、10.1.2.0/24、および 10.1.3.0/24 を 1 つのサマリー アドレス 10.1.0.0/16 に置き換えることができます。

IS-IS はルーティング テーブルに含まれている固有性の強いルートが多いほど、固有性の強いルートの最小メトリックと同じメトリックを指定して、サマリー アドレスをアドバタイズします。


) Cisco NX-OS は、自動ルート集約をサポートしません。


ルートの再配布

IS-IS を使用すると、スタティック ルート、他の IS-IS AS が学習したルート、または他のプロトコルからのルートを再配布できます。再配布を設定するには、ルート ポリシーを使用して、IS-IS に渡すルートを制御します。ルート ポリシーでは、宛先、送信元プロトコル、ルート タイプ、ルート タグなどのアトリビュートに基づいて、ルートをフィルタリングできます。詳細については、 第 14 章「Route Policy Manager の設定」 を参照してください。

IS-IS ルーティング ドメインにルートを再配布しても、デフォルトでは Cisco NX-OS がそのつど、IS-IS ルーティング ドメインにデフォルト ルートを再配布することはありません。IS-IS で デフォルト ルート を発生させ、ルート ポリシーでそのルートを制御できます。

IS-IS にインポートされたすべてのルートに使用する、デフォルトのメトリックも設定できます。

ロード バランシング

ロード バランシングを使用すると、ルータによって、宛先アドレスから同じ距離にあるすべてのルータ ネットワーク ポートにトラフィックが分散されます。ロード バランシングは、ネットワーク セグメントの使用率を向上させ、有効ネットワーク帯域幅を増加させます。

Cisco NX-OS は、ECMP(等コスト マルチパス)機能をサポートします。IS-IS ルート テーブルおよびユニキャスト RIB の等コスト パスは最大 16 です。これらのパスの一部または全部でトラフィックのロード バランシングが行われるように、IS-IS を設定できます。

仮想化サポート

Cisco NX-OS は、同一システム上で動作する複数の IS-IS プロトコル インスタンスをサポートします。IS-IS は VRF(仮想ルーティングおよびフォワーディング)インスタンスをサポートします。VRF は virtual device context(仮想デバイス コンテキスト; VDC)内に存在します。VDC で設定できる IS-IS インスタンスは、最大4 つです。

特に VDC および VRF を設定しないかぎり、デフォルトで、Cisco NX-OS はユーザにデフォルト VDC およびデフォルト VRF を使用させます。『 Cisco NX-OS Virtual Device Context Configuration Guide 』および 第 13 章「レイヤ 3 仮想化の設定」 を参照してください。

ハイ アベイラビリティおよびグレースフル リスタート

Cisco NX-OS システムでコールド リブートが発生した場合、ネットワークはシステムにトラフィックを転送しないで、ネットワーク トポロジからシステムを削除します。この状況では、IS-IS はステートレス リスタートになり、Cisco NX-OS がすべてのネイバーを削除します。Cisco NX-OS によってスタートアップ コンフィギュレーションが適用され、IS-IS はネイバーを再発見して、再びすべての IS-IS ルーティング情報を共有します。

Cisco NX-OS はハイ アベイラビリティをサポートします。Cisco NX-OS システムでコールド リブートが発生した場合、ネットワークはシステムへのトラフィック転送を中止し、ネットワーク トポロジからシステムを削除します。この状況では、IS-IS はステートレス リスタートになり、ローカル システムからすべてのネイバーを削除します。Cisco NX-OS によってスタートアップ コンフィギュレーションが適用され、IS-IS はネイバーを再発見して、再びすべての IS-IS ルーティング情報を共有します。

Cisco NX-OS を実行するスーパーバイザが 2 つあるプラットフォームでは、ステートフル スーパーバイザ スイッチオーバーが行われます。IS-IS はスイッチオーバーの発生前に、IS-IS がしばらく使用できなくなることを告知することによって、グレースフル リスタートを開始します。スイッチオーバーの間、ネットワークはトラフィック転送を続け、ネットワーク トポロジにシステムを残します。

スイッチオーバー後、Cisco NX-OS によって実行コンフィギュレーションが適用され、IS-IS は再び動作可能になったことをネイバーに通知します。

この間に問題が発生した場合は、IS-IS が自動的にリスタートします。リスタート後、IS-IS はプラットフォームがネットワーク トポロジから排除されないように、グレースフル リスタートを開始します。IS-IS を手動でリスタートした場合は、グレースフル リスタートが実行され、ステートフル スイッチオーバーと同様の結果が得られます。どちらの場合も、実行コンフィギュレーションが適用されます。


) IS-IS の ISSU(インサービス ソフトウェア アップグレード)をサポートするには、グレースフル リスタートをイネーブルにする必要があります。グレースフル リスタートをディセーブルにすると、この設定では ISSU をサポートできないことを伝える警告が Cisco NX-OS から出されます。


複数の IS-IS インスタンス

Cisco NX-OS は、同一システム上で動作する最大 4 つの IS-IS プロトコル インスタンスをサポートします。同一インターフェイス上で複数のインスタンスを設定することはできません。すべてのインスタンスで同じシステム ルータ ID を使用します。

IS-IS のライセンス要件

次の表に、この機能のライセンス要件を示します。

 

製品
ライセンス要件

NX-OS

IS-IS には Enterprise Services ライセンスが必要です。NX-OS ライセンス方式の詳細、ライセンスを取得して適用する方法については、『 Cisco NX-OS Licensing Guide 』を参照してください。

IS-IS の前提条件

IS-IS の前提条件は、次のとおりです。

IS-IS 機能をイネーブルにする必要があります(IS-IS 機能のイネーブル化を参照)。

VDC を設定する場合は、Advanced Services ライセンスをインストールし、所定の VDCを開始してください(『 Cisco NX-OS Virtual Device Context Configuration Guide 』を参照)。

設定時の注意事項および制約事項

IS-IS 設定時の注意事項および制約事項は、次のとおりです。

VDC ごとに最大 4 つの IS-IS インスタンスを設定できます。

IS-IS の設定

IS-IS を設定する手順は、次のとおりです。


ステップ 1 IS-IS 機能をイネーブルにします(IS-IS 機能のイネーブル化を参照)。

ステップ 2 IS-IS インスタンスを作成します(IS-IS インスタンスの作成を参照)。

ステップ 3 IS-IS インスタンスにインターフェイスを追加します(インターフェイス上での IS-IS の設定を参照)。

ステップ 4 認証、メッシュ グループ、ダイナミック ホスト交換などのオプション機能を設定します。


 

ここでは、次の内容について説明します。

「IS-IS コンフィギュレーション モード」

「IS-IS 機能のイネーブル化」

「IS-IS インスタンスの作成」

「インターフェイス上での IS-IS の設定」

「エリアでの IS-IS 認証の設定」

「インターフェイス上での IS-IS 認証の設定」

「メッシュ グループの設定」

「DIS の設定」

「ダイナミック ホスト交換の設定」

「過負荷ビットの設定」

「サマリー アドレスの設定」

「再配布の設定」

「仮想化の設定」

「IS-IS の調整」


) Cisco IOS の CLI に慣れている場合、この機能に対応する Cisco NX-OS コマンドは通常使用する Cisco IOS コマンドと異なる場合があるので注意してください。


IS-IS コンフィギュレーション モード

ここでは各コンフィギュレーション モードの開始方法について説明します。各モードから ? コマンドを入力すると、そのモードで使用できるコマンドが表示されます。

ここでは、次の内容について説明します。

「ルータ コンフィギュレーション モード」

「ルータ アドレス ファミリ コンフィギュレーション モード」

ルータ コンフィギュレーション モード

ルータ コンフィギュレーション モードを開始する例を示します。

switch#: conf t
switch(config)# router isis isp
switch(config-router)#
 

ルータ アドレス ファミリ コンフィギュレーション モード

ルータ アドレス ファミリ コンフィギュレーション モードを開始する例を示します。

switch(config)# router isis isp
switch(config-router)# address-family ipv6 unicast
switch(config-router-af)#
 

IS-IS 機能のイネーブル化

IS-IS を設定する前に、IS-IS 機能をイネーブルにする必要があります。

準備作業

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順概要

1. config t

2. feature isis

3. copy running-config startup-config

手順詳細

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

feature isis

 

switch(config)# feature isis

IS-IS 機能をイネーブルにします。

ステップ 3

copy running-config startup-config

 

switch(config)# copy running-config startup-config

(任意)この設定変更を保存します。

IS-IS 機能をディセーブルにして、関連するすべての設定を削除する場合は、 no feature isis コマンドを使用します。

 

コマンド
目的

no feature isis

 

switch(config)# no feature isis

IS-IS 機能をディセーブルにして、関連するすべての設定を削除します。

IS-IS インスタンスの作成

IS-IS インスタンスを作成し、そのインスタンスのエリア レベルを設定できます。

準備作業

IS-IS 機能がイネーブルになっていることを確認します(IS-IS 機能のイネーブル化を参照)。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順概要

1. config t

2. router is-is instance-tag

3. net network-entity-title

4. is-type {l evel-1 | level-2 | level-1-2 }

5. show isis [ vrf vrf-name ] process

6. copy running-config startup-config

手順詳細

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router isis instance-tag

 

switch(config)# router isis Enterprise

switch(config-router)#

instance tag を設定して、新しい IS-IS インスタンスを作成します。

ステップ 3

net network-entity-title

 

switch(config-router)# net 47.0004.004d.0001.0001.0c11.1111.00

この IS-IS インスタンスに対応する NET を設定します。

ステップ 4

is-type { level-1 | level-2 | level-1-2 }

 

switch(config-router)# is-type level-2

(任意)この IS-IS インスタンスのエリア レベルを設定します。デフォルトは level-1-2 です。

ステップ 5

show isis [ vrf vrf-name ] process

 

switch(config)# show isis process

(任意)すべての IS-IS インスタンスについて、IS-IS 要約情報を表示します。

ステップ 6

copy running-config startup-config

 

switch(config)# copy running-config startup-config

(任意)この設定変更を保存します。

IS-IS インスタンスおよび関連するすべての設定を削除する場合は、 no router isis コマンドを使用します。

 

コマンド
目的

no router isis instance-tag

 

switch(config)# no router isis Enterprise

IS-IS インスタンスおよび関連するすべての設定を削除します。


) IS-IS インスタンスに関するすべての設定を完全に削除するには、インターフェイス モードで設定した IS-IS コマンドも削除する必要があります。


IS-IS には次のオプション パラメータを設定できます。

 

コマンド
目的

distance value

 

switch(config-router)# distance 30

IS-IS の管理ディスタンスを設定します。有効値の範囲は 1 ~ 255 であり、デフォルトは 115 です。「管理ディスタンス」を参照してください。

log-adjacency-changes

 

switch(config-router)# log-adjacency-changes

IS-IS ネイバーのステートが変化するたびに、システム メッセージを送信します。

lsp-mtu size

 

switch(config-router)# lsp-mtu 600

この IS-IS インスタンスにおける LSP の MTU を設定します。有効値の範囲は 128 ~ 4352 バイトです。デフォルト値は 1492 です。

maximum-paths number

 

switch(config-router)# maximum-paths 6

IS-IS がルート テーブルで維持する等コスト パスの最大数を設定します。有効値の範囲は 1 ~ 16 であり、デフォルトは 4 です。

reference-bandwidth bandwidth-value { Mbps | Gbps }

 

switch(config-router)# reference-bandwidth 100 Gbps

IS-IS コスト メトリックの計算に使用する、デフォルトの基準帯域幅を設定します。有効値の範囲は 1 ~ 4000 Gbps です。デフォルト値は 40 Gbps です。

レベル 2 エリアで IS-IS インスタンスを作成する例を示します。

switch# config t

switch(config)# router isis Enterprise

switch(config-router)# net 47.0004.004d.0001.0001.0c11.1111.00

switch(config-router)# is-type level 2

switch(config-router)# copy running-config startup-config

 

ネイバーの統計情報を消去し、隣接関係を削除する場合は、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

clear isis [ instance-tag ] adjacency [ * | system-id | interface ]

 

switch(config-if)# clear isis adjacency *

ネイバーの統計情報を消去し、この IS-IS インスタンスの隣接関係を削除します。

IS-IS インスタンスの再起動

IS-IS インスタンスは再起動が可能です。再起動すると、インスタンスのすべてのネイバーが消去されます。

IS-IS インスタンスを再起動し、関連付けられたすべてのネイバーを削除するには、次のコマンドを使用します。

 

コマンド
目的

restart isis instance-tag

 

switch(config)# restart isis Enterprise

IS-IS インスタンスを再起動し、すべてのネイバーを削除します。

インターフェイス上での IS-IS の設定

IS-IS インスタンスにインターフェイスを追加できます。

準備作業

IS-IS 機能がイネーブルになっていることを確認します(IS-IS 機能のイネーブル化を参照)。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順概要

1. config t

2. interface interface-type slot/port

3. ip router isis instance-tag

または

ipv6 router isis instance-tag

4. show isis [ vrf vrf-name ] [ instance-tag ] interface [ interface-type slot/port ]

5. copy running-config startup-config

手順詳細

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface interface-type slot/port

 

switch(config)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

ip router isis instance-tag

 

switch(config-if)# ip router isis Enterprise

この IPv4 インターフェイスを IS-IS インスタンスに関連付けます。

ipv6 router isis instance-tag

 

switch(config-if)# ipv6 router isis Enterprise

この IPv6 インターフェイスを IS-IS インスタンスに関連付けます。

ステップ 4

show isis [ vrf vrf-name ] [ instance-tag ] interface [ interface-type slot/port ]

 

switch(config)# show isis Enterprise ethernet 1/2

(任意)インターフェイスの IS-IS 情報を表示します。

ステップ 5

copy running-config startup-config

 

switch(config)# copy running-config startup-config

(任意)この設定変更を保存します。

インターフェイス モードでは、IS-IS に次のオプション パラメータを設定できます。

 

コマンド
目的

isis circuit-type { level-1 | level-2 | level-1-2 }

 

switch(config-if)# isis circuit-type level-2

このインターフェイスが関与する隣接関係のタイプを設定します。このコマンドを使用するのは、レベル 1 とレベル 2 の両方のエリアにルータが関係する場合だけです。

isis metric value { level-1 | level-2 }

 

switch(config-if)# isis metric 30

このインターフェイスの IS-IS メトリックを設定します。有効値の範囲は 1 ~ 16777214 であり、デフォルトは 10 です。

isis passive { level-1 | level-2 | level-1-2 }

 

switch(config-if)# isis passive level-2

インターフェイスが隣接関係を形成しないようにしながら、なおかつ、インターフェイスに関連付けられたプレフィクスをアドバタイズするようにします。

IS-IS インスタンスにインターフェイス ethernet 1/2 を追加する例を示します。

switch# config t

switch(config)# interface ethernet 1/2

switch(config-if)# ip router isis Enterprise

switch(config-if)# copy running-config startup-config

 

エリアでの IS-IS 認証の設定

エリアで LSP を認証するように IS-IS を設定できます。

準備作業

IS-IS 機能がイネーブルになっていることを確認します(IS-IS 機能のイネーブル化を参照)。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順概要

1. config t

2. router isis instance-tag

3. authentication-type { cleartext | md5 } {l evel-1 | level-2 }

4. authentication-key keychain key { level-1 | level-2 }

5. authentication-check { level-1 | level-2 }

6. copy running-config startup-config

手順詳細

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router isis instance-tag

 

switch(config)# router isis Enterprise

switch(config-router)#

instance tag を設定して、新しい IS-IS インスタンスを作成します。

ステップ 3

authentication-type { cleartext | md5 } { level-1 | level-2 }

 

switch(config-router)# authentication-type cleartext level-2

クリアテキストまたは MD5 認証ダイジェストとして、レベル 1 またはレベル 2 エリアに使用する認証方式を設定します。

ステップ 4

authentication-key keychain key { level-1 | level-2 }

 

switch(config-router)# authentication-key ISISKey level-2

IS-IS エリアレベル認証に使用する認証鍵を設定します。

ステップ 5

authentication-check { level-1 | level-2 }

 

switch(config-router)# authentication-check level-2

(任意)受信パケットの認証パラメータ チェックをイネーブルにします。

ステップ 6

copy running-config startup-config

 

switch(config-router)# copy running-config startup-config

(任意)この設定変更を保存します。

IS-IS インスタンスにクリアテキスト認証を設定する例を示します。

switch# config t

switch(config)# router isis Enterprise

switch(config-router)# authentication-type cleartext level-2

switch(config-router)# authentication-key keychain ISISKey level-2

switch(config-router)# copy running-config startup-config

 

インターフェイス上での IS-IS 認証の設定

インターフェイス上で hello パケットを認証するように IS-IS を設定できます。

準備作業

IS-IS 機能がイネーブルになっていることを確認します(IS-IS 機能のイネーブル化を参照)。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順概要

1. config t

2. interface interface-type slot/port

3. isis authentication-type { cleartext | md5 } [level-1 | level-2 ]

4. isis authentication-key keychain key [ level-1 | level-2 ]

5. isis authentication-check [ level-1 | level-2 ]

6. copy running-config startup-config

手順詳細

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface interface-type slot/port

 

switch(config)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

isis authentication-type { cleartext | md5 } [ level-1 | level-2 ]

 

switch(config-if)# isis authentication-type cleartext level-2

クリアテキストまたは MD5 認証ダイジェストとして、このインターフェイスにおける IS-IS 認証タイプを設定します。

ステップ 4

isis authentication-key keychain key [ level-1 | level-2 ]

 

switch(config-if)# isis authentication-key ISISKey level-2

このインターフェイス上で IS-IS に使用する認証鍵を設定します。

ステップ 5

isis authentication-check { level-1 | level-2 }

 

switch(config-if)# isis authentication-check

(任意)受信パケットの認証パラメータ チェックをイネーブルにします。

ステップ 6

copy running-config startup-config

 

switch(config-if)# copy running-config startup-config

(任意)この設定変更を保存します。

IS-IS インスタンスにクリアテキスト認証を設定する例を示します。

switch# config t

switch(config)# interface ethernet 1/2

switch(config-if)# isis authentication-type cleartext level-2

switch(config-if)# isis authentication-key keychain ISISKey

switch(config-if)# copy running-config startup-config

 

メッシュ グループの設定

メッシュ グループにインターフェイスを追加することによって、そのメッシュ グループ内のインターフェイスに対する LSP フラッディング量を制限できます。任意で、メッシュ グループ内のインターフェイスに対して、すべての LSP フラッディングをブロックすることもできます。

メッシュ グループにインターフェイスを追加するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

isis mesh-group { blocked | mesh-id }

 

switch(config-if)# isis mesh-group 1

メッシュ グループにこのインターフェイスを追加します。有効値の範囲は 1 ~ 4294967295 です。

DIS の設定

インターフェイス プライオリティを設定することによって、ルータがマルチアクセス ネットワークの DIS(代表中継システム)になるように設定できます。

DIS を設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

isis priority number

 

switch(config-if)# isis priority 100

DIS 選択のためのプライオリティを設定します。有効値の範囲は 0 ~ 127 です。デフォルトは 64 です。

ダイナミック ホスト交換の設定

ダイナミック ホスト交換を使用することによって、システム ID とルータのホスト名がマッピングされるように IS-IS を設定できます。

ダイナミック ホスト交換を設定するには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

hostname dynamic

 

switch(config-router)# hostname dynamic

ダイナミック ホスト交換をイネーブルにします。

過負荷ビットの設定

最短パス優先(SPF)を計算するときの中間ホップとしてこのルータを使用しないことを他のルータに伝えるように、ルータを設定できます。任意で、起動時に BGP が収束するまで、一時的に過負荷ビットを設定することもできます。

過負荷ビットを設定する以外に、レベル 1 またはレベル 2 トラフィックに関して、LSP からの特定タイプの IP プレフィクス アドバタイズメントを抑制することが必要な場合もあります。

過負荷ビットを設定するには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

set-overload-bit { always | on-startup { seconds | wait-for bgp as-number }} [ suppress [ interlevel | external ]]

 

switch(config-router)# set-overload-bit on-startup 30

IS-IS に過負荷ビットを設定します。 seconds の範囲は 5 ~ 86400 です。

サマリー アドレスの設定

ルーティング テーブルでサマリー アドレスによって表される集約アドレスを作成できます。1 つのサマリー アドレスに、特定のレベルの複数のアドレス グループを含めることができます。Cisco NX-OS は固有性の強いすべてのルートのうち、最小メトリックをアドバタイズします。

準備作業

IS-IS 機能がイネーブルになっていることを確認します(IS-IS 機能のイネーブル化を参照)。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順概要

1. config t

2. router isis instance-tag

3. address-family { ipv4 | ipv6 } { unicast | multicast }

4. summary-address { ip-prefix/mask-len | ipv6-prefix/mask-len } { level-1 | level-2 | level-1-2 }

5. show isis [ vrf vrf-name ] ip summary-address ip-prefix [ longer-prefixes ]

6. show isis [ vrf vrf-name ] ipv6 summary-address ipv6-prefix [ longer-prefixes ]

7. copy running-config startup-config

手順詳細

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router isis instance-tag

 

switch(config)# router isis Enterprise

switch(config-router)#

instance tag を設定して、新しい IS-IS インスタンスを作成します。

ステップ 3

address-family { ipv4 | ipv6 } { unicast | multicast }

 

switch(config-router)# address-family ipv4 unicast

switch(config-router-af)#

アドレス ファミリ コンフィギュレーション モードを開始します。

ステップ 4

summary-address { ip-prefix/mask-len | ipv6-prefix/mask-len } { level-1 | level-2 | level-1-2 }

 

switch(config-router-af)# summary-address 192.0.2.0/24 level-2

IPv4 または IPv6 アドレスに対応する、ISIS エリア用のサマリー アドレスを設定します。

ステップ 5

show isis [ vrf vrf-name ] ip summary-address ip-prefix [ longer-prefixes ]]

 

switch(config-if)# show isis ip summary-address

(任意)IS-IS IPv4 サマリー アドレス情報を表示します。

ステップ 6

show isis [ vrf vrf-name ] ipv6 summary-address ipv6-prefix [ longer-prefixes ]]

 

switch(config-if)# show isis ipv6 summary-address

(任意)IS-IS IPv6 サマリー アドレス情報を表示します。

ステップ 7

copy running-config startup-config

 

switch(config--if)# copy running-config startup-config

(任意)この設定変更を保存します。

IS-IS に IPv4 ユニキャスト サマリー アドレスを設定する例を示します。

switch# config t

switch(config)# router isis Enterprise

switch(config-router)# address-family ipv4 unicast

switch(config-router-af)# summary-address 192.0.2.0/24 level-2

switch(config-router-af)# copy running-config startup-config

 

再配布の設定

別のルーティング プロトコルからのルーティング情報を受け入れて、IS-IS ネットワークを通じてその情報を再配布するように、IS-IS を設定できます。任意で、再配布ルートのためのデフォルト ルートを割り当てることができます。

準備作業

IS-IS 機能がイネーブルになっていることを確認します(IS-IS 機能のイネーブル化を参照)。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順概要

1. config t

2. router isis instance-tag

3. address-family { ipv4 | ipv6 } { unicast | multicast }

4. redistribute { bgp as | direct | eigrp as | isis id | ospf id | ospfv3 id | rip id | static } route-map map-name

5. default-information originate [ always ] [ route-map map-name ]

6. distribute { level-1 | level-2 } into { level-1 | level-2 } { route-map route-map | all }

7. show isis [ vrf vrf-name ] { ip | ipv6 } route { ip-prefix | ip6-prefix }[ detail | longer-prefixes [ summary | detail ]]

8. copy running-config startup-config

手順詳細

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router isis instance-tag

 

switch(config)# router isis Enterprise

switch(config-router)#

instance tag を設定して、新しい IS-IS インスタンスを作成します。

ステップ 3

address-family { ipv4 | ipv6 } { unicast | multicast }

 

switch(config-router)# address-family ipv4 unicast

switch(config-router-af)#

アドレス ファミリ コンフィギュレーション モードを開始します。

ステップ 4

redistribute { bgp as | direct | eigrp as | isis id | ospf id | ospfv3 id | rip id | static | direct } route-map map-name

 

switch(config-router-af)# redistribute eigrp 201 route-map ISISmap

他のプロトコルからのルートを IS-IS に再配布します。ルート マップの詳細については、「ルート マップの設定」を参照してください。

ステップ 5

default-information originate [ always ] [ route-map map-name ]

 

switch(config-router-af)# default-information originate always

(任意)IS-IS へのデフォルト ルートを作成します。

ステップ 6

distribute { level-1 | level-2 } into { level-1 | level-2 } { route-map route-map | all }

 

switch(config-router-af)# distribute level-1 into level-2 all

(任意)一方の IS-IS レベルから他方の IS-IS レベルへ、ルートを再配布します。

ステップ 7

show isis [ vrf vrf-name ] { ip | ipv6 } route { ip-prefix ip6-prefix }[ detail | longer-prefixes [ summary | detail ]]

 

switch(config-router-af)# show isis ip route

(任意)IS-IS のルートを表示します。

ステップ 8

copy running-config startup-config

 

switch(config-router-af)# copy running-config startup-config

(任意)この設定変更を保存します。

EIGRP を IS-IS に再配布する例を示します。

switch# config t

switch(config)# router isis Enterprise

switch(config-router)# address-family ipv4 unicast

switch(config-router-af)# redistribute eigrp 201 route-map ISISmap

switch(config-router-af)# copy running-config startup-config

 

グレースフル リスタートの設定

IS-IS にグレースフル リスタートを設定できます。

準備作業

IS-IS 機能がイネーブルになっていることを確認します(IS-IS 機能のイネーブル化を参照)。

VDC および VRF を作成します。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順概要

1. config t

2. router isis instance-tag

3. graceful-restart

4. graceful-restart t3 manual time

5. show running-config isis

6. copy running-config startup-config

手順詳細

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router isis instance-tag

 

switch(config)# router isis Enterprise

switch(config-router)#

名前を設定して、新しい IS-IS プロセスを作成します。

ステップ 3

graceful-restart

 

switch(config-router)# graceful-restart

グレースフル リスタートおよびグレースフル リスタート ヘルパー機能をイネーブルにします。イネーブルがデフォルトです。

ステップ 4

graceful-restart t3 manual time

 

switch(config-router)# graceful-restart t3 manual 300

グレースフル リスタート T3 タイマーを設定します。有効値の範囲は 30 ~ 65535 秒です。デフォルト値は 60 です。

ステップ 5

show running-config isis

 

switch(config-router)# show running-config isis

(任意)IS-IS の設定を表示します。

ステップ 6

copy running-config startup-config

 

switch(config-router)# copy running-config startup-config

(任意)この設定変更を保存します。

グレースフル リスタートをイネーブルにする例を示します。

switch# config t

switch(config)# router isis Enterprise

switch(config-router)# graceful-restart

switch(config-router)# copy running-config startup-config

 

仮想化の設定

VDC ごとに複数の IS-IS インスタンスを設定できます。各 VDC 内で複数の VRF を作成することもできます。また、各 VRF で同じ IS-IS インスタンスを使用することも、複数の IS-IS インスタンスを使用することも可能です。VRF に IS-IS インターフェイスを割り当てます。

設定した VRF に NET を設定する必要があります。


) インターフェイスに VRF を設定したあとで、その他のインターフェイス パラメータを設定します。インターフェイスに VRF を設定すると、そのインターフェイスに関するすべての設定が削除されます。


準備作業

IS-IS 機能がイネーブルになっていることを確認します(IS-IS 機能のイネーブル化を参照)。

VDC を作成します。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順概要

1. config t

2. vrf context vrf_name

3. exit

4. router isis instance-tag

5. vrf vrf_name

6. net network-entity-title

7. オプション パラメータの設定

8. interface type slot/port

9. vrf member vrf-name

10. ip address ip-prefix/length

11. ip router isis instance-tag

または

ipv6 router isis instance-tag

12. show isis [ vrf vrf-name ] [ instance-tag ] interface [ interface-type slot/port ]

13. copy running-config startup-config

手順詳細

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

vrf context vrf-name

 

switch(config)# vrf context RemoteOfficeVRF

switch(config-vrf)#

新しい VRF を作成し、VRF コンフィギュレーション モードを開始します。

ステップ 3

router isis instance-tag

 

switch(config)# router isis Enterprise

switch(config-router)#

instance tag を設定して、新しい IS-IS インスタンスを作成します。

ステップ 4

vrf vrf-name

 

switch(config-router)# vrf RemoteOfficeVRF

switch(config-router-vrf)#

(任意)VRF コンフィギュレーション モードを開始します。

ステップ 5

net network-entity-title

 

switch(config-router-vrf)# net 47.0004.004d.0001.0001.0c11.1111.00

この IS-IS インスタンスに対応する NET を設定します。

ステップ 6

exit

 

switch(config-router)# exit

switch(config-router)#

ルータ VRF コンフィギュレーション モードを終了します。

ステップ 7

address-family { ipv4 | ipv6 } { unicast | multicast }

 

switch(config-router)# address-family ipv4 unicast

switch(config-router-af)#

(任意)アドレス ファミリ コンフィギュレーション モードを開始します。

ステップ 8

redistribute { bgp as | direct | eigrp as | isis id | ospf id | ospfv3 id | rip id | static | direct } route-map map-name

 

switch(config-router-af)# redistribute eigrp 201 route-map ISISmap

(任意)他のプロトコルからのルートを IS-IS に再配布します。ルート マップの詳細については、「ルート マップの設定」を参照してください。

ステップ 9

interface ethernet slot/port

 

switch(config)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 10

vrf member vrf-name

 

switch(config-if)# vrf member RemoteOfficeVRF

VRF にこのインターフェイスを追加します。

ステップ 11

ip address ip-prefix/length

 

switch(config-if)# ip address 209.0.2.1/16

このインターフェイスの IP アドレスを設定します。この作業は、VRF にこのインターフェイスを割り当てたあとで行う必要があります。

ステップ 12

ip router isis instance-tag

 

switch(config-if)# ip router isis Enterprise

この IPv4 インターフェイスを IS-IS インスタンスに関連付けます。

ipv6 router isis instance-tag

 

switch(config-if)# ipv6 router isis Enterprise

この IPv6 インターフェイスを IS-IS インスタンスに関連付けます。

ステップ 13

show isis [ vrf vrf-name ] [ instance-tag ] interface [ interface-type slot/port ]

 

switch(config-if)# show isis Enterprise ethernet 1/2

(任意)VRF に含まれるインターフェイスの IS-IS 情報を表示します。

ステップ 14

copy running-config startup-config

 

switch(config-if)# copy running-config startup-config

(任意)この設定変更を保存します。

VRF を作成し、VRF にインターフェイスを追加する例を示します。

switch# config t

switch(config)# vrf context NewVRF

switch(config-vrf)# exit

switch(config)# router isis Enterprise

switch(config-router)# vrf NewVRF

switch(config-router-vrf)# net 47.0004.004d.0001.0001.0c11.1111.00

switch(config-router-vrf)# interface ethernet 1/2

switch(config-if)# vrf membmer NewVRF

switch(config-if)# ip address 209.0.2.1/16

switch(config-if)# ip router isis Enterprise

switch(config-if)# copy running-config startup-config

 

IS-IS の調整

ネットワーク要件に合わせて IS-IS を調整できます。

IS-IS を調整するには、ルータ コンフィギュレーション モードで次のオプション コマンドを使用します。

 

コマンド
目的

lsp-gen-interval [ level-1 | level-2 ] lsp-max-wait [ lsp-initial-wait lsp-second-wait ]

 

switch(config-router)# lsp-gen-interval level-1 500 500 500

LSP 発生に関する IS-IS スロットルを設定します。オプション パラメータは次のとおりです。

lsp-max-wait ― トリガーから LSP 発生までの最大待ち時間。有効値の範囲は 500 ~ 65535 ミリ秒です。

lsp-initial-wait ― トリガーから LSP 発生までの初期待ち時間。有効値の範囲は 50 ~ 65535 ミリ秒です。

lsp-second-wait ― バックオフ時の LSP スロットルに使用する第 2 待ち時間。有効値の範囲は 50 ~ 65535 ミリ秒です。

max-lsp-lifetime lifetime

 

switch(config-router)# max-lsp-lifetime 500

LSP の最大ライフタイムを秒数で設定します。有効値の範囲は 1 ~ 65535 であり、デフォルトは 1200 です。

spf-interval [ level-1 | level-2 ] spf-max-wait [ spf-initial-wait spf-second-wait ]

 

switch(config-router)# spf-interval level-2 500 500 500

LSA 到着までのインターバルを設定します。オプション パラメータは次のとおりです。

lsp-max-wait ― トリガーから SPF 計算までの最大待ち時間。有効値の範囲は 500 ~ 65535 ミリ秒です。

lsp-initial-wait ― トリガーから SPF 計算までの初期待ち時間。有効値の範囲は 50 ~ 65535 ミリ秒です。

lsp-second-wait ― バックオフ時の SPF 計算に使用する第 2 待ち時間。有効値の範囲は 50 ~ 65535 ミリ秒です。

shutdown

 

switch(config-router)# shutdown

設定を削除しないで、この IS-IS インスタンスをシャットダウンします。

wide-metric-only

 

switch(config-router)# wide-metric-only

ワイド メトリックをアドバタイズするように、IS-IS を設定します。

ルータ アドレス コンフィギュレーション モードで次のオプション コマンドを使用できます。

 

コマンド
目的

adjacency-check

 

switch(config-router-af)# adjacency-check

隣接関係チェックを実行し、IS-IS インスタンスが同じアドレス ファミリをサポートするリモート IS-IS エンティティに限って隣接関係を形成していることを確認します。イネーブルがデフォルトです。

IS-IS を調整するには、インターフェイス コンフィギュレーション モードで次のオプション コマンドを使用します。

 

コマンド
目的

isis hello-interval seconds [ level-1 | level-2 ]

 

switch(config-if)# isis hello-interval 20

IS-IS に hello インターバルを秒数で設定します。有効値の範囲は 1 ~ 65535 であり、デフォルトは 10 です。

isis hello-multiplier num [ level-1 | level-2 ]

 

switch(config-if)# isis hello-multiplier 20

ルータが隣接関係を破棄するまでに、ネイバーが見逃さなければならない IS-IS hello パケットの数を指定します。有効値の範囲は 3 ~ 1000 であり、デフォルトは 3 です。

isis hello-padding

 

switch(config-if)# isis hello-padding

フル MTU に hello パケットを埋め込みます。イネーブルがデフォルトです。

isis lsp-interval milliseconds

 

switch(config-if)# isis lsp-interval 20

フラッディング時にこのインターフェイスで LSP が送信される間隔をミリ秒数で設定します。有効値の範囲は 10 ~ 65535 であり、デフォルトは 33 です。

IS-IS の設定確認

IS-IS の設定を確認するには、次のコマンドを使用します。

 

コマンド
目的

show isis [ vrf vrf-name ] adjacency [ interface ] [ detail | summary ]

IS-IS の隣接関係を表示します。これらの統計情報を消去するには、 clear isis adjacency コマンドを使用します。

show isis [ vrf vrf-name ] database [ level-1 | level-2 ] [ detail | summary ] [ LSP ID ] {[ ip prefix ip-prefix ] | [ ipv6 prefix ipv6-prefix ] | [ router-id router-id ] | [ adjacency node-id ]}

IS-IS LSP データベースを表示します。

show isis [ vrf vrf-name ] hostname

ダイナミック ホスト交換情報を表示します。

show isis [ vrf vrf-name ] [ instance-tag ] interface [ interface ]

IS-IS インターフェイス情報を表示します。

show isis [ vrf vrf-name ] mesh-group

メッシュ グループ情報を表示します。

show isis [ vrf vrf-name ] process

IS-IS 情報を表示します。

show isis [ vrf vrf-name ] [ ipv6] route [ip-prefix | ipv6-prefix] [detail | longer-prefixes [ summary | detail ]]

IS-IS ルート テーブルを表示します。

show isis [ vrf vrf-name ] spf-log [ detail ]

IS-IS SPF 計算の統計情報を表示します。

show isis [ vrf vrf-name ] [ ipv6 ] summary-addres s [ ip-prefix | ipv6-prefix [ longer-prefixes ]]

IS-IS のサマリー アドレス情報を表示します。

show running-configuration isis

現在の実行中の IS-IS 設定を表示します。

各コマンド出力のフィールドの詳細については、『 Cisco NX-OS Command Reference 』を参照してください。

IS-IS 統計情報の表示

IS-IS の統計情報を表示するには、次のコマンドを使用します。

 

コマンド
目的

show isis [ vrf vrf-name ] [instance-tag] adjacency [ interface ] [ system-ID ]

IS-IS 隣接関係の統計情報を表示します。

show isis [ vrf vrf-name ] [ instance-tag ] statistics [ interface ]

IS-IS インターフェイスの統計情報を表示します。

show isis [ vrf vrf-name ] [ ip | ipv4 ] route-map statistics redistribute { bgp id | direct | eigrp id | isis id | ospf id | rip id | static }

IS-IS 再配布の統計情報を表示します。

show isis [ vrf vrf-name ] route-map statistics distribute { level-1 | level-2 } into { level-1 | level-2 }}

レベル間で配布されたルートに関する、IS-IS 配布統計情報を表示します。

IS-IS 設定の統計情報を消去するには、次のいずれかの作業を行います。

 

コマンド
目的

clear isis [ vrf vrf-name ] [instance-tag] adjacency [ interface ] [ system-ID ]

IS-IS 隣接関係の統計情報を消去します。

clear isis [ vrf vrf-name ] [ instance-tag ] statistics [ interface ]

IS-IS インターフェイスの統計情報を消去します。

clear isis [ vrf vrf-name ] [ ip | ipv4 ] route-map statistics redistribute { bgp id | direct | eigrp id | isis id | ospf id | rip id | static }

IS-IS 再配布の統計情報を消去します。

clear isis [ vrf vrf-name ] route-map statistics distribute { level-1 | level-2 } into { level-1 | level-2 }}

レベル間で配布されたルートに関する、IS-IS 配布統計情報を消去します。

IS-IS の設定例

[手順詳細の表で使用したコマンド例と整合する設定例を作成]

IS-IS の設定例を示します。

router isis Enterprise
is-type level-1
net 49.0001.0000.0000.0003.00
graceful-restart
 
interface Loopback0
passive
address-family ipv4 unicast
 
interface POS0/3/0/1
hello-password text encrypted 05080F1C2243
address-family ipv4 unicast

関連項目

ルート マップの詳細については、 第 14 章「Route Policy Manager の設定」 を参照してください。

デフォルト設定

表8-1 に、IS-IS パラメータのデフォルト設定を示します。

 

表8-1 デフォルトの IS-IS パラメータ

パラメータ
デフォルト

管理ディスタンス

115

エリア レベル

level-1-2

DIS プライオリティ

64

グレースフル リスタート

イネーブル

hello 回数

3

hello 埋め込み

イネーブル

hello タイム

10 秒

IS-IS 機能

ディセーブル

LSP インターバル

33

LSP MTU

1492

LSP 最大ライフタイム

1200 秒

最大パス数

4

メトリック

10

基準帯域幅

40 Gbps

その他の関連資料

IS-IS の実装に関連する詳細情報については、次の項を参照してください。

「関連資料」

「規格」

関連資料

 

関連項目
マニュアル名

IS-IS CLI コマンド

Cisco NX-OS Command Line Reference

VDC および VRF

Cisco NX-OS Virtual Device Contexts Configuration Guide

規格

 

規格
タイトル

この機能がサポートする新しい規格または変更された規格はありません。また、この機能で変更された既存規格のサポートはありません。

--