Cisco NX-OS Unicast Routing コンフィギュレーション ガイド Release 4.0
EIGRP の設定
EIGRP の設定
発行日;2012/01/13 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

EIGRP の設定

EIGRP について

EIGRP のコンポーネント

Reliable Transport Protocol

近隣探索および近隣回復

DUAL

EIGRP ルート更新

内部ルート メトリック

外部ルート メトリック

EIGRP とユニキャスト RIB

高度な EIGRP

認証

スタブ ルータ

ルート集約

ルート再配布

ロード バランシング

スプリット ホライズン

仮想化のサポート

グレースフル リスタートとハイ アベイラビリティ

EIGRP のライセンス要件

EIGRP の前提条件

設定時の注意事項および制約事項

基本的 EIGRP の設定

EIGRP 機能のイネーブル化

EIGRP インスタンスの作成

EIGRP インスタンスの再起動

EIGRP インスタンスのディセーブル化

インターフェイスでの EIGRP のディセーブル化

高度な EIGRP の設定

EIGRP での認証の設定

EIGRP スタブ ルーティングの設定

EIGRP の集約アドレスの設定

EIGRP へのルート再配布

EIGRP でのロード バランシングの設定

EIGRP のグレースフル リスタートの設定

hello パケットの間隔と保留時間の調整

スプリット ホライズンのディセーブル化

EIGRP の調整

EIGRP の仮想化の設定

EIGRP 設定の確認

EIGRP 統計情報の表示

EIGRP 設定の例

関連資料

デフォルト設定

その他の関連資料

関連資料

EIGRP の設定

この章では、Enhanced Interior Gateway Routing Protocol( EIGRP )を設定する方法について説明します。

ここでは、次の内容を説明します。

「EIGRP について」

「EIGRP のライセンス要件」

「EIGRP の前提条件」

「設定時の注意事項および制約事項」

「基本的 EIGRP の設定」

「高度な EIGRP の設定」

「高度な EIGRP の設定」

「EIGRP 統計情報の表示」

「EIGRP 設定の例」

「デフォルト設定」

「その他の関連資料」

EIGRP について

EIGRP は、リンクステート プロトコルの機能にディスタンス ベクトル プロトコルの利点を組み合わせたプロトコルです。EIGRP は、定期的に Hello メッセージを送信して近隣探索を行います。EIGRP は、新規ネイバーを検出すると、すべてのローカル EIGRP ルートおよびルート メトリックに対する一回限りの更新を送信します。受信側の EIGRP ルータは、受信したメトリックと、その新規ネイバーにローカルで割り当てられたリンクのコストに基づいて、ルート ディスタンスを計算します。この最初の全面的なルーティング テーブルの更新後は、ルート変更の影響を受けるネイバーにのみ、差分更新が EIGRP により送信されます。この処理により、収束にかかる時間が短縮され、EIGRP が使用する帯域幅が最小限になります。

ここでは、次の内容について説明します。

「EIGRP のコンポーネント」

「EIGRP ルート更新」

「高度な EIGRP」

EIGRP のコンポーネント

EIGRP には、次の基本コンポーネントがあります。

「Reliable Transport Protocol」

「近隣探索および近隣回復」

「DUAL」

Reliable Transport Protocol

リライアブル トランスポート プロトコル により、すべてのネイバーへの EIGRP パケットの配信が保証されます。(近隣探索および近隣回復 を参照)。Reliable Transport Protocol は、マルチキャスト パケットとユニキャスト パケットの混合伝送をサポートしています。高信頼性転送では、未確認パケットが保留されているときにも、マルチキャスト パケットの迅速な送信が可能です。この方式により、さまざまな速度のリンクでも短い収束時間が維持されるようになります。マルチキャスト パケットとユニキャスト パケットの送信を制御するデフォルト タイマーの変更の詳細については、「高度な EIGRP の設定」を参照してください。

Reliable Transport Protocol には、次のメッセージ タイプが含まれます。

Hello ― 近隣探索および近隣回復に使用されます。EIGRP はデフォルトでは、定期的なマルチキャスト Hello メッセージをローカル ネットワーク上に、設定された hello インターバル で送信します。デフォルトの hello 間隔は 5 秒です。

確認 ― 更新、照会、返信を確実に受信したことを確認します。

更新 ― ルーティング情報が変更されると、その影響を受けるネイバーに送信されます。更新には、ルートの宛先、アドレス マスク、および遅延や帯域幅などのルート メトリックが含まれます。更新情報は EIGRP トポロジ テーブルに格納されます。

照会および返信 ― 必要に応じて、EIGRP が使用する DUAL の一部として送信されます。

近隣探索および近隣回復

EIGRP は、Reliable Transport Protocol からの Hello メッセージを使用して、直接接続されたネットワーク上の隣接 EIGRP ルータを探索します。EIGRP により、ネイバー テーブルにネイバーが追加されます。ネイバー テーブルの情報には、ネイバーのアドレス、ネイバーが認識されたインターフェイス、および、ネイバーが到達不能であると宣言するまでの EIGRP の待機時間である ホールド タイム が含まれます。デフォルトの保留時間は、hello 間隔の 3 倍または 15 秒です。

EIGRP は、ローカル EIGRP ルーティング情報を共有するために、一連の更新メッセージを新規ネイバーに送信します。このルート情報は EIGRP トポロジ テーブルに格納されます。このように EIGRP ルート情報全体を最初に送信したあとは、ルーティングが変更されたときにのみ、EIGRP により更新メッセージが送信されます。これらの更新メッセージは新情報または更新情報のみを含んでおり、変更の影響を受けるネイバーにのみ送信されます。「EIGRP ルート更新」を参照してください。

EIGRP はネイバーへのキープアライブとして、Hello メッセージも使用します。Hello メッセージを受信している限り、Cisco DC-OS は、ネイバーがダウンせずに機能していると判定します。

DUAL

Diffusing アップデート アルゴリズム (DUAL)により、トポロジ テーブルの宛先ネットワークに基づいてルーティング情報が計算されます。トポロジ テーブルには、次の情報が含まれます。

IP アドレス/マスク ― この宛先のネットワーク アドレスおよびネットワーク マスク

サクセサ ― すべての フィージブル サクセッサ または、現在の フィージブル ディスタンス より短いディスタンスをアドバタイズするネイバーの IP アドレスおよびローカル インターフェイス接続

Feasibility Distance(FD; フィージビリティ ディスタンス) ― 計算された、宛先までの最短ディスタンス。FD は、ネイバーからアドバタイズされたディスタンスの合計に、そのネイバーまでのリンクのコストを加えた値です。

DUAL は、ディスタンス メトリックを使用して、ループが発生しない効率的なパスを選択します。DUAL はルートを選択し、フィージブル サクセサに基づいてユニキャスト Routing Information Base(RIB)に挿入します。トポロジが変更されると、DUAL は、トポロジ テーブルでフィージブル サクセサを探します。フィージブル サクセサが見つかった場合、DUAL は、最短のフィージブル ディスタンスを持つフィージブル サクセサを選択して、それをユニキャスト RIB に挿入します。これにより、再計算が不要となります。

フィージブル サクセサが存在しないが、宛先をアドバタイズするネイバーが存在する場合は、DUAL がパッシブ状態からアクティブ状態へと移行し、新しいサクセサまたは宛先へのネクストホップ ルータを決定する再計算をトリガーします。ルートの再計算に必要な時間は収束時間に影響します。EIGRP は照会メッセージをすべてのネイバーに送信し、フィージブル サクセサを探します。フィージブル サクセサを持つネイバーは、その情報を含む返信メッセージを送信します。フィージブル サクセサを持たないネイバーは、DUAL の再計算をトリガーします。

EIGRP ルート更新

トポロジが変更されると、EIGRP は、変更されたルーティング情報のみを含む更新メッセージを、影響を受けるネイバーに送信します。更新メッセージには、新規の、または更新されたネットワーク宛先へのディスタンス情報が含まれます。

EIGRP でのディスタンス情報は、帯域幅、遅延、負荷使用状況、リンクの信頼性などの使用可能なルート メトリックの組み合わせとして表現されます。各メトリックには重みが関連付けられており、これにより、メトリックがディスタンスの計算に含まれるかどうかが決定します。このメトリックの重みは設定するこができます。特性を微調整して最適なパスを完成することもできますが、設定可能なメトリックの大部分でデフォルト設定を使用することをお勧めします。

ここでは、次の内容について説明します。

「内部ルート メトリック」

「外部ルート メトリック」

「EIGRP とユニキャスト RIB」

内部ルート メトリック

内部ルートとは、同じ EIGRP Autonomous System(AS; 自律システム)内のネイバー間のルートです。これらのルートには、次のメトリックがあります。

ネクストホップ ― ネクストホップ ルータの IP アドレス

遅延 ― 宛先ネットワークへのルートを形成するインターフェイス上で設定された遅延の合計。10 マイクロ秒単位で設定されます。

帯域幅 ― 宛先へのルートの一部であるインターフェイスで設定された最小帯域幅から計算されます。


) デフォルト帯域幅の値の使用をお勧めします。この帯域幅パラメータは EIGRP でも使用されます。


MTU ― 宛先へのルート上の最大伝送単位の最小値

ホップ カウント ― 宛先までにルートが通過するホップまたはルータの数。このメトリックは、DUAL 計算で直接には使用されません。

信頼性 ― 宛先までのリンクの信頼性を示します。

負荷 ― 宛先までのリンク上のトラフィックの量を示します。

デフォルトで EIGRP は、帯域幅と遅延のメトリックを使用して、宛先までのディスタンスを計算します。計算に他のメトリックが含まれるよう、メトリックの重みを変更できます。

外部ルート メトリック

外部ルートとは、異なる EIGRP AS にあるネイバー間のルートです。これらのルートには、次のメトリックがあります。

ネクストホップ ― ネクストホップ ルータの IP アドレス

ルータ ID ― このルートを EIGRP に再配布したルータのルータ ID

AS 番号 ― 宛先の AS の番号

プロトコル ID ― 宛先へのルートを学習したルーティング プロトコルを表すコード

タグ ― ルートマップで使用可能な任意のタグ

メトリック ― 外部ルーティング プロトコルの、このルートのルート メトリック

EIGRP とユニキャスト RIB

EIGRP は、学習したルートをすべて、EIGRP トポロジ テーブルとユニキャスト RIB に追加します。トポロジが変更されると、EIGRP は、これらのルートを使用してフィージブル サクセサを探します。EIGRP は、他のルーティング プロトコルから EIGRP に再配布されたあらゆるルートの変更についてのユニキャスト RIB からの通知も待ち受けます。

高度な EIGRP

EIGRP の高度な機能を使用して、EIGRP の設定を最適化できます。

ここでは、次の内容について説明します。

「認証」

「スタブ ルータ」

「ルート集約」

「ルート再配布」

「ロード バランシング」

「スプリット ホライズン」

「仮想化のサポート」

「グレースフル リスタートとハイ アベイラビリティ」

認証

EIGRP メッセージに認証を設定して、ネットワークでの不正な、または無効なルーティング更新を防止できます。Cisco NX-OS は MD5 認証ダイジェストをサポートしています。

認証キーのキーチェーン管理を使用して、インターフェイスごとに EIGRP 認証を設定できます。キーチェーン管理を使用すると、MD5 認証ダイジェストが使用する認証キーへの変更を管理できます。キーチェーン作成の詳細については、『Cisco NX-OS Security Configuration Guide』を参照してください。

MD5 認証を行うには、ローカル ルータとすべてのリモート EIGRP ネイバーが共有するパスワードを設定します。EIGRP メッセージが作成されると、Cisco NX-OS は、そのメッセージ自体と暗号化されたパスワードに基づいて MD5 一方向メッセージ ダイジェストを作成し、このダイジェストを EIGRP メッセージとともに送信します。受信する EIGRP ネイバーは、同じ暗号化パスワードを使用して、このダイジェストを確認します。メッセージが変更されていない場合は計算が同一であるため、EIGRP メッセージは有効と見なされます。

MD5 認証には各 EIGRP メッセージのシーケンス番号も含まれており、これにより、ネットワークでのメッセージの再送が防止されます。

スタブ ルータ

EIGRP スタブ ルーティング機能を使用して、ネットワークの安定性を向上させ、リソースの使用を削減し、スタブ ルータ設定を簡素化することができます。スタブ ルータは、リモート ルータ経由で EIGRP ネットワークに接続します。「スタブ ルーティング」を参照してください。

EIGRP スタブ ルーティングを使用すると、EIGRP を使用するよう分散ルータとリモート ルータを設定し、リモート ルータのみをスタブとして設定する必要があります。EIGRP スタブ ルーティングで、分散ルータでの集約が自動的にイネーブルになるわけではありません。ほとんどの場合、分散ルータでの集約の設定が必要です。

EIGRP スタブ ルーティングを使用しない場合は、分散ルータからリモート ルータに送信されたルートがフィルタリングまたは集約された後でも、問題が発生することがあります。たとえば、ルートが企業ネットワーク内のどこかで失われた場合に、EIGRP が分散ルータに照会を送信することがあります。分散ルータは、ルートが集約されている場合でも、リモート ルータに照会を送信することがあります。分散ルータとリモート ルータの間の WAN リンク上の通信に問題が発生した場合は、EIGRP がアクティブ状態のままとなり、ネットワークの他の場所が不安定となる場合があります。EIGRP スタブ ルーティングを使用すると、リモート ルータに照会が送信されなくなります。

ルート集約

指定したインターフェイスに集約アドレスを設定できます。ルート集約により、多くのより具体的なアドレスが、すべての具体的なアドレスを表す 1 つのアドレスに置き換えられるため、ルーティング テーブルが簡素化されます。たとえば、10.1.1.0/24、10.1.2.0/24、および 10.1.3.0/24 というアドレスを 1 つの集約アドレス 10.1.0.0/16 に置き換えることができます。

より具体的なアドレスがルーティング テーブルにある場合、EIGRP は、より具体的なルートの最小メトリックに等しいメトリックを持つインターフェイスからの集約アドレスをアドバタイズします。


) Cisco NX-OS は、自動ルート集約をサポートしていません。


ルート再配布

EIGRP を使用して、スタティック ルート、他の EIGRP AS から学習したルート、または他のプロトコルからのルートを再配布できます。再配布を含むルート ポリシーを設定して、どのルートが EIGRP に渡されるかを制御します。ルート ポリシーを使用すると、宛先、送信元プロトコル、ルート タイプ、ルート タグなどの属性に基づいて、ルートをフィルタリングできます。 第 14 章「Route Policy Manager の設定」 を参照してください。

インポートされた EIGRP へのすべてのルートに使用されるデフォルト メトリックも設定できます。

ロード バランシング

ロード バランシングを使用すると、ルータが、宛先アドレスから同じディスタンスのすべてのルータ ネットワーク ポートにトラフィックを配布することが可能になります。ロード バランシングにより、ネットワーク セグメントの使用率が向上し、それによってネットワーク帯域幅の効率も向上します。

Cisco NX-OS は、EIGRP ルーティング テーブルおよびユニキャスト RIB 中の 16 までの等コスト パスを使用する Equal Cost Multiple Path(ECMP; 等コスト マルチパス)機能をサポートしています。これらのパスの一部または全部に対してトラフィックのロード バランシングを行うよう、EIGRP を設定できます。

スプリット ホライズン

スプリット ホライズンを使用して、EIGRP が、ルートを伝えたインターフェイスからそのルートをアドバタイズしないようにすることができます。

スプリット ホライズンは、EIGRP 更新パケットおよび EIGRP 照会パケットの送信を制御する方式です。インターフェイスでスプリット ホライズンをイネーブルにすると、Cisco NX-OS は、このインターフェイスから学習された宛先への更新パケットも照会パケットも送信しません。この方法で更新パケットと照会パケットを制御すると、ルーティング ループが発生する可能性が低下します。

ポイズン リバースによるスプリット ホライズンにより、EIGRP は、EIGRP がルートを学習したインターフェイス経由で、そのルートを到達不能としてアドバタイズするよう設定されます。

EIGRP は、次のシナリオでスプリット ホライズン、またはポイズン リバースによるスプリット ホライズンを使用します。

スタートアップ モードで、2 台のルータ間で初めてトポロジ テーブルを交換する。

トポロジ テーブルの変更をアドバタイズする。

照会メッセージを送信する。

デフォルトでは、スプリット ホライズン機能がすべてのインターフェイスでイネーブルになっています。

仮想化のサポート

Cisco NX-OS は、同じシステム上で動作する、EIGRP プロトコルの複数インスタンスをサポートしています。EIGRP は、Virtual Routing and Forwarding Instance(VRF; 仮想ルーティング/転送インスタンス)をサポートしています。VRF は Virtual Device Contexts(VDC; 仮想化デバイス コンテキスト)内にあります。デフォルトでは、特に別の VDC および VRF を設定しない限り、Cisco NX-OS によりデフォルト VDC およびデフォルト VRF が使用されます。詳細については、『 Cisco NX-OS Virtual Device Context Configuration Guide 』および 第 13 章「レイヤ 3 仮想化の設定」 を参照してください。

デフォルトでは、すべてのインスタンスが同じシステム ルータ ID を使用します。複数のインスタンスが同じ EIGRP AS にある場合は、各インスタンスのルータ ID を手動で設定する必要があります。

グレースフル リスタートとハイ アベイラビリティ

Cisco NX-OS は、EIGRP の Nonstop Forwarding(NSF)とグレースフル リスタートをサポートしています。

EIGRP の NSF を使用すると、フェールオーバー後に EIGRP ルーティング プロトコル情報が復元される間に、データ パケットを FIB 内の既存のルートで転送できます。NSF では、ピア ネットワーキング デバイスにルーティング フラップが発生しません。フェールオーバー中は、スタンバイ スーパーバイザがアクティブになる間に、データ トラフィックがインテリジェント モジュール経由で転送されます。

Cisco NX-OS システムでコールド リブートが発生した場合、ネットワークはシステムにトラフィックを転送せず、システムをネットワーク トポロジから削除します。このシナリオでは、EIGRP でステートレス リスタートが行われ、すべてのネイバーは削除されます。Cisco NX-OS はスタートアップ コンフィギュレーションを適用し、EIGRP は再度近隣探索を行い、EIGRP ルーティング情報全体を再度共有します。

Cisco NX-OS を実行するデュアル スーパーバイザ プラットフォームでは、ステートフル スーパーバイザ スイッチオーバーが発生する場合があります。このスイッチオーバーが発生する前に、EIGRP はグレースフル リスタートを使用して、EIGRP がしばらく使用不可であることを宣言します。スイッチオーバー中に EIGRP は NSF を使用して、FIB 中の情報に基づいてトラフィックの転送を続行します。また、システムはネットワーク トポロジから排除されません。

グレースフル リスタート対応のルータは、Hello メッセージを使用して、そのネイバーにグレースフル リスタート動作が開始されたことを通知します。グレースフル リスタート認識ルータがグレースフル リスタート対応のネイバーから、グレースフル リスタート動作が進行中であるという通知を受信すると、両方のルータはただちにそのトポロジ テーブルを交換します。グレースフル リスタート認識ルータは、その後、次の動作を行って再起動中のルータを支援します。

ルータは EIGRP Hello 保留タイマーを時間切れにして、設定された Hello メッセージの時間間隔を短縮します。これにより、グレースフル リスタート認識ルータが再起動中のルータにすばやく返信できるようになり、再起動中のルータが再度近隣探索を行って、トポロジを再構築するために必要な時間が短縮されます。

ルータは、ルート保留タイマーを開始します。このタイマーで、グレースフル リスタート認識ルータが、再起動中のルータのために既知のルートを保留する時間の長さが設定されます。デフォルトの時間は 240 秒です。

ルータはピア リストに隣接ルータが再起動中であることを記し、隣接関係を維持します。また、再起動中の隣接ルータが、グレースフル リスタート認識ルータから送信されるトポロジ テーブルを受信可能であるという合図をするか、ルート保留タイマーが切れるまで、ルートを保留します。グレースフル リスタート認識ルータでルート保留タイマーが切れた場合は、グレースフル リスタート認識ルータは保留ルートを廃棄し、再起動中のルータをネットワークに追加された新規ルータとして取り扱い、隣接関係を再度確立します。

スイッチオーバー後に、Cisco NX-OS は実行コンフィギュレーションを適用し、EIGRP は、自身が再び稼働していることをネイバーに通知します。


) グレースフル リスタートでは、EIGRP の In-Service Software Upgrade(ISSU; インサービス ソフトウェア アップグレード)のサポートをイネーブルにする必要があります。グレースフル リスタートをディセーブルにした場合は、Cisco NX-OS により、この設定では ISSU をサポートできないという警告が発行されます。


EIGRP のライセンス要件

次の表は、この機能のライセンス要件を示します。

 

製品
ライセンス要件

NX-OS

EIGRP には Enterprise Services ライセンスが必要です。NX-OS ライセンス方式の詳細説明およびライセンスの入手と適用の方法については、『 Cisco NX-OS Licensing Guide 』を参照してください。

EIGRP の前提条件

EIGRP には、次の前提条件があります。

EIGRP 機能がイネーブルにされている(EIGRP 機能のイネーブル化を参照)。

VDC を設定する場合は、Advanced Services ライセンスをインストールし、目的の VDC を入力します(『 Cisco NX-OS Virtual Device Context Configuration Guide 』を参照)。

設定時の注意事項および制約事項

EIGRP 設定時の注意事項および制約事項は次のとおりです。

他のプロトコル、接続されたルータ、またはスタティック ルートからの再配布には、メトリック設定(デフォルト メトリック設定オプションまたはルート ポリシーによる)が必要です( 第 14 章「Route Policy Manager の設定」 を参照)。

グレースフル スタートについては、NSF 認識ルータが動作中であり、ネットワークで完全に収束している場合にのみ、このルータが NSF 対応ルータのグレースフル リスタート動作を支援できます。

グレースフル リスタートについては、グレースフル リスタートに関与する隣接デバイスが NSF 認識または NSF 対応である必要があります。

Cisco NX-OS EIGRP には Cisco IOS の EIGRP との互換性があります。

妥当な理由がない限り、メトリックの重みを変更しないでください。メトリックの重みを変更した場合は、同じ AS 内のすべての EIGRP ルータに、それを適用する必要があります。

大規模ネットワークの場合は、スタブの使用を検討してください。

EIGRP ベクトル メトリックは維持されないため、異なる EIGRP AS 間での再配布は避けてください。

no ip next-hop-self コマンドでは、ネクストホップへの到達可能性は保証されていません。

ip passive-interface eigrp コマンドを使用すると、ネイバーが形成されなくなります。

Cisco NX-OS は IGRP も、IGRP および EIGRP クラウドの接続もサポートしていません。

自動集約は、デフォルトではイネーブルにされていません。

Cisco NX-OS は IP のみをサポートしています。


) Cisco IOS CLI の詳しい知識がある場合は、この機能で使用する Cisco NX-OS コマンドが、よく使用される Cisco IOS コマンドとは異なる可能性があることに注意してください。


基本的 EIGRP の設定

ここでは、次の内容について説明します。

「EIGRP 機能のイネーブル化」

「EIGRP インスタンスの作成」

「EIGRP インスタンスの再起動」

「EIGRP インスタンスのディセーブル化」

「インターフェイスでの EIGRP のディセーブル化」

EIGRP 機能のイネーブル化

EIGRP を設定するには、その前に EIGRP 機能をイネーブルにする必要があります。

操作の前に

正しい VDC を使用していることを確認します(または、 switchto vdc コマンドを使用します)。

コマンドの一覧

1. config t

2. feature eigrp

3. copy running-config startup-config

詳細な手順

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

feature eigrp

 

switch(config)# feature eigrp

EIGRP 機能をイネーブルにします。

ステップ 3

copy running-config startup-config

 

switch(config)# copy running-config startup-config

(任意)この設定変更を保存します。

EIGRP 機能をディセーブルにし、関連付けられた設定をすべて削除するには、 no feature eigrp コマンドを使用します。

 

コマンド
目的

no feature eigrp

 

switch(config)# no feature eigrp

EIGRP 機能をディセーブルにして、関連付けられたコンフィギュレーションをすべて削除します。

EIGRP インスタンスの作成

EIGRP インスタンスを作成して、そのインスタンスにインターフェイスを関連付けることができます。この EIGRP プロセスに一意の AS 番号を割り当てます( 自律システムを参照)。ルート再配布をイネーブルにしていない限り、外部 AS からルートがアドバタイズされることも、受信されることもありません。

操作の前に

EIGRP 機能がイネーブルにされていることを確認します(EIGRP 機能のイネーブル化を参照)。

EIGRP がルータ ID(設定済みのループバック アドレスなど)を入手可能であるか、またはルータ ID オプションを設定する必要があります。

正しい VDC を使用していることを確認します(または、 switchto vdc コマンドを使用します)。

コマンドの一覧

1. config t

2. router eigrp as-number

3. <configure optional parameters>

4. interface interface-type slot/port

5. ip router eigrp as-number

6. show ip eigrp interfaces

7. copy running-config startup-config

詳細な手順

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router eigrp as-number

 

switch(config)# router eigrp 201

switch(config-router)#

新しい EIGRP プロセスを作成し、それに AS 番号を設定します。

ステップ 3

eigrp router-id ip-address

 

switch(config-router)# eigrp router-id 192.0.2.1

(任意)EIGRP ルータ ID を設定します。この IP アドレスにより、この EIGRP インスタンスが識別されます。このアドレスは、システムの設定済みインターフェイス上に存在する必要があります。

router-id ip-address

 

switch(config-router)# router-id 192.0.2.1

(任意)EIGRP ルータ ID を設定します。このコマンドは、 eigrp router-id コマンドと同じです。

ステップ 4

eigrp log-neighbor-changes

 

switch(config-router)# eigrp log-neighbor-changes

(任意)ネイバーの状態が変化するたびに、システム メッセージを生成します。このコマンドは、デフォルトでイネーブルにされています。

ステップ 5

eigrp log-neighbor-warnings [ seconds]

 

switch(config-router)# eigrp log-neighbor-warnings

(任意)ネイバー警告が発生するたびに、システム メッセージを生成します。警告メッセージの時間間隔を、1 ~ 65535 の秒数で設定できます。デフォルト値は 10 秒です。このコマンドは、デフォルトでイネーブルにされています。

ステップ 6

interface interface-type slot/port

 

switch(config-router)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 7

ip router eigrp as-number

 

switch(config-if)# ip router eigrp 201

このインターフェイスを、設定された EIGRP プロセスに関連付けます。

ステップ 8

show ip eigrp interfaces

 

switch(config-if)# show ip eigrp interfaces

EIGRP インターフェイスに関する情報を表示します。

ステップ 9

copy running-config startup-config

 

switch(config)# copy running-config startup-config

(任意)この設定変更を保存します。

EIGRP プロセスと、関連付けられた設定を削除するには、 no router eigrp コマンドを使用します。

 

コマンド
目的

no router eigrp as-number

 

switch(config)# no router eigrp 201

EIGRP プロセスと、関連付けられたすべての設定を削除します。


) インターフェイス モードで設定された EIGRP コマンドもすべて、手動で削除する必要があります。


次に、EIGRP プロセスを作成し、EIGRP のインターフェイスを設定する例を示します。

switch# config t

switch(config)# router eigrp 201

switch(config)# i nterface ethernet 1/2

switch(config-if)# ip router eigrp 201

switch(config-if)# no shutdown

switch(config-if)# copy running-config startup-config

 

その他の EIGRP パラメータの詳細については、「高度な EIGRP の設定」を参照してください。

EIGRP インスタンスの再起動

EIGRP インスタンスを再起動できます。再起動すると、インスタンスのすべてのネイバーが解消されます。

EIGRP インスタンスを再起動して、関連付けられたすべてのネイバーを削除するには、次のコマンドを使用します。

 

コマンド
目的

restart eigrp instance-tag

 

switch(config)# restart eigrp 201

EIGRP インスタンスを再起動して、すべてのネイバーを削除します。

EIGRP インスタンスのディセーブル化

EIGRP インスタンスをディセーブルにするには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

switch(config-router)# shutdown

 

switch(config-router)# shutdown

この EIGRP インスタンスをディセーブルにします。

インターフェイスでの EIGRP のディセーブル化

インターフェイスで EIGRP をディセーブルにするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

switch(config-if)# ip eigrp as-numver shutdown

 

switch(config-router)# ip eigrp 201 shutdown

このインターフェイスで EIGRP をディセーブルにします。

高度な EIGRP の設定

ここでは、次の内容について説明します。

「EIGRP での認証の設定」

「EIGRP スタブ ルーティングの設定」

「EIGRP の集約アドレスの設定」

「EIGRP へのルート再配布」

「EIGRP でのロード バランシングの設定」

「EIGRP のグレースフル リスタートの設定」

「hello パケットの間隔と保留時間の調整」

「スプリット ホライズンのディセーブル化」

「EIGRP の調整」

「EIGRP の仮想化の設定」

EIGRP での認証の設定

EIGRP のネイバー間での認証を設定できます。「認証」を参照してください。

操作の前に

EIGRP 機能がイネーブルにされていることを確認します(EIGRP 機能のイネーブル化を参照)。

EIGRP プロセスのすべてのネイバーが、共有認証キーを含め、同じ認証設定を共有することを確認します。

この認証設定のキーチェーンを作成します。詳細については『 Cisco NX-OS Security Configuration Guide 』を参照してください。

正しい VDC を使用していることを確認します(または、 switchto vdc コマンドを使用します)。

コマンドの一覧

1. config t

2. router eigrp as-number

3. interface interface-type slot/port

4. ip router eigrp as-number

5. ip authentication key-chain eigrp as-number key-chain

6. ip authentication mode eigrp as-number md5

7. copy running-config startup-config

詳細な手順

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router eigrp as-number

 

switch(config)# router eigrp 201

switch(config-router)#

新しい EIGRP プロセスを作成し、それに AS 番号を設定します。

ステップ 3

interface interface-type slot/port

 

switch(config)interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip router eigrp as-number

 

switch(config-if)# ip router eigrp 201

このインターフェイスを、設定された EIGRP プロセスに関連付けます。

ステップ 5

ip authentication key-chain eigrp as-number key-chain

 

switch(config-if)# ip authentication key-chain eigrp 201 routeKeys

このインターフェイスの EIGRP プロセスにキーチェーンを関連付けます。

ステップ 6

ip authentication mode eigrp as-number md5

 

switch(config-if)# ip authentication mode eigrp 201 md5

このインターフェイスの MD5 メッセージ ダイジェスト認証モードを設定します。

ステップ 7

copy running-config startup-config

 

switch(config)# copy running-config startup-config

(任意)この設定変更を保存します。

次に、EIGRP の MD5 メッセージ ダイジェスト認証をイーサネット インターフェイス 1/2 上で設定する例を示します。

switch# config t

switch(config)# router eigrp 201

switch(config-router)# exit

switch(config)# interface ethernet 1/2

switch(config-if)# ip router eigrp 201

switch(config-if)# ip authentication key-chain eigrp 201 routeKeys

switch(config-if)# ip authentication mode eigrp 201 md5

switch(config-if)# copy running-config startup-config

 

EIGRP スタブ ルーティングの設定

ルータで EIGRP スタブ ルーティングを設定するには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

switch(config-router)# eigrp stub [ leak-map map-name | receive-only | redistributed [ direct ]]

 

switch(config-router)# eigrp stub redistributed

リモート ルータを EIGRP スタブ ルータとして設定します。

次に、直接接続され、再配布されるルートをアドバタイズするスタブ ルータを設定する例を示します。

switch# config t

switch(config)# router eigrp 201

switch(config-router)# eigrp stub direct redistributed

switch(config-router)# copy running-config startup-config

 

ルータがスタブ ルータとして設定されていることを確認するには、show ip eigrp neighbor detail コマンドを使用します。出力の最後の行は、リモート ルータまたはスポーク ルータのスタブ ステータスを示します。次に、 show ip eigrp neighbor detail コマンドの出力例を示します。

Router# show ip eigrp neighbor detail
IP-EIGRP neighbors for process 201
H Address Interface Hold Uptime SRTT RTO Q Seq Type
(sec) (ms) Cnt Num
0 10.1.1.2 Se3/1 11 00:00:59 1 4500 0 7
Version 12.1/1.2, Retrans: 2, Retries: 0
Stub Peer Advertising ( CONNECTED SUMMARY ) Routes
 

EIGRP の集約アドレスの設定

指定したインターフェイスに集約アドレスを設定できます。より具体的なアドレスがルーティング テーブルにある場合、EIGRP は、より具体的なすべてのルートの最小メトリックに等しいメトリックを持つインターフェイスからの集約アドレスをアドバタイズします。「ルート集約」を参照してください。

集約アドレスを設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

switch(config-if)# ip summary-address eigrp as-number ip-prefix/length [ distance | leak-map map-name ]

 

switch(config-if)# ip summary-address eigrp 201 209.0.2.0/8

集約アドレスを、IP アドレスとネットワーク マスク、または IP プレフィクス/長さとして設定します。また、この集約アドレスの管理ディスタンスを設定することもできます。集約アドレスのデフォルト管理ディスタンスは 5 です。

次に、EIGRP によりネットワーク 209.0.2.0 がイーサネット 1/2 のみに集約される用にする例を示します。

switch(config)# interface ethernet 1/2
switch(config-if)# ip summary-address eigrp 201 209.0.2.0 255.255.255.0

EIGRP へのルート再配布

他のルーティング プロトコルから EIGRP にルートを再配布できます。

操作の前に

EIGRP 機能がイネーブルにされていることを確認します(EIGRP 機能のイネーブル化を参照)。

他のプロトコルから再配布されるルートには、メトリック(デフォルト メトリック設定オプションまたはルート ポリシーによる)を設定する必要があります。

ルートマップを作成して、EIGRP に再配布されるルートのタイプを管理する必要があります。 第 14 章「Route Policy Manager の設定」 を参照してください。

正しい VDC を使用していることを確認します(または、 switchto vdc コマンドを使用します)。

コマンドの一覧

1. config t

2. router eigrp as-number

3. redistribute {{ bgp | eigrp | isis | ospf | rip } as-number | direct | static } route-map name

4. default-metric bandwidth delay reliability loading mtu

5. show ip eigrp policy statistics redistribute

6. copy running-config startup-config

詳細な手順

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router eigrp as-number

 

switch(config)# router eigrp 201

switch(config-router)#

新しい EIGRP プロセスを作成し、それに AS 番号を設定します。

ステップ 3

redistribute {{ bgp | eigrp | isis | ospf | rip } as-number | direct | static } route-map name

 

switch(config-router)# redistribute bgp 100 route-map BGPFilter

1 つのルーティング ドメインから EIGRP にルートを注入します。

ステップ 4

default-metric bandwidth delay reliability loading mtu
 

switch(config-router)# default-metric 500000 30 200 1 1500

ルート再配布で学習したルートに割り当てられるメトリックを設定します。デフォルト値は次のとおりです。

bandwidth ― 100000 kbps

delay ― 100(10 マイクロ秒単位)

reliability ― 255

loading ― 1

MTU ― 1500

ステップ 5

show ip eigrp policy statistics redistribute

 

switch(config-router)# show ip eigrp policy statistics redistribute bgp

EIGRP ポリシー統計に関する情報を表示します。

ステップ 6

copy running-config startup-config

 

switch(config)# copy running-config startup-config

(任意)この設定変更を保存します。

次に、BGP を EIGRP に再配布する例を示します。

switch# config t

switch(config)# router eigrp 201

switch(config-router)# redistribute bgp 100 route-map BGPFilter

switch(config-router)# default-metric 500000 30 200 1 1500

switch(config-router)# copy running-config startup-config

 

EIGRP でのロード バランシングの設定

EIGRP でのロード バランシングを設定できます。最大パス オプションを使用して、ECMP ルートの数を設定できます。「EIGRP でのロード バランシングの設定」を参照してください。

操作の前に

EIGRP 機能がイネーブルにされていることを確認します(EIGRP 機能のイネーブル化を参照)。

正しい VDC を使用していることを確認します(または、 switchto vdc コマンドを使用します)。

コマンドの一覧

1. config t

2. router eigrp as-number

3. maximum-paths num-paths

4. copy running-config startup-config

詳細な手順

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router eigrp as-number

 

switch(config)# router eigrp 201

switch(config-router)#

新しい EIGRP プロセスを作成し、それに AS 番号を設定します。

ステップ 3

maximum-paths num-paths

 

switch(config-router)# maximum-paths 5

EIGRP がルーティング テーブルに受け入れる等コスト パスの数を設定します。有効値の範囲は 1 ~ 16 であり、デフォルトは 16 です。

ステップ 4

copy running-config startup-config

 

switch(config-router)# copy running-config startup-config

(任意)この設定変更を保存します。

次に、6 つまでの等コストパスによる、EIGRP の等コスト ロード バランシングを設定する例を示します。

switch# config t

switch(config)# router eigrp 201

switch(config-router)# maximum-paths 6

switch(config-router)# copy running-config startup-config

 

EIGRP のグレースフル リスタートの設定

EIGRP のグレースフル リスタートまたは NSF を設定できます。「グレースフル リスタートとハイ アベイラビリティ」を参照してください。


) この機能を使用するには、NSF とグレースフル リスタートをイネーブルにする必要があります。


操作の前に

EIGRP 機能がイネーブルにされていることを確認します(EIGRP 機能のイネーブル化を参照)。

NSF 認識ルータが動作中であり、ネットワークで完全に収束している場合にのみ、このルータが NSF 対応ルータのグレースフル リスタート動作を支援できます。

グレースフル リスタートに関与する隣接デバイスが NSF 認識または NSF 対応である必要があります。

正しい VDC を使用していることを確認します(または、 switchto vdc コマンドを使用します)。

コマンドの一覧

1. config t

2. router eigrp as-number

3. nsf

4. eigrp graceful-restart

5. timers nsf converge seconds

6. timers nsf route-hold seconds

7. timers nsf signal seconds

8. copy running-config startup-config

詳細な手順

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router eigrp as-number

 

switch(config)# router eigrp 201

switch(config-router)#

新しい EIGRP プロセスを作成し、それに AS 番号を設定します。

ステップ 3

nsf

 

switch(config-router)# nsf

NSF をイネーブルにします。この機能は、デフォルトでイネーブルにされています。

ステップ 4

eigrp graceful-restart

 

switch(config-router)# graceful-restart

グレースフル リスタートをイネーブルにします。この機能は、デフォルトでイネーブルにされています。

ステップ 5

timers nsf converge seconds

 

switch(config-router)# timers nsf converge 100

スイッチオーバー後に収束するまでの制限時間を設定します。有効値の範囲は 60 ~ 180 秒です。デフォルト値は 120 です。

ステップ 6

timers nsf route-hold seconds

 

switch(config-router)# timers nsf route-hold 200

グレースフル リスタート認識ピアから学習したルートの保留時間を設定します。有効値の範囲は 20 ~ 300 秒です。デフォルト値は 240 です。

ステップ 7

timers nsf signal seconds

 

switch(config-router)# timers nsf signal 15

グレースフル リスタートの信号を送信する時間制限を設定します。有効値の範囲は 10 ~ 30 秒です。デフォルトでは 20 秒です。

ステップ 8

copy running-config startup-config

 

switch(config-router)# copy running-config startup-config

(任意)この設定変更を保存します。

次に、デフォルト タイマー値を使用してグレースフル リスタートを設定する例を示します。

switch# config t

switch(config)# router eigrp 201

switch(config-router)# nsf

switch(config-router)# graceful-restart

switch(config-router)# copy running-config startup-config

 

hello パケットの間隔と保留時間の調整

各 Hello メッセージの間隔と保留時間を調整できます。

デフォルトでは、5 秒ごとに Hello メッセージが送信されます。保留時間は Hello メッセージでアドバタイズされ、送信者が有効であると見なすまでの時間をネイバーに示します。デフォルトの保留時間は、hello 間隔の 3 倍または 15 秒です。

hello パケットの間隔を変更するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

switch(config-if)# ip hello-interval eigrp as-number seconds

EIGRP ルーティング処理の hello 間隔を設定します。有効値の範囲は 1 ~ 65535 秒であり、デフォルトは 5 です。

非常に混雑した大規模ネットワークでは、一部のルータが、デフォルト保留時間内にネイバーから hello パケットを受信できない可能性があります。この場合は、保留時間を増やすことをお勧めします。

保留時間を変更するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

switch(config-if)# ip hold-time eigrp autonomous-system-number seconds

EIGRP ルーティング処理の保留時間を設定します。有効値の範囲は 1 ~ 65535 です。

タイマー設定を確認するには、 show ip eigrp interface detail コマンドを使用します。

スプリット ホライズンのディセーブル化

スプリット ホライズンを使用して、ルート情報がルータにより、その情報の送信元インターフェイスの外部にアドバタイズされないようにすることができます。通常はスプリット ホライズンにより、特にリンクに障害がある場合に、複数のルーティング デバイス間での通信が最適化されます。

デフォルトでは、スプリット ホライズンがすべてのインターフェイスでイネーブルにされています。

スプリット ホライズンをディセーブルにするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

switch(config-if)# no ip split-horizon eigrp as-number

スプリット ホライズンをディセーブルにします。

EIGRP の調整

省略可能なパラメータを設定して、EIGRP をネットワークに合わせて調整できます。

ルータ コンフィギュレーション モードで、省略可能な次のパラメータを設定できます。

 

コマンド
目的
default-information originate [ always | route-map map-name ]
 

switch(config-router)# default-information originate always

プレフィクス 0.0.0.0/0 を持つデフォルト ルートを発信するか、受け入れます。ルートマップが提供されると、ルートマップが true 状態となっている場合にのみデフォルト ルートが発信されます。

distance internal external

 

switch(config-router)# distance 25 100

この EIGRP プロセスの管理ディスタンスを設定します。有効値の範囲は 1~ 255 です。内部の値で、同じ AS 内で学習したルートのディスタンスが設定されます(デフォルト値は 90 です)。外部の値で、外部 AS から学習したルートのディスタンスが設定されます(デフォルト値は 170 です)。

metric max-hops hop-count
 

switch(config-router)# metric max-hops 70

アドバタイズされるルートに許容される最大ホップ数を設定します。ホップ数がこの最大値を超えるルートは、到達不能としてアドバタイズされます。有効値の範囲は 1 ~ 255 であり、デフォルトは 100 です。

metric weights tos k1 k2 k3 k4 k5
 

switch(config-router)# metric weights 0 1 3 0 1 0

EIGRP メトリックまたは K 値を調整します。EIGRP は次の式を使用して、ネットワークへの合計メトリックを決定します。

metric = [k1*bandwidth + (k2*bandwidth)/(256 - load) + k3*delay] * [k5/(reliability + k4)]

デフォルト値と有効値範囲は、次のとおりです。

TOS ― 有効値の範囲は 0 ~ 8 です。

k1 ― 1。有効値の範囲は 1 ~ 255 です。

k2 ― 0。有効値の範囲は 0 ~ 255 です。

k3 ― 1。有効値の範囲は 1 ~ 255 です。

k4 ― 0。有効値の範囲は 0 ~ 255 です。

k5 ― 0。有効値の範囲は 0 ~ 255 です。

timers active-time { time-limit | disabled }

 

switch(config-router)# timers active-time 200.

(照会の送信後に)ルートがアクティブ(SIA)状態のままとなっていることを宣言するまでに、ルータが待機する時間を分単位で設定します。有効値の範囲は 1 ~ 65535 であり、デフォルトは 3 です。

インターフェイス コンフィギュレーション モードで、省略可能な次のパラメータを設定できます。

 

コマンド
目的

ip bandwidth eigrp as-number bandwidth

インターフェイス上の EIGRP の帯域幅メトリックを設定します。有効値の範囲は 1 ~ 10000000 kbpsです。

ip bandwidth-percent eigrp as-number percent

EIGRP がインターフェイス上で使用する可能性のある帯域幅のパーセンテージを設定します。デフォルトでは 50% です。

no ip delay eigrp as-number delay

インターフェイス上の EIGRP の遅延メトリックを設定します。有効値の範囲は 1 ~ 16777215(単位は 10 マイクロ秒)です。

ip distribute-list eigrp as-number
{ prefix-list name | route-map name} { in | out }

このインターフェイス上の EIGRP のルータ フィルタリング ポリシーを設定します。

no ip next-hop-self eigrp as-number

このインターフェイスのアドレスではなく、受信したネクストホップ アドレスを使用するよう、EIGRP を設定します。デフォルトでは、このインターフェイスの IP アドレスをネクストホップ アドレスに使用します。

ip offset-list eigrp as-number { prefix-list name | route-map name} { in | out } offset

EIGRP が学習したルートに、着信および発信メトリックへのオフセットを追加します。

ip passive-interface eigrp as-number

EIGRP インターフェイス上でルーティングが更新されないようにします。

EIGRP の仮想化の設定

各 VDC で複数の EIGRP プロセスを設定できます。各 VDC 内に複数の VRF を作成して、各 VRF で同じまたは複数の EIGRP プロセスを使用することもできます。VRF にはインターフェイスを割り当てます。


) インターフェイスの VRF を設定したあとに、インターフェイスの他のすべてのパラメータを設定します。インターフェイスの VRF を設定すると、そのインターフェイスの他の設定がすべて削除されます。


操作の前に

EIGRP 機能がイネーブルにされていることを確認します(EIGRP 機能のイネーブル化を参照)。

VDC と VRF を作成します。

正しい VDC を使用していることを確認します(または、 switchto vdc コマンドを使用します)。

コマンドの一覧

1. config t

2. vrf context vrf-name

3. router eigrp as-number

4. interface ethernet slot/port

5. vrf member vrf-id

6. ip-address ip-prefix/length

7. ip router eigrp as-number

8. copy running-config startup-config

詳細な手順

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

vrf context vrf-name

 

switch(config)# vrf context RemoteOfficeVRF

switch(config-vrf)#

新しい VRF を作成し、VRF コンフィギュレーション モードを開始します。

ステップ 3

router eigrp as-number

 

switch(config)# router eigrp 201

switch(config-router)#

新しい EIGRP プロセスを作成し、それに AS 番号を設定します。

ステップ 4

interface ethernet slot/port

 

switch(config)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 5

vrf member vrf-name

 

switch(config-if)# vrf member RemoteOfficeVRF

このインターフェイスを VRF に追加します。

ステップ 6

ip router eigrp as-number

 

switch(config-if)# ip router eigrp 201

このインターフェイスを EIGRP プロセスに追加します。

ステップ 7

copy running-config startup-config

 

switch(config-if)# copy running-config startup-config

(任意)この設定変更を保存します。

次に、VRF を作成して、その VRF にインターフェイスを追加する例を示します。

switch# config t

switch(config)# vrf context NewVRF

switch(config-vrf)# router eigrp 201

switch(config-router)# i nterface ethernet 1/2

switch(config-if)# ip router eigrp 201

switch(config-if)# vrf NewVRF

switch(config-if)# copy running-config startup-config

 

EIGRP 設定の確認

EIGRP 設定を確認するには、次のコマンドを使用します。

 

コマンド
目的

show ip eigrp as-number

EIGRP 設定に関する情報を表示します。

show ip eigrp [ as-number ] interfaces [ type number ] [detail]

インターフェイス上の EIGRP 設定に関する情報を表示します。

show ip eigrp as-number neighbors [ type number ] [ detail ]

EIGRP ネイバーに関する情報を表示します。

show ip eigrp [ as-number ] route [ ip-prefix/length ] [ active ] [ all-links ] [ detail-links ] [ pending ] [ summary ] [ zero-successors ] [ vrf vrf-name ]

EIGRP ルートに関する情報を表示します。

show ip eigrp [ as-number ] topology [ ip-prefix/length ] [ active ] [ all-links ] [ detail-links ] [ pending ] [ summary ] [ zero-successors ] [ vrf vrf-name ]

EIGRP トポロジに関する情報を表示します。

show running-configuration eigrp

現在実行中の EIGRP 設定を表示します。

EIGRP ネイバー設定を確認するには、 show ip eigrp neighbors コマンドを使用します。

EIGRP 統計情報の表示

EIGRP 統計情報を表示するには、次のコマンドを使用します。

 

コマンド
目的

show ip eigrp [ as-number ] accounting [ vrf vrf-name ]

EIGRP の課金統計情報を表示します。

show ip eigrp [ as-number ] policy statistics redistribute

EIGRP の再配布統計情報を表示します。

show ip eigrp [ as-number ] traffic [ vrf vrf-name ]

EIGRP のトラフィック統計情報を表示します。

EIGRP 設定の例

次に、EIGRP を設定する例を示します。

feature eigrp
interface ethernet 1/2
ip address 209.0.2.55/24
ip router eigrp 201
no shutdown
router eigrp 201
router-id 209.0.2.1
 

関連資料

ルートマップの詳細については、 第 14 章「Route Policy Manager の設定」 を参照してください。

デフォルト設定

表7-1 は、IP パラメータのデフォルト設定の一覧です。

 

表7-1 デフォルト IP パラメータ

パラメータ
デフォルト

Administrative distance

Internal routes ― 90

External routes ― 170

Bandwidth percent

50%

Default metric for redistributed routes

bandwidth ― 100000 kbps

delay ― 100(10 マイクロ秒単位)

reliability ― 255

loading ― 1

MTU ― 1500

EIGRP feature

ディセーブル

Hello interval

5 秒

Hold time

15 秒

Maximum equal cost paths

16

Metric weights

1 0 1 0 0

Next-hop address advertised

ローカル インターフェイスの IP アドレス

NSF convergence time

120

NSF route-hold time

240

NSF signal time

20

Redistribution

ディセーブル

Split horizon

イネーブル

その他の関連資料

EIGRP の実装に関する詳細情報については、次のページを参照してください。

「関連資料」

関連資料

 

関連項目
マニュアル名

EIGRP CLI コマンド

Cisco NX-OS Command Line Reference

VDC および VRF

Cisco NX-OS Virtual Device Contexts Configuration Guide

http://www.cisco.com/warp/public/103/1.html

Introduction to EIGRP Tech Note

http://www.cisco.com/en/US/tech/tk365/technologies_q_and_a_item09186a008012dac4.shtml

EIGRP Frequently Asked Questions