Cisco NX-OS Unicast Routing コンフィギュレーション ガイド Release 4.0
OSPFv2 の設定
OSPFv2 の設定
発行日;2012/01/13 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

OSPFv2 の設定

OSPFv2 について

hello パケット

ネイバー

隣接関係

代表ルータ

エリア

Link-State Advertisement

LSA タイプ

リンク コスト

フラッディングと LSA グループ ペーシング

リンクステート データベース

不透明 LSA

OSPFv2 とユニキャスト RIB

認証

簡易パスワード認証

MD5 認証

高度な機能

スタブ エリア

Not-So-Stubby エリア

仮想リンク

ルート再配布

ルート集約

ハイ アベイラビリティとグレースフル リスタート

OSPFv2 スタブ ルータ アドバタイズメント

複数の OSPFv2 インスタンス

SPF 最適化

仮想化のサポート

OSPFv2 のライセンス要件

OSPFv2 の前提条件

設定時の注意事項および制約事項

基本的 OSPFv2 の設定

OSPFv2 機能のイネーブル化

OSPFv2 インスタンスの作成

OSPFv2 インスタンス上のオプション パラメータの設定

OSPFv2 でのネットワークの設定

エリアの認証の設定

インターフェイスの認証の設定

高度な OSPFv2 の設定

境界ルータのフィルタ リストの設定

スタブ エリアの設定

Totally Stubby エリアの設定

NSSA の設定

仮想リンクの設定

再配布の設定

ルート集約の設定

スタブ ルート アドバタイズメントの設定

デフォルト タイマーの変更

グレースフル リスタートの設定

OSPFv2 インスタンスの再起動

仮想化による OSPFv2 の設定

OSPFv2 設定の確認

OSPFv2 統計情報の表示

OSPFv2 設定の例

デフォルト設定

その他の関連資料

関連資料

MIB

OSPFv2 の設定

この章では、IPv4 ネットワーク向けの OSPFv2(Open Shortest Path First version 2)の設定方法を説明します。

ここでは、次の内容を説明します。

「OSPFv2 について」

「OSPFv2 のライセンス要件」

「OSPFv2 の前提条件」

「設定時の注意事項および制約事項」

「基本的 OSPFv2 の設定」

「高度な OSPFv2 の設定」

「OSPFv2 設定の確認」

「OSPFv2 統計情報の表示」

「OSPFv2 設定の例」

「デフォルト設定」

「その他の関連資料」

OSPFv2 について

OSPFv2 は、IPv4 ネットワーク用 IETF リンクステート プロトコルです( リンクステート プロトコルを参照)。OSPFv2 ルータは、 hello パケット と呼ばれる特別なメッセージを各 OSPF イネーブル インターフェイスに送信して、他の OSPFv2 隣接ルータを探索します。隣接ルータが発見されると、この 2 台のルータは hello パケットの情報を比較して、両者の設定に互換性のあるかどうかを判定します。これらの隣接ルータは 隣接関係 を確立しようとします。つまり、両者のリンクステート データベースを同期させて、確実に同じ OSPFv2 ルーティング情報を持つようにします。隣接ルータは、各リンクの稼働状態に関する情報、リンクのコスト、およびその他のあらゆる近隣情報を含む リンクステート アドバタイズメント (LSA; リンクステート アドバタイズメント)を共有します。これらのルータはその後、受信した LSA をすべての OSPF イネーブル インターフェイスにフラッディングします。これにより、すべての OSPFv2 ルータのリンクステート データベースが最終的に同じになります。すべての OSPFv2 ルータのリンクステート データベースが同じになると、ネットワークは 収束 されます( 収束を参照)。その後、各ルータは、ダイクストラの最短パス優先(SPF)アルゴリズムを使用して、自身のルーティング テーブルを構築します。

OSPFv2 ネットワークは、複数のエリアに分割できます。ルータは、ほとんどの LSA を 1 つのエリア内にのみ送信するため、OSPF イネーブル ルータの CPU とメモリの要件が緩やかになります。

OSPFv2 は IPv4 をサポートし、OSPFv3 は IPv6 をサポートしています。詳細については、 第 6 章「OSPFv3 の設定」 を参照してください。

ここでは、次の内容について説明します。

「hello パケット」

「ネイバー」

「隣接関係」

「代表ルータ」

「エリア」

「Link-State Advertisement」

「OSPFv2 とユニキャスト RIB」

「認証」

「高度な機能」

hello パケット

OSPFv2 ルータは、すべての OSPF イネーブル インターフェイスに hello パケットを定期的に送信します。ルータがこの hello パケットを送信する頻度は、インターフェイスごとに設定された hello インターバル により決定されます。OSPFv2 は、hello パケットを使用して、次のタスクを実行します。

近隣探索

キープアライブ

双方向通信

代表ルータの選定(代表ルータを参照)

hello パケットには、リンクの OSPFv2 コスト割り当て、hello 間隔、送信元ルータのオプション機能など、送信元の OSPFv2 インターフェイスとルータに関する情報が含まれます。これらの hello パケットを受信する OSPFv2 インターフェイスは、設定に受信インターフェイスの設定との互換性があるかどうかを判定します。互換性のあるインターフェイスはネイバーとみなされ、ネイバー テーブルに追加されます(ネイバーを参照)。

hello パケットには、送信元インターフェイスが通信したルータのルータ ID のリストも含まれます。受信インターフェイスが、このリストで自身の ID を見つけた場合は、2 つのインターフェイス間で双方向通信が確立されます。

OSPFv2 は、hello パケットをキープアライブ メッセージとして使用して、ネイバーが通信を継続中であるかどうかを判定します。ルータが、設定された デッド インターバル (通常は hello 間隔の倍数)で hello パケットを受信しない場合は、そのネイバーがローカル ネイバー テーブルから削除されます。

ネイバー

ネイバーとは見なされるためには、OSPFv2 インターフェイスがリモート インターフェイスとの互換性を持つよう設定されている必要があります。この 2 つの OSPFv2 インターフェイスで、次の基準が一致している必要があります。

hello 間隔

デッド間隔

エリア ID(エリア を参照)

認証

オプション機能

一致する場合は、次の情報がネイバー テーブルに入力されます。

ネイバー ID ― ネイバーのルータ ID

優先度 ― ネイバーの優先度。優先度は、代表ルータの選定(代表ルータを参照)に使用されます。

状態 ― ネイバーから通信があったか、双方向通信の確立処理中であるか、リンクステート情報を共有しているか、または完全な隣接関係が確立されたかを示します。

デッド タイム ― このネイバーから最後の hello パケットを受信した後に経過した時間を示します。

IP アドレス ― ネイバーの IP アドレス

代表ルータ ― ネイバーが代表ルータ、またはバックアップ代表ルータとして宣言されたかどうかを示します(代表ルータを参照)。

ローカル インターフェイス ― このネイバーの hello パケットを受信したローカル インターフェイス

隣接関係

すべてのネイバーが隣接関係を確立するわけではありません。ネットワーク タイプと確立された代表ルータに応じて、完全な隣接関係を確立して、すべてのネイバーと LSA を共有するものと、そうでないものがあります。詳細については、「代表ルータ」を参照してください。

隣接関係は、OSPF のデータベース説明パケット、リンク状態要求パケット、およびリンク状態更新パケットを使用して確立されます。データベース説明パケットに含まれるのは、ネイバーのリンクステート データベースからの LSA ヘッダーのみです(リンクステート データベースを参照)。ローカル ルータは、これらのヘッダーを自身のリンクステート データベースと比較して、新規の LSA か、更新された LSA かを判定します。ローカル ルータは、新規または更新の情報を必要とする各 LSA について、リンク状態要求パケットを送信します。これに対し、ネイバーはリンク状態更新パケットを返信します。このパケット交換は、両方のルータのリンクステート情報が同じになるまで継続します。

代表ルータ

複数のルータを含むネットワークは、OSPF 特有の状況です。すべてのルータがネットワークで LSA をフラッディングした場合は、同じリンクステート情報が複数の送信元から送信されます。ネットワークのタイプに応じて、OSPFv2 は 代表ルータ DR )という 1 台のルータを使用して、LSA のフラッディングを制御し、OSPFv2 の残りの部分に対してネットワークを代表する場合があります(エリアを参照)。DR がダウンした場合、OSPFv2 は バックアップ代表ルータ (BDR)を選定し、この BDR を使用します。

ネットワーク タイプは次のとおりです。

ポイントツーポイント ― 2 台のルータ間にのみ存在するネットワーク。ポイントツーポイント ネットワーク上の全ネイバーは隣接関係を確立し、DR は存在しません。

ブロードキャスト ― ブロードキャスト トラフィックが可能なイーサネットなどの共有メディア上で通信できる複数のルータを持つネットワーク。OSPFv2 ルータは DR および BDR を確立し、これらにより、ネットワーク上の LSA フラッディングを制御します。OSPFv2 は、よく知られている IPv4 マルチキャスト アドレス 224.0.0.5 および MAC アドレス 0100.5300.0005 を使用して、ネイバーと通信します。

DR と BDR は、hello パケット内の情報に基づいて選択されます。インターフェイスは hello パケットの送信時に、どれが DR および BDR かわかっている場合は、優先フィールドと、DR および BDR フィールドを設定します。ルータは、hello パケットの DR および BDR フィールドで宣言されたルータと優先フィールドに基づいて、選定手順を実行します。最終的に OSPFv2 は、もっとも大きいルータ ID を DR および BDR として選択します。

他のルータはすべて DR および BDR と隣接関係を確立し、IPv4 マルチキャスト アドレス 224.0.0.6 を使用して、LSA 更新情報を DR と BDR に送信します。図5-1 は、すべてのルータと DR の間のこの隣接関係を示します。

DR は、ルータ インターフェイスに基づいています。1 つのネットワークの DR であるルータは、別のインターフェイス上の他のネットワークの DR となることはできません。

図5-1 マルチアクセス ネットワークの DR

 

エリア

OSPFv2 ネットワークを複数の エリア に分割すると、ルータに要求される OSPFv2 の CPU とメモリに関する要件を制限できます。エリアとは、ルータの論理的な区分で、OSPFv2 ドメイン内にリンクして別のサブドメインを作成します。LSA フラッディングはエリア内でのみ発生し、リンクステート データベースはエリア内のリンクにのみ制限されます。定義されたエリア内のインターフェイスには、エリア ID を割り当てることができます。エリア ID は、10.2.3.1 などの、数字またはドット付き 10 進表記で表現される 32 ビット値です。

OSPFv2 ネットワーク内に複数のエリアを定義する場合は、0 という予約されたエリア ID を持つバックボーン エリアも定義する必要があります。エリアが複数ある場合は、1 台以上のルータが エリア境界ルータ (ABR; エリア境界ルータ)となります。ABR は、バックボーン エリアと他の 1 つ以上の定義済みエリアの両方に接続します(図5-2 を参照)。

図5-2 OSPFv2 エリア

 

ABR には、接続するエリアごとに個別のリンクステート データベースがあります。ABR は、接続したエリアの 1 つからバックボーン エリアにネットワーク集約(タイプ 3)LSA(ルート集約を参照)を送信します。バックボーン エリアは、1 つのエリアに関する集約情報を別のエリアに送信します。図5-2 では、エリア 0 が、エリア 5 に関する集約情報をエリア 3 に送信しています。

OSPFv2 では、Autonomous System Boundary Router(ASBR; 自律システム境界ルータ)という、もう 1 つのルータ タイプも定義されています。このルータは、OSPFv2 エリアを別の自律システムに接続します。自律システムとは、単一の技術的管理エンティティにより制御されるネットワークです。OSPFv2 は、そのルーティング情報を別の自律システムに再配布したり、再配布されたルートを別の自律システムから受信したりできます。詳細については、「高度な機能」を参照してください。

Link-State Advertisement

OSPFv2 は LSA を使用して、自身のルーティング テーブルを構築します。

ここでは、次の内容について説明します。

「LSA タイプ」

「リンク コスト」

「フラッディングと LSA グループ ペーシング」

「リンクステート データベース」

「不透明 LSA」

LSA タイプ

表5-1 は、Cisco NX-OSでサポートされる LSA タイプを示します。

 

表5-1 LSA タイプ

タイプ
名前
説明

1

ルータ LSA

すべてのルータが送信する LSA。この LSA には、すべてのリンクの状態とコスト、およびリンク上のすべての OSPFv2 ネイバーの一覧が含まれます。ルータ LSA は SPF 再計算をトリガーします。ルータ LSA はローカル OSPFv2 エリアにフラッディングされます。

2

ネットワーク LSA

DR が送信する LSA。この LSA には、マルチアクセス ネットワーク内のすべてのルータの一覧が含まれます。ネットワーク LSA は SPF 再計算をトリガーします。「代表ルータ」を参照してください。

3

ネットワーク集約 LSA

ABR が、ローカル エリア内の宛先ごとに外部エリアに送信する LSA。この LSA には、ABR からローカルの宛先へのリンク コストが含まれます。「エリア」を参照してください。

4

ASBR 集約 LSA

ABR が外部エリアに送信する LSA。この LSA は、リンク コストを ASBR のみにアドバタイズします。「エリア」を参照してください。

5

AS 外部 LSA

ASBR が生成する LSA。この LSA には、外部 AS 宛先へのリンク コストが含まれます。AS 外部 LSA は、AS 全体にわたってフラッディングされます。「エリア」を参照してください。

7

NSSA 外部 LSA

ASBR が Not-So-Stubby Area(NSSA)内で生成する LSA。この LSA には、外部 AS 宛先へのリンク コストが含まれます。NSSA 外部 LSA は、ローカル NSSA 内のみでフラッディングされます。「エリア」を参照してください。

9-11

不透明 LSA

OSPF の拡張に使用される LSA。「不透明 LSA」を参照してください。

リンク コスト

各 OSPFv2 インターフェイスには、 リンク コスト が割り当てられます。このコストは任意の数字です。デフォルトでは、Cisco NX-OS が、設定された参照帯域幅をインターフェイス帯域幅で割った値をコストとして割り当てます。デフォルトでは、参照帯域幅は 40 Gbps です。リンク コストは各リンクに対して、LSA 更新情報で伝えられます。

フラッディングと LSA グループ ペーシング

OSPFv2 ルータは、LSA を受信すると、その LSA をすべての OSPF 対応インターフェイスに転送し、OSPFv2 エリアをこの情報でフラッディングします。この LSA フラッディングにより、ネットワーク内のすべてのルータが同じルーティング情報を持つことが保証されます。LSA フラッディングは、OSPFv2 エリアの設定により異なります(エリアを参照)。LSA は、 リンクステート リフレッシュ 時間に基づいて(デフォルトでは 30 分ごとに)フラッディングされます。各 LSA にはそれぞれ、リンクステート リフレッシュ時間が設定されています。

ネットワークの LSA 更新情報のフラッディング レートは、LSA グループ ペーシング機能を使用して制御できます。LSA グループ ペーシングにより、CPU またはバッファの使用率を低下させることができます。この機能により、同様のリンクステート リフレッシュ時間を持つ LSA がグループ化されるため、OSPFv2 で、複数の LSA を 1 つの OSPFv2 更新メッセージにまとめることが可能となります。

デフォルトでは、相互のリンクステート リフレッシュ時間が 4 分以内の LSA が同じグループに入れられます。この値は、大規模なリンクステート データベースでは低く、小規模のデータベースでは高くして、ネットワーク上の OSPFv2 負荷を最適化する必要があります。

リンクステート データベース

各ルータは、OSPFv2 ネットワーク用のリンクステート データベースを維持しています。このデータベースには、接続されたすべての LSA が含まれ、ネットワークを通過するすべてのルートに関する情報が格納されます。OSPFv2 は、この情報を使用して、各宛先への最適なパスを計算し、この最適なパスをルーティング テーブルに入力します。

LSA は、MaxAge と呼ばれる設定済みの時間間隔で 受信された LSA 更新情報がまったくない場合は、リンクステート データベースから削除されます。ルータは、LSA を 30 分ごとに繰り返してフラッディングし、正確なリンクステート情報が期限切れで削除されるのを防ぎます。Cisco NX-OS は、すべての LSA が同時にリフレッシュされるのを防ぐために、LSA グループ機能をサポートしています。詳細については、「フラッディングと LSA グループ ペーシング」を参照してください。

不透明 LSA

不透明 LSA により、OSPF 機能の拡張が可能となります。不透明 LSA は、標準 LSA ヘッダーと、それに続くアプリケーション固有の情報で構成されます。この情報は、OSPFv2 または他のアプリケーションにより使用される場合があります。OSPFv2 は不透明 LSA を使用して、OSPFv2 グレースフル リスタート機能(ハイ アベイラビリティとグレースフル リスタートを参照)をサポートしています。次のような 3 種類の不透明 LSA タイプが定義されています。

LSA タイプ 9 ― ローカル ネットワークにフラッディングされます。

LSA タイプ 10 ― ローカル エリアにフラッディングされます。

LSA タイプ 11 ― ローカル AS にフラッディングされます。

OSPFv2 とユニキャスト RIB

OSPFv2 は、リンクステート データベースでダイクストラの SPF アルゴリズムを実行します。このアルゴリズムにより、パス上の各リンクのリンク コストの合計に基づいて、各宛先への最適なパスが選択されます。そして、選択された各宛先への最短パスが OSPFv2 ルーティング テーブルに入力されます。OSPFv2 ネットワークが収束すると、このルーティング テーブルはユニキャスト RIB にデータを提供します。OSPFv2 はユニキャスト RIB と通信し、次の動作を行います。

ルートの追加または削除

他のプロトコルからのルートの再配布への対応

変更されていない OSPFv2 ルートの削除およびスタブ ルータ アドバタイズメントを行うための収束更新情報の提供(OSPFv2 スタブ ルータ アドバタイズメントを参照)

さらに OSPFv2 は、変更済みダイクストラ アルゴリズムを実行して、集約および外部(タイプ 3、4、5、7)LSA の変更の高速再計算を行います。

認証

OSPFv2 メッセージに認証を設定して、ネットワークでの不正な、または無効なルーティング更新を防止できます。Cisco NX-OS は、次の 2 つの認証方式をサポートしています。

簡易パスワード認証

MD5 認証ダイジェスト

OSPFv2 認証は、OSPFv2 エリアに対して、またはインターフェイスごとに設定できます。

簡易パスワード認証

簡易パスワード認証では、OSPFv2 メッセージの一部として送信された単純なクリア テキストのパスワードを使用します。受信 OSPFv2 ルータが OSPFv2 メッセージを有効なルート更新情報として受け入れるには、同じクリア テキスト パスワードで設定されている必要があります。パスワードがクリア テキストであるため、ネットワーク上のトラフィックを監視できるあらゆるユーザがパスワードを入手できます。

MD5 認証

OSPFv2 メッセージを認証するには、MD5 認証を使用する必要があります。そのためには、ローカル ルータとすべてのリモート OSPFv2 ネイバーが共有するパスワードを設定します。Cisco NX-OS は各 OSPFv2 メッセージに対して、メッセージと暗号化されたパスワードに基づく MD5 一方向メッセージ ダイジェストを作成します。インターフェイスはこのダイジェストを OSPFv2 メッセージとともに送信します。受信する OSPFv2 ネイバーは、同じ暗号化パスワードを使用して、このダイジェストを確認します。メッセージが変更されていない場合はダイジェストの計算が同一であるため、OSPFv2 メッセージは有効とみなされます。

MD5 認証には、ネットワークでのメッセージの再送を防ぐための、各 OSPFv2 メッセージのシーケンス番号が含まれます。

高度な機能

Cisco NX-OS は、ネットワークでの OSPFv2 の可用性やスケーラビリティを向上させる数多くの高度な OSPFv2 機能をサポートしています。ここでは、次の内容について説明します。

「スタブ エリア」

「Not-So-Stubby エリア」

「仮想リンク」

「ルート再配布」

「ルート集約」

「ハイ アベイラビリティとグレースフル リスタート」

「OSPFv2 スタブ ルータ アドバタイズメント」

「複数の OSPFv2 インスタンス」

「SPF 最適化」

「仮想化のサポート」

スタブ エリア

エリアを スタブ エリア にすると、エリアでフラッディングされる外部ルーティング情報の量を制限できます。スタブ エリアとは、AS 外部(タイプ 5)LSA(Link-State Advertisementを参照)が許可されないエリアです。これらの LSA は通常、外部ルーティング情報を伝播するためにローカル AS 全体でフラッディングされます。スタブ エリアには、次の要件があります。

スタブ エリア内のすべてのルータはスタブ ルータです。「スタブ ルーティング」を参照してください。

スタブ エリアには ASBR ルータは存在しません。

スタブ エリアには仮想リンクを設定できません。

図5-3 は、外部 AS に到達するためにエリア 10 内のすべてのルータが ABR を通過する必要のある OSPFv2 AS の例を示します。エリア 10 は、スタブ エリアとして設定できます。

図5-3 スタブ エリア

 

スタブ エリアは、外部 AS へのバックボーン エリアを通過する必要のあるすべてのトラフィックにデフォルト ルートを使用します。IPv4 の場合のデフォルト ルートは 0.0.0.0 です。

Not-So-Stubby エリア

Not-So-Stubby Area( NSSA )はスタブ エリアに似ていますが、NSSA では、再配布を使用して NSSA 内で AS 外部ルートを使用できる点が異なります。NSSA ASBR はこれらのルートを再配布し、NSSA 外部(タイプ 7)LSA を生成して NSSA 全体でフラッディングします。または、この NSSA 外部 LSA を AS 外部(タイプ 5)LSA に変換するよう、NSSA を他のエリアに接続する ABR を設定することができます。こうすると、ABR は、これらの AS 外部 LSA を OSPFv2 AS 全体にフラッディングします。変換時には、集約とフィルタリングがサポートされます。NSSA 外部 LSA の詳細については、「Link-State Advertisement」を参照してください。

たとえば、OSPFv2 を使用する中央サイトを、異なるルーティング プロトコルを使用するリモート サイトに接続するときに NSSA を使用すると、管理作業を簡素化できます。リモート サイトへのルートはスタブ エリア内に再配布できないため、NSSA を使用する前に、企業サイトの境界ルータとリモート ルータの間の接続を OSPFv2 スタブ エリアとして実行することはできません。NSSA を使用すると、企業のルータとリモート ルータ間のエリアを NSSA として定義する(NSSA の設定を参照)ことで、OSPFv2 を拡張してリモート接続性をサポートできます。

バックボーン エリア 0 を NSSA にすることはできません。

仮想リンク

仮想リンクを使用すると、物理的に直接接続できない場合に、OSPFv2 エリア ABR をバックボーン エリア ABR に接続できます。図5-4 は、エリア 3 をエリア 5 経由でバックボーン エリアに接続する仮想リンクを示します。

図5-4 仮想リンク

 

また、仮想リンクを使用して、分割エリアから一時的に回復できます。分割エリアは、エリア内のリンクがダウンしたために隔離された一部のエリアで、ここからはバックボーン エリアへの代表 ABR に到達できません。

ルート再配布

OSPFv2 は、ルート再配布を使用して、他のルーティング プロトコルからルートを学習できます。「ルート再配布」を参照してください。リンク コストをこれらの再配布されたルートに割り当てるか、またはデフォルト リンク コストを再配布されたすべてのルートに割り当てるよう、OSPFv2 を設定します。

ルート再配布では、ルートマップを使用して、再配布する外部ルートを管理します。ルートマップの設定の詳細については、 第 14 章「Route Policy Manager の設定」 を参照してください。ルートマップを使用して、これらの外部ルートがローカル OSPFv2 AS でアドバタイズされる前に AS 外部(タイプ 5)LSA および NSSA 外部(タイプ 7)LSA のパラメータを変更できます。

ルート集約

OSPFv2 は、学習したすべてのルートを、すべての OSPF 対応ルータと共有するため、ルート集約を使用して、すべての OSPF 対応ルータにフラッディングされる一意のルートの数を削減した方がよい場合があります。ルート集約により、より具体的な複数のアドレスが、すべての具体的なアドレスを表す 1 つのアドレスに置き換えられるため、ルーティング テーブルが簡素化されます。たとえば、10.1.1.0/24、10.1.2.0/24、および 10.1.3.0/24 というアドレスを 1 つの集約アドレス 10.1.0.0/16 に置き換えることができます。

一般的には、ABR の境界ごとに集約します。集約は 2 つのエリアの間でも設定できますが、バックボーンの方向に集約する方が適切です。こうすると、バックボーンがすべての集約アドレスを受信し、すでに集約されているそれらのアドレスを他のエリアに投入できるためです。集約には、次の 2 タイプがあります。

エリア間ルート集約

外部ルート集約

エリア間ルート集約は ABR 上で設定し、AS 内のエリア間のルートを集約します。集約の利点を生かすには、これらのアドレスを 1 つの範囲内にまとめられるよう、連続するネットワーク番号をエリア内で割り当てる必要があります。

外部ルート集約は、ルート再配布を使用して OSPFv2 に投入される外部ルートに特有のルート集約です。集約する外部の範囲が連続していることを確認する必要があります。異なる 2 台のルータからの重複範囲を集約すると、誤った宛先にパケットが送信される原因となる場合があります。外部ルート集約は、ルートを OSPF に再配布している ASBR で設定してください。

集約アドレスの設定時に Cisco NX-OS は、ルーティング ブラック ホールおよびルート ループを防ぐために、集約アドレスの廃棄ルートを自動的に設定します。

ハイ アベイラビリティとグレースフル リスタート

Cisco NX-OSはハイ アベイラビリティをサポートしています。Cisco NX-OS システムでコールド リブートが発生した場合は、ネットワークがシステムへのトラフィックの転送を停止し、システムをネットワーク トポロジから削除します。このシナリオでは、OSPFv2 でステートレス再起動が発生し、ローカル システム上のネイバーの隣接関係がすべて削除されます。Cisco NX-OS はスタートアップ コンフィギュレーションを適用し、OSPFv2 はネイバーを再探索して、隣接関係を再確立します。

Cisco NX-OS を実行する 2 つのスーパーバイザを持つプラットフォームでは、ステートフル スーパーバイザ スイッチオーバーが発生する場合があります。このスイッチオーバーが発生する前に、OSPFv2 は、OSPFv2 がしばらく使用不可であることを宣言して、グレースフル リスタートを開始します。スイッチオーバー中には、ネットワークでトラフィックの転送が続行され、システムはネットワーク トポロジ内に存在し続けます。

スイッチオーバー後に、Cisco NX-OS は実行コンフィギュレーションを適用し、OSPFv2 は、自身が再び稼働していることをネイバーに通知します。ネイバーは隣接関係の再確立を支援します。

OSPFv2 は、処理に問題が発生した場合は、自動的に再起動します。再起動後に OSPFv2 はグレースフル リスタートを開始するため、プラットフォームがネットワーク トポロジから削除されることはありません。手動で OSPF を再起動した場合は、ステートフル スイッチオーバーと同様のグレースフル リスタートが実行されます。いずれの場合にも実行コンフィギュレーションが適用されます。

グレースフル リスタート、つまり、Nonstop Forwarding(NSF)では、処理の再起動中も OSPFv2 がデータ転送パス上に存在し続けます。OSPFv2 の再起動が必要になると、OSPFv2 は最初に、猶予 LSA と呼ばれるリンクローカル 不透明(タイプ 9)LSA(不透明 LSAを参照)を送信します。この再起動中の OSPFv2 プラットフォームは NSF 対応と呼ばれます。

猶予 LSA には猶予期間が含まれます。猶予期間とは、ネイバー OSPFv2 インターフェイスは再起動中の OSPFv2 インターフェイスからの LSA を待つよう指定された時間です。(通常、OSPFv2 は隣接関係を解消し、ダウンした、または再起動中の OSPFv2 インターフェイスからのすべての LSA を廃棄します。)関与するネイバーは NSF ヘルパーと呼ばれ、再起動中の OSPFv2 インターフェイスが発信するすべての LSA を、このインターフェイスが隣接したままであるかのように維持します。

再起動中の OSPFv2 インターフェイスが稼働を再開すると、ネイバーを再探索して隣接関係を確立し、LSA 更新情報の送信を再開します。この時点で、NSF ヘルパーは、グレースフル リスタートが完了したと認識します。


) 再起動中の OSPFv2 インターフェイスが猶予期間内に稼働を再開しない場合、またはネットワークでトポロジが変更された場合は、各 OSPFv2 ネイバーは再起動中の OSPFv2 との隣接関係を解消し、通常の OSPFv2 の再起動として対応します。



) グレースフル リスタートでは、OSPFv2 の In-Service Software Upgrade(ISSU; インサービス ソフトウェア アップグレード)のサポートをイネーブルにする必要があります。グレースフル リスタートをディセーブルにした場合は、Cisco NX-OS により、この設定では ISSU をサポートできないという警告が発行されます。


OSPFv2 スタブ ルータ アドバタイズメント

OSPFv2 スタブ ルータ アドバタイズメント機能を使用して、OSPFv2 インターフェイスをスタブ ルータとして機能するよう設定することはできません。この機能は、ネットワークに新規ルータを機能制限付きで導入する場合や、過負荷になっているルータの負荷を制限する場合など、このルータ経由の OSPFv2 トラフィックを制限するときに使用します。また、この機能は、さまざまな管理上またはトラフィック エンジニアリング上の理由により使用される場合もあります。

OSPFv2 スタブ ルータ アドバタイズメントは、OSPFv2 ルータをネットワーク トポロジから削除しませんが、他の OSPFv2 ルータがこのルータを使用して、ネットワークの他の部分にトラフィックをルーティングできないようにします。このルータが宛先のトラフィック、またはこのルータに直接接続されたトラフィックのみが送信されます。

OSPFv2 スタブ ルータ アドバタイズメントは、すべてのスタブ リンク(ローカル ルータに直接接続された)を、ローカル OSPFv2 インターフェイスのコストとしてマークします。すべてのリモート リンクは、最大のコスト(0xFFFF)としてマークされます。

複数の OSPFv2 インスタンス

Cisco NX-OS は、同じノード上で動作する、OSPFv2 プロトコルの複数インスタンスをサポートしています。同じインターフェイス上で複数のインスタンスを設定することはできません。デフォルトでは、すべてのインスタンスが同じシステム ルータ ID を使用します。複数のインスタンスが同じ OSPFv2 AS にある場合は、各インスタンスのルータ ID を手動で設定する必要があります。

SPF 最適化

Cisco NX-OS は、次の方法で SPF アルゴリズムを最適化します。

ネットワーク(タイプ 2)LSA、ネットワーク集約(タイプ 3)LSA、および AS 外部(タイプ 5)LSA用部分 SPF ― これらの LSA のいずれかが変更されると、Cisco NX-OS は、全体的な SPF 計算ではなく、高速部分計算を実行します。

SPF タイマー ― さまざまなタイマーを設定して、SPF 計算を制御できます。これらのタイマーには、後続の SPF 計算の幾何バックオフが含まれます。幾何バックオフにより、複数の SPF 計算による CPU 負荷が制限されます。

仮想化のサポート

OSPFv2 は、Virtual Routing and Forwarding Instance(VRF; 仮想ルーティング/転送インスタンス)をサポートしています。VRF は Virtual Device Contexts(VDC; 仮想化デバイス コンテキスト)内にあります。デフォルトでは、特に別の VDC および VRF を設定しない限り、Cisco NX-OS によりデフォルト VDC およびデフォルト VRF が使用されます。VDC 内に含まれるのは、最大 4 つの OSPFv2 インスタンスです。詳細については、『 Cisco NX-OS Virtual Device Context Configuration Guide 』の 第 13 章「レイヤ 3 仮想化の設定」 を参照してください。

OSPFv2 のライセンス要件

次の表は、この機能のライセンス要件を示します。

 

製品
ライセンス要件

NX-OS

OSPFv2 には Enterprise Services ライセンスが必要です。NX-OS ライセンス方式の詳細説明およびライセンスの入手と適用の方法については、『 Cisco NX-OS Licensing Guide 』を参照してください。

OSPFv2 の前提条件

OSPFv2 には、次の前提条件があります。

OSPF を設定するための、ルーティングの基礎に関する詳しい知識がある。

スイッチにログオンしている。

リモート OSPFv2 ネイバーと通信可能な 1 つ以上の IPv4 用インターフェイスが設定されている。

Enterprise Services ライセンスがインストールされている。

OSPFv2 ネットワーク戦略と、ネットワークのプランニングが完成している。たとえば、複数のエリアが必要かどうかを決定する必要があります。

OSPF 機能がイネーブルにされている(OSPFv2 機能のイネーブル化を参照)。

Advanced Services ライセンスがインストールされ、VDC を設定している場合は、目的の VDC が入力されている(『 Cisco NX-OS Virtual Device Context Configuration Guide 』を参照)。

設定時の注意事項および制約事項

OSPFv2 設定時の注意事項および制約事項は次のとおりです。

VDC 内に含まれるのは、最大 4 つの OSPFv2 インスタンスです。


) Cisco IOS CLI の詳しい知識がある場合は、この機能で使用する Cisco NX-OS コマンドが、よく使用される Cisco IOS コマンドとは異なる可能性があることに注意してください。


基本的 OSPFv2 の設定

OSPFv2 は、OSPFv2 ネットワークを設計したあとに設定します。

ここでは、次の内容について説明します。

「OSPFv2 機能のイネーブル化」

「OSPFv2 インスタンスの作成」

「OSPFv2 インスタンス上のオプション パラメータの設定」

「OSPFv2 インスタンス上のオプション パラメータの設定」

「OSPFv2 でのネットワークの設定」

「エリアの認証の設定」

OSPFv2 機能のイネーブル化

OSPFv2 を設定するには、その前に OSPFv2 機能をイネーブルにする必要があります。

操作の前に

正しい VDC を使用していることを確認します(または、 switchto vdc コマンドを使用します)。

コマンドの一覧

1. config t

2. feature ospf

3. copy running-config startup-config

詳細な手順

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

feature ospf

 

switch(config)# feature ospf

OSPFv2 機能をイネーブルにします。

ステップ 3

copy running-config startup-config

 

switch(config)# copy running-config startup-config

(任意)この設定変更を保存します。

OSPFv2 機能をディセーブルにし、関連付けられた設定をすべて削除するには、 no feature ospf コマンドを使用します。

 

コマンド
目的

no feature ospf

 

switch(config)# no feature ospf

OSPFv2 機能をディセーブルにして、関連付けられた設定をすべて削除します。

OSPFv2 インスタンスの作成

OSPFv2 設定の最初のステップは OSPFv2 インスタンスの作成です。作成した OSPFv2 インスタンスには、一意のインスタンス タグを割り当てます。インスタンス タグは任意の文字列です。

OSPFv2 インスタンス パラメータの詳細については、「高度な OSPFv2 の設定」を参照してください。

操作の前に

OSPF 機能がイネーブルにされていることを確認します(OSPFv2 機能のイネーブル化を参照)。

show ip ospf instance-tag コマンドを使用して、インスタンス タグが使用されていないことを確認します。

OSPFv2 がルータ ID(設定済みのループバック アドレスなど)を入手可能であるか、またはルータ ID オプションを設定する必要があります。

正しい VDC を使用していることを確認します(または、 switchto vdc コマンドを使用します)。

コマンドの一覧

1. config t

2. router ospf instance-tag

3. router-id ip-address

4. show ip ospf instance-tag

5. copy running-config startup-config

詳細な手順

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router ospf instance-tag

 

switch(config)# router ospf 201

switch(config-router)#

新規 OSPFv2 インスタンスを作成して、設定済みのインスタンス タグを割り当てます。

ステップ 3

router-id ip-address

 

switch(config-router)# router-id 209.0.2.1

(任意)OSPFv2 ルータ ID を設定します。この IP アドレスにより、この OSPFv2 インスタンスが識別されます。このアドレスは、システムの設定済みインターフェイス上に存在する必要があります。

ステップ 4

show ip ospf instance-tag

 

switch(config-router)# show ip ospf 201

(任意)OSPF 情報を表示します。

ステップ 5

copy running-config startup-config

 

switch(config)# copy running-config startup-config

(任意)この設定変更を保存します。

OSPFv2 インスタンスと、関連付けられた設定をすべて削除するには、 no router ospf コマンドを使用します。

 

コマンド
目的

no router ospf instance-tag

 

switch(config)# no router ospf 201

OSPF インスタンスと、関連付けられた設定を削除します。


) このコマンドは、インターフェイス モードでは OSPF 設定を削除しません。インターフェイス モードで設定された OSPFv2 コマンドはいずれも、手動で削除する必要があります。


OSPFv2 インスタンス上のオプション パラメータの設定

OSPF のオプション パラメータを設定できます。

OSPFv2 インスタンス パラメータの詳細については、「高度な OSPFv2 の設定」を参照してください。

操作の前に

OSPF 機能がイネーブルにされていることを確認します(OSPFv2 機能のイネーブル化を参照)。

OSPFv2 がルータ ID(設定済みのループバック アドレスなど)を入手可能であるか、またはルータ ID オプションを設定する必要があります。

正しい VDC を使用していることを確認します(または、 switchto vdc コマンドを使用します)。

詳細な手順

ルータ コンフィギュレーション モードで、次の OSPFv2 用オプション パラメータを設定できます。

 

コマンド
目的

distance number

 

switch(config-router)# distance 25

この OSPFv2 インスタンスの管理ディスタンスを設定します。有効値の範囲は 1 ~ 255 であり、デフォルトは 110 です。

log-adjacency-changes [ detail ]

 

switch(config-router)# log-adjacency-changes

ネイバーの状態が変化するたびに、システム メッセージを生成します。

maximum-paths path-number

 

switch(config-router)# maximum-paths 4

ルーティング テーブル内の宛先への同じ OSPFv2 パスの最大数を設定します。このコマンドはロード バランシングに使用されます。有効値の範囲は 1 ~ 16 であり、デフォルトは 8 です。

次に、OSPFv2 インスタンスを作成する例を示します。

switch# config t

switch(config)# router ospf 201

switch(config-router)# copy running-config startup-config

OSPFv2 でのネットワークの設定

ルータがこのネットワークへの接続に使用するインターフェイスを介して、OSPFv2 へのネットワークを関連付けることで、このネットワークを設定できます(ネイバーを参照)。すべてのネットワークをデフォルト バックボーン エリア(エリア 0)に追加したり、任意の 10 進数または IP アドレスを使用して新規エリアを作成したりできます。


) すべてのエリアは、バックボーン エリアに直接、または仮想リンク経由で接続する必要があります。



) インターフェイスに有効な IP アドレスを設定するまでは、OSPF はインターフェイス上でイネーブルにされません。


操作の前に

OSPF 機能がイネーブルにされていることを確認します(OSPFv2 機能のイネーブル化を参照)。

正しい VDC を使用していることを確認します(または、 switchto vdc コマンドを使用します)。

コマンドの一覧

1. config t

2. interface interface-type slot/port

3. ip address ip-prefix/length

4. ip router ospf instance-tag area area-id [ secondaries none ]

5. show ip ospf instance-tag interface interface-type slot/por t

6. copy running-config startup-config

詳細な手順

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface interface-type slot/port

 

switch(config)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

ip address ip-prefix/length

 

switch(config-if)# ip address 209.0.2.1/16

このインターフェイスに IP アドレスおよびサブネット マスクを割り当てます。

ステップ 4

ip router ospf instance-tag area area-id [ secondaries none ]

 

switch(config-if)# ip router ospf 201 area 0

OSPFv2 インスタンスおよびエリアにインターフェイスを追加します。

ステップ 5

show ip ospf instance-tag interface interface-type slot/port

 

switch(config-if)# show ip ospf 201 interface ethernet 1/2

(任意)OSPF 情報を表示します。

ステップ 6

copy running-config startup-config

 

switch(config)# copy running-config startup-config

(任意)この設定変更を保存します。

インターフェイス コンフィギュレーション モードで、省略可能な次の OSPFv2 パラメータを設定できます。

 

コマンド
目的

ip ospf cost number

 

switch(config-if)# ip ospf cost 25

このインターフェイスの OSPFv2 コスト メトリックを設定します。デフォルトでは、参照帯域幅とインターフェイス帯域幅に基づいて、コスト メトリックが計算されます。有効値の範囲は 1 ~ 65535 です。

ip ospf dead-interval seconds

 

switch(config-if)# ip ospf dead-interval 50

OSPFv2 デッド間隔を秒単位で設定します。有効値の範囲は 1 ~ 65535 です。デフォルトでは、hello 間隔の秒数の 4 倍です。

ip ospf hello-interval seconds

 

switch(config-if)# ip ospf hello-interval 25

OSPFv2 hello 間隔を秒単位で設定します。有効値の範囲は 1 ~ 65535 であり、デフォルトは 10 秒です。

ip ospf mtu-ignore

 

switch(config-if)# ip ospf mtu-ignore

OSPFv2 で、ネイバーとのあらゆる IP MTU 不一致が無視されるよう設定します。デフォルトでは、ネイバー MTU がローカル インターフェイス MTU が不一致の場合には、隣接関係が確立されません。

ip ospf passive-interface

 

switch(config-if)# ip ospf passive-interface

インターフェイス上でルーティングが更新されないようにします。

ip ospf priority number

 

switch(config-if)# ip ospf priority 25

エリアの DR の決定に使用される OSPFv2 優先度を設定します。有効値の範囲は 0 ~ 255 であり、デフォルトは 1 です。「代表ルータ」を参照してください。

ip ospf shutdown

 

switch(config-if)# ip ospf shutdown

このインターフェイス上の OSPFv2 インスタンスをシャットダウンします。

次に、OSPFv2 インスタンス 201 にネットワーク エリア 10 を追加する例を示します。

switch# config t

switch(config)# interface ethernet 1/2

switch(config-if)# ip address 209.0.2.1/16

switch(config-if)# ip router ospf 201 area 10

switch(config-if)# copy running-config startup-config

 

インターフェイス設定を確認するには、 show ip ospf interface コマンドを使用します。このインターフェイスのネイバーを確認するには、 show ip ospf neighbor コマンドを使用します。

エリアの認証の設定

エリア内のすべてのネットワーク、またはエリア内の個々のインターフェイスの認証を設定できます。インターフェイス認証設定を使用すると、エリア認証は無効になります。

操作の前に

OSPF 機能がイネーブルにされていることを確認します(OSPFv2 機能のイネーブル化を参照)。

インターフェイス上のすべてのネイバーが、共有認証キーを含め、同じ認証設定を共有することを確認します。

この認証設定のキーチェーンを作成します。詳細については『 Cisco NX-OS Security Configuration Guide 』を参照してください。

正しい VDC を使用していることを確認します(または、 switchto vdc コマンドを使用します)。

コマンドの一覧

1. config t

2. router ospf instance-tag

3. area area-id authentication [ message-digest ]

4. interface interface-type slot/port

5. ip ospf authentication-key [ 0 | 3 ] key

または

ip ospf message-digest-key key-id md5 [ 0 | 3 ] key

6. show ip ospf instance-tag interface interface-type slot/por t

7. copy running-config startup-config

詳細な手順

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router ospf instance-tag

 

switch(config)# router ospf 201

switch(config-router)#

新規 OSPFv2 インスタンスを作成して、設定済みのインスタンス タグを割り当てます。

ステップ 3

area area-id authentication [ message-digest ]

 

switch(config-router)# area 10 authentication

エリアの認証モードを設定します。

ステップ 4

interface interface-type slot/port

 

switch(config-router)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 5

ip ospf authentication-key [ 0 | 3 ] key

 

switch(config-if)# ip ospf authentication-key 0 mypass

(任意)このインターフェイスに簡易パスワード認証を設定します。認証が、キーチェーンにもメッセージ ダイジェストにも設定されていない場合は、このコマンドを使用します。0 の場合は、パスワードをクリア テキストで設定します。3 の場合は、パスワードを 3DES 暗号化として設定します。

ip ospf message-digest-key key-id md5 [ 0 | 3 ] key

 

switch(config-if)# ip ospf message-digest-key 21 md5 0 mypass

(任意)このインターフェイスにメッセージ ダイジェスト認証を設定します。認証がメッセージ ダイジェストに設定されている場合は、このコマンドを使用します。key-id の範囲は 1 ~ 255 です。MD5 オプションが 0 の場合はパスワードがクリア テキストで設定され、3 の場合はパス キーが 3DES 暗号化として設定されます。

ステップ 6

show ip ospf instance-tag interface interface-type slot/port

 

switch(config-if)# show ip ospf 201 interface ethernet 1/2

(任意)OSPF 情報を表示します。

ステップ 7

copy running-config startup-config

 

switch(config)# copy running-config startup-config

(任意)この設定変更を保存します。

インターフェイスの認証の設定

エリア内の個々のインターフェイスに認証を設定できます。インターフェイス認証設定を使用すると、エリア認証は無効になります。

操作の前に

OSPF 機能がイネーブルにされていることを確認します(OSPFv2 機能のイネーブル化を参照)。

インターフェイス上のすべてのネイバーが、共有認証キーを含め、同じ認証設定を共有することを確認します。

この認証設定のキーチェーンを作成します。詳細については『 Cisco NX-OS Security Configuration Guide 』を参照してください。

正しい VDC を使用していることを確認します(または、 switchto vdc コマンドを使用します)。

コマンドの一覧

1. config t

2. interface interface-type slot/port

3. ip ospf authentication [ key-chain key-id | message-digest | null ]

4. ip ospf authentication-key [ 0 | 3 ] key

または

ip ospf message-digest-key key-id md5 [ 0 | 3 ] key

5. show ip ospf instance-tag interface interface-type slot/por t

6. copy running-config startup-config

詳細な手順

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface interface-type slot/port

 

switch(config)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

ip ospf authentication [ key-chain key-name | message-digest | null ]

 

switch(config-if)# ip ospf authentication message-digest

OSPFv2 のインターフェイス認証モードを設定します。これにより、エリアに基づくこのインターフェイスの認証が無効となります。すべてのネイバーが、この認証タイプを共有する必要があります。

キーチェーンの詳細については、『 Cisco NX-OS Security Configuration Guide 』Release 4.0 を参照してください。

ステップ 4

ip ospf authentication-key [ 0 | 3 | 7 ] key

 

switch(config-if)# ip ospf authentication-key 0 mypass

(任意)このインターフェイスに簡易パスワード認証を設定します。認証が、キーチェーンにもメッセージ ダイジェストにも設定されていない場合は、このコマンドを使用します。

オプションは次のとおりです。

0 ― パスワードをクリア テキストで設定します。

3 ― パス キーを 3DES 暗号化として設定します。

7 ― パス キーを Cisco タイプ 7 暗号化として設定します。

ステップ 5

ip ospf message-digest-key key-id md5 [ 0 | 3 | 7 ] key

 

switch(config-if)# ip ospf message-digest-key 21 md5 0 mypass

(任意)このインターフェイスにメッセージ ダイジェスト認証を設定します。認証がメッセージ ダイジェストに設定されている場合は、このコマンドを使用します。key-id の範囲は 1 ~ 255 です。MD5 オプションは次のとおりです。

0 ― パスワードをクリア テキストで設定します。

3 ― パス キーを 3DES 暗号化として設定します。

7 ― パス キーを Cisco タイプ 7 暗号化として設定します。

ステップ 6

show ip ospf instance-tag interface interface-type slot/port

 

switch(config-if)# show router ospf 201 interface ethernet 1/2

(任意)OSPF 情報を表示します。

ステップ 7

copy running-config startup-config

 

switch(config)# copy running-config startup-config

(任意)この設定変更を保存します。

次に、インターフェイスに暗号化されていない簡単なパスワードを設定し、イーサネット インターフェイス 1/2 のパスワードを設定する例を示します。

switch# config t

switch(config)# router ospf 201

switch(config-router)# exit

switch(config)# interface ethernet 1/2

switch(config-if)# ip router ospf 201 area 10

switch(config-if)# ip ospf authentication

switch(config-if)# ip ospf authentication-key 0 mypass

switch(config-if)# copy running-config startup-config

 

高度な OSPFv2 の設定

OSPFv2 は、OSPFv2 ネットワークを設計したあとに設定します。

ここでは、次の内容について説明します。

「境界ルータのフィルタ リストの設定」

「スタブ エリアの設定」

「Totally Stubby エリアの設定」

「NSSA の設定」

「仮想リンクの設定」

「再配布の設定」

「ルート集約の設定」

「スタブ ルート アドバタイズメントの設定」

「デフォルト タイマーの変更」

「グレースフル リスタートの設定」

「OSPFv2 インスタンスの再起動」

「グレースフル リスタートの設定」

境界ルータのフィルタ リストの設定

OSPFv2 ドメインを、関連性のある各ネットワークを含む一連のエリアに分離できます。すべてのエリアは、ABR 経由でバックボーン エリアに接続している必要があります。OSPFv2 ドメインは、 自律システム境界ルータ (ASBR; 自律システム境界ルータ)を介して、外部ドメインにも接続可能です。「エリア」を参照してください。

ABR には、省略可能な次の設定パラメータがあります。

Area range ― エリア間のルート集約を設定します。「ルート集約の設定」を参照してください。

Filter list ― ABR 上で、外部エリアから受信したネットワーク集約(タイプ 3)LSA をフィルタリングします。

ASBR もフィルタ リストをサポートしています。

操作の前に

OSPF 機能がイネーブルにされていることを確認します(OSPFv2 機能のイネーブル化を参照)。

フィルタ リストが、着信または発信ネットワーク集約(タイプ 3)LSA の IP プレフィクスのフィルタリングに使用するルートマップを作成します。 第 14 章「Route Policy Manager の設定」 を参照してください。

正しい VDC を使用していることを確認します(または、 switchto vdc コマンドを使用します)。

コマンドの一覧

1. config t

2. router ospf instance-tag

3. area area-id filter-list route-map map-name {in | out}

4. show ip ospf policy statistics

5. copy running-config startup-config

詳細な手順

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router ospf instance-tag

 

switch(config)# router ospf 201

switch(config-router)#

新規 OSPFv2 インスタンスを作成して、設定済みのインスタンス タグを割り当てます。

ステップ 3

area area-id filter-list route-map map-name { in | out }

 

switch(config-router)# area 10 filter-list route-map FilterLSAs in

ABR 上で着信または発信ネットワーク集約(タイプ 3)LSA をフィルタリングします。

ステップ 4

show ip ospf policy statistics area id filter-list { in | out }

 

switch(config-if)# show ip ospf policy statistics area 10 filter-list in

(任意)OSPF ポリシー情報を表示します。

ステップ 5

copy running-config startup-config

 

switch(config)# copy running-config startup-config

(任意)この設定変更を保存します。

次に、エリア 10 でフィルタ リストを設定する例を示します。

switch# config t

switch(config)# router ospf 201

switch(config-router)# area 10 filter-list route-map FilterLSAs in

switch(config-router)# copy running-config startup-config

 

スタブ エリアの設定

OSPFv2 ドメインの、外部トラフィックが不要な部分にスタブ エリアを設定できます。スタブ エリアは AS 外部(タイプ 5)LSA をブロックし、不要な、選択したネットワークへの往復のルーティングを制限します。「スタブ エリア」を参照してください。また、すべての集約ルートがスタブ エリアを経由しないようブロックすることもできます。

操作の前に

OSPF 機能がイネーブルにされていることを確認します(OSPFv2 機能のイネーブル化を参照)。

設定されるスタブ エリア内に、仮想リンクと ASBR のいずれも含まれないことを確認します。

正しい VDC を使用していることを確認します(または、 switchto vdc コマンドを使用します)。

コマンドの一覧

1. config t

2. router ospf instance-tag

3. area area-id stub

4. area area-id default-cost cost

5. show ip ospf instance-tag

6. copy running-config startup-config

詳細な手順

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router ospf instance-tag

 

switch(config)# router ospf 201

switch(config-router)#

新規 OSPFv2 インスタンスを作成して、設定済みのインスタンス タグを割り当てます。

ステップ 3

area area-id stub

 

switch(config-router)# area 10 stub

このエリアをスタブ エリアとして作成します。

ステップ 4

area area-id default-cost cost

 

switch(config-router)# area 10 default-cost 25

(任意)このスタブ エリアに送信されるデフォルト集約ルートのコスト メトリックを設定します。有効値の範囲は 0 ~ 16777215 であり、デフォルトは 1 です。

ステップ 5

show ip ospf instance-tag

 

switch(config-if)# show ip ospf 201

(任意)OSPF 情報を表示します。

ステップ 6

copy running-config startup-config

 

switch(config)# copy running-config startup-config

(任意)この設定変更を保存します。

次に、スタブ エリアを作成する例を示します。

switch# config t

switch(config)# router ospf 201

switch(config-router)# area 10 stub

switch(config-router)# copy running-config startup-config

 

Totally Stubby エリアの設定

Totally Stubby エリアを作成して、すべての集約ルート更新がスタブ エリアを経由しないようにすることができます。

Totally Stubby エリアを作成するには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

area area-id stub no-summary

 

switch(config-router)# area 20 stub no-summary

このエリアを Totally Stubby エリアとして作成します。

NSSA の設定

OSPFv2 ドメインの、ある程度の外部トラフィックが必要な部分に NSSA を設定できます。「Not-So-Stubby エリア」を参照してください。また、この外部トラフィックを AS 外部(タイプ 5)LSA に変換して、このルーティング情報で OSPFv2 ドメインをフラッディングすることもできます。NSSA は、省略可能な次のパラメータで設定できます。

No redistribution ― 再配布されたルートが NSSA をバイパスして、OSPFv2 AS 内の他のエリアに再配布されます。このオプションは、NSSA ASBR が ABR も兼ねているときに使用します。

Default information originate ― 外部 AS へのデフォルト ルートの NSSA 外部(タイプ 7)LSA を生成します。このオプションは、ASBR のルーティング テーブルにデフォルト ルートが含まれる場合に NSSA ASBR 上で使用します。このオプションは、ASBR のルーティング テーブルにデフォルト ルートが含まれるかどうかに関係なく、NSSA ASBR 上で使用できます。

Route map ― 目的のルートのみが NSSA および他のエリア全体でフラッディングされるよう、外部ルートをフィルタリングします。

Translate ― NSSA 外のエリア向けに、NSSA 外部 LSA を AS 外部 LSA に変換します。再配布されたルートを OSPFv2 AS 全体でフラッディングするには、このコマンドを NSSA ABR 上で使用します。また、これらの AS 外部 LSA の転送アドレスを無効にすることもできます。このオプションを選択した場合は、転送アドレスが 0.0.0.0 に設定されます。

No summary ― すべての集約ルートが NSSA でフラッディングされないようにします。このオプションは NSSA ABR 上で使用します。

操作の前に

OSPF 機能がイネーブルにされていることを確認します(OSPFv2 機能のイネーブル化を参照)。

設定する NSSA 上に仮想リンクがないことと、この NSSA がバックボーン エリアでないことを確認します。

正しい VDC を使用していることを確認します(または、 switchto vdc コマンドを使用します)。

コマンドの一覧

1. config t

2. router ospf instance-tag

3. area area-id nssa [ no-redistribution ] [ default-information-originate [ route-map map-name ]] [ no-summary ] [ translate type7 { always | never } [ suppress-fa ]]

4. area area-id default-cost cost

5. show ip ospf instance-tag

6. copy running-config startup-config

詳細な手順

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router ospf instance-tag

 

switch(config)# router ospf 201

switch(config-router)#

新規 OSPFv2 インスタンスを作成して、設定済みのインスタンス タグを割り当てます。

ステップ 3

area area-id nssa [ no-redistribution ] [ default-information-originate ]

[ route-map map-name ]] [ no-summary ] [ translate type7 { always | never } [ suppress-fa ]]

 

switch(config-router)# area 10 nssa

このエリアを NSSA として作成します。

ステップ 4

area area-id default-cost cost

 

switch(config-router)# area 10 default-cost 25

(任意)この NSSA に送信されるデフォルト集約ルートのコスト メトリックを設定します。

ステップ 5

show ip ospf instance-tag

 

switch(config-if)# show ip ospf 201

(任意)OSPF 情報を表示します。

ステップ 6

copy running-config startup-config

 

switch(config)# copy running-config startup-config

(任意)この設定変更を保存します。

次に、すべての集約ルート更新をブロックする NSSA を作成する例を示します。

switch# config t

switch(config)# router ospf 201

switch(config-router)# area 10 nssa no-summary

switch(config-router)# copy running-config startup-config

 

次に、デフォルト ルートを生成する NSSA を作成する例を示します。

switch# config t

switch(config)# router ospf 201

switch(config-router)# area 10 nssa default-info-originate

switch(config-router)# copy running-config startup-config

 

次に、外部ルートをフィルタリングし、すべての集約ルート更新をブロックする NSSA を作成する例を示します。

switch# config t

switch(config)# router ospf 201

switch(config-router)# area 10 nssa route-map ExternalFilter no-summary

switch(config-router)# copy running-config startup-config

 

次に、つねに NSSA 外部(タイプ 7)LSA を AS 外部(タイプ 5)LSA に変換する NSSA を作成する例を示します。

switch# config t

switch(config)# router ospf 201

switch(config-router)# area 10 nssa translate type 7 always

switch(config-router)# copy running-config startup-config

 

仮想リンクの設定

仮想リンクは、隔離されたエリアを、中継エリア経由でバックボーン エリアに接続します。「仮想リンク」を参照してください。仮想リンクには、省略可能な次のパラメータを設定できます。

Authentication ― 簡単なパスワード認証または MD5 メッセージ ダイジェスト認証、および関連付けられたキーを設定します。

Dead interval ― ローカル ルータがデッドであることを宣言し、隣接関係を解消する前に、ネイバーが hello パケットを待つ時間を設定します。

Hello interval ― 連続する hello パケット間の時間間隔を設定します。

Retransmit interval ― 連続する LSA 間の推定時間間隔を設定します。

Transmit delay ― LSA をネイバーに送信する推定時間間隔を設定します。


) リンクがアクティブになる前に、関与する両方のルータで仮想リンクを設定する必要があります。


スタブ エリアには仮想リンクを追加できません。

操作の前に

OSPF 機能がイネーブルにされていることを確認します(OSPFv2 機能のイネーブル化を参照)。

正しい VDC を使用していることを確認します(または、 switchto vdc コマンドを使用します)。

コマンドの一覧

1. config t

2. router ospf instance-tag

3. area area-id virtual-link router-id

4. show ip ospf virtual-link [ brief ]

5. copy running-config startup-config

詳細な手順

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router ospf instance-tag

 

switch(config)# router ospf 201

switch(config-router)#

新規 OSPFv2 インスタンスを作成して、設定済みのインスタンス タグを割り当てます。

ステップ 3

area area-id virtual-link router-id

 

switch(config-router)# area 10 virtual-link 10.1.2.3

switch(config-router-vlink)#

リモート ルータへの仮想リンクの端を作成します。仮想リンクをリモート ルータ上に作成して、リンクを完成させる必要があります。

ステップ 4

show ip ospf virtual-link [ brief ]

 

switch(config-router-vlink)# show ip ospf virtual-link

(任意)OSPF 仮想リンク情報を表示します。

ステップ 5

copy running-config startup-config

 

switch(config-router-vlink)# copy running-config startup-config

(任意)この設定変更を保存します。

仮想リンク コンフィギュレーション モードで、省略可能な次のコマンドを設定できます。

 

コマンドまたはアクション
目的

authentication [ key-chain key-id | message-digest | null ]

 

switch(config-router-vlink)# authentication message-digest

(任意)これにより、エリアに基づくこの仮想リンクの認証が無効となります。

authentication-key [ 0 | 3 ] key

 

switch(config-router-vlink)# authentication-key 0 mypass

(任意)この仮想リンクに簡易パスワードを設定します。認証が、キーチェーンにもメッセージ ダイジェストにも設定されていない場合は、このコマンドを使用します。0 の場合は、パスワードをクリア テキストで設定します。3 の場合は、パスワードを 3DES 暗号化として設定します。

dead-interval seconds

 

switch(config-router-vlink)# dead-interval 50

(任意)OSPFv2 デッド間隔を秒単位で設定します。有効値の範囲は 1 ~ 65535 です。デフォルトでは、hello 間隔の秒数の 4 倍です。

hello-interval seconds

 

switch(config-router-vlink)# hello-interval 25

(任意)OSPFv2 hello 間隔を秒単位で設定します。有効値の範囲は 1 ~ 65535 であり、デフォルトは 10 秒です。

message-digest-key key-id md5 [ 0 | 3 ] key

 

switch(config-router-vlink)#

message-digest-key 21 md5 0 mypass

(任意)この仮想リンクにメッセージ ダイジェスト認証を設定します。認証がメッセージ ダイジェストに設定されている場合は、このコマンドを使用します。0 の場合は、パスワードをクリア テキストで設定します。3 の場合は、パス キーを 3DES 暗号化として設定します。

retransmit-interval seconds

 

switch(config-router-vlink)# retransmit-interval 50

(任意)OSPFv2 再送間隔を秒単位で設定します。有効値の範囲は 1 ~ 65535 であり、デフォルトは 5 です。

transmit-delay seconds

 

switch(config-router-vlink)# transmit-delay 2

(任意)OSPFv2 送信遅延を秒単位で設定します。有効値の範囲は 1 ~ 450 であり、デフォルトは 1 です。

次に、2 つの ABR 間に簡単な仮想リンクを作成する例を示します。

ABR 1(ルータ ID 27.0.0.55)の設定は、次のとおりです。

switch# config t

switch(config)# router ospf 201

switch(config-router)# area 10 virtual-link 10.1.2.3

switch(config-router)# copy running-config startup-config

 

ABR 2(ルータ ID 10.1.2.3)の設定は、次のとおりです。

switch# config t

switch(config)# router ospf 101

switch(config-router)# area 10 virtual-link 27.0.0.55

switch(config-router)# copy running-config startup-config

 

再配布の設定

他のルーティング プロトコルから学習したルートを、ASBR 経由で OSPFv2 AS に再配布できます。

OSPF でのルート再配布には、省略可能な次のパラメータを設定できます。

Default information originate ― 外部 AS へのデフォルト ルートの AS 外部(タイプ 5)LSA を生成します。

Default metric ― すべての再配布ルートに同じコスト メトリックを設定します。

操作の前に

OSPF 機能がイネーブルにされていることを確認します(OSPFv2 機能のイネーブル化を参照)。

再配布で使用する、必要なルートマップを作成します。

正しい VDC を使用していることを確認します(または、 switchto vdc コマンドを使用します)。

コマンドの一覧

1. config t

2. router ospf instance-tag

3. redistribute { bgp id | direct | eigrp id | isis id | ospf id | rip id | static } route-map map-name

4. default-information originate [ always ] [ route-map map-name ]

5. default-metric cost

6. exit

7. copy running-config startup-config

詳細な手順

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router ospf instance-tag

 

switch(config)# router ospf 201

switch(config-router)#

新規 OSPFv2 インスタンスを作成して、設定済みのインスタンス タグを割り当てます。

ステップ 3

redistribute { bgp id | direct | eigrp id | isis id | ospf id | rip id | static } route-map map-name

 

switch(config-router)# redistribute bgp route-map FilterExternalBGP

設定したルートマップ経由で、選択したプロトコルを OSPF に再配布します。

ステップ 4

default-information originate [ always ] [ route-map map-name]

 

switch(config-router)# default-information-originate route-map DefaultRouteFilter

この OSPF ドメインにデフォルト ルートを作成します。always を使用すると、つねにデフォルトを作成します。route-map を使用すると、条件付きで(RIB にデフォルト ルートがある場合)、ルートマップが true を返す場合にデフォルト ルートを生成します。(再配布の概念に追加)

ステップ 5

default-metric cost

 

switch(config-router)# default-metric 25

再配布されたルートのコスト メトリックを設定します。

ステップ 6

copy running-config startup-config

 

switch(config-router)# copy running-config startup-config

(任意)この設定変更を保存します。

次に、Border Gateway Protocol(BGP)を OSPF に再配布する例を示します。

switch# config t

switch(config)# router ospf 201

switch(config-router)# redistribute bgp route-map FilterExternalBGP

switch(config-router)# copy running-config startup-config

 

ルート集約の設定

集約されたアドレス範囲を設定して、エリア間ルートのルート集約を設定できます。また、ASBR 上のこれらのルートの集約アドレスを設定して、外部の再配布されたルートのルート集約を設定することもできます。「ルート集約」を参照してください。

操作の前に

OSPF 機能がイネーブルにされていることを確認します(OSPFv2 機能のイネーブル化を参照)。

正しい VDC を使用していることを確認します(または、 switchto vdc コマンドを使用します)。

コマンドの一覧

1. config t

2. router ospf instance-tag

3. area area-id range ip-prefix/length [ no-advertise ]

または

4. summary-address ip-prefix/length [ no-advertise | tag tag-id ]

5. show ip ospf summary-address

6. copy running-config startup-config

詳細な手順

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router ospf instance-tag

 

switch(config)# router ospf 201

switch(config-router)#

新規 OSPFv2 インスタンスを作成して、設定済みのインスタンス タグを割り当てます。

ステップ 3

area area-id range ip-prefix/length [ no-advertise ]

 

switch(config-router)# area 10 range 10.3.0.0/16

一定の範囲のアドレスの集約アドレスを ABR 上に作成します。この集約アドレスをネットワーク集約(タイプ 3)LSA にアドバタイズしないようにすることもできます。

ステップ 4

summary-address ip-prefix/length [ no-advertise | tag tag]

 

switch(config-router)# summary-address 10.5.0.0/16 tag 2

一定の範囲のアドレスの集約アドレスを ABR 上に作成します。ルートマップによる再配布で使用できるよう、この集約アドレスにタグを割り当てることもできます。

ステップ 5

show ip ospf summary-address

 

switch(config-router)# show ip ospf summary-address

(任意)OSPF 集約アドレスに関する情報を表示します。

ステップ 6

copy running-config startup-config

 

switch(config-router)# copy running-config startup-config

(任意)この設定変更を保存します。

次に、ABR 上のエリア間の集約アドレスを作成する例を示します。

switch# config t

switch(config)# router ospf 201

switch(config-router)# area 10 range 10.3.0.0/16

switch(config-router)# copy running-config startup-config

 

次に、ABR 上の集約アドレスを作成する例を示します。

switch# config t

switch(config)# router ospf 201

switch(config-router)# summary-address 10.5.0.0/16

switch(config-router)# copy running-config startup-config

 

スタブ ルート アドバタイズメントの設定

短期間だけ、このルータ経由の OSPFv2 トラフィックを制限する場合は、スタブ ルート アドバタイズメントを使用します。「OSPFv2 スタブ ルータ アドバタイズメント」を参照してください。

スタブ ルート アドバタイズメントは、省略可能な次のパラメータで設定できます。

On startup ― 指定した宣言期間だけ、スタブ ルート アドバタイズメントを送信します。

Wait for BGP ― BGP が収束するまで、スタブ ルート アドバタイズメントを送信します。

操作の前に

OSPF 機能がイネーブルにされていることを確認します(OSPFv2 機能のイネーブル化を参照)。

正しい VDC を使用していることを確認します(または、 switchto vdc コマンドを使用します)。

コマンドの一覧

1. config t

2. router ospf instance-tag

3. max-metric router-lsa [ on-startup [ announce-time ] [ wait-for bgp tag ]]

4. copy running-config startup-config


) ルータの実行コンフィギュレーションがグレースフル シャットダウンを行うよう設定されている場合は、その実行コンフィギュレーションを保存しないでください。保存すると、ルータが、リロード後に最大メトリックをアドバタイズし続けることになります。


詳細な手順

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router ospf instance-tag

 

switch(config)# router ospf 201

switch(config-router)#

新規 OSPFv2 インスタンスを作成して、設定済みのインスタンス タグを割り当てます。

ステップ 3

max-metric router-lsa [ on-startup [ announce-time ] [ wait-for bgp tag ]]

 

switch(config-router)# max-metric router-lsa

OSPFv2 スタブ ルート アドバタイズメントを設定します。on-start-up を使用すると、アドバタイズメントの最初の起動時またはシステムの起動時にアドバタイズします。bgp のインスタンスの起動を待ち、概念に追加します。

ステップ 4

copy running-config startup-config

 

switch(config-router)# copy running-config startup-config

(任意)この設定変更を保存します。

次に、起動時にスタブ ルータ アドバタイズメント機能を、デフォルトの 600 秒間イネーブルにする例を示します。

switch# config t

switch(config)# router ospf 201

switch(config-router)# max-metric router-lsa on-startup

switch(config-router)# copy running-config startup-config

 

デフォルト タイマーの変更

OSPFv2 には、プロトコル メッセージの動作および SPF 計算を制御する数多くのタイマーが含まれます。OSPFv2 には、省略可能な次のタイマー パラメータが含まれます。

LSA arrival time ― ネイバーから着信する LSA 間で許容される最小間隔を設定します。この時間より短時間で到着する LSA はドロップされます。

Pacing LSAs ― LSA が集められてグループ化され、リフレッシュされて、チェックサムが計算される間隔、つまり期限切れとなる間隔を設定します。このタイマーは、LSA 更新が実行される頻度を制御し、LSA 更新メッセージで送信される LSA 更新の数を制御します(フラッディングと LSA グループ ペーシングを参照)。

Throttle LSAs ― LSA 生成のレート制限を設定します。このタイマーは、トポロジが変更されない場合に LSA が生成される頻度を制御します。

Throttle SPF calculation ― SPF 計算の実行頻度を制御します。

インターフェイス レベルでは、次のタイマーも制御できます。

Retransmit interval ― 連続する LSA 間の推定時間間隔を設定します。

Transmit delay ― LSA をネイバーに送信する推定時間を設定します。

hello 間隔とデッド タイマーに関する情報の詳細については、「OSPFv2 でのネットワークの設定」を参照してください。

操作の前に

OSPF 機能がイネーブルにされていることを確認します(OSPFv2 機能のイネーブル化を参照)。

正しい VDC を使用していることを確認します(または、 switchto vdc コマンドを使用します)。

コマンドの一覧

1. config t

2. router ospf instance-tag

3. timers lsa-arrival msec

4. timers lsa-group-pacing seconds

5. timers throttle lsa { network hold-interval | router hold-interva l }

6. timers throttle spf delay-time hold-time

7. interface type slot/port

8. ip ospf hello-interval seconds

9. ip ospf dead-interval seconds

10. ip ospf retransmit-interval seconds

11. ip ospf transmit-delay seconds

12. show ip ospf

13. copy running-config startup-config

詳細な手順

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router ospf instance-tag

 

switch(config)# router ospf 201

switch(config-router)#

新規 OSPFv2 インスタンスを作成して、設定済みのインスタンス タグを割り当てます。

ステップ 3

timers lsa-arrival msec

 

switch(config-router)# timers lsa-arrival 2000

LSA 到着時間をミリ秒で設定します。有効値の範囲は 10 ~ 600000 であり、デフォルトは 1000 ミリ秒です。

ステップ 4

timers lsa-group-pacing seconds

 

switch(config-router)# timers lsa-group-pacing 2000

LSA がグループ化される間隔を秒で設定します。有効値の範囲は 1 ~ 1800 であり、デフォルトは 240 秒です。

ステップ 5

timers throttle lsa { network delay-interval | router hold-interval }

 

switch(config-router)# timers throttle lsa network 3000

LSA 生成のレート制限をミリ秒で設定します。有効値の範囲は 10 ~ 600000 であり、デフォルトは 5000 ミリ秒です。

ステップ 6

timers throttle spf delay-time hold-time max-wait

 

switch(config-router)# timers throttle spf 3000 2000 4000

SPF 最適パス スケジュール初期遅延時間と、各 SPF 最適パス計算間の最小保留時間(秒単位)を設定します。有効値の範囲は 1 ~ 600000 です。デフォルトは、遅延時間なし、および保留時間 5000 ミリ秒です。

ステップ 7

interface type slot/port

 

switch(config)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 8

ip ospf hello-interval seconds

 

switch(config-if)# ip ospf retransmit-interval 30

このインターフェイスの hello 間隔を設定します。有効値の範囲は 1 ~ 65535 であり、デフォルトは 10 です。

ステップ 9

ip ospf dead-interval seconds

 

switch(config-if)# ip ospf retransmit-interval 30

このインターフェイスのデッド間隔を設定します。有効値の範囲は 1 ~ 65535 です。

ステップ 10

ip ospf retransmit-interval seconds

 

switch(config-if)# ip ospf retransmit-interval 30

このインターフェイスから送信される各 LSA 間の推定時間間隔を設定します。有効値の範囲は 1 ~ 65535 であり、デフォルトは 5 です。

ステップ 11

ip ospf transmit-delay seconds

 

switch(config-if)# ip ospf transmit-delay 600

switch(config-if)#

LSA をネイバーに送信する推定時間間隔を秒で設定します。有効値の範囲は 1 ~ 450 であり、デフォルトは 1 です。

ステップ 12

show ip ospf

 

switch(config-if)# show ip ospf

(任意)OSPF に関する情報を表示します。

ステップ 13

copy running-config startup-config

 

switch(config-if)# copy running-config startup-config

(任意)この設定変更を保存します。

次に、lsa-group-pacing オプションで LSA フラッディングを制御する例を示します。

switch# config t

switch(config)# router ospf 201

switch(config-router)# timers lsa-group-pacing 300

switch(config-router)# copy running-config startup-config

 

グレースフル リスタートの設定

グレースフル リスタートは、デフォルトでイネーブルにされています。OSPFv2 インスタンスのグレースフル リスタートには、省略可能な次のパラメータを設定できます。

Grace period ― グレースフル リスタートの開始後に、ネイバーが隣接関係を解消するまでに待つ時間を設定します。

Helper mode disabled ― ローカル OSPFv2 インスタンスのヘルパー モードをディセーブルにします。OSPFv2 は、ネイバーのグレースフル リスタートには関与しません。

Planned graceful restart only ― 予定された再起動の場合にのみグレースフル リスタートがサポートされるよう、OSPFv2 を設定します。

操作の前に

OSPF 機能がイネーブルにされていることを確認します(OSPFv2 機能のイネーブル化を参照)。

すべてのネイバーで、一致した省略可能なパラメータ一式とともにグレースフル リスタートが設定されていることを確認します。

正しい VDC を使用していることを確認します(または、 switchto vdc コマンドを使用します)。

コマンドの一覧

1. config t

2. router ospf instance-tag

3. graceful-restart

4. graceful-restart grace-period seconds

5. graceful-restart helper-disable

6. graceful-restart planned-only

7. show ip ospf instance-tag

8. copy running-config startup-config

詳細な手順

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router ospf instance-tag

 

switch(config)# router ospf 201

switch(config-router)#

新規 OSPFv2 インスタンスを作成して、設定済みのインスタンス タグを割り当てます。

ステップ 3

graceful-restart

 

switch(config-router)# graceful-restart

グレースフル リスタートをイネーブルにします。グレースフル リスタートは、デフォルトでイネーブルにされています。

ステップ 4

graceful-restart grace-period seconds

 

switch(config-router)# graceful-restart grace-period 120

(任意)猶予期間を秒で設定します。有効値の範囲は 5 ~ 1800 であり、デフォルトは 60 秒です。

ステップ 5

graceful-restart helper-disable

 

switch(config-router)# graceful-restart helper-disable

(任意)ヘルパー モードをディセーブルにします。デフォルトではイネーブルにされています。

ステップ 6

graceful-restart planned-only

 

switch(config-router)# graceful-restart planned-only

(任意)予定された再起動時にのみグレースフル リスタートを設定します。

ステップ 7

show ip ospf instance-tag

 

switch(config-if)# show ip ospf 201

(任意)OSPF 情報を表示します。

ステップ 8

copy running-config startup-config

 

switch(config)# copy running-config startup-config

(任意)この設定変更を保存します。

次に、ディセーブルにされているグレースフル リスタートをイネーブルにし、猶予期間を 120 秒に設定する例を示します。

switch# config t

switch(config)# router ospf 201

switch(config-router)# graceful-restart

switch(config-router)# graceful-restart grace-period 120

switch(config-router)# copy running-config startup-config

 

OSPFv2 インスタンスの再起動

OSPv2 インスタンスを再起動できます。再起動すると、インスタンスのすべてのネイバーが解消されます。

OSPFv2 インスタンスを再起動して、関連付けられたすべてのネイバーを削除するには、次のコマンドを使用します。

 

コマンド
目的

restart ospf instance-tag

 

switch(config)# restart ospf 201

OSPFv2 インスタンスを再起動して、すべてのネイバーを削除します。

仮想化による OSPFv2 の設定

各 VDC で複数の OSPFv2 インスタンスを設定できます。各 VDC 内に複数の VRF を作成して、各 VRF で同じまたは複数の OSPFv2 インスタンスを使用することもできます。VRF には OSPFv2 インターフェイスを割り当てます。


) インターフェイスの VRF を設定したあとに、インターフェイスの他のすべてのパラメータを設定します。インターフェイスの VRF を設定すると、そのインターフェイスのすべての設定が削除されます。


操作の前に

VDC を作成します。

OSPF 機能がイネーブルにされていることを確認します(OSPFv2 機能のイネーブル化を参照)。

正しい VDC を使用していることを確認します(または、 switchto vdc コマンドを使用します)。

コマンドの一覧

1. config t

2. vrf context vrf_name

3. exit

4. router ospf instance-tag

5. vrf vrf-name

6. <optional parameters configured>

7. interface interface-type slot/port

8. vrf member vrf-name

9. ip-address ip-prefix/length

10. router ospf instance-tag area area-id

11. copy running-config startup-config

詳細な手順

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

vrf context vrf-name

 

switch(config)# vrf context RemoteOfficeVRF

switch(config-vrf)#

新しい VRF を作成し、VRF コンフィギュレーション モードを開始します。

ステップ 3

router ospf instance-tag

 

switch(config-vrf)# router ospf 201

switch(config-router)#

新規 OSPFv2 インスタンスを作成して、設定済みのインスタンス タグを割り当てます。

ステップ 4

vrf vrf-name

 

switch(config-router)# vrf RemoteOfficeVRF

switch(config-router-vrf)#

VRF コンフィギュレーション モードを開始します。

ステップ 5

maximum-paths paths

 

switch(config-router-vrf)# maximum-paths 4

(任意)この VRF のルーティング テーブル内の宛先への、同じ OSPFv2 パスの最大数を設定します。ロード バランシングに使用されます。

ステップ 6

interface interface-type slot/port

 

switch(config-router-vrf)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 7

vrf member vrf-name

 

switch(config-if)# vrf member RemoteOfficeVRF

このインターフェイスを VRF に追加します。

ステップ 8

ip address ip-prefix/length

 

switch(config-if)# ip address 209.0.2.1/16

このインターフェイスの IP アドレスを設定します。この手順は、このインターフェイスを VRF に割り当てたあとに行う必要があります。

ステップ 9

ip router ospf instance-tag area area-id

 

switch(config-if)# ip router ospf 201 area 0

設定した OSPFv2 インスタンスおよびエリアに、このインターフェイスを割り当てます。

ステップ 10

copy running-config startup-config

 

switch(config)# copy running-config startup-config

(任意)この設定変更を保存します。

次に、VRF を作成して、その VRF にインターフェイスを追加する例を示します。

switch# config t

switch(config)# vrf context NewVRF

switch(config)# router ospf 201

switch(config)# interface ethernet 1/2

switch(config-if)# vrf member NewVRF

switch(config-if)# ip address 209.0.2.1/16

switch(config-if)# ip router ospf 201 area 0

switch(config)# copy running-config startup-config

 

OSPFv2 設定の確認

OSPFv2 設定を確認するには、次のコマンドを使用します。

 

コマンド
目的

show ip ospf

OSPFv2 設定を表示します。

show ip ospf border-routers [ vrf { vrf-name | all | default | management }]

OSPFv2 境界ルータ設定を表示します。

show ip ospf database [ vrf { vrf-name | all | default | management }]

OSPFv2 リンクステート データベースの要約を表示します。

show ip ospf interface number [ vrf { vrf-name | all | default | management }]

OSPFv2 インターフェイス設定を表示します。

show ip ospf lsa-content-changed-list interface - type number [ vrf { vrf-name | all | default | management }]

変更された OSPFv2 LSA を表示します。

show ip ospf neighbors [ neighbor-id ] [detail] [ interface - type number ] [ vrf { vrf-name | all | default | management }] [ summary ]

OSPFv2 ネイバーの一覧を表示します。

show ip ospf request-list neighbor-id [ interface - type number ] [ vrf { vrf-name | all | default | management }]

OSPFv2 リンクステート要求の一覧を表示します。

show ip ospf retransmission-list neighbor-id [ interface - type number ] [ vrf { vrf-name | all | default | management }]

OSPFv2 リンクステート再送の一覧を表示します。

show ip ospf route [ ospf-route ] [ summary ] [ vrf { vrf-name | all | default | management }]

内部 OSPFv2 ルートを表示します。

show ip ospf summary-address [ vrf { vrf-name | all | default | management }]

OSPFv2 集約アドレスに関する情報を表示します。

show ip ospf virtual-links [ brief ] [ vrf { vrf-name | all | default | management }]

OSPFv2 仮想リンクに関する情報を表示します。

show ip ospf vrf { vrf-name | all | default | management }

VRF ベースの OSPFv2 設定に関する情報を表示します。

show running-configuration ospf

現在実行中の OSPFv2 設定を表示します。

OSPFv2 統計情報の表示

OSPFv2 統計情報を表示するには、次のコマンドを使用します。

 

コマンド
目的

show ip ospf memory

OSPFv2 メモリ使用状況の統計情報を表示します。

show ip ospf policy statistics area area-id filter-list { in | out } [ vrf { vrf-name | all | default | management }]

エリアの OSPFv2 ルート ポリシー統計情報を表示します。

show ip ospf policy statistics redistribute { bgp id | direct | eigrp id | isis id | ospf id | rip id | static } vrf { vrf-name | all | default | management }]

OSPFv2 ルート ポリシー統計情報を表示します。

show ip ospf statistics [ vrf { vrf-name | all | default | management }]

OSPFv2 イベント カウンタを表示します。

show ip ospf traffic [ interface - type number ] [ vrf { vrf-name | all | default | management }]

OSPFv2 パケット カウンタを表示します。

OSPFv2 設定の例

次に、OSPFv2 を設定する例を示します。

feature ospf
router ospf 201
router-id 290.0.2.1
 
interface ethernet 1/2
ip router ospf 201 area 10
ip ospf authentication
ip ospf authentication-key 0 mypass
 

デフォルト設定

表5-2 は、OSPFv2 パラメータのデフォルト設定の一覧です。

 

表5-2 デフォルト OSPFv2 パラメータ

パラメータ
デフォルト

Hello interval

10 秒

Dead interval

40 秒

Graceful restart grace period

60 秒

Graceful restart notify period

15 秒

OSPFv2 feature

ディセーブル

Stub router advertisement announce time

600 秒

Reference bandwidth for link cost calculation

40 Gbps

LSA minimal arrival time

1000 ミリ秒

LSA group pacing

240 秒

SPF calculation initial delay time

0 ミリ秒

SPF calculation hold time

5000 ミリ秒

SPF calculation initial delay time

0 ミリ秒

その他の関連資料

OSPF の実装に関する詳細情報については、次のページを参照してください。

「関連資料」

「MIB」

関連資料

 

関連項目
マニュアル名

OSPFv2 CLI コマンド

Cisco NX-OS Unicast Routing Command Line Reference

VDC

Cisco NX-OS Virtual Device Contexts Configuration Guide

IPv6 ネットワーク向け OSPFv3

第 6 章「OSPFv3 の設定」

ルートマップ

第 14 章「Route Policy Manager の設定」

MIB

 

MIB
MIB のリンク

OSPF-MIB

OSPF-TRAP-MIB

MIB を見つけてダウンロードするには、次の URL を参照してください。

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml