Cisco NX-OS Unicast Routing コンフィギュレーション ガイド Release 4.0
RIP の設定
RIP の設定
発行日;2012/01/13 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

RIP の設定

RIP 情報

RIP の概要

RIPv2 の認証

スプリット ホライズン

ルート フィルタリング

ルート集約

ルートの再配布

ロード バランシング

ハイ アベイラビリティ

仮想化サポート

RIP のライセンス要件

RIP の前提条件

設定時の注意事項および制約事項

RIP の設定

RIP 機能のイネーブル化

RIP インスタンスの作成

RIP インスタンスの再起動

インターフェイス上での RIP の設定

RIP 認証の設定

受動インターフェイスの設定

ポイズン リバースを指定した スプリット ホライズンの設定

ルート集約の設定

ルートの再配布の設定

仮想化の設定

RIP の調整

RIP の設定確認

RIP 統計情報の表示

RIP の設定例

関連項目

関連情報

デフォルト設定

その他の関連資料

関連資料

規格

RIP 情報

ここでは、次の内容について説明します。

「RIP の概要」

「RIPv2 の認証」

「スプリット ホライズン」

「ルート フィルタリング」

「ルート集約」

「ルートの再配布」

「ロード バランシング」

「ハイ アベイラビリティ」

「仮想化サポート」

RIP の概要

RIP は UDP(ユーザ データグラム プロトコル)データ パケットを使用して、小規模なインターネットワークでルーティング情報を交換します。RIPv2 は IPv4をサポートし、RIPng は IPv6 をサポートします。RIP next generation(RIPng)が IPv6 の認証を使用するのに対して、RIPv2 は RIPv2 プロトコルがサポートするオプションの認証機能を使用します(RIPv2 の認証を参照)。


) この章では特に指示がないかぎり、RIP は RIPv2 と RIPng の両方を表します。


RIP では次の 2 種類のメッセージを使用します。

要求 ― マルチキャスト アドレスに送信され、他の RIP 対応ルータにルート アップデートを要求します。

応答 ― デフォルトでは 30 秒間隔で送信されます(RIP の設定確認を参照)。ルータも、要求メッセージの受信後に応答メッセージを送信します。応答メッセージには、RIP ルート テーブル全体が含まれます。RIP ルーティング テーブルが 1 つの応答パケットに収まらない場合、RIP は 1 つの要求に対して複数の応答パケットを送信します。

RIP はルーティング メトリックとして、 ホップ カウント を使用します。ホップ カウントは、パケットが宛先に到達するまでに、通過できるルータの数です。直接接続されたネットワークのメトリックは 1 です。到達不能なネットワークのメトリックは 16 です。RIP はこのようにメトリックの範囲が小さいので、大規模なネットワークに適したルーティング プロトコルではありません。

RIPv2 の認証

ネットワークで不正または無効なルーティング アップデートが行われないように、RIP メッセージに認証を設定できます。Cisco NX-OS は、単純なパスワードまたは MD5 認証ダイジェストをサポートします。

認証鍵のキーチェーン管理を使用することによって、インターフェイスごとに RIP 認証を設定できます。キーチェーン管理によって、MD5 認証ダイジェストまたは単純テキスト パスワード認証で使用される認証鍵の変更を制御できます。キーチェーン作成の詳細については、『Cisco NX-OS Security Configuration Guide』を参照してください。

MD5 認証ダイジェストを使用するには、ローカル ルータとすべてのリモート RIP ネイバーで共有されるパスワードを設定します。Cisco NX-OS は、メッセージそのものと暗号化されたパスワードに基づいて、MD5 一方向メッセージ ダイジェストを作成し、RIP メッセージ(要求または応答)とともにこのダイジェストを送信します。受信側の RIP ネイバーは、同じ暗号パスワードを使用して、ダイジェストを検証します。メッセージが変更されていない場合は、計算が一致し、RIP メッセージは有効とみなされます。

MD5 認証ダイジェストの場合はさらに、ネットワークでメッセージが再送されないように、各 RIP メッセージにシーケンス番号が組み込まれます。

スプリット ホライズン

スプリット ホライズンを使用すると、ルートを学習したインターフェイスからは、RIP がルートをアドバタイズしないようにできます。

スプリット ホライズンは、RIP アップデートおよびクエリー パケットの送信を制御する方法です。インターフェイス上でスプリット ホライズンがイネーブルの場合、Cisco NX-OS はそのインターフェイスから学習した宛先にはアップデート パケットを送信しません。この方法でアップデート パケットを制御すると、ルーティング ループの発生する可能性が小さくなります。

ポイズン リバースを指定してスプリット ホライズンを使用すると、ルートを学習したインターフェイス経由では到達不能であると RIP が学習したルートをアドバタイズするように、インターフェイスを設定できます。図11-1 に、ポイズン リバースをイネーブルにしてスプリット ホライズンを指定した、RIP ネットワークの例を示します。

図11-1 スプリット ホライズン ポイズン リバースを指定した RIP

 

ルータ C はルート X について学習し、そのルートを ルータ B にアドバタイズします。ルータ B は次に、ルート X をルータ A にアドバタイズしますが、ルータ C には、ルート X 到達不能アップデートを戻します。

スプリット ホライズンはデフォルトで、すべてのインターフェイスでイネーブルです。

ルート フィルタリング

RIP 対応インターフェイス上でルート ポリシーを設定すると、RIP アップデートをフィルタリングできます。Cisco NX-OS は、ルート ポリシーで許可されたルートだけを使用して、ルート テーブルをアップデートします。

ルート集約

指定したインターフェイスに、複数のサマリー集約アドレスを設定できます。ルート集約を使用すると、固有性の強い一連のアドレスをすべての固有アドレスを代表する 1 つのアドレスに置き換えることによって、ルート テーブルを簡素化できます。たとえば、10.1.1.0/24、10.1.2.0/24、および 10.1.3.0/24 を 1 つのサマリー アドレス 10.1.0.0/16 に置き換えることができます。

RIP はルーティング テーブルに含まれている固有性の強いルートが多いほど、固有性の強いルートの最大メトリックと同じメトリックのインターフェイスからのサマリー アドレスをアドバタイズします。


) Cisco NX-OS は、自動ルート集約をサポートしません。


ルートの再配布

RIP を使用すると、スタティック ルートまたは他のプロトコルからのルートを再配布できます。再配布を設定するには、ルート ポリシーを使用して、RIP に渡すルートを制御します。ルート ポリシーでは、宛先、送信元プロトコル、ルート タイプ、ルート タグなどのアトリビュートに基づいて、ルートをフィルタリングできます。詳細については、 第 14 章「Route Policy Manager の設定」 を参照してください。

RIP ルーティング ドメインにルートを再配布しても、デフォルトでは Cisco NX-OS がそのつど、RIP ルーティング ドメインにデフォルト ルートを再配布することはありません。RIP への デフォルト ルート を発生させ、ルート ポリシーでそのルートを制御できます。

RIP にインポートされたすべてのルートに使用する、デフォルトのメトリックも設定できます。

ロード バランシング

ロード バランシングを使用すると、ルータによって、宛先アドレスから同じ距離にあるすべてのルータ ネットワーク ポートにトラフィックが分散されます。ロード バランシングは、ネットワーク セグメントの使用率を向上させ、有効ネットワーク帯域幅を増加させます。

Cisco NX-OS は、ECMP(等コスト マルチパス)機能をサポートします。RIP ルート テーブルおよびユニキャスト RIB の等コスト パスは最大 16 です。これらのパスの一部または全部でトラフィックのロード バランシングが行われるように、RIP を設定できます。

ハイ アベイラビリティ

Cisco NX-OS は、RIP のステートレス リスタートをサポートします。リブートまたはスーパーバイザ スイッチオーバー後に、Cisco NX-OS が実行コンフィギュレーションを適用し、RIP がただちに要求パケットを送信して、ルーティング テーブルに再入力します。

仮想化サポート

Cisco NX-OS は、同一システム上で動作する複数の RIP プロトコル インスタンスをサポートします。RIP は VRF(仮想ルーティングおよびフォワーディング)インスタンスをサポートします。VRF は virtual device context(仮想デバイス コンテキスト; VDC)内に存在します。

VDC で設定できる RIP インスタンスは、最大4 つです。特に VDC および VRF を設定しないかぎり、デフォルトで、Cisco NX-OS はユーザにデフォルト VDC およびデフォルト VRF を使用させます。『 Cisco NX-OS Virtual Device Context Configuration Guide 』および 第 13 章「レイヤ 3 仮想化の設定」 を参照してください。

RIP のライセンス要件

次の表に、この機能のライセンス要件を示します。

 

製品
ライセンス要件

NX-OS

RIP にライセンスは不要です。ライセンス パッケージに含まれていない機能は、Cisco NX-OS システム イメージにバンドルされて提供されます。追加料金は発生しません。NX-OS ライセンス方式の詳細については、『 Cisco NX-OS Licensing Guide 』を参照してください。

RIP の前提条件

RIP の前提条件は、次のとおりです。

RIP 機能をイネーブルにする必要があります(RIP 機能のイネーブル化を参照)。

VDC を設定する場合は、Advanced Services ライセンスをインストールし、所定の VDCを開始してください(『 Cisco NX-OS Virtual Device Context Configuration Guide 』を参照)。

設定時の注意事項および制約事項

RIP に関する設定時の注意事項および制約事項は、次のとおりです。

Cisco NX-OS は、RIPv1 をサポートしません。RIPv1 パケットを受信した Cisco NX-OS は、メッセージを記録してパケットを廃棄します。

Cisco NX-OS は、RIPv1 ルータとの隣接関係を確立しません。

RIP の設定

ここでは、次の内容について説明します。

「RIP 機能のイネーブル化」

「RIP インスタンスの作成」

「インターフェイス上での RIP の設定」

「受動インターフェイスの設定」

「ルート集約の設定」

「ルートの再配布の設定」

「仮想化の設定」

「RIP の調整」


) Cisco IOS の CLI に慣れている場合、この機能に対応する Cisco NX-OS コマンドは通常使用する Cisco IOS コマンドと異なる場合があるので注意してください。


RIP 機能のイネーブル化

RIP を設定するには、RIP 機能をイネーブルにしておく必要があります。

準備作業

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順概要

1. config t

2. feature rip

3. copy running-config startup-config

手順詳細

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

feature rip

 

switch(config)# feature rip

RIP 機能をイネーブルにします。

ステップ 3

copy running-config startup-config

 

switch(config)# copy running-config startup-config

(任意)この設定変更を保存します。

RIP 機能をディセーブルにして、関連するすべての設定を削除する場合は、 no feature rip コマンドを使用します。

 

コマンド
目的

no feature rip

 

switch(config)# no feature rip

RIP 機能をディセーブルにして、関連するすべての設定を削除します。

RIP インスタンスの作成

RIP インスタンスを作成し、そのインターフェイス用のアドレス ファミリを設定できます。

準備作業

RIP 機能がイネーブルになっていることを確認します(RIP 機能のイネーブル化を参照)。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順概要

1. config t

2. router rip instance-tag

3. address-family { ip | ipv6 } unicast

4. show { ip | ipv6 } rip [ instance instance-tag ] [ vrf vrf-name ]

5. copy running-config startup-config

手順詳細

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router rip instance-tag

 

switch(config)# router RIP Enterprise

switch(config-router)#

instance tag を設定して、新しい RIP インスタンスを作成します。

ステップ 3

address-family { ipv4 | ipv6 } unicast

 

switch(config-router)# address-family ipv4 unicast

switch(config-router-af)#

この RIP インスタンスのアドレス ファミリを設定し、アドレス ファミリ コンフィギュレーション モードを開始します。

ステップ 4

show { ip | ipv6 } rip [ instance instance-tag ] [ vrf vrf-name ]

 

switch(config-router-af)# show ip rip

(任意)すべての RIP インスタンスについて、RIP 要約情報を表示します。

ステップ 5

copy running-config startup-config

 

switch(config-router-af)# copy running-config startup-config

(任意)この設定変更を保存します。

RIP インスタンスおよび関連するすべての設定を削除する場合は、 no router rip コマンドを使用します。

 

コマンド
目的

no router rip instance-tag

 

switch(config)# no router rip Enterprise

RIP インスタンスおよび関連するすべての設定を削除します。


) インターフェイス モードで設定した RIP コマンドを削除することも必要です。


アドレス ファミリ コンフィギュレーション モードでは、RIP に次のオプション パラメータを設定できます。

 

コマンド
目的

distance value

 

switch(config-router-af)# distance 30

RIP の管理ディスタンスを設定します。有効値の範囲は 1 ~ 255 であり、デフォルトは 120 です。「管理ディスタンス」を参照してください。

maximum-paths number

 

switch(config-router-af)# maximum-paths 6

RIP がルート テーブルで維持する等コスト パスの最大数を設定します。有効値の範囲は 1 ~ 16 であり、デフォルトは 16 です。

IPv4 に対応する RIP インスタンスを作成し、ロード バランシングのための等コスト パス数を設定する例を示します。

switch# config t

switch(config)# router rip Enterprise

switch(config-router)# address-family ipv4 unicast

switch(config-router-af)# max-paths 10

switch(config-router-af)# copy running-config startup-config

 

RIP インスタンスの再起動

RIP インスタンスの再起動が可能です。再起動すると、インスタンスのすべてのネイバーが消去されます。

RIP インスタンスを再起動し、関連付けられたすべてのネイバーを削除するには、次のコマンドを使用します。

 

コマンド
目的

restart rip instance-tag

 

switch(config)# restart rip Enterprise

RIP インスタンスを再起動し、すべてのネイバーを削除します。

インターフェイス上での RIP の設定

RIP インスタンスにインターフェイスを追加できます。

準備作業

RIP 機能がイネーブルになっていることを確認します(RIP 機能のイネーブル化を参照)。

RIP を設定する前に、必要に応じて有効な VDC を開始します。

手順概要

1. config t

2. interface interface-type slot/port

3. { ip | ipv6 } router rip instance-tag

4. show { ip | ipv6 } rip [ instance instance-tag ] interface [ interface-type slot/port ] [ vrf vrf-name ] [ detail ]

5. copy running-config startup-config

手順詳細

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface interface-type slot/port

 

switch(config)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

{ ip | ipv6 } router rip instance-tag

 

switch(config-if)# ip router rip Enterprise

このインターフェイスを RIP インスタンスに関連付けます。

ステップ 4

show { ip | ipv6 } rip [ instance i nstance-tag ] interface [ interface-type slot/port ] [ vrf vrf-name ] [ detail ]

 

switch(config-if)# show ip rip Enterprise tethernet 1/2

(任意)インターフェイスの RIP 情報を表示します。

ステップ 5

copy running-config startup-config

 

switch(config-if)# copy running-config startup-config

(任意)この設定変更を保存します。

RIP インスタンスにインターフェイス ethernet 1/2 を追加する例を示します。

switch# config t

switch(config)# interface ethernet 1/2

switch(config-if)# ip router rip Enterprise

switch(config)# copy running-config startup-config

 

RIP 認証の設定

インターフェイス上で RIP パケットの認証を設定できます。

準備作業

RIP 機能がイネーブルになっていることを確認します(RIP 機能のイネーブル化を参照)。

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

認証をイネーブルにする前に、必要に応じてキーチェーンを設定します。キーチェーン実装の詳細については、『Cisco NX-OS Security Configuration Guide』を参照してください。

手順概要

1. config t

2. interface interface-type slot/port

3. ip rip authentication mode { text | md5 }

4. ip rip authentication keychain key

5. copy running-config startup-config

手順詳細

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface interface-type slot/port

 

switch(config)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

ip rip authentication mode { text | md5 }

 

switch(config-if)# ip rip authentication mode md5

クリアテキストまたは MD5 認証ダイジェストとして、このインターフェイスにおける RIP 認証タイプを設定します。

ステップ 4

ip rip authentication keychain key

 

switch(config-if)# ip rip authentication keychain RIPKey

このインターフェイス上で RIP に使用する認証鍵を設定します。

ステップ 5

copy running-config startup-config

 

switch(config-if)# copy running-config startup-config

(任意)この設定変更を保存します。

キーチェーンを作成し、RIP インターフェイス上で MD5 認証を設定する例を示します。

switch# config t

switch(config)# key chain RIPKey

switch(config)# key-string myrip

switch(config)# accept-lifetime 00:00:00 Jan 01 2000 infinite

switch(config)# send-lifetime 00:00:00 Jan 01 2000 infinite

switch(config)# interface ethernet 1/2

switch(config-if)# ip rip authentication mode md5

switch(config-if)# ip rip authentication keychain RIPKey

switch(config-if)# copy running-config startup-config

 

受動インターフェイスの設定

インターフェイスを受動モードに設定することによって、ルートを受信するが、ルート アップデートの送信は行わないように RIP インターフェイスを設定できます。

受動モードで RIP インターフェイスを設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

{ ip | ipv6 } rip passive-interface

 

switch(config-if)# ip rip passive-interface

インターフェイスを受動モードに設定します。

ポイズン リバースを指定した スプリット ホライズンの設定

ポイズン リバースをイネーブルにすることによって、ルートを学習したインターフェイス経由では到達不能であると RIP が学習したルートをアドバタイズするように、インターフェイスを設定できます。

インターフェイス上で、ポイズン リバースを指定してスプリット ホライズンを設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

{ ip | ipv6 } rip poison-reverse

 

switch(config-if)# ip rip poison-reverse

ポイズン リバースを指定してスプリット ホライズンをイネーブルにします。ポイズン リバースを指定したスプリット ホライズンは、デフォルトでディセーブルです。

ルート集約の設定

ルーティング テーブルでサマリー アドレスによって代表される集約アドレスを作成できます。Cisco NX-OS は、固有性の強いすべてのルートの中でメトリックが最小のサマリー アドレス メトリックをアドバタイズします。

インターフェイス上でサマリー アドレスを設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

{ ip | ipv6 } rip summary-address { ip-prefix/mask-len | ipv6-prefix/mask-len }

 

switch(config-if)# ip router rip summary-address 192.0.2.0/24

IPv4 または IPv6 アドレスに対応する、RIP 用のサマリー アドレスを設定します。

ルートの再配布の設定

別のルーティング プロトコルからのルーティング情報を受け入れて、RIP ネットワークを通じてその情報を再配布するように、RIP を設定できます。再配布されたルートを任意で、デフォルト ルートとして割り当てることができます。

準備作業

RIP 機能がイネーブルになっていることを確認します(RIP 機能のイネーブル化を参照)。

RIP を設定する前に、必要に応じて有効な VDC を開始します。

再配布を設定する前に、ルート マップを設定します。ルート マップ設定の詳細については、「ルート マップの設定」を参照してください。

手順概要

1. config t

2. router rip instance-tag

3. address-family { ipv4 | ipv6 } unicast

4. redistribute { bgp as | direct | eigrp as | isis tag | rip tag | { ospf tag | ospfv3 tag } | static } route-map map-name

5. default-information originate [ always ] [ route-map map-name ]

6. default-metric value

7. show { ip | ipv6} rip route [{ ip-prefix | ip6-prefix }[ longer-prefixes | shorter-prefixes ]] [ vrf vrf-name ] [ summary ]

8. copy running-config startup-config

手順詳細

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router rip instance-tag

 

switch(config)# router rip Enterprise

switch(config-router)#

instance tag を設定して、新しい RIP インスタンスを作成します。

ステップ 3

address-family { ipv4 | ipv6 } unicast

 

switch(config-router)# address-family ipv4 unicast

switch(config-router-af)#

アドレス ファミリ コンフィギュレーション モードを開始します。

ステップ 4

redistribute { bgp as | direct | eigrp as | isis tag | rip tag | { ospf tag | ospfv3 tag } static } route-map map-name

 

switch(config-router-af)# redistribute eigrp 201 route-map RIPmap

他のプロトコルからのルートを RIP に再配布します。ルート マップの詳細については、「ルート マップの設定」を参照してください。

ステップ 5

default-information originate [ always ] [ route-map map-name ]

 

switch(config-router-af)# default-information originate always

(任意)RIP へのデフォルト ルートを作成し、任意でルート マップで制御します。

ステップ 6

default-metric value

 

switch(config-router-af)# distribute level-1 into level-2 all

(任意)再配布されたすべてのルートにデフォルト メトリックを設定します。有効値の範囲は 1 ~ 15 であり、デフォルトは 1 です。

ステップ 7

show { ip | ipv6 } rip route [{ ip-prefix | ip6-prefix } [ longer-prefixes | shorter-prefixes ] [ vrf vrf-name ][ summary ]

 

switch(config-router-af)# show ip rip route

(任意)RIP のルートを表示します。

ステップ 8

copy running-config startup-config

 

switch(config-router-af)# copy running-config startup-config

(任意)この設定変更を保存します。

EIGRP を RIP に再配布する例を示します。

switch# config t

switch(config)# router rip Enterprise

switch(config-router)# address-family ipv4 unicast

switch(config-router-af)# redistribute eigrp 201 route-map RIPmap

switch(config-router-af)# copy running-config startup-config

 

仮想化の設定

VDC ごとに複数の RIP インスタンスを設定できます。各 VDC 内で複数の VRF を作成することもできます。また、各 VRF で同じ RIP インスタンスを使用することも、複数の RIP インスタンスを使用することも可能です。VRF に RIP インターフェイスを割り当てます。


) インターフェイスに VRF を設定したあとで、その他のインターフェイス パラメータを設定します。インターフェイスに VRF を設定すると、そのインターフェイスに関するすべての設定が削除されます。


準備作業

RIP 機能がイネーブルになっていることを確認します(RIP 機能のイネーブル化を参照)。

VDC を作成します。

手順概要

1. config t

2. vrf context vrf_name

3. exit

4. router rip instance-tag

5. vrf vrf-name

6. address-family {ipv4 | ipv6} unicast

7. オプション パラメータの設定

8. interface ethernet slot/port

9. vrf member vrf-name

10. ip-address ip-prefix/length

11. { ip | ipv6 } router rip instance-tag

12. show { ip | ipv6 } rip [ instance instance-tag ] interface [ interface-type slot/port ] [ vrf vrf-name ]

13. copy running-config startup-config

手順詳細

 

コマンド
目的

ステップ 1

config t

 

switch# config t

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

vrf vrf-name

 

switch(config)# vrf RemoteOfficeVRF

switch(config-vrf)#

新しい VRF を作成します。

ステップ 3

exit

 

switch(config-vrf)# exit

switch(config)#

VRF コンフィギュレーション モードを終了します。

ステップ 4

router rip instance-tag

 

switch(config)# router rip Enterprise

switch(config-router)#

instance tag を設定して、新しい RIP インスタンスを作成します。

ステップ 5

vrf context vrf-name

 

switch(config)# vrf context RemoteOfficeVRF

switch(config-vrf)#

新しい VRF を作成し、VRF コンフィギュレーション モードを開始します。

ステップ 6

address-family { ipv4 | ipv6 } unicast

 

switch(config-router-vrf)# address-family ipv4 unicast

switch(config-router-vrf-af)#

(任意)この RIP インスタンスの VRF アドレス ファミリを設定します。

ステップ 7

redistribute { bgp as | direct | eigrp as | isis tag | rip tag | { ospf tag | ospfv3 tag } static } route-map map-name

 

switch(config-router-vrf-af)# redistribute eigrp 201 route-map RIPmap

(任意)他のプロトコルからのルートを RIP に再配布します。ルート マップの詳細については、「ルート マップの設定」を参照してください。

ステップ 8

interface ethernet slot/port

 

switch(config-router-vrf-af)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 9

vrf member vrf-name

 

switch(config-if)# vrf member RemoteOfficeVRF

VRF にこのインターフェイスを追加します。

ステップ 10

ip address ip-prefix/length

 

switch(config-if)# ip address 209.0.2.1/16

このインターフェイスの IP アドレスを設定します。この作業は、VRF にこのインターフェイスを割り当てたあとで行う必要があります。

ステップ 11

{ ip | ipv6 ) router rip instance-tag

 

switch(config-if)# ip router rip Enterprise

このインターフェイスを RIP インスタンスに関連付けます。

ステップ 12

show { ip | ipv6 ) rip [ instance i nstance-tag ] interface [ interface-type slot/port ] [ vrf vrf-name ]

 

switch(config-if)# show ip rip Enterprise ethernet 1/2

(任意)VRF に含まれるインターフェイスの RIP 情報を表示します。

ステップ 13

copy running-config startup-config

 

switch(config-if)# copy running-config startup-config

(任意)この設定変更を保存します。

VRF を作成し、VRF にインターフェイスを追加する例を示します。

switch# config t

switch(config)# vrf context RemoteOfficeVRF

switch(config-vrf)# exit

switch(config)# router rip Enterprise

switch(config-router)# vrf RemoteOfficeVRF

switch(config-router-vrf)# address-family ipv4 unicast

switch(config-router-vrf-af)# redistribute eigrp 201 route-map RIPmap

switch(config-router-vrf-af)# interface ethernet 1/2

switch(config-if)# vrf member RemoteOfficeVRF

switch(config-if)# ip address 209.0.2.1/16

switch(config-if)# ip router rip Enterprise

switch(config-if)# copy running-config startup-config

 

RIP の調整

ネットワーク要件に合わせて RIP を調整できます。RIP では複数のタイマーを使用して、ルーティング アップデート間隔、ルートが無効になるまでの時間の長さ、およびその他のパラメータを決定します。これらのタイマーを調整すると、インターネットワークのニーズに適合するように、ルーティング プロトコルのパフォーマンスを調整できます。


) ネットワーク上のすべての RIP 対応ルータで、RIP タイマーに同じ値を設定する必要があります。


RIP を調整するには、アドレス ファミリ コンフィギュレーション モードで次のオプション コマンドを使用します。

 

コマンド
目的

timers basic update timeout holddown garbage-collection

 

switch(config-router-af)# timers basic 40 120 120 100

RIP タイマーを秒数で設定します。パラメータは次のとおりです。

update ― 範囲は 5 ~任意の正の整数。デフォルト値は 30 です。

timeout ― ルートの無効を宣言するまでに、Cisco NX-OS が待機する時間。タイムアウト インターバルが終了するまでに、このルートのアップデート情報を Cisco NX-OS が受信しなかった場合、Cisco NX-OS はルートの無効を宣言します。有効値の範囲は 1 ~任意の正の整数です。デフォルト値は 180 です。

holddown ― 無効ルートに関するよりよいルート情報を Cisco NX-OS が無視する時間。有効値の範囲は 0 ~任意の正の整数です。デフォルト値は 180 です。

garbage-collection ― Cisco NX-OS がルートを無効として表示してから、Cisco NX-OS がそのルートをルーティング テーブルから削除するまでの時間。有効値の範囲は 1 ~任意の正の整数です。デフォルト値は 120 です。

RIP を調整するには、インターフェイス コンフィギュレーション モードで次のオプション コマンドを使用します。

 

コマンド
目的

{ ip | ipv6 } rip metric-offset value

 

switch(config-if)# ip rip metric-offset 10

このインターフェイスで受信する各ルータのメトリックに値を追加します。有効値の範囲は 1 ~ 15 であり、デフォルトは 1 です。

{ ip | ipv6 } rip route-filter {prefix-list list-name | route-map map-name | [ in | out ]

 

switch(config-if)# ip rip route-filter route-map InputMap in

着信または発信 RIP アップデートをフィルタリングするための、ルート マップを指定します。

RIP の設定確認

RIP の設定を確認するには、次のコマンドを使用します。

 

コマンド
目的

show { ip | ipv6 } rip instance [ instance-tag ] [ vrf vrf-name ]

RIP インスタンスの状態を表示します。

show { ip | ipv6 } rip [ instance instance-tag ] interface slot/port detail [ vrf vrf-name ]

インターフェイスの RIP ステータスを表示します。

show { ip | ipv6 } rip [ instance instance-tag ] neighbor [ interface-type number ] [ vrf vrf-name ]

RIP ネイバー テーブルを表示します。

show { ip | ipv6 } rip [ instance instance-tag ] route [{ ip-prefix/lengh | ipv6-prefix/length } [ longer-prefixes | shorter--prefixes ]][ summary ] [ vrf vrf-name ]

RIP ルート テーブルを表示します。

show running-configuration rip

現在実行中の RIP コンフィギュレーションを表示します。

RIP 統計情報の表示

RIP の統計情報を表示するには、次のコマンドを使用します。

 

コマンド
目的

show { ip | ipv6 } rip [ instance instance-tag ] policy statistics redistribute { bgp as | direct | eigrp as | isis tag | rip tag | { ospf tag | ospfv3 tag} static } [ vrf vrf-name ]

RIP ポリシー ステータスを表示します。

show { ip | ipv6 } rip [ instance instance-tag ] statistics interface-type number ] [ vrf vrf-name ]

RIP の統計情報を表示します。

ポリシーの統計情報を消去するには、 clear { ip | ipv6 } rip policy コマンドを使用します。

RIP の統計情報を消去するには、 clear { ip | ipv6 } rip statistics コマンドを使用します。

RIP の設定例

VRF で Enterprise RIP インスタンスを作成し、その RIP インスタンスに ethernet interface 1/2 を追加する例を示します。さらに、enthernet interface 1/2 の認証を設定し、この RIP ドメインに EIGRP を再配布します。

vrf context NewVRF

!

feature rip

router rip Enterprise

vrf NewVRF

address-family ip unicast

redistribute eigrp 201 route-map RIPmap

max-paths 10

!

interface ethernet 1/2

vrf NewVRF

ip address 209.0.2.1/16

ip router rip Enterprise

ip rip authentication mode md5

ip rip authentication keychain RIPKey

 

関連項目

ルート マップの詳細については、 第 14 章「Route Policy Manager の設定」 を参照してください。

関連情報

RIP のパラメータのデフォルト設定については、次の項を参照してください。

デフォルト設定

表11-1 に、RIP パラメータのデフォルト設定を示します。

 

表11-1 デフォルトの RIP パラメータ

パラメータ
デフォルト

ロード バランシングを行う最大パス数

16

RIP 機能

ディセーブル

スプリット ホライズン

イネーブル

その他の関連資料

RIP の実装に関連する詳細情報については、次の項を参照してください。

「関連資料」

「規格」

関連資料

 

関連項目
マニュアル名

RIP CLI コマンド

Cisco NX-OS Command Line Reference

VDC および VRF

Cisco NX-OS Virtual Device Contexts Configuration Guide

規格

 

規格
タイトル

この機能がサポートする新しい規格または変更された規格はありません。また、この機能で変更された既存規格のサポートはありません。

--