Cisco Nexus 7000 シリーズ NX-OS MPLS コンフィギュレーション ガイド
MPLS MVPNs の設定
MPLS MVPNs の設定
発行日;2012/05/08 | 英語版ドキュメント(2012/03/12 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

MPLS MVPNs の設定

MPLS MVPNs について

MPLS マルチキャスト VPN の概要

MPLS MVPN のルーティング、転送、マルチキャスト ドメイン

マルチキャスト配信ツリー

マルチキャスト トンネル インターフェイス

MPLS MVPNs の利点

MPLS MVPN サポートの BGP アドバタイズメント メソッドについて

概要

BGP MDT SAFI

MPLS MVPNs のライセンス要件

MPLS MVPNs の前提条件

MPLS MVPNs に関する注意事項と制限事項

MPLS MVPNs のデフォルト設定

MPLS MVPNs の設定

機能のイネーブル化

インターフェイスでの PIM のイネーブル化

VRF のデフォルト MDT の設定

VRF の MDT SAFI の強制

MPLS MVPNs での BGP の MDT アドレス ファミリの設定

データ MDT の設定

MPLS MVPN の設定の確認

MPLS MVPNs の設定例

例:MPLS MVPN の設定

例:データ MDT のマルチキャスト アドレスの範囲の設定

MPLS MVPNs に関する追加情報

関連資料

標準

RFC

MIB

MPLS MVPNs の機能履歴

MPLS MVPNs の設定

この章では、Cisco NX-OS デバイスで Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)Multicast Virtual Private Networks(MVPNs; マルチキャスト バーチャル プライベート ネットワーク)を設定する方法について説明します。

この章では、次の内容について説明します。

「MPLS MVPNs について」

「MPLS MVPN サポートの BGP アドバタイズメント メソッドについて」

「MPLS MVPNs のライセンス要件」

「MPLS MVPNs の前提条件」

「MPLS MVPNs に関する注意事項と制限事項」

「MPLS MVPNs のデフォルト設定」

「MPLS MVPNs の設定」

「MPLS MVPN の設定の確認」

「MPLS MVPNs の設定例」

「MPLS MVPNs に関する追加情報」

「MPLS MVPNs の機能履歴」

MPLS MVPNs について

MVPN 機能を使用して、レイヤ 3 VPN 上でマルチキャストをサポートできます。IP マルチキャストは、ビデオ、音声、およびデータを MPLS VPN ネットワーク コアにストリーミングするために使用します。

従来、ポイントツーポイント トンネルはサービス プロバイダー ネットワークに接続する唯一の方法でした。そのようなトンネル ネットワークには拡張性に問題があったにもかかわらず、Virtual Private Network(VPN; バーチャル プライベート ネットワーク)を経由して IP マルチキャスト トラフィックを転送する手段は他にありませんでした。


) このマニュアルではサービス プロバイダーについて言及していますが、MPLS を実行している企業にも適用されます。


レイヤ 3 VPN はユニキャスト トラフィック接続のみをサポートするため、レイヤ 3 VPN を使用することにより、サービス プロバイダーはレイヤ 3 VPN のカスタマーにユニキャスト接続とマルチキャスト接続の両方を提供できます。

ここでは、次の内容について説明します。

「MPLS マルチキャスト VPN の概要」

「MPLS MVPN のルーティング、転送、マルチキャスト ドメイン」

「マルチキャスト配信ツリー」

「マルチキャスト トンネル インターフェイス」

「MPLS MVPNs の利点」

MPLS マルチキャスト VPN の概要

MPLS MVPN により、サービス プロバイダーは MVPN 環境でマルチキャスト トラフィックを設定およびサポートできます。MVPNs は、個々の Virtual Routing and Forwarding(VRF)インスタンスでのマルチキャスト パケットのルーティングおよび転送をサポートし、サービス プロバイダーのバックボーンに VPN マルチキャスト パケットを転送するメカニズムも提供します。IP マルチキャストは、ビデオ、音声、およびデータを MPLS VPN ネットワーク コアにストリーミングするために使用します。

VPN は、Internet Service Provider(ISP; インターネット サービス プロバイダー)のような共有インフラストラクチャにネットワークの接続性を提供します。この機能により、低い所有コストでプライベート ネットワークと同じポリシーとパフォーマンスを提供します。

MVPNs により、企業はサービス プロバイダーのネットワーク バックボーンでプライベート ネットワークをトランスペアレントに相互接続することができます。MVPNs を使用して企業ネットワークを相互接続しても、企業ネットワークの管理方法や、企業の全体的な接続性は変更されません。

MPLS MVPN のルーティング、転送、マルチキャスト ドメイン

MVPNs は、VPN ルーティングおよび転送テーブルにマルチキャスト ルーティング情報を導入します。Provider Edge(PE; プロバイダー エッジ)ルータが Customer Edge(CE; カスタマー エッジ)ルータからマルチキャスト データまたはコントロール パケットを受信する場合は、ルータが MVPN Routing and Forwarding(MVRF; VPN ルーティング/転送)の情報に基づいてデータまたはコントロール パケットを転送します。MVPNs は、ラベル スイッチングを使用しません。

互いにマルチキャスト トラフィックを送信できる MVRFs のセットは、マルチキャスト ドメインを構成します。たとえば、特定タイプのマルチキャスト トラフィックをすべてのグローバルな従業員に送信するカスタマーのマルチキャスト ドメインは、そのエンタープライズと関連するすべての CE ルータから構成されます。

マルチキャスト配信ツリー

MVPNs は、各マルチキャスト ドメインにスタティック デフォルト Multicast Distribution Tree(MDT; マルチキャスト配信ツリー)を確立します。デフォルト MDT は、PE ルータが使用するパスを定義し、マルチキャスト ドメインにある他のすべての PE ルータに、マルチキャスト データとコントロール メッセージを送信します。

また、MVPNs は、高帯域幅伝送用の MDT のダイナミックな作成もサポートします。データ MDTs は、MPLS VPN コアで最適なトラフィック転送を確保するために、VPN 内部のフルモーション ビデオのような広帯域幅ソースを対象としています。マルチキャスト伝送が定義されたしきい値を超えると、送信側の PE ルータがデータ MDT を作成し、データ MDT に関する情報を含む User Datagram Protocol(UDP; ユーザ データグラム プロトコル)メッセージをデフォルト MDT のすべてのルータに送信します。PE ルータは、マルチキャスト ストリームがデータ MDT のしきい値を超えたかどうかを判断するために 1 秒に 1 回統計情報を調べます。PE ルータが UDP メッセージを送信した後は、切り替わるまで 3 秒以上かかります。

VRF で mdt data bidir-enable コマンドを使用する場合は、データ MDT が双方向ルートに作成されます。(デフォルトでは、双方向カスタマー ルートにデータ MDT は作成されません)。

次の例のサービス プロバイダーには、San Jose、New York、Dallas にオフィスがあるマルチキャスト カスタマーがいます。San Jose では、一方向のマルチキャスト プレゼンテーションが行われています。サービス プロバイダー ネットワークでは、このカスタマーと関連する 3 つすべてのサイト、および別のエンタープライズ カスタマーの Houston サイトがサポートされます。

エンタープライズ カスタマーのデフォルト MDT は、プロバイダーのルータ P1、P2、P3、およびその関連 PE ルータから構成されています。PE4 は別のカスタマーに関連付けられているため、デフォルト MDT の一部ではありません。図 26-1 からは、San Jose 以外はマルチキャストに加入していないため、データがデフォルト MDT に沿って転送されていないことがわかります。

図 26-1 デフォルト マルチキャスト配信ツリー の概要

 

New York の従業員がマルチキャスト セッションに加入します。New York のサイトに関連付けられている PE ルータは、カスタマーのマルチキャスト ドメインのデフォルト MDT を介して転送される加入要求を送信します。PE1 は、マルチキャスト セッションの送信元に関連付けられている PE ルータであり、この要求を受信します。図 26-2 は、PE ルータが、マルチキャスト送信元(CE1a)と関連する CE ルータに要求を転送する方法を示しています。

図 26-2 データ MDT の初期化

 

CE ルータ(CE1a)が関連する PE ルータ(PE1)へマルチキャスト データの送信を開始すると、PE ルータ(PE1)は、デフォルト MDT に沿ってマルチキャスト データを送信します。PE1 は、マルチキャスト データ送信後すぐに、マルチキャスト データがデータ MDT を作成する対象の帯域幅のしきい値を超えていることを認識します。したがって、PE1 はデータ MDT を作成し、データ MDT に関する情報を含むデフォルト MDT を使用して、すべてのルータにメッセージを送信し、3 秒後、データ MDT を使用して、その特定のストリームのマルチキャスト データを送信し始めます。この送信元に関係する受信先は PE2 だけにあるので、PE2 だけがデータ MDT に加入し、データ MDT でトラフィックを受信します。(データ MDT が設定されず、デフォルト MDT のみが設定されている場合、すべてのカスタマー サイトが不要なトラフィックを受信することになります)。

PE ルータは、デフォルト MDT を介して他の PE ルータと PIM 関係を維持するとともに、直接接続された P ルータとの PIM 関係をも維持します。

マルチキャスト トンネル インターフェイス

マルチキャスト ドメインごとに作成される MVPN Routing and Forwarding(MVRF; VPN ルーティング/転送)では、ルータは、すべての MVRF トラフィックが発信されるトンネル インターフェイスを作成する必要があります。マルチキャスト トンネル インターフェイスは、MVRF がマルチキャスト ドメインにアクセスするために使用するインターフェイスです。インターフェイスは、MVRF とグローバル MVRF を接続するコンジットです。MVRF ごとに 1 つのトンネル インターフェイスが作成されます。

MPLS MVPNs の利点

MVPNs の利点は、次のとおりです。

複数の場所に情報を動的に送信するスケーラブルなメソッドを提供します。

高速な情報伝送を提供します。

共有インフラストラクチャを介して接続性を提供します。

MPLS MVPN サポートの BGP アドバタイズメント メソッドについて

ここでは、次の内容について説明します。

「概要」

「BGP MDT SAFI」

概要

PIM-SM 環境ではなく PIM Source Specific Multicast(PIM-SSM)環境でデフォルト MDT を設定する場合は、受信側 PE は送信元 PE とデフォルト MDT に関する情報を必要とします。この情報は、送信元 PE に(S,G)join を送信し、送信元 PE からの配信ツリーを構築するために使用されます。Rendezvous Point(RP; ランデブー ポイント)は必要ありません。送信元の Provider Edge(PE; プロバイダー エッジ)アドレスとデフォルト MDT のアドレスは、Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)を使用して送信されます。

BGP MDT SAFI

BGP MDT SAFI は、MVPNs に使用される BGP アドバタイズメント メソッドです。現在のリリースでは、IPv4 のみがサポートされています。MDT SAFI の設定は次のとおりです。

AFI = 1

SAFI = 66

Cisco NX-OS では、BGP MDT SAFI のアップデートを使用して送信元 PE アドレスと MDT アドレスが PIM に渡されます。Route Descriptor(RD; ルート記述子)は RD type 0 に変更されており、BGP は PIM に情報を渡す前に、MDT アップデートのための最良パスを決定します。

address-family ipv4 mdt コマンドを使用して、BGP ネイバーの MDT SAFI アドレス ファミリを設定する必要があります。また、ローカル BGP の設定で MDT SAFI をサポートしていないネイバーをイネーブルにする必要があります。MDT SAFI が導入される前、VPNv4 ユニキャスト設定からの追加の BGP 設定は、MVPNs をサポートするために必要ではありませんでした。

MPLS MVPNs のライセンス要件

次の表に、この機能のライセンス要件を示します。

製品
ライセンス要件

Cisco NX-OS

MPLS レイヤ 3 VPNs には、MPLS Services ライセンスが必要です。Cisco NX-OS ライセンス方式の詳細と、ライセンスの取得および適用の方法については、『 Cisco NX-OS Licensing Guide 』を参照してください。

MPLS MVPNs の前提条件

MVPNs の設定には、次の前提条件があります。

ネットワークに MPLS および Label Distribution Protocol(LDP; ラベル配布プロトコル)を設定する必要があります。PE ルータを含む、コア内のすべてのルータは、MPLS 転送をサポートできる必要があります。

MPLS の正しいライセンスおよび MPLS で使用する他の機能をインストールすることが必要です。

MPLS MVPNs に関する注意事項と制限事項

MVPNs 設定時の注意事項と制限事項は次のとおりです。

デフォルトでは、BGP アップデートのソースは、MVPN トンネルのソースとして使用されます。ただし、 mdt source を使用して BGP アップデートのソースを上書きし、マルチキャスト トンネルに異なる送信元を提供することができます。

MDT SAFI 設定時の注意事項と制限事項は次のとおりです。

MVPN 操作に参加するすべてのルータで MDT SAFI を設定する必要があります。

コネクタ属性を伝送する VPNv4 Internal BGP(iBGP; 内部 BGP)セッションには、拡張コミュニティが必要です。

MPLS MVPNs のデフォルト設定

表 26-1 に、MPLS マルチキャスト VPN の各種パラメータについて、デフォルト設定を示します。

 

表 26-1 デフォルトの MPLS MVPN パラメータ

パラメータ
デフォルト

mdt default address

デフォルトなし

mdt enforce-bgp-mdt-safi

イネーブル

mdt data threshold

0 kbps

mdt source

デフォルトなし

mdt mtu mtu

1376

mdt ip pim hello-interval interval

30000 ミリ秒

mdt ip pim jp-interval interval

60000 ミリ秒

mdt data bidir-enable1

ディセーブル

mdt default asm-use-shared-tree [only]2

ディセーブル

1.bidir カスタマー ルートに作成されるようにデータ MDT をイネーブルにします。

2.デフォルト MDT が PIM ASM モードの場合、受信側 PE は MDT ルートの送信元に向かう(S,G)join をトリガーしません。

MPLS MVPNs の設定

ここでは、次の内容について説明します。

「機能のイネーブル化」

「インターフェイスでの PIM のイネーブル化」

「VRF のデフォルト MDT の設定」

「VRF の MDT SAFI の強制」

「MPLS MVPNs での BGP の MDT アドレス ファミリの設定」

「データ MDT の設定」

機能のイネーブル化

この項の詳細な手順を使用して、必要な機能をイネーブルにします。


) この手順は、機能をイネーブルにするために必要です。



) rip/ospf などの一部のプロトコルは、カスタマー VRFs とコアの両方で実行される必要があります。


手順の概要

1. configure terminal

2. feature bgp

3. feature pim

4. feature mvpn

5. feature mpls l3vpn

6. feature tunnel

7. feature mpls ldp

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

feature bgp

 

例:

switch(config)# feature bgp

BGP 機能をイネーブルにします。

ステップ 3

feature pim

 

例:

switch(config)# feature pim

PIM 機能をイネーブルにします。

ステップ 4

feature mvpn

 

例:

switch(config)# feature mvpn

MVPN 機能をイネーブルにします。

ステップ 5

feature mpls l3vpn

 

例:

switch(config)# feature mpls l3vpn

サイト間のユニキャスト ルート決定に必要な MPLS レイヤ 3 VPN 機能をイネーブルにします。

ステップ 6

feature tunnel

 

例:

switch(config)# feature tunnel

トンネル機能をイネーブルにします。

ステップ 7

feature mpls ldp

 

例:

switch(config)# feature mpls ldp

MPLS Label Distribution Protocol(LDP; ラベル配布プロトコル)をイネーブルにします。

インターフェイスでの PIM のイネーブル化

IP マルチキャストに使用されるすべてのインターフェイスの Protocol Independent Multicast(PIM; プロトコル独立マルチキャスト)を設定することができます。バックボーンに接続される Provider Edge(PE; プロバイダー エッジ)ルータのすべての物理インターフェイスで PIM スパース モードに設定することをお勧めします。また、すべてのループバック インターフェイスについて、それが BGP ピアリングに使用される場合や、その IP アドレスが PIM の RP アドレスとして使用される場合は、PIM スパース モードに設定することをお勧めします。


) この手順は、インターフェイスで PIM をイネーブルにするために必要です。


手順の概要

1. configure terminal

2. ip pim sparse-mode

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

ip pim sparse-mode

 

例:

switch (config-if)# ip pim sparse-mode

インターフェイスで PIM スパース モードをイネーブルにします。

VRF のデフォルト MDT の設定

VRF のデフォルト MDT を設定できます。

デフォルト MDT は、同じ VPN に属するすべてのルータの設定と同じであることが必要です。送信元 IP アドレスは、BGP セッションの送信元を特定するために使用するアドレスです。

手順の概要

1. configure terminal

2. vrf context vrf-name

3. mdt default address

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vrf context vrf-name

 

例:

switch(config)# vrf context vrf1

VRF 名を割り当てることにより、VRF コンテキストを設定します。

ステップ 3

mdt default address

 

例:

switch(config-vrf)# mdt default 232.0.0.1

VRF に、データ MDTs のマルチキャスト アドレスの範囲を次のように設定します。

このコマンドによって、トンネル インターフェイスが作成されます。

デフォルトでは、トンネル ヘッダーの宛先アドレスは address 引数です。

VRF の MDT SAFI の強制

VRF の MDT Subsequent Address Family Identifier(SAFI)を強制的に使用したり、MDT SAFI をサポートしていないピアと相互運用するために MDT を設定したりすることができます。

手順の概要

1. configure terminal

2. vrf context vrf-name

3. [no] mdt enforce-bgp-mdt-safi

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vrf context vrf-name

 

例:

switch(config)# vrf context vrf1
switch(config-vrf)#

VRF 名を割り当てることにより、VRF コンテキストを設定します。

ステップ 3

[no] mdt enforce-bgp-mdt-safi

 

例:

switch(config-vrf)# mdt enforce-bgp-mdt-safi

指定された VRF の MDT SAFI の使用を強制します。

このコマンドの no 形式により MDT がイネーブルになり、MDT SAFI をサポートしていないピアと相互運用することができます。 no 形式を使用する場合、Any Source Multicast(ASM)の範囲内であるときは、初期状態ではデフォルト MDT グループの(*,G)エントリのみが読み込まれます。その後、トラフィックに基づき、(S,G)エントリは、通常の ASM ルートと同じように学習されます。

MPLS MVPNs での BGP の MDT アドレス ファミリの設定

MVPNs の MDT ピアリング セッションを確立するために、PE ルータで MDT アドレス ファミリ セッションを設定することができます。

MDT アドレス ファミリ セッションを設定するには、ネイバー モードで address-family ipv4 mdt コマンドを使用してください。MDT アドレス ファミリ セッションは、BGP MDT Subaddress Family Identifier(SAFI)のアップデートを使用して PIM に送信元 PE アドレスと MDT アドレスを渡すために使用されます。

前提条件

MPLS マルチキャスト VPN ピアリングが MDT アドレス ファミリを介して確立できるようにするには、CE ルータに VPN サービスを提供する PE ルータで BGP ネットワークの MPLS とマルチプロトコル BGP を設定する必要があります。

手順の概要

1. configure terminal

2. feature bgp as-number

3. vrf context vrf-name

4. rd route-distinguisher

5. address-family ipv4 unicast

6. route-target import route-target-ext-community

7. route-target export route-target-ext-community

8. router bgp as - number

9. address-family ipv4 mdt

10. address-family {vpnv4} [ unicast]

11. address-family {ipv4} [ unicast]

12. neighbor neighbor-address

13. update source interface

14. address-family ipv4 mdt

15. address-family vpnv4 [ unicast]

16. send-community extended

17. (任意)show bgp {ipv4} unicast neighbors vrf vrf-name

18. (任意)copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

feature bgp as-number

 

例:

switch(config)# feature bgp 65535

スイッチ コンフィギュレーション モードを開始して、BGP ルーティング プロセスを作成します。

ステップ 3

vrf context vrf-name

 

例:

switch(config)# vrf context vpn1

switch(config-vrf)#

vrf-name で識別される VPN ルーティング インスタンスを定義し、VRF コンフィギュレーション モードを開始します。 vrf-name 引数には最大 32 文字の英数字文字列を指定します。大文字と小文字は区別されます。

ステップ 4

rd route-distinguisher

 

例:

switch(config-vrf)# rd 1.2:1

VRF の vrf-name にルート識別子を割り当てます。 route-distinguisher 引数によって、8 バイトの値が IPv4 プレフィクスに追加され、VPN IPv4 プレフィクスが作成されます。RD は、次のいずれかの形式で入力できます。

16 ビットまたは 32 ビットの AS 番号:32 ビットの番号。1.2:3 など。

32 ビットの IP アドレス:16 ビットの番号。192.0.2.1:1 など。

ステップ 5

address-family ipv4 unicast

 

例:

switch(config-vrf)# address-family ipv4 unicast

switch(config-vrf-af)#

IPv4 アドレス ファミリ タイプを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

ステップ 6

route-target import route-target-ext-community

 

例:

switch(config-vrf-af)# route-target import 1.0:1

VRF 用にルート ターゲット拡張コミュニティを指定します。 import キーワードを使用すると、ターゲット VPN 拡張コミュニティからルーティング情報がインポートされます。

route-target-ext-community 引数により、ルート ターゲット拡張コミュニティ属性が、インポート ルート ターゲット拡張コミュニティの VRF リストに追加されます。 route-target-ext-community 引数は、次のいずれかの形式で入力できます。

16 ビットまたは 32 ビットの AS 番号:32 ビットの番号。1.2:3 など。

32 ビットの IP アドレス:16 ビットの番号。192.0.2.1:1 など。

ステップ 7

route-target export route-target-ext-community

 

例:

switch(config-vrf-af)# route-target export 1.0:1

VRF 用にルート ターゲット拡張コミュニティを指定します。 export キーワードを使用すると、ルーティング情報がターゲット VPN 拡張コミュニティにエクスポートされます。

route-target-ext-community 引数により、ルート ターゲット拡張コミュニティ属性が、エクスポート ルート ターゲット拡張コミュニティの VRF リストに追加されます。 route-target-ext-community 引数は、次のいずれかの形式で入力できます。

16 ビットまたは 32 ビットの AS 番号:32 ビットの番号。1.2:3 など。

32 ビットの IP アドレス:16 ビットの番号。192.0.2.1:1 など。

ステップ 8

router bgp as - number

 

例:

switch(config)# router bgp 1.1

switch(config-router)#

BGP ルーティング プロセスを設定し、ルータ コンフィギュレーション モードを開始します。 as-number 引数は、ルータを他の BGP ルータに対して識別し、転送するルーティング情報にタグを設定する自律システムの番号を示します。AS 番号は 16 ビット整数または 32 ビット整数にできます。上位 16 ビット 10 進数と下位 16 ビット 10 進数による xx.xx という形式です。

ステップ 9

address-family ipv4 mdt

 

例:

switch(config-router)# address-family ipv4 mdt

IPv4 MDT アドレス ファミリ コンフィギュレーション モードを開始します。

ステップ 10

address-family {vpnv4} [unicast]

 

例:

switch(config-router-af)# address-family vpnv4

switch(config-router-af)#

アドレス ファミリ コンフィギュレーション モードを開始して、標準 VPNv4 または VPNv6 アドレス プレフィクスを使用する、BGP などのルーティング セッションを設定します。 unicast キーワード(任意)では、VPNv4 または VPNv6 ユニキャスト アドレス プレフィクスを指定します。

ステップ 11

address-family { ipv4 } unicast

 

例:

switch(config-router-af)# address-family ipv4 unicast

switch(config-router-af)#

標準 IPv4 または VPNv6 アドレス プレフィクスを使用するルーティング セッションを設定するために、アドレス ファミリ コンフィギュレーション モードを開始します。

ステップ 12

neighbor neighbor-address

 

例:

switch(config-switch-af)# neighbor 192.168.1.1

ネイバー コンフィギュレーション モードを開始します。

ステップ 13

update source interface

 

例:

switch (config-router-neighbor)# update-source loopback 1

アップデート ソースを loopback1 に設定します。

ステップ 14

address-family ipv4 mdt

 

例:

switch(config-router-neighbor)# address-family ipv4 mdt

アドレス ファミリ コンフィギュレーションを開始し、IP MDT アドレス ファミリ セッションを作成します。

ステップ 15

address-family vpnv4 [unicast]

 

例:

switch(config-router-neighbor-af)# address-family vpnv4

switch(config-router-neighbor-af)#

VPNv4 アドレス ファミリ コンフィギュレーション モードを開始します。

ステップ 16

send-community extended

 

例:

switch(config-router-neighbor-af)# send-community extended

拡張コミュニティ属性が BGP ネイバーに送信されるように指定します。

ステップ 17

show bgp { ipv4 } unicast neighbors vrf vrf-name

 

例:

switch(config-router-neighbor-af)# show bgp ipv4 unicast neighbors vrf vpn1

(任意)BGP ネイバーに関する情報を表示します。 vrf-name 引数には最大 32 文字の英数字文字列を指定します。大文字と小文字は区別されます。

ステップ 18

copy running-config startup-config

 

例:

switch(config-router-neighbor-af)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

データ MDT の設定

データ MDT を設定できます。

PE ルータごとに VRF 単位で最大 256 個のデータ MDT を含めることができます。データ MDT の作成に使用されるマルチキャスト グループは、設定済み IP アドレスのプールからダイナミックに選択されます。ストリームの数が 256 より大きい場合、複数のストリームが同じデータ MDT を共有します。

前提条件

データ MDT を設定する前に、VRF のデフォルト MDT を設定する必要があります。

手順の概要

1. configure terminal

2. vrf context vrf-name

3. mdt data data prefix [ threshold threshold-value ] [ routemap policy-name ]

4. exit

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vrf context vrf-name

 

例:

switch(config)# ip vrf vrf1

VRF コンフィギュレーション モードを開始し、VRF 名を割り当てることにより VPN ルーティング インスタンスを定義します。

ステップ 3

mdt data data prefix [threshold threshold-value] [routemap policy-name]

 

例:

switch(config-vrf)# mdt data 232.7.7.0/24 threshold 10 route-map rmap2mdt data 239.192.20.32 0.0.0.15 threshold 1

 

次のようにしきい値の値の範囲を指定します。

Prefix は、データ MDT プールで使用されるアドレスの範囲を指定します。

Threshold-value は、ストリームがデータ MDT に切り替えられるしきい値をキロビット/秒単位で指定します。

Policy-name は、データ MDT への切り替えで考慮されるカスタマー データ ストリームを定義するポリシー ファイルを定義します。

ステップ 4

exit

 

例:

switch(config-vrf)# exit

グローバル コンフィギュレーション モードに戻ります。

MPLS MVPN の設定の確認

MPLS MVPN の設定を表示するには、次のいずれかの作業を行います。

コマンド
目的

show interface

インターフェイスの詳細を表示します。

show ip mroute vrf

マルチキャスト ルートを表示します。

show ip pim event-history mvpn

MVPN のイベント履歴ログの詳細を表示します。

show ip pim mdt

MVPN によって作成された MTI トンネルの詳細を表示します。

show ip pim mdt receive

カスタマー ソース、データ MDT 送信元へのカスタマー グループ、および受信側のデータ MDT グループそれぞれのマッピングを表示します。

show ip pim mdt send

カスタマー ソース、データ MDT 送信元へのカスタマー グループ、および送信側のデータ MDT グループそれぞれのマッピングを表示します。

show ip pim neighbor

確立された PIM ネイバーの詳細を表示します。

show ip route detail

ユニキャスト ルーティング テーブルの詳細を表示します。

show mvpn bgp mdt-safi

MVPN の BGP MDT SAFI データベースを表示します。

show mvpn mdt encap

MVPN のカプセル化テーブルを表示します。このテーブルは、デフォルト vrf で MVPN パケットを送信するときにカプセル化する方法を示しています。

show mvpn mdt route

デフォルトおよび MDT ルートの詳細を表示します。このデータは、デフォルト VRF でカスタマー データと制御トラフィックを送信する方法を決定します。

show routing [ip] multicast mdt encap

MRIB のカプセル化テーブルを表示します。このテーブルは、デフォルト vrf で MVPN パケットを送信するときにカプセル化する方法を示しています。

MPLS MVPNs の設定例

ここでは、次の設定例を示します。

「例:MPLS MVPN の設定」

「例:データ MDT のマルチキャスト アドレスの範囲の設定」

例:MPLS MVPN の設定

次に、2 つのコンテキストで MPLS マルチキャスト VPN を設定する例を示します。

vrf context vpn1
ip pim rp-address 10.10.1.2 -list 224.0.0.0/8
ip pim rp-address 10.10.1.3 -list 239.0.0.0/8 bidir
ip pim ssm range 232.0.0.0/8
mdt source loopback2
mdt default 232.1.1.1
mdt data 232.2.2.0/24 threshold 10 route-map rmap2
mdt data bidir-enable
vrf context vpn4
ip pim rp-address 10.10.4.2 -list 224.0.0.0/8
ip pim rp-address 10.10.4.3 -list 239.0.0.0/8 bidir
ip pim ssm range 232.0.0.0/8
mdt default 235.1.1.1
mdt asm-use-shared-tree
ip pim rp-address 10.11.0.2 -list 224.0.0.0/8
ip pim rp-address 10.11.0.3 -list 239.0.0.0/8 bidir
ip pim rp-address 10.11.0.4 -list 235.0.0.0/8
ip pim ssm range 232.0.0.0/8

例:データ MDT のマルチキャスト アドレスの範囲の設定

次に、「blue」と名づけられた VRF を VPN ルーティング インスタンスに割り当てる方法の例を示します。VPN VRF の MDT デフォルトは 10.1.1.1、MDT のマルチキャスト アドレスの範囲は 10.1.2.0(ワイルドカード ビットが 0.0.0.3)です。

Vrf context blue
mdt data 239.1.0/24 threshold 10

MPLS MVPNs に関する追加情報

MPLS MVPN の設定に関する詳細情報については、次の項を参照してください。

関連資料

標準

RFC

MIB

関連資料

関連項目
参照先

マルチキャスト テクノロジーの概念

『IP Multicast Technology Overview』

VDC

Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide, Release 5.x

CLI コマンド

Cisco Nexus 7000 Series NX-OS Multicast Routing Command Reference

エクストラネット MPLS マルチキャスト VPN の概念、作業、および設定例

Configuring Multicast VPN Extranet Support

MPLS マルチキャスト VPN の機能

『Multicast-VPN--IP Multicast Support for MPLS VPNs』

基本的な IP マルチキャストの設定

Configuring Basic IP Multicast

標準

標準
タイトル

この機能でサポートされる新規または改訂された標準規格はありません。また、この機能による既存の標準規格サポートの変更はありません。

--

RFC

RFC
タイトル

この機能によりサポートされた新規 RFC または改訂 RFC はありません。またこの機能による既存 RFC のサポートに変更はありません。

--

MIB

MIB
MIB のリンク

MPLS-VPN-MIB

選択したプラットフォーム、リリース、およびフィーチャ セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

MPLS MVPNs の機能履歴

表 26-2 は、この機能のリリースの履歴です。

 

表 26-2 MPLS MVPNs の機能履歴

機能名
リリース
機能情報

レイヤ 3 インターフェイス上の MPLS MVPNs

5.2(1)

この機能が導入されました。

レイヤ 2 インターフェイス上の MPLS MVPNs

5.2(1)

この機能が導入されました。

MPLS MVPNs の IP マルチキャスト サポート

5.2(1)

この機能が導入されました。