Cisco Nexus 7000 シリーズ NX-OS MPLS コンフィギュレーション ガイド
基本的な MPLS TE の設定
基本的な MPLS TE の設定
発行日;2012/05/09 | 英語版ドキュメント(2011/09/29 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

基本的な MPLS TE の設定

MPLS TE の概要

MPLS TE の動作

MPLS TE と HA

MPLS TE のライセンス要件

MPLS TE の前提条件

MPLS TE に関する注意事項と制限事項

MPLS TE のデフォルト設定

MPLS TE のイネーブル化

MPLS TE の設定

IS-IS の MPLS TE 用の設定

OSPF の MPLS TE 用の設定

インターフェイスでの MPLS TE の設定

MPLS TE トンネルの設定

明示パスの設定

MPLS TE の設定の確認

MPLS VPN の設定例

例:IS-IS を使用した MPLS TE のイネーブル化

例:OSPF を使用した MPLS TE のイネーブル化

例:インターフェイスでの MPLS TE の設定

例:MPLS TE トンネルの設定

例:明示パスの作成

MPLS TE に関する追加情報

関連資料

MIB

RFC

MPLS TE の機能履歴

基本的な MPLS TE の設定

この章では、Cisco NX-OS デバイスで Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)Traffic Engineering(TE; トラフィック エンジニアリング)を設定する方法について説明します。

この章では、次の内容について説明します。

「MPLS TE の概要」(P.11-1)

「MPLS TE のライセンス要件」(P.11-3)

「MPLS TE の前提条件」(P.11-3)

「MPLS TE に関する注意事項と制限事項」(P.11-3)

「MPLS TE のデフォルト設定」(P.11-3)

「MPLS TE のイネーブル化」(P.11-3)

「MPLS TE の設定」(P.11-4)

「MPLS TE の設定の確認」(P.11-13)

「MPLS VPN の設定例」(P.11-13)

「MPLS TE に関する追加情報」(P.11-15)

「MPLS TE の機能履歴」(P.11-15)

MPLS TE の概要

トラフィック エンジニアリング用に MPLS をイネーブルにすることにより、従来のレイヤ 2 機能をレイヤ 3 で使用できるようになります。

ここでは、次の内容について説明します。

「MPLS TE の動作」(P.11-1)

「MPLS TE と HA」(P.11-2)

MPLS TE の動作

MPLS TE はトポロジとネットワーク内で使用可能なリソースを学習し、帯域幅などのリソース要件とネットワーク リソースに基づいてトラフィック フローを特定のパスにマッピングします。MPLS TE では、Label Switched Path(LSP; ラベル スイッチド パス)の形でソースから宛先への単方向トンネルが構築され、その後トラフィックの転送で使用されます。トンネルが開始される場所はトンネルのヘッドエンドまたはトンネル ソースと呼ばれ、トンネルが終了するノードはトンネルのテールエンドまたはトンネルの宛先と呼ばれます。

MPLS はリンクステートに基づく Interior Gateway(IGP)に対する拡張機能を使用します。これには、Intermediate System-to-Intermediate System(IS-IS)や Open Shortest Path First(OSPF)などが含まれます。MPLS では、必要なリソースと使用可能なリソースに基づき、LSP のヘッドで TE トンネルが計算されます(コンストレイントベース ルーティング)。IGP が設定されている場合、これらの LSP にトラフィックを自動的にルーティングします。通常、MPLS TE バックボーンを通過するパケットは、入力ポイントと出力ポイントを接続する単一の LSP 上を伝送されます。MPLS TE は、Resource Reservation Protocol(RSVP; リソース予約プロトコル)を使用して、MPLS ネットワーク全体で LSP を自動的に確立および維持します。

MPLS TE は、次の Cisco NX-OS メカニズムの上に構築されます。

TE トンネル インターフェイス:レイヤ 2 の観点では、MPLS TE トンネル インターフェイスは LSP のヘッドを表します。これは、帯域幅要件、メディア要件、プライオリティなどの一連のリソース要件を使用して設定されます。レイヤ 3 の観点では、TE トンネル インターフェイスはトンネル宛先への単一方向仮想リンクのヘッドエンドです。

MPLS TE パス計算:この計算は LSP ヘッドで動作し、LSP で使用するパスが決定されます。パス計算では、フラッディングされたトポロジおよびリソース情報を含むリンクステート データベースが使用されます。

TE 拡張を使用したリソース予約プロトコル(RSVP):各 LSP ホップで動作する RSVP を使用して、計算されたパスに基づいて LSP のシグナリングと維持が行われます。

MPLS TE リンク管理:リンク管理は各 LSP ホップで動作し、RSVP シグナリング メッセージに対するリンク コール アドミッションを実行し、フラッディングされるトポロジおよびリソース情報を追跡します。

リンクステート IGP(IS-IS または OSPF):これらの IGP(TE 拡張を使用)は、リンク管理に基づいてトポロジとリソース情報をグローバルにフラッディングします。

リンクステート IGP(IS-IS または OSPF)で使用される SPF 計算に対する拡張:設定されている場合、IGP は、トンネルの宛先に基づいて、トラフィックを適切な TE トンネルに自動的にルーティングします。また、スタティック ルートを使用して、TE トンネルにトラフィックを誘導することもできます。

ラベル スイッチング転送:この転送メカニズムは、レイヤ 2 と類似の機能をルータに提供し、RSVP シグナリングによって確立された LSP の複数のホップを経由してトラフィックを誘導できるようにします。

MPLS TE と HA

MPLS TE では、次の Cisco NX-OS High Availability(HA; ハイ アベイラビリティ)機能がサポートされています。

Nonstop Forwarding(NSF; ノンストップ フォワーディング)

ステートフル HA

MPLS TE では、NSF とステートフル HA を可能にするため、次の Cisco NX-OS HA テクノロジーがサポートされています。

ステートフル プロセス再起動

Stateful Switch Over(SSO; ステートフル スイッチオーバー)

In-Service Software Upgrade(ISSU; インサービス ソフトウェア アップグレード)

MPLS TE のライセンス要件

次の表に、この機能のライセンス要件を示します。

 

製品
ライセンス要件

Cisco NX-OS

MPLS TE 機能では、MPLS ライセンスが必要です。Cisco NX-OS ライセンス方式の詳細と、ライセンスの取得および適用の方法については、『 Cisco NX-OS Licensing Guide 』を参照してください。

MPLS TE の前提条件

MPLS TE には次の前提条件があります。

ネットワークがマルチプロトコル ラベル スイッチング(MPLS)をサポートしている必要があります。

ネットワークが、次のInterior Gateway Protocol(IGP)の少なくとも 1 つをサポートしている必要があります。

Intermediate System-to-Intermediate System(IS-IS)

Open Shortest Path First(OSPF)

MPLS TE に関する注意事項と制限事項

MPLS TE 設定時の注意事項と制限事項は次のとおりです。

MPLS TE は、1 つの IGP プロセスまたはインスタンスのみをサポートします。複数の IGP プロセスまたはインスタンスはサポートされず、複数の IGP プロセスまたはインスタンスでは MPLS TE を設定できません。MPLS TE を複数の OSPF エリアまたは両方の IS-IS レベルで設定することはできます。

論理 Generic Routing Encapsulation(GRE; 総称ルーティング カプセル化)トンネル インターフェイスには MPLS TE を設定できません。

MPLS TE のデフォルト設定

表 11-1 に、基本的な MPLS TE のデフォルト設定の一覧を示します。

 

表 11-1 MPLS TE のデフォルト設定

パラメータ
デフォルト

MPLS TE 機能

ディセーブル

MPLS TE のイネーブル化

デバイス上で MPLS TE 機能をイネーブルにすることができます。

前提条件

適切な VDC であることを確認します(または、 switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. feature mpls traffic-engineering

3. (任意) show running-config

4. (任意) copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

feature mpls traffic-engineering

 

例:

switch(config)# feature mpls traffic-engineering

MPLS TE 機能をイネーブルにします。

ステップ 3

show running-config

 

例:

switch(config)# show running-config

(任意)実行コンフィギュレーションに関する情報を表示します。

ステップ 4

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

MPLS TE の設定

ここでは、次の内容について説明します。

「IS-IS の MPLS TE 用の設定」(P.11-4)

「OSPF の MPLS TE 用の設定」(P.11-6)

「インターフェイスでの MPLS TE の設定」(P.11-7)

「MPLS TE トンネルの設定」(P.11-8)

「明示パスの設定」(P.11-11)

IS-IS の MPLS TE 用の設定

IS-IS を MPLS TE 用に設定できます。


) MPLS TE は、1 つの IGP プロセスまたはインスタンスをサポートします。MPLS TE は複数の IGP プロセスまたはインスタンスで設定できません。


前提条件

MPLS TE 機能がイネーブルになっている必要があります(「MPLS TE のイネーブル化」を参照)。

適切な VDC であることを確認します(または、 switchto vdc コマンドを使用します)。

手順の概要


) IS-IS が動作するルータを、Protocol-Independent Multicast(PIM; プロトコル独立マルチキャスト)と MPLS TE が連携するように設定できます。そのためには、mpls traffic-eng multicast-intact コマンドを使用します。PIM と MPLS TE の相互運用性をディセーブルにするには、no mpls traffic-eng multicast-intact コマンドを使用します。


1. configure terminal

2. feature isis

3. router isis instance-tag

4. mpls traffic-eng { level-1 | level-1-2 | level-2 }

5. mpls traffic-eng router-id interface

6. (任意) show running-config isis

7. (任意) copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

feature isis

 

例:

switch(config)# feature isis

IS-IS 機能をイネーブルにします。

ステップ 3

router isis instance -tag

 

例:

switch(config)# router isis

switch(config-router)#

IS-IS インスタンスを設定し、ルータ コンフィギュレーション モードを開始します。 instance-tag には最大 20 文字の英数字文字列を指定します。大文字と小文字は区別されます。

ステップ 4

mpls traffic-eng { level-1 | level-1-2 | level-2 }

 

例:

switch(config-router)# mpls traffic-eng level-1

MPLS TE を IS-IS 用に設定します。MPLS を、レベル 1、レベル 2、またはレベル 1 とレベル 2 のルータ用にイネーブルにできます。

ステップ 5

mpls traffic-eng router-id interface

 

例:

switch(config-router)# mpls traffic-eng router-id loopback0

ノードの TE ルータ ID を設定されたインターフェイスに関連付けられている IP アドレスにするように指定します。

ステップ 6

show running-config isis

 

例:

switch(config-router)# show running-config isis

(任意)IS-IS の設定に関する情報が表示されます。

ステップ 7

copy running-config startup-config

 

例:

switch(config-router)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

OSPF の MPLS TE 用の設定

OSPF を MPLS TE 用に設定できます。


) MPLS TE は、1 つの IGP プロセスまたはインスタンスをサポートします。MPLS TE は複数の IGP プロセスまたはインスタンスで設定できません。


前提条件

MPLS TE 機能がイネーブルになっている必要があります(「MPLS TE のイネーブル化」を参照)。

適切な VDC であることを確認します(または、 switchto vdc コマンドを使用します)。

手順の概要


) OSPF が動作しているルータを設定し、プロトコル独立マルチキャスト(PIM)と MPLS TE を連携させることができます。そのためには、mpls traffic-eng multicast-intact コマンドを使用します。PIM と MPLS TE の相互運用性をディセーブルにするには、no mpls traffic-eng multicast-intact コマンドを使用します。


1. configure terminal

2. feature ospf

3. router ospf instance-tag

4. mpls traffic-eng area area-id

5. mpls traffic-eng router-id interface

6. (任意) show running-config ospf

7. (任意) copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

feature ospf

 

例:

switch(config)# feature OSPF

IS-IS 機能をイネーブルにします。

ステップ 3

router ospf instance-tag

 

例:

switch(config)# router ospf 200

switch(config-router)#

OSPF ルーティング インスタンスを設定し、ルータ コンフィギュレーション モードを開始します。 instance-tag には最大 20 文字の英数字文字列を指定します。大文字と小文字は区別されます。

ステップ 4

mpls traffic-eng area area-id

 

例:

switch(config-router)# mpls traffic-eng area 1

指定された OSPF エリアについて MPLS TE を有効にします。 area-id 引数は、IP アドレスまたは正の整数です。

ステップ 5

mpls traffic-eng router-id interface

 

例:

switch(config-router)# mpls traffic-eng router-id loopback0

ノードの TE ルータ ID を設定されたインターフェイスに関連付けられている IP アドレスにするように指定します。

ステップ 6

show running-config ospf

 

例:

switch(config-router)# show running-config ospf

(任意)OSPF の設定に関する情報を表示します。

ステップ 7

copy running-config startup-config

 

例:

switch(config-router)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

インターフェイスでの MPLS TE の設定

TE トンネルの出力インターフェイス上で MPLS TE を設定できます。

前提条件

MPLS TE 機能がイネーブルになっている必要があります(「MPLS TE のイネーブル化」を参照)。

適切な VDC であることを確認します(または、 switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. interface type slot / port

3. mpls traffic-eng tunnels

4. mpls traffic-eng bandwidth [ interface-kbps | percent percentage ]

5. no shut

6. (任意) show interface type slot / port

7. (任意) copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface type slot / port

 

例:

switch(config)# interface ethernet 2/1

switch(config-if)#

インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。サポートされているインターフェイスのリストを表示するには、 ? を使用します。

ステップ 3

mpls traffic-eng tunnels

 

例:

switch(config-if)# mpls traffic-eng tunnels

インターフェイス上で MPLS TE トンネルをイネーブルにします。

ステップ 4

mpls traffic-eng bandwidth [ interface-kbps | percent percentage ]

 

例:

switch(config-if)# mpls traffic-eng bandwidth 1000

インターフェイス用の MPLS TE 帯域幅プールを割り当てます。 interface-kbps 引数は、TE フローごとに割り当てることができる最大帯域幅を指定します(kbps 単位)。指定できる範囲は 1 ~ 10000000 です。 percentage 引数は、TE フローごとに割り当てることができるリンク帯域幅の最大パーセンテージを指定します。指定できる範囲は 1 ~ 100 です。

ステップ 5

no shut

 

例:

switch(config-if)# no shut

インターフェイスをアクティブにします。

ステップ 6

show interface type slot / port

 

例:

switch(config-if)# show interface ethernet 2/1

(任意)インターフェイスに関する情報を表示します。サポートされているインターフェイスのリストを表示するには、 ? を使用します。

ステップ 7

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

MPLS TE トンネルの設定

優先される明示的なパスまたはバックアップ ダイナミック パス オプションを使用して MPLS TE トンネルを設定できます。


) この設定は、TE ヘッドエンド ノードのみに適用されます。


前提条件

MPLS TE 機能がイネーブルになっている必要があります(「MPLS TE のイネーブル化」を参照)。

適切な VDC であることを確認します(または、 switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. interface tunnel-te number

3. ip unnumbered type slot / port

4. destination { ip-address }

5. (任意) bandwidth bandwidth

6. path-option [ protect ] preference-number { dynamic | explicit { identifier id | name name} [ verbatim ]} [ lockdown ] [ bandwidth kbps] [ attributes listname]

7. (任意) autoroute announce

8. (任意)priority

9. no shutdown

10. (任意) show running-config interface int

11. (任意) copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface tunnel-te number

 

例:

switch(config)# interface tunnel-te 1

switch(config-if-te)#

TE インターフェイス コンフィギュレーション モードを開始します。引数 number の範囲は、0 ~ 65503 です。

ステップ 3

ip unnumbered type slot / port

 

例:

switch(config-if-te)# ip unnumbered loopback 0

このトンネル インターフェイスに、設定されているインターフェイスの IP アドレスと同じ IP アドレスを割り当てます。MPLS TE トンネル インターフェイスは、ループバック インターフェイスから取得したアドレスなど、安定したアドレスを使用する必要があります。サポートされているインターフェイスのリストを表示するには、 ? を使用します。

(注) このコマンドは、Lookback0 が IP アドレスとともに設定されるまでは有効になりません。

ステップ 4

destination { ip-address }

 

例:

switch(config-if-te)# destination 10.3.3.3

トンネルの宛先を指定します。宛先は、宛先デバイスの MPLS TE ルータ ID またはホスト名にする必要があります。 ip-address は、ドット付き 10 進表記で指定します。

ステップ 5

bandwidth bandwidth

 

例:

switch(config-if-te)# bandwidth 250

(任意)MPLS TE トンネルの帯域幅を設定します。 bandwidth 引数は、MPLS TE トンネルに設定された帯域幅(キロビット/秒単位)です。指定できる範囲は 1 ~ 4294967295 です。デフォルト値は 0 です。

ステップ 6

path-option [protect] preference-number {dynamic | explicit { identifier id | name name } [ verbatim ]} [lockdown] [ bandwidth kbps ] [ attributes listname ]

 

例:

switch(config-if-te)# path-option 10 explicit name Link5

指定した IP 明示パス、または TE トポロジ データベースからダイナミックに計算されたパスを使用するようにトンネルを設定します。 preference-number の指定できる範囲は 1 ~ 1000 です。 id の範囲は、1 ~ 65535 です(数値が小さいほうが優先されます)。 name は、大文字と小文字が区別される任意の英数字文字列です。 kbps の範囲は 1 ~ 4294967295 です。 listname は、63 文字以内の英数字の文字列(大文字と小文字を区別)で指定します。

(注) 複数のパス オプションを設定できます。TE は、有効かつ制約を満たす、番号が最も小さいパス オプションをシグナリングします。たとえば、明示パス オプションと、優先しない動的パス オプションを指定できます。明示パスが使用できない場合、優先しない動的パス オプションが試されます。

ステップ 7

autoroute announce

 

例:

switch(config-if-te)# autoroute announce

(任意)IGP における拡張 Shortest Path First(SPF)の計算において、(トンネルがアップの場合に)トンネルを使用する必要があることを指定します。

ステップ 8

priority

 

例:

switch(config-if-te)# priority

(任意)トラフィックにプライオリティを割り当てます。

ステップ 9

no shutdown

 

例:

switch(config-if-te)# no shutdown

インターフェイスをアクティブにします。

ステップ 10

show running-config interface int

 

switch(config-if-te)# show running-config interface tunnel-ts 1

(任意)インターフェイスの設定に関する情報を表示します。

ステップ 11

copy running-config startup-config

 

例:

switch(config-if-te)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

明示パスの設定

ヘッドエンド ルータ上で明示的な LSP パスを設定できます。

前提条件

MPLS TE 機能をイネーブルにしておく必要があります(「MPLS TE のイネーブル化」を参照)。

適切な VDC であることを確認します(または、 switchto vdc コマンドを使用します)。

手順の概要

1. configure terminal

2. mpls traffic-eng configuration

3. explicit-path { identifier id | name name }

4. [ index number ] { next-address [ loose | strict ] | exclude-address } address

5. パス内の各ルータについてステップ 4 を繰り返します。

6. (任意) shutdown

7. (任意) show running-config mpls

8. (任意) copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

mpls traffic-eng configuration

 

例:

switch(config)# mpls traffic-eng configuration

switch(config-te)#

MPLS TE コンフィギュレーション モードを開始します。

ステップ 3

explicit-path { identifier id | name name }

 

例:

switch(config-te)# explicit-path name Link5

明示パス コンフィギュレーション モードを開始し、指定されたパスを作成または変更します。指定できる id 範囲は 1 ~ 65535 です。 name は、大文字と小文字が区別される任意の英数字文字列です。

ステップ 4

[ index number ] { next-address [ loose | strict ] | exclude-address } address

 

例:

switch(config-te-expl-path)# index 10 next-address 10.3.3.3

指定したインデックスでパス エントリを挿入または変更します。指定できる範囲は 1 ~ 65535 です。 address は、ノード ID を表し、ドット付き 10 進表記の IP アドレスです。

index number オプションを省略すると、複数のコマンド ステートメントが入力した順序で適用されます。

Loose は、明示パスの中の前のアドレス(存在する場合)を次の IP アドレスに直接接続する必要がなく、前のアドレス(存在する場合)から次の IP アドレスへのパスをルータが自由に決定して良いことを指定します。

Strict は、明示パスの中の前のアドレス(存在する場合)を次の IP アドレスに直接接続する必要があることを指定します。

Exclude-address は、以降の部分的なパス セグメントからアドレスを除外します。リンクの IP アドレスかノードのルータ ID を入力します。

ステップ 5

パス内の各ルータについてステップ 4 を繰り返します。

--

ステップ 6

shutdown

 

例:

switch(config-te-expl-path)# shutdown

(任意)設定を削除せずに明示パスをディセーブルにします。

ステップ 7

show running-config mpls

 

例:

switch(config-te-expl-path)# show running-config mpls

(任意)MPLS の設定に関する情報を表示します。

ステップ 8

copy running-config startup-config

 

例:

switch(config-te-expl-path)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

MPLS TE の設定の確認

MPLS TE の設定を表示するには、次のいずれかの作業を行います。

 

コマンド
目的

show mpls traffic-eng

MPLS TE に関する情報を表示します。

show mpls traffic-eng tunnels

ヘッドおよび他のホップでシグナリングされた TE LSP で、設定されている MPLS TE トンネルに関する情報を表示します。

show run mpls traffic-eng

MPLS TE 機能の実行コンフィギュレーションに関する情報を表示します。

show mpls traffic-eng link-management summary

MPLS TE リンク管理に関するサマリー情報を表示します。

show mpls traffic-eng explicit-paths

MPLS TE の明示的パスに関する情報を表示します。

show mpls traffic-eng tunnels brief

MPLS TE トンネルに関する簡潔な情報を表示します。

show ip route

MPLS TE IP ルートを表示します。

これらのコマンドの出力フィールドの詳細については、『 Cisco NX-OS MPLS Command Reference 』を参照してください。

MPLS VPN の設定例

ここでは、次の設定例を示します。

「例:IS-IS を使用した MPLS TE のイネーブル化」(P.11-13)

「例:OSPF を使用した MPLS TE のイネーブル化」(P.11-14)

「例:インターフェイスでの MPLS TE の設定」(P.11-14)

「例:MPLS TE トンネルの設定」(P.11-14)

「例:明示パスの作成」(P.11-14)

例:IS-IS を使用した MPLS TE のイネーブル化

次に、IS-IS ルーティングを使用して MPLS TE をイネーブルにする例を示します。


) ネットワークのトラフィック エンジニアリング対象部分にあるすべてのルータまたはスイッチで次のコマンドを入力する必要があります。


feature isis
feature mpls traffic-engineering
router isis 100
mpls traffic-eng level-1
mpls traffic-eng router-id loopback0
 

例:OSPF を使用した MPLS TE のイネーブル化

次に、OSPF ルーティングを使用して MPLS TE をイネーブルにする例を示します。


) ネットワークのトラフィック エンジニアリング対象部分にあるすべてのルータまたはスイッチで次のコマンドを入力する必要があります。


feature ospf
feature mpls traffic-engineering
router ospf 100
mpls traffic-eng area 0
mpls traffic-eng router-id loopback0

例:インターフェイスでの MPLS TE の設定

次に、インターフェイスで TE を設定する例を示します。

feature mpls traffic-engineering
interface Ethernet 9/1
mpls traffic-eng tunnels
mpls traffic-eng bandwidth 1000
no shut

) インターフェイスは、IGP で使用されるように設定されている必要があります。ISIS では、次のような構文になります。
ip router isis p1


例:MPLS TE トンネルの設定

次に、TE トンネルを設定する例を示します。

feature mpls traffic-engineering
interface tunnel-te 1
ip unnumbered loopback 0
destination 10.3.3.3
bandwidth 250
path-option 10 explicit name Link5
path-option 20 dynamic
autoroute announce
no shut

例:明示パスの作成

次に、明示パスを設定する例を示します。

feature mpls traffic-engineering
mpls traffic-eng configuration
explicit-path name Link5
next-address 10.1.1.21
next-address 10.1.1.10
next-address 10.1.1.1
next-address 10.1.1.14

MPLS TE に関する追加情報

MPLS TE の実装に関する詳細情報については、次を参照してください。

「関連資料」(P.11-15)

「MIB」(P.11-15)

「RFC」(P.11-15)

関連資料

関連項目
参照先

MPLS TE コマンド

『Cisco NX-OS Multiprotocol Label Switching Command Reference』

MIB

MIB
MIB のリンク

CISCO-IETF-FRR-MIB

MPLS-FTN-STD-MIB

MPLS TE-STD-MIB

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットに対する Cisco MIB を特定してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 2205

『Resource ReSerVation Protocol (RSVP) - Version 1 Functional Specification』

RFC 2961

『RSVP Refresh Overhead Reduction Extensions』

RFC 3209

『RSVP TE: Extensions to RSVP for LSP Tunnels』

RFC 3630

『Traffic Engineering (TE) Extensions to OSPF Version 2』

RFC 3784

『Intermediate System to Intermediate System (IS-IS) Extensions for Traffic Engineering (TE)』

RFC 3812

『MPLS TE MIB』

RFC 3814

『MPLS-FTN-STD-MIB』

RFC 4090

『Fast Reroute Extensions to RSVP TE for LSP Tunnels』

MPLS TE の機能履歴

表 11-2 は、この機能のリリースの履歴です。

 

表 11-2 MPLS TE の機能履歴

機能名
リリース
機能情報

MPLS TE

5.2(1)

この機能が導入されました。