Cisco Nexus 7000 シリーズ NX-OS MPLS コンフィギュレーション ガイド
MPLS ラベル配布プロトコルの設定
MPLS ラベル配布プロトコルの設定
発行日;2012/05/08 | 英語版ドキュメント(2011/10/28 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

MPLS ラベル配布プロトコルの設定

MPLS LDP について

MPLS LDP の概要

MPLS LDP 機能の概要

MPLS LDP セッション

直接接続されている MPLS LDP セッション

直接接続されていない MPLS LDP セッション

LDP ラベル バインディングとラベル スペース

LDP Identifier

MPLS LDP 転送アドレス

明示的ヌル ラベル

MPLS LDP のためのハイ アベイラビリティ

MPLS LDP のライセンス要件

MPLS LDP の前提条件

MPLS および LDP に関する注意事項と制限事項

MPLS LDP のデフォルト設定

MPLS LDP の設定

MPLS LDP のグローバルなイネーブル化

インターフェイスでの MPLS LDP のイネーブル化

直接接続されている LDP セッションのイネーブル化

直接接続されていない MPLS LDP セッションの確立

MPLS LDP バックオフ間隔の設定

MPLS LDP ホールド タイムの設定

LDP ルータ ID の指定

MPLS LDP 転送アドレスの設定

MPLS LDP 明示的ヌル ラベルによる QoS 設定の保持

MPLS LDP サービスのシャットダウン

MPLS LDP 設定の確認

MPLS LDP の設定例

例:直接接続されている MPLS LDP セッションの接続

例:直接接続されていない MPLS LDP セッションの確立

例:LDP ルータ ID の指定

例:MPLS LDP 明示的ヌル ラベルによる QoS 設定の保持

MPLS LDP の追加情報

関連資料

RFC

MIB

MPLS LDP の機能履歴

MPLS ラベル配布プロトコルの設定

この章では、Cisco NX-OS デバイスで Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)Label Distribution Protocol(LDP; ラベル配布プロトコル)を設定する方法について説明します。

この章では、次の内容について説明します。

「MPLS LDP について」

「MPLS LDP のライセンス要件」

「MPLS LDP の前提条件」

「MPLS および LDP に関する注意事項と制限事項」

「MPLS LDP のデフォルト設定」

「MPLS LDP の設定」

「MPLS LDP 設定の確認」

「MPLS LDP の設定例」

「MPLS LDP の追加情報」

「MPLS LDP の機能履歴」

MPLS LDP について

MPLS LDP は、ピアの Label Switch Router(LSR; ラベル スイッチ ルータ)が MPLS ネットワークでホップバイホップ転送をサポートするためのラベル バインディング情報を交換できるようにします。

ここでは、MPLS LDP の概要について説明します。

「MPLS LDP の概要」

「MPLS LDP 機能の概要」

「MPLS LDP セッション」

「LDP ラベル バインディングとラベル スペース」

「LDP Identifier」

「MPLS LDP 転送アドレス」

「明示的ヌル ラベル」

「MPLS LDP のためのハイ アベイラビリティ」

MPLS LDP の概要

MPLS LDP では、LSR でプレフィクスのラベル バインディング情報をネットワークのピア ルータに要求、配信、および解放するための方法が提供されています。LDP は、LSR が潜在的なピアを検出し、ラベル バインディング情報を交換するために、それらのピアと LDP セッションを確立できるようにします。

MPLS LDP では、1 台の LSR が、自身が行ったラベル バインディングを別の LSR に通知します。一組のルータは LDP パラメータ通信を行うと、Label Switched Path(LSP; ラベル スイッチド パス)を確立します。MPLS LDP を使用すると、LSR は、通常ルーティングされるパスに沿ってラベルを配布して MPLS 転送に対応できます。このラベル配布方法は、 ホップバイホップ転送 とも呼ばれます。IP 転送では、パケットがルータに到達すると、そのルータは IP ヘッダー内の宛先アドレスを確認し、ルート検索を実行してパケットをネクスト ホップに転送します。MPLS 転送では、パケットがルータに到達すると、そのルータは入ラベルを確認し、テーブル内のラベルを検索してパケットをネクスト ホップに転送します。MPLS LDP は、MPLS Virtual Private Network(VPN; バーチャル プライベート ネットワーク)などのホップバイホップ転送を必要とするアプリケーションに役立ちます。

MPLS LDP 機能の概要

MPLS LDP は、MPLS VPN などの MPLS 対応アプリケーションのビルディング ブロックを提供します。

MPLS LDP は、基になる Interior Gateway Protocol(IGP)ルーティング プロトコルによって選択されたルートにラベルを割り当てることにより、MPLS ネットワークにおけるホップバイホップ(つまりダイナミック ラベル)配布の標準の方式を提供します。最終的な Label Switched Path(LSP; ラベル スイッチド パス)は、MPLS バックボーン上のラベル トラフィックを特定の宛先に転送します。これらの機能により、サービス プロバイダーは MPLS ベースの IP VPN を実装できます。

MPLS LDP セッション

MPLS LDP をイネーブルにすると、LSR はメッセージを送信して、LDP セッションを作成できる他の LSR を探そうとします。次からの項では、直接接続の LDP セッションと直接接続ではない LDP セッションの違いを説明します。

直接接続されている MPLS LDP セッション

LSR がそのネイバーから 1 つめのホップである場合、LSR はネイバーに直接接続されています。LSR は、LDP リンク hello メッセージを User Datagram Protocol(UDP; ユーザ データグラム プロトコル)パケットとしてサブネット上のすべてのルータに送信します(マルチキャスト)。ネイバー LSR がリンク hello メッセージに応答して、2 台のルータが LDP セッションを確立できます。このプロセスを ベーシック ディスカバリ と呼びます。

ルータ間で LDP セッションを開始するには、アクティブな役割を果たすルータとパッシブな役割を果たすルータを決定する必要があります。アクティブな役割を果たすルータは、LDP TCP 接続を確立し、LDP セッション パラメータのネゴシエーションを開始します。役割を決定するために、2 台のルータは転送アドレスを比較します。IP アドレスが高位のルータがアクティブな役割を担い、セッションを確立します。

LDP TCP 接続の確立後、LSR は、使用するラベル配布方法も含めてセッション パラメータをネゴシエーションします。2 つの方法があります。

Downstream unsolicited :LSR は要求されない場合もピアにラベル マッピングをアドバタイズします。

Downstream on demand :LSR は、ピアが要求した場合のみピアにラベル マッピングをアドバタイズします。

直接接続されていない MPLS LDP セッション

LSR がネイバーから 2 つめ以降のホップである場合、LSR はそのネイバーに直接接続されていません。これらの直接接続されていないネイバーの場合、LSR は、その LSR を明示的にアドレス指定した UDP パケットとしてターゲット hello メッセージを送信します(ユニキャスト)。直接接続されていない LSR が hello メッセージに応答すると、2 つのルータは LDP セッションの確立を開始します。このプロセスを 拡張ディスカバリ と呼びます。

MPLS LDP ターゲット セッションは、直接接続されていないルータ間のラベル配布セッションです。MPLS Traffic Engineering(TE; トラフィック エンジニアリング)トンネル インターフェイスを作成する場合、トンネルのヘッドエンドとテールエンドのルータ間でラベル配布セッションを確立する必要があります。直接接続されていない MPLS LDP セッションを確立するには、ターゲット hello メッセージの伝送をイネーブルにします。

2 つの直接接続されていないネイバー間でのターゲット hello メッセージの交換は、次のようないくつかの方法で行えます。

ルータ 1 がルータ 2 に応答要求を含むターゲット hello メッセージを送信します。ルータ 2 は、設定で許可されている場合、応答としてターゲット hello メッセージを送信します。この場合、ルータ 1 はアクティブと見なされ、ルータ 2 はパッシブと見なされます。

ルータ 1 とルータ 2 は、両方ともターゲット hello メッセージを相互に送信します。両方のルータがアクティブと見なされます。相互のルータから送信されたターゲット hello メッセージの要求に応答するように設定されている場合、両方または一方がパッシブと見なされるか、またはどちらもパッシブと見なされないことがあります。

LSR のデフォルトの動作では、ターゲット hello メッセージを送信する他の LSR からの要求を無視します。 discovery targeted-hello accept コマンドを使用して、ターゲット hello メッセージの要求に応答するように LSR を設定することができます。

LDP ラベル バインディングとラベル スペース

LDP ラベル バインディング とは、送信先プレフィクスとラベルの関連付けです。ラベル バインディングで使用されるラベルは、 ラベル スペース と呼ばれる使用可能なラベルのセットから割り当てられます。

LDP は 2 種類のラベル スペースをサポートします。

インターフェイス固有 :インターフェイス固有のラベル スペースは、ラベル用のインターフェイス リソースを使用します。設定によって、LDP プラットフォームでサポートされるインターフェイス固有のラベル スペースの数は、ゼロ、1 つ、または複数です。

プラットフォーム全体 :LDP プラットフォームは、同じラベルを共有できるインターフェイスで使用されるプラットフォーム全体のラベル スペース 1 つをサポートします。シスコのプラットフォームでは、すべてのインターフェイス タイプでプラットフォーム全体のラベル スペースが使用されます。

LDP Identifier

LDP では、 LDP Identifier LDP ID )と呼ばれる 6 バイトを使用してラベル スペースに名前を付けます。LDP ID は、次のコンポーネントで構成されます。

最初の 4 バイトは LDP ルータ ID と呼ばれ、ラベル スペースを所有する LSR を識別します。

最後の 2 バイトは ローカル ラベル スペース ID と呼ばれ、LSR 内のラベル スペースを識別します。プラットフォーム全体のラベル スペースの場合、LDP ID の最後の 2 バイトは、両方とも常に 0 です。

LDP ID は、 LDP ルータ ID : ローカル ラベル スペース ID という形式になります。

次に、LDP ID の例を示します。

172.16.0.0:0

192.168.0.0:3

次の手順では、LDP ルータ ID を決定するデフォルトのプロセスについて説明します。

1. ルータは、すべての動作インターフェイスの IP アドレスを調べます。

2. これらの IP アドレスにループバック インターフェイス アドレスが含まれている場合、ルータは最大のループバック アドレスを LDP ルータ ID として選択します。

ループバック アドレスを設定すると、リンクダウン イベントが発生した場合でも、ループバック アドレスの状態は変化しないので、ルータに安定した LDP ID を維持するのに役立ちます。また、一般に、LDP ルータ ID は複数のリブートにわたって保持されることが理想的です。

ループバック IP アドレスは、次の状況では LDP ルータ ID になりません。

ループバック インターフェイスが明示的にシャットダウンされた場合

LDP ルータ ID として使用する異なるインターフェイスを設定した場合。


) ループバック インターフェイスを使用する場合は、ループバック インターフェイスの IP アドレスが /32 ネットワーク マスクで設定されていることを確認します。さらに、使用中のルーティング プロトコルが対応する /32 ネットワークをアドバタイズするように設定されていることを確認します。


3. 含まれていない場合、ルータは、動作しているインターフェイスで見つかった最も大きい IP アドレスを LDP ルータ ID として選択します。


) ルータ ID を選択する LDP アルゴリズムはループバック インターフェイスを選択しようと試みますが、すべてのスタートアップ シナリオでその動作が保証されているわけではありません。したがって、LDP ルータ ID を明示的に設定することをお勧めします。


MPLS LDP 転送アドレス

LDP ルータ ID のデフォルトの決定方法では、特定の状況で使用できないルータ ID が選択される場合があります。たとえば、ルータは IP アドレスを、ルーティング プロトコルがネイバー ルータにアドバタイズできない LDP ルータ ID として選択することがあります。このため、インターフェイスの IP アドレスを LDP ルータ ID として指定する必要があります。そのように指定すると、ルータは、次に LDP ルータ ID を選択する必要があるときは、指定されたインターフェイスの IP アドレスを選択します(インターフェイスが動作している場合)。これは、通常、次に現在のルータ ID インターフェイスがシャットダウンされるかそのアドレスが変更されたときです。

2 台のルータ間で LDP セッションを確立するには、ルータ間でラベル アドバタイズメントを交換できるセッション TCP 接続が必要です。セッション TCP 接続を確立するには、各ルータが他のルータの転送アドレス(IP アドレス)を認識している必要があります。

LDP ディスカバリ メカニズムでは、ルータはセッションの終わりの TCP 接続の転送アドレスをアドバタイズできます。転送アドレスのアドバタイズメントが明示的な場合、転送アドレスは、ピアに送信されるディスカバリ hello メッセージの内容の一部として表示されます。転送アドレスのアドバタイズメントが暗黙的な場合、転送アドレスはディスカバリ hello メッセージには含まれず、ピアは受け取った hello メッセージの送信元 IP アドレスをピアの転送アドレスとして使用します。


) ピア デバイスに接続する複数のリンクがルータに存在する場合、そのルータでは、そのようなすべてのインターフェイス上で送信する LDP ディスカバリ hello メッセージで同じ転送アドレスをアドバタイズする必要があります。


明示的ヌル ラベル

LDP は通常、直接接続されたルートの暗黙的ヌル ラベルをアドバタイズします。暗黙的ヌル ラベルがアドバタイズされると、最後から 2 番めの LSR はパケットから MPLS ヘッダーを削除します。この場合、最後から 2 番めの LSR と最後の LSR は、MPLS ヘッダーが削除されるまで、パケットに含まれる Quality of Service(QoS)値にアクセスできません。Quality Of Service 値を保持するには、明示的ヌル ラベル(値が 0)をアドバタイズするように LSR を設定できます。最後から 2 番めのホップにある LSR は、IP パケットを転送する代わりにヌル ラベルの MPLS パケットを転送します。


) 最後から 2 番めのホップが少なくとも 2 つのラベルを含むラベル スタック付きの MPLS パケットを受け取り、最後から 2 番めのホップ ポップが実行されている場合、明示的ヌル ラベルは必要ありません。この場合は、最後から 2 番めの LSR と最後の LSR に必要な QoS 値を内部ラベルで伝送して、その QoS ポリシーを実装できます。


MPLS LDP のためのハイ アベイラビリティ

Cisco NX-OS アーキテクチャとハイ アベイラビリティ インフラストラクチャにより、フィーチャ コンポーネントの再起動がサポートされ、デバイスおよびネイバー デバイス上の他のサービスに対する操作がトランスペアレントに再開されます。このサポートにより、計画されているソフトウェア変更や予期しないソフトウェア障害中も連続的な動作が可能で、データ損失を最小限に抑えることができます。

MPLS LDP は、次の Cisco NX-OS のハイ アベイラビリティ テクノロジーをサポートしています。

レイヤ 2 トラフィックの Nonstop Forwarding(NSF; ノンストップ フォワーディング)

レイヤ 3 プロセスのグレースフル(ステートレス)リスタート

In-Service Software Upgrade(ISSU; インサービス ソフトウェア アップグレード)

MPLS LDP のライセンス要件

 

製品
ライセンス要件

Cisco NX-OS

MPLS LDP には MPLS Services ライセンスが必要です。Cisco NX-OS ライセンス方式の詳細と、ライセンスの取得および適用の方法については、『 Cisco NX-OS Licensing Guide 』を参照してください。

MPLS LDP の前提条件

MPLS LDP には次の前提条件があります。

アドレス予約された Intrusion Detection System(IDS; 侵入検知システム)チェックはデフォルトでディセーブルになっています。MPLS LDP を使用する予定の場合は、( hardware ip verify address reserved コマンドを使用して)このチェックをイネーブルにしないでください。

MPLS および LDP に関する注意事項と制限事項

MPLS LDP 設定時の注意事項と制限事項は次のとおりです。

LDP で、リロード中にループバック インターフェイスが物理インターフェイスの前に選択される保証はありません。ルータ ID を明示的に設定して、ルータのリロードおよび設定コピーにわたって同じルータ ID が選択されるようにすることをお勧めします。

MPLS LDP のデフォルト設定

表 3-1 に、MPLS LDP パラメータのデフォルト設定を示します。

 

表 3-1 デフォルトの MPLS LDP パラメータ

パラメータ
デフォルト

グローバル MPLS LDP

ディセーブル

インターフェイス上の MPLS LDP

ディセーブル

ラベル配布モード

独立

ラベル保持モード

リベラル

ラベル アドバタイズメント

Downstream unsolicited

ベーシック hello タイム

ホールド タイム 15 秒、hello 間隔 5 秒

ターゲット hello タイム

ホールド タイム 90 秒、hello 間隔 10 秒

セッション時間

ホールド タイム 180 秒、キープアライブ インターバル 60 秒

初期バックオフ時間

15 秒

最大バックオフ時間

120 秒

転送アドレス

LDP ルータ ID

MPLS LDP の設定

ここでは、次の内容について説明します。

「MPLS LDP のグローバルなイネーブル化」

「インターフェイスでの MPLS LDP のイネーブル化」

「直接接続されている LDP セッションのイネーブル化」

「直接接続されていない MPLS LDP セッションの確立」

「MPLS LDP バックオフ間隔の設定」

「MPLS LDP ホールド タイムの設定」

「LDP ルータ ID の指定」

「MPLS LDP 転送アドレスの設定」

「MPLS LDP 明示的ヌル ラベルによる QoS 設定の保持」

「MPLS LDP サービスのシャットダウン」

MPLS LDP のグローバルなイネーブル化

MPLS LDP を LSR でグローバルにイネーブルにすることができます。

前提条件

適切な VDC であることを確認します(または、 switchto vdc コマンドを使用します)。

アドレス予約の IDS チェックがディセーブルになっていることを確認します。


) このチェックはデフォルトでディセーブルになっています。イネーブルになっている場合は、no hardware ip verify address reserved コマンドを使用して、ディセーブルにしてください。


手順の概要

1. configure terminal

2. feature mpls ldp

3. (任意)show running-config mpls ldp

4. (任意)copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

feature mpls ldp

 

例:

switch(config)# feature mpls ldp

デバイスの MPLS LDP 機能をイネーブルにします。

(注) デバイスで MPLS LDP 機能がディセーブルになっていると、LDP コマンドを使用できません。

ステップ 3

show running-config mpls ldp

 

例:

switch(config)# show running-config mpls ldp

(任意)デバイス上の MPLS LDP の設定ステータスを表示します。

(注) デバイスで MPLS LDP がディセーブルになっていると、LDP 情報は表示されません。

ステップ 4

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

インターフェイスでの MPLS LDP のイネーブル化

個々のインターフェイスで MPLS LDP をイネーブルにすることができます。LDP をイネーブルにするには、グローバルに設定するとともに、必要な各インターフェイスで設定する必要があります。


) MPLS LDP 自動設定機能を使用して、指定された Interior Gateway Protocol(IGP)インスタンスに関連付けられたすべてのインターフェイスで MPLS LDP をグローバルに設定する方法もあります。自動設定機能を使用すると、各インターフェイスで個別に LDP を設定する必要がないので、LDP 設定を簡単に、迅速に、エラーを発生させることなく行うことができます。詳細については、「MPLS LDP 自動設定の設定」を参照してください。


前提条件

適切な VDC であることを確認します(または、 switchto vdc コマンドを使用します)。

MPLS LDP をイネーブルにするインターフェイスが動作していることを確認します。

インターフェイスに IP アドレスが設定されていることを確認します。

手順の概要

1. configure terminal

2. interface interface slot/port

3. mpls ip

4. (任意)show mpls interface detail

5. (任意)copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface slot / port

 

例:

switch(config)# interface ethernet 2/2

switch(config-if)#

MPLS LDP をイネーブルにするインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

mpls ip

 

例:

switch(config-if)# mpls ip

特定のインターフェイスで MPLS LDP をイネーブルにします。

ステップ 4

show mpls interface detail

 

例:

switch(config-if)# show mpls interface detail

(任意)インターフェイス上の MPLS LDP の設定ステータスを表示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

直接接続されている LDP セッションのイネーブル化

2 つの直接接続されているルータ間で MPLS LDP セッションを設定できます。


) MPLS ラベル転送のコンバージェンス時間が重要な場合は、代わりに、neighbor ip-address targeted コマンドを使用して、直接接続された MPLS LSR 間でターゲット セッションを作成することもできます。このコマンドを使用すると、直接接続されたネイバー LSR のリンクがダウンした場合に、これらのラベル コンバージェンス時間を短縮することができます。ネイバー LSR 間のリンクが動作している場合、リンクとターゲット両方の hello で LDP セッションが維持されます。ネイバー LSR 間のリンクがダウンした場合、ターゲット hello でセッションが維持され、LSR は相手から学習したラベルを保持できます。LSR を直接接続するリンクがアップ状態に戻ると、LSR はただちに転送用のラベルを再インストールします。このとき、LDP セッションを再確立したり、ラベルを交換したりする必要はありません。ターゲット hello を自動的に開始して、直接接続されている LDP セッションを保護する方法については、「MPLS LDP セッション保護の設定」を参照してください。


前提条件

適切な VDC であることを確認します(または、 switchto vdc コマンドを使用します)。

MPLS LDP セッションを確立するインターフェイスが動作していることを確認します。

インターフェイスに IP アドレスが設定されていることを確認します。

手順の概要

1. configure terminal

2. interface interface slot/port

3. mpls ip

4. exit

5. mpls ldp configuration

6. (任意) discovery hello { holdtime seconds | interval seconds }

7. (任意) show mpls ldp discovery [ detail ]

8. (任意)show mpls ldp neighbor [ detail ]

9. (任意)copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface slot/port

 

例:

switch(config)# interface ethernet 2/2

switch(config-if)#

インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

mpls ip

 

例:

switch(config-if)# mpls ip

MPLS ホップバイホップ転送を設定します。

ステップ 4

exit

 

例:

switch(config-if)# exit
switch(config)#

インターフェイス コンフィギュレーション モードを終了します。

ステップ 5

mpls ldp configuration

 

例:

switch(config)# mpls ldp configuration
switch(config-ldp)#

LDP コンフィギュレーション モードを開始します。

ステップ 6

discovery hello { holdtime seconds | interval seconds }

 

例:

switch(config-ldp)# discovery hello holdtime 10

(任意) 直接接続されているネイバーのホールド タイムまたは間隔を設定します。

holdtime seconds キーワードと引数のペアでは、検出された LDP ネイバーが、ネイバーから LDP hello メッセージを受信しなくても記憶される時間を定義します。指定できる範囲は 1 ~ 65535 秒です。

nterval seconds キーワードと引数のペアでは、連続する hello メッセージを送信する間隔を定義します。指定できる範囲は 1 ~ 65535 秒です。

(注) 間隔がホールド タイム値の 3 分の 1 より大きい場合、間隔はホールド タイム値の 3 分の 1 に自動的に調整されます。

ステップ 7

show mpls ldp discovery [ detail ]

 

例:

switch(config-ldp)# show mpls ldp discovery

(任意)インターフェイスが動作し、ディスカバリ hello メッセージを送信していることを確認します。

ステップ 8

show mpls ldp neighbor [ detail ]

 

例:

switch(config-ldp)# show mpls ldp neighbor

(任意)ルータ間の LDP セッションが正常に確立されたことを示します。

ステップ 9

copy running-config startup-config

 

例:

switch(config-ldp)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

直接接続されていない MPLS LDP セッションの確立

直接接続されていない MPLS LDP を設定して、直接接続されていないルータ間で LDP 接続を確立することができます。

前提条件

適切な VDC であることを確認します(または、 switchto vdc コマンドを使用します)。

トンネルのテールエンド LSR にターゲット hello を開始する場合は、トンネル インターフェイスで mpls ip コマンドを入力して、トンネルまたは MPLS Traffic Engineering(TE; トラフィック エンジニアリング)がイネーブルになっていることを確認します。 neighbor ip_address targeted コマンドを使用して、別の LSR にターゲット hello を開始することもできます。( トンネルは feature tunnel コマンドを使用して、MPLS TE は feature mpls traffic-engineering コマンドを使用してイネーブルにすることができます )。

MPLS LDP セッションを確立するトンネルが動作していることを確認します。

トンネルの両端のルータをアクティブに設定するか、 discovery targeted-hello accept コマンドを使用して 1 台のルータをパッシブにします。(このコマンドの使用方法については、ステップ 8 を参照してください)。

手順の概要

1. configure terminal

2. interface [ tunnel | tunnel-te ] number

3. tunnel destination ip-address

4. mpls ip

5. exit

6. (任意) show running-config interface [ tunnel number | tunnel-te number ]

7. mpls ldp configuration

8. discovery targeted-hello {accept [ from prefix-list ] | holdtime seconds | interval seconds }

9. (任意) show mpls ldp discovery [ detail ]

10. (任意)copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface { tunnel | tunnel-te } number

 

例:

switch(config)# interface tunnel-te 1

switch(config-if-te)#

トンネル インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

tunnel destination ip-address

 

例:

switch(config-if-te)# tunnel destination 172.16.1.1

トンネル インターフェイスに IP アドレスを割り当てます。

ステップ 4

mpls ip

 

例:

switch(config-if-te)# mpls ip

MPLS ホップバイホップ転送を設定します。

ステップ 5

exit

 

例:

switch(config-if-te)# exit
switch(config)#

インターフェイス コンフィギュレーション モードを終了します。

ステップ 6

show running-config interface [ tunnel number | tunnel-te number ]

 

例:

switch(config)# show running-config interface tunnel-te 1

(任意)トンネル インターフェイスの実行コンフィギュレーションを表示します。

ステップ 7

mpls ldp configuration

 

例:

switch(config)# mpls ldp configuration
switch(config-ldp)#

LDP コンフィギュレーション モードを開始します。

ステップ 8

discovery targeted-hello { accept [ from prefix-list ] | holdtime seconds | interval seconds }

 

例:

switch(config-ldp)# discovery targeted-hello accept

すべてのネイバーまたは任意のプレフィクス リストで指定されたネイバーからのターゲット hello メッセージの要求に応答するようにルータを設定するか、直接接続されていないネイバーのホールド タイムまたは間隔を設定します。

holdtime seconds キーワードと引数のペアでは、検出された LDP ネイバーが、ネイバーから LDP hello メッセージを受信しなくても記憶される時間を定義します。指定できる範囲は 1 ~ 65535 秒です。

nterval seconds キーワードと引数のペアでは、連続する hello メッセージを送信する間隔を定義します。指定できる範囲は 1 ~ 65535 秒です。

(注) 間隔がホールド タイム値の 3 分の 1 より大きい場合、間隔はホールド タイム値の 3 分の 1 に自動的に調整されます。

ステップ 9

show mpls ldp discovery [ detail ]

 

例:

switch(config-ldp)# show mpls ldp discovery

(任意)インターフェイスが動作し、ディスカバリ hello メッセージを送信していることを確認します。

ステップ 10

copy running-config startup-config

 

例:

switch(config-ldp)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

MPLS LDP バックオフ間隔の設定

LDP セッションの確立にかかる時間を制限し、パラメータ情報の交換中にネイバーどうしが互いに負荷をかけ合うのを防ぐためのバックオフ間隔を設定できます。バックオフ間隔を設定している場合、セッション設定がルータ間の非互換性によって失敗すると、各 LSR は次の試行を遅らせて(バックオフ)、最大バックオフ遅延に達するまで、失敗するたびに遅延を指数関数的に増加させます。


) デフォルト値で望ましくない動作が発生する場合のみ、この設定を変更してください。


前提条件

適切な VDC であることを確認します(または、 switchto vdc コマンドを使用します)。

デバイスで MPLS LDP がイネーブルになっていることを確認します。

手順の概要

1. configure terminal

2. mpls ldp configuration

3. backoff initial-backoff max-backoff

4. (任意) show mpls ldp backoff

5. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

mpls ldp configuration

 

例:

switch(config)# mpls ldp configuration
switch(config-ldp)#

LDP コンフィギュレーション モードを開始します。

ステップ 3

backoff initial-backoff max-backoff

 

例:

switch(config-ldp)# backoff 30 240

LDP バックオフ メカニズムのセッション設定遅延パラメータを設定します。

initial-backoff 引数では、初期バックオフ値を秒数で定義します。指定できる範囲は 5 ~ 2147483 です。

max-backoff 引数では、最大バックオフ値を秒数で定義します。指定できる範囲は 5 ~ 2147483 です。

ステップ 4

show mpls ldp backoff

 

例:

switch(config-ldp)# show mpls ldp backoff

(任意)設定済みのセッション設定バックオフ パラメータ、およびセッション設定をスロットリングするときに使用される任意の LDP ピアに関する情報を表示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config-ldp)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

MPLS LDP ホールド タイムの設定

MPLS LDP ホールド タイムを設定して、セッション ピアからの LDP メッセージがない場合に LDP セッションを維持する時間を指定できます。


) 2 つの LSR 間で LDP セッションが確立されると、セッションのホールド タイムには、2 つの LSR で設定されている小さい方の値が使用されます。


前提条件

適切な VDC であることを確認します(または、 switchto vdc コマンドを使用します)。

デバイスで MPLS LDP がイネーブルになっていることを確認します。

手順の概要

1. configure terminal

2. mpls ldp configuration

3. holdtime { seconds | infinite }

4. (任意) show mpls ldp parameters

5. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

mpls ldp configuration

 

例:

switch(config)# mpls ldp configuration
switch(config-ldp)#

LDP コンフィギュレーション モードを開始します。

ステップ 3

holdtime { seconds | infinite }

 

例:

switch(config-ldp)# holdtime 30

セッション ピアからの LDP メッセージがない状態で LDP セッションが維持される時間を指定します。指定できる範囲は 15 ~ 65535 秒です。

ステップ 4

show mpls ldp parameters

 

例:

switch(config-ldp)# show mpls ldp parameters

(任意)セッションのホールド タイムを含む LDP パラメータを表示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config-ldp)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

LDP ルータ ID の指定

インターフェイスの IP アドレスを LDP ルータ ID として設定できます。

前提条件

適切な VDC であることを確認します(または、 switchto vdc コマンドを使用します)。

インターフェイスで MPLS LDP がイネーブルになっていることを確認します。

LDP ルータ ID として指定する前に、指定したインターフェイスが動作していることを確認します。

手順の概要

1. configure terminal

2. interface interface slot/port

3. exit

4. mpls ldp configuration

5. router-id interface number [ force ]

6. (任意) show mpls ldp discovery [detail]

7. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface slot/port

 

例:

switch(config)# interface loopback 2
switch(config-if)#

インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

exit

 

例:

switch(config-if)# exit
switch(config)#

インターフェイス コンフィギュレーション モードを終了します。

ステップ 4

mpls ldp configuration

 

例:

switch(config)# mpls ldp configuration
switch(config-ldp)#

LDP コンフィギュレーション モードを開始します。

ステップ 5

router-id interface number [ force ]

 

例:

switch(config-ldp)# router-id loopback 2

LDP ルータ ID を決定するための優先インターフェイスを指定します。通常、次にインターフェイスがシャットダウンされるかアドレスの設定が解除されたときに決定されます。

force キーワードでは、ルータ ID をさらに迅速に有効にすることができます。ただし、ルータ ID の実装は、指定したインターフェイスの現在の状態に応じて、次のように異なります。

インターフェイスがアップ状態で、その IP アドレスが現在 LDP ルータ ID ではない場合、LDP ルータ ID は、強制的にそのインターフェイスの IP アドレスに変更されます。LDP ルータ ID のこの強制的な変更によって、既存の LDP セッションが切断され、LDP セッションから学習されたラベル バインディングが解放されます。また、バインディングに関連付けられていた MPLS 転送アクティビティが中断されます。

インターフェイスがダウンしている場合、インターフェイスがアップ状態に移行すると、LDP ルータ ID は、強制的にそのインターフェイスの IP アドレスに変更されます。LDP ルータ ID のこの強制的な変更によって、既存の LDP セッションが切断され、LDP セッションから学習されたラベル バインディングが解放されます。また、バインディングに関連付けられていた MPLS 転送アクティビティが中断されます。

ステップ 6

show mpls ldp discovery [ detail ]

 

例:

switch(config-ldp)# show mpls ldp discovery

(任意)ローカル ルータの LDP ID を表示します。

ステップ 7

copy running-config startup-config

 

例:

switch(config-ldp)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

MPLS LDP 転送アドレスの設定

LDP ルータ ID が状況にふさわしくない場合、インターフェイスで送信された LDP ディスカバリ hello メッセージでアドバタイズされた転送アドレスを指定できます。デフォルトでは、LDP は LDP ルータ ID を転送アドレスとしてアドバタイズします。

前提条件

適切な VDC であることを確認します(または、 switchto vdc コマンドを使用します)。

インターフェイスで MPLS LDP がイネーブルになっていることを確認します。

手順の概要

1. configure terminal

2. interface interface slot/port

3. mpls ldp discovery transport-address { ip-address | interface}

4. (任意) show mpls ldp discovery detail

5. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface slot/port

 

例:

switch(config)# interface ethernet 2/2

switch(config-if)#

インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

mpls ldp discovery transport-address { ip-address | interface }

 

例:

switch(config-if)# mpls ldp discovery transport-address 209.165.200.225

インターフェイスで送信された LDP ディスカバリ hello メッセージでアドバタイズされた転送アドレスを指定します。

ip-address 引数では、転送アドレスとしてアドバタイズされる特定の IP アドレスを指定します。

interface キーワードでは、転送アドレスとしてアドバタイズされるインターフェイス IP アドレスを指定します。

ステップ 4

show mpls ldp discovery detail

 

例:

switch(config-if)# show mpls ldp discovery detail

(任意)転送アドレスを含む、LDP ディスカバリ プロセスのステータスを表示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

MPLS LDP 明示的ヌル ラベルによる QoS 設定の保持

QoS 値を保持するために、明示的ヌル ラベル(値は 0)をアドバタイズするように LSR を設定できます。明示的ヌル ラベルは、直接接続プレフィクス用の暗黙的ヌル ラベルの代わりにアドバタイズされます。

前提条件

適切な VDC であることを確認します(または、 switchto vdc コマンドを使用します)。

デバイスで MPLS LDP がイネーブルになっていることを確認します。

手順の概要

1. configure terminal

2. mpls ldp configuration

3. explicit-null [ for prefix-list | to prefix-list | for prefix-list to prefix-list ]

4. (任意) show mpls forwarding statistics

5. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

mpls ldp configuration

 

例:

switch(config)# mpls ldp configuration
switch(config-ldp)#

LDP コンフィギュレーション モードを開始します。

ステップ 3

explicit-null [ for prefix-list | to prefix-list | for prefix-list to prefix-list ]

 

例:

switch(config-ldp)# explicit-null

通常、暗黙的ヌル ラベルがアドバタイズされる状況で、明示的ヌル ラベルをアドバタイズします。

ステップ 4

show mpls forwarding statistics

 

例:

switch(config-ldp)# show mpls forwarding statistics

(任意)MPLS パケットが明示的ヌル ラベル(値は 0)で転送されることを確認します。

ステップ 5

copy running-config startup-config

 

例:

switch(config-ldp)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

MPLS LDP サービスのシャットダウン

MPLS LDP サービスをシャットダウンできます。

前提条件

適切な VDC であることを確認します(または、 switchto vdc コマンドを使用します)。

LDP セッションが確立されていることを確認します。

手順の概要

1. configure terminal

2. mpls ldp configuration

3. shutdown

4. (任意) show mpls ldp neighbor [ ip-address | interface ] [ detail ]

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

mpls ldp configuration

 

例:

switch(config)# mpls ldp configuration
switch(config-ldp)#

LDP コンフィギュレーション モードを開始します。

ステップ 3

shutdown
 

例:

switch(config-ldp)# shutdown

すべての LDP セッションを切断し、フォワーディング プレーンからすべての出ラベルを取り消し、割り当て済みのすべてのローカル ラベルを解放します。

コマンドは、LDP がシャットダウンされたときに、LDP サービスを再起動します。

ステップ 4

show mpls ldp neighbor [ ip-address | interface ] [ detail ]

 

例:

switch(config-ldp)# show mpls ldp neighbor detail

(任意)LDP セッションのステータスを表示します。

MPLS LDP 設定の確認

MPLS LDP の設定を表示するには、次のいずれかの作業を行います。

 

コマンド
目的

show mpls interface detail

インターフェイス上の MPLS LDP の設定ステータスを表示します。

show mpls ldp backoff

設定済みのセッション設定バックオフ パラメータ、およびセッション設定をスロットリングするときに使用される任意の LDP ピアに関する情報を表示します。

show mpls ldp bindings

MPLS LDP Label Information Base(LIB; ラベル情報ベース)を表示します。

show mpls ldp capabilities

MPLS LDP 機能情報を表示します。

show mpls ldp checkpoint

MPLS LDP チェックポイント情報を表示します。

show mpls ldp discovery [detail]

LDP ディスカバリ プロセスのステータスを表示します。

show mpls ldp neighbor [ ip-address | interface ] [ detail ]

LDP セッションのステータスを表示します。

show mpls ldp parameters

現在の LDP パラメータを表示します。

show mpls switching

MPLS ラベル スイッチング データベースを表示します。このコマンドを使用して、LDP データベースおよび転送情報の一貫性を確認できます。

show running-config interface [tunnel | tunnel-te] number

トンネル インターフェイスの実行コンフィギュレーションを表示します。

show running-config mpls ldp

デバイス上の MPLS LDP の設定ステータスを表示します。

これらのコマンド出力のフィールドの詳細については、 Cisco Nexus 7000 Series NX-OS MPLS Command Reference を参照してください。

MPLS LDP の設定例

ここでは、MPLS LDP の設定例について説明します。内容は次のとおりです。

「例:直接接続されている MPLS LDP セッションの接続」

「例:直接接続されていない MPLS LDP セッションの確立」

「例:LDP ルータ ID の指定」

「例:MPLS LDP 明示的ヌル ラベルによる QoS 設定の保持」

例:直接接続されている MPLS LDP セッションの接続

次に、2 台の直接接続されているルータ間での MPLS LDP セッションの設定例を示します。

ルータ A の設定

switch(config)# interface ethernet 2/1

switch(config-if)# ip address 10.1.1.1 255.255.255.0

switch(config-if)# mpls ip
switch(config-if)# exit

ルータ B の設定

switch(config)# interface ethernet 2/1

switch(config-if)# ip address 10.1.1.2 255.255.255.0

switch(config-if)# mpls ip
switch(config-if)# exit
switch(config)# mpls ldp configuration
switch(config-ldp)# discovery hello interval 5

 

次に、インターフェイス Ethernet 2/1 が LDP を使用するように設定されていることを確認する例を示します。

switch# show mpls interface detail
Interface Ethernet2/1:
mpls te lif enabled
ldp enabled
MPLS operational
Label space id 0x10000001
MPLS sub-layer Ethernet2/1-mpls layer(0x26000003)

 

次に、インターフェイスがアップ状態で、LDP ディスカバリ hello メッセージを送信し、連続する hello メッセージが 5 秒間隔で送信されることを確認する例を示します。

switch# show mpls ldp discovery detail
Local LDP Identifier:
10.1.1.2:0
Discovery Sources:
Interfaces:
Ethernet2/1 (ldp): xmit
Enabled: Interface config
Hello interval: 5000 ms; Transport IP addr: 10.1.1.2
Clients: IPv4

 

次に、ルータ間の LDP セッションが正常に確立されたことを確認する例を示します。

switch# show mpls ldp neighbor
Peer LDP Ident: 10.1.1.1:0; Local LDP Ident 10.1.1.2:0
TCP connection: 10.1.1.1.646 - 10.1.1.2.12407
State: Oper; Msgs sent/rcvd: 12/11; Downstream
Up time: 00:00:10
LDP discovery sources:
FastEthernet1/0, Src IP addr: 10.20.10.2
Addresses bound to peer LDP Ident:
10.1.1.2 10.20.20.1 10.20.10.2

例:直接接続されていない MPLS LDP セッションの確立

次に、図 3-1 に示すサンプル ネットワークを使用して、直接接続されていない MPLS LDP セッション用のプラットフォームを設定する例を示します。この例で、ルータ 1、4、5、および 6 は、互いに直接接続されていません。

図 3-1 ターゲット セッションの LDP を設定するサンプル ネットワーク

 

この設定例は、次のことを示しています。

ルータ 1 と 4 およびルータ 1 と 5 の間のターゲット セッションでは LDP を使用する。ルータ 1、4、5 はアクティブである。

ルータ 1 と 6 の間のターゲット セッションで LDP を使用する。ルータ 1 はアクティブ、ルータ 6 はパッシブである。

これらの例では、直接接続されていないセッションのアクティブ エンドが MPLS トラフィック エンジニアリング トンネルなどのトンネル インターフェイスに関連付けられていることを前提としています。LDP ターゲット セッションの設定に関連するコマンドだけが示されています。ターゲット セッションを開始するアプリケーションの設定は示されていません。

ルータ 1 の設定

トンネル インターフェイスの tunnel-te 14、tunnel-te 15、および tunnel-te 16 は、これらのインターフェイスに関連付けられているターゲット LDP セッションを指定します。

interface Loopback0 !Loopback interface for LDP ID.
ip address 10.25.0.11 255.255.255.255
 
interface tunnel-te 14 !Tunnel to Router 4 requiring label distribution
tunnel destination 10.11.0.4 !Tunnel endpoint is Router 4
mpls ip !Enable hop-by-hop forwarding on the interface
 
interface tunnel-te 15 !Tunnel to Router 5 requiring label distribution
tunnel destination 10.11.0.5 !Tunnel endpoint is Router 5
mpls ip !Enable hop-by-hop forwarding on the interface
 
interface tunnel-te 16 !Tunnel to Router 6 requiring label distribution
tunnel destination 10.11.0.6 !Tunnel endpoint is Router 6
mpls ip !Enable hop-by-hop forwarding on the interface

ルータ 4 の設定

トンネル インターフェイス tunnel-te 41 は、ルータ 1 とのターゲット LDP セッションを指定します。

interface Loopback0 !Loopback interface for LDP ID.
ip address 10.25.0.44 255.255.255.255
 
interface tunnel-te 41 !Tunnel to Router 1 requiring label distribution
tunnel destination 10.11.0.1 !Tunnel endpoint is Router 1
mpls ip !Enable hop-by-hop forwarding on the interface

ルータ 5 の設定

トンネル インターフェイス tunnel-te 51 は、ルータ 1 とのターゲット LDP セッションを指定します。

interface Loopback0 !Loopback interface for LDP ID.
ip address 10.25.0.55 255.255.255.255
 
interface tunnel-te 51 !Tunnel to Router 1 requiring label distribution
tunnel destination 10.11.0.1 !Tunnel endpoint is Router 1
mpls ip !Enable hop-by-hop forwarding on the interface

ルータ 6 の設定

デフォルトでは、ルータをターゲット セッションのパッシブ ネイバーにすることはできません。したがって、ルータ 1、ルータ 4、およびルータ 5 はターゲット セッションのアクティブ ネイバーです。 discovery targeted-hello accept コマンドを発行すると、ルータ 6 をルータ 1 とのターゲット セッションのパッシブ ターゲットにすることができます。ルータ 6 をターゲット セッションのアクティブ ネイバーにすることもできますが、この例には、そのような設定は含まれていません。

interface Loopback0 !Loopback interface for LDP ID.
ip address 10.25.0.66 255.255.255.255
 
mpls ldp configuration
discovery targeted-hello accept from LDP_SOURCES
!Respond to requests for targeted hellos
!from sources permitted by prefix list LDP_SOURCES
 
ip prefix-list LDP_SOURCES !Define prefix list for targeted hello sources
permit 10.11.0.1/32 !Accept targeted hello request from Router 1

deny any !Deny requests from other sources

例:LDP ルータ ID の指定

次に、インターフェイス Ethernet 2/2 を LDP ルータ ID として指定する例を示します。

switch# configure terminal
switch(config)# mpls ldp configuration
switch(config-ldp)# router-id loopback 0 force

 

次に、LDP ルータ ID(10.15.15.15)の表示方法を示します。

switch# show mpls ldp discovery
 
Local LDP Identifier:
10.15.15.15:0
Discovery Sources:
Interfaces:
Ethernet2/2 (ldp): xmit

例:MPLS LDP 明示的ヌル ラベルによる QoS 設定の保持

次に、出力 LSR で明示的ヌル ラベルを設定する例を示します。これで、その LSR は隣接するすべての MPLS ルータに明示的ヌル ラベルをアドバタイズします。

switch# configure terminal
switch(config)# mpls ldp configuration
switch(config-ldp)# explicit-null

 

次に、明示的ヌル ラベルを設定し、プレフィクス リストに for キーワードを指定する例を示します。これで、隣接するすべての MPLS ルータ テーブルはプレフィクス リストで指定されたエントリについてのみ明示的ヌル ラベルを交換します。

switch# configure terminal
switch(config)# ip prefix-list 24 permit 10.24.24.24/32
switch(config)# mpls ldp configuration
switch(config-ldp)# explicit-null for 24

 

次に、明示的ヌル ラベルを設定し、プレフィクス リストに to キーワードを指定する例を示します。これで、プレフィクス リストで指定された隣接ルータに対してのみ明示的ヌル ラベルをアドバタイズできます。特定のルータに明示的ヌル ラベルをアドバタイズするには、プレフィクス リストでルータの LDP ID を指定する必要があります。

switch# configure terminal
switch(config)# ip prefix-list 15 permit 10.15.15.15/32
switch(config)# mpls ldp configuration
switch(config-ldp)# explicit-null to 15

 

次に、 for to の両方のキーワードを使用して明示的ヌル ラベルを設定する例を示します。これで、明示的ヌル ラベルでアドバタイズするルータと、これらの明示的ヌル ラベルのアドバタイズ先となる隣接ルータを指定できます。

switch# configure terminal
switch(config)# mpls ldp configuration
switch(config-ldp)# explicit-null for 24 to 15

MPLS LDP の追加情報

MPLS LDP の実装に関連する詳細情報については、次の項を参照してください。

「関連資料」

「RFC」

「MIB」

関連資料

関連項目
参照先

CLI コマンド

Cisco Nexus 7000 Series NX-OS MPLS Command Reference

RFC

RFC
タイトル

RFC 3036

『LDP Specification』

RFC 5036

『LDP Specification』

MIB

MIB
MIB のリンク

MPLS-LDP-STD-MIB

MIB を検索およびダウンロードするには、次の URL にアクセスしてください。

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

MPLS LDP の機能履歴

表 3-2 は、この機能のリリースの履歴です。

 

表 3-2 MPLS LDP の機能履歴

機能名
リリース
機能情報

MPLS LDP

5.2(1)

この機能が導入されました。