Cisco Nexus 7000 シリーズ NX-OS MPLS コンフィギュレーション ガイド
MPLS LDP IGP 同期の設定
MPLS LDP IGP 同期の設定
発行日;2012/05/08 | 英語版ドキュメント(2012/02/15 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

MPLS LDP IGP 同期の設定

MPLS LDP IGP 同期について

MPLS LDP IGP 同期プロセス

ピアとの MPLS LDP IGP 同期

MPLS LDP IGP 同期の遅延タイマー

MPLS LDP IGP 同期と IGP ノンストップ フォワーディングの非互換性

MPLS LDP IGP 同期と LDP グレースフル リスタートとの互換性

MPLS LDP IGP 同期のライセンス要件

MPLS LDP IGP 同期の前提条件

MPLS LDP IGP 同期に関する注意事項と制限事項

MPLS LDP IGP 同期のデフォルト設定

MPLS LDP IGP 同期の設定

OSPF インターフェイスに対する MPLS LDP IGP 同期の設定

IS-IS インターフェイスに対する MPLS LDP IGP 同期の設定

MPLS LDP IGP 同期遅延タイマーの設定

選択された OSPF または IS-IS インターフェイスでの MPLS LDP IGP 同期のディセーブル化

MPLS LDP IGP 同期の確認

MPLS LDP IGP 同期の設定例

MPLS LDP IGP 同期の追加情報

関連資料

RFC

MIB

MPLS LDP IGP 同期の機能履歴

MPLS LDP IGP 同期の設定

この章では、Cisco NX-OS デバイスで Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)Label Distribution Protocol(LDP; ラベル配布プロトコル)の Interior Gateway Protocol(IGP)同期を設定する方法について説明します。

この章では、次の内容について説明します。

「MPLS LDP IGP 同期について」

「MPLS LDP IGP 同期のライセンス要件」

「MPLS LDP IGP 同期の前提条件」

「MPLS LDP IGP 同期に関する注意事項と制限事項」

「MPLS LDP IGP 同期のデフォルト設定」

「MPLS LDP IGP 同期の設定」

「MPLS LDP IGP 同期の確認」

「MPLS LDP IGP 同期の設定例」

「MPLS LDP IGP 同期の追加情報」

「MPLS LDP IGP 同期の機能履歴」

MPLS LDP IGP 同期について

MPLS LDP IGP 同期機能では、IGP パスをスイッチングに使用する前に、LDP が完全に確立されていることが確認されます。

インターフェイスの起動時、LDP 隣接の前に IGP 隣接が起動すると、トラフィックはインターフェイスを通過しますが、LDP ラベルを使用できません。LDP ラベルが使用できるようになるまで、VPN オーバーレイ トラフィックはドロップされます。インターフェイス起動時の VPN トラフィックのドロップを減らすために、IGP と LDP を同期させることができます。

ここでは、次の内容について説明します。

「MPLS LDP IGP 同期プロセス」

「ピアとの MPLS LDP IGP 同期」

「MPLS LDP IGP 同期の遅延タイマー」

「MPLS LDP IGP 同期と IGP ノンストップ フォワーディングの非互換性」

「MPLS LDP IGP 同期と LDP グレースフル リスタートとの互換性」

MPLS LDP IGP 同期プロセス

パケット損失は、IGP アクションと LDP アクションが同期していないために発生することがあります。パケット損失は、次の状況で発生することがあります。

IGP 隣接が確立されると、ルータは、そのリンク上のピア間で LDP ラベル交換が完了する前に、新しい隣接を使用してパケットの転送を開始します。

LDP セッションが終了した場合、ルータは、LDP セッションと完全に同期した代替経路ではなく、LDP ピアに関連付けられているリンクを使用してトラフィックの転送を継続します。

MPLS LDP IGP 同期機能では、次のことが行われます。

LDP と IGP を同期させて、MPLS パケット損失を最小限に抑えることができます。

IGP Open Shortest Path First(OSPF)または Intermediate System-to-System(IS-IS)プロセスと関連付けられている各インターフェイスで LDP と IGP の同期をグローバルにイネーブルにできます。

同期の競合による MPLS パケット損失を防ぎます。

OSPF または IS-IS プロセスに属するすべてのインターフェイスに対して LDP IGP 同期をイネーブルにしたあとで、イネーブルにする必要のない特定のインターフェイスでディセーブルにすることができます。

LDP ピアに接続できる場合、IGP は同期が実現するのを無制限に(デフォルト)待機します。IGP セッションが待機する時間を制限できます。LDP ピアに接続できない場合、IGP は LDP とのセッションを確立するための隣接を設定します。

インターフェイスで IGP 隣接が確立し、LDP IGP 同期が実現していないか、同期が失われている場合、IGP はそのインターフェイスで最大メトリックをアドバタイズします。インターフェイスを介した少なくとも 1 つの LDP セッションが収束すると、IGP はインターフェイスに通常のメトリックをアドバタイズします。

ピアとの MPLS LDP IGP 同期

インターフェイスで MPLS LDP IGP 同期がイネーブルになっている場合、LDP は、ルーティング テーブルでピアの転送アドレスを検索して、インターフェイスによって接続されているピアに接続できるかどうかを判断します。ピアのルーティング エントリ(最長一致またはデフォルト ルーティング エントリを含む)が存在する場合、LDP はインターフェイスに LDP IGP 同期が必要であると見なし、IGP に LDP コンバージェンスを待機するように通知します。

ピアとの LDP IGP 同期では、ピアの転送アドレスに関してルーティング テーブルが正確であることが必要です。ルーティング テーブルでピアの転送アドレスのルートが示されている場合、そのルートはピアの転送アドレスに到達できる必要があります。ただし、ルートがサマリー ルート、デフォルト ルート、または静的に設定されたルートの場合は、ピアに対して適切なルートではない可能性があります。ルーティング テーブルのルートでピアの転送アドレスに到達できることを確認する必要があります。

ルーティング テーブルにピアの転送アドレスの不正確なルートが含まれている場合、LDP はピアとセッションを設定できず、IGP は同期保留時間中 LDP のコンバージェンスを不必要に待機することになります。

MPLS LDP IGP 同期の遅延タイマー

MPLS LDP IGP 同期では、インターフェイス ベースで MPLS LDP と IGP の同期の遅延時間を設定できます。通常、LDP と IGP の同期が設定されている場合は、LDP が収束するとすぐに LDP によって IGP に通知されます。遅延時間を設定すると、この通知が遅延します。

LDP の確立と同期が完了すると、LDP によって遅延タイマーが次のようにチェックされます。

遅延タイマーを設定した場合は、LDP によってタイマーが開始されます。タイマーが期限切れになると、LDP によって同期がまだ有効であることがチェックされて OSPF または IS-IS プロセスに通知されます。

遅延時間を設定しなかった場合、同期がディセーブルになるかダウンしている場合、IGP プロセスからインターフェイスが削除された場合、LDP によってタイマーが停止され、OSPF または IS-IS に即座に通知されます。

タイマーの実行中に新しい遅延時間を設定した場合は、LDP によって新しい遅延時間が保存されますが、実行中のタイマーは再設定されません。

MPLS LDP IGP 同期と IGP ノンストップ フォワーディングの非互換性

IGP Nonstop Forwarding(NFS; ノンストップ フォワーディング)が設定されている場合、MPLS LDP IGP 同期はスタートアップ期間中はサポートされません。IGP がスタートアップ中 NSF を実行している間は、MPLS LDP IGP 同期は IGP NSF と競合します。NSF スタートアップの完了後、MPLS LDP IGP 同期がサポートされます。

MPLS LDP IGP 同期と LDP グレースフル リスタートとの互換性

LDP グレースフル リスタートは、LDP セッションが失われた場合にトラフィックを保護します。グレースフル リスタートがイネーブルになっている LDP セッションをサポートするインターフェイスに障害が発生した場合でも、グレースフル リスタートで保護されている間、インターフェイス上で MPLS LDP IGP 同期が実現されます。MPLS LDP IGP 同期は次の状況で最終的に失われます。

LDP グレースフル リスタートの再接続タイマーが期限切れになる前に LDP が再起動に失敗した場合

LDP セッションが他のインターフェイスを通じて再起動し、LDP グレースフル リスタート回復タイマーが期限切れになったときに保護されたインターフェイス上の LDP セッションが回復できない場合

MPLS LDP IGP 同期のライセンス要件

 

製品
ライセンス要件

Cisco NX-OS

MPLS LDP IGP 同期には MPLS Services ライセンスが必要です。Cisco NX-OS ライセンス方式の詳細と、ライセンスの取得および適用の方法については、『 Cisco NX-OS Licensing Guide 』を参照してください。

MPLS LDP IGP 同期の前提条件

MPLS LDP IGP 同期には次の前提条件があります。

インターフェイスで MPLS LDP をイネーブルにする必要があります。

feature ospf コマンドと feature isis コマンドを使用して、デバイスで OSPF と IS-IS をイネーブルにする必要があります。

MPLS LDP IGP 同期に関する注意事項と制限事項

MPLS LDP IGP 同期設定時の注意事項と制限事項は次のとおりです。

この機能は、OSPF または IS-IS プロセスを実行しているインターフェイスでのみサポートされています。他の IGP はサポートされていません。

この機能は、MPLS トラフィック エンジニアリング トンネル インターフェイスではサポートされていません。

MPLS LDP IGP 同期がインターフェイスに対して設定されている場合、到達不能であることが証明されないかぎり(たとえば、LDP が hello メッセージを受信してインターフェイス上のネイバーを検出し、そのネイバーが到達不能であることがわかった場合)、LDP はそのインターフェイス経由でピアに到達できると見なします。

MPLS LDP IGP 同期のデフォルト設定

表 6-1 に、MPLS LDP IGP 同期パラメータのデフォルト設定を示します。

 

表 6-1 デフォルトの MPLS LDP IGP 同期パラメータ

パラメータ
デフォルト

MPLS LDP IGP 同期

ディセーブル

MPLS LDP IGP 同期遅延タイマー

0 秒

MPLS LDP IGP 同期の設定

ここでは、次の内容について説明します。

「OSPF インターフェイスに対する MPLS LDP IGP 同期の設定」

「IS-IS インターフェイスに対する MPLS LDP IGP 同期の設定」

「MPLS LDP IGP 同期遅延タイマーの設定」

「選択された OSPF または IS-IS インターフェイスでの MPLS LDP IGP 同期のディセーブル化」

OSPF インターフェイスに対する MPLS LDP IGP 同期の設定

OSPF プロセスを実行するすべてのインターフェイスに MPLS LDP IGP 同期を設定できます。

前提条件

適切な VDC であることを確認します(または、 switchto vdc コマンドを使用します)。

OSPF インターフェイスで MPLS LDP がイネーブルになっていることを確認します。

手順の概要

1. configure terminal

2. router ospf process-name

3. mpls ldp sync

4. (任意) show mpls ldp igp sync

5. (任意) copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router ospf process-name

 

例:

switch(config)# router ospf p1
switch(config-router)#

OSPF ルーティング プロセスをイネーブルにして、ルータ コンフィギュレーション モードを開始します。

process-name 引数には、最大 20 文字の英数字を入力できます。

ステップ 3

mpls ldp sync

 

例:

switch(config-router)# mpls ldp sync

すべての OSPF インターフェイスに対して MPLS LDP IGP 同期をイネーブルにします。

ステップ 4

show mpls ldp igp sync

 

例:

switch(config-router)# show mpls ldp igp sync

(任意)すべてのインターフェイス上の MPLS LDP IGP 同期のステータスを表示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config-router)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

IS-IS インターフェイスに対する MPLS LDP IGP 同期の設定

IS-IS プロセスを実行するすべてのインターフェイスに MPLS LDP IGP 同期を設定できます。

前提条件

適切な VDC であることを確認します(または、 switchto vdc コマンドを使用します)。

MPLS LDP が IS-IS インターフェイスでイネーブルになっていることを確認します。

手順の概要

1. configure terminal

2. router isis process-name

3. mpls ldp sync

4. (任意) show mpls ldp igp sync

5. (任意) copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router isis process-name

 

例:

switch(config)# router isis p1
switch(config-router)#

IS-IS ルーティング プロセスをイネーブルにし、ルータ コンフィギュレーション モードを開始します。

process-name 引数には、最大 20 文字の英数字を入力できます。

ステップ 3

mpls ldp sync

 

例:

switch(config-router)# mpls ldp sync

すべての IS-IS インターフェイスに対して MPLS LDP IGP 同期をイネーブルにします。

ステップ 4

show mpls ldp igp sync

 

例:

switch(config-router)# show mpls ldp igp sync

(任意)すべてのインターフェイス上の MPLS LDP IGP 同期のステータスを表示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config-router)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

MPLS LDP IGP 同期遅延タイマーの設定

インターフェイス ベースで MPLS LDP IGP 同期の遅延タイマーを設定できます。通常、LDP と IGP の同期が設定されている場合は、LDP が収束するとすぐに LDP によって IGP に通知されます。遅延タイマーが設定されている場合、この通知は遅延します。

前提条件

適切な VDC であることを確認します(または、 switchto vdc コマンドを使用します)。

インターフェイスで MPLS LDP がイネーブルになっていることを確認します。

手順の概要

1. configure terminal

2. interface ethernet slot/port

3. mpls ldp igp sync delay seconds

4. (任意) show mpls ldp igp sync interface ethernet slot / port

5. (任意) copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface ethernet slot/port

 

例:

switch(config)# interface ethernet 7/1
switch(config-if)#

MPLS LDP IGP 同期遅延タイマーを設定しているインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

mpls ldp igp sync delay seconds

 

例:

switch(config-if)# mpls ldp igp sync delay 30

指定したインターフェイスで MPLS LDP IGP 同期の遅延タイマーを設定します。

seconds 引数の範囲は 5 ~ 60 秒です。

コマンドでは、遅延タイマーを 0 に設定しますが、MPLS LDP IGP 同期はイネーブルのままにします。

ステップ 4

show mpls ldp igp sync interface ethernet slot/port

 

例:

switch(config-if)# show mpls ldp igp sync interface ethernet 7/1

(任意)指定されたインターフェイスで MPLS LDP IGP 同期の遅延時間の設定と実行ステータスを表示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

選択された OSPF または IS-IS インターフェイスでの MPLS LDP IGP 同期のディセーブル化

MPLS LDP IGP 同期機能の設定後に、特定の OSPF または IS-IS インターフェイスに対して LDP IGP 同期をディセーブルにすることができます。

前提条件

適切な VDC であることを確認します(または、 switchto vdc コマンドを使用します)。

インターフェイスで MPLS LDP がイネーブルになっていることを確認します。

手順の概要

1. configure terminal

2. interface ethernet slot/port

3. no mpls ldp igp sync [delay]

4. (任意) show mpls ldp igp sync interface ethernet slot / port

5. (任意) copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface ethernet slot/port

 

例:

switch(config)# interface ethernet 7/1
switch(config-if)#

MPLS LDP IGP 同期をディセーブルにするインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

no mpls ldp igp sync [delay]

 

例:

switch(config-if)# no mpls ldp igp sync

指定されたインターフェイスで MPLS LDP IGP 同期をディセーブルにします。

コマンドでは、遅延タイマーを 0 に設定しますが、MPLS LDP IGP 同期はイネーブルのままにします。

ステップ 4

show mpls ldp igp sync interface ethernet slot/port

 

例:

switch(config-if)# show mpls ldp igp sync interface ethernet 7/1

(任意)指定されたインターフェイス上の MPLS LDP IGP 同期のステータスを表示します。

ステップ 5

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

MPLS LDP IGP 同期の確認

MPLS LDP IGP 同期を表示するには、次の作業のいずれかを行います。

 

コマンド
目的

show ip ospf mpls ldp interface [ethernet slot / port ]

OSPF インターフェイス上の MPLS LDP IGP 同期のステータスを表示します。

show mpls ldp igp sync [interface ethernet slot / port ]

MPLS LDP IGP 同期のステータスを表示します。

これらのコマンド出力のフィールドの詳細については、 Cisco Nexus 7000 Series NX-OS MPLS Command Reference を参照してください。

MPLS LDP IGP 同期の設定例

次に、OSPF インターフェイスに対して MPLS LDP IGP 同期を設定し、結果を確認する例を示します。

switch# configure terminal
switch(config)# router ospf 1
switch(config-router)# mpls ldp sync
switch(config-router)# show mpls ldp igp sync
Ethernet2/1:
LDP configured; LDP-IGP Synchronization enabled.
Sync status: sync not achieved; peer not reachable.
Sync delay time: 0 seconds (0 seconds left)
IGP holddown time: infinite.
IGP enabled: isis-p1[gen:1]
Ethernet2/6:
LDP configured; LDP-IGP Synchronization enabled.
Sync status: sync not achieved; peer reachable.
Sync delay time: 0 seconds (0 seconds left)
IGP holddown time: infinite.
IGP enabled: isis-p1[gen:1]
 

次に、特定のインターフェイスで MPLS LDP IGP 同期の遅延時間を設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 2/1
switch(config-if)# mpls ldp igp sync delay 10
switch(config-if)# show mpls ldp igp sync interface ethernet 2/1
Ethernet2/1:
LDP configured; LDP-IGP Synchronization enabled.
Sync status: sync achieved; peer reachable.
Sync delay time: 10 seconds (0 seconds left)
IGP holddown time: infinite.
IGP enabled: isis-p1[gen:1]
 

次に、MPLS LDP IGP 同期機能を使用してイネーブルにしたあと、特定のインターフェイスで MPLS LDP IGP 同期をディセーブルにする方法を示します。

switch# configure terminal
switch(config)# interface ethernet 2/1
switch(config-if)# no mpls ldp igp sync
switch(config-if)# show mpls ldp igp sync interface ethernet 2/1
Ethernet2/1:
LDP configured; LDP-IGP Synchronization not enabled.

MPLS LDP IGP 同期の追加情報

MPLS LDP IGP 同期の実装に関連する詳細情報については、次の項を参照してください。

「関連資料」

「RFC」

「MIB」

関連資料

関連項目
参照先

CLI コマンド

Cisco Nexus 7000 Series NX-OS MPLS Command Reference

RFC

RFC
タイトル

RFC 3036

『LDP Specification』

RFC 3037

LDP Applicability

RFC 5036

『LDP Specification』

RFC 5443

『LDP IGP Synchronization』

MIB

MIB
MIB のリンク

MPLS-LDP-STD-MIB

MIB を検索およびダウンロードするには、次の URL にアクセスしてください。

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

MPLS LDP IGP 同期の機能履歴

表 6-2 は、この機能のリリースの履歴です。

 

表 6-2 MPLS LDP IGP 同期の機能履歴

機能名
リリース
機能情報

MPLS LDP IGP 同期

5.2(1)

この機能が導入されました。