Cisco Nexus 7000 シリーズ NX-OS MPLS コンフィギュレーション ガイド
MPLS LDP 自動設定の設定
MPLS LDP 自動設定の設定
発行日;2012/05/08 | 英語版ドキュメント(2011/10/28 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

MPLS LDP 自動設定の設定

MPLS LDP 自動設定について

MPLS LDP 自動設定のライセンス要件

MPLS LDP 自動設定の前提条件

MPLS LDP 自動設定に関する注意事項と制限事項

MPLS LDP 自動設定のデフォルト設定

MPLS LDP 自動設定の設定

OSPF インターフェイスに対する MPLS LDP 自動設定の設定

IS-IS インターフェイスに対する MPLS LDP 自動設定の設定

選択した OSPF または IS-IS インターフェイスでの MPLS LDP 自動設定のディセーブル化

MPLS LDP 自動設定の確認

MPLS LDP 自動設定の設定例

例:OSPF インターフェイスに対する MPLS LDP 自動設定の設定

例:IS-IS インターフェイスに対する MPLS LDP 自動設定の設定

MPLS LDP 自動設定の追加情報

関連資料

RFC

MIB

MPLS LDP 自動設定の機能履歴

MPLS LDP 自動設定の設定

この章では、Cisco NX-OS デバイスで Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)Label Distribution Protocol(LDP; ラベル配布プロトコル)の自動設定を設定する方法について説明します。

この章では、次の内容について説明します。

「MPLS LDP 自動設定について」

「MPLS LDP 自動設定のライセンス要件」

「MPLS LDP 自動設定の前提条件」

「MPLS LDP 自動設定に関する注意事項と制限事項」

「MPLS LDP 自動設定のデフォルト設定」

「MPLS LDP 自動設定の設定」

「MPLS LDP 自動設定の確認」

「MPLS LDP 自動設定の設定例」

「MPLS LDP 自動設定の追加情報」

「MPLS LDP 自動設定の機能履歴」

MPLS LDP 自動設定について

MPLS LDP 自動設定機能を使用すると、指定した Interior Gateway Protocol(IGP)インターフェイスに関連付けられている各インターフェイス上で LDP をグローバルに設定できます。

LDP をイネーブルにするには、グローバルに設定するとともに、必要な各インターフェイスで設定する必要があります。多くのインターフェイスで LDP を設定すると時間がかかることがあります。

MPLS LDP 自動設定機能は、Open Shortest Path First(OSPF)および Intermediate System-to-Intermediate System(IS-IS)IGP でサポートされています。自動設定機能を使用すると、各インターフェイスで個別に LDP を設定する必要がないので、LDP 設定を簡単に、迅速に、エラーを発生させることなく行うことができます。必要な場合は、自動設定をイネーブルにしたあとに、選択したインターフェイスで LDP をディセーブルにすることができます。

MPLS LDP 自動設定のライセンス要件

 

製品
ライセンス要件

Cisco NX-OS

MPLS LDP 自動設定には、MPLS Services ライセンスが必要です。Cisco NX-OS ライセンス方式の詳細と、ライセンスの取得および適用の方法については、『 Cisco NX-OS Licensing Guide 』を参照してください。

MPLS LDP 自動設定の前提条件

MPLS LDP 自動設定には次の前提条件があります。

MPLS LDP をイネーブルにする必要があります。

MPLS LDP 自動設定に関する注意事項と制限事項

MPLS LDP 自動設定には、次の注意事項および制限事項があります。

この機能は、OSPF または IS-IS プロセスを実行しているインターフェイスでのみサポートされています。他の IGP はサポートされていません。

LDP をグローバルにディセーブルにすると、自動設定が失敗し、まず LDP をグローバルにイネーブルにする必要があることを説明するコンソール メッセージが生成されます。

MPLS LDP 自動設定が IGP インスタンスに対して設定されている場合、グローバル shutdown コマンドを入力することはできません。LDP をディセーブルにするには、まず、 no mpls ldp igp autoconfig コマンドを入力する必要があります。

この機能は、Traffic Engineering(TE; トラフィック エンジニアリング)トンネル インターフェイスではサポートされていません。

MPLS LDP 自動設定のデフォルト設定

表 4-1 に、MPLS LDP 自動設定パラメータのデフォルト設定を示します。

 

表 4-1 デフォルトの MPLS LDP 自動設定パラメータ

パラメータ
デフォルト

MPLS LDP 自動設定

ディセーブル

MPLS LDP 自動設定の設定

ここでは、次の内容について説明します。

「OSPF インターフェイスに対する MPLS LDP 自動設定の設定」

「IS-IS インターフェイスに対する MPLS LDP 自動設定の設定」

「選択した OSPF または IS-IS インターフェイスでの MPLS LDP 自動設定のディセーブル化」

OSPF インターフェイスに対する MPLS LDP 自動設定の設定

OSPF プロセスを実行するすべてのインターフェイスに MPLS LDP 自動設定を設定できます。その結果、OSPF エリアに属するすべてのインターフェイスが LDP に対してイネーブルになります。

前提条件

適切な VDC であることを確認します(または、 switchto vdc コマンドを使用します)。

OSPF がイネーブルになっていることを確認します。( feature ospf コマンドを使用してイネーブルにできます )。

MPLS LDP がイネーブルになっていることを確認します。

手順の概要

1. configure terminal

2. router ospf process-name

3. mpls ldp autoconfig area area-id

4. (任意)show mpls ldp discovery detail

5. (任意)copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router ospf process-name

 

例:

switch(config)# router ospf p1
switch(config-router)#

OSPF ルーティング プロセスをイネーブルにして、ルータ コンフィギュレーション モードを開始します。

process-name 引数には、最大 20 文字の英数字を入力できます。

ステップ 3

mpls ldp autoconfig area area-id

 

例:

switch(config-router)# mpls ldp autoconfig area 10

すべての OSPF インターフェイスに対して MPLS LDP 自動設定をイネーブルにします。

area-id 引数には、エリア ID を整数(0 ~ 4,294,967,295)または IP アドレスとして指定できます。

ステップ 4

show mpls ldp discovery detail

 

例:

switch(config-router)# show mpls ldp discovery detail

(任意)インターフェイスで LDP をイネーブルにするときに使用された方法を表示します。

LDP が特定のインターフェイスでイネーブルになっていた場合、出力には「Interface config」と表示されます。

LDP が自動設定を使用してイネーブルになっていた場合、出力には「IGP config」と表示されます。

LDP が特定のインターフェイスでイネーブルになり、自動設定でもイネーブルになっていた場合、出力には「Interface config, IGP config」と表示されます。

ステップ 5

copy running-config startup-config

 

例:

switch(config-router)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

IS-IS インターフェイスに対する MPLS LDP 自動設定の設定

IS-IS プロセスを実行するすべてのインターフェイスに MPLS LDP 自動設定を設定できます。その結果、IS-IS エリアに属するすべてのインターフェイスが LDP に対してイネーブルになります。

前提条件

適切な VDC であることを確認します(または、 switchto vdc コマンドを使用します)。

IS-IS がイネーブルになっていることを確認します。( feature isis コマンドを使用してイネーブルにできます )。

MPLS LDP がイネーブルになっていることを確認します。

手順の概要

1. configure terminal

2. router isis process-name

3. mpls ldp autoconfig { level-1 | level-1-2 | level-2 }

4. (任意)show mpls ldp discovery detail

5. (任意)copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router isis process-name

 

例:

switch(config)# router isis p1
switch(config-router)#

IS-IS ルーティング プロセスをイネーブルにし、ルータ コンフィギュレーション モードを開始します。

process-name 引数には、最大 20 文字の英数字を入力できます。

ステップ 3

mpls ldp autoconfig {level-1 | level-1-2 | level-2}

 

例:

switch(config-router)# mpls ldp autoconfig level-1

レベル 1、レベル 2、またはレベル 1 とレベル 2 のすべての IS-IS インターフェイスで MPLS LDP 自動設定をイネーブルにします。

ステップ 4

show mpls ldp discovery detail

 

例:

switch(config-router)# show mpls ldp discovery detail

(任意)インターフェイスで LDP をイネーブルにするときに使用された方法を表示します。

LDP が特定のインターフェイスでイネーブルになっていた場合、出力には「Interface config」と表示されます。

LDP が自動設定を使用してイネーブルになっていた場合、出力には「IGP config」と表示されます。

LDP が特定のインターフェイスでイネーブルになり、自動設定でもイネーブルになっていた場合、出力には「Interface config, IGP config」と表示されます。

ステップ 5

copy running-config startup-config

 

例:

switch(config-router)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

選択した OSPF または IS-IS インターフェイスでの MPLS LDP 自動設定のディセーブル化

MPLS LDP 自動設定機能の設定後に、特定の OSPF または IS-IS インターフェイスに対して LDP をディセーブルにすることができます。

前提条件

適切な VDC であることを確認します(または、 switchto vdc コマンドを使用します)。

MPLS LDP がイネーブルになっていることを確認します。

手順の概要

1. configure terminal

2. interface ethernet slot/port

3. no mpls ldp igp autoconfig

4. (任意)show mpls ldp discovery detail

5. (任意)copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface ethernet slot/port

 

例:

switch(config)# interface ethernet 7/1
switch(config-if)#

LDP をディセーブルにするインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

no mpls ldp igp autoconfig

 

例:

switch(config-if)# no mpls ldp igp autoconfig

指定したインターフェイスに対して LDP をディセーブルにします。

ステップ 4

show mpls ldp discovery detail

 

例:

switch(config-if)# show mpls ldp discovery detail

(任意)インターフェイスで LDP をイネーブルにするときに使用された方法を表示します。LDP がインターフェイスでディセーブルになっていた場合、そのインターフェイスは出力に表示されません。

ステップ 5

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

MPLS LDP 自動設定の確認

MPLS LDP 自動設定を表示するには、次のいずれかの作業を行います。

 

コマンド
目的

show mpls ldp discovery detail

インターフェイスで LDP をイネーブルにするときに使用された方法を表示します。

これらのコマンド出力のフィールドの詳細については、 Cisco Nexus 7000 Series NX-OS MPLS Command Reference を参照してください。

MPLS LDP 自動設定の設定例

ここでは、次の内容について、MPLS LDP 自動設定の設定例を示します。

「例:OSPF インターフェイスに対する MPLS LDP 自動設定の設定」

「例:IS-IS インターフェイスに対する MPLS LDP 自動設定の設定」

例:OSPF インターフェイスに対する MPLS LDP 自動設定の設定

次に、OSPF インターフェイスに対して MPLS LDP 自動設定を設定し、結果を確認する例を示します。

switch# configure terminal
switch(config)# interface ethernet 2/1
switch(config-if)# ip address 10.0.0.13 255.0.0.0
switch(config-if)# exit
switch(config)# router ospf 1
switch(config-router)# area 3 range 10.0.0.13 0.0.255.255
switch(config-router)# mpls ldp autoconfig area 3
switch(config-router)# show mpls ldp discovery detail
Local LDP Identifier:
10.0.0.13:0
Discovery Sources:
Interfaces:
Ethernet2/1 (ldp): xmit/recv
Enabled: IGP config;
Hello interval: 5000 ms; Transport IP addr: 10.0.0.13
LDP Id: 10.0.0.21:0
Src IP addr: 168.5.5.21; Transport IP addr: 10.0.0.21
Hold time: 15 sec; Proposed local/peer: 15/15 sec
Reachable via 10.0.0.21/32
Password: not required, none, in use
Clients: IPv4
Ethernet2/6 (ldp): xmit/recv
Enabled: Interface config, IGP config;
Hello interval: 5000 ms; Transport IP addr: 10.0.0.13
LDP Id: 10.0.0.22:0
Src IP addr: 168.6.6.22; Transport IP addr: 10.0.0.22
Hold time: 15 sec; Proposed local/peer: 15/15 sec
Reachable via 10.0.0.22/32
Password: not required, neighbor, in use
Clients: IPv4
 

次に、MPLS LDP 自動設定機能を使用して、LDP をイネーブルにしたあとで、特定のインターフェイスで LDP をディセーブルにする例を示します。

switch# configure terminal
switch(config)# interface ethernet 2/1
switch(config-if)# no mpls ldp igp autoconfig
switch(config-if)# show mpls ldp discovery detail
Local LDP Identifier:
10.0.0.13:0
Discovery Sources:
Interfaces:
Ethernet2/6 (ldp): xmit/recv
Enabled: Interface config, IGP config;
Hello interval: 5000 ms; Transport IP addr: 10.0.0.13
LDP Id: 10.0.0.22:0
Src IP addr: 168.6.6.22; Transport IP addr: 10.0.0.22
Hold time: 15 sec; Proposed local/peer: 15/15 sec
Reachable via 10.0.0.22/32
Password: not required, neighbor, in use
Clients: IPv4

例:IS-IS インターフェイスに対する MPLS LDP 自動設定の設定

次に、IS-IS インターフェイスに対して MPLS LDP 自動設定を設定し、結果を確認する例を示します。

switch# configure terminal
switch(config)# interface ethernet 3/2
switch(config-if)# ip address 10.0.0.30 255.0.0.1
switch(config-if)# ip router isis p1
switch(config-if)# exit
switch(config)# router isis p1
switch(config-router)# mpls ldp autoconfig level-1-2
switch(config-router)# show mpls ldp discovery detail
Local LDP Identifier:
10.0.0.30:0
Discovery Sources:
Interfaces:
Ethernet3/2 (ldp): xmit/recv
Enabled: IGP config;
Hello interval: 5000 ms; Transport IP addr: 10.0.0.30
LDP Id: 10.0.0.31:0
Src IP addr: 60.0.0.2; Transport IP addr: 10.0.0.31
Hold time: 15 sec; Proposed local/peer: 15/15 sec
Reachable via 10.0.0.31/32
Password: not required, none, in use
Clients: IPv4

MPLS LDP 自動設定の追加情報

MPLS LDP 自動設定の実装に関連する詳細情報については、次の項を参照してください。

「関連資料」

「RFC」

「MIB」

関連資料

関連項目
参照先

CLI コマンド

Cisco Nexus 7000 Series NX-OS MPLS Command Reference

RFC

RFC
タイトル

RFC 3036

『LDP Specification』

RFC 3037

LDP Applicability

RFC 5036

『LDP Specification』

MIB

MIB
MIB のリンク

MPLS-LDP-STD-MIB

MIB を検索およびダウンロードするには、次の URL にアクセスしてください。

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

MPLS LDP 自動設定の機能履歴

表 4-2 は、この機能のリリースの履歴です。

 

表 4-2 MPLS LDP 自動設定の機能履歴

機能名
リリース
機能情報

MPLS LDP 自動設定

5.2(1)

この機能が導入されました。