Cisco Nexus 7000 シリーズ NX-OS CLI 管理ベスト プラクティス ガイド
EPLD ソフトウェアのアップグレードまたは ダウングレード
EPLD ソフトウェアのアップグレードまたはダウングレード
発行日;2012/02/02 | 英語版ドキュメント(2011/08/18 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 898KB) | フィードバック

目次

EPLD ソフトウェアのアップグレードまたはダウングレード

EPLD アップグレード/ダウングレードの確認

EPLD アップグレードの手順

EPLD ソフトウェアのアップグレードまたはダウングレード

この章では、Electronic Programmable Logic Device(EPLD)をアップグレードまたはダウングレードする推奨手順について説明します。EPLD は、ハードウェアを交換することなくアップグレードできる I/O モジュールにある、ASIC などのハードウェア コンポーネントです。EPLD のアップグレードは、通常は不要ですが、新しいシャーシのインストールまたはシャーシの再導入など、一部の場合には、最新の EPLD バージョンにアップグレードし、すべてのアップグレード可能なハードウェア コンポーネントに、最新の機能強化や重大な修正が含まれているようにすることを推奨します。

この章で説明する内容は、次のとおりです。

EPLD アップグレード/ダウングレードの確認

EPLD アップグレードの手順

EPLD アップグレード/ダウングレードの確認

導入:Cisco NX-OS Release 4.2(6)

EPLD のアップグレードを開始する前に、シャーシで検証チェックを実行し、必要な EPLD のアップグレード、および、各アップグレードの影響について、理解する必要があります。これは、アップグレードによって、不要にネットワークが停止される可能性があるような影響が、実稼動トラフィックに及ぼされるかどうかを判断する場合の準備に、役に立ちます。

n7000# show install all impact epld bootflash:n7000-s1-epld.5.1.1.img
 
Compatibility check:
Module Type Upgradable Impact Reason
------ ---- ---------- ---------- ------
1 LC Yes disruptive Module Upgradable
2 LC Yes disruptive Module Upgradable
4 LC No none Module is not Online
5 SUP Yes disruptive Module Upgradable
7 LC Yes disruptive Module Upgradable
8 LC Yes disruptive Module Upgradable
9 LC Yes disruptive Module Upgradable
10 LC Yes disruptive Module Upgradable
1 Xbar Yes disruptive Module Upgradable
2 Xbar Yes disruptive Module Upgradable
3 Xbar Yes disruptive Module Upgradable
1 FAN Yes disruptive Module Upgradable
2 FAN Yes disruptive Module Upgradable
3 FAN Yes disruptive Module Upgradable
4 FAN Yes disruptive Module Upgradable
 
Retrieving EPLD versions... Please wait.
 
Images will be upgraded according to following table:
 
Module Type EPLD Running-Version New-Version Upg-Required
------ ---- ------------- --------------- ----------- ------------
1 LC Power Manager 4.008 4.008 No
1 LC IO 1.015 1.016 Yes
1 LC Forwarding Engine 1.006 1.006 No
1 LC FE Bridge(1) 186.005 186.006 Yes
1 LC FE Bridge(2) 186.005 186.006 Yes
1 LC Linksec Engine(1) 2.006 2.006 No
1 LC Linksec Engine(2) 2.006 2.006 No
1 LC Linksec Engine(3) 2.006 2.006 No
1 LC Linksec Engine(4) 2.006 2.006 No
1 LC Linksec Engine(5) 2.006 2.006 No
1 LC Linksec Engine(6) 2.006 2.006 No
1 LC Linksec Engine(7) 2.006 2.006 No
 

EPLD アップグレードの手順

導入:Cisco NX-OS Release 4.0(1)

この項は、参照の目的で含まれており、必須ではない場合がありますが、読むことを推奨します。最新の EPLD イメージにアップグレードしなくても、Cisco NX-OS ソフトウェアをアップグレードできます。cisco.com にある EPLD のリリース ノートを確認し、新しい機能または重大な修正に基づいて、その EPLD をアップグレードする必要があるかどうかを判断する必要があります。新規インストールを実行する場合は、EPLD を最新バージョンにアップグレードし、EPLD のアップグレードの将来的な必要性を抑制すると効率的です。

EPLD は、install コマンドの使用時に、コンポーネントごとにアップグレードされます。アップグレードできるコンポーネントは、一度に 1 つだけです。1 つのコンポーネントをアップグレードすると、ネットワークに対する不要な影響を回避するため、より細かく制御できます。ELPD のアップグレードには、I/O モジュールごとに 30 分間かかります。ダウングレードは、通常は必要ではありませんが、コンポーネントのダウングレードにも、同じ手順を使用できます。

最善の結果を得るために、次の推奨事項に従ってください。

実稼動トラフィックを渡さない I/O モジュールで、EPLD のみをアップグレードします(アップグレードの開始前に、トラフィックをリダイレクトします)。

時間を節約するために、アップグレードしようとしている I/O モジュールの電源がオフになっていないことを確認してください。モジュールの電源がオフの場合、モジュールの電源はオンになり、モジュールにあるすべてのアップグレード可能なコンポーネントは、アップデートの必要性に関係なく、アップデートされます。この場合、I/O モジュールのアップグレードに、より長い時間を要します。

シャーシ全体で EPLD のアップグレードを開始するには、install all epld コマンドを使用します。この手順は、非実稼動シャーシでのみ使用する必要があります。実稼動シャーシでは、「実稼動」トラフィックは渡されません。

コンポーネントのアップグレード プロセスは中断しないでください。

 
n7000# install module 1 epld bootflash:n7000-s1-epld.5.1.1.img
 
Retrieving EPLD versions... Please wait.
 
Images will be upgraded according to following table:
Module Type EPLD Running-Version New-Version Upg-Required
------ ---- ------------- --------------- ----------- ------------
1 LC Power Manager 4.008 4.008 No
1 LC IO 1.015 1.016 Yes
1 LC Forwarding Engine 1.006 1.006 No
1 LC FE Bridge(1) 186.005 186.006 Yes
1 LC FE Bridge(2) 186.005 186.006 Yes
1 LC Linksec Engine(1) 2.006 2.006 No
1 LC Linksec Engine(2) 2.006 2.006 No
1 LC Linksec Engine(3) 2.006 2.006 No
1 LC Linksec Engine(4) 2.006 2.006 No
1 LC Linksec Engine(5) 2.006 2.006 No
1 LC Linksec Engine(6) 2.006 2.006 No
1 LC Linksec Engine(7) 2.006 2.006 No
1 LC Linksec Engine(8) 2.006 2.006 No
 
Module 1 will be powered down.
Do you want to continue? (yes/no) [n]: