Cisco Nexus 6000 シリーズ NX-OS インターフェイス コンフィギュレーション ガイド リリース 6.x
双方向フォワーディング検出の設定
双方向フォワーディング検出の設定
発行日;2014/01/07   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

双方向フォワーディング検出の設定

この章の内容は、次のとおりです。

BFD に関する情報

BFD は、メディア タイプ、カプセル化、トポロジ、およびルーティング プロトコルの転送パス障害を高速で検出するように設計された検出プロトコルです。 BFD を使用することで、さまざまなプロトコルの Hello メカニズムにより、変動速度ではなく一定速度で転送パス障害を検出できます。 BFD はプロファイリングおよびプランニングを簡単にし、再コンバージェンス時間の一貫性を保ち、予測可能にします。

BFD では、レイヤ 3 Hello メッセージの隣接検出を単一プロセスにオフロードすることによってすべてのルーティングおよびコントロール プレーンの CPU 使用率を低くします。 BFD プロセスはすべてのアプリケーションに対して均等に実行され、1 秒未満の間隔で障害を検出します。

非同期モード

Cisco NX-OS は、BFD 非同期モードをサポートします。BFD 非同期モードでは、2 個の隣接するデバイス間で BFD 制御パケットが送信され、デバイス間の BFD ネイバー セッションがアクティベートされ、維持されます。 両方のデバイス(または BFD ネイバー)で BFD を設定できます。 インターフェイスおよび適切なプロトコルで一度 BFD がイネーブルになると、Cisco NX-OS は BFD セッションを作成し、BFD セッション パラメータをネゴシエートし、BFD 制御パケットをネゴシエートされた間隔で各 BFD ネイバーに送信し始めます。 BFD セッション パラメータは、次のとおりです。

  • 目的の最小送信間隔:このデバイスが BFD Hello メッセージを送信する間隔。
  • 必要最小受信間隔:このデバイスが別の BFD デバイスからの BFD Hello メッセージを受け付ける最小間隔。
  • 検出乗数:転送パスの障害を検出するまでに喪失した、別の BFD デバイスからの BFD Hello メッセージの数。

次の図は、BFD セッションがどのように確立されているかを示します。 この図は、OSPF と BFD を実行する 2 台のルータがある単純なネットワークを示します。 OSPF がネイバーを検出すると(1)、OSPF 隣接ルータで BFD ネイバー セッションを開始する要求が、ローカル BFD プロセスに送信されます(2)。 OSPF 隣接ルータとの BFD ネイバー セッションが確立されました(3)。

図 1. BFD ネイバー関係の確立



障害検出

一度 BFD セッションが確立され、タイマー ネゴシエーションが終了すると、BFD ネイバーは、より速い速度の場合を除き IGP Hello プロトコルと同じ動作をする BFD 制御パケットを送信し、活性度を検出します。 BFD は障害を検出しますが、プロトコルが障害の発生したピアをバイパスするための処置を行う必要があります。

BFD は転送パスに障害を検出したとき、障害検出通知を BFD 対応プロトコルに送信します。 ローカル デバイスは、プロトコル再計算プロセスを開始してネットワーク全体の収束時間を削減できます。

次の図は、ネットワークで障害が発生した場合を示します(1)。 OSPF 隣接ルータでの BFD ネイバー セッションが停止されます(2)。 BFD はローカル OSPF プロセスに BFD ネイバーに接続できなくなったことを通知します(3)。 ローカル OSPF プロセスは OSPF ネイバー関係を解除します(4)。 代替パスが使用可能な場合、ルータはただちにそのパスでコンバージェンスを開始します。


(注)  


BFD 障害検出は 1 秒未満で行われます。これは OSPF Hello メッセージが同じ障害を検出するより速い必要があります。


図 2. OSPF ネイバー関係の解除



BFD エコー機能

BFD エコー機能は、転送エンジンからリモート BFD ネイバーにエコー パケットを送信します。 BFD ネイバーは検出を実行するために同じパスに沿ってエコー パケットを返送します。BFD ネイバーは、エコー パケットの実際の転送に参加しません。 エコー機能および転送エンジンが検出の処理を行います。 BFD はエコー機能がイネーブルになっている場合に非同期セッションの速度を低下させ、2 台の BFD ネイバー間で送信される BFD 制御パケット数を減らすために、slow timer を使用できます。 また、転送エンジンは、リモート システムを含めないでリモート(ネイバー)システムの転送パスをテストするので、パケット間遅延の変動が少なくなり、障害検出時間が短縮されます。

BFD ネイバーの両方がエコー機能を実行している場合、エコー機能には非対称性がありません。

(注)  


ユニキャスト リバース パス転送チェック(uRPF)はデフォルトではディセーブルです。 これを BFD のあるインターフェイス機能でイネーブルにする必要がある場合は、BFD エコー機能がディセーブルになっている必要があります。


セキュリティ

Cisco NX-OS は BFD パケットを隣接する BFD ピアから受信したことを確認するためにパケットの存続可能時間(TTL)値を使用します。 すべての非同期およびエコー要求パケットの場合、BFD ネイバーは TTL 値を 255 に設定し、ローカル BFD プロセスは着信パケットを処理する前に TTL 値を 255 として確認します。 エコー応答パケットの場合、BFD は TTL 値を 254 に設定します。

BFD パケットの SHA-1 認証を設定できます。

仮想化のサポート

BFD は、仮想ルーティングおよび転送(VRF)インスタンスをサポートしています。

BFD のライセンス要件

次の表に、この機能のライセンス要件を示します。

製品

ライセンス要件

Cisco NX-OS

BFD には、LAN Base Services ライセンスが必要です。 Cisco NX-OS ライセンス方式の詳細と、ライセンスの取得および適用の方法については、『Cisco NX-OS Licensing Guide』を参照してください。

前提条件

BFD には、次の前提条件があります。

  • BFD 機能をイネーブルにする必要があります(「BFD 機能のイネーブル化」を参照)。
  • BFD をイネーブルにする任意のクライアント プロトコルでは、そのクライアント プロトコルの BFD をイネーブルにします(「ルーティング プロトコルに対する BFD サポートの設定」を参照)。
  • Cisco Nexus 5548 および Cisco Nexus 5596 プラットフォームの BFD レイヤ 3 インターフェイスでインターネット制御メッセージ プロトコル(ICMP)v4 および v6 リダイレク トメッセージをディセーブルにします。
  • Cisco Nexus 60XX プラットフォームでインターネット制御メッセージ プロトコル(ICMP)v4 リダイレク トメッセージだけをディセーブルにします。
  • デフォルト VRF の同一 IP の送信元および宛先アドレスの検証チェックをディセーブルにします。
  • 設定作業とともに一覧表示されているその他の詳細な前提条件を参照してください。

注意事項と制約事項

BFD では、Cisco Nexus 6000 シリーズ スイッチについて次の注意事項と制約事項があります。

  • BFD は BFD バージョン 1 をサポートします。
  • BFD は IPv4 をサポートします。
  • BFD は、シングルホップ BFD をサポートします。
  • BFD は、バウンダリ ゲートウェイ プロトコル(BGP)をサポートしまし。
  • ボーダー ゲートウェイ プロトコル(BGP)の BFD は、シングルホップ External BGP(EBGP)および Internal BGP(iBGP)ピアをサポートしています。
  • BFD は、Enhanced Interior Gateway Routing Protocol(EIGRP)をサポートします。
  • BFD は、Open Shortest Path First(OSPF)ルーティング プロトコルをサポートします。
  • BFD は、キー付き SHA-1 認証をサポートします。
  • BFD は、物理インターフェイス、ポート チャネル、サブインターフェイス、および VLAN インターフェイスのレイヤ 3 インターフェイスをサポートします。
  • BFD はレイヤ 3 隣接情報に応じて、レイヤ 2 のトポロジ変更を含むトポロジ変更を検出します。 レイヤ 3 隣接情報が使用できない場合、VLAN インターフェイス(SVI)の BFD セッションはレイヤ 2 トポロジのコンバージェンス後に稼働しない可能性があります。
  • ポート チャネル設定の制限事項
    • BFD で使用されるレイヤ 3 ポート チャネルでは、ポート チャネルの LACP をイネーブルにする必要があります。
    • SVI のセッションで使用されるレイヤ 2 ポート チャネルでは、ポート チャネルの LACP をイネーブルにする必要があります。
  • BFD は、仮想ポート チャネル(vPC)、vPC ピア リンク、および FabricPath リンク全体に形成されている SVI インターフェイス上でサポートされます。
  • SVI の制限事項
    • ASIC リセットにより他のポートのトラフィックが中断されます。 このイベントは、その他のポートの SVI セッションがフラップする原因になることがあります。
    • トポロジを変更すると(たとえば、VLAN へのリンクを追加または削除するとき、またはレイヤ 2 ポート チャネルからのメンバを削除するとき)、SVI セッションが影響を受ける場合があります。 SVI セッションはダウンした後、トポロジ ディスカバリの終了後に起動する場合があります。

ヒント


SVI のセッションがフラップしないようにし、トポロジを変更する必要がある場合は、変更を加える前に BFD 機能をディセーブルにして、変更後、BFD を再度イネーブルにできます。 また、大きな値(たとえば、5 秒)になるように BFD タイマーを設定し、トポロジ変更の完了後に高速なタイマーに戻すこともできます。


  • 配信されたレイヤ 3 ポート チャネルで BFD エコー機能を設定するとき、BFD セッションがそのモジュールでホストしていたメンバー モジュール フラップを再ロードすると、それは結果としてパケット損失になります。 レイヤ 2 スイッチを間に入れずに BFD ピアを直接接続する場合、代替策として BFD per-link を使用できます。

(注)  


BFD per-link モードとサブインターフェイス最適化をレイヤ 3 ポート チャネルで同時に使用することはサポートされていません。


BFD のデフォルト設定

次の表に、BFD パラメータのデフォルト設定を示します。

パラメータ デフォルト
BFD 機能 ディセーブル
必要最小受信間隔 250 ミリ秒
目的の最小送信間隔 250 ミリ秒
検出乗数 3
エコー機能 イネーブル
モード 非同期
ポート チャネル

論理モード(送信元/宛先ペアのアドレスごとに 1 セッション)。

slow timer 2000 ミリ秒
サブインターフェイスの最適化 ディセーブル

BFD の設定

BFD 設定階層

グローバル レベル、およびインターフェイスまたはサブインターフェイス レベルで BFD を設定できます(物理インターフェイスとポート チャネルの場合)。 インターフェイスまたはサブインターフェイスの設定は、グローバル コンフィギュレーションよりも優先されます。 サポートされているインターフェイス上で、サブインターフェイス レベルの設定は、ポート チャネル インターフェイスでサブインターフェイスの最適化がイネーブルになっているか per-link コンフィギュレーションがイネーブルになっていない限りインターフェイスまたはポート チャネル設定よりも優先されます。 詳細については、「サブインターフェイスの BFD の最適化」を参照してください。


(注)  


BFD per-link モードとサブインターフェイス最適化をレイヤ 3 ポート チャネルで同時に使用することはサポートされていません。


ポート チャネルのメンバである物理ポートについては、メンバ ポートはマスター ポート チャネルの BFD 設定を継承します。 メンバ ポート サブインターフェイスは、サブインターフェイスの最適化がイネーブルになっていない限りマスター ポート チャネルの BFD 設定より優先することができます。

BFD 設定のタスク フロー

BFD の設定には、次の作業を行います。

手順
    ステップ 1   BFD 機能をイネーブルにします。
    ステップ 2   インターフェイス上に、グローバルな BFD パラメータを設定するかまたは BFD を設定します。
    ステップ 3   ルーティング プロトコルをサポートする BFD を設定します。

    BFD 機能のイネーブル化について

    デバイス VRF 内のインターフェイスおよびプロトコルで BFD を設定する前に、BFD 機能をイネーブルにする必要があります。

    BFD 機能のイネーブル化

    はじめる前に

    プロトコル グローバル レベルで BFD を変更するとき(たとえば、OSPF または BGP に対して)に正しい VRF を使用しているか確認する必要があります。

    手順
       コマンドまたはアクション目的
      ステップ 1switch# configure terminal 

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 2switch(config)# feature bfd 

      BFD 機能をイネーブルにします。

       
      ステップ 3switch(config)# show feature | include bfd  (任意)

      イネーブルおよびディセーブルにされた機能を表示します。

       
      ステップ 4switch(config)# copy running-config startup-config  (任意)

      この設定変更を保存します。

       

      次に、BFD をイネーブルにする例を示します。

      switch# configure terminal
      switch(config)# feature bfd
      switch(config)# show feature | include bfd
      switch(config)# copy running-config startup-config

      グローバル BFD パラメータの設定について

      デバイスのすべての BFD セッションの BFD セッション パラメータを設定できます。 BFD セッション パラメータは、スリーウェイ ハンドシェイクの BFD ピア間でネゴシエートされます。

      インターフェイスのグローバルなセッション パラメータを無効にするには、「インターフェイスでの BFD の設定」を参照してください。

      グローバルな BFD パラメータの設定

      はじめる前に

      正しい VRF を使用していることを確認します。

      BFD 機能をイネーブルにします。 「BFD 機能のイネーブル化」を参照してください。

      手順
         コマンドまたはアクション目的
        ステップ 1switch# configure terminal 

        グローバル コンフィギュレーション モードを開始します。

         
        ステップ 2switch(config)# bfd interval mintx min_rx msec multiplier value  

        デバイスのすべての BFD セッションの BFD セッション パラメータを設定します。 インターフェイスで BFD セッション パラメータを設定することにより、これらの値を無効にすることができます。 mintx および min_rx msec の範囲は 250 ~ 999 ミリ秒で、デフォルトは 250 です。 乗数の範囲は 3 ~ 50 です。 乗数のデフォルトは 3 です。

         
        ステップ 3switch(config)# bfd slow-timer [interval]  

        エコー機能で使用される slow timer を設定します。 この値はエコー機能がイネーブルの場合、BFD が新しいセッションを開始する速度および非同期セッションが BFD 制御パケットに使用する速度を決定します。 slow-timer 値は新しい制御パケット間隔として使用されますが、エコー パケットは設定された BFD 間隔を使用します。 エコー パケットはリンク障害検出に使用されますが、低速の制御パケットは BFD セッションを維持します。 指定できる範囲は 1000 ~ 30000 ミリ秒です。 デフォルト値は 2000 です。

         
        ステップ 4switch(config)# bfd echo-interface loopback interface number 

        双方向フォワーディング検出(BFD)エコー フレームに使用するインターフェイスを設定します。 このコマンドはエコー パケットの送信元アドレスを指定したループバック インターフェイスに設定したアドレスに変更します。 指定できるインターフェイス番号の範囲は 0 ~ 1023 です。

         
        ステップ 5switch(config)# show running-config bfd  (任意)

        BFD の実行コンフィギュレーションを表示します。

         
        ステップ 6switch(config)# copy running-config startup-config  (任意)

        この設定変更を保存します。

         

        次に、グローバル BFD パラメータを設定する例を示します。

        switch# configure terminal
        switch(config)# bfd interval 250 min_rx 250 multiplier 3
        switch(config)# bfd slow-timer 2000
        switch(config)# bfd echo-interface loopback 1 3
        switch(config-if)# show running-config bfd
        switch(config-if)# copy running-config startup-config
        

        インターフェイスでの BFD の設定について

        インターフェイスのすべての BFD セッションの BFD セッション パラメータを設定できます。 BFD セッション パラメータは、スリーウェイ ハンドシェイクの BFD ピア間でネゴシエートされます。

        この設定は、設定されたインターフェイスのグローバル セッション パラメータより優先されます。

        インターフェイスでの BFD の設定

        はじめる前に

        正しい VRF を使用していることを確認します。

        BFD 機能をイネーブルにします。 「BFD 機能のイネーブル化」を参照してください。

        手順
           コマンドまたはアクション目的
          ステップ 1switch# configure terminal 

          グローバル コンフィギュレーション モードを開始します。

           
          ステップ 2switch(config)# interface int-if 

          インターフェイス コンフィギュレーション モードを開始します。 ? キーワードを使用して、 サポートされているインターフェイスを表示します。

           
          ステップ 3switch(config-if)# bfd interval mintx min_rx msec multiplier value  

          インターフェイスのすべての BFD セッションの BFD セッション パラメータを設定します。 これはグローバルな BFD セッション パラメータより優先されます。 mintx および msec の範囲は 250 ~ 999 ミリ秒で、デフォルトは 250 です。 乗数の範囲は 3 ~ 50 です。 乗数のデフォルトは 3 です。

           
          ステップ 4switch(config-if)# bfd authentication keyed-sha1 keyid id key ascii_key  (任意)

          インターフェイスですべての BFD セッションの SHA-1 認証を設定します。 ascii_key 文字列は BFD ピア間で共有する秘密キーです。 id 値は、0 ~ 255 の数字で、この特定の ascii_key に割り当てられます。 BFD パケットは、複数のアクティブ キーでの使用が許可されている id でキーを指定します。 インターフェイスの SHA-1 認証をディセーブルにするには、コマンドの no 形式を使用します。

           
          ステップ 5switch(config-if)# show running-config bfd  (任意)

          BFD の実行コンフィギュレーションを表示します。

           
          ステップ 6switch(config-if)# copy running-config startup-config  (任意)

          この設定変更を保存します。

           

          次に、インターフェイスで BFD を設定する例を示します。

          switch# configure terminal
          switch(config)# interface ethernet 2/1
          switch(config-if)# bfd interval 250 min_rx 250 multiplier 3
          switch(config-if)# bfd authentication keyed-sha1 keyid 1 ascii_key cisco123
          switch(config-if)# show running-config bfd
          switch(config-if)# copy running-config startup-config

          ポート チャネルの BFD の設定について

          ポート チャネルのすべての BFD セッションの BFD セッション パラメータを設定できます。 レイヤ 3 ポート チャネルで per-link モードが使用されている場合、BFD により、ポート チャネルの各リンクのセッションが作成され、集約結果がクライアント プロトコルへ提供されます。 たとえば、ポート チャネルの 1 つのリンクの BFD セッションが稼働している場合、OSPF などのクライアント プロトコルにポート チャネルが稼働していることが通知されます。 BFD セッション パラメータは、スリーウェイ ハンドシェイクの BFD ピア間でネゴシエートされます。

          この設定は、設定されたポート チャネルのグローバル セッション パラメータより優先されます。 ポート チャネルのメンバ ポートはメンバ ポートのサブインターフェイス レベルで BFD パラメータを設定しない限り、ポート チャネルの BFD セッション パラメータを継承します。 その場合、サブインターフェイス最適化がイネーブルにされていなければ、メンバ ポート サブインターフェイスはサブインターフェイス BFD コンフィギュレーションを使用します。 詳細については、「サブインターフェイスの BFD の最適化」を参照してください。

          ポート チャネルの BFD の設定

          はじめる前に

          正しい VRF を使用していることを確認します。

          BFD をイネーブルにする前に、ポート チャネルの Link Aggregation Control Protocol(LACP)がイネーブルにされていることを確認します。

          BFD 機能をイネーブルにします。 「BFD 機能のイネーブル化」を参照してください。

          手順
             コマンドまたはアクション目的
            ステップ 1switch# configure terminal 

            グローバル コンフィギュレーション モードを開始します。

             
            ステップ 2switch(config)# interface port-channel number 

            ポート チャネル コンフィギュレーション モードを開始します。 ? キーワードを使用してサポートされている番号の範囲を表示します。

             
            ステップ 3switch(config-if)# bfd per-link 

            ポート チャネルに各リンクの BFD セッションを設定します。

             
            ステップ 4switch(config-if)# bfd intervalmintx min_rx msec multiplier value   (任意)

            ポート チャネルのすべての BFD セッションの BFD セッション パラメータを設定します。 これはグローバルな BFD セッション パラメータより優先されます。 mintx および min_rx msec の範囲は 250 ~ 999 ミリ秒で、デフォルトは 250 です。 乗数の範囲は 1 ~ 50 です。 乗数のデフォルトは 3 です。

             
            ステップ 5switch(config-if)# bfd authentication keyed-sha1 keyid idkey ascii_key   (任意)

            インターフェイスですべての BFD セッションの SHA-1 認証を設定します。 ascii_key 文字列は BFD ピア間で共有する秘密キーです。 id 値は、0 ~ 255 の数字で、この特定の ascii_key に割り当てられます。 BFD パケットは、複数のアクティブ キーでの使用が許可されている id でキーを指定します。 インターフェイスの SHA-1 認証をディセーブルにするには、コマンドの no 形式を使用します。

             
            ステップ 6switch(config-if)# show running-config bfd  (任意)

            BFD の実行コンフィギュレーションを表示します。

             
            ステップ 7switch(config-if)# copy running-config startup-config   (任意)

            この設定変更を保存します。

             

            次に、ポート チャネルに BFD を設定する例を示します。

            switch# configure terminal
            switch(config)# interface port-channel 2
            switch(config-if)# bfd interval 250 min_rx 250 multiplier 3
            switch(config-if)# bfd authentication keyed-sha1 keyid 1 ascii_key cisco123
            switch(config-if)# show running-config bfd
            switch(config-if)# copy running-config startup-config

            BFD エコー機能の設定について

            BFD モニタ対象リンクの一端または両端で BFD エコー機能を設定できます。 エコー機能は設定された slow timer に基づいて必要最小受信間隔を遅くします。 RequiredMinEchoRx BFD セッション パラメータは、エコー機能がディセーブルの場合、ゼロに設定されます。 slow timer は、エコー機能がイネーブルの場合、必要最小受信間隔になります。

            BFD エコー機能の設定

            はじめる前に

            正しい VRF を使用していることを確認します。

            BFD 機能をイネーブルにします。 「BFD 機能のイネーブル化」を参照してください。

            BFD セッション パラメータを設定します。 「グローバルな BFD パラメータの設定」の項または「インターフェイスでの BFD の設定」の項を参照してください。

            インターネット制御メッセージ プロトコル(ICMP)のリダイレクト メッセージが BFD 対応インターフェイスでディセーブルであることを確認します。 インターフェイスで no ip redirects コマンドまたは no ipv6 redirects コマンドを使用します。

            同一 IP の送信元および宛先アドレスの検証チェックがディセーブルであることを確認してください。

            手順
               コマンドまたはアクション目的
              ステップ 1switch# configure terminal 

              グローバル コンフィギュレーション モードを開始します。

               
              ステップ 2switch(config)# bfd slow-timer echo-interval  

              エコー機能で使用される slow timer を設定します。 この値は BFD が新しいセッションを開始する速度を決定し、BFD エコー機能がイネーブルの場合に非同期セッションの速度を低下させるために使用されます。 この値は、エコー機能がイネーブルの場合、必要最小受信間隔より優先されます。 指定できる範囲は 1000 ~ 30000 ミリ秒です。 デフォルト値は 2000 です。

               
              ステップ 3switch(config)# interface int-if  

              インターフェイス コンフィギュレーション モードを開始します。 ? キーワードを使用して、 サポートされているインターフェイスを表示します。

               
              ステップ 4switch(config-if)# bfd echo 

              エコー機能をイネーブルにします。 デフォルトではイネーブルになっています。

               
              ステップ 5switch(config-if)# show running-config bfd   (任意)

              BFD の実行コンフィギュレーションを表示します。

               
              ステップ 6switch(config-if)# copy running-config startup-config  (任意)

              この設定変更を保存します。

               

              次に、BFD エコー機能を設定する例を示します。

              switch# configure terminal
              switch(config)# bfd slow-timer 2000
              switch(config)# interface ethernet 2/1
              switch(config-if)# bfd echo
              switch(config-if)# show running-config bgp
              switch(config-if)# copy running-config startup-config

              サブインターフェイスの BFD の最適化について

              サブインターフェイスで BFD を最適化できます。 BFD により、設定されているすべてのサブインターフェイスのセッションが作成されます。 BFD により、設定されている最小の VLAN ID を持つサブインターフェイスがマスター サブインターフェイスとして設定され、そのサブインターフェイスは親インターフェイスの BFD セッション パラメータを使用します。 残りのサブインターフェイスは slow timer を使用します。 最適化されたサブインターフェイス セッションでエラーが検出されると、BFD により、その物理インターフェイスのすべてのサブインターフェイスがダウンとマークされます。

              サブインターフェイスの BFD の最適化

              はじめる前に

              正しい VRF を使用していることを確認します。

              BFD 機能をイネーブルにします。 「BFD 機能のイネーブル化」を参照してください。

              BFD セッション パラメータを設定します。 「グローバルな BFD パラメータの設定」および「インターフェイスでの BFD の設定」を参照してください。

              これらのサブインターフェイスが別の Cisco NX-OS デバイスに接続するようにしてください。 この機能は、Cisco NX-OS でだけサポートされます。

              手順
                 コマンドまたはアクション目的
                ステップ 1switch# configure terminal 

                グローバル コンフィギュレーション モードを開始します。

                 
                ステップ 2switch(config)# interface int-if 

                インターフェイス コンフィギュレーション モードを開始します。 ? キーワードを使用して、 サポートされているインターフェイスを表示します。

                 
                ステップ 3 switch(config-if)# bfd optimize subinterface 

                BFD 対応インターフェイスのサブインターフェイスを最適化します。 デフォルトではディセーブルになっています。

                 
                ステップ 4switch(config-if)# show running-config bfd  (任意)

                BFD の実行コンフィギュレーションを表示します。

                 
                ステップ 5switch(config-if)# copy running-config startup-config   (任意)

                この設定変更を保存します。

                 

                次の例では、インターフェイスで BFD を最適化する方法を示します。

                switch# configure terminal
                switch(config)# interface ethernet 2/1
                switch(config-if)# bfd optimize subinterface
                switch(config-if)# show running-config bfd
                switch(config-if)# copy running-config startup-config

                ルーティング プロトコルに対する BFD サポートの設定

                Cisco Nexus 6000 では、以下のルーティング プロトコルの BFD サポートを提供しています。

                • Border Gateway Protocol(BGP)
                • Enhanced Interior Gateway Routing Protocol(EIGRP)
                • Open Shortest Path First バージョン 2(通常は OSPF と呼ばれます)
                • ホットスタンバイ ルータ プロトコル(HSRP)
                • 仮想ルータ冗長プロトコル(VRRP)
                • スタティック ルート
                • プロトコル独立型マルチキャスト(PIM)

                BGP 上での BFD の設定について

                ボーダー ゲートウェイ プロトコル(BGP)の BFD を設定できます。

                BGP での BFD の設定

                はじめる前に 正しい VRF を使用していることを確認します。

                BFD 機能をイネーブルにします。 「BFD 機能のイネーブル化」を参照してください。

                BFD セッション パラメータを設定します。 「グローバルな BFD パラメータの設定」および「インターフェイスでの BFD の設定」を参照してください。

                BGP 機能をイネーブルにします。

                詳細については、『Cisco Nexus 6000 Series NX-OS Unicast Routing Configuration Guide, Release 6.x』を参照してください。

                手順
                   コマンドまたはアクション目的
                  ステップ 1switch# configure terminal 

                  グローバル コンフィギュレーション モードを開始します。

                   
                  ステップ 2switch(config)# router bgp as-number  BGP をイネーブルにして、ローカル BGP スピーカに AS 番号を割り当てます。 AS 番号は 16 ビット整数または 32 ビット整数にできます。上位 16 ビット 10 進数と下位 16 ビット 10 進数による xx.xx という形式です。  
                  ステップ 3switch(config-router)# neighbor {ip-address} remote-as as-number  リモート BGP ピアの IPv4 アドレスおよび AS 番号を設定します。 ip-address の形式は x.x.x.x です。  
                  ステップ 4switch(config-router-neighbor)# bfd 

                  この BGP ピアの BFD をイネーブルにします。

                   
                  ステップ 5switch(config-router-neighbor)# update-source interface-type number 

                  この BGP ピアに対する BFD を起動します。

                   
                  ステップ 6switch(config-router-neighbor)# show running-config bgp  (任意)

                  BGP の実行コンフィギュレーションを表示します。

                   
                  ステップ 7switch(config-router-neighbor)# copy running-config startup-config  (任意)

                  この設定変更を保存します。

                   

                  次に、BGP 上で BFD を設定する例を示します。

                  switch# configure terminal
                  switch(config)# router bgp 64496
                  switch(config-router)# neighbor 209.165.201.1 remote-as 64497
                  switch(config-router-neighbor)# bfd
                  switch(config-router-neighbor)# update-source ethernet 2/1
                  switch(config-router-neighbor)# show running-config bgp
                  switch(config-router-neighbor)# copy running-config startup-config

                  EIGRP 上での BFD の設定について

                  Enhanced Interior Gateway Routing Protocol(EIGRP)の BFD を設定できます。

                  EIGRP 上での BFD の設定

                  はじめる前に 正しい VRF を使用していることを確認します。

                  BFD 機能をイネーブルにします。 「BFD 機能のイネーブル化」を参照してください。

                  BFD セッション パラメータを設定します。 「グローバルな BFD パラメータの設定」および「インターフェイスでの BFD の設定」を参照してください。

                  EIGRP 機能をイネーブルにします。

                  詳細については、『Cisco Nexus 6000 Series NX-OS Unicast Routing Configuration Guide, Release 6.x』を参照してください。

                  手順
                     コマンドまたはアクション目的
                    ステップ 1switch# configure terminal 

                    グローバル コンフィギュレーション モードを開始します。

                     
                    ステップ 2switch(config)# router eigrp instance-tag 

                    インスタンス タグを設定して、新しい EIGRP プロセスを作成します。 インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

                    AS 番号であると認められていない instance-tag を設定する場合は、autonomous-system コマンドを使用して AS 番号を明示的に設定する必要があります。そうしないと、この EIGRP インスタンスはシャットダウン状態のままになります。

                     
                    ステップ 3switch(config-router)# bfd  (任意)

                    この EIGRP ルータの BFD をイネーブルにします。

                     
                    ステップ 4switch(config-router)# interface int-if 

                    インターフェイス コンフィギュレーション モードを開始します。 ? キーワードを使用して、 サポートされているインターフェイスを表示します。

                     
                    ステップ 5switch(config-if)# ip eigrp instance-tag bfd  (任意)

                    EIGRP インターフェイスで BFD をイネーブルまたはディセーブルにします。 インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

                    デフォルトではディセーブルになっています。

                     
                    ステップ 6switch(config-if)# show ip eigrp [vrf vrf-name] [interface if]  (任意)

                    EIGRP の実行コンフィギュレーションを表示します。

                     
                    ステップ 7switch(config-if)# copy running-config startup-config  (任意)

                    リブートおよびリスタート時に実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして、変更を永続的に保存します。

                     

                    次に、EIGRP 上で BFD を設定する例を示します。

                    switch# configure terminal
                    switch(config)# router eigrp Test1
                    switch(config-router)# bfd
                    switch(config-router)# interface ethernet 2/1
                    switch(config-if)# ip eigrp Test1 bfd
                    switch(config-if)# show ip eigrp
                    switch(config-if)# copy running-config startup-config

                    OSPF 上での BFD の設定について

                    Open Shortest Path First バージョン 2(OSPFv2)で BFD を設定できます。

                    OSPF での BFD の設定

                    はじめる前に

                    正しい VRF を使用していることを確認します。

                    BFD 機能をイネーブルにします。 1-7 ページの「BFD 機能のイネーブル化」を参照してください。

                    BFD セッション パラメータを設定します。 「グローバルな BFD パラメータの設定」および「インターフェイスでの BFD の設定」を参照してください。

                    OSPF 機能をイネーブルにします。

                    詳細については、『Cisco Nexus 6000 Series NX-OS Unicast Routing Configuration Guide, Release 6.x』を参照してください。

                    手順
                       コマンドまたはアクション目的
                      ステップ 1switch# configure terminal 

                      グローバル コンフィギュレーション モードを開始します。

                       
                      ステップ 2switch(config)# router ospf instance-tag 

                      新規 OSPFv2 インスタンスを作成して、設定済みのインスタンス タグを割り当てます。 インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

                       
                      ステップ 3switch(config-router)# bfd  (任意)

                      この OSPFv2 インスタンスの BFD をイネーブルにします。 また、各 OSPFv2 インターフェイスはイネーブルかディセーブルである必要があります。

                       
                      ステップ 4switch(config-router)# interface int-if 

                      インターフェイス コンフィギュレーション モードを開始します。 ? キーワードを使用して、 サポートされているインターフェイスを表示します。

                       
                      ステップ 5switch(config-if)# ip ospf bfd  (任意)

                      OSPFv2 インターフェイスで BFD をイネーブルまたはディセーブルにします。 デフォルトではディセーブルになっています。

                       
                      ステップ 6switch(config-if)# show ip ospf [vrf vrf-name] [interface if]  (任意)

                      BGP の実行コンフィギュレーションを表示します。

                       
                      ステップ 7switch(config-if)# copy running-config startup-config  (任意)

                      リブートおよびリスタート時に実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして、変更を永続的に保存します。

                       

                      次に、OSPF 上で BFD を設定する例を示します。

                      switch# configure terminal
                      switch(config)# router ospf 201
                      switch(config-router)# bfd
                      switch(config-router)# interface ethernet 2/1
                      switch(config-if)# ip ospf bfd
                      switch(config-if)# show ip ospf
                      switch(config-if)# copy running-config startup-config

                      HSRP 上での BFD の設定について

                      ホットスタンバイ ルータ プロトコル(HSRP)の BFD を設定できます。 アクティブおよびスタンバイの HSRP ルータは BFD を介して相互に追跡しています。

                      スタンバイ HSRP ルータ上の BFD がアクティブ HSRP ルータが動作していないことを検知すると、スタンバイ HSRP はこのイベントをアクティブ タイマー失効として取り扱いアクティブ HSRP ルータとして役割を引き継ぎます。 show hsrp detail では、このイベントが BFD@Act-down または BFD@Sby-down として表示されます。

                      HSRP での BFD の設定

                      はじめる前に 正しい VRF を使用していることを確認します。

                      BFD 機能をイネーブルにします。 「BFD 機能のイネーブル化」を参照してください。

                      BFD セッション パラメータを設定します。 「グローバルな BFD パラメータの設定」および「インターフェイスでの BFD の設定」を参照してください。

                      HSRP 機能をイネーブルにします。 詳細については、『Cisco Nexus 6000 Series NX-OS Unicast Routing Configuration Guide, Release 6.x』を参照してください。

                      手順
                         コマンドまたはアクション目的
                        ステップ 1switch# configure terminal 

                        グローバル コンフィギュレーション モードを開始します。

                         
                        ステップ 2switch(config)# hsrp bfd all-interfaces  (任意)

                        HSRP インターフェイスですべての BFD をイネーブルまたはディセーブルにします。 デフォルトではディセーブルになっています。

                         
                        ステップ 3switch(config)# interface int-if 

                        インターフェイス コンフィギュレーション モードを開始します。 ? キーワードを使用して、 サポートされているインターフェイスを表示します。

                         
                        ステップ 4switch(config-if)# hsrp bfd  (任意)

                        HSRP インターフェイスで BFD をイネーブルまたはディセーブルにします。 デフォルトではディセーブルになっています。

                         
                        ステップ 5switch(config-if)# show running-config hsrp  (任意)

                        HSRP の実行コンフィギュレーションを表示します。

                         
                        ステップ 6switch(config-if)# copy running-config startup-config  (任意)

                        リブートおよびリスタート時に実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして、変更を永続的に保存します。

                         

                        次に、HSRP 上で BFD を設定する例を示します。

                        switch# configure terminal
                        switch(config)# hsrp bfd all-interfaces
                        switch(config)# interface ethernet 2/1
                        switch(config-if)# hsrp bfd
                        switch(config-if)# show running-config hsrp
                        switch(config-if)# copy running-config startup-config

                        VRRP 上での BFD の設定について

                        仮想ルータ冗長プロトコル(VRRP)の BFD を設定できます。 アクティブおよびスタンバイの VRRP ルータは BFD を介して相互に追跡しています。 スタンバイ VRRP ルータ上の BFD がアクティブ VRRP ルータが動作していないことを検知すると、スタンバイ VRRP はこのイベントをアクティブ タイマー失効として取り扱いアクティブ VRRP ルータとして役割を引き継ぎます。

                        show vrrp detail では、このイベントが BFD@Act-down または BFD@Sby-down として表示されます。

                        VRRP での BFD の設定

                        はじめる前に 正しい VRF を使用していることを確認します。

                        BFD 機能をイネーブルにします。 「BFD 機能のイネーブル化」を参照してください。

                        BFD セッション パラメータを設定します。 「グローバルな BFD パラメータの設定」および「インターフェイスでの BFD の設定」を参照してください。

                        VRRP 機能をイネーブルにします。

                        詳細については、『Cisco Nexus 6000 Series NX-OS Unicast Routing Configuration Guide, Release 6.x』を参照してください。

                        手順
                           コマンドまたはアクション目的
                          ステップ 1switch# configure terminal 

                          グローバル コンフィギュレーション モードを開始します。

                           
                          ステップ 2switch(config)# interface int-if 

                          インターフェイス コンフィギュレーション モードを開始します。 ? キーワードを使用して サポートされているインターフェイスを表示します。

                           
                          ステップ 3switch(config-if)# vrrp group-no 

                          VRRP グループ番号を指定します。

                           
                          ステップ 4switch(config-if-vrrp)# vrrp bfd address 

                          VRRP インターフェイスで BFD をイネーブルまたはディセーブルにします。 デフォルトではディセーブルになっています。

                           
                          ステップ 5switch(config-if-vrrp)# show running-config vrrp  (任意)

                          VRRP の実行コンフィギュレーションを表示します。

                           
                          ステップ 6switch(config-if-vrrp)# copy running-config startup-config  (任意)

                          この設定変更を保存します。

                           

                          次に、VRRP 上で BFD を設定する例を示します。

                          switch# configure terminal
                          switch(config)# interface ethernet 2/1
                          switch(config-if)# vrrp 1
                          switch(config-if-vrrp)# vrrp bfd 10.0.0.10
                          switch(config-if-vrrp)# show running-config vrrp
                          switch(config-if-vrrp)# copy running-config startup-config

                          スタティック ルートでの BFD の設定について

                          インターフェイスのスタティック ルータの BFD を設定できます。 仮想ルーティングおよび転送(VRF)インスタンス内のスタティック ルートでの BFD を任意で設定できます。

                          スタティック ルートでの BFD の設定

                          はじめる前に 正しい VRF を使用していることを確認します。

                          BFD 機能をイネーブルにします。 「BFD 機能のイネーブル化」を参照してください。

                          BFD セッション パラメータを設定します。 「グローバルな BFD パラメータの設定」および「インターフェイスでの BFD の設定」を参照してください。

                          HSRP 機能をイネーブルにします。 詳細については、『Cisco Nexus 6000 Series NX-OS Unicast Routing Configuration Guide, Release 6.x』を参照してください。

                          手順
                             コマンドまたはアクション目的
                            ステップ 1switch# configure terminal 

                            グローバル コンフィギュレーション モードを開始します。

                             
                            ステップ 2switch(config)# vrf context vrf-name  (任意)

                            VRF コンフィギュレーション モードを開始します。

                             
                            ステップ 3switch(config-vrf)# ip route route interface{nh-address | nh-prefix} 

                            スタティック ルートを作ります。? キーワードを使用して、 サポートされているインターフェイスを表示します。

                             
                            ステップ 4switch(config-vrf)# ip route static bfd interface { nh-address | nh-prefix} 

                            インターフェイスのすべてのスタティック ルートの BFD をイネーブルにします。 ? サポートされているインターフェイスを表示します。

                             
                            ステップ 5switch(config-vrf)# show ip route static[vrf vrf-name]  (任意)

                            スタティック ルートを表示します。

                             
                            ステップ 6switch(config-vrf)# copy running-config startup-config  (任意)

                            この設定変更を保存します。

                             

                            次に、スタティック ルート上で BFD を設定する例を示します。

                            switch# configure terminal
                            switch(config)# vrf context Red
                            switch(config-vrf)# ip route 192.0.2.1 ethernet 2/1 192.0.2.4
                            switch(config-vrf)# ip route static bfd ethernet 2/1 192.0.2.4
                            switch(config-vrf)# show ip route static vrf Red
                            switch(config-vrf)# copy running-config startup-config

                            PIM 上での BFD の設定について

                            PIM(Protocol Independent Multicast)プロトコルの BFD を設定できます。

                            Protocol Independent Multicast(PIM)上での BFD の設置

                            はじめる前に 正しい VRF を使用していることを確認します。

                            BFD 機能をイネーブルにします。 「BFD 機能のイネーブル化」を参照してください。

                            BFD セッション パラメータを設定します。 「グローバルな BFD パラメータの設定」および「インターフェイスでの BFD の設定」を参照してください。

                            PIM 機能をイネーブルにします。 詳細については、『Cisco Nexus 6000 Series NX-OS Multicast Routing Configuration Guide, Release 6.x』を参照してください。

                            手順
                               コマンドまたはアクション目的
                              ステップ 1switch# configure terminal 

                              グローバル コンフィギュレーション モードを開始します。

                               
                              ステップ 2switch(config)# ip pim bfd 

                              PIM の BFD をイネーブルにします。

                               
                              ステップ 3switch(config)# interface int-if 

                              インターフェイス コンフィギュレーション モードを開始します。 ? キーワードを使用して、 サポートされているインターフェイスを表示します。

                               
                              ステップ 4switch(config-if)# ip pim bfd-instance [disable]  (任意)

                              PIM インターフェイスの BFD をイネーブルまたはディセーブルにします。 デフォルトではディセーブルになっています。

                               
                              ステップ 5switch(config-if)# show running-config pim  (任意)

                              PIM の実行コンフィギュレーションを表示します。

                               
                              ステップ 6switch(config-if)# copy running-config startup-config  (任意)

                              この設定変更を保存します。

                               

                              次に、PIM 上で BFD を設定する例を示します。

                              switch# configure terminal
                              switch(config)# ip pim bfd
                              switch(config)# interface ethernet 2/1
                              switch(config-if)# ip pim bfd-instance
                              switch(config-if)# show running-config pim
                              switch(config-if)# copy running-config startup-config

                              インターフェイスにおける BFD のディセーブル化

                              グローバルまたは VRF レベルでイネーブルにされた BFD のあるルーティング プロトコルに対するインターフェイス上の BFD を選択的にディセーブルにできます。

                              インターフェイス上の BFD をディセーブルにするには、インターフェイス コンフィギュレーション モードで次のコマンドのいずれかを使用します。

                              手順
                                 コマンドまたはアクション目的
                                ステップ 1switch(config)# ip eigrp instance-tag bfd disable

                                例:
                                switch(config)# ip eigrp Test1 bfd disable
                                 

                                EIGRP インターフェイスで BFD をディセーブルにします。 インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

                                 
                                ステップ 2switch(config-if)# ip ospf bfd disable

                                例:
                                switch(config-if)# ip ospf bfd disable
                                 

                                OSPFv2 インターフェイスで BFD をディセーブルにします。

                                 

                                BFD 設定の確認

                                BFD 設定情報

                                を表示するには、次の作業のいずれかを行います。
                                コマンド 目的

                                switch# show running-config bfd

                                BGP や OSPFv2 などのサポートされるアプリケーションの BFD に関する情報を表示します。

                                switch# show startup-config bfd

                                起動時に適用される BFD コンフィギュレーションに関する情報を表示します。

                                これらのコマンド出力のフィールドの詳細については、『Cisco Nexus 6000 Series NX-OS Interfaces Command Reference』を参照してください。

                                BFD のモニタ

                                BFD をモニタするには、次のコマンドを使用します。

                                コマンド 目的

                                switch# show bfd neighbors[application name] [details]

                                BGP や OSPFv2 などのサポートされるアプリケーションの BFD に関する情報を表示します。

                                switch# show bfd neighbors[interface int-if] [details]

                                指定したインターフェイスでの BFD に関する情報を表示します。

                                switch# show bfd neighbors [dest-ip ip-address] [src-ip ip-address] [details]

                                指定したインターフェイスでのセッションの BFD に関する情報を表示します。

                                switch# show bfd neighbors [vrf vrf-name] [details]

                                VRF の BFD に関する情報を表示します。

                                詳細については、『Cisco Nexus 6000 Series NX-OS Switch Interfaces Command Reference』を参照してください

                                BFD の設定例

                                次に、デフォルト BFD セッション パラメータを使用した、Ethernet 2/1 上の OSPFv2 の BFD 設定例を示します。

                                switch# configure terminal
                                switch(config)# feature bfd
                                switch(config)# feature ospf
                                switch(config)# router ospf Test1
                                switch(config-router)# interface ethernet 2/1
                                switch(config-if)# ip ospf bfd
                                switch(config-if)# no shutdown
                                

                                次に、デフォルト BFD セッション パラメータを使用した、EIGRP インターフェイスの BFD 設定例を示します。

                                switch# configure terminal
                                switch(config)# feature bfd
                                switch(config)# feature eigrp
                                switch(config)# bfd interval 250 min_rx 250 multiplier 4
                                switch(config)# router eigrp Test2
                                switch(config-router)# bfd

                                関連資料

                                関連項目 マニュアル タイトル

                                BFD コマンド

                                詳細については、『Cisco Nexus 6000 Series NX-OS Unicast Routing Command Reference, Release 6.x』を参照してください。

                                   

                                関連の標準

                                以下の業界標準は双方向フォワーディング検出に対応しています。
                                RFC Title
                                RFC 5880 双方向フォワーディング検出(BFD)
                                RFC 5881 『BFD for IPv4 and IPv6 (Single Hop)』