Cisco Nexus 6000 シリーズ NX-OS Quality of Service コンフィギュレーション ガイド リリース 6.x
VLAN での QoS の設定
VLAN での QoS の設定
発行日;2014/01/06   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

VLAN での QoS の設定

この章の内容は、次のとおりです。

VLAN QoS の概要

Cisco Nexus デバイスでは、VLAN での分類およびマーキング用の Quality of Service(QoS)ポリシーを設定できます。 VLAN に適用されるポリシーは、VLAN のレイヤ 2 およびスイッチ仮想インターフェイス(SVI)ポートのトラフィックに適用されます。

QoS ポリシーの優先順位

QoS ポリシーのマーキング要件によって優先順位が決まります。 インターフェイス QoS ポリシーが最優先され、VLAN QoS ポリシーがその次になり、システム QoS ポリシーが最も低い優先順位になります。

ただし、VLAN に VLAN QoS ポリシーと VLAN ACL(VACL)の両方が割り当てられている場合、VACL が最優先されます。

インターフェイス、システム、および VLAN ポリシーの優先順位例

次に、CoS 5 のインターフェイス 1/1 のトラフィックが qos-group 3 に送信される設定例を示します。 VLAN 10 および CoS 5 の他のインターフェイスのトラフィックは qos-group 4 に送信されます。 VLAN 10 および CoS 5 以外のインターフェイスのトラフィックは qos-group 5 に送信されます。

class-map type qos match-all cm1
  match cos 5
policy-map type qos pm-ifc
  class cm1
    set qos-group 3
  class class-default
policy-map type qos pm-vlan
  class cm1
    set qos-group 4
  class class-default
policy-map type qos pm-sys
  class cm1
    set qos-group 5
  class class-default

system qos
  service-policy type qos input pm-sys
vlan configuration 10
  service-policy type qos input pm-vlan
interface Ethernet1/1
  service-policy type qos input pm-ifc

インターフェイスおよびシステム QoS ポリシーの優先順位例

次に、CoS 5 のインターフェイス 1/1 のトラフィックが qos-group 3 に送信される設定例を示します。 CoS 5 の他のインターフェイスのトラフィックは qos-group 5 に送信されます。

class-map type qos match-all cm1
  match cos 5
policy-map type qos pm-ifc
  class cm1
    set qos-group 3
  class class-default
policy-map type qos pm-sys
  class cm1
    set qos-group 5
  class class-default

system qos
  service-policy type qos input pm-sys

interface Ethernet1/1
  service-policy type qos input pm-ifc

システムおよび VLAN ポリシーの優先順位例

次に、CoS 5 の VLAN 10 のトラフィックが qos-group 4 に送信される設定例を示します。 CoS 5 の他の VLAN のトラフィックは qos-group 5 に送信されます。

class-map type qos match-all cm1
  match cos 5
policy-map type qos pm-vlan
  class cm1
    set qos-group 4
  class class-default
policy-map type qos pm-sys
  class cm1
    set qos-group 5
  class class-default

system qos
  service-policy type qos input pm-sys
vlan configuration 10
  service-policy type qos input pm-vlan

VLAN QoS および VACL ポリシーの優先順位例

この例では、送信元 IP アドレスが 10.10.10.1 のパケットはドロップされます。 ただし、VLAN 10 および CoS 5 の他のパケットは qos-group 4 に送信されます。

ip access-list al1
  10 permit ip 10.10.10.1/24 any
vlan access-map v-am1
  match ip address al1
  action drop
vlan filter v-am1 vlan-list 10

class-map type qos match-all cm1
  match cos 5
policy-map type qos pm-vlan
  class cm1
    set qos-group 4
  class class-default

vlan configuration 10
  service-policy type qos input pm-vlan

VLAN QoS の TCAM エントリの制限

QoS TCAM リージョンは、インターフェイス QoS、システム QoS、および VLAN QoS ポリシーによって共有されます。 VLAN QoS ポリシーを定義するために、インターフェイス QoS ポリシーの TCAM エントリの数を制限する必要があります。 この制限を設定するには、hardware profile tcam feature interface-qos limit tcam-size を使用します。

図 1. QoS TCAM リージョン



VLAN QoS の注意事項および制約事項

  • VLAN には、設定するサービス ポリシーに対して少なくとも 1 個のアクティブ メンバ ポートが必要です。 VLAN に少なくとも 1 個のアクティブ メンバがない場合にサービス ポリシーを設定すると、設定は受け入れられますが、TCAM はプログラミングされません。
  • no vlan number コマンドを使用して VLAN を削除した場合、その VLAN に設定されたサービス ポリシーは残りますが、非アクティブになります。
  • TCAM には VLAN でのサービス ポリシーの設定に十分な空きエントリが必要です。
  • ロールバックは、インターフェイス QoS 制限がロール バック設定と実行コンフィギュレーションで異なる場合は、失敗する可能性があります。
  • QoS ポリシーが設定された VLAN が QoS ポリシーがないインターフェイスで設定されている場合、show policy-map interface number コマンドは VLAN 上に設定された QoS ポリシーを表示しません。
  • インターフェイス QoS 制限を変更する前に、すべてのインターフェイスの QoS ポリシーを削除します。

VLAN QoS の設定

インターフェイス QoS TCAM 制限の設定または変更

interface_qos_limit を特定の数に設定する場合、すべての ASIC の TCAM の QoS リージョンにその数のオフセットを超えるインターフェイス ポリシーを設定することはできません。 たとえば、interface_qos_limit を 1000 に設定する場合、すべての ASIC の TCAM の QoS リージョンにオフセット 1000 を超えるインターフェイス ポリシーを設定できません。

手順
     コマンドまたはアクション目的
    ステップ 1switch# configure terminal 

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 2switch(config)# hardware profile tcam feature interface-qos limit tcam-size 

    インターフェイス QoS TCAM 制限を設定します。 tcam-size の範囲は 7 ~ 446 エントリです。

     
    ステップ 3switch(config)# show hardware profile tcam feature qos 

    QoS TCAM の制限を表示します。

     
    ステップ 4switch(config)# copy running-config startup-config  (任意)

    リブートおよびリスタート時に実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして、変更を永続的に保存します。

     

    次に、インターフェイス QoS TCAM 制限を 20 エントリに設定する例を示します。

    switch(config)# configure terminal
    switch(config)# hardware profile tcam feature interface-qos limit 20
    switch(config)# show hardware profile tcam feature qos 
    Feature                  Limit (number of tcam entries)
    ------------------------------------------------------
    interface-qos              20
    vlan-qos + global-qos     428
    
    switch(config)# copy running-config startup-config
    

    TCAM からのインターフェイス QoS 制限の削除

    はじめる前に
    • すべての VLAN QoS ポリシーを削除します。
    手順
       コマンドまたはアクション目的
      ステップ 1switch# configure terminal 

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 2switch(config)# show hardware profile tcam feature qos 

      QoS TCAM の制限を表示します。

       
      ステップ 3switch(config)# no hardware profile tcam feature interface-qos limit tcam-size 

      インターフェイス QoS TCAM 制限を設定します。 tcam-size の範囲は 7 ~ 446 エントリです。

       
      ステップ 4switch(config)# copy running-config startup-config  (任意)

      リブートおよびリスタート時に実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして、変更を永続的に保存します。

       

      次に、インターフェイス QoS TCAM 制限を削除する例を示します。

      switch(config)# configure terminal
      switch(config)# show hardware profile tcam feature qos 
      Feature                  Limit (number of tcam entries)
      ------------------------------------------------------
      interface-qos              20
      vlan-qos + global-qos     428
      
      switch(config)# no hardware profile tcam feature interface-qos limit 20
      switch(config)# copy running-config startup-config
      

      VLAN のサービス ポリシーの設定

      はじめる前に
      • インターフェイス QoS 制限を設定する必要があります。
      • ポリシー マップを設定する必要があります。
      • TCAM には VLAN でのサービス ポリシーの設定に十分な空きエントリが必要です。
      手順
         コマンドまたはアクション目的
        ステップ 1switch# configure terminal 

        グローバル コンフィギュレーション モードを開始します。

         
        ステップ 2switch(config)# vlan configuration vlan-number  

        VLAN を作成し、VLAN コンフィギュレーション モードを開始します。 vlan-number の範囲は 1 ~ 4094 です。

         
        ステップ 3switch(config-vlan)# service-policy type qos input policy-name 

        VLAN にポリシー マップを割り当てます。 policy-name は、ポリシー マップに割り当てられた名前です。 名前には最大 40 文字までの英数字を指定できます。

         
        ステップ 4switch(config-vlan)# copy running-config startup-config  (任意)

        リブートおよびリスタート時に実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして、変更を永続的に保存します。

         

        次に、サービス ポリシーを作成し、VLAN 10 に割り当てる例を示します。

        switch# configure terminal
        switch(config)# class-map type qos cm1
        switch(config-cmap-qos)# match cos 5
        switch(config-cmap-qos)# policy-map type qos pm-vlan
        switch(config-pmap-qos)# class cm1
        switch(config-pmap-c-qos)# set qos-group 4
        switch(config-pmap-c-qos)# exit
        switch(config-pmap-qos)# exit
        switch(config)# vlan configuration 10
        switch(config-vlan-config)# service-policy type qos input pm-vlan
        switch(config-vlan-config)#
        

        VLAN からのサービス ポリシーの削除

        手順
           コマンドまたはアクション目的
          ステップ 1switch# configure terminal 

          グローバル コンフィギュレーション モードを開始します。

           
          ステップ 2switch(config)# vlan configuration vlan-number 

          指定された VLAN の VLAN コンフィギュレーション モードが開始されます。 vlan-number の範囲は 1 ~ 4094 です。

           
          ステップ 3switch(config-vlan-config)#no service-policy type qos input policy-name 

          VLAN からポリシーを削除します。 policy-name は、ポリシー マップに割り当てられた名前です。 名前には最大 40 文字までの英数字を指定できます。

           
          ステップ 4switch(config-vlan-config)# copy running-config startup-config  (任意)

          リブートおよびリスタート時に実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして、変更を永続的に保存します。

           

          次に、VLAN 10 から pm-vlan ポリシー マップを削除する例を示します。

          swtich# configure terminal
          switch(config)# vlan configuration 10
          switch(config-vlan-config)# no service-policy type qos input pm-vlan
          switch(config-vlan-config)# copy running-config startup-config
          

          VLAN QoS 設定の確認

          次のいずれかのコマンドを使用して、設定を確認します。

          コマンド

          目的

          show policy-map vlan vlan-number

          指定する VLAN に設定されている QoS ポリシーを表示します。

          show policy-map [name]

          スイッチで定義されたポリシー マップを表示します。 指定したポリシーだけを表示することもできます。

          running-config ipqos

          QoS の実行コンフィギュレーションに関する情報を表示します。

          startup-config ipqos

          QoS のスタートアップ コンフィギュレーションに関する情報を表示します。

          VLAN QoS 機能の履歴

          表 1 VLAN QoS 機能の履歴

          機能名

          リリース

          機能情報

          VLAN QoS

          5.1(3)N2(1)

          この機能が導入されました。