Cisco Nexus 5000 シリーズ NX-OS コマンド リファレンス
イーサネット コマンド
イーサネット コマンド
発行日;2012/01/09 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

イーサネット コマンド

bandwidth(インターフェイス)

cdp

cdp enable

channel-group(イーサネット)

clear mac access-list counters

clear mac address-table dynamic

clear spanning-tree counters

clear spanning-tree detected-protocol

delay(インターフェイス)

description(インターフェイス)

errdisable detect cause

errdisable recovery cause

errdisable recovery interval

feature vtp

instance vlan

interface ethernet

interface port-channel

ip igmp snooping(EXEC)

ip igmp snooping(VLAN)

lacp port-priority

lacp system-priority

link debounce

mac address-table aging-time

mac address-table notification

mac address-table static

monitor session

name(VLAN コンフィギュレーション)

name(MST コンフィギュレーション)

port-channel load-balance ethernet

private-vlan

private-vlan association

private-vlan synchronize

revision

shutdown(VLAN コンフィギュレーション)

spanning-tree bpdufilter

spanning-tree bpduguard

spanning-tree cost

spanning-tree guard

spanning-tree link-type

spanning-tree loopguard default

spanning-tree mode

spanning-tree mst configuration

spanning-tree mst cost

spanning-tree mst forward-time

spanning-tree mst hello-time

spanning-tree mst max-age

spanning-tree mst max-hops

spanning-tree mst port-priority

spanning-tree mst priority

spanning-tree mst root

spanning-tree mst simulate pvst

spanning-tree mst simulate pvst global

spanning-tree pathcost method

spanning-tree port type edge

spanning-tree port type edge bpdufilter default

spanning-tree port type edge bpduguard default

spanning-tree port type edge default

spanning-tree port type network

spanning-tree port type network default

spanning-tree port-priority

spanning-tree vlan

speed(イーサネット)

state

svi enable

switchport access vlan

switchport block

switchport mode private-vlan host

switchport mode private-vlan promiscuous

switchport private-vlan host-association

switchport private-vlan mapping

udld(コンフィギュレーション モード)

udld(イーサネット)

vlan(EXEC モード)

vrf context

vtp domain

vtp mode

vtp version

イーサネット コマンド

この章では、Cisco Nexus 5000 シリーズ スイッチで使用可能な Cisco NX-OS イーサネット コマンドについて説明します。

bandwidth(インターフェイス)

インターフェイスに継承帯域幅および受信帯域幅の値を設定するには、 bandwidth コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

bandwidth { kbps | inherit [ kbps ]}

no bandwidth { kbps | inherit [ kbps ]}

シンタックスの説明

kbps

情報帯域幅(キロビット/秒)。有効値は、1 ~ 10000000 です。

inherit

(任意)メイン インターフェイスから継承する帯域幅を指定します。

コマンドのデフォルト

1000000 kbps

コマンド モード

インターフェイス コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

bandwidth コマンドは、現在の帯域幅だけを上位のプロトコルに通知する情報パラメータを設定します。このコマンドを使用してインターフェイスの実際の帯域幅を調整できません。

bandwidth inherit コマンドは、サブインターフェイスがメイン インターフェイスの帯域幅を継承する方法を制御します。

no bandwidth inherit コマンドを使用すると、設定済みの帯域幅に関係なく、すべてのサブインターフェイスがメイン インターフェイスのデフォルトの帯域幅を継承するようになります。サブインターフェイスに帯域幅が設定されていない状態で bandwidth inherit コマンドを使用した場合、すべてのサブインターフェイスがメイン インターフェイスの現在の帯域幅を継承します。メイン インターフェイスに新しい帯域幅を設定すると、すべてのサブインターフェイスでその新しい値が使用されます。

サブインターフェイスに帯域幅を設定せずに、メイン インターフェイスに bandwidth inherit コマンドを設定した場合、サブインターフェイスは指定された帯域幅を継承します。

いずれの場合も、インターフェイスに明示的な帯域幅が設定されている場合、そのインターフェイスでは、帯域幅の継承設定が有効かどうかにかかわらず、その明示的な帯域幅が使用されます。

次に、このメイン インターフェイスのすべてのサブインターフェイスが設定された帯域幅を継承するように設定する例を示します。

switch(config-if)# bandwidth inherit 30000

関連コマンド

コマンド
説明

show interface

インターフェイス コンフィギュレーション情報を表示します。

 

cdp

Cisco Discovery Protocol(CDP)をイネーブルにし、CDP アトリビュートを設定するには、 cdp コマンドを使用します。CDP をディセーブルにするか、または CDP アトリビュートをリセットするには、このコマンドの no 形式を使用します。

cdp { advertise { v1 | v2 } | enable | format device-id { mac-address | serial-number | system-name } | holdtime seconds | timer seconds }

no cdp { advertise | enable | format device-id { mac-address | serial-number | system-name } | holdtime seconds | timer seconds }

シンタックスの説明

 

advertise { v1 | v2 }

使用するバージョンを設定して、CDP アドバタイズメントを送信します。バージョン 2 がデフォルト ステートです。

enable

すべてのイーサネット インターフェイスに対し、CDP をイネーブルにします。

format device-id

CDP デバイス ID の形式を設定します。

mac-address

Media Access Control(MAC; メディア アクセス制御)アドレスを CDP デバイス ID として使用します。

serial-number

シリアル番号を CDP デバイス ID として使用します。

system-name

システム名を CDP デバイス ID として使用します。このシステム名は、完全修飾ドメイン名として表記できます。これはデフォルトです。

holdtime seconds

CDP 情報が、レシーバーで廃棄されるまでに保持される時間を指定します。有効な範囲は 10 ~ 255 秒です。デフォルトは 180 秒です。

timer seconds

CDP アップデートの送信頻度を秒単位で設定します。有効な範囲は 5 ~ 254 秒です。デフォルトは 60 秒です。

コマンドのデフォルト

なし

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

次に、すべてのイーサネット インターフェイス上で CDP をイネーブルにする例を示します。

switch# configure terminal
switch(config)# cdp enable

次に、MAC アドレスを CDP デバイス ID として設定する例を示します。

switch# configure terminal
switch(config)# cdp format device-id mac-address

次に、すべてのイーサネット インターフェイスで CDP をディセーブルにする例を示します。

switch# configure terminal
switch(config)# no cdp enable

関連コマンド

コマンド
説明

show cdp

Cisco Discovery Protocol(CDP)情報を表示します。

 

cdp enable

イーサネット インターフェイスで Cisco Discovery Protocol(CDP)をイネーブルにするには、 cdp enable コマンドを使用します。インターフェイスで CDP をディセーブルにするには、このコマンドの no 形式を使用します。

cdp enable

no cdp enable

シンタックスの説明

このコマンドには、引数またはキーワードはありません。

コマンドのデフォルト

なし

コマンド モード

インターフェイス コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

次に、イーサネット インターフェイス上で CDP をイネーブルにする例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/1
switch(config-if)# cdp enable

関連コマンド

コマンド
説明

show interface

インターフェイス コンフィギュレーション情報を表示します。

 

channel-group(イーサネット)

物理インターフェイスを EtherChannel に割り当て、設定するには、 channel-group コマンドを使用します。インターフェイスからチャネル グループ設定を削除するには、このコマンドの no 形式を使用します。

channel-group number [ mode { active | on | passive }]

no channel-group [ number ]

シンタックスの説明

number

チャネル グループの番号です。番号の範囲は 1 ~ 4096 です。EtherChannel がまだ存在しない場合は、このチャネル グループに関連付けられる EtherChannel が Cisco NX-OS によって作成されます。

mode

(任意)インターフェイスの EtherChannel モードを指定します。

active

このコマンドを指定すると、ユーザが Link Aggregation Control Protocol(LACP)をイネーブルにしたときに、特定のインターフェイスの LACP がイネーブルになります。インターフェイスはアクティブなネゴシエーション状態になります。この状態では、ポートは LACP パケットを送信して他のポートとネゴシエーションを開始します。

on

デフォルトのチャネル モードです。 LACP を実行していないすべての EtherChannel が、このモードのままになることを指定します。LACP をイネーブルにする前に、チャネル モードを active または passive に変更しようとすると、スイッチはエラー メッセージ返します。

feature lacp コマンドで LACP をグローバルにイネーブルにしてから、チャネル モードを active または passive に設定することで各チャネルの LACP をイネーブルにします。このモードのインターフェイスでは、LACP パケットの開始も応答も行われません。LACP は、on ステートのインターフェイスとネゴシエートする場合、LACP パケットを受信しないため、そのインターフェイスと個別のリンクを形成します。そのため、チャネル グループには参加しません。

デフォルト モードは on です。

passive

このコマンドを指定すると、ユーザが LACP をイネーブルにしたときに、LACP デバイスが検出された場合にだけ LACP がイネーブルになります。インターフェイスはパッシブなネゴシエーション状態になります。この状態では、ポートは受信した LACP パケットに応答しますが、LACP ネゴシエーションを開始しません。

コマンドのデフォルト

なし

コマンド モード

インターフェイス コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

操作中のインターフェイスが含まれるチャネル グループを作成し、特定のインターフェイスをそのチャネル グループに追加したりそのチャネル グループから削除したりするには、このコマンドを使用します。また、あるチャネル グループから別のチャネル グループにポートを移動する場合も、このコマンドを使用します。ポートの移動先となるチャネル グループを入力すると、スイッチにより指定されたポートが自動的に現在のチャネル グループから削除され、指定のチャネル グループに追加されます。

feature lacp コマンドで LACP をグローバルにイネーブルにしてから、チャネル モードを active または passive に設定することで各チャネルの LACP をイネーブルにします。 on チャネル モードの EtherChannel は純粋な EtherChannel であり、最大 8 つのポートを集約できます。この EtherChannel では LACP は実行されません。

既存の EtherChannel またはそのインターフェイス(その EtherChannel で LACP が実行されていない場合)のモードは変更できません。したがって、チャネル モードは on のまま保持されます。モードを変更しようとすると、システムからエラー メッセージが返されます。

EtherChannel から物理インターフェイスを削除するには、このコマンドの no 形式を使用します。EtherChannel から最後の物理インターフェイスを削除しても、その EtherChannel は削除されません。EtherChannel を完全に削除するには、 interface port-channel コマンドの no 形式を使用します。

互換性チェックの対象となる動作属性は次のとおりです。

ポート モード

アクセス VLAN

トランク Native VLAN

タグ付きまたは非タグ付き

許可 VLAN リスト

SPAN(SPAN の送信元ポートおよび宛先ポートは不可)

ストーム制御

Cisco NX-OS で使用される互換性チェックの完全なリストを表示するには、 show port-channel compatibility-parameters コマンドを使用します。

スタティック EtherChannel(設定された集約プロトコルがないもの)に追加できるのは、チャネル モードが on に設定されたインターフェイスだけです。LACP を実行している EtherChannel に追加できるのは、チャネル モードが active または passive に設定されたインターフェイスだけです

これらのアトリビュートは個別のメンバ ポートに設定できます。アトリビュートに互換性がないメンバ ポートを設定した場合、Cisco NX-OS により EtherChannel 内のそのポートは一時停止されます。

インターフェイスが EtherChannel に参加すると、次のようなインターフェイスの個々のパラメータの一部は、EtherChannel の値で上書きされます。

MAC アドレス

Spanning Tree Protocol(STP; スパニング ツリー プロトコル)

サービス ポリシー

Quality of Service(QoS)

Access Control List(ACL; アクセス コントロール リスト)

インターフェイスが EtherChannel に参加または脱退しても、次のようなインターフェイス パラメータは影響を受けません。

説明

Cisco Discovery Protocol(CDP)

LACP ポート プライオリティ

デバウンス

レート モード

シャットダウン

SNMP トラップ

EtherChannel インターフェイスにインターフェイスが設定されていて、EtherChannel からメンバ ポートが削除されている場合、EtherChannel インターフェイスの設定はメンバ ポートに伝播されません。

EtherChannel インターフェイスに対し、互換性のあるパラメータに加えた設定変更は、その EtherChannel と同じチャネル グループ内のすべてのインターフェイスに伝播されます(たとえば、設定変更は、EtherChannel には含まれなくてもチャネル グループには含まれる物理インターフェイスにも伝播されます)。

次に、インターフェイスを active モードで LACP チャネル グループ 5 に追加する例を示します。

switch(config)# interface ethernet 1/1
switch(config-if)#
channel-group 5 mode active

関連コマンド

コマンド
説明

show interface port-channel

指定された EtherChannel インターフェイスのトラフィックに関する情報を表示します。

show lacp

LACP 情報を表示します。

show port-channel summary

EtherChannel に関する情報を表示します。

 

clear mac access-list counters

アクセス リストから統計情報をクリアするには、 clear mac access-list counters コマンドを使用します。

clear mac access-list counters [ name ]

シンタックスの説明

name

(任意)クリアする特定のカウンタの名前。

コマンドのデフォルト

なし

コマンド モード

EXEC モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

次に、アクセス リストから統計情報をクリアする例を示します。

switch# clear mac access-list counters

関連コマンド

コマンド
説明

show mac access-lists

MAC アドレス テーブルに関する情報を表示します。

 

clear mac address-table dynamic

MAC アドレス テーブルからダイナミック アドレス エントリをクリアするには、 clear mac address-table dynamic コマンドを使用します。

clear mac address-table dynamic [[ address mac-addr ] | [ interface { type slot / port | port-channel number }]] [ vlan vlan-id ]

シンタックスの説明

address mac-addr

(任意)テーブルから MAC アドレスを削除するように指定します。EEEE.EEEE.EEEE の形式を使用します。

interface type slot / port

(任意)テーブルから MAC アドレスを削除する必要があるインターフェイスを指定します。タイプは、 ethernet または port channel のいずれかにできます。適切なスロットまたは仮想インターフェイス グループ番号、およびポート番号を指定します。

port-channel number

(任意)テーブルから MAC アドレスを削除する必要がある EtherChannel を指定します。EtherChannel 番号を使用 します。

vlan vlan-id

(任意)テーブルから MAC アドレスを削除する必要がある VLAN を指定します。有効値の範囲は、1 ~ 4094 です。

コマンドのデフォルト

なし

コマンド モード

EXEC モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

4.2(1)N1(1)

コマンド構文が clear mac address-table dynamic に変更されました。

使用上のガイドライン

テーブルからすべてのダイナミック エントリを削除するには、引数を指定せずに、 clear mac address-table dynamic コマンドを使用します。

テーブルからスタティック MAC アドレスをクリアするには、 no mac address-table static コマンドを使用します。

オプションを指定しないで clear mac address-table dynamic コマンドを入力すると、すべてのダイナミック アドレスが削除されます。アドレスを指定してインターフェイスを指定しないと、すべてのインターフェイスからアドレスが削除されます。インターフェイスを指定してアドレスを指定しないと、スイッチによって指定のインターフェイス上のすべてのアドレスが削除されます。

次に、MAC アドレス テーブルからすべてのダイナミック エントリをクリアする例を示します。

switch# clear mac address-table dynamic
 

次に、VLAN 2 の MAC アドレス テーブルからすべてのダイナミック エントリをクリアする例を示します。

switch# clear mac address-table dynamic vlan 2
 

関連コマンド

コマンド
説明

show mac address-table

MAC アドレス テーブルに関する情報を表示します。

 

clear spanning-tree counters

スパニング ツリー プロトコル(STP)のカウンタをクリアするには、 clear spanning-tree counters コマンドを使用します。

clear spanning-tree counters [ interface { ethernet interface | port-channel channel }] [ vlan vlan-id ]

シンタックスの説明

interface

(任意)インターフェイス タイプを指定します。

ethernet interface

スロットおよびポート番号を指定します。

port-channel channel

EtherChannel 番号を指定します。

vlan vlan-id

(任意)VLAN を指定します。有効な範囲は 1 ~ 4094 です。

コマンドのデフォルト

なし

コマンド モード

EXEC モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

スイッチ全体、VLAN 単位、またはインターフェイス単位ですべての STP カウンタをクリアできます。

次に、VLAN 5 の STP カウンタをクリアする例を示します。

switch# clear spanning-tree counters vlan 5

関連コマンド

コマンド
説明

show spanning-tree

スパニング ツリー ステートに関する情報を表示します。

 

clear spanning-tree detected-protocol

プロトコル移行を再開するには、 clear spanning-tree detected-protocol コマンドを使用します。引数がない場合、コマンドはスイッチのすべてのポートに適用されます。

clear spanning-tree detected-protocol [ interface { ethernet interface | port-channel channel }]

シンタックスの説明

interface

(任意)インターフェイス タイプを指定します。

ethernet interface

スロットおよびポート番号を指定します。

port-channel channel

EtherChannel 番号を指定します。

コマンドのデフォルト

なし

コマンド モード

EXEC モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

Rapid per VLAN Spanning Tree Plus(Rapid PVST+)および Multiple Spanning Tree(MST; 多重スパニング ツリー)には、別バージョンの IEEE スパニング ツリーや別の領域との適切な対話が可能になる組み込みの互換性メカニズムがあります。たとえば、Rapid PVST+ を実行しているスイッチは、ポートの 1 つがレガシー デバイスに接続されている場合には、そのポートで 802.1D Bridge Protocol Data Unit(BPDU; ブリッジ プロトコル データ ユニット)を送信できます。MST スイッチは、レガシー BPDU または別の領域に関連する MST BPDU を受信すると、ポートが領域の境界にあることを検出できます。

これらのメカニズムにより、常に最も効率的なモードに戻れるわけではありません。たとえば、レガシー 802.1D ブリッジに指定された Rapid PVST+ スイッチは、レガシー ブリッジがリンクから取り外された後も 802.1D モードにとどまります。同様に、MST ポートは、接続先のブリッジが同じ領域に参加している場合には自身を境界ポートと見なします。

ポートがネイバーと再ネゴシエーションするように強制するには、 clear spanning-tree detected-protocol コマンドを使用します。

次に、特定のインターフェイスでプロトコル移行を再開する例を示します。

switch# clear spanning-tree detected-protocol interface ethernet 1/4

関連コマンド

コマンド
説明

show spanning-tree

スパニング ツリー ステートに関する情報を表示します。

 

delay(インターフェイス)

インターフェイスに遅延値を設定するには、 delay コマンドを使用します。デフォルトの遅延値に戻すには、このコマンドの no 形式を使用します。

delay tens-of-microseconds

no delay

シンタックスの説明

tens-of-microseconds

スループット遅延時間(10 マイクロ秒単位)。

コマンドのデフォルト

10 マイクロ秒

コマンド モード

インターフェイス コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

次に、インターフェイスに 30,000 マイクロ秒の遅延値を設定する例を示します。

switch(config)# interface ethernet 1/1
switch(config-if)# delay 3000

関連コマンド

コマンド
説明

show interface

インターフェイス コンフィギュレーション情報を表示します。

 

description(インターフェイス)

インターフェイス コンフィギュレーションに説明を追加するには、 description コマンドを使用します。説明を削除するには、このコマンドの no 形式を使用します。

description description

no description

シンタックスの説明

description

インターフェイス コンフィギュレーションを説明する文字列。最大文字数は 80 文字です。

コマンドのデフォルト

説明は追加されていません。

コマンド モード

インターフェイス コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

description コマンドは、特定のインターフェイスが何のために使用されているかを説明する注意書きをコンフィギュレーション中に提供するためにあります。この説明は、 show interface および show running-config などのコマンドの出力に表示されます。

次に、インターフェイスに説明を追加する例を示します。

switch(config)# interface ethernet 1/1
switch(config-if)# description "10G Server Link"

関連コマンド

コマンド
説明

show interface

インターフェイス コンフィギュレーション情報を表示します。

show running-config

現在実行中のコンフィギュレーション ファイルの内容を表示します。

 

errdisable detect cause

アプリケーションで errdisable 検出をイネーブルにするには、 errdisable detect cause コマンドを使用します。errdisable 検出をディセーブルにするには、このコマンドの no 形式を使用します。

errdisable detect cause {all | link-flap | loopback}

no errdisable detect cause {all | link-flap | loopback}

シンタックスの説明

 

all

すべての状況でエラー検出をイネーブルにします。

link-flap

リンクステート フラッピングの errdisable 検出をイネーブルにします。

loopback

ループバックの errdisable 検出をイネーブルにします。

コマンドのデフォルト

イネーブル

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

 

リリース
変更内容

4.2(1)N1(1)

このコマンドが追加されました。

使用上のガイドライン

errdisable 検出がイネーブルになっており、原因がインターフェイスで検出された場合、インターフェイスは errdisable ステートになります。これは、リンクダウン ステートに類似した動作ステートです。

次に、リンクステート フラッピングの errdisable 検出をイネーブルにする例を示します。

switch(config)# errdisable detect cause link-flap
switch(config)#
 

関連コマンド

 

コマンド
説明

errdisable recovery

errdisable ステートからの回復を設定します。

show interface status err-disabled

インターフェイスの errdisable ステートを表示します。

errdisable recovery cause

インターフェイスを errdisable ステートから解除し、アップ状態への移行をリトライするようにアプリケーションを設定するには、 errdisable recovery cause コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

errdisable recovery cause { all | bpduguard | link-flap-recovery | failed-port-state | pause-rate-limit | udld }

no errdisable recovery cause { all | bpduguard | link-flap-recovery | failed-port-state | pause-rate-limit | udld }

シンタックスの説明

 

all

すべての原因から回復するタイマーをイネーブルにします。

bpduguard

ブリッジ プロトコル データ ユニット(BPDU)ガード errdisable ステートから回復するタイマーをイネーブルにします。

failed-port-state

STP 設定ポート ステート障害から回復するタイマーをイネーブルにします。

link-flap

リンクステート フラッピングから回復するタイマーをイネーブルにします。

pause-rate-limit

ポーズ レート リミット errdisable ステートから回復するタイマーをイネーブルにします。

udld

UDLD errdisable ステートから回復するタイマーをイネーブルにします。

コマンドのデフォルト

なし

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

 

リリース
変更内容

4.2(1)N1(1)

このコマンドが追加されました。

使用上のガイドライン

errdisable 回復がイネーブルの場合、インターフェイスは自動的に errdisable ステートから回復し、デバイスによりインターフェイスのアップがリトライされます。

次に、リンクステート フラッピングからの errdisable 回復をイネーブルにする例を示します。

switch(config)# errdisable recovery cause link-flap
switch(config)#
 

関連コマンド

 

コマンド
説明

errdisable detect cause

errdisable(err-disabled)の検出をイネーブルにします。

show interface status err-disabled

インターフェイスの errdisable ステートを表示します。

errdisable recovery interval

インターフェイスを errdisable ステートから解除する回復時間の間隔を設定するには、 errdisable recovery interval コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

errdisable recovery interval time

no errdisable recovery interval

シンタックスの説明

 

time

errdisable 回復時間間隔。有効な範囲は 30 ~ 65535 秒です。

コマンドのデフォルト

ディセーブル

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

 

リリース
変更内容

4.2(1)N1(1)

このコマンドが追加されました。

使用上のガイドライン

errdisable 回復がイネーブルの場合、インターフェイスは自動的に errdisable ステートから回復し、デバイスによりインターフェイスのアップがリトライされます。

デバイスは 300 秒待機してからリトライします。

次に、errdisable 回復時間間隔を 100 秒でイネーブルにする例を示します。

switch(config)# errdisable recovery interval 100
switch(config)#
 

関連コマンド

 

コマンド
説明

errdisable recovery cause

インターフェイスでの errdisable 回復をイネーブルにします。

show interface status err-disabled

インターフェイスの errdisable ステートを表示します。

feature vtp

VLAN Trunking Protocol(VTP; VLAN トランキング プロトコル)をイネーブルにするには、 feature vtp コマンドを使用します。VTP をディセーブルにするには、このコマンドの no 形式を使用します。

feature vtp

no feature vtp

シンタックスの説明

このコマンドには、引数またはキーワードはありません。

コマンドのデフォルト

ディセーブル

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

 

リリース
変更内容

4.2(1)N1(1)

このコマンドが追加されました。

次に、スイッチで VTP をイネーブルにする例を示します。

switch(config)# feature vtp
 

関連コマンド

 

コマンド
説明

vtp

VTP を設定します。

show vtp status

VTP 情報を表示します。

instance vlan

VLAN または VLAN セットを Multiple Spanning Tree Instance(MSTI)にマッピングするには、 instance vlan コマンドを使用します。インスタンスを削除して、VLAN をデフォルト インスタンス(Common and Internal Spanning Tree(CIST))に戻すには、このコマンドの no 形式を使用します。

instance instance-id vlan vlan-id

no instance instance-id [ vlan vlan-id ]

シンタックスの説明

instance-id

指定の VLAN がマッピングされるインスタンス。有効値の範囲は、0 ~ 4094 です。

vlan vlan-id

指定の MSTI にマッピングする VLAN の番号を指定します。有効値の範囲は、1 ~ 4094 です。

コマンドのデフォルト

VLAN は MSTI にマッピングされません(すべての VLAN は CIST インスタンスにマッピングされます)。

コマンド モード

MST コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

VLAN 識別番号は、単一の値または範囲として入力します。

マッピングは、絶対的ではなく差分的に行われます。VLAN の範囲を入力すると、その範囲が既存のインスタンスに追加されるか、既存のインスタンスから削除されます。

マッピングされていない VLAN は、CIST インスタンスにマッピングされます。


注意 VLAN/MSTI マッピングを変更すると、MST は再起動されます。

次に、VLAN 範囲を MSTI 4 にマッピングする例を示します。

switch(config)# spanning-tree mst configuration
switch(config-mst)# instance 4 vlan 100-200

関連コマンド

コマンド
説明

show spanning-tree mst configuration

MST プロトコルに関する情報を表示します。

spanning-tree mst configuration

MST コンフィギュレーション モードを開始します。

interface ethernet

イーサネット IEEE 802.3 インターフェイスのインターフェイス コンフィギュレーション モードを開始するには、 interface ethernet コマンドを使用します。

interface ethernet [ chassis_ID /] slot / port

シンタックスの説明

chassis_ID

(任意)Fabric Extender シャーシ ID を指定します。シャーシ ID の範囲は、100 ~ 199 です。

(注) Cisco Nexus 2000 シリーズ Fabric Extender のホスト インターフェイスをアドレッシングする場合は、この引数は任意ではありません。

slot

1 ~ 3 のスロット。次のリストに使用可能なスロットを定義します。

スロット 1 にはすべての固定ポートが含まれます。Fabric Extender にあるのは、スロット 1 だけです。

スロット 2 には上位拡張モジュールのポートが含まれます(実装されている場合)。

スロット 3 には下位拡張モジュールのポートが含まれます(実装されている場合)。

port

特定のスロット内のポート番号を指定します。

コマンドのデフォルト

なし

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

4.0(1a)N2(1)

このコマンドは、シャーシ ID 引数を提供するように変更されました。

次に、イーサネット インターフェイス 1/4 でコンフィギュレーション モードを開始する例を示します。

switch(config)# interface ethernet 1/4
switch(config-if)#

次に、Fabric Extender のホスト インターフェイスでコンフィギュレーション モードを開始する例を示します。

switch(config)# interface ethernet 101/1/1
switch(config-if)#

関連コマンド

コマンド
説明

show fex

スイッチに接続されている、すべての設定済みの Fabric Extender シャーシを表示します。

show interface ethernet

イーサネット IEEE 802.3 インターフェイスの各種パラメータを表示します。

interface port-channel

EtherChannel インターフェイスを作成して、インターフェイス コンフィギュレーション モードを開始するには、 interface port-channel コマンドを使用します。EtherChannel インターフェイスを削除するには、このコマンドの no 形式を使用します。

interface port-channel channel-number

no interface port-channel channel-number

シンタックスの説明

channel-number

この EtherChannel 論理インターフェイスに割り当てられているチャネル番号。有効値の範囲は、1 ~ 4096 です。

コマンドのデフォルト

なし

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

ポートは、1 つのチャネル グループだけに属すことができます。

interface port-channel コマンドを使用する際には、次の注意事項に従ってください。

CDP を使用する場合は、EtherChannel インターフェイス上ではなく物理インターフェイス上だけで CDP を設定します。

EtherChannel インターフェイス上にスタティック MAC アドレスを割り当てない場合は、MAC アドレスが自動的に割り当てられます。スタティック MAC アドレスを割り当て、後で削除した場合は、MAC アドレスが自動的に割り当てられます。

EtherChannel の MAC アドレスは、チャネル グループに追加される最初の動作ポートのアドレスです。この最初に追加されたポートがチャネルから削除されると、次に追加された動作ポート(存在する場合)の MAC アドレスになります。

次に、チャネル グループ番号 50 を持つ EtherChannel グループ インターフェイスを作成する例を示します。

switch(config)# interface port-channel 50
switch(config-if)#
 

関連コマンド

コマンド
説明

show interface port-channel

指定の EtherChannel インターフェイスのトラフィックに関する情報を表示します。

show lacp

LACP 情報を表示します。

show port-channel summary

EtherChannel に関する情報を表示します。

 

ip igmp snooping(EXEC)

Internet Group Management Protocol(IGMP; インターネット グループ管理プロトコル)をイネーブルにするには、 ip igmp snooping コマンドを使用します。IGMP スヌーピングをディセーブルにするには、このコマンドの no 形式を使用します。

ip igmp snooping

no ip igmp snooping

シンタックスの説明

このコマンドには、引数またはキーワードはありません。

コマンドのデフォルト

IGMP スヌーピングはイネーブルです。


) グローバルな設定がディセーブルになっている場合は、すべての VLAN が、イネーブルかどうかに関係なくディセーブルと見なされます。


コマンド モード

EXEC モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

次に、IGMP スヌーピングをイネーブルにする例を示します。

switch# ip igmp snooping

関連コマンド

コマンド
説明

show ip igmp snooping

IGMP スヌーピング情報および設定を表示します。

 

ip igmp snooping(VLAN)

VLAN でインターネット グループ管理プロトコル(IGMP)を設定するには、 ip igmp snooping コマンドを使用します。コマンドを無効にするか、デフォルト設定に戻すには、このコマンドの no 形式を使用します。

ip igmp snooping parameter

no ip igmp snooping parameter

シンタックスの説明

parameter

設定するパラメータ。詳細情報については、「使用上のガイドライン」セクションを参照してください。

コマンドのデフォルト

デフォルト設定は、次のとおりです。

explicit-tracking :イネーブル

fast-leave :すべての VLAN についてディセーブル

last-member-query-interval seconds :1

querier IP-address :ディセーブル

report-suppression :イネーブル

コマンド モード

VLAN コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

表 2-1 に、 parameter の有効値を示します。

 

表 2-1 IGMP スヌーピング パラメータ

キーワードおよび引数
説明

explicit-tracking

VLAN ベースで各ポートの IGMPv3 メンバシップ レポートのトラッキングをイネーブルにします。デフォルトは、すべての VLAN でイネーブルです。

fast-leave

IGMPv3 スヌーピングの高速脱退処理をイネーブルにします。デフォルトは、すべての VLAN でディセーブルです。

last-member-query-interval seconds

すべてのホストが IGMP クエリー メッセージに応答しない場合は、グループを削除します。有効値は 1 ~ 25 秒です。デフォルトは 1 秒です。

mrouter interface interface

マルチキャスト ルータへのスタティック接続を設定します。指定のインターフェイスは、イーサネットまたは EtherChannel です。

querier IP-address

スヌーピング クエリアを設定します。IP アドレスは、メッセージの送信元として使用します。デフォルトはディセーブルです。

report-suppression

マルチキャスト対応ルータに送信されるメンバシップ レポート トラフィックを制限します。レポート抑制をディセーブルにすると、すべての IGMP レポートがそのままマルチキャスト対応ルータに送信されます。デフォルトはイネーブルです。

static-group group-ip-addr [ source source-ip-addr ] interface interface

VLAN に属するインターフェイスを、マルチキャスト グループのスタティック メンバとして設定します。指定のインターフェイスは、イーサネットまたは EtherChannel です。

次に、VLAN 5 の IGMP スヌーピング パラメータを設定する例を示します。

switch# configure terminal
switch(config)# vlan 5
switch(config-vlan)# ip igmp snooping last-member-query-interval 3
switch(config-vlan)# ip igmp snooping querier 192.168.2.106
switch(config-vlan)# ip igmp snooping explicit-tracking
switch(config-vlan)# ip igmp snooping fast-leave
switch(config-vlan)# ip igmp snooping report-suppression
switch(config-vlan)# ip igmp snooping mrouter interface ethernet 1/10
switch(config-vlan)# ip igmp snooping static-group 192.168.1.1 interface ethernet 1/10

関連コマンド

コマンド
説明

show ip igmp snooping

IGMP スヌーピング情報および設定を表示します。

 

lacp port-priority

Link Aggregation Control Protocol(LACP)の物理インターフェイスのプライオリティを設定するには、 lacp port-priority コマンドを使用します。ポート プライオリティをデフォルト値に戻すには、このコマンドの no 形式を使用します。

lacp port-priority priority

no lacp port-priority

シンタックスの説明

priority

物理インターフェイスのプライオリティ。有効な番号の範囲は、1 ~ 65535 です。

コマンドのデフォルト

システム プライオリティ値は 32768 です。

コマンド モード

インターフェイス コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

LACP を使用するように設定されたポートにはそれぞれ LACP ポート プライオリティがあります。1 ~ 65535 の値を設定できます。LACP は、このポート プライオリティとポート番号を組み合せてポート ID を生成します。ポート プライオリティは、ポート ID を作成するためにポート番号とともに使用されます。ポート プライオリティは、ハードウェアに制約があることが原因で互換性のあるポートをすべて集約できない場合、どのポートをスタンバイ モードにする必要があるかを決めるために使用されます。


) プライオリティを設定するときには、番号が大きいほどプライオリティが低くなることに注意してください。


次に、インターフェイスの LACP ポート プライオリティを 2000 に設定する例を示します。

switch(config-if)# lacp port-priority 2000

関連コマンド

コマンド
説明

show lacp

LACP 情報を表示します。

 

lacp system-priority

スイッチの Link Aggregation Control Protocol(LACP)システム プライオリティを設定するには、 lacp system-priority コマンドを使用します。システム プライオリティをデフォルト値に戻すには、このコマンドの no 形式を使用します。

lacp system-priority priority

no lacp system-priority

シンタックスの説明

priority

物理インターフェイスのプライオリティ。有効な番号の範囲は、1 ~ 65535 です。

コマンドのデフォルト

システム プライオリティ値は 32768 です。

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

LACP を実行するどのデバイスにも LACP システム プライオリティ値があります。1 ~ 65535 の値を設定できます。LACP は、このシステム プライオリティと MAC アドレスを組み合せてシステム ID を生成します。また、他のシステムとのネゴシエーション中にもシステム プライオリティを使用します。

プライオリティを設定するときには、番号が 大きい ほどプライオリティが 低く なることに注意してください。

次に、デバイスの LACP システム プライオリティを 2500 に設定する例を示します。

switch(config)# lacp system-priority 2500

関連コマンド

コマンド
説明

show lacp

LACP 情報を表示します。

 

link debounce

インターフェイス上のデバウンス タイマーをイネーブルにするには、 link debounce コマンドを使用します。このタイマーをディセーブルにするには、このコマンドの no 形式を使用します。

link debounce [ time milliseconds ]

no link debounce

シンタックスの説明

time milliseconds

(任意)拡張デバウンス タイマーを指定します。有効値は、0 ~ 5000 ミリ秒です。値を 0 ミリ秒にした場合は、デバウンス時間はディセーブルになります。

コマンドのデフォルト

なし

コマンド モード

インターフェイス コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

ポート デバウンス時間は、リンクがダウンしたことをスーパーバイザに通知するためにインターフェイスが待機する時間です。この時間、インターフェイスはリンクがアップ状態に戻ったかどうかを確認するために待機します。待機時間は、トラフィックが停止している時間です。


注意 デバウンス タイマーをイネーブルにすると、リンクのアップおよびリンクのダウンの検出が遅れるため、デバウンス時間中にトラフィックが失われます。この状況は、一部のプロトコルの収束に影響する場合があります。

次の例は、イーサネット インターフェイスでデバウンス タイマーをイネーブルにして、デバウンス時間を 1000 ミリ秒に設定する方法を示しています。

switch# configure terminal
switch(config)# interface ethernet 1/1
switch(config-if)# link debounce time 1000

次の例は、イーサネット インターフェイスでデバウンス タイマーをディセーブルにする方法を示しています。

switch(config-if)# no link debounce

関連コマンド

コマンド
説明

show interface

インターフェイス コンフィギュレーション情報を表示します。

mac address-table aging-time

MAC アドレス テーブルのエントリのエージング タイムを設定するには、 mac address-table aging-time コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

mac address-table aging-time seconds [ vlan vlan-id ]

no mac address-table aging-time [ vlan vlan-id ]

シンタックスの説明

seconds

MAC アドレス テーブル エントリのエージング タイム。有効な範囲は 0 ~ 1000000 秒です。デフォルトは 1,800 秒です。0 を入力すると、MAC アドレス エージングはディセーブルになります。

vlan vlan-id

(任意)変更されたエージング タイムを適用する VLAN を指定します。

コマンドのデフォルト

300 秒

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

4.2(1)N1(1)

コマンド構文が mac address-table aging-time に変更されました。

使用上のガイドライン

エージング プロセスをディセーブルにするには、0 秒を入力します。

エージング値は、5 秒の倍数に最も近い値に丸められます。システムによって丸められた値が、ユーザが指定した(丸め処理による)値と異なる場合、システムから情報メッセージが返されます。

このコマンドを EXEC モードで使用すると、設定を指定していないすべての VLAN のエージング値が変更され、個別にエージング タイムを変更した VLAN は変更されません。VLAN パラメータなしでこのコマンドの no 形式を使用すると、個別にエージング タイムが設定されていない VLAN だけがデフォルト値にリセットされます。個別にエージング タイムが変更されている VLAN は変更されません。

このコマンドを使用して VLAN を指定すると、指定した VLAN のエージング タイムだけが変更されます。このコマンドの no 形式を使用して VLAN を指定すると、VLAN のエージング タイムが現在のエージング タイムのグローバル設定に戻ります。デフォルト値の 300 秒に戻るかどうかは、スイッチのエージング タイムのグローバル設定の変更の有無に応じて異なります。

エージング タイムは、スイッチが最後に MAC アドレスを検出した時点からカウントされます。

次に、スイッチ全体でエントリが MAC アドレス テーブルにとどまる時間を 500 秒に変更する例を示します。

switch(config)# mac address-table aging-time 500

関連コマンド

コマンド
説明

show mac address-table

MAC アドレス テーブルに関する情報を表示します。

show mac address-table aging-time

MAC アドレスのエージング タイムに関する情報を表示します。

 

mac address-table notification

MAC アドレス テーブル イベントのログ メッセージ通知を設定するには、 mac address-table notification コマンドを使用します。ログ メッセージ通知をディセーブルにするには、このコマンドの no 形式を使用します。

mac address-table notification { mac-move | threshold [ limit percentage interval seconds ]}

no mac address-table notification { mac-move | threshold }

シンタックスの説明

mac-move

MAC アドレスが移動された場合に、通知メッセージを送信します。

threshold

MAC アドレス テーブルのしきい値を超えた場合に、通知メッセージを送信します。

limit percentage

(任意)割合の限界(1 ~ 100)を指定します。この割合を超えた時点でしきい値の通知がイネーブルになります。

interval seconds

(任意)2 つの通知間の最小時間を秒単位で指定します(10 ~ 10000 秒)。

コマンドのデフォルト

なし

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

4.2(1)N1(1)

コマンド構文が mac address-table notification に変更されました。

次に、しきい値が 45% を超えたときにログ メッセージ通知が送信され、アップデート間隔が 1024 秒に 1 回に制限されるように設定する例を示します。

switch(config)# mac address-table notification threshold limit 45 interval 1024

関連コマンド

コマンド
説明

show mac address-table

MAC アドレス テーブルに関する情報を表示します。

 

mac address-table static

MAC アドレス テーブルのスタティック エントリを設定するには、 mac address-table static コマンドを使用します。スタティック エントリを削除するには、このコマンドの no 形式を使用します。

mac address-table static mac-address vlan vlan-id { drop | interface { ethernet slot / port | port-channel number [ . subinterface-number ]} [ auto-learn ]

no mac address-table static mac-address { vlan vlan-id }

シンタックスの説明

mac-address

テーブルに追加する MAC アドレス。EEEE.EEEE.EEEE の形式を使用します。

vlan vlan-id

スタティック MAC アドレスを適用する VLAN を指定します。有効値は、1 ~ 4094 です。

drop

指定された VLAN 内の設定済みの MAC アドレスとの間で送受信されるすべてのトラフィックをドロップします。

interface

インターフェイスを指定します。タイプは、イーサネットまたは Ethernet のいずれかです。

ethernet slot / port

イーサネット インターフェイスおよび適切なスロット番号とポート番号を指定します。スロット番号は 1 ~ 255、ポート番号は 1 ~ 128 です。

port-channel number

EtherChannel インターフェイスおよび EtherChannel 番号を指定します。有効な範囲は 1 ~ 4096 です。

. subinterface-number

EtherChannel 番号とその後ろに続くドット(.)インジケータ、およびサブインターフェイス番号。

auto-learn

(任意)スイッチによりこの MAC アドレスが自動的にアップデートされるようにします。

コマンドのデフォルト

なし

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

4.2(1)N1(1)

コマンド構文が mac address-table static に変更されました。

使用上のガイドライン

マルチキャスト MAC アドレスには、 mac address-table static mac-address vlan vlan-id drop コマンドは適用できません。

スタティック MAC アドレスをインストールすると、スタティック MAC アドレスはポートに関連付けられます。別のポートに同じ MAC アドレスが表示される場合には、 auto-learn キーワードを入力すると、エントリが新しいポートによってアップデートされます。

次に、MAC アドレス テーブルにスタティック エントリを追加する例を示します。

switch(config)# mac address-table static 0050.3e8d.6400 vlan 3 interface ethernet 1/4

関連コマンド

コマンド
説明

show mac address-table

MAC アドレス テーブルに関する情報を表示します。

 

monitor session

新しい SPAN セッション設定を作成する場合、または既存のセッション設定に追加する場合は、 monitor session コマンドを使用します。SPAN セッションをクリアするには、このコマンドの no 形式を使用します。

monitor session { number [ shut | type local ] | all shut }

no monitor session { number | all } [ shut ]

シンタックスの説明

number

作成または設定する SPAN セッション。有効な範囲は 1 ~ 18 です。

all

コンフィギュレーション情報をすべての SPAN セッションに適用するように指定します。

shut

(任意)選択されたセッションがモニタリングのためにシャットダウンされるように指定します。

type

(任意)設定するセッションのタイプを指定します。

local

セッション タイプをローカルに指定します。

コマンドのデフォルト

なし

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

4.2(1)N1(1)

monitor session { number | all } suspend コマンドが廃棄されました。

monitor session { number | all } shut および monitor session { number | all } type コマンドが追加されました。

使用上のガイドライン

完全に新しいセッションを処理していることを確認するために、任意のセッション番号またはすべての SPAN セッションをクリアできます。

次に、SPAN セッションを作成する例を示します。

switch# configure terminal
switch(config)# monitor session 2

関連コマンド

コマンド
説明

show monitor session

SPAN セッションのコンフィギュレーション情報を表示します。

 

name(VLAN コンフィギュレーション)

VLAN の名前を設定するには、 name コマンドを使用します。ユーザが設定した名前を VLAN から削除するには、このコマンドの no 形式を使用します。

name vlan-name

no name

シンタックスの説明

vlan-name

VLAN の名前。最大で 32 文字の英数字を使用でき、大文字と小文字が区別されます。デフォルトの名前は VLAN xxxx で、 xxxx は VLAN ID 番号と同じ 4 桁の数値(先行ゼロを含む)です(たとえば VLAN0002)。

コマンドのデフォルト

なし

コマンド モード

VLAN コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

デフォルト VLAN、VLAN 1、または内部的に割り当てられている VLAN の名前は変更できません。

次に、VLAN 2 に名前を付ける例を示します。

switch(config)# vlan 2
switch(config-vlan)# name accounting

関連コマンド

コマンド
説明

show vlan

VLAN 情報を表示します。

 

name(MST コンフィギュレーション)

多重スパニング ツリー(MST)領域の名前を設定するには、 name コマンドを使用します。デフォルト名に戻すには、このコマンドの no 形式を使用します。

name name

no name name

シンタックスの説明

name

MST 領域に割り当てる名前。最大 32 文字の英数字からなる任意の文字列にできます。

コマンドのデフォルト

なし

コマンド モード

MST コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

同じ VLAN マッピングと設定バージョン番号を持つ 2 台以上のスイッチは、領域名が異なる場合には、別々の MST 領域にあると見なされます。


注意 name コマンドを使用して MST 領域名を設定する場合には注意してください。設定を間違えると、スイッチが別の領域に配置されてしまう可能性があります。設定名は、大文字と小文字が区別されるパラメータです。

次に、領域に名前を付ける例を示します。

switch(config)# spanning-tree mst configuration
switch(config-mst)# name accounting

関連コマンド

コマンド
説明

show spanning-tree mst configuration

MST プロトコルに関する情報を表示します。

spanning-tree mst configuration

MST コンフィギュレーション モードを開始します。

 

port-channel load-balance ethernet

チャネルグループ バンドルのインターフェイス間でロード バランシング方式を設定するには、 port-channel load-balance ethernet コマンドを使用します。システム プライオリティをデフォルト値に戻すには、このコマンドの no 形式を使用します。

port-channel load-balance ethernet method

no port-channel load-balance ethernet [ method ]

シンタックスの説明

method

ロード バランシング方式。有効値のリストについては、「使用上のガイドライン」セクションを参照してください。

コマンドのデフォルト

送信元および宛先 MAC アドレスの負荷分散。

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

有効なロード バランシング method 値は、次のとおりです。

destination-ip :宛先 IP アドレスの負荷分散。

destination-mac :宛先 MAC アドレスの負荷分散。

destination-port :宛先ポートの負荷分散。

source-destination-ip :送信元および宛先 IP アドレスの負荷分散。

source-destination-mac :送信元および宛先 MAC アドレスの負荷分散。

source-destination-port :送信元および宛先ポートの負荷分散。

source-ip :送信元 IP アドレスの負荷分散。

source-mac :送信元 MAC アドレスの負荷分散。

source-port :送信元ポートの負荷分散。

使用している設定で最も多様なバランス基準を提供するオプションを使用してください。たとえば、ある EtherChannel のトラフィックが単一の MAC アドレスだけに送信されている場合に、宛先 MAC アドレスを EtherChannel のロード バランシングの基準として使用すると、EtherChannel 内で常に同じリンクが選択されます。送信元アドレスまたは IP アドレスを使用すると、ロード バランシングが向上する場合があります。

次に、送信元 IP を使用するロード バランシング方式を設定する例を示します。

switch(config)# port-channel load-balance ethernet source-ip

関連コマンド

コマンド
説明

show port-channel load-balance

EtherChannel ロード バランシングに関する情報を表示します。

 

private-vlan

プライベート VLAN を設定するには、 private-vlan コマンドを使用します。指定の VLAN を標準 VLAN モードに戻すには、このコマンドの no 形式を使用します。

private-vlan { isolated | community | primary }

no private-vlan { isolated | community | primary }

シンタックスの説明

isolated

VLAN を独立セカンダリ VLAN として指定します。

community

VLAN をコミュニティ セカンダリ VLAN として指定します。

primary

VLAN をプライマリ VLAN として指定します。

コマンドのデフォルト

なし

コマンド モード

VLAN コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

プライベート VLAN を設定する前に、 feature private-vlan コマンドを使用してプライベート VLAN をイネーブルにする必要があります。プライベート VLAN をイネーブルにするまで、プライベート VLAN を設定するためのコマンドは表示されません。

プライマリ VLAN またはセカンダリ VLAN を削除すると、その VLAN に関連付けされたポートは非アクティブになります。 no private-vlan コマンドを入力すると、VLAN は通常の VLAN モードに戻ります。その VLAN におけるすべてのプライマリとセカンダリの関連付けは一時停止しますが、インターフェイスはプライベート VLAN モードのままです。指定の VLAN をプライベート VLAN モードに再変換すると、元の関連付けが回復します。

プライマリ VLAN に対して no vlan コマンドを入力すると、その VLAN に関連付けされたすべてのプライベート VLAN は失われます。セカンダリ VLAN に対して no vlan コマンドを入力した場合、その VLAN とプライベート VLAN の関連付けは一時停止します。指定の VLAN を再作成して以前のセカンダリ VLAN として設定すると再度イネーブルになります。

VLAN1 または内部的に割り当てられている VLAN は、プライベート VLAN として設定できません。

プライベート VLAN は、VLAN 番号ペアの共通セットを使用することを特徴とするプライベート ポートのセットです。各ペアは、少なくとも 2 つの特別な単方向 VLAN から構成され、ルータと通信するために独立ポートまたはコミュニティ ポート(またはその両方)により使用されます。

独立 VLAN は、混合モード ポートと通信するために独立ポートにより使用される VLAN です。独立 VLAN のトラフィックは、同じ VLAN のその他すべてのプライベート ポートでブロックされます。独立 VLAN のトラフィックは、対応するプライマリ VLAN に割り当てられた標準トランキング ポートおよび混合モード ポートだけが受信できます。

混合モード ポートは、プライマリ VLAN に割り当てられたプライベート ポートとして定義されています。

コミュニティ VLAN は、対応するプライマリ VLAN 上にある、コミュニティポート間のトラフィックおよびコミュニティ ポートから混合モード ポートへのトラフィックを運ぶ VLAN として定義されています。

プライマリ VLAN は、トラフィックをルータからプライベート ポート上のカスタマー エンド ステーションへ伝送するために使用される VLAN として定義されています。

複数のコミュニティ VLAN および独立 VLAN が許可されています。プライマリ VLAN の範囲を入力すると、システムによって範囲の最初の番号が関連付けに使用されます。


) 現行リリースの Cisco NX-OS を実行している Cisco Nexus 5000 シリーズ スイッチのプライベート VLAN 独立ポートは、IEEE 802.1Q のカプセル化をサポートしておらず、トランク ポートとして使用できません。


次の例は、VLAN 5 をプライマリ VLAN としてプライベート VLAN に割り当てる方法を示しています。

switch# configure terminal
switch(config)# vlan 5
switch(config-vlan)# private-vlan primary

次の例は、VLAN 100 をコミュニティ VLAN としてプライベート VLAN に割り当てる方法を示しています。

switch(config-vlan)# exit
switch(config)# vlan 100
switch(config-vlan)# private-vlan community

次の例は、VLAN 109 を独立 VLAN としてプライベート VLAN に割り当てる方法を示しています。

switch(config-vlan)# exit
switch(config)# vlan 109
switch(config-vlan)# private-vlan isolated

関連コマンド

コマンド
説明

feature private-vlan

プライベート VLAN をイネーブルにします。

show vlan

VLAN の情報を表示します。

show vlan private-vlan

プライベート VLAN の情報を表示します。

 

private-vlan association

プライベート VLAN 上のプライマリ VLAN とセカンダリ VLAN 間の関連付けを設定するには、 private-vlan association コマンドを使用します。関連付けを削除するには、このコマンドの no 形式を使用します。

private-vlan association {[ add ] secondary-vlan-list | remove secondary-vlan-list }

no private-vlan association

シンタックスの説明

add

(任意)セカンダリ VLAN をプライマリ VLAN に関連付けます。

secondary-vlan-list

セカンダリ VLAN の番号。

remove

セカンダリ VLAN とプライマリ VLAN 間の関連付けをクリアします。

コマンドのデフォルト

なし

コマンド モード

VLAN コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

プライベート VLAN を設定する前に、 feature private-vlan コマンドを使用してプライベート VLAN をイネーブルにする必要があります。プライベート VLAN をイネーブルにするまで、プライベート VLAN を設定するためのコマンドは表示されません。

プライマリ VLAN またはセカンダリ VLAN を削除すると、その VLAN に関連付けされたポートは非アクティブになります。 no private-vlan コマンドを入力すると、VLAN は通常の VLAN モードに戻ります。その VLAN におけるすべてのプライマリとセカンダリの関連付けは一時停止しますが、インターフェイスはプライベート VLAN モードのままです。ただし、指定の VLAN をプライベート VLAN モードに再変換すると、元の関連付けが回復します。

プライマリ VLAN に対して no vlan コマンドを入力すると、その VLAN に関連付けされたすべてのプライベート VLAN は失われます。ただし、セカンダリ VLAN に対して no vlan コマンドを入力した場合、その VLAN とプライベート VLAN の関連付けは一時停止します。この VLAN を再作成して以前のセカンダリ VLAN として設定すると元に戻ります。

secondary-vlan-list 引数にスペースを含めることはできません。カンマで区切った複数の項目を含めることができます。各項目は、単一のセカンダリ VLAN ID、またはセカンダリ VLAN ID をハイフンでつないだ範囲にできます。 secondary-vlan-list パラメータには、複数のセカンダリ VLAN ID を含めることができます。

プライベート VLAN は、VLAN 番号ペアの共通セットを使用することを特徴とするプライベート ポートのセットです。各ペアは、少なくとも 2 つの特別な単方向 VLAN から構成され、ルータと通信するために独立ポートまたはコミュニティ ポート(またはその両方)により使用されます。

複数のコミュニティ VLAN および独立 VLAN が許可されています。プライマリ VLAN の範囲を入力すると、システムによって範囲の最初の番号が関連付けに使用されます。

独立 VLAN およびコミュニティ VLAN は、1 つのプライマリ VLAN とだけ関連付けられます。すでにプライマリ VLAN としてプライマリ VLAN に関連付けられている VLAN は設定できません。


) 現行リリースの Cisco NX-OS を実行している Cisco Nexus 5000 シリーズ スイッチのプライベート VLAN 独立ポートは、IEEE 802.1Q のカプセル化をサポートしておらず、トランク ポートとして使用できません。


次に、プライマリ VLAN 14、独立 VLAN 19、およびコミュニティ VLAN 20 と 21 間のプライベート VLAN 関係を作成する例を示します。

switch(config)# vlan 19
switch(config-vlan)# private-vlan isolated
switch(config)# vlan 20
switch(config-vlan)# private-vlan community
switch(config)# vlan 21
switch(config-vlan)# private-vlan community
switch(config)# vlan 14
switch(config-vlan)# private-vlan primary
switch(config-vlan)# private-vlan association 19-21

次に、プライベート VLAN の関連付けから独立 VLAN 18 およびコミュニティ VLAN 20 を削除する例を示します。

switch(config)# vlan 14
switch(config-vlan)# private-vlan association remove 18,20

関連コマンド

コマンド
説明

feature private-vlan

プライベート VLAN をイネーブルにします。

show vlan

VLAN の情報を表示します。

show vlan private-vlan

プライベート VLAN の情報を表示します。

 

private-vlan synchronize

セカンダリ VLAN をプライマリ VLAN として同じ多重スパニング ツリー(MST)インスタンスにマッピングするには、 private-vlan synchronize コマンドを使用します。

private-vlan synchronize

シンタックスの説明

このコマンドには、キーワードと引数はありません。

コマンドのデフォルト

なし

コマンド モード

MST コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

MST コンフィギュレーション モードの終了時に、関連付けられたプライマリ VLAN としてセカンダリ VLAN を同じ MST インスタンスにマッピングしていない場合、関連付けられた VLAN として同じインスタンスにマッピングされていないセカンダリ VLAN を一覧表示した警告メッセージがデバイスに表示されます。 private-vlan synchronize コマンドにより、すべてのセカンダリ VLAN が、関連付けられたプライマリ VLAN として自動的に同じインスタンスにマッピングされます。

次に、プライベート VLAN 同期を初期化する例を示します。

switch(config)# spanning-tree mst configuration
switch(config-mst)# private-vlan synchronize

関連コマンド

コマンド
説明

show spanning-tree mst configuration

MST プロトコルに関する情報を表示します。

spanning-tree mst configuration

MST コンフィギュレーション モードを開始します。

 

revision

多重スパニング ツリー(MST)領域設定のリビジョン番号を設定するには、 revision コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

revision version

no revision version

シンタックスの説明

version

MST 領域設定のリビジョン番号。有効値の範囲は 0 ~ 65535 です。

コマンドのデフォルト

リビジョン 0

コマンド モード

MST コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

同一の VLAN マッピングおよび名前を持つ 2 台以上のスイッチは、設定リビジョン番号が異なる場合には、異なる MST 領域にあると見なされます。


注意 設定を間違えるとスイッチが別の領域に配置されてしまう可能性があるため、revision コマンドを使用して MST 領域設定のリビジョン番号を設定する場合は注意してください。

次に、MST 領域設定のリビジョン番号を設定する例を示します。

switch(config)# spanning-tree mst configuration
switch(config-mst)# revision 5

関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

 

shutdown(VLAN コンフィギュレーション)

VLAN 上のローカル トラフィックをシャットダウンするには、 shutdown コマンドを使用します。VLAN をデフォルトの動作ステートに戻すには、このコマンドの no 形式を使用します。

shutdown

no shutdown

シンタックスの説明

このコマンドには、引数またはキーワードはありません。

コマンドのデフォルト

シャットダウンしません。

コマンド モード

VLAN コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

VLAN 1 または VLAN 1006 ~ 4094 は、シャットダウンしたりディセーブルにしたりできません。

VLAN をシャットダウンすると、その VLAN 上でのトラフィック フローが終了します。その VLAN 上のアクセス ポートもダウンします。トランク ポートは、そのポートで許可されている他の VLAN へのトラフィック伝送を継続します。ただし、指定の VLAN のインターフェイス関連付けは保持されます。その指定の VLAN を再度イネーブルにするか再作成すると、スイッチによってその VLAN の元のポートがすべて自動的に復元されます。

VLAN が内部的にシャットダウンされているかどうかを調べるには、 show vlan コマンド出力の Status フィールドを確認します。VLAN が内部的にシャットダウンされている場合は、Status フィールドに次の値のいずれか 1 つが表示されます。

act/lshut:VLAN ステータスはアクティブで、内部的にシャットダウンされています。

sus/lshut:VLAN ステータスは一時停止で、内部的にシャットダウンされています。


) VLAN が一時停止およびシャットダウンされている場合は、no shutdown および state active コマンドの両方を使用して VLAN をアクティブ ステートに戻します。


次に、VLAN をシャットダウンまたはディセーブルにした後、VLAN 2 上のローカル トラフィックを復元する例を示します。

switch(config)# vlan 2
switch(config-vlan)# no shutdown

関連コマンド

コマンド
説明

show vlan

VLAN 情報を表示します。

spanning-tree bpdufilter

インターフェイス上でブリッジ プロトコル データ ユニット(BPDU)フィルタリングをイネーブルにするには、 spanning-tree bpdufilter コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree bpdufilter { enable | disable }

no spanning-tree bpdufilter

シンタックスの説明

enable

このインターフェイスで BPDU フィルタリングをイネーブルにします。

disable

このインターフェイスで BPDU フィルタリングをディセーブルにします。

コマンドのデフォルト

spanning-tree port type edge bpdufilter default コマンドの入力時点ですでに設定されている設定。

コマンド モード

インターフェイス コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

spanning-tree bpdufilter enable コマンドを入力して BPDU フィルタリングをイネーブルにすると、スパニング ツリー エッジ ポート設定が上書きされます。そのポートは、標準スパニング ツリーポート タイプに戻り、標準スパニング ツリーの移行が行われます。


注意 指定インターフェイスで spanning-tree bpdufilter enable コマンドを入力するときは注意してください。ホストに接続されていないポート上で BPDU フィルタリングを明示的に設定すると、そのポートはすべての受信 BPDU を無視することになるため、ブリッジング ループが生じ、ポートが STP フォワーディング ステートに移行する可能性があります。

すべてのスパニング ツリー エッジ ポート上で BPDU フィルタリングをイネーブルにするには、 spanning-tree port type edge bpdufilter default コマンドを使用します。

次に、スパニング ツリー エッジ ポート Ethernet 1/4 で BPDU フィルタリングを明示的にイネーブルにする例を示します。

switch (config)# interface ethernet 1/4
switch(config-if)# spanning-tree bpdufilter enable

関連コマンド

コマンド
説明

show spanning-tree summary

スパニング ツリー ステートに関する情報を表示します。

spanning-tree bpduguard

インターフェイス上でブリッジ プロトコル データ ユニット(BPDU)ガードをイネーブルにするには、 spanning-tree bpduguard コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree bpduguard { enable | disable }

no spanning-tree bpduguard

シンタックスの説明

enable

このインターフェイスで BPDU ガードをイネーブルにします。

disable

このインターフェイスで BPDU ガードをディセーブルにします。

コマンドのデフォルト

spanning-tree port type edge bpduguard default コマンドの入力時点ですでに設定されている設定。

コマンド モード

インターフェイス コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

BPDU ガードにより、ポートは BPDU を受信しなくなります。ポートが引き続き BPDU を受信する場合は、保護対策としてポートが errdisable ステートになります。


注意 このコマンドを使用するときは注意してください。このコマンドは、端末に接続するインターフェイスに限って使用する必要があります。そうしないと、偶発的なトポロジ ループが原因でデータ パケット ループが発生し、スイッチおよびネットワークの動作が中断する可能性があります。

この BPDU ガード コマンドをグローバルにイネーブルにすると、スパニング ツリー エッジ ポートだけにこのコマンドが適用されます。BPDU ガードのグローバル コマンドについての詳細は、 spanning-tree port type edge bpduguard default コマンドを参照してください。一方、インターフェイス上でこの機能をイネーブルにすると、スパニング ツリー ポート タイプにかかわらず、そのインターフェイスに機能が適用されます。

このコマンドには次の 3 つの状態があります。

spanning-tree bpduguard enable 指定インターフェイスで BPDU ガードを無条件にイネーブルにします。

spanning-tree bpduguard disable 指定インターフェイスで BPDU ガードを無条件にディセーブルにします。

no spanning-tree bpduguard インターフェイスが動作中のスパニング ツリー エッジ ポートであり、 spanning-tree port type edge bpduguard default コマンドが設定されていれば、インターフェイス上で BPDU ガードをイネーブルにします。

通常、この機能は、アクセス ポートがスパニング ツリーに参加しないようにネットワーク管理者によって設定されるサービス プロバイダーの環境で使用されます。

次に、このインターフェイス上で BPDU ソース ガードをイネーブルにする例を示します。

switch(config-if)# spanning-tree bpduguard enable

関連コマンド

コマンド
説明

show spanning-tree summary

スパニング ツリー ステートに関する情報を表示します。

 

spanning-tree cost

スパニング ツリー プロトコル(STP)計算用にインターフェイスのパス コストを設定するには、 spanning-tree cost コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree [ vlan vlan-id ] cost { value | auto }

no spanning-tree [ vlan vlan-id ] cost

シンタックスの説明

vlan vlan-id

(任意)パス コストを割り当てるこのトランク インターフェイス上の VLAN のリストを示します。このパラメータは、アクセス ポートでは使用しません。有効な範囲は 1 ~ 4094 です。

value

ポート コストの値。使用可能なコスト範囲は、次のようにパス コスト計算方式によって異なります。

short:有効な範囲は 1 ~ 65536 です。

long:有効な範囲は 1 ~ 200,000,000 です。

auto

インターフェイスのメディア速度によってポート コストの値を設定します(値については、 表 2-2 を参照してください)。

コマンドのデフォルト

メディア速度によってポート コストが設定されます。

コマンド モード

インターフェイス コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

STP ポートのパス コストのデフォルト値は、LAN インターフェイスのメディア速度およびパス コスト計算方式で決まります( 表 2-2 を参照)。Rapid per VLAN Spanning Tree Plus(Rapid PVST+)のパス コスト計算方式の設定については、 spanning-tree pathcost method コマンドを参照してください。

 

表 2-2 デフォルト ポート コスト

帯域幅
ショート パス コスト方式のポート コスト
ロング パス コスト方式のポート コスト

10 Mbps

100

2,000,000

100 Mbps

19

200,000

1 ギガビット イーサネット

4

20,000

10 ギガビット イーサネット

2

2,000

value を設定するときは、高い値ほどコストが高くなります。

アクセス ポートでは、ポート コストをポートごとに割り当てます。トランク ポートでは、ポート コストを VLAN ごとに割り当てます。トランク ポートのすべての VLAN を同じポート コストに設定できます。

EtherChannel バンドルは、単一ポートと見なされます。ポート コストは、そのチャネルに割り当てられている設定済みのすべてのポート コストの合計です。


) このコマンドを使用して Rapid PVST+ のポート コストを設定します。MST のポート コストを設定するには、spanning-tree mst cost コマンドを使用します。


次に、インターフェイスにアクセスして、そのインターフェイスに関連付けられているスパニング ツリー VLAN にパス コスト値 250 を設定する例を示します。

switch(config)# interface ethernet 1/4
switch(config-if)# spanning-tree cost 250

関連コマンド

コマンド
説明

show spanning-tree

スパニング ツリー設定に関する情報を表示します。

 

spanning-tree guard

ループ ガードまたはルート ガードをイネーブルまたはディセーブルにするには、 spanning-tree guard コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree guard { loop | none | root }

no spanning-tree guard

シンタックスの説明

loop

インターフェイス上でループ ガードをイネーブルにします。

none

ガード モードを None に設定します。

root

インターフェイス上でルート ガードをイネーブルにします。

コマンドのデフォルト

ディセーブル

コマンド モード

インターフェイス コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

スパニング ツリー エッジ ポート上でループ ガードをイネーブルにするコマンドはスイッチによって受け入れられますが、ルート ガードがイネーブルになっている場合はループ ガードをイネーブルにできません。

次に、ルート ガードをイネーブルにする例を示します。

switch(config-if)# spanning-tree guard root

関連コマンド

コマンド
説明

show spanning-tree summary

スパニング ツリー ステートに関する情報を表示します。

 

spanning-tree link-type

ポートのリンク タイプを設定するには、 spanning-tree link-type コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree link-type { auto | point-to-point | shared }

no spanning-tree link-type

シンタックスの説明

auto

インターフェイスのデュプレックス設定に基づいてリンク タイプを設定します。

point-to-point

インターフェイスがポイントツーポイント リンクになるように指定します。

shared

インターフェイスが共有メディアになるように指定します。

コマンドのデフォルト

デュプレックス設定に基づいて自動的に設定されるリンク タイプ。

コマンド モード

インターフェイス コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

高速移行(IEEE 802.1w で指定)は、2 つのブリッジ間のポイントツーポイント リンク上だけで機能します。

デフォルトでは、スイッチはデュプレックス モードからポートのリンク タイプを取得します。全二重ポートはポイントツーポイント リンクと見なされ、半二重設定は共有リンク上にあると見なされます。


) Cisco Nexus 5000 シリーズ スイッチでは、ポート デュプレックスを設定できません。


次に、ポートを共有リンクとして設定する例を示します。

switch(config-if)# spanning-tree link-type shared

関連コマンド

コマンド
説明

show spanning-tree interface

スパニング ツリー ステートに関する情報を表示します。

 

spanning-tree loopguard default

ループ ガードを、すべてのスパニング ツリー標準およびネットワーク ポート上でデフォルトとしてイネーブルにするには、 spanning-tree loopguard default コマンドを使用します。ループ ガードをディセーブルにするには、このコマンドの no 形式を使用します。

spanning-tree loopguard default

no spanning-tree loopguard default

シンタックスの説明

このコマンドには、追加の引数またはキーワードはありません。

コマンドのデフォルト

ディセーブル

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

ループ ガードを使用すると、ブリッジ ネットワークのセキュリティを高めることができます。ループ ガードは、単方向リンクを引き起こす可能性のある障害が原因で、代替ポートまたはルート ポートが指定ポートになるのを防ぎます。

ループ ガードは、スパニング ツリーによってポイントツーポイント リンクと見なされるポートだけで動作し、スパニング ツリー エッジ ポート上では稼動しません。

指定のインターフェイスで spanning-tree guard loop コマンドを入力すると、このグローバル ループ ガード コマンドが上書きされます。

次に、ループ ガードをイネーブルにする例を示します。

switch(config)# spanning-tree loopguard default

関連コマンド

コマンド
説明

show spanning-tree summary

スパニング ツリー ステートに関する情報を表示します。

 

spanning-tree mode

Rapid per VLAN Spanning Tree Plus(Rapid PVST+)と多重スパニング ツリー(MST)スパニング ツリー プロトコル(STP)モードを切り替えるには、 spanning-tree mode コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mode { rapid-pvst | mst }

no spanning-tree mode

シンタックスの説明

rapid-pvst

STP モードを Rapid PVST+ に設定します。

mst

STP モードを MST に設定します。

コマンドのデフォルト

Rapid PVST+

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

スイッチ上で MST と Rapid PVST+ との同時実行はできません。


注意 spanning-tree mode コマンドを使用して、Rapid PVST+ モードと MST モードを切り替えるときには注意してください。コマンドを入力すると、以前のモードのすべての STP インスタンスが停止して、新しいモードで再開されます。このコマンドの使用により、ユーザ トラフィックが中断される可能性があります。

次に、MST モードに切り替える例を示します。

switch(config)# spanning-tree mode mst
switch(config-mst)#

関連コマンド

コマンド
説明

show spanning-tree summary

スパニング ツリー設定に関する情報を表示します。

 

spanning-tree mst configuration

多重スパニング ツリー(MST)コンフィギュレーション モードを開始するには、 spanning-tree mst configuration コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst configuration

no spanning-tree mst configuration

シンタックスの説明

このコマンドには、キーワードと引数はありません。

コマンドのデフォルト

MST 設定のデフォルト値は、MST 設定のすべてのパラメータのデフォルト値となります。

VLAN は MSTI にマッピングされません(すべての VLAN は CIST インスタンスにマッピングされます)。

領域名は空の文字列になります。

リビジョン番号は 0 です。

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

MST 設定は、3 つの主要パラメータで構成されています。

Instance VLAN mapping: instance vlan コマンドを参照してください。

Region name: name(MST コンフィギュレーション) コマンドを参照してください。

Configuration revision number: revision コマンドを参照してください。

abort および exit コマンドで、MST コンフィギュレーション モードを終了できます。この 2 つのコマンドは、変更を保存するかどうかで異なります。

exit コマンドでは、MST コンフィギュレーション モードを終了する前にすべての変更がコミットされます。

abort コマンドでは、変更はコミットされないで MST コンフィギュレーション モードが終了します。

関連付けられたプライマリ VLAN と同じインスタンスにセカンダリ VLAN をマッピングしていない場合は、MST コンフィギュレーション モードの終了時に次の警告メッセージが表示されます。

These secondary vlans are not mapped to the same instance as their primary:
-> 3
 

switchport mode private-vlan host コマンドを参照して、この問題を修正してください。

MST コンフィギュレーション モード パラメータを変更すると、接続が切断される可能性があります。サービスの中断を減らすには、MST コンフィギュレーション モードを開始したら、現在の MST 設定のコピーを変更します。設定の編集が終了したら、exit キーワードを使用して、すべての変更を一度に適用できます。

万一、2 人の管理者がまったく同時に新しいコンフィギュレーションをコミットした場合は、次の警告メッセージが表示されます。

% MST CFG:Configuration change lost because of concurrent access

次に、MST コンフィギュレーション モードを開始する例を示します。

switch(config)# spanning-tree mst configuration
switch(config-mst)#

次に、MST 設定(名前、インスタンス マッピング、およびリビジョン番号)をデフォルト設定にリセットする例を示します。

switch(config)# no spanning-tree mst configuration

関連コマンド

コマンド
説明

instance vlan

VLAN または VLAN セットを MST インスタンスにマッピングします。

name(MST コンフィギュレーション)

MST 領域の名前を設定します。

revision

MST 設定のリビジョン番号を設定します。

show spanning-tree mst

MST プロトコルに関する情報を表示します。

 

spanning-tree mst cost

多重スパニング ツリー(MST)インスタンス(インスタンス ID が 0 の Common and Internal Spanning Tree [CIST] も含む)のパス コスト パラメータを設定するには、 spanning-tree mst cost コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst instance-id cost { cost | auto }

no spanning-tree mst instance-id cost

シンタックスの説明

instance-id

インスタンス ID 番号。有効値の範囲は、0 ~ 4094 です。

cost

インスタンスのポート コスト。有効値の範囲は、1 ~ 200,000,000 です。

auto

インターフェイスのメディア速度によってポート コストの値を設定します。

コマンドのデフォルト

ポート コスト値を自動的に設定します。

10 Mbps:2,000,000

100 Mbps:200,000

1 ギガビット イーサネット:20,000

10 ギガビット イーサネット:2,000

コマンド モード

インターフェイス コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

ポート コストは、ポート速度によって異なります。インターフェイス速度が速いほど、コストは小さくなります。MST は、常にロング パス コストを使用します。

コスト値が大きいほど、コストが高くなります。コストを入力する際はカンマをエントリに含めないでください。たとえば、1,000 ではなく 1000 と入力します。

EtherChannel バンドルは、単一ポートと見なされます。ポート コストは、そのチャネルに割り当てられている設定済みのすべてのポート コストの合計です。

次に、インターフェイス パス コストを設定する例を示します。

switch(config-if)# spanning-tree mst 0 cost 17031970

関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

 

spanning-tree mst forward-time

スイッチ上のすべてのインスタンスの転送遅延タイマーを設定するには、 spanning-tree mst forward-time コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst forward-time seconds

no spanning-tree mst forward-time

シンタックスの説明

seconds

スイッチ上のすべてのインスタンスの転送遅延タイマーに設定する秒数。有効値の範囲は、4 ~ 30 秒です。

コマンドのデフォルト

15 秒

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

次に、転送遅延タイマーを設定する例を示します。

switch(config)# spanning-tree mst forward-time 20

関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

 

spanning-tree mst hello-time

スイッチ上のすべてのインスタンスの hello タイム遅延タイマーを設定するには、 spanning-tree mst hello-time コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst hello-time seconds

no spanning-tree mst hello-time

シンタックスの説明

seconds

スイッチ上のすべてのインスタンスの hello タイム遅延タイマーに設定する秒数。有効値の範囲は、1 ~ 10 秒です。

コマンドのデフォルト

2 秒

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

hello-time 値を指定しない場合は、ネットワークの直径から値が計算されます。

次に、hello タイム遅延タイマーを設定する例を示します。

switch(config)# spanning-tree mst hello-time 3

関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

 

spanning-tree mst max-age

スイッチ上のすべてのインスタンスの最大エージング タイマーを設定するには、 spanning-tree mst max-age コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst max-age seconds

no spanning-tree mst max-age

シンタックスの説明

seconds

スイッチ上のすべてのインスタンスの最大エージング タイマーに設定する秒数。有効値の範囲は、6 ~ 40 秒です。

コマンドのデフォルト

20 秒

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

このパラメータは、インスタンス 0 または IST だけが使用します。

次に、最大エージング タイマーを設定する例を示します。

switch(config)# spanning-tree mst max-age 40

関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

 

spanning-tree mst max-hops

ブリッジ プロトコル データ ユニット(BPDU)が廃棄される前に領域で許容されるホップ数を指定するには、 spanning-tree mst max-hops コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst max-hops hop-count

no spanning-tree mst max-hops

シンタックスの説明

hop-count

BPDU が廃棄される前に領域で許容されるホップ数。有効値の範囲は、1 ~ 255 ホップです。

コマンドのデフォルト

20 ホップ

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

次に、許容されるホップ数を設定する例を示します。

switch(config)# spanning-tree mst max-hops 25

関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

 

spanning-tree mst port-priority

多重スパニング ツリー(MST)インスタンス(インスタンス ID が 0 の Common and Internal Spanning Tree(CIST)も含む)のポート プライオリティ パラメータを設定するには、 spanning-tree mst port-priority コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst instance-id port-priority priority

no spanning-tree mst instance-id port-priority

シンタックスの説明

instance-id

インスタンス ID 番号。有効値は 0 ~ 4094 です。

priority

インスタンスのポート プライオリティ。有効値の範囲は、0 ~ 224 です(32 単位で増加)。

コマンドのデフォルト

ポート プライオリティ値は 128 です。

コマンド モード

インターフェイス コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

port-priority priority 値が大きいほど、プライオリティは低くなります。

プライオリティ値は、0、32、64、96、128、160、192、224 です。その他の値はすべて拒否されます。

次に、インターフェイス プライオリティを設定する例を示します。

switch(config-if)# spanning-tree mst 0 port-priority 64

関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

spanning-tree port-priority

デフォルト STP のポート プライオリティを設定します。デフォルト STP は Rapid PVST+ です。

 

spanning-tree mst priority

ブリッジ プライオリティを設定するには spanning-tree mst priority コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst instance-id priority priority-value

no spanning-tree mst instance-id priority

シンタックスの説明

instance-id

インスタンスの識別番号。有効値の範囲は 0 ~ 4094 です。

priority-value

ブリッジ プライオリティ。有効値および追加情報については「使用上のガイドライン」セクションを参照してください。

コマンドのデフォルト

ブリッジ プライオリティのデフォルト値は 32768 です。

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

ブリッジ プライオリティには、4096 単位で増加する値だけを設定できます。プライオリティを設定する場合、有効な値は、0、4096、8192、12288、16384、20480、24576、28672、32768、36864、40960、45056、49152、53248、57344、および 61440 です。

priority-value 引数に 0 を設定することで、スイッチをルートにできます。

instance-id 引数には、1 つのインスタンスまたはインスタンス範囲を入力できます。たとえば、0-3、5、7-9 と入力できます。

次に、ブリッジ プライオリティを設定する例を示します。

switch(config)# spanning-tree mst 0 priority 4096

関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

 

spanning-tree mst root

プライマリ ルートおよびセカンダリ ルートを指定して、インスタンスのタイマー値を設定するには、 spanning-tree mst root コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst instance-id root { primary | secondary } [ diameter dia [ hello-time hello-time ]]

no spanning-tree mst instance-id root

シンタックスの説明

instance-id

インスタンスの識別番号。有効値の範囲は 0 ~ 4094 です。

primary

スパニング ツリー インスタンスのブリッジ ルートを作成するのに十分な高プライオリティ(小さな値)を指定します。

secondary

プライマリ ルートに障害が発生した場合に、セカンダリ ルートとなるようにスイッチを指定します。

diameter dia

(任意)ネットワークの直径に基づく、ブリッジのタイマー値を指定します。

hello-time hello-time

(任意)ルート スイッチが設定メッセージを生成する間隔を指定します。有効な範囲は 1 ~ 10 秒で、デフォルトは 2 秒です。

コマンドのデフォルト

なし

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

instance-id 引数には、1 つのインスタンスまたはインスタンス範囲を入力できます。たとえば、0-3、5、7-9 と入力できます。

hello-time 引数を指定しない場合は、ネットワークの直径から引数が計算されます。 hello-time hello-time キーワードと引数を指定するには、まず diameter dia キーワードと引数を指定する必要があります。

次に、プライマリ ルートを指定する例を示します。

switch(config)# spanning-tree mst 0 root primary

次に、ブリッジのプライオリティ値およびタイマー値を設定する例を示します。

switch(config)# spanning-tree mst 0 root primary diameter 7 hello-time 2

関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

 

spanning-tree mst simulate pvst

特定のインターフェイスを再度イネーブルにして、多重スパニング ツリー(MST)と Rapid per VLAN Spanning Tree Plus(Rapid PVST+)間で自動的に相互運用するには、 spanning-tree mst simulate pvst コマンドを使用します。特定の MST インターフェイスと Rapid PVST+ を実行している接続先デバイスとの自動的な相互運用を回避するには、 spanning-tree mst simulate pvst disable コマンドを使用します。特定のインターフェイスをスイッチにグローバルに設定されているデフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst simulate pvst

spanning-tree mst simulate pvst disable

no spanning-tree mst simulate pvst

シンタックスの説明

このコマンドには、キーワードと引数はありません。

コマンドのデフォルト

イネーブル デフォルトでは、スイッチのすべてのインターフェイスは、MST と Rapid PVST+ との間でシームレスに相互運用します。この設定をグローバルに変更するには、 spanning-tree mst simulate pvst global コマンドを参照してください。

コマンド モード

インターフェイス コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

MST は、ユーザが設定しなくても、Rapid PVST+ と相互運用できます。PVST+ シミュレーション機能により、このシームレスな相互運用が可能になっています。ただし、MST と Rapid PVST+ との接続を制御し、MST 対応ポートを Rapid PVST+ 対応ポートに誤って接続するのを防止することが必要な場合もあります。

spanning-tree mst simulate pvst disable コマンドを使用すると、Rapid PVST+(SSTP)ブリッジ プロトコル データ ユニット(BPDU)を受信した指定の MST インターフェイスが STP ブロッキング ステートに移行します。これらのインターフェイスは、ポートでの Rapid PVST+ BPDU の受信が停止するまで不整合な状態で保持され、ポートで BPDU の受信を停止すると、通常の STP 移行プロセスを再開します。


) スイッチ全体で MST と Rapid PVST+ の自動的な相互運用をブロックするには、no spanning-tree mst simulate pvst global コマンドを使用します。


このコマンドは、Rapid PVST+ を実行するデバイスに誤って接続することを回避するうえで役立ちます。

特定のインターフェイス上で MST と Rapid PVST+ 間のシームレスな運用を再度イネーブルにするには、 spanning-tree mst simulate pvst コマンドを使用します。

次に、指定のポートと Rapid PVST+ を実行する接続先デバイスとの自動的な相互運用を回避する例を示します。

switch(config-if)# spanning-tree mst simulate pvst disable

関連コマンド

コマンド
説明

spanning-tree mst simulate pvst global

MST と Rapid PVST+ 間のシームレスな相互運用をグローバルにイネーブルにします。

 

spanning-tree mst simulate pvst global

多重スパニング ツリー(MST)スイッチと Rapid per VLAN Spanning Tree Plus(Rapid PVST+)を実行する接続先デバイスとの自動的な相互運用を回避するには、 spanning-tree mst simulate pvst global コマンドを使用します。デフォルト設定(スイッチ上で MST と Rapid PVST+ 間のシームレスな運用が行われる)に戻すには、 no spanning-tree mst simulate pvst global コマンドを使用します。

spanning-tree mst simulate pvst global

no spanning-tree mst simulate pvst global

シンタックスの説明

このコマンドには、キーワードと引数はありません。

コマンドのデフォルト

イネーブル デフォルトでは、スイッチが MST と Rapid PVST+ 間でシームレスに相互運用します。

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

MST では、Rapid PVST+ と相互運用するためのユーザ設定は必要ありません。PVST+ シミュレーション機能により、このシームレスな相互運用が可能になっています。ただし、MST と Rapid PVST+ との接続を制御し、MST 対応ポートを Rapid PVST+ 対応ポートに誤って接続するのを防止することが必要な場合もあります。

no spanning-tree mst simulate pvst global コマンドを使用すると、MST モードで稼動するスイッチにより、Rapid PVST+(SSTP)ブリッジ プロトコル データ ユニット(BPDU)を受信するすべてのインターフェイスが、スパニング ツリー プロトコル(STP)ブロッキング ステートに移行されます。これらのインターフェイスは、ポートでの Rapid PVST+ BPDU の受信が停止するまで不整合な状態で保持され、ポートで BPDU の受信を停止すると、通常の STP 移行プロセスを再開します。

インターフェイス モードからもこのコマンドを使用でき、設定はスイッチ全体に適用されます。


) 特定のインターフェイス上で MST と Rapid PVST+ の自動的な相互運用をブロックするには、spanning-tree mst simulate pvst コマンドを使用します。


このコマンドは、MST を実行していないデバイスに誤って接続することを回避するうえで役立ちます。

スイッチを MST と Rapid PVST+ 間のシームレスな運用に戻すには、 spanning-tree mst simulate pvst global コマンドを使用します。

次に、スイッチのすべてのポートと Rapid PVST+ を実行する接続先デバイスとの自動的な相互運用を回避する例を示します。

switch(config)# no spanning-tree mst simulate pvst global

関連コマンド

コマンド
説明

spanning-tree mst simulate pvst

MST と Rapid PVST+ 間のシームレスな相互運用をインターフェイス単位でイネーブルにします。

 

spanning-tree pathcost method

デフォルト パス コスト計算方式を設定するには、 spanning-tree pathcost method コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree pathcost method { long | short }

no spanning-tree pathcost method

シンタックスの説明

long

ポートのパス コストに 32 ビット ベース値を指定します。

short

ポートのパス コストに 16 ビット ベース値を指定します。

コマンドのデフォルト

short

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

long パス コスト計算方式では、パス コスト計算に 32 ビットをすべて利用して、2 ~ 2,00,000,000 の値を生成します。

short パス コスト計算方式(16 ビット)では、1 ~ 65535 の値を生成します。


) このコマンドは、デフォルト モードである Rapid per VLAN Spanning Tree Plus(Rapid PVST+)スパニング ツリー モードだけに適用されます。多重スパニング ツリー(MST)スパニング ツリー モードを使用している場合、スイッチはパス コストの計算に long 方式だけを使用します。これは MST についてはユーザ設定可能ではありません。


次に、デフォルト パス コスト方式に long を設定する例を示します。

switch(config)# spanning-tree pathcost method long

関連コマンド

コマンド
説明

show spanning-tree summary

スパニング ツリー ステートに関する情報を表示します。

 

spanning-tree port type edge

ホストに接続されているインターフェイスをエッジ ポートとして設定するには、 spanning-tree port type edge コマンドを使用します。この設定により、ポートはブロッキング ステートまたはラーニング ステートを通過することなく自動的にスパニング ツリー フォワーディング ステートに移行します。ポートを標準スパニング ツリー ポートに戻すには、 spanning-tree port type normal コマンドまたは no spanning-tree port type コマンドを使用します。

spanning-tree port type edge [ trunk ]

spanning-tree port type normal

no spanning-tree port type

シンタックスの説明

trunk

(任意)トランク ポートをスパニング ツリー エッジ ポートして設定します。

コマンドのデフォルト

デフォルトは、 spanning-tree port type edge default コマンドの入力時に設定されるデフォルト ポート タイプ エッジのグローバル設定です。グローバル設定を設定しなかった場合、デフォルトのスパニング ツリー ポート タイプは標準です。

コマンド モード

インターフェイス コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用して、ポートをスパニング ツリー エッジ ポートとしてトランク モードに設定することもできます。


注意 このコマンドは、端末に接続するインターフェイスに限って使用する必要があります。そうしないと、偶発的なトポロジ ループが原因でデータ パケット ループが発生し、スイッチおよびネットワークの動作が中断する可能性があります。

リンクがアップすると、スパニング ツリー エッジ ポートは、標準の転送遅延時間の経過を待たずに、ただちにスパニング ツリー フォワーディング ステートに移行します。


) これは、以前にシスコ独自の PortFast 機能が提供していた機能と同じです。


このコマンドを使用すると、システムによって次のようなメッセージが返されます。

Warning: portfast should only be enabled on ports connected to a single
host. Connecting hubs, concentrators, switches, bridges, etc... to this
interface when portfast is enabled, can cause temporary bridging loops.
Use with CAUTION
 

trunk キーワードを指定せずにこのコマンドを使用すると、システムから次のような追加メッセージが返されます。

%Portfast has been configured on Ethernet1/40 but will only
have effect when the interface is in a non-trunking mode.
 

トランク インターフェイスをスパニング ツリー エッジ ポートとして設定するには、 spanning-tree port type trunk コマンドを使用します。スパニング ツリー エッジ ポート タイプ設定を削除するには、 spanning-tree port type normal コマンドを使用します。

デフォルトのスパニング ツリー ポート タイプは「標準」です。

次に、ホストに接続されたインターフェイスをエッジ ポートとして設定する例を示します。この設定により、インターフェイスは、リンクがアップしたときに自動的にフォワーディング ステートに移行されます。

switch(config-if)# spanning-tree port type edge

関連コマンド

コマンド
説明

show spanning-tree

スパニング ツリー ステートに関する情報を表示します。

 

spanning-tree port type edge bpdufilter default

すべてのスパニング ツリー エッジ ポート上でデフォルトでブリッジ プロトコル データ ユニット(BPDU)フィルタリングをイネーブルにするには、 spanning-tree port type edge bpdufilter default コマンドを使用します。すべてのエッジポート上でデフォルトで BPDU フィルタリングをディセーブルにするには、このコマンドの no 形式を使用します。

spanning-tree port type edge bpdufilter default

no spanning-tree port type edge bpdufilter default

シンタックスの説明

このコマンドには、キーワードと引数はありません。

コマンドのデフォルト

ディセーブル

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

デフォルトで BPDU フィルタリングをイネーブルにするには、次を実行する必要があります。

spanning-tree port type edge または spanning-tree port type edge default コマンドを使用して、インターフェイスをスパニング ツリー エッジ ポートとして設定します。

BPDU フィルタリングをイネーブルにします。

すべてのスパニング ツリー エッジ ポート上で BPDU フィルタリングをグローバルにイネーブルにするには、このコマンドを使用します。BPDU フィルタリングにより、ポートは BPDU を送受信しなくなります。


注意 このコマンドを使用するときには注意してください。誤って使用すると、ブリッジング ループが発生する可能性があります。

インターフェイス レベルで BPDU フィルタリングを設定することにより、この spanning-tree port type edge bpdufilter default コマンドのグローバルな影響を無効にできます。この機能をインターフェイス レベルで使用する場合の詳細については、 spanning-tree bpdufilter コマンドを参照してください。


) BPDU フィルタリングは、ポート単位でイネーブルにしたときとグローバルにイネーブルにしたときでは、その機能が異なります。グローバルにイネーブルにされた BPDU フィルタリングは、動作中のスパニング ツリー エッジ ポートにだけ適用されます。ポートは数個の BPDU をリンクアップ時に送出してから、実際に、発信 BPDU のフィルタリングを開始します。BPDU を受信したエッジ ポートはただちに標準スパニング ツリー ポートになり、通常の移行が起こり、BPDU フィルタリングがディセーブルになります。ポートでローカルに BPDU フィルタリングをイネーブルにすると、スイッチはこのポートで BPDU の送受信を行わなくなります。


次に、動作中のすべてのスパニング ツリー エッジ ポート上で、デフォルトで BPDU フィルタリングをグローバルにイネーブルにする例を示します。

switch(config)# spanning-tree port type edge bpdufilter default

関連コマンド

コマンド
説明

show spanning-tree summary

スパニング ツリー設定に関する情報を表示します。

spanning-tree bpdufilter

インターフェイス上で BPDU フィルタリングをイネーブルにします。

spanning-tree port type edge

インターフェイスをスパニング ツリー エッジ ポートとして設定します。

 

spanning-tree port type edge bpduguard default

すべてのスパニング ツリー エッジ ポート上でデフォルトでブリッジ プロトコル データ ユニット(BPDU)ガードをイネーブルにするには、 spanning-tree port type edge bpduguard default コマンドを使用します。デフォルトですべてのエッジ ポートの BPDU ガードをディセーブルにするには、このコマンドの no 形式を使用します。

spanning-tree port type edge bpduguard default

no spanning-tree port type edge bpduguard default

シンタックスの説明

このコマンドには、キーワードと引数はありません。

コマンドのデフォルト

ディセーブル

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

デフォルトで BPDU ガードをイネーブルにするには、次を実行する必要があります。

spanning-tree port type edge または spanning-tree port type edge default コマンドを入力して、インターフェイスをスパニング ツリー エッジ ポートとして設定します。

BPDU ガードをイネーブルにします。

すべてのスパニング ツリー エッジ ポート上で BPDU ガードをグローバルにイネーブルにするには、このコマンドを使用します。BPDU を受信したポートは、BPDU ガードによってディセーブルになります。

グローバル BPDU ガードは、スパニング ツリー エッジ ポート上だけに適用されます。

BPDU ガードは、インターフェイス単位でもイネーブルにできます。詳細については、 spanning-tree bpduguard コマンドを参照してください。


) すべてのスパニング ツリー エッジ ポートで BPDU ガードをイネーブルにすることを推奨します。


次に、すべてのスパニング ツリー エッジ ポートで、デフォルトで BPDU ガードをイネーブルにする例を示します。

switch(config)# spanning-tree port type edge bpduguard default

関連コマンド

コマンド
説明

show spanning-tree summary

スパニング ツリー設定に関する情報を表示します。

spanning-tree bpduguard

インターフェイス上で BPDU ガードをイネーブルにします。

spanning-tree port type edge

インターフェイスをスパニング ツリー エッジ ポートとして設定します。

 

spanning-tree port type edge default

ホストに接続されているすべてのアクセス ポートをデフォルトでエッジ ポートとして設定するには、 spanning-tree port type edge default コマンドを使用します。ホストに接続されているすべてのポートをデフォルトで標準スパニング ツリー ポートに戻すには、このコマンドの no 形式を使用します。

spanning-tree port type edge default

no spanning-tree port type edge default

シンタックスの説明

このコマンドには、引数またはキーワードはありません。

コマンドのデフォルト

ディセーブル

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

すべてのインターフェイスをデフォルトでスパニング ツリー エッジ ポートとして自動的に設定するには、このコマンドを使用します。このコマンドは、トランク ポート上では機能しません。


注意 このコマンドを使用するときは注意してください。このコマンドは、端末に接続するインターフェイスに限って使用する必要があります。そうしないと、偶発的なトポロジ ループが原因でデータ パケット ループが発生し、スイッチおよびネットワークの動作が中断する可能性があります。

リンクがアップすると、エッジ ポートとして設定されているインターフェイスは、標準の転送遅延時間の経過を待たずに、ただちにスパニング ツリー フォワーディング ステートに移行します (この移行は、以前は、シスコ独自の PortFast 機能として設定していました)。

このコマンドを使用すると、システムによって次のようなメッセージが返されます。

Warning: this command enables portfast by default on all interfaces. You
should now disable portfast explicitly on switched ports leading to hubs,
switches and bridges as they may create temporary bridging loops.
 

spanning-tree port type edge コマンドを使用して、個々のインターフェイスをエッジ ポートして設定できます。

デフォルトのスパニング ツリー ポート タイプは「標準」です。

次に、ホストに接続されたすべてのポートをスパニング ツリー エッジ ポートとしてグローバルに設定する例を示します。

switch(config)# spanning-tree port type edge default

関連コマンド

コマンド
説明

show spanning-tree summary

スパニング ツリー設定に関する情報を表示します。

spanning-tree port type edge

インターフェイスをスパニング ツリー エッジ ポートとして設定します。

 

spanning-tree port type network

グローバル設定に関係なく、スイッチに接続されているインターフェイスをネットワーク スパニング ツリー ポートとして設定するには、 spanning-tree port type network コマンドを使用します。ポートを標準スパニング ツリー ポートに戻すには、 spanning-tree port type normal コマンドを使用するか、またはこのコマンドの no 形式を使用します。

spanning-tree port type network

spanning-tree port type normal

no spanning-tree port type

シンタックスの説明

このコマンドには、引数またはキーワードはありません。

コマンドのデフォルト

デフォルトは、 spanning-tree port type network default コマンドの入力時に設定されるデフォルト ポート タイプ ネットワークのグローバル設定です。グローバル設定を設定しなかった場合、デフォルトのスパニング ツリー ポート タイプは標準です。

コマンド モード

インターフェイス コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

スイッチに接続されているインターフェイスをスパニング ツリー ネットワーク ポートとして設定するには、このコマンドを使用します。Bridge Assurance は、スパニング ツリー プロトコル(STP)ネットワーク ポート上だけで実行されます。


) ホストに接続されているポートを誤って STP ネットワーク ポートとして設定し、Bridge Assurance をイネーブルにすると、それらのポートは自動的にブロッキング ステートに移行します。



) Bridge Assurance はデフォルトでイネーブルとなり、スパニング ツリー ネットワーク ポートとして設定されているすべてのインターフェイスの Bridge Assurance がイネーブルになります。


ポートをスパニング ツリー ネットワーク ポートとして設定するには、 spanning-tree port type network コマンドを使用します。この設定を削除するには、 spanning-tree port type normal コマンドを使用します。 no spanning-tree port type コマンドを使用すると、ソフトウェアによってポートがネットワーク ポート タイプのグローバルなデフォルト設定に戻されます。

spanning-tree port type network default コマンドを入力すると、スイッチに接続されているすべてのポートをデフォルトでスパニング ツリー ネットワーク ポートとして設定できます。

デフォルトのスパニング ツリー ポート タイプは「標準」です。

次に、スイッチまたはブリッジに接続されているインターフェイスをスパニング ツリー ネットワーク ポートとして設定する例を示します。

switch(config-if)# spanning-tree port type network

関連コマンド

コマンド
説明

show spanning-tree interface

指定のインターフェイス単位でスパニング ツリー設定に関する情報を表示します。

 

spanning-tree port type network default

すべてのポートをデフォルトでスパニング ツリー ネットワーク ポートとして設定するには、 spanning-tree port type network default コマンドを使用します。すべてのポートをデフォルトで標準スパニング ツリー ポートに戻すには、このコマンドの no 形式を使用します。

spanning-tree port type network default

no spanning-tree port type network default

シンタックスの説明

このコマンドには、引数またはキーワードはありません。

コマンドのデフォルト

ディセーブル

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

スイッチに接続されているすべてのインターフェイスをデフォルトでスパニング ツリー ネットワーク ポートとして自動的に設定するには、このコマンドを使用します。その後、 spanning-tree port type edge コマンドを使用して、ホストに接続されている指定のポートをスパニング ツリー エッジ ポートとして設定できます。


) ホストに接続されているポートを誤ってスパニング ツリー プロトコル(STP)ネットワーク ポートとして設定し、Bridge Assurance をイネーブルにすると、それらのポートは自動的にブロッキング ステートに移行します。


Bridge Assurance 機能により、ホストに接続されているネットワーク ポートはスパニング ツリー ブロッキング ステートに移行するため、他のスイッチに接続されているポートだけをネットワークポートとして設定してください。

spanning-tree port type network コマンドを使用して、個々のインターフェイスをネットワーク ポートとして識別できます。

デフォルトのスパニング ツリー ポート タイプは「標準」です。

次に、スイッチに接続されたすべてのポートをスパニング ツリー ネットワーク ポートとしてグローバルに設定する例を示します。

switch(config)# spanning-tree port type network default

関連コマンド

コマンド
説明

show spanning-tree summary

スパニング ツリー設定に関する情報を表示します。

 

spanning-tree port-priority

2 台のブリッジがルート ブリッジとして位置競合している場合に、インターフェイス プライオリティを設定するには、 spanning-tree port-priority コマンドを使用します。設定するプライオリティによって、優劣が決まります。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree [ vlan vlan-id ] port-priority value

no spanning-tree [ vlan vlan-id ] port-priority

シンタックスの説明

vlan vlan-id

(任意)VLAN 識別番号を指定します。有効値の範囲は、0 ~ 4094 です。

value

ポート プライオリティ。有効値の範囲は、1 ~ 224 です(32 単位で増加)。

コマンドのデフォルト

ポート プライオリティのデフォルト値は 128 です。

コマンド モード

インターフェイス コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

アクセス ポート上では、 vlan vlan-id パラメータを使用しないでください。ソフトウェアは、アクセス ポートにはポート プライオリティ値、トランク ポートには VLAN ポート プライオリティ値を使用します。

プライオリティ値は、0、32、64、96、128、160、192、224 です。その他の値はすべて拒否されます。


) デフォルト STP モードである Rapid per VLAN Spanning Tree Plus(Rapid PVST+)スパニング ツリー モードのポート プライオリティを設定するには、このコマンドを使用します。多重スパニング ツリー(MST)スパニング ツリー モードのポート プライオリティを設定するには、spacing-tree mst port-priority コマンドを使用します。


次に、ポート プライオリティを 32 に変更して、アクセス ポート インターフェイス 2/0 上のスパニング ツリー インスタンスがルート ブリッジとして選択される確率を高める例を示します。

switch(config-if)# spanning-tree port-priority 32

関連コマンド

コマンド
説明

show spanning-tree

スパニング ツリー ステートに関する情報を表示します。

spanning-tree interface priority

インターフェイスのスパニング ツリー ポート プライオリティに関する情報を表示します。

 

spanning-tree vlan

VLAN 単位でスパニング ツリー プロトコル(STP)パラメータを設定するには、 spanning-tree vlan コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree vlan vlan-id [ forward-time value | hello-time value | max-age value | priority value | [ root { primary | secondary } [ diameter dia [ hello-time value ]]]]

no spanning-tree vlan vlan-id [ forward-time | hello-time | max-age | priority | root ]

シンタックスの説明

vlan-id

VLAN 識別番号。有効値の範囲は、0 ~ 4094 です。

forward-time value

(任意)STP 転送遅延時間を指定します。有効値の範囲は、4 ~ 30 秒です。

hello-time value

(任意)ルート スイッチが設定メッセージを生成する間隔を秒単位で指定します。有効値の範囲は、1 ~ 10 秒です。

max-age value

(任意)ブリッジ プロトコル データ ユニット(BPDU)の情報が有効になっている最大時間を秒数で指定します。有効値の範囲は、6 ~ 40 秒です。

priority value

(任意)STP ブリッジ プライオリティを指定します。有効な値は、0、4096、8192、12288、16384、20480、24576、28672、32768、36864、40960、45056、49152、53248、57344、または 61440 です。 その他の値はすべて拒否されます。

root primary

(任意)このスイッチを強制的にルート ブリッジに設定します。

root secondary

(任意)プライマリ ルートに障害が発生した場合には、このスイッチを強制的にルート スイッチにします。

diameter dia

(任意)端末間の 2 つの接続ポイントの間に存在するブリッジの最大数を指定します。

コマンドのデフォルト

デフォルトの設定は次のとおりです。

forward-time :15

hello-time :2

max-age :20

priority :32768

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン


注意 no spanning-tree vlan vlan-id コマンドを使用して、VLAN 上のスパニング ツリーをディセーブルにするときは、VLAN のすべてのスイッチおよびブリッジのスパニング ツリーがディセーブルになっていることを確認してください。VLAN 内の一部のスイッチおよびブリッジのスパニング ツリーをディセーブルにし、同じ VLAN 内の別のスイッチおよびブリッジのスパニング ツリーをイネーブルのままにしておくことはできません。スパニング ツリーがイネーブルになっているスイッチおよびブリッジは、ネットワークの物理トポロジについて不完全な情報しか持たないからです。


注意 物理的なループがないトポロジであっても、スパニング ツリーをディセーブルにしないことを推奨します。スパニング ツリーは、設定の誤りおよび配線の誤りに対する保護手段です。VLAN に物理ループが存在しないことを確認せずに、VLAN でスパニング ツリーをディセーブルにしないでください。

max-age seconds の設定時に、ルート ブリッジからの BPDU が指定のインターバル内にブリッジで見えない場合、ブリッジはネットワークが変更されたものと見なし、スパニング ツリー トポロジを再計算します。

spanning-tree root primary では、このスイッチのブリッジ プライオリティが 24576 に変更されます。spanning-tree root primary コマンドを入力してもスイッチがルートにならない場合、ブリッジ プライオリティは現在のブリッジのブリッジ プライオリティより 4096 だけ小さい値に変更されます。ルート ブリッジになるために必要な値が 1 より小さい場合は、このコマンドは失敗します。スイッチがルートにならない場合は、エラーが発生します。

ネットワーク デバイスのデフォルト ブリッジ プライオリティが 32768 に設定されている場合に、spanning-tree root secondary コマンドを入力すると、ソフトウェアによってこのスイッチのブリッジ プライオリティが 28762 に変更されます。ルート スイッチに障害が発生すると、このスイッチが次のルート スイッチになります。

spanning-tree root コマンドは、バックボーン スイッチ上だけで使用してください。

次に、VLAN 200 上でスパニング ツリーをイネーブルにする例を示します。

switch(config)# spanning-tree vlan 200

次の例では、スイッチを VLAN 10 のルート スイッチとして設定し、ネットワーク直径を 4 に設定する方法を示します。

switch(config)# spanning-tree vlan 10 root primary diameter 4

次の例では、スイッチを VLAN 10 のセカンダリ ルート スイッチとして設定し、ネットワーク直径を 4 に設定する方法を示します。

switch(config)# spanning-tree vlan 10 root secondary diameter 4

関連コマンド

コマンド
説明

show spanning-tree

スパニング ツリー ステートに関する情報を表示します。

 

speed(イーサネット)

イーサネット インターフェイスに送受信速度設定をするには、 speed コマンドを使用します。デフォルトの速度にリセットするには、このコマンドの no 形式を使用します。

speed { 1000 | 10000 }

no speed

シンタックスの説明

1000

インターフェイス速度を 1 ギガビットに設定します。

10000

インターフェイス速度を 10 ギガビットに設定します。これがデフォルト速度です。

コマンドのデフォルト

デフォルト速度は 10000(10 ギガビット)です。

コマンド モード

インターフェイス コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(1a)N1(1)

このコマンドが追加されました。

使用上のガイドライン

Nexus 5010 スイッチの最初の 8 個のポートと、Nexus 5020 スイッチの最初の 16 個のポートは、スイッチ可能な 1 ギガビット ポートと 10 ギガビット ポートです。デフォルトのインターフェイス速度は 10 ギガビットです。これらのポートを 1 ギガビット イーサネット用に設定するには、1 ギガビット イーサネット SFP トランシーバを適切なポートに挿入し、speed コマンドを使用して速度を設定します。


) インターフェイスとトランシーバの速度が一致しない場合、show interface ethernet slot/port コマンドを入力すると、SFP 検証失敗メッセージが表示されます。たとえば、speed 1000 コマンドを設定しないで 1 ギガビット SFP トランシーバをポートに挿入すると、このエラーが発生します。

デフォルトでは、Cisco Nexus 5000 シリーズ スイッチ上のすべてのポートは 10 ギガビットです。


次に、1 ギガビット イーサネット ポートの速度を設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/1
switch(config-if)# speed 1000

関連コマンド

コマンド
説明

show interface

インターフェイス コンフィギュレーション情報を表示します。

 

state

VLAN の動作ステートを設定するには、 state コマンドを使用します。VLAN をデフォルトの動作ステートに戻すには、このコマンドの no 形式を使用します。

state { active | suspend }

no state

シンタックスの説明

active

VLAN がアクティブにトラフィックを受け渡すように指定します。

suspend

VLAN がパケットを受け渡さないように指定します。

コマンドのデフォルト

VLAN がアクティブにトラフィックを受け渡します。

コマンド モード

VLAN コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

VLAN 1 および VLAN 1006 ~ 4094 のステートは一時停止できません。

一時停止ステートの VLAN は、パケットを受け渡しません。

次に、VLAN 2 を一時停止する例を示します。

switch(config)# vlan 2
switch(config-vlan)# state suspend

関連コマンド

コマンド
説明

show vlan

VLAN 情報を表示します。

 

svi enable

VLAN インターフェイスの作成をイネーブルにするには、 svi enable コマンドを使用します。VLAN インターフェイス機能をディセーブルにするには、このコマンドの no 形式を使用します。

svi enable

no svi enable

シンタックスの説明

このコマンドには、引数またはキーワードはありません。

コマンドのデフォルト

VLAN インターフェイスはディセーブルです。

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

4.0(1a)N1(1)

このコマンドは廃止予定で、 feature interface-vlan コマンドに置き換えられます。このコマンドは、下位互換性のためにいくつかのリリースにわたって保持されます。

使用上のガイドライン

VLAN インターフェイスを作成する前に、 feature interface-vlan または svi enable コマンドを使用する必要があります。

次に、スイッチでインターフェイス上の VLAN 機能をイネーブルにする例を示します。

switch(config)# svi enable

関連コマンド

コマンド
説明

interface vlan

VLAN インターフェイスを作成します。

 

switchport access vlan

インターフェイスがアクセス モードのときにアクセス VLAN を設定するには、 switchport access vlan コマンドを使用します。アクセス モード VLAN をスイッチの適切なデフォルト VLAN にリセットするには、このコマンドの no 形式を使用します。

switchport access vlan vlan-id

no switchport access vlan

シンタックスの説明

vlan-id

インターフェイスがアクセス モードのときに設定する VLAN。有効な値は、1 ~ 4094 ですが、内部で使用するために予約されている VLAN は除きます。

コマンドのデフォルト

VLAN 1

コマンド モード

インターフェイス コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

アクセス モード VLAN をスイッチの適切なデフォルト VLAN にリセットするには、 switchport access vlan コマンドの no 形式を使用します。このアクションにより、ポートが接続されているデバイスに関するメッセージが生成される場合があります。

次に、VLAN 2 に参加するようにイーサネット インターフェイスを設定する例を示します。

switch(config)# interface ethernet 1/7
switch(config-if)#
switchport access vlan 2

関連コマンド

コマンド
説明

show interface switchport

ポートの管理ステータスおよび動作ステータスを表示します。

 

switchport block

不明のマルチキャストまたはユニキャスト パケットが転送されないようにするには、 switchport block コマンドを使用します。不明のマルチキャストまたはユニキャスト パケットの転送を許可するには、このコマンドの no 形式を使用します。

switchport block { multicast | unicast }

no switchport block { multicast | unicast }

シンタックスの説明

multicast

不明のマルチキャスト トラフィックがブロックされるように指定します。

unicast

不明のユニキャスト トラフィックがブロックされるように指定します。

コマンドのデフォルト

未知のマルチキャストおよびユニキャスト トラフィックはブロックされません。未知の MAC アドレスを持ったすべてのトラフィックがすべてのポートに送信されます。

コマンド モード

インターフェイス コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

スイッチ ポート上の不明なマルチキャストまたはユニキャスト トラフィックをブロックできます。

不明なマルチキャストまたはユニキャスト トラフィックのブロックは、スイッチ ポート上で自動的にイネーブルにはなりません。明示的に設定する必要があります。

次に、インターフェイス上で不明なマルチキャスト トラフィックをブロックする例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/1
switch(config-if)# switchport block multicast

関連コマンド

コマンド
説明

show interface switchport

指定のインターフェイスまたはすべてのインターフェイスのスイッチ ポート情報を表示します。

 

switchport mode private-vlan host

インターフェイス タイプをプライベート VLAN のホスト ポートとして設定するには、 switchport mode private-vlan host コマンドを使用します。

switchport mode private-vlan host

シンタックスの説明

このコマンドには、引数またはキーワードはありません。

コマンドのデフォルト

なし

コマンド モード

インターフェイス コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

ポートをプライベート VLAN ホスト ポートとして設定し、次のいずれか 1 つがあてはまる場合にはポートが非アクティブになります。

ポートに有効なプライベート VLAN 関連付けが設定されていない。

ポートが Switched Port Analyzer(SPAN; スイッチド ポート アナライザ)宛先である。

プライベート VLAN 関連付けが一時停止されている。

プライベート VLAN ポート関連付けを削除するか、プライベート ポートを SPAN 宛先として設定した場合、削除されたプライベート VLAN ポート関連付けまたは SPAN 宛先として設定されたプライベート ポートは非アクティブになります。


) スパニング ツリー BPDU ガードをすべてのプライベート VLAN ホスト ポートでイネーブルにすることを推奨します。


次に、ポートをプライベート VLAN のホスト モードに設定する例を示します。

switch(config-if)# switchport mode private-vlan host

関連コマンド

コマンド
説明

show interface switchport

スイッチポートとして設定されているすべてのインターフェイスに関する情報を表示します。

 

switchport mode private-vlan promiscuous

インターフェイス タイプをプライベート VLAN 混合モード ポートに設定するには、 switchport mode private-vlan promiscuous コマンドを使用します。

switchport mode private-vlan promiscuous

シンタックスの説明

このコマンドには、キーワードと引数はありません。

コマンドのデフォルト

なし

コマンド モード

インターフェイス コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

ポートをプライベート VLAN 混合モード ポートとして設定し、次のいずれか 1 つがあてはまる場合はポートが非アクティブになります。

ポートに有効なプライベート VLAN マッピングが設定されていない。

ポートが Switched Port Analyzer(SPAN; スイッチド ポート アナライザ)宛先である。

プライベート VLAN ポート マッピングを削除するか、プライベート ポートを SPAN 宛先として設定した場合、削除されたプライベート VLAN ポート マッピングまたは SPAN 宛先として設定されたプライベート ポートは非アクティブになります。

混合モード ポートの詳細については、 private-vlan コマンドを参照してください。

次に、ポートをプライベート VLAN の混合モードに設定する例を示します。

switch(config-if)# switchport mode private-vlan promiscuous

関連コマンド

コマンド
説明

show interface switchport

スイッチポートとして設定されているすべてのインターフェイスに関する情報を表示します。

 

switchport private-vlan host-association

独立ポートまたはコミュニティ ポートのプライベート VLAN 関連付けを定義するには、switchport private-vlan host-association コマンドを使用します。ポートからプライベート VLAN 関連付けを削除するには、このコマンドの no 形式を使用します。

switchport private-vlan host-association { primary-vlan-id } { secondary-vlan-id }

no switchport private-vlan host-association

シンタックスの説明

primary-vlan-id

プライベート VLAN 関係のプライマリ VLAN の番号。

secondary-vlan-id

プライベート VLAN 関係のセカンダリ VLAN の番号。

コマンドのデフォルト

なし

コマンド モード

インターフェイス コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

ポートがプライベート VLAN のホスト モードでない限り、ポート上でランタイムの効果はありません。ポートがプライベート VLAN ホスト モードであっても、VLAN がどちらも存在しない場合は、コマンドは許可されますが、ポートは非アクティブになります。プライベート VLAN 間の関連付けが一時停止されている場合も、ポートが非アクティブになる可能性があります。

セカンダリ VLAN は、独立 VLAN またはコミュニティ VLAN である可能性があります。

プライマリ VLAN、セカンダリ VLAN、および独立ポートまたはコミュニティ ポートについての詳細は、 private-vlan コマンドを参照してください。


) 現行リリースの Cisco NX-OS を実行している Cisco Nexus 5000 シリーズ スイッチのプライベート VLAN 独立ポートは、IEEE 802.1Q のカプセル化をサポートしておらず、トランク ポートとして使用できません。


次に、プライマリ VLAN(VLAN 18)およびセカンダリ VLAN(VLAN 20)とのレイヤ 2 プライベート VLAN ホスト ポートを設定する例を示します。

switch(config-if)# switchport private-vlan host-association 18 20

次に、ポートからプライベート VLAN 関連付けを削除する例を示します。

switch(config-if)# no switchport private-vlan host-association

関連コマンド

コマンド
説明

show vlan private-vlan

プライベート VLAN に関する情報を表示します。

 

switchport private-vlan mapping

混合モード ポートのプライベート VLAN 関連付けを定義するには、 switchport private-vlan mapping コマンドを使用します。プライマリ VLAN からすべてのマッピングをクリアするには、このコマンドの no 形式を使用します。

switchport private-vlan mapping { primary-vlan-id } {[ add ] secondary-vlan-id | remove secondary-vlan-id }

no switchport private-vlan mapping

シンタックスの説明

primary-vlan-id

プライベート VLAN 関係のプライマリ VLAN の番号。

add

(任意)セカンダリ VLAN をプライマリ VLAN に関連付けます。

secondary-vlan-id

プライベート VLAN 関係のセカンダリ VLAN の番号。

remove

セカンダリ VLAN とプライマリ VLAN 間の関連付けを消去します。

コマンドのデフォルト

なし

コマンド モード

インターフェイス コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

ポートがプライベート VLAN の混合モードでない限り、ポート上でランタイムの効果はありません。ポートがプライベート VLAN 混合モードであっても、プライマリ VLAN が存在しない場合は、コマンドは許可されますが、ポートは非アクティブになります。

セカンダリ VLAN は、独立 VLAN またはコミュニティ VLAN である可能性があります。

プライマリ VLAN、セカンダリ VLAN、および独立ポートまたはコミュニティ ポートについての詳細は、 private-vlan コマンドを参照してください。


) 現行リリースの Cisco NX-OS を実行している Cisco Nexus 5000 シリーズ スイッチのプライベート VLAN 独立ポートは、IEEE 802.1Q のカプセル化をサポートしておらず、トランク ポートとして使用できません。


次に、プライベート VLAN 混合モード ポートでセカンダリ独立 VLAN 20 にプライマリ VLAN 18 を関連付けるように設定する例を示します。

switch(config-if)# switchport private-vlan mapping 18 20

次に、混合モード ポート上の関連付けに VLAN を追加する例を示します。

switch(config-if)# switchport private-vlan mapping 18 add 21

次に、ポートからすべてのプライベート VLAN 関連付けを削除する例を示します。

switch(config-if)# no switchport private-vlan mapping

関連コマンド

コマンド
説明

show interface switchport

スイッチポートとして設定されているすべてのインターフェイスに関する情報を表示します。

show interface private-vlan mapping

VLAN インターフェイスのプライベート VLAN マッピングまたは SVI に関する情報を表示します。

 

udld(コンフィギュレーション モード)

スイッチ上で Unidirectional Link Detection(UDLD; 単一方向リンク検出)プロトコルを設定するには、 udld コマンドを使用します。UDLD をディセーブルにするには、このコマンドの no 形式を使用します。

udld { aggressive | message-time timer-time | reset }

no udld { aggressive | message-time | reset }

シンタックスの説明

aggressive

スイッチ上でアグレッシブ モードで UDLD をイネーブルにします。

message-time timer-time

アドバタイズ モードにあり、現在は双方向と判別されたポートにおける UDLD プローブ メッセージ間の時間間隔を設定します。有効な範囲は 7 ~ 90 秒です。デフォルトは 15 秒です。

reset

UDLD によりシャットダウンされたすべてのポートをリセットし、トラフィックの転送を再び許可します。スパニング ツリーなどのその他の機能は、イネーブルになっている場合は通常どおり動作します。

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(1a)N1(1)

このコマンドが追加されました。

使用上のガイドライン

デフォルトでは、UDLD アグレッシブ モードはディセーブルになっています。UDLD アグレッシブ モードは、UDLD アグレッシブ モードをサポートするネットワーク デバイスの間のポイントツーポイントのリンク上に限って設定できます。UDLD アグレッシブ モードがイネーブルになっている場合、UDLD ネイバー関係が確立されている双方向リンク上のポートが UDLD フレームを受信しなくなったとき、UDLD はネイバーとの接続の再確立を試行します。この再試行に 8 回失敗すると、ポートはディセーブルになります。

スパニング ツリー ループを回避するために、デフォルトの 15 秒間隔を使用するノーマル UDLD により、(デフォルトのスパニング ツリー パラメータを使用している場合)ブロッキング ポートがフォワーディング ステートに移行する前に、すみやかに単方向リンクをシャットダウンできます。

UDLD アグレッシブ モードをイネーブルにすると、次のようなことが発生します。

リンクの一方にポート スタックが生じる(送受信どちらも)

リンクの一方がダウンしているにもかかわらず、リンクのもう一方がアップしたままになる

このような場合、UDLD アグレッシブ モードでは、リンクのポートの 1 つがディセーブルになり、トラフィックが廃棄されるのを防止します。

次に、スイッチのアグレッシブ UDLD モードをイネーブルにする例を示します。

switch# configure terminal
switch(config)# udld aggressive

次に、UDLD によってシャットダウンされたすべてのポートをリセットする例を示します。

switch# configure terminal
switch(config)# udld reset

関連コマンド

コマンド
説明

show udld

UDLD の管理ステータスおよび動作ステータスを表示します。

 

udld(イーサネット)

イーサネット インターフェイスで単一方向リンク検出(UDLD)プロトコルをイネーブルにして設定するには、 udld コマンドを使用します。UDLD をディセーブルにするには、このコマンドの no 形式を使用します。

udld { aggressive | disable | enable }

no udld { aggressive | disable | enable }

シンタックスの説明

aggressive

インターフェイス上でアグレッシブ モードで UDLD をイネーブルにします。

disable

インターフェイス上で UDLD をディセーブルにします。

enable

インターフェイス上でノーマル モードで UDLD をイネーブルにします。

コマンドのデフォルト

なし

コマンド モード

インターフェイス コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(1a)N1(1)

このコマンドが追加されました。

使用上のガイドライン

イーサネット インターフェイスでは、UDLD をノーマルまたはアグレッシブ モードに設定できます。インターフェイスで UDLD モードをイネーブルにする前に、スイッチ上で UDLD がイネーブルになっていることを確認する必要があります。UDLD は他方のリンク先のインターフェイスおよびそのデバイスでもイネーブルになっている必要があります。

リンクで UDLD ノーマル モードを使用するには、片方のポートをノーマル モードに設定し、もう一方のポートをノーマル モードまたはアグレッシブ モードに設定する必要があります。UDLD アグレッシブ モードを使用するには、リンクの両端をアグレッシブ モードに設定する必要があります。

次の例は、イーサネット ポートのノーマル UDLD モードをイネーブルにする方法を示しています。

switch# configure terminal
switch(config)# interface ethernet 1/1
switch(config-if)# udld enable

次の例は、イーサネット ポートのアグレッシブ UDLD モードをイネーブルにする方法を示しています。

switch(config-if)# udld aggressive

次の例は、イーサネット ポートの UDLD をディセーブルにする例を示しています。

switch(config-if)# udld disable

関連コマンド

コマンド
説明

show udld

UDLD の管理ステータスおよび動作ステータスを表示します。

 

vlan(EXEC モード)

VLAN を追加するか VLAN コンフィギュレーション モードを開始するには、 vlan コマンドを使用します。VLAN を削除して VLAN コンフィギュレーション モードを終了するには、このコマンドの no 形式を使用します。

vlan { vlan-id | vlan-range }

no vlan { vlan-id | vlan-range }

シンタックスの説明

vlan-id

VLAN の 番号。有効値の範囲は、1 ~ 4094 です。

(注) VLAN 1 または内部的に割り当てられているいずれの VLAN も作成、削除、または修正できません。

vlan-range

設定された VLAN の範囲。有効値のリストについては、「使用上のガイドライン」セクションを参照してください。

コマンドのデフォルト

なし

コマンド モード

グローバル コンフィギュレーション モード


) これらの同じコマンドを使用して、VLAN コンフィギュレーション モードで VLAN を作成および削除することもできます。


コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

vlan vlan-id コマンドを入力すると、すべてのデフォルト パラメータが設定された新しい VLAN が作成され、Command Line Interface(CLI; コマンド ライン インターフェイス)で VLAN コンフィギュレーション モードが開始されます。入力した vlan-id 引数が既存の VLAN に一致する場合は、VLAN コンフィギュレーション モードが開始されるだけで、他には何も起こりません。

カンマ( , )、ダッシュ( - )、および番号を使用して、 vlan-range を入力できます。

VLAN 1 パラメータは出荷時に設定されており、変更できません。この VLAN は、作成も削除もできません。さらに、VLAN 4095 または内部的に割り当てられているいずれの VLAN も作成または削除できません。

VLAN を削除すると、その VLAN のすべてのアクセス ポートがシャットダウンされ、トラフィック フローが停止します。トランク ポートでは、ポートで許可されている他の VLAN へのトラフィック フローは継続されますが、削除された VLAN 宛てのパケットは廃棄されます。ただし、その VLAN VLAN とポートのマッピングはシステム上にすべて存続しているため、その指定の VLAN を再イネーブル化または再作成すると、スイッチにより元のポートすべてが自動的にその VLAN に戻されます。

次に、新しい VLAN を追加して、VLAN コンフィギュレーション モードを開始する例を示します。

switch(config)# vlan 2
switch(config-vlan)#

次に、新しい VLAN 範囲を追加して、VLAN コンフィギュレーション モードを開始する例を示します。

switch(config)# vlan 2,5,10-12,20,25,4000
switch(config-vlan)#

次に、VLAN を削除する例を示します。

switch(config)# no vlan 2

関連コマンド

コマンド
説明

show vlan

VLAN 情報を表示します。

 

vrf context

Virtual Routing and Forwarding(VRF; 仮想ルーティングおよび転送)インスタンスを作成して、VRF コンフィギュレーション モードを開始するには、 vrf context コマンドを使用します。VRF エントリを削除するには、このコマンドの no 形式を使用します。

vrf context { name | management }

no vrf context { name | management }

シンタックスの説明

name

VRF の名前。

management

設定可能な VRF 名を指定します。

コマンドのデフォルト

なし

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

VRF コンフィギュレーション モードを開始すると、次のコマンドが使用可能になります。

exit :現在のコマンド モードを終了します。

ip :IP 機能の設定をイネーブルにします。

Internet Protocol(IP; インターネット プロトコル)コンフィギュレーション モードで使用可能な追加コマンド:

domain-list :追加のドメイン名を追加します。

domain-lookup :DNS lookup をイネーブルまたはディセーブルにします。

domain-name :デフォルト ドメイン名を指定します。

host :IP ホスト名テーブルにエントリを追加します。

name-server :DNS ネームサーバの IP アドレスを指定します。

route :ネクスト ホップ サーバの IP アドレスを指定することで、ルート情報を追加します。

no :コマンドを無効にするか、そのデフォルトに設定します。

shutdown :現在の VRF コンテキストをシャットダウンします。

次に、VRF コンテキスト モードを開始する例を示します。

switch(config)# vrf context management
switch(config-vrf)#

関連コマンド

コマンド
説明

show vrf

VRF 情報を表示します。

 

vtp domain

VLAN トランキング プロトコル(VTP)管理ドメインの名前を設定するには、 vtp domain コマンドを使用します。ドメイン名を削除するには、このコマンドの no 形式を使用します。

vtp domain name

no vtp domain

シンタックスの説明

 

name

VTP ドメイン名。名前には最大 32 文字までの ASCII 文字が指定できます。

コマンドのデフォルト

ブランク

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

 

リリース
変更内容

4.2(1)N1(1)

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用する前に、 feature vtp コマンドを使用してスイッチ上で VTP をイネーブルにする必要があります。

次に、VTP ドメインを作成する例を示します。

switch(config)# vtp domain accounting
switch(config)#
 

関連コマンド

 

コマンド
説明

feature vtp

スイッチ上で VTP をイネーブルにします。

show vtp status

VTP 情報を表示します。

vtp mode

VLAN トランキング プロトコル(VTP)デバイス モードを設定するには、vtp mode コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

vtp mode transparent

no vtp mode

シンタックスの説明

 

transparent

デバイス モードをトランスペアレントとして指定します。

コマンドのデフォルト

トランスペアレント

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

 

リリース
変更内容

4.2(1)N1(1)

このコマンドが追加されました。

次に、VTP モードを設定する例を示します。

switch(config)# vtp mode transparent
switch(config)#
 

関連コマンド

 

コマンド
説明

feature vtp

スイッチ上で VTP をイネーブルにします。

show vtp status

VTP 情報を表示します。

vtp version

VLAN トランキング プロトコル(VTP)バージョンに管理ドメインを設定するには、 vtp version コマンドを使用します。デフォルト バージョンに戻すには、このコマンドの no 形式を使用します。

vtp version version

no vtp version

シンタックスの説明

 

version

VTP バージョン。有効な範囲は 1 ~ 2 です。

コマンドのデフォルト

バージョン 1 はイネーブルです。

バージョン 2 はディセーブルです。

コマンド モード

グローバル コンフィギュレーション モード

コマンドの履歴

 

リリース
変更内容

4.2(1)N1(1)

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用する前に、 feature vtp コマンドを使用してスイッチ上で VTP をイネーブルにする必要があります。

VTP をイネーブルにした場合、バージョン 1 またはバージョン 2 のいずれかを設定する必要があります。VTP をトークン リング環境で使用している場合は、バージョン 2 を使用する必要があります。

次に、VTP ドメインを作成する例を示します。

switch(config)# vtp version 2
switch(config)#
 

関連コマンド

 

コマンド
説明

feature vtp

スイッチ上で VTP をイネーブルにします。

show vtp status

VTP 情報を表示します。