Cisco Nexus 5000/6000 シリーズ NX-OS インターフェイス オペレーション ガイド リリース 6.0(2)N1(1)
拡張 vPC の使用
拡張 vPC の使用
発行日;2013/06/19 | 英語版ドキュメント(2013/03/27 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

拡張 vPC の使用

拡張 vPC について

サポートされるプラットフォーム

拡張 vPC トポロジとスケーラビリティ

サポートされる拡張 vPC トポロジ

サポートされない拡張 vPC トポロジ

ホストと、単一の Cisco Nexus 5500 シリーズ デバイスに接続された FEX ペア間の vPC

複数の FEX からのポートとホスト間のポート チャネル

拡張 vPC のスケーラビリティ

Cisco Nexus 5000 シリーズ デバイスごとの FEX の合計数

FCoE を使用する拡張 vPC

SAN A と SAN B のトラフィックの分離

FEX アップリンクのトラフィック ロード

拡張 vPC の障害対応

ポート チャネル メンバ ポートの障害

FEX の障害

Cisco Nexus 5000 シリーズ デバイスの障害

FEX アップリンクの障害

vPC ピア リンクの障害

vPC キープアライブの障害

拡張 vPC の展開とモニタリング

拡張 vPC の設定

拡張 vPC の整合性検査

ポート チャネル ID の検査

異なるポート チャネル メンバ

グローバルな vPC 整合性検査

ポート チャネル インターフェイス レベルの設定検査

拡張 vPC での FCoE の設定

拡張 vPC でのソフトウェア アップグレード

拡張 vPC でのトラフィックの監視

拡張 vPC の使用

この章では、拡張仮想ポートのチャネリング(vPC)の概要について説明します。

この章の内容は、次のとおりです。

「拡張 vPC について」

「拡張 vPC トポロジとスケーラビリティ」

「拡張 vPC のスケーラビリティ」

「FCoE を使用する拡張 vPC」

「拡張 vPC の障害対応」

「拡張 vPC の展開とモニタリング」

拡張 vPC について

拡張 vPC を使用すると、1 つのトポロジによるサーバ接続と、高可用性および高帯域幅を保つためのアドレス要件をサポートできます。拡張 vPC は、図 5-1 に示されているトポロジをサポートするテクノロジーです。このトポロジでは、Cisco Nexus 2000 ファブリック エクステンダ(FEX)が Cisco Nexus 5500 シリーズ デバイスのペアにデュアルホーム接続されていると同時に、vPC を使用してホストも FEX のペアにデュアルホーム接続されています。

図 5-1 拡張 vPC トポロジ

 

拡張 vPC では、ホストから FEX、および FEX から Cisco Nexus 5500 シリーズ デバイスへの使用可能なすべてのパスがアクティブとなり、イーサネット トラフィックを伝送し、使用可能な帯域幅を最大限に活用します。拡張 vPC トポロジで使用可能なパスはすべて、イーサネット トラフィックを伝送できます。

拡張 vPC では、シングルホーム接続 FEX トポロジ(図 5-2 を参照)またはデュアルホーム接続 FEX トポロジ(デュアルホーム接続 FEX トポロジの例については図 5-3 を参照)のいずれかを選択できます。

シングルホーム接続 FEX テクノロジーは、802.3ad ポート チャネルをサポートする複数の NIC を搭載したサーバに適しています。デュアルホーム接続 FEX トポロジは NIC が 1 つのサーバに理想的です。これは、デュアルホーム接続では一方の Cisco Nexus 5500 シリーズ デバイスの障害によって FEX がダウンすることがなく、単一 NIC のサーバがネットワークから切り離されないためです。デュアルホーム接続 FEX トポロジは、複数の NIC を搭載したサーバにも導入できますが、802.3ad はサポートされません。拡張 vPC サーバを使用しなければ、FEX が両方の Cisco Nexus 5500 シリーズ デバイスにデュアルホーム接続されている場合、ポート チャネルを FEX に接続できません。

図 5-2 シングルホーム接続 FEX トポロジ

 

図 5-3 デュアルホーム接続 FEX トポロジ

 

デュアルホーム接続 FEX を Cisco Nexus 5000 シリーズ デバイスに接続して、単一 NIC サーバの冗長性を高めるため、また同時に、複数の NIC と FEX を使用するサーバ間でポート チャネルを実行するためには、拡張 vPC を使用します。シングル ホーム接続のサーバとホスト vPC を使用した拡張 vPC の例については、図 5-4 を参照してください。

図 5-4 シングル ホーム接続のサーバとホスト vPC を使用した拡張 vPC

 

サポートされるプラットフォーム

Cisco NX-OS 5.1(3)N1(1) では Cisco Nexus 5548P、Cisco Nexus 5548UP、および Cisco Nexus 5596UP デバイスで拡張 vPC をサポートします。Cisco Nexus 5010 および Cisco Nexus 5020 デバイスは拡張 vPC をサポートできません。拡張 vPC は、Cisco Nexus 5500 シリーズ デバイスで実装され、FEX からの特定の要件はありません。そのため、異なるタイプの FEX を拡張 vPC トポロジに導入できます。

拡張 vPC は、Cisco Nexus 5500 シリーズ デバイスで実行されているレイヤ 3 でサポートされますが、レイヤ 3 CLI や、レイヤ 3 機能が Cisco Nexus 5500 シリーズ デバイスで実装される方法は変更されません。

拡張 vPC の導入により、Cisco Nexus 5500 シリーズ デバイスおよび FEX では、シングルホーム接続 FEX トポロジ、デュアルホーム接続 FEX トポロジ、および拡張 vPC トポロジの 3 つのトポロジがサポートされています。また、FEX とホストが同じ Cisco Nexus 5500 シリーズ デバイスのペアに接続されるハイブリッド トポロジもサポートされています。

拡張 vPC トポロジとスケーラビリティ

サポートされる拡張 vPC トポロジ

図 5-5 に、拡張 vPC トポロジでサポートされる各種のサーバ接続を示します。

図 5-5 さまざまなサーバ接続タイプの拡張 vPC

 

この図は、次の構成を示しています。

シングルホーム接続サーバ:Cisco Nexus 5000 シリーズ デバイスのいずれか、または Cisco Nexus 5000 シリーズ デバイスと FEX の間のリンクに障害が発生した場合にフェールオーバー パスが提供されます (図 5-5 の H1 を参照)。

デュアル ホーム接続サーバが同じ FEX にポート チャネルを実行(図 5-5 の H2 を参照)。

デュアルホーム接続サーバが 2 台の FEX へのポート チャネルを実行:スタティックポート チャネルと LACP ベース ポート チャネルの両方をサポートします。ポート チャネル メンバは、最大 2 台の FEX にまたがって実行できます。(図の H3 を参照)。

デュアルホーム接続サーバが同じ Cisco Nexus 5000 シリーズ デバイス ペアに接続する 2 台の FEX へのポート チャネルを実行:拡張 vPC トポロジは、ホストと、同じ Cisco Nexus 5000 シリーズ デバイス ペアに接続する、ランダムに選択された FEX の間のポート チャネルをサポートします。図 5-5 に示されているように、ホスト H3 が FEX 101 および FEX 102 からのポートへのポート チャネルを実行する一方で、ホスト H4 は FEX 102 および FEX 103 からのポートへのポート チャネルを実行できます。つまり、1 つのポート チャネルを任意の 2 つのラインカードにまたがって使用できます。この設定は、Cisco Nexus 5000 シリーズ デバイスと FEX が EoR デバイスとして導入された場合に、すべての FEX がネットワークに設置されるときに便利です。どの FEX がホスト vPC 接続用の FEX ペアと見なされるか追跡する必要はなく、サーバはポートを使用できる任意の 2 台の FEX に接続できます。

デュアル ホーム接続サーバが Fiber Channel over Ethernet(FCoE)およびイーサネットのポート チャネルを実行:拡張 vPC トポロジはサーバへの FCoE 接続をサポートします。図 5-5 では、ホスト H3 と H4 が CNA を使用して Cisco Nexus 2232PP に接続し、ストレージ トラフィックに FCoE、およびイーサネット トラフィックにポート チャネルを実行できます。FC トラフィックを処理する方法と、拡張 vPC トポロジにおける「SAN A と SAN B のトラフィックの分離」の FC トラフィックの分離を実施する方法については、「FEX アップリンクのトラフィック ロード」を参照してください。

デュアルホーム接続サーバがアクティブ/スタンバイ NIC チーミングを実行:この構成は、デュアルホーム接続 FEX トポロジと同様です。サーバは、アクティブまたはスタンバイ NIC を実行し、2 台以上の FEX に接続できます。図 5-5 の H5 を参照してください。

各種の接続に加え、同じ Cisco Nexus 5000 シリーズ デバイス ペアでシングルホーム接続 FEX トポロジをサポートすることもできます。このような組み合わせをハイブリッド トポロジと呼びます。

サポートされない拡張 vPC トポロジ

ホストと、単一の Cisco Nexus 5500 シリーズ デバイスに接続された FEX ペア間の vPC

図 5-6 に、vPC が、ホストと、Cisco Nexus 5500 シリーズ デバイスに接続されている 2 台の FEX の間にある、サポートされていないトポロジを示します。このトポロジでは、Cisco Nexus 5000 シリーズ デバイスに障害が発生するとサーバがネットワークへの接続を失うため、ハイ アベイラビリティ ソリューションを提供しません。

図 5-6 サポートされていないトポロジ:1 台の Cisco Nexus 5000 シリーズ デバイスを使用したホスト vPC

 

Cisco Nexus 5000 シリーズ デバイスが 1 台しかないときに、マルチホーミング サーバを FEX のペアに接続する必要がある場合は、サーバからアクティブまたはスタンバイ NIC チーミングを実行できます。

複数の FEX からのポートとホスト間のポート チャネル

拡張 vPC では、同一の Cisco Nexus 5000 シリーズ デバイスのペアに接続している最大 2 台の FEX からのポート間にポート チャネルを形成できます。図 5-7 に示されているこのトポロジは、機能せず、サポートされていません。

図 5-7 サポートされないトポロジ:複数の FEX にまたがるホスト vPC

 

このトポロジには、高可用性の面で価値がほとんどなく、ケーブル接続と管理も複雑になります。CLI は、ポート チャネル メンバが複数の FEX からなることを検出すると、設定を拒否します。

拡張 vPC のスケーラビリティ

一般に、拡張 vPC では、Cisco Nexus 5000 シリーズ デバイスと FEX のスケーラビリティは変わりません。スケーラビリティは、デュアルホーム接続 FEX トポロジと同様です。

Cisco Nexus 5000 シリーズ デバイスごとの FEX の合計数

Cisco NX-OS 5.1(3)N1(1) 以降のリリースから、Cisco Nexus 5500 シリーズの各デバイスは、レイヤ 3 を使用しない場合、最大 24 台の FEX を管理およびサポートできます。L3 を使用した場合、Cisco Nexus 5500 シリーズ デバイスごとにサポートされる FEX は 8 台です。拡張 vPC とデュアルホーム接続 FEX トポロジでは、各 FEX が両方の Cisco Nexus 5000 シリーズ デバイスによって管理されます。その結果、Cisco Nexus 5500 シリーズ デバイスの 1 組のペアは、レイヤ 2 およびレイヤ 3 用に最大 24 台の FEX および 16 台の FEX をサポートできます。

Straight Through トポロジ、デュアルホーム接続 FEX トポロジ、および拡張 vPC トポロジでは、スケーラビリティに相違があります。Straight Through トポロジでは、1 台の Cisco Nexus 5000 シリーズ デバイスだけが各 FEX を管理し、Cisco Nexus 5500 シリーズ デバイスのペアが最大 48 台の FEX を管理します。レイヤ 2 でのこの違いを図 5-8 に示します。

図 5-8 FEX のスケーラビリティ

 

Cisco Nexus 5000 シリーズ デバイスのペアによってサポートされる FEX の合計数がこの 2 つのトポロジ間で異なるので、Cisco Nexus 5000 シリーズ デバイスの 1 つのペアごとに 24 台を超える FEX を使用した FEX Straight Through 設計を拡張 vPC トポロジに移行することはできません。

設定は次のようになります。

ホスト vPC の合計数:拡張 vPC を使用すると、各 FEX ポートをホスト vPC の一部にすることができます。ホスト vPC は親である Cisco Nexus 5000 シリーズ デバイスのポート チャネル リソースを使用しません。

ホスト vPC ごとのポート合計数:各ホスト vPC に割り当てることができるポートの合計数は FEX のモデルごとに異なります。

Cisco Nexus 2148 デバイスは、ポート チャネルをサポートしません。Cisco Nexus 2148 デバイスを使用する場合、ホスト vPC には、各 Cisco Nexus 2148 から 1 つずつ、合計で最大 2 つのポートを割り当てることができます。

Cisco Nexus 2248、Cisco Nexus 2224、Cisco Nexus 2232、および Cisco Nexus 2248TP-E デバイスは、ハードウェア ポート チャネルと、ホスト vPC で各 FEX から 8 個ずつ、合計で最大 16 個のポートをサポートします。

FCoE を使用する拡張 vPC

SAN A と SAN B のトラフィックの分離

拡張 vPC トポロジに FCoE を展開できます。従来、SAN ネットワークは SAN A と SAN B の 2 つのファブリックを維持します。サイド A からのトラフィックは、サイド B から分離されます。高可用性を保つため、ホストとストレージ アレイはホスト SAN ネットワークに接続されます。拡張 vPC トポロジの FCoE トラフィックは、2 つの SAN ネットワーク用にトラフィックの分離を維持します。次のように、FCoE コマンドを使用すると、FEX からの FCoE トラフィックが 1 台の Cisco Nexus 5000 シリーズ デバイスにしか送信されないようになります。

N5k-1(config)# fex 101
N5k-1(config-fex)# fcoe
 
N5k-2(config)# fex 102
N5k-2(config-fex)# fcoe
 

この設定では、FEX 101 からの FCoE トラフィックが N5k-1 にしか送信されず、FEX 102 からの FCoE トラフィックは N5k-2 にしか送信されませんが、両方の FEX は両方のデバイスに接続されています。このことは、Cisco Nexus 5000 シリーズ デバイスから FEX への逆方向の FCoE トラフィックにも当てはまり、その場合は FCoE トラフィックが 1 台の FEX だけに送信されます。その結果、SAN A および SAN B の分離が実現されます。

Cisco NX-OS 5.1(3)N1(1) リリース以降は、FCoE は拡張 vPC トポロジとデュアルホーム接続 FEX トポロジに対してもサポートされます。

拡張 vPC を使用したイーサネット専用のネットワークの場合、図 5-9 のホスト H3 と H4 のように、ランダムに選択した FEX のペアにホストを接続することもできます。ただし、SAN ネットワークの同じサイドにマッピングされた 2 台の FEX にホストが接続される可能性があるため、このアプローチは推奨されません。

Cisco NX-OS 5.1(3)N1(1) 以降のリリースでは、ホスト vPC に 4 つのポート(各 FEX に 2 つのポート)を持つトポロジはサポートされません。

図 5-9 拡張 vPC での FCoE トラフィック フロー

 

FEX アップリンクのトラフィック ロード

拡張 vPC トポロジでは、SAN トラフィックの分離のために、FEX からの FCoE トラフィックが 1 台の Cisco Nexus 5000 シリーズ デバイスに転送されるので、FEX アップリンクのトラフィック ロードは均等ではありません。N5k-1 と FEX 101 間の Po101、および N5k-2 と FEX 102 間の Po102 は、FEX と Cisco Nexus 5000 シリーズ デバイスの間の残りの 2 つのポート チャネルより多くのトラフィックを伝送します。FCoE とイーサネット トラフィックの両方を伝送するリンクで好ましくないオーバーサブスクリプションが生じないように、十分な帯域幅を用意する必要があります。

不均等なトラフィック分配を回避するため、FEX を含む FCoE の導入には FEX Straight Through トポロジを推奨します。拡張 vPC トポロジでは、Cisco Nexus 2232 デバイスごとの FCoE トラフィックに対して最大 4 つの 10 ギガバイト イーサネット リンクしか使用できません。ただし、FEX Straight Through トポロジでは、8 つの 10 ギガバイト イーサネット アップリンクすべてが FCoE トラフィックを伝送できます。

入力と出力のキューイング ポリシーを設定することによって、イーサネット トラフィックと FCoE トラフィックの間での FEX アップリンクの帯域幅の共有を制御できます。デフォルト QoS テンプレートは、それぞれに半分ずつ帯域幅を割り当てます。イーサネット トラフィックと FCoE トラフィックの両方を伝送するリンクについては、輻輳が生じた場合、それぞれ保証帯域幅の半分を取得します。輻輳が生じると、各タイプのトラフィックは使用可能な帯域幅をすべて使用できます。イーサネット トラフィックのみを伝送するリンクの場合、イーサネット トラフィックに 10 ギガバイトの帯域幅をすべて使用できます。

拡張 vPC の障害対応

ポート チャネル メンバ ポートの障害

1 つのポート チャネル メンバに障害が発生した場合、トラフィック フローは残りのポート チャネル メンバに移動されます。ホストが 1 台の FEX に対するすべての接続を失った場合、トラフィック フローは、ホストからネットワークおよびネットワークからホストの両方に関して、別のフローにリダイレクトされます。

FEX の障害

FEX に障害が生じると、すべてのフローは拡張 vPC トポロジの 2 番目の FEX に移動されます。いずれの宛先でも、トラフィックが vPC ピアリンクを通過する必要はありません。

Cisco Nexus 5000 シリーズ デバイスの障害

一方の Cisco Nexus 5000 シリーズ デバイスがダウンしても、すべての FEX はもう一方の Cisco Nexus 5000 シリーズ デバイスへの接続を維持します。すべての FEX の前面パネル ポートは、引き続き動作できます。すべてのトラフィック フローは、すべての FEX によって転送が続行されます。

FEX アップリンクの障害

FEX のアップリンクが切断されると、FEX の前面パネル ポートがシャットダウンされ、トラフィックは拡張 vPC トポロジの別の FEX によって伝送されます。

vPC ピア リンクの障害

vPC のセカンダリ デバイスがピア リンクの障害を検出すると、ピア キープアライブ リンクを介してプライマリ デバイスが有効であるかどうかをチェックします。プライマリ デバイスが有効な場合、セカンダリ デバイスはすべての vPC メンバ ポートを一時停止します。拡張 vPC トポロジでは、vPC セカンダリ デバイスは FEX に接続するすべてのインターフェイスを一時停止します。この結果、すべての FEX は、vPC プライマリ デバイスのみに接続されるようになります。すべての FEX ホスト ポートが起動し、トラフィックは引き続き、両方の FEX に分配されます。

ピア リンクに障害が発生したときに FEX は vPC のセカンダリ デバイスに接続されないため、vPC のセカンダリ デバイスは FCoE トラフィックを伝送できず、セカンダリ デバイスは FEX ホスト ポートにバインドされるすべての VFC インターフェイスをシャットダウンします。ホスト上で実行するマルチパス ソフトウェアは、すべての SAN トラフィック フローを残りの VFC インターフェイスに移動します。

セカンダリ デバイスがキープアライブ リンクを介してプライマリ デバイスに到達できない場合、セカンダリ デバイスはその vPC メンバ ポートが起動し続けるようにします。

vPC キープアライブの障害

vPC キープアライブの障害は、vPC とトラフィック フローに影響を及ぼしません。できる限り早急にキープアライブ リンクを検査し、復元することをお勧めします。

拡張 vPC の展開とモニタリング

拡張 vPC の設定

拡張 vPC トポロジでは、FEX は仮想ラインカードであり、FEX の前面パネル ポートは親である Cisco Nexus 5000 シリーズ デバイスの仮想インターフェイスにマッピングされます。CLI の観点からすると、拡張 vPC の設定は、2 台の FEX からのメンバ ポートを持つ通常のポート チャネルと同じです。拡張 vPC を作成するために、CLI vpc vpc ID を入力する必要はありません。次に示すトポロジで拡張 vPC を作成する例を示します。

次の手順では、図 5-10 に示されているトポロジを使用しています。図では、線の横に記載された番号がインターフェイス ID です。すべてのポートがベース ポートであり、インターフェイス ID 2 が Cisco Nexus 5000 シリーズ デバイスのインターフェイス eth1/2 を示していると想定します。

図 5-10 拡張 vPC トポロジの作成

 

最初の Cisco Nexus 5000 シリーズ デバイスでの設定

N5k-1(config)# interface eth101/1/, eth101/1/2
N5k-1(config-if)# channel-group 2 mode active
N5k-1(config-if)# interface eth102/1/, eth102/1/2
N5k-1(config-if)# channel-group 2 mode active
 

2 番目の Cisco Nexus 5000 シリーズ デバイスからの設定

N5k-2(config)# interface eth101/1/, eth101/1/2
N5k-2(config-if)# channel-group 2 mode active
N5k-2(config-if)# interface eth102/1/, eth102/1/2
N5k-2(config-if)# channel-group 2 mode active
 

vPC vPC ID コマンドは必要ありませんが、ソフトウェアは各拡張 vPC に内部の vPC ID を割り当てます。show vpc コマンドの出力で、この内部 vPC ID が示されます。


ステップ 1 vPC および LACP を有効にします。

N5k-1(config)# feature vpc
N5k-1(config)# feature lacp
N5k-2(config)# feature vpc
N5k-2(config)# feature lacp
 

ステップ 2 VLAN を作成します。

N5k-1(config)# vlan 10-20
N5k-2(config)# vlan 10-20
 

ステップ 3 vPC ドメイン ID を割り当て、vPC ピア キープアライブを設定します。

N5k-1(config)# vpc domain 123
N5k-1(config-vpc)# peer-keepalive destination 172.25.182.100
 
N5k-2(config)# vpc domain 123
N5k-2(config-vpc)# peer-keepalive destination 172.25.182.99
 

ステップ 4 vPC ピア リンクを設定します。

N5k-1(config)# interface eth1/1-2
N5k-1(config-if)# channel-group 1 mode active
N5k-1(config-if)# interface Po1
N5k-1(config-if)# switchport mode trunk
N5k-1(config-if)# switchport trunk allowed vlan 1, 10-20
N5k-1(config-if)# vpc peer-link
 
N5k-2(config)# interface eth1/1-2
N5k-2(config-if)# channel-group 1 mode active
N5k-2(config-if)# interface Po1
N5k-2(config-if)# switchport mode trunk
N5k-2(config-if)# switchport trunk allowed vlan 1, 10-20
N5k-2(config-if)# vpc peer-link
 

ステップ 5 FEX 101 を設定します。

N5k-1(config)# fex 101
N5k-1(config-fex)# interface eth1/3-4
N5k-1(config-if)# channel-group 101
N5k-1(config-if)# interface po101
N5k-1(config-if)# switchport mode fex-fabric
N5k-1(config-if)# vpc 101
N5k-1(config-if)# fex associate 101
 
N5k-2(config)# fex 101
N5k-2(config-fex)# interface eth1/3-4
N5k-2(config-if)# channel-group 101
N5k-2(config-if)# interface po101
N5k-2(config-if)# switchport mode fex-fabric
N5k-2(config-if)# vpc 101
N5k-2(config-if)# fex associate 101
 

ステップ 6 FEX 102 を設定します。

N5k-1(config)# fex 102
N5k-1(config-fex)# interface eth1/5-6
N5k-1(config-if)# channel-group 102
N5k-1(config-if)# interface po102
N5k-1(config-if)# switchport mode fex-fabric
N5k-1(config-if)# vpc 102
N5k-1(config-if)# fex associate 102
 
N5k-2(config)# fex 102
N5k-2(config-fex)# interface eth1/5-6
N5k-2(config-if)# channel-group 102
N5k-2(config-if)# interface po102
N5k-2(config-if)# switchport mode fex-fabric
N5k-2(config-if)# vpc 102
N5k-2(config-if)# fex associate 102
 

ステップ 7 拡張 vPC を作成します。

N5k-1(config)# interface eth101/1/1, eth101/1/2
N5k-1(config-if)# channel-group 2 mode active
N5k-1(config-if)# interface eth102/1/1, eth102/1/2
N5k-1(config-if)# channel-group 2 mode active
N5k-1(config-if)# int po2
N5k-1(config-if)# switchport access vlan 10
 
N5k-2(config)# interface eth101/1/1, eth101/1/2
N5k-2(config-if)# channel-group 2 mode active
N5k-2(config-if)# interface eth102/1/1, eth102/1/2
N5k-2(config-if)# channel-group 2 mode active
N5k-2(config-if)# int po2
N5k-2(config-if)# switchport access vlan 10
 


 

上記の手順に示されているように、拡張 vPC 設定は、同じ FEX からのチャネル メンバを含むホスト ポート チャネルを設定する場合と同じ設定です。

拡張 vPC の整合性検査

Cisco NX-OS は望ましくないデータ フォワーディング動作を回避するため、2 台の vPC ピア デバイス間で vPC 関連の設定に整合性があるかどうかを検査します。Cisco NX-OS は、グローバル コンフィギュレーション パラメータとインターフェイス レベル コンフィギュレーション パラメータの両方を検査します。拡張 vPC のグローバル コンフィギュレーション パラメータに対する整合性検査は、デュアルホーム接続 FEX トポロジに対するものと同じです。vPC の整合性検査の詳細については、vPC のオペレーション ガイドを参照してください。

http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/operations/n5k_vpc_ops.html

ポート チャネル ID の検査

Cisco NX-OS では、拡張 vPC の 2 台のピア デバイスで同じポート チャネル ID が使用されている必要があります。同じ FEX ポートに別のポート チャネル ID が使用されていると、ポート チャネルとそのチャネル メンバは一時停止されます。次の例は、FEX インターフェイス eth110/1/1 と eth111/1/1 が 2 台の vPC デバイス上で異なるポート チャネルに割り当てられることを示しています。そのため、両方の Cisco Nexus 5000 シリーズ デバイスで 2 つの FEX インターフェイスが一時停止されており、ポート チャネルは動作しません。

N5596-1# show run int e110/1/1,e111/1/1
 
!Command: show running-config interface Ethernet110/1/1, Ethernet111/1/1
!Time: Sun Aug 28 03:38:23 2011
 
version 5.1(3)N1(1)
 
interface Ethernet110/1/1
channel-group 1002
 
interface Ethernet111/1/1
channel-group 1002
 
N5596-2# show run int e110/1/1,e111/1/1
 
!Command: show running-config interface Ethernet110/1/1, Ethernet111/1/1
!Time: Mon Aug 29 21:01:20 2011
 
version 5.1(3)N1(1)
 
interface Ethernet110/1/1
hardware N2348TP queue-limit 1024000 rx
hardware N2348TP queue-limit 1024000
switchport access vlan 20
channel-group 1001
 
interface Ethernet111/1/1
switchport access vlan 20
channel-group 1001
 
N5596-2#
 
N5596-2# show int e110/1/1
Ethernet110/1/1 is down (suspended by vpc)
Hardware: 100/1000 Ethernet, address: 7081.0500.2402 (bia 7081.0500.2402)
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec
<snip>
 
N5596-1# show int e110/1/1
Ethernet110/1/1 is down (suspended by vpc)
Hardware: 100/1000 Ethernet, address: 7081.0500.2402 (bia 7081.0500.2402)
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec
 
<snip>

異なるポート チャネル メンバ

2 台の Cisco Nexus 5000 シリーズ デバイス間に共通のポート チャネル メンバが少なくとも 1 つあれば、ポート チャネルはアップし、動作します。一方の Cisco Nexus 5000 シリーズ デバイスだけでポート チャネルに割り当てられている FEX インターフェイスは、一時停止されます。次の例では、FEX インターフェイスの eth110/1/1 と eth111/1/1 が N5596-1 の Po1001 に割り当てられています。ただし、N5596-2 では、eth110/1/1 だけが Po1001 に割り当てられています。したがって、eth110/1/1 のみがアクティブなポート チャネル メンバとなり、Po1001 は両方の Cisco Nexus 5000 シリーズ デバイスでアップします。FEX インターフェイス eth111/1/1 は、両方の Cisco Nexus 5000 シリーズ デバイスで一時停止されます。この設定では、ホストは FEX 110 だけに接続されます。

N5k-1(config)# interface eth110/1/1, eth111/1/1
N5k-1(config-if)# channel-group 1001
N5k-1(config-if)# int po1001
N5k-1(config-if)# switchport access vlan 20
 
N5k-2(config)# interface eth110/1/1
N5k-2(config-if)# channel-group 1001
N5k-2(config-if)# int po1001
N5k-2(config-if)# switchport access vlan 20
 
N5596-1(config)# show int e111/1/1
Ethernet111/1/1 is down (suspended by vpc)
Hardware: 100/1000 Ethernet, address: 7081.0500.2582 (bia 7081.0500.2582)
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec
reliability 255/255, txload 1/255, rxload 1/255
N5596-1# show port-channel summary
Flags: D - Down P - Up in port-channel (members)
I - Individual H - Hot-standby (LACP only)
s - Suspended r - Module-removed
S - Switched R - Routed
U - Up (port-channel)
M - Not in use. Min-links not met
 

表 5-1 は、N5596-1 のポート ポートチャネルの概要を示しています。

表 5-1 N5596-1 のポート チャネルの概要

 

グループ
ポート チャネル
タイプ
プロトコル
メンバ
ポート

1

Po1(SU)

Ethernet

LACP

1/1 (P)

E th 1/2 (P)

31

Po31(RU)

Ethernet

LACP

1/21 (P)

E th 1/22 (P)

101

Po101(SD)

Ethernet

--

1/41 (D)

E th 1/42 (D)

102

Po102(SU)

Ethernet

--

1/43 (P)

E th 1/44 (P)

103

Po103(SD)

Ethernet

--

1/10 (D)

E th 1/11 (D)

110

Po110(SU)

Ethernet

--

1/33 (P)

--

111

Po111(SU)

Ethernet

--

1/35 (P)

--

961

Po961(SD)

Ethernet

--

--

--

1001

Po1001(SU)

Ethernet

--

110/1/1 (P)

E th 111/1/1 (D)

2000

Po2000(SD)

Ethernet

--

110/1/3 (D)

E th 110/1/5 (D)

N5596-1#
N5596-2# show int e111/1/1
Ethernet111/1/1 is down (suspended by vpc)
Hardware: 100/1000 Ethernet, address: 7081.0500.2582 (bia 7081.0500.2582)
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec
reliability 255/255, txload 1/255, rxload 1/255
 
N5596-2# show port-channel summary
Flags: D - Down P - Up in port-channel (members)
I - Individual H - Hot-standby (LACP only)
s - Suspended r - Module-removed
S - Switched R - Routed
U - Up (port-channel)
M - Not in use. Min-links not met
 

表 5-2 は、N5596-2 のポート ポートチャネルの概要を示しています。

表 5-2 N5596-2 のポート チャネルの概要

 

グループ
ポート チャネル
タイプ
プロトコル
メンバ
ポート

1

Po1(SU)

Ethernet

LACP

1/1 (P)

1/2 (P)

31

Po31(SD)

Ethernet

--

--

--

32

Po32(RU)

Ethernet

LACP

1/21 (P)

1/22 (P)

101

Po101(SU)

Ethernet

--

1/41 (D)

1/42 (D)

102

Po102(SD)

Ethernet

--

--

--

110

Po110(SU)

Ethernet

--

1/33 (P)

--

111

Po111(SU)

Ethernet

--

1/35 (P)

--

1001

Po1001(SU)

Ethernet

--

110/1/1 (P)

--

グローバルな vPC 整合性検査

グローバルな vPC 整合性検査が実施される設定は、次のように表示されます。

N5596-1# show vpc consistency-parameters global
Legend:
Type 1 : vPC will be suspended in case of mismatch
 

表 5-3 に、vPC の整合性検査を示します。

表 5-3 vPC の整合性検査

 

名前

タイプ

ローカル値

ピア値

QoS

2

([], [], [], [], [],

([], [], [4], [], [],

[])

[])

Network QoS(MTU)

2

(9216, 0, 0, 0, 0, 0)

(1538, 0, 1538, 0, 0,

0)

Network Qos(Pause)

2

(F, F, F, F, F, F)

(F, F, F, F, F, F)

Input Queuing(Bandwidth)

2

(100, 0, 0, 0, 0, 0)

(100, 0, 0, 0, 0, 0)

Input Queuing(Absolute

2

(F, F, F, F, F, F)

(F, F, F, F, F, F)

Priority)

Output Queuing(Bandwidth)

2

(100, 0, 0, 0, 0, 0)

(100, 0, 0, 0, 0, 0)

Output Queuing(Absolute

2

(F, F, F, F, F, F)

(F, F, F, F, F, F)

Priority)

STP Mode

1

MST

Rapid PVST

STP Disabled

1

VLANs 123

None

STP MST Region Name

1

""

""

STP MST Region Revision

1

0

0

STP MST Region Instance to

1

VLAN Mapping

STP Loopguard

1

Disabled

Disabled

STP Bridge Assurance

1

Enabled

Enabled

STP Port Type, Edge

1

Normal, Disabled,

Normal, Disabled,

BPDUFilter、Edge BPDUGuard

Disabled

Disabled

STP MST Simulate PVST

1

Enabled

Enabled

Allowed VLANs

--

1,10,20,58-61,100-102, 1,10,20,58-61,100,1000

N5596-1#

タイプ 2 の整合性検査パラメータでは、両方の vPC デバイスの設定を同一にするためのリマインダとして、警告メッセージが表示されます。vPC と vPC メンバ ポートは、両方の Cisco Nexus 5000 シリーズ デバイスでアップし、実行されます。Cisco NX-OS 5.0(2)N2(1) リリースから、グレースフル整合性検査と呼ばれる拡張機能が導入され、vPC の復元力が改善されました。この機能を使用すると、vPC のセカンダリ デバイスでタイプ 1 の整合性検査に不一致が生じると、その vPC メンバ ポートが一時停止されます。vPC プライマリ デバイスは、vPC の背後にあるネットワーク デバイスの接続性が完全に失われないように、vPC メンバ ポートを動作可能な状態に維持します。

グレースフル整合性検査機能は、デュアルホーム接続 FEX トポロジと拡張 vPC トポロジには機能しません。タイプ 1 の整合性検査パラメータに不一致があると、どちらの vPC デバイスも、デュアルホーム接続 FEX と拡張 vPC に対する vPC メンバ ポートを一時停止します。たとえば、前述の出力は、2 台の Cisco Nexus 5596 デバイスで STP モードの設定に相違があることを示しています。タイプ 1 の設定の不一致によって、デュアルホーム接続 FEX からのすべてのインターフェイスが一時停止されます。

vPC グレースフル整合性検査は、FEX Straight Through トポロジに対して機能します。

ポート チャネル インターフェイス レベルの設定検査

拡張 vPC 設定のポート チャネルには、ポート モード(access と trunk)と trunk モードに許可される VLAN という 2 つの重要なパラメータがあります。

インターフェイス レベルの整合性検査が実施される適用可能な設定パラメータは、show vpc consistency check interface で表示されます。

N5K# show vpc consistency-parameters interface po1000
 
Legend:
Type 1 : vPC will be suspended in case of mismatch
 

表 5-4 に、ポート チャネル インターフェイス レベルの設定検査を示します。

表 5-4 ポート チャネル インターフェイス レベルの設定検査

 

名前
タイプ
ローカル値
ピア値

mode

1

on

on

Speed

1

1000 Mb/s

1000 Mb/s

Duplex

1

full

full

Port Mode

1

access

trunk

MTU

1

1500

1500

Admin port mode

1

Shut Lan

1

No

No

vPC+ Switch-id

1

3000

3000

Allowed VLANs

-

10

1-57,61-3967,4048-4093

Local suspended VLANs

-

10

-

N5596-1#

拡張 vPC での FCoE の設定

Cisco NX-OS 5.1(3)N1(1) よりも前のリリースでは、イーサネット インターフェイスがポート チャネル メンバである場合に、VFC インターフェイスをバインドできるのはポート チャネルのみでした。

次の例は、拡張 vPC を使用して FCoE を設定する方法を示しています。

 
interface eth100/1/1
Channe-group 1001
 
Interface Po1001
Switchport mode trunk
Switchport trunk allowed vlan 1, 100,2000
 
Interface vfc 1
bind interface Po1001
 

この設定モデルでは、ポート チャネルのメンバが 1 つのみである必要があります。ポート チャネルに複数のインターフェイスが存在する拡張 vPC に対してはサポートされません。Cisco NX-OS 5.1(3)N1(1) 以降のリリースでは、VFC インターフェイスを物理インターフェイスにバインドできます。

図 5-11 は FCoE 設定トポロジを示しています。

図 5-11 FCoE 設定トポロジの例

 

この例は、図 5-11 に示されているトポロジの設定方法を示しています。

N5k-1(config)# fex 101
N5k-1(config-fex)# fcoe
N5k-1(config-fex)# interface vfc1
N5k-1(config-if)# bind interface eth101/1/1
 
N5k-2(config)# fex 102
N5k-2(config-fex)# fcoe
N5k-2(config-fex)# interface vfc1
N5k-2(config-if)# bind interface eth102/1/1
 

SAN トラフィックを分離するため、2 つの vPC デバイスの FCoE 部分の設定は異なっており、vPC 整合性検査は実施されません。

fcoe コマンドを入力して、FCoE トラフィックに対して FEX と Cisco Nexus 5000 シリーズ デバイス間の関連性を作成できます。このコマンドを使用して、FEX から FCoE トラフィックをどの Cisco Nexus 5000 シリーズ デバイスに転送すべきかを指定できます。

同じ FEX を両方の Cisco Nexus 5000 シリーズ デバイスに関連付けることはできません。次の例で示されている設定は、FCoE に対して、両方の Cisco Nexus 5000 シリーズ デバイスに関連付けられた同じ FEX が拒否されることを示しています。

N5k-1(config)# fex 101
N5k-1(config-fex)# fcoe
N5k-2(config)# fex 101
N5k-2(config-fex)# fcoe
 

Cisco Nexus 5000 シリーズ デバイスでは、インターフェイスが存在する FEX が、FCoE の観点からすでに Cisco Nexus 5000 シリーズ デバイスに関連付けられている場合のみ、VFC を FEX インターフェイスにバインドできます。次の例では、FEX 101 が N5k-1 に関連付けられています。VFC インターフェイスを FEX 102 からのインターフェイスにバインドしようとすると、コマンドは拒否されます。

 
N5k-1(config)# fex 101
N5k-1(config-fex)# fcoe
N5k-1(config-fex)# interface vfc1
N5k-1(config-if)# bind interface eth102/1/1
 

拡張 vPC トポロジ用に VFC インターフェイスを作成するには、Cisco Nexus 5000 シリーズ デバイスに対する FEX の関連性を設定する必要があります。

拡張 vPC でのソフトウェア アップグレード

拡張 vPC トポロジでは、Cisco NX-OS ソフトウェア アップグレードの手順は変わりません。デュアルホーム接続 FEX トポロジと同じアップグレード手順です。ISSU 条件を満たす場合は、ISSU がサポートされます。ソフトウェア アップグレード/ダウングレードの手順の詳細については、次の URL を参照してください。

http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/upgrade/503_N1_1/n5k_upgrade_downgrade_503.html

拡張 vPC でのトラフィックの監視

各 vPC デバイスがトラフィック フローの半分を伝送する場合、vPC トポロジではトラフィックの監視に問題が生じます。ERSPAN よりも前のバージョンでは、vPC との間で送受信されるすべてのフローを監視するために、両方の vPC デバイスにローカル SPAN を設定する必要があります。この手順では、2 つの SPAN 宛先ポートからのパケット トレースを組み合わせて、完全な表示を得られるようにする必要があります。

Cisco NX-OS 5.1(3)N1(1) 以降のリリースでは、Cisco Nexus 5000 シリーズ デバイスは ERSPAN ソース セッションをサポートします。ERSPAN を使用すると、同じ vPC のすべてのフローを 1 つのスニファから監視し、キャプチャすることができます。次に、拡張 vPC の背後にあるホストからのすべてのトラフィック フローをキャプチャする例を示します。


) Cisco Nexus 5000 シリーズ デバイスは ERSPAN ソース セッションのみをサポートし、ERSPAN 宛先セッションはサポートしません。ERSPAN 宛先セッションをサポートするプラットフォームには、Cisco Nexus 7000 シリーズ デバイス、Cisco Catalyst 6500 シリーズ デバイス、および Cisco Nexus 1010 NAM などがあります。


図 5-12 拡張 vPC でのトラフィックの監視

 

拡張 vPC トポロジでは、ホスト vPC に含まれる 2 台の FEX のいずれかに、ユニキャストおよびマルチキャスト フローを送信できます。次の例は、トラフィック フローの転送先となるパスの識別方法を示しています。次の例では、po1001 が、eth110/1/1 および eth111/1/1 で構成される拡張 vPC ホスト ポート チャネルです。30.30.1.2 から 30.30.3.2 へのユニキャスト フローは FEX 111 に送信されます。N5k-1 から FEX 111 へのどの FEX インターフェイスがフローを伝送するのかを判別するコマンドを入力します。

N5596-1# show port-channel load-balance forwarding-path interface po1001 Vlan 10 Src-ip 30.30.1.2 dst-ip 30.30.3.2 src-mac 0000.0100.1100 dst-mac 0000.0000.0b00
 
Missing params will be substituted by 0's.
Load-balance Algorithm on FEX: source-dest-ip
crc8_hash: Not Used Outgoing port id: Ethernet111/1/1
Param(s) used to calculate load-balance (Unknown unicast, multicast and broadcast packets):
dst-mac: 0000.0000.0b00
vlan id: 10
 

次の例は、FEX 110 とインターフェイス eth110/1/1 が Po1001 のマルチキャスト フローを伝送していることを示しています。

N5596-1# show port-channel load-balance forwarding-path interface po1001 vlan 10 src-mac 0000.0100.1100 dst-mac 0100.5e01.010a src-ip 30.30.1.2 dst-ip 224.1.1.10
Missing params will be substituted by 0's.
Load-balance Algorithm on FEX: source-dest-ip
crc8_hash: Not Used Outgoing port id: Ethernet110/1/1
Param(s) used to calculate load-balance (Unknown unicast, multicast and broadcast packets):
dst-ip: 224.1.1.10
vlan id: 10
N5596-1#