Cisco Nexus 5000 シリーズ NX-OS FCoE オペレーション ガイド リリース 5.0(3)N2(1) Cisco Nexus 5000 プラットフォーム スイッチ用 および Cisco Nexus 5500 プラットフォーム スイッチ用
FCoE ポートの設定例
FCoE ポートの設定例
発行日;2013/04/10 | 英語版ドキュメント(2012/11/21 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

FCoE ポートの設定例

VE ポートの設定例

FCoE VE ポート トポロジの例

FCoE のイネーブル化および QoS 設定の検証

VE ポートの設定

FCoE ポートの設定例

この付録では、FCoE トポロジに関するポートの設定例について説明します。内容は次のとおりです。

「VE ポートの設定例」

「FCoE VE ポート トポロジの例」

「FCoE のイネーブル化および QoS 設定の検証」

「VE ポートの設定」

VE ポートの設定例

ここでは、Cisco Nexus 5000 シリーズ スイッチの FCoE VE ポート実装の設定例を示します。この設定は、スイッチ モードのスイッチを対象としています。FCoE の発信側はこのラボで使用されます。Nexus 5000 シリーズ スイッチの FC GEM に FC F ポート ストレージを直接接続することまたは FCoE ターゲットを使用することのいずれかが可能です。


) この例は、両方のファブリックで 2 台の Cisco Nexus 5000 シリーズ スイッチ間の VE ポートの設定に使用できます。サーバ設定は含まれません。


FCoE VE ポート トポロジの例

図 3-1 に、設定例に使用するトポロジを示します。このトポロジでは、次の設定パラメータを使用しています。

ファブリック A の FCoE VLAN:10

ファブリック A の FCoE VSAN:10

ファブリック B の FCoE VLAN:20

ファブリック B の FCoE VSAN:20

両方のファブリックをまたがるイーサネット専用 VLAN:200

設定時にこれらの値を選択する必要があります。

図 3-1 FCoE VE ポート トポロジ

 


) FCoE VLAN/VSAN の番号がファブリック内で同一である必要はありません。ベスト プラクティスとして、混乱を避けるために、2 台のファブリック間の別の FCoE VLAN 番号および VSAN 番号を使用します。1 台のファブリックに ODD VLAN/VSAN、別のファブリックに EVEN VLAN/VSAN を割り当てる設定が一般的です。これは 2 台のファブリック間で番号を分離するための一例にすぎません。


FCoE のイネーブル化および QoS 設定の検証


ステップ 1 FCoE をイネーブルにします。

switch# configure terminal
switch(config)# feature fcoe
FC license checked out successfully
fc_plugin extracted successfully
FC plugin loaded successfully
FCoE manager enabled successfully
FC enabled on all modules successfully
 

ステップ 2 (任意)デフォルトの Quality of Service(QoS)設定を使用しない場合は、独自のポリシーを指定します。


) 注:カスタム ポリシーを使用するときは、QoS ポリシーに class-fcoe を含める必要があります。


switch(config) system qos
switch(config-sys-qos)# service-policy type qos input fcoe-customized-in-policy-name
switch(config-sys-qos)# service-policy type queuing input fcoe-customized-in-policy-name
switch(config-sys-qos)# service-policy type queuing output fcoe-customized-out-policy-name
switch(config-sys-qos)# service-policy type network-qos fcoe-customized-nq-policy-name
 

ステップ 3 FCoE のポリシーマップが実行コンフィギュレーションに含まれることを確認します。


) 注:ステップ 2 で、カスタマイズされた QoS ポリシーマップ名を指定した場合は、カスタマイズされたマップ名でデフォルト マップ名を必ず置き換えてください。


switch(config-sys-qos)# show policy-map system
 
Type network-qos policy-maps
===============================
 
policy-map type network-qos system
class type network-qos class-fcoe
match qos-group 1
 
pause no-drop
mtu 2158
class type network-qos class-default
match qos-group 0
 
mtu 1500
 
Service-policy (qos) input: system
policy statistics status: disabled
 
Class-map (qos): class-fcoe (match-any)
Match: cos 3
set qos-group 1
 
Class-map (qos): class-default (match-any)
Match: any
set qos-group 0
 
Service-policy (queuing) input: default-in-policy
policy statistics status: disabled
 
Class-map (queuing): class-fcoe (match-any)
Match: qos-group 1
bandwidth percent 50
 
Class-map (queuing): class-default (match-any)
Match: qos-group 0
bandwidth percent 50
 
Service-policy (queuing) output: default-out-policy
policy statistics status: disabled
 
Class-map (queuing): class-fcoe (match-any)
Match: qos-group 1
bandwidth percent 50
 
Class-map (queuing): class-default (match-any)
Match: qos-group 0
bandwidth percent 50
 

Nexus 5000 シリーズの Quality of Service の設定は次の 3 種類の主要要素で構成されています。

クラス マップおよびポリシーマップ タイプ qos:分類用

クラス マップおよびポリシーマップ タイプ network:drop、no drop、キュー サイズなどのネットワーク プロパティ用

クラス マップおよびポリシーマップ タイプ queueing:帯域割り当て用

この演習は、FCoE の帯域割り当てと、COS の設定の変更で構成されています。

QoS に class-fcoe の正しい設定がないと、次の問題が発生する可能性があります。

vFC インターフェイスが起動しない(CNA では FCoE のために DCB パラメータのアドバタイズメントが必要)

I/O のドロップの検出


) QoS には、次のガイドラインがあります。

分類ポリシーマップは入力だけで適用されます

ネットワーク ポリシーマップはグローバル(システム)に適用されます

キューイング ポリシーマップは通常は出力で意味を持ちますが、この演習では CNA から Cisco Nexus 5000 シリーズ スイッチへの帯域割り当ての制御に使用するため、この場合は入力に適用します


 

Cisco NX-OS Release 5.0(2)N1(1) からは、no-drop クラスのバッファ割り当てを変更できます。

switch(config-pmap-nq)# policy-map type network-qos nqos_policy
switch(config-pmap-nq)# class type network-qos nqos_class
switch(config-pmap-nq-c)# pause no-drop buffer-size <size> pause-threshold <threshold> resume-threshold <threshold>
 

ステップ 4 FCoE システム クラスがアクティブであることを確認します。

switch(config-sys-qos)# show queuing interface ethernet 1/1
Ethernet1/1 queuing information:
TX Queuing
qos-group sched-type oper-bandwidth
0 WRR 50
1 WRR 50
RX Queuing
qos-group 0
q-size: 370240, HW MTU: 1500 (1500 configured)
drop-type: drop, xon: 0, xoff: 2314
Statistics:
Pkts received over the port : 0
Ucastpkts sent to the cross-bar : 0
Mcastpkts sent to the cross-bar : 0
Ucastpkts received from the cross-bar : 0
Pkts sent to the port : 0
Pkts discarded on ingress : 0
Per-priority-pause status : Rx (Inactive), Tx (Inactive)
qos-group 1
q-size: 79360, HW MTU: 2158 (2158 configured)
drop-type: no-drop, xon: 128, xoff: 252
Statistics:
Pkts received over the port : 0
Ucastpkts sent to the cross-bar : 0
Mcastpkts sent to the cross-bar : 0
Ucastpkts received from the cross-bar : 0
Pkts sent to the port : 0
Pkts discarded on ingress : 0
Per-priority-pause status : Rx (Inactive), Tx (Inactive)
Total Multicast crossbar statistics:
Mcastpkts received from the cross-bar : 0
 

ステップ 5 両方のアップストリーム Cisco Nexus 5000 シリーズ スイッチ(この例では、CORE_N5k-1 および CORE_N5k-2)で、ステップ 1 およびステップ 4 を繰り返します。

VE ポートの設定

この例の FCoE VLAN および VSAN の番号は次のとおりです。

ファブリック A は FCoE VLAN 10 および VSAN 10 を使用します

ファブリック B は FCoE VLAN 20 および VSAN 20 を使用します


) ファブリック A に 2 台のスイッチとファブリック B に 2 台のスイッチがあります。同じファブリックのスイッチ間で VE ポートを起動するには、スイッチ間で FCoE VLAN/VSAN が一致する必要があります。



ステップ 1 ファブリック A の Nexus 5000 シリーズ スイッチで VSAN を設定します。

switch(config)#
switch(config)# vsan database
switch(config-vsan-db)# vsan 10
 

ステップ 2 ファブリック A のために FCoE VLAN から VSAN へのマッピングを設定し、起動していて、動作していることを確認します。

switch(config)# vlan 10
switch(config-vlan)# fcoe vsan 10
switch(config-vlan)#
switch(config-vlan)# show vlan fcoe
Original VLAN ID Translated VSAN ID Association State
---------------- ------------------ -----------------
10 10 Operational
switch(config-vlan)#
 

ステップ 3 ファブリック A のアップストリーム Nexus 5000 シリーズ スイッチで、ステップ 1 およびステップ 2 を繰り返します。

ステップ 4 ファブリック B の Nexus 5000 で VSAN を設定します。

switch(config)#
switch(config)# vsan database
switch(config-vsan-db)# vsan 20
 

ステップ 5 ファブリック B のために FCoE VLAN から VSAN へのマッピングを設定し、起動していて、動作していることを確認します。

switch(config)# vlan 20
switch(config-vlan)# fcoe vsan 20
switch(config-vlan)#
switch(config-vlan)# show vlan fcoe
Original VLAN ID Translated VSAN ID Association State
---------------- ------------------ -----------------
20 20 Operational
switch(config-vlan)#
 

ステップ 6 ファブリック B のアップストリーム Nexus 5000 シリーズ スイッチで、ステップ 1 およびステップ 2 を繰り返します。

ステップ 7 vFC インターフェイスをバインドする基礎となる 10 ギガビット イーサネット ポートを設定します。VE ポートは、2 台のスイッチ間の FCoE トラフィックを物理的に転送するために、このインターフェイスを使用します。このインターフェイスは、適切な FCoE VLAN およびイーサネット VLAN をトランキングするように設定する必要があります(この例では、イーサネット トラフィックを伝送するために VLAN 200 を使用しています)。

このラボで、スイッチを接続する 10 ギガビット イーサネット インターフェイスを上記のトポロジに示します。

ファブリック A は FCoE VLAN 10 および VSAN 10 を使用します

ファブリック B は FCoE VLAN 20 および VSAN 20 を使用します

PODX-N5K-1(ファブリック A)はイーサネット 1/15 を使用して CORE N5K1 に接続します

PODX-N5K-2(ファブリック B)はイーサネット 1/16 を使用して CORE N5K2 に接続します

ファブリック A における両方のスイッチの設定:

switch(config)# vlan 200
switch(config)# interface ethernet 1/15
switch(config-if)# switchport mode trunk
switch(config-if)# switchport trunk allowed vlan 10, 200
switch(config-if)#
 

ファブリック A における両方のスイッチの設定:

switch(config)# vlan 200
switch(config)# interface ethernet 1/16
switch(config-if)# switchport mode trunk
switch(config-if)# switchport trunk allowed vlan 20, 200
switch(config-if)#
 

ステップ 8 VE ポートにバインドされるスイッチ上の vFC インターフェイスを設定し、VSAN データベースの VSAN 44 にこの vFC インターフェイスを追加します。

VE ポートの vFC 番号を次に示します。

ファブリック A は FCoE VLAN 10 および VSAN 10 を使用します

ファブリック B は FCoE VLAN 20 および VSAN 20 を使用します

POD1-N5K-1(ファブリック A)はイーサネット 1/15 を使用して CORE N5K1 に接続します

POD1-N5K-2(ファブリック B)はイーサネット 1/16 を使用して CORE N5K2 に接続します

POD1-N5K-1(ファブリック A)は vfc 15 を使用し、これをイーサネット 1/15 にバインドします

POD1-N5K-2(ファブリック B)は vfc 16 を使用し、これをイーサネット 1/16 にバインドします

ファブリック A における両方のスイッチの設定:

switch(config)# int vfc 15
switch(config-if)# switchport mode e
switch(config-if)# switchport trunk allowed vsan 10
switch(config-if)# bind interface eth 1/15
switch(config-if)# no shutdown
switch(config-if)# exit
switch(config)# vsan database
switch(config-vsan-db)# vsan 10 interface vfc 15
switch(config-vsan-db)# show vsan membership
vsan 1 interfaces:
fc2/1 fc2/2 fc2/3 fc2/4
fc2/5 fc2/6 fc2/7 fc2/8
vsan 10 interfaces:
vfc15
vsan 4079(evfp_isolated_vsan) interfaces:
vsan 4094(isolated_vsan) interfaces:
switch(config-vsan-db)# exit
 

ファブリック B における両方のスイッチの設定:

switch(config)# int vfc 16
switch(config-if)# switchport mode e
switch(config-if)# switchport trunk allowed vsan 20
switch(config-if)# bind interface eth 1/16
switch(config-if)# no shutdown
switch(config-if)# exit
switch(config)# vsan database
switch(config-vsan-db)# vsan 20 interface vfc 16
switch(config-vsan-db)# show vsan membership
vsan 1 interfaces:
fc2/1 fc2/2 fc2/3 fc2/4
fc2/5 fc2/6 fc2/7 fc2/8
vsan 20 interfaces:
vfc16
vsan 4079(evfp_isolated_vsan) interfaces:
vsan 4094(isolated_vsan) interfaces:
switch(config-vsan-db)# exit

) これらのインターフェイス設定は、同じファブリックで 2 台のスイッチを接続する ISL の両側に設定する必要があることに注意してください。


ステップ 9 vFC が起動し、動作していることを確認します。デフォルトでは、vFC はトランキングとして示されます。適切な物理インターフェイスにバインドされていることおよび VSAN 44 が使用可能で、vFC インターフェイスで起動されていることを確認します。

ファブリック A の両方のスイッチを確認します。

switch(config)# show int vfc 15
vfc15 is trunking
Bound interface is Ethernet1/15
Hardware is Virtual Fibre Channel
Port WWN is 20:0e:00:0d:ec:b4:43:7f
Peer port WWN is 00:00:00:00:00:00:00:00
Admin port mode is E, trunk mode is on
snmp link state traps are enabled
Port mode is TE
Port vsan is 10
Trunk vsans (admin allowed and active) (10)
Trunk vsans (up) (10)
Trunk vsans (isolated) ()
Trunk vsans (initializing) ()
1 minute input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
1 minute output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
13 frames input, 1028 bytes
0 discards, 0 errors
13 frames output, 1180 bytes
0 discards, 0 errors
last clearing of "show interface" counters never
Interface last changed at Sat Nov 6 17:58:39 2010
 

ファブリック A の両方のスイッチを確認します。

switch(config)# show int vfc 16
vfc16 is trunking
Bound interface is Ethernet1/16
Hardware is Virtual Fibre Channel
Port WWN is 20:0e:00:0d:ec:b4:43:7d
Peer port WWN is 00:00:00:00:00:00:00:00
Admin port mode is E, trunk mode is on
snmp link state traps are enabled
Port mode is TE
Port vsan is 20
Trunk vsans (admin allowed and active) (20)
Trunk vsans (up) (20)
Trunk vsans (isolated) ()
Trunk vsans (initializing) ()
1 minute input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
1 minute output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
13 frames input, 1028 bytes
0 discards, 0 errors
13 frames output, 1180 bytes
0 discards, 0 errors
last clearing of "show interface" counters never
Interface last changed at Sat Nov 6 17:58:39 2010