Cisco Nexus 5000 シリーズ NX-OS FCoE オペレーション ガイド リリース 5.0(3)N2(1) Cisco Nexus 5000 プラットフォーム スイッチ用 および Cisco Nexus 5500 プラットフォーム スイッチ用
Cisco Nexus 4000 シリーズ スイッチによる FCoE の設定例
Cisco Nexus 4000 シリーズ スイッチによる FCoE の設定例
発行日;2013/04/10 | 英語版ドキュメント(2012/11/21 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

Cisco Nexus 4000 シリーズ スイッチによる FCoE の設定例

スイッチング モードの Cisco Nexus 5000 シリーズ スイッチ

Cisco MDS ディレクトリ シリーズに接続された Cisco Nexus 5000 シリーズ スイッチの SAN ポート チャネルの設定

Cisco Nexus 4000 シリーズ スイッチに接続された Cisco Nexus 5000 シリーズ スイッチのポート チャネルの設定

Cisco Nexus 4000 シリーズ スイッチの仮想ファイバ チャネル インターフェイスの設定

Cisco Nexus 5000 シリーズ スイッチの VSAN の設定

Cisco Nexus 5000 シリーズ スイッチの FCoE VLAN の設定

Cisco Nexus 4000 シリーズ スイッチの FIP スヌーピング VLAN の設定

FCoE トラフィックを許可する Cisco Nexus 4000 シリーズ スイッチ アップリンクの設定

Cisco Nexus 4000 シリーズ スイッチでの FCoE トラフィック用ブレード サーバ イーサネット インターフェイスの設定

Device Manager を使用した vFC インターフェイスの設定

Cisco Nexus 4000 シリーズ スイッチによる FCoE の設定例

ここでは、FCoE を使用して Cisco MDS 9000 シリーズ ファミリ スイッチの FC ストレージにアクセスする Cisco Nexus 5000 シリーズ スイッチに接続された、Cisco Nexus 4000 シリーズ スイッチに接続する IBM ブレード サーバの設定方法に関する設定例を示します。Cisco Nexus 4000 シリーズ スイッチは FIP スヌーピング ブリッジであるため、CNA で行われる FLOGI は Cisco Nexus 4000 シリーズ スイッチにログインしないで、FCF である Cisco Nexus 5000 シリーズ スイッチにログオンします。Cisco Nexus 4000 シリーズ スイッチ ブレード サーバの vFC インターフェイスを作成しても、Cisco Nexus 5000 シリーズ スイッチがスイッチングと NPV いずれのモードなのかは変更されません。ここで、実際に実行されるファブリック ログインは、Cisco Nexus 5000 シリーズ スイッチのモードによって決まります。

スイッチング モードの Cisco Nexus 5000 シリーズ スイッチ:Cisco Nexus 5000 シリーズ スイッチにログインします。

NPV モードの Cisco Nexus 5000 シリーズ スイッチ:ログインは Cisco MDS 9000 シリーズ ファミリ スイッチまたは NPIV が設定された FC スイッチのアップストリームで行われます。

この例では、スイッチング モードの Cisco Nexus 5000 シリーズ スイッチです。図 5-1 に、例で使用されているトポロジを示します。

図 5-1 Nexus 4000 FCoE ラボ トポロジ

 

次のハードウェアが使用されました。

IBM Blade シャーシ モデル BCH

Qlogic QMI8142 を使用して Windows 2003 を実行している IBM HS22 ブレード サーバ

Cisco NX-OS Release 4.1(2)E1(1) を実行している Cisco Nexus 4000 シリーズ スイッチ

Cisco NX-OS Release 4.1(3)N1(1) を実行している Cisco Nexus 5010 スイッチ

Cisco SAN-OS Release 4.1(3a) を実行する Cisco MDS 9124 ディレクタ スイッチ

EMC CX4-480

この付録は、次の項で構成されています。

「スイッチング モードの Cisco Nexus 5000 シリーズ スイッチ」

「Cisco MDS ディレクトリ シリーズに接続された Cisco Nexus 5000 シリーズ スイッチの SAN ポート チャネルの設定」

「Cisco Nexus 4000 シリーズ スイッチに接続された Cisco Nexus 5000 シリーズ スイッチのポート チャネルの設定」

「Cisco Nexus 4000 シリーズ スイッチの仮想ファイバ チャネル インターフェイスの設定」

「Cisco Nexus 5000 シリーズ スイッチの VSAN の設定」

スイッチング モードの Cisco Nexus 5000 シリーズ スイッチ

この例の手順に従う前に、Cisco Nexus 5000 シリーズ スイッチの基本設定(IP アドレス(mgmt0)、スイッチ名、管理者のパスワードなど)が完了しており、FCoE がディセーブルになっていることを確認してください。

実働環境でこの設定例を使用するには、FC 機能パッケージのライセンスがインストールされている必要があります。そうでない場合は、90 日後に期限切れになる一時ライセンスがあります。ライセンスが期限切れになると、機能はディセーブルになります。

Cisco Nexus 5000 シリーズ スイッチでは、デフォルトで FCoE はディセーブルです。

次に、FCoE をイネーブルにする例を示します。

n5k-2# show interface brief
-------------------------------------------------------------------------------------------------------------
Ethernet VLAN Type Mode Status Reason Speed Port
Interface Ch #
Eth1/1 1 eth access up none 10G(D) --
Eth1/2 1 eth access up none 10G(D) --
[snip]
Eth2/4 1 eth access down SFP not inserted 10G(D) --
--------------------------------------------------------------------------------
Port VRF Status IP Address Speed MTU
--------------------------------------------------------------------------------
mgmt0 -- up 172.25.182.164 1000 1500

) Cisco Nexus 5010 スイッチに搭載された 4x4 GEM カードであるにもかかわらず、FC インターフェイスはありません。


n5k-2# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n5k-2(config)# feature fcoe
FC license checked out successfully fc_plugin extracted successfully FC plugin loaded successfully FCoE manager enabled successfully FC enabled on all modules successfully

) Cisco NX-OS Release 4.1(3)N1(1) 以降では、FCoE をイネーブルにするときにスイッチをリブートする必要はありません。FCoE がイネーブルの場合、Cisco Nexus 5000 シリーズ スイッチは、デフォルトでスイッチング モードです。


n5k-2(config)# show feature
Feature Name Instance State
fcsp 1 disabled
fcoe 1 enabled
fex 1 enabled
 
n5k-2(config)# show interface brief
-------------------------------------------------------------------------------------------------------------
Interface Vsan Admin Admin Status SFP Oper Oper Port
Mode Trunk Mode Speed Channel
Mode (Gbps)
------------------------------------------------------------------------------------------------------------
fc2/1 1 auto on down swl -- --
fc2/2 1 auto on down swl -- --
fc2/3 1 auto on down swl -- --
fc2/4 1 auto on sfpAbsent -- -- --
-----------------------------------------------------------------------------------------------------------
Ethernet VLAN Type Mode Status Reason Speed Port
Interface Ch #
-----------------------------------------------------------------------------------------------------------
Eth1/1 1 eth access up none 10G(D) --
Eth1/2 1 eth access up none 10G(D) --

) FC インターフェイスを表示するには、show interface brief コマンドを使用します。


Cisco MDS ディレクトリ シリーズに接続された Cisco Nexus 5000 シリーズ スイッチの SAN ポート チャネルの設定

次に、Cisco MDS 9000 ディレクタに接続された Cisco Nexus 5000 シリーズ スイッチの SAN ポート チャネルを設定する例を示します。冗長性を確保するために、FC インターフェイスからの SAN ポート チャネルを作成することを推奨します。


ステップ 1 Cisco Nexus 5000 シリーズ スイッチの SAN ポート チャネルを設定します。

Fn5k-2# configure terminal
n5k-2(config)# interface san-port-channel 1
n5k-2(config-if)# interface fc2/1-2
n5k-2(config-if)# channel-group 1

) san-port-channel 1 に fc2/1 fc2/2 を追加したら、ポート チャネルをディセーブルにする必要があります。これは、ポート チャネルのもう一方の端にあるスイッチでも実行する必要があります。次に、インターフェイスを起動するために両端でインターフェイスを停止します。


n5k-2(config-if)# no shut
n5k-2(config-if)# interface san-port-channel 1
n5k-2(config-if)# no shut
n5k-2(config-if)# show san-port-channel database
san-port-channel 1
Administrative channel mode is on Operational channel mode is on Last membership update is successful 2 ports in total, 0 ports up Age of the port-channel is 0d:00h:17m:14s
Ports: fc2/1 [down] fc2/2 [down]
n5k-2(config-if)#

) Cisco MDS 9000 シリーズ ディレクタが設定されていないため、SAN ポート チャネルは、この時点では停止しています。


ステップ 2 Cisco Nexus 5000 シリーズ スイッチと Cisco MDS 9124 スイッチ間のポート チャネルを作成するために Cisco MDS 9124 スイッチを設定します。


) Cisco Nexus 5000 の SAN ポート チャネルを MDS に対して設定してある場合は、Cisco MDS 9000 シリーズ スイッチで同じ設定を行う必要があります。Cisco MDS 9000 シリーズ スイッチの SAN ポート チャネル設定をポート チャネルと呼びます。


mds9124-2# configure terminal
mds9124-2(config)# interface port-channel 1
mds9124-2(config-if)# interface fc1/5, fc1/6
mds9124-2(config-if)# channel-group 1 force

) ポート チャネル 1 に fc1/5 fc1/6 を追加した後にポート チャネルをディセーブルにする必要があります。これは、ポート チャネルのもう一方の端にあるスイッチでも実行する必要があります。次に、インターフェイスを起動するために両端でインターフェイスを停止します。




mds9124-2(config-if)# no shut
mds9124-2(config-if)# interface port-channel 1
mds9124-2(config-if)# no shut
 

ステップ 3 Cisco Nexus 5000 シリーズ スイッチの SAN ポート チャネルが稼働中であることを確認します。 show san-port-channel database コマンドを使用して、SAN ポート チャネルの設定を表示します。

n5k-2(config-if)# show san-port-channel database
san-port-channel 1
Administrative channel mode is on
Operational channel mode is on
Last membership update is successful
2 ports in total, 2 ports up
First operational port is fc2/2
Age of the port-channel is 0d:00h:25m:10s
Ports: fc2/1 [up]
fc2/2 [up] *

Cisco Nexus 4000 シリーズ スイッチに接続された Cisco Nexus 5000 シリーズ スイッチのポート チャネルの設定

次に、Cisco Nexus 4000 シリーズ スイッチに接続された Cisco Nexus 5000 シリーズ スイッチのポート チャネルを設定する例を示します。


ステップ 1 Cisco Nexus 5000 シリーズ スイッチのポート チャネルを設定します。

このポート チャネルは、Cisco Nexus 4000 シリーズ スイッチから Cisco Nexus 5000 シリーズ スイッチに着信するトラフィックに冗長性を提供するように設定されます。この例では、すべての VLAN がポート チャネルを通過できます。FCoE VLAN およびネイティブ VLAN がポート チャネルを通過できる必要があります。実稼働環境では、ネットワーク管理者は、このネットワークを通過するように他の VLAN を指定できます。

n5k-2# configure terminal
n5k-2(config)# feature lacp
n5k-2(config)# interface port-channel 2 mode active
n5k-2(config-if)# interface eth1/9-10
n5k-2(config-if)# channel-group 2
n5k-2(config)# interface port-channel 2
n5k-2(config-if)# switchport mode trunk
n5k-2(config-if)# no shut
n5k-2#
 

ステップ 2 Cisco Nexus 4000 シリーズ スイッチのポート チャネルを設定します。

bch1-n4k-b9# configure terminal
bch1-n4k-b9(config)# feature lacp
bch1-n4k-b9(config)# interface port-channel 20
bch1-n4k-b9(config-if)# interface eth1/15-16
bch1-n4k-b9(config-if)# channel-group 2 mode active
bch1-n4k-b9(config)# interface port-channel 2
bch1-n4k-b9(config-if)# switchport mode trunk
bch1-n4k-b9(config-if)# no shut
bch1-n4k-b9(config-if)#
 

Cisco Nexus 4000 シリーズ スイッチの仮想ファイバ チャネル インターフェイスの設定

次に、Cisco Nexus 4000 シリーズ スイッチの vFC インターフェイスを設定する例を示します。


ステップ 1 Cisco Nexus 5000 シリーズ スイッチで、Cisco MDS 9000 シリーズ スイッチの実稼働 VSAN と一致するように VSAN を設定します。これはワンタイム設定です。

ステップ 2 Cisco Nexus 5000 シリーズ スイッチで、VSAN にマッピングするために FCoE VLAN を設定します(VLAN-to-VSAN マッピング)。これはワンタイム設定です。

ステップ 3 Cisco Nexus 4000 シリーズ スイッチで、Nexus 5000 シリーズ スイッチの FCoE VLAN と一致する FIP スヌーピング VLAN を設定します。これはワンタイム設定です。

ステップ 4 Cisco Nexus 4000 シリーズ スイッチで、FCoE トラフィック(FIP スヌーピング)を許可する、アップリンクを設定します。

ステップ 5 Cisco Nexus 4000 シリーズ スイッチのブレード サーバで、FCoE トラフィックのイーサネット インターフェイスを設定します。

ステップ 6 Cisco Nexus 5000 シリーズ スイッチで、vFC を設定します。

ステップ 7 Cisco Nexus 4000 シリーズ スイッチのブレード サーバで、ブレード サーバの MAC アドレスに vFC をバインドします。

ステップ 8 vFC が正しい VSAN にあることを確認します。


) 上記の作業を完了すると Nexus 4000 からブレード サーバにある FCoE CNA に確実に接続できるようになります。


Cisco Nexus 5000 シリーズ スイッチの VSAN の設定

Fabric Manager、Device Manager、または CLI を使用して Cisco Nexus 5000 シリーズ スイッチの VSAN を設定できます。次に、CLI 設定作業および Fabric Manager または Device Manager GUI の作業の例を示します。

この例は、Cisco MDS 9000 シリーズのストレージが VSAN 2 にあることを示します。Cisco Nexus 5000 シリーズ スイッチに設定されている vFC がストレージ デバイスと通信できるように、VSAN を設定します。

n5k-2# configure terminal
n5k-2(config)# vsan database
n5k-2(config-vsan-db)# vsan 2
n5k-2(config-vsan-db)# show vsan vsan 1 information
name:VSAN0001 state:active
interoperability mode:default
loadbalancing:src-id/dst-id/oxid
operational state:up
vsan 2 information
name:VSAN0002 state:active
interoperability mode:default
loadbalancing:src-id/dst-id/oxid
operational state:down
vsan 4079:evfp_isolated_vsan
vsan 4094:isolated_vsan
 

Cisco Nexus 5000 シリーズ スイッチの FCoE VLAN の設定

VLAN を設定してから、CLI を使用して特定の VSAN に VLAN をマッピングできます。Fabric Manager および Device Manager はこの設定には使用できません。シスコでは、FCoE トラフィックに個別の VLAN および標準イーサネット トラフィックに個別の VLAN を設定することを推奨します。

次に、FCoE VLAN を作成する例を示します。

n5k-2# configure terminal
n5k-2(config)# vlan 30
n5k-2(config-vlan)# fcoe vsan 2
n5k-2(config-vlan)# show vlan fcoe
VLAN
VSAN
Status
--------
--------
--------
30
2
Operational
 

Cisco Nexus 4000 シリーズ スイッチの FIP スヌーピング VLAN の設定

Cisco Nexus 4000 シリーズ スイッチでは、デフォルトで FIP スヌーピング機能はディセーブルです。シスコでは、基本設定中にプロンプトが表示されたら、FCoE および FIP スヌーピングをイネーブルにし、たとえば、適切なサービス クラス(CoS)である no drop、MTU、および QoS を設定して、初期設定後にこれらの機能を手動で設定する必要をなくすことを推奨します。

次に、FIP スヌーピングがイネーブルになっていることを確認する例を示します。

bch1-n4k-b9# show feature
Feature Name Instance State
tacacs 1 disabled lacp 1 enabled [snip] fipsm 1 enabled
 

VLAN 30 として Cisco Nexus 5000 シリーズ スイッチに設定されている FCoE VLAN を使用する場合は、Cisco Nexus 4000 シリーズ スイッチの VLAN を作成するために同じ VLAN 番号を使用する必要があり、この VLAN を FIP スヌーピング VLAN として設定する必要があります。

次に、Cisco Nexus 4000 シリーズ スイッチの VLAN を設定する例を示します。

bch1-n4k-b9# configure terminal
bch1-n4k-b9(config)# vlan 30
bch1-n4k-b9(config-vlan)# fip-snooping enable
 

FCoE トラフィックを許可する Cisco Nexus 4000 シリーズ スイッチ アップリンクの設定

この例では、すべての VLAN が Cisco Nexus 4000 シリーズ スイッチと Cisco Nexus 5000 シリーズ スイッチの間のアップリンクを通過できるようにするポート チャネルを前の項ですでに作成しました。ポート タイプ モード fcf で FIP スヌーピングを行うために、アップリンク(この場合はポート チャネル)をイネーブルにする必要があります。

次に、アップリンクを設定する例を示します。

bch1-n4k-b9# configure terminal
bch1-n4k-b9(config)# interface port-channel 20
bch1-n4k-b9(config-if)# fip-snooping port-mode fcf
 

Cisco Nexus 4000 シリーズ スイッチでの FCoE トラフィック用ブレード サーバ イーサネット インターフェイスの設定

CLI を使用して、ブレード サーバを設定できます。Fabric Manager および Device Manager はこの設定には使用できません。

FCoE VLAN(VLAN 30)がブレード サーバのイーサネット インターフェイス(イーサネット 1/4)を通過できるようにします。ほとんどの場合、CNA のポートでは、通常のイーサネット トラフィックと、異なる VLAN に存在する FCoE トラフィックの両方を許可します。デフォルトでは、Cisco Nexus 4000 シリーズ スイッチ上のすべてのイーサネット インターフェイスは、アクセス モードであり、VLAN 1 にあります。

次に、複数の VLAN(トランク)を許可するようにイーサネット インターフェイスを設定する例を示します。

bch1-n4k-b9#configure terminal
bch1-n4k-b9(config)#interface ethernet 1/4
bch1-n4k-b9(config-if)# switchport mode trunk
bch1-n4k-b9(config-if)# switchport trunk allowed vlan 1,30
 

) 上記のコマンドは必須ではありませんが、許可される VLAN を指定する場合は、FCoE VLAN が例に示すように、許可リストにあることを確認してください。


bch1-n4k-b9(config-if)# spanning-tree port type edge trunk
Warning: Edge port type (portfast) should only be enabled on ports connected to a single
host. Connecting hubs, concentrators, switches, bridges, etc... to this interface when edge port type (portfast) is enabled, can cause temporary bridging loops.
Use with CAUTION
 
Creating vFC Interfaces on the Nexus 5000 - CLI
 

トランク設定が完了したら、Cisco Nexus 5000 シリーズ スイッチの vFC インターフェイスを作成します。Device Manager または CLI を使用して vFC インターフェイスを設定できます。

CNA は Cisco Nexus 4000 シリーズ スイッチのイーサネット インターフェイス eth1/4 で接続されており、Cisco Nexus 5000 シリーズ スイッチに物理的に接続されていないため、FCoE を実施している CNA の MAC アドレスに vFC をバインドする必要があります。現時点では、Cisco Nexus 4000 シリーズ スイッチと相互運用可能なブレード サーバ上の FCoE を実施するベンダーは Qlogic のみです。Qlogic では、標準イーサネット トラフィック用に 1 個と FCoE 専用にもう 1 個の 2 個の個別 MAC アドレスを提供します。

次に、IBM Blade シャーシの特定のブレード サーバから MAC アドレスを指定する例を示します。

bch1-n4k-b9# show fip-snooping vlan-discovery
Legend:
Interface VLAN FIP MAC
Eth1/4 1 00:c0:dd:04:0c:df
Eth1/5 1 00:c0:dd:04:0d:13
 

 

Cisco Nexus 5000 シリーズ スイッチでこのブレード サーバの vFC を作成するには、このブレード サーバで識別されている MAC アドレスを使用します。

次に、vFC が VSAN 2 に移動される例を示します。Cisco Nexus 4000 シリーズ スイッチでデバイスに対する vFC 番号を作成するときのベスト プラクティスとして、いずれのブレード シャーシのいずれのブレード サーバに vFC がマッピングされているのかを簡単に識別できる番号設定方式を作成する必要があります。この例では、1 台目の IBM ブレード シャーシのスロット 4 に搭載されたブレード サーバ BCH1 を使用しています。この例では、このブレード サーバの vFC はインターフェイス vfc104 です。

n5k-2# configure terminal
n5k-2(config)# interface vfc 104
n5k-2(config-if)# bind mac-address 00:c0:dd:04:0c:df
n5k-2(config-if)# no shutdown
n5k-2(config-if)# show vsan membership
vsan 1 interfaces:
fc2/1 fc2/2 fc2/3 fc2/4 san-port-channel 1 vfc104
vsan 2 interfaces:
vsan 4079(evfp_isolated_vsan) interfaces:
vsan 4094(isolated_vsan) interfaces:
n5k-2(config-if)# vsan database ð
this will get to the VSAN database
n5k-2(config-vsan-db)# vsan 2 interface vfc104
n5k-2(config-vsan-db)# show vsan membership
vsan 1 interfaces: fc2/1 fc2/2 fc2/3 fc2/4 san-port-channel 1
vsan 2 interfaces:
vfc104
vsan 4079(evfp_isolated_vsan) interfaces:
n5k-2# show interface vfc104
vfc104 is up
 

バインドされた MAC は 00:c0:dd:04:0c:df、FCF プライオリティは 128、ハードウェアは仮想ファイバ チャネル、ポート WWN は 20:67:00:0d:ec:b2:b9:bf、管理ポート モードは F、トランク モードはオン、SNMP リンク状態トラップはイネーブル、ポート モードは F、FCID は 0xcd0000、ポート VSAN は 2 [snip]

Device Manager を使用した vFC インターフェイスの設定

次に、Device Manager を使用して vFC インターフェイスを作成する例を示します。


ステップ 1 Device Manager を開き、Cisco Nexus 5000 シリーズ スイッチにログインします。

図 5-2 Device Manager の [Login] ウィンドウ

 

ステップ 2 1 台の vFC を設定するには、Device Manager のメニューから [Interface] > [Virtual Interfaces] > [Fibre Channel] を選択します。Quick Configuration ツールを使用して複数の vFC を設定し、物理インターフェイスに一度にバインドすることもできます。

図 5-3 Device Manager のメニュー

 

ステップ 3 [Virtual FC Interfaces] ウィンドウで [Create] をクリックして vFC を作成します。

図 5-4 [Virtual FC Interfaces] ウィンドウ

 

ステップ 4 [Create Virtual FC Interfaces General] ウィンドウで、VFC ID、バインド タイプおよびインターフェイス(バインド タイプに応じて物理または MAC アドレス)を入力し、[Create] をクリックします。新しい vFC ID を持つ vFC を表示するウィンドウが再表示されます。

図 5-5 [Create Virtual FC Interfaces General] ウィンドウ

 


) ベスト プラクティスとして、ブレード サーバに戻る vFC を認識可能な vFC を作成します。たとえば、104 は、ブレード サーバ 4 の BCH1 と相互に関連します。


ステップ 5 [Virtual FC Interfaces] ウィンドウから、[Bind Type] > [macAddress] を選択します。

図 5-6 インターフェイスから MAC アドレスへのバインド タイプの変更

 

バインド タイプが macAddress に設定されている場合、[Bind MAC Address] カラムでブレード サーバの MAC アドレスを入力できます。この例では、00:c0:dd:04:0c:df が MAC アドレスです。デフォルトでは、VSAN メンバーシップが down および VSAN 1 に設定されています。これらのセクションを編集して、たとえば、VSAN 2 および up にすることができます。

ステップ 6 [Apply] をクリックして変更をコミットしてから、[Refresh] をクリックして vFC が稼働していることを検証します。

図 5-7 Device Manager で設定済みの vFC の MAC アドレス

 

これにより、Cisco Nexus 5000 シリーズ スイッチにアップリンクした Cisco Nexus 4000 シリーズ スイッチの FCoE 設定が完了します。ゾーン分割、LUN マスキングなどのファブリック管理は、既存の SAN 管理者ツールを使用して管理されます。vFC は標準 FC デバイスとして Fabric Manager に表示されますが、ホストへの実線ではなく、Cisco Nexus 5000 シリーズ スイッチからホストへの破線が表示されます。

図 5-8 FCoE デバイスを含む Fabric Manager ビュー