Cisco Nexus 5000 シリーズ NX-OS FCoE オペレーション ガイド リリース 5.1(3)N1(1) Cisco Nexus 5000 プラットフォーム スイッチ用 および Cisco Nexus 5500 プラットフォーム スイッチ用
FCoE NPV の使用
FCoE NPV の使用
発行日;2013/03/25 | 英語版ドキュメント(2012/11/21 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

FCoE NPV の使用

FCoE NPV について

FCoE NPV ライセンス

VNP ポート

FCoE NPV の設定

FCoE NPV の機能

FCoE 対応デバイスとの相互運用性

Cisco Nexus 5000、Cisco Nexus 7000、および Cisco MDS 9500 デバイスを使用したネットワーク設計

ETS に対するカスタム QoS の設定

統合リンクと専用リンクの使用

Cisco Nexus 7000 シリーズ デバイス用のストレージ VDC

FCoE および拡張 vPC に関する考慮事項

LACP ベースのホスト vPC を介したイニシエータの SAN ブート

Adapter-FEX を使用した FCoE 機能

概要

Cisco Nexus 5000 シリーズ デバイスでの FCoE ポート プロファイルの作成

Cisco UCS サーバでの vHBA の作成およびポート プロファイルへのバインディング

CIMC を使用したポート プロファイルへの vHBA のバインディング

FCoE NPV の使用

この章では、Cisco Nexus 5000 シリーズ デバイスで Fiber Channel over Ethernet(FCoE)の N ポート バーチャライゼーション(NPV)を設定する方法について説明します。

この章の内容は、次のとおりです。

「FCoE NPV について」

「FCoE NPV ライセンス」

「VNP ポート」

「FCoE NPV の設定」

「FCoE および拡張 vPC に関する考慮事項」

「LACP ベースのホスト vPC を介したイニシエータの SAN ブート」

「Adapter-FEX を使用した FCoE 機能」

FCoE NPV について

Cisco NX-OS Release 5.0(3)N2(1) 以降では、Cisco Nexus 5000 シリーズ デバイスで FCoE NPV がサポートされます。FCoE NPV 機能は、FCoE Initialization Protocol(FIP)スヌーピングの拡張版であり、FCoE 対応ホストから FCoE 対応 FCoE フォワーダ(FCF)デバイスに安全に接続する方法を提供します。FCoE NPV 機能には次の利点があります。

FCoE NPV には、FCF でのホストのリモート管理に付随する管理上およびトラブルシューティング上の問題がありません。

FCoE NPV は、トラフィックエンジニアリング、VSAN 管理、管理、およびトラブルシューティングといった NPV の機能を維持しながら、NVP 機能の拡張として FIP スヌーピングを実装します。

FCoE NPV と NPV を共に使用することで、FC と FCoE ポートを介した通信を同時に行えるようになるため、FC から FCoE トポロジに移動する際に、スムーズに移行できます。

FCoE NPV ライセンス

FCoE NPV をイネーブルにするには、次のいずれかの方法を選択します。

FCoE をイネーブルにしてから NPV をイネーブルにする:この方法では、feature fcoe コマンドを使用して FCoE をイネーブルにしてから、feature npv コマンドを使用して NPV をイネーブルにする必要があります。FCoE がイネーブルになったときのデフォルトの動作モードは、FC スイッチングです。NPV をイネーブルにすると、モードは NPV モードに変わります。NPV モードへの切り替えにより、自動的に書き込み消去が行われ、システムがリロードされます。リロードされると、システムは NPV モードで稼働します。NPV モードを終了し、FC スイッチング モードに戻るには、no feature npv コマンドを入力します。NPV モードを終了すると、書き込み消去とデバイス リロードもトリガーされます。この方法には、ストレージ プロトコル サービス パッケージ(FC_FEATURES_PKG)ライセンスが必要です。

FCoE NPV をイネーブルにする:feature fcoe-npv コマンドを使用して FCoE NPV をイネーブルにすると、モードが NPV に変わります。この方法を使用すると、書き込み消去とリロードは行われません。この方法では、ライセンス パッケージ(FCOE_NPV_PKG)が別途必要です。このライセンスも、ストレージ プロトコル サービス ライセンスに含まれています。

VNP ポート

FCoE NPV ブリッジから FCF への接続は、ポイントツーポイント リンク上でのみサポートされます。これらのリンクは、個々のイーサネット インターフェイスまたはポート チャネル インターフェイスになります。イーサネット インターフェイスに接続された FCF ごとに、vFC インターフェイスを作成し、バインドする必要があります。これらの vFC インターフェイスは、VNP ポートとして設定する必要があります。

VNP ポートでは、FCoE NPV ブリッジが、それぞれ固有の eNode MAC アドレスが付いた複数の eNode を持つ FCoE 対応ホストをエミュレートします。デフォルトでは、VNP ポートはトランク モードでイネーブルになります。

VNP ポートには、複数の VSAN を設定できます。VNP ポート VSAN に対応する FCoE VLAN を、バインドしたイーサネット インターフェイスに設定する必要があります。


) Cisco Nexus 5000 シリーズ デバイスの VNP ポートは、それぞれ固有の Fabric Provided MAC-Addresses(FPMA)が付いた複数のイーサネット ノードを持つ FCoE 対応ホストをエミュレートします。


FCoE NPV の設定

図 6-1 にあるように、FCoE-NPV デバイスは、統合型ネットワーク アダプタ(CNA)と FCoE FCF デバイス間の FIP 制御メッセージおよびファブリック ログイン(FLOGI)をプロキシしています。FIP スヌーピング ブリッジとは異なり、FCoE NPV は VSAN を認識し、CNA から FCF アップリンクへのログインをマッピング(またはピン接続)するときに VSAN を考慮します。イニシエータ(eNode)からの FLOGI については、FCoE NPV および FCF デバイスに接続する各ポート チャネル インターフェイス(VNP)からなる 2 つのリンク間でロードバランスが行われます。


) Cisco Nexus 5000 シリーズ デバイスでは、FCoE NPV 機能によって FLOGI は FDISC に変換されません。



) VNP、VF、および VE の各インターフェイスにバインドされているイーサネット インターフェイス上の FCoE VLAN に対しては、スパニングツリー プロトコル(STP)がディセーブルになります。


図 6-1 FCoE NPV のピン接続、VSAN に基づいた FLOGI

 

FCoE NPV デバイスでは、サーバ側のポートにバインドされた VFC インターフェイスは VF モードで設定され、FCoE FCF 側の VFC インターフェイスは VNP ポートとして設定されます。次の設定例では、FCoE NPV デバイスが FCOE_NPV_PKG ライセンスを使用して FCoE NPV 機能をイネーブルにしています。VNP ポートですべての VSAN を許可する代わりに、特定の VSAN リストを選択して許可することをお勧めします。

 
switch(config)# feature fcoe-npv
switch(config)# vsan database
switch(config-vsan-db)# vsan 1-2
switch(config)# vlan 10
switch(config-vlan)# fcoe vsan 1
switch(config)# vlan 20
switch(config-vlan)# fcoe vsan 2
switch(config)# interface eth1/1
switch(config-if)# switchport mode trunk
switch(config)# interface Eth1/2
switch(config-if)# switchport mode trunk
switch(config)# interface vfc1
switch(config-if)# bind interface eth1/1
switch(config-if)# switchport trunk allowed vsan 1
switch(config-if)# no shut
switch(config)# interface vfc2
switch(config-if)# bind interface eth1/2
switch(config-if)# switchport trunk allowed vsan 2
switch(config-if)# no shut
switch(config)# interface vfc101
switch(config-if)# switchport trunk allowed vsan 10
switch(config-if)# switchport trunk allowed vsan add 20
switch(config-if)# no shut
switch(config)# vsan database
switch(config-vsan-db)# vsan 1 interface vfc1, vfc101
switch(config-vsan-db)# vsan 2 interface vfc2
 

QoS 要件

Cisco Nexus 5500 プラットフォーム デバイスの場合、すべてのタイプの QoS ポリシーマップで class-fcoe を設定する必要があります。

次に、すべての QoS ポリシーマップで class-fcoe を設定する例を示します。

switch# config t
switch(config)# system qos
switch(config-sys-qos)# service-policy type qos input fcoe-default-in-policy
switch(config-sys-qos)# service-policy type queuing input fcoe-default-in-policy
switch(config-sys-qos)# service-policy type queuing output fcoe-default-out-policy
switch(config-sys-qos)# service-policy type network-qos fcoe-default-nq-policy

) 前述の QoS の設定は、Cisco NX-OS Release 5.0(3)N2(1) またはそれ以前のリリースを実行する Cisco Nexus 5548 および Cisco Nexus 5596 プラットフォームでは必須です。NX-OS Release 5.1(3)N1(1) より、この設定は、FCoE トラフィックに対するユーザ定義のカスタム ポリシーがすでに存在している場合を除いて自動的に適用されます。ユーザ定義のポリシーがすでに設定されている場合、デフォルトの QOS ポリシーは適用されません。


FCoE NPV の機能

FiberChannel NPV 機能は次のとおりです。

自動トラフィック マッピング

スタティック トラフィック マッピング

ディスラプティブ ロード バランシング

FCoE NPV ブリッジでの FCoE 転送

VNP ポートを介して受信された CoE フレームは、L2_DA が、VF ポートでホストに割り当てられている FCoE MAC アドレスのいずれかに一致する場合にのみ転送されます。それ以外の場合、これらのフレームは破棄されます。


) ポート チャネルの VNP ポートを介した FCoE NPV では、FIP ネゴシエーションにのみ自動トラフィック マッピングが使用されます。ポート チャネルの VNP ポートを介した FCoE トラフィック分散は、計算されたハッシュ値に基づきます。


FCoE 対応デバイスとの相互運用性

Cisco NX-OS Release 5.0(3)N2(1) 以降、Cisco Nexus 5000 シリーズ デバイスは次の FCoE 対応デバイスと相互運用します。

FCF 機能(FCoE NPV および VE)の実行がイネーブルな Cisco MDS 9000 シリーズ マルチレイヤ デバイス。

FCF 機能(FCoE NPV および VE)の実行がイネーブルな Cisco Nexus 7000 シリーズ デバイス。

FIP スヌーピングがイネーブルな Cisco Nexus 4000 シリーズ デバイス。

Cisco Nexus 5000、Cisco Nexus 7000、および Cisco MDS 9500 デバイスを使用したネットワーク設計

Cisco NX-OS Release 5.2 以降、Cisco Nexus 7000 シリーズ サーバでは、32 ポート 10G SFP+ F1 ラインカードで FCoE 機能がサポートされます。Cisco NX-OS Release 5.2 以降、Cisco MDS 9500 マルチレイヤ ディレクタでは、10 Gbps 8 ポートの FCoE モジュールで FCoE がサポートされます。SAN の設計要件に基づいて、Cisco Nexus 7000 シリーズ、Cisco Nexus 5000 シリーズ、および Cisco MDS 9000 シリーズ デバイスの組み合わせを使用して、単一ホップ、マルチホップ、またはマルチプル ティアの FCoE ネットワークを設計できます。

図 6-2 は、Cisco Nexus 7000 シリーズ、Cisco Nexus 5000 シリーズ、および Cisco MDS 9000 シリーズ デバイスを使用した、推奨されるマルチプル ティアの FCoE 設計トポロジを示しています。Cisco Nexus 5000 シリーズ デバイスは、FCoE NPV および FC NPV を同時に実行でき、既存の SAN ネットワークとの接続性を維持しながら、サーバと CNA の接続性を FCF デバイスに提供します。

図 6-2 FCoE NPV を使用したマルチホップの統合化 FCoE ネットワーク設計

 

ETS に対するカスタム QoS の設定

デフォルトで、Cisco Nexus 5000 シリーズ、Cisco Nexus 7000 シリーズ、および Cisco MDS 9000 シリーズ デバイスは FCoE トラフィックに CoS 値 3 を使用します。FCoE が Cisco Nexus 5000 シリーズ デバイスでイネーブルである場合、CoS 3 は no-drop サービス(PFC 設定)に対して自動的に設定され、輻輳が生じると(ETS 設定)、保証帯域幅の 50 パーセントが FCoE トラフィックに割り当てられます。

FCoE の no-drop トラフィック クラスに対する Cisco Nexus 7000 シリーズ デバイスおよび Cisco MDS 9000 シリーズ デバイスのデフォルト ETS 設定は、70 パーセントです。

Cisco Nexus 7000 シリーズ デバイスで FCoE トラフィックに QoS を設定するには、次のコマンドが必要です。

N7K-1# configure terminal
N7K-1(config)# system qos
N7K-1(config-sys-qos)# service-policy type network-qos default-nq-7e-policy

) Cisco Nexus 7000 シリーズ、Cisco Nexus 5000 シリーズ、および Cisco MDS 9000 シリーズ デバイスの場合、FCoE トラフィックに対するデフォルトの CoS 値 3 を維持しながら、同じエンドツーエンドの保証帯域幅がこの FCoE no-drop クラスに割り当てられていることを確認します。


統合リンクと専用リンクの使用

FCoE の統合リンクと専用リンクのコストと利点の兼ね合いについては、「FCoE の統合リンクおよび専用リンク」の項に説明があります。この項では、Cisco Nexus 7000 シリーズおよび Cisco MDS 9000 シリーズ デバイスを使用して FCoE ネットワークを設計するときに考慮すべき設計上の考慮事項とリンク タイプの選択について取り上げています。

FCoE リンクはストレージ仮想デバイス コンテンツ(VDC)の一部であり、イーサネット VDC の一部ではないため、専用リンクを使用して、Cisco Nexus 7000 シリーズと Cisco Nexus 5000 シリーズ デバイスの間の FCoE トラフィックを伝送することをお勧めします。Cisco Nexus 7000 シリーズ デバイスのストレージ VDC にアクセスする統合リンクは、このリンク上を伝送されるイーサネット トラフィックをドロップします。同様に、Cisco Nexus 7000 シリーズ デバイスでイーサネット VDC の一部として設定されている統合リンクは、そのリンク上で伝送されるすべての FCoE トラフィックをドロップします。イーサネットおよび FCoE トラフィックに専用リンクを使用するネットワーク設計では、LAN と SAN の両ネットワークのハイ アベイラビリティ機能を使用します。

Cisco MDS 9000 シリーズ デバイスはイーサネット トラフィックのスイッチングをサポートしていないため、Cisco Nexus 5000 シリーズおよび Cisco MDS 9000 シリーズ デバイスを接続するインターフェイスにイーサネット VLAN がマップされないようにすることをお勧めします。イーサネット LAN トラフィックを Cisco MDS 9000 シリーズ デバイスに誘導すると、トラフィックのブラック ホールが生じ、トラフィックが失われる可能性があります。

Cisco Nexus 7000 シリーズ デバイス用のストレージ VDC

VDC は Cisco Nexus 7000 シリーズ デバイスで使用できるため、デバイス レベルで仮想化を行うことができ、そこで論理エンティティを作成してプロセスの分離と耐障害性を実現できます。FCoE については、入力トラフィックがストレージ VDC である別個の VDC で処理されるように、専用リンクを設定できます。

Cisco Nexus 7000 シリーズ デバイスでは、次のようにして FCoE トラフィックのストレージ VDC を作成する必要があります。

N7K-1# configure terminal
N7K-1(config)# vdc fcoe_vdc type storage
Note: Creating VDC, one moment please...
N7K-1(config)# limit-resource module-type f1
N7K-1(config)# allow feature-set fcoe
N7K-1(config-vdc)# allocate interface ethernet 3/1-32
 

ポートを移動すると、ソース VDC でこのポートに関連付けられているすべての設定が削除されます。

FCoE および拡張 vPC に関する考慮事項

Cisco NX-OS Release 5.1(3)N1(1) 以降、Cisco Nexus 5000 シリーズ デバイスでは拡張 vPC(EVPC)で FCoE がサポートされます。EVPC トポロジでは、SAN ファブリック分離ルールに違反するため、FCoE トラフィックが FEX から複数の Cisco Nexus 5000 シリーズ デバイスに転送されないようにすることが重要です。

この動作は、各 FEX に 1 台の Cisco Nexus 5000 シリーズ デバイスだけを関連付けることによって実装されます。Cisco Nexus 2000 と Cisco Nexus 5000 のペアは、1 つの FCoE SAN ファブリックのみに属します。

図 6-3 に、eVPC レイヤの vPC を使用した FCoE ネットワーク設計を示します。FEX で受信されたサーバ FCoE トラフィックは、関連付けられた Cisco Nexus 5000 シリーズ デバイスにのみ送信されます。FEX の設定に fcoe コマンドを使用すると、FEX デバイスが 1 台の Cisco Nexus 5000 シリーズ デバイスに関連付けられます。FCoE トラフィックには 1 つの vPC リンクが使用されるので、SAN A と SAN B の分離を実装しやすくなります。

図 6-3 eVPC レイヤの vPC を使用した FCoE ネットワーク設計

 

次に、FEX および Cisco Nexus 5000 シリーズ デバイスを FCoE SAN ファブリックと関連付ける例を示します。

nexus5000-sanA(config)# fex 101
nexus5000-sanA(config-fex)# fcoe
nexus5000-sanB(config)# fex 102
nexus5000-sanB(config-fex)# fcoe
 

) FEX に関連付けられたホスト側の VFC リンクを切断し、FCoE トラフィック障害が生じる可能性があるため、同じ FEX を複数の Cisco Nexus 5000 シリーズ デバイスに関連付けないでください。


LACP ベースのホスト vPC を介したイニシエータの SAN ブート

Cisco NX-OS Release 5.1(3)N1(1) 以降、Cisco Nexus 5000 シリーズ デバイスは Link Aggregation Control Protocol(LACP)ベースの vPC でのイニシエータの SAN ブートをサポートします。この制限事項は、LACP ベースのポート チャネルに固有です。ホスト側の VFC インターフェイスは、ポート チャネル自体ではなく、ポート チャネル メンバにバインドされます。このバインディングにより、最初の構成で LACP ベースのポート チャネルに依存することなく、CNA/ホスト バス アダプタ(HBA)のリンクがアップした時点で、SAN ブート中にホスト側の VFC がアップするようになります。

図 6-4 は、イニシエータが vPC を介して SAN から起動するように設定されたネットワーク設計を示しています。VFC1 は、ポート チャネル 1 の一部である物理インターフェイス Eth101/1/1 にバインドされています。VFC インターフェイスは、ホスト側の vPC のチャネルメンバ状態がアップになると同時にアップになり、イニシエータが vPC を介して SAN から起動できるようにします。

次に、ホスト側 FEX を設定する例を示します。

nexus5000-sanA(config)#fex 101
nexus5000-sanA(config-fex)#fcoe
nexus5000-sanA(config)#interface vfc 1
nexus5000-sanA(config-if)#bind interface eth101/1/1
nexus5000-sanA(config)#interface eth101/1/1
nexus5000-sanA(config-if)#channel-group 1
nexus5000-sanB(config)#fex 102
nexus5000-sanB(config-fex)#fcoe
nexus5000-sanB(config)#interface vfc 1
nexus5000-sanB(config-if)#bind interface eth102/1/1
nexus5000-sanB(config)#interface eth102/1/1
nexus5000-sanB(config-if)#channel-group 1

図 6-4 vPC を介して SAN から起動するように発信側が設定されたネットワーク設計

 


) ホスト vPC 設定への VFC バインディングは、FEX が FEX Straight Through トポロジ(非 EVPC モード)に設定されている場合にのみ許可されます。この機能により、Cisco NX-OS Release 5.1(3)N1(1) よりも前の設定およびサポートされいるすべてのトポロジとの下位互換性が保たれます。



) 複数の VFC インターフェイスと複数の vPC メンバをバインドすることはできません。



) ローカル Cisco Nexus 5000 シリーズ デバイスに関連付けられていない FEX にメンバ ポートが存在する場合は、2 レイヤ vPC トポロジのポート チャネルのメンバに VFC をバインドできません。


Adapter-FEX を使用した FCoE 機能

概要

Cisco NXOS 5.1(3)N1(1) 以降、Cisco Nexus 5000 シリーズ デバイスは、P81E アダプタを使用して Cisco UCS サーバに接続している場合、vEthernet インターフェイス上で FCoE をサポートできます。Cisco UCS P81E 仮想インターフェイス カードは、Cisco UCS C シリーズのラックマウント サーバで使用するように設計され、仮想化が最適化された Fibre Channel over Ethernet(FCoE)PCI Express(PCIe)2.0 x8 10 Gbps アダプタです。Adapter-FEX モードで設定すると、2 つの統合ポートを 2 つの FCoE チャネルに分割できるので、オペレーティング システムに使用できる 4 つの vHBA インターフェイスが作成されます。

図 6-5 は、Adapter-FEX を介した FCoE のトポロジの実装を示しています。Adapter-FEX を介した FCoE ネットワーク設計の場合、Cisco Nexus シリーズ 5000 シリーズと FEX の間に vPC を使用する設定が現在サポートされています。同時に、P81E アダプタのホスト側を Active/Stanby モードに設定する必要があります。FCoE および EVPC トポロジの場合、FEX は FCoE トラフィックの転送に対して 1 つの Cisco Nexus 5000 シリーズ ファブリックに関連付けられます。ホスト HBA は Active/Standby モードに設定されているため、Adapter FEX を介した FcoE のトポロジを実装するには、別個のイーサネットまたは vEthernet から VFC へのマッピングを他の FEX と Cisco Nexus 5000 シリーズ ペアで実行する必要があります。

図 6-5 Adapter-FEX を介した FCoE のトポロジの実装

 

VFC を vEthernet インターフェイスにバインドするには、Cisco Nexus 5000 シリーズ デバイスで次の設定が必要です。FCoE については、ホスト側で Active/Standby モードを使用して Adapter-FEX を展開できます。

nexus5000-sanA(config)# install feature-set virtualization
nexus5000-sanA(config)# feature-set virtualization
nexus5000-sanA(config)# feature vmfex
nexus5000-sanA(config)# interface vfc 1
nexus5000-sanA(config-if)# bind interface veth 1
nexus5000-sanA(config-if)# interface veth 1
nexus5000-sanA(config-if)# bind interface eth101/1/1 channel 3
nexus5000-sanA(config-if)# interface eth101/1/1
nexus5000-sanA(config-if)# switchport mode vntag
nexus5000-sanA(config-if)# fex 101
nexus5000-sanA(config-fex)# fcoe
 
nexus5000-sanB(config)# interface vfc 2
nexus5000-sanB(config-if)# bind interface veth 2
nexus5000-sanB(config-if)# interface veth 2
nexus5000-sanB(config-if)# bind interface eth102/1/1 channel 4
nexus5000-sanB(config-if)# interface eth102/1/1
nexus5000-sanB(config-if)# switchport mode vntag
nexus5000-sanB(config-if)# fex 102
nexus5000-sanB(config-fex)# fcoe

) 仮想マシンの vNIC は、Cisco Nexus 5000 シリーズ デバイスの vEthernet インターフェイスにマッピングされるため、冗長性を保つために設定された 2 台の Cisco Nexus 5000 シリーズ デバイス間では vEthernet インターフェイス番号が固有である必要があります。



) FCoE トラフィックに専用リンクを使用することにより、FCoE および FCoE NPV 機能を FabricPath と共存させることができます。



) VNP ポートを使用して Cisco Nexus 5000 シリーズ デバイスに接続しているときは、Cisco UCS P81E アダプタで NPIV モードはサポートされません。



) Cisco UCS P81E 仮想インターフェイス カードを使用したイニシエータの SAN ブートは、ネットワーク インターフェイスの仮想化機能がイネーブルである場合のみサポートされます。


Cisco Nexus 5000 シリーズ デバイスでの FCoE ポート プロファイルの作成

Cisco Nexus 5000 シリーズ デバイスで vEthernet ポート プロファイルを作成するためおよび vCenter への接続を形成するためには、次の設定が必要です。

ポート プロファイルの設定:

nexus5000-sanA(config)# config t
nexus5000-sanA(config)# port-profile type vethernet vnic-fcoe-1
nexus5000-sanA(config)# switchport mode trunk
nexus5000-sanA(config)# switchport trunk allowed vlan 1,100
nexus5000-sanA(config)# state enabled
 

vCenter への SVS 接続:

nexus5000-sanA(config)# svs connection vCenter-Nexus5000
nexus5000-sanA(config)# protocol vmware-vim
nexus5000-sanA(config)# remote ip address 172.28.3.19 port 80 vrf management
nexus5000-sanA(config)# dvs-name SJC-LAB
nexus5000-sanA(config)# vmware dvs datacenter-name TME-LAB
nexus5000-sanA(config)# connect

) vCenter を使用して SVS 接続を設定すると、Cisco Nexus 5000 シリーズ デバイスで作成されたポート プロファイルが自動的に vCenter にプッシュされます。


Cisco UCS サーバでの vHBA の作成およびポート プロファイルへのバインディング

UCS サーバの Cisco UCS P81E アダプタの Adapter-FEX 機能は、Cisco UCS Manager CLI を使用して設定します。次に、Cisco UCS Manager CLI に接続して、vHBA インターフェイスを作成する例を示します。

sjc-xdm-054$ ssh -l admin ucs-afex-02.cisco.com
admin@ucs-afex-02.cisco.com's password:
ucs-afex-02# scope chassis
ucs-afex-02 /chassis # show adapter
 
PCI Slot Product Name Serial Number Product ID Vendor
-------- -------------- -------------- -------------- --------------------
1 UCS VIC P81E QCI1532A34U N2XX-ACPCI01 Cisco Systems Inc
ucs-afex-02 /chassis # scope adapter 1
ucs-afex-02 /chassis/adapter # set niv-mode enabled
ucs-afex-02 /chassis/adapter # create host-fc-if vHBA-P81E-01
ucs-afex-02 /chassis/adapter # set port-profile vnic-fcoe-1
ucs-afex-02 /chassis/adapter/host-fc-if *# set channel-number 7
ucs-afex-02 /chassis/adapter/host-fc-if *# commit
ucs-afex-02 /chassis/adapter/host-fc-if # show detail
Name vHBA-P81E-01:
World Wide Node Name: 10:00:E8:B7:48:4E:0A:A0
World Wide Port Name: 20:00:E8:B7:48:4E:0A:A0
FC SAN Boot: disabled
Persistent LUN Binding: disabled
Uplink Port: 0
MAC Address: E8:B7:48:4E:0A:A0
CoS: N/A
VLAN: NONE
Rate Limiting: N/A
PCIe Device Order: ANY
EDTOV: 2000
RATOV: 10000
Maximum Data Field Size: 2048
Channel Number: 5
Port Profile: vnic-fcoe-1

) Cisco NX-OS Release OS 5.1(3)N1(1) の Cisco UCS C シリーズ Cisco Integrated Management Controller(CIMC)グラフィカル ユーザ インターフェイス(GUI)を使用した 3 つ以上の vHBA インターフェイスの作成はサポートされていません。


CIMC を使用したポート プロファイルへの vHBA のバインディング

UCS C シリーズ サーバの CLI を使用して作成された仮想 HBA インターフェイスは、CIMC GUI を使用してポート プロファイルにマッピングできます。CIMC は、UCS C シリーズ サーバ用の管理サービスであり、サーバ内で実行されます。CIMC コンポーネントには、Web ブラウザを使用してアクセスできます。

Cisco Nexus 5000 シリーズ デバイスに作成されたポート プロファイルは、VNTag リンクを使用して Cisco UCS P81E アダプタにプッシュされます。VNTag は、アダプタによって送信元と宛先の vNIC を識別するために割り当てられる固有のタグです。ポート プロファイルは、CIMC のドロップダウン メニューに表示されます。

図 6-6 は、CIMC ツールを使用してポート プロファイルを vHBA インターフェイスにマッピングする方法を示しています。

図 6-6 CIMC ツールを使用した vHBA インターフェイスへのポート プロファイルのマッピング