Cisco Nexus 5000 シリーズ NX-OS FCoE オペレーション ガイド リリース 5.1(3)N1(1) Cisco Nexus 5000 プラットフォーム スイッチ用 および Cisco Nexus 5500 プラットフォーム スイッチ用
vPC を使用した FCoE の設定例
vPC を使用した FCoE の設定例
発行日;2013/03/25 | 英語版ドキュメント(2012/11/21 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

vPC を使用した FCoE の設定例

Cisco Nexus 5000 シリーズ スイッチの vPC の設定例

Cisco Nexus 5000 シリーズ スイッチの FCoE の設定例

vPC を使用した FCoE の設定例

Cisco NX-OS Release 4.1(3)N1(1) 以降では、Cisco Nexus 5000 シリーズ スイッチは、設定することによって帯域幅を増やせる vPC と、イーサネット ファブリックに対する増強されたロードバランシングをサポートします。この付録では、vPC を使用する場合に、Cisco Nexus 5000 シリーズ スイッチで FCoE を設定する方法に関する設定例を示します。具体的な内容は次のとおりです。

「Cisco Nexus 5000 シリーズ スイッチの vPC の設定例」

「Cisco Nexus 5000 シリーズ スイッチの FCoE の設定例」

図 4-1 に、この付録で説明する例で使用するトポロジを示します。

図 4-1 Nexus 5000 FCoE および vPC ラボ トポロジ

 

設定例では、次のパラメータが含まれています。

switchname: n5k-tme-1

switchname: n5k-tme-2

mgmt ip: 172.25.182.66

mgmt ip: 172.25.182.67

設定例には、次のハードウェアが含まれています。

Dell サーバ PE2950

QLogic QLE8142(Schultz)第 2 世代 CNA

Cisco NX-OS Release 4.1(3)N1(1) を実行している 2 台の Cisco Nexus 5010 スイッチ

設定例は次の考慮事項と要件を含んでいます。

1. DCBX をサポートする第 2 世代 CNA が必要です。

2. 別のスイッチへの単一のホスト CNA ポート チャネル接続。単一スイッチのポート チャネルで、ポート チャネルまたは vPC に複数のメンバー ポートが含まれている場合、FCoE インターフェイスは機能しません。

3. Cisco NX-OS Release 4.1(3)N1(1) またはそれ以降のリリース。

4. FC 機能パッケージ(FC_FEATURES_PKG)は FCoE を実行するために必要です。これがインストールされていない場合、90 日持続する一時ライセンスがあります。

この付録は、次の項で構成されています。

「Cisco Nexus 5000 シリーズ スイッチの vPC の設定例」

「Cisco Nexus 5000 シリーズ スイッチの FCoE の設定例」

Cisco Nexus 5000 シリーズ スイッチの vPC の設定例

この例では、基本設定(IP アドレス(mgmt0)、スイッチ名、管理者のパスワードなど)がスイッチで完了していると仮定します。

次に、基本的な vPC を設定する例を示します。vPC の設定の詳細については、『 Cisco Nexus 5000 Series vPC Quick Configuration Guide 』を参照してください。


) 設定は、vPC トポロジの両方のピア スイッチで実行する必要があります。



ステップ 1 両方のピア スイッチで vPC 機能をイネーブルにします。

tme-n5k-1# conf t
Enter configuration commands, one per line. End with CNTL/Z.
tme-n5k-1(config)# feature vpc
tme-n5k-1(config)#
 
tme-n5k-2# conf t
Enter configuration commands, one per line. End with CNTL/Z.
tme-n5k-2(config)# feature vpc
tme-n5k-2(config)#
 

ステップ 2 vPC ドメインおよびピアのキープアライブの宛先を設定します。

tme-n5k-1(config)# vpc domain 2
tme-n5k-1(config-vpc-domain)# peer-keepalive destination 192.165.200.229
 
tme-n5k-2(config)# vpc domain 2
tme-n5k-2(config-vpc-domain)# peer-keepalive destination 192.165.200.230

) この設定では、スイッチ tme-n5k-1 の管理 IP アドレスは 192.165.200.229、スイッチ tme-n5k-2 の管理 IP アドレスは 192.165.200.230 です。


ステップ 3 vPC ピアリンクとして使用するポート チャネル インターフェイスを設定します。

tme-n5k-1(config)# int port-channel 1
tme-n5k-1(config-if)# vpc peer-link

) vPC ピアリンクでは、スパニングツリー ポート タイプは、ネットワーク ポート タイプに変更されます。これにより、STP ブリッジ保証(デフォルトでイネーブル)がディセーブルでなければ、vPC ピアリンクの STP ブリッジ保証がイネーブルになります。


tme-n5k-2(config)# int port-channel 1
tme-n5k-2(config-if)# vpc peer-link
 

ステップ 4 ピア キープアライブに到達できることを確認します。

tme-n5k-1(config)# show vpc peer-keepalive
vPC keep-alive status : peer is alive
--Destination : 172.25.182.167
--Send status : Success
--Receive status : Success
--Last update from peer : (0 ) seconds, (975 ) msec
tme-n5k-1(config)#
 
tme-n5k-2(config)# show vpc peer-keepalive
--PC keep-alive status : peer is alive
--Destination : 172.25.182.166
--Send status : Success
--Receive status : Success
--Last update from peer : (0 ) seconds, (10336 ) msec
tme-n5k-2(config)#
 

ステップ 5 vPC ピア リンク ポート チャネルにメンバー ポートを追加し、このポート チャネル インターフェイスを起動します。

tme-n5k-1(config-if-range)# int po 1
tme-n5k-1(config-if)# switchport mode trunk
tme-n5k-1(config-if)# no shut
tme-n5k-1(config-if)# exit
tme-n5k-1(config)# int eth 1/39-40
tme-n5k-1(config-if-range)# switchport mode trunk
tme-n5k-1(config-if-range)# channel-group 1
tme-n5k-1(config-if-range)# no shut
tme-n5k-1(config-if-range)#
 
tme-n5k-2(config-if-range)# int po 1
tme-n5k-2(config-if)# switchport mode trunk
tme-n5k-2(config-if)# no shut
tme-n5k-2(config-if)# exit
tme-n5k-2(config)# int eth 1/39-40
tme-n5k-2(config-if-range)# switchport mode trunk
tme-n5k-2(config-if-range)# channel-group 1
tme-n5k-2(config-if-range)# no shut
tme-n5k-2(config-if-range)#
 
tme-n5k-1(config-if-range)# show int po1
port-channel 1 is up
Hardware: Port-Channel, address: 000d.ecde.a92f (bia 000d.ecde.a92f)
MTU 1500 bytes, BW 20000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA
Port mode is trunk
full-duplex, 10 Gb/s
Beacon is turned off
Input flow-control is off, output flow-control is off
Switchport monitor is off
Members in this channel: Eth1/39, Eth1/40
Last clearing of "show interface" counters never
1 minute input rate 1848 bits/sec, 0 packets/sec
1 minute output rate 3488 bits/sec, 3 packets/sec
tme-n5k-1(config-if-range)#
 
tme-n5k-2(config-if-range)# show int po1
port-channel1 is up
Hardware: Port-Channel, address: 000d.ecdf.5fae (bia 000d.ecdf.5fae) MTU 1500 bytes, BW 20000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA
Port mode is trunk
full-duplex, 10 Gb/s
Beacon is turned off
Input flow-control is off, output flow-control is off
Switchport monitor is off
Members in this channel: Eth1/39, Eth1/40
Last clearing of "show interface" counters never
minute input rate 1848 bits/sec, 0 packets/sec
minute output rate 3488 bits/sec, 3 packets/sec
tme-n5k-2(config-if-range)#
 

ステップ 6 vPC を作成し、メンバー インターフェイスを追加します。

tme-n5k-1(config)# int po 11
tme-n5k-1(config-if)# vpc 11
tme-n5k-1(config-if)# switchport mode trunk
tme-n5k-1(config-if)# no shut
tme-n5k-1(config-if)# int eth 1/1
tme-n5k-1(config-if)# switchport mode trunk
tme-n5k-1(config-if)# channel-group 11
tme-n5k-1(config-if)# spanning-tree port type edge trunk
tme-n5k-1(config-if)#

警告 エッジ ポート タイプ(PortFast)は、単一のホストに接続されているポートだけでイネーブルにする必要があります。エッジ ポート タイプ(PortFast)がイネーブルの場合、このインターフェイスにハブ、コンセントレータ、スイッチ、ブリッジなどの一部のデバイスを接続すると、一時的なブリッジング ループが発生することがあります。このタイプの設定は、慎重に行う必要があります


tme-n5k-2(config)# int po 11
tme-n5k-2(config-if)# vpc 11
tme-n5k-2(config-if)# switchport mode trunk
tme-n5k-2(config-if)# no shut
tme-n5k-2(config-if)# int eth 1/1
tme-n5k-2(config-if)# switchport mode trunk
tme-n5k-2(config-if)# channel-group 11
tme-n5k-2(config-if)# spanning-tree port type edge trunk

警告 エッジ ポート タイプ(PortFast)は、単一のホストに接続されているポートだけでイネーブルにする必要があります。エッジ ポート タイプ(PortFast)がイネーブルの場合、このインターフェイスにハブ、コンセントレータ、スイッチ、ブリッジなどの一部のデバイスを接続すると、一時的なブリッジング ループが発生することがあります。このタイプの設定は、慎重に行う必要があります。



) vPC トポロジを介した FCoE を実行するには、ポート チャネルは単一のメンバー インターフェイスのみ持てます。



) ポート チャネル インターフェイスの下に設定された vPC 番号は、両方の Nexus 5000 スイッチで一致する必要があります。ポート チャネル インターフェイス番号が両方のスイッチで一致している必要はありません。


ステップ 7 vPC インターフェイスが起動していて、動作していることを確認します。

tme-n5k-1(config-if)# show vpc statistics vpc 11
port-channel11 is up
vPC Status: Up, vPC number: 11
Hardware: Port-Channel, address: 000d.ecde.a908 (bia 000d.ecde.a908)
MTU 1500 bytes, BW 10000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA
Port mode is trunk
full-duplex, 10 Gb/s
Beacon is turned off
Input flow-control is off, output flow-control is off
Switchport monitor is off
Members in this channel: Eth1/1
Last clearing of "show interface" counters never
minute input rate 4968 bits/sec, 8 packets/sec
minute output rate 792 bits/sec, 1 packets/sec
tme-n5k-1(config-if)#
 
tme-n5k-2(config-if)# show vpc statistics vpc 11
port-channel11 is up
vPC Status: Up, vPC number: 11
Hardware: Port-Channel, address: 000d.ecdf.5fae (bia 000d.ecdf.5fae)
MTU 1500 bytes, BW 10000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA
Port mode is trunk
full-duplex, 10 Gb/s
Beacon is turned off
Input flow-control is off, output flow-control is off
Switchport monitor is off
Members in this channel: Eth1/1
Last clearing of "show interface" counters never
minute input rate 4968 bits/sec, 8 packets/sec
minute output rate 792 bits/sec, 1 packets/sec
tme-n5k-1(config-if)#

Cisco Nexus 5000 シリーズ スイッチの FCoE の設定例

vPC が 2 台の Nexus 5000 間に設定されれば、FCoE トポロジの設定に進むことができます。この虎の巻では、IP アドレス(mgmt0)、スイッチ名、パスワード、管理者などを指定する基本設定が Nexus 5000 スイッチ上で実施済みであり、前の項に従って vPC 設定が完了していると想定しています。次の手順では、vPC トポロジとともに FCoE トポロジを設定するために必要な FCoE の基本設定を行います。


ステップ 1 Nexus 5000 上で FCoE をイネーブルにします。

tme-n5k-1(config)# feature fcoe
FC license checked out successfully
fc_plugin extracted successfully
FC plugin loaded successfully
FCoE manager enabled successfully
FC enabled on all modules successfully
tme-n5k-1(config)#
 
tme-n5k-2(config)# feature fcoe
FC license checked out successfully
fc_plugin extracted successfully
FC plugin loaded successfully
FCoE manager enabled successfully
FC enabled on all modules successfully
fme-n5k-2(config)#

) これが完了するまでに数分かかることがあります。


ステップ 2 VSAN を作成して、FCoE トラフィックの伝送用として指定されている VLAN にマッピングします。

tme-n5k-1(config)# vsan database
tme-n5k-1(config-vsan-db)# vsan 100
tme-n5k-1(config-vsan-db)# exit
tme-n5k-1(config)# vlan 100
me-n5k-1(config-vlan)# fcoe vsan 100
tme-n5k-1(config-vlan)# show vlan fcoe
VLAN VSAN Status
-------- -------- --------
100 100 Operational
tme-n5k-1(config-vlan)#
 
tme-n5k-2(config)# vsan database
tme-n5k-2(config-vsan-db)# vsan 101
tme-n5k-2(config-vsan-db)# exit
tme-n5k-2(config)# vlan 101
tme-n5k-2(config-vlan)# fcoe vsan 101
tme-n5k-2(config-vlan)# show vlan fcoe
VLAN VSAN Status
-------- -------- --------
101 101 Operational
tme-n5k-2(config)#

) VLAN 番号および VSAN 番号が同じである必要はありません。


ステップ 3 vPC リンクの通過を許可される VLAN を設定します。

tme-n5k-1(config)# int po 11
tme-n5k-1(config-if)# switchport trunk allowed vlan 1, 100
tme-n5k-1(config-if)# show int trunk
------------------------------------------------------------------
Port Native Status Port
------------------------------------------------------------------
Eth1/1 1 trnk-bndl Po11
Eth1/39 1 trnk-bndl Po1
Eth1/40 1 trnk-bndl Po1
Po1 1 trunking --
Po11 1 trunking --
 
------------------------------------------------------------------
Port Vlans Allowed on Trunk
------------------------------------------------------------------
Eth1/1 1,100
Eth1/39 1-3967,4048-4093
Eth1/40 1-3967,4048-4093
Po1 1-3967,4048-4093
Po11 1,100
 
------------------------------------------------------------------
Port Vlans Err-disabled on Trunk
------------------------------------------------------------------
Eth1/1 none
Eth1/39 100
Eth1/40 100
Po1 100
Po11 none
 
------------------------------------------------------------------
Port STP Forwarding
------------------------------------------------------------------
Eth1/1 none
Eth1/39 none
Eth1/40 none
Po1 1
Po11 1,100
tme-n5k-1(config-if)#
 
tme-n5k-2(config)# int po 11
tme-n5k-2(config-if)# switchport trunk allowed vlan 1, 101
tme-n5k-2(config-if)# show int trunk
------------------------------------------------------------------
Port Native Status Port
------------------------------------------------------------------
Eth1/1 1 trnk-bndl Po11
Eth1/39 1 trnk-bndl Po1
Eth1/40 1 trnk-bndl Po1
Po1 1 trunking --
Po11 1 trunking --
 
------------------------------------------------------------------
Port Vlans Allowed on Trunk
------------------------------------------------------------------
Eth1/1 1,101
Eth1/39 1-3967,4048-4093
Eth1/40 1-3967,4048-4093
Po1 1-3967,4048-4093
Po11 1,101
 
------------------------------------------------------------------
Port Vlans Err-disabled on Trunk
------------------------------------------------------------------
Eth1/1 none
Eth1/39 101
Eth1/40 101
Po1 101
Po11 none
 
------------------------------------------------------------------
Port STP Forwarding
------------------------------------------------------------------
Eth1/1 none
Eth1/39 none
Eth1/40 none
Po1 1
Po11 1,101
tme-n5k-2(config-if)#
 

ステップ 4 仮想ファイバ チャネル インターフェイス(vfc)を作成し、前のステップで作成した VSAN に追加します。

tme-n5k-1(config)# int vfc 1
tme-n5k-1(config-if)# bind interface po11
Warning: VFC will not come up for pre-FIP CNA
tme-n5k-1(config-if)# no shut
tme-n5k-1(config-if)#
 
tme-n5k-2(config)# int vfc 1
tme-n5k-2(config-if)# bind interface po11
Warning: VFC will not come up for pre-FIP CNA
tme-n5k-2(config-if)# no shut
tme-n5k-2(config-if)#
 
tme-n5k-1(config)# vsan database
tme-n5k-1(config-vsan-db)# vsan 100 interface vfc 1
tme-n5k-1(config)# show vsan membership
vsan 1 interfaces:
fc2/1 fc2/2 fc2/3 fc2/4
fc2/5 fc2/6 fc2/7 fc2/8
 
vsan 100 interfaces:
vfc1
 
vsan 4079(evfp_isolated_vsan) interfaces:
 
vsan 4094(isolated_vsan) interfaces:
tme-n5k-1(config)#
 
tme-n5k-2(config)# vsan database
tme-n5k-2(config-vsan-db)# vsan 101 interface vfc 1
tme-n5k-2(config)# show vsan membership
vsan 1 interfaces:
fc2/1 fc2/2 fc2/3 fc2/4
fc2/5 fc2/6 fc2/7 fc2/8
 
vsan 101 interfaces:
vfc1
 
vsan 4079(evfp_isolated_vsan) interfaces:
 
vsan 4094(isolated_vsan) interfaces:
tme-n5k-2(config)#
 

ステップ 5 vfc が起動し、動作していることを確認します。

tme-n5k-1(config-if)# show int brief
------------------------------------------------------------------
Ethernet VLAN Type Mode Status Reason Speed
------------------------------------------------------------------
Eth1/1 1 eth trunk up none 10G(D)
Eth1/2 1 eth access up none 10G(D)
Eth1/38 1 eth access down SFP not inserted 10G(D)
Eth1/39 1 eth trunk up none 10G(D)
Eth1/40 1 eth trunk up none 10G(D)
 
------------------------------------------------------------------
Port-channel VLAN Type Mode Status Reason Speed
------------------------------------------------------------------
Po1 1 eth trunk up none a-10G(D) none
Po11 1 eth trunk up none a-10G(D) none
 
------------------------------------------------------------------
Port VRF Status IP Address Speed MTU
------------------------------------------------------------------
mgmt0 -- up 172.25.182.166 1000 1500
 
------------------------------------------------------------------
Interface Vsan Admin Admin Status SFP Oper Oper Port
------------------------------------------------------------------
vfc1 100 F on up -- F auto --
tme-n5k-1(config-if)#
 
tme-n5k-2(config-if)# show int brief
------------------------------------------------------------------
Ethernet VLAN Type Mode Status Reason Speed Port
------------------------------------------------------------------
Eth1/1 1 eth trunk up none 10G(D) 11
Eth1/2 1 eth access up none 10G(D) --
Eth1/38 1 eth access down SFP not inserted 10G(D) --
Eth1/39 1 eth trunk up none 10G(D) 1
Eth1/40 1 eth trunk up none 10G(D) 1
 
------------------------------------------------------------------
Port-channel VLAN Type Mode Status Reason Speed Protocol
------------------------------------------------------------------
Po1 1 eth trunk up none a-10G(D) none
Po11 1 eth trunk up none a-10G(D) none
 
------------------------------------------------------------------
Port VRF Status IP Address Speed MTU
------------------------------------------------------------------
mgmt0 -- up 172.25.182.167 1000 1500
 
------------------------------------------------------------------
Interface Vsan Admin Admin Status SFP Oper Oper
------------------------------------------------------------------
vfc1 101 F on up -- F auto --
tme-n5k-2(config-if)#
 

ステップ 6 仮想ファイバ チャネル インターフェイスがファブリックにログインしたことを確認します。

tme-n5k-1# show flogi database
------------------------------------------------------------------
INTERFACE VSAN FCID PORT NAME NODE NAME
-----------------------------------------------------------------------
vfc1 100 0x540000 21:00:00:c0:dd:11:2a:01 20:00:00:c0:dd:11:2a:01
 
Total number of flogi = 1.
tme-n5k-2# show flogi database
-----------------------------------------------------------------------
INTERFACE VSAN FCID PORT NAME NODE NAME
------------------------------------------------------------------------
vfc1 101 0x540000 21:00:00:c0:dd:11:2a:01 20:00:00:c0:dd:11:2a:01
 
Total number of flogi = 1.
 
 

ステップ 7 vPC が起動し、動作していることを確認します。

 
tme-n5k-1(config-if)# show vpc statistics vpc 11
port-channel11 is up
vPC Status: Up, vPC number: 11
Hardware: Port-Channel, address: 000d.ecde.a908 (bia 000d.ecde.a908)
MTU 1500 bytes, BW 10000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA
Port mode is trunk
full-duplex, 10 Gb/s
Beacon is turned off
Input flow-control is off, output flow-control is off
Switchport monitor is off
Members in this channel: Eth1/1
Last clearing of "show interface" counters never
1 minute input rate 4968 bits/sec, 8 packets/sec
1 minute output rate 792 bits/sec, 1 packets/sec
 
tme-n5k-2(config-if)# show vpc statistics vpc 11
port-channel11 is up
vPC Status: Up, vPC number: 11
Hardware: Port-Channel, address: 000d.ecdf.5fae (bia 000d.ecdf.5fae)
MTU 1500 bytes, BW 10000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA
Port mode is trunk
full-duplex, 10 Gb/s
Beacon is turned off
Input flow-control is off, output flow-control is off
Switchport monitor is off
Members in this channel: Eth1/1
Last clearing of "show interface" counters never
1 minute input rate 4968 bits/sec, 8 packets/sec
1 minute output rate 792 bits/sec, 1 packets/sec