Cisco Nexus 5000 シリーズ NX-OS アダプタ FEX オペレーション ガイド リリース 5.1(3)N1(1) Cisco Nexus 5000 プラットフォーム スイッチ用 および Cisco Nexus 5500 プラットフォーム スイッチ用
Adapter-FEX の使用
Adapter-FEX の使用
発行日;2013/02/14 | 英語版ドキュメント(2012/11/21 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 713KB) | フィードバック

目次

Adapter-FEX の使用

Adapter-FEX に関する情報

仮想イーサネット インターフェイス、vNIC、およびチャネル番号

サポートされるプラットフォーム

Cisco Nexus 5500 Adapter-FEX トポロジ

スイッチと Adapter-FEX トポロジ

デュアルホーム接続の FEX トポロジ

アクティブ/スタンバイ Adapter-FEX トポロジ

トラブルシューティング

サーバ ネットワーク アダプタ搭載のサーバの削除

別の物理インターフェイスへのサーバの再配置

ポート プロファイルの変更

別のサーバへのサーバ ネットワーク アダプタの再配置

設定例

サーバ ネットワーク アダプタ トポロジを使用するサーバの設定例

Adapter-FEX のデバイスでの設定

Adapter-FEX のアダプタでの設定

アダプタ上の vNIC の設定

サーバ ネットワーク アダプタの初期化

デュアルホーム接続の FEX トポロジの設定例

アクティブ/スタンバイ サーバ ネットワーク アダプタ トポロジの設定例

vPC トポロジにおけるアクティブ/スタンバイ アップリンクを使用した Adapter-FEX の初期化

デュアルホーム接続 FEX へのアクティブ/スタンバイ アップリンクを使用した Adapter-FEX の初期化

仮想イーサネット インターフェイスの設定

仮想イーサネット インターフェイスの自動作成

仮想イーサネット インターフェイスの手動作成

デバイスとサーバ ネットワーク アダプタ間の設定の競合

Adapter-FEX の使用

この章では、Cisco Nexus 5000 シリーズ Adapter-FEX を設定および使用する方法について説明します。

この章の内容は、次のとおりです。

「Adapter-FEX に関する情報」

「仮想イーサネット インターフェイス、vNIC、およびチャネル番号」

「サポートされるプラットフォーム」

「Cisco Nexus 5500 Adapter-FEX トポロジ」

「トラブルシューティング」

「設定例」

Adapter-FEX に関する情報

Cisco Nexus 5000 シリーズ プラットフォームには、Fibre Channel over Ethernet(FCoE)の導入の一部としてインターフェイスの仮想化が組み込まれ、1 つのイーサネット インターフェイスをファイバ チャネル インターフェイスとイーサネット インターフェイスに仮想化できるようになりました。この統合により、イーサネットおよびファイバ チャネル トラフィックの両方で同じリンクを使用できるようになります。

Cisco Fabric Extender Link(FEXLink)アーキテクチャでは、親デバイス(Cisco Nexus 2000 シリーズ ファブリック エクステンダ搭載または非搭載の Cisco Nexus 5000 シリーズ デバイス)に接続する複数のファブリック アップリンクを利用する複数の Cisco Nexus 2000 シリーズ ファブリック エクステンダ(FEX)ホスト/サーバ インターフェイスを仮想化することにより、この概念が拡張されました。

Cisco NX-OS Adapter-FEX は、サーバ I/O 仮想化に FEXLink アーキテクチャの利点を提供して、1 つのイーサネット インターフェイスを介して複数の仮想インターフェイスを作成して、サーバにデュアル ポート NIC を導入し、サーバが通常のイーサネット インターフェイスとして参照する 2 つ以上の仮想インターフェイスを設定できるようにします。このアプローチにより、電力および冷却のコストと、データセンターに必要なネットワーク ポート数が削減されます。


) このマニュアルで使用している IP アドレスは、実際のアドレスを示すものではありません。このマニュアルに記載されている例、設定のサンプル出力、および図は、説明のみを目的として使用されています。


仮想イーサネット インターフェイス、vNIC、およびチャネル番号

Adapter-FEX では、1 つの物理リンクを複数の仮想リンクまたはチャネルに分割するメカニズムを使用します(図 1-1を参照)。各チャネルは、固有のチャネル番号で識別され、その範囲は物理リンクに制限されています。

物理リンクはサーバ ネットワーク アダプタ上のポートを、デバイス上のイーサネット ポートに接続します。これによってチャネルは、デバイス上の仮想イーサネット インターフェイスを使用して、サーバ上の仮想ネットワーク インターフェイス カード(vNIC)に接続できるようになります。

各チャネル上のパケットには、特定の送信元仮想インターフェイス ID(VIF)を持つ仮想ネットワーク タグ(VNTag)が付けられます。VIF によって、レシーバはソース トランスミットがパケットに使用しているチャネルを特定できるようになります。

図 1-1 複数の仮想リンク

 

サポートされるプラットフォーム

アクセス レイヤでは、Adapter-FEX は、サーバ上の FEX 対応アダプタが、インターフェイスの仮想化をサポートする親デバイスに接続していることを必要とします。次のプラットフォームで Adapter-FEX がサポートされています。

Cisco Unified Computing System(UCS)プラットフォームは、UCS サーバと UCS Fabric Interconnect 間の Adapter-FEX をサポートします。

Adapter-FEX は、Cisco Nexus 5500 シリーズ プラットフォームと、Cisco Nexus 5500 シリーズの親デバイスに接続されている Cisco Nexus 2200 ファブリック エクステンダでサポートされます。この実装は、UCS C-Series プラットフォーム用の Cisco UCS P81E 仮想インターフェイス カード(VIC)アダプタや、仮想ネットワーク タグ(VNTag)テクノロジーを実装する Broadcom BCM57712 Convergence Network Interface Card などのサードパーティ製アダプタなど、さまざまな FEX 対応アダプタで機能します。


) Cisco UCS P81E VIC の詳細については、『Cisco UCS C-Series Servers Integrated Management Controller CLI Configuration Guide』の Cisco UCS P81E VIC に関する資料を参照してください。



) Broadcom BCM57712 Convergence NIC については、Broadcom Corp の資料を参照してください。


Cisco Nexus 5500 Adapter-FEX トポロジ

ここでは、このマニュアルに記載されている例で使用されている、サポート対象のトポロジを示します。

スイッチと Adapter-FEX トポロジ

図 1-2 は、Cisco Nexus 5500 シリーズ デバイスに接続されているサーバ ネットワーク アダプタのトポロジを示しています。

図 1-2 Cisco Nexus 5000 シリーズ デバイスに接続されている Adapter-FEX 対応サーバ

 

図 1-3 は、親の Cisco Nexus 5500 シリーズ デバイスに接続されている Cisco Nexus 2000 シリーズ ファブリック エクステンダに接続されたサーバ ネットワーク アダプタのトポロジを示しています。

図 1-3 Cisco Nexus 2000 シリーズ ファブリック エクステンダに接続された Adapter-FEX 対応サーバ

 

デュアルホーム接続の FEX トポロジ

図 1-4 は、仮想ポート チャネル(vPC)トポロジで 2 台のピア Cisco Nexus 5500 シリーズ デバイスに接続している Cisco Nexus 2000 シリーズ ファブリック エクステンダに接続された、サーバ ネットワーク アダプタを示しています。

図 1-4 vPC トポロジでデュアルホーム接続 FEX に接続する Adapter-FEX 対応サーバ

 

アクティブ/スタンバイ Adapter-FEX トポロジ

アクティブ/スタンバイ アップリンクをサポートするアダプタは、次の追加のトポロジをサポートします。


) Cisco UCS P81E 仮想インターフェイス カードは、現在、アクティブ/スタンバイ アップリンクをサポートする唯一のアダプタであり、各仮想 NIC(vNIC)が 2 つのアップリンクのうち、いずれかをアクティブ アップリンクとして選択することを可能にします。もう一方のアップリンクは、スタンバイ アップリンクとして設定できます。詳細については、次の URL の Cisco UCS P81E 仮想インターフェイス カードのマニュアルを参照してください。http://www.cisco.com/en/US/prod/collateral/ps10265/ps10493/data_sheet_c78-558230.html



) アクティブ/スタンバイ トポロジ(1 つのアクティブ アップリンクと 1 つのスタンバイ アップリンク)を使用することを推奨します。使用するアダプタによっては、vNIC ごとにアクティブ アップリンクとスタンバイ アップリンクを選択できます。各アップリンクは、指定された vNIC に対してアクティブ アップリンクとなり、その他の vNIC に対してスタンバイとなります。


図 1-5 は、アクティブ アップリンク インターフェイスによって Cisco Nexus 5500-A デバイスに接続されたサーバ ネットワーク アダプタと、スタンバイ アップリンク インターフェイスによって Cisco Nexus 5500-B デバイスに接続されたサーバ ネットワーク アダプタを示しています。

図 1-5 アクティブ/スタンバイ アップリンクが有効な Adapter-FEX 対応サーバ

 

図 1-6 は、仮想ポート チャネル(vPC)トポロジで 2 台のピア Cisco Nexus 5500 シリーズ デバイスに接続しているデュアルホーム接続の Cisco Nexus 2000 シリーズ ファブリック エクステンダに接続する、サーバ ネットワーク アダプタを示しています。アダプタのアクティブ アップリンク インターフェイスは、ファブリック エクステンダのイーサネット 100/1/15 に接続され、スタンバイ アップリンク インターフェイスは第 2 のファブリック エクステンダのイーサネット 101/1/15 に接続されます。

図 1-6 デュアルホーム接続 FEX へのアクティブ/スタンバイ アップリンクを使用する Adapter-FEX 対応サーバ

 

トラブルシューティング

ここでは、トラブルシューティング手順について説明します。

サーバ ネットワーク アダプタ搭載のサーバの削除

サーバ ネットワーク アダプタに接続しているサーバが Cisco Nexus 5500 シリーズ デバイスに接続されると、サーバ ネットワーク アダプタをサポートするために仮想イーサネット インターフェイスが作成されます。サーバを切断したり、電源を切ったりすると、仮想イーサネット インターフェイスはダウン状態に設定され、手動で削除するまではデバイスに残されたままになります。

サーバを永続的に切断する前に、必ず、no interface virtual Ethernet コマンドを使用してすべての仮想イーサネット インターフェイスをデバイスから削除し、copy running-config startup-config コマンドを使用して実行システム コンフィギュレーションを保存してください。

別の物理インターフェイスへのサーバの再配置

サーバ ネットワーク アダプタに接続しているサーバが、Cisco Nexus 5500 シリーズ デバイスの物理インターフェイスから同じデバイスの別のインターフェイスに再配置されると、新規の仮想イーサネット インターフェイスが作成され、新規の物理インターフェイスにバインドされます。元の物理インターフェイスにバインドされていた元の仮想イーサネット インターフェイスは、削除されるまで存在します。必ず、no interface virtual Ethernet コマンドを使用して元の仮想イーサネット インターフェイスをデバイスから削除し、copy running-config startup-config コマンドを使用して実行システム コンフィギュレーションを保存してください。

(当該の物理インターフェイスにバインドされていた元の仮想イーサネット インターフェイスが存在する)サーバ ネットワーク アダプタ搭載の再配置されたサーバに接続していた物理インターフェイスに、新規のサーバを接続すると、その仮想イーサネット インターフェイスが再利用されます。このトポロジでは、デバイスとサーバ ネットワーク アダプタで設定の競合が発生します(「デバイスとサーバ ネットワーク アダプタ間の設定の競合」 を参照)。

vPC トポロジでは、vNIC の仮想イーサネット番号は両方の vPC ピアで同じでなければなりません。サーバ ネットワーク アダプタを搭載したサーバを、ピア デバイスの仮想イーサネット インターフェイスを削除せずに、物理インターフェイスから vPC ピアのどちらかに存在する別のインターフェイスに移動すると、番号の異なる仮想イーサネット インターフェイスが新たに作成されます。これにより、同期されていない 2 つの vPC ピアが作成され、仮想イーサネット インターフェイスは作成されなくなります。サーバを新規の物理インターフェイスに接続する前に、ピア デバイスにある元の仮想イーサネット インターフェイスを削除する必要があります。

手順


ステップ 1 デバイス上の元の物理インターフェイスをシャットダウンします。

switch# configure terminal
switch(config)# interface ethernet 1
switch(config-if)# shutdown
switch(config-if)# exit
switch(config) #

 

ステップ 2 サーバに関連付けられたすべての仮想イーサネット インターフェイスを削除します。

switch(config)# no interface vethernet 1
switch(config)#

 

この手順を繰り返して、サーバ上のすべての仮想イーサネット インターフェイスを削除します。

ステップ 3 vPC ピア デバイスの物理インターフェイスから VNTag のコンフィギュレーションを削除します。

vPC Peer A:
switch# configure terminal
switch(config)# interface ethernet 1
switch(config-if)# no switchport mode vntag
switch(config-if)#
 
vPC Peer B:
switch# configure terminal
switch(config)# interface ethernet 1
switch(config-if)# no switchport mode vntag
switch(config-if)#
 

ステップ 4 両方の vPC ピア デバイスからサーバのケーブルを取り外します。

ステップ 5 サーバを新規の物理インターフェイスに接続します。

ステップ 6 サーバ ネットワーク アダプタに新規デバイスを設定します。


 

ポート プロファイルの変更

仮想イーサネット インターフェイスの新規ポート プロファイルをデバイスに追加すると、そのポート プロファイルは接続しているすべてのサーバ ネットワーク アダプタにただちに渡され、それらのアダプタで使用可能になります。同様に、ポート プロファイルを削除すると、接続しているすべてのサーバ ネットワーク アダプタからその名前が取り消されます。

サーバ ネットワーク アダプタにはポート プロファイルの名前だけが渡されるので、ポート プロファイル内の設定を変更しても、その内容はサーバ ネットワーク アダプタには渡されません。

新規または既存の vNIC に関連付けるなど、新たに追加したポート プロファイルを使用するときは、サーバのリブートが必要になる場合があります。詳細については、ご使用のアダプタのマニュアルを参照してください。

ポート プロファイルを削除すると、そのポート プロファイルに関連付けられたすべての仮想イーサネット インターフェイスが管理上、ダウン状態に設定されます。

別のサーバへのサーバ ネットワーク アダプタの再配置

サーバ ネットワーク アダプタをサーバから別のサーバに移動すると、vNIC に関する情報などのサーバ ネットワーク アダプタの設定も一緒に移動されます。設定は、サーバ ネットワーク アダプタに保存されます。

設定例

ここでは、設定例を示します。

サーバ ネットワーク アダプタ トポロジを使用するサーバの設定例

ここでは、Adapter-FEX のサーバ ネットワーク アダプタでサーバを設定する方法について説明します。

Adapter-FEX のデバイスでの設定

サーバ ネットワーク アダプタ搭載のサーバに接続されている各 Cisco Nexus 5500 シリーズ デバイスで、Adapter-FEX 機能を有効にする必要があります。また、Adapter-FEX をサポートするようにデバイスを設定する必要があります。

手順


ステップ 1 デバイスに Cisco 仮想マシンの機能セットをインストールします。

switch# configure terminal
switch(config)# install feature-set virtualization
switch(config)#
 

ステップ 2 デバイスで Cisco 仮想マシン機能を有効にします。

switch(config)# feature-set virtualization
switch(config)#
 

ステップ 3 デバイスで仮想イーサネット インターフェイスの自動作成を有効にします。

switch(config)# virtual Ethernet auto-create
switch(config)#
 

Adapter-FEX 機能が、デバイスでイネーブルになります。

ステップ 4 アダプタの vNIC に関連付ける仮想イーサネット タイプのポート プロファイルを作成します。たとえば、サーバに 4 つの vNIC(データ用に 2 つ、管理用に 1 つ、バックアップ用に 1 つ)が必要である場合、vNIC のタイプ(user_data、user_management、および user_backup)ごとに 1 つのポート プロファイルを作成します。ポート プロファイルには、VLAN、帯域幅、QoS、および ACL などの関連するプロパティやポリシーを設定します。

次に、デバイスにポート プロファイル user_data を作成して設定する例を示します。

switch(config)# port profile type virtual Ethernet user_data
switch(config-port-prof)# switchport trunk allowed vlan 2-100
switch(config-port-prof)# switchport trunk native vlan 2
switch(config-port-prof)# switchport mode trunk
switch(config-port-prof)# state enabled
switch(config-port-prof)# exit
switch(config)#
 

次に、デバイスにポート プロファイル user_management を作成して設定する例を示します。

switch(config)# port profile type virtual Ethernet user_management
switch(config-port-prof)# switchport access vlan 1
switch(config-port-prof)# state enabled
switch(config-port-prof)# exit
switch(config)#
 

次に、デバイスにポート プロファイル user_backup を作成して設定する例を示します。

switch(config)# port profile type virtual Ethernet user_backup
switch(config-port-prof)# switchport mode trunk
switch(config-port-prof)# switchport trunk allowed vlan 2-100
switch(config-port-prof)# switchport trunk native vlan 2
switch(config-port-prof)# mac port access-group mac_acl1
switch(config-port-prof)# ip port access-group ip_acl1 in
switch(config-port-prof)# ipv6 port traffic-filter ipv6_acl1 in
switch(config-port-prof)# state enabled
switch(config-port-prof)# exit
switch(config)#
 

ステップ 5 アダプタのアップリンク インターフェイスに接続しているデバイスのイーサネット インターフェイスで、ポートを VNTag ポートとして設定します。

switch(config)# interface ethernet1/5
switch(config-if)# description ucs_vic2/0
switch(config-if)# switchport mode vntag
switch(config-if)#
 

デバイスが、Adapter-FEX をサポートするように設定されます。サーバからデバイスまたはファブリック エクステンダへのアダプタのアップリンク インターフェイスを接続します。

この例では、Cisco Nexus 5500 シリーズの設定を示します。

install feature-set virtualization
feature-set virtualization
vethernet auto-create
 
port-profile type vethernet user_data
switchport trunk allowed vlan 2-100
switchport trunk native vlan 2
switchport mode trunk
state enabled
 
port-profile type vethernet user_management
switchport access vlan 1
state enabled
 
port-profile type vethernet user_backup
switchport mode trunk
switchport trunk allowed vlan 2-100
switchport trunk native vlan 2
mac port access-group mac_acl1
ip port access-group ip_acl1 in
ipv6 port traffic-filter ipv6_acl1 in
state enabled
 
interface Ethernet1/5
description ucs_vic2/0
switchport mode vntag

サーバ ネットワーク アダプタの初期ハンドシェイクおよびネゴシエーション

Cisco Nexus 5500 シリーズ デバイス、または Cisco Nexus 5500 シリーズ デバイスに接続しているファブリック エクステンダの VNTag モードのイーサネット ポートにサーバ ネットワーク アダプタを接続すると、ハンドシェイクが開始されます。

NIV 機能に関する情報交換が実行され、通信は VNTag モードで開始されます。デバイスは、設定されたポート プロファイルのリスト(type vEthernet)をアダプタに渡します。これらのポート プロファイルの名前は、サーバ ネットワーク アダプタの設定ユーティリティに選択可能なオプションとして表示されます。


) サーバ ネットワーク アダプタには、ポート プロファイルの名前だけが渡されます。ポート プロファイルの設定は、サーバ ネットワーク アダプタには渡されません。


サーバ ネットワーク アダプタがデバイスに接続されていなければ、まだ、サーバの vNIC を設定できます。ただし、アダプタではポート プロファイル名を使用できません。

Adapter-FEX のアダプタでの設定

サーバのサーバ ネットワーク アダプタ設定ユーティリティを使用して、アダプタでネットワーク インターフェイス仮想化(NIV)をイネーブルにします。詳細については、ご使用のサーバ ネットワーク アダプタのマニュアルを参照してください。

設定を完了するため、サーバをリブートしてネットワーク アダプタをリセットすることが必要になる場合があります。


) Cisco UCS P81E VIC の詳細については、『Cisco UCS C-Series Servers Integrated Management Controller CLI Configuration Guide』の Cisco UCS P81E VIC に関する資料を参照してください。



) Broadcom BCM57712 Convergence NIC については、Broadcom Corp の資料を参照してください。


アダプタ上の vNIC の設定

サーバのネットワーク アダプタ設定ユーティリティを使用して、適切な数の vNIC を作成します。vNIC ごとに、固有なチャネル番号、MAC アドレス、アップリンク フェールオーバー プロパティ、またはポート プロファイル名などの適切なプロパティで作成します。


) 初期ハンドシェイクとネゴシエーションが終わると、デバイスに設定されたポート プロファイルのリストがサーバ アダプタで自動的に使用可能になります。これらのポート プロファイル名を vNIC に関連付けることができます。


各 vNIC には、固有のチャネル番号が関連付けられています。デバイス上の vNIC は、物理ポートと vNIC のチャネル番号を仮想イーサネット インターフェイスに関連付ける bind コマンドによって識別されます。詳細については、ご使用のサーバ ネットワーク アダプタのマニュアルを参照してください。


) Cisco UCS P81E VIC の詳細については、『Cisco UCS C-Series Servers Integrated Management Controller CLI Configuration Guide』の Cisco UCS P81E VIC に関する資料を参照してください。



) Broadcom BCM57712 Convergence NIC については、Broadcom Corp の資料を参照してください。


VNTag 接続が確立されると、ポート プロファイル名(type vEthernet)だけがサーバ ネットワーク アダプタに渡されます。ポート プロファイルの設定は、サーバ ネットワーク アダプタには渡されません。

ポート プロファイル名は、ネットワーク アダプタ設定ユーティリティに選択可能なオプションとして表示されます。

サーバ ネットワーク アダプタの初期化

図 1-2 および 図 1-3 に示すようなトポロジについて考えます。

サーバ ネットワーク アダプタに vNIC を設定したあとは、設定を完了させるために、ドライバをリロードするか、サーバおよびアダプタをリブートすることが必要になる場合があります。詳細については、ご使用のサーバ ネットワーク アダプタのマニュアルを参照してください。

設定が完了すると、サーバ ネットワーク アダプタとデバイスはリンクを再確立し、初期ハンドシェイクとネゴシエーション プロセスを実行します。また、サーバ ネットワーク アダプタとデバイスは、Virtual Interface Configuration(VIC)プロトコルを使用してさらに高いレベルのコントロール プレーン接続を確立します。


) VIC プロトコルは、リモート デバイスに仮想インターフェイスをプロビジョニングし、管理します。VIC プロトコルは、Cisco UCS VIC アダプタとは異なります。


VIC プロトコル接続が確立されると、サーバ ネットワーク アダプタは、サーバ ネットワーク アダプタに設定されている各 vNIC 用の仮想イーサネット インターフェイスを作成するように、デバイスに要求します。また、サーバ ネットワーク アダプタは、仮想イーサネット インターフェイスの作成要求のほか、アップリンク インターフェイスを介して次の属性を渡します。

最大伝送単位(MTU)

ポート プロファイル名

チャネル番号

アクティブ/スタンバイ アップリンク

デバイスは、サーバ ネットワーク アダプタの vNIC ごとに仮想イーサネット インターフェイスを作成し、ポート プロファイルとチャネル番号をその仮想イーサネット インターフェイスに関連付けます。

仮想イーサネット インターフェイスが作成されるまで、サーバの起動プロセスは BIOS 設定フェーズで一時停止される場合があります。仮想イーサネット インターフェイスの作成が完了すると、起動プロセスが再開し、OS がロードされます。詳細については、ご使用のアダプタの資料を参照してください。


) Cisco UCS P81E VIC の詳細については、『Cisco UCS C-Series Servers Integrated Management Controller CLI Configuration Guide』の Cisco UCS P81E VIC に関する資料を参照してください。



) Broadcom BCM57712 Convergence NIC については、Broadcom Corp の資料を参照してください。



) no vethernet auto-create コマンドを実行すると、仮想イーサネット インターフェイスの自動作成が停止されます。デバイスに vethernet auto-create コマンドが設定されていない場合は、適切なバインディングとポート プロファイルの設定を使用して、仮想イーサネット インターフェイスを手動で設定する必要があります。



) デバイスによって作成された仮想イーサネット インターフェイスには、作成されるときに自動的に番号が付けられます。これらの仮想イーサネット インターフェイス番号は、32769 から始まります。デバイスは、新規の仮想イーサネット インターフェイスを作成するときに、最も低い未使用の番号を選択します。
仮想イーサネット インターフェイスを手動で作成するときは、仮想イーサネット インターフェイスに任意の番号を選択できます。32678 よりも小さい、1 ~ 2000 の番号を選択することをお勧めします。


次に、デバイスの仮想イーサネット インターフェイスに関連付けられた設定の例を示します。

interface vethernet 21
bind interface ethernet 1/5 channel 1
inherit port-profile user_data
interface vethernet 22
bind interface ethernet 1/5 channel 2
inherit port-profile user_data
interface vethernet 23
bind interface ethernet 1/5 channel 3
inherit port-profile user_management
interface vethernet 24
bind interface ethernet 1/5 channel 4
inherit port-profile user_backup

デュアルホーム接続の FEX トポロジの設定例

図 1-4 に示されているトポロジを検討します。アップリンク インターフェイスをデュアルホーム接続のファブリック エクステンダに接続するときは、サーバ ネットワーク アダプタの初期化を実行できます。

仮想イーサネット インターフェイスの作成が完了すると、Cisco Nexus 5500-A デバイスの仮想イーサネット インターフェイスの設定は、次のようになります。

interface vethernet 21
bind interface ethernet 101/1/15 channel 1
inherit port-profile user_data
interface vethernet 22
bind interface ethernet 101/1/15 channel 2
inherit port-profile user_data
interface vethernet 23
bind interface ethernet 101/1/15 channel 3
inherit port-profile user_management
interface vethernet 24
bind interface ethernet 101/1/15 channel 4
inherit port-profile user_backup
 

Cisco Nexus 5500-B デバイスの仮想イーサネット インターフェイスの設定は、次のようになります。

interface vethernet 21
bind interface ethernet 101/1/15 channel 1
inherit port-profile user_data
interface vethernet 22
bind interface ethernet 101/1/15 channel 2
inherit port-profile user_data
interface vethernet 23
bind interface ethernet 101/1/15 channel 3
inherit port-profile user_management
interface vethernet 24
bind interface ethernet 101/1/15 channel 4
inherit port-profile user_backup

) 設定は、Cisco Nexus 5500-A デバイスと Cisco Nexus 5500-B デバイスで同じです。


アクティブ/スタンバイ サーバ ネットワーク アダプタ トポロジの設定例

この項では、次のトピックについて取り上げます。

「vPC トポロジにおけるアクティブ/スタンバイ アップリンクを使用した Adapter-FEX の初期化」

「デュアルホーム接続 FEX へのアクティブ/スタンバイ アップリンクを使用した Adapter-FEX の初期化」

vPC トポロジにおけるアクティブ/スタンバイ アップリンクを使用した Adapter-FEX の初期化

図 1-5 のトポロジについて検討します。このトポロジには、アクティブとして 1 つのアップリンク インターフェイスと、スタンバイとしてもう 1 つのアップリンク インターフェイスが存在します。スタンバイ アップリンク デバイスで作成された仮想イーサネット インターフェイスのチャネル番号は、アクティブ アップリンク インターフェイスのチャネル番号と同じです。

vPC トポロジの vPC プライマリ デバイスおよびセカンダリ デバイスでは、単一の vNIC に関連付けられた仮想イーサネット インターフェイスのインターフェイス番号は同じです。

この例のサーバ ネットワーク アダプタに、次の設定で 4 つの vNIC(eth0、eth1、eth2、eth3)と 2 つのアップリンク(uplink_0、uplink_1)があるとします。

表 1-1 vPC トポロジにおけるアクティブ/スタンバイ アップリンクを持つサーバ ネットワーク アダプタの例

vNIC
アップリンク
ポート プロファイル名

チャネル番号

eth0

Uplink_0

user_data

1

eth1

Uplink_1

user_management

2

eth2

Uplink_0

user_data

3

eth3

Uplink_1

user_backup

4

 

また、uplink_0 が Cisco Nexus 5500-A デバイスのイーサネット 1/5 に接続され、uplink_1 が Cisco Nexus 5500-B デバイスのイーサネット 1/15 に接続されているとします。

仮想イーサネット インターフェイスの作成が完了すると、Cisco Nexus 5500-A デバイスの仮想イーサネット インターフェイスの設定は、次のようになります。

interface vethernet 37
bind interface ethernet 1/5 channel 1
inherit port-profile user_data
interface vethernet 38
bind interface ethernet 1/5 channel 2
inherit port-profile user_data
interface vethernet 39
bind interface ethernet 1/5 channel 3
inherit port-profile user_management
interface vethernet 40
bind interface ethernet 1/5 channel 4
inherit port-profile user_backup
 

Cisco Nexus 5500-B デバイスの仮想イーサネット インターフェイスの設定は、次のようになります。

interface vethernet 37
bind interface ethernet 1/5 channel 1
inherit port-profile user_data
interface vethernet 38
bind interface ethernet 1/5 channel 2
inherit port-profile user_data
interface vethernet 39
bind interface ethernet 1/5 channel 3
inherit port-profile user_management
interface vethernet 40
bind interface ethernet 1/5 channel 4
inherit port-profile user_backup

) 設定は、Cisco Nexus 5500-A デバイスと Cisco Nexus 5500-B デバイスで同じです。


vPC アクティブ/スタンバイ トポロジでは、仮想イーサネット インターフェイスの番号は vPC プライマリ デバイスのみによって割り当てられます。仮想イーサネット インターフェイスの作成要求を受信すると、vPC セカンダリ デバイスはプライマリ デバイスに割り当てを要求します。show vpc brief コマンドを実行すると、デバイスの vPC ロールが表示されます。

サーバ ネットワーク アダプタに接続されたサーバが、ある物理インターフェイスから vPC ピアの一方にある物理インターフェイスに移動されると、そのサーバ ネットワーク アダプタの接続は、古い仮想イーサネット インターフェイスが削除されるまで確立されません。

デュアルホーム接続 FEX へのアクティブ/スタンバイ アップリンクを使用した Adapter-FEX の初期化

図 1-6 のトポロジについて検討します。このトポロジには、アクティブとして 1 つのアップリンク インターフェイスと、スタンバイとしてもう 1 つのアップリンク インターフェイスが存在します。

このサーバ ネットワーク アダプタに、次の設定で 4 つの vNIC(eth0、eth1、eth2、eth3)と 2 つのアップリンク(uplink_0、uplink_1)があるとします。

表 1-2 デュアルホーム接続 FEX のサーバ ネットワーク アダプタの例

vNIC
アップリンク
ポート プロファイル名

チャネル番号

eth0

Uplink_0

user_data

1

eth1

Uplink_1

user_management

2

eth2

Uplink_0

user_data

3

eth3

Uplink_1

user_backup

4

 

また、uplink_0 がファブリック エクステンダのイーサネット 100/1/15 に接続され、uplink_1 がファブリック エクステンダのイーサネット 101/1/15 に接続されているとします。

仮想イーサネット インターフェイスの作成が完了すると、Cisco Nexus 5500-A デバイスの仮想イーサネット インターフェイスの設定は、次のようになります。

interface vethernet 37
bind interface ethernet 100/1/15 channel 1
bind interface ethernet 101/1/15 channel 1
inherit port-profile user_data
interface vethernet 38
bind interface ethernet 100/1/15 channel 2
bind interface ethernet 101/1/15 channel 2
inherit port-profile user_data
interface vethernet 39
bind interface ethernet 100/1/15 channel 3
bind interface ethernet 101/1/15 channel 3
inherit port-profile user_management
interface vethernet 40
bind interface ethernet 100/1/15 channel 4
bind interface ethernet 101/1/15 channel 4
inherit port-profile user_backup
 

Cisco Nexus 5500-B デバイスの仮想イーサネット インターフェイスの設定は、次のようになります。

interface vethernet 37
bind interface ethernet 100/1/15 channel 1
bind interface ethernet 101/1/15 channel 1
inherit port-profile user_data
interface vethernet 38
bind interface ethernet 100/1/15 channel 2
bind interface ethernet 101/1/15 channel 2
inherit port-profile user_data
interface vethernet 39
bind interface ethernet 100/1/15 channel 3
bind interface ethernet 101/1/15 channel 3
inherit port-profile user_management
interface vethernet 40
bind interface ethernet 100/1/15 channel 4
bind interface ethernet 101/1/15 channel 4
inherit port-profile user_backup

) 設定は、Cisco Nexus 5500-A デバイスと Cisco Nexus 5500-B デバイスで同じです。


仮想イーサネット インターフェイスの設定

ここでは、仮想イーサネット インターフェイスの作成と設定方法について説明します。

仮想イーサネット インターフェイスの自動作成

ここでは、サーバ ネットワーク アダプタが Cisco Nexus 5500 シリーズ デバイスの VNTag モード イーサネット インターフェイスに接続されたときに、仮想イーサネット インターフェイスを自動的に作成する方法について説明します。

サーバ ネットワーク アダプタは、Cisco Nexus 5500 シリーズ デバイスに仮想イーサネット インターフェイスを 1 つずつ作成するように要求します。

スタートアップ コンフィギュレーション ファイルへの仮想イーサネット インターフェイスの保存

VIC プロトコル インターフェイスの作成要求によって作成された仮想イーサネット インターフェイスは、実行コンフィギュレーションに保存されます。実行コンフィギュレーションが保存されると、仮想イーサネット インターフェイスとその設定は、スタートアップ コンフィギュレーション ファイルに保存されます。

デバイスをリロードすると、デバイスはスタートアップ コンフィギュレーション ファイルをロードし、仮想イーサネット インターフェイスはそのスタートアップ コンフィギュレーションから静的に作成されます。VNTag インターフェイスが初期化され、サーバ ネットワーク アダプタが仮想イーサネット インターフェイスの作成を要求した場合は、すでに存在する仮想イーサネット インターフェイスが使用されます。詳細については、「仮想イーサネット インターフェイスの手動作成」を参照してください。

仮想イーサネット インターフェイスは、no interface vethernet コマンドを使用してシステムから削除できます。仮想イーサネット インターフェイスはスタートアップ コンフィギュレーションに保存されるので、実行コンフィギュレーションをスタートアップ コンフィギュレーション ファイルに保存することをお勧めします。

仮想イーサネット インターフェイスの手動作成

Cisco Nexus 5500 シリーズ デバイスに仮想イーサネット インターフェイスを手動で作成するには、interface vethernet コマンドを使用します。Cisco Nexus 5500 シリーズ デバイスには、最大で 2000 個の仮想イーサネット インターフェイスを設定できます。


) 仮想イーサネット インターフェイスを手動で作成する前に、デバイスでの仮想イーサネット インターフェイスの自動作成を無効にする(no vethernet auto-create コマンドを使用する)ことをお勧めします。


サーバ ネットワーク アダプタに接続されたデバイスは、仮想イーサネット インターフェイスの作成要求を受信すると、仮想イーサネット インターフェイスの作成要求のチャネル番号に一致する仮想イーサネット インターフェイスが手動で設定されているかどうかをチェックします。手動で設定された仮想イーサネット インターフェイスがすでに存在する場合は、そのインターフェイスが使用され、新規の仮想イーサネット インターフェイスは作成されません。仮想イーサネット インターフェイスが存在しない場合は、新規の仮想イーサネット インターフェイスが作成されます。


) サーバ ネットワーク アダプタに接続しているサーバを永続的に切断する前に、必ず、デバイスからすべての仮想イーサネット インターフェイスを削除してください。


デバイスとサーバ ネットワーク アダプタ間の設定の競合

手動で設定された仮想イーサネット インターフェイス、またはスタートアップ コンフィギュレーションに保存された仮想イーサネット インターフェイスの設定と、サーバ ネットワーク アダプタでの設定の間に、ポート プロファイル名の競合が発生する場合があります。

たとえば、サーバ ネットワーク アダプタがチャネル番号 5 の vNIC をポート プロファイル user_backup に関連付けるのに対し、デバイスはチャネル番号 5 にバインドされた仮想イーサネット インターフェイスをポート プロファイル user_data に関連付ける場合があります。

この種の競合が発生した場合は、サーバ ネットワーク アダプタの設定が優先され、デバイスの設定は上書きされます。

ポート プロファイルが vNIC に関連付けられた場合に、そのポート プロファイルがデバイスに存在しない場合、仮想イーサネット インターフェイスの作成と初期化は失敗します。