Cisco Nexus 5000 シリーズ NX-OS オペレーション ガイド リリース 5.1(3)N1(1)
VM-FEX の使用方法
VM-FEX の使用方法
発行日;2012/07/19 | 英語版ドキュメント(2012/07/16 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

VM-FEX の使用方法

VM-FEX について

VN-Link

スタティック インターフェイス

スタティック仮想アダプタ

ダイナミック インターフェイスまたはダイナミック VNIC

フローティング仮想インターフェイス

固定 vEthernet インターフェイス

ダイナミック フローティング vEthernet インターフェイス

スタティック フローティング vEthernet インターフェイス

固定 vEthernet インターフェイス プロビジョニング モデル

スタティック固定 vEthernet インターフェイスの設定

ダイナミック固定 vEthernet インターフェイスの設定

NIV ホスト検出

ポート プロファイルの継承

分散仮想スイッチ

ハードウェアおよびソフトウェアの要件

ダイナミック固定 vEthernet インターフェイス設定

スタティック固定 vEthernet インターフェイス設定

vPC システムでの固定 vEthernet インターフェイスのフェールバックおよびフェールオーバー

vPC システムでの固定スタティック vEthernet インターフェイスのフェールバックおよびフェールオーバー

VM-FEX の設定シナリオ

スタティック VNIC の設定

ダイナミック フローティング vEthernet インターフェイスの設定シナリオ

VM-to-VM-FEX 接続のシナリオ

VM-FEX 接続の確認シナリオ

設定の概要

設定例

VM-FEX の使用方法

この章では、Cisco Virtual Machine Fabric Extender(VM-FEX)の使用方法について説明します。

この章は、次の内容で構成されています。

「VM-FEX について」

「ハードウェアおよびソフトウェアの要件」

「ダイナミック固定 vEthernet インターフェイス設定」

「スタティック固定 vEthernet インターフェイス設定」

「vPC システムでの固定 vEthernet インターフェイスのフェールバックおよびフェールオーバー」

「vPC システムでの固定スタティック vEthernet インターフェイスのフェールバックおよびフェールオーバー」

「VM-FEX の設定シナリオ」

「ダイナミック フローティング vEthernet インターフェイスの設定シナリオ」

「VM-to-VM-FEX 接続のシナリオ」

「VM-FEX 接続の確認シナリオ」

「VM-FEX 接続の確認シナリオ」

「設定例」

VM-FEX について

Cisco Virtual Machine Fabric Extender(VM-FEX)は Cisco 仮想インターフェイス カード(VIC)アダプタと連動して、サーバでのソフトウェアベースのスイッチングを外部のハードウェアベースのスイッチングで置き換えます。VM-FEX には数多くの新しいコンポーネントおよび概念が導入されています。ネットワークに VM-FEX を正常に展開するには、これらのコンポーネントおよび概念を理解することが重要です。

VN-Link

仮想ネットワーク リンク(VN-Link)は仮想ネットワーク インターフェイス カード(vNIC)で、Fibre Channel over Ethernet(FCoE)トンネルを使用して仮想ファイバ チャネル(vFC)インターフェイスと接続する仮想ホスト バス アダプタ(VHBA)または仮想イーサネット(vEthernet)インターフェイスと接続します。

スタティック インターフェイス

スタティック インターフェイスとは、管理者が手動で設定するパラメータを持つインターフェイスです。スタティック インターフェイスにすることができるのは、vEthernet またはファイバ チャネル インターフェイスです。
静的に作成される固定とフローティング vEthernet インターフェイスの場合、デバイス管理者が、インターフェイスを起動する前に設定を vEthernet インターフェイスに関連付けることができます。競合を解決するために次のルールに従います。

vEthernet インターフェイスの下で指定されたすべての設定はポート プロファイルの設定よりも優先されます。

vEthernet インターフェイスがポート プロファイルで事前設定されているときに、NIV アダプタまたは vEthernet モジュールが異なるポート プロファイルを知らせた場合は、プロトコル メッセージに指定されているポート プロファイルが優先されます。

vEthernet の設定またはポート プロファイルの設定は、2 つの Cisco Nexus 5000 シリーズ デバイス間の設定同期がイネーブルになっていれば、同期プロファイルで指定できます。

スタティック仮想アダプタ

スタティック仮想アダプタは、仮想ネットワーク インターフェイス カード(VNIC)または仮想ホスト バス アダプタ(vHBA)です。

ダイナミック インターフェイスまたはダイナミック VNIC

ダイナミック インターフェイスまたはダイナミック VNIC は、アダプタとデバイスが通信するときに自動的に設定される vEthernet インターフェイスです。ダイナミック VNIC は、仮想マシン(VM)上の仮想ネットワーク インターフェイス カード(VNIC)ポート グループのパラメータを継承します。
仮想 NIC はダイナミック仮想アダプタにできますが、仮想 HBA はできません。ダイナミック仮想インターフェイスにできるのは、vEthernet インターフェイスです。ダイナミック インターフェイスは、Unified Computing System(UCS)の UCS VIC カードでのハードウェアベースのフェールオーバーをサポートします。
ダイナミック固定およびフローティングの vEthernet インターフェイスは、デバイス上に動的に作成されるので、それに設定を関連付けることはできません。したがって、このタイプの vEthernet にデバイスが設定を関連付けることができるのは、VIF_CREATE または仮想イーサネット モジュール(VEM)添付メッセージに指定されているポート プロファイルを使用した場合に限られます。

フローティング仮想インターフェイス

仮想のコンピューティング、ネットワーキング、サーバ、およびストレージ アーキテクチャを持つ Cisco ネットワーク インターフェイス仮想化(NIV)環境では、VM は一方の物理サーバから、物理デバイス上に仮想ネットワーク リンクと vEthernet インターフェイスを持つ他方のサーバに移行します。フローティング仮想インターフェイスとは、VM および仮想ネットワークと一緒に、そのプロファイル特性およびパラメータとともに移行する仮想インターフェイスです。

フローティング(スタティックまたはダイナミック)vEthernet インターフェイスの場合、設定変更(shut または no shut を含む)は、バインディング設定(vEthernet インターフェイスが接続されている間は変更不可)を除いて、接続された(vNIC に要求されるハイパーバイザ)状態に関係なくいつでも許可されます。バインディング設定を変更できるのは、vEthernet インターフェイスが接続されていない場合のみです。vEthernet インターフェイスの接続状態を確認するには、 show interface veth コマンドを使用します。

固定 vEthernet インターフェイス

固定 vEthernet インターフェイスとは、物理インターフェイス間の移行をサポートしない仮想インターフェイスです。
shut または no shut コマンドあるいは create または delete コマンドの使用を含み、固定 vEthernet インターフェイス(スタティックまたはダイナミック)の設定はいつでも変更できます。vEthernet 番号とチャネル番号のバインディングは、ユーザが変更しない限り持続します。

ダイナミック フローティング vEthernet インターフェイス

vEthernet インターフェイスは、ハイパーバイザ上で新しい VM が起動されるときに動的に作成されます。vMotion を使用して VM を移行するときに、ダイナミック フローティング vEthernet インターフェイスは、一方の VEM から別の VEM へ移動できます。また、ダイナミック vEthernet インターフェイスの統計情報とポリシーは、VM が一方のホストから別のホストに移動するときに保持されます。

次のプロセスは、VM およびそれに関連付けられた vEthernet インターフェイスの起動方法を示しています。

1. デバイス上にポート プロファイルを作成し、それを VMware vCenter(vCenter)にプッシュします。

2. vCenter は、ポート グループ ID またはポート プロファイルを割り当て、VMware ポート グループ ID で応答します。

3. サーバ管理者がハイパーバイザ上で VM を起動したとき、管理者は VM のポート グループを選択し、ハイパーバイザに VM を起動するよう指示します。

4. 選択されたポート グループが Cisco Nexus 5000 シリーズ分散仮想スイッチ(DVS)、VEM、または NIV アダプタに属しているポート グループである場合、ハイパーバイザには、DV ポート ID およびポート グループ ID を持つ VM の接続保留が通知されます。

5. 次のいずれかのアクションが行われます。

a. ポート グループが VEM に属している場合、VEM は Cisco Nexus 5000 シリーズ デバイス上で動作する仮想スーパーバイザ モジュール(VSM)に VM 接続保留通知を送信します。そうでなければ、新しい vEthernet がその DV ポート ID に作成されます。

b. ポート グループが NIV アダプタに属している場合、NIV アダプタは Pass-Through スイッチング(PTS)を使用して VM の接続保留を検出し、VMware プロビジョニング Type-Length-Value(TLV)に VM の DV ポート ID およびポート グループ ID を持つデバイスに対して VIF 作成メッセージを送信します。さらにアダプタは、ポート プロファイルからパラメータを継承するダイナミック VNIC の設定も行います。

6. このデバイスは適切な vEthernet インターフェイスを作成し、さらに VM のポート グループ ID をポート プロファイルに展開してそれを vEthernet インターフェイスに適用します。

7. 次のいずれかのアクションが行われます。

a. VEM の場合、デバイス コントロール プレーンが vEthernet インターフェイスを通常のイーサネット インターフェイスのように起動し、データ プレーン プログラミングは Message and Transaction Service(MTS)メッセージを通して VEM 上で行われます。

b. NIV アダプタの場合、デバイスが vEthernet インターフェイスを起動するため、仮想ネットワーク タグ(VNTag)が vEthernet インターフェイスに割り当てられ、デバイス転送パスとアダプタ転送パスの両方が仮想インターフェイス カード(VIC)を使用して VNTag にセットアップされます。vEthernet インターフェイス パラメータ(たとえば、デフォルト VLAN、デフォルトの Class of Service(CoS)など)が VIC を使用してアダプタに送信されます。vEthernet インターフェイスのアップが宣言され、アップ中(動作可能)として vNIC をマークするように指示する VIC メッセージがアダプタに送信されます。

スタティック フローティング vEthernet インターフェイス

フローティング vEthernet インターフェイスを作成して設定できます。

次のコマンドを使用して、分散仮想ポートおよび分散仮想スイッチ(DVS)が与えられている vEthernet インターフェイス番号を選択できます。

int veth10
vmware dvport <dvport-number> dvsswitch uuid <uuid>
 

次のコマンドを使用して、VM の MAC アドレスの vEthernet インターフェイス番号を選択できます。

int veth11
vsi mac <mac-address>
 

スタティックとダイナミックのフローティング vEthernet インターフェイスの作成モデルに違いはありません。VEM または NIV アダプタが vEthernet インターフェイスの作成をデバイスに知らせると、デバイスは最初に設定済みのスタティック vEthernet インターフェイスのための照合を試みます。一致するものが見つかると、その特定の vEthernet インターフェイス番号が使用されます。スタティック vEthernet インターフェイスの設定が指定されている場合は、その設定が、ポート プロファイル内で指定されているものよりも優先されます。

固定 vEthernet インターフェイス プロビジョニング モデル

固定 vEthernet インターフェイスは VM と関連付けられません。固定 vEthernet インターフェイスは、ホスト オペレーティング システム(OS)に対して通常の NIC として作成し、公開できます。ホスト OS は、それらの vEthernet インターフェイスおよび通常のイーサネット インターフェイスをブート デバイスとして使用できます。サーバが VM 対応の場合、これらの固定 vEthernet インターフェイスは、物理アダプタとして現れます。その理由は、vCenter は、vMotion を使用してこのタイプの vEthernet インターフェイスを移行できないからです。

固定 vEthernet インターフェイスに適したプロビジョニング モデルは、ダイナミック モデルです。このプロビジョニング モデルには、vEthernet インターフェイスを表すデバイスの設定が存在しません。このモデルは、VIC プロトコルによってデバイスに提供されるポート プロファイル情報に依存します。

デバイスは、VIC コントロール チャネル(VIF_SET は 0)を使用して、デバイスに設定されているポート プロファイル名のリストをアドバタイズします。NIV アダプタには、それぞれの固定 vEthernet インターフェイスに接続されるポート プロファイルのリストからサーバ管理者が選択できる方法があります。

次のプロセスでは、固定 vEthernet インターフェイスを起動する方法について説明します。

1. NIV アダプタが、チャネル番号およびオプションのポート プロファイル名とともに VIF_CREATE メッセージを送信します。

2. デバイスがそのスタティック固定 vEthernet インターフェイス設定のリストから一致を探し、次のいずれかを行います。

a. 一致するチャネル番号が存在する場合、その vEthernet インターフェイス番号が起動されます。

b. 一致するチャネル番号を持つスタティック固定 vEthernet インターフェイスが存在しない場合は、ダイナミック固定 vEthernet インターフェイスが代わりに作成されます。ダイナミック固定 vEthernet インターフェイスには、それに関連付けられるユーザ設定もポート プロファイルもありません。

3. ポート プロファイル名が VIF_CREATE メッセージに含まれている場合、固定 vEthernet インターフェイスがデバイス設定内のポート プロファイルでまだ設定されていなければ、VIF_CREATE メッセージ内のポート プロファイル パラメータがその vEthernet インターフェイスに設定されます。

4. スタティック固定モデルでは、デバイスの管理者が、デバイスに設定されている vEthernet インターフェイスを、それが表す vNIC のチャネル番号にマッピングする必要があります。このタスクでは、デバイス管理者はチャネル情報をサーバまたはアダプタの管理者から取得しなければならず、エラーになりやすいため、スタティック設定はあまり望ましくないと見なされます。

5. アダプタでプロビジョニングされているそれぞれのスタティック固定 vNIC では、対応する vEthernet インターフェイスを作成し、それをイーサネット インターフェイスおよびチャネル番号にバインドする必要があります。ここで、イーサネット インターフェイスはアダプタの接続先である物理インターフェイス番号、チャネル番号はアダプタでプロビジョニングされている vNIC インスタンス番号です。

次の例では、vEthernet インターフェイス 10 を作成し、イーサネット インターフェイス 1/10、チャネル 4 にバインドしています。

int veth10
bind interface ethernet 1/10 channel 4
inherit port profile xxx
 

各物理インターフェイスには、一意のチャネル番号が与えられる必要があります。vEthernet インターフェイスがホストの VNIC に接続されたあとであっても(つまり、デバイスが vif-create コマンドを受信したあとであっても)、バインディングは、no bind interface ethernet コマンドを使用することによって削除できます。この動作は、フローティング vEthernet インターフェイスの作成とは異なります。固定 vEthernet インターフェイスでは、アダプタは内部的にチャネル番号を OS に可視の NIC インターフェイスにマッピングし、マッピング情報をアダプタ ツールで表示します。

FEX Active-to-Active トポロジには、少なくとも 2 つの VIF が各 vEthernet インターフェイスに存在し、複数のバインド インターフェイス コマンドが vEthernet インターフェイス下で許可されます。たとえば、アダプタに 2 つのアップリンクがあり、各アップリンクを FEX ポート 100/1/10 と 100/1/11 に接続する場合、両方のバインドされたインターフェイスをスタティック固定 vEthernet インターフェイスとして設定する必要があります。

int veth10
bind interface ethernet 100/1/10 channel 4
bind interface ethernet 101/1/11 channel 4
 

スタティック固定 vEthernet インターフェイスの設定

Cisco Integrated Management Controller(CIMC)では、VNIC にポート プロファイルは指定されず、デバイスで、スタティック固定 vEthernet インターフェイスを手動で実行コンフィギュレーションに設定します。

interface veth 1
bind int e 100/1/1 channel 1
no shut

ダイナミック固定 vEthernet インターフェイスの設定

スタティック固定 vEthernet インターフェイスを作成する代わりに、デバイスを dynamic_vnic_profile ポート プロファイルで設定し、バインドされたインターフェイスを VNTag モードに設定します。デバイスは dynamic_vnic_profile ポート プロファイを Unified Computing System(UCS)VIC アダプタにプッシュします。

CIMC に進み、ポート プロファイルを dynamic_vnic_profile に変更して固定 vNIC プロパティの追加または編集を行う必要があります。手動でストリング「dynamic_vnic_profile」を入力するか、デバイスはすべてのポート プロファイルをアダプタにプッシュしているためドロップダウン メニューも使用できます。

次に、サーバをリブートして初期ファームウェア リリースで変更を有効にする必要があります。その結果、ダイナミック固定 vEthernet インターフェイスがデバイスの実行コンフィギュレーションに自動的に入力されます。

interface veth 1
inherit port-profile xyz
bind int e 100/1/1 channel 1
 

NIV ホスト検出

NIV vEthernet インターフェイスを作成する前に、ホストに接続している物理インターフェイスを VNTag モードで設定し、スイッチポートとホスト アップリンクの間の Data Center Bridging Exchange(DCBX)通信を VNTag モードで設定する必要があります。

int e1/1 or e100/1/1
switchport mode vntag
 

) access または trunk キーワードは必須パラメータであるため、インターフェイス上で常時 VNTag カプセル化のみを強制する方法はありません。



) VEM からのフレームに VNTag が含まれないため、VEM インターフェイス vEthernet は、この設定を必要としません。


softPTS を実行するホストは、VNTag モードに移行する前にクラシカル イーサネット モードで動作することができます。VNTag モードへの移行は、ホストが NIV 機能(つまり、TLV)を自身の DCBX アドバタイズメントに含め始めたときに行われます。それまでは、softPTS を実行するホストは、クラシカル イーサネット モードで動作します。ホストは、クラシカル イーサネット モードで動作する間、VNTag モードで設定されたデバイスに接続している物理インターフェイス経由でネットワークに完全に接続できます。ポートはアクセスまたはトランク モードで設定できるため、次のコマンドを使用して、ポートが VNTag モードで設定されている場合にスイッチポート動作を設定できます。

switchport trunk allowed vlan [add|all|except|none|remove] <vlan-list>
switchport trunk native vlan <vlan>
switchport access vlan <vlan>
 

switchport trunk allowed vlan および switchport trunk native vlan vlan コマンドは、ポートが、クラシカル イーサネット モードで動作している VNTag トランク デバイス ポートであると設定されている場合にのみ使用できます。このコマンドは、スイッチポートに許可 VLAN リストを設定し、トランク ポートにデフォルト VLAN を設定します。

switchport access vlan は、ポートが、クラシカル イーサネット モードで動作している VNTag アクセス デバイス ポートとして設定されている場合にのみ使用できます。このコマンドでは、デバイス ポートにアクセス VLAN を設定できます。

ポート プロファイルの継承

ダイナミック固定およびフローティングの vEthernet インターフェイスは、デバイス上に動的に作成されるので、それに設定を関連付けることはできません。したがって、このタイプの vEthernet インターフェイスをデバイスが設定できるのは、VIF_CREATE または VEM 接続メッセージに指定されているポート プロファイルを使用した場合に限られます。

静的に作成される固定とフローティングの vEthernet インターフェイスの場合、デバイス管理者は、インターフェイスの起動前に設定を vEthernet インターフェイスに関連付けることができます。競合を解決するために次のルールが必要です。

vEthernet インターフェイスの下で指定されたすべての設定はポート プロファイルの設定よりも優先されます。

vEthernet インターフェイスがポート プロファイルで事前設定されているときに、NIV アダプタまたは VEM が異なるポート プロファイルを知らせた場合は、プロトコル メッセージに指定されているポート プロファイルが優先されます。

vEthernet インターフェイスの設定またはポート プロファイルの設定は、2 つの Cisco Nexus 5000 シリーズ デバイス間で設定同期がイネーブルになっていれば、同期プロファイルで指定できます。

分散仮想スイッチ

DVS または仮想分散スイッチ(VDS)は、複数の VMware vSphere(vSphere)ホストにまたがり、仮想スイッチング環境のネットワーク管理を集中型管理インターフェイスに集約しています。DVS が登場する前は、サーバごとにデバイスを設定する必要がありました。そのため、VMware vMotion(vMotion)を使用する場合は、それらのデバイスの設定がクラスタ全体で矛盾がないことを手作業で確認する必要がありました。DVS では、クラスタ内のすべてのサーバにまたがる単一のデバイスが作成されます。ポート グループは、一度設定するだけで、クラスタ内のすべてのサーバに自動的に適用されます。

ESX システム用の VEM には、常に、Local Switching モジュールと PTS モジュールの両方が含まれています。PTS モジュールは、VEM 機能と NIV 機能の両方を柔軟にイネーブルにすることができる Soft-PTS モードおよび Hard-PTS モードの機能を対象とします。このソフトウェア パッケージは、一般に VIB とも呼ばれています。VIB とは、VMware で使用されている形式です。

ハードウェアおよびソフトウェアの要件

表 1 に、VM-FEX のハードウェアおよびソフトウェア要件を示します。

表 2-1 VM-FEX のハードウェアおよびソフトウェア要件

 

 

コンポーネント
ハードウェアおよびソフトウェアの組み合わせ 1
ハードウェアおよびソフトウェアの組み合わせ 2
ハードウェアおよびソフトウェアの組み合わせ 3

サーバ

Cisco C250-M2

OS =Wind2008 r2 sp1

ESX v4.1u1

CIMC

1.4(0.21)

BIOS

1.4.1

Cisco UCS P81E

VNIC ドライバ

cxxx-scu-drivers-w2k8r2x64-1.3.1.1

Cisco Nexus 5548 デバイス

5.1(3)N1(1)

Cisco NX-OS 5.. (0.223)

CNA VIC アダプタ ファームウェア バージョン

1.6 (0.72)

FC ストレージ アレイ

--

VCenter サーバ/クライアント

バージョン 4.1

Enterprise plus ライセンス

ダイナミック固定 vEthernet インターフェイス設定

固定 vEthernet インターフェイスに可能な 2 つの設定モデルはスタティックとダイナミックです。設定が簡単で、かつ vEthernet 設定のセットアップにデバイスとサーバ管理者の間で必要な対話が最小限であるため、デバイスで優先される設定モデルはダイナミック固定 vEthernet インターフェイスです。

最初に、デバイス管理者がデバイス上で複数のポート プロファイルを設定します。各ポート プロファイルは vEthernet インターフェイスに適用される一連のデバイス ポート設定を定義します。この設定は、ホストがネットワーク内で果たすさまざまな役割に基づいており、サーバ管理者がサーバ ポートに必要な設定を選択する際のテンプレートになります。

アダプタとデバイスの間で VIC セッションが確立されるとき、プロトコル ハンドシェイクの一環として、デバイスは関連するポート プロファイルのリストをホストに渡します。BIOS またはアダプタ ツールを使用して、このポート プロファイルのリストを表示し、PCI バスに提供されている vNIC 用にリストから特定のポート プロファイルを選択できます。ポート プロファイルを選択すると、この VIF の起動の一環として、ポート プロファイル ID が VIC プロトコル経由でデバイスに送り返されます。デバイスは、この VIF の起動中にダイナミック vEthernet インターフェイスを作成し、アダプタから受け取ったポート プロファイルを適用します。

ダイナミック固定 vEthernet インターフェイスがデバイスの実行コンフィギュレーションに自動的に入力されます。

interface veth 1
inherit port-profile xyz
bind int e 100/1/1 channel 1
 

vEthernet ハンドシェイクが完了し、インターフェイスがアップ状態になると、ポート プロファイルに含まれていたすべてのインターフェイス設定がそのインターフェイスに適用され、そのインターフェイスは動作を開始します。

サーバとデバイスの間の物理リンクがフラップしたり、デバイスとサーバの間の VIC セッションに中断が発生したりすると、ホスト上に古い情報を残さないために、サーバ上のポート プロファイル リストがクリアされます。VIC セッションが再確立されると、新しいポート プロファイル リストがサーバに送信されます。

図 2-1 に、デバイス上のダイナミック vEthernet 設定を示します。

図 2-1 デバイス上に設定されたダイナミック vEthernet

 

スタティック固定 vEthernet インターフェイス設定

CIMC では、VNIC にポート プロファイルは指定されません。デバイスには、実行コンフィギュレーションにスタティック固定 vEthernet を手動で次のように入力します。

interface vEthernet 1
bind int e 1/18 channel 1
no shut
 

) UCS VIC のスタティック VNIC のフェールオーバーおよびフェールバックは、UCS VIC 上のハードウェア内で実行される場合、ホスト OS から認識されません。つまり、OS はフェールオーバーまたはフェールバック中に VNIC をアップかつ実行中であると認識します。


リターン トラフィックの再コンバージェンスに必要な時間が発生するため、一部のパケットが失われる可能性があります。

Cisco Nexus 5548 シリーズ デバイスは、再コンバージェンスのためにフェールオーバーまたはフェールバックしたアクティブ vEthernet インターフェイスのスタティック MAC および IGMP 加入メッセージについて、Gratuitous ARP 応答を送信します。このアクションにより、ネットワークからホストに向かう方向のリターン トラフィック パスがすぐにイネーブルになります。

FEX Straight-Trough トポロジでは、アクティブ Cisco Nexus 5000 シリーズ デバイスによって、アクティブ vEthernet インターフェイス上で学習されたすべてのユニキャスト MAC アドレスは、スタンバイ vEthernet インターフェイスを持つ Cisco Nexus 5000 シリーズ デバイスと連続的に同期されます。これらのユニキャスト MAC アドレスの宛先は、スタンバイ Cisco Nexus 5000 シリーズ デバイス上の Multichassis EtherChannel Trunk(MCT)を示します。ユニキャスト MAC アドレスは、Cisco Fabric Services over Ethernet(CFSoE)をトランスポートとして使用して同期されます。IGMP グループは同期されません。

今後の Cisco NX-OS バージョンは、フェールオーバー/フェールバックした vEthernet ポートの背後で獲得されたスタティック アドレスに加えてすべての MAC ダイナミック アドレスについて、およびアクティブ vEthernet インターフェイス用に収集されたすべての IGMP 加入メッセージについて、IGMP 加入要求と、Gratuitous ARP 応答を外部ネットワークに対して送信します。

vPC システムでの固定 vEthernet インターフェイスのフェールバックおよびフェールオーバー

vPC システムでの固定 vEthernet インターフェイスのフェールバックおよびフェールオーバーのプロセスは、次のとおりです。

1. アダプタが起動されます。

2. このインターフェイスが固定 vEthernet インターフェイスの場合は、NIV アダプタが、アクティブ Cisco Nexus 5000 シリーズ デバイス上に 1 つの vEthernet インターフェイスとスタンバイ Cisco Nexus 5000 シリーズ デバイス上に 1 つの vEthernet インターフェイスの作成も行います。

3. NIV アダプタはこの 2 つの Cisco Nexus 5000 シリーズ デバイスに対する両方の VIF_CREATE メッセージで同じチャネル番号を使用します。I

4. スタティック固定 vEthernet インターフェイスの場合は、ユーザが同じ vEthernet インターフェイス番号とチャネル番号で 2 つの Cisco Nexus 5000 シリーズ デバイス上に vEthernet インターフェイスを作成します。

5. アダプタは、アップリンクの 1 つに VIF_ACTIVATE メッセージを知らせる状態に達し、vEthernet インターフェイスの 1 つをアクティブにします。他方のインターフェイスはスタンバイ状態のままです。

6. NIV アダプタは、リンク ダウン イベントによって、または DCBX キープ アライブ メッセージがタイムアウトになったときに、フェールオーバーが必要であることを検出します。

これらのイベントのいずれかが発生すると、NIV アダプタは、VIF の新しい転送パスにするためにスタンバイ リンクをアクティブにします。NIV アダプタは VIF_ACTIVATE メッセージをスタンバイ Cisco Nexus 5000 シリーズ デバイスに送信します。

7. VIF_ACTIVATE メッセージを受信すると、スタンバイ Cisco Nexus 5000 シリーズ デバイスは次を行います。

a. MCT ではなく VIF を指すようにすべてのユニキャスト MAC アドレスの宛先を調整します。

b. アダプタに対して IGMP General Query を開始します。ホスト OS からの IGMP 加入がネットワーク パス全体のメンバーシップすべてを更新します。

c. Gratuitous ARP 応答をこの VIF のすべてのユニキャスト MAC アドレスについて送信して、ネットワーク パス全体をスタンバイ側に調整します。

d. PVLAN または ACL など、他のすべての設定ベースの機能は、この VIF のハードウェアにすでに事前にプログラムされているため、フェールオーバー時に調整は必要ありません。

8. 障害の発生したパスがオンラインに復帰しても、デバイスはフェールバック アクションを実行しません。デバイスがアクションを実行するのは、NIV アダプタが新しいリンク上で VIF_ACTIVATE メッセージを送信した場合のみです。その結果、同じプロセスが再び行われます。

vPC システムでの固定スタティック vEthernet インターフェイスのフェールバックおよびフェールオーバー

固定スタティック vEthernet インターフェイスの vPC システムへのフェールバックまたはフェールオーバーのプロセスは、次のとおりです。

1. アダプタが起動されます。このインターフェイスが固定 vEthernet インターフェイスの場合は、NIV アダプタが、アクティブ側の Cisco Nexus 5000 シリーズデバイス上に 1 つの vEthernet を作成し、スタンバイ側の Cisco Nexus 5000 シリーズ デバイス上に 1 つの vEthernet も作成します。NIV アダプタはこの 2 つの Cisco Nexus 5000 シリーズ デバイスに対する両方の VIF_CREATE メッセージで同じチャネル番号を使用します。スタティック固定 vEthernet インターフェイスの場合は、同じ vEthernet 番号とチャネル番号で 2 つの Cisco Nexus 5000 シリーズ デバイス上に vEthernet インターフェイスを作成する必要があります。

2. アダプタは、アップリンクの 1 つに VIF_ACTIVATE メッセージを知らせる状態に達し、vEthernet インターフェイスの 1 つをアクティブにします。他方のインターフェイスはスタンバイ状態のままです。

3. NIV アダプタは、リンク ダウン イベントまたは DCBX キープアライブ タイムアウトによって、フェールオーバーが必要であることを検出します。Cisco Nexus 5000 シリーズ デバイスおよび FEX ファブリックに考えられるすべての障害を列挙してみます。いずれかのイベントが発生すると、NIV アダプタは、VIF の新しい転送パスにするためにスタンバイ リンクをアクティブにします。

4. NIV アダプタは VIF_ACTIVATE メッセージをスタンバイ Cisco Nexus 5000 シリーズ デバイスに送信します。VIF_ACTIVATE メッセージを受信すると、スタンバイ Cisco Nexus 5000 シリーズ デバイスは次を行います。

a. MCT ではなく VIF を指すようにすべてのユニキャスト MAC アドレスの宛先を調整します。

b. アダプタに対して IGMP General Query を開始します。ホスト OS からの IGMP 加入がネットワーク パス全体のメンバーシップすべてを更新します。

c. Gratuitous ARP 応答をこの VIF のすべてのユニキャスト MAC アドレスについて送信して、ネットワーク パス全体をスタンバイ側に調整します。

d. PVLAN または ACL など、他のすべての設定ベースの機能は、この VIF のハードウェアにすでに事前にプログラムされているため、フェールオーバー時に調整は必要ありません。

5. 障害の発生したパスがオンラインに復帰しても、デバイスはフェールバック アクションを実行しません。デバイスがアクションを実行するのは、NIV アダプタが新しいリンク上で VIF_ACTIVATE メッセージを送信した場合のみです。その結果、同じプロセスが再び行われます。

VM-FEX の設定シナリオ

このシナリオでは、サンプル ネットワークで VM-FEX を設定する手順を示します。

FM-FEX を設定する概略の手順は次のとおりです。

1. VEM-PTS bits がインストールされたサーバを起動します。

2. MT カード上の 2 つのスタティック vNIC をアクティブにします。

3. スタティック vEthernet ポートでデバイスを設定し、それを物理ポートにバインドします。

4. Cisco UCS P81E 仮想インターフェイス カード上の 2 つのスタティック vNIC をアクティブにします。

5. Cisco UCS P81E 仮想インターフェイス カード上のダイナミック vNIC にポート プロファイルを定義します。

6. サーバをリブートします。

7. 2 つの vEthernet インターフェイスがアクティブで、2 つのスタティック vNIC に接続されていることを確認します。

8. ダイナミック vEthernet インターフェイスがアクティブで、ダイナミック vNIC に接続されていることを確認します。

9. システム上で vPC をイネーブルにします。

10. 仮想分散スイッチ(VDS)として vPC システムを vCenter に登録します。

11. VM-FEX データセンターを作成し、それを vds-nx5k VDS フォルダに割り当てます。

ポート プロファイルは、vmware ポート グループとして vds-nx5k VDS に伝搬する必要があります。

12. ホストを vds-nx5k VDS に追加して 2 つのスタティック vNIC をそこにマッピングします。

13. VM を ESX ホスト上でアクティブにしてそれをポート グループにマッピングします。

14. ダイナミック vNIC がアクティブになり、PTS の VM に割り当てられ、VN-Link を使用して Cisco Nexus 5000 シリーズ デバイス vPC 上の vEthernet ポートに接続されることに注意してください。

スタティック VNIC の設定

スタティック VNIC の設定は次のとおりです。


) 次のステップを EXS ホスト 1 と ESX ホスト 2 の両方の上で実行します。



ステップ 1 ESX ホスト 1 と ESX ホスト 2 の CIMC コントローラに接続します。

ステップ 2 左のナビゲーション ペインで、[Server] > [Inventory] を選択します。

ステップ 3 [Network Adapters] メニューで、UCS VIC アダプタ カードを選択して、図 2-2 に示すように、NIV モードがアダプタでイネーブルになっていることを確認します。

図 2-2 NIV モードの確認

 


) • Cisco UCS P81E VIC は FEX モードまたは CNA モードでイネーブルにすることができます。

FEX モードの Cisco UCS P81E VIC は、ハードウェアベースのフェールオーバーをサポートします。このフェールオーバーは、CIMC によって、または VNIC から Cisco Nexus 5548 デバイス上の vEthernet ポートまでのアクティブ/スタンバイ VN-Link によって提供されます。

VNIC は主に、Cisco Nexus 5548 デバイス上の vEthernet ポートに接続され、Cisco Nexus 5548 デバイス上のスタンバイ インターフェイスに接続したスタンバイ VN-Link を持ちます。

CNA モードの Cisco UCS P81E VIC は、アクティブ/アクティブ モードをサポートします。


 

ステップ 4 [Adapter Card] メニューで、[VNICs] タブを選択し、[Add] ボタンをクリックして 2 つのスタティック VNIC(A-FEX)を各サーバの Ethernet0 および Ethernet1 VNIC に追加します。

ステップ 5 2 つのスタティック VNIC を ESX ホスト 1 でアクティブするために、各 VNIC のプロパティを定義します。これらのスタティック VNIC は、図 2-3 に示すように、VNIC プロキシ パスの VMware VDS(VDS)が必要とします。

図 2-3 VNIC のプロパティ

 

ステップ 6 ESX ホスト 1 の UCS VIC 上の 2 つのスタティック VNIC に次のパラメータを入力します。

ESX Host 1

Name: stateth 0

Uplink Port: 0

MAC Address: すでに関連付け

Channel Number: 10

Port Profile: 関連付けなし

Enable Uplink Failover(Enable to)

Failback Timeout: 5

Name: stateth 1

Uplink Port: 0

MAC Address: すでに関連付け

Channel Number: 11

Port Profile: 関連付けなし

Enable Uplink Failover(Enabled)

Failback Timeout: 5

他の値はデフォルト設定のまま

ESX ホスト 1 の UCS VIC 上のスタティック VNIC のパラメータを図 2-4 に示します。

図 2-4 ESX ホスト 1 の UCS VIC 上の VNIC

 

stateht1 の vNIC プロパティを図 2-5 に示します。

図 2-5 ESX ホスト 2 の UCS VIC 上の VNIC

 

ステップ 7 ESX ホスト 2 の UCS VIC 上の 2 つのスタティック VNIC に次のパラメータを入力します。

ESX Host 2

Name: stateth 0

Uplink Port: 0

MAC Address: すでに関連付け

Channel Number: 10

Port Profile: 関連付けなし

Enable Uplink Failover(Enabled)

Failback Timeout: 5

Name: stateth 1

Uplink Port: 0

MAC Address: すでに関連付け

Channel Number: 11

Port Profile: 関連付けなし

Enable Uplink Failover(Enable to)

他の値はデフォルト設定のまま。

ESX ホスト 1 の UCS VIC 上のスタティック VNIC のパラメータを図 2-6 に示します。

図 2-6 ESX ホスト 2 の vNIC プロパティ

 

stateht1 の vNIC の追加を図 2-7 に示します。

図 2-7 vNIC の追加

 

ステップ 8 [Server] タブで、[Summary] フォルダを選択します。

ステップ 9 右パネル内の [Power Cycle Server] オプションを選択してサーバをリブートします。


) サーバのリブートは、VNIC 設定に関係する変更を Cisco UCS P81E VIC 上でアクティブにするために、初期バージョンの Cisco UCS P81E VIC ファームウェアで必要です。


図 2-8 に、リブート後の画面を示します。

図 2-8 Cisco Integrated Management Controller

 

ステップ 10 Cisco Nexus 5548-1 デバイスおよび Cisco Nexus 5548-2 シリーズ デバイスに接続し、それらをスタティック VNIC(A-FEX)接続用に次のように設定します。

a. 両方のデバイス上で、次のコマンドを入力して、次の機能がイネーブルになっていることを確認します。

install feature-set virtualization

feature-set virtualization

feature fex

feature vmfex

feature lldp

feature vpc

vethernet auto-create

feature fcoe

copy run start

reload

b. 両方のデバイス上で、両方の ESX サーバに接続される物理インターフェイスをイネーブルにします。

interface Ethernet1/17
switchport mode vntag
shut
interface Ethernet1/18
switchport mode vntag
shut

c. 両方のデバイス上で、Cisco UCS VIC 上でイネーブルになっている 2 つのスタティック VNIC に接続する必要のある仮想インターフェイスをイネーブルにします。

Cisco Nexus 5548-1 デバイスで、次のコマンドを入力します。

pod1-5548-1(config)# interface vethernet1
pod1-5548-1(config-if)# bind interface eth 1/17 channel 10
pod1-5548-1(config-if)# no shut
pod1-5548-1(config-if)# interface vethernet 3
pod1-5548-1(config-if)# bind interface eth 1/17 channel 11
pod1-5548-1(config-if)# no shut
 
pod1-5548-1(config-if)# interface vethernet 2
pod1-5548-1(config-if)# bind interface eth 1/18 channel 10
pod1-5548-1(config-if)# no shut
pod1-5548-1(config-if)# interface vethernet 4
pod1-5548-1(config-if)# bind interface eth 1/18 channel 11
pod1-5548-1(config-if)# no shut
 

Cisco Nexus 5548-2 デバイスで、次のコマンドを入力します。

pod1-5548-2(config)# interface vethernet 1
pod1-5548-2(config-if)# bind interface eth 1/17 channel 10
pod1-5548-2(config-if)# no shut
pod1-5548-2(config-if)# interface vethernet 3
pod1-5548-2(config-if)# bind interface eth 1/17 channel 11
pod1-5548-2(config-if)# no shut
 
pod1-5548-2(config-if)# interface vethernet 2
pod1-5548-2(config-if)# bind interface eth 1/18 channel 10
pod1-5548-2(config-if)# no shut
pod1-5548-2(config-if)# interface vethernet 4
pod1-5548-2(config-if)# bind interface eth 1/18 channel 11
pod1-5548-2(config-if)# no shut
 

d. 両方のデバイス上で、両方の ESX サーバに接続されるインターフェイスをイネーブルにします。

interface Ethernet1/17
no shutdown
nterface Ethernet1/18
no shutdown
 

e. 次の確認コマンドを使用して、両方の ESX ホスト上で 2 つのスタティック VNIC が Cisco NX5548 デバイス上の各スタティック固定 vEthernet インターフェイスに VN-Link で接続されていることを確認します

Cisco Nexus 5548-1 デバイスで、次のコマンドを入力します。

pod1-5548-1# show interface vethernet 1
Vethernet1 is up
Bound Interface is Ethernet1/17
Hardware is Virtual, address is 0005.73fc.24a0
Port mode is access
Speed is auto-speed
Duplex mode is auto
300 seconds input rate 0 bits/sec, 0 packets/sec
300 seconds output rate 0 bits/sec, 0 packets/sec
Rx
0 unicast packets 0 multicast packets 0 broadcast packets
0 input packets 0 bytes
0 input packet drops
Tx
0 unicast packets 0 multicast packets 0 broadcast packets
0 output packets 0 bytes
0 flood packets
0 output packet drops
 
POD1-5548-1# show interface vethernet 1 detail
vif_index: 20
--------------------------
veth is bound to interface Ethernet1/17 (0x1a010000)
priority: 0
vntag: 16
status: active
channel id: 10
registered mac info:
vlan 0 - mac 00:00:00:00:00:00
vlan 0 - mac 58:8d:09:0f:0b:3c
vlan 0 - mac ff:ff:ff:ff:ff:ff
 

Cisco Nexus 5548-2 デバイスで、次のコマンドを入力します。

POD1-5548-2# show interface vethernet 1 detail
vif_index: 20
--------------------------
veth is bound to interface Ethernet1/17 (0x1a010000)
priority: 0
vntag: 16
status: standby
channel id: 10
registered mac info:
vlan 0 - mac 00:00:00:00:00:00
vlan 0 - mac 58:8d:09:0f:0b:3c
vlan 0 - mac ff:ff:ff:ff:ff:ff
 
POD1-5548-1# show mac address
Legend:
* - primary entry, G - Gateway MAC, (R) - Routed MAC, O - Overlay MAC
age - seconds since last seen,+ - primary entry using vPC Peer-Link
VLAN MAC Address Type age Secure NTFY Ports
---------+-----------------+--------+---------+------+----+------------------
* 1 588d.090f.0970 static 0 F F Veth2
* 1 588d.090f.0971 static 0 F F Veth4
* 1 588d.090f.0b3c static 0 F F Veth1
* 1 588d.090f.0b3d static 0 F F Veth3
* 4040 0005.73fc.1fbc static 0 F F Router

) アクティブおよびスタンバイの両方の vEthernet 1 インターフェイスが両方の Cisco Nexus 5548 デバイス上でアップ中ですが、スタティック MAC アドレスはアクティブ vEthernet によってのみ学習されています。


f. イーサネット 1/17-18 インターフェイスをシャットダウンして、固定 vEthernet インターフェイスがフェールオーバー状態にあることを確認します。スタンバイの vEthernet 1 インターフェイスがアクティブ vEthernet 1 のロールを引き継ぎ、それとともにそのスタティック MAC アドレスが移動します。

POD1-5548-1(config-if-range)# inerface ethernet 1/17-18
POD1-5548-1(config-if-range)# no shut
 
POD1-5548-2# show interface vethernet 1 detail
vif_index: 20
--------------------------
veth is bound to interface Ethernet1/17 (0x1a010000)
priority: 0
vntag: 16
status: active
channel id: 10
registered mac info:
vlan 0 - mac 00:00:00:00:00:00
vlan 0 - mac 58:8d:09:0f:0b:3c
vlan 0 - mac ff:ff:ff:ff:ff
 
POD1-5548-2# show mac address
Legend:
* - primary entry, G - Gateway MAC, (R) - Routed MAC, O - Overlay MAC
age - seconds since last seen,+ - primary entry using vPC Peer-Link
VLAN MAC Address Type age Secure NTFY Ports
---------+-----------------+--------+---------+------+----+------------------
* 1 588d.090f.0970 static 0 F F Veth2
* 1 588d.090f.0971 static 0 F F Veth4
* 1 588d.090f.0b3c static 0 F F Veth1
* 1 588d.090f.0b3d static 0 F F Veth3
 
 
POD1-5548-1(config-if-range)# show interface veth 1 detail
veth is not bound
priority: n/a
vlan: n/a
vntag: n/a
registered mac info:
 
POD1-5548-1(config-if-range)# show mac address
Legend:
* - primary entry, G - Gateway MAC, (R) - Routed MAC, O - Overlay MAC
age - seconds since last seen,+ - primary entry using vPC Peer-Link
VLAN MAC Address Type age Secure NTFY Ports
---------+-----------------+--------+---------+------+----+------------------
* 4040 0005.73fc.1fbc static 0 F F Router
POD1-5548-1(config-if-range)#
 

g. Cisco Nexus 5548-1 デバイス上の物理イーサネット 1/17-18 インターフェイスをアクティブにして、スタティック固定 vEthernet インターフェイスのフェールバックが実行されること、およびアクティブ ロールとスタティック MAC アドレスが Cisco Nexus 5548-1 デバイスに戻されることを確認します。

 
POD1-5548-1# show interface vethernet 1 detail
vif_index: 20
--------------------------
veth is bound to interface Ethernet1/17 (0x1a010000)
priority: 0
vntag: 16
status: active
channel id: 10
registered mac info:
vlan 0 - mac 00:00:00:00:00:00
vlan 0 - mac 58:8d:09:0f:0b:3c
vlan 0 - mac ff:ff:ff:ff:ff:ff
 
POD1-5548-1# show mac address
Legend:
* - primary entry, G - Gateway MAC, (R) - Routed MAC, O - Overlay MAC
age - seconds since last seen,+ - primary entry using vPC Peer-Link
VLAN MAC Address Type age Secure NTFY Ports
---------+-----------------+--------+---------+------+----+------------------
* 4040 0005.73fc.1fbc static 0 F F Router
* 1 588d.090f.0970 static 0 F F Veth2
* 1 588d.090f.0971 static 0 F F Veth4
* 1 588d.090f.0b3c static 0 F F Veth1
* 1 588d.090f.0b3d static 0 F F Veth3
POD1-5548-1#
 
POD1-5548-2# show interface vethernet 1 detail
vif_index: 20
--------------------------
veth is bound to interface Ethernet1/17 (0x1a010000)
priority: 0
vntag: 16
status: standby
channel id: 10
registered mac info:
vlan 0 - mac 00:00:00:00:00:00
vlan 0 - mac 58:8d:09:0f:0b:3c
vlan 0 - mac ff:ff:ff:ff:ff:ff
 
POD1-5548-2# show mac address
POD1-5548-2#
 


 

ダイナミック フローティング vEthernet インターフェイスの設定シナリオ

ダイナミック フローティング vEthernet インターフェイスの設定シナリオは、次のとおりです。


ステップ 1 各サーバの UCS VIC カード上で 20 個のダイナミック VNIC をイネーブルにします。

ステップ 2 CIMC のナビゲーション ペインで、[Server Menu] > [Inventory] フォルダを選択します。

ステップ 3 右ウィンドウで、Cisco UCS VIC の [General] タブを選択し、[Modify Adapter Properties] をクリックして 20 個のダイナミック VNIC インターフェイスを NIV モードの両方の ESX ホスト上でイネーブルにします。

ステップ 4 [Save Changes] をクリックします。

ステップ 5 サーバをリブートし、変更を有効にします。

アダプタ プロパティの修正を図 2-9 に示します。

図 2-9 アダプタ プロパティの修正

 

ステップ 6 両方の Cisco Nexus 5548 シリーズ デバイス上で、Cisco Nexus 5548 デバイス上の自動的に作成されたダイナミック vEthernet インターフェイスに接続するダイナミック VNIC のポート プロファイルを設定します。このポート プロファイルは、VDS 上でポート グループとして表示されます。

ダイナミック vEthernet インターフェイスは、実行コンフィギュレーションに入力して、図 2-10 に示すように、PTS モードで VM がダイナミック ポート グループに接続したときにダイナミック vNIC に自動的に接続される必要があります。

図 2-10 仮想 FEX

 

ステップ 7 両方の Cisco Nexus 5548 デバイス上で、ポート グループ VLAN 61 として vCenter VDS にエクスポートされるポート プロファイルを設定します。

ステップ 8 VLAN 61 をイネーブルにします。

port-profile type vethernet VLAN61
switchport mode access
switchport access vlan 61
dvs-name all
port-bindindg dynamic
state enabled
vlan 61
 

dvs-name all コマンドは、図 2-11 に示すように、このポート プロファイルがポート グループとしてエクスポートされる先の vCenter の dvs デバイスを定義します。all オプションを使用すると、ポート グループはデータセンターのすべての DVS にエクスポートされます。

次のキーワードは vEthernet ポート バインディング タイプです。

dynamic キーワードは、VM の電源がオンになったときにポートが接続され、電源がオフになったときに切断されることを指定します。最大ポート制限が実施されます。

ephemeral キーワードは、VM の電源がオンになったときにポートが作成され、電源がオフになったときに破棄されることを指定します。最大ポート制限は実施されません。

static キーワードは、ポートが常に接続されていることを指定します。最大ポート制限が実施されます。

ステップ 9 vSphere クライアントを使用して vCenter サーバに接続します。

ステップ 10 vSphere クライアントで、[Home] > [Inventory] > [Hosts and Clusters] を選択します。

ステップ 11 vSphere サーバを右クリックして新しいデータセンター名(たとえば、DCy、y はポッドの番号)を作成します。

ステップ 12 証明書の警告は無視します。

図 2-11 vSphere クライアント

 

ステップ 13 vCenter vSphere サーバを vPC システムに接続します。次の設定指示は、図 2-12 に示すように、vCenter サーバと vPC システムの間に SVS 接続を確立します。

図 2-12 vCenter サーバと vPC システムの間の SVS 接続

 


) vPC モードでの Cisco Nexus 5000 シリーズ デバイスまたは Cisco Nexus 5000 シリーズ デバイスのペアは 1 つの DVS クラスタをサポートできます。


各 DVS は、拡張キーと証明書を付けて作成されます。2 つの Cisco Nexus 5000 シリーズ デバイスが vPC トポロジで設定されている場合、プライマリ vPC デバイスは DVS と拡張キーのペアを、vCenter とポート プロファイルでサポートされている特定のデータセンターにプッシュします。プライマリとセカンダリのデバイスは、両方とも単独で vCenter をポーリングして、使用中の DV ポート ID のリストを取得することにより、ガーベッジ コレクションを実行します。未使用の DV ポート ID にマッピングするすべての vEthernet インターフェイスは削除されます。vCenter は決してデバイスとの通信を開始しません。

ステップ 14 Cisco Nexus 5548 デバイス プラグインを vSphere サーバに次のように登録します。

a. Cisco_nexus_5000_extension.xml ファイルを両方の Cisco Nexus 5548 デバイスからダウンロードして保存します。

b. 図 2-13 に示すように、Cisco Nexus 5548 Web サーバの IP アドレスをブラウザに入力することによってプラグインをダウンロードします。

図 2-13 ダウンロードのインデックス

 

ステップ 15 両方の Cisco_nexus_5000_extension.xml ファイルを、次の手順を使用して vSphere サーバに登録します。

a. vCenter サーバの [Plug-In] メニューで、 [Manage Plug-ins] オプションを選択し、使用可能なプラグインの上の空スペースを右クリックして新しいプラグインを作成します。

b. 証明書の警告は無視します。

図 2-14 プラグイン マネージャ

 

c. 図 2-14 に示すように、新しいプラグインを参照し、[Register plug-in] ボタンをクリックします。

図 2-15 プラグインの登録

 

d. セキュリティ証明書の警告は無視し、図 2-15 に示すように、正常にインストールされたプラグインについてのレポートを待ちます。その結果、プラグインは [Available Plug-ins] の下にリストされます。


) プロセスがエラーを返す場合、使用可能なプラグインの下にプラグインがすでにインポートされている可能性があります。


e. vCenter で、図 2-16 に示すように、プラグインが両方の Cisco Nexus 5548 デバイス用に正常にインストールされていることを確認します。

図 2-16 プラグインのステータス

 

ステップ 16 Cisco Nexus 5548-1 および Cisco Nexus 5548-2 シリーズ デバイス上で、vPC ドメインと LACP 機能をイネーブルにします。

Cisco Nexus 5548-2 シリーズ デバイス上で次のコマンドを入力します。

 
pod1-5548-2(config)# feature vpc
pod1-5548-2(config)# feature lacp
 
pod1-5548-2(config)# vpc domain 1
pod1-5548-2(config-vpc-domain)# role priority 100 /no priority the other switch
pod1-5548-2(config-vpc-domain)# peer-keepalive destination 10.29.186.195 vrf management
 
pod1-5548-2(config)# int eth 1/27-30
pod1-5548-1(config-if-range)# channel-group 10
pod1-5548-1(config-if-range)# exit
 
pod1-5548-2(config)# int po10
pod1-5548-2(config-if)# vpc peer-link
pod1-5548-2(config-if)# spanning-tree port type network
pod 1-5548-2(config-if)# // permit all vlans but but not FCOE VLAN 200!
pod 1-5548-2(config-if)# sw trunk allowed vlan 1-199, 201-3967, 4048-4093
pod1-5548-2(config-if)# no shut
 

Cisco Nexus 5548-1 シリーズ デバイス上:

pod1-5548-1(config)# feature vpc
pod1-5548-1(config)# feature lacp
 
pod1-5548-1(config)# vpc domain 1
pod1-5548-1(config-vpc-domain)# role priority 90
pod1-5548-1(config-vpc-domain)# peer-keepalive destination 10.29.186.196 vrf management
 
 
pod1-5548-1(config)# int eth 1/27-30
pod1-5548-1(config-if-range)# channel-group 10
pod1-5548-1(config-if-range)# exit
 
pod1-5548-1(config)# int po10
pod1-5548-1(config-if)# vpc peer-link
pod1-5548-1(config-if)# spanning-tree port type network // permit all vlans but but not FCOE VLAN 200!
pod1-5548-1(config-if)#) sw trunk allowed vlan 1-199, 201-3967, 4048-4093 //no fcoe vlan
pod1-5548-1(config-if)#no shut
 
 

ステップ 17 いずれの vPC メンバがプライマリで、いずれがセカンダリ vPC メンバであるかを確認します。

pod1-5548-2# show vpc
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
 
vPC domain id : 1
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status: success
Per-vlan consistency status : success
vPC role : secondary
Number of vPCs configured : 0
Peer Gateway : Disabled
Dual-active excluded VLANs : -
Graceful Consistency Check : Enabled
 
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po10 up 1,61
POD1-5548-1# show vpc
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
 
vPC domain id : 1
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status: success
Per-vlan consistency status : success
vPC role : primary
Number of vPCs configured : 0
Peer Gateway : Disabled
Dual-active excluded VLANs : -
Graceful Consistency Check : Enabled
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po10 up 1,61
OD1-5548-2(config-if)# show vpc role
 
vPC Role status
----------------------------------------------------
vPC role : secondary
Dual Active Detection Status : 0
vPC system-mac : 00:23:04:ee:be:01
vPC system-priority : 32667
vPC local system-mac : 00:05:73:fc:24:fc
vPC local role-priority : 110
 
----------------------------------------------------- ---------------------------------------------------------------
 
POD1-5548-1# show vpc role
 
vPC Role status
----------------------------------------------------
vPC role : primary
Dual Active Detection Status : 0
vPC system-mac : 00:23:04:ee:be:01
vPC system-priority : 32667
vPC local system-mac : 00:05:73:fc:1f:bc
vPC local role-priority : 90
POD1-5548-1#
 

ステップ 18 プライマリおよびセカンダリ vPC メンバ上で SVS 接続を設定します。


) セカンダリ SVS メンバは、拡張キーを同期するためにプライマリ SVS メンバと通信します。


pod1-5548-1(config)# svs connection 2VC
pod1-5548-1(config-svs-conn)# protocol vmware-vim
pod1-5548-1(config-svs-conn)# vmware dvs datacenter-name DC1
pod1-5548-1(config-svs-conn)# dvs-name Pod1PTS
pod1-5548-1(config-svs-conn)# remote ip address 10.29.186.125 port 80 vrf management
pod1-5548-1(config-svs-conn)# install certificate default
pod1-5548-1(config-svs-conn)# extension-key: Cisco_Nexus_1000V_1543569268 // only on the primary vpc member
 

) vCenter サーバでそれぞれの Cisco Nexus 5548 シリーズ デバイスのインストール済みプラグインの下で拡張キー Cisco_Nexus_1000V_1543569268 の名前を見つけます。install certificate default コマンドを使用して、図 2-17 に示すように、vCenter サーバにインポートできる拡張キーを生成します。


図 2-17 使用可能なプラグイン

 


) 設定プロセスは、install certificate コマンドがデバイス上で発行されたあとでプラグインがインポートされた場合に、より一貫します。


ステップ 19 プライマリ vPC メンバを vSphere センターに接続します。

pod1-5548-1(config)# svs connection 2VC
pod1-5548-1(config-svs-conn)# connect
Note: Command execution in progress..please wait
pod1-5548-1(config-svs-conn)#
 

接続アクションの結果の 1 つでは、図 2-18 に示すように、dvs-pts フォルダがデータセンターの下に作成されます。

図 2-18 vSphere - DCVMFEX1

 

ステップ 20 セカンダリ vPC メンバを手動で設定してそれを vCenter に接続します。


) セカンダリ vPC メンバは、connect コマンドが正常であっても接続しません。


pod1-5548-2(config)# svs connection 2VC
pod1-5548-2(config-svs-conn)# protocol vmware-vim
pod1-5548-2(config-svs-conn)# vmware dvs datacenter-name DC1
pod1-5548-2(config-svs-conn)# dvs-name Pod1PTS
pod1-5548-2(config-svs-conn)# remote ip address 10.29.186.125 port 80 vrf management
pod1-5548-2(config-svs-conn)# install certificate default
pod1-5548-2(config-svs-conn)#

) 拡張キーは手動で設定しません。代わりに、vPC によって同期されます。


拡張キーは、プライマリ vPC メンバによってセカンダリ vPC メンバと同期されます。 show svs connection コマンドを使用することによって、拡張キーが両方のピアで同じであることを確認できます。2 つの Cisco Nexus 5548 デバイスが vPC ピアでなければ、拡張キーは各デバイスで異なり、各デバイスは vCenter との間に独自の接続を確立する必要があります。

ステップ 21 vCenter と vPC システムの間の SVS 接続が正しくアクティブになっていること、および新しい VDS デバイス、Pod1PTS、およびポート プロファイが新しい VDS デバイスのポート グループとして vCenter にインポートされていることを確認します。

POD1-5548-1(config)# show svs connection
 
connection 2VC:
ip address: 10.29.186.125
remote port: 80
vrf: amang
protocol: vmware-vim https
certificate: default
datacenter name: DC1
extension key: Cisco_Nexus_1000V_1543569268
dvs name: Pod1PTS
DVS uuid: 44 f1 04 50 47 cc 42 d6-ba ea 53 f9 f9 32 4b fb // This is pushed by VCenter to switch
config status: Enabled
operational status: Connected // Only Primary connects to VCenter
sync status: in progress
version: VMware vCenter Server 4.1.0 build-258902
 
Peer Info:
----------
connection 2VC:
ip address: 10.29.186.125
remote port: 80
vrf: management
protocol: vmware-vim https
extension key: Cisco_Nexus_1000V_1543569268 //This extension key is result of sync
certificate: default //status of the VPC primary to second.
certificate match: TRUE
datacenter name: DC1
dvs name: Pod1PTS
DVS uuid: -
config status: Disabled
operational status: Disconnected
 

ステップ 22 SVS 接続がアクティブになったあとで、vPC システムがポート プロファイル VLAN61 および他の 2 つのポート プロファイル(使用されていない)を VDS に対してプッシュしたことを確認します。これらのポート プロファイルは、DC1 データセンターの下の VDS ポート グループになります。また、図 2-19 に示すように、Po1PTS VDS が vPC システムによって vCenter に作成されたことを確認します。

図 2-19 vCenter における vPC システム

 

POD1-5548-2# show svs connection
 
connection 2VC:
ip address: 10.29.186.125
remote port: 80
vrf: management
protocol: vmware-vim https
certificate: default
datacenter name: DC1
extension key: Cisco_Nexus_1000V_1543569268 // Received from the VPC Primary
dvs name: pod1PTS
DVS uuid: -
config status: Enabled
operational status: Disconnected
sync status: -
version: -
 
 
Peer Info:
----------
connection 2VC:
ip address: 10.29.186.125
remote port: 80
vrf: amang
protocol: vmware-vim https
extension key: Cisco_Nexus_1000V_1543569268
certificate: default
certificate match: TRUE
datacenter name: DC1
dvs name: Pod1PTS
DVS uuid: 44 f1 04 50 47 cc 42 d6-ba ea 53 f9 f9 32 4b fb //Received from VCenter
config status: Enabled
operational status: Connected
 

ステップ 23 VEM が両方の ESX ホスト上に PTS モードで正常にインストールされていることを確認します。VEM が正しくインストールされていない場合には、『 VM-FEX/A-FEX Hardware/Software Installation Procedure 』を参照してください(現在、VDS デバイスには、ホストも VMNIC も関連付けられていません。デバイスで使用可能なのはポート グループのみです)。


注意 [Home] > [Inventory] > [Hosts & Clusters] フォルダを選択することによって、2 つの ESX ホストを vSphere サーバの DC1 データセンターに追加します。次の特性を 2 つのホストに定義します。

ESX ホスト 1:

10.29.186.197
Username= root
Password= Not4u2use!
Use the Enterprise License Plus entered
Select the shared datastore visible across the Qlogic VHBA and the datastore1 which is local.
 

ESX ホスト 2:

10.29.186.198
Username= root
Password= Not4u2use!
se the Enterprise License Plus entered.
Select the shared datastore visible across the Qlogic VHBA and the datastore1 which is local.
 

ホストの追加中に、ウィザードは各ホストに図 2-20 に示すような画面を表示します。

図 2-20 ホストの追加ウィザードの画面

 

ウィザードが完了する前のサマリーを図 2-21 に示します。

図 2-21 サマリーのレビュー

 

Sphere クライアント上の新しい仮想マシンを図 2-22 に示します。

図 2-22 Sphere クライアント上の新しい仮想マシン

 

ステップ 24 ESX ホスト 1 および ESX ホスト 2 を、作成された PodYPTS VDS に追加します。VSphere サーバで [Home] > [Inventory] > [Networking] フォルダを選択し、データセンター DC y y はポッドの番号)を右クリックします。図 2-23 を参照してください。

図 2-23 PodYPTS VDS へのホストの追加

 


) ESX ホストをデータセンターに追加できない場合は、そのホストが別の vCenter サーバによって管理されていないか確認します。他の VCenter サーバからそのホストにリモート アクセスし、それを正しい vCenter サーバに追加します。vSphere Enterprise License Plus ライセンスを選択します。


ステップ 25 vCenter サーバで、[Home] > [Inventory] > [Networking] を、PODy の下の選択された PODy PTS VDS(y はポッド番号)について選択します

ステップ 26 両方のホストを VDS に追加し、2 つの VMNIC(VMware プロキシ パスの VMware によって必要とされるスタティック固定 VNIC)を選択します。

ステップ 27 Cisco UCS VIC VNIC 上の staticeth 0 および staticeth 1 インターフェイスによって認識される ESX ホストごとに、vEthernet 1、vEthernet 2、vEthernet 3 および vEthernet 4 インターフェイスに接続されている 2 つの VMNIC を選択します。図 2-24 を参照してください。

図 2-24 各 VMNIC の詳細の表示

 


) 各 VMNIC の [View Details] オプションを使用すると、適切なスタティック VMNIC の選択に役立ちます。特に、この場合、VMNIC16 および VMNIC17 は、vEthernet 1、vEthernet 2、vEthernet 3 および vEthernet 4 インターフェイスに接続されているため、各ホストに割り当てられます。図 2-25 を参照してください。


図 2-25 物理アダプタ詳細 - vEthenet1

 

ポート ID vEthenet3 の物理アダプタ詳細を図 2-26 に示します。

図 2-26 物理アダプタ詳細 - vEthenet3

 

ポート ID vEthenet2 の物理アダプタ詳細を図 2-27 に示します。

図 2-27 物理アダプタ詳細 - vEthenet2

 

ポート ID vEthenet4 の物理アダプタ詳細を図 2-28 に示します。

図 2-28 物理アダプタ詳細 - vEthenet4

 

ステップ 28 残りのパラメータはデフォルト設定のままにして、PTS 内の VEM に VMNIC を関連付けるプロセスを終了します。

ステップ 29 2 つのホストを追加するプロセスが終了するまで [Next] を選択します。

このプロセスの結果は次のとおりです。

新しい VDS が PTS という名前で作成されています。

この新しい VDS は 2 つの ESX ホストに基づきます。

ESX ホストはそれぞれ VEM を PTS モードで実行しています。

各 VEM は、2 つのスタティック アップリンク VMNIC に関連付けられます。

これらのスタティック アップリンク VMNIC はアップ中で vEthernet 1、vEthernet 2、vEthernet 3 および vEthernet 4 インターフェイスに接続されています。

すべての 4 つの VMNIC がアップかつ実行中である必要があります。VMNIC 横の赤い x は VMNIC が接続されていないことを示し、各ホスト上の Pod1PTS VDS への VMNIC に 2 つのスタティック VNIC がマッピングされていることに注意してください(図 2-29 を参照)。

図 2-29 各ホスト上の Pod1PTS VDS

 

アダプタが最初に起動されます。

このインターフェイスが固定 vEthernet インターフェイスの場合は、NIV アダプタが、アクティブ Cisco Nexus 5000 シリーズ デバイス上に 1 つの vEthernet インターフェイスとスタンバイ Cisco Nexus 5000 シリーズ デバイス上に 1 つの vEthernet インターフェイスの作成も行います。NIV アダプタはこの 2 つの Cisco Nexus 5000 シリーズ デバイスに対する両方の VIF_CREATE メッセージで同じチャネル番号を使用します。スタティック固定 vEthernet インターフェイスの場合は、同じ vEthernet インターフェイス番号とチャネル番号で 2 つの Cisco Nexus 5000 シリーズ デバイス上に vEthernet インターフェイスを作成する必要があります。動的に作成される固定 vEthernet インターフェイスの場合、2 つの Cisco Nexus 5000 シリーズ デバイスは協調して、2 つの Cisco Nexus 5000 シリーズ デバイス上の同じチャネル番号が同じ vEthernet インターフェイス番号にマッピングされるようにします。

これがフローティング(スタティックまたはダイナミック)vEthernet インターフェイスの場合は、NIV アダプタが、アクティブ Cisco Nexus 5000 シリーズ デバイス上に 1 つの vEthernet インターフェイスとスタンバイ Cisco Nexus 5000 シリーズ デバイス上に 1 つの vEthernet インターフェイスの作成を行います。各 Cisco Nexus 5000 シリーズ デバイスは NIV アダプタに対して独自の VIC プロトコル セッションを実行します。NIV アダプタは 2 つの Cisco Nexus 5000 シリーズ デバイスに対する両方の VIF_CREATE メッセージで同じ dvport-id を使用します。2 つの Cisco Nexus 5000 シリーズ デバイスは協調して、同じ vEthernet 番号が、同じ dvport_id にマッピングされている 2 つの vEthernet インターフェイスに割り当てられるようにします。

VM-to-VM-FEX 接続のシナリオ

VM-to-VM-FEX 接続のシナリオは次のとおりです。


ステップ 1 VM を ESX ホスト上に作成して、それを VM-FEX(PTS 付きハードウェアの VN-Link)を使用して、ハードウェアベースの冗長性を使用する vPC システム上のダイナミック vEthernet ポートに接続します。

ステップ 2 ESX ホスト 1 上に、フローティング vEthernet インターフェイスを表示するために、一方のホストから他方のホストに移行する新しい VM を作成します。VM は VM-FEX モードで vPC システムに接続されます。VM ストレージは両方のホストが使用できる必要があります。このストレージは、FC ストレージ アレイに存在しマルチホップの Fiber Channel over Ethernet(FCoE)ネットワークにわたって使用可能な VMFS フォーマットの論理ユニット番号(LUN)です(Qlogic アダプタ上の vfc 400 インターフェイスおよび vfc 500 インターフェイス)。

ステップ 3 新しい VM を追加するためにホストを右クリックします。図 2-30 を参照してください。

図 2-30 新しい仮想マシンの追加

 

ステップ 4 標準的な VM を選択し、名前をその VM に関連付け、DCY(Y はポッドの番号)をインベントリ ロケーションとして定義して 60GB_shared_datastore を選択します。

ステップ 5 Linux OS の [Red Hat Enterprise Linux 4 (64-bit)] を選択し、[Next] をクリックします。図 2-31 を参照してください。

図 2-31 新しい仮想マシンの作成

 

ステップ 6 図 2-32 に示すように、共有データストア上の 7 GB から 15 GB の仮想ディスクを選択します。

図 2-32 共有データストア

 

[Ready to Complete] 画面を図 2-33 に示します。

図 2-33 [Ready to Complete] 画面

 

ステップ 7 図 2-34 に示すように、[New Nic] を選択して、新しい VM VNIC を、vPC システム上に作成された VLAN61 ポート グループにマッピングします。

図 2-34 仮想マシンのプロパティ

 

ステップ 8 図 2-35 に示すように、[New CD/DVD] ドライブを選択して、共有ストレージからの RedHat ISO イメージを新しい仮想 CD/DVD ドライブとしてマッピングします。

図 2-35 RedHat ISO イメージを新しい仮想 CD/DVD ドライブとしてマッピング

 

ステップ 9 [New Virtual Machine] を右クリックして VM の [Power] > [Power on] を選択し、RedHat OS のロードを確認します。

図 2-36 仮想マシンの電源オン

 

ステップ 10 VM コンソールで、図 2-37 に示すように OS がロードされたことを確認します。

図 2-37 Red Hat Linux 5 がロードされた画面

 

VM-FEX 接続の確認シナリオ

VM-FEX 接続の確認シナリオは次のとおりです。


ステップ 1 VM がダイナミック VNIC/VMNIC にマッピングされ、VM-FEX をまたいで Cisco Nexus 5548 デバイス上の新しく自動的に作成されたダイナミック vEthernet インターフェイスに接続される様子を確認します。

NIV モードの Cisco UCS VIC は、VM がポート グループ VLAN61 に関連付けられたときにダイナミック VNIC をイネーブルにし、それをポート グループから継承されたパラメータで設定します。Cisco UCS VIC は DCBX VIC メッセージを Cisco Nexus 5548 デバイス vPC システムに送信します。vPC システムは、vPC メンバ上においてアクティブ/スタンバイ モードでダイナミック vEthernet インターフェイスをイネーブルにし、VNIC を vPC システムに、PTS 付きハードウェアの VN-Link を使用して接続します。ダイナミック VNIC は、インハードウェアベースのフェールオーバーがイネーブルになっている UCS VIC 上にある 20 個のプロビジョニングされたダイナミック VNIC のうちの 1 つです。

POD1-5548-2# show running // this interface was not manually configured but automatically that is why it is called dynamic
interface Vethernet5
inherit port-profile VLAN61
vsi mac 0050.5684.0000
 
...output omitted...
 
OD1-5548-1# show interface vethernet 5
Vethernet5 is up
Bound Interface is Ethernet1/17
Hardware is Virtual, address is 0023.04ee.be01
Port mode is access
Speed is auto-speed
Duplex mode is auto
300 seconds input rate 0 bits/sec, 0 packets/sec
300 seconds output rate 0 bits/sec, 0 packets/sec
Rx
0 unicast packets 0 multicast packets 0 broadcast packets
0 input packets 0 bytes
0 input packet drops
Tx
0 unicast packets 5 multicast packets 0 broadcast packets
5 output packets 1420 bytes
0 flood packets
0 output packet drops
 
POD1-5548-1#
 
 
POD1-5548-1# show running // this interface was not manually configured but automatically that is why it is called dynamic
 
interface Vethernet5
inherit port-profile VLAN61
vsi mac 0050.5684.0000
 
...output omitted...
 
 
POD1-5548-2# show interface vethernet 5
Vethernet5 is up
Bound Interface is Ethernet1/17
Hardware is Virtual, address is 0023.04ee.be01
Port mode is access
Speed is auto-speed
Duplex mode is auto
300 seconds input rate 0 bits/sec, 0 packets/sec
300 seconds output rate 0 bits/sec, 0 packets/sec
Rx
0 unicast packets 0 multicast packets 0 broadcast packets
 
POD1-5548-2# show interface veth 5 detail // veth 5 is standby on switch NX5548-2
vif_index: 25
--------------------------
veth is bound to interface Ethernet1/17 (0x1a010000) // veth 5 is maped to phy. Interf. eth 1/17
priority: 0
vntag: 6
status: standby
registered mac info:
 
POD1-5548-2#
 

ステップ 2 VM VNIC MAC アドレスがダイナミック vEthernet ポート番号 5 に接続されているダイナミック VNIC の MAC アドレスと同じであることを確認します。

 
POD1-5548-2# show mac address
Legend:
* - primary entry, G - Gateway MAC, (R) - Routed MAC, O - Overlay MAC
age - seconds since last seen,+ - primary entry using vPC Peer-Link
VLAN MAC Address Type age Secure NTFY Ports
---------+-----------------+--------+---------+------+----+------------------
+ 61 0050.5684.0000 dynamic 0 F F Po10 // VM connects in VLAN 61
+ 1 588d.090f.0970 dynamic 0 F F Po10
+ 1 588d.090f.0971 dynamic 0 F F Po10
+ 1 588d.090f.0b3c dynamic 0 F F Po10
+ 1 588d.090f.0b3d dynamic 0 F F Po10
POD1-5548-2#
 

これらのインターフェイスは、vCenter サーバによって報告され、Pod1PTS VDS が使用できます。ポート 32 は、VLAN61 内に存在し、アップ状態で VM VNIC に接続されているダイナミック VMNIC インターフェイスです(図 2-38 を参照)。

図 2-38 ダイナミック VMNIC インターフェイス

 

ホストに対する KVM セッションを開くことにより、ESX CIMC を使用してそれらのインターフェイスをリストできます。また、次の ESX console コマンドを入力して、VM がポート グループ VLAN61 に接続するとアクティブにできる 20 個のダイナミック VMNIC をリストできます。

ifconfig-a | more
 

このコマンドの出力におけるダイナミック VNIC の名前 vm_vmnic0 から vf_vmnic19 を図 2-39 に示します。

図 2-39 出力におけるダイナミック VNIC の名前

 

ステップ 3 VLAN61 ポート グループに接続されている VM の電源をオフにして、vEthernet 5 が実行コンフィギュレーションに存在しない状態に移り、ダイナミック MAC アドレスが MAC アドレス テーブルから消える様子を観察します。

POD1-5548-2# show interface vethernet 5
 

このインターフェイスは、(たとえ、VLAN61 の vCenter サーバで VMNIC インターフェイスだったダイナミック VNIC であるポート 32 もダウンしている場合であっても)実行コンフィギュレーションにもう存在しません。

ステップ 4 VM の電源を再投入します。 


 

設定の概要

VM は、電源がオンにされ、ESX ホスト 1 に常駐し、すべての情報が共有ストレージに保存されます。

VM は、Cisco Nexus 5548 デバイス上に作成されたポート グループ VLAN61 に関連付けることによって、PODy(y は POD の番号)PTS VDS に接続されました。VM は、ハードウェアの VN-Link を使用して PTS モードまたは VM-FEX モードで、vPC システムに自動的に接続されています。

VEM bits は、VM VNIC を VMNIC インターフェイスに接続するために PTS モードで使用されます。

この場合、VMNIC インターフェイスは実際の VMNIC ではなく、ESX OS に対するインターフェイスとして提示されるダイナミック VNIC です。ダイナミック VNIC は、Cisco UCS VIC がポート グループ VLAN61 から継承した VNIC パラメータを作成および設定したときにイネーブルにされます。

設定例

!Command: show running-config
!Time: Thu Sep 1 09:29:07 2011
 
version 5.1(3)N1(1)
feature fcoe
 
install feature-set virtualization
feature-set virtualization
hostname POD1-5548-1
 
feature telnet
cfs eth distribute
feature interface-vlan
feature lacp
feature vmfex
feature vpc
feature lldp
feature fex
 
username adminbackup password 5 ! role network-operator
username admin password 5 $1$W40UpSMJ$RP8cRyIJjLhVYlwls9lcq1 role network-admin
no password strength-check
 
banner motd #Nexus 5000 Switch
#
 
ip domain-lookup
class-map type qos class-fcoe
class-map type queuing class-fcoe
match qos-group 1
class-map type queuing class-all-flood
match qos-group 2
class-map type queuing class-ip-multicast
match qos-group 2
class-map type network-qos class-fcoe
match qos-group 1
class-map type network-qos class-all-flood
match qos-group 2
class-map type network-qos class-ip-multicast
match qos-group 2
 
system qos
service-policy type qos input fcoe-default-in-policy
service-policy type queuing input fcoe-default-in-policy
service-policy type queuing output fcoe-default-out-policy
service-policy type network-qos fcoe-default-nq-policy
policy-map type control-plane copp-system-policy
control-plane
service-policy input copp-system-policy
snmp-server user admin network-admin auth md5 0xb2ee7c583c00370672f6605f06113332
priv 0xb2ee7c583c00370672f6605f06113332 localizedkey
snmp-server enable traps entity fru
 
vrf context management
ip route 0.0.0.0/0 10.29.184.1
vlan 1,61
vlan 200
fcoe vsan 200
vethernet auto-create
vpc domain 1
role priority 90
peer-keepalive destination 10.29.186.196
port-profile type vethernet VLAN61
switchport access vlan 61
state enabled
port-profile type ethernet Unused_Or_Quarantine_Uplink
shutdown
description Port-group created for Nexus1000V internal usage. Do not use.
state enabled
port-profile type vethernet Unused_Or_Quarantine_Veth
shutdown
description Port-group created for Nexus1000V internal usage. Do not use.
state enabled
port-profile type vethernet statfloat
sw access vlan 1
state enabled
vsan database
vsan 200
fcdomain fcid database
vsan 200 wwn 20:00:58:8d:09:0f:09:6e fcid 0x730000 dynamic
vsan 200 wwn 21:00:00:c0:dd:15:21:7f fcid 0x730001 dynamic
vsan 200 wwn 21:00:00:c0:dd:12:14:03 fcid 0x730002 dynamic
 
 
interface Vlan1
 
interface Vlan61
no shutdown
ip address 10.10.10.1/24
 
interface port-channel10
switchport mode trunk
spanning-tree port type network
vpc peer-link
 
interface vfc300
bind interface Ethernet1/26
switchport mode E
switchport trunk allowed vsan 1
switchport trunk allowed vsan add 200
no shutdown
 
interface vfc100
bind interface Vethernet100
 
interface vfc400
bind interface Ethernet1/5
no shutdown
 
interface vfc200
bind interface Vethernet200
 
interface vfc500
bind interface Ethernet1/6
no shutdown
vsan database
vsan 200 interface vfc300
vsan 200 interface vfc100
vsan 200 interface vfc400
vsan 200 interface vfc200
vsan 200 interface vfc500
 
 
interface Ethernet1/1
 
interface Ethernet1/2
 
interface Ethernet1/3
 
interface Ethernet1/4
 
interface Ethernet1/5
switchport mode trunk
 
interface Ethernet1/6
switchport mode trunk
 
interface Ethernet1/7
 
interface Ethernet1/8
 
interface Ethernet1/9
 
interface Ethernet1/10
 
interface Ethernet1/11
 
interface Ethernet1/12
 
interface Ethernet1/13
 
interface Ethernet1/14
 
interface Ethernet1/15
 
interface Ethernet1/16
 
interface Ethernet1/17
switchport mode vntag
 
interface Ethernet1/18
switchport mode vntag
 
interface Ethernet1/19
 
interface Ethernet1/20
 
interface Ethernet1/21
 
interface Ethernet1/22
 
interface Ethernet1/23
 
interface Ethernet1/24
shutdown
 
interface Ethernet1/25
 
interface Ethernet1/26
switchport mode trunk
 
interface Ethernet1/27
switchport mode trunk
spanning-tree port type network
channel-group 10
 
interface Ethernet1/28
switchport mode trunk
spanning-tree port type network
channel-group 10
 
interface Ethernet1/29
switchport mode trunk
spanning-tree port type network
channel-group 10
 
interface Ethernet1/30
switchport mode trunk
spanning-tree port type network
channel-group 10
 
interface Ethernet1/31
 
interface Ethernet1/32
 
interface mgmt0
ip address 10.29.186.195/22
 
interface Vethernet1
bind interface Ethernet1/17 channel 10
 
interface Vethernet2
bind interface Ethernet1/18 channel 10
 
interface Vethernet3
bind interface Ethernet1/17 channel 11
 
interface Vethernet4
bind interface Ethernet1/18 channel 11
 
interface Vethernet5
inherit port-profile VLAN61
vsi mac 0050.5684.0004
 
interface Vethernet100
shutdown
switchport mode trunk
bind interface Ethernet1/17 channel 3
 
interface Vethernet145
inherit port-profile statfloat
vsi mac 0050.5601.0144
 
interface Vethernet200
shutdown
switchport mode trunk
bind interface Ethernet1/18 channel 3
 
line console
line vty
boot kickstart bootflash:/n5000-uk9-kickstart.5.1.3.N1.0.223.gbin
boot system bootflash:/n5000-uk9.5.1.3.N1.0.223.gbin
svs connection 2VC
protocol vmware-vim
remote ip address 10.29.186.125 port 80 vrf managment
vmware dvs uuid "8e c7 04 50 cb 46 d1 71-d1 98 68 74 a3 26 6d ff" datacenter-n
ame DC1
connect
logging monitor 4
zone default-zone permit vsan 1
zone default-zone permit vsan 200
 
 
 
 
!Command: show running-config
!Time: Thu Sep 1 09:36:47 2011
 
version 5.1(3)N1(1)
feature fcoe
 
install feature-set virtualization
feature-set virtualization
hostname POD1-5548-2
 
feature telnet
cfs eth distribute
feature interface-vlan
feature lacp
feature vmfex
feature vpc
feature lldp
feature fex
 
username adminbackup password 5 ! role network-operator
username admin password 5 $1$2/VZLE3/$esbYsWazKUXTc/G3xDXd3/ role network-admin
no password strength-check
 
banner motd #Nexus 5000 Switch
#
 
ip domain-lookup
class-map type qos class-fcoe
class-map type queuing class-fcoe
match qos-group 1
class-map type queuing class-all-flood
match qos-group 2
class-map type queuing class-ip-multicast
match qos-group 2
class-map type network-qos class-fcoe
match qos-group 1
class-map type network-qos class-all-flood
match qos-group 2
class-map type network-qos class-ip-multicast
match qos-group 2
 
system qos
service-policy type qos input fcoe-default-in-policy
service-policy type queuing input fcoe-default-in-policy
service-policy type queuing output fcoe-default-out-policy
service-policy type network-qos fcoe-default-nq-policy
policy-map type control-plane copp-system-policy
control-plane
service-policy input copp-system-policy
snmp-server user admin network-admin auth md5 0x659dc61aafac579799b0801bb80a7435
priv 0x659dc61aafac579799b0801bb80a7435 localizedkey
snmp-server enable traps entity fru
 
vrf context management
ip route 0.0.0.0/0 10.29.184.1
vlan 1,61
vlan 200
fcoe vsan 200
vethernet auto-create
vpc domain 1
role priority 100
peer-keepalive destination 10.29.186.195
port-profile type vethernet VLAN61
switchport access vlan 61
state enabled
port-profile type ethernet Unused_Or_Quarantine_Uplink
shutdown
description Port-group created for Nexus1000V internal usage. Do not use.
state enabled
port-profile type vethernet Unused_Or_Quarantine_Veth
shutdown
description Port-group created for Nexus1000V internal usage. Do not use.
state enabled
port-profile type vethernet statfloat
switchport access vlan 1
state enabled
vlan 200
fcoe vsan 200
vethernet auto-create
vpc domain 1
role priority 100
peer-keepalive destination 10.29.186.195
vsan database
vsan 200
fcdomain fcid database
vsan 200 wwn 21:00:00:c0:dd:15:21:7d fcid 0x080000 dynamic
vsan 200 wwn 21:00:00:c0:dd:12:14:01 fcid 0x080001 dynamic
vsan 200 wwn 20:00:58:8d:09:0f:09:6f fcid 0x080002 dynamic
 
interface port-channel10
switchport mode trunk
spanning-tree port type network
vpc peer-link
 
interface vfc300
bind interface Ethernet1/26
switchport mode E
switchport trunk allowed vsan 1
switchport trunk allowed vsan add 200
no shutdown
 
interface vfc100
bind interface Vethernet100
 
interface vfc400
bind interface Ethernet1/5
no shutdown
 
interface vfc200
bind interface Vethernet200
 
interface vfc500
bind interface Ethernet1/6
no shutdown
vsan database
vsan 200 interface vfc100
vsan 200 interface vfc400
vsan 200 interface vfc200
vsan 200 interface vfc500
 
interface Ethernet1/1
 
interface Ethernet1/2
 
interface Ethernet1/3
 
interface Ethernet1/4
 
interface Ethernet1/5
switchport mode trunk
 
interface Ethernet1/6
switchport mode trunk
 
interface Ethernet1/7
 
interface Ethernet1/8
 
interface Ethernet1/9
 
interface Ethernet1/10
 
interface Ethernet1/11
 
interface Ethernet1/12
 
interface Ethernet1/13
 
interface Ethernet1/14
 
interface Ethernet1/15
 
interface Ethernet1/16
 
interface Ethernet1/17
switchport mode vntag
 
interface Ethernet1/18
switchport mode vntag
 
interface Ethernet1/19
shutdown
 
interface Ethernet1/20
shutdown
 
interface Ethernet1/21
shutdown
 
interface Ethernet1/22
shutdown
 
interface Ethernet1/23
shutdown
 
interface Ethernet1/24
shutdown
 
interface Ethernet1/25
shutdown
 
interface Ethernet1/26
switchport mode trunk
 
interface Ethernet1/27
switchport mode trunk
channel-group 10
 
interface Ethernet1/28
switchport mode trunk
channel-group 10
 
interface Ethernet1/29
switchport mode trunk
channel-group 10
 
interface Ethernet1/30
switchport mode trunk
channel-group 10
 
interface Ethernet1/31
 
interface Ethernet1/32
 
interface Ethernet2/1
 
interface Ethernet2/2
 
interface Ethernet2/3
 
interface Ethernet2/4
 
interface Ethernet2/5
 
interface Ethernet2/6
 
interface Ethernet2/7
 
interface Ethernet2/8
 
interface mgmt0
ip address 10.29.186.196/22
 
interface Vethernet1
bind interface Ethernet1/17 channel 10
 
interface Vethernet2
bind interface Ethernet1/18 channel 10
 
interface Vethernet3
bind interface Ethernet1/17 channel 11
 
interface Vethernet4
bind interface Ethernet1/18 channel 11
 
interface Vethernet5
inherit port-profile VLAN61
vsi mac 0050.5684.0004
 
 
interface Vethernet100
shutdown
switchport mode trunk
bind interface Ethernet1/17 channel 4
 
interface Vethernet145
inherit port-profile statfloat
vsi mac 0050.5601.0144
 
interface Vethernet200
shutdown
switchport mode trunk
bind interface Ethernet1/18 channel 4
line console
line vty
boot kickstart bootflash:/n5000-uk9-kickstart.5.1.3.N1.0.223.gbin
boot system bootflash:/n5000-uk9.5.1.3.N1.0.223.gbin
svs connection 2VC
protocol vmware-vim
remote ip address 10.29.186.125 port 80 vrf management
zone default-zone permit vsan 1
zone default-zone permit vsan 200
 
 
pod1-5596-2# sh run
 
!Command: show running-config
!Time: Thu Sep 1 12:54:08 2011
 
version 5.1(3)N1(1)
feature fcoe
 
install feature-set virtualization
feature-set virtualization
switchname pod1-5596-2
 
feature telnet
feature lacp
feature vmfex
feature lldp
feature fex
 
username admin password 5 $1$sdMFwb78$3J2cgv7YbedIzxXlrm66H0 role network-admin
no password strength-check
 
banner motd #Nexus 5000 Switch
#
 
ip domain-lookup
class-map type qos class-fcoe
class-map type queuing class-fcoe
match qos-group 1
class-map type queuing class-all-flood
match qos-group 2
class-map type queuing class-ip-multicast
match qos-group 2
class-map type network-qos class-fcoe
match qos-group 1
class-map type network-qos class-all-flood
match qos-group 2
class-map type network-qos class-ip-multicast
match qos-group 2
system qos
service-policy type qos input fcoe-default-in-policy
service-policy type network-qos fcoe-default-nq-policy
service-policy type queuing input fcoe-default-in-policy
service-policy type queuing output fcoe-default-out-policy
class-map type control-plane match-any copp-system-class-arp
match protocol arp
class-map type control-plane match-any copp-system-class-bgp
match protocol bgp
class-map type control-plane match-any copp-system-class-bridging
match protocol bridging
class-map type control-plane match-any copp-system-class-cdp
match protocol cdp
class-map type control-plane match-any copp-system-class-default
match protocol default
class-map type control-plane match-any copp-system-class-dhcp
match protocol dhcp
class-map type control-plane match-any copp-system-class-eigrp
match protocol eigrp
class-map type control-plane match-any copp-system-class-exception
match protocol exception
class-map type control-plane match-any copp-system-class-glean
match protocol glean
class-map type control-plane match-any copp-system-class-hsrp-vrrp
match protocol hsrp_vrrp
class-map type control-plane match-any copp-system-class-icmp-echo
match protocol icmp_echo
class-map type control-plane match-any copp-system-class-igmp
match protocol igmp
class-map type control-plane match-any copp-system-class-ip-frag
match protocol ip_frag
class-map type control-plane match-any copp-system-class-isis-dce
match protocol isis_dce
class-map type control-plane match-any copp-system-class-lacp
match protocol lacp
class-map type control-plane match-any copp-system-class-lldp
match protocol lldp_dcbx
class-map type control-plane match-any copp-system-class-mgmt
match protocol mgmt
class-map type control-plane match-any copp-system-class-msdp
match protocol msdp
class-map type control-plane match-any copp-system-class-multicast
match protocol multicast
class-map type control-plane match-any copp-system-class-ospf
match protocol ospf
class-map type control-plane match-any copp-system-class-pim
match protocol pim
class-map type control-plane match-any copp-system-class-reg
match protocol reg
class-map type control-plane match-any copp-system-class-rip
match protocol rip
class-map type control-plane match-any copp-system-class-same-if
match protocol same_if
class-map type control-plane match-any copp-system-class-ttl
match protocol ttl
control-plane
service-policy input copp-system-policy-default
slot 1
port 39-48 type fc
snmp-server user admin network-admin auth md5 0x338f7b1376b2f1548acf1f8295c0e734
priv 0x338f7b1376b2f1548acf1f8295c0e734 localizedkey
snmp-server enable traps entity fru
snmp-server community labpublic group network-operator
 
vrf context management
ip route 0.0.0.0/0 10.29.184.1
vlan 1
vlan 200
fcoe vsan 200
vsan database
vsan 200
fcdomain fcid database
vsan 1 wwn 26:02:00:01:55:35:0c:d3 fcid 0xc90000 dynamic
vsan 1 wwn 21:00:00:c0:dd:15:21:7f fcid 0xc90001 dynamic
vsan 1 wwn 21:00:00:c0:dd:12:14:01 fcid 0xc90002 dynamic
vsan 1 wwn 21:00:00:c0:dd:15:21:7d fcid 0xc90003 dynamic
vsan 200 wwn 26:02:00:01:55:35:0c:d3 fcid 0x340000 dynamic
 
 
interface vfc300
bind interface Ethernet1/32
switchport mode E
switchport trunk allowed vsan 1
switchport trunk allowed vsan add 200
no shutdown
vsan database
vsan 200 interface vfc300
vsan 200 interface fc1/48
 
 
interface fc1/39
 
interface fc1/40
no shutdown
 
interface fc1/41
 
interface fc1/42
 
interface fc1/43
 
interface fc1/44
 
interface fc1/45
 
interface fc1/46
 
interface fc1/47
 
interface fc1/48
no shutdown
 
interface Ethernet1/1
switchport trunk allowed vlan none
spanning-tree port type edge trunk
 
interface Ethernet1/2
switchport mode trunk
switchport trunk allowed vlan 1,1000
 
interface Ethernet1/3
 
interface Ethernet1/4
 
interface Ethernet1/5
 
interface Ethernet1/6
 
interface Ethernet1/7
 
interface Ethernet1/8
 
interface Ethernet1/9
 
interface Ethernet1/10
 
interface fc1/41
 
interface fc1/42
 
interface fc1/43
 
interface fc1/44
 
interface fc1/45
 
interface fc1/46
 
interface fc1/47
 
interface fc1/48
no shutdown
 
interface Ethernet1/1
switchport trunk allowed vlan none
spanning-tree port type edge trunk
 
interface Ethernet1/2
switchport mode trunk
switchport trunk allowed vlan 1,1000
 
interface Ethernet1/3
 
interface Ethernet1/4
 
interface Ethernet1/5
 
interface Ethernet1/6
 
interface Ethernet1/7
 
interface Ethernet1/8
 
interface Ethernet1/9
 
interface Ethernet1/10
 
interface Ethernet1/11
 
interface Ethernet1/12
 
interface Ethernet1/13
 
interface Ethernet1/14
 
interface Ethernet1/15
 
interface Ethernet1/16
 
interface Ethernet1/17
 
interface Ethernet1/18
 
interface Ethernet1/19
 
interface Ethernet1/20
 
interface Ethernet1/21
 
interface Ethernet1/22
 
interface Ethernet1/23
 
interface Ethernet1/24
 
interface Ethernet1/25
 
interface Ethernet1/26
shutdown
 
interface Ethernet1/27
 
interface Ethernet1/28
 
interface Ethernet1/29
 
interface Ethernet1/30
 
interface Ethernet1/31
 
interface Ethernet1/32
switchport mode trunk
 
interface Ethernet1/33
 
interface Ethernet1/34
 
interface Ethernet1/35
 
interface Ethernet1/36
 
interface Ethernet1/37
 
interface Ethernet1/38
 
interface mgmt0
ip address 10.29.186.193/22
line console
line vty
boot kickstart bootflash:/n5000-uk9-kickstart.5.1.3.N1.0.212.bin
boot system bootflash:/n5000-uk9.5.1.3.N1.0.212.bin
interface fc1/39
interface fc1/40
interface fc1/41
interface fc1/42
interface fc1/43
interface fc1/44
interface fc1/45
interface fc1/46
interface fc1/47
interface fc1/48
switchport mode F
logging monitor 6
zone default-zone permit vsan 1
zone default-zone permit vsan 200
 
 
!Command: show running-config
!Time: Thu Sep 1 09:42:50 2011
 
version 5.1(3)N1(1)
feature fcoe
 
install feature-set virtualization
feature-set virtualization
hostname pod1-5596-1
 
feature telnet
feature vmfex
feature lldp
feature fex
 
username admin password 5 $1$aFZpnyOJ$kKzqLw8Ftu2I.T8mS.w1O0 role network-admin
no password strength-check
 
banner motd #Nexus 5000 Switch
#
 
ip domain-lookup
class-map type qos class-fcoe
class-map type queuing class-fcoe
match qos-group 1
class-map type queuing class-all-flood
match qos-group 2
class-map type queuing class-ip-multicast
match qos-group 2
class-map type network-qos class-fcoe
match qos-group 1
class-map type network-qos class-all-flood
match qos-group 2
class-map type network-qos class-ip-multicast
match qos-group 2
system qos
service-policy type qos input fcoe-default-in-policy
service-policy type network-qos fcoe-default-nq-policy
service-policy type queuing input fcoe-default-in-policy
service-policy type queuing output fcoe-default-out-policy
class-map type control-plane match-any copp-system-class-arp
match protocol arp
class-map type control-plane match-any copp-system-class-bgp
match protocol bgp
class-map type control-plane match-any copp-system-class-bridging
match protocol bridging
 
police cir 1024 kbps bc 4800000 bytes
class copp-system-class-icmp-echo
police cir 640 kbps bc 3600000 bytes
class copp-system-class-ospf
police cir 1024 kbps bc 4800000 bytes
class copp-system-class-reg
police cir 1024 kbps bc 4800000 bytes
class copp-system-class-rip
police cir 1024 kbps bc 4800000 bytes
class copp-system-class-unicast
police cir 1024 kbps bc 3200000 bytes
class copp-system-class-multicast
police cir 1024 kbps bc 3200000 bytes
class copp-system-class-ip-frag
police cir 1024 kbps bc 3200000 bytes
class copp-system-class-same-if
police cir 1024 kbps bc 3200000 bytes
class copp-system-class-ttl
police cir 1024 kbps bc 3200000 bytes
class copp-system-class-default
police cir 2048 kbps bc 6400000 bytes
policy-map type control-plane copp-system-policy-scaled-l3
class copp-system-class-igmp
police cir 1200 kbps bc 65535 bytes
class copp-system-class-pim
police cir 1024 kbps bc 4800000 bytes
class copp-system-class-bridging
police cir 20000 kbps bc 4800000 bytes
class copp-system-class-arp
police cir 4000 kbps bc 3600000 bytes
class copp-system-class-dhcp
police cir 1024 kbps bc 4800000 bytes
class copp-system-class-mgmt
police cir 12000 kbps bc 4800000 bytes
class copp-system-class-lacp
police cir 1024 kbps bc 4800000 bytes
class copp-system-class-lldp
police cir 2048 kbps bc 4800000 bytes
class copp-system-class-udld
police cir 2048 kbps bc 4800000 bytes
class copp-system-class-msdp
police cir 1024 kbps bc 4800000 bytes
class copp-system-class-vic
police cir 1024 kbps bc 4800000 bytes
class copp-system-class-cdp
police cir 1024 kbps bc 4800000 bytes
class copp-system-class-bgp
police cir 1024 kbps bc 4800000 bytes
class copp-system-class-eigrp
police cir 1024 kbps bc 4800000 bytes
class copp-system-class-exception
police cir 1024 kbps bc 4800000 bytes
class copp-system-class-glean
police cir 4000 kbps bc 4800000 bytes
class copp-system-class-hsrp-vrrp
police cir 1024 kbps bc 4800000 bytes
class copp-system-class-icmp-echo
police cir 4000 kbps bc 3600000 bytes
class copp-system-class-ospf
police cir 1024 kbps bc 4800000 bytes
class copp-system-class-reg
police cir 1024 kbps bc 4800000 bytes
class copp-system-class-rip
police cir 1024 kbps bc 4800000 bytes
class copp-system-class-unicast
police cir 1024 kbps bc 3200000 bytes
class copp-system-class-multicast
police cir 4000 kbps bc 3200000 bytes
class copp-system-class-ip-frag
police cir 1024 kbps bc 3200000 bytes
class copp-system-class-same-if
police cir 1024 kbps bc 3200000 bytes
class copp-system-class-ttl
police cir 1024 kbps bc 3200000 bytes
class copp-system-class-default
police cir 2048 kbps bc 6400000 bytes
control-plane
service-policy input copp-system-policy-default
slot 1
port 39-48 type fc
snmp-server user admin network-admin auth md5 0x512632220ce767d7bf7aed2f7af4b8e9
priv 0x512632220ce767d7bf7aed2f7af4b8e9 localizedkey
snmp-server enable traps entity fru
snmp-server community labpublic group network-operator
 
vrf context management
ip route 0.0.0.0/0 10.29.184.1
vlan 1
vlan 200
fcoe vsan 200
port-profile type ethernet Unused_Or_Quarantine_Uplink
shutdown
description Port-group created for Nexus1000V internal usage. Do not use.
state enabled
port-profile type vethernet Unused_Or_Quarantine_Veth
shutdown
description Port-group created for Nexus1000V internal usage. Do not use.
state enabled
 
vsan database
vsan 200
fcdomain fcid database
vsan 1 wwn 26:01:00:01:55:35:0c:d3 fcid 0x9a0000 dynamic
vsan 1 wwn 21:00:00:c0:dd:14:57:4d fcid 0x9a0001 dynamic
vsan 1 wwn 21:00:00:c0:dd:12:14:03 fcid 0x9a0002 dynamic
vsan 1 wwn 21:00:00:c0:dd:15:21:7f fcid 0x9a0003 dynamic
vsan 200 wwn 26:01:00:01:55:35:0c:d3 fcid 0xe50000 dynamic
 
 
interface vfc300
bind interface Ethernet1/32
switchport mode E
switchport trunk allowed vsan 1
switchport trunk allowed vsan add 200
no shutdown
vsan database
vsan 200 interface vfc300
vsan 200 interface fc1/48
 
 
interface fc1/39
 
interface fc1/40
no shutdown
 
interface fc1/41
 
interface fc1/42
 
interface fc1/43
 
interface fc1/44
 
interface fc1/45
 
interface fc1/46
 
interface fc1/47
 
interface fc1/48
no shutdown
 
interface Ethernet1/1
switchport mode trunk
switchport trunk allowed vlan 1,1000
spanning-tree port type edge trunk
 
interface Ethernet1/2
 
interface Ethernet1/3
 
interface Ethernet1/4
 
interface Ethernet1/5
 
interface Ethernet1/6
 
interface Ethernet1/7
 
interface Ethernet1/8
 
interface Ethernet1/9
 
interface Ethernet1/10
 
interface Ethernet1/11
 
interface Ethernet1/12
 
interface Ethernet1/13
 
interface Ethernet1/14
 
interface Ethernet1/15
 
interface Ethernet1/16
 
interface Ethernet1/17
 
interface Ethernet1/18
 
interface Ethernet1/19
 
interface Ethernet1/20
 
interface Ethernet1/21
 
interface Ethernet1/22
 
interface Ethernet1/23
 
interface Ethernet1/24
 
interface Ethernet1/25
 
interface Ethernet1/26
 
interface Ethernet1/27
 
interface Ethernet1/28
 
interface Ethernet1/29
 
interface Ethernet1/30
 
interface Ethernet1/31
 
interface Ethernet1/32
switchport mode trunk
 
interface Ethernet1/33
 
interface Ethernet1/34
 
interface Ethernet1/35
 
interface Ethernet1/36
 
interface Ethernet1/37
 
interface Ethernet1/38
 
interface mgmt0
ip address 10.29.186.194/22
line console
line vty
boot kickstart bootflash:/n5000-uk9-kickstart.5.1.3.N1.0.212.bin
boot system bootflash:/n5000-uk9.5.1.3.N1.0.212.bin
interface fc1/39
interface fc1/40
interface fc1/41
interface fc1/42
interface fc1/43
interface fc1/44
interface fc1/45
interface fc1/46
interface fc1/47
interface fc1/48
zone default-zone permit vsan 1
zone default-zone permit vsan 200