Cisco Nexus 5000 シリーズ NX-OS オペレーション ガイド Cisco NX-OS Release 5.0(2)N1(1) および 5.0(2)N2(1)
設定の同期操作
設定の同期操作
発行日;2012/05/09 | 英語版ドキュメント(2012/03/27 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

設定の同期操作

設定の同期操作

この章では、vPC トポロジにおける設定の同期操作について説明します。この章で説明する内容は、次のとおりです。

「概要」

「設定の同期に関するベスト プラクティス」

「設定例」

「At-A-Glance コンフィギュレーション モード」

「用語」

概要

一部の Cisco NX-OS ソフトウェア機能では、ネットワーク内の Cisco Nexus 5000 シリーズ スイッチ間で整合性のある設定が必要になります。たとえば、Virtual Port Channel(vPC; 仮想ポート チャネル)トポロジでは、各ピア スイッチ上に同じ設定が必要になります。その結果、ネットワーク管理者は両方のスイッチで設定を繰り返す必要があります。この処理では、設定ミスや漏れによるエラーが発生する場合があります。これは、設定の不一致によるその他のサービス障害につながる可能性があります。設定の同期機能は、ネットワーク管理者が 1 つのスイッチを設定し、ピア スイッチの設定を自動的に同期させることができるようにすることにより、これらの問題を除去します。

vPC トポロジでは、2 つの物理スイッチ間に Etherchannel を形成できます。vPC は、任意のネットワーキング デバイスまたはエンド ホストに接続できます。各 Cisco Nexus 5000 シリーズ スイッチはダウンストリーム デバイスへの Etherchannel バンドルを形成しているため、各スイッチのいくつかのパラメータが一致している必要があります。vPC 整合性検査は、両方の Cisco Nexus 5000 シリーズ スイッチが同じ設定(Type1 または Type2)を持つことを確認するために使用されます。設定が一致しない場合は、グローバル(スパニング ツリー ポート モードなど)、ポートレベル(速度、デュプレックス、またはチャネルグループ タイプなど)、またはポート チャネル インターフェイスであるかどうかに応じて、両方のピア スイッチで vPC が中断ステートになったり、VLAN がブロッキング ステートになったりする可能性があります。その結果、管理者は、1 つのスイッチの設定がまったく同じようにピア スイッチにコピーされていることを確認する必要があります。

設定の同期は、ネットワーク内のスイッチのペア間の設定を同期させるためのメカニズムを提供します。スイッチ プロファイルは、ローカルに適用されるだけでなく、そのピアに同期されるコンフィギュレーション ファイルを作成するために使用されます。設定の同期と vPC は、独立した 2 つの機能です。設定の同期では、vPC 整合性検査は除外されません。この検査は継続され、設定の不一致がある場合は、vPC が中断ステートになります。設定の同期機能の重要なメリットの 1 つは、ネットワーク管理者が両方のスイッチで同じ設定を繰り返す必要がなくなることです。

ここでは、次の内容について説明します。

「設定の同期のメリット」

「要件」

「注意事項および制約事項」

「IP を介した Cisco Fabric Service」

「スイッチ プロファイル」

「User-Based アクセス コントロール」

「確認チェック」

「コミット」

「バッファリング」

「インポート」

設定の同期のメリット

設定の同期には、次のメリットがあります。

スイッチ間の設定を同期させるためのメカニズムが提供されます。

ピア間で接続が確立されると、設定がマージされます。

同期させる設定をネットワーク管理者が選択できます。

コマンドの相互排他機能が提供されます。

NX-OS コマンドの確認およびコミット機能が提供されます。

既存のセッションおよびポートのプロファイル機能がサポートされています。

既存の vPC 設定をスイッチ プロファイルに移行するためのインポート コマンドが提供されます。

Gigabit Expansion Module(GEM, ギガビット拡張モジュール)および Fabric Extender(FEX)事前プロビジョニングがサポートされています。

要件

設定の同期機能を使用するには、次のものが必要です。

Cisco NX-OS Release 5.0(2)N1(1) またはそれ以降のリリース

各ピア上でイネーブルになっている Cisco Fabric Services over IP(CFSoIP; IP を介した Cisco Fabric Service)

各スイッチ上に同一のスイッチ プロファイル

構成されたピア IP アドレス

注意事項および制約事項

設定の同期に関するガイドラインは、次のとおりです。

スイッチ プロファイル内に次のインターフェイスを設定する必要があります。

ポート チャネル インターフェイス

チャネル グループ メンバーでないポート

すべてのポート チャネル メンバーは、設定端末モードで、スイッチ プロファイル外に設定する必要があります。

設定は、指定された順序に従っている必要があります。

vPC トポロジのタイプ(A/A または Straight Through)および必要な設定のタイプ(ポート チャネル、非ポート チャネル、FEX、QoS など)に応じて、スイッチ プロファイル モードまたは設定端末モードを使用する必要があります。さまざまなタイプの設定に使用されるモードの識別については、「At-A-Glance コンフィギュレーション モード」を参照してください。

設定の同期には、次の制限があります。

vPC における FCoE

通常、設定はピア スイッチごとに異なるため、スイッチ プロファイル内では FCoE 設定はサポートされません。vPC ピア スイッチで FCoE がイネーブルになっている場合は、スイッチ プロファイル内でポート チャネルを設定しないでください。

feature コマンド

スイッチ プロファイル内では、条件機能をイネーブルにする feature feature name コマンドはサポートされません。これらのコマンドは、設定端末モードで、各ピア スイッチに対して個別に設定する必要があります。

コンフィギュレーション ロールバック機能と条件機能

設定の同期では、チェックポイントには条件機能が存在するのに実行コンフィギュレーションには存在しない場合は、そのチェックポイントへのコンフィギュレーション ロールバックが失敗します。これを回避するには、コンフィギュレーション ロールバックが実行される前に、条件機能(「feature xyz」)を再設定します。この回避策は、vpc-domain モードでの vpc domain コマンドおよび peer-keepalive コマンドにも適用されます。

vPC 設定

設定の同期を使用するには、vPC トポロジ内で設定された 2 つの Cisco Nexus 5000 シリーズ スイッチ ピア スイッチが必要です。図 2-1 は、2 つの Cisco Nexus 5000 シリーズ スイッチ(N5k-1 および N5k-2)に設定された vPC トポロジを示したものです。

図 2-1 vPC トポロジ

 

2 つの Cisco Nexus 5000 シリーズ スイッチに vPC を設定するには、次の手順を実行します。


ステップ 1 vPC ドメインを作成し、vPC キープアライブ リンクを設定します。

両方のピア スイッチで、同じ vPC ドメイン ID を作成する必要があります。

このドメイン ID は、vPC システム MAC アドレスを自動的に形成するために使用されます。

N5k-1(config)#vpc domain 10
N5k-2(config)#vpc domain 10
 

ステップ 2 vPC ピアキープアライブ リンクを設定します。

キープアライブ メッセージを伝送するピアキープアライブ リンクの宛先 IP を設定できます。必要に応じて、キープアライブ メッセージのその他のパラメータも設定できます。

N5k-1(config)#vpc domain 10
N5k-1(config-vpc-domain)#peer-keepalive destination 10.29.170.8 vrf management
 
N5k-2(config)#vpc domain 10
N5k-2(config-vpc-domain)#peer-keepalive destination 10.29.170.7 vrf management
 

ステップ 3 vPC ピア リンクを作成して設定します。

ピア リンクは、各スイッチで、指定された vPC ドメインのピア リンクとして EtherChannel を指定することによって作成できます。冗長性を確保するため、トランク モードで vPC ピア リンクとして指定する EtherChannel を設定し、各 vPC ピア スイッチで個別のモジュールの 2 つのポートを使用することを推奨します。

 
N5k-1(config)#interface port-channel 10
N5k-1(config-if)vpc peer-link
 
N5k-1(config)#interface ethernet 1/17-18
N5k-1(config-if-range)#switchport mode trunk
N5k-1(config-if-range)#channel-group 10
 
N5k-2(config)#interface port-channel 10
N5k-2(config-if)#vpc peer-link
 
N5k-2(config)#interface ethernet 1/17-18
N5k-2(config-if-range)#switchport mode trunk
N5k-2(config-if-range)#channel-group 10
 

) 2 つの Cisco Nexus 5000 シリーズ スイッチ間の vPC ピア リンクは、両方のスイッチで手動で設定するか、2 つのピア スイッチのいずれかから設定の同期を使用して設定できます。vPC ピア リンクを設定するための設定の同期方法については、「設定の同期を使用した vPC トポロジの設定」を参照してください。vPC 機能の詳細については、次の URL にある「仮想ポート チャネルの操作」および『Cisco Nexus 5000 Series NX-OS Layer 2 Switching Configuration Guide, Release 5.0(2)N2(1)』を参照してください。
http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/layer2/502_n2_1/Cisco_n5k_laye
r2_config_gd_rel_502_N2_1_chapter8.html


IP を介した Cisco Fabric Service

CFSoIP(Cisco Fabric Services over IP)プロトコルは、mgmt0 インターフェイス(mgmt Virtual Routing and Forwarding(VRF))を介して設定の同期機能を転送します。mgmt0 インターフェイスに接続されていることを確認する必要があります。CFSoIP と Cisco Fabric Service(CFS)は、異なるプロトコルです。CFS は、vPC のピア リンクを介して実行されます。どちらのプロトコルも CFS プロトコルに基づいていますが、異なる制御パケットを交換します。

CFSoIP プロトコルを使用して設定の同期を行うには、次の手順を実行します。


ステップ 1 各ピア スイッチで、CFSoIP を手動でイネーブルにします。

N5k-1# config terminal
N5k-1(config)# cfs ipv4 distribute
 
N5k-2# config t
N5k-2(config)# cfs ipv4 distribute
 

) CFSoIP は、Switch Virtual Interface(SVI; スイッチ仮想インターフェイス)/デフォルト VRF ではサポートされません。


ステップ 2 mgmt0 トランスポート インターフェイスを介したピア接続を確立します。

 
N5K-1# configure terminal
N5K-1(config)# interface mgmt 0
N5K-1(config-if)# ip address 10.29.170.7/24
N5K-1(config-if)# vrf context management
N5K-1(config-vrf)# ip route 0.0.0.0/0 10.29.170.1
 
 
N5K-2# configure terminal
N5K-2(config)# interface mgmt 0
N5K-2(config-if)# ip address 10.29.170.8/24
N5K-2(config-if)# vrf context management
N5K-2(config-vrf)# ip route 0.0.0.0/0 10.29.170.1
 

スイッチ プロファイル

Cisco NX-OS Release 5.0(2)N1(1) 以降では、config-sync コンフィギュレーション モードを使用してスイッチ プロファイルを作成できます。スイッチ プロファイルには、両方のピアが同じ設定を持つようにピア スイッチを構成するために使用できる定義済みの設定が含まれます。config-sync モードでは、ピアおよびスイッチ プロファイルの設定を定義できます。各ピアは IP アドレスによって識別され、各スイッチ プロファイルに対してローカルです。config-sync モードで入力したコマンドは、コミットされるまでバッファリングされます。設定端末モードで行われた設定変更は、ローカル スイッチだけに適用されます。

config-sync モードでは、各ピア スイッチで同じスイッチ プロファイルを作成する必要があります。この設定は自動的に同期されないため、各ピア スイッチ上で設定する必要があります。

スイッチ プロファイルを作成するには、次の手順を実行します。

N5k-1# config sync
N5k-1(config-sync)# switch-profile Test
N5k-1(config-sync)# sync-peers destination 10.29.170.8
 
N5k-2# config sync
N5k-2(config-sync)# switch-profile Test
N5k-2(config-sync)# sync-peers destination 10.29.170.7
 

) 両方のピアで、同じスイッチ プロファイル名を使用する必要があります。各ピア スイッチでは、1 つのスイッチ プロファイルだけを作成できます。


Cisco NX-OS Release 5.0(2)N1(1) では、スイッチ プロファイルでサポートされないコマンドがあります。config-sync モード コマンドの使用は、vPC 設定に制限されています。

スイッチ プロファイル コマンド

スイッチ プロファイル内では、次のコンフィギュレーション コマンドがサポートされます。

VLAN

ACL

Spanning-Tree Protocol(STP; スパニング ツリー プロトコル)

Quality of Service(QoS; サービス品質)

インターフェイス設定(イーサネット、ポート チャネル、または vPC インターフェイス)

スイッチ プロファイル内では、次のコマンドはサポートされません。

enable フィーチャ セット(特定の機能を手動でイネーブルにしてから関連設定を追加する必要があります)。

vPC ドメイン

vPC ピアキープアライブ

FCoE

User-Based アクセス コントロール

Cisco NX-OS Release 5.0(2)N1(1) では、たとえ別のユーザが同じ管理者特権を持っていても、スイッチ プロファイルを編集できるのは、そのスイッチ プロファイルを作成したユーザだけです。Cisco NX-OS Release 5.0(2)N2(1) 以降では、Role Based Access Control(RBAC; ロールベース アクセス コントロール)設定に基づいて、スイッチ プロファイル設定を追加、削除、または変更できます。スイッチ プロファイルにアクセスするための適切な特権レベルを持つユーザは、スイッチプロファイルを正常に変更し、設定をコミットできます。

RBAC の詳細については、次の URL にある『 Cisco Nexus 5000 Series System Management Configuration Guide 』を参照してください。

http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/system_management/502_n1_1/Cisco_n5k_system_mgmt_cg_rel_502_n1_1_chapter6.html#con_1230576

ネットワーク管理者は、スイッチ プロファイルへのユーザ アクセスを制限できます。制限されているユーザは、スイッチ プロファイルにアクセスするための特権を持っていれば、発信側スイッチでそのスイッチ プロファイルを正常にコミットできます。ただし、特定のコマンド(たとえば、 switchport mode access コマンド)の発行は、そのユーザに割り当てられている RBAC ポリシーおよびルールに従って失敗したり成功したりします。

また、ピア スイッチで正常にコミットするためには、同じユーザ名と特権レベルが存在する必要があります。ピア スイッチに同じユーザ名と特権レベルが存在しない場合は、コミットに失敗します。設定の同期対象ピアがまったく同じように設定されたユーザおよびロールを持つことを確認する必要もあります。場合によっては、同じユーザ名が存在していても、ロールが不一致になることがあります。また、1 つのピア スイッチに同じユーザが存在すると、他方のピア スイッチでのロールの制限がより厳しくなり、コミットに失敗する可能性もあります。これらの問題を回避するため、管理者は、一致するロールを持つユーザ名をピア スイッチ上で設定する必要があります。ベスト プラクティスとしては、ネットワーク管理者ロールを持つユーザがスイッチ プロファイルを作成します。これにより、権限の問題によって設定のコミットに失敗するリスクが軽減されます。

vPC トポロジでは、1 つ目のピア スイッチで Cisco NX-OS Release 5.0(2)N1(1) が稼動し、2 つ目のピア スイッチで Cisco NX-OS Release 5.0(2)N2(1) が稼動している場合、コミットに成功するかどうかは、コミットの発行に使用されたスイッチによって決まります。Cisco NX-OS Release 5.0(2)N1(1) が稼動しているスイッチでは、スイッチ プロファイルを作成したユーザだけがコミットを発行できます。Cisco NX-OS Release 5.0(2)N2(1) が稼動しているスイッチでは、適切な特権を持つユーザがコミットを発行できます。

確認チェック

スイッチ プロファイル設定またはスイッチ プロファイルの一部ではない設定を上書きする可能性を減らすため、次の 2 種類の確認チェックが実行されます。

「相互排他」

「マージ チェック」

相互排他

相互排他チェックでは、スイッチ プロファイル設定とグローバル設定(スイッチ プロファイルの一部ではない設定)間の潜在的な競合が特定されます。スイッチ プロファイルに含まれるコマンドはそのスイッチ プロファイル外に設定できませんが、これと同じルールがピア スイッチにも適用されます。

相互排他チェックは、ローカルに、ピア スイッチ上で実行されます。 verify または commit コマンドを入力すると、mgmt0 インターフェイスを使用してピア スイッチに到達できる場合は、ローカル スイッチとピア スイッチの両方でチェックが実行されます。ピア スイッチに到達できないときは、ローカル スイッチ上でのみ、チェックが実行されます。

相互排他チェックに失敗した場合は、手動で設定を修正し、 commit コマンドを再度入力する必要があります。

次のコマンドは例外で、コマンドをスイッチ プロファイルの内部および外部に記述できます。相互交換エラーを受信することもありません。

インターフェイス コンフィギュレーション コマンド

shutdown/no shutdown コマンド

システムの Quality of Service(QoS; サービス品質)コマンド( system qos コマンド)

マージ チェック

マージ チェックは、受信される設定が受信側スイッチにすでに存在するスイッチ プロファイル設定と競合しないことを確認するために、ピア スイッチで実行されます。マージ チェックに失敗した場合は、設定を手動で修正し、 commit コマンドを再度入力する必要があります。

コミット

設定をピア スイッチと同期させ、設定をローカルに適用するには、 commit コマンドを使用します。設定は、 commit コマンドが発行されるまでバッファ内に格納されます。コミットは、vPC のプライマリ スイッチまたはセカンダリ スイッチによって実行できます。イニシエータは、 commit コマンドの発行元のスイッチです。 commit コマンドは、一度に 1 つのスイッチでのみ実行できます。コミットの実行中に別のコミットを実行しようするとと、実行しようとしたコミットは失敗し、次の Syslog メッセージが表示されます。

Failed: Session Database already locked, Verify/Commit in Progress
 

ベスト プラクティスとしては、1 つのスイッチをイニシエータとして割り当て、そのスイッチですべての設定を行ってから、ピア スイッチで設定を同期させます。これにより、処理が簡素化され、考えられる混乱が減少します。

スイッチ プロファイル セッションが進行している間は、すべての設定変更が阻止されます。これは、サポートされているすべてのコマンドに対する設定端末モードでの変更も含みます。


) ピア スイッチに到達できる場合に commit コマンドが発行されると、設定はローカルに、およびそのピア スイッチに適用されます。コミットが正常に実行されない場合は、ローカル スイッチまたはリモート スイッチ上で設定が適用されません(アトミック動作)。


コマンドは、バッファリングされた順序で実行されます。特定のコマンド(たとえば、QoS ポリシー コマンド)間に順序の依存関係がある場合は、適用する前に定義しておく必要があります。コマンドの順序は、バッファ内で編集できます。イネーブルにする必要がある機能の一部であるコマンドを含める場合は、各スイッチでその機能が手動でイネーブルになり、定義されていることを確認する必要があります。


feature コマンド(たとえば、feature vpcfeature lacp)は、ピア間で同期されません。


commit コマンドを発行する際に、CLI プロンプトがすぐに返されない場合があります。設定のサイズが極端に大きいと、設定が適用されるまでに長い時間がかかる可能性があります。これは正常動作であり、( Ctrl+C Ctrl+Z を発行することによって)コミットを中止しないことを推奨します。中止すると、設定が不整合状態になる可能性があります

バッファリング

スイッチ プロファイル設定は、 commit コマンドが発行されるまでバッファ内に格納されます。バッファ内では、設定を追加、削除、または変更できます。 commit コマンドを使用して設定がプッシュされると、その設定はシステム設定に適用されます。設定が適用されたことを確認するには、 show running コマンドを使用します。 show running switch-profile コマンドを使用して、スイッチ プロファイルによってどの設定が同期されたかを明確に確認することもできます。

バッファに格納された設定に関する次のガイドラインを考慮してください。

設定は、正常にコミットされるまでバッファ内に格納されます。

バッファ内では、設定を追加、削除、または変更できます。

コマンドは、バッファリングされた順序で実行されます。バッファ内での順序は、 buffer-delete コマンドまたは buffer-move コマンドを使用して変更できます。

インポート

Cisco NX-OS Release 5.0(2)N1(1) にアップグレードする際に、 import コマンドを入力して、サポートされている実行コンフィギュレーション コマンドをスイッチ プロファイルにコピーできます。 switch -profile import コマンドを使用すると、実行コンフィギュレーション全体をインポートするか、マージする特定のインターフェイスを選択できます。インポート処理中の変更はサポートされません。インポート設定に加えて新しいコマンドを追加すると、コミットに失敗する可能性があります。その場合、コマンドはバッファ内に維持されます。バッファを修正して commit コマンドを再度入力するか、インポート モードを中止するかを選択できます。インポートを中止すると、バッファ内のコマンドは失われます。

設定の同期に関するベスト プラクティス

設定の同期は、主に vPC トポロジで使用されます。設定の同期が正常に行われるように、次のベスト プラクティス ガイドラインを考慮してください。


注意 Cisco NX-OS Release 5.0(2)N1(1) を使用している場合は、この章で説明する設定の同期に関するベスト プラクティスに従う必要があります。そうしないと、設定が不整合状態になる可能性があります。

Cisco NX-OS Release 5.0(2)N1(1) では、設定の同期に加えて、3 つの追加機能が導入されています。

事前プロビジョニング:オフラインの GEM および FEX インターフェイスを設定できます。

ポート プロファイル:整合性のあるインターフェイス設定を定義して、複数のポートに適用できます。

ポート プロファイルはポートに適用され、スイッチ プロファイルはスイッチ設定に適用されます。これらは、同じではありません。

ポート プロファイルは設定の同期に必須ではありませんが、設定の同期に含めることができます。

コンフィギュレーション ロールバック:実行コンフィギュレーションのチェックポイントを作成して、それらのチェックポイントへのロールバックを実行できます。

設定の同期を強化し、vPC トポロジで最大のメリットを提供するには、事前プロビジョニング、ポート プロファイル、およびコンフィギュレーション ロールバックを使用します。この章で示す例には、これらの機能が含まれます。これらの機能の詳細については、『 Cisco Nexus 5000 Series Configuration Guide 』を参照してください。


) これらの機能は設定の同期に依存しないため、設定の同期を使用するためにイネーブルにする必要はありません。


設定例

ここでは、次の設定例を示します。

「設定の同期を使用した vPC トポロジの設定」

「デュアルホーム接続 FEX トポロジ(Active/Active FEX トポロジ)」

「Active/Active FEX トポロジでの新しい展開」

「Active/Active FEX トポロジを使用した既存の展開」

「スイッチ vPC トポロジと Straight-Through FEX トポロジ(ホスト vPC)」

「vPC トポロジおよび Straight-Through FEX トポロジでの新しい展開」

「vPC トポロジおよび Straight-Through FEX トポロジでの既存の展開」

「新しい Cisco 2000 シリーズ Fabric Extender の設置」

「Cisco Nexus 5000 シリーズ スイッチのリロード」

「vPC ピア リンクの失敗」

「mgmt0 インターフェイスの接続が失われた場合」

「条件機能によるロールバックの失敗」


) 次の例は、Cisco NX-OS Release 5.0(2)N1(1) の時点で最新です。


設定の同期を使用した vPC トポロジの設定

図 2-2 に示すトポロジでは、N5k-1 および N5k-2 は vPC ドメイン 10 の一部です。ピアキープアライブは mgmt0 インターフェイスを介して設定され、Ethernet 1/17-18 は PO 10 にバンドルされてピア リンクを形成しています。設定の同期により、ピア スイッチ上での設定の整合性が維持され、vPC トポロジでのスイッチ管理が簡素化されます。

図 2-2 vPC トポロジ

 

例 2-1 は、vPC を動作可能にするために必要な実行コンフィギュレーションの例を示します。

例 2-1 vPC トポロジでのピア スイッチの実行コンフィギュレーション

N5k-1 の vPC 設定
N5k-2 の vPC 設定
vlan 1-10
 
feature vpc
 
vpc domain 10
peer-keepalive destination 10.29.170.8
peer-config-check-bypass
 
interface port-channel10
switchport mode trunk
vpc peer-link
spanning-tree port type network
 
interface Ethernet1/17
switchport mode trunk
channel-group 10
 
interface Ethernet1/18
switchport mode trunk
channel-group 10
vlan 1-10
 
feature vpc
 
vpc domain 10
peer-keepalive destination 10.29.170.7
peer-config-check-bypass
 
interface port-channel10
switchport mode trunk
vpc peer-link
spanning-tree port type network
 
interface Ethernet1/17
switchport mode trunk
channel-group 10
 
interface Ethernet1/18
switchport mode trunk
channel-group 10

) vPC のベスト プラクティス設定は、peer-config-check-bypass です。詳細については、次の URL にある『Cisco Nexus 5000 Series Design Guide』を参照してください。http://www.cisco.com/en/US/prod/collateral/switches/ps9441/ps9670/C07-572829-01_Design_N5K_N2K_vPC_DG.pdf


図 2-2 に示す vPC トポロジを設定するには、次の手順を実行します。


ステップ 1 ピア スイッチで vPC 機能をイネーブルにします。

N5K-1(config-vpc-domain)# feature vpc
 
N5K-2(config-vpc-domain)# feature vpc
 

ステップ 2 mgmt0 インターフェイスを使用して、両方のスイッチでピアキープアライブを設定します。

N5K-1(config)# vpc domain 10
N5K-1(config-vpc-domain)# peer-keepalive destination 10.29.170.8
 
N5K-2(config)# vpc domain 10
N5K-2(config-vpc-domain)# peer-keepalive destination 10.29.170.7
 

ステップ 3 両方のスイッチで CFSoIP をイネーブルにします。

N5k-1# configuration terminal
N5k-1(config)# cfs ipv4 distribute
 
N5k-2# configuration terminal
N5k-2(config)# cfs ipv4 distribute
 

ステップ 4 両方のスイッチで、同じ名前を持つスイッチ プロファイルを設定します。

N5K-1(config)# config sync
N5K-1(config-sync)# switch-profile Test
 
N5K-2(config)# config sync
N5K-2(config-sync)# switch-profile Test

ステップ 5 sync peer destination コマンドを入力して、両方のスイッチを設定します。

N5k-1# config sync
N5k-1(config-sync)# switch-profile Test
N5k-1(config-sync-sp)# sync-peers destination 10.29.170.8
 
N5k-2# config sync
N5k-2(config-sync)# switch-profile Test
N5k-2(config-sync-sp)# sync-peers destination 10.29.170.7
 

ステップ 6 スイッチ プロファイル モードで、ピア リンクのポート チャネル インターフェイスを作成します。

N5K-1(config-if)# config sync
N5K-1(config-sync)# switch-profile Test
N5K-1(config-sync-sp)# int po10
N5K-1(config-sync-sp-if)# exit
N5K-1(config-sync-sp)# commit
 

ステップ 7 インターフェイス モードで、ポート チャネル メンバーを PO 10 に関連付けます。

N5K-1# config t
N5K-1(config)# int ether 1/17-18
N5K-1(config-if)# channel-group 10
 
N5K-2# config t
N5K-2(config)# int ether 1/17-18
N5K-2(config-if)# channel-group 10
 

ステップ 8 スイッチ プロファイル モードで、ポート チャネル インターフェイスの下に適切な設定を追加してピア リンクを形成します。

N5K-1(config-if)# config sync
N5K-1(config-sync)# switch-profile Test
Switch-Profile started, Profile ID is 1
N5K-1(config-sync-sp)# interface po10
N5K-1(config-sync-sp-if)# switchport mode trunk
N5K-1(config-sync-sp-if)# vpc peer-link
N5K-1(config-sync-sp-if)# commit
 
Verification successful...
Proceeding to apply configuration. This might take a while depending on
amount of configuration in buffer.
Please avoid other configuration changes during this time.
Commit Successful
 

デュアルホーム接続 FEX トポロジ(Active/Active FEX トポロジ)

図 2-3 は、各 FEX が 2 つの Cisco Nexus 5000 シリーズ スイッチにデュアルホーム接続されていることを示します。各 FEX の FEX ファブリック インターフェイスは、両方のピア スイッチで vPC として設定されています。FEX のホスト インターフェイスは、両方のピア スイッチに表示されます。これらのホスト インターフェイスが 1 つのポート チャネルにバンドルされている場合は、両方のピア スイッチでそのポート チャネルをまったく同じように設定する必要があります。設定の同期により、vPC ピア スイッチのペア間で FEX 設定が同期された状態を維持できます。

図 2-3 デュアルホーム接続 FEX Active/Active トポロジ

 

図 2-3 に示すトポロジでは、vPC はすでに動作状態です。FEX 100 は、FEX ファブリック インターフェイスである Ethernet 1/1 上の親スイッチ N5k-1 および N5k-2 にデュアルホーム接続されています。FEX は事前プロビジョニングされているため、Ethernet 1/1 上には既存の実行コンフィギュレーションは存在しません。


) 同じ FEX 内のポート チャネルは、Cisco Nexus 2200 シリーズ Fabric Extender でサポートされます。


FEX 100 は、2 種類のホスト インターフェイスを持つように設定されています。1 つはサーバに単独で接続された Ethernet100/1/1(非ポート チャネル メンバー)であり、もう 1 つはサーバへのポート チャネル内で設定された Ethernet 100/1/2-3(ポート チャネル メンバー)です。

例 2-2 は、ピア スイッチの実行コンフィギュレーションの例を示します。2 種類の設定を示しています。

基本設定

ポート プロファイル設定

いずれかのオプションを使用することも、両方の設定を同時に使用することもできます。


) ポート プロファイルは必須ではありませんが、運用上のオーバーヘッドを削減するために使用できます。


例 2-2 ピア スイッチの A/A トポロジでの FEX実行コンフィギュレーション

基本設定:ポート プロファイルなし
ポート プロファイル設定
vlan 1-10
 
interface port-channel100
switchport mode fex fabric
vpc 100
fex associate 100
 
interface port-channel 200
switchport mode trunk
switchport trunk allowed vlan 1-5
 
interface Ethernet1/1
fex associate 100
switchport mode fex fabric
channel-group 100
 
interface Ethernet100/1/1
switchport mode trunk
switchport trunk allowed vlan 1-10
 
interface Ethernet100/1/2
switchport mode trunk
switchport trunk allowed vlan 1-5
channel-group 200
 
interface Ethernet100/1/3
switchport mode trunk
switchport trunk allowed vlan 1-5
channel-group 200
 
vlan 1-10
 
port-profile type ethernet eth-profile
switchport mode trunk
state enabled
 
port-profile type port-channel pc-profile
switchport mode trunk
state enabled
 
interface port-channel100
switchport mode fex fabric
vpc 100
fex associate 100
 
interface port-channel 200
inherit port-profile pc-profile
switchport trunk allowed vlan 1-5
 
interface Ethernet1/1
fex associate 100
switchport mode fex fabric
channel-group 100
 
interface Ethernet100/1/1
inherit port-profile eth-profile
switchport trunk allowed vlan 1-10
 
interface Ethernet100/1/2
switchport mode trunk
switchport trunk allowed vlan 1-5
channel-group 200
 
interface Ethernet100/1/3
switchport mode trunk
switchport trunk allowed vlan 1-5
channel-group 200

Active/Active FEX トポロジでの新しい展開

この展開では、ピア スイッチ間の設定を同期させるために、最初から設定の同期を導入します。その結果、FEX ポート上には既存の実行コンフィギュレーションは存在しません。

次に、図 2-3 に示すデュアルホーム接続 FEX A/A トポロジを設定する例を示します。


ステップ 1 両方のスイッチで CFSoIP をイネーブルにします。

N5k-1# config t
N5k-1(config)# cfs ipv4 distribute
 
N5k-2# config t
N5k-2(config)# cfs ipv4 distribute
 

ステップ 2 両方のスイッチでスイッチ プロファイルを作成します。

N5k-1# config sync
N5k-1(config-sync)# switch-profile Test
N5k-1(config-sync-sp)# sync-peers destination <out of band mgmt0 IP address of peer switch N5k-2>
 
N5k-2# config sync
N5k-2(config-sync)# switch-profile Test
N5k-2(config-sync-sp)# sync-peers destination <out of band mgmt0 IP address of peer switch N5k-1>
 

ステップ 3 FEX を事前プロビジョニングします。


) FEX A/A トポロジでは、必ずスイッチ プロファイル内でデュアルホーム接続された FEX を事前プロビジョニングしてください。これにより、FEX が Cisco Nexus 5000 シリーズ スイッチに接続されていない場合の設定の同期が容易になります。


N5k-1(config-sync-sp)# slot 100
N5k-1(config-sync-sp-slot)# provision model N2k-C2232P
N5k-1(config-sync-sp-slot)# exit
 
N5K-1(config-sync-sp-if)# sh switch-profile buffer
 
switch-profile : Test
----------------------------------------------------------
Seq-no Command
----------------------------------------------------------
1 slot 100
1.1 provision model N2K-C2232P
 

ステップ 4 参照先のグローバル設定をスイッチ プロファイルに追加します。


) インターフェイス設定が同期されるため、インターフェイス上で適用するすべてのポリシー(ポート プロファイル、QoS、ACL ポリシーなど)を同期させる必要があります。


N5k-1(config-sync-sp)# port-profile type ethernet eth-profile
N5k-1(config-sync-port-prof)# switchport mode trunk
N5k-1(config-sync-port-prof)# state enabled
 
N5k-1(config-sync-sp)# port-profile type port-channel pc-profile
N5k-1(config-sync-port-prof)# switchport mode trunk
N5k-1(config-sync-port-prof)# state enabled
 

ステップ 5 スイッチ プロファイル内にイーサネット インターフェイス(非ポート チャネル メンバー)を設定します。

N5k-1(config-sync-sp)# interface Ethernet100/1/1
N5k-1(config-sync-sp-if)# inherit port-profile eth-profile
N5k-1(config-sync-sp-if)# switchport trunk allowed vlan 1-10
 

ステップ 6 スイッチ プロファイル内にポート チャネル インターフェイスを作成します。


) ポート チャネル インターフェイスは、設定端末モードではなく、スイッチ プロファイル内に設定する必要があります。


ポート チャネル 100(vPC 100)は、N5k と N2k 間の EtherChannel です。

N5k-1(config-sync-sp)# interface Port-channel100
 

ポート チャネル 200 は、N2k とエンド デバイス間の EtherChannel です。

N5k-1(config-sync-sp)# interface Port-channel200
 

) まずスイッチ プロファイル内にポート チャネル インターフェイスを作成する必要があります。ポート チャネルは、メンバー インターフェイス上で channel-group コマンドを入力することによって暗黙的に作成しないでください。


ステップ 7 スイッチ プロファイル内の設定をコミットします。

N5k-1(config-sync-sp)# commit
 

ステップ 8 設定端末モードで、両方のスイッチのポート チャネルにメンバーを追加します。


) この設定は設定端末モードで行われるため、両方のスイッチで別個に設定する必要があります。


N5k-1 の Ethernet1/1 は、ポート チャネル 100 に属する FEX ファブリック メンバーです。

N5k-1(config)# int ether1/1
N5k-1(config-if)# channel-group 100 force
 

N5k-1 の Ethernet1/100/2-3 は、ポート チャネル 200 のメンバーです。

N5k-1(config)# interface Ethernet100/1/2-3
N5k-1(config-if-range)# channel-group 200 force
 

N5k-2 の Ethernet1/1 は、ポート チャネル 100 に属する FEX ファブリック インターフェイスです。

N5k-2(config)# int ether1/1
N5k-2(config-if)# channel-group 100 force
 

N5k-2 の Ethernet1/100/2-3 は、ポート チャネル 200 のメンバーです。

N5k-2(config)# interface Ethernet100/1/2-3
N5k-2(config-if-range)# channel-group 200 force
 

) Cisco NX-OS Release 5.0(2)N2(1) では、イーサネット インターフェイス上で channel-group 200 force コマンドを使用しないと、オフラインの事前プロビジョニングされたインターフェイス上で問題が発生します。たとえば、モジュール 100 がオフラインである場合は、channel-group コマンドに加えて、ステップ 8 の PO 200 の設定がメンバー インターフェイス上で明確に定義されている必要があります。channel-group 200 force コマンドは、Cisco NX-OS Release 5.0(2)N1(1) 以前のリリースではサポートされません。


N5k-1(config)# interface Ethernet100/1/2-3
N5k-1(config-if-range)# switchport mode trunk
N5k-1(config-if-range)# switchport trunk allowed vlan 1-5
 
N5k-2(config)# interface Ethernet100/1/2-3
N5k-2(config-if-range)# switchport mode trunk
N5k-2(config-if-range)# switchport trunk allowed vlan 1-5
 

ステップ 9 スイッチ プロファイル内のポート チャネル設定を変更します。

N5k-1(config-sync-sp-if)# interface Port-Channel100
N5k-1(config-sync-sp-if)# switchport mode fex-fabric
N5k-1(config-sync-sp-if)# fex associate 100
N5k-1(config-sync-sp-if)# vpc 100
 
N5k-1(config-sync-sp)# interface Port-channel200
N5k-1(config-sync-sp-if)# inherit port-profile pc-profile
N5k-1(config-sync-sp-if)# switchport trunk allowed vlan 1-5
 

ステップ 10 スイッチ プロファイル内の設定をコミットします。

N5k-1(config-sync-sp)# commit
 

Active/Active FEX トポロジを使用した既存の展開

既存の展開では、設定がすでに存在するため、設定の同期は将来の設定変更を簡素化するために使用されます。

図 2-3 に示す vPC トポロジのピア スイッチを設定するには、次の手順を実行します。


ステップ 1 両方のスイッチで CFSoIP をイネーブルにします。

N5k-1# config t
N5k-1(config)# cfs ipv4 distribute
 
N5k-2# config t
N5k-2(config)# cfs ipv4 distribute
 

ステップ 2 両方のスイッチでスイッチ プロファイルを作成します。

N5k-1# config sync
N5k-1(config-sync)# switch-profile Test
 
N5k-2# config sync
N5k-2(config-sync)# switch-profile Test
 

ステップ 3 両方のスイッチで FEX を事前プロビジョニングします。


) FEX A/A トポロジでは、必ずスイッチ プロファイル内でデュアルホーム接続された FEX を事前プロビジョニングしてください。これにより、FEX が Cisco Nexus 5000 シリーズ スイッチに接続されていない場合の設定の同期が容易になります。


N5k-1(config-sync-sp)# slot 100
N5k-1(config-sync-sp-slot)# provision model N2k-C2232P
N5k-1(config-sync-sp-slot)# exit
 
N5k-2(config-sync-sp)# slot 100
N5k-2(config-sync-sp-slot)# provision model N2k-C2232P
N5k-2(config-sync-sp-slot)# exit
 

ステップ 4 両方のスイッチで、スイッチ プロファイル内の設定をコミットします。

N5k-1(config-sync-sp)# commit
 
N5k-2(config-sync-sp)# commit
 

ステップ 5 両方のスイッチで、設定をスイッチ プロファイルにインポートします。次の 3 つの方法のいずれかを使用して設定をインポートできます。

実行コンフィギュレーション:スイッチ プロファイル内で許可されるすべての設定がインポートされます。不要な設定を削除する必要があります。たとえば、ポート チャネル メンバー設定は削除する必要があります。

インターフェイス設定:指定したインターフェイス設定だけがインポートされます。

手動モード:選択した設定がインポートされます。インポートする必要がある設定が小規模である場合は、手動モードを使用して目的の設定を貼り付けます。

次に、実行コンフィギュレーションをインポートする例を示します。

N5k-1(config-sync-sp)# import running-config
N5k-1(config-sync-sp-import)# show switch-profile Test buffer
 
シーケンス番号
コマンド
1
vlan 1-10
2
2.1
2.2
2.3
interface port-channel100
switchport mode fex-fabric
vpc 100
fex associate 100
3
3.1
3.2
interface port-channel200
switchport mode trunk
switchport trunk allowed vlan 1-5
4
4.1
4.2
4.3
interface Ethernet1/1
fex associate 100
switchport mode fex-fabric
channel-group 100
5
5.1
5.2
interface Ethernet100/1/1
switchport mode trunk
switchport trunk allowed vlan 1-10
6
6.1
6.2
6.3
interface Ethernet100/1/2
switchport mode trunk
switchport trunk allowed vlan 1-5
channel-group 200
7
7.1
7.2
7.3
interface Ethernet100/1/3
switchport mode trunk
switchport trunk allowed vlan 1-5
channel-group 200

メンバー インターフェイス PO 100 および PO 200 は、バッファから削除する必要があります。

N5k-1(config-sync-sp-import)# buffer-delete 4, 6, 7
 

不要な設定をバッファから削除するには、 buffer-delete コマンドを使用します。

ステップ 6 両方のスイッチで、スイッチ プロファイル内の設定をコミットします。

N5k-1(config-sync-sp-import)# commit
 
N5k-2(config-sync-sp-import)# commit
 

ステップ 7 両方のスイッチで同期ピアを追加します。


) 設定をインポートする場合は、両側のスイッチで設定を個別にインポートしてから、sync-peers コマンドを使用する必要があります。


N5k-1# config sync
N5k-1(config-sync)# switch-profile sp
N5k-1(config-sync-sp)# sync-peers destination <out of band mgmt0 IP address of peer switch N5k-2>
 
N5k-2# config sync
N5k-2(config-sync)# switch-profile sp
N5k-2(config-sync-sp)# sync-peers destination <out of band mgmt0 IP address of peer switch N5k-1>
 

注意 no switch-profile name [all-config | local-config] コマンドを使用してスイッチ プロファイルを削除すると、ただちにスイッチ プロファイル内の設定が実行コンフィギュレーションから削除されます。これにより、スイッチ プロファイル内に存在していた設定(たとえば、ポート チャネル設定や vPC 設定など)に混乱が生じます。この問題に関する最新情報については、『Cisco Nexus 5000 Series Switch and Cisco Nexus 2000 Series Fabric Extender Release Notes』および次の URL にある『Cisco Bug Toolkit』の「CSCtl87240」および「CSCtl87260」を参照してください。http://tools.cisco.com/Support/BugToolKit/action.do?hdnAction=searchBugs

スイッチ vPC トポロジと Straight-Through FEX トポロジ(ホスト vPC)

図 2-4 に示す vPC トポロジでは、Cisco Nexus 5000 シリーズ スイッチ ポートは別のスイッチまたはホストに接続されており、vPC の一部となるポート チャネルの一部として設定されています。

図 2-4 は、N5k-1 上に Eth1/10 および N5K-2 上に Eth2/1 をメンバーとして持つポート チャネル 20 上に vPC 20 が設定されていることを示します。

図 2-4 スイッチ vPC トポロジ

 

図 2-5 に示すホスト vPC トポロジでは、各 EFX は Cisco Nexus 5000 シリーズ スイッチにシングルホーム接続(Straight-Through FEX トポロジ)されています。この FEX 上のホスト インターフェイスはポート チャネルとして設定され、それらのポート チャネルは vPC として設定されています。

N5K-1 上の Eth100/1/1 および N5K-2 上の Eth102/1/5 は PO200 のメンバーとして設定され、PO200 は vPC 200 用に設定されています。

図 2-5 FEX Straight-Through トポロジ(ホスト vPC)

 

どちらのトポロジでも、ポート チャネル P020 および P0200 をピア スイッチ上でまったく同じように設定する必要があります。その後、設定の同期を使用して vPC スイッチの設定を同期します。

例 2-3 は、図 2-4 および図 2-5 の vPC トポロジに示すピア スイッチ用に設定する必要がある実行コンフィギュレーションの例を示します。

例 2-3 vPC Straight-Through トポロジでの Nexus 5000 シリーズ スイッチの実行コンフィギュレーションの例

基本設定:ポート プロファイルなし
ポート プロファイル設定
vlan 1-10
 
interface port-channel 20
switchport mode trunk
vpc 20
switchport trunk allowed vlan 1-5
 
interface port-channel 200
switchport mode trunk
vpc 200
switchport trunk allowed vlan 1-5
 
interface Ethernet1/10
switchport mode trunk
switchport trunk allowed vlan 1-5
channel-group 20
 
interface Ethernet100/1/1
switchport mode trunk
switchport trunk allowed vlan 1-5
channel-group 200
vlan 1-10
 
port-profile type port-channel pc-profile
switchport mode trunk
state enabled
 
interface port-channel 20
inherit port-profile pc-profile
vpc 20
switchport trunk allowed vlan 1-5
 
interface port-channel 200
inherit port-profile pc-profile
vpc 200
switchport trunk allowed vlan 1-5
 
interface Ethernet1/10
switchport mode trunk
switchport trunk allowed vlan 1-5
channel-group 20
 
interface Ethernet100/1/1
switchport mode trunk
switchport trunk allowed vlan 1-5
channel-group 200
 

vPC トポロジおよび Straight-Through FEX トポロジでの新しい展開

新しい展開では、新しい設定を同期させるために、最初に設定の同期が導入されます。新しい展開であるため、FEX ポート上には既存の実行コンフィギュレーションは存在しません。


) Straight-Through FEX トポロジでは、設定端末モードを使用して FEX または GEM を事前プロビジョニングする必要があります。


図 2-4 および図 2-5 に示すトポロジのピア スイッチを設定するには、次の手順を実行します。


ステップ 1 設定端末モードで、両方のスイッチの FEX の設定を事前プロビジョニングします。

N5k-1 の slot 100 は、FEX 100 用にプロビジョニングされています。

N5K-1(config)# slot 100
N5K-1(config-slot)# provision model N2K-C2232P
N5K-1(config)# int ether 1/1-2
N5K-1(config-if-range)# channel-group 100
N5K-1(config-if-range)# int po100
N5K-1(config-if)# fex associate 100
N5K-1(config-if)# switchport mode fex-fabric
 

N5k-2 の slot 102 は、FEX 102 用にプロビジョニングされています。

N5K-2(config)# slot 102
N5K-2(config-slot)# provision model N2K-C2232P
N5K-2(config)# int ether 1/1-2
N5K-2(config-if-range)# channel-group 102
N5K-2(config-if-range)# int po102
N5K-2(config-if)# fex associate 102
N5K-2(config-if)# switchport mode fex-fabric
 

N5k-2 の slot 2 は、GEM 用にプロビジョニングされています。

N5K-2(config)# slot 2
N5K-2(config-slot)# provision model N55-M16P
 

ステップ 2 両方のスイッチで CFSoIP をイネーブルにします。

N5k-1# config t
N5k-1(config)# cfs ipv4 distribute
 
N5k-2# config t
N5k-2(config)# cfs ipv4 distribute
 

ステップ 3 両方のスイッチで、スイッチ プロファイルを作成し、ピアを設定します。

N5k-1# config sync
N5k-1(config-sync)# switch-profile Test
N5k-1(config-sync-sp)# sync-peers destination <out of band mgmt0 IP address of peer switch N5k-2>
 
N5k-2# config sync
N5k-2(config-sync)# switch-profile Test
N5k-2(config-sync-sp)# sync-peers destination <out of band mgmt0 IP address of peer switch N5k-1>
 

ステップ 4 参照先のグローバル設定をスイッチ プロファイルに追加します。インターフェイス上の設定が同期されるため、インターフェイス上で適用するすべてのポリシー(ポート プロファイル、QoS、ACL ポリシーなど)を同期させる必要があります。

N5k-1(config-sync-sp)# port-profile type port-channel pc-profile
N5k-1(config-sync-port-prof)# switchport mode trunk
N5k-1(config-sync-port-prof)# state enabled
 

ステップ 5 スイッチ プロファイル内にポート チャネル インターフェイスを作成します。


) スイッチ プロファイル モードで、ポート チャネル インターフェイスを作成します。


N5k-1(config-sync-sp)# interface port-channel 20
N5k-1(config-sync-sp)# interface port-channel 200
 

ステップ 6 スイッチ プロファイル内の設定をコミットします。

N5k-1(config-sync-sp)# commit
 

ステップ 7 設定端末モードで、両方のスイッチのポート チャネルにメンバーを追加します。この設定は設定端末モードで行われるため、両方のスイッチで個別に設定する必要があります。


) このトポロジでは、ピア スイッチのポート チャネル メンバーが同じであってはなりません。Cisco NX-OS Release 5.0(2)N1(1) の場合、ポート チャネル メンバーは、スイッチ プロファイル内ではなく、常に設定端末モードで設定する必要があります。


N5k-1(config)# interface Ethernet1/10
N5k-1(config-if)# channel-group 20 force
N5k-1(config)# interface Ethernet100/1/1
N5k-1(config-if)# channel-group 200 force
 
N5k-2(config)# interface Ethernet2/1
N5k-2(config-if)# channel-group 20 force
N5k-2(config)# interface Ethernet102/1/5
N5k-2(config-if)# channel-group 200 force
 

) Cisco NX-OS Release 5.0(2)N2(1) では、イーサネット インターフェイス上で channel-group 200 force コマンドを使用しないと、オフラインの事前プロビジョニングされたインターフェイス上で問題が発生します。たとえば、モジュール 100 がオフラインである場合は、ステップ 7 の P0200 の設定がメンバー インターフェイス上で明確に設定されている必要があります。channel-group 200 force コマンドは、Cisco NX-OS Release 5.0(2)N1(1) 以前のリリースではサポートされません。


N5k-1(config)# interface Ethernet100/1/1
N5k-1(config-if)# switchport mode trunk
N5k-1(config-if)# switchport trunk allowed vlan 1-5
 
N5k-2(config)# interface Ethernet2/1
N5k-2(config-if)# switchport mode trunk
N5k-2(config-if)# switchport trunk allowed vlan 1-5
 
N5k-2(config)# interface Ethernet102/1/5
N5k-2(config-if)# switchport mode trunk
N5k-2(config-if)# switchport trunk allowed vlan 1-5
 

) Ethernet 1/10 は、事前プロビジョニングされていない(オフライン インターフェイスである)ため、リストに含まれません。


ステップ 8 スイッチ プロファイル内のポート チャネル設定を変更します。

N5k-1(config-sync-sp)# interface port-channel 20
N5k-1(config-sync-sp-if)# inherit port-profile pc-profile
N5k-1(config-sync-sp-if)# vpc 20
N5k-1(config-sync-sp-if)# switchport trunk allowed vlan 1-5
N5k-1(config-sync-sp)# interface port-channel 200
N5k-1(config-sync-sp-if)# inherit port-profile pc-profile
N5k-1(config-sync-sp-if)# vpc 200
N5k-1(config-sync-sp-if)# switchport trunk allowed vlan 1-5
 

ステップ 9 スイッチ プロファイル内の設定をコミットします。

N5k-1(config-sync-sp)# commit
 

vPC トポロジおよび Straight-Through FEX トポロジでの既存の展開

既存の展開では、設定がすでに存在するため、設定の同期は将来の設定変更を簡素化するために使用されます。


) Straight-Through FEX トポロジでは、設定端末モードを使用して FEX および GEM を事前プロビジョニングします。


図 2-4 および図 2-5 に示すトポロジのピア スイッチを設定するには、次の手順を実行します。


ステップ 1 設定端末モードで、両方のスイッチの FEX を事前プロビジョニングします。

N5K-1(config)# slot 100
 
N5K-2(config)# slot 102
 

ステップ 2 両方のスイッチで CFSoIP をイネーブルにします。

N5k-1# config t
N5k-1(config)# cfs ipv4 distribute
 
N5k-2# config t
N5k-2(config)# cfs ipv4 distribute
 

ステップ 3 両方のスイッチでスイッチ プロファイルを作成します。

N5k-1# config sync
N5k-1(config-sync)# switch-profile Test
 
N5k-2# config sync
N5k-2(config-sync)# switch-profile Test
 

ステップ 4 両方のスイッチで、設定をスイッチ プロファイルにインポートします。次の 3 つの方法のいずれかを使用して設定をインポートできます。

実行コンフィギュレーション:スイッチ プロファイル内で許可されるすべての設定がインポートされます。不要な設定を削除する必要があります。たとえば、ポート チャネル メンバー設定は削除する必要があります。

インターフェイス設定:指定したインターフェイス設定だけがインポートされます。

手動モード:選択した設定がインポートされます。インポートする必要がある設定が小規模である場合は、手動モードを使用して目的の設定を貼り付けます。

次に、実行コンフィギュレーションをインポートする例を示します。

N5k-1(config-sync-sp)# import running-config
N5k-1(config-sync-sp-import)# show switch-profile Test buffer
 
シーケンス番号
コマンド
1
vlan 1-10
2
2.1
2.2
2.3
interface port-channel20
switchport mode trunk
vpc 20
switchport trunk allowed vlan 1-5
3
3.1
3.2
interface port-channel100
switchport mode fex-fabric
fex associate 100
3
3.1
3.2
interface port-channel200
switchport mode trunk
vpc 200
switchport trunk allowed vlan 1-5
4
4.1
4.2
4.3
interface port-channel20
switchport mode trunk
vpc 20
switchport trunk allowed vlan 1-5
5
5.1
5.2
5.3
interface Ethernet1/1
fex associate 100
switchport mode fex-fabric
channel-group 100
6
6.1
6.2
6.3
interface Ethernet1/2
fex associate 100
switchport mode fex-fabric
channel-group 100
7
7.1
7.2
7.3
interface Ethernet1/10
switchport mode trunk
switchport trunk allowed vlan 1-5
channel-group 20
8
8.1
8.2
8.3
interface Ethernet100/1/1
switchport mode trunk
switchport trunk allowed vlan 1-5
channel-group 200
N5k-2(config-sync-sp)# import running-config
 

ファブリック設定を同期させない場合は、ファブリック設定とメンバー インターフェイス PO 20 および PO 200 をバッファから削除します。

N5k-1(config-sync-sp-import)# buffer-delete 3,5,6-8
 

buffer-delete コマンドを使用すると、不要な設定がバッファから削除されます。

ステップ 5 両方のスイッチで、スイッチ プロファイル内の設定をコミットします。

N5k-1(config-sync-sp-import)# commit
 
N5k-2(config-sync-sp-import)# commit
 

ステップ 6 両方のスイッチで同期ピアを追加します。


) 設定をインポートする場合は、両側のスイッチの設定を個別にインポートしてから、sync-peers コマンドを使用します。


N5k-1# config sync
N5k-1(config-sync)# switch-profile Test
N5k-1(config-sync-sp)# sync-peers destination <out of band mgmt0 IP address of peer switch N5k-2>
 
N5k-2# config sync
N5k-2(config-sync)# switch-profile Test
N5k-2(config-sync-sp)# sync-peers destination <out of band mgmt0 IP address of peer switch N5k-1>
 

注意 no switch-profile name [all-config | local-config] コマンドを使用してスイッチ プロファイルを削除すると、ただちにスイッチ プロファイル内の設定が実行コンフィギュレーションから削除されます。これにより、スイッチ プロファイル内に存在していた設定(たとえば、ポート チャネル設定や vPC 設定など)に混乱が生じます。この問題に関する最新情報については、『Cisco Nexus 5000 Series Switch and Cisco Nexus 2000 Series Fabric Extender Release Notes』および次の URL にある『Cisco Bug Toolkit』の「CSCtl87240」および「CSCtl87260」を参照してください。http://tools.cisco.com/Support/BugToolKit/action.do?hdnAction=searchBugs

新しい Cisco 2000 シリーズ Fabric Extender の設置

事前プロビジョニング機能により、Cisco Nexus 5000 シリーズ スイッチに接続される前に FEX を完全に設定できます。


ステップ 1 FEX モデルでスロットを事前プロビジョニングします。

ステップ 2 まるで FEX が接続されているかのように、インターフェイスを設定します。

ステップ 3 FEX を接続して、オンラインになるのを待ちます。

ステップ 4 すべての設定が正しく適用されたことを確認します。


) FEX がオンラインになると、すべての設定がベスト エフォート方式で連続的に適用されます。


Cisco Nexus 5000 シリーズ スイッチのリロード

この展開では、N5k-2 がリブートし、スイッチ プロファイルを使用して N5k-1 上で新しい設定がコミットされます。

次の例は、N5k-2 のリロード前にピア間で同期された設定を示します。

例 2-4 N5k-2 のリロード前に同期されたピア スイッチの設定

N5k-1 の実行コンフィギュレーション
N5k-2 の実行コンフィギュレーション
interface Ethernet100/1/11
switchport mode trunk
interface Ethernet100/1/11
switchport mode trunk

次の例は、N5k-2 のリロード中に N5k-1 上で行われた設定変更を示します。


) コミットが(たとえば、N5k-1 スイッチ上で)発行された時点でピアに到達できない場合、その設定はローカルに適用されます。


N5K-1(config-sync)# switch-profile Test
Switch-Profile started, Profile ID is 1
N5K-1(config-sync-sp)# int ether 100/1/11
N5K-1(config-sync-sp-if)# switchport trunk allowed vlan 5,6
N5K-1(config-sync-sp)# commit
 
Verification successful...
Proceeding to apply configuration. This might take a while depending on
amount of configuration in buffer.
Please avoid other configuration changes during this time.
Commit Successful
 
N5K-1(config-sync)# show run int ether 100/1/11
 
interface Ethernet100/1/11
switchport mode trunk
switchport trunk allowed vlan 5-6
 

次に、vPC 整合性パラメータを表示する例を示します。

N5K-1(config-sync)# switch-profile Test
Switch-Profile started, Profile ID is 1
N5K-1(config-sync-sp)# int ether 100/1/11
N5K-1# show vpc consistency-parameters int ether 100/1/11
 
Legend:
Type 1 : vPC will be suspended in case of mismatch
 
 
Name Type Local Value Peer Value
------------- ---- ---------------------- -----------------------
Allowed VLANs - 5-6 1-3967,4048-4093
Local suspended VLANs - - -
 

スイッチのリロード後のピア スイッチの同期

次に、いずれかのピア スイッチのリロード後に、ピア スイッチ上で設定を同期させる例を示します。


ステップ 1 N5k-1 上で変更した設定を再適用します。

N5K-2(config-sync)# switch-profile Test
N5K-2(config-sync-sp)# interface ethernet100/1/11
N5K-2(config-sync-sp-if)# switchport trunk all vlan 5-6
 

ステップ 2 N5k-2 上で、 commit コマンドを入力します。

N5K-2(config-sync)# switch-profile Test
N5K-2(config-sync-sp)# commit
Verification successful...
Proceeding to apply configuration. This might take a while depending on
amount of configuration in buffer.
Please avoid other configuration changes during this time.
Commit Successful
 

ステップ 3 設定が正しく適用され、ピア上で同期されていることを確認します。

N5K-2#show vpc consistency-parameters int ether 100/1/11
Legend:
Type 1 : vPC will be suspended in case of mismatch
 
Name Type Local Value Peer Value
------------- ---- ---------------------- -----------------------
Allowed VLANs - 5-6 5-6
Local suspended VLANs - - -
 
 
N5K-2# show run int ether 100/1/11
 
!Command: show running-config interface Ethernet100/1/11
 
interface Ethernet100/1/11
switchport mode trunk
switchport trunk allowed vlan 5-6

) FEX がオンラインになると、すべての設定がベスト エフォート方式で連続的に適用されます。


vPC ピア リンクの失敗

ピア リンクに失敗したが、両方のスイッチが動作状態であれば、セカンダリ スイッチはその vPC ポートをシャットダウンします。FEX A/A トポロジの場合、この状況では、セカンダリ スイッチの A/A FEX の接続が解除されます。スイッチ プロファイル設定がプライマリ スイッチ上で変更された場合は、A/A FEX が事前プロビジョニングされていない限り、設定はセカンダリ スイッチ上で受け入れられません。設定の同期機能を使用する際に、すべての A/A FEX を事前プロビジョニングすることを推奨します。


) FEX は、たとえ最初に設定端末モードで設定され、動作状態になっていても、各 FEX がスイッチ プロファイル内でプロビジョニングされ、プロビジョニングされた FEX として認識されていることが重要です。


このトポロジでは、FEX 100 はプロビジョニングされ、FEX 101 はプロビジョニングされていません。また、FEX 100 と 101 の両方はすでに動作状態です。

次の例は、FEX 100(すでに動作状態です)用の実行コンフィギュレーションを示します。

例 2-5 FEX 100 の実行コンフィギュレーション

FEX 100 の実行コンフィギュレーション
fex 100
pinning max-links 1
description “FEX0101”
interface port-channel200
switchport mode fex-fabric
vpc 200
fex associate 100
 
interface Ethernet1/10
description connects to Fex 100
fex associate 100
switchport mode fex-fabric
channel-group 200

次の手順では、スイッチ プロファイル内で FEX 100 をプロビジョニングします。

次に、FEX 100 がプロビジョニングされている場合の実行コンフィギュレーションの例を示します。

例 2-6 プロビジョニングされた FEX 100 の実行コンフィギュレーション

プロビジョニングを使用した FEX 100 の実行コンフィギュレーション
fex 100
pinning max-links 1
description “FEX0101”
 
slot 100
provision model N2K-C2148T
 
interface port-channel200
switchport mode fex-fabric
vpc 200
fex associate 100
 
interface Ethernet1/10
description connects to Fex 100
fex associate 100
switchport mode fex-fabric
channel-group 200

機能している例

次に、FEX をプロビジョニングする例を示します。

N5K-1(config-sync-sp)# slot 100
N5K-1(config-sync-sp-slot)# provision model N2K-C2148T
N5K-1(config-sync-sp-slot)# exit
N5K-1(config-sync-sp)#
N5K-1(config-sync-sp)# commit
 

このシナリオでは、vPC ピア リンクは失敗します。

N5K-1(config-sync-sp)# sh vpc
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
 
vPC domain id : 10
Peer status : peer link is down
vPC keepalive status : peer is alive
 

スイッチ プロファイル内で、Ethernet 100/1/1 の下に設定を追加します。

N5K-1(config-sync)# switch-profile Test
Switch-Profile started, Profile ID is 1
N5K-1(config-sync-sp)# int ether 100/1/1
N5K-1(config-sync-sp-if)# switchport mode trunk
N5K-1(config-sync-sp-if)# commit
Verification successful...
Proceeding to apply configuration. This might take a while depending on
amount of configuration in buffer.
Please avoid other configuration changes during this time.
Commit Successful
 

両方のスイッチが同期されていることを確認します。

N5K-1(config-if)# sh run int ether 100/1/1
interface Ethernet100/1/1
switchport mode trunk
 
N5K-2(config-if)# sh run int ether 100/1/1
interface Ethernet100/1/1
switchport mode trunk
 

機能していない例

例 2-7 は、スイッチ プロファイル内でプロビジョニングされていない FEX 101 の実行コンフィギュレーションを示したものです。

例 2-7 FEX 101 の実行コンフィギュレーション

FEX 101 の実行コンフィギュレーション
fex 101
pinning max-links 1
description “FEX0101”
 
interface port-channel201
switchport mode fex-fabric
vpc 201
fex associate 101
 
interface Ethernet1/11
description connects to Fex 101
fex associate 101
switchport mode fex-fabric
channel-group 201

 

この例では、vPC ピア リンクは失敗します。

N5K-1(config-sync-sp)# sh vpc
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
 
vPC domain id : 10
Peer status : peer link is down
vPC keepalive status : peer is alive
 

次に、スイッチ プロファイル内で FEX 101 がプロビジョニングされていないために、N5k-1 上で Ethernet 101/1/1 に対して行われた設定変更が失敗する例を示します。

N5K-1(config-sync)# switch-profile Test
Switch-Profile started, Profile ID is 1
N5K-1(config-sync-sp)# int ethernet 101/1/1
N5K-1(config-sync-sp-if)# switchport mode trunk
N5K-1(config-sync-sp-if)# commit
Verification successful...
Failed to Commit: Commit Failed
 

次に、スイッチ プロファイル内で FEX 101 をプロビジョニングすることによって問題を解決する例を示します。スイッチ プロファイル内で FEX 101 がプロビジョニングされていない場合は、両方のスイッチで手動で設定変更を行う必要があります。

N5K-1(config-sync)# switch-profile Test
Switch-Profile started, Profile ID is 1
N5K-1(config-sync-sp)# slot 101
N5K-1(config-sync-sp-slot)# provision model N2K-C2148T
N5K-1(config-sync-sp-slot)# commit
 

もう一度、同じ設定変更を行います。

N5K-1(config-sync)# switch-profile Test
Switch-Profile started, Profile ID is 1
N5K-1(config-sync-sp)# int ether 101/1/1
N5K-1(config-sync-sp-if)# switchport mode trunk
N5K-1(config-sync-sp-if)# commit
 
Verification successful...
Proceeding to apply configuration. This might take a while depending on
amount of configuration in buffer.
Please avoid other configuration changes during this time.
Commit Successful
 
!Command: show running-config interface Ethernet101/1/1
 
interface Ethernet101/1/1
switchport mode trunk
 
!Command: show running-config interface Ethernet101/1/1
!Time: Tue Oct 19 01:18:14 2010
 
version 5.0(2)N1(1)
 
interface Ethernet101/1/1
switchport mode trunk
speed 1000
 

mgmt0 インターフェイスの接続が失われた場合

設定の同期では、スイッチ プロファイルの設定は、mgmt0 インターフェイスを介してピア スイッチに送信されます。mgmt0 インターフェイスの接続が失われたために設定を変更する必要がある場合は、両方のスイッチでスイッチ プロファイルを変更します。mgmt0 インターフェイスが復元されると、両方のスイッチが同期状態になります。


) mgmt0 インターフェイスがダウンしたために設定を変更する場合は、各スイッチに適用される設定を同じにする必要があります。設定が同じでない場合は、mgmt0 インターフェイスが起動し、いずれかのスイッチでコミットが発行されると、そのコミットは失敗します。これは、設定が一致していないために起こります。


mgmt0 インターフェイスの稼動中にコミットが発行されてから mgmt0 インターフェイスがダウンすると、両方のスイッチで mgmt0 インターフェイスからピア スイッチに到達できないことが検出された時点で、そのコミットは最終的に失敗します。

条件機能によるロールバックの失敗

設定の同期では、チェックポイントには条件機能が存在するが実行コンフィギュレーションには存在しない場合に、そのチェックポイントへのロールバックが失敗します。これを回避するには、ロールバックが実行される前に条件機能を再設定します。この回避策は、vpc-domain モードでの vpc domain コマンドおよび peer-keepalive コマンドに適用されます。

次に、 chkpt という名前のチェックポイントが作成されているときのシステムの実行コンフィギュレーションの例を示します。

feature vpc
 
vpc domain 100
vpc peer-keepalive destination 10.0.0.1
 
interface Ethernet 1/1
switchport mode trunk
channel-group 100
 
switch-profile Test
interface port-channel 100
switchport mode trunk
vpc peer-link
 

このポイントで書き込み消去を実行し、スイッチをリロードしてチェックポイント「chkpt」へのロールバックを実行しようとすると、そのロールバックは失敗します。次に、この状況が発生したときのロールバックの失敗の例を示します。


) ロールバックの失敗を回避するには、feature vpcvpc domain、および peer-keepalive を事前に設定してからロールバックを実行します。


N5k-1# rollback running-config checkpoint chkpt verbose
 

) 設定を同時に適用すると、ロールバックの確認に失敗する可能性があります。


Collecting Running-Config
Generating Rollback patch for switch profile
Executing Rollback patch for switch profiles. WARNING - This will change the configuration of switch profiles and will also affect any peers if configured
========================================================
`config sync `
`switch-profile Test`
Switch-Profile started, Profile ID is 1
`interface port-channel100`
`switchport mode trunk`
Syntax error while parsing 'vpc peer-link'
 
========================================================
Generating Running-config for verification
 
Verification failed, rolling back to previous configuration
Collecting Running-Config
2010 Oct 14 07:43:12 switch %$ VDC-1 %$ %ASCII-CFG-2-ACFG_OPER_FAIL: Operation failed because of Rollback Patch is not Empty
...
 

チャネル グループの失敗

ポート チャネルが存在しない場合(自動作成がサポートされていない場合)、ポート プロファイルまたは事前プロビジョニングされたインターフェイスに対する channel-group コマンドは失敗します。これを回避するには、最初に interface port-channel xxx コマンドを使用して明示的にポート チャネルを作成します。


) ポート チャネル メンバーは、設定端末モードで設定する必要があります。


機能していない例

次に、ポート チャネル インターフェイスを最初に作成していない場合に表示されるエラー メッセージの例を示します。

N5K-1(config-if-range)# int ether 100/1/2-3
N5K-1(config-if-range)# channel-group 200
Pre-provisioned interface: port channel must exist first
 

設定変更をポート チャネル上で行ったが、事前プロビジョニングされたインターフェイス上で行っていない場合、モジュールがオンラインになったときに channel-group コマンドが失敗します。この失敗は、 channel-group xxx force コマンドをサポートしている Cisco NX-OS Release 5.0(2)N2(1) では発生しません。

At-A-Glance コンフィギュレーション モード

表 2-1 は、A/A トポロジまたは Straight-Through トポロジの機能とインターフェイス、および vPC トポロジのスイッチとホストを設定するために使用されるモードを示したものです。

たとえば、A/A トポロジのポート チャネル インターフェイスを設定するには、スイッチ プロファイル コンフィギュレーション モードを使用します。

表 2-1 At-A-Glance トポロジ コンフィギュレーション モード

設定
FEX A/A トポロジ
Straight-Through トポロジ
スイッチ/ホスト vPC トポロジ

非ポート チャネル メンバー

スイッチ プロファイル モード

スイッチ プロファイル モード

スイッチ プロファイル モード

ポート チャネル インターフェイス(interface port channel コマンド)

スイッチ プロファイル モード

スイッチ プロファイル モード

スイッチ プロファイル モード

ポート チャネル メンバー インターフェイス

設定端末モード

設定端末モード

設定端末モード

FEX/GEM 事前プロビジョニング

スイッチ プロファイル モード

設定端末モード

設定端末モード

グローバル設定(ポート プロファイル、QoS、ACL など)

スイッチ プロファイル モード

スイッチ プロファイル モード

スイッチ プロファイル モード

用語

ポート チャネル インターフェイス:ポート チャネルの一部であるインターフェイス。

非ポート チャネル メンバー:ポート チャネルの一部ではないスタンドアロン インターフェイス。

ポート チャネル メンバー:ポート チャネルのメンバーであるインターフェイス。

スイッチ プロファイル:ピア スイッチ間で整合性のある設定を実現するために使用される定義済みの同期設定プロファイル。スイッチ プロファイルは、設定の同期機能で使用されます。

ポート プロファイル:さまざまなインターフェイス(イーサネット、VLAN ネットワーク インターフェイス、ポート チャネルなど)に適用できるインターフェイス コマンド プロファイル。

設定の同期:スイッチ プロファイルを使用して、2 つのピア スイッチ間で整合性のある設定を実現するための同期機能。

config-sync モード:スイッチ プロファイルを定義し、そのスイッチ プロファイルにアクセスするために使用されるコンフィギュレーション モード。

設定端末モード(config-t):スイッチ上で設定をローカルにコミットするために使用されるコンフィギュレーション モード。

事前プロビジョニング:接続される(またはオンラインになる)前にオフライン インターフェイスを設定できるようにするための事前プロビジョニング。事前プロビジョニングは、Nexus 2000 Fabric Extenders(FEX)/GEM モジュール、AKA 拡張モジュールで実行できます。