Cisco Nexus 5000 シリーズ NX-OS ユニキャスト ルーティング コマンド リファレンス
R コマンド
R コマンド
発行日;2013/04/23 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

R コマンド

redistribute(RIP)

restart(RIP)

router rip

R コマンド

この章では、R で始まる Cisco NX-OS Routing Information Protocol(RIP)コマンドについて説明します。

redistribute(RIP)

別のルーティング ドメインからのルートを Routing Information Protocol(RIP)に再配布するには、 redistribute コマンドを使用します。ルートの再配布をしないデフォルトの状態にシステムを戻すには、このコマンドの no 形式を使用します。

redistribute { bgp id | direct | eigrp id | ospf id | static } route-map map-name

 
構文の説明

bgp id

ボーダー ゲートウェイ プロトコル(BGP)からのルートを再配布します。id は、自律システム番号です。2 バイト番号の範囲は 1 ~ 65535 です。4 バイト番号の範囲は 1.0 ~ 65535.65535 です。

direct

直接接続されたルートだけからのルートを再配布します。

eigrp id

Enhanced GRP(EIGRP)からのルートを再配布します。id は、ルートが再配布される EIGRP インスタンス名です。値は文字列の形式を取ります。10 進数を入力できますが、Cisco NX-OS はこれを文字列として内部に保存します。

ospf id

OSPF プロトコルからのルートを再配布します。id は、ルートが再配布される OSPF インスタンス名です。値は文字列の形式を取ります。10 進数を入力できますが、ストリングとして内部に格納されます。

static

IP スタティック ルートからのルートを再配布します。

route-map map-name

ルート マップを関連付けて RIP の再配布ポリシーを設定します。

 
コマンド デフォルト

ルートの再配布はディセーブルです。

 
コマンド モード

ルータ アドレス ファミリ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

Cisco NX-OS は、ルート マップを使用して再配布のルーティング情報をフィルタリングします。ルート マップには再配布ルートに使用される RIP メトリックを設定できます。RIP メトリックをルート マップで指定しなかった場合、Cisco NX-OS は再配布されるプロトコルまたは default-metric コマンドに基づいてメトリックを決定します。有効なメトリックを決定できない場合、Cisco NX-OS はルートを再配布しません。

次に、BGP ルートを RIP プロセスに再配布する例を示します。

switch(config)# router rip Enterprise
switch(config-router)# address-family ipv4 unicast
switch(config-router-af)# redistribute bgp 64496
switch(config-router-af)#
 

 
関連コマンド

コマンド
説明

address-family

アドレスファミリ コンフィギュレーション モードに入ります。

default-information originate

RIP に再配布されるルートのデフォルト ルートを生成します。

default-metric

他のプロトコルから RIP に再配布されるルートのデフォルト メトリック値を設定します。

show ip rip

すべての RIP インスタンスの RIP 要約情報を表示します。

restart(RIP)

Routing Information Protocol(RIP)インスタンスを再起動し、関連付けられたすべてのネイバーを削除するには、 restart コマンドを使用します。

restart eigrp instance-tag

 
構文の説明

instance-tag

RIP ルーティング インスタンスの名前。この名前には、最大 20 文字の英数字を指定できます。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、LAN Base Services ライセンスが必要です。

次に、RIP インスタンスを再起動し、すべてのネイバーを削除する例を示します。

switch(config)# restart rip Enterprise
switch(config)#
 

 
関連コマンド

コマンド
説明

copy running-config startup-config

コンフィギュレーションをスタートアップ コンフィギュレーション ファイルに保存します。

show ip eigrp interfaces

EIGRP インターフェイスに関する情報を表示します。

router rip

Routing Information Protocol(RIP)ルーティング プロセスを設定するには、 router rip コマンドを使用します。RIP ルーティング プロセスをオフにするには、このコマンドの no 形式を使用します。

router rip instance-tag

no router rip

 
構文の説明

instance-tag

この RIP インスタンスの名前

 
コマンド デフォルト

RIP ルーティング プロセスは定義されていません。

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが追加されました。

次に、RIP ルーティング プロセスを開始する例を示します。

switch(config)# router rip Enterprise
 

 
関連コマンド

コマンド
説明

ip router rip

インターフェイスの RIP インスタンスを定義します。