Cisco Nexus 5000 シリーズ NX-OS ユニキャスト ルーティング コマンド リファレンス
A コマンド
A コマンド
発行日;2013/04/23 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

A コマンド

address-family(OSPFv3)

area authentication(OSPF)

area default-cost(OSPF)

area default-cost(OSPFv3)

area filter-list(OSPF)

area filter-list(OSPFv3)

area nssa(OSPF)

area nssa(OSPFv3)

area range(OSPF)

area range(OSPFv3)

area stub(OSPF)

area stub(OSPFv3)

area virtual-link(OSPF)

area virtual-link(OSPFv3)

authentication(OSPF 仮想リンク)

authentication-key(OSPF 仮想リンク)

auto-cost(OSPF)

auto-cost(OSPFv3)

A コマンド

この章では、A で始まる Cisco NX-OS Open Shortest Path First(OSPF)コマンドについて説明します。

address-family(OSPFv3)

Open Shortest Path First バージョン 3(OSPFv3)プロトコルでアドレス ファミリ モードを開始するには、 address-family コマンドを使用します。

address-family ipv6 unicast

 
構文の説明

ipv6

IPv6 アドレス ファミリを指定します。

unicast

ユニキャスト アドレス サポートを指定します。

 
コマンド デフォルト

このコマンドには、デフォルト設定がありません。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドには、Enterprise Services ライセンスが必要です。

次に、OSPFv3v3 インスタンスで IPv6 ユニキャスト アドレス ファミリを開始する例を示します。

switch(config)# router ospfv3v3 Enterprise
switch(config-router)# address-family ipv6 unicast
switch(config-router-af)#
 

 
関連コマンド

コマンド
説明

default-information(OSPFv3)

デフォルト ルートの配布を制御します。

default-metric(OSPFv3)

OSPFv3 に再配布されたルートにデフォルト メトリックを設定します。

distance(OSPFv3)

アドミニストレーティブ ディスタンスを設定します。

maximum-paths(OSPFv3)

等コスト パスの最大数を設定します。

redistribute(OSPFv3)

OSPFv3 に経路再配布を設定します。

timers(OSPFv3)

OSPFv3 タイマーを設定します。

area authentication(OSPF)

OSPF エリアの認証をイネーブルにするには、 area authentication コマンドを使用します。エリアの認証を削除するには、このコマンドの no 形式を使用します。

area area-id authentication [ message-digest ]

no area area-id authentication [ message-digest ]

 
構文の説明

area-id

認証をイネーブルにする OSPF エリアの識別子。正の整数値または IP アドレスを指定します。

message-digest

(任意) area-id 引数によって指定されたエリアで Message Digest 5(MD5)認証をイネーブルにします。

 
コマンド デフォルト

認証なし

 
コマンド モード

ルータ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

area authentication コマンドを使用し、OSPF エリア全体に認証モードを設定します。

認証タイプと認証パスワードは、エリア内のすべての OSPF デバイスで同じである必要があります。インターフェイス コンフィギュレーション モードで ip ospf authentication-key コマンドを使用し、このパスワードを指定します。

message-digest キーワードで MD5 認証をイネーブルにする場合、インターフェイス コンフィギュレーション モードで ip ospf message-digest-key コマンドを使用して、パスワードを設定する必要があります。

このコマンドには、LAN Base Services ライセンスが必要です。

次に、OSPF ルーティング プロセス 201 のエリア 0 に認証を設定する例を示します。

switch(config)# router ospf 201
switch(config-router)# area 0 authentication message-digest
switch(config-router)# interface ethernet 1/1
switch(config-if)# no switchport
switch(config-if)# ip ospf area 0
switch(config)-if# ip ospf message-digest-key 10 md5 0 adcdefgh
 

 
関連コマンド

コマンド
説明

copy running-config startup-config

コンフィギュレーションの変更をスタートアップ コンフィギュレーション ファイルに保存します。

ip ospf authentication-key

OSPF の簡易パスワード認証にパスワードを割り当てます。

ip ospf message-digest-key

OSPF MD5 認証にパスワードを割り当てます。

show ip ospf interface

OSPF インターフェイス関連の情報を表示します。

area default-cost(OSPF)

OSPF スタブまたは Not-So-Stubby Area(NSSA)に送信されるデフォルト サマリー ルートのコストを指定するには、 area default-cost コマンドを使用します。割り当てられたデフォルト ルートのコストを削除するには、このコマンドの no 形式を使用します。

area area-id default-cost cost

no area area-id default-cost cost

 
構文の説明

area-id

デフォルト コストを設定したい OSPF エリアの識別情報。エリア ID には 0 ~ 4294967295 か、または IP アドレスを指定できます。

cost

スタブまたは NSSA で使用されるデフォルト サマリー ルートのコスト。指定できる範囲は 0 ~ 16777215 です。

 
コマンド デフォルト

サマリー ルートのコストは、サマリー ルートを生成した Area Border Router(ABR; エリア ボーダー ルータ)に基づいています。

 
コマンド モード

ルータ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

スタブまたは NSSA に接続されている ABR で area default-cost コマンドを使用し、ABR によってスタブ エリアに生成されるサマリー デフォルト ルートにメトリックを設定します。

このコマンドには、LAN Base Services ライセンスが必要です。

次に、スタブ ネットワーク 192.0.2.0 に 20 のデフォルト コストを設定する例を示します。

switch(config)# router ospf 201
switch(config-router)# area 192.0.2.0 stub
switch(config-router)# area 192.0.2.0 default-cost 20
switch(config-router)#
 

 
関連コマンド

コマンド
説明

area stub

エリアをスタブ エリアとして定義します。

copy running-config startup-config

コンフィギュレーションの変更をスタートアップ コンフィギュレーション ファイルに保存します。

show ip ospf

OSPF 情報を表示します。

area default-cost(OSPFv3)

OSPFv3 スタブまたは NSSA に送信されるデフォルト サマリー ルートのコストを指定するには、 area default-cost コマンドを使用します。割り当てられたデフォルト ルートのコストを削除するには、このコマンドの no 形式を使用します。

area area-id default-cost cost

no area area-id default-cost cost

 
構文の説明

area-id

デフォルト コストを設定したい OSPFv3 エリアの識別情報。IP アドレスまたは番号(0 ~ 4294967295)のいずれかで指定します。

cost

スタブまたは NSSA で使用されるデフォルト サマリー ルートのコスト。指定できる範囲は 0 ~ 16777215 です。

 
コマンド デフォルト

サマリー ルートのコストは、サマリー ルートを生成した Area Border Router(ABR; エリア ボーダー ルータ)に基づいています。

 
コマンド モード

アドレスファミリ コンフィギュレーション

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

スタブまたは NSSA に接続されている ABR で area default-cost コマンドを使用し、ABR によってスタブ エリアに生成されるサマリー デフォルト ルートにメトリックを設定します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、スタブ ネットワーク 33 に 20 のデフォルト コストを設定する例を示します。

switch(config)# router ospfv3 201
switch(config-router)# area 33 stub
switch(config-router)# address-family ipv4 unicast
switch(config-router-af)# area 33 default-cost 20

 
関連コマンド

コマンド
説明

area stub

エリアをスタブ エリアとして定義します。

area filter-list(OSPF)

Area Border Router(ABR; エリア ボーダー ルータ)の OSPF(Open Shortest Path First)エリア間のタイプ 3 Link-State Advertisement(LSA; リンクステート アドバタイズメント)でアドバタイズされたプレフィックスをフィルタ処理するには、area filter-list コマンドを使用します。フィルタを変更またはキャンセルするには、このコマンドの no 形式を使用します。

area area-id filter-list route-map map-name { in | out }

no area area-id filter-list route-map map-name { in | out }

 
構文の説明

area-id

フィルタリングを設定したい OSPF エリアの識別情報。正の整数値または IP アドレスを指定します。

route-map map-name

フィルタ ポリシーとして使用するルート マップの名前を指定します。 map-name 引数は、英数字で最大 63 文字の任意のストリングです。

in

このエリアに送信されるネットワークをフィルタ処理します。

out

このエリアから送信されるネットワークをフィルタ処理します。

 
コマンド デフォルト

なし

 
コマンド モード

ルータ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

area filter-list コマンドを使用し、タイプ 3 LSA をフィルタ処理します。 in キーワードでルート マップを適用すると、ルート マップは、ABR によってこのエリアに発生したすべてのタイプ 3 LSA(area range コマンドによって他のエリアに発生したタイプ 3 LSA を含む)をフィルタ処理します。

out キーワードでルート マップを適用すると、ルート マップは、ABR によって他のすべてのエリアにアドバタイズされるすべてのタイプ 3 LSA(このエリアで設定された area range コマンドによってローカルに発生するタイプ 3 LSA を含む)をフィルタ処理します。

Cisco NX-OS は、ルート マップ内のエントリと一致しないプレフィックスを黙示的に拒否します。

このコマンドには、LAN Base Services ライセンスが必要です。

次に、ほかのすべてのエリアからエリア 1 に送信されるプレフィックスをフィルタ処理する例を示します。

switch(config)# router ospf 202
switch(config-router)# area 1 filter-list route-map FilterExternal in
switch(config-router)#
 

 
関連コマンド

コマンド
説明

area range

エリア境界でルートを統合および集約します。

copy running-config startup-config

コンフィギュレーションの変更をスタートアップ コンフィギュレーション ファイルに保存します。

route-map

1 つのルーティング プロトコルから他のルーティング プロトコルへのルートを再配布するか、またはポリシー ルーティングをイネーブルにするための条件を定義します。

show ip ospf policy statistics area

エリアの OSPF ポリシー統計情報を表示します。

area filter-list(OSPFv3)

Area Border Router(ABR; エリア ボーダー ルータ)の OSPFv3(Open Shortest Path First バージョン 3)エリア間のタイプ 3 Link-State Advertisement(LSA; リンクステート アドバタイズメント)でアドバタイズされたプレフィックスをフィルタ処理するには、area filter-list コマンドを使用します。フィルタを変更またはキャンセルするには、このコマンドの no 形式を使用します。

area area-id filter-list route-map map-name { in | out }

no area area-id filter-list route-map map-name { in | out }

 
構文の説明

area-id

フィルタリングを設定したい OSPFv3 エリアの識別情報。IP アドレスまたは番号(0 ~ 4294967295)のいずれかで指定します。

route-map map-name

フィルタ ポリシーとして使用するルート マップの名前を指定します。 map-name 引数は、63 文字以下の任意の英数字文字列にできます。

in

このエリアに送信されるネットワークをフィルタ処理します。

out

このエリアから送信されるネットワークをフィルタ処理します。

 
コマンド デフォルト

なし

 
コマンド モード

アドレスファミリ コンフィギュレーション

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

area filter-list コマンドを使用し、タイプ 3 LSA をフィルタ処理します。 in キーワードでルート マップを適用すると、ルート マップは、ABR によってこのエリアに発生したすべてのタイプ 3 LSA(area range コマンドによって他のエリアに発生したタイプ 3 LSA を含む)をフィルタ処理します。

out キーワードでルート マップを適用すると、ルート マップは、ABR によって他のすべてのエリアにアドバタイズされるすべてのタイプ 3 LSA(このエリアで設定された area range コマンドによってローカルに発生するタイプ 3 LSA を含む)をフィルタ処理します。

Cisco NX-OS は、ルート マップ内のエントリと一致しないプレフィックスを黙示的に拒否します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、他のすべてのエリアからエリア 1 に送信されるプレフィックスをフィルタ処理する例を示します。

switch(config)# router ospfv3 201
switch(config-router)# address-family ipv6 unicast
switch(config-router-af)# area 1 filter-list route-map FilterExternal in

 
関連コマンド

コマンド
説明

area range(OSPFv3)

エリア境界でルートを統合および集約します。

route-map

1 つのルーティング プロトコルから他のルーティング プロトコルへのルートを再配布するか、またはポリシー ルーティングをイネーブルにするための条件を定義します。

area nssa(OSPF)

エリアを Open Shortest Path First(OSPF)Not-So-Stubby Area(NSSA)として設定するには、 area nssa コマンドを使用します。NSSA エリアを削除するには、このコマンドの no 形式を使用します。

area area-id nssa [ default-information-originate [ route-map map-name ]] [ no-redistribution ] [ no-summary ] [ translate type7 [ always | never ] [ suppress-fa ]]

no area area-id nssa [ default-information-originate [ route-map map-name ]] [ no-redistribution ] [ no-summary ] [ translate type7 [ always | never ] [ suppress-fa ]]

 
構文の説明

area-id

OSPF NSSA エリアの識別情報。エリア ID には 0 ~ 4294967295 か、または IP アドレスを指定できます。

default-information-
originate

(任意)タイプ 7 のデフォルトを NSSA エリアに生成します。このキーワードは、NSSA エリア境界ルータ(ABR)または NSSA 自律システム境界ルータ(ASBR)だけで有効です。

route-map map-name

(任意)ルート マップに基づいて、タイプ 7 のデフォルト生成をフィルタ処理します。 map-name 引数は、63 文字以下の任意の英数字文字列にできます。

no-redistribution

(任意)再配布されたリンクステート アドバタイズメント(LSA)がこの NSSA エリアに入るのを阻止します。ルータが NSSA ASBR と NSSA ABR の両方であり、 redistribute コマンドでルートを通常のエリアにインポートしたいが、NSSA エリアにはインポートしたくない場合は、このキーワードを使用します。

no-summary

(任意)エリアが NSSA エリアになることを許可しますが、エリアにサマリー ルートを導入させません。

translate type7

(任意)タイプ 7 LSA をタイプ 5 LSA に変換します。

always

(任意)常に LSA を変換します。

never

(任意)LSA を変換しません。

suppress-fa

(任意)変換された LSA 内の転送アドレスを抑制します。ABR はフォワーディング IPv4 アドレスとして 0.0.0.0 を使用します。

 
コマンド デフォルト

なし

 
コマンド モード

ルータ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

area nssa コマンドを使用し、OSPF 自律システムに NSSA エリアを作成します。変換された LSA に転送アドレスの抑制を設定する前に、ネットワーク トポロジについて理解しておくことを推奨します。宛先の転送アドレスに到達するためのより良いパスが別に存在する場合は、最適なルーティングとは言えません。

このコマンドには、LAN Base Services ライセンスが必要です。

次に、エリア 1 を NSSA エリアとして設定する例を示します。

switch(config)# router ospf 10
switch(config-router)# area 1 nssa
switch(config-router)#
 

次に、エリア 1 を NSSA エリアとして設定し、タイプ 7 LSA をエリア 1 からタイプ 5 LSA に変換するが、タイプ 7 転送アドレスをタイプ 5 LSA に配置しない例を示します (OSPF は 0.0.0.0 を転送アドレスとしてタイプ 5 LSA に配置します)。

switch(config)# router ospf 2
switch(config-router)# area 1 nssa translate type7 suppress-fa
switch(config-router)#
 

 
関連コマンド

コマンド
説明

copy running-config startup-config

コンフィギュレーションの変更をスタートアップ コンフィギュレーション ファイルに保存します。

redistribute

1 つのルーティング プロトコルから学習したルートを他のルーティング プロトコル ドメインに再配布します。

show ip ospf

OSPF 情報を表示します。

area nssa(OSPFv3)

エリアを OSPFv3(Open Shortest Path First バージョン 3)Not-So-Stubby Area(NSSA)として設定するには、 area nssa コマンドを使用します。NSSA エリアを削除するには、このコマンドの no 形式を使用します。

area area-id nssa [ default-information-originate [ route-map map-name ]] [ no-redistribution ] [ no-summary ] [ translate type7 [ always | never ] [ suppress-fa ]]

no area area-id nssa [ default-information-originate [ route-map map-name ]] [ no-redistribution ] [ no-summary ] [ translate type7 [ always | never ] [ suppress-fa ]]

 
構文の説明

area-id

OSPFv3 NSSA エリアの識別情報。IP アドレスまたは番号(0 ~ 4294967295)のいずれかで指定します。

default-information-
originate

(任意)タイプ 7 のデフォルトを NSSA エリアに生成します。このキーワードは、NSSA Area Border Router(ABR; エリア ボーダー ルータ)または NSSA Autonomous System Border Router(ASBR; 自律システム ボーダー ルータ)でのみ有効です。

route-map map-name

(任意)ルート マップに基づいて、タイプ 7 のデフォルト生成をフィルタ処理します。 map-name 引数は、63 文字以下の任意の英数字文字列にできます。

no-redistribution

(任意)再配布された Link-State Advertisement(LSA; リンクステート アドバタイズメント)がこの NSSA エリアに入るのを阻止します。ルータが NSSA 自律システム境界ルータ(ASBR)および NSSA エリア境界ルータ(ABR)の両方であり、 redistribute コマンドによってルートを通常のエリアにインポートしたいが、NSSA エリアにはインポートしたくない場合、このキーワードを使用します。

no-summary

(任意)エリアが NSSA エリアになることを許可しますが、エリアにサマリー ルートを導入させません。

translate type7

(任意)タイプ 7 LSA をタイプ 5 LSA に変換します。

always

(任意)常に LSA を変換します。

never

(任意)LSA を変換しません。

suppress-fa

(任意)変換された LSA 内の転送アドレスを抑制します。ABR はフォワーディング IPv4 アドレスとして 0.0.0.0 を使用します。

 
コマンド デフォルト

なし

 
コマンド モード

ルータ コンフィギュレーション

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

area nssa コマンドを使用し、OSPFv3 自律システムに NSSA エリアを作成します。変換された LSA に転送アドレスの抑制を設定する前に、ネットワーク トポロジについて理解しておくことを推奨します。宛先の転送アドレスに到達するためのより良いパスが別に存在する場合は、最適なルーティングとは言えません。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、エリア 1 を NSSA エリアとして設定する例を示します。

switch(config)# router ospfv3 10
switch(config-router)# area 1 nssa
 

次に、エリア 1 を NSSA エリアとして設定し、タイプ 7 LSA をエリア 1 からタイプ 5 LSA に変換するが、タイプ 7 転送アドレスをタイプ 5 LSA に配置しない例を示します (OSPFv3 は 0.0.0.0 を転送アドレスとしてタイプ 5 LSA に配置します)。

switch(config)# router ospfv3 2
switch(config-router)# area 1 nssa translate type7 suppress-fa
 

 
関連コマンド

コマンド
説明

redistribute(OSPFv3)

1 つのルーティング プロトコルから学習したルートを他のルーティング プロトコル ドメインに再配布します。

area range(OSPF)

OSPF エリアの境界にあるルートを統合して集約するには、 area range コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

area area-id range ip-prefix [ not-advertise ]

no area area-id range ip-prefix [ not-advertise ]

 
構文の説明

area-id

ルートを集約したい OSPF エリアの識別情報。エリア ID には 0 ~ 4294967295 か、または IP アドレスを指定できます。

ip-prefix

IP アドレス/サブネット マスクの長さ( A . B . C . D / LEN )として指定された IP プレフィックス

not-advertise

(任意)アドレス範囲ステータスを DoNotAdvertise に設定します。Type 3 サマリー LSA は抑制され、コンポーネント ネットワークは他のネットワークから隠された状態のままです。

 
コマンド デフォルト

ディセーブル

 
コマンド モード

ルータ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

area range コマンドを Area Border Router(ABR; エリア ボーダー ルータ)でのみ使用し、エリアのルートを統合または集約します。ABR は 1 つのサマリー ルートが他のエリアにアドバタイズされることを通知し、エリアの境界でルーティング情報を集約します。

複数の area range コマンドを設定することにより、OSPF が多くの異なるアドレス範囲のセットのアドレスを集約するように設定できます。

このコマンドには、LAN Base Services ライセンスが必要です。

次に、1 つのサマリー ルートが、ABR によってネットワーク 192.0.2.0 上のすべてのホストの他のエリアにアドバタイズされるように設定する例を示します。

switch(config-if)# interface ethernet 1/2
switch(config-if)# ip address 192.0.2.201 255.255.255.0
switch(config-if)# ip ospf area 201
switch(config-if)# exit
switch(config)# router ospf 12
switch(config-router)# area 0 range 192.0.2.0 255.255.0.0
switch(config-router)#
 

 
関連コマンド

コマンド
説明

copy running-config startup-config

コンフィギュレーションの変更をスタートアップ コンフィギュレーション ファイルに保存します。

show ip ospf

OSPF 情報を表示します。

area range(OSPFv3)

OSPFv3 エリアの境界にあるルートを統合して集約するには、 area range コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

area area-id range ipv6-prefix / length [ not-advertise ]

no area area-id range ipv6-prefix [ not-advertise ]

 
構文の説明

area-id

ルートを集約したい OSPF エリアの識別情報。IP アドレスまたは番号(0 ~ 4294967295)のいずれかで指定します。

ipv6-prefix/length

IPv6 アドレス/長さ(A:B::C:D/LEN)として指定された IP プレフィックス。 length 引数の範囲は 1 ~ 127 です。

not-advertise

(任意)アドレス範囲ステータスを DoNotAdvertise に設定します。Type 3 サマリー LSA は抑制され、コンポーネント ネットワークは他のネットワークから隠された状態のままです。

 
コマンド デフォルト

ディセーブル

 
コマンド モード

ルータ コンフィギュレーション

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

area range コマンドを Area Border Router(ABR; エリア ボーダー ルータ)でのみ使用し、エリアのルートを統合または集約します。ABR は 1 つのサマリー ルートが他のエリアにアドバタイズされることを通知し、エリアの境界でルーティング情報を集約します。

複数の area range コマンドを設定することにより、OSPFv3 が多くの異なるアドレス範囲のセットのアドレスを集約するように設定できます。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、1 つのサマリー ルートが、ABR によってネットワーク 2001:0DB8::/32 上のすべてのホストの他のエリアにアドバタイズされるように設定する例を示します。

switch(config)# router ospfv3 201
switch(config-router)# address-family ipv6 unicast
switch(config-router-af)# area 0 range 2001:0DB8::/32
 

area stub(OSPF)

エリアを OSPF(Open Shortest Path First)スタブ エリアとして定義するには、 area stub コマンドを使用します。エリアを削除するには、このコマンドの no 形式を使用します。

area area-id stub [ no-summary ]

no area area-id stub [ no-summary ]

 
構文の説明

area-id

OSPF スタブ エリアの識別情報。エリア ID には 0 ~ 4294967295 か、または IP アドレスを指定できます。

no-summary

(任意)Area Border Router(ABR; エリア ボーダー ルータ)が要約リンク アドバタイズメントをスタブ エリアに送信するのを防ぎます。

 
コマンド デフォルト

なし

 
コマンド モード

ルータ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

area stub コマンドを使用し、スタブ エリアに接続されているすべてのデバイスを設定します。スタブ エリアに接続されている ABR で area default-cost コマンドを使用します。 area default-cost コマンドは、ABR によってスタブ エリアに生成されたサマリー デフォルト ルートにメトリックを提供します。

スタブ エリアに送信される Link-State Advertisement(LSA; リンクステート アドバタイズメント)の数をさらに減少させるために、ABR で no-summary キーワードを設定し、集約 LSA(タイプ 3 LSAs3)をスタブ エリアに送信するのを防ぐことができます。

このコマンドには、LAN Base Services ライセンスが必要です。

次に、OSPF 209 にスタブ エリア 33 を作成する例を示します。

switch(config)# router ospf 201
switch(config-router)# area 33 stub
switch(config-router)#
 

 
関連コマンド

コマンド
説明

area default-cost

スタブ エリアに送信されるデフォルト サマリー ルートのコストを指定します。

copy running-config startup-config

コンフィギュレーションの変更をスタートアップ コンフィギュレーション ファイルに保存します。

show ip ospf

OSPF 情報を表示します。

area stub(OSPFv3)

エリアを OSPFv3(Open Shortest Path First バージョン 3)スタブ エリアとして定義するには、 area stub コマンドを使用します。エリアを削除するには、このコマンドの no 形式を使用します。

area area-id stub [ no-summary ]

no area area-id stub [ no-summary ]

 
構文の説明

area-id

OSPFv3 スタブ エリアの識別情報。IP アドレスまたは番号(0 ~ 4294967295)のいずれかで指定します。

no-summary

(任意)Area Border Router(ABR; エリア ボーダー ルータ)が要約リンク アドバタイズメントをスタブ エリアに送信するのを防ぎます。

 
コマンド デフォルト

なし

 
コマンド モード

ルータ コンフィギュレーション

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

area stub コマンドを使用し、スタブ エリアに接続されているすべてのデバイスを設定します。スタブ エリアに接続されている ABR で area default-cost コマンドを使用します。 area default-cost コマンドは、ABR によってスタブ エリアに生成されたサマリー デフォルト ルートにメトリックを提供します。

スタブ エリアに送信される Link-State Advertisement(LSA; リンクステート アドバタイズメント)の数をさらに減少させるために、ABR で no-summary キーワードを設定し、集約 LSA(タイプ 3 LSAs3)をスタブ エリアに送信するのを防ぐことができます。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、OSPFv3 209 にスタブ エリア 33 を作成する例を示します。

switch(config)# router ospfv3 201
switch(config-router)# area 33 stub
 
 
 

 
関連コマンド

コマンド
説明

area default-cost(OSPFv3)

スタブ エリアに送信されるデフォルト サマリー ルートのコストを指定します。

area virtual-link(OSPF)

OSPF 仮想リンクを定義するには、 area virtual-link コマンドを使用します。仮想リンクを削除するには、このコマンドの no 形式を使用します。

area area-id virtual-link router-id

no area area-id virtual-link router-id

 
構文の説明

area-id

仮想リンクのトランジット エリアに割り当てられた OSPF エリアの識別情報。エリア ID には 0 ~ 4294967295 か、または IP アドレスを指定できます。

router-id

仮想リンク ネイバーに関連付けられるルータ ID。IP アドレスを指定します。ルータ ID は show ip ospf neighbors ディスプレイに表示されます。

 
コマンド デフォルト

なし

 
コマンド モード

ルータ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

area virtual-link コマンドを使用し、リモート エリアからバックボーン エリアへの仮想リンクを確立します。OSPF では、すべてのエリアがバックボーン エリアに接続されている必要があります。バックボーンへの接続が失われた場合は、仮想リンクを確立して修復できます。

area virtual-link コマンドを使用し、次のコマンドを使用できる仮想リンク コンフィギュレーション モードを開始します。

authentication [key-chain | message-digest | null]

authentication-key [0 | 3] key

dead-interval seconds

hello-interval seconds

message-digest-key key-id md5 key

retransmit-interval seconds

transmit-delay seconds

構文と使用方法の詳細については、各コマンドを参照してください。

仮想リンクの両側で、同じエリア ID および対応する仮想リンク ネイバー ルータ ID を設定する必要があります。ルータ ID を表示するには、任意のモードで show ip ospf neighbors コマンドを使用します。


) Not-So-Stubby Area(NSSA)には仮想リンクを設定できません。


このコマンドには、LAN Base Services ライセンスが必要です。

次に、すべてのオプションのパラメータのデフォルト値で 2 つのデバイス(A と B)間に仮想リンクを確立する例を示します。

Device A:
switch(config)# router ospf 1
switch(config-router)# router-id 192.0.2.2
switch(config-router)# area 1 virtual-link 192.0.2.1
switch(config-router-vlink)#
 
Device B:
switch(config# router ospf 209
switch(config-router)# router-id 192.0.2.1
switch(config-router)# area 1 virtual-link 192.0.2.2
switch(config-router-vlink)#
 

 
関連コマンド

コマンド
説明

authentication(OSPF 仮想リンク)

OSPF 仮想リンクの認証をイネーブルにします。

authentication-key(OSPF 仮想リンク)

OSPF の単純パスワード認証を使用しているネイバー ルータが使用するパスワードを割り当てます。

copy running-config startup-config

コンフィギュレーションの変更をスタートアップ コンフィギュレーション ファイルに保存します。

dead-interval(OSPF 仮想リンク)

OSPF 仮想リンクのデッド間隔を設定します。

hello-interval(OSPF 仮想リンク)

OSPF 仮想リンクの hello 間隔を設定します。

message-digest-key(仮想リンク)

OSPF 仮想リンクで OSPF Message Digest 5(MD5)認証をイネーブルにします。

retransmit-interval(OSPF 仮想リンク)

OSPF 仮想リンクの再送信間隔を設定します。

show ip ospf neighbors

OSPF ネイバー情報を表示します。

show ip ospf virtual-link

OSPF 仮想リンク情報を表示します。

transmit-delay(OSPF 仮想リンク)

OSPF 仮想リンクの送信遅延を設定します。

area virtual-link(OSPFv3)

OSPFv3 仮想リンクを定義するには、 area virtual-link コマンドを使用します。仮想リンクを削除するには、このコマンドの no 形式を使用します。

area area-id virtual-link router-id

no area area-id virtual-link router-id

 
構文の説明

area-id

仮想リンクのトランジット エリアに割り当てられた OSPFv3 エリアの識別情報。IP アドレスまたは番号(0 ~ 4294967295)のいずれかで指定します。

router-id

仮想リンク ネイバーに関連付けられるルータ ID。IP アドレスを指定します。ルータ ID は show ospfv3 neighbors ディスプレイに表示されます。

 
コマンド デフォルト

なし

 
コマンド モード

ルータ コンフィギュレーション

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

area virtual-link コマンドを使用し、リモート エリアからバックボーン エリアへの仮想リンクを確立します。OSPFv3 では、すべてのエリアはバックボーン エリアに接続している必要があります。バックボーンへの接続が失われた場合は、仮想リンクを確立して修復できます。

area virtual-link コマンドを使用し、次のコマンドを使用できる仮想リンク コンフィギュレーション モードを開始します。

dead-interval seconds

hello-interval seconds

retransmit-interval seconds

transmit-delay seconds

構文と使用方法の詳細については、各コマンドを参照してください。

仮想リンクの両側で、同じエリア ID および対応する仮想リンク ネイバー ルータ ID を設定する必要があります。ルータ ID を表示するには、任意のモードで show ospfv3 neighbors コマンドを使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、すべてのオプションのパラメータのデフォルト値で 2 つのデバイス(A と B)間に仮想リンクを確立する例を示します。

Device A:
switch(config)# router ospfv3 1
switch(config-router)# router-id 192.0.2.2
switch(config-router)# area 1 virtual-link 192.0.2.1
 
Device B:
switch(config# router ospfv3 209
switch(config-router)# router-id 192.0.2.1
switch(config-router)# area 1 virtual-link 192.0.2.2
 

 
関連コマンド

コマンド
説明

dead-interval(OSPFv3 仮想リンク)

OSPFv3 仮想リンクのデッド間隔を設定します。

hello-interval(OSPFv3 仮想リンク)

OSPFv3 仮想リンクの hello 間隔を設定します。

retransmit-interval(OSPFv3 仮想リンク)

OSPFv3 仮想リンクの再送信間隔を設定します。

transmit-delay(OSPFv3 仮想リンク)

OSPFv3 仮想リンクの送信遅延を設定します。

authentication(OSPF 仮想リンク)

OSPF 仮想リンクの認証タイプを指定するには、 authentication コマンドを使用します。仮想リンクの認証タイプを削除するには、このコマンドの no 形式を使用します。

authentication [ key-chain key-name | message-digest | null ]

no authentication

 
構文の説明

key-chain key-name

(任意)使用するキー チェーンを指定します。 key-name 引数は、英数字で最大 63 文字の任意のストリングです。

message-digest

(任意)メッセージ ダイジェスト認証を使用するように指定します。

null

(任意)認証を使用しないように指定します。エリアに設定されている場合、認証をディセーブルにします。

 
コマンド デフォルト

オプションのキーワードなしで認証を設定すると、デフォルトでパスワード認証になります。

 
コマンド モード

OSPF 仮想リンク コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

仮想リンク コンフィギュレーション モードで authentication コマンドを使用し、仮想リンクで使用する認証方式を設定します。 message-digest キーワードを使用して MD5 メッセージ ダイジェスト認証を設定し、 message-digest-key コマンドを使用してこの認証設定を完了します。 key-chain キーワードは、キー チェーンを使用したパスワード認証を設定し、key chain コマンドを使用してこの認証設定を完了するために使用します。キーワードなしで authentication コマンドを使用して仮想リンクのパスワードを設定し、 authentication-key コマンドを使用してこの認証設定を完了します。

このコマンドには、LAN Base Services ライセンスが必要です。

次に、メッセージ ダイジェスト認証をイネーブルにする例を示します。

switch(config)# router ospf 22
switch(config-router)# area 99 virtual-link 192.0.2.12
switch(config-router-vlink)# authentication message-digest
switch(config-router-vlink)# message-digest key 4 md5 0 abcd
 

 
関連コマンド

コマンド
説明

area authentication

OSPF エリアの認証をイネーブルにします。

authentication-key(OSPF 仮想リンク)

OSPF のパスワード認証を使用しているネイバー ルート用のパスワードを指定します。

key chain

認証キーを管理するためのキー チェーンを作成します。

message-digest-key(OSPF 仮想リンク)

OSPF Message Digest 5(MD5)認証をイネーブルにします。

authentication-key(OSPF 仮想リンク)

OSPF 仮想リンクで使用されるパスワードを割り当てるには、 authentication-key コマンドを使用します。過去に割り当てられた OSPF パスワードを削除するには、このコマンドの no 形式を使用します。

authentication-key [ 0 | 3 ] password

no authentication-key

 
構文の説明

0

(任意)暗号化されていない認証キーを指定します。

3

(任意)トリプル DES 暗号化認証キーを指定します。

password

キーボードから入力可能な文字による最大 8 バイトの連続したストリング

 
コマンド デフォルト

非暗号化パスワード

 
コマンド モード

OSPF 仮想リンク コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

authentication-key コマンドを使用し、OSPF 仮想リンクでパスワード認証のパスワードを設定します。同じ仮想リンクにあるすべてのデバイスは、OSPF 情報を交換できるように同じパスワードを持っている必要があります。

このコマンドには、LAN Base Services ライセンスが必要です。

次に、文字列 yourpass を使用して認証キーをイネーブルにする例を示します。

switch(config)# router ospf 22
switch(config-router)# area 99 virtual-link 192.0.2.12
switch(config-router-vlink)# authentication
switch(config-router-vlink)# authentication-key yourpass

 
関連コマンド

コマンド
説明

authentication(仮想リンク)

OSPF 仮想リンクの認証をイネーブルにします。

auto-cost(OSPF)

OSPF(Open Shortest Path First)がインターフェイスのデフォルト メトリックを計算する方法を制御するには、 auto-cost コマンドを使用します。40 Gb/s のデフォルト基準帯域幅を割り当てるには、このコマンドの no 形式を使用します。

auto-cost reference-bandwidth bandwidth [ Gbps | Mbps ]

no auto-cost reference-bandwidth

 
構文の説明

reference-bandwidth bandwidth

インターフェイスのデフォルト メトリックを計算するために使用する基準帯域幅を設定します。範囲は Gbps キーワードを使用するか MBps キーワードを使用するかによって異なります。

Gbps

(任意)レートを Gbps で指定します(帯域幅)。範囲は 1 ~ 4000 で、デフォルトは 40 です。

Mbps

(任意)レートを Mbps で指定します(帯域幅)。範囲は 1 ~ 4000000 で、デフォルトは 40000 です。

 
コマンド デフォルト

40 Gb/s。 Gpbs または Mbps キーワード を指定しない場合、帯域幅はデフォルトで Gb/s になります。

 
コマンド モード

ルータ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

auto-cost コマンドを使用し、OSPF コスト メトリックの計算により使用される基準帯域幅を設定します。

ip ospf cost コマンドによって設定された値は、 auto-cost コマンドによって設定されたコストを上書きします。

このコマンドには、LAN Base Services ライセンスが必要です。

次に、OSPF インスタンス内のすべてのローカル インターフェイスに基準帯域幅を設定する例を示します。

switch(config)# router ospf 201
switch(config-router)# auto-cost reference-bandwidth 10
 

 
関連コマンド

コマンド
説明

ip ospf cost

インターフェイス上でパケットを送信するコストを明示的に指定します。

auto-cost(OSPFv3)

OSPFv3(Open Shortest Path First バージョン 3)がインターフェイスのデフォルト メトリックを計算する方法を制御するには、 auto-cost コマンドを使用します。40 Gb/s のデフォルト基準帯域幅を割り当てるには、このコマンドの no 形式を使用します。

auto-cost reference-bandwidth bandwidth [Gbps | Mbps]

no auto-cost reference-bandwidth

 
構文の説明

reference-bandwidth bandwidth

インターフェイスのデフォルト メトリックを計算するために使用する基準帯域幅を設定します。範囲は Gbps キーワードを使用するか MBps キーワードを使用するかによって異なります。

Gbps

(任意)レートを Gbps で指定します(帯域幅)。範囲は 1 ~ 4000 で、デフォルトは 40 です。

Mbps

(任意)レートを Mbps で指定します(帯域幅)。範囲は 1 ~ 4000000 で、デフォルトは 40000 です。

 
コマンド デフォルト

40 Gb/s。 Gpbs または Mbps キーワード を指定しない場合、帯域幅はデフォルトで Gb/s になります。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

auto-cost コマンドを使用し、OSPFv3 コスト メトリックの計算により使用される基準帯域幅を設定します。

ipv6 ospfv3 cost コマンドによって設定された値は、 auto-cost コマンドによって設定されたコストを上書きします。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、OSPFv3 インスタンス内のすべてのローカル インターフェイスに基準帯域幅を設定する例を示します。

switch(config)# router ospfv3 201
switch(config-router)# auto-cost reference-bandwidth 10

 
関連コマンド

コマンド
説明

ipv6 ospfv3 cost

インターフェイス上でパケットを送信するコストを明示的に指定します。