Cisco Nexus 5000 シリーズ NX-OS ユニキャスト ルーティング コマンド リファレンス
I コマンド
I コマンド
発行日;2013/04/23 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

I コマンド

ip address

ip arp

ip arp gratuitous

ip arp timeout

ip directed-broadcast

interface ethernet(レイヤ 3)

ip local-proxy-arp

interface loopback

interface port-channel

ip port-unreachable

ip policy route-map

ip proxy-arp

ip tcp path-mtu-discovery

ip tcp synwait-time

ip unreachables

ipv6 nd

ipv6 address

ipv6 host

ipv6 nd hop-limit

ipv6 nd managed-config-flag

ipv6 nd mtu

ipv6 nd ns-interval

ipv6 nd other-config-flag

ipv6 nd ra-interval

ipv6 nd ra-lifetime

ipv6 nd reachable-time

ipv6 nd redirects

ipv6 nd retrans-timer

ipv6 nd suppress-ra

ipv6 neighbor

ipv6 unreachables

ipv6 policy route-map

I コマンド

この章では、I で始まる Cisco NX-OS レイヤ 3 インターフェイス コマンドについて説明します。

ip address

インターフェイスのプライマリまたはセカンダリ IP アドレスを設定するには、 ip address コマンドを使用します。IP アドレスを削除するか、IP プロセシングをディセーブルにするには、このコマンドの no 形式を使用します。

ip address ip-address mask [ secondary ]

no ip address ip-address mask [ secondary ]

 
構文の説明

ip-address

A . B . C . D または A . B . C . D / length の形式の IPv4 アドレス。

mask

関連する IP サブネットのマスク。

secondary

(任意)設定されたアドレスをセカンダリ IP アドレスに指定します。このキーワードが省略された場合、設定されたアドレスはプライマリ IP アドレスになります。

 
コマンド デフォルト

IP アドレスはインターフェイスに定義されません。

 
コマンド モード

インターフェイス コンフィギュレーション モード
サブインターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン


) このコマンドを使用する前に、レイヤ 3 機能を使用するためにインターフェイス上で no switchport コマンドを使用していることを確認してください。


インターフェイスには、1 つのプライマリ IP アドレスと 1 つのセカンダリ IP アドレスを割り当てることができます。

no ip address コマンドを使用して IP アドレスを削除することにより、特定のインターフェイス上の IP プロセシングをディセーブルにできます。

オプションの secondary キーワードを使用すると、セカンダリ IP アドレスを指定できます。システムがセカンダリの送信元アドレスのルーティングの更新以外にデータグラムを生成しないということを除けば、セカンダリ アドレスはプライマリ アドレスのように処理されます。IP ブロードキャストおよびアドレス解決プロトコル(ARP)要求は、IP ルーティング テーブル内のインターフェイス ルートのように処理されます。


) Open Shortest Path First(OSPF)アルゴリズムを使用してルーティングする場合は、インターフェイスのセカンダリ アドレスがプライマリ アドレスと同じ OSPF エリアにあることを確認してください。


次に、イーサネット インターフェイス 1/5 のプライマリ アドレスとして IP アドレス 192.168.0.27 を、セカンダリ アドレスとして 192.168.0.5 を設定する例を示します。

switch(config)# interface ethernet 1/5
switch(config-if)# no switchport
switch(config-if)# ip address 192.168.0.27 255.255.255.0
switch(config-if )# ip address 192.168.0.5 255.255.255.0 secondary
switch(config-if)#
 

 
関連コマンド

コマンド
説明

copy running-config startup-config

コンフィギュレーションの変更をスタートアップ コンフィギュレーション ファイルに保存します。

no switchport

レイヤ 3 設定のインターフェイスをイネーブルにします。

show ip interface

IPv4 に設定されたインターフェイスを表示します。

 

ip arp

スタティック ARP エントリを設定するには、 ip arp コマンドを使用します。スタティック ARP エントリを削除するには、このコマンドの no 形式を使用します。

ip arp ip-address mac-address

no ip arp ip-address

 
構文の説明

ip-address

A . B . C . D の形式の IPv4 アドレス。

mac-address

次の形式の MAC アドレス:

E.E.E

EE-EE-EE-EE-EE-EE

EE:EE:EE:EE:EE:EE

EEEE.EEEE.EEEE

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード
サブインターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドは、レイヤ 2 インターフェイス、レイヤ 3 インターフェイスおよびレイヤ 3 サブインターフェイス上で使用します。

次に、インターフェイス イーサネット 1/2 上でスタティック ARP エントリを設定する例を示します。

switch(config)# interface ethernet 1/2
switch(config-if)# no switchport
switch(config-if)# ip arp 192.0.2.1 0150.5a03.efab
switch(config-if)#
 

次に、サブインターフェイス上でスタティック ARP エントリを設定する例を示します。

switch(config)# interface ethernet 1/5
switch(config-if)# no switchport
switch(config-if)# interface ethernet 1/1.1
switch(config-subif)# ip arp 192.0.2.1 0150.5a03.efab
switch(config-subif)#
 

 
関連コマンド

コマンド
説明

show ip arp

ARP エントリを表示します。

ip arp gratuitous

無償 ARP をイネーブルにするには、 ip arp gratuitous コマンドを使用します。無償 ARP をディセーブルにするには、このコマンドの no 形式を使用します。

ip arp gratuitous { request | update }

no ip arp gratuitous { request | update }

 
構文の説明

request

アドレス重複検出時の無償 ARP 要求の送信をイネーブルにします。

update

無償 ARP 用の ARP キャッシュのアップデートをイネーブルにします。

 
コマンド デフォルト

イネーブル

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

インターフェイス Ethernet 2/1 上の gratuitous ARP 要求をディセーブルにする例を示します。

switch(config)# interface ethernet 1/2
switch(config-if)# no switchport
switch(config-if)# ip arp gratuitous
switch(config-if)#
 

 
関連コマンド

コマンド
説明

ip arp

スタティック ARP エントリを設定します。

show ip arp

ARP 設定情報を表示します。

ip arp timeout

アドレス解決プロトコル(ARP)のタイムアウトを設定するには、 ip arp timeout コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

ip arp timeout timeout-value

no ip arp timeout

 
構文の説明

timeout-value

ARP キャッシュ内にエントリを残す時間(秒単位)。有効な値は 60 ~ 28800 で、デフォルトは 1500 です。

 
コマンド デフォルト

1500 秒

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(2)N1(1)

このコマンドが導入されました。

次に、ARP タイムアウト値を 120 秒に設定する例を示します。

switch(config)# ip arp timeout 120
switch(config)#
 

次に、ARP タイムアウト値をデフォルトの 1500 秒に戻す例を示します。

switch(config)# no ip arp timeout
switch(config)#
 

 
関連コマンド

コマンド
説明

show running-config arp all

デフォルト設定を含む ARP 設定を表示します。

ip directed-broadcast

ダイレクト ブロードキャストから物理ブロードキャストへの変換をイネーブルにするには、 ip directed-broadcast コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

ip directed-broadcast

no ip directed-broadcast

 
構文の説明

このコマンドには引数またはキーワードはありません。

 
コマンド デフォルト

ディセーブル。すべての IP ダイレクト ブロードキャストが破棄されます。

 
コマンド モード

インターフェイス コンフィギュレーション モード
サブインターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

IP ダイレクト ブロードキャストは、宛先アドレスが何らかの IP サブネットの有効なブロードキャスト アドレスであるにもかかわらず、その宛先サブネットに含まれないノードから発信される IP パケットです。

宛先サブネットに直接接続されていないデバイスは、そのサブネット上のホストを宛先とするユニキャスト IP パケットを転送する場合と同じ方法で IP ダイレクト ブロードキャストを転送します。ダイレクト ブロードキャスト パケットが、宛先サブネットに直接接続されたデバイスに到着すると、そのパケットはその宛先サブネット上でブロードキャストされます。パケットの IP ヘッダー内の宛先アドレスはそのサブネットに設定された IP ブロードキャスト アドレスに書き換えられ、パケットはリンク層ブロードキャストとして送信されます。

あるインターフェイスでダイレクト ブロードキャストがイネーブルになっている場合、着信した IP パケットが、そのアドレスに基づいて、そのインターフェイスが接続されているサブネットを対象とするダイレクト ブロードキャストとして識別されると、そのパケットはそのサブネット上でブロードキャストされます。

no ip directed-broadcast コマンドがインターフェイスに対して設定されている場合は、そのインターフェイスが接続されたサブネット行きのダイレクト ブロードキャストが展開されずに破棄されます。


) ダイレクト ブロードキャストの中でも特にインターネット制御メッセージ プロトコル(ICMP)ダイレクト ブロードキャストは、悪意のある人物によって不正使用されたことがあるため、ダイレクト ブロードキャストを必要としないインターフェイス上では ip directed-broadcast コマンドをディセーブルにすることを推奨します。また、アクセス リストを使用してブロードキャスト パケットの数を制限することも推奨します。


次に、イーサネット インターフェイス 2/1 上で IP ダイレクト ブロードキャストの転送をイネーブルにする例を示します。

switch(config)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# ip directed-broadcast
switch(config-if)#
 

 
関連コマンド

コマンド
説明

show ip interface

インターフェイスの IP 情報を表示します。

 

interface ethernet(レイヤ 3)

レイヤ 3 イーサネット IEEE 802.3 ルーテッド インターフェイスを設定するには、 interface ethernet コマンドを使用します。

interface ethernet [ chassis_ID /] slot / port [ . subintf-port-no ]

 
構文の説明

chassis_ID

(任意)ファブリック エクステンダ シャーシ ID を指定します。シャーシ ID の範囲は、100 ~ 199 です。

(注) Cisco Nexus 2000 シリーズ ファブリック エクステンダのホスト インターフェイスをアドレス指定する場合、この引数は必須です。

slot

1 ~ 3 のスロット。次のリストに使用可能なスロットを示します。

スロット 1 にはすべての固定ポートが含まれます。ファブリック エクステンダにのみ、1 つのスロットが含まれます。

スロット 2 には上位拡張モジュールのポートが含まれます(実装されている場合)。

スロット 3 には下位拡張モジュールのポートが含まれます(実装されている場合)。

port

特定のスロット内のポート番号を指定します。指定できるポート番号は 1 ~ 128 です。

.

(任意)サブインターフェイスの区切り文字を指定します。

subintf-port-no

(任意)サブインターフェイスのポート番号。有効な範囲は 1 ~ 48 です。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード
インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

インターフェイスをレイヤ 3 ルーテッド インターフェイスとして設定するためには、 no switchport コマンドをインターフェイス コンフィギュレーション モードで使用する必要があります。インターフェイスをレイヤ 3 インターフェイスとして設定すると、そのインターフェイスのすべてのレイヤ 2 固有のコンフィギュレーションが削除されます。

レイヤ 3 インターフェイスをレイヤ 2 インターフェイスに変換するには、 switchport コマンドを使用します。インターフェイスをレイヤ 2 インターフェイスとして設定すると、このインターフェイスのすべてのレイヤ 3 固有のコンフィギュレーションが削除されます。

次に、レイヤ 3 イーサネット インターフェイス 1/5 のコンフィギュレーション モードを開始する例を示します。

switch(config)# interface ethernet 1/5
switch(config-if)# no switchport
switch(config-if)# ip address 10.1.1.1/24
switch(config-if)#
 

次に、ファブリック エクステンダ上のホスト インターフェイスのコンフィギュレーション モードを開始する例を示します。

switch(config)# interface ethernet 101/1/1
switch(config-if)# no switchport
switch(config-if)# ip address 10.1.1.1/24
switch(config-if)#
 

次に、グローバル コンフィギュレーション モードでイーサネット インターフェイス 1/5 のレイヤ 3 サブインターフェイスを設定する例を示します。

switch(config)# interface ethernet 1/5.2
switch(config-if)# no switchport
switch(config-subif)# ip address 10.1.1.1/24
switch(config-subif)#
 

次に、インターフェイス コンフィギュレーション モードでレイヤ 3 サブインターフェイスを設定する例を示します。

switch(config)# interface ethernet 1/5
switch(config-if)# interface ethernet 1/5.1
switch(config-if)# no switchport
switch(config-subif)# ip address 10.1.1.1/24
switch(config-subif)#
 

次に、レイヤ 3 インターフェイスをレイヤ 2 インターフェイスに変換する例を示します。

switch(config)# interface ethernet 1/5
switch(config-if)# no switchport
switch(config-if)# ip address 10.1.1.1/24
switch(config-if)# switchport
switch(config-if)#
 

 
関連コマンド

コマンド
説明

bandwidth

インターフェイスの帯域幅パラメータを設定します。

delay

インターフェイス スループット遅延値を設定します。

encapsulation

インターフェイスのカプセル化タイプを設定します。

ip address

インターフェイスに対するプライマリ IP アドレスまたはセカンダリ IP アドレスを設定します。

inherit

インターフェイスにポート プロファイルを割り当てます。

interface vethernet

仮想イーサネット インターフェイスを設定します。

no switchport

インターフェイスをレイヤ 3 インターフェイスとして設定します。

service-policy

インターフェイスのサービス ポリシーを設定します。

show fex

スイッチに接続されているすべての設定済みファブリック エクステンダ シャーシを表示します。

show interface ethernet

イーサネット IEEE 802.3 インターフェイスのさまざまなパラメータを表示します。

 

ip local-proxy-arp

ローカル プロキシ アドレス解決プロトコル(ARP)機能をイネーブルにするには、 ip local-proxy-arp コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

ip local-proxy-arp

no ip local-proxy-arp

 
構文の説明

このコマンドには引数またはキーワードはありません。

 
コマンド デフォルト

ディセーブル

 
コマンド モード

インターフェイス コンフィギュレーション モード
サブインターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

ローカル プロキシ ARP 機能を使用するには、その前に ip proxy-arp コマンドを使用して IP プロキシ ARP 機能をイネーブルにする必要があります。IP プロキシ ARP 機能は、デフォルトではディセーブルです。


) このコマンドは、レイヤ 3 ループバック インターフェイスには使用できません。


次に、ローカル プロキシ ARP をイネーブルにする例を示します。

switch(config)# interface ethernet 1/5
switch(config-if)# no switchport
switch(config-if)# ip arp local-proxy-arp
switch(config-if)#
 

 
関連コマンド

コマンド
説明

copy running-config startup-config

コンフィギュレーションをスタートアップ コンフィギュレーション ファイルに保存します。

ip proxy-arp

インターフェイス上でプロキシ ARP をイネーブルにします。

show ip arp

ARP 設定情報を表示します。

 

interface loopback

ループバック インターフェイスを作成して、インターフェイス コンフィギュレーション モードを開始するには、 interface loopback コマンドを使用します。ループバック インターフェイスを削除するには、このコマンドの no 形式を使用します。

interface loopback number

no interface loopback number

 
構文の説明

number

インターフェイス番号。有効な値は 0 ~ 1023 です。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

interface loopback コマンドは、ループバック インターフェイスを作成または変更するために使用します。

ループバック インターフェイス コンフィギュレーション モードからは、次のパラメータを使用できます。

description :インターフェイスの目的を説明します。

ip :インターフェイスの IP アドレス、アドレス解決プロトコル(ARP)属性、ロード バランシング、ユニキャスト リバース パス転送(RPF)、IP ソース ガードなどの IP 機能を設定します。

logging :イベントのロギングを設定します。

shutdown :インターフェイスでトラフィックをシャットダウンします。

このコマンドにライセンスは必要ありません。

次に、ループバック インターフェイスを作成する例を示します。

switch(config)# interface loopback 50
switch(config-if)# ip address 10.1.1.1/24
switch(config-if)#
 

 
関連コマンド

コマンド
説明

show interface loopback

指定されたループバック インターフェイスのトラフィックに関する情報を表示します。

 

interface port-channel

EtherChannel インターフェイスを作成して、インターフェイス コンフィギュレーション モードを開始するには、 interface port-channel コマンドを使用します。EtherChannel インターフェイスを削除するには、このコマンドの no 形式を使用します。

interface port-channel channel-number [. subintf-channel-no ]

no interface port-channel channel-number [. subintf-channel-no ]

 
構文の説明

channel-number

この EtherChannel 論理インターフェイスに割り当てられているチャネル番号。指定できる範囲は 1 ~ 4096 です。

.

(任意)サブインターフェイスの区切り文字を指定します。

(注) レイヤ 3 インターフェイスが対象となります。

subintf-channel-no

(任意)EtherChannel サブインターフェイスのポート番号。有効な範囲は 1 ~ 4093 です。

(注) レイヤ 3 インターフェイスが対象となります。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード
インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

5.0(3)N1(1)

レイヤ 3 インターフェイスおよびサブインターフェイスのサポートが追加されました。

 
使用上のガイドライン

ポートは、1 つのチャネル グループにだけ属すことができます。

レイヤ 2 インターフェイスに interface port-channel コマンドを使用する場合は、次のガイドラインに従ってください。

CDP を使用する場合は、EtherChannel インターフェイス上ではなく物理インターフェイス上でだけ設定します。

EtherChannel インターフェイス上にスタティック MAC アドレスを割り当てない場合は、MAC アドレスが自動的に割り当てられます。スタティック MAC アドレスを割り当て、後で削除した場合は、MAC アドレスが自動的に割り当てられます。

EtherChannel の MAC アドレスは、そのチャネル グループに追加された最初の動作ポートのアドレスです。この最初に追加されたポートがチャネルから削除されると、次に追加された動作ポート(存在する場合)の MAC アドレスになります。

EtherChannel インターフェイスをレイヤ 3 インターフェイスとして設定するには、インターフェイス コンフィギュレーション モードで no switchport コマンドを使用する必要があります。インターフェイスをレイヤ 3 インターフェイスとして設定すると、そのインターフェイスのすべてのレイヤ 2 固有のコンフィギュレーションが削除されます。

レイヤ 3 EtherChannel インターフェイスをレイヤ 2 インターフェイスに変換するには、 switchport コマンドを使用します。インターフェイスをレイヤ 2 インターフェイスとして設定すると、このインターフェイスのすべてのレイヤ 3 固有のコンフィギュレーションが削除されます。

ルーテッド インターフェイスで構成されるポート チャネルに 1 つまたは複数のサブインターフェイスを設定できます。

次に、チャネル グループ番号 50 を持つ EtherChannel グループ インターフェイスを作成する例を示します。

switch(config)# interface port-channel 50
switch(config-if)#
 

次に、チャネル グループ番号 10 のレイヤ 3 EtherChannel グループ インターフェイスを作成する例を示します。

switch(config)# interface port-channel 10
switch(config-if)# no switchport
switch(config-if)# ip address 192.0.2.1/24
switch(config-if)#
 

次に、インターフェイス コンフィギュレーション モードでチャネル グループ番号 1 のレイヤ 3 EtherChannel サブインターフェイスを設定する例を示します。

switch(config)# interface port-channel 10
switch(config-if)# no switchport
switch(config-if)# interface port-channel 10.1
switch(config-subif)# ip address 192.0.2.2/24
switch(config-subif)#
 

次に、グローバル コンフィギュレーション モードでチャネル グループ番号 20.1 のレイヤ 3 EtherChannel サブインターフェイスを設定する例を示します。

switch(config)# interface port-channel 20.1
switch(config-subif)# ip address 192.0.2.3/24
switch(config-subif)#
 

 
関連コマンド

コマンド
説明

encapsulation

(レイヤ 3 インターフェイス)インターフェイスのカプセル化タイプを設定します。

ip address

(レイヤ 3 インターフェイス)インターフェイスのプライマリ IP アドレスまたはセカンダリ IP アドレスを設定します。

no switchport

(レイヤ 3 インターフェイス)レイヤ 3 インターフェイスとしてインターフェイスを設定します。

show interface

インターフェイスに関する設定情報を表示します。

show lacp

LACP 情報を表示します。

show port-channel summary

EtherChannel に関する情報を表示します。

vtp(インターフェイス)

インターフェイスの VLAN トランキング プロトコル(VTP)をイネーブルにします。

 

ip port-unreachable

ICMP ポート到達不能メッセージの生成をイネーブルにするには、 ip port-unreachable コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

ip port-unreachable

no ip port-unreachable

 
構文の説明

このコマンドには引数またはキーワードはありません。

 
コマンド デフォルト

イネーブル

 
コマンド モード

インターフェイス コンフィギュレーション モード
サブインターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

ライセンスが必要です。

次に、必要に応じて、インターフェイス上で ICMP ポート到達不能メッセージの生成をイネーブルにする例を示します。

switch# configure terminal
switch(config)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# ip port-unreachable
 

 
関連コマンド

コマンド
説明

ip unreachables

ICMP 到達不能メッセージを送信します。

 

ip policy route-map

インターフェイスでのポリシー ルーティングに使用するルート マップを特定するには、 ip policy route-map コマンドを使用します。ルート マップを削除するには、このコマンドの no 形式を使用します。

ip policy route-map name

no ip policy route-map [ name ]

 
構文の説明

name

ルート マップ名。名前は、63 文字以下の任意の英数字文字列にできます。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

ポリシー ルーティングに使用するルート マップを特定するには、 ip policy route-map コマンドを使用します。ルート マップを作成するには、 route-map コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドでは、パケットの宛先 IP アドレスに基づいて、一致基準(そのインターフェイスにポリシー ルーティングが許可される条件)を指定します。 set コマンドでは、set 処理( match コマンドによる基準が満たされた場合に実行する特定のポリシー ルーティング処理)を指定します。 no ip policy route-map コマンドは、ルート マップへのポインタを削除します。

match ip address コマンドを使用し、拡張 IP アクセス リストを参照する場合、拡張 IP アクセス リストに定義可能なあらゆる一致基準でポリシーベース ルーティングを実行できます。

ip policy route-map コマンドを使用する前に、 feature pbr コマンドでポリシーベース ルーティングをイネーブルにする必要があります。


) このコマンドは、レイヤ 3 ループバック インターフェイスには使用できません。


このコマンドには、LAN Base Services ライセンスが必要です。

次に、インターフェイスにポリシーベース ルート マップを設定する例を示します。

switch# configure terminal
switch(config)# feature pbr
switch(config)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# ip policy route-map policymap
 

 
関連コマンド

コマンド
説明

no switchport

インターフェイスを、レイヤ 3 ルーテッド インターフェイスとして設定します。

route-map

ルート マップを作成します。

show ip policy

ルート ポリシー情報を表示します。

ip proxy-arp

インターフェイス上でプロキシ ARP をイネーブルにするには、 ip proxy-arp コマンドを使用します。インターフェイス上でプロキシ ARP をディセーブルにするには、このコマンドの no 形式を使用します。

ip proxy-arp

no ip proxy-arp

 
構文の説明

このコマンドには引数またはキーワードはありません。

 
コマンド デフォルト

ディセーブル

 
コマンド モード

インターフェイス コンフィギュレーション モード
サブインターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

ライセンスが必要です。

次に、プロキシ ARP をイネーブルにする例を示します。

switch(config)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# ip proxy-arp
switch(config-if)#
 

 
関連コマンド

コマンド
説明

copy running-config startup-config

コンフィギュレーションをスタートアップ コンフィギュレーション ファイルに保存します。

show ip arp

ARP 設定情報を表示します。

 

ip tcp path-mtu-discovery

IPv4 または IPv6 インターフェイス上のパス最大伝送単位(MTU)ディスカバリをイネーブルにするには、 ip tcp path-mtu discovery コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

ip tcp path-mtu discovery

no ip tcp path-mtu discovery

 
構文の説明

このコマンドには引数またはキーワードはありません。

 
コマンド デフォルト

ディセーブル

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドにライセンスは必要ありません。

次に、IPv4 と IPV6 の両方に対するパス MTU ディスカバリをイネーブルにする例を示します。

switch# configure terminal
switch(config)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# ip tcp path-mtu-discovery
switch(config-if)#

 
関連コマンド

コマンド
説明

show ip arp

ARP 設定情報を表示します。

 

ip tcp synwait-time

Cisco NX-OS ソフトウェアが TCP 接続の確立を試みながら、タイム アウトになるまで待機する時間を設定するには、 ip tcp synwait-time コマンドを使用します。デフォルトの時間に戻すには、このコマンドの no 形式を使用します。

ip tcp synwait-time seconds

no ip tcp synwait-time

 
構文の説明

seconds

TCP 接続の確立を試みながら待機する時間(秒数)。5 ~ 300 秒までの整数を指定できます。

 
コマンド デフォルト

5 秒

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドにライセンスは必要ありません。

次に、10 秒間 TCP 接続の確立を試み続けるようにスイッチ ソフトウェアを設定する例を示します。

switch# configure terminal
switch(config)# ip tcp synwait-time 10
Setting syn time to 10 seconds
switch(config)#
 

次に、インターフェイス上で TCP の同期をディセーブルにする例を示します。

switch# configure terminal
switch(config)# no ip tcp synwait-time
switch(config)#
 

 
関連コマンド

コマンド
説明

show running-config

実行システム コンフィギュレーション情報を表示します。

 

ip unreachables

ICMP 到達不能メッセージの生成をイネーブルにするには、 ip unreachables コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

ip unreachables

no ip unreachables

 
構文の説明

このコマンドには引数またはキーワードはありません。

 
コマンド デフォルト

イネーブル

 
コマンド モード

インターフェイス コンフィギュレーション モード
サブインターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

ライセンスが必要です。

次に、インターフェイス上で ICMP 到達不能メッセージの生成をイネーブルにする例を示します。

switch# configure terminal
switch(config)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# ip unreachables
 

 
関連コマンド

コマンド
説明

ip port-unreachable

ICMP ポート到達不能メッセージを送信します。

ipv6 nd

IPv6 ネイバー探索(ND)を設定するには、ipv6 nd コマンドを使用します。IPv6 ND 設定を削除するには、このコマンドの no 形式を使用します。

ipv6 nd {hop-limit hop-limit | managed-config-flag | mtu | ns-interval ns-interval | other-config-flag | prefix {A:B::C:D/LEN | default {0-4294967295 | infinite {infinite [no-autoconfig | no-onlink | off-link]}| no-advertise}} | ra-interval ra-interval | ra-lifetime ra-lifetime | reachable-time reachable-time | redirects | retrans-timer retrans-timer | suppress-ra [mtu]}

no ipv6 nd {hop-limit hop-limit | managed-config-flag | mtu mtu-size | ns-interval ns-interval | other-config-flag | prefix {A:B::C:D/LEN | default {0-4294967295 | infinite {infinite [no-autoconfig | no-onlink | off-link]}| no-advertise}} | ra-interval ra-interval | ra-lifetime ra-lifetime | reachable-time reachable-time | redirects | retrans-timer retrans-timer | suppress-ra [mtu]}

 
構文の説明

hop-limit

IPv6 ヘッダーにホップ リミットを指定します。

hop-limit

ホップ リミット 有効な範囲は 0 ~ 255 です。

managed-config-flag

アドレス情報を取得するためにホストがステートフル アドレス自動設定を使用するように通知します。

mtu

MTU のサイズを指定します。

mtu-size

MTU のサイズを指定します。範囲は 1280 ~ 65535 です。

ns-interval

ネイバー送信要求メッセージの送信間の再送信間隔を指定します。

ns-interval

ミリ秒単位の間隔です。範囲は 1000 ~ 3600000 です。

other-config-flag

非アドレス関連情報を取得するためにホストがステートフル自動設定を使用するように通知します。

prefix

ルータ アドバタイズメント メッセージでアドバタイズする IPv6 プレフィックスを指定します。

A:B::C:D/LEN

IPv6 アドレス プレフィックスを指定します。

default

プレフィックスのデフォルト パラメータを指定します。

0-4294967295

ライフタイムに有効な値。

infinite

無期限のライフタイムを指定します。

no-autoconfig

(任意)自動設定にプレフィックスを使用しないことを指定します。

no-onlink

(任意)オンリンク判別にプレフィックスを使用しないことを指定します。

off-link

プレフィックスが、オフリンクであることを示します。

no-advertise

プレフィックスをアドバタイズしないことを指定します。

ra-interval

ルータ アドバタイズメント メッセージの送信間の間隔を指定します。

ra-interval

ルータ アドバタイズメント メッセージ間隔。範囲は 4 ~ 1800 です。

ra-lifetime

デフォルト ルータのルータ ライフタイムを指定します。

ra-lifetime

ルータ アドバタイズメント メッセージのライフタイム。範囲は 4 ~ 1800 です。デフォルト ルータの値は 0 に設定できません。

reachable-time

ノードが到達可能性確認の受信後にネイバーがアップしていると見なす、アドバタイズされた時間を指定します。

reachable-time

到達可能時間。有効な範囲は 0~3600000 です。

redirects

ICMPv6 リダイレクト メッセージの送信をイネーブルにします。

retrans-timer

NS メッセージ間のアドバタイズされる時間を指定します。

retrans-timer

メッセージの間隔です。範囲は 0 ~ 4294967295 です。

suppress-ra

ルータ アドバタイズメント メッセージの送信をディセーブルにします。

 
デフォルト

hop-limit-64
mtu-1500
ns-interval-1000
ra-interval-600
reachable-time-0
retrans-timer-0

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)U3(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドにライセンスは必要ありません。

次に、IPv6 ネイバー探索を設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/5
switch(config-if)# ipv6 nd
switch(config-if)# ipv6 nd reachable time 30
 

次に、IPv6 ネイバー探索を削除する例を示します。

switch(config-if)# no ipv6 nd reachable time 30
switch(config-if)#

 
関連コマンド

コマンド
説明

show ipv6 nd interface

ネイバー探索インターフェイス情報を表示します。

ipv6 address

インターフェイスに IPv6 アドレスを設定するには、 ipv6 address コマンドを使用します。アドレスを削除するには、このコマンドの no 形式を使用します。

ipv6 address { addr [ eui64 ] [ route-preference preference ] [ secondary ] tag tag-id ] | use-link-local-only ]

no ipv6 address { addr [ eui64 ] [ route-preference preference ] [ secondary ] [ tag tag-id ] | use-link-local-only

 
構文の説明

addr

IPv6 アドレス。形式は A:B::C:D/length です。length の範囲は 1 ~ 128 です。

eui64

(任意)アドレスの下位 64 ビットに Extended Unique Identifier(EUI64)を設定します。

route-preference preference

(任意)ローカル ルートまたは直接ルートのルート プリファレンスを設定します。有効な範囲は 0 ~ 255 です。

secondary

(任意)セカンダリ IPv6 アドレスを作成します。

tag tag-id

(任意)ローカル ルートまたは直接ルートのルート タグ値を設定します。

use-link-local-only

単一のリンクローカルのみを使用しているインターフェイスに、IPv6 を指定します。

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

インターフェイスに IPv6 のアドレスまたはセカンダリ アドレスを設定するには、 ipv6 address コマンドを使用します。

このコマンドにライセンスは必要ありません。

次に、IPv6 アドレスを設定する例を示します。

switch# config t
switch(config)# interface ethernet 2/1
switch(config-if)# ipv6 address 2001:0DB8::3/48
 

 
関連コマンド

コマンド
説明

ip address

インターフェイスに IPv4 アドレスを設定します。

ipv6 host

DNS ホスト キャッシュ内でスタティック ホスト名/アドレス マッピングを定義するには、 ipv6 host コマンドを使用します。ホスト名/アドレス マッピングを削除するには、このコマンドの no 形式を使用します。

ipv6 host name address1 [ address2 ... address6 ]

no ipv6 host name address1 [ address2 ... address6 ]

 
構文の説明

name

ホスト名。 name は、大文字と小文字が区別される 80 文字以下の任意の英数字文字列にできます。

address1

A:B::C:D 形式の IPv6 アドレス。

address2 ... address6

(任意)A:B::C:D 形式の追加の IPv6 アドレス(最大 5 個)。

 
デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

ipv6 host コマンドは、スタティック ホスト名を DNS に追加するために使用します。

このコマンドにライセンスは必要ありません。

次に、スタティック ホスト名を設定する例を示します。

switch(config)# ipv6 host mycompany.com 2001:0DB8::4
 

 
関連コマンド

コマンド
説明

ip host

スタティック ホスト名を設定します。

ipv6 nd hop-limit

IPv6 ネイバー探索パケット内のホップ リミットをアドバタイズするには、 ipv6 nd hop-limit コマンドを使用します。デフォルトに戻すには、このコマンドの no 形式を使用します。

ipv6 nd hop-limit hop-limit

no ipv6 nd hop-limit [ hop-limit ]

 
構文の説明

hop-limit

IPv6 ヘッダー内のホップ リミット。有効な範囲は 0 ~ 255 です。

 
デフォルト

64

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドにライセンスは必要ありません。

次に、IPv6 ホップ リミットを設定する例を示します。

switch(config)# interface ethernet 2/1
switch(config-if)# ipv6 nd hop-limit 55

 

 
関連コマンド

コマンド
説明

show ipv6 nd interface

インターフェイスの IPv6 ネイバー探索情報を表示します。

ipv6 nd managed-config-flag

ステートフル アドレス自動設定を使用してアドレス情報を取得するように ICMPv6 Router-Advertisement メッセージ内でアドバタイズするには、 ipv6 nd managed-config-flag コマンドを使用します。デフォルトに戻すには、このコマンドの no 形式を使用します。

ipv6 nd managed-config-flag

no ipv6 nd managed-config-flag

 
構文の説明

このコマンドには、キーワードと引数はありません。

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドにライセンスは必要ありません。

次に、ステートフル アドレス自動設定を使用してアドレス情報を取得するように ICMPv6 Router-Advertisement メッセージ内でアドバタイズする例を示します。

switch(config)# interface ethernet 2/1
switch(config-if)# ipv6 nd managed-config-flag
 

 
関連コマンド

コマンド
説明

show ipv6 nd interface

インターフェイスの IPv6 ネイバー探索情報を表示します。

ipv6 nd mtu

このリンク上で ICMPv6 Router-Advertisement メッセージ内の最大伝送単位(MTU)をアドバタイズするには、 ipv6 nd mtu コマンドを使用します。デフォルトに戻すには、このコマンドの no 形式を使用します。

ipv6 nd mtu mtu

no ipv6 nd mtu [ mtu ]

 
構文の説明

mtu

バイト単位の MTU。範囲は 1280 ~ 65535 です。

 
デフォルト

1500

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドにライセンスは必要ありません。

次に、リンク上でアドバタイズする MTU 値を設定する例を示します。

switch(config)# interface ethernet 2/1
switch(config-if)# ipv6 nd mtu 1280
 

 
関連コマンド

コマンド
説明

show ipv6 nd interface

インターフェイスの IPv6 ネイバー探索情報を表示します。

ipv6 nd ns-interval

IPv6 Neighbor Solicitation(NS; ネイバー送信要求)メッセージ間の再送信インターバルを設定するには、 ipv6 nd ns-interval コマンドを使用します。デフォルトに戻すには、このコマンドの no 形式を使用します。

ipv6 nd ns-interval interval

no ipv6 nd ns-interval [ interval ]

 
構文の説明

interval

ミリ秒単位のインターバル。範囲は 1000 ~ 3600000 です。

 
デフォルト

1000

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドにライセンスは必要ありません。

次に、ネイバー送信要求インターバルを設定する例を示します。

switch(config)# interface ethernet 2/1
switch(config-if)# ipv6 nd ns-interval 1280
 
 

 
関連コマンド

コマンド
説明

show ipv6 nd interface

インターフェイスの IPv6 ネイバー探索情報を表示します。

ipv6 nd other-config-flag

ホストがステートフル自動設定を使用して非アドレス関連情報を取得するように ICMPv6 ルータ アドバタイズメント メッセージ内で指定するには、 ipv6 nd other-config-flag コマンドを使用します。デフォルトの設定に戻すには、このコマンドの no 形式を使用します。

ipv6 nd other-config-flag

no ipv6 nd other-config-flag

 
構文の説明

このコマンドには、キーワードと引数はありません。

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドにライセンスは必要ありません。

次に、ICMPv6 ルータ アドバタイズメント メッセージ内でステートフル自動設定を設定する例を示します。

switch(config)# interface ethernet 2/1
switch(config-if)# ipv6 nd other-config-flag
 

 
関連コマンド

コマンド
説明

show ipv6 nd interface

インターフェイスの IPv6 ネイバー探索情報を表示します。

ipv6 nd ra-interval

ICMPv6 ルータ アドバタイズメント メッセージの送信間のインターバルを設定するには、 ipv6 nd ra-interval コマンドを使用します。デフォルトに戻すには、このコマンドの no 形式を使用します。

ipv6 nd ra-interval interval

no ipv6 nd ra-interval [ interval ]

 
構文の説明

interval

ルータ アドバタイズメント メッセージの送信間のインターバル(秒単位)。範囲は 4 ~ 1800 です。

 
デフォルト

600

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドにライセンスは必要ありません。

次に、ICMPv6 ルータ アドバタイズメント メッセージ インターバルを設定する例を示します。

switch(config)# interface ethernet 2/1
switch(config-if)# ipv6 nd ra-interval 500
 

 
関連コマンド

コマンド
説明

show ipv6 nd interface

インターフェイスの IPv6 ネイバー探索情報を表示します。

ipv6 nd ra-lifetime

ICMPv6 ルータ アドバタイズメント メッセージ内でデフォルト ルータのライフタイムをアドバタイズするには、 ipv6 nd ra-lifetime コマンドを使用します。デフォルトの設定に戻すには、このコマンドの no 形式を使用します。

ipv6 nd ra-lifetime lifetime

no ipv6 nd ra-lifetime [ lifetime ]

 
構文の説明

lifetime

秒単位のライフタイム。範囲は 0 ~ 9000 です。0 の場合は、このルータがデフォルト ルータになりません。

 
デフォルト

ルータ アドバタイズメント インターバルの 3 倍。

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドにライセンスは必要ありません。

次に、ICMPv6 ルータ アドバタイズメント メッセージ ライフタイムを設定する例を示します。

switch(config)# interface ethernet 2/1
switch(config-if)# ipv6 nd ra-lifetime 1500
 

 
関連コマンド

コマンド
説明

show ipv6 nd interface

インターフェイスの IPv6 ネイバー探索情報を表示します。

ipv6 nd reachable-time

ICMPv6 ルータ アドバタイズメント メッセージ内の到達可能性確認の受信後にノードでネイバーがアップしたことを認識した時間をアドバタイズするには、 ipv6 nd reachable-time コマンドを使用します。デフォルトの設定に戻すには、このコマンドの no 形式を使用します。

ipv6 nd reachable-time time

no ipv6 nd reachable-time [ time ]

 
構文の説明

lifetime

秒単位のライフタイム。範囲は 0 ~ 9000 です。0 の場合は、このルータがデフォルト ルータになりません。

 
デフォルト

0

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドにライセンスは必要ありません。

次に、ICMPv6 ルータ アドバタイズメント到達可能性時間を設定する例を示します。

switch(config)# interface ethernet 2/1
switch(config-if)# ipv6 nd reachable-time 1500
 

 
関連コマンド

コマンド
説明

show ipv6 nd interface

インターフェイスの IPv6 ネイバー探索情報を表示します。

ipv6 nd redirects

ICMPv6 リダイレクト メッセージの送信をイネーブルにするには、 ipv6 redirects コマンドを使用します。デフォルトの設定に戻すには、このコマンドの no 形式を使用します。

ipv6 nd redirects

no ipv6 nd redirects

 
構文の説明

このコマンドには、キーワードと引数はありません。

 
デフォルト

ディセーブル

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドにライセンスは必要ありません。

次に、ICMPv6 ルータ アドバタイズメント メッセージをディセーブルにする例を示します。

switch(config)# interface ethernet 2/1
switch(config-if)# no ipv6 nd redirects
 

 
関連コマンド

コマンド
説明

show ipv6 nd interface

インターフェイスの IPv6 ネイバー探索情報を表示します。

ipv6 nd retrans-timer

ICMPv6 ルータ アドバタイズメント メッセージ内で Neighbor Solicitation(NS; ネイバー送信要求)間の時間をアドバタイズするには、 ipv6 nd retrans-timer コマンドを使用します。デフォルトの設定に戻すには、このコマンドの no 形式を使用します。

ipv6 nd retrans-timer time

no ipv6 nd retrans-timer [ time ]

 
構文の説明

lifetime

秒単位のライフタイム。範囲は 0 ~ 9000 です。0 の場合は、このルータがデフォルト ルータになりません。

 
デフォルト

0

 
コマンド モード

if-igp コンフィギュレーション (config-xxx)

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドにライセンスは必要ありません。

次に、ICMPv6 ルータ アドバタイズメント到達可能性時間を設定する例を示します。

switch(config)# interface ethernet 2/1
switch(config-if)# ipv6 nd retrans-timer
 

 
関連コマンド-

コマンド
説明

show ipv6 nd interface

インターフェイスの IPv6 ネイバー探索情報を表示します。

ipv6 nd suppress-ra

ICMPv6 ルータ アドバタイズメント メッセージの送信をディセーブルにするには、 ipv6 nd suppress-ra コマンドを使用します。デフォルトに戻すには、このコマンドの no 形式を使用します。

ipv6 nd suppress-ra

no ipv6 nd suppress-ra

 
構文の説明

このコマンドには、キーワードと引数はありません。

 
デフォルト

イネーブル

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドにライセンスは必要ありません。

次に、ICMPv6 ルータ アドバタイズメント メッセージをディセーブルにする例を示します。

switch(config)# interface ethernet 2/1
switch(config-if)# ipv6 nd suppress-ra
 

 
関連コマンド

コマンド
説明

show ipv6 nd interface

インターフェイスの IPv6 ネイバー探索情報を表示します。

ipv6 neighbor

IPv6 ネイバー探索キャッシュ内のスタティック エントリを設定するには、 ipv6 neighbor コマンドを使用します。IPv6 ネイバー探索キャッシュからスタティック IPv6 エントリを削除するには、このコマンドの no 形式を使用します。

ipv6 neighbor pv6-address interface-type interface-number hardware-address

no ipv6 neighbor ipv6-address interface-type interface-number hardware-address

 
構文の説明

ipv6-address

ローカル データリンク アドレスに対応する IPv6 アドレス。

この引数は、RFC 2373 に記述されている形式にする必要があります。コロン区切りの 16 ビット値を使用して、アドレスを 16 進数で指定します。

interface-type

インターフェイス タイプ。サポートされているインターフェイス タイプについては、疑問符(?)オンライン ヘルプ機能を使用してください。

interface-number

インターフェイス番号を指定します。

hardware-address

ローカル データリンク アドレス(48 ビット アドレス)。

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

ipv6 neighbor コマンドは、スタティック エントリを作成するために使用します。IPv6 ネイバー探索プロセスによる学習を通して、指定された IPv6 アドレスのエントリがネイバー探索キャッシュにすでに存在する場合、エントリは自動的にスタティック エントリに変換されます。

show ipv6 neighbors コマンドは、IPv6 ネイバー探索キャッシュ内のスタティック エントリを表示するために使用します。IPv6 ネイバー探索キャッシュ内のスタティック エントリは次のいずれかの状態になります。

INCMP(不完全):このエントリのインターフェイスがダウンしています。

REACH(到達可能):このエントリのインターフェイスがアップしています。


) 到達可能性検出は、IPv6 ネイバー探索キャッシュ内のスタティック エントリに適用されません。そのため、INCMP および REACH 状態に関する説明とダイナミックおよびスタティック キャッシュ エントリに関する説明は一致しません。ダイナミック キャッシュ エントリの INCMP および REACH 状態の説明については、show ipv6 neighbors コマンドを参照してください。


clear ipv6 neighbors コマンドは、スタティック エントリを除いて、IPv6 ネイバー探索キャッシュ内のすべてのエントリを削除します。 no ipv6 neighbor コマンドは、指定されたスタティック エントリをネイバー探索キャッシュから削除します。このコマンドは、IPv6 ネイバー探索プロセスから取得されたダイナミック エントリをキャッシュから削除しません。 no ipv6 enable コマンドまたは no ipv6 unnumbered コマンドを使用してインターフェイス上の IPv6 をディセーブルにすると、スタティック エントリ(INCMP に対するエントリ変更のステート)を除いて、そのインターフェイスに設定されたすべての IPv6 ネイバー探索キャッシュ エントリが削除されます。

IPv6 ネイバー探索キャッシュ内のスタティック エントリがネイバー探索プロセスによって変更されることはありません。

次の例では、イーサネット インターフェイス 2/1 上の IPv6 アドレスが 2001:0DB8::45A で、リンク層アドレスが 0002.7D1A.9472 のネイバーに関する IPv6 ネイバー探索キャッシュ内のスタティック エントリを設定します。

switch(config)# interface ethernet 2/1
switch(config-if)# ipv6 neighbor 2001:0DB8::45A ethernet 2/10002.7D1A.9472

ipv6 unreachables

ICMPv6 到達不能メッセージの送信をイネーブルにするには、 ipv6 unreachables コマンドを使用します。デフォルトに戻すには、このコマンドの no 形式を使用します。

ipv6 [ icmp ] unreachables

no ipv6 [ icmp ] unreachables

 
構文の説明

icmp

(任意)ICMPv6 コマンド。

 
デフォルト

ディセーブル

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

ポート到達不能メッセージは、常に、レート リミットがイネーブルになっています。

このコマンドにライセンスは必要ありません。

次に、ICMPv6 到達不能メッセージをイネーブルにする例を示します。

switch(config)# interface ethernet 2/1
switch(config-if)# ipv6 unreachables
 

 
関連コマンド

コマンド
説明

show ipv6 nd interface

インターフェイスの IPv6 ネイバー探索情報を表示します。

ipv6 policy route-map

インターフェイス上のポリシー ルーティングに使用されるルート マップを特定するには、 ipv6 policy route-map コマンドを使用します。ルート マップを削除するには、このコマンドの no 形式を使用します。

ipv6 policy route-map name

no ipv6 policy route-map [ name ]

 
構文の説明

name

ルート マップ名。名前は、63 文字以下の任意の英数字文字列にできます。

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

iv6 policy route-map コマンドは、IPv6 インターフェイス上でポリシー ルーティングを使用するためのルート マップを特定するために使用します。ルート マップを作成するには、 route-map コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、パケットの宛先 IPv6 アドレスに基づいて、一致基準(インターフェイスに対してポリシー ルーティングが許可される条件)を指定します。 set コマンドでは、set 処理( match コマンドによる基準が満たされた場合に実行する特定のポリシー ルーティング処理)を指定します。 no ipv6 policy route-map コマンドは、ルート マップへのポインタを削除します。

match ipv6 address コマンドを使用し、IPv6 アクセス リストを参照している場合は、IPv6 アクセス リスト内で定義可能な任意の一致基準でポリシーベース ルーティングを実行できます。

ipv6 policy route-map コマンドを使用する前に、 feature pbr コマンドでポリシーベース ルーティングをイネーブルにする必要があります。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、インターフェイスにポリシーベース ルート マップを設定する例を示します。

switch# configure terminal
switch(config)# feature pbr
switch(config)# interface ethernet 2/1
switch(config-if)# ipv6 policy route-map policymap
 
 

 
関連コマンド

コマンド
説明

feature pbr

ポリシーベース ルーティング機能をイネーブルにします。

route-map

ルート マップを作成します。

show route-map pbr-statistics

ポリシーベース ルート マップについての統計情報を表示します。

show ipv6 policy

IPv6 ポリシーに関する情報を表示します。