Cisco Nexus 5000 シリーズ NX-OS ユニキャスト ルーティング コマンド リファレンス
R コマンド
R コマンド
発行日;2013/04/23 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

R コマンド

redistribute(EIGRP)

redistribute maximum-prefix(EIGRP)

restart eigrp(EIGRP)

router eigrp

router-id(EIGRP)

R コマンド

この章では、R で始まる Cisco NX-OS Enhanced Interior Gateway Routing Protocol(EIGRP)コマンドについて説明します。

redistribute(EIGRP)

1 つのルーティング ドメインからのルートを Enhanced IGRP(EIGRP)に注入するには、 redistribute コマンドを使用します。コンフィギュレーション ファイルから redistribute コマンドを削除し、ルートの再配布をしないデフォルトの状態にシステムを戻すには、このコマンドの no 形式を使用します。

redistribute { bgp as-number | direct | eigrp id | ospf instance-tag | rip instance-tag | static } [ route-map map-name ]

no redistribute { bgp as-number | direct | eigrp as-number | ospf instance-tag | rip instance-tag | static }

 
構文の説明

bgp as-number

ボーダー ゲートウェイ プロトコル(BGP)からのルートを配布します。 as-number は、2 バイトまたは 4 バイトの自律システム番号です。2 バイト番号の範囲は 1 ~ 65535 です。4 バイト番号の範囲は 1.0 ~ 65535.65535 です。

direct

インターフェイス上の直接接続されているルートを配布します。

eigrp id

EIGRP インスタンスの名前を指定します。 id には、大文字と小文字が区別される最大 20 文字の任意の英数字文字列を指定できます。

ospf instance-tag

OSPF プロトコルからのルートを配布します。このプロトコルは IPv4 アドレス ファミリでサポートされています。 instance-tag には、最大 20 文字の英数字を指定できます。

rip instance-tag

RIP プロトコルからのルートを配布します。 instance-tag には、最大 20 文字の英数字を指定できます。

static

IP スタティック ルートを再配布します。

route-map map-name

(任意)設定したルート マップの識別情報を指定します。ルート マップを使用して、EIGRP に再配布するルートをフィルタリングします。

 
コマンド デフォルト

ディセーブル

 
コマンド モード

アドレス ファミリ コンフィギュレーション モード
ルータ コンフィギュレーション モード
ルータ VRF コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

他のルーティング プロトコルからのルートを EIGRP にインポートするには、 redistribute コマンドを使用します。これらのルートのフィルタリングには必ずルート マップを使用して、意図した再配布のルートのみ EIGRP から再配布されるようにしてください。

他のプロトコルからのルートを EIGRP に再配布するには、デフォルト メトリックを設定する必要があります。デフォルト メトリックは、 default-metric コマンドを使用して設定するか、 redistribute コマンドで設定したルート マップを使用して設定できます。

このコマンドには、LAN Base Services ライセンスが必要です。

次に、BGP ルートを EIGRP 自律システムに再配布する例を示します。

switch(config)# router eigrp 209
switch(config-router) address-family ipv4 unicast
switch(config-router-af)# redistribute bgp 64496
switch(config-router-af)
 

 
関連コマンド

コマンド
説明

default-metric(EIGRP)

EIGRP に再配布されるルートのデフォルト メトリックを設定します。

show ip eigrp

EIGRP 情報を表示します。

redistribute maximum-prefix(EIGRP)

EIGRP に再配布されるルートの数を制限するには、 redistribute maximum-prefix コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

redistribute maximum-prefix max [ threshold ] [ warning-only | withdraw [ num-retries timeout ]]

no redistribute maximum-prefix max [ threshold ] [ warning-only | withdraw [ num-retries timeout ]

 
構文の説明

max

EIGRP が配布するプレフィックスの最大数。指定できる範囲は 0 ~ 65536 です。

threshold

(任意)警告メッセージをトリガーする最大プレフィックス数のパーセンテージ。範囲は 1 ~ 100 です。デフォルトは 75% です。

warning-only

(任意)プレフィックスの最大数を超えた場合に警告メッセージを記録します。

widthdraw

(任意)再配布されたすべてのルートを取り消します。

num-retries

(任意)EIGRP が再配布されたルートの取得を試みる回数。範囲は 1 ~ 12 です。デフォルトは 1 です。

timeout

(任意)再試行のインターバル。値の範囲は 60 ~ 600 秒です。デフォルト値は 300 です。

 
コマンド デフォルト

制限なし

 
コマンド モード

ルータ コンフィギュレーション モード
VRF コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

redistribute maximim-prefix コマンドは、EIGRP に再配布されるルートの数を制限するために使用します。 clear ip eigrp redistribute コマンドは、すべてのルートが取り消された場合に使用します。

次に、EIGRP に再配布されるルートの数を制限する例を示します。

switch# configure terminal

switch(config)# router eigrp 201

switch(config-router)# address-family ipv4 unicast

switch(config-router-af)# redistribute bgp route-map FilterExternalBGP

switch(config-router-af)# redistribute maximum-prefix 1000 75

switch(config-router-af)#

 
関連コマンド

コマンド
説明

copy running-config startup-config

コンフィギュレーションの変更をスタートアップ コンフィギュレーション ファイルに保存します。

feature eigrp

EIGRP 機能をイネーブルにします。

redistribute(EIGRP)

EIGRP のルート再配布を設定します。

show running-config eigrp

EIGRP の実行コンフィギュレーションを表示します。

 

restart eigrp(EIGRP)

Enhanced Interior Gateway Routing Protocol(EIGRP)インスタンスを再起動し、関連付けられたすべてのネイバーを削除するには、 restart コマンドを使用します。

restart eigrp instance-tag

 
構文の説明

instance-tag

EIGRP ルーティング インスタンスの名前。この名前には、最大 20 文字の英数字を指定できます。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、LAN Base Services ライセンスが必要です。

次に、OSPFv2 インスタンスを再起動し、すべてのネイバーを削除する例を示します。

switch# configure terminal
switch(config)# restart eigrp Test1
switch(config)#
 

 
関連コマンド

コマンド
説明

copy running-config startup-config

コンフィギュレーションをスタートアップ コンフィギュレーション ファイルに保存します。

show ip eigrp interfaces

EIGRP インターフェイスに関する情報を表示します。

 

router eigrp

Enhanced IGRP(EIGRP)のルーティング プロセスを設定し、ルータ コンフィギュレーション モードを開始するには、 router eigrp コマンドを使用します。EIGRP ルーティング プロセスをオフにするには、このコマンドの no 形式を使用します。

router eigrp instance-tag

no router eigrp instance-tag

 
構文の説明

instance-tag

EIGRP インスタンスの名前。 instance-tag には最大 20 文字の英数字文字列を指定します。大文字と小文字は区別されます。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、LAN Base Services ライセンスが必要です。

次に、EIGRP のルーティング プロセスを設定する例を示します。

switch(config)# router eigrp 1
switch(config-router)#

 
関連コマンド

コマンド
説明

default-information

デフォルト ルートの配布を制御します。

default-metric

EIGRP に再配布されるルートのデフォルト メトリックを設定します。

distance

アドミニストレーティブ ディスタンスを設定します。

maximum-paths

等コスト パスの最大数を設定します。

redistribute

EIGRP のルート再配布を設定します。

router-id

ルータ ID を設定します。

timers

EIGRP タイマーを設定します。

router-id(EIGRP)

Enhanced IGRP(EIGRP)プロセスのルータ ID を設定するには、 router-id コマンドを使用します。デフォルトの方法でルータ ID を決定するには、このコマンドの no 形式を使用します。

router-id router-id

no router-id

 
構文の説明

router-id

4 分割のドット付き 10 進表記で指定した 32 ビット ルータ ID

 
コマンド デフォルト

このコマンドが設定されていない場合、EIGRP はルータのいずれかのインターフェイスの IPv4 アドレスをルータ ID として選択します。

 
コマンド モード

アドレス ファミリ コンフィギュレーション モード
ルータ コンフィギュレーション モード
ルータ VRF コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

router-id コマンドは、ルータ ID の一意の 32 ビット数値を指定するために使用します。この処理によって、インターフェイス アドレスの設定に関係なく、EIGRP が機能することが保証されます。

このコマンドには、LAN Base Services ライセンスが必要です。

次に、EIGRP プロセス 1 に 192.0.2.1 の IP アドレスを割り当てる例を示します。

switch(config)# router eigrp 1
switch(config-router) address-family ipv4
switch(config-router-af)# router-id 192.0.2.1
 

 
関連コマンド

コマンド
説明

show ip eigrp

EIGRP プロセスの要約を表示します。