Cisco Nexus 5000 シリーズ NX-OS ユニキャスト ルーティング コマンド リファレンス
I コマンド
I コマンド
発行日;2013/04/23 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

I コマンド

ip authentication key-chain eigrp

ip authentication mode eigrp

ip bandwidth eigrp

ip bandwidth-percent eigrp

ip delay eigrp

ip distribute-list eigrp

ip eigrp shutdown

ip hello-interval eigrp

ip hold-time eigrp

ip next-hop-self eigrp

ip offset-list eigrp

ip passive-interface eigrp

ip route

ipv6 route

ip router eigrp

ip split-horizon eigrp

ip summary-address eigrp

ipv6 authentication key-chain eigrp

ipv6 authentication mode eigrp

ipv6 bandwidth eigrp

ipv6 bandwidth-percent eigrp

ipv6 delay eigrp

ipv6 distribute-list eigrp

ipv6 eigrp shutdown

ipv6 hello-interval eigrp

ipv6 hold-time eigrp

ipv6 next-hop-self eigrp

ipv6 offset-list eigrp

ipv6 passive-interface eigrp

ipv6 router eigrp

ipv6 split-horizon eigrp

ipv6 summary-address eigrp

I コマンド

この章では、I で始まる Cisco NX-OS Enhanced Interior Gateway Routing Protocol(EIGRP)コマンドについて説明します。

ip authentication key-chain eigrp

Enhanced Interior Gateway Routing Protocol(EIGRP)パケットの認証をイネーブルにして、インターフェイス上で使用可能なキー セットを指定するには、 ip authentication key-chain eigrp コマンドを使用します。認証を禁止するには、このコマンドの no 形式を使用します。

ip authentication key-chain eigrp instance-tag name-of-chain

no ip authentication key-chain eigrp instance-tag name-of-chain

 
構文の説明

instance-tag

EIGRP インスタンスの名前。 instance-tag には最大 20 文字の英数字文字列を指定します。大文字と小文字は区別されます。

name-of-chain

有効なキー グループ

 
コマンド デフォルト

EIGRP パケットには認証は適用されません。

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

インターフェイス コンフィギュレーション モードで ip authentication mode eigrp コマンドを使用して、認証モードを設定する必要があります。インターフェイスに対する認証設定を完了するには、 key-chain コマンドを使用して、別途キー チェーンを設定する必要があります。

このコマンドには、LAN Base Services ライセンスが必要です。

次に、キーチェーン ツリーに属しているキーの受け入れと送信をインターフェイスに設定する例を示します。

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 1/2
switch(config-if)# no switchport
switch(config-if)# ip authentication key-chain eigrp 209 trees
switch(config-if)#
 

 
関連コマンド

コマンド
説明

ip authentication mode eigrp

インターフェイスに EIGRP の認証モードを設定します。

key-chain

認証方式で使用可能なキー セットを作成します。

show ip eigrp interfaces

EIGRP インターフェイスに関する情報を表示します。

 

ip authentication mode eigrp

EIGRP パケット内で使用される認証タイプを指定するには、 ip authentication mode eigrp コマンドを使用します。認証を削除するには、このコマンドの no 形式を使用します。

ip authentication mode eigrp instance-tag md5

no ip authentication mode eigrp instance-tag md5

 
構文の説明

instance-tag

EIGRP インスタンスの名前。 instance-tag には最大 20 文字の英数字文字列を指定します。大文字と小文字は区別されます。

md5

Message Digest 5(MD5)認証を指定します。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドには、LAN Base Services ライセンスが必要です。

次に、MD5 認証を使用するようにインターフェイスを設定する例を示します。

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 1/2
switch(config-if)# no switchport
switch(config-if)# ip authentication mode eigrp 209 md5
switch(config-if)#
 

 
関連コマンド

コマンド
説明

authentication mode(EIGRP)

VRF の EIGRP の認証モードを設定します。

copy running-config startup-config

コンフィギュレーションの変更をスタートアップ コンフィギュレーション ファイルにコピーします。

ip authentication key-chain eigrp

EIGRP の認証をイネーブルにして、インターフェイスに使用可能なキー セットを指定します。

key chain

認証方式で使用可能なキー セットを作成します。

show ip eigrp interfaces

EIGRP インターフェイスに関する情報を表示します。

 

ip bandwidth eigrp

Enhanced Interior Gateway Routing Protocol(EIGRP)インターフェイスの帯域幅を設定するには、 ip bandwidth eigrp コマンドを使用します。デフォルトに戻す場合は、このコマンドの no 形式を入力します。

ip bandwidth eigrp instance-tag bandwidth

no ip bandwidth eigrp

 
構文の説明

instance-tag

EIGRP インスタンスの名前。 instance-tag には最大 20 文字の英数字文字列を指定します。大文字と小文字は区別されます。

bandwidth

帯域幅値。範囲は 1 ~ 2,560,000,000 キロビットです。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドには、LAN Base Services ライセンスが必要です。

次に、自律システム 209 で 10000 の帯域幅メトリックを使用するように EIGRP を設定する例を示します。

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# ip bandwidth eigrp 209 10000
 

 
関連コマンド

コマンド
説明

ip bandwidth-percent eigrp

インターフェイスの帯域幅のうち、EIGRP に使用できる割合をパーセントで設定します。

show ip eigrp

EIGRP 情報を表示します。

ip bandwidth-percent eigrp

インターフェイス上で Enhanced Interior Gateway Routing Protocol(EIGRP)に使用できる帯域幅のパーセンテージを設定するには、 ip bandwidth eigrp コマンドを使用します。デフォルトに戻す場合は、このコマンドの no 形式を入力します。

ip bandwidth-percent eigrp instance-tag percent

no ip bandwidth-percent eigrp

 
構文の説明

instance-tag

EIGRP インスタンスの名前。 instance-tag には最大 20 文字の英数字文字列を指定します。大文字と小文字は区別されます。

percent

EIGRP に使用できる帯域幅のパーセンテージ

 
コマンド デフォルト

percent :50

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

EIGRP が使用する帯域幅は、リンクの帯域幅の最大 50 %です。このパーセンテージは、 ip bandwidth インターフェイス コンフィギュレーション コマンドで定義されます。このデフォルトのパーセンテージを変更するには、 ip bandwidth-percent コマンドを使用します。

このコマンドには、LAN Base Services ライセンスが必要です。

次に、自律システム 209 でインターフェイスの最大 75 % を使用するように EIGRP を設定する例を示します。

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# ip bandwidth-percent eigrp 209 75
switch(config-if)#

 
関連コマンド

コマンド
説明

ip bandwidth eigrp

インターフェイスの EIGRP 帯域幅値を設定します。

show ip eigrp

EIGRP 情報を表示します。

 

ip delay eigrp

インターフェイスでの Enhanced Interior Gateway Routing Protocol(EIGRP)のスループット遅延を設定するには、 ip delay eigrp コマンドを使用します。デフォルトに戻す場合は、このコマンドの no 形式を入力します。

ip delay eigrp instance-tag seconds

no ip delay eigrp instance-tag

 
構文の説明

instance-tag

EIGRP インスタンスの名前。 instance-tag には最大 20 文字の英数字文字列を指定します。大文字と小文字は区別されます。

seconds

スループット遅延(10 マイクロ秒)。範囲は 1 ~ 16777215 です。

 
コマンド デフォルト

100(10 マイクロ秒単位)

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

10 マイクロ秒単位でインターフェイスにスループット遅延を設定します。たとえば、 ip delay eigrp コマンドを 100 に設定すると、スループット遅延は 1000 マイクロ秒になります。

このコマンドには、LAN Base Services ライセンスが必要です。

次に、インターフェイスの遅延を 400 マイクロ秒に設定する例を示します。

switch(config)# router eigrp 1
switch(config-router)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# ip delay eigrp 1 40
 

 
関連コマンド

コマンド
説明

ip hello-interval eigrp

自律システム番号で指定される EIGRP ルーティング プロセスに対するインターフェイスの hello インターバルを設定します。

show ip eigrp

EIGRP 情報を表示します。

ip distribute-list eigrp

インターフェイスでの Enhanced Interior Gateway Routing Protocol(EIGRP)の配布リストを設定するには、 ip distribute-list eigrp コマンドを使用します。デフォルトに戻す場合は、このコマンドの no 形式を入力します。

ip distribute-list eigrp instance-tag { prefix-list list-name | route-map map-name } { in | out }

no ip distribute-list eigrp instance-tag { prefix-list list-name | route-map map-name } { in | out }

 
構文の説明

instance-tag

EIGRP インスタンスの名前。 instance-tag には最大 20 文字の英数字文字列を指定します。大文字と小文字は区別されます。

prefix-list list-name

EIGRP ルートのフィルタリングに使用する IP プレフィックス リストの名前を指定します。

route-map map-name

EIGRP ルートのフィルタリングに使用するルート マップの名前を指定します。

in

着信ルートにルート ポリシーを適用します。

out

発信ルートにルート ポリシーを適用します。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

インターフェイスに対するルート フィルタ ポリシーを設定するには、 ip distribute-list eigrp コマンドを使用します。この設定を完了するためには、ルート マップまたはプレフィックス リストの名前を設定する必要があります。

このコマンドには、LAN Base Services ライセンスが必要です。

インターフェイスに着信するすべての EIGRP ルートのルート マップを設定する例を示します。

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# ip distribute-list eigrp 209 route-map InputFilter in
switch(config-if)#
 

 
関連コマンド

コマンド
説明

prefix-list

プレフィックス リストを設定します。

route-map

ルート マップを設定します。

show ip eigrp

EIGRP 情報を表示します。

 

ip eigrp shutdown

インターフェイスの Enhanced Interior Gateway Routing Protocol(EIGRP)をシャットダウンするには、 ip eigrp shutdown コマンドを使用します。デフォルトに戻す場合は、このコマンドの no 形式を入力します。

ip eigrp instance-tag shutdown

no ip eigrp instance-tag shutdown

 
構文の説明

instance-tag

EIGRP インスタンスの名前。 instance-tag には最大 20 文字の英数字文字列を指定します。大文字と小文字は区別されます。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

ip eigrp shutdown コマンドは、保守のために、EIGRP 用のインターフェイスをシャットダウンして、インターフェイスに対する EIGRP 隣接関係を禁止します。このインターフェイスのネットワーク アドレスが EIGRP トポロジ テーブルに表示されなくなります。

ip passive-interface eigrp コマンドは、EIGRP の隣接関係を禁止しますが、トポロジ テーブル内のネットワーク アドレスを維持するために使用します。

このコマンドには、LAN Base Services ライセンスが必要です。

次に、インターフェイス上で EIGRP をディセーブルにする例を示します。

switch(config)# router eigrp 201
switch(config-router)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# ip eigrp 201 shutdown

 
関連コマンド

コマンド
説明

ip passive-interface eigrp

EIGRP のインスタンスを設定します。

router eigrp

EIGRP のインスタンスを設定します。

ip hello-interval eigrp

インターフェイスの EIGRP hello インターバルを設定するには、 ip hello-interval eigrp コマンドを使用します。デフォルトに戻す場合は、このコマンドの no 形式を入力します。

ip hello-interval eigrp instance-tag seconds

no ip hello-interval eigrp instance-tag

 
構文の説明

instance-tag

EIGRP インスタンスの名前。 instance-tag には最大 20 文字の英数字文字列を指定します。大文字と小文字は区別されます。

seconds

hello インターバル(秒単位)。有効な範囲は 1 ~ 65535 です。

 
コマンド デフォルト

5 秒

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドには、LAN Base Services ライセンスが必要です。

次に、インターフェイスの hello 間隔を 10 秒に設定する例を示します。

switch(config)# router eigrp 1
switch(config-router)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# ip hello-interval eigrp 1 10
switch(config-if)#
 

 
関連コマンド

コマンド
説明

copy running-config startup-config

コンフィギュレーションの変更をスタートアップ コンフィギュレーション ファイルに保存します。

show ip eigrp

EIGRP 情報を表示します。

ip hold-time eigrp

EIGRP インターフェイスのホールド時間を設定するには、 ip hold-time eigrp コマンドを使用します。デフォルトに戻す場合は、このコマンドの no 形式を入力します。

ip hold-time eigrp instance-tag seconds

no ip hold-time eigrp instance-tag

 
構文の説明

instance-tag

EIGRP インスタンスの名前。 instance-tag には最大 20 文字の英数字文字列を指定します。大文字と小文字は区別されます。

seconds

ホールド時間(秒単位)。有効な範囲は 1 ~ 65535 です。

 
コマンド デフォルト

15 秒

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

ip hold-time eigrp コマンドは、非常に輻輳した大規模ネットワーク上のデフォルト保持時間を増加するために使用します。

ホールド時間は、hello インターバルの 3 倍以上の値に設定することを推奨します。指定されたホールド時間内にルータが hello パケットを受信しなかった場合は、そのルータ経由のルートが使用できないと判断されます。

ホールド タイムを増やすと、ネットワーク全体のルート収束が遅くなります。

このコマンドには、LAN Base Services ライセンスが必要です。

次に、インターフェイスの保持時間を 40 秒に設定する例を示します。

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# ip hold-time eigrp 209 40
 

 
関連コマンド

コマンド
説明

copy running-config startup-config

コンフィギュレーションの変更をスタートアップ コンフィギュレーション ファイルに保存します。

ip hello-interval eigrp

自律システム番号で指定された EIGRP ルーティング プロセス用のインターフェイス上の hello インターバルを設定します。

show ip eigrp

EIGRP 情報を表示します。

 

ip next-hop-self eigrp

ルートのアドバタイズ時にネクストホップ アドレスとしてローカル IP アドレスを使用するように Enhanced Interior Gateway Routing Protocol(EIGRP)プロセスに指示するには、ip next-hop-self eigrp コマンドを使用します。受信したネクストホップ値を使用するには、このコマンドの no 形式を使用します。

ip next-hop-self eigrp instance-tag

no ip next-hop-self eigrp instance-tag

 
構文の説明

instance-tag

EIGRP インスタンスの名前。 instance-tag には最大 20 文字の英数字文字列を指定します。大文字と小文字は区別されます。

 
コマンド デフォルト

EIGRP は常に、IP ネクストホップ値を自身に設定します。

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

デフォルトの設定では、EIGRP は、ルータがルートを学習したインターフェイスと同じインターフェイス上でルートをアドバタイズする場合も、アドバタイズするルートの IP ネクストホップ値としてそれ自身を設定します。このデフォルト設定を変更するには、 no ip next-hop-self eigrp コマンドを使用して、これらのルートのアドバタイズ時に受信したネクスト ホップ値を使用するように EIGRP に指示する必要があります。

デフォルトの IP ネクスト ホップ値を変更し、受信したネクスト ホップ値を使用するように EIGRP に指示する例を示します。

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# no ip next-hop-self eigrp 209
 

 
関連コマンド

コマンド
説明

copy running-config startup-config

コンフィギュレーションの変更をスタートアップ コンフィギュレーション ファイルに保存します。

show ip eigrp

EIGRP 情報を表示します。

 

ip offset-list eigrp

インターフェイスでの Enhanced Interior Gateway Routing Protocol(EIGRP)のオフセット リストを設定するには、 ip offset-list eigrp コマンドを使用します。デフォルトに戻す場合は、このコマンドの no 形式を入力します。

ip offset-list eigrp instance-tag { prefix-list list-name | route-map map-name } { in | out } offset

no ip offset-list eigrp instance-tag { prefix-list list-name | route-map map-name } { in | out } offset

 
構文の説明

instance-tag

EIGRP インスタンスの名前。 instance-tag には最大 20 文字の英数字文字列を指定します。大文字と小文字は区別されます。

prefix-list list-name

EIGRP ルートのフィルタリングに使用する IP プレフィックス リストの名前を指定します。

route-map map-name

EIGRP ルートのフィルタリングに使用するルート マップの名前を指定します。

in

着信ルートにルート ポリシーを適用します。

out

発信ルートにルート ポリシーを適用します。

offset

EIGRP メトリックに追加する値 範囲は 0 ~ 2147483647 です。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

Cisco NX-OS は、指定されたプレフィックス リストまたはルート マップと一致するすべてのルートに、設定されたオフセット値を追加します。この設定を完了するためには、ルート マップまたはプレフィックス リストの名前を設定する必要があります。

このコマンドには、LAN Base Services ライセンスが必要です。

次に、ルート マップ OffsetFilter と一致するインターフェイスに着信する EIGRP ルートのメトリックに 20 を追加するようにオフセット リスト フィルタを設定する例を示します。

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# ip offset-list eigrp 209 route-map OffsetFilter in 20
switch(config-if)#

 
関連コマンド

コマンド
説明

prefix-list

プレフィックス リストを設定します。

route-map

ルート マップを設定します。

show ip eigrp

EIGRP 情報を表示します。

 

ip passive-interface eigrp

Enhanced Interior Gateway Routing Protocol(EIGRP)インターフェイスのすべてのルーティング アップデートを停止するには、 ip passive-interface eigrp コマンドを使用します。ルーティング アップデートの送信を再度イネーブルにするには、このコマンドの no 形式を使用します。

ip passive-interface eigrp instance-tag

no ip passive-interface eigrp instance-tag

 
構文の説明

instance-tag

EIGRP インスタンスの名前。名前には、大文字と小文字が区別される最大 20 文字の任意の英数字文字列を指定できます。

 
コマンド デフォルト

インターフェイス上でルーティング アップデートが送信されます。

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

ip passive-interface eigrp コマンドは、インターフェイス上のすべてのルーティング更新を停止し、EIGRP 隣接関係の形成を抑制するために使用します。インターフェイスのネットワーク アドレスは、EIGRP トポロジ テーブル内に残ります。

このコマンドには、LAN Base Services ライセンスが必要です。

次に、イーサネット 2/1 上の EIGRP ルーティング アップデートを停止する例を示します。

switch(config)# router eigrp 201
switch(config-router)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# ip passive-interface eigrp 201
switch(config-if)#
 

 
関連コマンド

コマンド
説明

copy running-config startup-config

コンフィギュレーションをスタートアップ コンフィギュレーション ファイルに保存します。

no switchport

インターフェイスを、レイヤ 3 ルーテッド インターフェイスとして設定します。

show ip eigrp interfaces

EIGRP インターフェイスに関する情報を表示します。

 

ip route

スタティック ルートを設定するには、 ip route コマンドを使用します。スタティック ルートを削除するには、このコマンドの no 形式を使用します。

ip route ip-prefix / mask {[ interface ] next-hop } [ preference ] [ tag id ]

no ip route ip-prefix / mask {[ interface ] next-hop } [ preference ] [ tag id ]

 
構文の説明

ip-prefix / mask

IP プレフィックスおよびプレフィックス マスク。形式は x.x.x.x/length です。length は 1 ~ 32 です。

interface

(任意)このルートに到達するためにすべてのパケットが送信されるインターフェイス。 ? を使用してサポートされているインターフェイスのリストを表示します。

next-hop

ネットワークに到達するために使用可能なネクスト ホップの IP アドレス。IP アドレス、インターフェイス タイプ、およびインターフェイス番号を指定できます。形式は x.x.x.x/length です。length は 1 ~ 32 です。

preference

(任意)このルートへのアドミニストレーティブ ディスタンスとして使用されるルート プリファレンス。指定できる範囲は 1 ~ 255 です。デフォルトは 1 です。

tag id

(任意)ルート マップ内の照合に使用可能なルート タグを割り当てます。範囲は 0 ~ 4294967295 です。デフォルトは 0 です。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

スタティック ルートのデフォルトのアドミニストレーティブ ディスタンスは 1 です。ダイナミック ルーティング プロトコルをスタティック ルートよりも優先させたい場合は、スタティック ルート プリファレンス引数をダイナミック ルーティング プロトコルのアドミニストレーティブ ディスタンスよりも大きい値に設定する必要があります。たとえば、EIGRP を使用して抽出されたルートのデフォルト アドミニストレーティブ ディスタンスが 100 とします。スタティック ルートよりも EIGRP ダイナミック ルートを優先する場合は、100 を超えるアドミニストレーティブ ディスタンスを指定する必要があります。

次に、ネクストホップ アドレス 10.0.0.2 を介して到達可能な IP アドレス プレフィックス 192.168.1.1/32 を持つ宛先へのスタティック ルートを作成する例を示します。

switch(config)# ip route 192.168.1.1/32 10.0.0.2
 

次に、前述の例にタグを割り当てて、このスタティック ルート上で照合可能なルート マップを設定できるようにする例を示します。

switch(config)# ip route 192.168.1.1/32 10.0.0.2 tag 5
 

次に、110 のプリファレンスを選択する例を示します。この場合、アドミニストレーティブ ディスタンスが 110 未満のダイナミック ルート情報を入手できなければ、プレフィックスが 10.0.0.0 のパケットが 172.31.3.4 にあるルータに転送されます。

switch# configure terminal
switch(config)# ip route 10.0.0.0/8 172.31.3.4 110
switch(config)#
 

 
関連コマンド

コマンド
説明

ipv6 route

IPv6 スタティック ルートを設定します。

match tag

ルートに関連付けられたタグ値を照合します。

show vrf

VRF 設定情報を表示します。

 

ipv6 route

スタティック IPv6 ルートを設定するには、 ipv6 route コマンドを使用します。 スタティック ルートを削除するには、このコマンドの no 形式を使用します。

ipv6 route ipv6-prefix / length {{ next-hop-addr | next-hop-prefix } | interface | link-local-addr } [ preference ] [ tag tag-id ]

no ipv6 route ipv6-prefix / length

 
構文の説明

ipv6-prefix /l ength

IPv6 プレフィックスとプレフィックス長。形式は A:B::C:D/length です。長さの範囲は 1 ~ 128 です。

next-hop-addr

ネクストホップ アドレス。フォーマットは、A:B::C:D です。

next-hop-prefix

ネクストホップのプレフィックスと長さ。形式は A:B::C:D/length です。長さの範囲は 1 ~ 128 です。

interface

このルートに到達するためのインターフェイス。 ? を使用してサポートされているインターフェイスのリストを表示します。

link-local-addr

IPv6 リンクローカル アドレス。フォーマットは、A:B::C:D です。

preference

(任意)このルートまでのアドミニストレーティブ ディスタンスとして使用されるルート プリファレンスを設定します。指定できる範囲は 1 ~ 255 です。デフォルトは 1 です。

tag id

(任意)ルート マップ内の照合に使用可能なルート タグを割り当てます。範囲は 0 ~ 4294967295 です。デフォルトは 0 です。

 
デフォルト

ディセーブル

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドにライセンスは必要ありません。

次に、IPv6 スタティック ルートを作成する例を示します。

switch(config)# ipv6 route 2001:0DB8::/48 2b11::2f01:4c
 
 

 
関連コマンド

コマンド
説明

ip route

IPv4 スタティック ルートを設定します。

ip router eigrp

インターフェイス用の EIGRP インスタンスを指定するには、 ip router eigrp コマンドを使用します。デフォルトに戻すには、このコマンドの no 形式を使用します。

ip router eigrp instance-tag

no ip router eigrp instance-tag

 
構文の説明

instance-tag

EIGRP インスタンスの名前。 instance-tag には最大 20 文字の英数字文字列を指定します。大文字と小文字は区別されます。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドを使用する前に、スイッチで EIGRP をイネーブルにするようにしてください。

このコマンドには、LAN Base Services ライセンスが必要です。

次に、インターフェイス用の EIGRP インスタンスを設定する例を示します。

switch(config)# interface ethernet 1/2
switch(config-if)# no switchport
switch(config-if)# ip router eigrp Base
switch(config-if)#
 

 
関連コマンド

コマンド
説明

copy running-config startup-config

コンフィギュレーションの変更をスタートアップ コンフィギュレーション ファイルに保存します。

feature eigrp

スイッチで EIGRP をイネーブルにします。

show ip eigrp interfaces

EIGRP インターフェイスに関する情報を表示します。

 

ip split-horizon eigrp

Enhanced Interior Gateway Routing Protocol(EIGRP)プロセスのスプリット ホライズンをイネーブルにするには、 ip split-horizon eigrp コマンドを使用します。スプリット ホライズンをディセーブルにするには、このコマンドの no 形式を使用します。

ip split-horizon eigrp instance-tag

no ip split-horizon eigrp instance-tag

 
構文の説明

instance-tag

EIGRP インスタンスの名前。 instance-tag には最大 20 文字の英数字文字列を指定します。大文字と小文字は区別されます。

 
コマンド デフォルト

イネーブル

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

インターフェイスのスプリット ホライズンをディセーブルにするには、 no ip split-horizon eigrp コマンドを使用します。

このコマンドには、LAN Base Services ライセンスが必要です。

次に、イーサネット リンクのスプリット ホライズンをディセーブルにする例を示します。

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# no ip split-horizon eigrp 209
switch(config-if)#
 

 
関連コマンド

コマンド
説明

copy running-config startup-config

コンフィギュレーションの変更をスタートアップ コンフィギュレーション ファイルに保存します。

show ip eigrp

EIGRP 情報を表示します。

ip summary-address eigrp

指定の Enhanced Interior Gateway Routing Protocol(EIGRP)インターフェイスのサマリー集約アドレスを設定するには、 ip summary-address eigrp コマンドを使用します。設定をディセーブルにするには、このコマンドの no 形式を使用します。

ip summary-address eigrp instance-tag { ip-address / length | ip-address mask } [ admin-distance | leak-map map-name ]

no ip summary-address eigrp instance-tag { ip-address / length | ip-address mask }

 
構文の説明

instance-tag

EIGRP インスタンスの名前。 instance-tag には最大 20 文字の英数字文字列を指定します。大文字と小文字は区別されます。

ip-address / length

インターフェイスに適用するサマリー IP プレフィックスとプレフィックス長(4 分割ドット付き 10 進表記)。たとえば、/8 は、IP プレフィックスの最初の 8 ビットがネットワーク ビットであることを示します。 length を使用する場合、スラッシュが必要です。

ip-address

インターフェイスに適用するサマリー IP アドレス(4 分割ドット付き 10 進表記)。

mask

IP アドレス マスク

admin-distance

(任意)アドミニストレーティブ ディスタンス。指定できる範囲は 1 ~ 255 です。

leak-map map-name

(任意)リーク マップを指定します。

 
コマンド デフォルト

EIGRP サマリー ルートには、アドミニストレーティブ ディスタンス 5 が適用されます。
事前設定されるサマリー アドレスはありません。

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

インターフェイス レベルのアドレス集約を設定するには、 ip summary-address eigrp コマンドを使用します。EIGRP サマリー ルートのアドミニストレーティブ ディスタンスは 5 です。

このコマンドには、LAN Base Services ライセンスが必要です。

次に、EIGRP インターフェイス上の 192.168.0.0/16 サマリー アドレスに 95 のアドミニストレーティブ ディスタンスを設定する例を示します。

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# ip summary-address eigrp 209 192.168.0.0/16 95
switch(config-if)#

 
関連コマンド

コマンド
説明

copy running-config startup-config

コンフィギュレーションの変更をスタートアップ コンフィギュレーション ファイルに保存します。

show ip eigrp interfaces

EIGRP インターフェイス関連の情報を表示します。

 

ipv6 authentication key-chain eigrp

EIGRP for IPv6 パケットの認証をイネーブルにして、インターフェイス上で使用可能なキー セットを指定するには、 ipv6 authentication key-chain eigrp コマンドを使用します。認証を禁止するには、このコマンドの no 形式を使用します。

ipv6 authentication key-chain eigrp instance-tag name-of-chain

no ipv6 authentication key-chain eigrp instance-tag name-of-chain

 
構文の説明

instance-tag

EIGRP インスタンスの名前。 instance-tag は、大文字と小文字が区別される 63 文字以下の任意の英数字文字列にできます。

name-of-chain

キー チェーンの名前。キー チェーン名は、大文字と小文字が区別される 63 文字以下の任意の英数字文字列にできます。

 
デフォルト

EIGRP パケットには認証は適用されません。

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

インターフェイス コンフィギュレーション モードで ipv6 authentication mode eigrp コマンドを使用して、認証モードを設定する必要があります。インターフェイスに対する認証設定を完了するには、 key-chain コマンドを使用して、別途キー チェーンを設定する必要があります。

このコマンドには、Enterprise Services ライセンスが必要です。

キーチェーン ツリーに属しているキーの受け入れと送信をインターフェイスに設定する例を示します。

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 1/2
switch(config-if)# ipv6 authentication key-chain eigrp 209 trees
 

 
関連コマンド

コマンド
説明

ipv6 authentication mode eigrp

EIGRP for IPv6 インターフェイス用の認証モードを設定します。

key-chain

認証方式で使用可能なキー セットを作成します。

ipv6 authentication mode eigrp

EIGRP for IPv6 パケットに使用される認証タイプを指定するには、 ipv6 authentication mode eigrp コマンドを使用します。認証を削除するには、このコマンドの no 形式を使用します。

ipv6 authentication mode eigrp instance-tag md5

no ipv6 authentication mode eigrp instance-tag md5

 
構文の説明

instance-tag

EIGRP インスタンスの名前。 instance-tag は、大文字と小文字が区別される 63 文字以下の任意の英数字文字列にできます。

md5

Message Digest 5(MD5)認証を指定します。

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドには、Enterprise Services ライセンスが必要です。

インターフェイスに使用される認証方式を MD5 に設定する例を示します。

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 1/2
switch(config-if)# ipv6 authentication mode eigrp 209 md5

 
関連コマンド

コマンド
説明

authentication mode(EIGRP)

アドレスファミリ モードで EIGRP 用の認証モードを設定します。

iv6p authentication key-chain eigrp

EIGRP の認証をイネーブルにして、インターフェイスに使用可能なキー セットを指定します。

key chain

認証方式で使用可能なキー セットを作成します。

ipv6 bandwidth eigrp

EIGRP for IPv6 インターフェイスで帯域幅メトリックを設定するには、 ipv6 bandwidth eigrp コマンドを使用します。デフォルトに戻す場合は、このコマンドの no 形式を入力します。

ipv6 bandwidth eigrp instance-tag bandwidth

no ipv6 bandwidth eigrp

 
構文の説明

instance-tag

EIGRP インスタンスの名前。 instance-tag は、大文字と小文字が区別される 63 文字以下の任意の英数字文字列にできます。

bandwidth

帯域幅値。範囲は 1 ~ 2,560,000,000 キロビットです。

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドには、Enterprise Services ライセンスが必要です。

自律システム 209 で帯域幅 10000 が使用されるように EIGRP を設定する例を示します。

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 2/1
switch(config-if)# ipv6 bandwidth eigrp 209 10000

 
関連コマンド

コマンド
説明

ipv6 bandwidth-percent eigrp

インターフェイスの帯域幅のうち、EIGRP に使用できる割合をパーセントで設定します。

ipv6 bandwidth-percent eigrp

EIGRP for IPv6 インターフェイスで使用可能な帯域幅のパーセンテージを設定するには、 ipv6 bandwidth-percent eigrp コマンドを使用します。デフォルトに戻す場合は、このコマンドの no 形式を入力します。

ipv6 bandwidth-percent eigrp instance-tag percent

no ipv6 bandwidth-percent eigrp

 
構文の説明

instance-tag

EIGRP インスタンスの名前。 instance-tag は、大文字と小文字が区別される 63 文字以下の任意の英数字文字列にできます。

percent

EIGRP に使用できる帯域幅のパーセンテージ

 
デフォルト

percent :50

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

EIGRP が使用する帯域幅は、リンクの帯域幅の最大 50 %です。このパーセンテージは、 ip bandwidth インターフェイス コンフィギュレーション コマンドで定義されます。このデフォルトのパーセンテージを変更するには、 ip bandwidth-percent コマンドを使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

自律システム 209 でインターフェイスの帯域幅の最大 75 %を使用するように EIGRP を設定する例を示します。

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 2/1
switch(config-if)# ipv6 bandwidth-percent eigrp 209 75

 
関連コマンド

コマンド
説明

ipv6 bandwidth eigrp

インターフェイスの EIGRP 帯域幅値を設定します。

ipv6 delay eigrp

EIGRP for IPv6 インターフェイスのスループット遅延を設定するには、 ipv6 delay eigrp コマンドを使用します。デフォルトに戻す場合は、このコマンドの no 形式を入力します。

ipv6 delay eigrp instance-tag seconds

no ipv6 delay eigrp instance-tag

 
構文の説明

instance-tag

EIGRP インスタンスの名前。 instance-tag は、大文字と小文字が区別される 63 文字以下の任意の英数字文字列にできます。

seconds

スループット遅延(10 マイクロ秒)。範囲は 1 ~ 16777215 です。

 
デフォルト

100(10 マイクロ秒単位)

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

10 マイクロ秒単位でインターフェイスにスループット遅延を設定します。たとえば、 ipv6 delay eigrp コマンドを 100 に設定すると、スループット遅延は 1000 マイクロ秒になります。

このコマンドには、Enterprise Services ライセンスが必要です。

インターフェイスの遅延を 400 マイクロ秒に設定する例を示します。

switch(config)# router eigrp 1
switch(config-router)# interface ethernet 2/1
switch(config-if)# ipv6 delay eigrp 1 40

 
関連コマンド

コマンド
説明

ipv6 hello-interval eigrp

自律システム番号で指定される EIGRP ルーティング プロセスに対するインターフェイスの hello インターバルを設定します。

ipv6 distribute-list eigrp

EIGRP for IPv6 インターフェイス用の配布リストを設定するには、 ipv6 distribute-list eigrp コマンドを使用します。デフォルトに戻す場合は、このコマンドの no 形式を入力します。

ipv6 distribute-list eigrp instance-tag { prefix-list list-name | route-map map-name } { in | out }

no ipv6 distribute-list eigrp instance-tag { prefix-list list-name | route-map map-name } { in | out }

 
構文の説明

instance-tag

EIGRP インスタンスの名前。 instance-tag は、大文字と小文字が区別される 63 文字以下の任意の英数字文字列にできます。

prefix-list list-name

EIGRP ルートをフィルタするための IPv6 プレフィックス リストの名前を指定します。

route-map map-name

EIGRP ルートのフィルタリングに使用するルート マップの名前を指定します。

in

着信ルートにルート ポリシーを適用します。

out

発信ルートにルート ポリシーを適用します。

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

ipv6 distribute-list eigrp コマンドは、インターフェイス上のルート フィルタ ポリシーを設定するために使用します。この設定を完了するためには、ルート マップまたはプレフィックス リストの名前を設定する必要があります。

このコマンドには、Enterprise Services ライセンスが必要です。

インターフェイスに着信するすべての EIGRP ルートのルート マップを設定する例を示します。

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 2/1
switch(config-if)# ipv6 distribute-list eigrp 209 route-map InputFilter in

 
関連コマンド

コマンド
説明

prefix-list

プレフィックス リストを設定します。

route-map

ルート マップを設定します。

ipv6 eigrp shutdown

EIGRP for IPv6 インターフェイスをシャットダウンするには、 ipv6 eigrp shutdown コマンドを使用します。デフォルトに戻す場合は、このコマンドの no 形式を入力します。

ipv6 eigrp instance-tag shutdown

no ipv6 eigrp instance-tag shutdown

 
構文の説明

instance-tag

EIGRP インスタンスの名前。 instance-tag は、大文字と小文字が区別される 63 文字以下の任意の英数字文字列にできます。

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドには、Enterprise Services ライセンスが必要です。

インターフェイスの EIGRP を ディセーブルにする例を示します。

switch(config)# router eigrp 201
switch(config-router)# interface ethernet 2/1
switch(config-if)# ipv6 eigrp 201 shutdown

 
関連コマンド

コマンド
説明

router eigrp

EIGRP のインスタンスを設定します。

ipv6 hello-interval eigrp

インターフェイスの EIGRP for IPv6 hello インターバルを設定するには、 ipv6 hello-interval eigrp コマンドを使用します。デフォルトに戻す場合は、このコマンドの no 形式を入力します。

ipv6 hello-interval eigrp instance-tag seconds

no ipv6 hello-interval eigrp instance-tag

 
構文の説明

instance-tag

EIGRP インスタンスの名前。 instance-tag は、大文字と小文字が区別される 63 文字以下の任意の英数字文字列にできます。

seconds

hello インターバル(秒単位)。有効な範囲は 1 ~ 65535 です。

 
デフォルト

5 秒

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドには、Enterprise Services ライセンスが必要です。

インターフェイスの hello インターバルを 10 秒に設定する例を示します。

switch(config)# router eigrp 1
switch(config-router)# interface ethernet 2/1
switch(config-if)# ipv6 hello-interval eigrp 1 10

ipv6 hold-time eigrp

EIGRP for IPv6 インターフェイスのホールド時間を設定するには、 ipv6 hold-time eigrp コマンドを使用します。デフォルトに戻す場合は、このコマンドの no 形式を入力します。

ipv6 hold-time eigrp instance-tag seconds

no ipv6 hold-time eigrp instance-tag

 
構文の説明

instance-tag

EIGRP インスタンスの名前。 instance-tag は、大文字と小文字が区別される 63 文字以下の任意の英数字文字列にできます。

seconds

ホールド時間(秒単位)。有効な範囲は 1 ~ 65535 です。

 
デフォルト

15 秒

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

ipv6 hold-time eigrp コマンドは、非常に輻輳した大規模ネットワーク上のデフォルト ホールド時間を増加するために使用します。

ホールド時間は、hello インターバルの 3 倍以上の値に設定することを推奨します。指定されたホールド時間内にルータが hello パケットを受信しなかった場合は、そのルータ経由のルートが使用できないと判断されます。

ホールド タイムを増やすと、ネットワーク全体のルート収束が遅くなります。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、インターフェイスのホールド時間を 40 秒に設定する例を示します。

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 2/1
switch(config-if)# ipv6 hold-time eigrp 209 40
 
 

 
関連コマンド

コマンド
説明

ipv6 hello-interval eigrp

自律システム番号で指定された EIGRP ルーティング プロセス用のインターフェイス上の hello インターバルを設定します。

ipv6 next-hop-self eigrp

これらのルートのアドバタイズ時にネクストホップ アドレスとしてローカル IPv6 アドレスを使用するように EIGRP for IPv6 プロセスに指示するには、 next-hop-self eigrp コマンドを使用します。受信したネクストホップ値を使用するには、このコマンドの no 形式を使用します。

ipv6 next-hop-self eigrp instance-tag

no ipv6 next-hop-self eigrp instance-tag

 
構文の説明

instance-tag

EIGRP インスタンスの名前。 instance-tag は、大文字と小文字が区別される 63 文字以下の任意の英数字文字列にできます。

 
デフォルト

EIGRP は、常に、IPv6 ネクストホップ値を自己設定します。

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

デフォルトで、EIGRP は、ルータがルートを取得したインターフェイスと同じインターフェイス上でルートをアドバタイズする場合でも、アドバタイズするルートの IPv6 ネクストホップ値を自己設定します。このデフォルトを変更するには、 no ipv6 next-hop-self eigrp インターフェイス コンフィギュレーション コマンドを使用して、これらのルートのアドバタイズ時に受信したネクストホップ値を使用するように EIGRP に指示する必要があります。

デフォルトの IPv6 ネクストホップ値を変更し、受信したネクストホップ値を使用するように EIGRP に指示する例を示します。

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 2/1
switch(config-eigrp-af-if)# no ipv6 next-hop-self eigrp 209

ipv6 offset-list eigrp

EIGRP for IPv6 インターフェイスのオフセット リストを設定するには、 ipv6 offset-list eigrp コマンドを使用します。デフォルトに戻す場合は、このコマンドの no 形式を入力します。

ipv6 offset-list eigrp instance-tag { prefix-list list-name | route-map map-name } { in | out } offset

no ipv6 offset-list eigrp instance-tag { prefix-list list-name | route-map map-name } { in | out } offset

 
構文の説明

instance-tag

EIGRP インスタンスの名前。 instance-tag は、大文字と小文字が区別される 63 文字以下の任意の英数字文字列にできます。

prefix-list list-name

EIGRP ルートをフィルタするための IPv6 プレフィックス リストの名前を指定します。

route-map map-name

EIGRP ルートのフィルタリングに使用するルート マップの名前を指定します。

in

着信ルートにルート ポリシーを適用します。

out

発信ルートにルート ポリシーを適用します。

offset

EIGRP メトリックに追加する値

 
デフォルト

このコマンドには、デフォルトはありません。

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

ipv6 offset-list eigrp コマンドは、インターフェイス上でアドバタイズされるルートに影響を与えます。Cisco NX-OS は、指定されたプレフィックス リストまたはルート マップと一致するすべてのルートに、設定されたオフセット値を追加します。この設定を完了するためには、ルート マップまたはプレフィックス リストの名前を設定する必要があります。

このコマンドには、Enterprise Services ライセンスが必要です。

次の例では、ルート マップ OffsetFilter と一致するインターフェイスに着信する EIGRP ルートのメトリックに 20 を追加するように、オフセット リスト フィルタを設定します。

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 2/1
switch(config-if)# ipv6 offset-list eigrp 209 route-map OffsetFilter in 20

 
関連コマンド

コマンド
説明

prefix-list

プレフィックス リストを設定します。

route-map

ルート マップを設定します。

ipv6 passive-interface eigrp

EIGRP for IPv6 インターフェイス上のすべてのルーティング アップデートを抑制するには、 ipv6 passive-interface eigrp コマンドを使用します。ルーティング アップデートの送信を再度イネーブルにするには、このコマンドの no 形式を使用します。

ipv6 passive-interface eigrp instance-tag

no ipv6 passive-interface eigrp instance-tag

 
構文の説明

instance-tag

EIGRP インスタンスの名前。 instance-tag は、大文字と小文字が区別される 63 文字以下の任意の英数字文字列にできます。

 
デフォルト

インターフェイス上でルーティング アップデートが送信されます。

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

ipv6 passive-interface eigrp コマンドは、インターフェイス上のすべてのルーティング アップデートを停止し、EIGRP 隣接関係の形成を抑制するために使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、インターフェイス Ethernet 2/1 上の EIGRP ルーティング アップデートを停止する例を示します。

switch(config)# router eigrp 201
switch(config-router)# interface ethernet 2/1
switch(config-if)# ipv6 passive-interface eigrp 201

ipv6 router eigrp

EIGRP for IPv6 インターフェイスを指定するには、 ipv6 router eigrp コマンドを使用します。デフォルトに戻すには、このコマンドの no 形式を使用します。

ipv6 router eigrp instance-tag

no ipv6 router eigrp instance-tag

 
構文の説明

instance-tag

EIGRP インスタンスの名前。 instance-tag は、大文字と小文字が区別される 63 文字以下の任意の英数字文字列にできます。

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

ipv6 router eigrp コマンドは、インターフェイス用の EIGRP インスタンスを指定するために使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、インターフェイス用の EIGRP インスタンスを設定する例を示します。

switch(config)# interface ethernet 1/2
switch(config-if)# ipv6 router eigrp Base

ipv6 split-horizon eigrp

Enhanced Interior Gateway Routing Protocol(EIGRP)for IPv6 プロセスのスプリット ホライズンをイネーブルにするには、 ipv6 split-horizon eigrp コマンドを使用します。スプリット ホライズンをディセーブルにするには、このコマンドの no 形式を使用します。

ipv6 split-horizon eigrp instance-tag

no ipv6 split-horizon eigrp instance-tag

 
構文の説明

instance-tag

EIGRP インスタンスの名前。 instance-tag は、大文字と小文字が区別される 63 文字以下の任意の英数字文字列にできます。

 
デフォルト

イネーブル

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

no ipv6 split-horizon eigrp コマンドは、インターフェイス上のスプリット ホライズンをディセーブルにするために使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

イーサネット リンクのスプリット ホライズンをディセーブルにする例を示します。

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 2/1
switch(config-eigrp-af-if)# no ipv6 split-horizon eigrp 209

ipv6 summary-address eigrp

指定された EIGRP for IPv6 インターフェイスのサマリー集約アドレスを設定するには、 ipv6 summary-address eigrp コマンドを使用します。設定をディセーブルにするには、このコマンドの no 形式を使用します。

ipv6 summary-address eigrp instance-tag { ipv6-address / length } [ admin-distance ]

no ipv6 summary-address eigrp instance-tag { ipv6-address / length }

 
構文の説明

instance-tag

EIGRP インスタンスの名前。 instance-tag は、大文字と小文字が区別される 63 文字以下の任意の英数字文字列にできます。

ipv6-address / length

インターフェイスに A:B::C:D/length 形式で適用されるサマリー IPv6 プレフィックスとプレフィックス長。長さの範囲は 1 ~ 128 です。

admin-distance

(任意)アドミニストレーティブ ディスタンス。指定できる範囲は 1 ~ 255 です。

 
デフォルト

EIGRP サマリー ルートには、アドミニストレーティブ ディスタンス 5 が適用されます。
事前設定されるサマリー アドレスはありません。

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

ipv6 summary-address eigrp コマンドは、インターフェイス レベルのサマリー アドレスを設定するために使用します。EIGRP サマリー ルートのアドミニストレーティブ ディスタンスは 5 です。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、2001:0DB8::/48 サマリー アドレス用の EIGRP インターフェイス上で 95 のアドミニストレーティブ ディスタンスを設定する例を示します。

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 2/1
switch(config-if)# ipv6 summary-address eigrp 209 2001:0DB8::/48 95