Cisco Nexus 5000 シリーズ NX-OS ユニキャスト ルーティング コマンド リファレンス
V コマンド
V コマンド
発行日;2013/04/23 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

V コマンド

vrf

vrf context

vrf member

V コマンド

この章では、V で始まる Cisco NX-OS ボーダー ゲートウェイ プロトコル(BGP)コマンドについて説明します。

vrf

仮想ルーティングおよび転送(VRF)コンフィギュレーション モードを開始して、サブモード コマンドを設定するには、 vrf コマンドを使用します。VRF インスタンスの削除または VRF コンフィギュレーション モードをディセーブルにするには、このコマンドの no 形式を使用します。

vrf name | management

no vrf name | management

 
構文の説明

name

VRF の名前。 name には最大 32 文字の英数字を使用できます。大文字と小文字は区別されます。

management

管理 VRF を指定します。

 
コマンド デフォルト

なし

 
コマンド モード

アドレスファミリ コンフィギュレーション モード
ルータ コンフィギュレーション モード
VRF コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

VRF は、グローバル コンフィギュレーション モードで同じ名前の VRF が作成されるまでアクティブになりません。

VRF コンフィギュレーション モードを開始すると、次のコマンドが使用可能になります。

area :(OSPF)エリア プロパティを設定します。

address-family :(BGP)アドレスファミリを設定します。詳細については、 address-family(BGP) コマンドを参照してください。

auto-cost :(OSPF)帯域幅に従って OSPF コストを計算します。

cluster-id { cluster-id | cluster-ip-addr } :(BGP)ルート リフレクタのクラスタ ID(ルータ、VRF)を設定します。範囲は 1 ~ 4294967295 です。クラスタ ID は、32 ビットの数値または IP アドレスとして入力できます。クラスタ ID を削除するには、このコマンドの no 形式を使用します。ルート リフレクタとそのクライアントがともにクラスタを形成します。クラスタ内のルート リフレクタが 1 つの場合、クラスタはルート リフレクタのルータ ID で識別されます。

cluster-id コマンドは、クラスタ内に 1 つまたは複数のルート リフレクタがある場合に、ルート リフレクタにクラスタ ID を割り当てるために使用します。クラスタに複数のルート リフレクタを導入することで、冗長性が向上し単一障害ポイントを避けることができます。クラスタ内に複数のルート リフレクタを設定すると、すべてのルート リフレクタに同じクラスタ ID が割り当てられます。これにより、クラスタ内のすべてのルート リフレクタが同じクラスタ内のピアからのアップデートを認識できるようになると共に、BGP ルーティング テーブル内に格納する必要のあるアップデートの数が削減されます。


) すべてのルート リフレクタは、クラスタ内のすべてのピア間で安定したセッションを維持する必要があります。安定したセッションを維持できない場合は、代わりにオーバーレイ ルート リフレクタ クラスタ(異なるクラスタ ID を持つルート リフレクタ)を使用するようにしてください。


default-information :(OSPF)デフォルト ルートの配布を制御します。詳細については、 default-information originate(OSPF) コマンドを参照してください。

default-metric :(OSPF)再配布されたルートのデフォルト メトリックを指定します。詳細については、 default-metric(OSPF) コマンドを参照してください。

distance :(OSPF)OSPF アドミニストレーティブ ディスタンスを定義します。詳細については、 distance(OSPF) コマンドを参照してください。

exit :(BGP)現在のコマンド モードを終了します。

log-adjacency-changes :(OSPF)隣接状態の変更をログに記録します。

log-neighbor-changes :BGP ネイバー リセットのロギングをイネーブルにします。BGP ネイバールータとの隣接関係の変化に関するロギングをディセーブルにするには、このコマンドの no 形式を使用します。 log-neighbor-changes コマンドは、BGP ネイバー ステータスの変化(アップまたはダウン)およびリセットに関するロギングをイネーブルにします。ログはネットワークの接続問題のトラブルシューティングおよびネットワークの安定性の評価に使用します。ネイバーが突然リセットする場合は、ネットワークのエラー率の高いことやパケット損失の多いことが考えられるので、調査するようにしてください。

ステータスの変化に関するメッセージをロギングするために log-neighbor-changes コマンドを使用しても、BPG アップデート デバッグをイネーブルにする場合などと異なり、パフォーマンスに大きな影響を与えることはありません。UNIX の syslog ファシリティがイネーブルの場合、メッセージは syslog デーモンを実行している UNIX ホストに送信され、保存およびアーカイブされます。UNIX の syslog ファシリティがイネーブルでない場合、ステータスの変化に関するメッセージはディスクではなくルータの内部バッファに保持されます。このバッファのサイズは logging buffered コマンドで設定できますが、利用可能なメモリのサイズに依存します。

bgp log-neighbor-changes コマンドがディセーブルの場合、ネイバー ステータスの変化に関するメッセージは、 show ip bgp neighbors コマンドの出力として常に使用可能なリセットの理由を除いて、追跡されません。

eigrp log-neighbor-changes コマンドは、Enhanced Interior Gateway Routing Protocol(EIGRP)隣接ルータとの隣接関係のロギングをイネーブルにしますが、BGP ネイバーに関するメッセージは、bgp log-neighbor-changes コマンドで明確にイネーブルにされた場合にのみ記録されます。

BGP ネイバーの変化に関するログを表示するには、 show logging コマンドを使用します。

max-metric :(OSPF)コスト メトリックを最大化します。詳細については、 max-metric(OSPF) コマンドを参照してください。

maximum-paths :(OSPF)OSPF がサポートできるパラレル ルートの最大数を設定します。詳細については、 maximum-paths (OSPF) コマンドを参照してください。

neighbor :BGP ネイバーを設定します。詳細については、 neighbor コマンドを参照してください。

no :コマンドを無効にするか、そのデフォルトに設定します。

redistribute :(OSPF)別のルーティング プロトコルからの情報を再配布します。詳細については、 redistribute(OSPF) コマンドを参照してください。

rfc1583compatibility :(OSPF)外部のパス プリファレンスに対する RFSC 1583 互換性を設定します。詳細については、 rfc1583compatibility コマンドを参照してください。

router-id ip-addr :ルータ ID として使用する IP アドレスを指定します。

shutdown :(OSPF)OSPF プロトコル インスタンスをシャットダウンします。詳細については、 shutdown(OSPF) コマンドを参照してください。

summary-address :(OSPF)再配布のルート集約を設定します。詳細については、 summary-address(OSPF) コマンドを参照してください。

timers bestpath-timeout :最適パスのタイムアウト値を秒単位で設定します。範囲は 1 ~ 3600 です。デフォルトは 300 です。

次に、BGP 環境で VRF コンフィギュレーション モードを開始する例を示します。

switch(config)# router bgp 100
switch(config-router)# vrf management
switch(config-router-vrf)#
 

次に、OSPF 環境で VRF コンフィギュレーション モードを開始する例を示します。

switch(config)# vrf context RemoteOfficeVRF
switch(config-vrf)# router ospf 201
switch(config-router)# vrf RemoteOfficeVRF
switch(config-router-vrf)#
 

 
関連コマンド

コマンド
説明

vrf context

VRF を作成します。

show vrf

VRF 設定情報を表示します。

 

vrf context

仮想ルーティングおよび転送インスタンス(VRF)を作成して、VRF コンフィギュレーション モードを開始するには、 vrf context コマンドを使用します。VRF エントリを削除するには、このコマンドの no 形式を使用します。

vrf context { name | management }

no vrf context { name | management }

 
構文の説明

name

VRF の名前。 name には最大 32 文字の英数字を使用できます。大文字と小文字は区別されます。

management

管理 VRF を指定します。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが追加されました。

次に、VRF コンテキストを作成する例を示します。

switch(config)# vrf context RemoteOfficeVRF
switch(config-vrf)#
 

 
関連コマンド

コマンド
説明

vrf

VRF インスタンスを作成または設定します。

show vrf

VRF 設定情報を表示します。

 

vrf member

仮想ルーティングおよび転送(VRF)インスタンスにインターフェイスを追加するか、または VRF インスタンスに対するオブジェクト トラッキングを設定するには、 vrf member コマンドを使用します。このルートのオブジェクト トラッキングを削除するには、このコマンドの no 形式を使用します。

vrf member vrf-name

no vrf member vrf-name

 
構文の説明

vrf-name

VRF 名。name には最大 32 文字の英数字を使用できます。大文字と小文字は区別されます。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード
オブジェクト トラッキング コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

デフォルト VRF 以外のオブジェクトを追跡するには、オブジェクト トラッキング コンフィギュレーション モードで vrf member コマンドを使用します。

次に、VRF Red の IP ルートを追跡する例を示します。

switch(config)# track 1 ip route 10.10.10.0/8 reachability
switch(config-track)# vrf member Red
switch(config-track)#
 

次に、イーサネット インターフェイス 1/5 を VRF RemoteOfficeVRF に追加する例を示します。

switch(config)# interface ethernet 1/5
switch(config-if)# no switchport
switch(config-if)# vrf member RemoteOfficeVRF
switch(config-if)#
 

 
関連コマンド

コマンド
説明

show vrf

VRF 設定情報を表示します。