Cisco Nexus 5000 シリーズ NX-OS ユニキャスト ルーティング コマンド リファレンス
T コマンド
T コマンド
発行日;2013/04/23 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

T コマンド

template(BGP)

T コマンド

この章では、T で始まる Cisco NX-OS ボーダー ゲートウェイ プロトコル(BGP)コマンドについて説明します。

template(BGP)

ピア テンプレートを作成し、ピア テンプレート コンフィギュレーション モードを開始するには、 template コマンドを使用します。ピア テンプレートを削除するには、このコマンドの no 形式を使用します。

template { peer name | peer-policy name | peer-session name }

no template { peer name | peer-policy name | peer-session name }

 
構文の説明

peer name

ネイバー テンプレート名を指定します。

peer-policy name

ピア ポリシー テンプレート名を指定します。

peer-session name

ピア セッション テンプレート名を指定します。

 
コマンド デフォルト

このコマンドにはデフォルト設定がありません。

 
コマンド モード

ネイバー アドレスファミリ コンフィギュレーション モード
ルータ BGP コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

template コマンドを使用すると、ネイバーが継承する一連の定義済み属性をイネーブルにできます。


) ボーダー ゲートウェイ プロトコル(BGP)ネイバーを、ピア グループとピア テンプレートの両方と連動するようには設定できません。BGP ネイバーは、ピア グループに属するか、ポリシーをピア テンプレートから継承するようにしか設定できません。


ピア テンプレートでは、基本ポリシー コマンドのみサポートされます。特定のアドレス ファミリまたは NLRI コンフィギュレーション モードに限定して設定される BGP ポリシー コンフィギュレーション コマンドを、ピア テンプレートを使用して設定します。

ピア ポリシー テンプレート コンフィギュレーション モードを開始すると、次のコマンドが使用できます。

suppress-inactive :アクティブ ルートをピアのみにアドバタイズします。追加情報については、 suppress-inactive コマンドを参照してください。

exit :現在のコンフィギュレーション モードを終了します。

filter-list name { in | out }:インバウンドおよびアウトバウンド BGP ルートに関する AS-PATH フィルタリスト を作成します 。エントリを削除するには、このコマンドの no 形式を使用します。

in :アクセス リストを着信ルートに適用します。

out :アクセス リストを発信ルートに適用します。

inherit peer-policy policy-name seq-num :別のピア ポリシー テンプレートの設定を継承するようにピア ポリシー テンプレートを設定します。ピア ポリシー テンプレートから、継承文を削除するには、このコマンドの no 形式を使用します。範囲:1 ~ 65535。デフォルトで、継承文は設定されていません。

ピア ポリシー テンプレートを評価する順序は、シーケンス番号で決まります。ルートマップのシーケンス番号と同じように、最も低いシーケンス番号が最初に評価されます。ピア ポリシー テンプレートでは継承がサポートされており、ピアはピア ポリシー テンプレートを 7 つまで直接または間接的に継承できます。ルート マップと同じように、継承されたピア ポリシー テンプレートにはシーケンス番号が設定されます。ルート マップと同じように、継承したピア ポリシー テンプレートは最も低いシーケンス番号を持つ継承文が最初に評価されます。ただし、ピア ポリシー テンプレートが抜けることはありません。すべてのシーケンスが評価されます。BGP ポリシー コマンドが異なる値で再び適用された場合は、より低いシーケンス番号による以前の値が上書きされます。


) BGP ルーティング プロセスをピア グループのメンバーにすると同時に、ピア テンプレートをグループ設定に使用するようには設定できません。どちらか一方の設定を使用する必要があります。パフォーマンスとスケーラビリティが向上するため、ピア テンプレートを推奨します。


maximum-prefix max :このネイバーからの最大プレフィックス数を指定します。範囲は 1 ~ 300000 です。デフォルトで、このコマンドはディセーブルになっています。最大プレフィックス数を超えると、ピアリング セッションはディセーブルになります。詳しくは maximum-prefix コマンドを参照してください。

next-hop-self :ルータを BGP ネイバーまたはピア グループのネクスト ホップとして設定します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。デフォルトで、ディセーブルになっています。

next-hop-third-party :可能であればサードパーティ ネクスト ホップを計算します。

no :コマンドを無効にするか、デフォルト設定にします。

prefix-list name { in | out } :プレフィックス リストを適用するルート タイプを指定します。エントリを削除するには、このコマンドの no 形式を使用します。

in :プレフィックス リストを着信ルートに適用します。

out :プレフィックス リストを発信ルートに適用します。

route-map name { in | out }:ネイバーに適用するルート タイプを適用するルート マップ名を指定します。

in :ルート マップを着信ルートに適用します。

out :ルート マップを発信ルートに適用します。

route-reflector-client :ルータを BGP ルート リフレクタとして設定し、指定のネイバーをそのクライアントとして設定します。ネイバーがクライアントでないことを示すには、このコマンドの no 形式を使用します。Autonomous System(AS; 自律システム)にルート リフレクタは存在しません。

デフォルトでは、自律システム内のすべての internal BGP(iBGP)スピーカーが完全にメッシュ化されている必要があります。また、ネイバーは、iBGP で学習されたルートを再度ネイバーにアドバタイズすることはしません。これにより、ルーティング情報のループが防止されます。すべてのクライアントがディセーブルになると、ローカル ルータはルート リフレクタでなくなります。

ルート リフレクタを使用する場合は、すべての iBGP スピーカーを完全なメッシュ型にする必要はありません。ルート リフレクタ モデルでは、1 つの iBGP ピアをルート リフレクタに設定します。このルート リフレクタは iBGP で学習したルートを iBGP ネイバーに渡す役割があります。この方式を使用することで、各ルータが他のすべてのルータと通信する必要がなくなります。

このコマンドで設定されたネイバーはすべてクライアント グループのメンバーであり、残りの iBGP ピアはローカル ルート リフレクタの非クライアント グループのメンバーです。

send-community :コミュニティ属性を BGP ネイバーに送信するように指定します。エントリを削除するには、このコマンドの no 形式を使用します。

soft-reconfiguration :アップデートの保存を開始するように Cisco NX-OS ソフトウェアを設定します。受信したアップデートを格納しないようにするには、このコマンドの no 形式を使用します。デフォルトで、ディセーブルになっています。このコマンドを入力すると、アップデートの格納が開始されます。これは着信ソフト再設定を行うために必要です。BGP 発信ソフト再設定では、着信ソフト再設定をイネーブルにする必要はありません。

事前設定ではなく、ソフト再設定(ソフト リセット)を使用するには、両方の BGP ピアがソフト ルート リフレッシュ機能をサポートしている必要があります。この機能は、ピアが TCP セッションを確立する際に送信する OPEN メッセージに格納され、アドバタイズされます。 soft-reconfiguration コマンドを使用して BGP セッションをクリアするとネットワーク動作に悪影響が及ぶため、最終手段として使用してください。

BGP ルータがこの機能をサポートしているかどうかを確認するには、 show ip bgp neighbors コマンドを使用します。ルータがルート リフレッシュ機能をサポートしている場合は、次のメッセージが表示されます。

「Received route refresh capability from peer.」

peer-group-name 引数を使用して BGP ピア グループを指定した場合は、ピア グループのすべてのメンバーがこのコマンドで設定された特性を継承します。

ピア セッション テンプレート コンフィギュレーション モードを開始すると、次のコマンドが使用できます。

description description :ローカルまたはピア ルータに表示される説明を設定します。スペースを含めて 80 文字まで入力できます。

disable-connected-check :eBGP ピアにループバック インターフェイスが設定されているときは、1 ホップだけ離れた eBGP ピアの接続検証をディセーブルにします。

ebgp-multihop :直接接続されていないネットワーク上に存在する外部ピアとの BGP による接続を受け入れたり、接続を試行したりします。


) このコマンドを使用する場合は、必ずシスコのテクニカルサポート担当者の指示に従ってください。


exit :現在のコンフィギュレーション モードを終了します。

inherit peer-session session-name :ピア セッション テンプレートを設定します。別のピア セッション テンプレートから設定を継承するには、 peer-session キーワードを使用します。ピア セッション テンプレートから継承文を削除するには、このコマンドの no 形式を使用します。

local-as :eBGP ピア グループの AS 番号のカスタマイズを可能にします。

neighbor inherit peer-session :ネイバーで設定が継承できるようにするためのピア セッション テンプレートを送信するようにルータを設定します。

neighbor translate-update :NLRI 形式で BGP を実行しているルータをマルチプロトコル BGP をサポートするようにアップグレードします。

password :2 つの BGP ピア間の TCP 接続において MD5 認証をイネーブルにします。次の設定ツールを使用できます。

0 password :非暗号化ネイバー パスワードを指定します。

3 password :3DES 暗号化ネイバー パスワードを指定します。

password :非暗号化(クリアテキスト)ネイバー パスワードを指定します。

remote-private-as :プライベート AS 番号を発信アップデートから削除します。

show ip bgp template peer-policy :ローカルで設定されたピア ポリシー テンプレートを表示します。

show ip bgp template peer-session :ローカルで設定されたピア セッション テンプレートを表示します。

shutdown :ネイバーまたはピア グループをディセーブルにします。

timers keepalive-time :キープアライブ タイマーおよびホールド タイマーの値を秒数で設定します。範囲は 0 ~ 3600 です。デフォルトは 60 です。

update-source { ethernet mod / port | loopback virtual-interface | port-channel number [ . sub-interface ]} :BGP セッションおよびアップデートの発信元を指定します。 virtual-interface の範囲は 0 ~ 1023 で、 number の範囲は 0 ~ 4096 です。(任意) sub-interface の範囲は 1 ~ 4093 です

基本セッション コマンドをピア セッション テンプレートに一度設定してから、ピア セッション テンプレートを直接適用する方法か、ピア セッション テンプレートから間接的に継承する方法で多くのネイバーに適用できます。ピア セッション テンプレートを設定すると、AS 内のすべてのネイバーに通常適用される基本セッション コマンドの設定を簡略化できます。

このコマンドには、LAN Enterprise Services ライセンスが必要です。

次に、CORE1 という名前のピア セッション テンプレートを作成する例を示します。この例では、INTERNAL-BGP という名前のピア セッション テンプレートの設定が継承されます。

switch# configure terminal
switch(config)# router bgp 64496
switch(config-router)# template peer-session CORE1
switch(config-router-stmp)#
 

次に、CUSTOMER-A という名前のピア ポリシー テンプレートの作成と設定を行う例を示します。

switch# configure terminal
switch(config)# router bgp 64496
switch(config-router)# template peer-policy CUSTOMER-A
switch(config-router-ptmp)# exit
switch(config-router)# route-map SET-COMMUNITY in
switch(config-router)# filter-list 20 in
switch(config-router)# inherit peer-policy PRIMARY-IN 20
switch(config-router)# inherit peer-policy GLOBAL 10
switch(config-router)# exit-peer-policy
switch(config-router)#
 

次に、192.168.1.1 ネイバーから受け入れられる最大プレフィックス数が 1000 に設定される例を示します。

switch# configure terminal
switch(config)# router bgp 64496
switch(config-router) network 192.168.0.0
switch(config-router)# maximum-prefix 1000
switch(config-router)#
 

次に、192.168.2.2 ネイバーから受け入れられるプレフィックスの最大数が 5000 に設定される例を示します。ルータは、最大プレフィックス リミット(2500 プレフィックス)の 50% に到達した段階で警告メッセージを表示するようにも設定されます。

switch# configure terminal
switch(config)# router bgp 64496
switch(config-router) network 192.168.0.0
switch(config-router)# maximum-prefix 5000 50
switch(config-router)#
 

次に、192.168.3.3 ネイバーから受け入れられるプレフィックスの最大数が 2000 に設定される例を示します。ルータは、30 分後にディセーブルにされたピアリング セッションを再確立するようにも設定されます。

switch# configure terminal
switch(config)# router bgp 64496
switch(config-router) network 192.168.0.0
switch(config-router)# neighbor 192.168.3.3 maximum-prefix 2000 restart 30
switch(config-router)#
 

次に、192.168.4.4 ネイバーの最大プレフィックス数の制限値(500)を超えたときに警告メッセージが表示される例を示します。

switch# configure terminal
switch(config)# router bgp 64496
switch(config-router)# network 192.168.0.0
switch(config-router)# maximum-prefix 500 warning-only
switch(config-router)#
 

次に、10.108.1.1 に宛てられたすべてのアップデートにより、このルータをネクスト ホップとして強制的にアドバタイズする例を示します。

switch# configure terminal
switch(config)# router bgp 64496
switch(config-router)# next-hop-self
switch(config-router)#
 

次に、ルータが自律システム 109 に属していて、IP アドレス 172.16.70.23 にあるネイバーにコミュニティ属性を送信するように設定される例を示します。

switch# configure terminal
switch(config)# router bgp 64496
switch(config-router)# send-community
switch(config-router)#
 

次に、ルータが自律システム 109 に属していて、IP アドレス 172.16.70.23 にあるネイバーにコミュニティ属性を送信するように設定される例を示します。

switch# configure terminal
switch(config)# router bgp 64496
switch(config-router)# address-family ipv4 multicast
switch(config-router-af)# send-community
switch(config-router-af)#
 

次に、ネイバー 10.108.1.1 の着信ソフト再設定をイネーブルにする例を示します。このネイバーから受信されるすべてのアップデートは、着信ポリシーを無視してそのまま格納されます。後になって着信ソフト再設定が行われるときは、格納されている情報を使用して新しい着信アップデートのセットが生成されます。

switch# configure terminal
switch(config)# router bgp 64496
switch(config-router)# soft-reconfiguration inbound
switch(config-router)#

 
関連コマンド

コマンド
説明

address-family

BGP のアドレス ファミリ モードを開始します。

password(BGP)

2 つの BGP ピアに MD5 パスワードを設定します。

router bgp

ルータに割り当てる自律システム(AS)番号を入力し、ルータで BGP コンフィギュレーション モードを開始します。