Cisco Nexus 5000 シリーズ NX-OS ユニキャスト ルーティング コマンド リファレンス
S コマンド
S コマンド
発行日;2013/04/23 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

S コマンド

send-community

set as-path

set comm-list delete

set community

set dampening

set extcommunity

set extcomm-list delete

set ip default next-hop

set ip next-hop

set ipv6 default next-hop

set ipv6 next-hop

set ipv6 default next-hop

set local-preference

set metric

set metric-type

set origin

set tag

set vrf

set weight

shutdown(BGP)

soft-reconfiguration inbound(BGP)

suppress-inactive

S コマンド

この章では、S で始まる Cisco NX-OS ボーダー ゲートウェイ プロトコル(BGP)コマンドについて説明します。

send-community

ピアにボーダー ゲートウェイ プロトコル(BGP)コミュニティ属性を送信するには、 send-community コマンドを使用します。デフォルトの設定に戻すには、このコマンドの no 形式を使用します。

send-community [ extended ]

no send-community [ extended ]

 
構文の説明

extended

(任意)BGP 拡張コミュニティを指定します。

 
コマンド デフォルト

ピアにコミュニティ属性は送信されません。

 
コマンド モード

BGP ネイバー アドレスファミリ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドを使用する前に、 set community コマンドを使用して BGP コミュニティを設定する必要があります。

このコマンドには、LAN Enterprise Services ライセンスが必要です。

次に、ネイバー 192.168.1.3 にコミュニティ属性を送信するようにルータを設定する例を示します。

switch# configure terminal
switch(config)# router bgp 102
switch(config-router)# neighbor 192.168.1.3 remote-as 64497
switch(config-router-neighbor)# address-family ipv4 multicast
switch(config-router-neighbor-af)# send-community
switch(config-router-neighbor-af)#
 

 
関連コマンド

コマンド
説明

set community

BGP コミュニティ属性を定義します。

show ip bgp

BGP 設定情報を表示します。

set as-path

BGP ルートの自律システム パス(as-path)を変更するには、 set as-path コマンドを使用します。自律システム(AS)パスを変更しないようにするには、このコマンドの no 形式を使用します。

set as-path { tag | { prepend as-num [ ... as-num ] | last-as num }}

no as-path { tag | { prepend as-num [.. . as-num ] | last-as num }}

 
構文の説明

tag

ルートのタグを自律システム パスに変換します。ルートをボーダー ゲートウェイ プロトコル(BGP)に再配布する場合にのみ適用されます。

prepend as-num

指定された AS 番号を、ルート マップと一致するルートの自律システム パスに付加します。インバウンドおよびアウトバウンド BGP ルート マップ両方に適用します。範囲:1 ~ 65535。1 つ以上の AS 番号を設定できます。

last-as num

最後の AS 番号を as-path に付加します。範囲は 1 ~ 10 です。

 
コマンド デフォルト

自律システム パスは変更されません。

 
コマンド モード

ルート マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

route-map コマンドをイネーブルにする前にポリシーベース ルーティング(PBR)をイネーブルにするには、 feature pbr グローバル コンフィギュレーション モード コマンドを入力する必要があります。

route-map コマンドを使用して、ルート マップ コンフィギュレーション モードを開始します。 route-map コマンドを入力すると、プロンプトが次のように変わります。

switch(config-route-map)#
 

ルートマップ コンフィギュレーション モードを開始すると、 set コマンドを入力できます。

最適なパス選択に影響を与える唯一のグローバル BGP メトリックは、自律システム パス長です。自律システム パスの長さを変化させることにより、BGP スピーカーは、遠くのピアによる最適パスの選択に影響を与えることができます。

タグを自律システム パスに変換することで、このコマンドの set as-path tag が変わり自律システム長を変更できます。 set as-path prepend のバリエーションを使用すれば、任意の自律システム パス文字列を BGP ルートに付加できます。通常、ローカル自律システム番号は複数回付加され、自律システム パスの長さが増加します。

次に、再配布されたルートのタグを自律システム パスに変換する例を示します。

switch(config)# route-map test1
switch(config-route-map)# set as-path tag
 

次に、10.108.1.1 にアドバタイズされたすべてのルートに 100 を付加する例を示します。

switch(config)# route-map test1
switch(config-route-map)# match as-path 1
switch(config-route-map)# set as-path prepend 100
 
 
switch(config)# router bgp 64496
switch(config-router)# neighbor 10.108.1.1 remote-as 64497
switch(config-router-neighbor)# address-family ipv4 unicast
switch(config-router-neighbor-af)# route-map set-as-path test1 out
 

 
関連コマンド

コマンド
説明

match as-path

BGP 自律システム パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定されたアクセス リストのいずれかによって渡されたネクスト ホップ ルータ アドレスを含むすべてのルートを再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric

指定したメトリックを持つルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set community

BGP コミュニティ属性を設定します。

set level

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

set comm-list delete

インバウンドまたはアウトバウンド アップデートのコミュニティ属性からコミュニティを削除するには、 set comm-list delete コマンドを使用します。以前の set comm-list delete コマンドを削除するには、このコマンドの no 形式を使用します。

set comm-list community-list-name delete

no set comm-list

 
構文の説明

community-list-name

標準または拡張コミュニティ リスト名。名前は 63 文字以下の任意の英数字文字列です。

 
コマンド デフォルト

コミュニティは削除されません。

 
コマンド モード

ルート マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

この set route-map コンフィギュレーション コマンドの場合、削除するコミュニティをフィルタリングおよび決定するルート マップを使用して、インバウンドまたはアウトバウンド アップデートのコミュニティ属性からコミュニティを削除します。ルート マップがネイバーのインバウンドまたはアウトバウンド アップデートに適用されたかどうかに応じて、ルート マップ permit 句を通過し、特定のコミュニティ リストを照合する各コミュニティは、ボーダー ゲートウェイ プロトコル(BGP)ネイバーとの間で送受信されるコミュニティ属性から削除されます。

標準コミュニティ リストの各エントリは、 set comm-list delete コマンドで使用した場合に、1 つのコミュニティのみを表示します。たとえば、コミュニティ 10:10 と 10:20 を削除できるようにするには、次の形式を使用してエントリを作成する必要があります。

switch(config)# ip community-list 500 permit 10:10
switch(config)# ip community-list 500 permit 10:20
 

コミュニティ リスト エントリの次の形式では、 set comm-list delete コマンドは実行されません。別の方法を実行してください。

switch(config)# ip community-list 500 permit 10:10 10:20
 

set community community-number コマンドと set comm-lis t delete コマンド両方がルート マップ属性の同じシーケンスに設定されている場合、削除操作( set comm-list delete )は設定操作( set community community-number )の前に実行されます。

次に、インバウンドまたはアウトバウンド アップデートのコミュニティ属性からコミュニティを削除する例を示します。

switch(config)# route-map test1
switch(config-route-map)# match as-path 1
switch(config-route-map)# set comm-list list1 delete
 

 
関連コマンド

コマンド
説明

match as-path

BGP 自律システム パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定されたアクセス リストのいずれかによって渡されたネクスト ホップ ルータ アドレスを含むすべてのルートを再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric

指定したメトリックを持つルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set community

BGP コミュニティ属性を設定します。

set level

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

set community

ボーダー ゲートウェイ プロトコル(BGP)コミュニティ属性を設定するには、 set community コマンドを使用します。エントリを削除するには、このコマンドの no 形式を使用します。

set community { none | { aa : nn [... aa:nn ] | additive | local-as | no-advertise | no-export }}

no set community { none | { aa : nn | additive | local-as | no-advertise | no-export }}

 
構文の説明

none

コミュニティ属性は指定しません。

none キーワードを設定している場合、他のキーワードは設定できません。

aa : nn

4 バイトの新しいコミュニティ形式で入力された自律システム(AS)番号およびネットワーク番号。この値は、コロンで区切られた 2 バイトの数 2 つで設定されます。それぞれの 2 バイト番号として 1 ~ 65535 の数値を入力できます。1 つのコミュニティ、または複数のコミュニティをそれぞれスペースで区切って入力できます。

1 つまたは複数の AS 番号を設定できます。

1 つまたは複数のキーワードを設定できます。

additive

既存のコミュニティに追加します。

1 つまたは複数のキーワードを設定できます。

local-as

local-as コミュニティを指定します(well-known コミュニティ)。コミュニティのあるルートは、ローカル自律システムの一部であるピアへのみ、または連合のサブ自律システム内のピアへのみアドバタイズされます。これらのルートは、外部ピアや、連合内の他のサブ自律システムにはアドバタイズされません。

1 つまたは複数のキーワードを設定できます。

no-advertise

no-advertise コミュニティを指定します(well-known コミュニティ)。このコミュニティのあるルートはピア(内部または外部)にはアドバタイズされません。

1 つまたは複数のキーワードを設定できます。

no-export

no-export コミュニティを指定します(well-known コミュニティ)。このコミュニティのあるルートは、同じ自律システム内のピアへのみ、または連合内の他のサブ自律システムへのみアドバタイズされます。これらのルートは外部ピアにはアドバタイズされません。

1 つまたは複数のキーワードを設定できます。

 
コマンド デフォルト

BGP コミュニティ属性は存在しません。

 
コマンド モード

ルート マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

タグを設定する場合は、match 句を使用する必要があります(「permit everything」リストを指している場合でも)。

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準(現在の route-map コマンドで再配布が許可される条件)を指定します。set コマンドは、set 処理( match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

set ルート マップ コンフィギュレーション コマンドは、ルート マップのすべての一致基準が満たされたときに実行される再配布 set 処理を指定します。すべての一致基準を満たすと、すべての set 処理が実行されます。

次に、自律システム パス アクセス リスト 1 を通過してコミュニティが 109:02 と 33:40 に設定されるルートを設定する例を示します。自律システム パス アクセス リスト 2 を通過するルートのコミュニティは no-export に設定されます(これらのルートは、どの外部 BGP(eBGP)ピアにもアドバタイズされません)。

switch(config)# route-map test1 10 permit
switch(config-route-map)# match as-path 1
switch(config-route-map)# set community 109:02 33:40
switch(config-route-map)# exit
switch(config)# route-map test1 20 permit
switch(config-route-map)# match as-path 2
switch(config-route-map)# set community no-export
 

次に、自律システム パス アクセス リスト 1 を通過してコミュニティが 109:30 に設定されるルートを設定する例を示します。自律システム パス アクセス リスト 2 を通過するルートのコミュニティは local-as に設定されます(ルータは、 このルートをローカル自律システムの外部のピアにはアドバタイズしません )。

switch(config)# route-map test1 10 permit
switch(config-route-map)# match as-path 1
switch(config-route-map)# set community 109:30 additive
switch(config-route-map)# exit
switch(config)# route-map test1 20 permit
switch(config-route-map)# match as-path 2
switch(config-route-map)# set community local-as
 

 
関連コマンド

コマンド
説明

ip community-list

BGP 用のコミュニティ リストを作成し、このリストへのコントロール アクセスを作成します。

match community

BGP コミュニティを照合します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set comm-list delete

インバウンドまたはアウトバウンド アップデートのコミュニティ属性からコミュニティを削除します。

show ip bgp community

指定された BGP コミュニティに属するルートを示します。

set dampening

ボーダー ゲートウェイ プロトコル(BGP)ルート ダンプニング係数を設定するには、 set dampening コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

set dampening half-life reuse suppress max-suppress-time

no set dampening

 
構文の説明

half-life

ペナルティが小さくなるまでの時間(分単位)。ルートにペナルティが割り当てられると、ペナルティは半減期で半分まで小さくなります(デフォルトでは 15 分です)。ペナルティを減らすプロセスは 5 秒ごとに発生します。範囲は 1 ~ 45 で、デフォルトは 15 です。

reuse

フラッピング ルートのペナルティがこの値を下回るまで減少すると、抑制されなくなるルート。ルートの抑制中止プロセスは、10 秒経過ごとに発生します。範囲は 1 ~ 20000 です。デフォルトは 750 です。

suppress

ペナルティがこの制限を超えると抑制されるルート。範囲は 1 ~ 20000 で、デフォルトは 2000 です。

max-suppress-time

ルートを抑制できる最長時間(分単位)。範囲は 1 ~ 255 で、デフォルトは half-life 値の 4 倍です。デフォルトの half-life 値が使用された場合、最大抑制時間はデフォルトの 60 分になります。

 
コマンド デフォルト

ディセーブル

 
コマンド モード

ルート マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準(現在の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドは、set 処理( match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

BGP ピアがリセットされた場合、ルートは廃止され、フラップ統計情報は消去されます。この場合、ルート フラップ ダンプニングがイネーブルの場合でも、withdrawal(取り消し)によるペナルティが生じません。

次に、半減期を 30 分に、再使用値を 1500 に、抑制値を 10000 に、最大抑制時間を 120 分に設定する例を示します。

switch(config)# route-map test1 10 permit
switch(config-route-map)# set dampening 30 1500 10000 120
 

 
関連コマンド

コマンド
説明

match as-path

BGP 自律システム パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定されたアクセス リストのいずれかによって渡されたネクスト ホップ ルータ アドレスを含むすべてのルートを再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric

指定したメトリックを持つルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set community

BGP コミュニティ属性を設定します。

set level

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

set extcommunity

BGP 拡張コミュニティ属性を設定するには、 set extcommunity コマンドを使用します。エントリを削除するには、このコマンドの no 形式を使用します。

set extcommunity { none | { generic { transitive | nontransitive } aa4 : nn [... aa4:nn ] } | additive }

no set extcommunity { none | { generic { transitive | nontransitive } aa4 : nn [... aa4:nn ] } | additive }

 
構文の説明

none

コミュニティ属性は指定しません。

generic

汎用特定拡張コミュニティ タイプを指定します。

transitive

拡張コミュニティ属性を他の自律システムに伝搬するように BGP を設定します。

nontransitive

拡張コミュニティ属性を他の自律システムに伝搬するように BGP を設定します。

aa4 : nn

自律システム番号とネットワーク番号。この値は、コロンで区切られた 4 バイトの AS 番号と 2 バイトのネットワーク番号を使用して設定されます。4 バイトの AS 番号の範囲は 1 ~ 4294967295(プレーンテキスト表記)または 1.0 ~ 56636.65535(AS.dot 表記)です。単一のコミュニティまたはスペースで区切られた複数のコミュニティを入力できます。

additive

既存のコミュニティに追加します。

 
コマンド デフォルト

BGP コミュニティ属性は存在しません。

 
コマンド モード

ルート マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

set extcommunity コマンドは、ルート マップ内で BGP ルート内の拡張コミュニティ属性を設定するために使用します。

set コマンドを使用する場合は、ルート マップ内に match 句を入力する必要があります(「permit everything」リストを指している場合でも)。

set コマンドは、ルート マップのすべての一致基準が満たされたときに実行される set 処理を指定します。すべての一致基準を満たすと、すべての set 処理が実行されます。

次に、拡張コミュニティを 1.5 に設定するルート マップを設定する例を示します。

switch(config)# route-map test1 10 permit
switch(config-route-map)# match as-path 1
switch(config-route-map)# set extcommunity generic transitive 1.5
switch(config-route-map)# exit
 

 
関連コマンド

コマンド
説明

ip extcommunity-list

BGP のコミュニティ リストを作成し、アクセスを制御します。

match extcommunity

ルート マップ内の拡張コミュニティを照合します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義します。

send-community

コミュニティ属性を BGP ピアに伝搬するように BGP を設定します。

 

set extcomm-list delete

インバウンドまたはアウトバウンド BGP アップデートの拡張コミュニティ属性から拡張コミュニティを削除するには、 set extcomm-list delete コマンドを使用します。以前の set comm-list delete コマンドを削除するには、このコマンドの no 形式を使用します。

set extcomm-list community-list-name delete

no set extcomm-list

 
構文の説明

community-list-name

標準または詳細拡張コミュニティ リスト名。名前は 63 文字以下の任意の英数字文字列です。

 
コマンド デフォルト

コミュニティは削除されません。

 
コマンド モード

ルート マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

set extcomm-list コマンドは、ルート マップ内で BGP ルート内の拡張コミュニティ属性を削除するために使用します。

set コマンドを使用する場合は、ルート マップ内に match 句を入力する必要があります(「permit everything」リストを指している場合でも)。

set コマンドは、ルート マップのすべての一致基準が満たされたときに実行される set 処理を指定します。すべての一致基準を満たすと、すべての set 処理が実行されます。

set extcommunity community-number コマンドと set ext comm-lis t delete コマンドの両方をルート マップ属性の同じシーケンスで設定した場合は、set 処理( set extcommunity community-number )の前に deletion 処理( set extcomm-list delete )が実行されます。

次に、インバウンドまたはアウトバウンド アップデートの拡張コミュニティ属性から拡張コミュニティを削除する例を示します。

switch# configure terminal
switch(config)# route-map test1
switch(config-route-map)# match as-path 1
switch(config-route-map)# set extcomm-list list1 delete
switch(config-route-map)#

 
関連コマンド

コマンド
説明

match as-path

BGP 自律システム パス アクセス リストを照合します。

match extcommunity

BGP 拡張コミュニティを照合します。

set extcommunity

BGP 拡張コミュニティ属性を設定します。

show route-map

ルート マップの情報を表示します。

 

set ip default next-hop

ポリシー ルーティングのルート マップの match 句を満たしたパケットのうち、Cisco NX-OS ソフトウェアが宛先に対する明示ルートを持っていないパケットの出力先を指定するには、 set ip default next-hop コマンドを使用します。エントリを削除するには、このコマンドの no 形式を使用します。

set ip default next-hop ip-address [ ... ip-address ] [ load-share ]

no set ip default next-hop ip-address [ ... ip-address ]

 
構文の説明

ip-address

パケットが出力される出力先ネクスト ホップの IP アドレス。ネクスト ホップは隣接ルータである必要があります。最大 32 の IP アドレスを設定できます。

load-share

(任意)ロード シェアリングをイネーブルにします。

 
コマンド デフォルト

このコマンドは、デフォルトでディセーブルになっています。

 
コマンド モード

ルート マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

コマンド構文の省略記号(...)は、コマンド入力で ip-address 引数 に複数の値を含めることができることを示します。

このコマンドを使用すると、特定のユーザに異なるデフォルト ルートを提供します。ソフトウェアがパケットの宛先への明示ルートを持たない場合、パケットは次のネクスト ホップにルーティングされます。 set ip default next-hop コマンドで指定された最初のネクスト ホップはルータに隣接している必要があります。次に、オプションの IP アドレスが使用されます。

ポリシー ルーティング パケットに関する条件を定義するには、 ip policy route-map インターフェイス コンフィギュレーション コマンド、 route-map グローバル コンフィギュレーション コマンド、 match および set route-map コンフィギュレーション コマンドを使用します。 ip policy route-map コマンドは、名前でルート マップを識別します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。match コマンドは、一致基準(ポリシー ルーティングが発生する条件)を指定します。 set コマンドは、set 処理( match コマンドによって強制される基準が満たされた場合に実行される特定のルーティング アクション)を指定します。

set 句は互いに組み合わせて使用できます。set 句は次の順で評価されます。

1. set ip next-hop

2. set ip default next-hop


) set ip next-hop と set ip default next-hop は類似のコマンドですが、操作順が異なります。set ip next-hop コマンドを設定すると、最初にポリシー ルーティングを使用してからルーティング テーブルを使用します。 set ip default next-hop コマンドを設定すると、最初にルーティング テーブルを使用してから指定のネクスト ホップをポリシー ルーティングします。


次に、IPv4 デフォルト ネクスト ホップ アドレスを設定するルート マップを設定する例を示します。

switch(config)# ip access-list test
switch(config-ip-acl)# permit ip 192.0.2.0/24 any
switch(config-ip-acl)# exit
switch(config)# route-map equal-access
switch(config-route-map)# match ip address test
switch(config-route-map)# set ip default next-hop ip 192.0.2.3
switch(config-route-map))# exit
switch(config)# interface externet 2/1
switch(config-if)# ip policy route-map equal-access
 
 

 
関連コマンド

コマンド
説明

match as-path

BGP 自律システム パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定されたアクセス リストのいずれかによって渡されたネクスト ホップ ルータ アドレスを含むすべてのルートを再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric

指定したメトリックを持つルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set community

BGP コミュニティ属性を設定します。

set level

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

set ip next-hop

ポリシー ルーティングにおいてルート マップの match 句を通過するパケットの出力先を示すには、ルート マップ コンフィギュレーション モードで set ip next-hop コマンドを使用します。エントリを削除するには、このコマンドの no 形式を使用します。

set ip next-hop { ip-address [ ... ip-address ] [ load-share] | peer-address }

no set ip next-hop { ip-address [ ... ip-address ] [ load-share] | peer-address }

 
構文の説明

ip-address

パケットが出力される出力先ネクスト ホップの IP アドレス。隣接ルータである必要はありません。1 つまたは複数の IP アドレスを設定できます。

load-share

(任意)ロード シェアリングをイネーブルにします。

peer-address

ネクスト ホップを BGP ピア アドレスに設定します。

 
コマンド デフォルト

このコマンドは、デフォルトでディセーブルになっています。

 
コマンド モード

ルート マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

コマンド構文の省略記号(...)は、コマンド入力で ip-address 引数 に複数の値を含めることができることを示します。

ポリシー ルーティング パケットに関する条件を定義するには、 ip policy route-map インターフェイス コンフィギュレーション コマンド、 route-map グローバル コンフィギュレーション コマンド、 match および set コンフィギュレーション コマンドを使用します。 ip policy route-map コマンドは、名前でルート マップを識別します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準(ポリシー ルーティングが発生する条件)を指定します。 set コマンドは、set 処理( match コマンドによって強制される基準が満たされた場合に実行される特定のルーティング アクション)を指定します。

set ip next-hop コマンドで指定された最初のネクスト ホップがダウン状態になると、任意で指定された IP アドレスが使用されます。

BGP ピアのインバウンド ルート マップで peer-address キーワードを指定し、 set ip next-hop コマンドを使用すると、受信した一致するルートのネクスト ホップをネイバー ピア アドレスに設定し、サードパーティのネクスト ホップを上書きします。同じルート マップを複数の BGP ピアに適用すると、サードパーティのネクスト ホップを上書きできます。

BGP ピアのアウトバウンド ルート マップで peer-address キーワードを指定し、 set ip next-hop コマンドを使用すると、アドバタイズされた一致するルートのネクスト ホップをローカル ルータのピア アドレスに設定し、ネクスト ホップ計算をディセーブルにします。他のルートではなく、一部のルートにネクスト ホップを設定できるので、 set ip next-hop コマンドは、(ネイバー単位の) neighbor next-hop-self コマンドよりも詳細に設定できます。 neighbor next-hop-sel f コマンドを使用すると、ネクスト ホップをネイバーに送信されたすべてのルートに設定します。

set 句は互いに組み合わせて使用できます。set 句は次の順で評価されます。

1. set ip next-hop

2. set ip default next-hop

次に、3 台のルータを同じ LAN 上に設定する例を示します(IP アドレスは、それぞれ 10.1.1.1、10.1.1.2、10.1.1.3)。それぞれが異なる Autonomous System(AS; 自律システム)です。 set ip next-hop peer-address コマンドは、ルート マップと一致する、リモート自律システム 64496 内のルータ(10.1.1.3)からリモート自律システム 64497 内のルータ(10.1.1.1)へのトラフィックが、LAN への相互接続上で自律システム 100 内のルータ(10.1.1.1)に直接送信されるのではなく、ルータ bgp 64498 を通過するように指定します。

switch(config)# router bgp 64498
switch(config-router)# neighbor 10.1.1.3 remote-as 64496
switch(config-router)# neighbor 10.1.1.3 route-map set-peer-address out
switch(config-router)# neighbor 10.1.1.1 remote-as 64497
!
switch(config)# route-map set-peer-address permit 10
switch(config-route-map)# set ip next-hop peer-address
 

 
関連コマンド

コマンド
説明

ip policy route-map

インターフェイスでポリシー ルーティングに使用するルート マップを特定します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match length

パケットのレベル 3 長に基づいてポリシー ルーティングを実行します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set ip default next-hop

ポリシー ルーティングにおいてルート マップの match 句を通過するパケットの宛先への明示ルートを Cisco NX-OS ソフトウェアが持たない場合の出力先を示します。

set ipv6 default next-hop

ポリシー ルーティングのルート マップの match 句を満たしたパケットのうち、Cisco NX-OS ソフトウェアが宛先に対する明示ルートを持っていないパケットの出力先を指定するには、 set ipv6 default next-hop コマンドを使用します。エントリを削除するには、このコマンドの no 形式を使用します。

set ipv6 default next-hop ipv6-address [ ...ipv6-address ] [ load-share ]

no set ipv6 default next-hop ipv6-address [ ...ipv6-address ]

 
構文の説明

ipv6-address

パケットが出力されるネクスト ホップの IPv6 アドレス。ネクスト ホップは隣接ルータである必要があります。最大 32 個の IPv6 アドレスを設定できます。

load-share

(任意)ロード シェアリングをイネーブルにします。

 
デフォルト

このコマンドは、デフォルトでディセーブルになっています。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

コマンド構文の省略記号(...)は、コマンド入力で ipv6-address 引数に複数の値を含めることができることを意味します

このコマンドを使用すると、特定のユーザに異なるデフォルト ルートを提供します。ソフトウェアがパケットの宛先への明示ルートを持たない場合、パケットは次のネクスト ホップにルーティングされます。 set ipv6 default next-hop コマンドで指定された最初のネクスト ホップはルータに隣接している必要があります。次に、オプションの IP アドレスが使用されます。

ポリシー ルーティング パケットに関する条件を定義するには、 ipv6 policy route-map インターフェイス コンフィギュレーション コマンド、 route-map グローバル コンフィギュレーション コマンド、 match および set route-map コンフィギュレーション コマンドを使用します。 ipv6 policy route-map コマンドは、名前でルート マップを識別します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。match コマンドは、 一致基準ポリシー ルーティングが発生する条件)を指定します。 set コマンドは、 set 処理 match コマンドによって強制される基準が満たされた場合に実行される特定のルーティング アクション)を指定します。

set 句は互いに組み合わせて使用できます。set 句は次の順で評価されます。

1. set ipv6 next-hop

2. set ipv6 default next-hop


) set ipv6 next-hop と set ipv6 default next-hop は類似のコマンドですが、操作順が異なります。set ipv6 next-hop コマンドを設定すると、システムで最初にポリシー ルーティングが使用されてから、ルーティング テーブルが使用されます。set ipv6 default next-hop コマンドを設定すると、システムで最初にルーティング テーブルが使用されてから、指定されたネクスト ホップがポリシー ルーティングされます。


このコマンドにライセンスは必要ありません。

次に、IPv6 デフォルト ネクストホップ アドレスの設定を行うルート マップを設定する例を示します。

switch(config)# ipv6 access-list test
switch(config-ipv6-acl)# permit ipv6 2001:0DB8::/48 any
switch(config-ipv6-acl)# exit
switch(config)# route-map equal-access
switch(config-route-map)# match ipv6 address test
switch(config-route-map)# set ipv6 default next-hop 2001:0DB8::3
switch(config-route-map))# exit
switch(config)# interface externet 2/1
switch(config-if)# ipv6 policy route-map equal-access
 

 
関連コマンド

コマンド
説明

match as-path

BGP 自律システム パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ipv6 address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ipv6 next-hop

指定のアクセス リストのいずれかが通過する、ネクスト ホップ ルータ アドレスを持ったルートをすべて再配布します。

match ipv6 route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric

指定したメトリックを持つルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set community

BGP コミュニティ属性を設定します。

set level

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

set ipv6 next-hop

ポリシー ルーティングでルート マップの match 句を満たしたパケットの出力先を示すには、ルートマップ コンフィギュレーション モードで set ipv6 next-hop コマンドを使用します。エントリを削除するには、このコマンドの no 形式を使用します。

set ipv6 next-hop { ipv6-address [ ... ipv6-address ] [ load-share] | peer-address }

no set ipv6 next-hop { ipv6-address [ ... ipv6-address ] [ load-share] | peer-address }

 
構文の説明

ipv6-address

パケットが出力されるネクスト ホップの IPv6 アドレス。隣接ルータである必要はありません。1 つまたは複数の IP アドレスを設定できます。

load-share

(任意)ロード シェアリングをイネーブルにします。

peer-address

ネクスト ホップを BGP ピア アドレスに設定します。

 
デフォルト

このコマンドは、デフォルトでディセーブルになっています。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

コマンド構文の省略記号(...)は、コマンド入力で ipv6-address 引数に複数の値を含めることができることを意味します

このコマンドを使用すると、特定のユーザに異なるデフォルト ルートを提供します。ソフトウェアがパケットの宛先への明示ルートを持たない場合、パケットは次のネクスト ホップにルーティングされます。 set ipv6 default next-hop コマンドで指定された最初のネクスト ホップはルータに隣接している必要があります。次に、オプションの IP アドレスが使用されます。

ポリシー ルーティング パケットに関する条件を定義するには、 ipv6 policy route-map インターフェイス コンフィギュレーション コマンド、 route-map グローバル コンフィギュレーション コマンド、 match および set route-map コンフィギュレーション コマンドを使用します。 ipv6 policy route-map コマンドは、名前でルート マップを識別します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。match コマンドは、 一致基準ポリシー ルーティングが発生する条件)を指定します。 set コマンドは、 set 処理 match コマンドによって強制される基準が満たされた場合に実行される特定のルーティング アクション)を指定します。

set 句は互いに組み合わせて使用できます。set 句は次の順で評価されます。

1. set ipv6 next-hop

2. set ipv6 default next-hop


) set ipv6 next-hop と set ipv6 default next-hop は類似のコマンドですが、操作順が異なります。set ipv6 next-hop コマンドを設定すると、システムで最初にポリシー ルーティングが使用されてから、ルーティング テーブルが使用されます。set ipv6 default next-hop コマンドを設定すると、システムで最初にルーティング テーブルが使用されてから、指定されたネクスト ホップがポリシー ルーティングされます。


このコマンドにライセンスは必要ありません。

次に、IPv6 ネクストホップ アドレスの設定を行うルート マップを設定する例を示します。

switch(config)# ipv6 access-list test
switch(config-ipv6-acl)# permit ipv6 2001:0DB8::/48 any
switch(config-ipv6-acl)# exit
switch(config)# route-map equal-access
switch(config-route-map)# match ipv6 address test
switch(config-route-map)# set ipv6 next-hop 2001:0DB8::3
switch(config-route-map))# exit
switch(config)# interface externet 2/1
switch(config-if)# ipv6 policy route-map equal-access
 

 
関連コマンド

コマンド
説明

match as-path

BGP 自律システム パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ipv6 address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ipv6 next-hop

指定のアクセス リストのいずれかが通過する、ネクスト ホップ ルータ アドレスを持ったルートをすべて再配布します。

match ipv6 route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set ipv6 default next-hop

ネクスト ホップのアドレスを指定します。

set ipv6 default next-hop

ポリシー ルーティングのルート マップの match 句を満たすパケットのうち、Cisco NX-OS ソフトウェアが宛先への明示的なルートを認識していないパケットの出力先を指定するには、ルート マップ コンフィギュレーション モードで set ipv6 default next-hop コマンドを使用します。エントリを削除するには、このコマンドの no 形式を使用します。

set ipv6 default next-hop ipv6-address [ ...ipv6-address ] [ load-share ]

no set ipv6 default next-hop ipv6-address [ ...ip-address ]

 
構文の説明

ipv6-address

パケットが出力される出力先ネクスト ホップの IP アドレス。ネクスト ホップは隣接ルータである必要があります。1 つまたは複数の IP アドレスを入力できます。

load-share

(任意)ロード シェアリングをイネーブルにします。

 
コマンド デフォルト

このコマンドは、デフォルトでディセーブルになっています。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

 
コマンド履歴

リリース
変更内容

5.2(1)

このコマンドが導入されました。

 
使用上のガイドライン

コマンド構文の省略記号(...)は、コマンド入力で ipv6-address 引数に複数の値を含めることができることを意味します

このコマンドを使用すると、特定のユーザに異なるデフォルト ルートを提供します。ソフトウェアがパケットの宛先への明示ルートを持たない場合、パケットは次のネクスト ホップにルーティングされます。 set ipv6 default next-hop コマンドで指定された最初のネクスト ホップはルータに隣接している必要があります。次に、オプションの IP アドレスが使用されます。

ポリシー ルーティング パケットに関する条件を定義するには、 ipv6 policy route-map インターフェイス コンフィギュレーション コマンド、 route-map グローバル コンフィギュレーション コマンド、 match および set route-map コンフィギュレーション コマンドを使用します。 ipv6 policy route-map コマンドは、名前でルート マップを識別します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。match コマンドは、 一致基準ポリシー ルーティングが発生する条件)を指定します。 set コマンドは、 set 処理 match コマンドによって強制される基準が満たされた場合に実行される特定のルーティング アクション)を指定します。

set 句は互いに組み合わせて使用できます。set 句は次の順で評価されます。

1. set ipv6 next-hop

2. set ipv6 default next-hop


) set ipv6 next-hop と set ipv6 default next-hop は類似のコマンドですが、操作順が異なります。set ipv6 next-hop コマンドを設定すると、システムで最初にポリシー ルーティングが使用されてから、ルーティング テーブルが使用されます。set ipv6 default next-hop コマンドを設定すると、システムで最初にルーティング テーブルが使用されてから、指定されたネクスト ホップがポリシー ルーティングされます。


このコマンドにライセンスは必要ありません。

次に、2 つの送信元が、異なるサービス プロバイダーに対して同等アクセスを持つ例を示します。パケットの宛先についての明示ルートがソフトウェアにない場合、送信元 10.1.1.1 からイーサネット インターフェイス 1 に届くパケットは、172.16.6.6 のルータに送られます。パケットの宛先についての明示ルートがソフトウェアにない場合、送信元 10.2.2.2 から届くパケットは、172.17.7.7 のルータに送られます。ソフトウェアに宛先に関する明示ルートが設定されていないその他のパケットはすべて廃棄されます。

switch(config)# access-list 1 permit ip 10.1.1.1 0.0.0.0
switch(config)# access-list 2 permit ip 10.2.2.2 0.0.0.0
!
switch(config)# interface ethernet 1
switch(config-if)# ip policy route-map equal-access
!
switch(config-route-map)# route-map equal-access permit 10
switch(config-route-map)# match ipv6 address 1
switch(config-route-map)# set ipv6 default next-hop 172.16.6.6
switch(config-route-map)# route-map equal-access permit 20
switch(config-route-map)# match ip address 2
switch(config-route-map)# set ipv6 default next-hop 172.17.7.7
switch(config-route-map)# route-map equal-access permit 30
switch(config-route-map)# set default interface null0

set local-preference

自律システム パスにプリファレンス値を指定するには、 set local-preference コマンドを使用します。エントリを削除するには、このコマンドの no 形式を使用します。

set local-preference number-value

no set local-preference number-value

 
構文の説明

number-value

プリファレンス値。範囲は 0 ~ 4294967295 です。デフォルトは 100 です。

 
コマンド デフォルト

デフォルトでは、プリファレンス値は 100 です。

 
コマンド モード

ルート マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

プリファレンスは、ローカル自律システム内のすべてのルータにのみ送信されます。

タグを設定する場合は、match 句を使用する必要があります(「permit everything」リストを指している場合でも)。

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準(現在の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドは、set 処理( match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

set route-map コンフィギュレーション コマンドは、ルート マップのすべての一致基準が満たされたときに実行される再配布 set 処理を指定します。すべての一致基準を満たすと、すべての set 処理が実行されます。

bgp default local-preference コマンドを使用して、デフォルトのプリファレンス値を変更できます。

次に、アクセス リスト 1 に含まれるすべてのルートに対して、ローカル プリファレンスを 100 に設定する例を示します。

switch# configure terminal
switch(config)# route-map test1
switch(config-router)# route-map map-preference
switch(config-route-map)# match as-path 1
switch(config-route-map)# set local-preference 100
switch(config-route-map)#

 
関連コマンド

コマンド
説明

match as-path

BGP 自律システム パス アクセス リストを照合します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

show route-map

ルート マップの情報を表示します。

 

set metric

ルーティング プロトコルのメトリック値を設定するには、 set metric コマンドを使用します。デフォルトのメトリック値に戻すには、このコマンドの no 形式を使用します。

set metric [ + | - ] bandwidth-metric

set metric bandwidth-metric [d elay-metric reliability-metric load-metric mtu ]

no set metric

 
構文の説明

+

(任意)既存の遅延メトリック値に加算します。

-

(任意)既存の遅延メトリック値から減算します。

bandwidth-metric

Interior Gateway Routing Protocol(IGRP)帯域幅(Kb/s 単位)。範囲は 0 ~ 4294967295 です。

delay-metric

(任意)IGRP 遅延メトリック(10 マイクロ秒単位)。指定できる範囲は 1 ~ 4294967295 です。

reliability-metric

(任意)IGRP 信頼性メトリック。有効な範囲は 0 ~ 255 です。

load-metric

(任意)IGRP 負荷メトリック。指定できる範囲は 1 ~ 255 です。

mtu

(任意)パスの IGRP 最大伝送単位(MTU)。指定できる範囲は 1 ~ 4294967295 です。

 
コマンド デフォルト

なし

 
コマンド モード

ルート マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

set metric コマンドは、IGRP メトリック値を変更するために使用します。


) デフォルト値を変更する前に、シスコのテクニカル サポート担当者に問い合わせてください。


r eliability-metric 引数と load-metric 引数を設定する場合、255 は 100% の信頼性を意味します。

+ キーワードまたは - キーワードは、既存の遅延メトリック値を変更するために使用します。これらのキーワードを使用する場合は、遅延メトリックしか変更できません。

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準(現在の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドは、set 処理( match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

set route-map コンフィギュレーション コマンドは、ルート マップのすべての一致基準が満たされたときに実行される再配布 set 処理を指定します。すべての一致基準を満たすと、すべての set 処理が実行されます。

次に、ルーティング プロトコルの帯域幅メトリック値を 100 に設定する例を示します。

switch# configure terminal
switch(config)# route-map set-metric
switch(config-route-map)# set metric 100
switch(config-route-map)#
 

次に、ルーティング プロトコルの帯域幅メトリック値を 100 増やす例を示します。

switch# configure terminal
switch(config)# route-map set-metric
switch(config-route-map)# set metric +100
switch(config-route-map)#

 
関連コマンド

コマンド
説明

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

show route-map

ルート マップの情報を表示します。

 

set metric-type

宛先ルーティング プロトコルのメトリック値を設定するには、 set metric-type コマンドを使用します。デフォルトに戻るには、 no 形式のコマンドを使用します。

set metric-type { internal | external | type-1 | type-2 }

no set metric-type { internal | external | type-1 | type-2 }

 
構文の説明

internal

Intermediate System-to-Intermediate System(IS-IS)内部メトリックまたは Interior Gateway Protocol(IGP)メトリックを BGP の Multi-Exit Discriminator(MED)として指定します。

external

IS-IS 外部メトリックを指定します。

type-1

OSPF 外部タイプ 1 メトリックを指定します。

type-2

OSPF 外部タイプ 2 メトリックを指定します。

 
コマンド デフォルト

このコマンドは、デフォルトでディセーブルになっています。

 
コマンド モード

ルート マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準(現在の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドは、set 処理( match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

set route-map コンフィギュレーション コマンドは、ルート マップのすべての一致基準が満たされたときに実行される再配布 set 処理を指定します。すべての一致基準を満たすと、すべての set 処理が実行されます。


) このコマンドは、BGP へのルートの再配送ではサポートされていません。


次に、宛先プロトコルのメトリック タイプを OSPF 外部タイプ 1 に設定する例を示します。

switch# configure terminal
switch(config)# route-map map-type
switch(config-route-map)# set metric-type type-1
switch(config-route-map)#

 
関連コマンド

コマンド
説明

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

show ip community-list

コミュニティ リストの情報を表示します。

show ip extcommunity-list

拡張コミュニティ リストの情報を表示します。

show ip prefix-list

IPv4 プレフィックス リストに関する情報を表示します。

show route-map

ルート マップの情報を表示します。

 

set origin

ボーダー ゲートウェイ プロトコル(BGP)送信元コードを設定するには、 set origin コマンドを使用します。エントリを削除するには、このコマンドの no 形式を使用します。

set origin { egp as-num [: as-num ] | igp | incomplete }

no set origin

 
構文の説明

egp as-num

リモート エクステリア ゲートウェイ プロトコル(EGP)システムの自律システム(AS)番号を指定します。AS 番号を 2 バイトの整数または 4 バイトの整数として aa:nn 形式で指定できます。値の範囲は 1 ~ 65535 です。

igp

ローカル IGP システムを指定します。

incomplete

未知の継承を指定します。

 
コマンド デフォルト

主な IP ルーティング テーブルのルートに基づいた、デフォルトの送信元

 
コマンド モード

ルート マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

タグを設定する場合は、match 句を使用する必要があります(「permit everything」リストを指している場合でも)。

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準(現在の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドは、set 処理( match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドを実行すると、ルートマップが削除されます。

set route-map コンフィギュレーション コマンドを使用すると、ルート マップのすべての一致基準を満たした場合に実行する再配布 set 処理を指定します。すべての一致基準を満たすと、すべての set 処理が実行されます。

次に、ルート マップを IGP に送信するルートの発信を設定する例を示します。

switch# configure terminal
switch(config)# route-map set_origin
switch(config-route-map)# match as-path 10
switch(config-route-map)# set origin igp
switch(config-route-map)#

 
関連コマンド

コマンド
説明

match as-path

BGP 自律システム パス アクセス リストを照合します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

show ip community-list

コミュニティ リストの情報を表示します。

show ip extcommunity-list

拡張コミュニティ リストの情報を表示します。

show ip prefix-list

IPv4 プレフィックス リストに関する情報を表示します。

show route-map

ルート マップの情報を表示します。

 

set tag

宛先ルーティング プロトコルのタグ値を設定するには、 set tag コマンドを使用します。エントリを削除するには、このコマンドの no 形式を使用します。

set tag tag-value

no set tag tag-value

 
構文の説明

tag-value

タグの名前。値は、0 ~ 4294967295 の整数です

 
コマンド デフォルト

指定されていないと、デフォルトのアクションは、送信元ルーティング プロトコルのタグを新しい宛先プロトコルに 転送 します。

 
コマンド モード

ルート マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準(現在の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドは、set 処理( match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

set route-map コンフィギュレーション コマンドは、ルート マップのすべての一致基準が満たされたときに実行される再配布 set 処理を指定します。すべての一致基準を満たすと、すべての set 処理が実行されます。

次に、宛先ルーティング プロトコルのタグ値を 5 に設定する例を示します。

switch(config)# route-map test
switch(config-route-map)# set tag 5
 

 
関連コマンド

コマンド
説明

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

 

set vrf

ポリシーベース ルーティング(PBR)用のルート マップ内の仮想ルーティングおよび転送(VRF)インスタンスの選択をイネーブルにするには、set vrf コマンドを使用します。ルート マップ内で VRF 選択ディセーブルにするには、このコマンドの no 形式を使用します。

set vrf { vrf-name | default | management }

no set vrf [ vrf-name | default | management ]

 
構文の説明

vrf-name

VRF に割り当てられた名前。名前は 32 文字の英数字で、大文字と小文字が区別されます。

default

VRF をデフォルトの VRF に設定します。

management

VRF を管理 VRF に設定します。

 
コマンド デフォルト

なし

 
コマンド モード

ルート マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

set vrf route-map コンフィギュレーション コマンドが、MPLS VPN とともに導入されました(ポリシー ベース ルーティング機能を使用した VRF 選択により、VRF 選択の PBR メカニズムを提供)。このコマンドは、ルート マップ経由でパケットをポリシー ルーティングすることで VRF 選択をイネーブルにするのに使用されます。ルート マップは着信インターフェイスに接続されます。一致基準は IP アクセス リストまたは IP プレフィックス リストで定義されます。match length ルート マップ コマンドを使用し、パケット長に基づいて一致基準を定義することもできます。このコマンドを設定する前に VRF を定義する必要があります。インターフェイスまたはサブインターフェイスでポリシー ルーティングをイネーブルにするには、ip policy route-map インターフェイス コンフィギュレーション コマンドを設定する必要があります。VRF が定義されていない、またはポリシー ルーティングがイネーブルでない場合に set vrf コマンドを設定しようとすると、エラー メッセージがコンソールに表示されます。


) VRF を指定するときに、パケットをインターフェイスに設定したり、ネクスト ホップを変更したりできないため、set vrf コマンドは set ip default next-hop および set ip next-hop ポリシー ルーティング コマンドと一緒に設定できません。これらの set 句のいずれかで set vrf コマンドを設定しようとすると、エラー メッセージがコンソールに表示されます。


次に、3 つの異なるアクセス リストで定義された一致基準に基づいて VRF を選択および設定するルートマップ シーケンスを設定する例を示します。(アクセス リストの設定については、この例では示しません)。ルート マップを通して一致が見つからなかった場合は、宛先がローカルになっているパケットがドロップされます。

switch(config)# route-map PBR-VRF-Selection permit 10
switch(config-route-map)# match ip address 40
switch(config-route-map)# set vrf VRF_1
!
switch(config)# route-map PBR-VRF-Selection permit 20
switch(config-route-map)# match ip address 50
switch(config-route-map)# set vrf VRF_2
!
switch(config)# route-map PBR-VRF-Selection permit 30
switch(config-route-map)# match ip address 60
switch(config-route-map)# set vrf VRF_3
 

 
関連コマンド

コマンド
説明

access-list(IP 標準)

標準 IP アクセス リストを定義します。

debug ip policy

IP ポリシー ルーティング パケットのアクティビティを示します。

ip policy route-map

インターフェイスでポリシー ルーティングに使用するルート マップを特定します。

ip vrf

VRF ルーティング テーブルを設定します。

ip vrf receive

インターフェイスの IP アドレスを接続ルート エントリとして VRF ルーティング テーブルに挿入します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスのあるルートを配布する、またはパケットでポリシー ルーティングを実行します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set weight

ルーティング テーブルのボーダー ゲートウェイ プロトコル(BGP)の重みを指定するには、 set weight コマンドを使用します。エントリを削除するには、このコマンドの no 形式を使用します。

set weight number

no set weight [ number ]

 
構文の説明

number

重み値。範囲は 0 ~ 65535 です。

 
コマンド デフォルト

重みは指定のルート マップによって変更されません。

 
コマンド モード

ルート マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

実行された重みは、最初に一致した Autonomous System(AS; 自律システム)パスに基づいています。自律システム パスが一致したときに表示された重みは、グローバルな neighbor コマンドによって割り当てられた重みを無効にします。

次に、自律システム パス アクセス リストに一致するルートの BGP 重みを 200 に設定する例を示します。

switch# configure terminal
switch(config)# route-map set-weight
switch(config-route-map)# match as-path 10
switch(config-route-map)# set weight 200
switch(config-route-map)#

 
関連コマンド

コマンド
説明

match as-path

BGP 自律システム パス アクセス リストを照合します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

show ip community-list

コミュニティ リストの情報を表示します。

show ip extcommunity-list

拡張コミュニティ リストの情報を表示します。

show ip prefix-list

IPv4 プレフィックス リストに関する情報を表示します。

show route-map

ルート マップの情報を表示します。

 

shutdown(BGP)

BGP のインスタンスをシャットダウンするには、 shutdown コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

shutdown

no shutdown

 
構文の説明

このコマンドには引数またはキーワードはありません。

 
コマンド デフォルト

イネーブル

 
コマンド モード

ルータ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

設定を削除することなく BGP のインスタンスをディセーブルにするには、 shutdown コマンドを使用します。

このコマンドには、LAN Enterprise Services ライセンスが必要です。

次に、BGP 64496 をディセーブルにする例を示します。

switch# configure terminal
switch(config)# router bgp 64496
switch(config-router)# shutdown
switch(config-router)#

 
関連コマンド

コマンド
説明

show bgp

BGP ルートを表示します。

 

soft-reconfiguration inbound(BGP)

ボーダー ゲートウェイ プロトコル(BGP)ピア アップデートの保存を開始するようにスイッチ ソフトウェアを設定するには、 soft-reconfiguration コマンドを使用します。受信したアップデートを格納しないようにするには、このコマンドの no 形式を使用します。

soft-reconfiguration inbound

no soft-reconfiguration inbound

 
構文の説明

このコマンドには引数またはキーワードはありません。

 
コマンド デフォルト

ディセーブル

 
コマンド モード

ネイバー アドレスファミリ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドを入力すると、アップデートの格納が開始されます。これは着信ソフト再設定を行うために必要です。

事前設定ではなく、ソフト再設定(ソフト リセット)を使用するには、両方の BGP ピアがソフト ルート リフレッシュ機能をサポートしている必要があります。

次に、192.168.0.1 にあるネイバー上でソフト再設定を設定する例を示します。

switch# configure terminal
switch(config)# router bgp 102
switch(config-router)# neighbor 192.168.0.1 remote-as 201
switch(config-router-neighbor)# address-family ipv4 unicast
switch(config-router-neighbor-af)# soft-reconfiguration inbound
switch(config-router-neighbor-af)#
 

 
関連コマンド

コマンド
説明

address-family(BGP)

BGP ルーティング セッションを設定するために、ルータでアドレス ファミリ コンフィギュレーション モードを開始します。

neighbor

BGP ネイバーを設定します。

show ip bgp neighbors

BGP ピアの情報を表示します。

 

suppress-inactive

アクティブ ルートをボーダー ゲートウェイ プロトコル(BGP)ピアへのみアドバタイズするには、 suppress-inactive コマンドを使用します。制限を削除するには、このコマンドの no 形式を使用します。デフォルトの設定に戻すには、このコマンドの default 形式を使用します。

suppress-inactive

no default suppress-inactive

 
構文の説明

このコマンドには引数またはキーワードはありません。

 
コマンド デフォルト

ルートがテーブル内でアクティブ ルートでなくても、ルートがローカル ルーティング テーブルにインストールされるとすぐに BGP はルートをピアにアドバタイズします。

 
コマンド モード

ネイバー アドレスファミリ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

アクティブ ルートのみを BGP ピアにアドバタイズするには、 suppress-inactive コマンドを使用します。

このコマンドには、LAN Enterprise Services ライセンスが必要です。

次に、サマリー アドレスを作成する例を示します。このルートにアドバタイズされたパスは、集約されるすべてのパスに含まれるすべての要素で構成された自律システム セットです。

switch# configure terminal
switch(config)# router bgp 64496
switch(config-router)# neighbor 192.0.2.1/8 remote-as 64497
switch(config-router-neighbor)# address-family ipv4 unicast
switch(config-router-neighbor af)# suppress-inactive
switch(config-router-neighbor af)#

 
関連コマンド

コマンド
説明

route-map

ルート マップを作成します。