Cisco Nexus 5000 シリーズ NX-OS ユニキャスト ルーティング コマンド リファレンス
N コマンド
N コマンド
発行日;2013/04/23 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

N コマンド

neighbor

network

nexthop route-map

next-hop-self

nexthop trigger-delay

N コマンド

この章では、N で始まる Cisco NX-OS ボーダー ゲートウェイ プロトコル(BGP)コマンドについて説明します。

neighbor

ボーダー ゲートウェイ プロトコル(BGP)ネイバー(ルータまたは VRF)を設定し、ネイバー コンフィギュレーション モードを開始するには、 neighbor コマンドを使用します。エントリを削除するには、このコマンドの no 形式を使用します。

neighbor { ip-addr | ip-prefix / length | ipv6-addr | ipv6-prefix / length } [ remote-as { as-num [ . as-num ] | route-map name }

no neighbor { ip-addr | ip-prefix / length | ipv6-addr | ipv6-prefix / length } [ remote-as { as-num [ . as-num ] | route-map name }]

 
構文の説明

ip-addr

ネイバーの IP アドレス(A.B.C.D 形式)。

ip-prefix / length

IP プレフィックスおよび IP プレフィックス長。形式は x.x.x.x/ length です。 length の範囲は 1 ~ 32 です。

ipv6-addr

ネイバーの IPv6 アドレス。フォーマットは、A:B::C:D です。

ipv6-prefix/length

ネイバーの IPv6 プレフィックスおよび IPv6 プレフィックスの長さ。形式は A:B::C:D/ length です。 length の範囲は 1 ~ 128 です。

remote-as

(任意)ネイバーの自律システム(AS)番号を指定します。

as-num

ルータと他の BGP ルータを区別し、渡されたルーティング情報にタグを付ける AS の番号。有効な範囲は 1 ~ 65535 です。

. as-num

(任意)ルータと他の BGP ルータを区別し、渡されたルーティング情報にタグを付ける AS の番号。有効な範囲は 1 ~ 65535 です。

route-map name

(任意)AS 番号のリストまたは正規表現に照らして BGP ピア AS 番号を照合するルート マップを指定します。63 文字以内の英数字のストリング(大文字と小文字を区別)で指定します。

 
コマンド デフォルト

なし

 
コマンド モード

ネイバー アドレスファミリ コンフィギュレーション モード
ルータ BGP コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

BGP ネイバー コンフィギュレーション モードから、次の操作を実行できます。

address-family :アドレスファミリ(ルータ、ネイバー、VRF)を設定します。詳細については、 address-family(BGP) コマンドを参照してください。

description description ネイバーの説明を記述します。スペースを含めて 80 文字まで入力できます。

disable-connected-check :直接接続されているピアに対する接続検証をディセーブルにします。 disable-connected-check コマンドは、ローカル ルータに直接接続された exterior Border Gateway Protocol(eBGP)ピアに対するチェックをディセーブルにするために使用します。BGP は、 disable-connected-check コマンドを使用してこのチェックがディセーブルにされていない限り、1 ホップ離れていることがわかっているすべての eBGP ピアに対する接続チェックを自動的にトリガーします。チェックが失敗した場合、BGP はセッションを開始しません。eBGP ピアに対して ebgp-multihop コマンドが設定されていない(つまり、存続可能時間(TTL)値が 1 である)場合、BGP はその EBGP ピアを 1 ホップ離れていると見なします。

このコマンドは、 neighbor コマンドで route-map キーワードが使用されている場合に無視されます。

dont-capability-negotiate :このネイバーのネゴシエーション機能をオフにします。

dynamic-capability :ダイナミック機能をイネーブルにします。

ebgp-multihop :直接接続されていないネットワーク上に存在する外部ピアとの BGP による接続を受け入れたり、接続を試行したりします。このコマンドは、 neighbor コマンドで route-map キーワードが使用されている場合に無視されます。


) このコマンドを使用する場合は、必ずシスコのテクニカルサポート担当者の指示に従ってください。


exit :現在のコマンド モードを終了します。

inherit peer-session session-name :他のピア セッション テンプレートから設定を継承するようにピアを設定します。ピア セッション テンプレートから継承文を削除するには、このコマンドの no 形式を使用します。

no :コマンドを無効にするか、デフォルト設定にします。

transport connection-mode passive :受動接続設定のみを許可します。制限を削除するには、このコマンドの no 形式を使用します。

remove-private-as :プライベート AS 番号を発信アップデートから削除します。

shutdown :このネイバーを管理上のシャットダウンにします。

timers keepalive-time :キープアライブ タイマーおよびホールド タイマーの値を秒数で設定します。範囲は 0 ~ 3600 です。デフォルトは 60 です。

update-source { ethernet mod / port | loopback virtual-interface | port-channel number [ . sub-interface ]} :BGP セッションおよびアップデートの発信元を指定します。 virtual-interface の範囲は 0 ~ 1023 です。 number の範囲は 0 ~ 4096 です。 sub-interface の範囲は 1 ~ 4093 です。

Cisco NX-OS ソフトウェアは、ネイバー コンフィギュレーション モードで update-source コマンドが入力された場合に、BGP セッションで TCP 接続に対して任意の動作可能インターフェイスを使用できるようにします。インターフェイスの割り当てを最も近いインターフェイス(最適ローカル アドレス)に復元するには、このコマンドの no 形式を使用します。

内部または外部 BGP セッションの IPv6 リンクローカル ピアリングをイネーブルにするには、 update-source コマンドを使用する必要があります。

このコマンドには、LAN Enterprise Services ライセンスが必要です。

次に、2 つの BGP ピア間で 1 ホップ eBGP ピアリング セッションを設定する例を示します。この 2 つのピアは各ルータ上のローカル ループバック インターフェイスを経由して同じネットワーク セグメント上で到達可能になっています。

BGP ピア 1

switch(config)# interface loopback 1
switch(config-if)# ip address 10.0.0.100 255.255.255
switch(config-if)# exit
switch(config)# router bgp 64497
switch(config-router)# neighbor 192.168.0.200 remote-as 64496
switch(config-router-neighbor)# update-source loopback 2
switch(config-router-neighbor)# disable-connected-check
switch(config-router-neighbor)#

BGP ピア 2

switch(config)# interface loopback 2
switch(config-if)# ip address 192.168.0.200 255.255.255
switch(config-if)# exit
switch(config)# router bgp 64496
switch(config-router)# neighbor 10.0.0.100 remote-as 64497
switch(config-router-neighbor)# update-source loopback 1
switch(config-router-neighbor)# disable-connected-check
switch(config-router-neighbor)#
 

次に、指定されたネイバーの BGP TCP 接続に、ベスト ローカル アドレスではなく、ループバック インターフェイスの IP アドレスを供給する例を示します。

switch(config)# router bgp 64496
switch(config-router)# neighbor 172.16.0.0 remote-as 64496
switch(config-router-neighbor)# update-source Loopback0
switch(config-router-neighbor)#
 

次に、自律システム 64496 内の指定されたネイバーの IPv6 BGP TCP 接続にループバック インターフェイス 0 のグローバル IPv6 アドレスを供給し、自律システム 64498 内の指定されたネイバーにイーサネット インターフェイス 2/1 のリンクローカル IPv6 アドレスを供給する例を示します。

switch(config)# router bgp 64497
switch(config-router)# neighbor 3ffe::3 remote-as 64496
switch(config-router-neighbor)# update-source Loopback0
switch(config-router-neighbor)# neighbor fe80::2 remote-as 64498
switch(config-router-neighbor)# update-source Ethernet 2/1

 

 
関連コマンド

コマンド
説明

feature bgp

ルータ上で BGP をイネーブルにします。

route-map

ルート マップを作成します。

 

network

IP プレフィックスをアドバタイズするように設定するには、 network コマンドを使用します。アドバタイズする IP プレフィックスを削除するには、このコマンドの no 形式を使用します。

network ip-addr | ip-prefix / length mask mask-num [ route-map name ]

no network ip-network | ip-prefix / length mask mask-num [ route-map name ]

 
構文の説明

ip-addr

アドバタイズする IP ネットワーク アドレス。A.B.C.D の形式を使用します。

ip-prefix / length

IP プレフィックスおよび IP プレフィックス長。IPv6 プレフィックス長は、アドレスの連続する上位何ビットがプレフィックス(アドレスのネットワーク部分)を構成するかを示す 10 進値です。10 進数値の前にスラッシュ記号が必要です。A.B.C.D/length の形式を使用します。

mask mask-num

アドバタイズする IP プレフィックスのマスクをドット付き 4 オクテット形式で設定します。

route-map name

(任意)属性を変更するルート マップの名前を指定します。

 
コマンド デフォルト

なし

 
コマンド モード

ネイバー アドレスファミリ コンフィギュレーション モード
ルータ BGP コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

アドバタイズする IP プレフィックスは、同等またはより特異性の高いルートがルーティング テーブル内に存在する場合にのみ、ピアへの最適パスおよびアドバタイズメントと見なされます。

次に、アドバタイズする IP プレフィックスを設定する例を示します。

switch(config-router-af)# network 2.2.2.2 mask 3.3.3.3 route-map test
switch(config-router-af)#
 

 
関連コマンド

コマンド
説明

show ip prefix-list

IP プレフィックス リストについての情報を表示します。

 

nexthop route-map

ボーダー ゲートウェイ プロトコル(BGP)ルートが、特定の特性に一致するルートを含むネクスト ホップのみを使用して解決されるように指定するには、 nexthop route-map コマンドを使用します。ルート マップを削除するには、このコマンドの no 形式を使用します。

nexthop route-map name

no nexthop route-map name

 
構文の説明

name

ルート マップ名。名前は、63 文字以下の任意の英数字文字列にできます。

 
コマンド デフォルト

なし

 
コマンド モード

アドレスファミリ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

nexthop route-map コマンドは、ネクストホップに対するルート ポリシー フィルタリングを設定するために使用します。

BGP ネクスト ホップ フィルタリングを使用すると、ルーティング情報ベース(RIB)でネクスト ホップ アドレスがチェックされるときに、そのネクスト ホップ アドレスの基盤となるルートがルート マップを通過するように指定できます。ルート マップでそのルートが拒否されると、ネクストホップ アドレスは到達不能として扱われます。

BGP は、ルート ポリシーによって拒否されたすべてのネクストホップを無効であるとマークし、無効なネクストホップ アドレスを使用するルートについてベスト パスを計算しません。

このコマンドには、LAN Enterprise Services ライセンスが必要です。

次に、ネクスト ホップ アドレスをフィルタリングするようにルート マップを設定する例を示します。

switch# configure terminal
switch(config)#route-map CHECK-BGP25 deny 10
switch(config-route-map)# match ip address prefix-list FILTER25
switch(config-route-map)# match source-protocol ospf-o1
switch(config-route-map)# exit
switch(config)#ip prefix-list FILTER25 seq 5 permit 0.0.0.0/0 le 25
switch(config)# router bgp 1.0
switch(config-router)# address-family ipv4 unicast
switch(config-router-af)# nexthop route-map CHECK-BGP25
switch(config-router-af)#
 

 
関連コマンド

コマンド
説明

feature bgp

BGP をイネーブルにします。

nexthop trigger-delay

BGP ネクストホップ アドレス トラッキング用の遅延時間を設定します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義します。

 

next-hop-self

ルータの IP アドレスをネクスト ホップ アドレスとして設定するには、 next-hop-self コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

next-hop-self

no next-hop-self

 
構文の説明

このコマンドには引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

BGP ネイバー アドレスファミリ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドには、LAN Enterprise Services ライセンスが必要です。

次に、ルータの IP アドレスをネクスト ホップ アドレスとして設定する例を示します。

switch# configure terminal
switch(config)# router bgp 102
switch(config-router)# neighbor 192.168.1.3 remote-as 64497
switch(config-router-neighbor)# address-family ipv4 unicast
switch(config-router-neighbor-af)# next-hop-self
switch(config-router-neighbor-af)#
 

 
関連コマンド

コマンド
説明

address-family(BGP ネイバー)

BGP ネイバー アドレスファミリ コンフィギュレーション モードを開始します。

feature bgp

BGP をイネーブルにします。

show ip bgp

BGP 構成情報を表示します。

 

nexthop trigger-delay

ネクスト ホップ計算をトリガーするためのボーダー ゲートウェイ プロトコル(BGP)遅延を指定するには、 nexthop trigger-delay コマンドを使用します。トリガー遅延をデフォルト値に設定するには、このコマンドの no 形式を使用します。

nexthop trigger-delay { critical delay | non-critical delay }

no nexthop trigger-delay { critical delay | non-critical delay }

 
構文の説明

critical delay

致命的ネクストホップ トリガー遅延をミリ秒単位で指定します。範囲は 0 ~ 4294967295 です。デフォルトは 3000 です。

non-critical delay

非致命的ネクストホップ トリガー遅延をミリ秒単位で指定します。範囲は 0 ~ 4294967295 です。デフォルトは 10000 です。

 
コマンド デフォルト

critical delay:3000 ミリ秒
noncritical delay:10000 ミリ秒

 
コマンド モード

アドレスファミリ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

nexthop trigger-delay コマンドは、BGP がネクストホップ アドレス トラッキング イベントを処理するタイミングを変更するために使用します。

non-critical delay 値は常に、少なくとも critical delay 値以上の値に設定する必要があります。

遅延は、Interior Gateway Protocol(IGP)の場合に要する時間よりも少しだけ長く設定して、イベント後に安定状態になるようにする必要があります(IGP コンバージェンス時間)。

このコマンドには、LAN Enterprise Services ライセンスが必要です。

次に、ネクスト ホップ アドレス トラッキング遅延を変更する例を示します。

switch# configure terminal
switch(config)# router bgp 1.0
switch(config-router)# address-family ipv4 unicast
switch(config-router-af)# nexthop trigger-delay critical 5000 non-critical 20000
 

 
関連コマンド

コマンド
説明

feature bgp

BGP をイネーブルにします。

nexthop route-map

BGP ネクストホップ アドレス トラッキング用のルート マップを設定します。