Cisco Nexus 5000 シリーズ NX-OS ユニキャスト ルーティング コマンド リファレンス
M コマンド
M コマンド
発行日;2013/04/23 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

M コマンド

mac-list

match as-number

match as-path

match community

match extcommunity

match interface

match ip address

match ip multicast

match ip next-hop prefix-list

match ip route-source prefix-list

match ipv6 address

match ipv6 next-hop prefix-list

match ipv6 route-source prefix-list

match metric

match mac-list

match route-type

match tag

match vlan

maxas-limit

maximum-paths(BGP)

maximum-prefix

M コマンド

この章では、M で始まる Cisco NX-OS ボーダー ゲートウェイ プロトコル(BGP)コマンドについて説明します。

mac-list

MAC アドレスに基づいてフィルタするには、 mac-list コマンドを使用します。MAC リスト エントリを削除するには、このコマンドの no 形式を使用します。

mac-list name [ seq number ] { permit | deny } mac-address [ mac-mask ]

no mac-list name [ seq number ] { permit | deny } mac-address [ mac-mask ]

 
構文の説明

name

MAC リスト名。名前には最大 32 文字の英数字を使用できます。大文字と小文字は区別されます。

seq number

(任意)MAC リスト内にエントリを作成します。 seq の範囲は 1 ~ 4294967294 です。

permit

MAC リスト内の MAC アドレスと一致するパケットまたはルートを許可します。

deny

MAC リスト内の MAC アドレスと一致するパケットまたはルートをブロックします。

mac-address

フィルタ対象の MAC アドレス。

mac-mask

(任意)照合する MAC アドレスの部分(MAC アドレス形式)。

 
コマンド デフォルト

match の値は定義されません。

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

MAC アドレスに基づいて Overlay Transport Virtualization(OTV)をフィルタリングするには、mac-list コマンドを使用します。OTV 再配布に関連付けられているルート マップ内のこの MAC リストに対して照合できます。

このコマンドには LAN Enterprise ライセンスが必要です。

次に、Red MAC リストを作成する例を示します。

switch(config)# mac-list Red seq 1 permit 0022.5579.a4c1 ffff.ffff.0000

 
関連コマンド

コマンド
説明

match mac-list

OTV 用の MAC リスト内で MAC アドレスを照合します。

show mac-list

MAC リストに関する情報を表示します。

 

match as-number

Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)自律システム(AS)番号と照合するには、 match as-number コマンドを使用します。AS 番号リスト エントリを削除するには、このコマンドの no 形式を使用します。

match as-number { number [, number ...] | as-path-access-list name [... name ]}

no match as-number { number [, number ...] | as-path-access-list name [... name ]}]

 
構文の説明

number

AS 番号。有効な範囲は 1 ~ 65535 です。

...number

(任意)AS 番号。有効な範囲は 1 ~ 65535 です。

as-path-access-list name

AS 番号を照合する AS-path アクセス リストを指定します。名前は、63 文字以下の任意の英数字文字列にできます。

... name

(任意)AS-path アクセス リスト。名前は、63 文字以下の任意の英数字文字列にできます。

 
コマンド デフォルト

なし

 
コマンド モード

ルート マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

match as-number コマンドは、正規表現を使用して AS 番号のリストまたは AS-path アクセス リストを生成するために使用します。BGP は、この一致基準を使用して、BGP セッションを構築する BGP ピアを特定します。

ルート マップは、ピアがプレフィックス ピアリングを通してローカル BGP とのセッションを確立できる AS 番号の範囲を指定するために使用します。Cisco NX-OS は、 match as-number コマンドがルート マップ内に存在する場合に他の match コマンドを無視します。

次に、AS 番号のリストを設定する例を示します。

switch(config)# route-map IGP2BGP
switch(config-route-map)# match as-number 64496, 64498-64510
 

 
関連コマンド

コマンド
説明

ip as-path access-list

AS-path リストを作成します。

neighbor

BGP ピアを設定します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

match as-path

ボーダー ゲートウェイ プロトコル(BGP)自律システム(AS)パス アクセス リストを照合するには、 match as-path コマンドを使用します。パス リスト エントリを削除するには、このコマンドの no 形式を使用します。

match as-path name [... name ]

no match as-path name [... name ]

 
構文の説明

name

自律システム パス アクセス リスト。名前は、63 文字以下の任意の英数字文字列にできます。

... name

(任意)自律システム パス アクセス リスト。最大 32 個のアクセス リスト名を設定できます

 
コマンド デフォルト

パス リストは定義されません。

 
コマンド モード

ルート マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

match as-path コマンドを使用して値を設定すると、グローバル値が上書きされます。

ルート マップは、いくつかの部分にわかれている可能性があります。 route-map コマンドに関連した少なくとも 1 つの match 句に一致しないルートは、すべて無視されます。つまり、発信ルート マップではルートはアドバタイズされず、着信ルート マップではルートは受け入れられません。一部の特定のデータを変更したい場合は、明示的な match が指定された 2 つ目のルート マップ セクションを設定する必要があります。

次に、Autonomous System(AS; 自律システム)パスと BGP AS パス アクセス リスト 20 を照合する設定の例を示します。

switch(config)# route-map IGP2BGP
switch(config-route-map)# match as-path 20
switch(config-route-map)#

 
関連コマンド

コマンド
説明

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定されたアクセス リストのいずれかによって渡されたネクスト ホップ ルータ アドレスを含むすべてのルートを再配布します。

match route-type

指定されたタイプのルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set comm-list

ルート マップの設定におけるタグ値を自動計算します。

set community

BGP コミュニティ リストを設定します(削除用)。

set level

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set origin(BGP)

BGP 送信元コードを設定します。

set tag

宛先ルーティング プロトコルの値を設定します。

set vrf

ネクストホップ解決用の Virtual Routing and Forwarding(VRF)を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match community

BGP コミュニティを照合するには、 match community コマンドを使用します。コンフィギュレーション ファイルから match community コマンドを削除し、システムをデフォルトの条件(BGP コミュニティ リスト エントリを削除)に戻すには、このコマンドの no 形式を使用します。

match community name [... name ] [ exact-match ]

no match community name [... name ] [ exact-match ]

 
構文の説明

name

1 つ以上のコミュニティ リスト名。名前は、63 文字以下の任意の英数字文字列にできます。最大 32 のコミュニティ リストを設定できます。

exact-match

(任意)完全一致が必要であることを示します。指定されたすべてのコミュニティのみが存在する必要があります。

 
コマンド デフォルト

ルート マップではコミュニティ リストの照合は行われません。

 
コマンド モード

ルート マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

ルート マップは、いくつかの部分にわかれている可能性があります。 route-map コマンドに関連した少なくとも 1 つの match コマンドに一致しないルートは、すべて無視されます。つまり、発信ルート マップではルートはアドバタイズされず、着信ルート マップではルートは受け入れられません。一部の特定のデータを変更したい場合は、明示的な match が指定された 2 つ目のルート マップ セクションを設定する必要があります。

コミュニティ リスト番号に基づく照合は、BGP に適用できる match コマンドのタイプの 1 つです。

次に、2 つの BGP コミュニティを照合する例を示します。

switch(config)# route-map test2
switch(config-route-map)# match community bgpLow bgpHigh
 

次に、コミュニティ リスト 1 に一致するルートの重みが 200 に設定される例を示します。標準コミュニティ 109 のみを含むすべてのルートの重みが 200 に設定されます。

switch(config)# ip community-list standard bgpLow permit 109
switch(config)# route-map set_weight
switch(config-route-map)# match community bgpLow exact-match
switch(config-route-map)# set weight 200
 

この例は、コミュニティ リスト 500 に一致するルートを示しています。拡張コミュニティ 1 を含むすべてのルートの重みが 150 に設定されます。

switch(config)# ip community-list expanded 500 permit [0-9]*
switch(config)# route-map MAP_NAME permit 10
switch(config-route-map)# match community 500
switch(config-route-map)# set weight 150
 

 
関連コマンド

コマンド
説明

ip community-list

BGP のコミュニティ リストを作成し、アクセスを制御します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match extcommunity

ルート マップ内の BGP 拡張コミュニティを照合するには、 match extcommunity コマンドを使用します。ルート マップから match を削除するには、このコマンドの no 形式を使用します。

match extcommunity name [... name ] [ exact-match ]

no match extommunity name [... name ] [ exact-match ]

 
構文の説明 ]

name

1 つ以上の拡張コミュニティ リスト名。名前は、63 文字以下の任意の英数字文字列にできます。最大 32 のコミュニティ リストを設定できます。

exact-match

(任意)完全一致が必要であることを示します。指定されたすべてのコミュニティとそれらの拡張コミュニティのみが存在する必要があります。

 
コマンド デフォルト

ルート マップではコミュニティ リストの照合は行われません。

 
コマンド モード

ルート マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

ルート マップは、いくつかの部分にわかれている可能性があります。ルート マップ内の少なくとも 1 つの match コマンドに一致しないルートは、すべて無視されます。つまり、発信ルート マップではルートはアドバタイズされず、着信ルート マップではルートは受け入れられません。一部の特定のデータを変更したい場合は、明示的な match が指定された 2 つ目のルート マップ セクションを設定する必要があります。

コミュニティ リスト番号に基づく照合は、BGP に適用可能な match コマンドのタイプのいずれかです。

次に、2 つの BGP 拡張コミュニティ リストを照合する例を示します。

switch(config)# route-map test2
switch(config-route-map)# match extcommunity bgpLocal bgpRemote
 

次に、拡張コミュニティ リスト bgpLocal に一致するルートが非推移的から推移的に変更される例を示します。

switch(config)# ip extcommunity-list standard bgpLocal permit generic nontransitive 1.9
switch(config)# route-map deletCommunity
switch(config-route-map)# match extcommunity bgpLocal exact-match
switch(config-route-map)# set extcommunity generic transitive 1.9
 

 
関連コマンド

コマンド
説明

ip extcommunity-list

BGP のコミュニティ リストを作成し、アクセスを制御します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義します。

send-community

コミュニティ属性を BGP ピアに伝搬するように BGP を設定します。

set extcommunity

ルート マップ内の拡張コミュニティを設定します。

match interface

ルート マップ内のインターフェイスを照合するには、 match interface コマンドを使用します。この match 設定を削除するには、このコマンドの no 形式を使用します。

match interface { interface-type number [, interface-type number ...] }

no match interface { interface-type number [, interface-type number ...] }

 
構文の説明

interface-type

インターフェイス タイプ。 ? を使用してサポートされているインターフェイスのリストを表示します。

number

(任意)インターフェイス番号。 ? を使用して範囲を表示します。

 
コマンド デフォルト

なし

 
コマンド モード

ルート マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

いずれかのインターフェイスによって到達されるルート ネクスト ホップ アドレスは、ルート マップと一致します。

ルート マップは、いくつかの部分にわかれている可能性があります。 route-map コマンドに関連する少なくとも 1 つの match 句に一致しないルートは、すべて無視されます。つまり、発信ルート マップではルートはアドバタイズされず、着信ルート マップではルートは受け入れられません。一部の特定のデータを変更したい場合は、明示的な match が指定された 2 つ目のルート マップ セクションを設定する必要があります。

次に、インターフェイスのリストを設定する例を示します。

switch(config)# route-map test1
switch(config-route-map)# match interface ethernet 2/1, ethernet 4/3
 

 
関連コマンド

コマンド
説明

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

match ip address

宛先 IP ネットワーク番号アドレスが標準アクセス リスト、拡張アクセス リスト、またはプレフィックス リストで許可されているルートを配布する場合、またはパケットでポリシー ルーティングを実行する場合は、 match ip address コマンドを使用します。 match ip address エントリを削除するには、このコマンドの no 形式を使用します。

match ip address { access-list-name [ access-list-name... ] | prefix-list prefix-list-name [ prefix-list-name... ]}

no match ip address { access-list-name [ access-list-name... ] | prefix-list prefix-list-name [ prefix-list-name... ]}

 
構文の説明

access-list-name...

標準アクセス リストまたは拡張アクセス リストの名前。最大 63 文字の英数字を使用できます。省略符号は、複数値(最大 32 のプレフィックス リスト)の入力が可能であることを示します。

prefix-list prefix-list-name ...

プレフィックス リストに基づいてルートを配布します。プレフィックス リストには最大 63 文字の英数字を使用できます。省略符号は、複数値(最大 32 のプレフィックス リスト)の入力が可能であることを示します。

 
コマンド デフォルト

アクセス リスト名もプレフィックス リストも指定されません。

 
コマンド モード

ルート マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

access-list-name 引数がサポートされるのは、PBR のルート マップに限定されます。

このコマンド構文内の省略符号(...)は、 access-list-name 引数 または prefix-list-name 引数に複数の値を入力できることを示します

同じルート マップ サブブロック内の類似 match は、「OR」(論理和)でフィルタリングされます。ルート マップ サブブロック全体の中に一致する match 節が 1 つあれば、照合の成功として処理されます。非類似 match 句は「AND」(論理積)でフィルタリングされるため、非類似照合は論理的にフィルタリングされます。最初の条件セットが満たされない場合、2 つ目の match 節がフィルタリングされます。このプロセスは一致するものが見つかるまで、または match 節がなくなるまで続きます。

ルートの再配布またはパケットのポリシー ルーティングを実行するには、ルート マップを使用します。両方の用途について、ここで説明します。

再分配

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準(現在の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドは、set 処理( match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

match route-map コンフィギュレーション コマンドには複数の形式があります。 match コマンドの順序は任意に指定できます。すべての match コマンドが満たされないと、 set コマンドで指定した set 処理に従ってルートの再配布が行われません。 match コマンドの no 形式を使用すると、指定した一致基準が削除されます。

ルート マップを使用してルートを渡す場合、ルート マップの複数のセクションに特定の match 節を入力できます。 route-map コマンドに関連する少なくとも 1 つの match 句に一致しないルートは、すべて無視されます。つまり、発信ルート マップではルートはアドバタイズされず、着信ルート マップではルートは受け入れられません。一部の特定のデータを変更したい場合は、明示的な match が指定された 2 つ目のルート マップ セクションを設定する必要があります。

ポリシー ルーティング

ルート マップには、ポリシー ルーティングをイネーブルにするというもう 1 つの用途があります。match ip address コマンドは、拡張アクセス リスト(プロトコル、プロトコル サービス、送信元または宛先の IP アドレスなど)による一致基準に基づいたパケットのポリシー ルーティングを可能にします。パケットのポリシー ルーティング条件を定義するには、 ip policy route-map インターフェイス コンフィギュレーション コマンド、 route-map グローバル コンフィギュレーション コマンド、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準(ポリシー ルーティングが発生する条件)を指定します。 set コマンドは、set 処理( match コマンドによって強制される基準が満たされた場合に実行される特定のルーティング アクション)を指定します。送信元に基づくパケットのポリシー ルーティングを、たとえばアクセス リストを使用して実行できます。

次に、アクセス リスト テストで指定されたアドレスを含むルートを照合する例を示します。

switch(config)# feature pbr
switch(config)# interface ethernet 2/10
switch(config-if)# no switchport
switch(config-if)# ip policy route-map chicago
switch(config-if)# exit
switch(config)# route-map chicago
switch(config-route-map)# match ip address test

 
関連コマンド

コマンド
説明

ip local policy route-map

インターフェイスでポリシー ルーティングに使用するルート マップを特定します。

ip policy route-map

インターフェイスでポリシー ルーティングに使用するルート マップを特定します。

match as-path

BGP 自律システム パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match interface

指定されたインターフェイスのいずれかがネクスト ホップであるルートを再配布します。

match ip next-hop

指定されたアクセス リストのいずれかによって渡されたネクスト ホップ ルータ アドレスを含むすべてのルートを再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match length

パケットのレベル 3 長に基づいてポリシー ルーティングを実行します。

match metric

指定したメトリックを持つルートを再配布します。

match route-type

指定されたタイプのルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set automatic-tag

自動的にタグ値を計算します。

set community

BGP コミュニティ属性を設定します。

set ip default next-hop

ポリシー ルーティングにおいてルート マップの match 句を通過するパケットの宛先への明示ルートを Cisco NX-OS ソフトウェアが持たない場合の出力先を示します。

set ip next-hop

ポリシー ルーティング用のルート マップの match 節を通過したパケットの送出先を示します。

set level

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match ip multicast

ルート マップの照合に IPv4 マルチキャスト機能を設定するには、 match ip multicast コマンドを使用します。この match 設定を削除するには、このコマンドの no 形式を使用します。

match ip multicast { group address / length | source address / length | rp address / length [ rp-type { asm | bidir } ]}

no match ip multicast

 
構文の説明

group address / length

グループ アドレスと、ネットワーク マスクの長さ(ビット単位)を A . B . C . D / length の形式で指定します。ネットワーク番号には、任意の有効な IP アドレスまたはプレフィックスを指定できます。ビット マスクは、0 ~ 32 の数値にできます。

group、source、および rp オプションを設定できます。

source address / length

ソース アドレスと、ネットワーク マスクの長さ(ビット単位)を A . B . C . D / length の形式で指定します。ネットワーク番号には、任意の有効な IP アドレスまたはプレフィックスを指定できます。ビット マスクは、0 ~ 32 の数値にできます。

group、source、および rp オプションを設定できます。

rp address / length

IPv4 Rendezvous Prefix(RP)と、 IPv4 プレフィックス マスクの長さ(ビット単位)を A . B . C . D / length の形式で指定します。ネットワーク番号には、任意の有効な IPv4 アドレスまたはプレフィックスを指定できます。ビット マスクは、0 ~ 32 の数値にできます。

group、source、および rp オプションを設定できます。

rp-type

(任意)マルチキャスト Rendezvous Point(RP; ランデブー ポイント)タイプを指定します。

asm

(任意)Any-Source Multicast(ASM)ランデブー ポイント タイプを指定します。

bidir

双方向(bidir)マルチキャスト RP タイプを指定します。

 
コマンド デフォルト

なし

 
コマンド モード

ルート マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

match ip multicast コマンドは、ルート マップで評価される唯一の match コマンドです。グループ プレフィックス、グループ範囲、および送信元プレフィックスを指定して、 match ip multicast コマンドでメッセージをフィルタリングできます。

照合するマルチキャスト属性を指定するには、 match ip multicast コマンドを使用します。

route-map コマンドを使用して、ルート マップ コンフィギュレーション モードを開始します。 route-map コマンドを入力すると、プロンプトが次のように変わります。

switch(config-route-map)#
 

ルートマップ コンフィギュレーション モードになると、 match ip multicast コマンドを入力できます。

group と rp の両方のオプションを設定できます。

次に、照合するネイバーの group IPv4 プレフィックスと、IPv4 プレフィックスの長さを指定する例を示します。

switch(config)# route-map blueberry
switch(config-route-map)# match ip multicast group 192.0.0.0/19
switch(config-route-map)#
 

次に、照合するネイバーの group IPv4 プレフィックスと、IPv4 プレフィックスのランデブー ポイントの両方を指定する例を示します。

switch(config)# route-map raspberry
switch(config-route-map)# match ip multicast group 192.0.0.0/19 rp 209.165.201.0/27
switch(config-route-map)#
 

 
関連コマンド

コマンド
説明

ip local policy route-map

インターフェイスでポリシー ルーティングに使用するルート マップを特定します。

ip policy route-map

インターフェイスでポリシー ルーティングに使用するルート マップを特定します。

match as-path

BGP 自律システム パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match interface

指定されたインターフェイスのいずれかがネクスト ホップであるルートを再配布します。

match ip next-hop

指定されたアクセス リストのいずれかによって渡されたネクスト ホップ ルータ アドレスを含むすべてのルートを再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match length

パケットのレベル 3 長に基づいてポリシー ルーティングを実行します。

match metric

指定したメトリックを持つルートを再配布します。

match route-type

指定されたタイプのルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set automatic-tag

自動的にタグ値を計算します。

set community

BGP コミュニティ属性を設定します。

set ip default next-hop

ポリシー ルーティングにおいてルート マップの match 句を通過するパケットの宛先への明示ルートを Cisco NX-OS ソフトウェアが持たない場合の出力先を示します。

set ip next-hop

ポリシー ルーティング用のルート マップの match 節を通過したパケットの送出先を示します。

set level

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match ip next-hop prefix-list

指定されたアクセス リストのいずれかによって渡されたネクスト ホップ ルータ アドレスを含むすべての IPv4 ルートを再配布するには、 match ip next-hop prefix-list コマンドを使用します。ネクスト ホップ エントリを削除するには、このコマンドの no 形式を使用します。

match ip next-hop prefix-list prefix-list-name [ ...prefix-list-name ]

no match ip next-hop prefix-list prefix-list-name [ ...prefix-list-name ]

 
構文の説明

prefix-list-name

プレフィックス リストの番号または名前。最大 63 文字の英数字を使用できます。省略符号は、複数値(最大 32 のプレフィックス リスト)の入力が可能であることを示します。

 
コマンド デフォルト

ネクスト ホップ アドレスの一致を必要とせず、自由にルートが再配布されます。

 
コマンド モード

ルート マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンド構文内の省略符号(...)は、 prefix-list-name 引数に複数の値を入力できることを示します

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準(現在の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドは、set 処理( match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

match route-map コンフィギュレーション コマンドには複数の形式があります。 match コマンドの順序は任意に指定できます。すべての match コマンドが満たされないと、 set コマンドで指定した set 処理に従ってルートの再配布が行われません。 match コマンドの no 形式を使用すると、指定した一致基準が削除されます。

ルートがルート マップを通過するようにするときには、ルート マップに複数の要素を持たせることができます。 route-map コマンドに関連する少なくとも 1 つの match 句に一致しないルートは、すべて無視されます。つまり、発信ルート マップではルートはアドバタイズされず、着信ルート マップではルートは受け入れられません。一部の特定のデータを変更したい場合は、明示的な match が指定された 2 つ目のルート マップ セクションを設定する必要があります。

次に、プレフィックス リスト test によって渡されたネクスト ホップ ルータ アドレスを含むルートを配布する例を示します。

switch(config)# route-map blue
switch(config-route-map)# match ip next-hop prefix-list test
switch(config-route-map)#
 

 
関連コマンド

コマンド
説明

match as-path

BGP 自律システム パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match route-type

指定されたタイプのルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set automatic-tag

自動的にタグ値を計算します。

set communit

BGP コミュニティ属性を設定します。

set level

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match ip route-source prefix-list

アクセス リストで指定されたアドレスにあるルータおよびアクセス サーバによってアドバタイズされた IPv4 ルートを再配布するには、 match ip route-source prefix-list コマンドを使用します。ルート ソース エントリを削除するには、このコマンドの no 形式を使用します。

match ip route-source prefix-list prefix-list-name [ ...prefix-list-name ]

no match ip route-source prefix-list prefix-list-name [ ...prefix-list-name ]

 
構文の説明

prefix-list-name

プレフィックス リストの番号または名前。最大 63 文字の英数字を使用できます。省略符号は、複数値(最大 32 のプレフィックス リスト)の入力が可能であることを示します。

 
コマンド デフォルト

ルート ソースに対するフィルタリングは実行されません。

 
コマンド モード

ルート マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンド構文内の省略符号(...)は、 prefix-list-name 引数に複数の値を入力できることを示します

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準(現在の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドは、set 処理( match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

match route-map コンフィギュレーション コマンドには複数の形式があります。 match コマンドの順序は任意に指定できます。すべての match コマンドが満たされないと、 set コマンドで指定した set 処理に従ってルートの再配布が行われません。 match コマンドの no 形式を使用すると、指定した一致基準が削除されます。

ルート マップは、いくつかの部分にわかれている可能性があります。 route-map コマンドに関連する少なくとも 1 つの match 句に一致しないルートは、すべて無視されます。つまり、発信ルート マップではルートはアドバタイズされず、着信ルート マップではルートは受け入れられません。一部のデータのみを変更したい場合は、2 番目のルート マップ セクションに明示的に match を指定する必要があります。

ルートのネクスト ホップとソース ルータ アドレスが同じではない場合もあります。

次に、アクセス リスト 5 および 80 で指定されているアドレスのルータおよびアクセス サーバによってアドバタイズされたルートを配布する例を示します。

switch(config)# route-map blue
switch(config-route-map)# match ip route-source prefix-list 5 80
 

 
関連コマンド

コマンド
説明

match as-path

BGP 自律システム パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定されたアクセス リストのいずれかによって渡されたネクスト ホップ ルータ アドレスを含むすべてのルートを再配布します。

match route-type

指定されたタイプのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set automatic-tag

自動的にタグ値を計算します。

set community

BGP コミュニティ属性を設定します。

set level

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match ipv6 address

宛先 IPv6 ネットワーク番号アドレスが標準アクセス リスト、拡張アクセス リスト、またはプレフィックス リストで許可されているルートを配布する場合、またはパケットにポリシー ルーティングを実行する場合は、ルートマップ コンフィギュレーション モードで match ipv6 address コマンドを使用します。 match 文をルート マップから削除するには、このコマンドの no 形式を使用します。

match ipv6 address { prefix-list prefix-list-name [ prefix-list-name... ] | access-list-name

no match ipv6 address { prefix-list prefix-list-name [ prefix-list-name... ] | access-list-name }

 
構文の説明

prefix-list prefix-list-name...

プレフィックス リストに基づいてルートを配布します。プレフィックス リストには最大 63 文字の英数字を使用できます。省略符号は、複数の値を入力可能であることを示します。最大 32 のプレフィックス リストを設定できます。

access-list-name...

標準アクセス リストまたは拡張アクセス リストの名前。最大 63 文字の英数字を使用できます。

使用できるのは、ポリシーベース ルーティング用のアクセス リストだけです。

 
デフォルト

アクセス リスト名もプレフィックス リストも指定されません。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

access-list-name 引数がサポートされるのは、PBR のルートマップに限定されます。

このコマンド構文内の省略符号(...)は、 prefix-list-name 引数に複数の値を入力できることを示します

同じルート マップ サブブロック内の類似 match は、「OR」(論理和)でフィルタリングされます。ルート マップ サブブロック全体の中に一致する match 節が 1 つあれば、照合の成功として処理されます。非類似 match 句は、「AND」(論理積)でフィルタリングされます。したがって、非類似照合は論理的にフィルタリングされます。最初の条件セットが満たされない場合、2 つ目の match 節がフィルタリングされます。このプロセスは一致するものが見つかるまで、または match 節がなくなるまで続きます。

ルートの再配布またはパケットのポリシー ルーティングを実行するには、ルート マップを使用します。両方の用途について、ここで説明します。

再分配

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、 一致基準 (現在の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドは、 set 処理( match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

match route-map コンフィギュレーション コマンドには複数の形式があります。 match コマンドの順序は任意に指定できます。すべての match コマンドが満たされないと、 set コマンドで指定した set 処理 に従ってルートの再配布が行われません。 match コマンドの no 形式を使用すると、指定した一致基準が削除されます。

ルート マップを使用してルートを渡す場合、ルート マップの複数のセクションに特定の match 節を入力できます。 route-map コマンドに関連付けられているどの match ステートメントとも一致しないルートは無視されます。したがって、そのルートは発信ルート マップ用にアドバタイズされることも、着信ルート マップ用に受け入れられることもありません。一部のデータのみ修正したい場合は、別にルート マップ セクションを設定して明示的に一致基準を指定する必要があります。

このコマンドにライセンスは必要ありません。

次に、red というアクセス リストで指定されたアドレスを持つルートを照合する例を示します。

switch(config)# feature pbr
switch(config)# route-map blue
switch(config-route-map)# match ipv6 address red
 

 
関連コマンド

コマンド
説明

ipv6 local policy route-map

インターフェイスでポリシー ルーティングに使用するルート マップを特定します。

ipv6 policy route-map

インターフェイスでポリシー ルーティングに使用するルート マップを特定します。

match as-path

BGP 自律システム パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match interface

指定されたインターフェイスのいずれかがネクスト ホップであるルートを再配布します。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクスト ホップ ルータ アドレスを持ったルートをすべて再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match length

パケットのレベル 3 長に基づいてポリシー ルーティングを実行します。

match metric

指定したメトリックを持つルートを再配布します。

match route-type

指定されたタイプのルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set automatic-tag

自動的にタグ値を計算します。

set community

BGP コミュニティ属性を設定します。

set ip default next-hop

ポリシー ルーティングにおいてルート マップの match 句を通過するパケットの宛先への明示ルートを Cisco NX-OS ソフトウェアが持たない場合の出力先を示します。

set ip next-hop

ポリシー ルーティング用のルート マップの match 節を通過したパケットの送出先を示します。

set level

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match ipv6 next-hop prefix-list

指定されたアクセス リストの 1 つにより渡されたネクスト ホップ ルータ アドレスを持つ IPv6 ルートを再配布するには、 match ipv6 next-hop prefix-list コマンドを使用します。ネクスト ホップ エントリを削除するには、このコマンドの no 形式を使用します。

match ipv6 next-hop prefix-list name [ ... name ]

no match ipv6 next-hop prefix-list name [ ... name ]

 
構文の説明

name...

プレフィックス リストの名前。最大 63 文字の英数字を使用できます。省略符号は、複数値(最大 32 のプレフィックス リスト)の入力が可能であることを示します。

 
デフォルト

ネクスト ホップ アドレスの一致を必要とせず、自由にルートが再配布されます。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンド構文内の省略符号(...)は、 name 引数に複数の値を入力できることを意味します

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、 一致基準 (現在の route-map コマンドに許可された再配布の条件)を指定します。 set コマンドは、 set 処理 match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

match route-map コンフィギュレーション コマンドには複数の形式があります。 match コマンドの順序は任意に指定できます。すべての match コマンドが満たされないと、 set コマンドで指定した set 処理 に従ってルートの再配布が行われません。 match コマンドの no 形式を使用すると、指定した一致基準が削除されます。


match コマンドがなく、set コマンドだけの許可ルート マップでは、すべてのルートが許可されます。


ルートがルート マップを通過するようにするときには、ルート マップに複数の要素を持たせることができます。 route-map コマンドに関連付けられているどの match ステートメントとも一致しないルートは無視されます。したがって、そのルートは発信ルート マップ用にアドバタイズされることも、着信ルート マップ用に受け入れられることもありません。一部のデータのみ修正したい場合は、別にルート マップ セクションを設定して明示的に一致基準を指定する必要があります。

このコマンドにライセンスは必要ありません。

次に、プレフィックス リスト 5 を通過したネクスト ホップ ルータ アドレスを持つルートを配布する例を示します。

switch(config)# route-map blue
switch(config-route-map)# match ipv6 next-hop prefix-list test

 
関連コマンド

コマンド
説明

ipv6 local policy route-map

インターフェイスでポリシー ルーティングに使用するルート マップを特定します。

ipv6 policy route-map

インターフェイスでポリシー ルーティングに使用するルート マップを特定します。

match as-path

BGP 自律システム パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ipv6 next-hop

指定のアクセス リストのいずれかが通過する、ネクスト ホップ ルータ アドレスを持ったルートをすべて再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match length

パケットのレベル 3 長に基づいてポリシー ルーティングを実行します。

match route-type

指定されたタイプのルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set community

BGP コミュニティ属性を設定します。

set ipv6 default next-hop

ポリシー ルーティングにおいてルート マップの match 句を通過するパケットの宛先への明示ルートを Cisco NX-OS ソフトウェアが持たない場合の出力先を示します。

set ipv6 next-hop

ポリシー ルーティング用のルート マップの match 節を通過したパケットの送出先を示します。

set level

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match ipv6 route-source prefix-list

アクセス リストに指定されているアドレスのルータおよびアクセス サーバによってアドバタイズされた IPv6 ルートを再配布するには、ルートマップ コンフィギュレーション モードで、 match ipv6 route-source prefix-list コマンドを使用します。ルート ソース エントリを削除するには、このコマンドの no 形式を使用します。

match ipv6 route-source prefix-list name [ ... name ]

no match ipv6 route-source prefix-list name [ ... name ]

 
構文の説明

name...

プレフィックス リストの名前。最大 63 文字の英数字を使用できます。省略符号は、複数値(最大 32 のプレフィックス リスト)の入力が可能であることを示します。

 
デフォルト

ルート ソースに対するフィルタリングは実行されません。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

 
コマンド履歴

リリース
変更内容

5.2(1)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンド構文内の省略符号(...)は、 name 引数に複数の値を入力できることを意味します

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、 一致基準 (現在の route-map コマンドに許可された再配布の条件)を指定します。 set コマンドは、 set 処理 match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

match route-map コンフィギュレーション コマンドには複数の形式があります。 match コマンドの順序は任意に指定できます。すべての match コマンドが満たされないと、 set コマンドで指定した set 処理 に従ってルートの再配布が行われません。 match コマンドの no 形式を使用すると、指定した一致基準が削除されます。

ルート マップは、いくつかの部分にわかれている可能性があります。 route-map コマンドに関連付けられているどの match ステートメントとも一致しないルートは無視されます。したがって、そのルートは発信ルート マップ用にアドバタイズされることも、着信ルート マップ用に受け入れられることもありません。一部のデータのみを変更したい場合は、2 番目のルート マップ セクションに明示的に match を指定する必要があります。

ルートのネクスト ホップとソース ルータ アドレスが同じではない場合もあります。

このコマンドにライセンスは必要ありません。

次に、プレフィックス リスト test で指定されているアドレスのルータおよびアクセス サーバによってアドバタイズされたルートを配布する例を示します。

switch(config)# route-map blue
switch(config-route-map)# match ipv6 route-source prefix-list test

 
関連コマンド

コマンド
説明

match as-path

BGP 自律システム パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクスト ホップ ルータ アドレスを持ったルートをすべて再配布します。

match route-type

指定されたタイプのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set automatic-tag

自動的にタグ値を計算します。

set community

BGP コミュニティ属性を設定します。

set level

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match metric

ルーティング メトリック値と一致するルーティング テーブル内のルートを再配布するには、 match metric コマンドを使用します。タグ エントリを削除するには、このコマンドの no 形式を使用します。

match metric metric-value [ +- deviation-number ] [... metric-value [ +- deviation-number ]]

no match metric metric-value [ +- deviation-number ] [... metric-value [ +- deviation-number ]]

 
構文の説明

metric-value

内部ルート メトリック。範囲は 1 ~ 4,294,967,295 です。

+ -

メトリックの標準偏差範囲を指定します。ルータは、その範囲内に収まるすべてのメトリックを照合します。

deviation-number

(任意) metric-value 引数に対して設定された数値をオフセットする標準偏差値。 deviation-number 引数は任意の数値にできます。デフォルトはありません。

 
コマンド デフォルト

match の値は定義されません。

 
コマンド モード

ルート マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

メトリックが指定されたルートを再配布するには、ルートマップ コンフィギュレーション モードで match metric コマンドを使用します。ルーティング テーブルから再配布されたルートに関するエントリを削除するには、このコマンドの no 形式を使用します。

deviation-number 引数を使用して、1 つ以上のメトリックまたはメトリックの範囲を指定できます。コマンドが通過するには、指定されたメトリックのうち少なくとも 1 つが一致する必要があります。

このコマンド構文内の省略符号(...)は、コマンド入力に複数の引数の値を含めることができることを意味します

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準(現在の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドは、set 処理( match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

match route-map コンフィギュレーション コマンドには複数の形式があります。 match コマンドの順序は任意に指定できます。すべての match コマンドが満たされないと、 set コマンドで指定した set 処理に従ってルートの再配布が行われません。 match コマンドの no 形式を使用すると、指定した一致基準が削除されます。

ルート マップは、いくつかの部分にわかれている可能性があります。 route-map コマンドに関連する少なくとも 1 つの match 句に一致しないルートは、すべて無視されます。つまり、発信ルート マップではルートはアドバタイズされず、着信ルート マップではルートは受け入れられません。一部の特定のデータを変更したい場合は、明示的な match が指定された 2 つ目のルート マップ セクションを設定する必要があります。

次に、ルーティング テーブルにメトリック 5 で保存されたルートを再配布する例を示します。

switch(config)# route-map blueberry
switch(config-route-map)# match metric 5
 

 
関連コマンド

コマンド
説明

match as-path

BGP 自律システム パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定されたアクセス リストのいずれかによって渡されたネクスト ホップ ルータ アドレスを含むすべてのルートを再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric

指定したメトリックを持つルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set community

BGP コミュニティ属性を設定します。

set level

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match mac-list

MAC リスト内の MAC アドレスに一致するルーティング テーブル内のルートを再配布するには、 match mac-list コマンドを使用します。タグ エントリを削除するには、このコマンドの no 形式を使用します。

match mac-list listname

no match mac-list listname

 
構文の説明

listname

MAC リスト名。名前には最大 32 文字の英数字を使用できます。大文字と小文字は区別されます。

 
コマンド デフォルト

match の値は定義されません。

 
コマンド モード

ルート マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

MAC アドレスが指定されたルートを Overlay Transport Virtualization(OTV)ネットワークに再配布するには、ルートマップ コンフィギュレーション モードで match mac-list コマンドを使用します。ルーティング テーブルから再配布されたルートに関するエントリを削除するには、このコマンドの no 形式を使用します。

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準(現在の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドは、set 処理( match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

match route-map コンフィギュレーション コマンドには複数の形式があります。 match コマンドの順序は任意に指定できます。すべての match コマンドが満たされないと、 set コマンドで指定した set 処理に従ってルートの再配布が行われません。 match コマンドの no 形式を使用すると、指定した一致基準が削除されます。

ルート マップは、いくつかの部分にわかれている可能性があります。 route-map コマンドに関連する少なくとも 1 つの match 句に一致しないルートは、すべて無視されます。つまり、発信ルート マップではルートはアドバタイズされず、着信ルート マップではルートは受け入れられません。一部の特定のデータを変更したい場合は、明示的な match が指定された 2 つ目のルート マップ セクションを設定する必要があります。

このコマンドには LAN Enterprise ライセンスが必要です。

次に、Red MAC リスト内のエントリと一致する、ルーティング テーブルに保存されたルートを再配布する例を示します。

switch# configure terminal
switch(config)# route-map blueberry
switch(config-route-map)# match mac-list Red
switch(config-route-map)#

 
関連コマンド

コマンド
説明

match as-path

BGP 自律システム パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定されたアクセス リストのいずれかによって渡されたネクスト ホップ ルータ アドレスを含むすべてのルートを再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric

指定したメトリックを持つルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set community

BGP コミュニティ属性を設定します。

set level

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

 

match route-type

指定されたタイプのルートを再配布するには、 matchroute-type コマンドを使用します。ルート タイプ エントリを削除するには、このコマンドの no 形式を使用します。

match route-type { external | internal | level-1 | level-2 | local | nssa-external | type-1 | type-2 }

no match route-type { external | internal | level-1 | level-2 | local | nssa-external | type-1 | type-2 }

 
構文の説明

external

外部ルートを指定します(Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)、Enhanced Interior Gateway Routing Protocol(EIGRP)、および Open Shortest Path First(OSPF)タイプ 1/2)。複数のキーワードを指定できます。

internal

内部ルートを指定します(OSPF エリア内/エリア間) 複数のキーワードを指定できます。

level-1

Intermediate System-to-Intermediate System(IS-IS)レベル 1 ルートを指定します。

複数のキーワードを指定できます。

level-2

IS-IS レベル 2 ルートを指定します。

複数のキーワードを指定できます。

local

ローカル生成ルートを指定します。複数のキーワードを指定できます。

nssa-external

NSSA 外部ルートを指定します(OSPF タイプ 1/2)。複数のキーワードを指定できます。

type-1

OSPF 外部タイプ 1 ルートを指定します。複数のキーワードを指定できます。

type-2

OSPF 外部タイプ 2 ルートを指定します。複数のキーワードを指定できます。

 
コマンド デフォルト

ディセーブル

 
コマンド モード

ルート マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準(現在の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドは、set 処理( match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

match route-map コンフィギュレーション コマンドには複数の形式があります。 match コマンドの順序は任意に指定できます。すべての match コマンドが満たされないと、 set コマンドで指定した set 処理に従ってルートの再配布が行われません。 match コマンドの no 形式を使用すると、指定した一致基準が削除されます。

ルート マップは、いくつかの部分にわかれている可能性があります。 route-map コマンドに関連する少なくとも 1 つの match 句に一致しないルートは、すべて無視されます。つまり、発信ルート マップではルートはアドバタイズされず、着信ルート マップではルートは受け入れられません。一部の特定のデータを変更したい場合は、明示的な match が指定された 2 つ目のルート マップ セクションを設定する必要があります。

複数のキーワードを指定できます。

次に、内部ルートを再配布する例を示します。

switch(config)# route-map blueberry
switch(config-route-map)# match route-type internal
 

次に、内部ルートと type-1 OSPF ルートを再配布する例を示します。

switch(config)# route-map blueberry
switch(config-route-map)# match route-type internal type-1
 

 
関連コマンド

コマンド
説明

match as-path

BGP 自律システム パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定されたアクセス リストのいずれかによって渡されたネクスト ホップ ルータ アドレスを含むすべてのルートを再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric

指定したメトリックを持つルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set community

BGP コミュニティ属性を設定します。

set level

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match tag

指定タグと一致するルーティング テーブル内のルートを再配布するには、 match tag コマンドを使用します。タグ エントリを削除するには、このコマンドの no 形式を使用します。

match tag tag-value [ ...tag-value ]

no match tag tag-value [ ...tag-value ]

 
構文の説明

tag-value

1 つ以上のルート タグ値のリスト。各値には 0 ~ 4,294,967,295 の整数を指定できます。最大 32 個のタグを設定できます。

 
コマンド デフォルト

match tag の値は定義されません。

 
コマンド モード

ルート マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンド構文内の省略符号(...)は、 tag-value 引数に複数の値を入力できることを示します

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準(現在の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドは、set 処理( match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

match route-map コンフィギュレーション コマンドには複数の形式があります。 match コマンドの順序は任意に指定できます。すべての match コマンドが満たされないと、 set コマンドで指定した set 処理に従ってルートの再配布が行われません。 match コマンドの no 形式を使用すると、指定した一致基準が削除されます。

ルート マップは、いくつかの部分にわかれている可能性があります。 route-map コマンドに関連する少なくとも 1 つの match 句に一致しないルートは、すべて無視されます。つまり、発信ルート マップではルートはアドバタイズされず、着信ルート マップではルートは受け入れられません。一部の特定のデータを変更したい場合は、明示的な match が指定された 2 つ目のルート マップ セクションを設定する必要があります。

次に、ルーティング テーブルにタグ 5 で保存されたルートを再配布する例を示します。

switch(config)# route-map blueberry
switch(config-route-map)# match tag 5

 
関連コマンド

コマンド
説明

match as-path

BGP 自律システム パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定されたアクセス リストのいずれかによって渡されたネクスト ホップ ルータ アドレスを含むすべてのルートを再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric

指定したメトリックを持つルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set community

BGP コミュニティ属性を設定します。

set level

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match vlan

指定された VLAN を使用してルートをフィルタするには、 match vlan コマンドを使用します。ルーティング テーブルから再配布されたルートに関するエントリを削除するには、このコマンドの no 形式を使用します。

match vlan vlan-range

no match vlan vlan-range

 
構文の説明

vlan-range

このコマンドで照合される VLAN の範囲。有効な範囲は 1 ~ 4094 です。

 
コマンド デフォルト

match vlan の値は定義されません。

 
コマンド モード

ルート マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

指定された VLAN を使用してルートをフィルタするには、 match vlan コマンドを使用します。1 つ以上の VLAN または VLAN の範囲を指定できます。コマンドが通過するには、指定された VLAN のうち少なくとも 1 つが一致する必要があります。このコマンドは、範囲内に収まるすべての VLAN を照合します。

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準(現在の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドは、set 処理( match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

match route-map コンフィギュレーション コマンドには複数の形式があります。 match コマンドの順序は任意に指定できます。すべての match コマンドが満たされないと、 set コマンドで指定した set 処理に従ってルートの再配布が行われません。 match コマンドの no 形式を使用すると、指定した一致基準が削除されます。

ルート マップは、いくつかの部分にわかれている可能性があります。 route-map コマンドに関連する少なくとも 1 つの match 句に一致しないルートは、すべて無視されます。つまり、発信ルート マップではルートはアドバタイズされず、着信ルート マップではルートは受け入れられません。一部の特定のデータを変更したい場合は、明示的な match が指定された 2 つ目のルート マップ セクションを設定する必要があります。

次に、VLAN 5 ~ 10 に一致するルートを再配布する例を示します。

switch(config)# route-map blueberry
switch(config-route-map)# match vlan 5-10
 

 
関連コマンド

コマンド
説明

match as-path

BGP 自律システム パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定されたアクセス リストのいずれかによって渡されたネクスト ホップ ルータ アドレスを含むすべてのルートを再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric

指定したメトリックを持つルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set community

BGP コミュニティ属性を設定します。

set level

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

maxas-limit

AS-path 属性内の自律システム(AS)番号が大きいルートを破棄するように external Border Gateway Protocol(eBGP)を設定するには、 maxas-limit コマンドを使用します。デフォルトの設定に戻すには、このコマンドの no 形式を使用します。

maxas-limit [ number ]

no maxas-limit

 
構文の説明

number

(任意)AS-path 属性内で許可された AS 番号の最大値。指定できる範囲は 1 ~ 2000 です。

 
コマンド デフォルト

制限なし

 
コマンド モード

ルータ コンフィギュレーション モード
VRF コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドには、LAN Enterprise Services ライセンスが必要です。

次に、AS 番号の最大値を 50 に設定する例を示します。

switch(config)# router bgp 64496
switch(config-router)# maxas-limit 50
switch(config-router)#
 

 
関連コマンド

コマンド
説明

feature bgp

BGP 機能をイネーブルにします。

router bgp

BGP インスタンスを作成します。

maximum-paths(BGP)

ボーダー ゲートウェイ プロトコル(BGP)がサポートするパラレル ルートの最大数を制御するには、 maximum-paths コマンドを使用します。デフォルトのパラレル ルート数に戻すには、このコマンドの no 形式を使用します。

maximum-paths [ ibgp ] number-paths

no maximum-paths [ ibgp ] number-paths

 
構文の説明

ibgp

(任意)interior BGP(iBGP)パスの最大数を設定します。

number-paths

IP ルーティング プロトコルがルーティング テーブルにインストールするパラレル ルートの最大数。指定できる範囲は 1 ~ 16 です。

 
コマンド デフォルト

8 パス

 
コマンド モード

ルータ アドレス ファミリ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドには使用上のガイドラインはありません。

次に、BGP ルーティング プロセスで、1 つの宛先に最大 16 のパスを許容する例を示します。

switch# configure terminal
switch(config)# router bgp 64496
switch(config-router)# maximum-paths 16
switch(config-router)#
 

 
関連コマンド

コマンド
説明

feature bgp

ルータの BGP 機能をイネーブルにします。

router bgp

BGP をイネーブルにします。

 

maximum-prefix

ネイバーから受信可能なプレフィックスの数を設定するには、 maximum-prefix コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

maximum-prefix maximum [ threshold ] [ restart restart-interval ] [ warning-only ]

no maximum-prefix

 
構文の説明

maximum

指定ネイバーから受信できるプレフィックスの最大数。設定可能なプレフィックス数は、ルータ上の使用可能なシステム リソースのみによって制限されます。範囲は 1 ~ 300000 です。

threshold

(任意)ルータが警告メッセージの生成を開始する最大プレフィックス数の制限値のパーセンテージを指定します。範囲は 1 ~ 100 です。デフォルトは 75 です。

restart interval

(任意)ピアリング セッションが再確立される時間間隔(分)。範囲:1 ~ 65535。

warning-only

(任意)最大プレフィックス数の制限値を超えた場合、ピアリング セッションを終了せずに、ルータが syslog メッセージを生成できるようにします。

 
コマンド デフォルト

このコマンドは、デフォルトでディセーブルになっています。最大プレフィックス数を超えると、ピアリング セッションはディセーブルになります。再起動間隔(restart interval)を設定しないと、最大プレフィックス数の制限値超過後、ディセーブルになったセッションはダウン状態のままになります。

 
コマンド モード

ピア テンプレート コンフィギュレーション モード
BGP ルータ コンフィギュレーション モード
BGP ネイバー アドレスファミリ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが導入されました。

 
使用上のガイドライン

設定可能なプレフィックス数は、ルータ上の使用可能なシステム リソースのみによって制限されます。

maximum-prefix コマンドを使用すると、ボーダー ゲートウェイ プロトコル(BGP)ルーティング プロセスが指定されたピアから受け入れるプレフィックスの最大数を設定できます。この機能は、ピアから受信されるプレフィックスの制御メカニズムを提供します(配布リスト、フィルタ リスト、ルート マップに加えて)。

受信プレフィックスの数が設定されている最大数を超えると、BGP はピアリング セッションをディセーブルにします(デフォルト)。 再起動間隔(restart interval )を設定した場合、BGP は、設定されている時間間隔でピアリング セッションを自動的に再確立します。 再起動間隔(restart interval )を設定せずに、最大プレフィックス数の制限値を超えたためにピアリング セッションが終了した場合、そのピアリング セッションは clear ip bgp コマンドが入力されるまで再確立されません。 warning-only キーワードが設定されていれば、BGP はログ メッセージだけを送信し、送信側とピアを保ちます。

このコマンドで設定できるプレフィックス数には、デフォルトの制限値はありません。設定可能なプレフィックス数の制限は、システム リソースの容量によって決まります。

次に、192.168.1.1 ネイバーから受け入れられる最大プレフィックス数を 1000 に設定する例を示します。

switch(config)# router bgp 64496
switch(config-router)# network 192.168.0.0
switch(config-router)# maximum-prefix 1000
switch(config-router)#
 

次に、192.168.2.2 ネイバーから受け入れられるプレフィックスの最大数を 5000 に設定する例を示します。ルータは、最大プレフィックス リミット(2500 プレフィックス)の 50% に到達した段階で警告メッセージを表示するようにも設定されます。

switch(config)# router bgp 64496
switch(config-router)# network 192.168.0.0
switch(config-router)# maximum-prefix 5000 50
switch(config-router)#
 

次に、192.168.3.3 ネイバーから受け入れられるプレフィックスの最大数を 2000 に設定する例を示します。ルータは、30 分後にディセーブルにされたピアリング セッションを再確立するようにも設定されます。

switch(config)# router bgp 64496
switch(config-router)# network 192.168.0.0
switch(config-router)# maximum-prefix 2000 restart 30
switch(config-router)#
 

次に、192.168.4.4 ネイバーの最大プレフィックス数の制限値(500)を超えたときに表示される警告メッセージを設定する例を示します。

switch(config)# router bgp 64496
switch(config-router)# network 192.168.0.0
switch(config-router)# maximum-prefix 500 warning-only
switch(config-router)#
 

次に、192.168.1.3 ネイバーから受け入れられるプレフィックスの最大数を 1500 に設定する例を示します。

switch(config)# router bgp 64496
switch(config-router)# neighbor 192.168.1.3 remote-as 64497
switch(config-router-neighbor)# address-family ipv4 multicast
switch(config-router-neighbor-af)# maximum-prefix 1500
switch(config-router-neighbor-af)#
 

 
関連コマンド

コマンド
説明

address-family(BGP ネイバー)

BGP ネイバー アドレスファミリ コンフィギュレーション モードを開始します。

neighbor

BGP ネイバーを設定します。

network

アドバタイズする IP プレフィックスを設定します。

show ip bgp

BGP 構成情報を表示します。